MicroSCADA Pro SYS600 9.4
Pipeline Application Design
Contents

1 Copyrights ........................................................................................................... 5

2 Introduction ..................................................................................................... 7
   2.1 This manual ............................................................................................ 7
   2.2 Use of symbols ................................................................................... 7
   2.3 Intended audience ............................................................................... 7
   2.4 Related documents ............................................................................ 8
   2.5 Document conventions ........................................................................ 8
   2.6 Document revisions ........................................................................... 8

3 About Pipeline library ..................................................................................... 9
   3.1 General ............................................................................................... 9
   3.2 Supported objects ............................................................................... 9
   3.3 Protocol support ................................................................................ 10
   3.4 Engineering ....................................................................................... 10

4 Preparing application ..................................................................................... 11
   4.1 Object identification ......................................................................... 11
   4.2 Installation Tool ............................................................................... 11

5 Application Engineering ............................................................................... 13
   5.1 Language translation ......................................................................... 13
   5.2 Standard Function installation .......................................................... 14
   5.3 Symbol installation ........................................................................... 16
      5.3.1 Installing symbols with dynamics ........................................ 16
      5.3.2 Installing static symbols .......................................................... 16
   5.4 Descriptions to the Standard Function Attributes ....................... 17

6 Application Engineering information ......................................................... 25
   6.1 Process Objects .................................................................................. 25
      6.1.1 Station ....................................................................................... 25
      6.1.2 Composition ............................................................................. 25
      6.1.3 Valve, Pump, Fan, Compressor, Rotary Feeder .................. 26
      6.1.4 Control unit, simple ................................................................. 26
      6.1.5 Measurement .......................................................................... 27

Index .................................................................................................................. 29
1

Copyrights

The information in this document is subject to change without notice and should not be construed as a commitment by ABB Oy. ABB Oy assumes no responsibility for any errors that may appear in this document.

In no event shall ABB Oy be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB Oy be liable for incidental or consequential damages arising from the use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB Oy, and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license.

Copyright © 2014 ABB Oy. All rights reserved.

Trademarks

ABB is a registered trademark of ABB Group. All other brand or product names mentioned in this document may be trademarks or registered trademarks of their respective holders.

Guarantee

Please inquire about the terms of guarantee from your nearest ABB representative.

Third Party Copyright Notices

List of third Party Copyrights notices are documented in "3rd party licenses.txt" and included in SYS600 installation package.
2 Introduction

2.1 This manual

This manual describes how to supervise and control the power process with the SYS600 Monitor Pro user interface. The supervision and control is done by means of Process Displays, event/alarm displays, trends, measurement reports and so on. The manual also describes the basic customizing possibilities of the user interface.

2.2 Use of symbols

This publication includes warning, caution and information symbols where appropriate to point out safety-related or other important information. It also includes tips to point out useful hints to the reader. The corresponding symbols should be interpreted as follows:

⚠️ Warning icon indicates the presence of a hazard which could result in personal injury.

❗️ Caution icon indicates important information or a warning related to the concept discussed in the text. It might indicate the presence of a hazard, which could result in corruption of software or damage to equipment/property.

ℹ️ Information icon alerts the reader to relevant factors and conditions.

💡 Tip icon indicates advice on, for example, how to design a project or how to use a certain function.

Although warning hazards are related to personal injury, and caution hazards are associated with equipment or property damage, it should be understood that operation of damaged equipment could, under certain operational conditions, result in degraded process performance leading to personal injury or death. Therefore, comply fully with all warnings and caution notices.

2.3 Intended audience

This manual is intended for installation personnel, administrators and skilled operators to support installation of the software.
2.4 Related documents

<table>
<thead>
<tr>
<th>Name of the manual</th>
<th>Document ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMS600 4.4 Operation Manual</td>
<td>1MRS757319</td>
</tr>
<tr>
<td>SYS600 9.4 Application Design</td>
<td>1MRS758122</td>
</tr>
<tr>
<td>SYS600 9.4 Process Display Design</td>
<td>1MRS758088</td>
</tr>
<tr>
<td>SYS600 9.4 Installation and Administration Manual</td>
<td>1MRS758086</td>
</tr>
</tbody>
</table>

2.5 Document conventions

The following conventions are used for the presentation of material:

- The words in names of screen elements (for example, the title in the title bar of a dialog, the label for a field of a dialog box) are initially capitalized.
- Capital letters are used for file names.
- Capital letters are used for the name of a keyboard key if it is labeled on the keyboard. For example, press the CTRL key. Although the Enter and Shift keys are not labeled they are written in capital letters, e.g. press ENTER.
- Lowercase letters are used for the name of a keyboard key that is not labeled on the keyboard. For example, the space bar, comma key and so on.
- Press CTRL+C indicates that the user must hold down the CTRL key while pressing the C key (in this case, to copy a selected object).
- Press ALT E C indicates that the user presses and releases each key in sequence (in this case, to copy a selected object).
- The names of push and toggle buttons are boldfaced. For example, click OK.
- The names of menus and menu items are boldfaced. For example, the File menu.
- The following convention is used for menu operations: Menu Name > Menu Item > Cascaded Menu Item. For example: select File > Open > New Project.
- The Start menu name always refers to the Start menu on the Windows Task Bar.
- System prompts/messages and user responses/input are shown in the Courier font. For example, if the user enters a value that is out of range, the following message is displayed: Entered value is not valid.
  The user may be told to enter the string MIF349 in a field. The string is shown as follows in the procedure: MIF349
- Variables are shown using lowercase letters: sequence name

2.6 Document revisions

<table>
<thead>
<tr>
<th>Version</th>
<th>Software revision number</th>
<th>Date</th>
<th>History</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>9.4</td>
<td>16.5.2014</td>
<td>New document</td>
</tr>
</tbody>
</table>
3 About Pipeline library

3.1 General

Pipeline library contains objects that can be used for monitoring and controlling application areas like water applications and heat distribution.

Figure 3.1: Example display

3.2 Supported objects

The following objects are supported:

- Station
- Bay (Equipment group)
- Valve
- Pump
- Fan
- Compressor
- Motor
- Rotary Feeder
- Measurement
- Control Unit
3.3 Protocol support

The following protocols are supported:

- IEC 60870-5-101/104
- MODBUS
- SPA/External OPC DA

3.4 Engineering

The engineering of the pipeline application is done by means of:

1. Application Initialization Tool
2. Text Tool
3. Object Navigator
4. Display Builder

The engineering is explained in more detail in following chapters.
4 Preparing application

4.1 Object identification

The usage of the object identification (OI-attribute) has to be settled before creating any process objects. This means that the number of levels in the object identification hierarchy needs to be decided. The configuration of the OI-attribute usage is done in SYS_BASCON.COM.

4.2 Installation Tool

The application is prepared for software modules with Application Initialization Tool. The tool is opened from the Monitor Pro menu Tools > Engineering Tools > Tool Manager and Application Objects sheet.

![Application Initialization Tool](image)

Figure 4.1: Application Initialization Tool

There are dependencies between different modules. Pipeline requires the Base Backbone and Base Process Library modules. Select the modules and click **Prepare selected packages**.

After the application is prepared, a restart of the MicroSCADA service is required.
5 Application Engineering

5.1 Language translation

There are two types of translatable text files, SCIL Text Databases and plain ASCII files. Submodules typically have one text database to be translated. The text database is located in the directory `<drive>\SC\LIB5\module\sub module\LANG_TEXTS`. To fully translate the pipeline application, all three submodules must be translated: base\bbone, base\process and fmod\pipeline.

The text database contains the texts for signal texts (OX - attribute), Event Handling objects and Visual SCIL control dialogs. The actual translation is done with Text Tool.

ASCII files are located in directory `<drive>\SC\LIB5\module\sub module\LANG_TEXTS\ISO 639-1 code`. ASCII files can contain longer texts, such as the Standard Function Installation help. To make a translation, copy the files from the EN directory to the local language directory, for example FI and translate the files there. There is no specific translation tool for these files.

![Figure 5.1: Location of translatable files](image)

Figure 5.1: Location of translatable files
5.2 Standard Function installation

Standard Functions for pipeline are installed and configured in Object Navigator by means of:

- Installation Tool
- Standard Function Tool

The installation procedure is:

1. In Object Navigator, select **Standard Function > Install**
2. In Installation Tool, select the object from Pipeline_LIB and click **Install**
3. Define the attribute values in Standard Function Tool.
4. Then go to the Tools sheet and create a process object with Process Object Tool

![Figure 5.2: Standard Function installation](image)

Additionally, in Standard function Tool, two user Programs, U_INTERLOCKING and U_OTHER_OBJECTS, can be utilized. The usage of these programs is optional.
This program can be used for defining custom interlocking condition for the control dialog. The program must return a LIST that has the following attributes:

### Table 5.1: Attributes for program U_INTERLOCKING

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPEN_INTERLOCKED</td>
<td>BOOLEAN, open interlocking state. If TRUE, the Open button is disabled in control dialog</td>
</tr>
<tr>
<td>CLOSE_INTERLOCKED</td>
<td>BOOLEAN, close interlocking state. If TRUE, the Close button is disabled in control dialog</td>
</tr>
<tr>
<td>INTERLOCKING_CAUSE</td>
<td>TEXT, reason for the interlocking is displayed in a control dialog info field.</td>
</tr>
<tr>
<td>EVENT_OBJECTS</td>
<td>VECTOR of LISTs, control dialog reacts to the indication changes of these process objects in an event based manner.</td>
</tr>
</tbody>
</table>

The following is an example of the program:

```plaintext
;initial values
@OPEN_INTERLOCKED = FALSE
@CLOSE_INTERLOCKED = FALSE
@INTERLOCKING_CAUSE = ""
@EVENT_OBJECTS = VECTOR

;define event objects
@EVENT_OBJECTS = VECTOR(LIST(LN="MY_LN", IX = 10))

;define interlocking condition
#IF MY_LN:P10 == 1 #THEN #BLOCK
 @OPEN_INTERLOCKED = TRUE
 @CLOSE_INTERLOCKED = TRUE
 @INTERLOCKING_CAUSE = "Interlocked by u_interlocking"
 #BLOCK_END

#RETURN LIST(-
 OPEN_INTERLOCKED=%OPEN_INTERLOCKED,-
 CLOSE_INTERLOCKED=%CLOSE_INTERLOCKED,-
 INTERLOCKING_CAUSE=%INTERLOCKING_CAUSE,-
 EVENT_OBJECTS=%EVENT_OBJECTS)
```

### U_OTHER_OBJECTS

The logical names of process objects of the station and bay can be defined. If the logical name is defined, a process database query for these objects is not necessary. If the value NONE is given to STATION_LN or BAY_LN, it means that the station or bay is not checked in the control dialog.
5.3  Symbol installation

Process displays are made in Display Builder. Display Builder is opened from the Monitor Pro menu Tools > Engineering Tools > Display Builder.

There are two kinds of symbols for the pipeline library, dynamic symbols and static symbols. Dynamic symbols are installed with Object Browser (Display Builder Object Browser).

5.3.1  Installing symbols with dynamics

1. Open Object Browser from Display Builder > Object Browser
2. Select an application
3. Navigate to the object to be installed in the tree view
4. Select the symbol representation from the drop down list
5. Drag and drop the symbol into the display from the tree view (or double click the node in 3)

![Figure 5.3: Installation in Object Browser](image)

5.3.2  Installing static symbols

There are static symbols that can be utilized when building the display. Static symbols can be dragged and dropped from the Palette (Window > Show Palette).

Symbols designed for pipeline are located in 08 - PL_Equipment and 09 - PL_Pipes sheets. 08 - PL_Equipment contains both static and dynamic symbols.
5.4 Descriptions to the Standard Function Attributes

AUTHORIZATION_GROUP

A selector type of an editable combo box to select the authorization group for the object. The maximum length of the text is 63 characters. The given text has to be usable as a SCIL list attribute name. For more information about the SCIL list attribute name, see SYS600 Programming Language SCIL. The content of the selection list is taken from the existing authorization groups.

⚠️ The name may not be composed of two letters followed by a number.

The attribute needs to be defined if the object needs to be included in some authorization group. The authorization level of each user in this group can be defined afterwards by the system manager with User Management tool.

BAY_LR_IN_USE

An ON/OFF type of a toggle button to select if the bay local/remote switch is in use, meaning that a physical switch exists.

By default, the bay local/remote switch is in use.

The process object for bay local/remote switch is created regardless of the selection. If the bay local/remote switch is NOT in use, the process object should be left as it is created, that is, switching state (SS) to manual and value (DB) as 2 (remote).
BAY_LR_POLARITY

The polarity of the bay local/remote switch input signal.

BAY_NAME

A selector type of an editable combo box to select or enter the name of the bay (feeder). By default, the maximum length of the text is 14 characters. The selection list shows up to ten recent entries.

The configurable attribute is read directly from the process object database, if there is any process object linked to the selected bay picture function. Therefore, the configurable attribute within a picture function has a meaning only when the process objects have not been created.

This text is used as a bay (feeder) identifier of the common bay objects on the event list, alarm list, printout, database query, and so on. It is very important that this text is similar to all objects within the same bay (feeder).

CONTROL_BITS

A vector type of an input field for integer values to specify the bits to be used to send a control command. The configurable attribute is enabled if the attribute MOTORIZED is set and CONTROL_TYPE is a secured control with an analog output.

The user must specify two or four elements for that vector. If two elements are specified, the first element represents the bit for Open execute while the second element is for Close execute.

When four elements are used, the first represents the bit for Open select, the second represents Close select, the third represents Execute and the fourth represents Cancel.

When five elements are used, the first represents the bit for Open select, the second represents Close select, the third represents Open execute, the fourth represents Close execute and the fifth represents Cancel.

The bit vector shall be given to the SCT in the following way: (0,1) or (9,10,11,8) or (0,0,1,2,3).

CMD_PARAMETER

A selector type of a combo box to select a command parameter for the control method. This attribute has meaning only if IEC 60870-5-101 protocol is selected. Otherwise this attribute is disabled.

The supported control parameters for the IEC 60870-5-101 protocol are:

- Single command (ASDU 45)
- Double command (ASDU 46)
CONTROL_PULSE_LENGTH

An input field for an integer value to set the pulse length of the control pulses. The configurable attribute is enabled if the attribute MOTORIZED is set and CONTROL_TYPE is secured control with two digital outputs.

CONTROL_TYPE

A selector type of a combo box to select the control method and the type of the control process object(s). If the configurable attribute MOTORIZED is not selected, this attribute is disabled, and its value has no meaning.

The purpose of this configurable attribute is to support other control methods and process object types than the conventional one. The conventional control method depends very much on the configurable attribute STATION_TYPE since there is a certain default method for each protocol to control the switching device. The supported control methods are:

• Secured command with four binary outputs
• Secured command with two binary outputs
• Secured command with two digital outputs
• Secured command with a single binary output
• Secured command with a single analog output
• Secured command with five binary outputs
• Direct command with a single binary output

DEVICE_NAME

A selector type of an editable combo box to select or enter the name (identifier) of the switching device. By default, the maximum length of the text is 5 characters. The selection list shows up to ten recent entries.

The configurable attribute is read directly from the process object database, if there are any process objects linked to the selected switching device.

Therefore, the configurable attribute within a picture function has a meaning only when the process objects have not been created.

This text is used as an identifier of the switching device on the event list, alarm list, printout, database query, and so on.

FOLDER_'number'_TITLE

The name of the measurement to be shown in the measurement dialog. The attribute is optional. If it is not given, the measurement is referred to as Meas. 'number' in the dialog.

If the configurable attribute TYPE_MEAS_'number' is not configured, this attribute is disabled, and the value has no meaning.
IND_ANALOG_INPUT

An ON/OFF type of a toggle button to select if the bay switch indication type is analog input. This selection is disabled and it has no meaning if the local/remote switch is not in use, that is if BAY_LR_IN_USE is not set.

Analog input:

0 = Off
1 = Local
2 = Remote
3 = Error
4 = Error
5 = All

IND_DOUBLE_BINARY

An ON/OFF type of a toggle button to select whether the station/remote switch or bay local/remote indication type is double binary or single binary. This selection is disabled and it has no meaning if the station/remote switch or bay local/remote is not in use, that is if STATION_LR_IN_USE or BAY_LR_IN_USE is not set.

Depending on the actual field device or communication protocol, the indication of the local/remote switch is sent either in a single binary (0/1) or a double binary (0/1/2/3) format.

Station:

Binary input:

0 = Remote
1 = Station

Double binary input:

0 = Local
1 = Station
2 = Remote
3 = Out of use

Bay:

Binary input:

Local or Remote. Depends on Bay L/R switch polarity
Double binary input:

0 = Disabled
1 = Local
2 = Remote
3 = Reserved

**INDICATION_TYPE**

A selector type of a combo box to select the type of the position indication process object(s). By default, the process object type is defined as a double indication (DB).

The purpose of this configurable attribute is to support data types other than double indication as the position indication of the switching device. The supported data types are:

- Double indication (DB)
- Single indication (BI)
- 2 x Single indications (2 x BI)
- Analog input (AI)

The interface between the picture function and the process object database is always with double indication object, that is, there is an additional process object(s) receiving information and then passing it to double indication.

**LR_REMOTELY_CONTROLLABLE (Station)**

An ON/OFF type of a toggle button for the selection, whether the station local/remote switch can be controlled remotely by SYS600 or not.

By default, the station local/remote switch is defined as manually controllable only.

Typically, if there is a remote control for the station local/remote switch, switching election between the station and remote can be done remotely, whereas switching election to or from local has to be performed locally.

Switching to and from local can be achieved by setting the attribute SS (switching state) of the local command process object to OFF (0). Setting the SS attribute to 0 will make the relevant Radio button in the dialog insensitive for selections.

**LR_REMOTELY_CONTROLLABLE (Composition)**

An ON/OFF type of a toggle button to select if the bay local/remote switch can be controlled remotely by SYS600. This selection is disabled and it has no meaning if the bay local/remote switch is not in use, that is if BAY_LR_IN_USE is not set.

By default, the bay local/remote switch is defined as manually controllable only.

It is typical that if there is a remote control for the bay local/remote switch, shift to local can be done remotely, whereas shift from local to remote has to be performed locally.
This can be achieved by setting the attribute SS (switching state) of the local command process object to OFF (0). By setting the SS.attribute to 0, the relevant Radio button in the dialog becomes insensitive to shifting.

**MOTORIZED**

An ON/OFF type of a toggle button to select if the switching device is motorized and remotely controllable. By default, the switching device is defined as a motorized object.

By selecting Motorized option, the Process Object Tool (POT) will create a set of process objects for control purpose, and all configurable attributes related to control are being enabled.

**OBJECT_TYPE_DESCRIPTION**

A selector type of a combo box to select the lib object type for the object. The lib object type can be used to configure:

- Index convention of process objects.
- Value semantic of process objects.
- Predefined custom methods.
- Object specific process object.

**P_OBJECT_LN**

The logical name of a database process object. The maximum length of the text is 63 characters. Allowed characters are letters A-Z, all digits and the underscore (_).

The logical names of process objects have to be unique throughout the entire system, meaning that different objects cannot have the same logical name. Therefore, it is very important to have a proper naming convention for the process object database.

The following list is presented as an example of the proper naming convention within one bay. The station name is Green Bay and the bay name is HA12 Downtown:

- GRB, station
- GRBHA12BAY, Composition
- GRBHA12V1, Valve V1

**STATION_LR_IN_USE**

An ON/OFF type of a toggle button to select if the station local/remote switch is in use, that is if a physical switch exists.

By default, the station local/remote switch is in use.

If this selection is set to OFF, the control authority is given to everyone whose personal authorization level is high enough for the control actions. This is gained by setting the state (value) of the station local/remote switch permanently out of use.
The process object for the station local/remote switch is created regardless of the selection. If the station local/remote switch is NOT in use, the process object should be left as it is created, that is switching state (SS) to manual and value (DB) to 3 (out of use).

**STATION_NAME**

A selector type of an editable combo box to select or enter the name of the substation. By default, the maximum length of the text is 9 characters. The selection list shows up to ten recent entries.

The configurable attribute is read directly from the process object database, if there is any process object linked to the selected station picture function. Therefore, the configurable attribute within a picture function only has a meaning when the process objects have not been created.

This text is used as a substation identifier of the common station objects on the event list, alarm list, printout, database query, and so on. It is very important that this text is similar to all objects within the same substation.

**STATION_TYPE**

A selector type of a combo box to select the station type of the objects.

The database process objects are created for the station type defined here. The list of supported protocols is as follows:

- SPA
- IEC 60870-5-101/104
- MODBUS

**TYPE_MEAS_'number’**

The type of the measurement. The type identifies the measurement for the creation of database (indexes, object texts, units...). In case no suitable alternative can be found, the indexes 27...37 can be used. The indexes 27 ... 32 are for user defined analog (AI) objects, and the indexes 33 ... 37 are for user-defined pulse counter (PC) objects.

The database objects are not created until the Process Object Tool has been used to create them.

**MEAS_'number’_DECIMALS**

The number of decimals used when presenting the measurement value in the dialog.

If the configurable attribute TYPE_MEAS_'number’ is not configured, this attribute is disabled and the value has no meaning.
6 Application Engineering information

6.1 Process Objects

6.1.1 Station

Table 6.1: process objects created by station L/R switch

<table>
<thead>
<tr>
<th>Index</th>
<th>Obj. type</th>
<th>Process object</th>
<th>Remarks</th>
<th>Group identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>DB/BI</td>
<td>Station local/remote switch indication</td>
<td></td>
<td>FPAPLAILRS</td>
</tr>
<tr>
<td>11</td>
<td>BO</td>
<td>L/R-sw. to Local -command or Station Remote command</td>
<td></td>
<td>FPAPLACLRS</td>
</tr>
<tr>
<td>12</td>
<td>BO</td>
<td>L/R-sw. to Station -command</td>
<td></td>
<td>FPAPLACLRS</td>
</tr>
<tr>
<td>13</td>
<td>BO</td>
<td>L/R-sw. to Remote -command</td>
<td></td>
<td>FPAPLACLRS</td>
</tr>
<tr>
<td>14</td>
<td>BO</td>
<td>L/R-sw. to Out of use -command</td>
<td></td>
<td>FPAPLACLRS</td>
</tr>
<tr>
<td>15</td>
<td>AI</td>
<td>Blockings</td>
<td>Internal, optional</td>
<td>FPAPLAXBLK</td>
</tr>
<tr>
<td>16</td>
<td>AI</td>
<td>Station selected on monitor</td>
<td>Internal, optional</td>
<td>FPAPLAXMEV</td>
</tr>
</tbody>
</table>

6.1.2 Composition

Table 6.2: Process objects created by composition L/R switch

<table>
<thead>
<tr>
<th>Index</th>
<th>Obj. type</th>
<th>Process object</th>
<th>Remarks</th>
<th>Group identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>DB/BI</td>
<td>Local/remote switch ind</td>
<td></td>
<td>FPAGROILRS</td>
</tr>
<tr>
<td>11</td>
<td>BO</td>
<td>L/R-sw. to Local -command or Local Remote command</td>
<td></td>
<td>FPAGROCLRS</td>
</tr>
<tr>
<td>12</td>
<td>BO</td>
<td>L/R-sw. to Local -command</td>
<td></td>
<td>FPAGROCLRS</td>
</tr>
<tr>
<td>13</td>
<td>BO</td>
<td>L/R-sw. to Remote -command</td>
<td></td>
<td>FPAGROCLRS</td>
</tr>
<tr>
<td>14</td>
<td>BO</td>
<td>L/R-sw. to Reserved -command</td>
<td>Only if ind. type DB</td>
<td>FPAGROCLRS</td>
</tr>
<tr>
<td>15</td>
<td>BI</td>
<td>Blockings</td>
<td>Optional</td>
<td>FPAGROIINH</td>
</tr>
<tr>
<td>16</td>
<td>BI</td>
<td>Station selected on monitor</td>
<td>Internal, optional</td>
<td>FPAGROIINH</td>
</tr>
<tr>
<td>17</td>
<td>BO</td>
<td>Interl. in use/out of use -cmd</td>
<td>Internal, optional</td>
<td>FPAGROCINH</td>
</tr>
<tr>
<td>18</td>
<td>BI</td>
<td>Interl. in use/out of use -ind.</td>
<td>Internal, optional</td>
<td>FPAGROIINH</td>
</tr>
<tr>
<td>19</td>
<td>BO</td>
<td>Interl. in use/out of use -cmd</td>
<td>Internal, optional</td>
<td>FPAGROCINH</td>
</tr>
<tr>
<td>20</td>
<td>AI</td>
<td>Blockings</td>
<td>Internal, optional</td>
<td>FPAPROXBLK</td>
</tr>
<tr>
<td>21</td>
<td>AI</td>
<td>Selected on monitor</td>
<td>Internal, optional</td>
<td>FPAPROXMEV</td>
</tr>
</tbody>
</table>
## 6.1.3 Valve, Pump, Fan, Compressor, Rotary Feeder

*Table 6.3: Process objects created by Valve, Pump, Fan, Compressor and Rotary Feeder*

<table>
<thead>
<tr>
<th>Index</th>
<th>Obj. type</th>
<th>Process object</th>
<th>Remarks</th>
<th>Group identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>DB/BI</td>
<td>Position indication</td>
<td>-</td>
<td>DPDxxxIPOS</td>
</tr>
<tr>
<td>11</td>
<td>BO</td>
<td>Open command or Open execute</td>
<td>Sec. control with 4xB0, 2xBO or 2xDO</td>
<td>DPDxxxCOBC</td>
</tr>
<tr>
<td>12</td>
<td>BO</td>
<td>Close command or Close execute</td>
<td>Sec. control with 4xB0, 2xBO or 2xDO</td>
<td>DPDxxxCOBC</td>
</tr>
<tr>
<td>13</td>
<td>BO</td>
<td>Execute command or Open/Close select and Execute/Cancel command or Open execute command</td>
<td>Sec. control with 4xB0</td>
<td>DPDxxxCOBC</td>
</tr>
<tr>
<td>14</td>
<td>BO</td>
<td>Cancel command or close execute command</td>
<td>Sec. control with 4xB0</td>
<td>DPDxxxCOBC</td>
</tr>
<tr>
<td>15</td>
<td>BI</td>
<td>External control blocking</td>
<td>-</td>
<td>DPDxxxIBLK</td>
</tr>
<tr>
<td>16</td>
<td>BI</td>
<td>External interlock for close/open/start cmd</td>
<td>For valve close</td>
<td>DPDxxxINH</td>
</tr>
<tr>
<td>17</td>
<td>BO</td>
<td>External interlock for close/open/stop cmd</td>
<td>For valve open</td>
<td>DPDxxxINH</td>
</tr>
<tr>
<td>18</td>
<td>BI</td>
<td>External interlocking cause</td>
<td>Internal, optional</td>
<td>DPDxxxINH</td>
</tr>
<tr>
<td>19</td>
<td>BO</td>
<td>Object selected on monitor</td>
<td>Internal, optional</td>
<td>DPDxxxXMEV</td>
</tr>
<tr>
<td>20</td>
<td>AI</td>
<td>Object command event</td>
<td>Internal, optional</td>
<td>DPDxxxICEV</td>
</tr>
</tbody>
</table>

## 6.1.4 Control unit, simple

*Table 6.4: Process objects created by control unit*

<table>
<thead>
<tr>
<th>Index</th>
<th>Obj. type</th>
<th>Process object</th>
<th>Remarks</th>
<th>Group identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AI</td>
<td>Measurement</td>
<td>-</td>
<td>DXPX03CXXX</td>
</tr>
<tr>
<td>13</td>
<td>AI</td>
<td>Setpoint</td>
<td>-</td>
<td>DXPX03CXXX</td>
</tr>
<tr>
<td>14</td>
<td>AI</td>
<td>Measurement 2</td>
<td>-</td>
<td>DXPX03CXXX</td>
</tr>
<tr>
<td>15</td>
<td>AI</td>
<td>Measurement 3</td>
<td>-</td>
<td>DXPX03CXXX</td>
</tr>
<tr>
<td>19</td>
<td>AI</td>
<td>Selected on monitor</td>
<td>-</td>
<td>DXPX03CXXX</td>
</tr>
</tbody>
</table>
### 6.1.5 Measurement

**Table 6.5: Process objects created by measurement**

<table>
<thead>
<tr>
<th>Index</th>
<th>Obj. type</th>
<th>Process object</th>
<th>Remarks</th>
<th>Group identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AI</td>
<td>Volume [m³]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>11</td>
<td>AI</td>
<td>Flow [m³/h]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>12</td>
<td>AI</td>
<td>Pressure [bar]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>13</td>
<td>AI</td>
<td>Level [mWs]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>14</td>
<td>AI</td>
<td>Temperature [°C]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>15</td>
<td>AI</td>
<td>Degree of opening [%]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>16</td>
<td>AI</td>
<td>Suction pressure [bar]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>17</td>
<td>AI</td>
<td>pH-value</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>18</td>
<td>AI</td>
<td>Turbidity [FNU]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>19</td>
<td>AI</td>
<td>UV-disinfection [W / m²]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>20</td>
<td>AI</td>
<td>Count rate [*1 m³]</td>
<td>-</td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>21-44</td>
<td>AI</td>
<td>User defined measurement</td>
<td></td>
<td>DPDMEAMXXX</td>
</tr>
<tr>
<td>45-49</td>
<td>PC</td>
<td>User defined counter</td>
<td></td>
<td>DPDMEAMXXX</td>
</tr>
</tbody>
</table>
Index

B
BAY_LR_IN_USE ................................................. 17
BAY_LR_POLARITY ............................................ 18
BAY_NAME .......................................................... 18

C
CMD_PARAMETER ............................................. 18
CONTROL_BITS .................................................. 18
CONTROL_PULSE_LENGTH ............................. 19
CONTROL_TYPE ................................................. 19

D
DEVICE_NAME .................................................... 19

F
FOLDER_'number'_TITLE ................................... 19

I
IND_DOUBLE_BINARY ............................... 20
INDICATION_TYPE .............................................. 21

L
LR_REMOTELY_CONRTOLLABLE .................... 21
LR_REMOTELY_CONTROLLABLE .................... 21

M
MEAS_'number'_DECIMALS ............................... 23
MOTORIZED ........................................................ 22

P
P_OBJECT_LN .................................................... 22

S
STATION_LR_IN_USE ......................................... 22
STATION_NAME .................................................. 23
STATION_TYPE ................................................... 23
Switching state (SS) ................................. 21–22

T
TYPE_MEAS_'number' ............................... 23