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1 Installation and maintenance
System requirements
Starting the setup program
Installing the program - installation steps
Language Selection dialog box
Welcome dialog box
User Information and User Rights dialog box
Target Folder dialog box
Installation Type dialog box
Starting the installation
Uninstalling or customizing the program
Application Maintenance dialog box

1.1 System requirements
The following hardware and software components are required to install and run the program properly:

• PC, IBM compatible, at least Pentium processor, 166 MHz, 
• 64 MB RAM, 
• 20 MB free hard disk space, 
• SVGA card, at least 256 colors, 
• Windows 98, NT 
• CD-ROM drive for installing the program
• InternetExplorer Version 5.01 or higher

1.2 Starting the setup program
Insert the CD in your CD-ROM drive. The setup program will be started automatically. You can also start
the setup program manually by following the instructions below: 

On the CD you will find the Setup.exe program in the roots directory.

Double-click on Setup.exe to start the setup program. The Windows Installer dialog box appears. If the
Windows installer should not yet be available on your system, it is automatically installed then. After this,
your system needs to be restarted. After the restart the setup program will start again automatically to
continue the installation. Note: Some systems do not permit an automatic restart of the setup program.
In this case, manually start Setup.exe as described above. 

1.3 Installing the program - installation steps

1.3.1 Language Selection dialog box
When the setup program has been started, the Language Selection dialog box will pop up. In this dialog
you can select the language for both theR&C Process Data Management and the installation program.

Select a language from the list and confirm with OK to continue. (Note: The selected language can be the
same as your system language, but does not need to be). 

1.3.2 Welcome dialog box
A setup wizard started with a welcome screen will help you to install the program. To ensure proper in-
stallation it is strongly recommended to exit all other applications before running the setup program. Be
sure that this is case before selecting "Next". Otherwise, the current setup procedure should be can-
celled. 
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Installation and maintenance
1.3.3 User Information and User Rights dialog box
Enter your full name and organization in the respective fields. 

Note that special user rights can only be assigned by the system administrator of the PC on which the
software is to be installed. 

If the menu option "All users" is selected, the program will always appear in the start menu, no matter who
is currently logged on. 

When selecting the "Me only" option the program will only appear in the start menu when you are logged
on under your personal account. 

1.3.4 Target Folder dialog box
In this dialog you can define the target drive and folder in which the program is to be installed. Click on
the "Browse" button to change the default drive and folder. 

1.3.5 Installation Type dialog box
In this dialog box you can select to install Typical, All or Custom products. 

Typical 
Installs the R&C Process Data Management with the following products: Modbus, Visu, Konfi Device
Type Manager (DTM) for Datavis for device configuration and control (Prog1 and Prog2 functionality) 

All
Installs all products

Custom
Product selection as required. You can select the products you want to install from the next dialog box. 

1.3.6 Starting the installation
When all necessary entries and settings have been made, you can start installation. The installation pro-
cedure may take some time. When installation is complete, a message appears indicating that the instal-
lation was successful. The menu item "R&C Process Data Management " is now available in the start
menu.

1.3.7 Uninstalling or customizing the program
There are two possible ways to uninstall the program or to install/uninstall specific program components: 

• Start the Setup.exe program or
• Select [Settings -> Control Panel -> Add/Remove Programs] from the Start menu and then double-click

on the "R&C-Process-Data-Management " option.

In both cases the Setup program is started, and the Application Maintenance dialog box appears.

1.3.8 Application Maintenance dialog box
This dialog box provides several service and maintenance options for your program: 

Customize
Add or remove components

Repair
Re-install or add components that have been purchased at a later time

Uninstall
Completely uninstall the program. 
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Workspace components
Project and project tree
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2.1 R&C Process Data Management Software
The R&C Process Data Management Software from ABB Recording & Control includes the following PC
software packages for measured value processing: 
• Modbus OPC Server (DA 2.0 Standard),
• Device Bus OPC Server (DA 2.0 Standard) for devices that exclusively support the H&B Device Bus

(from version 3 and higher)
• Process Data Visualization (OPC client)
• OPC HDA Server for recording and handling historical values (from version 3 and higher)
• R&C Process Web Server for process data visualization via the Internet (from version 3 and higher)
• FDT Device Configurator and Device Type Manager for device management and configuration

The following tasks for small automation applications are fully covered by this software: 
• Process data acquisition 
• Archiving (from version 3.0 and higher)
• Visualization
• Device management and configuration

All products of the R&C Process Data Management Software use the following standards and trends of
advanced process automation: 
• OPC (OLE for Process Control) for process data acquisition, 
• OPC-HDA (Historical Data Access) for process data archiving (Version 3 and higher)
• Web and browser technologies  (HTML, DHTML, JavaScript, ActiveX components technology, etc.) for

process data visualization
• FDT (Field Device Tool) Standard for device configuration

Due to its compliance with the above-stated standards the R&C Software Suite is an open system pro-
viding the following features: 
• trouble-free cooperation of different software packages
• preservation of you investment in already purchased ABB devices
• integration of bus-compatible devices from other vendors
• integration of OPC servers for other fieldbuses (e.g. Profibus, FoundationFieldbus, InterbusS etc.) 
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Workspace
• free access throughout the network to all process data on recorders, controllers and indicators from pro-
cess control systems or other visualization systems

2.2 Workspace and software concept
All software packages of the R&C Process Data Management Software share a common R&C instrumen-
tation software library. The library is installed with the first product of the software suite, and may be up-
dated if required when a new product of the R&C Process Data Management software package is
installed. Among other items the library contains all communication components like OPC and FDT. 

To ensure user-friendliness and convenient control all software packages use a common graphical user
interface, the so-called workspace. This does not apply to the ProcessWebServer which does not need
a user interface. The workspace is installed with the first product of the software suite, and may be up-
dated if required when a new product of the  R&C Process Data Management software package is in-
stalled.

2.3 Starting the workspace
The menu item "R&C Process Data Management Software " is available in the start menu under "Pro-
grams". Click on the "Workspace" menu item to start the program.

2.4 Workspace components
After starting the workspace the user interface appears (refer to the illustration). The project tree is dis-
played in the left section of the window. It is the main tool for navigating and for controlling the installed
software packages. Moreover, it is the starting point for all functions related to data acquisition, visualiza-
tion and device parameterization. The right sub-window is the Web browser display area, where any Web
site selected can be displayed. The installed and licensed software packages are shown here by default.

Fig. 2-1 Work space components
8 Data Archiving Tool HDA100, R&C Process Data Management Software 42/49-29 EN
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2.5 Project and project tree
The project tree is the main tool for navigating and is used for organizing and handling all devices, plants
and applications in a structured hierarchy, as seen in the illustration. 

Example
The example shows a plant hierarchy in the project tree. The project may contain any number of folders
and subfolders. Devices, visualization pages and subfolders can be arranged in every folder such that
they represent the structure of the actual plant.  

Fig. 2-2

2.5.1 Working with the project tree (Edit current project)
Upon loading or creation of a project the project tree can be designed or adapted freely to meet the re-
quirements of the respective application. You can create hierarchies, change names, and add elements
like plants, devices, servers or visualization pages. 

Fig. 2-3

All these action can be performed in the project tree. Right-click on the appropriate node in the project
tree. A shortcut menu adapted to the respective node type appears, where all actions can be performed. 

2.5.2 Editing the project name
Right-click on the root directory. Select "Rename" from the shortcut menu that appears. You can edit the
project name directly in the tree view, then. 

Note As a rule, every element in the project tree can be renamed in this way.
42/49-29 EN Data Archiving Tool HDA100, R&C Process Data Management Software 9
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2.5.3 Creating a new element in the project tree
Right-click on the folder icon to open the shortcut menu. Then select "New". A pull-down menu with var-
ious options for creating a new project element will pop up. The following menu options can be selected: 

Folder
Creates another hierarchy level, where other elements can be. 

Device
Creates a new device. The device type can be selected from a device selection list. The selection list con-
tains all Device Type Managers (DTMs) installed on your PC and the virtual devices like the R&C Modbus
OPC Server. 

External application
Permits to integrate any external 32-bit program, e.g. Paraline200. This feature is especially designed for
supporting devices for which no DTM complying with the FDT standard exists yet. 

Visualization page
Permits to create visualization pages by using one of the 11 pre-configured standard visualization pages
as a template, and to integrate user-defined HTML pages.

Fig. 2-4

2.5.4 Creating a device
Right-click on the folder icon to open the shortcut menu. Then select "New". A pull-down menu with var-
ious options for creating a new project element will pop up. Select "Device (by type)" to open the dialog
box for selecting the device type (see the illustration (see Fig. 2-5). 

Fig. 2-5
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Workspace
Select a device from the list of available devices. Press the "Create device" button to confirm. The device
will be created in the selected folder with the name "New device". Directly upon creation the edit mode
will be active, i.e. you can change the node name according to your needs. 

Note The name is freely configurable, independent of the device type. Names like "Datavis-1", "Datavis (heater
A)", or simply "Tag 01" are valid without any limitations.

Double-click on the menu item to start the device-specific Device Type Manager with all parameter defi-
nitions of the device. See topic "Device Type Manager" for details.

2.5.5 Integrating external applications
The program permits to integrate any external 32-bit program, e.g. Parapoint200. This feature is espe-
cially designed for supporting devices for which no DTM complying with the FDT standard exists yet. You
can also integrate any other 32-bit program, e.g. Excel. 

Right-click on the folder icon to open the shortcut menu. Under "New" a select list for creating a new
project element can be called up. Select "External application". The dialog box for integrating external
programs appears.  

Fig. 2-6

Command line
Enter the program name with full path information in the command line.

Work directory:
If you don't want to use the program folder as your work directory, you can enter a path for your work
directory here.

Confirm with OK. The new item appears in the tree. Double-click on the item to start your application.
42/49-29 EN Data Archiving Tool HDA100, R&C Process Data Management Software 11
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Editing remarks
A remark can be stored for every node in the project tree. Select the "Remarks" menu item from the short-
cut menu to open the Remarks dialog box. 
You can enter simple texts without attributes in this dialog box. Confirm with OK. The text is taken over
and allocated to the node. 

Fig. 2-7

Linked documents
Documents like operating instructions for the device, logs, etc. can be linked with every node. Click on 
the "Linked documents" menu item to open the "Documents linked with this element" dialog box where 
you can add, remove or open documents. 

Fig. 2-8
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Workspace
2.6 File menu
The workspace offers a project management function for creating, loading and saving projects. This al-
lows you to work with different projects. The file menu of the workspace (see illustration) is used for
project management (see Fig. 2-1).

Fig. 2-9

2.6.1 Creating a new project
In order to create a new project open the File menu and select "New". If you have already opened a
project and have not yet saved it, you will be asked if you want to save that project before creating a new
one. If yes the File dialog box appears, if no the current project is closed without saving, and the new
project is created immediately. 
The new project is first created with the default name "New project", which can be changed as required.
Refer to the topic "Editing the project name" for details.

2.6.2 Opening an existing project
In order to open an existing project open the File menu and select "Open...". If you have already opened
a project and have not yet saved it, you will be asked if you want to save that project before opening an-
other one. If yes the File dialog box appears, if no the current project is closed without saving.  The "Open
file" dialog box appears where you can select the respective file and then load it into the workspace.
Project files have the extension ".ids".

2.6.3 Saving the current project
In order to save the current project open the File menu and select "Save". The project will be saved with-
out further prompts. If the project is saved for the first time, the "Save as" dialog box will appear, where
you can enter a new name for your project. 

2.6.4 Saving a project under a new name
Select the "Save as..." menu option from the File menu if you want to save the current project under a
new name. The "Save as" dialog box will appear, where you can enter a new name for your project. After
this the project will appear in the workspace under the new name.

2.6.5 Saving a copy of the project
Select the "Save copy as..." menu option from the File menu if you want to save a copy of the current
project under a new name. The "Save as" dialog box will appear, where you can enter a new name for
your project. The project name that already exists in the workspace will not be changed. 

2.6.6 Sending a project to
Under "File" -> "Send to" "E-mail address" you can send you project as an e-mail to an addressee. The
mailing program is opened. A new mail is created automatically, and the project file (.ids) is already at-
tached to it. Enter an e-mail address and send off the mail.
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Workspace
2.7 View menu
In the View menu you can adapt the workspace to your needs. You can select the dialog language and
show/hide the toolbar, the status bar, and the project tree (Project view). 

Fig. 2-10

2.7.1 Dialog language
Select the "Change language" menu item to change the dialog language. The "Change language" dialog
window appears.

Fig. 2-11

Select a language from the list of installed languages and confirm with OK. The new language setting will
be activated when the program is started the next time. Terminate/restart your program. 

2.7.2 Showing/hiding the toolbar and status bar
Click on the "Toolbar" menu item to show/hide the toolbar. 
Click on the "Status bar" menu item to show/hide the status bar.

2.7.3 Showing/hiding the project view
Click on the "Project view" menu item to show/hide. 
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Workspace
2.8 Project menu
In the project menu you can set the project-specific parameters.

Fig. 2-12

2.8.1 Defining the fieldbus segments
A fieldbus segment represents the configuration of serial PC or bus segment interface. If the PC has sev-
eral serial interfaces, you can define several fieldbus segments with different settings (e.g. for the baud
rate). In the device configuration a fieldbus segment can be allocated to the respective device. 

Select the "Define fieldbus segment" menu item from the "Project" menu. 
A dialog box appears where the defined fieldbus segments are listed. 

Fig. 2-13

Select the name of the link, the protocol (under fieldbus type) and the COM interface in the "Fieldbus seg-
ment" dialog box.

Fig. 2-14
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Workspace
Click on "Edit". 
A window appears, where you can define the interface settings: RS 232 or RS 485, baud rate, etc. 

Remark Usually, RS 232 is the correct setting, even if the device is connected to the RS 232 interface of your
computer via an  RS 485 converter. RS 485 has to be selected only if a so-called hardware flow control
is required, e.g. for a non-automatic RS 485/RS 232 converter. 

2.8.2 Options
In the Project options dialog box you can define that the last accessed project is automatically opened
when the workspace is started.  

Fig. 2-15

2.9 Help Menu
The Help Menu contains the item Help and Register with that one can open the license dialog.

The Help for the License dialog can be opened by pressing the help button avaliable on this dialog.

Comment The Licensing software is a common ABB software independent of the R&C Process Data Management.
This is the reason why it has his own separate help. 
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3 OPC HDA Server for Process Data Archiving
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Status Dialog
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3.1 OPC (OLE for Process Control)
What is OPC?
OPC is an approach for data access via standardized interfaces.

In the past, every software and application engineer had to develop proprietary interfaces, servers or driv-
ers for the data exchange with fieldbus instruments. The problem was due to the large variety of different
field instruments, bus systems and data recording stations available on the market, resulting in incompat-
ible proprietary solutions. OPC defines a common, open interface doing away with this. Special drivers
are no longer needed. OPC allows for standardized access to any fieldbus from either HMI, SCADA or
open control systems.  

OLE for Process Control (OPC) thus enables standardized data exchange between heterogeneous au-
tomation instruments and different PC applications. OLE stands for Object Linking and Embedding and
is a software interface for displaying and embedding information from one program in other applications.
OPC is sustained by the OPC Foundation who has worked out the technical specifications and nowadays
has more than 140 members, among them big companies like ABB, Siemens, etc. 

3.2 OPC HDA Server
The OPC HDA server (HDA = historical data access) requires an OPC DA server (DA = Data Access to
online data). The HDA server saves the process data from the allocated channels (OPC DA items) in an
archive and provides them to the PC world on the network via the OPC HDA interface. 

3.2.1 Notes for Installation
When the OPC HDA server is installed on your system, the work environment common to all R&C Pro-
cess Data Management products is installed as well. If it should already reside on your system (since
another product of this series has been installed before) it is updated, if required. 
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3.2.2 Data Archiving Tool Concept and Operating Principle
Data archiving is based on the OPC HDA server concept. The OPC HDA server receives data from on
OPC DA server (e.g. the Modbus OPC server), stores them in a file archive, and provides the stored data
to the application programs (OPC HDA clients) on request. A typical application is e.g. process data vi-
sualization using line charts. 

The mechanism for recording and playing back process data is realized by the so-called HDA data re-
corders in the user interface. HDA data recorders are virtual devices created and integrated in the project
tree of the Process Data Management. The channels to be recorded, the archive directory, and the op-
erating mode (recording and playback, or recording only) can be set via these HDA data recorders as
well. 

Starting the HDA-Server /Standby Mode
The OPC HDA server is started together with the ABB Process Data Management program, provided that
an HDA data recorder already exists in the project tree. The HDA server status can be polled via an icon
in the Windows task bar. Seen from the technical point of view, the HDA data recorder is used to configure
the ABB OPC HDA server. Data recording and playback can be started for the configured channels by
selecting the "OPC HDA recorder active" menu item from the device shortcut menu. This establishes a
link between the "Device" (i.e. the data sources configured in the data recorder) and the OPC HDA server.
The archived data are then directly made available to all OPC HDA clients (e.g. the Data Visualization
program) throughout the system. When the "OPC HDA recorder active" menu item is unselected, the
OPC-HCA server does not "known" the respective data recorder, and the data recorder is more or less
in Standby Mode (data recording and/or data playback stopped).

Data Recording and Playback
When OPC communication is active, the data recorder can be run in two modes:
• In the "Data recording" mode (default setting) the values measured in online mode are stored in a spe-

cific directory.
• In the "Data playback" mode no new measuring values are recorded; only already recorded (historical

data are made available to the HDA clients upon request. The data playback mode can be activated by
ticking the "Data playback only" check box on the "Archive" configuration page of the HDA data recor-
der.

Terminating Data Archiving
Data archiving can be terminated in the following ways:
• Terminating / Canceling data archiving for a specific device: 

Simply disable OPC communication via the shortcut menu of the respective HDA data recorder. The
OPC HDA server will continue operation.

• Switching off the OPC HDA server:
Usually, the OPC HDA server is not closed down when the program is closed or the project is chan-
ged. However, this default setting can be changed by selecting the "Stop HDA server when project is
closed" option in the Project/Options menu. With this setting, the HDA server will be closed down when
the R&C Process Data Management program is exited. At the same time, data archiving will be inter-
rupted as well. 
Additionally, the OPC HDA server can be stopped separately. Right-click the OPC HDA icon in the task
bar to open the "Server context menu" window and then actuate the "Shutdown" button in this window.
Answer the system prompt with "Yes". The OPC server will be closed down.

3.2.3 Creating a New OPC HDA Recorder
In the project tree, the OPC HDA server is represented by one or more HDA data recorders, through
which the OPC HDA server can be configured. 

Data recording and archiving via the OPC HDA server can be achieved in two ways:
• Using OPC DA servers as data source
• Importing data files via the HDA data recorder (Rev. 3.1 or higher)
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Using OPC DA servers as data source
Basically, any OPC DA server in accordance with OPC DA standard 2.0 can be used as a data source.
Refer to the respective help system for more information about the ABB R&C MODBUS-OPC DA server. 

Proceed as described below to create an HDA data recorder in the project tree: 

Right-click on the folder symbol to open the context menu. Select "New" to create a new project element. 

Fig. 3-1

Select "Device (acc. to type)" from the pull-down menu to call the dialog box for choosing the device type. 

Fig. 3-2

Select "OPC HDA recorder" from the list box and click on the "Create device" button to close the dialog
box and create a new device node in the project tree. 

Directly upon creation of the node, the edit mode is active and you can change the device name if re-
quired. 
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HDA Data Recorder Shortcut Menu

Right-click on the HDA data recorder device node to open the data recorder shortcut menu. 

Fig. 3-3

The menu items "Comments", "Linked documents", "Delete", "Rename", and "Select fieldbus link" are
general and beyond the scope of this help system. Please refer to the help system of the work environ-
ment for details. 

Configuration
Selecting the "Configuration" item will open the HDA data recorder configuration dialog. 

OPC HDA recorder active 
This function is usually ticked (on the left hand side) and, thus, active. "OPC HDA recorder active" means
that the defined process variables of the device are available in the OPC name area of the OPC HDA
server and can be called by all OPC HDA applications throughout the system.

Deactivating OPC communication is in some cases useful e.g. if configured process variables temporarily
shall not be accessible.
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3.2.4 OPC HDA Data Recorder Configuration Dialog
Double-click on the HDA data recorder node in the project tree to start the HDA data recorder configura-
tion dialog. The navigation tree appears in the window section on the left hand side. 

Click on the navigation tree items to call up the individual dialog sheets. 

Archive Dialog
The Archive dialog is used to set the following data recorder features: 

• the mode (data recording and playback or data playback only, without recording)
• the directory where the measured values are to be saved (mandatory!)
• the ring buffer size and overflow protection (Rev. 3.1 and higher)

Fig. 3-4 Archive settings
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Channels Dialog
The following settings can be made in the Channels dialog:

• The process variables to be archived (OPC DA server as data source). Press the "..." button to open
the OPC browser window. For details about channel selection please refer to the help system for the
visualization pages.

• In the "OPC HDA item ID" window the designation of the selected channel (highlighted gray in the lower
window section) can be modified.

• In the "Description" window the item description taken over from the DA server can be edited. 
• "Unit" is the engineering unit of the process variables (e.g. m³/h etc.)
• The "Scale low" and "Scale high" values can be used e.g. by HDA clients for pre-configured scales.
• The "Update rate" indicates, how often a new value is saved, under the proviso that the deadband is

zero. 
The deadband is a settable value (indicated as a percentage of the measuring span) by which a value
must differ from the previous one in order to be transmitted to the HDA server by the DA server. 
Example:
The tolerance band is set to 1%, with a scale of 0...200. The previous value transmitted to the HDA
server is 50. If a new value differs by at least 2 from 50, it is transmitted to the HDA server. The time
interval between the individual polls is given by the update rate.

Fig. 3-5
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Trigger Dialog
The Trigger dialog (Rev. 3.1 and higher) is used to set the data recorder start/stop conditions. Data ar-
chiving can be started either immediately or at a defined time later on. If "Never" is selected here, the data
recorder will not record any data. 

Analogously, data archiving can be stopped at a given time, after a defined recording time, or manually. 

Fig. 3-6
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Status Dialog
The Status dialog window is used to display the current HDA server status. 

The following items are listed:
• OPC HDA server start time
• HDA data recorder status (recording active/not active/standby)
• configured OPC DA channels (measuring channels)
• the names of all channels archived in the specified folder

Fig. 3-7

After the configuration has been confirmed with "OK" the recorder is ready for data recording, and the
process variables listed in the Channels dialog are then available to all OPC HDA clients throughout the
system. 

3.3 Files and Directories
The measured values are stored in the directory specified in the configuration dialog window of the HDA
data recorder. One sub-directory is created for every recorded channel, and a separate file with recorded
data is created in this sub-directory for every day. This is done automatically directly upon recording start,
without requiring any user interaction. The naming conventions listed below are valid.

For the subdirectory: 
"data_recorder_name.OPC_server_name.OPC_DA_item_ID"

Description:
• data_recorder_name: the name of the HDA recorder for data recording integrated in the project tree (in

this example: sm200-hda)
• OPC_server_name: the name of the OPC DA server used for data recording (in this example:

ABB_IM_OpcServer_1)
• OPC_DA_item_ID: the name of the data recording device under which it is listed in the project tree (in

this example: Sm200.SM200_300_Stifte.Pen06)
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Fig. 3-8

Due to these naming conventions, the entire recording path can be traced back to the recording source. 

The archive directory can be named or selected as required. Also, the data can be moved from one di-
rectory to another at a later time. The new directory can then be accessed by simply creating a data re-
corder and entering the respective directory name. The server will then browse the entire directory
including all sub-directories to find the respective data files and will then make available the data through-
out the system in accordance with the conventions listed above. 

The data files stored in these subdirectory follow the same naming conventions and structure, but the
names additionally contain the current date. 

The data files are binary files with a digital signature which ensures that the data can be validated. Ma-
nipulated data sets are considered as invalid and marked accordingly, e.g. in the HDA Chart Control of
the Process Data Management Visualization. 

3.4 Archive Backup and Recovery
If considerable archive data are to be saved on a CD ROM or similar, the respective data can be copied
to the storage medium and then deleted from the archive directory.

Data recovery can be achieved by simply copying the historical data to an any appropriate archive direc-
tory or by creating a recorder pointing to the CD ROM drive. 

Note The directory tree within the archive directory can be modified at any time by renaming or moving folders
- even while the system is running - without affecting operation.

The exact names of directories and files have NO effect on data consistency or accessibility. 
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