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Application Note  
 

AC500 PLC and ABB ACS355 Drive via Modbus TCP/IP with ABB 
Standard Library  
 
 

    Description 
This application note will take you through the hardware installation and configuration of ABB ACS355 Drives 
and eCo PLC in order to prepare for Modbus TCP/IP protocol control. AC500 ABB‐specific ready‐made 
function blocks and visualizations from the PS553‐ DRIVES library will be used for the control of the drives.  

    Objectives: 
In this aplication note, we use an AC500 eCo PLC and ACS355 drive with Modbus TCP/IP communication. 
The personal computer will connect to PLC and drive via unmanaged switch box.  The eCo PLC controls drive 
via Modbus TCP/IP connection. 
 

Equipment List 
 

Description Quantity 
PC with AB V1.0 software installed 1 
ABB eCo CPU PM556 ETH CPU 1 
CAT5 Ethernet Patch cable 3 
FENA-01 Fieldbus module 1 
Unmanaged switch 1 

    Connection diagram 
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1. Install the FENA-01 field bus module into this ACS355 drive 
2. Connect the Ethernet cable from PC to PM583 ETH CPU to unmanaged switch box 
3. Connect the Ethernet cable from ACS355 drive’s FENA-01 to unmanaged switch box 

 

    ACS355 drive’s parameter setup 
All parameter settings are based on drive default settings. If the drive has been parameterized previously, 
return to default settings before continuing. It can be done by: 
 

Changing macro (and then changing back again) in parameter 99.02 for ACS355 drive 
 

• Power up the drive 
• Enter/verify the parameters as shown below 

Minimum required parameter settings (based on factory default) 
 

 

 
 
 
 
 
 

Parameter Description Setting Comment 

98.02 COMM PROT SEL EXT FBA Activates fieldbus module 

51.01 FBA TYPE ETHERNET Type of the connected fieldbus module. Read only 

51.02 PROTOCOL / 
PROFILE 

 1 0=ModbusTCP ABB Drives profile classic 
1= ModbusTCP ABB Drives profile enhanced 

51.03 COMMRATE 0 Bit rate for the Ethernet interface. 
51.04 IP 

CONFIGURATION 
0 (Static IP) Sets the method for configuring the IP address. 

0 = Disable DCHP –>static IP address 
51.05 IP ADDRESS 1 [IP address 1] 192 
51.06 IP ADDRESS 2 [IP address 2] 168 
51.07 IP ADDRESS 3 [IP address 3] 3 
51.08 IP ADDRESS 4 [IP address 4] 66 

 51.09 SUBNET CIDR [Subnet 
 

24 = 255.255.255.0 
54.01 
 

 102 Speed (rpm) 
54.02  104 Current (A) 
54.03  105 Torque (%) 
54.04  106 Power kW 
51.20 MODBUS/TCP 

TIMEOUT 
20 *) Timeout = (MODBUS/TCP Timeout value) * 100 

milliseconds.*)  20 = 2 seconds 
51.27 REFRESH 1 Updates fieldbus settings (groups 51 to 55) 

10.01 EXT 1 
 

COMM Fieldbus interface as source for start and stop 
11.02 EXT1/EXT2 SEL COMM Fieldbus interface as source to switch to EXT2 
11.03 REF1 SELECT COMM Fieldbus interface as source for speed reference 
16.04 FAULT RESET SEL COMM Fieldbus interface as source for fault reset 
11.05 REF1 MAX  Max speed/frequency scaling value. Must be less or 

equal 
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    Create new PLC project in Automation Builder software tool: 
 

5.1 Double click on ABB Automation Builder software tool  icon on the desktop. 

(If Automation Builder icon is not available on your desktop, click Start, go to All Programs, select ABB 
folder and click on Automation Builder software tool.)  

 
5.2 The Automation Builder Screen will appear as shown below, if Internet access is available Automation 

Builder will show the default ABB homepage for PLC products  
 

5.3 Create a new project by clicking the New button or selecting the File > New Project  
 

5.4 Enter project name as shown in example below:  AC500 and ACS355 with Modbus RTU project 
 

5.5 Select the location to store the project in PC 
 

5.6 Select OK to start the project 
 

     Specifying the hardware configuration:   
 

To specify the hardware configuration, the I/Os and their symbolic names have to be defined. Configure 
your I/O by double clicking I/O (Onboard I/Os) and refer to the mapping tab window opened on the right 
side where you can give variable names to each I/O points. 
 
6.1 Double click AC500 (PM564-ETH) on the left to open this hardware menu 

 
6.2 Change the value of Check battery from ON to OFF ( if no battery present for this example)  

 
 

    Setup the Ethernet communication in Windows: 
Before you are able to download the compiled program the first time from the PC to the PLC, you have 
to setup the communication parameter. There are two options you can use to login to the PLC, either 
with Ethernet or serial with TK503 USB cable. 

 
For this exercise, we are using Ethernet connection for online access to this PLC. 
 
Make sure that your PC address is in the same class as the CPU’s IP address. The factory setting of 
the CPU for IP address is 192.168.0.10. Then the IP of the PC should be 192.168.0.x, x should be 
different number than 10 so that it will not have an IP conflict with the CPU. Subnet mask should be 
255.255.255.0. 
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To change the IP address in your PC: 

 
7.1 Windows Control Panel > Network and Internet > Network and Sharing Center 
7.2 Click on Change adapter settings 
7.3 Select Local Area Connection (in this example is  PLC network connection below) and right click it 

to open the menu. 
 

        
 
Choose Properties ( the status is active when the Ethernet connection between PC and  PLC is active) 
7.4  Select Internet Protocol Version 4 (TCP/IPv4) and double click to see properties. 
7.5  Type in your desired IP address and subnet mask then click OK. 

 

 
 

 Setup the IP address in Automation Builder software: 
8.1 Make sure the CPU’s RUN switch is STOP position 
8.2 Click IP-Configuration to access Scan tool 
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8.3 Click on Scan button for searching active PLC on the network 
8.4 Highlight the active IP address in the search window 
8.5 Change the IP address to new IP address such as 192.168.3.20 
8.6 Click on Send Configuration button to send new IP address to PLC.  

 

         
 

• The warning message window display is shown below for this change.   
• This screen shows the progress of IP address settings is sending to CPU. Wait about 30 seconds 

for CPU to register new IP address (the RUN and ERR lights are flashing during this process). 
• Click OK to accept this new IP address for this CPU. 

 
 

• Press “Scan” button again to verify the IP address of CPU. This window shows the Configured IP 
address sent to CPU successfully.  This IP address will be used in IEC 61131-3 CoDeSys to 
download your PLC project to CPU. 

 

     
 
8.7 Click File > Save Project to save the configuration settings for this lab. 
8.8 Right on AC500 > Create Configuration data to save the settings before go to CoDeSys window. 
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   Modbus TCP/IP configuration: 

9.1 Right click on Protocols > Add object to access Protocols menu 
9.2     Select Modbus TCP/IP Server for this connection 

 
 

 
9.3    Set Server connections = 4.   

   Note:  Server Connections are for Maximum number of logical parallel connections, 
that  are kept for connection requests by clients in operation mode as server.  

  
 

 

   IEC61131-3 Application (CoDeSys): 
 
10.1  Double‐click “Application“ from the Device tree in Automation Builder project to access the  

IEC61131-3 application (CoDeSys) 
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10.2 Open the Library Manager by double‐clicking “Library Manager” from “Resources”  tab 
10.3 Right‐click in the library field and choose “Additional Library”  

 

 
 

10.4 Select the “ACSDrivesBase_AC500_V20.lib” and “ACSDrivesComModTCP_AC500_V22.lib” 
from the PS553‐DRIVES folder (under the standard CODESYS library folder) 

10.5 Click “Open” to add the libraries to the project 

          Create new PLC logic in FBD ( Function Block Diagram) 
 

10.6 Compile your project, choose “Rebuild all” from the “Project” menu. 
 

 
 

10.7 Right‐click “PLC_PRG” in the “POUs” tab  
10.8 Choose “Convert Object” 

a. Choose Target Language “FBD” 
10.9 Click “OK” 

 
 
 
 
 
 
 
 
 
 
 

10.10 Right‐click in the POUs field and choose “Add Object” 
10.11 Set Type of POU to “Program” 

 
 
 
 
 
 
 
   

10.12 Set language of the POU to “FBD”  
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10.13 Name the Program and click “OK” e.g. “Drive1”  
10.14 Double‐click “PLC_PRG” to open the main program 
10.15 Select the dotted box in Network 0001 
10.16 Right-mouse Click to insert a box 

 

 
 
10.17 Press the F2 key and select your program from the list as shown below 

 

 
 

   ACS_COM_MOD_TCP Function Block Creation 
 

11.1   Double‐click your new program: Drive1 
11.2 Add a box 
11.3   Press F2 while the block title is selected 
11.4 Choose “ACS_COM_MOD_TCP_ENHANCED” from “Standard Function Blocks”,  
11.5 Click “OK”  

 
Tip: Check √ the “Structured” box in the Input assistant menu 

 

 
 

11.6 Give the instance of the drive communication block a name 



LVD-EOTN118U-EN REVA                                                                                         Page 9 of 16  
 

11.7   Declare it as of type “ACS_COM_MOD_TCP”  
a. The type is automatically listed after the function block is selected. 

 

 
 

11.8 Open the program again from the “POUs” tab and connect the function block inputs as shown 
11.9  In the example below, the block will always be enabled 
11.10 Slot 0 of the PLC is used for Modbus TCP/IP (Slot 0 is CPU’s onboard Ethernet port)  
11.11 The drive’s  IP Address 192.168.3.66 
11.12  Type number 4 as Drive type is for ACS355 drive 
11.13 Connect the variable DrivePointer to DRIVE_DATA 

a. DrivePointer: ACS_DRIVE_DATA_TYPE; 
 

 
 

     ACS_DRIVES_CTRL_STANDARD Function Block Creation 
 

Create a second Network After (Ctrl +T) in the Drive1 program  
12.1 Add the block “ACS_DRIVES_CTRL_STANDARD” as shown previously 
12.2 Name this function block is Drive_Control 
12.3 Connect the function block inputs as shown below 
12.4 Other than Enable input the complete block will be controlled by using the Visualization. 
 

NOTE: The variable connected to “ACS_DRIVES_CTRL_STANDARD” ‐> “DRIVE_DATA” must be 
the same as the one connected to “ACS_COM_MOD_TCP” ‐> “DRIVE_DATA” and must be of 
type “ACS_DRIVE_DATA_TYPE”. 
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   Create Visualizations to control ACS355 drive 
13.1   Click Visualizations tab in the bottom left of IEC61131-3 programming environment 

 
 

                   
 
13.2 Right‐click “Visualizations” in the “Visualizations” tab 

 

 
 
13.3   Choose “Add Object”, give the visualization page a name 

a. E.g. PLC_VISU 

 
 
 
 

 
 

13.4 From the new page, choose “Visualization” from the “Insert” menu and draw a box 
13.5 Select Visualization “ACS_COM_MOD_TCP_ENHANCED_VISU_PH” as shown below 
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13.6 Double click on the visualization to view the configuration dialog 
13.7   Select “Placeholder…” 
13.8 Place the cursor in the “Replacement” Column, and press the F2 key 

 
 
 

 
13.9 Select the Drive_Access object as shown below 

 

                                    
 

13.10 Press “OK” to accept and exit 
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   Create ACS_DRIVES_CTRL_STANDARD Visualization template 
14.1 From the same page as previously described, choose “Visualization”  from menu and draw  

 a box in visualization screen 
14.2 Select Visualization “ACS_DRIVES_CTRL_STANDARD_VISU_PH” template 

 
 

14.3 Double click on the visualization to view the configuration dialog 
14.4 Select “Placeholder…” 
14.5 Place the cursor in the “Replacement” Column, and press the F2 key 
14.6 Select the Drive_Control object as shown below 

 

 
 
 

 
14.7 Press “OK” to accept and exit 

 

Here is the complete PLC codes for this Application Note: 
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   Download program to PLC and Go online: 
15.1 From Online menu, select Communication Parameters. 

 
 
15.2 In the Communication Parameter dialog box, click New… button to add a new channel. Type  

        the name for this channel.  In this example below, 192.168.3.35 is the name for this channel. 
15.3 In the popup Communication Parameters: New Channel dialog, fill in the “Name” field with  

         192.168.3.35, select TCP/IP in Device window then click OK.  
15.4 Double click in Value field, type 192.168.3.35 for PLC’s IP address. 
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15.5 Click Gateway then select Local for Connection from popup Communication Parameters:  
        Gateway window as shown below. 

                                  
 

15.6 Double click in each Value field to replace with  
• Address: 192.168.3.35 
• Port:  1201 
• Motorola byteorder:  Yes  

Click OK to accept these entries. 
 

 
 

15.7   Click Online>login in top menu to download the changes and go online with CPU.   
15.8 Click Yes when message appear below.  
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15.9 The download progress as shown below. 

 
 

   Create boot project 
 

In  “Online”  mode  (Login),  choose  “Create  boot  project”  from  the  “Online”  menu. With this 
command, the compiled project is stored to the flash in such a way that the PLC will load it 
automatically when CPU re-started. 

 
 
 
 
 
 
 
 
 
 
 

 
 

   Run PLC Program 
 

17.1   Click Online then Login to go online with CPU 
 

17.2 Click RUN to put CPU in RUN mode. Verify the PLC is in run mode at Status line in bottom  
 

right of the window. 
 

17.3   Reset the Drive if needed 
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a. Click Start button in  ACS_DRIVES_CTRL_STANDARD visualization template 

 
17.4 Enter a SPEED_REF  

a. The speed ref is in counts (+/- 20,000) 
b. Refer to drive parameters 11.05 for motor speed RPM scaling 

 
17.5   Verify the drive’s motor running. 

 

Here is the visualization for this project: 
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