
System Description Advant Controller 31
Intelligent Decentralized
Automation System

Fieldbus Configurator
907 FB 1131

In order to easier find the different descriptions, they are separated by coloured
paper sheets.

Fieldbus Configurator Colour of paper sheet at the
beginning

PROFIBUS ...................................... red

DeviceNet ........................................ green

Interbus ........................................... blue

CANopen ......................................... orange

Ethernet ........................................... yellow





Operating Instruction Manual

907 FB 1131
Fieldbus Configurator PROFIBUS

Edition: 9
Language: English (EN)

ABB STOTZ-KONTAKT GmbH
Eppelheimer Straße 82

D-69123 Heidelberg
Germany

Tel: +49(0)6221/701-0

Hotline Tel: +49(0)6221/701-1444
Hotline Fax: +49(0)6221/701-1382

Email Hotline: Desst.helpline@de.abb.com

Web: www.abb.de/sto



2  ••••   Overview FB 1131 Fieldbus Configurator PROFIBUS

Copyright •  ABB STOTZ-KONTAKT GmbH •

List of Revisions
Index Date Version Chapter Revision
4 15.09.98 2.530 PROFIBUS.DLL

2.070 FB 1131.EXE
all Created

5 05.01.00 2.620 PROFIBUS.DLL
2.620 FB 1131.EXE

all New structure of chapters,
Chapter Installation and Licensing revised,
New chapter: Getting started,
Device Assignment,
Menu now focus dependent / focus controlled,
New functions: IO Watch, Message Monitor, DPV1
Extended Device Diagnostic expanded,
Error numbers expanded,
New chapter: Appendix

6 17.04.00 2.620 PROFIBUS.DLL
2.620 FB 1131.EXE

5.2
10.3

Bus Parameters more detailed described
New section List of equations

7 12.02.01 2.700 PROFIBUS.DLL
2.638 FB 1131.EXE

6.3 New function Automatic Network Scan
Additional overview tables: Diagnostic functions, User data
transfer

8 06.02.02 2.723 PROFIBUS.dll
2.638 FB 1131.exe

all revised
CSV Export

9 25.11.02 2.723 PROFIBUS.dll
2.6383 FB1131.exe

2 revised

Although this program has been developed with great care and intensively
tested, ABB STOTZ-KONTAKT GmbH cannot guarantee the suitability of
this program for any purpose not confirmed by us in writing.
Guarantee claims shall be limited to the right to require rectification. Liability
for any damages which may have arisen from the use of this program or its
documentation shall be limited to cases of intent.
We reserve the right to modify our products and their specifications at any
time in as far as this contributes to technical progress. The version of the
manual supplied with the program applies.



Fieldbus Configurator PROFIBUS Table Of Contents  ••••   3

Copyright •  ABB STOTZ-KONTAKT GmbH •

Table Of Contents

1 OVERVIEW FB 1131...................................................................................................7
1.1 Main Functions .........................................................................................................7
1.2 Properties.................................................................................................................8

2 INSTALLATION AND LICENSING ..............................................................................9
2.1 System Requirements ..............................................................................................9
2.2 Software Installation ...............................................................................................10

3 GETTING STARTED – CONFIGURATION STEPS ..................................................11
3.1 Overview Communication Types ............................................................................11

3.1.1 PROFIBUS-DP .................................................................................................. 11

3.2 PROFIBUS-DP.......................................................................................................12
3.2.1 Configuration DP Master to a DP Slave ............................................................ 12
3.2.2 Configuration DP Slave to any DP Master......................................................... 13

4 CONFIGURATION OF PROFIBUS WITH FB 1131...................................................15
4.1 Setting up the PROFIBUS Configuration ................................................................15
4.2 GSD Files...............................................................................................................15
4.3 Master ....................................................................................................................17

4.3.1 Insert Master ...................................................................................................... 17
4.3.2 Master Configuration.......................................................................................... 18
4.3.3 Auto Configuration (PROFIBUS-DP) ................................................................. 19
4.3.4 Replace Master.................................................................................................. 20

4.4 DP Slave ................................................................................................................21
4.4.1 Insert DP Slave .................................................................................................. 21
4.4.2 Slave Configuration............................................................................................ 23
4.4.3 Inserting Predefined Device – PDD................................................................... 26
4.4.4 Replace Slave.................................................................................................... 28

5 SETTINGS.................................................................................................................29
5.1 Gateway Driver.......................................................................................................29
5.2 Bus Parameters......................................................................................................31

5.2.1 Setting the Bus Parameters and Profiles........................................................... 31
5.2.2 Descriptions of the Individual Parameters ......................................................... 33
5.2.3 Rules.................................................................................................................. 36

5.3 DP Master ..............................................................................................................37
5.3.1 Master Configuration.......................................................................................... 37
5.3.2 Group Membership ............................................................................................ 37

5.4 DP Slave ................................................................................................................38
5.4.1 DP Slave Configuration...................................................................................... 38
5.4.2 Parameter Data.................................................................................................. 39



4  ••••   Overview FB 1131 Fieldbus Configurator PROFIBUS

Copyright •  ABB STOTZ-KONTAKT GmbH •

5.5 Project Information .................................................................................................41
5.6 Path........................................................................................................................41
5.7 Language ...............................................................................................................42

6 ONLINE FUNCTIONS ...............................................................................................43
6.1 Introduction ............................................................................................................43
6.2 Online to the Coupler..............................................................................................43

6.2.1 Downloading the Configuration.......................................................................... 43
6.2.2 Firmware Download........................................................................................... 44
6.2.3 Firmware / Reset................................................................................................ 45
6.2.4 Device Info ......................................................................................................... 45

6.3 Automatic Network Scan ........................................................................................46
6.3.1 Assign Slave ...................................................................................................... 49
6.3.2 Assign Module ................................................................................................... 50
6.3.3 Slave with Station Address 126 - Determination of the Ident Number .............. 51

6.4 Start/Stop Communication......................................................................................52
6.5 Diagnostic Functions ..............................................................................................53

6.5.1 Live List .............................................................................................................. 54
6.5.2 Debug Mode (PROFIBUS-DP) .......................................................................... 55
6.5.3 Global State Field .............................................................................................. 62
6.5.4 Extended Device Diagnostic.............................................................................. 64

6.6 PROFIBUS Services ..............................................................................................66
6.6.1 Setting the Slave Address ................................................................................. 66

7 FILE, PRINT, EDIT AND VIEW .................................................................................67
7.1 File .........................................................................................................................67

7.1.1 Open .................................................................................................................. 67
7.1.2 Save and Save As ............................................................................................. 67
7.1.3 Close.................................................................................................................. 67

7.2 Print........................................................................................................................68
7.3 Edit .........................................................................................................................69

7.3.1 Cut, Copy and Paste (Master) ........................................................................... 69
7.3.2 Cut, Copy and Paste (Slave) ............................................................................. 70
7.3.3 Delete................................................................................................................. 71
7.3.4 Replace.............................................................................................................. 71

7.4 View of the Configuration........................................................................................72
7.4.1 Device Table ...................................................................................................... 72
7.4.2 Address Table.................................................................................................... 73

8 TOOLS ......................................................................................................................77
8.1 GSD Viewer............................................................................................................77

9 ERROR NUMBERS...................................................................................................79
9.1 Possible Control Error Messages to FB1131 Telegrams ........................................79
9.2 RCS Error Numbers (4 .. 93) ..................................................................................80



Fieldbus Configurator PROFIBUS Table Of Contents  ••••   5

Copyright •  ABB STOTZ-KONTAKT GmbH •

9.3 Database Access Error Numbers (100 .. 130) ........................................................82
9.4 Online Data Manager Error Numbers .....................................................................83

9.4.1 Online Data Manager Error Numbers (1000 .. 1018) ........................................ 83
9.4.2 Message Handler Error Numbers (2010 .. 2027) .............................................. 84
9.4.3 Driver Functions Error Numbers (2501 .. 2512) ................................................ 85
9.4.4 Online Data Manager Subfunctions Error Numbers (8001 .. 8035) .................. 85

9.5 Data Base Functions Error Numbers (4000 .. 4098) ...............................................86
9.6 Converting Functions Error Numbers (5001 .. 5008)...............................................90

10 APPENDIX ................................................................................................................91
10.1 Extended Device Diagnostic Master .......................................................................91

10.1.1 PLC_TASK Common Variables......................................................................... 91
10.1.2 USR_INTF Task State ....................................................................................... 92
10.1.3 USR_INTF Running States................................................................................ 93
10.1.4 USR_INTF Global State Field............................................................................ 93
10.1.5 USR_INTF Communication Error ...................................................................... 94
10.1.6 USR_INTF Parameter Set List .......................................................................... 95
10.1.7 USR_INTF Last Download Parameter............................................................... 96
10.1.8 USR_INTF Disconnect Report........................................................................... 97
10.1.9 USR_INTF Diagnostic Report............................................................................ 98
10.1.10 USR_INTF DPV1 Data ...................................................................................... 99
10.1.11 FDL_TASK Task State..................................................................................... 100
10.1.12 FDL_TASK Act. Bus parameter....................................................................... 101
10.1.13 FDL_TASK DDLM Requests Class 1 .............................................................. 102
10.1.14 FDL_TASK DDLM Requests Class 2 .............................................................. 103
10.1.15 FDL_TASK FDL Requests............................................................................... 104
10.1.16 FDL_TASK FMA Requests.............................................................................. 105
10.1.17 FDL_TASK DP Retry for Slave........................................................................ 106
10.1.18 FDL_TASK DP Activated Slave....................................................................... 107

10.2 Extended Device Diagnostic DP Slave .................................................................108
10.2.1 PLC_TASK Variables....................................................................................... 108
10.2.2 SPC3CTRL SPC3............................................................................................ 109
10.2.3 SPC3CTRL Slave Config................................................................................. 110
10.2.4 SPC3CTRL Master Config............................................................................... 111
10.2.5 SPC3CTRL Param Data.................................................................................. 112
10.2.6 SPC3CTRL DPM ............................................................................................. 113
10.2.7 SPC3CTRL DPV1 Class 1............................................................................... 114
10.2.8 SPC3CTRL DPV1 Class 2............................................................................... 116
10.2.9 SPC3CTRL Code Diagnostic........................................................................... 117

10.3 Identifier Bytes......................................................................................................118
10.3.1 Identifier Bytes (General Identifier Format GIF) .............................................. 118
10.3.2 Special Identifier Byte Format (SIF)................................................................. 121

11 LISTS.......................................................................................................................123
11.1 List of Figures.......................................................................................................123
11.2 List of Tables ........................................................................................................125
11.3 List of Equations...................................................................................................127



6  ••••   Overview FB 1131 Fieldbus Configurator PROFIBUS

Copyright •  ABB STOTZ-KONTAKT GmbH •



Fieldbus Configurator PROFIBUS Overview FB 1131  ••••   7

Copyright •  ABB STOTZ-KONTAKT GmbH •

1 Overview FB 1131
1.1 Main Functions

The main functions of the PROFIBUS Fieldbus Configurator are:
Function Section Short Description

Overview Communication Types Overview communication types and
description of the configuration steps

Configuration

Automatic Network Scan Scans the network
Diagnostic Diagnostic Functions Diagnostic functions, e.g. Life List,

Debugger, Global State Field etc.
Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: FB 1131 Main Functions
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1.2 Properties
FB 1131 is an universal Fieldbus Configurator
This means you can configure the most important Fieldbus systems like
PROFIBUS, InterBus and  DeviceNet with the same configuration tool.

FB 1131 is a global Fieldbus Configurator
You configure all devices with one tool. FB 1131 checks the dependencies
between the devices. FB 1131 only allows configurations that make sense.
In case of doubt FB 1131 will give you a warning.

FB 1131 documents your Fieldbus system
After the configuration you can print out a detailed documentation of your
Fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the detail of one
device.

FB 1131 uses standardised configuration files
Some protocols support standardised files containing information about all
features and limitations of the Slave device. FB 1131 uses these files for
the configuration.

FB 1131 is a diagnostic tool
After the configuration you can switch FB 1131 into the diagnostic mode.
You can watch all status information of ABB devices, see protocol
dependent diagnostic information, e.g. live list or Slave diagnostic
information on PROFIBUS. In this case a Slave not operating correctly will
be displayed in a different colour.
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2 Installation and Licensing
2.1 System Requirements

•  PC with 486-, Pentium processor or higher

•  Windows 95/98/ME, Windows NT/2000/XP

•  Free disk space: 30 - 80 MByte

•  CD ROM drive

•  RAM: min. 16 MByte

•  Graphic resolution: min. 800 x 600 pixel

•  Windows 95: Service Pack 1 or higher

•  Windows NT: Service Pack 3 or higher

•  Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the 907 AC 1131 CD in the local CD ROM drive. If "Autorun" is
enabled on the PC the CD menu will start automatically. Otherwise it is
started by starting the file "CD_Menu_Vxx.exe" in the root directory of the
CD. For example by the menu Start > Run and entering
"[X:]\CD_Menu_Vxx.exe" ([X] is the CD rom drive and Vxx stands for the
version number).
You reach the Installation menu of the CD by operating the Installation
907 AC 1131 Vxx button.

With the menu Notes for Installation you get a description of the
innstallation and the components of the 907 AC 1131, the programming
software, the Fieldbus Configurator 907 FB 1131, OPC Server.

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation of the Fieldbus Configurator 907 FB 1131!
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3 Getting Started – Configuration Steps
3.1 Overview Communication Types

Select from the following the communication type that you want to use. The
configuration steps are described in the given chapter.

3.1.1 PROFIBUS-DP

Communication Device Device Described in section Page
PROFIBUS-DP
(Class 1)

DP Master DP Slave Configuration DP Master to a DP Slave 12

PROFIBUS-DP
(Class 1)

DP Slave DP Master Configuration DP Slave to any DP Master 13

Table 2: Overview Communication Types PROFIBUS-DP
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3.2 PROFIBUS-DP

3.2.1 Configuration DP Master to a DP Slave
The following table describes the steps to configure a DP Master to a DP
Slave as it is typical for many cases.

# Action Menu in the Fieldbus Configurator Detail information in section Page
1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS

Configuration
15

2 Copy GSD file of the DP
Slave, if the Slave is not in
the selection list

File > Copy GSD GSD Files 15

3 Choose DP Master and
provide bus address

Insert > Master Insert Master 17

4 Choose DP Slave and
provide bus address

Insert > Slave Insert DP Slave 21

5 Assign the input and output
modules

6 Assign the offset addresses

Mark the Slave (left mouse click), then
Settings > Slave Configuration

Slave Configuration 23

7 Assign the DP Slave
Parameter data, if the Slave
needs Parameter data

Mark the Slave (left mouse click), then
Settings > Parameter Data

Parameter Data 39

8 Set the bus parameter Mark the Master (left mouse click), then
Settings > Bus Parameters

Bus Parameters 31

9 Set device assignment, if no
assignment has occured

Mark the Master (left mouse click), then
Settings > Device Assignment

Gateway Driver 29

10 Save project File > Save Save and Save As 67

11 Download Mark the Master (left mouse click), then
Online > Download

Downloading the
Configuration

43

12 Live List Mark the Master (left mouse click), then
Online > Live List

Live List 54

13 Start Debugger Mark the Master (left mouse click), then
Online > Start Debug Mode

Debug Mode (PROFIBUS-
DP)

55

14 Device diagnostic Mark the Slave (left mouse click), then
Online > Device Diagnostic

PROFIBUS DP Device
Diagnostic

56

15 Stop Debugger Online > Stop Debug Mode Debug Mode (PROFIBUS-
DP)

55

16 Global Diagnostic Mark the Master (left mouse click), then
Online > Global State Field

Global State Field 62

Table 3: Steps for Configuration DP Master to a DP Slave
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3.2.2 Configuration DP Slave to any DP Master
The following table describes the steps to configure a DP Slave to any DP
Master as it is typical for many cases.

# Action Menu in the Fieldbus Configurator Detail information in section Page
1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS

Configuration
15

2 Choose DP Master and
provide bus address

Insert > Master Insert Master 17

3 Choose DP Slave and
provide bus address

Insert > Slave Insert DP Slave 21

4 Assign the input and output
modules

Mark the Slave (left mouse click), then
Settings > Slave Configuration

Slave Configuration 23

5 Set device assignment, if no
assignment has occured

Mark the Master (left mouse click), then
Settings > Device Assignment

Gateway Driver 29

6 Save project File > Save Save and Save As 67

7 Download Mark the Master (left mouse click), then
Online > Download

Downloading the
Configuration

43

8 Configuration diagnostic Mark the Slave (left mouse click), then
Online > Extended Device Diagnostic
> SPC3CTRL Slave Config

SPC3CTRL Slave Config 110

9 Configuration diagnostic Mark the Slave (left mouse click), then
Online > Extended Device Diagnostic
> SPC3CTRL Slave Config

SPC3CTRL Master Config 111

Table 4: Configuration DP Slave to any DP Master
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4 Configuration of PROFIBUS with FB 1131
4.1 Setting up the PROFIBUS Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Choose the PROFIBUS. If only the
PROFIBUS fieldbus system is installed, the configuration window will open
directly.
The name of the configuration file can be allocated when the configuration
is finished or with File > Save As.

4.2 GSD Files
GSD (Electronic data sheet of a device) files contain and describe the
functions and characteristics of PROFIBUS devices. The abbreviation GSD
means 'Gerätestammdaten' (Device Base Files). All the available GSD files
together form the device database.
When the program is started, the Fieldbus Configurator automatically
retrieves all the GSD files stored in the GSD directory. The device names
are placed into an internal list. During the configuration, the device-specific
data is retrieved directly from the GSD files.
If a DP Slave device does not appear in the selection list, a corresponding
GSD file can be copied into the GSD directory with File > Copy GSD.
Another possibility is to copy the GSD file into the FB 1131 GSD directory
with the Windows Explore and then retrieve the GSD files into the GSD
directory with Settings > Path and OK.
The GSD files can be viewed with the Tools > GSD Viewer menu.

Figure 1: GSD files and bitmaps directory

•  ABB Devices: The GSD files for ABB devices are already included
and installed.

•  Other Devices: The respective device manufacturer provides the
GSD files for other devices.

The GSD files of many vendors are available on the PROFIBUS user
organisation home page.
http://www.profibus.com

Note: GSD files are only used for PROFIBUS-DP.
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The GSD directory is adjustable. In order to alter the directory from a
previous setting in another directory, use the Settings > Path menu. All
GSD files must be placed in this directory.
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4.3 Master

4.3.1 Insert Master
In order to insert a Master into the configuration, choose the Insert >
Master menu, in order to open the selection window, or click on the
symbol:
Symbol
Insert > Master

Table 5: Symbol Insert > Master

The mouse pointer automatically changes into the Insert Master pointer.
Mousepointer
insert Master

Table 6: Mousepointer insert Master

Click on the position where the Master is to be inserted. The dialog box,
from which one or more Masters can be chosen, opens.

Figure 2: Insert > Master

In this window you select the Master you want by clicking on it in the list
Available Masters and then click the Add button to put the Master to
Selected Masters. With OK you confirm the selection and the Master will
be insert.
This example shows a 07 KT 97-DPM that is inserted with the Station
address 1 and the Description Master0.
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4.3.2 Master Configuration
The Master-specific configuration is carried out in the following window.
Set the focus on the Master (left mouse click) and then select the Settings
> Master Configuration menu
or
make a double click on the symbol of the Master to be configured the
following window will open.

Figure 3: Settings > Master Configuration

The following can be set in this Master Configuration window:

•  A (symbolic) Description of the Master

•  The Station address of the Master

•  Selection of the Master as the Actual Master (for example, for
carrying out a Download)

For PROFIBUS-DP can be set

•  open the DP Master Settings window

•  activate or deactivate the automatic addressing (Auto addressing)
for this DP Master.
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4.3.3 Auto Configuration (PROFIBUS-DP)
The Auto Configuration can be used to configure a Slave. The parameter
data cannot be retrieved from a PROFIBUS-DP Slave. These, if the Slave
requires parameter data, can only be provided by the user.
The following is the procedure for Auto Configuration:

# Action Menu in the Fieldbus Configurator Detail information in
section

Page

1 Create a new project File > New > PROFIBUS Setting up the PROFIBUS
Configuration

15

2 Copy GSD file of the DP
Slave, if the Slave is not in the
selection list

File > Copy GSD GSD Files 15

3 Choose ABB DP Master and
provide bus address

Insert > Master Insert Master 17

4 Choose DP Slave and provide
bus address

Insert > Slave Insert DP Slave 21

5 Set the bus parameter Mark the Master (left Mouse click), then
Settings > Bus Parameters

Bus Parameters 31

6 Save project File > Save Save and Save As 67

7 Download Mark the Master (left Mouse click), then
Online > Download

Downloading the
Configuration

43

8 Live List Mark the Master (left Mouse click), then
Online > Live List

Live List 54

9 Start Debugger Mark the Master (left Mouse click), then
Online > Start Debug Mode

Debug Mode (PROFIBUS-
DP)

55

10 Device diagnostic Mark the Slave (left Mouse click), then
Online > Device Diagnostic

PROFIBUS DP Device
Diagnostic

56

11 Compare Configuration Compare Configuration - -

12 Automatic configuration Automatic Configuration - -
13 Stop Debugger Online > Stop Debug Mode Debug Mode (PROFIBUS-

DP)
55

14 Set device assignment, if no
assignment has occured

Mark the Master (left mouse click), then
Settings > Device Assignment

Gateway Driver 29

15 Save project File > Save Save and Save As 67

16 Download Mark the Master (left Mouse click), then
Online > Download

Downloading the
Configuration

43

17 Start Debugger Mark the Master (left Mouse click), then
Online > Start Debug Mode

Debug Mode (PROFIBUS-
DP)

55

18 Device diagnostic Mark the Slave (left Mouse click), then
Online > Device Diagnostic

PROFIBUS DP Device
Diagnostic

56

19 Stop Debugger Online > Stop Debug Mode Debug Mode (PROFIBUS-
DP)

55

Table 7: Auto Configuration (PROFIBUS-DP)
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4.3.4 Replace Master
If a Master already exists in the configuration and should be replaced
against another Master, you first have to set the focus on the Master (left
mouse click at the Master) and then choose the menu Edit > Replace
or
make a right mouse click at the Master and select Replace.
In the now opened window the question appears if the Master should be
replaced.

Figure 4: Security question replace Master

If you click the Yes button a new window opens, where you can replace the
Master against another one.

Figure 5: Edit > Replace Master

In this window you select the Master you want by clicking on it in the list
Available Masters. By clicking the Add button you put the Master in the list
Selected Masters. With OK you confirm the selection and the Master will
be replaced.
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4.4 DP Slave

4.4.1 Insert DP Slave
In order to insert a PROFIBUS-DP Slave into the configuration, choose the
Insert > Slave menu to open the selection window, or click on the symbol:
Symbol
Insert > Slave

Table 8: Symbol Insert > Slave

The mouse pointer automatically changes to the Insert Slave pointer.
Mousepointer
insert Slave

Table 9: Mousepointer insert Slave

Click on the position where the Slave is to be inserted. The dialog box, from
which one or more Slaves can be selected opens.

Figure 6: Insert > Slave

The list on the left displays for selection all the Slave devices whose GSD
files have been put in the GSD directory. A filter can be used to limit the
selection list to Slave type and Vendor (manufacturer). Further information
on a Slave is shown below the selection list (Available Slaves) when it is
selected (a mouse click). The Slave appears in the list Selected Slaves
with a double click or with the Add button.
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All devices in the right-hand list are assigned to the current Master that is
also shown in this window. If the Slaves in the right-hand list are chosen
one after the other (a mouse click), then every Slave can be allocated a
Station address as well as a name in the Description field.

For every Slave accepted into the right-hand list, the station address count
is automatically raised by one but can be overwritten by the user in the
Station address field.

Note: It is permissible to choose a Slave several times. However, each
Slave must possess its own (unique) station address in order to distinguish
it in the network.
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4.4.2 Slave Configuration
First click at the symbol of the Slave with the left mouse button and then
choose the Settings > Slave Configuration menu.

or
Open the Slave configuration window by double clicking on the PROFIBUS-
DP Slave device.
The Slave-specific configuration is carried out in this window. Here, the
modules and their addresses are allocated in the process data memory in
the Master. Note that the address must agree with that in the PC
application program.

Note 1: The information of the offset addresses refers to the addressing of
the data in the Master! The address information does not refer to the
addressing of the data in the Slave! The Slave organises its own data
addressing.

There are two types of Slaves. A simple Slave has a fixed data length. The
data length of a modular Slave is configurable. A modular Slave can be
understood as a combination of a simple Slave with a Station address.
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Figure 7: Settings > Slave Configuration

The selection list (upper list) shows all possible modules of the Slave. In the
case of a simple Slave, one module is shown and this is automatically
copied into the configuration list (lower list). In the case of a modular Slave,
the user must select the required modules and transfer these by means of
a double click or transfer it using the Append Module button into the
configuration list (lower list).
If a module consists of several sub-modules, then each sub-module is
shown in the configuration list (lower list) in a separate row. This is
displayed by the number in the Slot column. The Index column shows a
sequential number for sub-modules.
For configuration of the modules (selection of the modules) of a Slave,
proceed as follows:

•  Transfer all the required modules from the selection list (upper list)
into the configuration list (lower list). The sequence of the modules in
the configuration list (lower list) is important and must be in
agreement with the Slave. Typically, the sequence follows the actual
physical sequence. There are Slaves to which this rule does not apply
and where first analogue modules and then digital modules must be
entered, independent of their actual sequence.
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•  In the configuration list (lower list) allocate the address of each
module to the process depiction memory. The address is entered
separately in the Type and Addr columns for Inputs and Outputs.

The I/O addresses can be allocated by the user or can be automatically
assigned by FB 1131. For this purpose Auto addressing must be activated
or deactivated in the Master Configuration window.
Auto addressing activated Auto addressing deactivated

Auto addressing
(by FB 1131)

Manually addressing
(by the user)

The addresses will be allocated beginning
with 0 and incremented in accordance with
the entry sequence of the Slaves before
downloading and can be viewed and
checked in the View > Address Table.

The address 0 is shown in the I Addr or O
Addr and must be overwritten by the user.

Table 10: Auto addressing activated / deactivated

Depending on the Addressing mode, which can be set in the DP Master
Settings, the addresses are either Byte or Word addresses.
The DP Slaves utilise the Watchdog Control setting in order to detect
communication errors to the assigned DP Master. When the DP Slave finds
an interruption of an already operational communication, defined by a
Watchdog time, then the Slave carries out an independent Reset and
places the outputs into the secure condition.

Caution: When the monitoring by means of the Watchdog Control has
been deactivated, it is possible that the outputs are not reset by the Slave,
even though the communication has been interrupted.

If Activate Device in the Current Configuration is selected, the process
memory for this Slave is occupied in the Master and at the bus a data
exchange is carried out from the bus to this Slave. If this setting is switched
off, the process memory for this Slave is occupied in the Master and at the
bus no data exchange is carried out from the bus to this Slave.
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4.4.3 Inserting Predefined Device – PDD
In order to insert predefined devices, choose Insert > PDD. This function is
used for simple copying or re-using already configured devices. Before this
function can be used, a PDD Export must be carried out with the menu File
> Export > PDD Export.

Figure 8: Inserting predefined device – PDD (1)

Select the PDD file and then Open. The following window appears.

Figure 9: Inserting predefined device – PDD (2)

Select the device or devices of the Found predefined devices (left-hand
side) and pull this over to the Selected predefined devices (right-hand
side) and release the left mouse button (drag and drop). The following
picture will appear.
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Figure 10: Inserting predefined device – PDD (3)

The figure shows a device with the description PC_Slave consisting of two
modules with the description Module1 and Module2.
Choose Ok in order to insert the device into the configuration.

Subsequently the station address of the device can be altered.
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4.4.4 Replace Slave
If a Slave already exists in the configuration and should be replaced against
another Slave, you first have to set the focus on the Slave (left mouse click
at the Slave) and then choose the menu Edit > Replace
or
make a right mouse click at the Slave and select Replace.
In the now opened window the question appears if the Slave should be
replaced.

Figure 11: Security question replace Slave

If you click the Yes button a new window opens, where you can replace the
Slave against another one.

Figure 12: Edit > Replace Slave

In this window you select the Slave you want by clicking on it in the list
Available Slaves. By clicking the Add button you put the Slave in the list
Selected Slaves. With OK you confirm the selection and the Slave will be
replaced.



Fieldbus Configurator PROFIBUS Settings  ••••   29

Copyright •  ABB STOTZ-KONTAKT GmbH •

5 Settings
5.1 Gateway Driver

The Gateway Driver determines how the Fieldbus Configurator
communicates with the device. This is set in the Device Assignment via the
menu Settings > Device Assignment.

Figure 13: Settings > Device Assingment

After the selection of the Gateway channel or clicking the Connect button
FB 1131 tries to set up a connection to the selected controller. If the
connection was successful the configurable couplers are shown in the field
Device Information. The desired coupler is selected by clicking on the field
next to the name of the coupler and confirming with the OK button.
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By clicking at the Gateway Configuration button a new window appears
where the Gateway channel can be selected or a new Gateway channel
can be configured.

Figure 14: Configure Gateway

To confirm the Channel selection click at the OK button.
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5.2 Bus Parameters
The Bus Parameters are the foundations of a functioning data exchange.
This section contains information for setting the Bus Parameters as well as
the descriptions of the individual parameters.

Basic Rule: The Bus Parameters must be set the same for all devices. The
Station Address, on the other hand, must be different from device to device.

For PROFIBUS Master devices the Bus Parameters are set.
Most of the PROFIBUS-DP Slave devices

•  recognize the Baud rate automatically and adapt themselves to it.
This is especially the case when the ASIC SPC3 is used.

•  however, there are also PROFIBUS-DP Slave devices, in which the
Bus Parameters must be set by the user.

5.2.1 Setting the Bus Parameters and Profiles
The Baud rate can be set in the Settings > Bus Parameters menu.
Furthermore, the optimizing or profile can be selected.

Figure 15: Settings > Bus Parameters

The Bus Parameters can be viewed with the Settings > Bus Parameters
menu and can be edited by clicking on the Edit button. The Bus
Parameters are either editable or not editable depending on the optimizing
or profile.
The optimizing standard provides each Baud rate with default Bus
Parameters for PROFIBUS-DP systems.
By changing the settings in the Optimizing field from Standard to User
defined, all Bus Parameters become editable.
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Figure 16: Editing Bus Parameters

Caution: The changing of Bus Parameters can cause communication
interruptions.

Note: The offline Bus Parameters are displayed. The Bus Parameters are
only accepted by the device after the download of the configuration.

The Baud rate must be set to be the same for all devices on the bus. The
result of changing the Baud rate is that all other parameters must be re-
calculated. The Fieldbus Configurator tests whether the Baud rate is
supported by all configured PROFIBUS-DP Slave devices, on the basis of
entries in the GSD files. If the Fieldbus Configurator recognizes at least one
device that does not support the selected Baud rate, then an error message
will appear.
The highest station address is the highest bus address up to which a
Master searches for another Master at the bus in order to pass on the
Token. This station address must on no account be smaller than the Master
station address.
For PROFIBUS-DP, the field Access monitoring time is used for the entry
of the monitoring time of the Slave. If the time chosen for this is too short
for a low Baud rate, then it is possible that the Slaves will set their outlets to
zero. If the time chosen is too long, it is possible that if an interruption
occurs, the Slaves will take a long time to set their outlets to zero.
For PROFIBUS-DP, the Auto Clear setting is provided for global error
handling. The DP Master monitors the user data exchange (DataExchange)
to all DP Slaves by means of a timer. If no data exchange occurs to at least
one DP Slave, or an existing data exchange takes place after the expiration
of a monitoring time, and the Auto clear mode option is ON, then the
Master leaves the DataExchange and sets the outlets of all assigned DP
Slaves into a secure condition.
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5.2.2 Descriptions of the Individual Parameters
All times for the Bus parameters are given in Bit times.

The Bit time tBit is the result of the reciprocal of the Baud rate:

tBit = 1 / Baud rate (Baud rate in Bit/s)

Formula 1: Bit time tBit

The conversion from milliseconds into a Bit time is shown in the following
formula:

Bit time = Time [milliseconds] * Baud rate,

Formula 2: Conversion into Bit time tBit

The Bus parameters and their meanings:

•  Baud rate

Transfer speed: number of Bits per second.
Baudrate Bit time (tBit) Max cable length (type

A)
9,6 kBaud 104,2 us 1200 m
19,2 kBaud 52,1 us 1200 m
93,75 kBaud 10,7 us 1200 m
187,5 kBaud 5,3 us 1000 m
500 kBaud 2 us 400 m
1,5 Mbaud 666,7 ns 200 m
3 Mbaud 333,3 ns 100 m
6 Mbaud 166,7 ns 100 m
12 Mbaud 83,3 ns 100 m

Table 11: Baud rates, Bit times and cable lengths

Note: The maximum cable length is dependent on the Baud rate.

•  Minimum Station Delay of Responders (min TSDR)

This is the shortest time period that must elapse before a remote
recipient (Responder) may send an acknowledgement of a received
query telegram. The shortest time period between receipt of the last
Bit of a telegram to the sending of the first Bit of a following telegram.
Value range: 1 .. 65535

•  Maximum Station Delay of Responders (max TSDR)
This is the longest time period that must elapse before a Sender
(Requestor) may send a further query telegram. Greatest time period
between receipt of the last Bit of a telegram to the sending of the first
Bit of a following telegram.
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The Sender (Requestor, Master) must wait at least for this time period
after the sending of an unacknowledged telegram (e.g. Broadcast
only) before a new telegram is sent.
Value range: 1 .. 65535

•  Slot Time (TSL)
'Wait for receipt' – monitoring time of the Senders (Requestor) of
telegram for the acknowledgement of the recipient (Responder). After
expiration, a retry occurs in accordance with the value of 'Max.
telegram retries'.
Value range: 52 .. 65535

•  Quiet Time (TQUI)

This is the time delay that occurs for modulators (Modulator-trip time)
and Repeaters (Repeater-switch time) for the change over from
sending to receiving.
Value range: 0 .. 255

•  Setup Time (TSET)
Minimum period “reaction time” between the receipt of an
acknowledgement to the sending of a new query telegram (Reaction)
by the Sender (Requestor).
Value range: 1 .. 255

•  Target Rotation Time (TTR)
Pre-set nominal Token cycling time within the Sender authorization
(Token) will cycle around the ring. How much time the Master still has
available for sending data telegrams to the Slaves is dependent on
the difference between the nominal and the actual token cycling time.
Value range: 1 .. 16.777.215

•  GAP Update Factor (G)

Factor for determining after how many Token cycles an added
participant is accepted into the Token ring. After expiry of the time
period G*TTR, the Station searches to see whether a further
participant wishes to be accepted into the logical ring.
Value range: 1 .. 100

•  Max number of telegram retries (Max_Retry_Limit)
Maximum number of repeats in order to reach a Station.
Value range: 1 .. 8

•  Highest Station Address (HSA)

Station address of the highest active (Master) Station.
Value range: 2 .. 126
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Further, there are:

•  Ready time (TRDY)

This is the time period, after the Master has sent out a query, during
which it must be ready for the respective acknowledgement or
answer.

•  Synchronization time (TSYN)

This is the minimum time that must be available to each device as a
rest condition before it is allowed to accept the start of a query. It is
defined at 33 Bit times.

The following parameters are applicable only for PROFIBUS-DP:

•  Data Control Time (Data_Control_Time)
This parameter defines the time within the Data_Transfer_List is
updated at least once. After the expiration of this period, the Master
(class 1) reports its operating condition automatically via the
Global_Control command.
Value range: 1 .. 65535 (time basis 10ms)

•  Min Slave Interval (Min_Slave_Interval)
This parameter defines the minimum time period between two Slave
list cycles. The maximum value that the active Stations require is
always given.
Value range: 1 .. 65535 (time basis 100us)

•  Access Monitoring (TWD)
Access monitoring TWD at the Slave ensures that when an interruption
of the DP Master occurs, the outlets are placed in a secure condition
after this time period.

•  Poll Timeout (Poll_Timeout)
This parameter defines the maximum time period in a Master-Master
relationship within which the answer must be fetched by the
Requestor.
Value range: 1 .. 65535 (time basis 1ms)

•  TID1 and TID2

This is the time that the Sender spends at idle after the receipt of the
last Bit of a telegram on the Bus, until the first Bit of a new telegram is
sent on the Bus.
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Depending on the type of the telegram:
TID1 starts after the Initiator has received an acknowledgement,
answer or a Token telegram.

TID1 = max (TQUI + 2 * TSET + 2 + TSYN, min TSDR).   (*)

Formula 3: TID1

TID2 starts after the Initiator has sent a telegram that is not
acknowledged.

TID2 = max (TQUI + 2 * TSET + 2 + TSYN, max TSDR).   (*)

Formula 4: TID2

These times cannot be set directly, they result from the given
calculations.
(*) Depending on the ASIC and Baud rate utilized, the TID1 and TID2
can take on somewhat different values due to the ASIC software.

5.2.3 Rules

For min TSDR, max TSDR and TSL the following rule applies:
0 < min TSDR < max TSDR < TSL

Formula 5: Min TSDR, Max TSDR and TSL

For TQUI, TRDY  and min TSDR the following rule applies:

TQUI < TRDY < min TSDR.

Formula 6: TQUI, TRDY and min TSDR

For access monitoring (TWD) and Target Rotation Time (TTR):

TWD > TTR

Formula 7: TWD and TTR

For the Data_Control_Time the following rule applies:
Data_Control_Time > 6 * TWD

Formula 8: Data_Control_Time
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5.3 DP Master

5.3.1 Master Configuration
The Master configuration is described further above in section Master
Configuration on page 18.

5.3.2 Group Membership
After the Master has been assigned, the Slaves can be assigned to up to
eight different groups. These groups can then be assigned here. Choose
the Settings > Group membership menu. Choose the group that is to
support the DP-Freeze and DP-Sync commands.

Figure 17: Settings > Group Membership (1)

In the Group Membership the Slaves can be assigned to the groups with
the desired characteristics. The table shows all configured Slave devices
from the main editor window. Here it can be selected to which eight
possible groups the Slave is assigned. The selected group membership is
transferred to the Slaves during their start-up sequence. The group
membership acts as a filter for the Sync and Freeze global commands.
These are output as Broadcast telegrams in order to synchronize the input
and output data of several Slaves. Only those Slaves in whose group these
commands have been released react on it.

Figure 18: Settings > Group Membership (2)



38  ••••   Settings Fieldbus Configurator PROFIBUS

Copyright •  ABB STOTZ-KONTAKT GmbH •

5.4 DP Slave

5.4.1 DP Slave Configuration
The Slave Configuration is described further above in section Slave
Configuration on page 23.
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5.4.2 Parameter Data
The Parameter Data can be edited in the Settings > Parameter Data
menu.
If default parameters are configured in the GSD file of the Slave, then these
are automatically inserted when the menu is called up for the first time.
Some of the DP Slave devices require further Parameter data, for instance
in order to change a measuring limit or a value range. This type of data  is
Slave specific and their functionality cannot be described here.
The meaning of the parameters are determined by the device
manufacturer. The explanations can be taken from the manufacturer’s
manual.
The window below gives an example of parameter data of a Slave.

Figure 19: Parameter Data (Hexadecimal depiction)

A modular PROFIBUS-DP Slave station could require parameter data for
one or more modules and for the Slave station itself (main station). There
are three possibilities:

•  Parameter data. These are all the parameters of a Slave station

•  Common. Parameter Data of the main station

•  Modul. Parameter Data form on of the modules
After the choice of the text button, the following window with the text
parameter data appears. These parameters are for the main station.
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Example for parameter data:

Figure 20: Parameter Data (Text depiction)

It is possible to return to the hex depiction by pressing the Hex button.
It is possible to edit the value by means of a double click on a row of
parameter data.

Figure 21: Parameter Data (individual depiction)

or to change the description via the text setting.

Figure 22: Parameter Data

When several modules in the Slave configuration have been selected, then
it is also possible to change the module parameters by means of a double
click on its associated line.
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5.5 Project Information
If the user creates his own project, the project information can be typed in
into the Settings > Project Information menu. Anybody can then read this
entry when this menu is called up.

Figure 23: Settings > Project Information

5.6 Path
When the Settings > Path menu is selected, the search path for GSD files
is displayed.

Figure 24: Settings > Path

If you click the OK button all GSD files are read in.
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5.7 Language
Choose the Settings > Language menu and the following window opens:

Figure 25: Settings > Language

Here can be set the language of the Fieldbus Configurator. Select the
desired language and confirm with the OK button.

A message appears that the Fieldbus Configurator must be started again in
order to activate the selected language. Please carry this out.
After restarting the Fieldbus Configurator, the language will have changed
to the one selected.

Note: Up to now not all languages are available for all fieldbuses!
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6 Online Functions
6.1 Introduction

In this section, all the functions that directly influence PROFIBUS devices,
are presented.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched On or Off.

6.2 Online to the Coupler

6.2.1 Downloading the Configuration
First, the desired device must be chosen for downloading by a left mouse
click on the symbol of the device.
In order to release the configuration and network access, a transfer
(Download) to the devices must be carried out on the Online > Download
menu. A warning will appear that the communication on the PROFIBUS will
be interrupted. This warning must be confirmed.

Figure 26: Security question before Download

Attention: The download overwrites the configuration in the device and the
connection with the connected devices is interrupted.

Figure 27: Online > Download
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Before the Download is executed, the configuration is checked by the
Configurator. The most common cause of error is overlapping of addresses
in the process data image. This can be checked by calling up the address
table with the View > Address Table menu point.

If the issue of addresses in the process data image should be carried out
automatically, then the Auto Addressing button in the Master
Configuration window must be activated.

The configuration is transferred into the selected device and stored there in
FLASH memory in a zero voltage manner so that the configuration is
available when the voltage supply is switched off and on again.

6.2.2 Firmware Download
If a Firmware download is to be carried out, proceed as follows: first choose
the desired device for Firmware downloading. Then, call up the Online >
Firmware Download menu. Select the new Firmware and retrieve it with
Download into the device. The Firmware is now retrieved.

Figure 28: Online > Firmware Download
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6.2.3 Firmware / Reset
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then the Online > Firmware / Reset menu must be
called up and the name and the version of the Firmware are displayed.

Figure 29: Online > Firmware / Reset

The device can be resetted with the Reset button.

6.2.4 Device Info
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Device Info menu in order
to obtain further information on the selected device.
The manufacturer date, the device number and the serial number of the
device is retrieved and shown.

Figure 30: Online > Device Info
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6.3 Automatic Network Scan
This function scans the network structure. During the scan it will be
detected which devices are connected to this PROFIBUS network and how
these devices are configured. Therefore the following steps are necessary:

•  Create a new project: Select the menu File > New and PROFIBUS.

•  Select the Master: Select the Master from the menu Insert > Master.
•  Set the Baudrate: Select the menu Settings > Bus parameter and

set the Baudrate.

•  Load these settings to the Master: Select the menu Online >
Download to download these settings into the Master device.

•  Save: Select File > Save to save the settings.

•  Scan the network: Select the menu Online > Automatic Network
Scan.

Note: This function detects the connected devices on the PROFIBUS
network and can read out how these devices are configured. This function
can not read out the parameters, because this is not possible from the
PROFIBUS principle. Parameter data have always to be set by the user to
the Master device and the Master devices transfer the parameter data to
the Slave device.

Figure 31: Online > Automatic Network Scan (security question)

Answer this question with Yes, if the connected PROFIBUS network should
be scanned. Answer this question with No, if this functions should not be
performed.
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Figure 32: Online > Automatic Network Scan (During the Scan)

All buttons are grey during the network scan.
The Fieldbus Configurator detects in the first step which devices are
connected to the PROFIBUS network. The Fieldbus Configurator then
reads the identcode from each Slave. The configuration data (identifier
bytes) is read out from each Slave and these configuration data is searched
in the corresponding GSD file (if GSD file is available) and the module is
displayed in the column Real Cfg. Dat (Modules).

Figure 33: Online > Automatic Network Scan (After the Scan)

Note: Some Slave devices only allows to read out the default configuration.
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In the window Actual Network Constellation the texts in the columns
Found Slave and Real Configuration Data can be displayed in the
following colours.

Colour Found Slave Real Configuration Data

0 orange For this device no suitable GSD file was
found

No suitable modul was found in
the GSD file

1 black For this device exactly one suitable GSD
file was found

Exactly one modul was found in
the GSD file

≥2 blue For this device more than one suitable
GSD file was found

More than one modul was
found in the GSD file

Table 12: Network scan - Description of the displayed window

If a device is coloured red in the Actual Network Constellation an error
has occurred. For example a Slave with the Station Address 126 was
detected. In this case the Ident number can not be read out. Further
information you find in section Slave with Station Address 126 on page 51.
When you exit the window Actual Network Constellation the Fieldbus
Configurator asks if this constellation should be taken into the configuration
or not.

Figure 34: Online > Automatic Network Scan > Accept Configuration

Example:
This example shows a scanned Network Constellation with more than one
suitable modules for the GSD file. The modules (Real Cfg. Data) are
coloured blue, which means, that you can assign or change an assignment
of the modules by clicking the Assign Module button.

Figure 35: Online > Automatic Network Scan - Example for Assignment
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6.3.1 Assign Slave
The identnumber is read out from the Slave device during the network
scan. If more than one GSD file is available with this identnumber in the
window Assign Slave, a list is displayed and the user can select the
correct Slave device from this list.

Figure 36: Online > Automatic Network Scan > Assign Slave

In the list Selected Slaves the device which was found during the
Automatic Network Scan is selected. By clicking the Remove button the
device is removed and another device can be insert in the Actual Network
Constellation.
For this select a device by clicking on it. Click the Add button to put it into
the right list. By pressing the OK button the device is assigned to the Actual
Network Constellation.

Figure 37: Change of the GSD against a GSE file

This picture shows a change of the WAGOB754.GSD against the
WACOB754.GSE.
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6.3.2 Assign Module
It can be that more than one similar Configuration Data for a device was
found during the network scan. By clicking the button Assign Module in
the Network Scan window you get a selection of suitable modules for the
assigned EDS file which you can assign here.

Figure 38: Online > Automatic Network Scan > Assign Module

In the list Available modules the modul which was found during the
Automatic Network Scan is selected. By clicking the Remove button the
modul is removed and another modul can be insert in the Actual Network
Constellation.
Select a modul by clicking on it and press the button Add to put it into the
right list. The module is assigned by clicking the OK button.

Note: The available modules all have the identifier byte 0x00.
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6.3.3 Slave with Station Address 126 - Determination of the Ident
Number

The identnumber from Slave devices with station address 126 can not be
read out via the PROFIBUS. Therefore

•  select the GSD file from the list of Slave devices or

•  enter the ident number manually.

6.3.3.1 Select GSD File

Figure 39: Online > Automatic Network Scan > Set Slave Address

A window opens where a Slave device can be selected. There you have to
select one.
Then a station address between 0 and 125 is assigned with Set Slave
Address and then you have to scan the network again.

6.3.3.2 Ident Number

If you enter the ident number manually the following window appears. The
ident number has to be entered in hexadecimal format.

Figure 40: Online > Automatic Network Scan > Enter Ident Number

Then a station address between 0 and 125 is assigned with Set Slave
Address and then you have to scan the network again.
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6.4 Start/Stop Communication
The communication between PROFIBUS-DP Master and PROFIBUS-DP
Slave can be manually started or stopped.
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Communication start or
Online > Communication stop menu.
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6.5 Diagnostic Functions
The following table shows diagnostic functions and the usability for

•  ABB PROFIBUS-DP Master devices

•  ABB PROFIBUS-DP Slave devices.

Diagnostic function Usage Usable with
PROFIBUS-DP Master
devices

Usable with
PROFIBUS-DP Slave
devices

Debug Mode (PROFIBUS-DP) Detect, to which PROFIBUS-
DP Slave devices the DP
Master device has
communication

Yes No, only at DP Master
devices

Global State Field Status information from the
PROFIBUS DP Master

Yes No, only at DP Master
devices

Extended Device Diagnostic Statistic information and
status information from the
PROFIBUS device

Yes Yes

Table 13: Overview Diagnostic Functions
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6.5.1 Live List
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Live List menu to get an
overview over all active devices at the PROFIBUS network.

Figure 41: Online > Live List

A green number shows a Master and a blue number a Slave, whereby the
number indicates the Station address. The meaning of the other colours is
given in the list above the table.
A click on a coloured number brings up its device type and status of the
station.

Figure 42: Device type and device status of a Master and a Slave

The display is not automatically updated as this function loads the
PROFIBUS network. However, the Live List can be renewed with the
Update button.
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6.5.2 Debug Mode (PROFIBUS-DP)
First the Master device must be chosen with a left mouse click on the
symbol of the Master device. Then select the Online > Start Debug Mode
menu. The Fieldbus Configurator cyclically interrogates the status of the
network communication and the individual condition of the devices.
To end the Debug Mode select the menu Online > Stop Debug Mode.

6.5.2.1 Debug Window

When the debug session is started the configuration window changes into
the debug window. The devices and the line between them are displayed in
green or red colour depending on the established network communication.

Figure 43: The Debug Window

If a diagnostic information is available for a specific device, the text Diag
appears in red next to the device icon. To get further device specific
diagnostic information then doubleclick on the device itself or set the focus
to the device and select Online > Device Diagnostic.
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6.5.2.2 PROFIBUS DP Device Diagnostic

To activate the Debug Mode select the menu Online > Start Debug Mode.
Then mark a Slave (left mouse click) and then the menu Online > Device
Diagnostic to open the diagnostic window for this Slave. Alternatively
make a double click at the symbol of the device to open this window. To
end the Debug Mode select the menu Online > Stop Debug Mode.
After the debugger was started FB 1131 requests the state of all devices
from the Master. If there is an error on a device, the bus line to this Slave is
displayed in red colour, otherwise it is green. FB 1131 also displays the
letters Diag, if the device signals a diagnostic information or the master
holds a diagnostic information in its internal diagnostic buffer. This
information is displayed closer if you click with the mouse onto the
corresponding device in Debug Mode.
The diagnostic information of a DP Slave can be 6 to 100 (max. 244) bytes.
The first 6 bytes are standard diagnostic information (specification). The
meaning of these 6 bytes is according to the PROFIBUS specification and
contains the Station Status 1, 2 , 3, the assigned master address and
the ident number of the Slave.

Figure 44: Online > Device Diagnostic

Station Status 1, 2 and 3 is described on the next page.
At Assigned Master Address the address of the master is shown, that has
parameterised and configured this Slave. If the value 255 is displayed, it
means that the Slave reports that

•  it is not parameterised or configured yet or

•  that the received parameter information and configuration information
are rejected because of an error.
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At Real Ident Number the ident number from the DP Slave is displayed. At
GSD Ident Number the ident number is displayed, that the Fieldbus
Configurator has read out in the used GSD file. Both ident numbers have to
agree. When they are different the reason could be

•  the wrong GSD file is used or

•  a wrong DP Slave was connected to the PROFIBUS.
When the Real Ident Number shows 0000, then the master still has no
connection via the PROFIBUS to the DP Slave.

The meaning of Station Status 1:
Station-
Status 1

Set by Meaning and Remedy

Master Lock
(Bit 7)

Master Meaning: The Slave has already been parameterised by another Master and is locked in
its access.
Remedy: This is security mechanism of PROFIBUS-DP. First clarify which master should
have access to this Slave. Then add this Slave to the configuration of the master that
should have access to this Slave and remove this Slave from the configuration of the other
master.

Parameter
Fault
(Bit 6)

Slave Meaning: This bit is set by the Slave automatically, when the parameters sent by the
Master are containing wrong or insufficient data. On every received parameter telegram
the Slave executes a check routine on the whole parameter telegram. If the Slave detects
a faulty parameter value or illegal data during its check, it will report the parameter fault.
During the check routine the Slave compares its identnumber with the one sent by Master.
Remedy: So if the Slave reports this error, first compare the Real Ident Number shown in
the Slave diagnostic field in debugger mode with the one shown at GSD Ident Number. If
this two Ident numbers are the same, check the parameter data. If they are different, either
a wrong GSD file is used or a wrong device was connected to the bus.

Invalid Slave
Response
(Bit 5)

Master Meaning: This bit is set by the Master, when the Master receives an invalid answer from
the Slave. So the physical contact to the Slave works principally, but the logical answer
was not understood.
Remedy: An error at the physical transmission line could have appeared like twisted
cable, missing bus termination or missing shield connection.
Use standardized DP Slave.
This also can happen, for example if a PROFIBUS-FMS Slave is connected to the DP-
Master instead of a DP Slave. So the Slave do not understand the DP-Telegram and
rejects it. It's handled as 'Invalid Slave Response'.

Function not
supported
(Bit 4)

Slave Meaning: This bit is set by the Slave, when a function should be performed which is not
supported. Newer releases of Slave stations normally support the Sync and Freeze-Mode
for I/O data. This is fixed in the GSD-File and read out by FB 1131 and sent to the Slave in
the parameter telegram.
Remedy: If this error occurs the GSD-File declares at least one of these commands as
supported, but the Slave does not. In this case contact the manufacturer of the Slave
device for the right GSD-File for the used Slave.

Table 14: PROFIBUS-DP Diagnostic Station state 1 (Bit 7 to 4)
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Station-
Status 1

Set by Meaning and Remedy

Extended Diag
(Bit 3)

Slave Meaning: This bit is set by the Slave, if extended diagnostic data are a read out. Extended
diagnostic data is optionally and normally used by a Slave to hand out manufacturer
specific diagnostic information.
Remedy: Click on the button Extended Diagnostic to get a Hex-dump of the diagnostic
data and read about their meaning in the manual of the manufacturer. If the GSD-File
contains information about the Extended Device Diagnostic it can be analysed with the
Fieldbus Configurator.

Configuration
Fault
(Bit 2)

Slave Meaning: During the PROFIBUS-DP startup procedure the Slave compares its internal I/O
configuration with the configuration of the Master. If the Slave detects differences it will
report a configuration error. That means that the Master has another I/O module
constellation as the Slave.
Remedy: So first compare visually all configured I/O modules in the configuration data of
FB 1131 for this Slave with its real physical constellation. Note that the order of the module
has to agree. Some Slaves need virtual I/O modules to be configured first or empty slot
modules to get an even number of modules to run. This Slave specific I/O module
behaviour has to be written down in the Slave documentation because it can not be read
out from the GSD file. Please read the configuration notes of the manufacturer.
Another possibility to get the Slave module constellation is to read out its constellation by a
PROFIBUS-DP command Compare Configuration. So click on this button in the
diagnostic field and you will get a Hex-Dump of the real Slave configuration data and the
configured one (Real Configuration and FB 1131 Configuration). Note, that the DP
configuration is coded in a very compact form. The code for the modules is shown in the
Slave Configuration.

Station Not
Ready
(Bit 1)

Slave Meaning: The DP Slave is still not ready for the data exchange.
Remedy: When or at which event the Slave sets this bit is not defined in the specification.
That means it can have several Slave specific reasons. Usually the bit is set in
combination with one the other fault bits.
Check especially the parameter and the configuration. Often the report 'Station not Ready'
results in case of parameter fault or configuration faults.
It is possible that the supply voltage at the Slave was just first switched on. Wait until the
device is initialized.

Station not
existent
(Bit 0)

Master Meaning: This bit is set by the Master automatically, if this Slave does not answer or is not
reachable on the bus.
Remedy: Please check your PROFIBUS cable. Both signal wires need to be connected
correctly between all devices. In addition the connectors at the end of the cable need to be
provided with termination resistors.
Check that the device is connected to the bus cable.
Check the power supply at the Slave device.
Compare the station address at the Slave with the configuration of the Master. With the
menu Online > Live List you can check which Slaves are available respectively
connected to the PROFIBUS.
Check, if the Slave supports the configured baud rate. Some Slaves only work with up to
1.5 Mbaud or need to be set for a PROFIBUS-DP conform behaviour.
Check the connectors intermediated LWL (optical) converters and repeaters.

Table 15: PROFIBUS-DP Diagnostic Station state 1 (Bit 3 to 0)
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The meaning of Station State 2:
Station-
Status 2

Set by
DP

Meaning

Slave
Deactivated
(Bit 7)

Master This bit is set by the Master, if the Slave in its parameter set is marked as inactive, so that
it is taken out from the cyclic I/O exchange.

Reserved
(Bit 6)

- -

Sync Mode
(Bit 5)

Slave This bit is set by the Slave, when it has received the sync control command.

Freeze Mode
(Bit 4)

Slave This bit is set by the Slave, when is has received the freeze control command.

Watchdog ON
(Bit 3)

Slave This bit is set by the DP-Slave, when its Watchdog control is active to supervise its
corresponding Master connection.

Slave Device
(Bit 2)

Slave This bit is always set by the Slave.

Static Diag
(Bit 1)

Slave The Slave sets this bit to indicate the Master to be not operative because of a general
error. Typically the DP Slave is not ready for an I/O data transfer. In a case of a set static
diagnostic bit the Master has to collect diagnostic information as long as this bit is active.
On which events or at what time this bit can be set by a Slave device, is not defined in the
norm description and can not be mentioned here.

Parameter Req
used
(Bit 0)

Slave The Slave sets this bit to force the Master system to do a new parameterisation. This bit is
set as long as new parameterization must be performed. In case of this error you should
compare firstly the real ident number with the GSD ident number in this window. This
numbers need to be the same. Furthermore you have to check the parameter data.

Table 16: PROFIBUS-DP Diagnostic Station state 2

The meaning of Station State 3:
Station-
Status 3

Set by Meaning

Ext Diag
Overflow
(Bit 7)

Master
Slave

This bit is set, if there is more extended diagnostic information to report to the Master than
can be given to the Master in one diagnostic telegram. The DP-Slave sets this bit for
example if there is more diagnostic channel information than the Slave can hold down in
its diagnostic buffer.

Reserved
(Bit 6 to 0)

- -

Table 17: PROFIBUS-DP Diagnostic Stations status 3
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6.5.2.3 Compare Configuration

The configuration can be read out from the DP Slave via the PROFIBUS in
the debug mode. This information is displayed in the upper part of the
window Compare Configuration.
In the lower part of the window the configuration is displayed and compared
as set in the Fieldbus Configurator.

Figure 45: Online > Device Diagnostic > Compare Configuration

Note: Some DP Slaves only gives their default configuration when reading
it out via the PROFIBUS. To use this function the DP Slave has to support
it.

The meaning of the identifier bytes is described in chapter Identifier Bytes
on page 118.
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6.5.2.4 Extended DP Slave Diagnostic

Figure 46: Device Diagnostic (PROFIBUS-DP extended diagnostic)

In the Extended Device Diagnostic window, a diagnostic telegram is
shown as a Hexdump. Here, the first 6 Bytes are the standard diagnostic
Bytes like described in section PROFIBUS DP Device Diagnostic at page
56.
The Extended Device Diagnostic starts at the 7th Byte. This is manufacturer
specific and can contain

•  station related diagnostic

•  modul related diagnostic

•  channel related diagnostic.

In the middle region of the window you can see details and in the top region
the diagnostic report in clear text to this extent as these are given in the
GSD file.

Note: To evaluate the extended (manufacturer specific) diagnostic read the
device description of the manufacturer.
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6.5.3 Global State Field
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Global State Field menu. A
display window opens in which the cyclic states on the Bus condition and
the connected devices are shown.

Figure 47: Online > Global State Field

The first row displays the main state of the Master. It can have the status
OPERATE, STOP, OFFLINE or AUTO CLEAR.
The next row displays individual bus errors. A pending error is displayed in
a red field. The meanings of the individual abbreviations are shown in the
following.
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Status Bits Meaning

TOUT TIMEOUT-ERROR the device has detected a skipped timeout supervision
time because of rejected PROFIBUS telegrams. It's an indication for bus
short circuits while the Master interrupts the communication. The number of
detected timeouts are fixed in the statistic bus information variable. The bit
will be set when the first timeout was detected and will not be deleted any
more.

NRDY HOST-NOT-READY-NOTIFICATION shows, if the application is ready or
not. If this bit is set, the application is not ready to receive data.

EVE EVENT-ERROR the device has detected bus short circuits. The number of
detected events are fixed in the statistic bus information variable. The bit will
be set when the first event was detected and will not be deleted any more.

FAT FATAL-ERROR because of heavy bus error, no further bus communication
is possible.

NEXC NON-EXCHANGE-ERROR at least one Slave has not reached the data
exchange state and no process data exchange is done.

ACLR AUTO-CLEAR-ERROR device stopped the communication to all Slaves and
reached the auto-clear end state.

CTRL CONTROL-ERROR parameterization error.

Table 18: Meaning of collecting status bits in the Global State Field

Further displays are:
Collective online error location and corresponding error gives the
station address and the error text.
Statistic bus information displays the number of the detected bus short
circuits and the number of rejected telegrams.
Device specific status bits:
Parameterized Devices, Activated Devices and Devices with
Diagnostic are shown if you click at that button. The activated addresses
are coloured numbers.
This application updates online the status in the global state field.
You can see the diagnostic by double-clicking at a highlighted station
address of a device.
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6.5.4 Extended Device Diagnostic
The Extended Device Diagnostic helps to find bus and configuration errors
when the FB 1131 menu functions are of no further help.
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Extended Device
Diagnostic menu.
This menu opens a list of diagnostic structures. These contain online
counters, states and parameter information:

Figure 48: Extended Device Diagnostic as and example for the PROFIBUS-DP Master

6.5.4.1 PROFIBUS-DP Master

USR_INTF (User-Interface): DP administration
No Task / Task state Page

1 PLC_TASK Common Variables 91
2 USR_INTF Task State 92

3 USR_INTF Running States 93

4 USR_INTF 93

5 USR_INTF Communication Error 94
6 USR_INTF Parameter Set List 95

7 USR_INTF Last Download Param 96

8 USR_INTF Disconnect Report 97

9 USR_INTF Diagnostic Report 98

10 USR_INTF DPV1 Data 99

11 FDL_TASK Task State 100
12 FDL_TASK Act. Bus parameter 101

13 FDL_TASK DDLM Requests Class 1 102

14 FDL_TASK DDLM Requests Class 2 103

15 FDL_TASK FDL Requests 104

16 FDL_TASK FMA Requests 105

17 FDL_TASK DP Retry for Slave 106
18 FDL_TASK DP Activated Slave 107

Table 19: PROFIBUS-DP Master Task State
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6.5.4.2 PROFIBUS-DP Slave

PLC_TASK
SPC3CTRL (SPC3 Control)

No Task / Task state Page DPS

1 PLC_TASK Variables 108 X
2 SPC3CTRL SPC3 109 X
3 SPC3CTRL Slave Config 110 X
4 SPC3CTRL Master Config 111 X
5 SPC3CTRL Param Data 112 X
6 SPC3CTRL DPM 113 X
7 SPC3CTRL DPV1 Class 1 114 X
8 SPC3CTRL DPV1 Class 2 116 X
9 SPC3CTRL Code Diagnostic 117 X

Table 20: PROFIBUS-DP Slave Task State
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6.6 PROFIBUS Services

6.6.1 Setting the Slave Address
First the desired Slave device must be chosen with a left mouse click on
the symbol of the Slave. Then set the Station address of a Slave at the
PROFIBUS with the Online > Set Slave Address menu.
Enter the new address into the New station address field. If you do not
want to allow further alterations to the Station address, mark the No
additional changing  field. If required, enter further parameters in
hexadecimal format into Remote Slave parameter field. Activate the
command with the Set Address button.

Figure 49: Online > Set Slave Address

Note: The setting of the Station address is only possible for Slaves that
support this service.
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7 File, Print, Edit and View
7.1 File

7.1.1 Open
An existing project can be opened with File > open.

7.1.2 Save and Save As
When the file name is known, the configuration can be saved under the File
> Save menu, otherwise the File > Save As menu must be selected.

7.1.3 Close
The current project can be closed with File > Close.
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7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.

Figure 50: File > Print

The base setting prints information on one sheet  only for one device.
Topology prints the topology of the bus system.
Bus parameters prints the bus parameters of the bus system.
Address table prints the address table of the Master.
Device table prints the device table.
The scope can be given with the Device Selection menu point. The
following can be chosen:

•  All

•  From Station address to Station address

•  Selection of a device by means of its description
If no option is selected and the OK button is pressed nothing will be printed
out. It is like clicking the Cancel button.
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7.3 Edit

7.3.1 Cut, Copy and Paste (Master)
With the menus Edit > Cut and Edit > Copy you put the cut/copied Master
with its settings and configuration (only not the description of the Master) in
the Clipboard and with Edit > Paste it can be insert.
The difference between Cut and Copy is:
With the menu option Edit > Cut you move a Master from one point in the
configuration to another. With the menu option Edit > Copy you duplicate
an existing Master.
If you select Edit > Cut a security question appears.

Figure 51: Security question cut device (Master)

If you answer this question with Yes the Master is cut and stays in the
clipboard.
With the menu Edit > Insert and clicking at the position where the Master
should be insert, a window opens where the cut/copied Master can be
selected.

Figure 52: Insert a cut/copied Master

When you click on the OK button the Master will be insert in the
configuration.
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7.3.2 Cut, Copy and Paste (Slave)
With the menus Edit > Cut and Edit > Copy you put the cut/copied device
with its settings and configuration (only not the description of the device) in
the Clipboard and with Edit > Paste it can be insert.
The difference between Cut and Copy is:
With the menu option Edit > Cut you move a device from one point in the
configuration to another. With the menu option Edit > Copy you duplicate
an existing device.
If you select Edit > Cut a security question appears.

Figure 53: Security question cut device (Slave)

If you answer this question with Yes the device is cut and stays in the
clipboard.
With the menu Edit > Insert and clicking at the position where the device
should be insert, a window opens where the cut/copied device can be
selected.

Figure 54: Insert a cut/copied device

When you click on the OK button the device will be insert in the
configuration.
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7.3.3 Delete
To delete a Master or Slave device you first have to mark this device and
then select the menu Edit > Delete. Before FB 1131 deletes the Master or
Slave a security question appears.

Figure 55: Security question delete device

Note: When you delete a device the settings and the configuration of this
device get lost.

7.3.4 Replace
With the menu Edit > Replace a Master or Slave device can be replaced.
How to replace the Master look in section Replace Master at page 20. If
you want to replace a Slave device look in section Replace Slave at page
28.
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7.4 View of the Configuration
The configuration can be displayed in a table. The following tables are
available:

•  Device Table

•  Address Table (Occupation of the process image memory in the
PROFIBUS-DP Master )

7.4.1 Device Table
The View > Device Table menu shows the list of all devices that have
been inserted.

Figure 56: View > Device Table
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7.4.2 Address Table
A list of all addresses used in the process depiction is displayed in the View
> Address Table menu. For this purpose the current Master must be
chosen for which the table is displayed.
Addresses refer to the Master.

Figure 57: View > Address Table

It is possible to sort the addresses according to Station addresses or data
addresses.
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7.4.2.1 Address Overview

Starting from View > Address Table and then Address Overview opens
the window with the overview over the used addresses in the input process
image and the output process image.

Figure 58: View > Address Table > Address Overview

Note: To change the offset addresses here the auto addressing mode has
to be disabled.

The assignments can be changed here by making the auto addressing
disabled. In order to change the assignment, click with the left mouse
button on a cross and keep the mouse button pressed. The mouse button
changes to an arrow. Pull the arrow (with depressed mouse button) to the
desired (unoccupied) position and release the mouse button. A
confirmation query will appear, whether the change is carried out or not.
The assignment of the Offset address can also be carried out via the Slave
configuration menu.
The above example shows the moving of a two- Byte modules.
Overlapping addresses are shown with a red cross. This means that this
address is used by more than one module.
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7.4.2.2 Byteinformation Window

The information which Slave occupies a particular address can be seen by
a double click on the corresponding cross. The Byte information window
opens.
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8 Tools
8.1 GSD Viewer

The menu Tools > GSD Viewer opens a GSD file to view it.

Figure 59: Tools > GSD Viewer

With More the information e.g. max. Number of modules, max. Number of
I/O data, max. length of input data and max. length of output data is
displayed.
With Layout the icons for the Slave are displayed for

•  Configuration phase

•  Run phase

•  Diagnostic phase.
With Identifier the modules of the device and its identifier bytes are
displayed.
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9 Error Numbers
9.1 Possible Control Error Messages to FB1131 Telegrams

Error Number Description
401 Driver error in the control
402 slot number is not supported by the hardware
403 no coupler at the given slot
404 control not in STOP
405 configuration data invalid
406 coupler still configured by 907 AC 1131-internal PROFIBUS Configurator
407 answer timeout of the coupler

Table 21: Possible Control Error Messages to FB1131 Telegrams
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9.2 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of ABB devices. The
error number is returned in an answer message. Command messages and
answer messages are used to communicate between the application (e.g.
the Fieldbus Configurator) and the ABB device. An example of this
communication is the download of a configuration.
Error Number Description
4 Task does not exist
5 Task is not initialised
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existed
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong licence. The OEM licence of the Fieldbus Configurator

allows only communication to devices that have the same licence inside
38 The data base created by the Fieldbus Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 22: RCS error numbers (answer message) (4..39)
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Error Number Description
40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 Licence code invalid
92 Licence code does already exist
93 All memory locations for licence codes already in use

Table 23: RCS error numbers (answer message) (40..93)
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9.3 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description
100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WriteDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 24: Database Access Error Numbers (100..130)
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9.4 Online Data Manager Error Numbers

9.4.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description
1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviceObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 25: Online Data Manager Error numbers (1000..1018)
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9.4.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description
2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout

No message received.
Possible Error Cause: Different reasons.
(1) The selected interrupt is not free or used also from another PC
component (shared interrupt).
(2) CIF is not initialised. This is shown by a acyclic flashing RUN LED.
(3) CIF is in bootstraploader mode. This is indicated by a flashing RDY
LED.
(4) Another application program is accessing to the CIF the same time
as FB 1131.
Remedy:
(1A) Use polling mode instead of interrupt mode. Shared interrupts are
not supported from the CIF device driver under Windows 95/98/ME/NT.
(1B) Use a free interrupt.
(2) Download the configuration. If necessary create a new configuration.
(3) First download the firmware and then download the configuration.
(4) Close all other application programs that communicates to the CIF.

2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 26: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)
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9.4.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description
2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 27: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

9.4.4 Online Data Manager Subfunctions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Subfunctions of the Online
Data Manager.
Error Number Description
8001 Driver not opened. E.g. CIF Device Driver
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 28: Subfunction Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)
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9.5 Data Base Functions Error Numbers (4000 .. 4098)
The following table lists the error numbers of the converting functions.
Error Number Description
4000 File does not exist
4001 Success in comprimizing
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 29: Error numbers of converting functions (4000..4029)
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Error Number Description
4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialisation
4040 Printer not ready
4041 The data base is used from another function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEntries
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 30: Error numbers of converting functions (4030..4060)
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Error Number Description
4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initialization of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 31: Error numbers of converting functions (4061..4075)
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Error Number Description
4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialisation not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exist
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 32: Error numbers of converting functions (4082..4199)
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9.6 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description
5000 Function PackLongToByteShort: Not enough space in pvD (Number of

elements greater than reserved memory)
5001 Function PackLongToByteShort: Not enough space in pvD. Detected

during converting of pvS
5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringBumpToByteArray: A character was found, which is

not convertable into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 33: Error Numbers of data base functions (5000 .. 5012)
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10 Appendix
10.1 Extended Device Diagnostic Master

On the following pages the task state structure of PROFIBUS-DP Master is
described.

10.1.1 PLC_TASK Common Variables

Figure 60: PLC_TASK Common Variables

Variable Meaning

Version Compiled Hardware
Task State Task State
Handshake Counter Counter for the performed process data handshakes
Handshake Mode This value represents the actual handshake mode

between application and CIF.
0 = Bus synchronous, Device Controlled
1 = Buffered, Device Controlled
2 = Uncontrolled
3 = Buffered, Host Controlled
4 = Bus synchronous, Host Controlled

Table 34: PLC_TASK Common Variables



92  ••••   Appendix Fieldbus Configurator PROFIBUS

Copyright •  ABB STOTZ-KONTAKT GmbH •

10.1.2 USR_INTF Task State

Figure 61: USR_INTF Task State

Variable Meaning

Scheduler State Status value of the Scheduler
Announced Modules Number of configured Slaves
Wrong Parameters Number of Slaves with faulty data sets
Activated Modules Number of activated Slaves
Activated Bus Parameters 0 = Bus Parameter active, 255 = Bus Parameter

inactive
Active Data Exchange Current active Data_Exchange-Service
Inactive Data Exchange Number of Stations with that no process data possible

is
Active Queue Number of stored Commands
Data Control Time Counter of Data_Contol_Time
Min. Interval Time Counter of min.Slave_Intervals
Width of used RAM Number of used bytes in the upper RAM
Faulty Station Address Station address of the faulty Station
Timeout Counter Supervision counter that is activated when a short

circuit was detected on the bus

Table 35: USR_INTF Task State
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10.1.3 USR_INTF Running States

Figure 62: USR_INTF Running States

Variable Meaning

Slave x (x=0 .. 125) Slave handler-State for Station address x

Table 36: USR_INTF Running States

10.1.4 USR_INTF Global State Field
See section Global State Field on page 62.
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10.1.5 USR_INTF Communication Error

Figure 63: USR_INTF Communication Error

Variable Meaning

Slave x (x=0 .. 125) Error number of the Slave

Table 37: USR_INTF Communication Error
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10.1.6 USR_INTF Parameter Set List

Figure 64: USR_INTF Parameter Set List

Variable Meaning

Slave x (x=0 .. 125) 0 = no or no valid parameter data set
1 = valid parameter data set

Table 38: USR_INTF Parameter Set List
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10.1.7 USR_INTF Last Download Parameter

Figure 65: USR_INTF Last Download Parameter

Variable Meaning

Byte 0 to 119 Last parameter data set

Table 39: USR_INTF Last Download Parameter
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10.1.8 USR_INTF Disconnect Report

Figure 66: USR_INTF Disconnect Report

Variable Meaning

Slave (x=0 .. 125) Counter for disconnection for Slave x (x = 0 to 125)

Table 40: USR_INTF Disconnect Report

The status table shows the number of communication break downs
(disconnections) resulted by a bus communication errors for each Slave
station. The counter is incremented only when the Master was
communicating in the 'Data Exchange All' mode with all Slaves before. A
hard error is when the max retries were reached (given by the
max_retry_limit). See bus parameter max_retry_limit.
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10.1.9 USR_INTF Diagnostic Report

Figure 67: USR_INTF Diagnostic Report

Variable Meaning

Slave (x=0 .. 125) Counter for diagnostic reports for Slave x (x = 0 .. 125)

Table 41: USR_INTF Diagnostic Report

The status table shows the number of diagnostic reports for each Slave
station that has reported to the Master. For each received report the
data_exchange state to this Slave was left for one DP cycle to read out the
diagnostic information.
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10.1.10 USR_INTF DPV1 Data

Figure 68: USR_INTF DPV1 Data

Variable Meaning

Read Req Counter for Read Requests
Read Con Pos Counter for Read Confirmations Positive
Read Con Neg Counter for Read Confirmations Negative
Write Req Counter for Write Requests
Write Con Pos Counter for Write Confirmations Positive
Write Con Neg Counter for Write Confirmations Negative
Alarm Req Counter for Alarm Requests
Alarm Con Pos Counter for Alarm Confirmations Positive
Alarm Con Neg Counter for Alarm Confirmations Negative
FDL Data Reply Req Counter for FDL Data Reply Requests
FDL Data Reply Con POs Counter for FDL Data Reply Confirmations Positive
FDL Data Reply Con Neg Counter for FDL Data Reply Confirmations Negative
Change Diag Ind. Counter for Change Diag Indication
Alarm Stop Ind Counter for Alarm Stop Indication
Alarm Not Enable Counter for Alarm Stop Enable
Status Counter for Status

Table 42: USR_INTF DPV1 Data
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10.1.11 FDL_TASK Task State

Figure 69: FDL_TASK Task State

Variable Meaning

Task State Task state number
Last FDL error state Error state
Last FDL init. Error Initialization error
Last FDL runtime error Runtime error
ASPC2 bus short circuit Counter for occurred bus synchrony error reports or

bus short circuits of the ASPC2
ASPC2 bus error Counter for occurred bus error reports of the ASPC2
Free application blocks free applications blocks of the software
Free SAP blocks free SAP blocks of the software
Free CLASS2 blocks free class 2 blocks of the software

Table 43: FDL_TASK Task State
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10.1.12 FDL_TASK Act. Bus parameter

Figure 70: FDL_TASK Act. Bus parameter

Display of the bus parameters
Variable Meaning

Highest station address HSA Highest Station address
Bus address of this Master
station

TS (This station) own bus address

Transmission rate Transmission rate
0 = 9600; 1 = 19200; 2 = 93,75; 3 = 187,5; 4 = 500k; 7
= 1.5M; 8 = 3M; 9 = 6M; 10 = 12M

Maximum request retry in error
case

Number of retries for bus errors

Slot time TSL Slot Time
Transmitter fall time TQUI Transmitter Fall Time
Setup time TSET Setup Time
Smallest station delay MIN TSDR minimum station delay
Largest station delay MAX TSDR maximum station delay
Target rotation time TTR Target Rotation Time
GAP update factor G GAP Update Factor

Table 44: FDL_TASK Act. Bus parameter
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10.1.13 FDL_TASK DDLM Requests Class 1

Figure 71: FDL_TASK DDLM Requests Class 1

Variable Meaning

Set bus parameters Counter for 'Set-Bus-Par' Request
Set Slave address list Counter for 'Set-Slave-List' Request
Slave diagnostic requests Counter for 'Slave-Diag' Request
Set parameter request Counter for 'Set-Prm' Request
Check configuration request Counter for 'Check-Cfg' Request
Global control request Counter for 'Global-Control' Request
Data exchange requests Counter for 'Data-Exchange' Request
Data exchange conf pos Counter for 'Data-Exchange' Confirmation positive
Data exchange conf neg Counter for 'Data-Exchange' Confirmation negative
Data exchange all requests Counter for 'Data-Exchange-All' Request
Data exchange all conf pos Counter for positive Confirmation of 'Data-Exchange-

All'
Data exchange all conf neg Counter for negative Confirmation of 'Data-Exchange-

All'

Table 45: FDL_TASK DDLM Requests Class 1

Services which were send continued to the according to the PROFIBUS-DP
standard are counted in this table. Fundamental only the 'data-exchange-
all' should be count in a faultless network. The services 'set-slave-list', 'set-
prm', 'chk-cfg', 'data-exchange' permits in case of faultless course for each
configured Slave module to be activated only one time. If the count
changes continuously in case of this services, a bus error has occurred. If
for example the service 'slave-diag' changes sporadically the bus cable can
have an defect or the terminating resistor is missing in the cable. It is also
possible that a conscious error report of a Slave module that activates the
service in the Master.
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10.1.14 FDL_TASK DDLM Requests Class 2

Figure 72: FDL_TASK DDLM Requests Class 2

Variable Meaning

Service/Function Counter for this Service/Function

Table 46: FDL_TASK DDLM Requests Class 2
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10.1.15 FDL_TASK FDL Requests

Figure 73: FDL_TASK FDL Requests

Variable Meaning

SDA request Counter for 'SDA' Request
SDA confirmation pos Counter for 'SDA' Confirmation, positive
SDA confirmation neg Counter for 'SDA' Confirmation, negative
SDA indication Counter for 'SDA' Indication
SDN request Counter for 'SDN' Request
SDN confirmation pos Counter for 'SDN' Confirmation, positive
SDN confirmation neg Counter for 'SDN' Confirmation, negative
SDN indication Counter for 'SDN' Indication
SRD request Counter for 'SRD' Request
SRD confirmation pos Counter for 'SRD' Confirmation, positive
SRD confirmation neg Counter for 'SRD' Confirmation, negative
SRD indication Counter for 'SRD' Indication
SRD update request Counter for 'SRD' Update Request
SRD update con pos Counter for 'SRD' Update Confirmation, positive
SRD update con neg Counter for 'SRD' Update Confirmation, negative

Table 47: FDL_TASK FDL Requests

FDL Services that are activated on the bus according to the PROFIBUS
specification are counted in this window. The request (send), its
confirmation (positive or negative) and the indication (received) are
counted.
Not all services/functions are supported by the firmware.
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10.1.16 FDL_TASK FMA Requests

Figure 74: FDL_TASK FMA Requests

Variable Meaning

SAP act. Request Counter for 'SAP Activate' Request
SAP act. Confirmation pos Counter for 'SAP Activate' Confirmation, positive
SAP act. Confirmation neg Counter for 'SAP Activate' Confirmation, negative
RSAP act. Request Counter for 'RSAP Activate' Request
RSAP act. Confirmation pos Counter for 'RSAP Activate' Confirmation, positive
RSAP act. Confirmation neg Counter for 'RSAP Activate' Confirmation, negative
SAP deact. Request Counter for 'SAP Deactivate' Request
SAP deact. Confirmation pos Counter for 'SAP Deactivate' Confirmation, positive
SAP deact. Confirmation neg Counter for 'SAP Deactivate' Confirmation, negative
LiveList request Counter for 'LiveList' Request
LiveList confirmation pos Counter for 'LiveList' Confirmation, positive
LiveList confirmation neg Counter for 'LiveList' Confirmation, negative

Table 48: FDL_TASK FMA Requests

FMA Services that are activated on the bus according to the PROFIBUS
specification are counted in this window. The request (send) and its
confirmation (positive or negative) are counted.
Not all services/functions are supported by the firmware.
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10.1.17 FDL_TASK DP Retry for Slave

Figure 75: FDL_TASK DP Retry for Slave

Variable Meaning

Slave x (x=0 .. 125) Retries for Slave x (x=0 .. 125)

Table 49: FDL_TASK DP Retry for Slave

If based on an bus error a telegram to a Slave is repeated this is counted in
this window. The single count of retries per telegram can’t be read out here.
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10.1.18 FDL_TASK DP Activated Slave

Figure 76: FDL_TASK DP Activated Slave

Variable Meaning

Slave x (x=0 .. 125) Inactive (=0) or active (=1) Slave x (x=0 .. 125)

Table 50: FDL_TASK DP Activated Slave
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10.2 Extended Device Diagnostic DP Slave
On the following pages the task state structures for PROFIBUS-DP Slave
are described.

10.2.1 PLC_TASK Variables

Figure 77: PLC_TASK Variables (Slave)

The variables of the PLC task are not longer supported in newer firmware
because of  performance reasons.
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10.2.2 SPC3CTRL SPC3

Figure 78: PLC_TASK Variables

Variable Meaning

Baud Rate Baudrate
Bus Address Bus address
Ident Number Ident Number
Task State Task state
Input Length Length of input bytes for cyclic transfer
Output Length Length of output bytes for cyclic transfer
Error Cnt Error counter
Last Error Error code of the last error
IRQ Select Number of the SPC3 interrupt line
IRQ Polarit. Polarity of the SPC3 interrupt line
Device Manuf. Device manufacturer
Device Type Device Type
Device Model Device Model
IRQ Bits Type of the last SPC3 interrupts
IRQ Cnt Counter for SPC3 interrupt requests
Addr Switch Type of the address switch
DevTabEntry Internal usage
Module Count Number of the configured input/output modules on the

PROFIBUS
I/O Field Len Length of the input/output data buffer in the SPC3
KByte Field Len Length of the configuration data buffer in the SPC3
Param Field Len Length of the parameter data buffer in the SPC3
Diag Field Len Length of the diagnostic data buffer in the SPC3
Param User Internal usage
State Param Internal usage

Table 51: PLC_TASK Variables
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10.2.3 SPC3CTRL Slave Config

Figure 79: SPC3CTRL Slave Config

Variable Meaning

Config Length Length of the actual Configuration data in the Slave
Config Byte 1 Configuration data Byte 1
... ...

Table 52: SPC3CTRL Slave Config
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10.2.4 SPC3CTRL Master Config

Figure 80: SPC3CTRL Master Config

Variable Meaning

Config Length Length of the configuration data send by the Master
Config Byte 1 Configuration data Byte 1
... ...

Table 53: SPC3CTRL Master Config
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10.2.5 SPC3CTRL Param Data

Figure 81: SPC3CTRL Param Data

Variable Meaning

Param Length Length of the User-Param-Data send by the Master
Param Byte User-Param-Data-Byte 1
... ...

Table 54: SPC3CTRL Param Data

The standard Parameter data bytes are not displayed.
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10.2.6 SPC3CTRL DPM

Figure 82: SPC3CTRL DPM

Display of the internal variables of the SPC3 PROFIBUS ASIC.
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10.2.7 SPC3CTRL DPV1 Class 1

Figure 83: SPC3CTRL DPV1 Class 1
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Variable Meaning

Status Requests from User Status reports by the user
Status Messages Sent Status reports sent to the PROFIBUS
Negative Status Confirmations to
User

Status reports rejected with error by the user

Diagnosis Requests from User Single diagnostic reports by the user
Diagnosis Messages Sent Single diagnostic reports sent to the PROFIBUS
Negative Diag Confirmations to
User

Single diagnostic reports rejected with error by the
user

Alarm Request from User Alarm reports by the user
Alarm Messages Sent Alarm reports sent to the PROFIBUS
Positive Alarm Confirmations to
User

Alarm reports confirmed by the user

Negative Alarm Confirmations to
User

Alarm reports rejected by the user

Requests DPV1 class 1 requests from PROFIBUS received
Immediate Negative
Confirmations

DPV1 class 1 requests rejected with error

R/W Indications to User Read/Write requests forwarded to the user
Positive R/W Responses from
User

Read/Write requests from the user (positive)

Negative R/W Responses from
User

Read/Write requests from the user (negative)

Alarm Ack Indications Alarm acknowledgement from PROFIBUS received
Alarm Ack Responses Alarm acknowledgement answered
Alarm Ack Errors Alarm acknowledgement with errors
Erroneous Responses from User DPV1 class 1 answers from the user with error
Unexpected Responses from
User

Unexpected DPV1 class 1 answers from the user

Table 55: SPC3CTRL DPV1 Class 1
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10.2.8 SPC3CTRL DPV1 Class 2

Figure 84: SPC3CTRL DPV1 Class 2

Variable Meaning

PDUs Received DPV1 class 2 PDUs from PROFIBUS received
PDUs Provided DPV1 class 2 PDUs given to the PROFIBUS
PDUs Fetched by Master DPV1 class 2 PDUs taken by the Master on the

PROFIBUS
Initiate Indications to User Initiate indication forwarded to the user
Positive Initiate Responses from
User

Initiate response of the user (positive)

Negative Initiate Responses from
User

Initiate response of the user (negative)

R/W/T Indications to User Read/Write/Data transport indication forwarded to the
user

Positive R/W/T Responses from
User

Read/Write/Data transport responses of the user
(positive)

Negative R/W/T Responses from
User

Read/Write/Data transport responses of the user
(negative)

Idle Requests Received Idle telegrams received from PROFIBUS
Idle Requests Sent Idle telegrams sent to PROFIBUS
Abort Requests Received Abort request received from PROFIBUS
Abort Requests Sent Abort request sent to PROFIBUS
Abort Requests from User Abort request from user
Abort Indications to User Abort indication forward to user
Erroneous Responses from User DPV1 class 2 answers of the user with error
Unexpected Responses from
User

Unexpected DPV1 class 2 answers of the user

Services Stopped DPV1 class 2 services stopped

Table 56: SPC3CTRL DPV1 Class 2
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10.2.9 SPC3CTRL Code Diagnostic

Figure 85: SPC3CTRL Code Diagnostic

Display for state and error reports from the firmware.



118  ••••   Appendix Fieldbus Configurator PROFIBUS

Copyright •  ABB STOTZ-KONTAKT GmbH •

10.3 Identifier Bytes
In the configuration telegram identifier bytes are used. The meaning of
them is specified in the PROFIBUS specification.
The following table is an overview.

Value Meaning

GIF/SIF 0x00 00 free place
0x01-0x0F 01-15 see SIF

GIF 0x10-0x1F 16-31 1-16 Byte Input Consistency over Byte
GIF 0x20-0x2F 32-47 1-16 Byte Output Consistency over Byte
GIF 0x30-0x3F 48-63 1-16 Byte Input/Output Consistency over Byte

0x40-0x4F 64-79 see SIF
GIF 0x50-0x5F 80-95 1-16 Word Input Consistency over Word
GIF 0x60-0x6F 96-111 1-16 Word Output Consistency over Word
GIF 0x70-0x7F 112-127 1-16 Word Consistency over Word

0x80-0x8F 128-143 see SIF
GIF 0x90-0x9F 144-159 1-16 Byte Input Consistency over whole length
GIF 0xA0-0xAF 160-175 1-16 Byte Output Consistency over whole length
GIF 0xB0-0xBF 176-191 1-16 Byte Consistency over whole length

0xC0-0xCF 192-207 see SIF
GIF 0xD0-0xDF 208-223 1-16 Word Input Consistency over whole length
GIF 0xE0-0xEF 224-239 1-16 Word Output Consistency over whole length
GIF 0xF0-0xFF 240-255 1-16 Word Consistency over whole length

Table 57: Identifier bytes (overview)

10.3.1 Identifier Bytes (General Identifier Format GIF)
For the identifier bytes in general identifier format the following table shows
the meaning.
MSB LSB

7 6 5 4 3 2 1 0 Meaning
Bit 3 to 0: Length
0000 = 1 Byte or 1 Word
0001 = 2 Byte or 2 Word
...
1111 = 16 Byte or 16 Word
Bit 5 and 4: Input/Output
00 = special identifier format (SIF)
01 = Input
10 = Output
11 = Input and Output
Bit 6: Format
0 = Byte
1 = Word
Bit 7: Consistency over
0 = Byte or Word
1 = whole length

Figure 86: Identifier Bytes (General Identifier Byte Format GIF)
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Value Meaning

GIF/SIF 0x00 00 Free place
SIF 0x01 – 0x0F see SIF
GIF 0x10 16 1 Byte Input Consistency over Byte
GIF 0x11 17 2 Byte Input Consistency over Byte
GIF ... ... ... Byte Input Consistency over Byte
GIF 0x1F 31 16 Byte Input Consistency over Byte
GIF 0x20 32 1 Byte Output Consistency over Byte
GIF 0x21 33 2 Byte Output Consistency over Byte
GIF ... ... ... Byte Output Consistency over Byte
GIF 0x2F 47 16 Byte Output Consistency over Byte
GIF 0x30 48 1 Byte Input/Output Consistency over Byte
GIF 0x31 49 2 Byte Input/Output Consistency over Byte
GIF ... ... ... Byte Input/Output Consistency over Byte
GIF 0x3F 63 16 Byte Input/Output Consistency over Byte
SIF 0x40 – 0x4F see SIF
GIF 0x50 80 1 Word Input Consistency over Word
GIF 0x51 81 2 Word Input Consistency over Word
GIF ... ... ... Word Input Consistency over Word
GIF 0x5F 95 16 Word Input Consistency over Word
GIF 0x60 96 1 Word Output Consistency over Word
GIF 0x61 97 2 Word Output Consistency over Word
GIF ... ... ... Word Output Consistency over Word
GIF 0x6F 111 16 Word Output Consistency over Word
GIF 0x70 112 1 Word Input/Output Consistency over Word
GIF 0x71 113 2 Word Input/Output Consistency over Word
GIF ... ... ... Word Input/Output Consistency over Word
GIF 0x7F 127 16 Word Input/Output Consistency over Word
SIF 0x80 – 0x8F see SIF
GIF 0x90 144 1 Byte Input Consistency over whole length
GIF 0x91 145 2 Byte Input Consistency over whole length
GIF ... ... ... Byte Input Consistency over whole length
GIF 0x9F 159 16 Byte Input Consistency over whole length

Table 58: Identifier Bytes 0x10 .. 0x3F, 0x50 .. 0x7F, 0x90 .. 0x9F (GIF)
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Value Meaning

GIF 0xA0 160 1 Byte Output Consistency over whole length
GIF 0xA1 161 2 Byte Output Consistency over whole length
GIF ... ... ... Byte Output Consistency over whole length
GIF 0xAF 175 16 Byte Output Consistency over whole length
GIF 0xB0 176 1 Byte Input/Output Consistency over whole length
GIF 0xB1 177 2 Byte Input/Output Consistency over whole length
GIF ... ... ... Byte Input/Output Consistency over whole length
GIF 0xBF 191 16 Byte Input/Output Consistency over whole length
SIF 0xC0 – 0xCF see SIF
GIF 0xD0 208 1 Word Input Consistency over whole length
GIF 0xD1 209 2 Word Input Consistency over whole length
GIF ... ... ... Word Input Consistency over whole length
GIF 0xDF 223 16 Word Input Consistency over whole length
GIF 0xE0 224 1 Word Output Consistency over whole length
GIF 0xE1 225 2 Word Output Consistency over whole length
GIF ... ... ... Word Output Consistency over whole length
GIF 0xEF 239 16 Word Output Consistency over whole length
GIF 0xF0 240 1 Word Input/Output Consistency over whole length
GIF 0xF1 241 2 Word Input/Output Consistency over whole length
GIF ... ... ... Word Input/Output Consistency over whole length
GIF 0xFF 255 16 Word Input/Output Consistency over whole length

Table 59: Identifier Bytes 0xA0 .. 0xBF, 0xD0 .. 0xFF (GIF)
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10.3.2 Special Identifier Byte Format (SIF)
The special identifier byte format (SIF) is an extension of the general
identifier byte format and offers more flexibility. Also manufacturer specific
information can be used with it.

MSB LSB Meaning

7 6 5 4 3 2 1 0
Bit 0 to 3: Length of manufacturer specific
data according to the length byte for In-
and/or Output
In case of DDLM_Chk_Cfg:
0000 = no manufacturer specific data follow
0001 = 1 manufacturer specific data follow
...
1110 = 14 manufacturer specific data follow
1111 = no manufacturer specific data follow
In case of DDLM_Get_Cfg:
0000 = no manufacturer specific data follow
0001 = 1 manufacturer specific data follow
...
1110 = 14 manufacturer specific data follow
1111= not allowed
Bit 5 and 4: solid
00 = solid
Bit 7 and 6: Input/Output
00 = free place
01 = a length byte for Input follows
10 = a length byte for Output follows
11 = a length byte for Input and Output
follows

Figure 87: Special Identifier Format (SIF)

Length Byte
MSB LSB Meaning

7 6 5 4 3 2 1 0
Bit 0 to 5: Length
000000 = 1 Byte or 1 Word
000001 = 2 Byte or 2 Word
...
111111 = 64 Byte or 64 Word
Bit 6: Format
0 = Byte
1 = Word
Bit 7: Consistency over
0 = Byte or Word (element)
1 = whole length

Table 60:Length Byte of the SIF
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Value Meaning

GIF/SIF 0x00 00 free place
GIF 0x01 – 0x0E 01 – 14 free place and 1-14 manufacturer specific data
GIF 0x0F 15 free place and no manufacturer specific data
GIF 0x40 64 1 length byte Input
GIF 0x41 – 0x4E 65 – 78 1 length byte Input and 1-14 manufacturer specific data
GIF 0x4F 79 1 length byte Input and no manufacturer specific data
GIF 0x80 128 1 length byte Output
GIF 0x81 – 0x8E 129 – 142 1 length byte Output 1 and 1-14 manufacturer specific data
GIF 0x8F 143 1 length byte Output 1 and no manufacturer specific data
GIF 0xC0 192 1 length byte Output and 1 length byte Input
GIF 0xC1 – 0xCE 193 – 206 1 length byte Output, 1 length Input byte and 1-14 manufacturer

specific data
GIF 0xCF 207 1 length byte Output, 1 length Input byte and no manufacturer

specific data

Table 61: Special Identifier bytes 0x01 .. 0x0F, 0x40 .. 0x4F, 0x80 .. 0x8F, 0xC0 .. 0xCF
(SIF)

Length Byte
Value Meaning

0x00 – 0x3F 00-63 1-64 Byte Consistency over Byte
0x40 – 0x7F 64-127 1-64 Word Consistency over Word
0x80 – 0xBF 129-191 1-64 Byte Consistency over whole length
0xC0 – 0xFF 193-255 1-64 Word Consistency over whole length

Table 62: Length byte of the special identifiers (SIF)
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1 Overview FB 1131
1.1 Main Functions

The main functions of the DeviceNet Fieldbus Configurator are:
Function Section Short Description

Overview Communication Types Overview communication types and
description of the configuration steps

Configuration

Automatic Network Scan Scans the network
Diagnostic Functions Diagnostic functions, Debugger,

Global State Field etc.
Diagnostic

Use Data Transfer I/O Monitor, I/O Watch, Get/Set
Attribute, Message Monitor

Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: FB 1131 Main Functions
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1.2 Properties
FB 1131 is an universal Fieldbus Configurator
This means you can configure the most important fieldbus systems like
PROFIBUS, DeviceNet, and InterBus with the same tool.

FB 1131 is a global Fieldbus Configurator
You configure all devices with one tool. FB 1131 checks the dependencies
between the devices. FB 1131 only allows configurations that make sense.
In case of doubt FB 1131 will give you a warning.

FB 1131 documents your Fieldbus system
After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the detail of one
device.

FB 1131 uses standardized configuration files
Some protocols support standardized files containing information about all
features and limitations of the Slave device. FB 1131 uses these files for
the configuration.

FB 1131 is a diagnostic tool
After the configuration you can switch FB 1131 into the diagnostic mode.
You can watch all status information of the couplers, see protocol
dependent diagnostic information. In this case a Slave is not operating
correctly will be displayed in a different colour.
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2 Installation and Licensing
2.1 System Requirements

•  PC with 486-, Pentium processor or higher

•  Windows 95/98/ME, Windows NT 4.0, Windows 2000

•  Free disk space: 30 - 80 MByte

•  CD ROM drive

•  RAM: min. 16 MByte

•  Graphic resolution: min. 800 x 600 pixel

•  Windows 95: Service Pack 1

•  Windows NT: Service Pack 3

•  Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the 907 AC 1131 CD in the local CD ROM drive. If "Autorun" is
enabled on the PC the CD menu will start automatically. Otherwise it is
started by starting the file "CD_Menu_Vxx.exe" in the root directory of the
CD. For example by the menu Start > Run and entering
"[X:]\CD_Menu_Vxx.exe" ([X] is the CD rom drive and Vxx stands for the
version number).
You reach the Installation menu of the CD by operating the Installation
907 AC 1131 Vxx button.

With the menu Notes for Installation you get a description of the
innstallation and the components of the 907 AC 1131, the programming
software, the Fieldbus Configurator 907 FB 1131, OPC Server.

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation of the Fieldbus Configurator 907 FB 1131!
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3 Getting Started – Configuration Steps
3.1 Overview Communication Types

Select from the following the communication that you want to use. The
configuration steps are described in the given chapter.

Communication Device Device Described in section Page
DeviceNet DeviceNet

Master
Any
DeviceNet
Device

Configuration DeviceNet Master to any DeviceNet Slave 12

Table 2: Overview Communication Types
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3.2 Configuration DeviceNet Master to any DeviceNet Slave
The following table describes the steps to configure a DeviceNet Master to
any DeviceNet Slave as it is typical for many cases.

# Action Menu in the Fieldbus Configurator Detail information in section Page
1 Create a new project File > New > DeviceNet Configuration of DeviceNet

with FB 1131
13

2 Copy EDS file of the
DeviceNet device (Slave), if
the device is not in the
selection list

File > Copy EDS EDS Files (Electronic Data
Sheet Files)

13

3 Choose DeviceNet Master
and provide MAC ID address

Insert > Master Insert Master 15

4 Choose DeviceNet device
and provide MAC ID address

Insert > Device Insert DeviceNet Slave 17

5 Assign the input and output
modules

6 Assign the offset addresses

Mark the Device (left Mouse click), then
Settings > Device Configuration

Device Configuration 19

7 Assign the Device Parameter
data, if the Device needs
Parameter data

Mark the Device (left Mouse click), then
Settings > Device Configuration >
Parameter Data

Parameter Data 22

8 Set the Bus parameter Mark the Master (left Mouse click), then
Settings > Bus Parameters

Bus Parameters 28

9 Set device assignment if no
automatic assignment has
occurred

Mark the Master (left Mouse click), then
Settings > Device Assignment

Gateway Driver 27

10 Save project File > Save Save and Save As 47
11 Download Mark the Master (left Mouse click), then

Online > Download
Downloading the
Configuration

31

12 Live list Mark the Master (left Mouse click), then
Online > Live List

Live List 37

13 Start Debugger Mark the Master (left Mouse click), then
Online > Start Debug Mode

Debug Mode (DeviceNet) 39

14 Device diagnostic Mark the Slave (left Mouse click), then
Online > Device Diagnostic

Device Diagnostic 40

15 Stop Debugger Online > Stop Debug Mode Debug Mode (DeviceNet) 39

16 Global Diagnostic Mark the Master (left Mouse click), then
Online > Global State Field

Global State Field 41

Table 3: Steps for Configuration DeviceNet Master to any DeviceNet Slave
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4 Configuration of DeviceNet with FB 1131
4.1 Setting up the DeviceNet Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Choose the DeviceNet. If only a
DeviceNet fieldbus system is installed with FB 1131, the configuration
window will open directly.
The name of the configuration file can be allocated when the configuration
is ended or with File > Save As.

4.2 EDS Files (Electronic Data Sheet Files)
An Electronic Data Sheet (EDS) provides information necessary to access
and alter the configurable parameters of a device. An Electronic Data Sheet
(EDS) is an external file that contains information about configurable
attributes for the device, including object addresses of each parameter.
The application objects in a device represent the destination addresses for
configuration data. These addresses are encoded in the EDS.
 The figure below shows a general block diagram of a sample EDS.

Device Parameter 1

Device Parameter X

EDS

Standard Device Profile

Standard Device Profile

Device Parameter 1

General Device
Information

Vendor-Specific

Device Parameter X
Vendor-Specific

Optional

Figure 1: General block diagram of an EDS file
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4.2.1 EDS files and FB 1131
When the Fieldbus Configurator is started, it automatically retrieves all the
EDS files stored in the EDS directory. The device names are placed into an
internal list. During the configuration, the device-specific data is retrieved
directly from the EDS files.
If a DeviceNet device does not appear in the selection list (Insert Master or
Insert Device), then a corresponding EDS file can be copied into the EDS
directory with File > Copy EDS. Another possibility is to copy the EDS file
into the FB 1131 EDS directory with Windows Explorer and then retrieve
the EDS files into the EDS directory with Settings > Path and OK.

Figure 2: EDS Files and bitmaps directory

ABB Stotz-Kontakt devices: The EDS files for ABB Stotz-Kontakt devices
are already included and installed.
Other devices: The respective device manufacturer provides the EDS files
for other devices.
The EDS directory is adjustable. In order to alter the directory from a
previous setting in another directory, use the menu Settings > Path. All
EDS files must be placed in this directory.
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4.3 Master

4.3.1 Insert Master
In order to insert a Master into the configuration, choose the Insert >
Master menu, in order to open the selection window, or click on the
symbol:
Insert > Master

Table 4: Insert > Master

The window opens from which exactly one Master can be chosen. After this
selection the chosen Master is at the first position in the configuration
window.

Figure 3: Insert > Master

The MAC ID of the Master can be changed here.
The Description field will accept up to 32 characters of text. This text will
appear later in the main configuration window.
The chosen Master is automatically placed at the first position in the main
configuration window, if the selection was confirmed with the OK button.
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4.3.2 Replace Master
If a Master already exists in the configuration and should be replaced
against another Master, you first have to set the focus on the Master (left
mouse click at the Master) and then choose the menu Edit > Replace. In
the opened window appears the question if the Master should be replaced.

Figure 4: Security question replace Master

If you click the button Yes a new window opens, where you can replace the
Master against the existing Master.

Figure 5: Edit > Replace Master

In this window you select the Master you want by clicking on it in the list
Available Masters and then click the Add button to put the Master to
Selected Masters. With OK you confirm the selection and the Master will
be replaced.
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4.4 DeviceNet Slave

4.4.1 Insert DeviceNet Slave
In order to insert an DeviceNet Slave into the configuration, choose the
Insert > Device menu to open the selection window
or
click on the symbol:
Insert > Slave
device

Mousepointer for
Insert > Device

Table 5: Insert > Device

The mouse pointer automatically changes to the Insert Slave pointer. Click
at the position where the Slave should be insert. A dialog box opens where
one or more Slaves could be selected.

Figure 6: Insert > Device

The list on the left displays for selection all the Slave devices whose EDS
files have been put in the EDS directory. A filter can be used to limit the
selection list by the Type and the Vendor. Further information on a Slave is
shown below the selection list (Available Slaves) when it is selected (one
mouse click). Apart from the manufacturer name and the description
especially the ID-Code, the Length-Code, the file name and the file revision
are given. The Slave appears on the right-hand list with a mouse click or
with the Add button. All devices in the right-hand list are assigned to the
current Master that is also shown in this window. If the Slaves in the right-
hand list are chosen one after the other (a mouse click), then every Slave
can be assigned a MAC ID and a name in the Description field.
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4.4.2 Replace Device
If a device already exists in the configuration and should be replaced
against another device, you first have to set the focus on this device (left
mouse click at the device) and then choose the menu Edit > Replace. In
the opened window appears the question if the device should be replaced.

Figure 7: Security question replace device

If you click the button Yes a new window opens, where you can replace the
device.

Figure 8: Edit > Replace

In this window you select the device you want by clicking on it and then
click the Add button to put the device to Selected devices. With OK you
confirm the selection and the device will be replaced.
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4.4.3 Device Configuration
First click the symbol of the Slave with the left mouse button and then
choose the Settings > Slave Configuration menu.

or
open the Slave configuration window by double clicking on the DeviceNet
Slave device.
The slave-specific configuration is carried out in this window. Here, the
modules and their addresses are assigned in the process data memory in
the Master. Note that the address must agree with that in the PC
application.

Figure 9: Settings > Slave Configuration

Note 1: The offset addresses set in this window are for the addressing of
the input data and output data in the Master! These address settings
(offsets) are not the settings in the DeviceNet device (Slave). The
DeviceNet device (Slave) organizes its data itself.
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The EDS file which is used by the device is shown by the File name.
The Description and the MAC ID show the settings which were set during
the insert of the device. Both entries can be changed here.
If Activate device in actual configuration is selected, the Master carries
out an data exchange to this device. Is this setting deactivated, then the
Master doesn't carry out a data exchange to this device. In both cases
however the memory in the process image is used respectively reserved in
the Master.

4.4.3.1 MAC ID (Device network address)

The network address of a device serves to distinguish itself on a DeviceNet
fieldbus system from any other device or Slave on this network. This should
be a unique number for each device. A valid MAC-ID address is within a
range of 0 to 63 and can be re-entered and changed in the MAC-ID box in
the Device Configuration Dialog.

4.4.3.2 Actual chosen I/O Connection

DeviceNet allows to establish several kinds of I/O connections between
devices. Please note that a device has not to support all types of IO
connections.
I/O connection

Poll
Bit Strobe
Change of State
Cyclic

Table 6: Overview I/O connections

 Here is an explanation of the different connections types.

•  Polled I/O Connection - One poll command from the Master sends a
number of output data to a single, specific device (point-to-point). The
device receives (consumes) the poll command and processes the
output data. If it has input data configured for this poll connection it
reacts by sending (producing) back a number of input data and/or
status information to the Master. Before a polled I/O connection is
initiated by the Master, it reads the Consumed and Produced
Connection Size of the data from the Slave first and compares each
value with the internally configured one. If the Master detects
differences the connection cannot be established. Sending a poll
command can happen at any time the Master wants to and has timer
or event dependencies. A device has to respond if it has consumed
and understood the poll command request of the Master, even if it
has no input data. Else the Master will report a timeout error. Polling
data to many devices has the disadvantage that the network traffic
rate is very high and most data which is transferred has not changed
since the last transmission. Furthermore the higher the bus load more
communication errors can occur if the bus is disturbed by external
influences.
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•  Bit Strobe I/O Connection - Bit strobe command and response
messages rapidly move small amounts of I/O data between the
Master device and one/some/all Slave devices. The bit strobe
message contains a bit string of 64 bits of output data, one output bit
per possible device. Each bit in there is assigned to one device
address in the network. Herewith this service has broadcast
functionality that means more than one Slave device can be
addressed by one command. Because all addressed Slave devices
get this command at the same time, this command is normally used
to synchronize data transfer to several Slave devices. A Slave device
can take its corresponding output bit as a real output information to
give it to the peripheral connections (e.g. an LED) and/or use the bit
as a trigger to send back its input data with a poll response message.
The data that can be send back from each Slave after a bit strobe
command was received is limited to 8 bytes in length. Bit strobe
usage causes therefore a reduced bus loading than poll connections.

•  Change of State/Cyclic I/O Connection - The Master device sends
a number of output data to a single, specific device (point-to-point).
Data production is triggered by either a determined changed value in
the output data or the cyclic timer expiration. Depending on how the
Slave behaviour is configured, the Slave can send back an
acknowledge message, containing a number of input data and/or
status information. The Slave device sends a number of input data to
the Master, if the data is either changed or the cyclic timer has
expired. The Master itself can acknowledge this message with output
data if configured.

Change of state only production of data hold down the bus load as small as
possible, while data than can be transmitted as fast as possible by each
device because bus conflicts are less possible. So you can get high
performance data transmission with in comparison low baud rates.

4.4.3.3 Connection Object Instance Attributes

The Production Inhibit Time, one for each connection, configures the
minimum delay time between new data production in multiples of a
millisecond. The timer is reloaded each time new data production through
the established connection occurs. While the timer is running the device
suppresses new data production until the timer has expired. This method
prevents that the device is overloaded with to fast incoming requests.
The value 0 defines no inhibit time and data production can and will be
done as fast as possible. If in polled mode for example a Production
Inhibit Time of 1000dec is configured, then the poll request message to
the device will be sent every second.
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The Expected Packet Rate, one for each connection, is always transferred
to the device before starting and doing the I/O transfer . The value is used
by the device later to reload its 'Transmission Trigger' and 'Watchdog
Timer'. The 'Transmission Trigger Timer' is used in a 'cyclic' I/O connection
to control the time when the data shall be produced. Expiration of this timer
then is an indication that the associated connection must transmit the
corresponding I/O message. In 'change of state' connections the timer is
used to avoid the watchdog timeout in this connection, when a production
has not occurred since the timer was activated or reloaded.

Note: the Production Inhibit Time is verified against the Expected
Packet Rate. If the Expected Packet Rate value is unequal zero, but less
than the Production Inhibit Time value, then an error window is opened
when pressing the OK button or changing to a wrong value.

The Watchdog Timeout Action defines the device behaviour when the
watchdog timer in the device expires. The following values are defined and
their functionality is closer described in the DeviceNet specification.
Transition to Timed Out: The connection transitions to the Timed Out
state and remains in this state until it is Reset or Deleted.
Auto Delete: The connection class automatically deletes the connection if it
experiences an Inactivity/Watchdog timeout.
Auto Reset: The connection remains in the established state and
immediately restarts the Inactivity/Watchdog timer.

4.4.3.4 UCMM Check

The UCMM Check box is used for modules that require the use of UCMM
messaging format. Class 1,2,and 3 are supported. Check the
documentation for your Slave device to identify if this box must be checked.

4.4.3.5 Fragmented Timeout (Expl. Message Timeout)

If a transmission of I/O data or explicit message is greater than 8 bytes in
length, it must be transmitted on DeviceNet in a fragmented manner. The
maximum time the Master will wait until a Slave has to respond during the
fragmented transmissions is the fragmented timeout.

4.4.3.6 Parameter Data

The button Parameter Data can be selected in the Device Configuration
window to edit the parameter data.
If default parameters are configured in the EDS file for this Node, they are
inserted automatically when the menu is chosen the first time.
Some of devices need some further parameterisation data, to change for
example a measurement limitation or a value range. These data is Node
specific and their functionality can not be explained at this point.
The explanation can be normally found in the corresponding Node manual.
This window below shows an example of parameter data of a device.
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Figure 10: Parameter Data

Two tables are shown: one table with all available parameters and one
table for configured parameters. These parameters can be selected from
the available parameters to that table.
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4.4.3.7 Process Data Configuration

•  Fixed I/O data transferred
DeviceNet handles I/O data transparent as a byte string without defining
any data type in the transferred data. To be operative it defines only the
number of bytes in consumed and produced direction that shall be
transferred across a connection, nothing else. But FB 1131 and the
firmware now allows to assign modular each byte or a bunch of bytes of the
transparent string to different data types. A list of the supported data types
of the connection can be found in the middle table of the window called
Available Predefined Connection Data Types.

The following data types are supported:

•  Bit, Byte, Word, Dword, Byte Array

By selecting a data type of the available and defined connection types and
clicking on the Add button after this or a double click at the defined
connection data type in the Configured I/O connection data and its
offset address are taken over in the table.
If the data type Byte Array is chosen the number of bytes that shall be
reserved for this data type can be entered in the Data Count column in the
lower table. Any other data type has its fixed length that can not be
changed. The data types are distinguished in process output and process
input data in the view of the Master device.
A double-click on a predefined data type or a click in the Add to
configured I/O data button will insert the chosen data type in the lower
table called Configured I/O connection data. This table contains all data
that shall be really transferred across the connection. FB 1131 will add
separately the number of used bytes of each configured I/O data and forms
the values Consumed and Produced Connection Size automatically.
Both values indicates the sum of bytes which shall be sent by the Master as
outputs (Consumed by the device) and received by the Master as inputs
(Produced by the device).

•  Assigning the process data offset addresses

The I/O offset addresses of each placed data type in the connection data
table can be freely configured in a range of 0 to 3583 or they are set
automatically by FB 1131. To enable or disable free configuration use the
flag Auto Addressing in the menu Settings > Auto Addressing. If
enabled FB 1131 will place all configured I/O data spaceless in physical
order one to each other based on the rising MAC-ID order. This is done
during the download procedure. The assigned addresses can be checked
then in the overview Address Table of the menu View. If the addresses
are entered manually the default address 0 in the input address
respectively the output address must be overwritten.
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In case of manual addressing (that means auto addressing is deactivated)
the configuration window looks like:

Figure 11: Settings > Device Configuration

 In the column I Addr and O Addr you have to assign the addresses where to locate
the data in the process image. Remember that these addresses correspond to your
application on the HOST side.
If you deactivate a device in the actual configuration the device is shown like this:
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Figure 12: Deactivated Device

To activate or deactivate a device in a configuration can be very useful for
such devices which don't exist in the real physical network, but for which
the I/O offset addresses shall be reserved or simply a symbolic 'missing
device' wanted to be inserted as long the device is not connected.
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5 Settings
5.1 Gateway Driver

The Gateway Driver terminies how the Fieldbus Configurator
communicates with the device. This is set in the Device Assignment which
can be opened with the menu Settings > Device Assignment.

Figure 13: Settings > Device Assignment

After the selection of the Gateway channel or clicking the Connect button
FB 1131 tries to set up a connection to the selected controller.
If the connection was successful the configurable couplers are shown in the
field Device Information.

The desired coupler is selected by clicking on the field next to the name of
the coupler and confirming with the OK button.
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By clicking at the Gateway Configuration button a new window appears
where the Gateway channel can be selected or a new Gateway channel
can be configured.

Figure 14: Configure Gateway

To confirm the Channel selection click at the OK button.

5.2 Bus Parameters
Here the basic settings for the DeviceNet network are carried out. The Bus
Parameters can be displayed with the menu Settings > Bus Parameters.

Figure 15: Settings > Bus Parameters

Mainly, this concerns the determination of the Baudrate. The DeviceNet
board supports the baudrates 125kbit/s, 250kbit/s and 500kbit/s. Normally
DeviceNet components uses the autobaud detection to get the baudrate
automatically once.
The Auto Clear mode feature defines the behaviour of the Master if the
communication breaks down or is interrupted to a Node. If the flag Auto
clear mode is activated, then the Master will also stop the communication to
all further Nodes which were still responding and active. If the flag Auto
clear mode is not activated, then a lost communication contact to one Node
has no influence on the communication channel of the still present ones.
For all the error effected Nodes the Master remains in the state to try the
reestablishment of the communication again.
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5.3 Project Information
If the user creates his own project, then the project information can be
written into the Settings > Project Information menu. Anybody can then
read this entry when this menu is opened.

Figure 16: Settings > Project information
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5.4 Path
When the Settings > Path menu is selected, then the search path for EDS
files is displayed. The passed value is C:\Program
Files\AC1131\FB1131\Fieldbus\DEVNet\EDS.

Figure 17: Settings > Path

5.5 Language
Choose the Settings > Language menu and the following window opens:

Figure 18: Settings > Language

Here can be set the language of the Fieldbus Configurator. Select the
desired language and confirm the entry with the OK button.

A message appears that the Fieldbus Configurator must be started again in
order to activate the selected language. Please carry this out.
After restarting the Fieldbus Configurator, the language will have changed
to the one selected.

Note: Up to now not all languages are available for all fieldbuses!
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6 Online Functions
6.1 Introduction

In this chapter, all functions that directly influence the DeviceNet Master are
presented.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched On or Off.

6.2 Online to the Coupler

6.2.1 Downloading the Configuration
First, the desired device must be chosen for downloading by a left mouse
click on the symbol of the device.
In order to release the configuration and network access, a transfer
(Download) to the devices must be carried out on the Online > Download
menu. A warning will appear that the communication on the DeviceNet will
be interrupted. This warning must be confirmed.

Figure 19: Security question before download

Figure 20: Online > Download

Before the download is carried out, the configuration is tested by the
Configurator. The most common cause of error is overlapping of addresses
in the process data image. This can be checked by calling up the address
table with the View > Address Table menu point.
If the issue of addresses in the process data image is carried out
automatically, then the Auto addressing button in the Master
Configuration window must be activated.

The configuration is transferred into the selected device and is stored there
in FLASH memory in a zero voltage manner so that the configuration is
available when the voltage supply is switched off and on again.
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6.2.2 Firmware Download
If you want to carry out a Firmware download, act as follow: First the
desired device for Firmware downloading must be chosen in that the
symbol of the device is selected with a left mouse click. Then, call up the
Online > Firmware Download menu. Select the new Firmware and
retrieve it with Download into the device. The Firmware is now retrieved.

Figure 21: Online > Firmware Download

6.2.3 Firmware / Reset
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then the Online > Firmware / Reset menu must be
called up and the name and the version of the Firmware are displayed.

Figure 22: Online > Firmware / Reset

The device can be resetted with the Reset button.
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6.2.4 Device Info
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Device Info menu in order
to obtain further information on the selected device.
The manufacturer date, the device number and the serial number of the
device is retrieved and shown.

Figure 23: Online > Device Info

6.2.5 Read Project Information
With Online > Read Project Information can be picked out the project
information from the device.



34  ••••   Online Functions Fieldbus Configurator DeviceNet

Copyright •  ABB STOTZ-KONTAKT GmbH •

6.3 Automatic Network Scan
This function scans the network structure. This allows a very fast
configuration, and you also have the possibility to change detailed
parameters for these devices later.
To start an automatic network scan, please proceed as followed:
1. Insert a Master device
2. Click on Settings > Bus Parameters and select the baudrate and the

MAC ID from the Master (explained in section Bus Parameters at
page 28).

3. Select Online > Download to load these settings into the DeviceNet
Master.

4. Click on the Master and choose Online > Automatic Network Scan
5. A new window is displayed, where you see the current status of the

network scan and the devices, which were already found in your
DeviceNet network:

Figure 24: Online > Automatic Network Scan (During the Scan)

The Automatic Network Scan takes about 30 seconds. The scan can not be
interrupted until the status shows next the "current status" changes to
"Ready". When the scan has finished all detected devices and their MAC ID
are shown.
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Figure 25: Online > Automatic Network Scan (After the Scan)

Here is an explanation of the different columns:
Variable Meaning

Supported functions Functions supported by the device, could be polled, bit strobe
or cyclic/change of state (see explanation in Actual chosen
I/O Connection, page 20)

Device Name Name of the device, result from network scan
Poll Size Produced Number of data for poll connection (input)
Poll Size Consumed Number of data for poll connection (output)
BitStr. Size Produced Number of data for bit strobe connection (input)
BitStr. Size Consumed Number of data for bit strobe connection (output)
Cyc/COS. Size Produced Number of data for cyclic/COS connection (input)
Cyc/COS. Size Consumed Number of data for cyclic/COS connection (output)
Chosen config Configuration chosen by the user, could be Change of State,

Cyclic, Polling, Bit strobed or explicit only and depends on the
functions supported by the device. Click on the cell to change
the configuration.

Table 7: Explanation of the columns in the automatic network scan
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A double click on the first or second column of the corresponding row of the
device shows information of the device.

Figure 26: Information on a device in the automatic scan window

If you want to use this configuration as your configuration, click on
Automatic Configuration and select Yes when prompted. Afterwards you
can close the Automatic Configuration Window by clicking on OK. If you do
not want the devices that were found in your configuration, just click OK.

If you want to insert your devices manually, please go on with section Insert
DeviceNet Slave on page 17.

6.4 Start/Stop Communication
First the desired device must be chosen with a left mouse click on the
symbol of the device. The communication between DeviceNet Master and
DeviceNet Slave can be manually started or stopped. In order to do this
select the Online > Communication start or Online > Communication
stop menu.
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6.5 Diagnostic Functions
The following table shows Diagnostic Functions and their using for
DeviceNet Master:

Diagnostic Function Using Used for DeviceNet
Master devices

Live List Detects which devices are connected to
the Master device

Yes

Debug Mode (DeviceNet) Detects to which DeviceNet devices
(Slaves) the DeviceNet Master can
communicate

Yes

Global State Field Status information of the DeviceNet
Master

Yes

Extended Device Diagnostic Statistic information and State information
from the DeviceNet device

Yes

Table 1: Overview Diagnostic Functions

6.5.1 Live List
If you select the menu Online > Live List you will get an overview of all
devices physically present in the actual network constellation. Present
devices are drawn in black, all other non present devices are drawn in grey.
The live list works online. If you connect or disconnect one station you will
see the result as soon as SyCon collects the latest live list from the Master
board. Remember that all devices on DeviceNet have to proceed the
autobaud detection phase first to get wholly run. This can take up to some
milliseconds.

Figure 27: Online > Live List
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6.5.1.1 Change MAC-ID

The window to change a MAC-ID opens with a double click on the address
(MAC-ID) of a DeviceNet device (slave).

Figure 28: Online > Live List > Change MAC-ID

Select the new MAC-ID in the New MAC-ID field and click on the Send
button to send it to the DeviceNet device (slave).

Note: The DeviceNet device (slave) has to support this function if this
function should be used.
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6.5.2 Debug Mode (DeviceNet)
Select the Online > Start Debug Mode menu. The Fieldbus Configurator
cyclically interrogates the status of the network communication on the
coupler and the individual condition of the devices.
To end the Debug Mode select the menu Online > Stop Debug Mode.

6.5.2.1 Debug Window

When started the debug session the configuration window changes into the
debug window. The devices and the line between them are displayed in
green or red colour depending on the established network communication.

Figure 29: The Debug Window

If a diagnostic information is available for a specific device, next to the
device icon the text Diag appears in red. To get further device specific
diagnostic information then doubleclick on the device itself or set the focus
to the device and select Online > Device Diagnostic.
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6.5.3 Device Diagnostic
After the debugger was started from this time FB 1131 requests the status
of all devices from the Master. If there is an error on a device the bus line to
this Slave is drawn in red colour otherwise it is green. This information is
displayed closer if you click with the mouse onto the corresponding device
in debug mode.
To activate the debug mode you have to mark the Master and select the
menu Online > Start Debug Mode. Then set the focus at the Slave and
with the menu Online > Device Diagnostic you activate the DeviceNet
device diagnostic. To end the Debug Mode you have to mark the Master
again and select the menu Online > Stop Debug Mode.

Figure 30: Online > Device Diagnostics

The individual bits in the Device Diagnostic have the following meaning:
Bits in the Device
Diagnostic

Meaning

No response The Device is configured but is not present in the network.
Please check the physical connection between the Master
and this Node. Check also the chosen baudrate and if this
baudrate is supported by this device.

Error buffer overflow An error can occur at each user during operation. These
errors are stored in an internal buffer, which can take up
50 error registrations per user. This bit is set, if the buffer
overflows.

Parameterization fault The device announces a peripheral device error. That can
be e.g. a short-circuit at the device outputs or an
undervoltage.

Configuration fault The ID code or the Length Code of the device does not
correspond with that of the user configured.

UCMM support This box is selected, if the device needs UCMM support.
Deactivated This bit is set automatically by the Master, if the device is

set in the device configuration as not active (Device
Configuration > Deactivate device in actual configuration).

Table 8: Meaning of the bits in the Device Diagnostic
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6.5.4 Global State Field
With the menu option Online > Global State Field opens a window in that
cyclically Statistic about the bus status and attached devices to be output.

Figure 31: Online > Global State Field

The first row displays the main status of the Master. It can have the status
OPERATE or STOP.
The next row displays individual bus errors. A pending error is displayed
with a red field. The meaning of the individual abbreviations is described in
the following.
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Status Bits Meaning

PDUP DUPLICATE-MAC-ID check: The device is involved in the duplicate
MAC-ID check procedure, to check if other devices with the same
address are connected to the network. The duplicate MAC-ID check
will be finished, if at least one DeviceNet device could have been
found connected to the network.

DMAC The device has stopped the duplicate MAC-ID check procedure and
found an other device having the same MAC-ID address. Change the
device address to avoid this failure.

NRDY HOST-NOT-READY-NOTIFICATION indicates if the host program
has set its state to operative or not. If this bit is set the host program
is not ready to communicate.

EVE EVENT-ERROR The used DeviceNet Master chip has detected at
least on transmission error. The number of detected events are
counted in Number of defective process data cycles and the error
Number of network reinintialisations. The bit will be set when the first
event was detected and will not be cleared any more and remains set
then.

NEXC NON-EXCHANGE-ERROR An activated bit indicates that one of the
configured device is not operational because of an configuration fault
or simply because it's not present in the network.

ACLR AUTO-CLEAR-ERROR This bit is set, when the Master stops the
communication to all its handled devices because of missing devices.
Before doing this it sets all output values of the left devices to the
save zero condition. The behaviour, if the Master shall shut down or
not, when it lost the contact to at least one device, is configurable in
FB 1131 configuration tool or in the bus parameter download
procedure. After the Master has shut down only a warm- or coldstart
can reactivate the communication again.

CTRL CONTROL-ERROR Configuration or heavy runtime error. Some of
them can occur during startup procedure of the Master. For example
if the DeviceNet controller of the Master card do not respond or the
configuration of FB 1131 has inconsistencies.

Table 9: Meaning of collecting status bits in the Global State Field

Further displays are:
Collective online error location and corresponding error indicate the
address of the faulty station and the pending error in plain text. Statistical
bus information indicates the number of the detected bus short-circuits an
rejected telegrams.
Devices specific status bits:
These display the parameterized devices, the active devices or the
devices with diagnostic according to the activated switching surface. A
pending diagnostic information can be received by a double click on the
respective station.
This display is cyclically updated.
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6.5.5 Extended Device Diagnostic
The extended device diagnostic helps to find bus and configuration errors
when the FB 1131 menu functions are of no further help.
First select the device with a left mouse click on the symbol of the device.
Then select the Online > Extended Device Diagnostic menu.

This menu opens a list of diagnostic structures. These contain online
counters, status information and parameters:

Figure 32: Extended Device Diagnostic by the example of DeviceNet Master

First the specification for the DeviceNet Master and far down for the
DeviceNet Slave follows.

For DeviceNet Master

PLC_TASK: DeviceNet Administration

DNM_TASK: Application interface (PCP Channel)

Task / Task State Page DNM

PLC_TASK Common Variables 63 X
DNM_TASK Common Variables 64 X
DNM_TASK Device running states 65 X
DNM_TASK Global state field 65 X
DNM_TASK Communication error 65 X
DNM_TASK Receive queue 66 X
DNM_TASK Transmit queue 67 X
DNM_TASK DeviceNet command
counter

68 X

DNM_TASK Timeout counter 69 X
DNM_TASK Init counter 69 X

Table 10: DeviceNet Master Task State
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6.6 Use Data Transfer
The following table shows test functions with user data transfer and the
usability for DeviceNet Master.

Use data transfer function Usage Usable with DeviceNet
Master devices

Get Device Attribute and
Set Device Attribute

Read or write data (objects) Yes

Table 11: Overview User Data Transfer

6.7 DeviceNet Services

6.7.1 Get Device Attribute
This menu selection enables the user to get/receive attribute related
information from a Slave device. The user should be familiar with the
supported Class, Instance, and Attribute entrees for the Slave device.
These entries should be available within the suppliers data sheet for the
Slave product. The return value will be represented in Hexadecimal.
Clicking the ASCII button will change this value to ASCII text. The
Hexadecimal code can be resorted by clicking now the Hex button. Clicking
the Get button will receive the Value from the device.

Figure 33: Get Attribute window
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6.7.2 Set Device Attribute
This menu selection enables the user to set a attribute related to a Slave
device. The user should be familiar with the supported Class, Instance, and
Attribute entrees for the Slave device. These entrees should be available
within the suppliers data sheet for the Slave product. The Value will be
represented in Hexadecimal. Clicking the Set button will send the
information to the Slave device.

Figure 34: Set Attribute window

6.7.3 Change MAC-ID
To change a MAC-ID of a DeviceNet devie (slave) you have to open the
Live List. This is described in section Change MAC-ID on page 38.
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7 File, Print and View
7.1 File

7.1.1 Open
An existing project can be opened with File > open.

7.1.2 Save and Save As
When the file name is known, then the configuration can be saved under
the File > Save menu, otherwise the File > Save As menu must be
selected.

7.1.3 Close
The current project can be closed with File > Close.
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7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.

Figure 35: File > Print

Topology the topology of the Bus system.
Bus parameters prints the Bus parameters of the Bus system.
Address table prints the address table of the Master.
Device table prints the device table.
The scope can be given with the Device selection menu point. The
following can be chosen:

•  All

•  From Station address to Station address

•  Selection of a device by means of its description
If no option is selected and the OK button is pressed nothing will be printed
out. It is like clicking the Cancel button.
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7.3 View of the Configuration
The configuration can be displayed in a table. The following tables are
available:

•  Device Table

•  Address Table (Occupation of the process image memory in the
DeviceNet Master )

7.3.1 Device Table
The View > Device Table menu shows the list of all devices that have
been inserted.

Figure 36: View > Device Table
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7.3.2 Address Table
A list of all addresses used in the process depiction is displayed in the View
> Address table menu.

Figure 37: View > Address Table

It is possible to sort the addresses according to Station addresses or data
addresses.
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8 Error Numbers
8.1 Possible Control Error Messages to FB1131 Telegrams

Error Number Description
401 Driver error in the control
402 slot number is not supported by the hardware
403 no coupler at the given slot
404 control not in STOP
405 configuration data invalid
406 coupler still configured by 907 AC 1131-internal PROFIBUS Configurator
407 answer timeout of the coupler

Table 12: Possible Control Error Messages to FB1131 Telegrams
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8.2 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of couplers. The
error number is returned in an answer message. Command messages and
answer messages are used to communicate between the application (e.g.
the Fieldbus Configurator) and the coupler. An example of this
communication is the download of a configuration.
Error Number Description
4 Task does not exist
5 Task is not initialised
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existent
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong licence. The OEM licence of the Fieldbus Configurator

allows only communication to devices that have the same licence inside
38 The data base created by the Fieldbus Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 13: RCS error numbers (answer message) (4..39)
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Error Number Description
40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 Licence code invalid
92 Licence code does already exist
93 All memory locations for licence codes already in use

Table 14: RCS error numbers (answer message) (40..93)
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8.3 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description
100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WritsDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 15: Database Access Error Numbers (100..130)
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8.4 Online Data Manager Error Numbers

8.4.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description
1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviveObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 16: Online Data Manager Error numbers (1000..1018)

8.4.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description
2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout
2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 17: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)
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8.4.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description
2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 18: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

8.4.4 Online Data Manager Subfunctions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Subfunctions of the Online
Data Manager.
Error Number Description
8001 Driver not opened
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 19: Subfunction Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)
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8.5 Data Base Functions Error Numbers (4000 .. 4199)
The following table lists the error numbers of the converting functions.
Error Number Description
4000 File does not exist
4001 Success in comprimizing
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 20: Error numbers of converting functions (4000..4029)
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Error Number Description
4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialisation
4040 Printer not ready
4041 The data base is used from an other function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEintraege
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 21: Error numbers of converting functions (4030..4060)
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Error Number Description
4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initialising of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 22: Error numbers of converting functions (4061..4075)
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Error Number Description
4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialisation not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exists
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 23: Error numbers of converting functions (4082..4199)
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8.6 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description
5000 Function PackLongToByteShort: Not enough space in pvD (Number of

elements greater than reserved memory)
5001 Function PackLongToByteShort: Not enough space in pvD. Detected

during converting of pvS
5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringBumpToByteArray: A character was found, which is

not convertable into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 24: Error Numbers of data base functions (5000 .. 5012)
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9 Appendix
9.1 Extended Device Diagnostic Master

On the following pages the task state structures of DeviceNet Master are
described.

Figure 38: Online > Extended Device Diagnostic

9.1.1 PLC_TASK Common Variables

Figure 39: PLC_TASK Common Variables

Variable Meaning

Version Compiled Hardware
Task State Task State
Handshake Counter Counter for the performed process data handshakes
Handshake Mode This value represents the actual handshake mode between

application and CIF.
0 = Bus synchronous, Device Controlled
1 = Buffered, Device Controlled
2 = No consistence, Uncontrolled
3 = Buffered, Host Controlled
4 = Bus synchronous, Host Controlled
5 = Buffered, extended host controlled

Table 25: PLC_TASK Common Variables
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9.1.2 DNM_TASK Common Variables

Figure 40: DNM_TASK Common Variables

Variable Meaning

Received message number of received CAN-messages
Sent messages number of sent CAN-messages
Receive overruns this counter is incrementing when to many incoming CAN

messages overload the Master. An incremented counter will
always cause lost CAN message data, so it should normally
contain the value 0

Received Overruns our DeviceNet controller has two internal error frame counter
for detected

Low Transmission Quality if the internal DeviceNet controller error frame counter
overstep a defined limit

Bus Off Counter This number will increment when the bus is off or not powered
during bus cycles

Baudrate this value shows numeric the actual baudrate the Master is
working with (, 1 = 500kBaud, 2 = 250Kbaud, 3 = 125kBaud)

Activated bus parameters value 0, the Master has found a configuration data base
coming from FB 1131, value 1, the Master device isn’t
configured and need to be configured via FB 1131

Announced Nodes this value represents the number of found device data sets in
the download database

Wrong parameters this value indicates, if the Master has detected errors in a
device data set which was a containment of the actual
downloaded database. For each Slave device that has a
wrong entry the counter is incremented by 1

Hard Transmission Aborts this value indicates transmission aborts by the Master

Table 26: DNM_TASK Common Variables
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9.1.3 DNM_TASK Device running states

Figure 41: DNM_TASK Device running states

To handle the Slave devices in their different states the Master device has
a Slave device handler running, where each Slave device has its own
actual running state. FB 1131 interprets what the actual state of each Slave
and enters these states on the screen in textual form.

9.1.4 DNM_TASK Global state field
See in section Global State Field at page 41.

9.1.5 DNM_TASK Communication error

Figure 42: DNM_TASK Communication error

For each Slave device the Master has an internal online error buffer. FB
1131 interprets the actual error condition and prints it on the screen in
textual form.
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9.1.6 DNM_TASK Receive queue

Figure 43: DNM_TASK Receive queue

The Receive Queue is used to monitor the receive transmission queue of
the internal CAN controller.
Variable Meaning

bRear A pointer to where the next message will be dequeue from the
queue body

bFront A pointer to where the next message will be stored
bInner The actual number of stored messages

Table 27: DNM_TASK Receive queue
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9.1.7 DNM_TASK Transmit queue

Figure 44: DNM_TASK Transmit queue

The Transmit Queue is used to monitor the transmission queue of the
internal CAN controller.
Variable Meaning

bRear A pointer to where the next message will be dequeue from the
queue body

bFront A pointer to where the next message will be stored
bInner The actual number of stored messages

Table 28: DNM_TASK Transmit queue
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9.1.8 DNM_TASK DeviceNet command counter

Figure 45: DNM_TASK DeviceNet command counter

The DeviceNet command counters dialog box shows a listing of the
DeviceNet specific commands used by the controller and there associated
usage count.
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9.1.9 DNM_TASK Timeout counter

Figure 46: DNM_TASK Timeout counter

The Timeout Counter shows the number of timeouts for each Slave device
configured in the DeviceNet bus system.

9.1.10 DNM_TASK Init counter

Figure 47: DNM_TASK Init counter

The Device init counter is incremented whenever the Slave device is
initialized. Normally the counter must show the value 1 for each configured
Slave, but if a Slave is detected as inactive during the diagnostic
procedure, then the Master tries to reinitialise the Slave again. If this
happens the Slave init counter is incremented by a value of 1. So values
larger then 1 are an indication for communication error to the corresponding
Slave.
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1 Overview FB 1131
1.1 Main Functions

The main functions of the InterBus Fieldbus Configurator are:
Function Section Short Description

Overview Communication Types Overview communication types and
description of the configuration steps

Configuration

Automatic Network Scan Scans the network
Diagnostic Functions Diagnostic functions, Debugger,

Global State Field etc.
Diagnostic

User Data Transfer I/O Monitor, I/O Watch, PCP Monitor,
Message Monitor

Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: FB 1131 Main Functions
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1.2 Properties
FB 1131 is an universal Fieldbus Configurator
This means you can configure the most important fieldbus systems like
PROFIBUS, InterBus and DeviceNet with the same tool.

FB 1131 is a global Fieldbus Configurator
You configure all devices with one tool. FB 1131 checks the dependencies
between the devices. FB 1131 only allows configurations that make sense.
In case of doubt FB 1131 will give you a warning.

FB 1131 documents your Fieldbus system
After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the detail of one
device.

FB 1131 uses standardized configuration files
Some protocols support standardized files containing information about all
features and limitations of the Slave device. FB 1131 uses these files for
the configuration.

FB 1131 is a diagnostic tool
After the configuration you can switch FB 1131 into the diagnostic mode.
You can watch all status information of couplers, see protocol dependent
diagnostic information. In this case a Slave is not operating correctly will be
displayed in a different colour.
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2 Installation and Licensing
2.1 System Requirements

•  PC with 486-, Pentium processor or higher

•  Windows 95/98/ME, Windows NT 4.0/2000/XP

•  Free disk space: 30 - 80 MByte

•  CD ROM drive

•  RAM: min. 16 MByte

•  Graphic resolution: min. 800 x 600 pixel

•  Windows 95: Service Pack 1 or higher

•  Windows NT: Service Pack 3 or higher

•  Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the 907 AC 1131 CD in the local CD ROM drive. If "Autorun" is
enabled on the PC the CD menu will start automatically. Otherwise it is
started by starting the file "CD_Menu_Vxx.exe" in the root directory of the
CD. For example by the menu Start > Run and entering
"[X:]\CD_Menu_Vxx.exe" ([X] is the CD rom drive and Vxx stands for the
version number).
You reach the Installation menu of the CD by operating the Installation
907 AC 1131 Vxx button.

With the menu Notes for Installation you get a description of the
innstallation and the components of the 907 AC 1131, the programming
software, the Fieldbus Configurator 907 FB 1131, OPC Server.

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation of the Fieldbus Configurator 907 FB 1131!
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3 Getting Started – Configuration Steps
3.1 Overview Communication Types

Select from the following the communication that you want to use. The
configuration steps are described in the given section.

Communication Device Device Described in section Page
InterBus (I/O) ABB

InterBus
Master

Any
InterBus
Slave

Configuration InterBus Master to any InterBus Slave 12

InterBus PCP ABB
InterBus PCP
Master

Any
InterBus PCP
Slave

Configuration InterBus PCP Master to any InterBus PCP
Slave

13

Table 2: Overview Communication Types
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3.2 Configuration InterBus Master to any InterBus Slave
The following table describes the steps to configure a InterBus Master to
any InterBus Slave as it is typical for many cases.

# Action Menu in the Fieldbus Configurator Detail information in section Page
1 Create a new project File > New > InterBus Setting up the InterBus

Configuration
15

2 Choose InterBus Master Insert > Master Insert Master 16
3 Choose InterBus Slave Insert > Remote Bus Branch Interface

or
Insert > Local Bus Branch Interface or
Insert > Remote Bus Device or
Insert > Local Bus Device

Insert InterBus Slave 18

4 Assign the input and output
modules

5 Assign the offset addresses

Mark the Slave (left Mouse click), then
Settings > Slave Configuration

Slave Configuration 20

6 Set device assingment, if no
automatic assignment has
occured

Mark the Master (left mouse click), then
Settings > Device Assingment

Gateway Driver 29

7 Save project File > Save Save and Save As 55

8 Download Mark the Master (left Mouse click), then
Online > Download

Downloading the
Configuration

37

9 Start Debugger Mark the Master (left Mouse click), then
Online > Start Debug Mode

Debug Mode (InterBus
Master)

43

10 Device diagnostic Mark the Slave (left Mouse click), then
Online > Device Diagnostic

InterBus Slave Device
Diagnostic

44

11 Stop Debugger Online > Stop Debug Mode Debug Mode (InterBus
Master)

43

12 Global Diagnostic Mark the Master (left Mouse click), then
Online > Global State Field

Global State Field 46

Table 3: Steps for Configuration InterBus Master to any InterBus Slave
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3.3 Configuration InterBus PCP Master to any InterBus PCP
Slave

The following table describes the steps to configure a InterBus PCP Master
to any InterBus PCP Slave as it is typical for many cases.

# Action Menu in the Fieldbus Configurator Detail information in section Page
1 Create a new project File > New > InterBus Setting up the InterBus

Configuration
15

2 Choose InterBus PCP Master Insert > Master Insert Master 16

3 Choose InterBus PCP Slave Insert > Remote Local Bus Device Insert InterBus Slave 18

4 Set InterBus PCP Parameter Mark the Slave (left Mouse click), then
Settings > Communication Reference
List (CRL)

Communication Reference
List (CRL)

23

5 Set objects Mark the Master (left Mouse click), then
Settings > Object Directory

Object Directory 27

6 Set device assingment, if no
automatic assignment has
occured

Mark the Master (left mouse click), then
Settings > Device Assingment

Gateway Driver 29

7 Save project File > Save Save and Save As 55

8 Download Mark the Master (left Mouse click), then
Online > Download

Downloading the
Configuration

37

Table 4: Steps for Configuration InterBus PCP Master to any InterBus PCP Slave
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4 Configuration of InterBus with FB 1131
4.1 Setting up the InterBus Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Choose the InterBus. If only the
InterBus fieldbus system is installed, the configuration window will open
directly.
The name of the configuration file can be allocated when the configuration
is finished or with File > Save As.

4.2 EDS Files
EDS (Electronic Data Sheet of a device) files contain and describe the
functions and characteristics of InterBus devices. All the available EDS files
together from the device database.
When the Fieldbus Configurator is started, the program automatically
retrieves all the EDS files stored in the EDS directory. The device names
for example are placed into an internal list. During the configuration, the
device-specific data is retrieved directly from the EDS files.
If an EDS file for a device is needed which does not appear in the selection
list, you can generate with the Fieldbus Configurator in the menu Tools >
EDS Generator an EDS file (see section EDS Generator on page 64). If an
EDS file was already generated then the EDS file can be copied into the
EDS directory with File > Copy EDS. Another possibility is to copy the EDS
file into the FB 1131 EDS directory with the Windows Explore and then
retrieve the EDS files into the EDS directory with Settings > Path and OK.
The EDS files can be viewed with the Tools > EDS Viewer menu.

Figure 1: EDS files and bitmaps directory

The EDS files for ABB STOTZ-KONTAKT devices as well as devices from
other manufacturers are already included in the scope of delivery and
installed. The files are based on no standard and couldn't obtained from
other manufacturers because of this reason.
The EDS directory is adjustable. In order to alter the directory from the
default setting in another directory, use the Settings > Path menu. All EDS
files must be placed in this directory.
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4.3 Master

4.3.1 Insert Master
In order to insert a Master into the configuration, choose the Insert >
Master menu, in order to open the selection window, or click on the
symbol:
Insert > Master

Figure 2: Insert > Master Symbol

The window opens from which exactly one Master can be chosen. After this
selection the chosen master is at the first position in the configuration
window.

Figure 3: Insert > Master

This example shows a 07 KT 97-IBM. It gets no Station address but the
standard description Master. This description is changeable in this window.
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4.3.2 Replace Master
If a Master already exists in the configuration and should be replaced
against another Master, you first have to set the focus on the Master (left
mouse click at the Master) and then choose the menu Edit > Replace. In
the opened window appears the question if the Master should be replaced.

Figure 4: Security question replace Master

If you click the button Yes a new window opens, where you can replace the
Master against the existing Master.

Figure 5: Edit > Replace Master

In this window you select the Master you want by clicking on it and then
click the Add button to put the Master to Selected devices. With OK you
confirm the selection and the Master will be replaced.
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4.4 InterBus Slave

4.4.1 Insert InterBus Slave
In order to insert an InterBus Slave into the configuration, choose the Insert
> Remote Bus Branch Interface, Insert > Local Bus Branch Interface,
Insert > Remote Bus Device, Insert > Local Bus Device menu to open
the selection window
or
click on the symbol:
Insert > Remote
Bus Branch
Interface

Insert > Local Bus
Branch Interface

Insert > Remote
Bus Device

Insert > Local Bus
Device

Table 5: Insert an InterBus Slave

The mouse pointer automatically changes to the Insert Slave pointer. First
the a mouse pointer for “no insert position” appears.
Mouse pointer “no insert position”

Table 6: Mouse pointer “no insert position“

Possible insert positions are displayed with a coloured circle . If you
move the mouse pointer on the coloured circle, it changes into these
symbols:
Mouse pointer for
Insert > Remote
Bus Branch
Interface

Mouse pointer for
Insert > Local Bus
Branch Interface

Mouse pointer for
Insert > Remote
Bus Device

Mouse pointer for
Insert > Local Bus
Device

Table 7: Mouse pointer for insert an InterBus Slave
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Click on the position where the Slave is to be inserted.

Figure 6: Possible insert positions of devices with identification by a coloured circle

The window opens where one or more Slaves could be selected.

Figure 7: Insert > Remote Bus Device

The list on the left displays for selection all the Slave devices whose EDS
files have been put in the EDS directory. A filter can be used to limit the
selection list of the manufacturer. Further information on a Slave is shown
below the selection list (Available Slaves) when it is selected (one mouse
click). Apart from the manufacturer name and the description especially the
ID-Code, the Length-Code, the file name and the file revision are given.
The Slave appears on the right-hand list with a mouse click or with the Add
button. All devices in the right-hand list are assigned to the current insert
point that is also shown in this window. If the Slaves in the right-hand list
are chosen one after the other (a mouse click), then every Slave can be
assigned a name in the Description field.
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4.4.2 Slave Configuration
First click the symbol of the Slave with the left mouse button and then
choose the Settings > Slave Configuration menu.

or
open the Slave configuration window by double clicking on the Slave
device.
The Slave-specific configuration is carried out in this window. Here, the
modules and their addresses are assigned in the process data memory in
the Master. Note that the address must agree with that in the PC
application.

Note: The information of the offset addresses refers to the addressing of
the data in the Master! The address information does not refer to the
addressing of the data in the Slave! The Slave organizes its own data
addressing.

Figure 8: Settings > Slave Configuration
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The device-specific configuration is carried out here. These are in detail:

•  a Description of the device,

•  activate or deactivate the Slave in the actual configuration,

•  configurating the Process Data Addressing (see following
description)

•  selecting an other device without leaving the window

•  changing the settings for the Parameter Data Channel with the PCP
Config... button, if the device is PCP capable. You first have to set
the focus on the Slave (left mouse click) and select the menu Edit >
Replace. The Parameter Data Channel (PCP is described in an own
section on page 23.

If Activate device in actual configuration is selected, the Master carries
out an data exchange to this device. Is this setting deactivated, then the
master doesn't carry out a data exchange to this device. In both cases
however the memory in the process image is used respectively reserved in
the Master.
The I/O addresses can be automatically assigned by FB 1131 or can be
allocated by the user. For this purpose you have to activate (Auto
addressing) and deactivate (manual addressing) respectively it in the menu
Settings > Global Settings the Process Data Auto Addressing. When
the Auto Addressing is active, then the addresses of the Slaves will be
allocated in their physical order by FB 1131. The addresses can be viewed
and checked in the View > Address Table. When the Auto addressing is
deactivated, then only the address 0 is shown in the I Addr or O Addr and
must be overwritten by the user.
In the state of auto configuration is shown if the Process Data Addressing
are placed automatically by FB 1131 (selected) or manual by the user (not
selected).
At actual device you can change to another Slave device without leaving
the window.
Individual InterBus Slave devices can be combined to groups with the
group number. This is optional. In the field group number you can

•  indicate only one number (from 1 to 255)

•  also indicate an alternative number (from 1 to 255) apart from the
group number in the course of which group number and alternative
have to be separated with a hyphen. For example: 2-4 (group 2,
alternative 4).

The group number is used to switch devices of one group on and off
together.
The alternative number is used to switch on one or another alternative,
however not more than one alternatives.
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4.4.3 Replace Slave
To replace a Slave device in the configuration against another you first
have to set the focus on the Slave (left mouse click at the Slave) and select
the menu Edit > Replace. In the opened window the question appears if
the Slave device should be replaced.

Figure 9: Security question replace device

If you answer this question with Yes, the following window appears where
you can select an other Slave device.

Figure 10: Edit > Replace Device

In this window you can choose the device you want by clicking on it. By
clicking the Add button  the Slave is shown under Selected devices. With
OK you confirm the selection and the Slave will be replaced.
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4.4.4 Parameter Data Channel (PCP)
The PCP Channel offers the user data exchange with the functions read
and write.
The direction of user data is shown in the following table:
Function Direction of user

data

Read From server to client
Write From client to server

Table 8: PCP Channel: direction of user data for reading and writing

Before you are able to use the functions read and write you first have to

•  Set logic connection (Communication Reference List, CRL) in both
devices (see section Communication Reference List (CRL) at page
23) as well as

•  Set objects in the sever (see section Object Directory at page 27)
With the Download of the configuration into the ABB InterBus Master the
Communication Reference List is loaded into the Master.

4.4.4.1 Communication Reference List (CRL)

Communication between two PCP devices is only possible, when a
communication relation is configured between both devices (each device
has to be PCP capable). This means both devices get information how to
communicate with the other device. This information is saved in a data
base, called Communication Reference List (CRL).
The logic connection (Communication Reference CR) can be set from the
view of the Master or from the view of the Slave.
From the view point of the Master:
At first you have to mark the Master (left mouse click) and then select the
menu Settings > Communication Reference List...
or
right mouse click on Master and click on Communication Reference
List...
A new Communication Reference will be added in the CRL Table with Add
or Insert.
If a new entry is added or insert into an empty CRL table, this entry gets the
description CR 2 because CR 1 is used internally.
In Remote address / device you can select the remote station for the
current Communication Reference.
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Note: The number of the Communication Reference is the key for the
communication.

The difference between CR Add and Insert is:
With the button Add you insert the new entry at the end of the list. With
Insert the new entry is fitted in at the current position and the other CR in
the list move one position forwards.
The following figure shows the typical settings for Max. SCC, Max. RCC,
Max SAC, Max RAC, the Client Services, the Server Services, the Acyclic
Control Interval (ACI) as well as for  the Max. PDU Size Send and Max.
Size Receive.

Figure 11: Communication Reference List from the view of the Master

Note: Please note that the permissible settings in the instruction of InterBus
Slave device (configuration instructions).

Note: Please note that these settings also exist in the communication
partner device!
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From the view point of the Slave:
At first you have to mark the Slave (left mouse click) and select the menu
Settings > Communication Reference List...
or
right mouse click on the Slave and click on Communication Reference
List...
or
double click on the Slave and press in the window Device Configuration
the button PCP Config... In the following window PCP Configuration you
have to choose Device CRL. Finally confirm with the OK button.

Figure 12: Selection of Master or Device CRL

A window with the CRL of the selected Device appears.
You have to carry out the settings as already described in this section.
These settings are from the view point of the Slaves.
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Figure 13: Communication Reference List from the Slaves point of view
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4.4.4.2 Object Directory

The Slave expects a description about the objects, which are available in
the user application. For this you have to create an Object Directory. All
configured objects are shown in the window Object Directory. Objects can
be added or removed and their specific property can be set.
First mark the Slave (left mouse click) and select the menu Settings >
Object Directory
or
right mouse click on the Slave and select Object Directory.

Figure 14: Object Directory single element

Insert a new object into the Object Directory with Add or Insert.
•  General

The Objectindex describes a unique number which is assigned to a
definite data object inside the Object Directory of the Slave. You can
save a short text as a description to each object. Here appears a
standard object  with the index 1000h.

•  Data Type
The Data Type of an object is decisive for it's length. Here you can
select different Data Types: Boolean, Int8, Int16, Int32, Uint8, Uint16
and two string Data Types (ASCII in OCTET), which require
information for it's length.

•  Object Type
Objects can be distinguished according to single element or field.
Single element Types (Standard Object Types or Single Element)
are for example Integer-Variable. On the other hand field Object
Types are Arrays. Arrays need the information about the number of
the available Elements.
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Figure 15: Object Directory Array (field)
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5 Settings
5.1 Gateway Driver

The Gateway Driver terminies how the Fieldbus Configurator
communicates with the device. This is set in the Device Assignment which
can be opened with the menu Settings > Device Assignment.

Figure 16: Settings > Device Assignment

After the selection of the Gateway channel or clicking the Connect button
FB 1131 tries to set up a connection to the selected controller. If the
connection was successful the configurable couplers are shown in the field
Device Information. The desired coupler is selected by clicking on the field
next to the name of the coupler and confirming with the OK button.
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By clicking at the Gateway Configuration button a new window appears
where the Gateway channel can be selected or a new Gateway channel
can be configured.

Figure 17: Configure Gateway

To confirm the Channel selection click at the OK button.
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5.2 Bus Parameters
The Bus Parameters can be displayed with the menu Settings > Bus
Parameters.

Figure 18: Settings > Bus Parameters

Attention: The alteration of Bus Parameters can cause communication
faults.

Note: The displayed Bus Parameters are offline values. The Bus
Parameters are used after the download of the configuration to the device.

The Baud rate is only adjustable up to 500kBaud. We reserve the right for
extensions.
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The Network Supervision Parameters serve for adjustment of error
tolerance in the case of data cycle errors. The Master supervises every
data cycle. If an error happens this data cycle is repeated after an
identification cycle was executed.
•  Maximum try time to execute one valid, faultless process data

cycle before network is resetted and rescanned. This parameter is
a time in the multiples of 8 milliseconds, in which the master tries to
transmit a disturbed data cycle error free N times. After a data cycle
error the master always starts an identification cycle, in order to
recognize all available Slave devices, before the same data cycle is
restarted. This procedure is repeated until the data cycle is
transferred without an error and is however terminated when the
maximum configured time interval exceeds its limit. At least then the
network is resetted. As a function of the Behaviour in case of
defective Slave device and Network Scan Time Interval if devices
missing the master stops the entire communication or tries to
initialize the network again.

•  Maximum number of bundled process data cycle errors before
network is resetted and rescanned. Sometimes it is possible, e.g.
by an EMC disturbance within the InterBus network that a whole
sequence of successive data cycles are destroyed. The maximum
permissible number of direct successively disturbed cycles are
defined here. A value of 20 is the presented value. If this value is
exceeded, the master as a function of Behaviour in case of
defective Slave device  and Network Scan Time Interval if
devices missing stops entire communication or tries to reinitialize
the network again.

•  Maximum number of error detecting network scans after a
defective process data cycle, before the process data cycle is
retried again. If a data cycle error occurs, the master starts
automatically an identification cycle, in order to determine the source
of error in the network. If this following identification cycle is executed
also incorrect too, the master tries to repeat it according the number
indicated here, before it reacts in accordance to the Behaviour in
case of defective Slave device and Network Scan Time Interval if
devices missing.
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The Behaviour in case of defective Slave device determines the
procedure of the Masters, if a Slave is detected as missed during run time
and during the first network start up phase
•  Try to hold the rest of the network operative, if one device is

defective. The master does not consider the status of the attached
Slaves and the resetting of the network in the case of an error is
disabled. Depending on the Network Scan Time Interval in case of
missing devices, the master tries to get all missing devices
reoperative by rescanning the network cyclically.

•  Reset the whole network and stop the communication, if one
device is missing. The master stops entire network communication
and resets the entire network, if it detects a missing Slave device
during the first network scan or during the data exchange.

•  Reset the whole network and stop the communication, if one
device is reporting peripheral error. The master stops the entire
communication and resets the whole network, if at least one Slave
device is reporting an InterBus specific module error. Modules
reporting such an error are indicating thereby e.g. a short-circuit at an
output or undervoltage.

•  Reset the whole network and stop the communication, if one
device is reporting peripheral error or device is missing. The
master stops entire communication and resets the network, if it
detects a missing Slave during the first network scan or during the
data exchange or if at least one Slave device indicates an InterBus
specific module error.

Network scan time interval in case of missing devices
This parameter enables or disables the scan cycles in those cases a
missing Slave device was detected. If the value is configured to 0, this
function is deactivated.
The first network scan cycle, which is executed by the master directly after
the initialization, is independent of this parameter and is always executed.
Values unequal of 0 configure a cycle time in the multiples of 800 msec.
Please note that the cyclic data exchange during this rescan is interrupted,
but the initially left and original process data during this cycle are remaining
at their old values.

5.2.1 Slave Configuration
The Slave configuration is described further above in the section
Slave Configuration on page 20.
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5.3 Project Information
If the user creates his own project, the project information can be typed in
into the Settings > Project Information menu. Anybody can then read this
entry when this menu is opened.

Figure 19: Settings > Project Information

By clicking the OK button the Project Information is saved.

5.4 Path
When the Settings > Path menu is selected, then the search path for EDS
files is displayed.

Figure 20: Settings > Path

If you click the OK button all EDS files are read in.
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5.5 Language
Choose the Settings > Language menu and the following window opens:

Figure 21: Settings > Language

Here can be set the language of the Fieldbus Configurator. Select the
desired language and confirm the entry with the OK button.

A message appears that the Fieldbus Configurator must be started again in
order to activate the selected language. Please carry this out.
After restarting the Fieldbus Configurator, the language will have changed
to the one selected.

Note: Up to now not all languages are available for all fieldbuses!
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6 Online Functions
6.1 Introduction

In this section, all the functions that directly influence InterBus devices, are
presented.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched ON or OFF.

6.2 Online to the Coupler

6.2.1 Downloading the Configuration
First, the desired device must be chosen for downloading by a left mouse
click on the symbol of the device.
In order to transfer the configuration, a transfer download to the devices
must be carried out on the Online > Download menu. A warning will
appear that the communication on the InterBus will be interrupted. This
warning must be confirmed.

Figure 22: Security question before download

Attention: The download overwrites the configuration in the device.

Figure 23: Online > Download

Before the Download is executed, the configuration is checked by the
Configurator. The most common cause of error is overlapping of addresses
in the process data image. This can be checked by calling up the address
table with the View > Address Table menu.
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6.2.2 Firmware Download
If you want to carry out a Firmware download, act as follow: First the
desired device for Firmware downloading must be chosen in that the
symbol of the device is selected with a left mouse click. Then, call up the
Online > Firmware Download menu. Select the new Firmware and
retrieve it with Download into the device. The Firmware is now
downloaded.

Figure 24: Online > Firmware Download

6.2.3 Firmware / Reset
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then the Online > Firmware / Reset menu must be
called up and the name and the version of the Firmware are displayed.

Figure 25: Online > Firmware / Reset

The device can be resetted with the Reset button.
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6.2.4 Device Info
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Device Info menu in order
to obtain further information on the selected device.
The manufacturer date, the device number and the serial number of the
device is read out and shown.

Figure 26: Online > Device Info

6.2.5 Read Project Information
With Online > Read Project Information can be read out the project
information from the device.
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6.3 Automatic Network Scan
This function scans the network structure. During the scan it will be
detected which devices are connected to this InterBus. Therefore the
following steps are necessary:

•  Create a new project: Select the menu File > New and InterBus.

•  Select the Master: Select the Master from the menu Insert > Master.
•  If the Master isn't initialized you need to make a download first. To

make this download select the menu Online > Download.

•  Scan the network: Select the menu Online > Automatic Network
Scan. Hereby the Length and ID code as well as the installation
depth of all users attached at the network are determined.

Figure 27: Online > Automatic Network Scan (security question)

Answer this question with Yes, if the connected InterBus network should be
scanned. Answer this question with No, if this functions should not be
performed.

Figure 28: Online > Automatic Network Scan (During the Scan)

All buttons are grey during the network scan.
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Figure 29: Online > Automatic Network Scan (After the Scan)

6.3.1 Automatic Configuration
If you activate the button Automatic Configuration, the following safety
question appears.

Figure 30: Online > Automatic Network Scan > accept configuration

Answer the question with Yes, if the read in structure is to be taken over as
configuration. Answer the question with No, if the old configuration is to be
maintained.
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6.4 Start/Stop Communication
First the desired device must be chosen with a left mouse click on the
symbol of the device. The communication between InterBus Master and
InterBus Slave can be manually started or stopped. In order to do this
select the Online > Communication start or Online > Communication
stop menu.



FB 1131 Fieldbus Configurator InterBus Online Functions  ••••   43

Copyright •  ABB STOTZ-KONTAKT GmbH •

6.5 Diagnostic Functions

6.5.1 Debug Mode (InterBus Master)
Starting from the Master select the Online > Start Debug Mode menu. The
Fieldbus Configurator cyclically reads out the status of the network
communication on the device and the individual condition of the devices.
To end the Debug Mode select the menu Online > Stop Debug Mode.

6.5.1.1 Debug Window

When started the debug session the configuration window changes into the
debug window. The devices and the line between them are displayed in
green or red colour depending on the established network communication.

Figure 31: The Debug Window

If a diagnostic information is available for a specific device, next to the
device icon the text Diag appears in red. To get further device specific
diagnostic information then doubleclick on the device itself or set the focus
to the device and select Online > Device Diagnostic.
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6.5.1.2 InterBus Slave Device Diagnostic

After the debugger was started from this time FB 1131 requests the status
of all devices from the Master. If there is an error on a device the bus line to
this Slave is drawn in red colour otherwise it is green. This information is
displayed closer if you click with the mouse onto the corresponding device
in debug mode.
To activate the debug mode you have to mark the Master and select the
menu Online > Start Debug Mode. Then set the focus at the Slave and
with the menu Online > Device Diagnostic you activate the InterBus
device diagnostic. To end the Debug Mode you have to mark the Master
again and select the menu Online > Stop Debug Mode.

Figure 32: Online > Device Diagnostic (InterBus standard diagnostic)
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The individual bits in the Device Diagnostic have the following meaning:
Bits in the Device
Diagnostic

Meaning

No answer The station is configured but missing at the network.
Please you check the cable connection between the
master and the Slave device.

Error buffer overflow An error can occur at each Slave device during operation.
These errors are stored in an internal buffer, which can
take up 50 error registrations per Slave device . This bit is
set, if the buffer overflows.

Peripheral device error The Slave device  announces a peripheral device error.
That can be e.g. a short-circuit at the device outputs or an
undervoltage.

Configuration error The ID code or the Length Code of the Slave device does
not correspond with the configured ID code or length code.

Reconfiguration The device announces a reconfiguration request.
Error interface 1 An error on the outgoing interface 1 was detected.
Error interface 2 An error on the outgoing interface 2 was detected.
Deactivated The Slave device is deactivated in the current

configuration and does not participate in the data
exchange.

Number of CRC errors This counter accumulates all detected check sum errors.
Length-/Ident-Code The real length code and ID code of the Slave device are

displayed here.
Online error The currently detected errors are displayed here.
Number of error registrations This value indicates the number of entries in the internal

error buffer.
Error table This table shows the detected errors in the occurred order.

Table 9: Meaning of the bits in the Device Diagnostic
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6.5.2 Global State Field
With the menu option Online > Global State Field opens a window in that
cyclically Statistic about the bus status and attached devices to be output.

Figure 33: Online > Global State Field

The first row displays the main state of the Master. It can have the state
OPERATE or STOP.
The next row displays individual bus errors. A pending error is displayed
with a red field. The meaning of the individual abbreviations is described in
the following.
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Status Bits Meaning

I2ER INTERFACE-2-ERROR: If this bit is set at least one remote bus interface
(called outgoing interface 2) of a Slave device was detected during the ID
scan, which has produced a timeout after it was opened in this session. This
error can only occur either at InterBus branch interface or at remote bus
devices, because both are having the outgoing interface 2 to connect it to
the next remote bus device. If more defective interfaces were detected at
the same time, the value shows the physically nearest Slave device to the
master in the InterBus ring.

I1ER INTERFACE-1-ERROR: If this bit is set at least one local bus interface or
remote bus branch interface (called outgoing interface 1) of a Slave device
was detected during the ID scan, which has produced a timeout after it was
opened in this session. This error can only occur at InterBus branch
interfaces, because these are the only components which have an interface
1 to manage InterBus branching. If more defective interfaces were detected
at the same time, the value shows the physically nearest Slave device to the
master in the InterBus ring.

NRDY HOST-NOT-READY-NOTIFICATION: indicates if the host program has set
its state to operative or stop. If this bit is set the host program is not ready to
communicate.

EVE EVENT-ERROR: The used InterBus master chip has detected at least one
transmission error. The number of detected events are counted in Number
of defective process data cycles and the error Number of network
reinintialisations. The bit will be set when the first event was detected and
will not be cleared any more and remains set then.

PRHL PERIPHERAL-ERROR: Some InterBus modules have the capability to
indicate if they have detected low power or a short circuit in the in the
external periphery. If at least one module reports this error it is shown in this
bit. If all errors have disappeared, the bit will be released.

NEXC NON-EXCHANGE-ERROR: An activated bit indicates that at least one of
the configured Slave device is not operational because of an configuration
fault or simply because it's not present in the network.

ACLR AUTO-CLEAR-ERROR: This bit is set, when the master stops the
communication to all handled Slave devices because of missing Slave
devices. Before doing this the Master sets all output values of the left Slave
devices to the save zero condition. The behaviour, if the master shall shut
down or not, when it losts the contact to at least one device, is configurable
in FB 1131 configuration tool or in the bus parameter download procedure.
After the master has shut down only a warm- or coldstart (reset) can
reactivate the communication again.

CTRL CONTROL-ERROR: Configuration error or heavy runtime error. Some of
them can occur during startup procedure of the master. For example if the
InterBus controller Ix1 of the master card do not respond or the
configuration of FB 1131 has inconsistencies.

Table 10: Meaning of collecting status bits in the Global State Field

Further displays are:
Error at device address and Corresponding error event indicate the
address of the faulty station and the actual error in plain text. Statistical bus
information indicates the number of the detected bus short-circuits an
rejected telegrams.
Devices specific status bits:
These display the parameterized devices, the active devices or the
devices with diagnostic according to the activated button. A pending
diagnostic information can be received by a double click on the respective
number of the station.
This display is cyclically updated.
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6.5.3 Extended Device Diagnostic
The Extended Device Diagnostic helps to find bus errors and configuration
errors when the FB 1131 menu functions are of no further help.
First select the device with a left mouse click on the symbol of the device.
Then select the Online > Extended Device Diagnostic menu.

This menu opens a list of diagnostic structures. These contain online
counters, status information and parameter information:

Figure 34: Online > Extended Device Diagnostic

6.5.3.1 Extended Device Diagnostic for the InterBus Master
IBM_TASK: InterBus Administration

ALPMLIPD: Application interface (PCP Channel)

Task / Task State Page

PLC_TASK Common Variables 79
IBM_TASK Common Variables 80
IBM_TASK Device Running States 82
IBM_TASK Global State Field 82
IBM_TASK Communication Error 83
IBM_TASK Extended InterBus Status 84
IBM_TASK PDL Requests 85
IBM_TASK PDL Confirmation 86
IBM_TASK PDL Indication 87
IBM_TASK Data Cycle Status 87
IBM_TASK Scanned ID Codes 89
ALPMLIP Common Variables 90
ALPMLIPD ALI Information 92
ALPMLIPD PMS Information 93
ALPMLIPD LLI Information 94

Table 11: Extended Device Diagnostic for the InterBus Master
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6.5.4 Statistic Information
In the window Statistic Information a long-term recording of the InterBus
communication can be activated and deactivated. Occurred error
messages can be stored into a log file.

Figure 35: Online > Statistic Information

Under log file the path and the name of the file can be changed. The
recording is started by clicking the Start button.
If the Master is connected, the information about data cycles, ID scan
cycles, transfer errors and the transfer rate are displayed online.
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The following figure shows a faultless communication.

Figure 36: Online > Statistic Information (faultless)
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The following figure shows an error message to a data transfer with an
occurred communication error. The displayed figure shows an error
message of an cable interruption (cable disconnected and connected
again).

Figure 37: Online > Statistic Information (error displayed)
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6.6 User Data Transfer
The following table shows test functions with user data transfer and the
usability for

•  InterBus Master devices

•  InterBus Slave devices

User data transfer function Usage Usable with ABB
InterBus Master
devices

Usable with ABB
InterBus Slave devices

PCP Monitor Read or write data (objects) Yes No

Table 12: Overview User Data Transfer
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6.6.1 PCP Monitor
With this function InterBus services based on the current configuration, can
be carried out.
First select the Master with a left mouse click on the Master device. Then
select Online > PCP Monitor.

Figure 38: Online > PCP Monitor

The Read or Write service on the desired Object can be selected by
means of the corresponding Communication reference and can be
activated via the Send button. When writing, the data must be entered in
the Value field. On the left side, the acknowledgement, or when reading,
the received data are displayed.

Note: Only Client functions are available in this version. Server functions
are not supported.
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Positive result:

Figure 39: Online > PCP Monitor (positive result)

Negative result:

Figure 40: Online > PCP Monitor (negative result)
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7 File, Print, Edit and View
7.1 File

7.1.1 Open
An existing project can be opened with File > Open.

7.1.2 Save and Save As
When the file name is known, then the configuration can be saved under
the File > Save menu, otherwise the File > Save As menu must be
selected.

7.1.3 Close
The current project can be closed with File > Close.
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7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.

Figure 41: File > Print

Topology the topology of the Bus system.
Bus parameters prints the Bus parameters of the Bus system.
Address table prints the address table of the Master.
Device table prints the device table.
The scope can be given with the Device selection menu point. The
following can be chosen:

•  All

•  From station number to Station number

•  Selection of a device by means of its description
If no option is selected and the OK button is pressed nothing will be printed
out. It is like clicking the Cancel button.
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7.3 Edit

7.3.1 Cut, Copy and Paste
With Edit > Cut and Edit > Copy you put the cut/copied Slave device with
its settings and configuration (only not the description of the device) in the
Clipboard and with Edit > Paste it can be insert.
The difference between Cut and Copy is:
With the menu option Edit > Cut you move a Slave device from one point
in the configuration to another. With the menu option Edit > Copy you
duplicate an existing Slave device.
If you select Edit > Cut a security question appears.

Figure 42: Security question cut device

If you answer this question with Yes the Slave device is cut and stays in the
clipboard.
When you select Edit > Paste the device can be insert again at the position
you want.

Possible insert positions are displayed with a coloured circle . If you
move the mouse pointer over this circles it changes into one of these
symbols dependent on which Slave device was cut or copied.
Mousepointer - possible insert positions

Remote Bus
Branch

Interface

Local Bus
Branch

Interface

Remote Bus
Device

Local Bus
Device

Table 13: Mousepointer - possible insert positions
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Figure 43: Paste a Slave device in the configuration

Click on the position where the Slave is to be inserted. A window opens
where the cut/copied Slave device can be selected.

Figure 44: Edit > Paste Insert Device from Clipboard

With the OK button the Slave will be insert.
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7.3.2 Delete
To delete the Master or a Slave device you have to have to mark this
device and then select the menu Edit > Delete. Before FB 1131 deletes the
Master or a Slave a security question appears.

Figure 45: Security question delete device

Note: When you delete a device the settings and the configuration of this
device get lost.

7.3.3 Replace
With the menu Edit > Replace the Master or a Slave device can be
replaced. How to replace the Master look in section Replace Master at
page 17. If you want to replace a Slave device look in section Replace
Slave at page 22.
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7.4 View of the Configuration
The configuration can be displayed in a table. The following tables are
available:

•  Device Table

•  Address Table (Occupation of the process image memory in the
InterBus Master )

7.4.1 Device Table
The View > Device Table menu shows the list of all devices are used in
the configuration.

Figure 46: View > Device Table



FB 1131 Fieldbus Configurator InterBus File, Print, Edit and View  ••••   61

Copyright •  ABB STOTZ-KONTAKT GmbH •

7.4.2 Address Table
A list of all addresses used in the process data image is displayed in the
View > Address table menu.

Figure 47: View > Address Table

It is possible to sort the addresses according to Slave numbers or data
addresses.
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7.5 View Menu FB 1131

7.5.1 Toolbars
In the menu View > Toolbars the user has the possibility to activate or
deactivate the Toolbars Standard and Fieldbus. If this function is
deactivated the toolbars are not shown.

7.5.2 Status Bar
In the menu View > Status Bar this bar can be activated (with hook) or
deactivated (without hook).



FB 1131 Fieldbus Configurator InterBus Tools  ••••   63

Copyright •  ABB STOTZ-KONTAKT GmbH •

8 Tools
8.1 EDS Viewer

The menu Tools > EDS Viewer opens a EDS file to view it.

Figure 48: Tools > EDS Viewer

ID-Code, Length Code, input length and output length are not displayed, if
the device supports several ID- and Length Codes.

The following device types are available:
•  Remote Bus Branch Interface

•  Local Bus Branch Interface

•  Remote Bus Device

•  Local Bus Device
The button Layout displays the assigned figures of the device (see section
Layout on page 65).
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8.2 EDS Generator
If a InterBus device is not contained into the provided EDS files, the
appropriate EDS file can be produced with Tools > EDS Generator.

Figure 49: Tools > EDS Generator

In this window the device-specific data must be filled in. See manual of this
device. The two most important parameters are the Length Code and the
ID-Code, which are also imprinted on the devices normally. Both guarantee
that the Slave device is detected in the network.
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8.3 Layout
On the basis of Tools > EDS Viewer or Tools > EDS Generator the
current course arranging of bitmaps of the device can be seen.
The bitmaps of the device for
•  Configuration Phase (typical colour grey),

•  Operating Phase (typical colour: green),

•  Diagnostic Phase (typical colour: red)
are displayed.

Figure 50: Layout for Tools > EDS Viewer or Tools > EDS Generator
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9 Error Numbers
9.1 Possible Control Error Messages to FB1131 Telegrams

Error Number Description
401 Driver error in the control
402 slot number is not supported by the hardware
403 no coupler at the given slot
404 control not in STOP
405 configuration data invalid
406 coupler still configured by 907 AC 1131-internal PROFIBUS Configurator
407 answer timeout of the coupler

Table 14: Possible Control Error Messages to FB1131 Telegrams
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9.2 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of couplers. The
error number is returned in an answer message. Command messages and
answer messages are used to communicate between the application (e.g.
the Fieldbus Configurator) and the couplers. An example of this
communication is the download of a configuration.
Error Number Description
4 Task does not exist
5 Task is not initialised
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existent
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong licence. The OEM licence of the Fieldbus Configurator

allows only communication to devices that have the same licence inside
38 The data base created by the Fieldbus Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 15: RCS error numbers (answer message) (4..39)
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Error Number Description
40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 Licence code invalid
92 Licence code does already exist
93 All memory locations for licence codes already in use

Table 16: RCS error numbers (answer message) (40..93)
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9.3 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description
100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WritsDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 17: Database Access Error Numbers (100..130)
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9.4 Online Data Manager Error Numbers

9.4.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description
1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviveObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 18: Online Data Manager Error numbers (1000..1018)

9.4.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description
2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout
2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 19: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)



72  ••••   Error Numbers FB 1131 Fieldbus Configurator InterBus

Copyright •  ABB STOTZ-KONTAKT GmbH •

9.4.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description
2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 20: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

9.4.4 Online Data Manager Subfunctions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Subfunctions of the Online
Data Manager.
Error Number Description
8001 Driver not opened. e.g. CIF Device Driver
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 21: Subfunction Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)
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9.5 Data Base Functions Error Numbers (4000 .. 4199)
The following table lists the error numbers of the converting functions.
Error Number Description
4000 File does not exist
4001 Success in comprimizing
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 22: Error numbers of converting functions (4000..4029)
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Error Number Description
4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialisation
4040 Printer not ready
4041 The data base is used from another function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEintraege
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 23: Error numbers of converting functions (4030..4060)



FB 1131 Fieldbus Configurator InterBus Error Numbers  ••••   75

Copyright •  ABB STOTZ-KONTAKT GmbH •

Error Number Description
4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initializing of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 24: Error numbers of converting functions (4061..4075)
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Error Number Description
4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialisation not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exists
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 25: Error numbers of converting functions (4082..4199)
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9.6 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description
5000 Function PackLongToByteShort: Not enough space in pvD (Number of

elements greater than reserved memory)
5001 Function PackLongToByteShort: Not enough space in pvD. Detected

during converting of pvS
5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringBumpToByteArray: A character was found, which is

not convertable into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 26: Error Numbers of data base functions (5000 .. 5012)
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10 Appendix
10.1 Extended Device Diagnostic Master

On the following pages the task state structures of the InterBus Master are
described.

10.1.1 PLC_TASK Common Variables

Figure 51: PLC_TASK Common Variables

Variable Meaning

Version Compiled Hardware
Task State Task State
Handshake
Counter

Counter for the performed process data hand shakes

Handshake Mode This value represents the actual handshake mode between
application and CIF.
0 = Bus synchonous, Device Controlled
1 = Buffered, Device Controlled
2 = Uncontrolled
3 = Buffered, Host Controlled
4 = Bus synchonous, Host Controlled

Table 27: Meaning of Variables
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10.1.2 IBM_TASK Common Variables

Figure 52: IBM_TASK Common Variables

Configuration State Meaning

Configured devices number of device that are actual configured
Wrong configured devices the master executes a consistency check of each Slave

parameter set and increments this counter by each found
faulty data set

Connected remote bus
devices

this value shows the actual number of scanned remote
bus device in the connected network.

Projected remote bus devices this value indicates the number of configured remote bus
devices the master wants to run with.

Turned off remote bus
devices

in case of configuration faults, like wrong ID code for
example, the master deactivates these network
components. The number of disabled device is indicated
here. The value should normally be 0.

Connected local bus devices this value shows the actual number of scanned local bus
device in the connected network.

Projected local bus devices this value indicates the number of configured local bus
devices the master wants to run with.

Turned off local bus devices in case of configuration faults, like wrong ID code for
example, the master deactivates these network
components. The number of disabled device is indicated
here. The value should normally be 0.

Defective I1-Interfaces for each timeout causing branch interface of the network
this counter is incremented. The value should normally be
zero, else check the network visual and search for red LB-
LEDs on the modules. This indicates the defective
interface module.

Defective I2-Interfaces for each timeout causing remote interface of the network
this counter is incremented. The value should normally be
zero, else check the network visual and search for red RB-
LEDs on the modules. This indicates the defective
interface module.
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Counter of data cycles this value shows the actual number of driven process data
cycles since the last master reset.

Counter of ident cycles this value is normally incremented during the startup
phase of the InterBus network when the master does its
management ID-sequence. If the counter increments
during runtime, then the master has to proceed some
extra ID-sequences because of defective data cycles. So
normally the value shouldn’t increment.

No. of shifting process bits the master adds up here the number of actual shifted
process data bits of all active devices.

Error detected in line the master code has special debug information included,
which shows in case of a hard communication to the
fieldbus controller at which source code line the error
happened.

IX1 response status this value represents the actual confirmation command of
the fieldbus controller. During runtime the value is 48hex
which indicates ‘Start data cycle confirmation’.

SetConf service counter during the management ID-sequence startup phase of the
network. The values should normally be zero.

DataCycle service counter here the master counts all InterBus process data cycle
errors which forced him to leave the process data
exchange and need to drive an extra management ID
cycle to search for the error location. The data errors as
well as CRC errors and module errors are errors which
can occur normally during runtime because of electrical
disturbance. These kind of errors can be corrected by the
master and influence the process data exchange in case
of moderate occurrence only a little. But the system errors
which means timeout in the incoming process data
stream, or loop errors which means the InterBus ring was
shortened, forces the master to go into stop and resets the
network.

SetConf, CheckConf,
DataCycle and Get Conf
counter

These counter are incremented only if the Master detects
heavy communication errors. These values should
normally be zero.

Table 28: Configuration State
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10.1.3 IBM_TASK Device Running States

Figure 53:IBM_TASK Device Running States

Variable Meaning

Device x (x=0..128) Textural state for station address

Table 29: IBM_TASK Device Running States

10.1.4 IBM_TASK Global State Field
See section Global State Field on page 46.
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10.1.5 IBM_TASK Communication Error

Figure 54: IBM_TASK Communication Error

Variable Meaning

Slave x (x=0..128) Actual error number of the Slave

Table 30: IBM_TASK Communication Error
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10.1.6 IBM_TASK Extended InterBus Status

Figure 55: IBM_TASK Extended InterBus Status

The extended InterBus status displays special variables, which are stored
directly after the first ID cycle. These values can help networks errors in
special cases in again installed InterBus to localize. These values can be
interpreted just with our Hotline and because of this they are not described
here furthermore.
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10.1.7 IBM_TASK PDL Requests

Figure 56: IBM_TASK PDL Requests

The Peripherals Data Link (PDL) layer is part of Data Link Layer (DLL)
which is responsible for the safety transmission of data packages trough
the PCP protocol and ensures that each PDL message is transported to the
other remote station without any error.
The Counter for PDL Requests counts for each Slave the number of sent
PDL service data units from the master to a PCP capable Slave device.
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10.1.8 IBM_TASK PDL Confirmation

Figure 57: IBM_TASK PDL Confirmation

The Peripherals Data Link (PDL) layer is part of Data Link Layer (DLL)
which is responsible for the safety transmission of data packages trough
the PCP protocol and ensures that each PDL message is transported to the
other remote station without any error.
The Counter for PDL Confirmations counts for each Slave the number of
confirmed PDL service data units which were previously sent by the master
as requests.
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10.1.9 IBM_TASK PDL Indication

Figure 58: IBM_TASK PDL Indication

The Peripherals Data Link (PDL) layer is part of Data Link Layer (DLL)
which is responsible for the safety transmission of data packages trough
the PCP protocol and ensures that each PDL message is transported to the
other remote station without any error.
The Counter for PDL Indications counts for each Slave the number of
received PDL service data units which were sent by a PCP capable Slave
device to the master. Usually an indication is received from a PCP server
Slave when a previous request was sent before, or can be received at any
time if a Slave works as PCP client Slave.

10.1.10 IBM_TASK Data Cycle Status

Figure 59: IBM_TASK Data Cycle Status
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Variable Meaning

Noise received after a process data cycle is finished normally no further
data should be received be the master in the backline of
the InterBus ring. But in case of electronical disturbance
the InterBus can be influence in this way that noise is
produced in the shifting register. Before the master starts
the next data cycle it looks for received noise telegrams. If
noise was received it increments the counter and drives
an ID-cycle to search for the error location.

Idle indication the master supervises the incoming bit stream all the time.
Because of the InterBus principle there exits always bus
activity also in process data idle times. If the incoming bus
activity is interrupted because of a cut wire for example,
the master increment this value and drive ID cycles to
search for the error.

Data byte missing the master supervises the InterBus delay of incoming
process data. If this time equidistant value is overstepped
in its limit, the mater drives ID-cycles to search for the
error.

State bits changed each telegram that is sent into the InterBus ring has a IBS
specific 3 bit head information included which is
transported by each device back to the master
transparently. If the master detects differences between
the constellation it has sent and the constellation that
comes back from the devices it drives an extra ID-cycle
and searches for the error.

Wrong loop back word the transmission of the process data, must be received
back after all process input data was received without any
change. If there are differences detected a transmission
error has occurred and the master drives an extra I
management cycle.

CRC-Check timeout after each data cycle a CRC check procedure is following.
This procedure is supervised by a timer. If the time limit is
overstepped for the incoming CRC telegrams of the
devices a transmission error has occurred and the master
drives an ID-cycle.

Last CRC-Error class 1 = Stopbit unequal zero
2 = CRC indicated transmission error
3 = Faulty InterBus-Telegramstatusbits
4 = Process data transfer timeout
5 = Checksum transfer timeout

Num. of CRC-Checks failed here the number of failed CRC procedures are counted.
Check sum status low Counts the number of received invalid checksum-status

low telegrams
Check sum status high Counts the number of received invalid checksum-status

high telegrams

Table 31:IBM_TASK Data Cycle Status
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10.1.11 IBM_TASK Scanned ID Codes

Figure 60: IBM_TASK Scanned ID Codes

This buffer represents always the last received ID code image of the
current connected InterBus network. Is it updated by the master on each
extra driven ID cycle during the process data cycle transfer. With its
contents conclusions are possible for the kind of error and error location.
For example the picture above shows a scanned ID-Code to D503hex and
the next value to A518hex = loop back word. The master sends in case of a
transmission error always the number of expected active (devices + 1) loop
back words into the InterBus ring. Normally it will receive back all ID-Codes
of the connected device instead of the loop back word, but in the picture it
receives only the ID-Code of the first device. So it seems that the contact
was interrupted to all the following Devices and this was actually the fault
that was produced here in this example constellation.
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10.1.12 ALPMLIP Common Variables

Figure 61: ALPMLIP Common Variables

This common variables structure is responsible for the indication of
connection establishment errors during the initiate phase of the master in
an PCP connection. The structure always shows the latest information of a
failed connection initialisation.
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Variable Meaning

Initiate request Counts the number of initialisation requests of all Client-
Slaves.

Initiate response pos. Counts globally the number of faultless master
initialisations to PCP Slaves.

Initiate response neg. Counts globally the number of failed master initialisations
to PCP Slaves.

Error class 0 = Initiate
5 = Service
6 = Access
8 = Other

Error code 1 = Max. PCP length insufficient
2 = Service not supported.

Additional code Actually not used.
Max. send length low Maximum supported send PCP length with low priority of

the last requested device to which the connection
initialisation has failed

Max. send length high Not supported, always 0
Max. recv. length low Maximum supported receive PCP length with low priority

of the last requested device to which the connection
initialisation has failed.

Max. recv. length high Not supported, always 0
Client services 1 Bit 7 (128) Get OV Long
Client services 2 Bit 5 (32) Read

Bit 4 (16) Write
Client services 3 Bit 7 (128) Information Report
Server services 1 Bit 7 (128) Get OV Long
Server services 2 Bit 5 (32) Read

Bit 4 (16) Write
Server services 3 Bit 7 (128) Information Report

Table 32: ALPMLIP Common Variables



92  ••••   Appendix FB 1131 Fieldbus Configurator InterBus

Copyright •  ABB STOTZ-KONTAKT GmbH •

10.1.13 ALPMLIPD ALI Information

Figure 62: ALPMLIPD ALI Information

This table shows the actual status information of all ever requested and
received services within the master since its last reset.
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10.1.14 ALPMLIPD PMS Information

Figure 63: ALPMLIPD PMS Information

Variable Meaning

Send response Number of sent master response to previous
corresponding Slave request.

Send request Number of sent master requests.
Receive indication Number of received Slave requests.
Receive confirmation Number of received Slave response to previous

corresponding master request.

Table 33: ALPMLIPD PMS Information
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10.1.15 ALPMLIPD LLI Information

Figure 64: ALPMLIPD LLI information

Variable Meaning

PDL receive ind./conf. Number of all ever received Slave confirmation or
indications.

LLI send res./req. Number of all ever sent master requests or responses.
LLI abort request Number of ever sent connection aborting requests.
PDL reset Number of internal resets of the sub protocol stack PDL.

Table 34: ALPMLIPD LLI information
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10.2 Length and ID Codes

10.2.1 Length Code
The Length Code contains information about the (max. possible) data
weigth of the Slave. The Master can read out the 5 bit containing Length
Code over the Bus from the Slave. The following table shows the
determination in accordance with the InterBus standard DIN EN 50254.
Decimal Hexadecimal Meaning Alternatively Interpretation

(Hex)

0 00 No Data 00
1 01 1 Word 01
2 02 2 Words 02
3 03 3 Words 03
4 04 4 Words 04
5 05 5 Words 05
6 06 8 Words 08
7 07 9 Words 09
8 08 4 Bit 41
9 09 1 Byte 81
10 0A 12 Bit 43
11 0B 3 Byte 83
12 0C 1 Bit C1
13 0D 2 Bit C2
14 0E 6 Words 06
15 0F 7 Words 07
16 10 reserved -
17 11 26 Words 1A
18 12 16 Words 10
19 13 24 Words 18
20 14 32 Words 20
21 15 10 Words 0A
22 16 12 Words 0C
23 17 14 Words 0E
24 18 reserved -
25 19 reserved -
26 1A reserved -
27 1B reserved -
28 1C reserved -
29 1D reserved -
30 1E reserved -
31 1F reserved -

Table 35: Lengths Code

Note see next page.
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Note: The given values in the column Alternatively Interpretation (8 Bits)
are used partly by other configuration softwares and printed on the lables of
Slaves or they are given in the product documentation. FB 1131 used the
Length Code in accordance with DIN EN 50254. Is for example the Length
Code 41H printed on the Slave (Alternatively Interpretation), you have to
use 08H in FB 1131.
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10.2.2 ID Code
The ID Code contains information about the device type. A part of this are
for example the information Remote Bus-, Local Bus Device, Bus Branch,
digital or analog modules and further more the PCP capacity of the device.
Dec Hex Description of the Modul Function

1 01 Remote Bus Device, digital Output modules
2 02 Remote Bus Device, digital Input modules
3 03 Remote Bus Device, digital In- and Output modules
4 04 Bus Branch with InterBus-Loop-Branch
5 05 Remote Bus Device (digital), ISO-Valve Ile (Output)
8 08 Bus Branch with 2-Conductor-Local Bus Branch
12 0C Bus Branch with 2-Conductor-Remote Bus Branch
13 0D Remote Bus Device (digital), profile concurring digital Output modules
14 0E Remote Bus Device, profile concurring digital Input modules
47 2F Remote Bus Device, profile concurring digital In- and Output modules
49 31 Remote Bus Device, analog Output modules
50 32 Remote Bus Device, analog Input modules
51 33 Remote Bus Device, analog In- and Output modules
52 34 Bus Branch with 8-Conductor-Local Bus Branch
53 35 Remote Bus Device, profile concurring analog Output modules
54 36 Remote Bus Device (analog), ENCOM with Input data
55 37 Remote Bus Device (analog), ENCOM with In- and Output data
56 * 38 * Remote Bus Device with Parameter Cannel, "µP_Not_Ready" with

register interlock
58 3A Remote Bus Device, profile concurring analog Input modules
59 3B Remote Bus Device, profile concurring analog In- and Output modules
60 * 3C * Remote Bus Device with Parameter Channel, "µP_Not_Ready" for

reinitialization
83 53 Local Bus Device, analog In- and Output modules with event Inputsand

Configuration Outputs
91 5B Local Bus Device, analog Output modules with event Inputs
95 5F Local Bus Device, analog Input modules with Configuration Outputs
99 ** 63 ** Local Bus Device, analog Loop In- and Loop Output modules with event

Inputs and Configuration Outputs
102 66 Local Bus Device (analog), ENCOM with Input data
103 67 Local Bus Device (analog), ENCOM with In- and Output data
104 * 68 * Local Bus Device with Parameter Channel, "µP_Not_Ready" for

reinitialization, Loop
107 ** 6B ** Local Bus Device, analog Loop Output modules with event Inputs
108 * 6C * Local Bus Device with Parameter Channel, "µP_Not_Ready" for

reinitialization, Local Bus
111 ** 6F ** Local Bus Device, analog Loop Input modules with configuration Outputs
113 71 Local Bus Device, analog Loop Output modules
114 72 Local Bus Device, analog Loop Input modules
115 73 Local Bus Device, analog Loop In- and Output modules



98  ••••   Appendix FB 1131 Fieldbus Configurator InterBus

Copyright •  ABB STOTZ-KONTAKT GmbH •

120 * 78 * Local Bus Device with Parameter Channel, "µP_Not_Ready" with
register interlock

121 79 Local Bus Device, profile concurring analog Output modules
122 7A Local Bus Device, profile concurring analog Input modules
123 7B Local Bus Device, profile concurring analog In- and Output modules
125 7D Local Bus Device, analog Output modules
126 7E Local Bus Device, analog Input modules
127 7F Local Bus Device, analog In- and Output modules
177 B1 Local Bus Device, digital-InterBus-Loop Output modules
178 B2 Local Bus Device, digital-InterBus-Loop Input modules
179 B3 Local Bus Device, digital-InterBus-Loop In- and Output modules
181 B5 Local Bus Device, profile concurring digital Output modules
182 B6 Local Bus Device, profile concurring digital Input modules
183 B7 Local Bus Device, profile concurring digital In- and Output modules
187 BB Local Bus Device, screwing controller
189 BD Local Bus Device, digital Output modules
190 BE Local Bus Device, digital Input modules
191 BF Local Bus Device, digital In- and Output modules
192 * C0 * Local Bus Device with Parameter Channel, DRIVECOM (2 PCP-Words)
193 * C1 * Local Bus Device with Parameter Channel, DRIVECOM (4 PCP-Words)
195 C3 Local Bus Device with Parameter Channel, DRIVECOM (1 PCP-Word)
212 * D4 * Local Bus Device with Parameter Channel, ENCOM (2 PCP-Words)
213 * D5 * Local Bus Device with Parameter Channel, ENCOM (4 PCP-Words)
215 D7 Local Bus Device with Parameter Channel, ENCOM (1 PCP-Word)
216 * D8 * Local Bus Device with Parameter Channel, profile concurring

(2 PCP-Words)
217 * D9 * Local Bus Device with Parameter Channel, profile concurring

(2 PCP-Words)
219 DB Local Bus Device with Parameter Channel, profile concurring

(1 PCP-Word)
220 * DC * Local Bus Device, modul with Parameter Channel (2 PCP-Words)
221 * DD * Local Bus Device, modul with Parameter Channel (4 PCP-Words)
223 DF Local Bus Device, modul with Parameter Channel (1 PCP-Word)
224 * E0 * Remote Bus Device with Parameter Channel, DRIVECOM

(2 PCP-Words)
225 * E1 * Remote Bus Device with Parameter Channel, DRIVECOM

(4 PCP-Words)
227 E3 Remote Bus Device with Parameter Channel, DRIVECOM

(1 PCP-Word)
228 * E4 * Remote Bus Device with Parameter Channel, profile concurring modules

(2 PCP-Words)
229 * E5 * Remote Bus Device with Parameter Channel, profile concurring modules

(4 PCP-Words)
231 E7 Remote Bus Device with Parameter Channel, profile concurring modules

(1 PCP-Word)
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240 * F0 * Remote Bus Device, modul with Parameter Channel (2 PCP-Words)
241 * F1 * Remote Bus Device, modul with Parameter Channel (4 PCP-Words)
243 F3 Remote Bus Device, modul with Parameter Channel (1 PCP-Word)
244 * F4 * Remote Bus Device with Parameter, ENCOM (2 PCP-Words)
245 * F5 * Remote Bus Device with Parameter, ENCOM (4 PCP-Words)
247 F7 Remote Bus Device with Parameter, ENCOM (1 PCP-Word)

Tabelle 1: ID-Codes

* This ID Code is not supported until the InterBus Master Generation 4.
** This ID Code is not supported until the InterBus Master Firmware V 4.50.
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1 Overview FB1131
1.1 Main Functions

The main functions of the CANopen Fieldbus Configurator are:
Function Section Short Description

Configuration Overview Communication Types Overview communication types and
description of the configuration steps

Diagnostic Functions Diagnostic functions, e.g. Life List,
Debugger, Global State Field etc.

Diagnostic

User Data Transfer Read and Write Objects
Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: FB1131 Main Functions
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1.2 Properties
FB 1131 is an universal Fieldbus Configurator
This means you can configure the most important fieldbus systems like
PROFIBUS, DeviceNet, and InterBus with the same tool.

FB 1131 is a global Fieldbus Configurator
You configure all devices with one tool. FB 1131 checks the dependencies
between the devices. FB 1131 only allows configurations that make sense.
In case of doubt FB 1131 will give you a warning.

FB 1131 documents your Fieldbus system
After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the detail of one
device.

FB 1131 uses standardized configuration files
Some protocols support standardized files containing information about all
features and limitations of the Slave device. FB 1131 uses these files for
the configuration.

FB 1131 is a diagnostic tool
After the configuration you can switch FB 1131 into the diagnostic mode.
You can watch all status information of the couplers, see protocol
dependent diagnostic information. In this case a Slave is not operating
correctly will be displayed in a different colour.
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1.3 CAN and CANopen

1.3.1 CAN
CAN means Controller Area Network. The CAN specification describes the
physical interface, the telegram structure and the secure transmission of a
CAN telegram. It describes the send and the receive of a telegram.
The CAN telegram consists (simplified) of a telegram identifier and 0 to 8
bytes of data.
The meaning of the telegram identifier and of the max. 8 bytes user data is
not described, e.g. it does not say anything about the application layer.

1.3.2 CANopen
CANopen is an open standard and based on CAN. The meaning of the
telegram identifier and of the 0 to 8 bytes of user data is described
(specified).
CANopen is a standard application layer defined by the CIA (CAN in
automation) specifications DS 301.
CANopen is network concept and determines what data and what services
are to be transmitted and what is the meaning of the data for the individual
device classes.
CANopen provides functions for the network initialization, the network
guarding and the network configuration.
CANopen offers a big flexibility.

1.3.3 CANopen Device Model
A CANopen device can be described generally as 3 components:
communication, objects and application.
Component Description

Communication The communication unit contains the mechanism for the transport of
data according to the CANopen specification over the CAN.

Object dictionary The object dictionary is the connection between the application unit
and the communication unit. It contains configuration data and device
information. All entries have an object index (index) and a subindex.

Application The application unit describes the function of the CANopen device.

Table 2: Components of the CANopen Device Model
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2 Installation
2.1 System Requirements

•  PC with 486-, Pentium processor or higher

•  Windows 95/98/ME, Windows NT 4.0/2000/XP

•  Free disk space: 30 - 80 MByte

•  CD ROM drive

•  RAM: min. 16 MByte

•  Graphic resolution: min. 800 x 600 pixel

•  Windows 95: Service Pack 1 or higher

•  Windows NT: Service Pack 3 or higher

•  Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the 907 AC 1131 CD in the local CD ROM drive. If "Autorun" is
enabled on the PC the CD menu will start automatically. Otherwise it is
started by starting the file "CD_Menu_Vxx.exe" in the root directory of the
CD. For example by the menu Start > Run and entering
"[X:]\CD_Menu_Vxx.exe" ([X] is the CD rom drive and Vxx stands for the
version number).
You reach the Installation menu of the CD by operating the Installation
907 AC 1131 Vxx button.

With the menu Notes for Installation you get a description of the
innstallation and the components of the 907 AC 1131, the programming
software, the Fieldbus Configurator 907 FB 1131, OPC Server.

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation of the Fieldbus Configurator 907 FB 1131!
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3 Getting Started – Configuration Steps
3.1 Overview Communication Types

Select the communication that you want to use from the following table.
The configuration steps are described in the given section.
CANopen offers the following communication possibilities:
Communication Overview in section Page

PDO (CANopen) Configuration for PDO Communication
(CANopen)

14

SDO (CANopen) Configuration for SDO Communication
(CANopen)

14

Send/Receive Transparent
(CAN)

Configuration for Send/Receive transparent
(CAN)

14

Table 3: Overview Communication Types CANopen
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3.1.1 Configuration for PDO Communication (CANopen)
Communication Device Device Described in section Page

PDO (CANopen) CANopen
Master

Any
CANopen
Node

Configuration CANopen Master to any CANopen Node 15

Table 4: Overview Communication Types PDO Communication

3.1.2 Configuration for SDO Communication (CANopen)
Communication Device Device Described in section Page

SDO (CANopen) CANopen
Master

Any
CANopen
Node

Configuration CANopen Master to any CANopen Node 16

Table 5: Overview Communication Types SDO Communication

3.1.3 Configuration for Send/Receive transparent (CAN)
Communication Device Device Described in section Page

Send / Receive
transparently
(CAN)

CANopen
Master

Any CAN
device

Configuration CANopen Master to any CAN Device for
Send/Receive transparent (CAN)

17

Table 6: Overview Communication Types CAN send/receive transparent
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3.2 Configuration for PDO Communication

3.2.1 Configuration CANopen Master to any CANopen Node (PDO)
The following table describes the steps to configure a CANopen Master to
any CANopen Node for PDO communication, as it is typical for many
cases.

# Action Menu in the Fieldbus Configurator Detail information in
section

Page

1 Create a new project File > New > CANopen Setting up the CANopen
Configuration

19

2 Copy EDS file of CANopen
Node, if Node is not available
yet

File > Copy EDS EDS files 19

3 Select CANopen Master Insert > Master Insert Master 20

4 Select CANopen Node and
set Node address

Insert > Node Insert Node 22

5 Set PDO
6 Set Offset address (*1)

Left mouse click at the Node, then
Settings > Node Configuration

Node Configuration 24

7 Set Bus Parameter Left mouse click at the Master, then
Settings > Bus Parameter

Bus Parameter 45

8 Save project File > Save Save and Save As 65

9 Download Left mouse click at the Master, then
Online > Download

Downloading the
Configuration

51

10 Live List Left mouse click at the Master, then
Online > Live List

Live List 56

11 Start Debugger Left mouse click at the Master, then
Online > Start Debug Mode

Debugmode (CANopen) 57

12 Stop Debugger Online > Stop Debug Mode Debugmode (CANopen) 57

13 Global Diagnostic Left mouse click at the Master, then
Online > Global State Field

Global State Field 59

Table 7: Configuration CANopen Master to any CANopen Node (PDO)

Note (*1): The Offsetaddresses assigned in the Node configuration are
always related to the Master.
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3.3 Configuration for SDO Communication

3.3.1 Configuration CANopen Master to any CANopen Node (SDO)
The following table describes the steps to configure a CANopen Master to
any CANopen Node for SDO communication, as it is typical for many
cases.

# Action Menu in the Fieldbus Configurator Detail information in
section

Page

1 Create a new project File > New > CANopen Setting up the CANopen
Configuration

19

2 Copy EDS file of CANopen
Node, if Node is not available
yet

File > Copy EDS EDS files 19

3 Select CANopen Master Insert > Master Insert Master 20

4 Select CANopen Node and
set Node address

Insert > Node Insert Node 22

5 Set Bus Parameter Left mouse click at the Master, then
Settings > Bus Parameter

Bus Parameter 45

6 Save project File > Save Save and Save As 65
7 Download Left mouse click at the Master, then

Online > Download
Downloading the
Configuration

51

8 Live List Left mouse click at the Master, then
Online > Live List

Live List 56

9 Transfer user data:
Read objects
Write objects

Left mouse click at the Node, then
Online > Read Objects
Online > Write Objects

Read Objects (SDO Upload)
Write Object (SDO
Download)

63
63

Table 8: Configuration CANopen Master to any CANopen Node (SDO)
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3.4 Configuration for Send/Receive transparently (CAN)

3.4.1 Configuration CANopen Master to any CAN Device for
Send/Receive transparent (CAN)

The following table describes the steps to configure a CANopen Master for
send/receive CAN telegrams (Layer 2) transparently, as it is typical for
many cases.

# Action Menu in the Fieldbus Configurator Detail information in
section

Page

1 Create a new project File > New > CANopen Setting up the CANopen
Configuration

19

2 Select CANopen Master Insert > Master Insert Master 20

3 Set Bus Parameter Left mouse click at the Master, then
Settings > Bus Parameter

Bus Parameter 45

4 Save project File > Save Save and Save As 65

5 Download on the Master Left mouse click at the Master, then
Online > Download

Downloading the
Configuration

51

6 Send/Receive of CAN
telegrams via function blocks
in the SPS program

- - -

Table 9: Configuration CANopen Master to any CAN Device for Send/Receive transparent
(CAN)
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4 Configuration of CANopen with FB1131
4.1 Setting up the CANopen Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Select CANopen. If only the CANopen
fieldbus system is installed, the configuration window will open directly.
The name of the configuration file can be allocated when the configuration
is finished or with File > Save As.

4.2 EDS files
Each CANopen device manufacturer defines the CANopen characteristics
of its device in a so called Electronic Data Sheet, also called EDS file. This
description files form the basis of the configuration.
Devices EDS files

ABB STOTZ-KONTAKT
devices

The EDS files for ABB STOTZ-KONTAKT devices are
already included in the delivery of the Fieldbus
Configurator FB1131.

Devices from other
manufacturers

For other devices these have to be delivered by the
device manufacturer.

Table 10: EDS files - Source of Supply

During the program start the Fieldbus Configurator reads in automatically
all EDS files, which are put down in the EDS directory. In this act the device
names are taken up to an internal list. The device-specific data are read out
during the configuration directly from the EDS file.
If a CANopen Node (Slave) is needed, which does not appear yet in the
selection list, then the appropriate EDS file can be copied in the EDS
directory with the menu File > Copy EDS. Another possibility is to copy the
EDS file with the Windows Explore into the FB1131 EDS directory and then
read in the EDS files in the EDS directory again with the menu Settings >
Path.

Figure 1: EDS files and bitmaps directory

The EDS path is changeable. The standard setting can be changed with
the menu Settings > Path.
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4.3 Master

4.3.1 Insert Master
In order to insert a Master into the configuration, choose the Insert >
Master menu, in order to open the selection window, or click on the
symbol:
Insert > Master

Figure 2: Insert > Master Symbol

A window appears where you can select one master device.

Figure 3: Insert > Master

In this window you select the Master you want by clicking on it in the list
Available devices and then click the Add button or make a double click to
put the Master in the list Selected devices. With OK you confirm the
selection and the Master will be insert.
This example shows a 07 KT 97-COM with the Description Master, which
is changeable in this field.
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4.3.2 Replace Master
If a Master already exists in the configuration and should be replaced
against another Master, you first have to set the focus on the Master (left
mouse click) and then select the menu Edit > Replace.
or
make a right mouse click at the Master and select in the now opened
window the menu Replace.

In the opened window appears the question if the Master should be
replaced.

Figure 4: Security question Replace Master

If you click the Yes button a new window opens, where you can replace the
Master against the existing Master.

Figure 5: Edit > Replace Master

In this window you select the Master you want by clicking on it. By clicking
the Add button this Master is shown in the first position by Selected
devices. With OK you confirm the selection and the Master will be
replaced.
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4.4 Node (Slave)

4.4.1 Insert Node
In order to insert a CANopen Node into the configuration, select the Insert
> Node menu to open the selection window, or click on the symbol:
Insert > Node

Figure 6: Insert > Node

The mouse cursor changes automatically to the insert Node cursor. Click
on the position where you want to insert the new Node. A dialogue box
appears where you can select one or more Nodes for insertion.

Mousepointer for
Insert> Node

Figure 7: Mousepointer for Insert > Node

Figure 8: Insert > Node

The left list all available Node devices are shown which are present in the
EDS directory. A filter can be used to limit the selection list via the Vendor
and the Profile. lf one Node is selected there you can see some additional
information about that Node below the list box.
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With a double click or with the button Add, the Node appears in the list
Selected devices. When a new Node is chosen FB1131 always looks for
the next free Node ID value and propose it. If you select each Node by
each you can change its Node ID and give it a short description in the field
Description. The Description field will accept up to 32 characters of text.
It is possible to configured an available Node multiple times with different
Node IDs. In CANopen the Node address is called Node ID. The Node ID
distinguishes the different Nodes from each other in the network. It’s a
unique number that can’t be forgiven twice. Therefore your made entry in
the field Node ID must be equivalent to the real Node ID itself, else the
master will get no contact later to the Node when it wants to establish the
communication.
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4.4.2 Node Configuration
At first you have to make a left mouse click on the symbol of the Node and
select the menu Settings > Node Configuration.

or
Make a double click on the CANopen Node to open the Node Configuration
window.
The Node specific configuration is carried out in this window. Here the PDO
(Process data objects) and their addresses in the process data image are
assigned in the Master. Please note, that the addresses have to agree with
the addresses in the PC application program.

Note (Master): The information about the Offset addresses relate to the
addressing of the data in the Master! The addresses don't relate to the
addressing of the data in the Node. The Node organizes its data
addressing itself.

Figure 9: Settings > Node Configuration
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The following table shows the fields and elements of the Node
Configuration window.

•  Node
The name of the device coming from the EDS file is shown in the field
Node.

•  Description
The field Description contains a symbolic name for the Node.

•  File name
File name of the EDS file.

•  Activate Node in actual configuration
If Activate Node in actual configuration is selected, process
memory in the Master is reserved for this Node and the Master
makes a data exchange at the bus to this Node. If this setting is
deactivated, the Master reserves memory in the process data image
for this Node, but no data exchange to this Node is made at the bus.

•  Automatic COB-ID allocation in accordance with Profile 301
In the basic setting Automatic COB-ID allocation in accordance
with Profile 301 is activated. Then the COB-ID is presetted for a
PDO depending on the Node address and depending on the used
PDO. If this field is deactivated, a manual assignment can be done.
In order to reduce configuration effort for simple networks a
mandatory default identifier allocation scheme is defined, which is
described in section COB-ID at page 98. These identifiers are
available in the Pre-operational state of a Node which works in
accordance to the Communication Profile 301 directly after
initialization. These pre-defined connection sets are used by FB1131
if automatic allocation is enabled. Then the COB-IDs in the already
configured PDO COB-ID column are not editable. So if the automatic
allocation is disabled the COB-IDs can be edited in the range from 0
–2047.

Note: If the setting Automatic COB-ID allocation in accordance with Profile
301 is deactivated, FB1131 does not check if a COB-ID was assigned two
times. This is the job of the user. Further more you have to check, if the
Node supports this function.

•  Device Profile and Device Type
Because of the information of the Device Profile and the Device Type
the Master can read out the Object 1000H from the Node and
compare it with this information when it start communication.
If the Device Profile and the Device Type do not agree the Master
reports a parameterization error.
Further information about the Device Profile and the Device Type you
find in section Device Profile and Device Type at page 28.



26  ••••   Configuration of CANopen with FB1131 FB1131 Fieldbus Configurator CANopen

Copyright •  ABB STOTZ-KONTAKT GmbH •

•  NodeID (address)
The NodeID (address) is necessary for the addressing of the device
at the bus and has to be unique. Therefore it is not allowed to use this
number two times in the same network. And it has to agree with the
set Node address of the device. Otherwise it is not possible for the
Master to build up a communication to this device.
The NodeID (address) also fixes the used COB-ID.

•  Guard time
The Guard time is the supervision time of the Master related to the
Node. Further information about the Guard Time you find in section
Node supervision - Nodeguarding and Lifeguarding at page 39.

•  Life time factor
The Life time factor is an information for the Node for the supervision
of the Master. Further information about the Life time factor you find
in section Node supervision - Nodeguarding and Lifeguarding at page
39.

•  Emergency COB-ID
Is an information of the COB-ID of the Emergency telegram.

•  Nodeguard COB-ID
Is an information of the COB-ID of the Nodeguard telegram.

•  OK
To close the Node Configuration window and to take over the
settings.

•  Cancel
To close the Node Configuration window and to reject the settings.

•  Node BootUp
The NodeBootUp defines the start up behaviour of the Master with
regard to each individual Node and is described in section Node
BootUp at page 37.

•  Object Configuration
Via the button Object Configuration the object directory can be read
out from the EDS file and if necessary added to the Node
configuration. Further information you find in section Object
Configuration at page 40.

•  Actual Node
Changes to the Node configuration of another Node without leaving
the window.

•  PDO mapping method
Lays down the procedure of the PDO mapping. You can select
between the methods DS301 V4 and DS301 V3. The difference
between this methods are described in section PDO Mapping Method
at page 107.
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•  Predefined Process Data Objects (PDOs) from the EDS file
Shows the list of the PDOs which are given in the EDS file and which
can be used for the configuration. Further information you find in
section Process Data Configuration - Selection of PDO at page 29.

•  Configured PDOs
Shows the PDOs which are used for the data exchange between
Master and Node. In addition to the Offsets in the process data image
also the length of the PDOs is indicated. Further information you find
in section Process Data Configuration - Selection of PDO on page 29.

•  Add to configured PDOs
By clicking on a PDO in the list Configured PDOs and afterwards a
click on the button Add to configured PDOs the selected PDO is
taken over in the list of Configured PDOs.

•  PDO Contents Mapping
First you have to select a PDO in the list Configured PDOs. By
making a double click or a click at the PDO Contents Mapping
button the in the PDO transferred user data can be shown and the
combination can be changed if necessary. Further information you
find in section PDO Contents Mapping on page 36.

•  PDO Characteristics
First you have to select a PDO in the list Configured PDOs. With a
click at the PDO Characteristics button the transmission settings of
the PDO can be shown and adjusted if necessary.

•  Define new Receive PDO
By clicking on this button a new Receive PDO is added to the
Configured PDOs. This is described in section Creating own
Receive PDOs at page 33.

•  Define new Transmit PDO
By clicking on this button a new Transmit PDO is added to the
Configured PDOs. This is described in section Creating own
Transmit PDOs at page 35.

•  Delete configured PDO
To delete a configured PDO you first have to select the PDO in
Configured PDOs and then click on the Delete configured PDO
button.
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4.4.2.1 Overview Node Configuration

For the Node Configuration to transfer PDO data the following typical steps
have to be made.
Configuration step Description

Device Profile and Device Type Set or take over the value which is read out of the EDS
file

Process Data Configuration Select the PDO
Process Data Configuration Set the PDO transmission characteristics
PDO Mapping Take over the basic setting or adjust the PDO

combination
Node Bootup Set startup behaviour
Node supervision Set Nodeguarding and/or Lifeguarding

Table 11: Overview Node Configuration

4.4.2.2 Device Profile and Device Type

Each CANopen Node has a mantatory Object 1000H, which has to be
existing in the object directory. This object is named Device Type. The
Device Type also includes the information about the Device Profile.
The Master reads out the Object 1000H from the Node when starting up the
CANopen bus and compares the entries, which are made in the two
available fields Device Profile and Device Type. If the Device Profile and
the Device Type do not agree, the Master reports a parameterization error
and does not establish a process data transfer to the Node. To get the real
values of the Node, use the online function Online > Read Object or click
on the Node in Debug mode.
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4.4.2.3 Process Data Configuration - Selection of PDO

The process data are transmitted via process data objects, short PDOs,
and assigned to the process data image. CANopen distinguishes between
receive- and send PDOs.
Receive PDOs Send PDOs

Data from the Master to the Node
Output data
are processed by the Node

Data from the Node (Slave) to the Master
Input data
are generated by the Node (Slave)

Table 12: PDO: Send PDO and Receive PDO

The data of the Node in the process data image of the Master are serviced
for the application with the configuration of the PDOs.
The configuration window contains two tables. The upper table Predefined
Process Data Objects (PDOs) from EDS file shows all configurable
PDOs, which are predefined in the EDS file of the device. By making a
double click on a table entry or via the Add to configured PDOs button the
entry is taken over in the table Configured PDOs.
The columns of the table Configured PDOs have the following meaning:

•  PDO name
Here the RxPDO parameter and TxPDO parameter are shown.

•  Symbolic Name
Here the symbolic name, which is used in case of OPC
communication, is given. PDO_1400 and PDO_1800 and continuous
names are used as pre-set value. This can be overwritten by the
user.

•  COB-ID
In this column the CAN telegram identifier is shown. In case of
automatic award of COB-ID the routine described in section COB-ID
(Predefined Connection Set) on page 98 is used. In case of manual
award the telegram identifier of the CAN telegram which is
transmitted with the PDO can be edit in the range from 0 to 2047.
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•  I Type and O Type
The specification IB stands for Input Byte and the specification QB
stands for Output Byte.

•  I Addr. and O Addr.
The I Addr. (Input Address) and the O Addr. (Output Address) define
the address of the PDO data in the process data image, which is lead
in the Dual-port memory of the Master. The range can be between 0
and 3583. According to information the number of data bytes is
shown under I Number and O Number.
The addresses can be assigned automatically by FB1131 or manually
by the user. This is set in the menu Settings > Global Settings in the
field Process Data Auto Addressing, which is described in section
Global Settings at page 47. A screening for double addresses takes
place before the Download of Configuration and when you open the
window Address Table.

•  I Len. and O Len.
Gives the length of the PDO in bytes and can be max 8. If the value 0
is shown, the PDO still does not includes user data. Via the PDO
Mapping the user data for this PDO have to be set.
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4.4.2.4 PDO Communication Parameter (PDO Characteristic)

Before a chosen PDO is moved into the lower window, the PDO
characteristics window is opened automatically.

A PDO in CANopen can be configured in Event Driven mode or Cyclic
Transmission. Both kinds of transmission types can be synchronised to a
special sychronization message which is sent by the master in defined time
intervals. Because of the different behaviour of a transmit and receive PDO,
two different windows will be open during the PDO insertion. The several
transmissions are distinguished in the so-called Transmission type value.
Synchronous means that the transmission of the PDO shall be related to
the SYNC message that is sent cyclically by the Master. Preferably the
Nodes use the SYNC message as a trigger to output or actuate based on
the previous synchronous Receive-PDO respectively to update the data
transmitted at the following synchronous Transmit-PDO. Details of this
mechanism depend on the device type and are defined in the device
profile.
Asynchronous means that the transmission of the PDO is not related to the
SYNC message and can happen at any time.
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4.4.2.5 Receive PDO characteristics

Receive PDO are output data of the Master and where received from the
Node. One calls this PDOs therefore Receive PDOs from view of the Node.

Figure 10: Receive PDO Parameter

Transmission
Type

cycl. acycl. syn-
chronous

asyn-
chronous

RTR Description

0 X X The telegram is transferred related to the SYNC,
but not periodically.

1..240 X X A value between 1 and 240 means that the PDO is
transferred synchronously and periodically and that
the value of the type of transmission shows the
number of SYNC telegrams between the two
transferring PDOs.

241..251 res. reserved
254 X Type of transmission 254 means that the

application event is manufacturer dependent.

Table 13: PDO Communication Parameter > Transmission Types (Receive PDO)

The event control selection menu has two possibilities to configure a
Receive PDO for its mailing event.
•  On the one hand there is the selection event-controlled, which

configures the Master in such a way, that the Master sends the
Receive PDO only if it has changed. This kind of the event control
keeps the bus load low.

•  On the other hand there is the possibility to transmit the PDO cyclic.
However this time is indicated here not in milliseconds, but in Node
cycle intervals. A Node cycle interval is the time the Master needs to
test all configured PDOs in their states and to process them once.
The smallest cycle interval is indicated with about 300µsec.
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4.4.2.6 Creating own Receive PDOs

If further PDOs shall be used, which are not predefined in the table
Predefined Process Data Objects (PDOs) from EDS file, this can be
done with the functions Define new Receive PDO.

Figure 11: Definite a new receive PDO

FB1131 suggests a free message number, which can be edited later in the
PDO configuration window, if the PDO was taken over.
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4.4.2.7 Transmit PDO characteristics
Transmit PDOs are input data of the Masters and they were sent by the
Node. This PDOs are called Transmit PDOs from view of the Node.

Figure 12: Transmit PDO Parameter

Transmission
Type

cycl. acycl. syn-
chronous

asyn-
chronous

RTR Description

0 X X The telegram is transferred related to the SYNC,
but not periodically.

1..240 X X A value between 1 and 240 means that the PDO
is transferred synchronously and periodically and
that the value of the type of transmission
indicates the number of SYNC of telegrams
between the two transferring PDOs.

241..251 res. reserved
252 X X The transmission types 252 and 253 mean that

the PDO is an event without immediate
notification and it is only  transferred with remote
transmission requirement. With the type of
transmission 252 the data are immediately
updated after receiving the SYNC Telegram
(however not sent).

253 X X The transmission types 252 and 253 mean that
the PDO is an event without immediate
notification and it is only  transferred with remote
transmission requirement. With the type of
transmission 253 the data are immediately
updated after receiving the SYNC Telegram

254 X The Transmission type 254 means that the
application event is manufacturer dependent.

255 X The Transmission type 255 means that the
application event is defined in the respectively
supported equipment profile. The exact
transmission mode whether cyclically, event-
controlled etc. can reread there.

Table 14: PDO Communication Parameter > Transmission Types (Transmit PDO)
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The event control selection menu has to two possibilities to configure a
transmit PDO for its mailing event.
•  On the one hand there is the selection no remote request. The Master

behaves completely passively to the PDO and is programmed only for
receiving. When the PDO is received is completely Node dependent
here.

•  On the other hand there is the possibility to set remote request. Here
the Master sends so-called Remote-Telegrams in settable Node cycle
intervals, which arrange the Node to send its Transmit PDO to the
Master after receiving it.

4.4.2.8 Creating own Transmit PDOs

If further PDOs shall be used, which are not predefined in the table
Predefined Process Data Objects (PDOs) from EDS file, this can be
done with the functions Define new Transmit PDO.

Figure 13: Definite a new Transmit PDO

FB1131 suggests a free message number, which can be edited later in the
PDO configuration window, if the PDO was taken over.
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4.4.2.9 PDO Contents Mapping - Arrange a PDO

Some CANopen Nodes support the PDO data mapping and dynamic
distribution. That means a user defined containment mapping of objects
into a PDO. The mapping itself is always done by the Node internally after
is has received new RX-PDO or has to send new TX-PDO, so that the
master can handle the input and output PDOs coming from and going to
the Node completely transparent. This guarantees high speed data transfer
and execution in the view of the master. His job is it only to configure the
Node’s mapping dictionary during its configuration phase once.
A PDO can contain always up to 8 byte process data. The combination of
these individual process data elements can be changed when the button
Append Object is used. When a PDO was transferred from the upper table
to the Configured PDOs table, FB1131 maps automatically all found
mappable process data from the Node EDS file into this PDO.

Figure 14: PDO Contents Mapping

The picture above is an example for a TX-PDO mapping. The upper table
shows all available objects with their access right which are declared as
supported in the node’s EDS file. A double click onto one of these transfer it
into the lower table. This table contains the real mapped objects that shall
be a content of the PDO later in the process data exchange phase.

Note: Not all CANopen Nodes supports the PDO mapping feature!
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4.4.2.10 Node BootUp

The Node BootUp defines the network startup behaviour of the Master for
the particular Node to get it operative. There are different states a Master is
running through per Node, till the BootUp sequence is finished for the
Node. Each state now is configurable and can be enabled (activated) or
disabled (deactivated) here. In the basic setting all states are activated.

Figure 15: Online > Node Configuration > Node BootUp
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Node BootUp
parameter

Description

Node Reset If enabled, the master sends as first the CANopen specific Node
Reset Communication command.

Check Node Type
and Profile

If enabled, the master will compare the contents of the mandatory
Node Object 1000H is the device type with the values that are
configured within FB1131. If the values are different, the master will
report a parameterisation error.

Configuration
Guarding Protocol

A CANopen has two specific register responsible for the Node
guarding protocol. If the item is enabled, the master will write the
Guard Time and Life-Time factor of the Node configuration into the
corresponding objects of the Node during startup.

Configuration
SYNC COB-ID

If the item is enabled, the master will write the SYNC COB-ID of the
configuration into the corresponding objects of the Node during
startup.

Configuration
EMCY COB-ID

If the item is enabled, the master will write the EMCY COB-ID of
the configuration into the corresponding objects of the Node during
startup.

Configuration
download of objects

To get a PDO communication to a Node working, the master has to
send all relevant configuration objects to the Node. For example
the mapping table, the COB-ID a PDO shall be sent through are
covered here. If enabled, all these parameter and also the user
specific objects which are added manually in the Node object
configuration window are written down to the Node by the master.

Start Node To reach the operational state in CANopen a Node has to get the
CANopen specific Start Node command. If enabled, the master will
send the Start Node command to the Node at the end of the boot-
up procedure.

Initiate PDO data This item selects if the installed PDOs shall be automatically written
and read by the master directly after the startup once. This ensures
that the latest output data which can be found within the Masters
output process data area is sent to the Node and that the latest
Node input data is read from the Node and be placed into the input
process data area.

Table 15: Node BootUp
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4.4.2.11 Node supervision - Nodeguarding and Lifeguarding

The Guard time and Life time factor settings serve the supervision of the
Node and the supervision of the Master in the view of the Node. If the
communication is established once to the Node later, the Master will poll
the Node in Guard time multiplied Life time factor time intervals with
special guard telegrams to check if it is still present in the network or not.
The Node supervises if the Master has done a guard polling during the
configured time interval to check if the Master is still present. If one of these
values is configured to 0, then the supervision is disabled in the Master as
well as in the Node. The Node itself will start with the Node guarding when
the first remote-transmit-request from the Master for its guarding identifier is
received. The Master itself will start the Node guarding after it has initialized
all for the communication necessary objects of the Node. If the Node
guarding fails during runtime, the Master will reset the communication to
the specific Node and restarts its initialization again.

Note: If the Node does not support the Nodeguarding, the Master cannot
recognize that the Node failed.
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4.4.2.12 Object Configuration

The most important part of a CANopen device is its object directory. The
object directory is essentially a grouping of objects accessible via the
network in an ordered predefined fashion. Each object within the directory
is addressed using a 16-bit index. The Device profiles of CANopen define
the name, the meaning, the value range and data type of the Service Data
Objects (SDO). With so-called Service Data Messages the contents of an
object and its subindex can be changed. This is necessary to set up the
behaviour of a CANopen Node in the right manner. This is necessary to
change the behaviour of the CANopen Node.
To get access to the SDO configuration press the Object Configuration
button. The following window below will appear and FB1131 shows in the
upper table all supported objects read out from the EDS file of the Node. If
you have already inserted some PDOs you will find existing entries in the
lower table too.
FB1131 places some objects in this table automatically when a PDO in the
Node Configuration window is inserted, to set up the several variables of
the PDO objects right, so that the wished configuration corresponds to the
Node behaviour later in the process data communication. These values can
not be edited.

Figure 16: Online > Node Configuration > Object Configuration
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4.4.3 Replace Node
If a Node already exists in the configuration and should be replaced against
the other Node, you first have to set the focus on the Node (left mouse
click) and then choose the menu Edit > Replace.
or
make a right mouse click at the Node and select Replace in the now
opened menu.
In the opened window the question appears if the Node should be replaced.

Figure 17: Security question Replace Device

If you click the button Yes a new window opens, where you can replace the
Node against the existing Node.

Figure 18: Edit > Replace Node

In this window you select the Node you want by clicking on it. By clicking
the Add button this Node is shown in the first position by Selected
devices. With OK you confirm the selection and the Node will be replaced.
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5 Settings
5.1 Gateway Driver

The Gateway Driver terminies how the Fieldbus Configurator
communicates with the device. This is set in the Device Assignment which
can be opened with the menu Settings > Device Assignment.

Figure 19: Settings > Device Assignment

After the selection of the Gateway channel or clicking the Connect button
FB 1131 tries to set up a connection to the selected controller.
If the connection was successful the configurable couplers are shown in the
field Device Information.

The desired coupler is selected by clicking on the field next to the name of
the coupler and confirming with the OK button.
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By clicking at the Gateway Configuration button a new window appears
where the Gateway channel can be selected or a new Gateway channel
can be configured.

Figure 20: Configure Gateway

To confirm the Channel selection click at the OK button.
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5.2 Bus Parameter
In this windows the basic settings for the CANopen network are done.
Mainly, this concerns the setting of the Baudrate.

Attention: Check that all CANopen Nodes support also the selected Baud
rate.

Basic rule: The Baud rate must be set same for all devices. The Node
address on the other hand must differ from Node to Node. The Master itself
does not have a Node address.

Figure 21: Settings > Bus Parameter

•  SYNC COB-ID and SYNC-Message
Furthermore the cycle time of the SYNC-Message and its message
number COB-ID has to be set. The default value is 128. As soon as a
participant with synchronized PDO transfer is configured, the SYNC
message is sent in the configured cycle period frame from the Master.

•  Auto clear mode OFF
The Auto Clear feature defines the behaviour of the Master if the
communication is interrupted to at least one Node. If the flag Auto
clear mode ON is activated, the Master will also stop the
communication to all further Nodes which were still responding and
active. If the flag Auto clear mode OFF is activated, then a lost
communication contact to one Node has no influence on the
communication channel of the still present ones. For all the error
affected Nodes the master remains in the state to try the
reestablishment of the communication again.
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•  Enable Global Start Node
After the Master started all Nodes configured individually first, it sends
a Global Start Node with activated menu option afterwards, in order to
synchronize all Nodes again.

•  Enable 29 Bit Selector
If this menu option is activated the 29 Bit identifier is switched free for
the Master.

Figure 22: Diagram Acceptance Code / Acceptance Mask
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5.3 CANopen Master

5.3.1 Global Settings
First you have to set the focus on the Master (left mouse click) and select
the menu Settings > Global Settings
or
click with the right mouse key on the symbol of the Master device to select
the menu Master Configuration and then click the button Global Settings.

Figure 23: Settings > Global Settings

•  Process Data Auto Addressing
In this window it is adjusted whether the process data addressing is
executed automatically by FB1131 (active selected) or manually by
the user (active not selected).

Auto Addressing active Auto Addressing deactivated

Auto addressing (by FB1131) Manually addressing (by the user)
The addresses will be allocated beginning
with 0 and incremented in accordance with
the entry sequence of the Slaves before
downloading and can be viewed and
checked in the menu View > Address
Table.

The address 0 is shown in the I Addr or O
Addr and must be overwritten by the user.

Table 16: Process Data Auto Addressing activated / deactivated



48  ••••   Settings FB1131 Fieldbus Configurator CANopen

Copyright •  ABB STOTZ-KONTAKT GmbH •

•  COB-ID Allocation during PDO insertion
The CANopen specification provides that the message number (COB-
ID) of a PDO is given relatively to the Node address according to a
fixed routine. It is called Pre-Defined Connection Set. This is
described in section COB-ID (Predefined Connection Set) on page
98.

•  Automatic Allocation in accordance with Profile 301
If this menu option is selected, an alteration of the message number
of the PDOs is not possible and its assignment takes place
automatically by the CANopen profile 301.

•  Manual Allocation in range 0-2047
If this menu option is selected, a definition of the message number of
the PDOs is possible and can take place in the context of the possible
2048 (11 bit) different CAN-Identifier manually.
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5.4 Project Information
If the user creates his own project, the project information can be typed in
into the Settings > Project Information menu. Anybody can then read this
entry when this menu is called up.

Figure 24: Settings > Project Information

By clicking the OK button the Project Information is saved.

5.5 Path
When the Settings > Path menu is selected, then the search path for EDS
files is displayed.

Figure 25: Settings > Path

If you click the button OK, all EDS files are read in.
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5.6 Language
Choose the Settings > Language menu and the following window opens:

Figure 26: Settings > Language

Here one is in a position of setting the language of the Fieldbus
Configurator. Select the desired language and confirm the entry with the
OK button.
A message appears that the Fieldbus Configurator must be started again in
order to activate the selected language. Please carry this out.
After restarting the Fieldbus Configurator, the language will have changed
to the one selected.

Note: Up to now not all languages are available for all fieldbuses!
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6 Online Functions
6.1 Introduction

In this section all the functions that directly influence CANopen devices,
e.g. 07 KT 97-COM, 07 KT 97-COM are presented.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched ON or OFF.

6.2 Online to the Coupler

6.2.1 Downloading the Configuration
First, the desired device must be chosen for downloading by a left mouse
click on the symbol of the device.
In order to release the configuration and network access, a transfer
(Download) to the device must be carried out on the Online > Download
menu. A warning will appear that the communication on the CANopen will
be interrupted. This warning must be confirmed.

Figure 27: Security question before Download

Attention: The download overwrites the configuration in the device and the
communication with the connected devices is interrupted.

Figure 28: Online > Download
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Before the Download is executed, the configuration is checked by the
Configurator. The most common cause of error is overlapping of addresses
in the process data image. This can be checked by calling up the address
table with the View > Address Table menu point.

If the issue of addresses in the process data image should be carried out
automatically, then the Auto Addressing button in the Master
Configuration window must be activated.

The configuration is transferred into the selected device and is stored there
in FLASH memory in a zero voltage manner so that the configuration is
available when the voltage supply is switched off and on again.
After the download, the device carries out an internal restart and begins
with the communication if in CANopen Master Settings the Automatic
Release of Communication by the Device menu point has been set.

6.2.2 Firmware Download
If a Firmware download is to be carried out, proceed as follows: first the
desired device for Firmware downloading must be chosen in that the
symbol of the device is selected with a left mouse click. Then, call up the
Online > Firmware Download menu. Select the new Firmware and
retrieve it with Download into the device. The Firmware is now retrieved.

Figure 29: Online > Firmware Download
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6.2.3 Firmware / Reset
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then the Online > Firmware / Reset menu must be
called up and the name and the version of the Firmware are displayed.

Figure 30: Online > Firmware / Reset

The device is reset with the Reset button.

6.2.4 Device Info
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Device Info menu in order
to obtain further information on the selected device.
The manufacturer date, the device number and the serial number of the
device is retrieved and shown.

Figure 31: Online > Device Info
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6.3 Start/Stop Communication
The communication between CANopen Master and CANopen Node can be
manually started or stopped.
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Communication start or
Online > Communication stop menu.
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6.4 Diagnostic Functions
The following table shows diagnostic functions and their using in case of
CANopen Master devices.

Diagnostic Function Using Usable for CANopen
Master devices

Live List Determine, which devices are connected to the CANopen
Master device.

Yes

Debugmode (CANopen) Determine, to which CANopen Nodes the CANopen Master
has communication

Yes

Global State Field Status information of the CANopen Master Yes
Extended Device Diagnostic Statistic information and status information from the

CANopen device
Yes

Table 17: Overview Diagnostic Functions
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6.4.1 Live List
First the desired device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Live List menu and obtain
an overview over all active devices at the CANopen network.

Figure 32: Online > Live List

Generally all devices are displayed grey. At the bus detected Nodes are
represented black on the basis their appropriate Node address.
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6.4.2 Debugmode (CANopen)
Click the menu item Online > Start Debug Mode. Then the Fieldbus
Configurator cyclically interrogates the status of the network communication
from the Bus Coupler and the individual conditions of the Nodes.
To end the Debug Mode select the menu Online > Stop Debug Mode.

6.4.2.1 The Debugwindow

When the debug session is started the configuration window changes into
the debug window. The devices and the line between them are displayed in
green or red colour depending on the established network communication.

Figure 33: The Debugwindow

If a diagnostic information is available for a specific device, next to the
device Icon the text Diag appears in red. To get further device specific
diagnostic information then doubleclick on the device itself or set the focus
to the device and select Online > Device Diagnostic.

Note: Only if the CANopen Node supports the Nodeguarding, the
CANopen Master (NMT-Master) can recognize that the Node has failed.

The Master icon has the  sign to show the stop mode.

In run mode the Master icon has the sign .
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6.4.2.2 Emergency Telegrams
Emergency telegrams are sent by the Node when an internal event occurs
if a Node enters. The CANopen Master can buffer maximally 5 Emergency
telegrams.

Figure 34: Online > Device Diagnostic > Interpretation of emergency telegrams

A table with the Error Codes is described in section Emergency Telegram
Error Codes at page 112.

Note: The table Emergency Error Codes is a general list. For the exact
meaning it is referred to the manual of the Node manufacturer.
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6.4.3 Global State Field
With the menu option Online > Global State Field opens a window in that
cyclically statistic about the bus status and connected devices are shown.

Figure 35: Online > Global State Field

The first row displays the main status of the Master. It can take the status
OPERATE or STOP or OFFLINE.
The next row displays individual bus errors. A pending error is displayed
with a red field. The meaning of the individual abbreviations is described in
the following:
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Bus error Meaning

TOUT Timeout Error
NRDY HOST-NOT-READY-NOTIFICATION

shows, if the application program is ready or not. If this bit is set the
application program is not ready to communicate.

EVE EVENT-ERROR
the CAN chip has detected transmission errors. The number of detected
events are counted in the bus off reports and the error warning limit
counter. The bit will be set when the first event was detected and will not
be deleted any more.

FAT FATAL-ERROR
because of heavy bus error, no further bus communication is possible.

NEXC NON-EXCHANGE-ERROR
At least one Node has not reached the data exchange state and no
process data are exchange with it.

ACLR AUTO-CLEAR-ERROR
device stopped the communication to all Nodes and reached the auto-
clear end state.

CTRL CONTROL-ERROR
a parameterisation error has occurred.

Table 18: Meaning of collective status bits in the Global State Field

Further contents are given:
Collective online error location and corresponding error gives the
address of the incorrect station and the lining up error in plain text.
Statistic bus information gives the number of detected bus short-circuits
and rejected telegrams.
Device specific status bits
Parameterized Devices, Activated Devices and Devices with
Diagnostic are shown if you click at that button. The activated addresses
are coloured numbers. You can see the diagnostic by double-clicking at a
highlighted station address of a device.
This displaying is cyclically updated.
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6.4.4 Extended Device Diagnostic
The Extended Device Diagnostic helps to find Bus and configuration errors
when the FB1131 menu functions are of no further help.
First the required device must be chosen with a left mouse click on the
symbol of the device. Then select the Online > Extended Device
Diagnostic menu.
This menu opens a list of diagnostic structures. These contain online
counters, statuses and parameters:

Figure 36: Online > Extended Device Diagnostic

6.4.4.1 Extended Device Diagnostic CANopen Master
Task/Taskstate Page

PLC_TASK Common Variables 89
CAN_TASK Common Variables 90
CAN_TASK Node Running State 92
CAN_TASK Global State Field 92
CAN_TASK Communication Error 92
CAN_TASK Nodeguard Inputqueue 93
CAN_TASK Management Inputqueue 93
CAN_TASK Emergency Inputqueue 94
CAN_TASK Transmit Queue 94
CAN_TASK CMS Domain Services 95
CAN_TASK Timeout Counter 96
CAN_TASK Node Init Counter 97

Table 19: CANopen Master Taskstate
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6.5 User Data Transfer
The following table show test functions with user data transfer and the
usability for CANopen Master devices.

User data transfer function Usage Usable with CANopen
Master devices

Read Objects (SDO Upload) Read objects (SDO Upload) Yes
Write Object (SDO Download) Write objects (SDO Download) Yes

Table 20: Overview User Data Transfer
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6.5.1 Read Objects (SDO Upload)
With this function you can execute the CANopen services read object and
write object based on the current configuration.
As the first you must select the required device, by clicking with the left
mouse button on the symbol Node. Then select the menu Online Read
Object or Online > Write Object.

Figure 37: Online > Read Object

6.5.2 Write Object (SDO Download)
With this function you can execute the CANopen services read object and
write object based on the current configuration.
As the first you must select the required device, by clicking with the left
mouse button on the symbol Node. Then select the menu Online Read
Object or Online > Write Object.

Figure 38: Online > Write Object

Objects in CANopen are addresses in the manner Object-Index and
corresponding Sub-Index. Both values must be specified in the selected
window. Press Read or Write button to start the action. FB1131 informs
about success and failure of the action.
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7 File, Print, Edit, Export and View
7.1 File

7.1.1 Open
An existing project can be opened with File > open.

7.1.2 Save and Save As
When the file name is known, the configuration can be saved under the File
> Save menu, otherwise the File > Save As menu must be selected.

7.1.3 Close
The current project can be closed with File > Close.
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7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.

Figure 39: File > Print

The base setting prints information on one sheet  only for one device.
Topology prints the topology of the Bus system.
Bus parameters prints the Bus Parameters of the Bus system.
Address table prints the address table of the Master.
Device table prints the device table.
ID Table prints the ID Table.
PDO Configuration prints the PDO Configuration.
SDO Table prints the SDO Table.
The scope can be given with the Device Selection menu point. The
following can be chosen:

•  All

•  From Station address to Station address

•  Selection of a device by means of its description
If no option is selected and the OK button is pressed nothing will be printed
out. It is like clicking the Cancel button.
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7.3 Export Functions

7.3.1 CSV Export
With the menu File > Export > CSV the configuration data of the
connected Slaves can be exported into a table.
Requirement is, that the configuration was saved before the export is
executed. The exported file has the ending .csv (comma separated value)
and is taken off in the same directory as the configuration, but with the
ending *.csv.
The CSV file can be read with a table program like for example Excel.
The CSV Export saves only the text and the values of the configured
Slaves. The meaning of the individual values can be shown in the table.
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Here is the description of the parameters:
Parameter Meaning

Stationaddress The Stationaddress is the unique device address of the Slave on the
bus.

RecordType The RecordType defines the version of the following structure and is
always 2.

IdentNumber This number is the unique device number of the Slave.
VendorNumber The VendorNumber is the clear number of the vendor (if available).
VendorName Here the name of the vendor is shown (max. 32 characters).
Device Name of the device (max. 32 characters).
Description This is the description of the device, which is set by the user (max. 32

characters).
MasterAddress This is the number of the Master Address, where the devices are

related to.
Settings Contains information about the addressing mode and the storage

format of the process data (words, double words and floats) see
section Description of the Parameter Settings.

Reserved reserved
ModulCount Number of the modules of the device. For each modul the parameters

data type, data size, data position and offsetaddress are given. It can
be follow max 60 modules. The parameters for modul 1 are marked
with ..._0 and of the modul 60 are marked with ..._59.

DataSize_0 Number of bytes, which were used by the module.
DataType_0 The DataType, which is used in the configuration. The code for this

you find below this table in section Description of the Parameter
DataType.

DataPosition_0 The byte DataPosition, which is used in the configuration. The code for
this you find below this table in section Description of the Parameter
DataPosition.

Address_0 Offset Address in the Dual-port memory
... ...
DataSize_59 if used, see at the top
DataType_59 if used, see at the top
DataPosition_59 if used, see at the top
Address_59 if used, see at the top

Table 21: CSV Export - Meaning of the values
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7.3.1.1 Description of the Parameter Settings
D7 D6 D5 D4 D3 D2 D1 D0
Reserved Area Format Address Mode

0 byte Address
1 word Address

1 little endian (LSB/MSB)
0 big endian (MSB/LSB)

reserved

Table 22: CSV-Export - Description of the Byte Settings

7.3.1.2 Description of the Parameter DataType
D7 D6 D5 D4 D3 D2 D1 D0
SubFlag Data Direction Data Format

according EN standard
0 blank space
1 Boolean
2 Integer 8
3 Integer 16
4 Integer 32
5 Unsigned Integer 8
6 Unsigned Integer 16
7 Unsigned Integer 32
8 Float
9 ASCII
10 String
14 Bit

0 emty space
1 input
2 output

0 start of a module
1 submodule

Table 23: CSV Export > DataType Code

7.3.1.3 Description of the Parameter DataPosition
D7 D6 D5 D4 D3 D2 D1 D0
Reserved Area Bit Position

Bit Position of the Offset Address
reserved

Table 24: CSV Export > DataPosition Code
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7.3.1.4 Example of a CSV file

Example of a CSV file which was exported in Excel:

Figure 40: Example of a CSV File in Excel

Cell Parameter Value Meaning

A1 StationAddress 1 Station address of the CANopen Node.
B1 RecordType 2 The RecordType is always 2.
C1 IdentNumber 0 IdentNumber of the Node.
D1 VendorNumber 301 The vendor number is 301.
E1 VendorName Hilscher Vendor name of the device.
F1 Device CIF 50-COS Description of the device.
G1 Description Node1 Description of the device which is also shown in FB1131 as the name

of the device.
H1 MasterAddress 255 Address of the related Master.
I1 Settings 0 The addressing mode (byte- or word addressing) and the data format

of the process data are shown. The description you see in section
Description of the Parameter Settings.

J1 reserved reserved reserved
K1 ModulCount 1 Number of the modules of the device. For each modul the

information with datatype, data size, data position and the
offsetaddress follow. The information for
modul 1 you find in the cells L1, M1, N1, O1 and for
modul 2 in the cells P1, Q1, R1, S1 and so on.

L1 DataSize 8 The size of the modul is 8 bytes.
M1 DataType 37 Input; Datatype unsigned Integer 8
N1 DataPosition 0 Output; Datatype unsigned Integer 8
O1 Offsetaddress 0 The Offset address is 0.
P1...IQ1 DataSize 0 The modules 2 till 59 are not used for this device and so a 0 is

shown.

Table 25: Example of a CSV File in Excel

If two or more Slave devices are connected to the Master, these are
displayed in the next lines of the table.
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7.4 Edit

7.4.1 Cut, Copy and Paste
With the menus Edit > Cut and Edit > Copy you put the cut/copied device
with its settings and configuration (only not the description of the device) in
the Clipboard and with Edit > Paste it can be insert.
The difference between Cut and Copy is:
With the menu option Edit > Cut you move a device from one point in the
configuration to another. With the menu option Edit > Copy you duplicate
an existing device.
If you select Edit > Cut a security question appears.

Figure 41: Security question cut device

If you answer this question with Yes the device is cut and stays in the
clipboard.
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With the menu Edit > Insert and clicking at the position where the device
should be insert, a window opens where the cut/copied device can be
selected.

Figure 42: Edit > Insert cut/copied device

When you click on the OK button the device will be insert in the
configuration.
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7.4.2 Delete
To delete the Master or a Slave device you have to have to mark this
device and then select the menu Edit > Delete. Before FB1131 deletes the
Master or a Slave a security question appears.

Figure 43: Security question delete device

Note: When you delete a device the settings and the configuration of this
device get lost.

7.4.3 Replace
With the menu Edit > Replace the Master or a Slave device can be
replaced. How to replace the Master look in section Replace Master at
page 21. If you want to replace a Slave device look in section Replace
Node at page 41.
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7.5 View of the Configuration
The configuration can be displayed in a table. The following tables are
available:

•  Device Table

•  Address Table

•  ID Table

•  SDO Table

7.5.1 Device Table
The list of all added devices is displayed with the menu item View > Device
Table. Apart from the Node address the name of the device displayed with
the pertinent alterable description. Look at section Node Configuration at
page 24.

Figure 44: View > Device Table
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7.5.2 Address Table
With the menu item View > Address Table you get an overview of all
configured PDOs and the booked start addresses in the process image
including their length.

Figure 45: View > Address Table

It is possible to sort the addresses according to Station Addresses or
according to Data Addresses.

7.5.3 ID Table
With the menu item View > ID Table is sorted listed for each Node, which
message numbers in the CAN network are occupied by the respective
Nodes. This are the Emergency ID, Nodeguard ID and the IDs of the
PDOs.

Figure 46: View > ID Table
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7.5.4 SDO Table
With the menu item View > SDO Table you get an overview of the
transmitted objects during the Node BootUp phase for each Node. Apart
from the Node Address for each entry the Object- and Subindex is
displayed with the pertinent value. Thereby if a line contains a cross in the
column PDO Dialog, then the entry was created automatically when
inserting a PDOs by FB1131 and can be changed in section Node
Configuration (see at page 24). If an entry does not contain a cross in the
column PDO Dialog, then the appropriate object is manually created in the
Object Configuration (see at page 40) and can be changed there.
Exceptions here form the entries COB-ID SYNC and Communication Cycle
Period, which can be changed in the dialog Bus Parameter (see at page
45). It is possible to hid or to display the configured objects of the PDO
Dialog. The representation method of the object values can be selected
between decimal and hexadecimal.

Figure 47: View > SDO Table
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8 Error Numbers
8.1 Possible PLC Error Messages to FB1131 Telegrams

Error Number Description

401 Driver error in the control
402 slot number is not supported by the hardware
403 no coupler at the given slot
404 control not in STOP
405 configuration data invalid
406 coupler still configured by 907 AC 1131-internal PROFIBUS Configurator
407 answer timeout of the coupler

Table 26: Possible Control Error Messages to FB1131 Telegrams
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8.2 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of Controller of series
90. The error number is returned in an answer message. Command
messages and answer messages are used to communicate between the
application (e.g. the Fieldbus Configurator) and the ABB Stotz-Kontakt
device. An example of this communication is the download of a
configuration.
Error Number Description

4 Task does not exist
5 Task is not initialised
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existent
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong licence. The OEM licence of the Fieldbus Configurator

allows only communication to devices that have the same licence inside
38 The data base created by the Fieldbus Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 27: RCS error numbers (answer message) (4..39)
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Error Number Description

40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 Licence code invalid
92 Licence code does already exist
93 All memory locations for licence codes already in use

Table 28: RCS error numbers (answer message) (40..93)
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8.3 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description

100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WritsDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 29: Database Access Error Numbers (100..130)
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8.4 Online Data Manager Error Numbers

8.4.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description

1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviveObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 30: Online Data Manager Error numbers (1000..1018)

8.4.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description

2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout
2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 31: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)
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8.4.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description

2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 32: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

8.4.4 Online Data Manager Subfunctions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Subfunctions of the Online
Data Manager.
Error Number Description

8001 Driver not opened. E.g. CIF Device Driver
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 33: Subfunction Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)
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8.5 Data Base Functions Error Numbers (4000 .. 4098)
The following table lists the error numbers of the converting functions.
Error Number Description

4000 File does not exist
4001 Success in comprimizing
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 34: Error numbers of converting functions (4000..4029)
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Error Number Description

4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialisation
4040 Printer not ready
4041 The data base is used from another function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEintraege
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 35: Error numbers of converting functions (4030..4060)
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Error Number Description

4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initializing of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 36: Error numbers of converting functions (4061..4075)
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Error Number Description

4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialisation not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exists
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 37: Error numbers of converting functions (4082..4199)
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8.6 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description

5000 Function PackLongToByteShort: Not enough space in pvD (Number of
elements greater than reserved memory)

5001 Function PackLongToByteShort: Not enough space in pvD. Detected
during converting of pvS

5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringBumpToByteArray: A character was found, which is

not convertable into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 38: Error Numbers of data base functions (5000 .. 5012)
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9 Appendix
9.1 Extended Device Diagnostic Master

The menu item Online > Extended Device Diagnostic helps to find
possible network and configuration faults while trying to get the network
fully operative, when the normal debugger does not rudicate any helpful
information any more to get the fault location. This menu activates a list of
available structures. The listed structures can be displayed to show the
values. The structures will be resetted after power on or after a cold or
warmstart command.

Figure 48: Online > Extended Device Diagnostic

This points contain online counters, values, parameters and statuses.
Several task states are available

9.1.1 PLC_TASK Common Variables

Figure 49: PLC_TASK Common Variables

Variable Meaning

Version compiled indicates the hardware version the software is compiled for
Task state is always filled up with value 0
Handshake counter number of process data handshakes ever done with the

application
Handshake mode represent the actual process data handshake mode the card

is actual running with. The mode can be switched in the menu
Settings > CANopen Master Settings

Table 39: PLC_TASK Common Variables
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9.1.2 CAN_TASK Common Variables

Figure 50: CAN_TASK Common Variables
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Variable Meaning

Received messages Number of received CAN-Messages
Sent messages Number of sent CAN-Messages
Receive overruns This counter is incrementing when to much incoming CAN

messages overload the master. An incremented counter will
always cause lost CAN message data, so it should normally
contain the value 0.

Bus errors Our used CAN controller has two internal error frame counter
for detected transmission errors one for receive and one for
transmit messages. If one of these error counter oversteps a
defined value, the bus error counter is incremented by a value
of 1.

Controller reinits If the internal CAN controller error frame counter overstep a
defined limit the controller goes into the bus off state. If this
occurs we reinitialize the controller again to be preoperative
and increment this counter value. A value unequal 0 is an
indication for bad transmission quality, for unsatisfied bus
wiring or for low power in the CAN-controller interface driver.

Synctimer reload This value represent the value that was configured via the
menu Settings > Bus parameter in FB1131 and shows the
actual configured and handled value.

Baudrate This value shows numeric the actual baudrate the master is
working with:
0 = 1Mbaud,
1 = 800Kbaud,
2 = 500kBaud,
3 = 250Kbaud,
4 = 125kBaud,
5 = 100Kbaud,
6 = 50kBaud,
7 = 20kBaud,
8 = 10kBaud

Activated bus parameter Value 0, the master device has found a configuration data
base coming from FB1131, value 1, the master device isn’t
configured and need to be configured via FB1131

Announced Nodes This value represents the number of found Node data sets in
the download database.

Wrong parameters This value indicates, if the master has detected any error in a
Node data set which was a containment of the actual
downloaded data base. For each Node which has a wrong
entry in there the counter is incremented by 1.

Table 40: CAN_TASK Common Variables
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9.1.3 CAN_TASK Node Running State

Figure 51: CAN_TASK Node Running State

To handle the Nodes in their different states and requirements the master
device has a so-called Node handler running, where each Node has its own
actual state. FB1131 interpret now the actual state of each Node and print it
on the screen in textual form.

9.1.4 CAN_TASK Global State Field
See section Global State Field at page 59.

9.1.5 CAN_TASK Communication Error

Figure 52: CAN_TASK Communication Error

For each Node the master has an internal online error buffer. FB1131
interprets now the actual error condition and print it on the screen in textual
form.
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9.1.6 Queues
The different incoming CAN specific identifier with their message
containment are assigned to different input message queues. A received
message is interpreted directly after it was received by the CAN controller
and stored into its corresponding queue as well as the messages that shall
be sent are stored in a queue while the CAN controller is busy in sending a
message. A main loop then interpret these messages and dequeue them or
the interrupt handler send the next message. The message queue handler
has three parameters and their containments are shown by FB1131.
bInner is the number of actual stored messages. bFront is the pointer
where the next message will be store and bRear is the pointer where the
next message will be dequeue from the queue body area. In a running
system the value bInner should normally decrease automatically to 0 and
bFront and bRear should be equal.

9.1.6.1 CAN_TASK Nodeguard Inputqueue

Figure 53: CAN_TASK Nodeguard Inputqueue

Variable Meaning

bRear Position of the next read access to the puffer of received CAN
telegrams

bFront Position of the next write access
bInner Number of CAN telegrams which are actual included in the

puffer

Table 41: CAN_TASK Nodeguard Inputqueue

9.1.6.2 CAN_TASK Management Inputqueue

Figure 54: CAN_TASK Management Inputqueue

Variable Meaning

bRear Position of the next read access to the puffer of received CAN
telegrams

bFront Position of the next write access
bInner Number of CAN telegrams which are actual included in the

puffer

Table 42: CAN_TASK Management Inputqueue
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9.1.6.3 CAN_TASK Emergency Inputqueue

Figure 55: CAN_TASK Emergency Inputqueue

Variable Meaning

bRear Position of the next read access to the puffer of received CAN
telegrams

bFront Position of the next write access
bInner Number of CAN telegrams which are actual included in the

puffer

Table 43: CAN_TASK Emergency Inputqueue

9.1.6.4 CAN_TASK Transmit Queue

Figure 56: CAN_TASK Transmit Queue

Variable Meaning

bRear Position of the next read access to the puffer of received CAN
telegrams

bFront Position of the next write access
bInner Number of CAN telegrams which are actual included in the

puffer

Table 44: CAN_TASK Transmit Queue
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9.1.7 CAN_TASK CMS Domain Services

Figure 57: CAN_TASK CMS Domain Services

The CANopen protocol defines different services which are summarised
under the name Domain Services. All Domain Services that are
transmitted and were received are counted in this table and shown online
by FB1131. A special value is the Hard transmission abort counter. Each
CAN message which is inserted into the CAN controller to be sent is
supervised by a simultaneously started timer. If the CAN controller cannot
sent the message because it don’t find any other CAN controller active in
the connected network who is acknowledging him the message, the
message can’t be sent and the timer expires. If so the message is thrown
away and the next message of the queue is inserted to be sent. So an
incrementing Hard transmission abort counter is directly an indication for
a physical hardware problem in the network. A possible fault that is often
made is a wrong configured baud rate for example that causes such an
error too.



96  ••••   Appendix FB1131 Fieldbus Configurator CANopen

Copyright •  ABB STOTZ-KONTAKT GmbH •

9.1.8 CAN_TASK Timeout Counter

Figure 58: CAN_TASK Timeout Counter

Normally PDOs are transferred in CANopen protocol without sending back
any kind of acknowledge message. But if input PDO data is polled by the
master with a remote request telegram each addressed Node has to
response. If a Node do not response to an outstanding remote request,
then the Timeout Counter of the corresponding Node is incremented by a
value of 1. So if a counter shows a value unequal 0 this can be seen as an
indication that the remote request rate is to high for the Node which cannot
answer to every request. In such case decrease the Node request poll rate
in the Node configuration window.
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9.1.9 CAN_TASK Node Init Counter

Figure 59: CAN_TASK Node Init Counter

The Node init counter is always incremented whenever the Node is
initialized. Normally the counter must show the value 1 for each configured
Node, but if a Node is detected as inactive during the Node guarding
procedure, then the master tries to reinitialize the Node again. If this
happens the Node init counter is incremented by a value of 1. So values
larger then 1 are an indication for communication error to the corresponding
Node station.
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9.2 COB-ID (Predefined Connection Set)
COB-ID means Communication Object Identifier. This is the 11 bit telegram
identifier of the CAN telegram. The higher 4 bits (bit 10 to 8) is the function
code and the lower 7 bits (bit 7 to 0) is the bus address of the Node.
Broadcast Objects:
Object Function

Code
COB ID
hex

COB ID
dec

Index in the Object
Directory

NMT 0000 00H 0 -
SYNC 0001 80H 128 1005H, 1006H, 1007H
TIME STAMP 0010 100H 256 1012H, 1013H

Table 45: COB ID - Broadcast Objects

Peer-to-Peer Objects:
Object Function

Code
COB ID
hex

COB ID
dec

Index in the Object
Directory

Emergency 0001 81H-FFH 129-255 1014H, 1015H
PDO 1 (tx) 0011 181H-1FFH 385-511 1800H
PDO 1 (rx) 0100 201H-27FH 513-639 1400H
PDO 2 (tx) 0101 281H-2FFH 641-767 1801H
PDO 2 (rx) 0110 301H-37FH 769-895 1401H
PDO 3 (tx) 0111 381H-3FFH 897-1023 1802H
PDO 3 (rx) 1000 401H-47FH 1025-1151 1402H
PDO 4 (tx) 1001 481H-4FFH 1153-1279 1803H
PDO 4 (rx) 1010 501H-57FH 1281-1407 1403H
SDO (tx) 1011 581H-5FFH 1409-1535 1200H
SDO (rx) 1100 601H-67FH 1537-1663 1200H
NMT Error
Control

1110 701H-77FH 1793-1919 1016H, 1017H

Table 46: COB ID - Peer-to-Peer Objects



FB1131 Fieldbus Configurator CANopen Appendix  ••••   99

Copyright •  ABB STOTZ-KONTAKT GmbH •

9.3 Object Dictionary
The Object Dictionary is a collection of data, which have influence on the
application and the communication of a CANopen device and the device
can be configured with this data collection. The entries are structured by
the index and the subindex.

9.3.1 Object Name and Object Code
The following table shows a list of the Object Codes:
Object Name Comment Object Code

NULL A dictionary entry with no data fields 0
DOMAIN Large variable amount of data e.g. executable program

code
2

DEFTYPE Denotes a type definition such as a Boolean, UNSIGED
16, float and so on

5

DEFSTRUCT complex Data type definition, e.g. PDO Mapping-
Structure

6

VAR A single value such as Unsigned 8, Boolean, visible
string etc.

7

ARRAY A multiple data field object where each data field is a
simple variable of the same basic data type e.g. array of
Unsigned 16
Sub-index 0 is of Unsigned 8 and therefore not part of
the array data.

8

RECORD A multiple data field object where the data fields may be
any combination of simple variables.
Sub-index 0 is of Unsigned 8 and therefor not part of the
record data.

9

Table 47: Object Codes

Note: The list of the Object Names and Object Codes is no information that
the Master or the Node support the respective data type.
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9.3.2 Object Dictionary Data Types
The following table is a survey of the data types and an extract of the
CANopen specification.

Note: The list of the data types is no information that the Master or the
Node support the respective data type.

Range Index (Hex) Object Name

Reserved 0000 reserved reserved
0001 DEFTYPE BOOLEAN
0002 DEFTYPE INTERGER 8
0003 DEFTYPE INTERGER 16
0004 DEFTYPE INTERGER 32
0005 DEFTYPE UNSIGNED 8
0006 DEFTYPE UNSIGNED 16
0007 DEFTYPE UNSIGNED 32
0008 DEFTYPE REAL 32
0009 DEFTYPE VISIBLE_STRING
000A DEFTYPE OCTET_STRING
000B DEFTYPE UNICODE_STRING
000C DEFTYPE TIME_OF_DAY
000D DEFTYPE TIME_DIFFERENCE
000E DEFTYPE BIT_STRING
000F DEFTYPE DOMAIN
0010 DEFTYPE INTERGER 24
0011 DEFTYPE REAL 64
0012 DEFTYPE INTERGER 40
0013 DEFTYPE INTERGER 48
0014 DEFTYPE INTERGER 56
0015 DEFTYPE INTERGER 64
0016 DEFTYPE UNSIGNED 24
0017 reserved reserved
0018 DEFTYPE UNSIGNED 40
0019 DEFTYPE UNSIGNED 48
001A DEFTYPE UNSIGNED 56
001B DEFTYPE UNSIGNED 64

Static data types

001C-001F reserved reserved

Continuation see next page.
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0020 DEFSTRUCT PDO_COMMUNICATION_PARAMETER
0021 DEFSTRUCT PDO_MAPPING
0022 DEFSTRUCT SDO_PARAMETER
0023 DEFSTRUCT IDENTITY

Complex data types

0024-003F reserved reserved
Manufacturer specific
complex data types

0040-005F DEFSTRUCT Manufacturer specific complex data types

0060-007F DEFTYPE Device profile (0) specific standard data types
0080-009F DEFSTRUCT Device profile (0) specific complex data types
00A0-00BF DEFTYPE Device profile 1 specific standard data types
00C0-00DF DEFSTRUCT Device profile 1 specific complex data types
00E0-00FF DEFTYPE Device profile 2 specific standard data types
0100-011F DEFSTRUCT Device profile 2 specific complex data types
0120-013F DEFTYPE Device profile 3 specific standard data types
0140-015F DEFSTRUCT Device profile 3 specific complex data types
0160-017F DEFTYPE Device profile 4 specific standard data types
0180-019F DEFSTRUCT Device profile 4 specific complex data types
01A0-01BF DEFTYPE Device profile 5 specific standard data types
01C0-01DF DEFSTRUCT Device profile 5 specific complex data types
01E0-01FF DEFTYPE Device profile 6 specific standard data types
0200-021F DEFSTRUCT Device profile 6 specific complex data types
0220-023F DEFTYPE Device profile 7 specific standard data types

Device profile data types

0240-025F DEFSTRUCT Device profile 7 specific complex data types
Reserved 0300-0FFF reserved reserved

Table 48: Object Dictionary Data Types
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9.3.3 Object Dictionary Profile
The following table is a survey of the profile object dictionary and an extract
of the CANopen specification.

Note: The list of the single objects is no information that the Master or the
Node support the respective object and the function which is associated
with it.

Range Index (Hex) Object Name Type / Access

1000 VAR Device Type Unsigned 32 / ro
1001 VAR Error Register Unsigned 8 / ro
1002 VAR Manufacturer Status Register Unsigned 32 / ro
1003 ARRAY Pre-defined Error Field Unsigned 32 / ro
1004 - Reserved -
1005 VAR COB-ID SYNC Unsigned 32 / rw
1006 VAR Communication Cycle Period Unsigned 32 / rw
1007 VAR Synchronous Window Length Unsigned 32 / rw
1008 VAR Manufacturer Device Name Visible_string / c
1009 VAR Manufacturer Hardware Version Visible_string / c
100A VAR Manufacturer Software Version Visible_string / c
100B - Reserved -
100C VAR Guard Time Unsigned 32 / rw
100D VAR Life Time Factor Unsigned 32 / rw
100E - Reserved -
100F - Reserved -
1010 VAR Store Parameters Unsigned 32 / rw
1011 VAR Restore Default Parameters Unsigned 32 / rw
1012 VAR COB-ID TIME Unsigned 32 / rw
1013 VAR High Resolution Time Stamp Unsigned 32 / rw
1014 VAR COB-ID EMCY Unsigned 32 / rw
1015 VAR Inhibit Time EMCY Unsigned 16 / rw
1016 ARRAY Consumer Heartbeat Time Unsigned 32 / rw
1017 VAR Producer Heartbeat Time Unsigned 16 / rw
1018 RECORD Identity Object Identity / ro
1018 / 0 Number of Entries Unsigned 8
1018 / 1 Vendor Information Unsigned 32
1018 / 2 Product Code Unsigned 32
1018 / 3 Revision Number Unsigned 32
1018 / 4 Serial Number Unsigned 32

Communication Profile

1019-11FF - Reserved -

Continuation see next page.
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Range Index (Hex) Object Name Type / Access

1200 RECORD Server 1. SDO Parameter SDO_Parameter
/ ro

1200 / 0 Number of Entries Unsigned 8
1200 / 1 COB-ID Client -> Server Unsigned 32
1200 / 2 COB-ID Client <- Server Unsigned 32
1200 / 3 NodeID Unsigned 8
1201-1277 RECORD Server 2. to 127. SDO Parameter SDO_Parameter

/ rw
1280-12FF RECORD Client SDO Parameter SDO_Parameter

/ rw
1300-13FF - Reserved -
1400-15FF RECORD Receive PDO Parameter PDO_Com_Para

/ rw
1400 / 0 Number of Entries Unsigned 8
1400 / 1 COB-ID Unsigned 32
1400 / 2 Transmission Type Unsigned 8
1400 / 3 Transmit Prohibited Time Unsigned 16
1400 / 4 Reserved Unsigned 8
1400 / 5 Event Timer Unsigned 16
1600-17FF ARRAY Receive PDO Mapping PDO_Mapping /

rw
1600 / 0 Number of Entries Unsigned 8
1600 / 1 1. Object Unsigned 32
1600 / 2 2. Object Unsigned 32
1600 / ... n. Object Unsigned 32
1600 / 40 64. Object Unsigned 32
1800-19FF RECORD Transmit PDO Parameter PDO_Com_Para

/ rw
1A00-1BFF ARRAY Transmit PDO Mapping PDO_Mapping /

rw

Communication Profile

1C00-1FFF - Reserved -
Manufacturer Specific
Profile

2000-5FFF

6000-67FF Device Profile 1
6800-6FFF Device Profile 2
7000-77FF Device Profile 3
7800-7FFF Device Profile 4
8000-87FF Device Profile 5
8800-8FFF Device Profile 6
9000-97FF Device Profile 7

Standardized Device
Profiles

9800-9FFF Device Profile 8
Reserved A000-FFFF - Reserved -

Table 49: Object Dictionary Profile
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9.4 Communication Profile, Device Profile and Device Type
The Communication Profile DS 301 specifies, how to communicate. The
Device Profiles DS 401ff specify, what is communicated.
Device Profile Description

301 Common communication profile according to DS301
401 Device profile for I/O modules
402 Device profile for drives
406 Device profile for encoder

Table 50: Device Profile and Device Type

9.4.1 Communication Profile 301
The communication profile DS 301 is a common profile. It is the basic of
CANopen communication and lays down, how the device on the CANopen
communicate with each other.

9.4.2 Device Profile 401 - Device Profile for I/O Modules
The device profile DS 401 is a profile for I/O modules.

Figure 60: Device Profile 401

Figure 61: Selection of the Device Type in case of Device Profile 401

Device Profile Device Type Description

401 Digital Input
Digital Output
Analog Input
Analog Output

Device Profile for I/O Modules

Table 51: Device Profile for I/O Modules
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9.4.3 Device Profile 402 - Device Profile for Drives
The device profile DS 402 is a profile for drives.

Figure 62: Device Profile 402

Figure 63: Selection Device Type in case of Device Profile 402

Device Profile Device Type Description

402 Frequency Converter
Servo Drive
Stepper Motor
I/O Module
Multi device module

Device profile for drives

Table 52: Device Profile for Drives
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9.4.4 Device Profile 406 - Device Profile for Encoder
The device profile DS 406 is a profile for encoder.

Figure 64: Device Profile 406

Figure 65: Selection of the Device Type in case of Device Profile 406

Device Profile Device Type Description

406 Single Turn absolute rotary encoder
Multi Turn absolute rotary encoder
Single Turn absolute rotarey encoder with
electronic turncount
Incremental rotary encoder
Incremental rotary encoder with electronic
counting
Incremental linear encoder
Incremental linear encoder with electronic
counting
Absolute linear encoder
Absolute linear encoder with cyclic coding

Device profile for encoder

Table 53: Device Profile for Encoder
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9.5 PDO Mapping Method
The PDO Mapping with degree of freedom was fixed in the specification
DS301 V3. The Fieldbus Configurator produces the following PDO
Mapping:

•  Subindex 0 the number of objects (value N) is entered in object 16xx
(and object 1Axx respectively).

•  Subindex 1 to N are entered in the objects which are to be mapped in
object 16xx (and object 1Axx respectively).

The PDO Mapping was laid down more exactly in the specification DS301
V4. Thereby particular the fist mapped information in the Node is deleted,
then it is described new and after this it is set to valid.
•  To delete the information of the PDO Mapping in the Node (and to set

it back to the default mapping respectively), in object 16xx (and object
1Axx respectively) Subindex 0 the value 0 is written down.

•  The objects which are to be mapped are entered in object 16xx (and
respectively object 1Axx) Subindex 1 to N.

•  The number of objects is entered (value N) in object 16xx (and
respectively object 1Axx).
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9.6 NMT State Machine (State Diagram)
NMT stands for Network Management.
The following diagram shows the possible states of a CANopen Node.

Figure 66: NMT-State Machine

Number Meaning

1 At Power on the initialisation state is entered autonomously
2 Initialisation finished -enter PRE_OPERATIONAL automatically
3, 6 Start_Remote_Node indication
4, 7 Enter_PRE-OPERATIONAL_State indication
5, 8 Stop_Remote_Node indication
9, 10, 11 Reset_Node indication
12, 13, 14 Reset_Communication indication

Table 54: Description NMT-State Machine
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9.6.1 Communication Characteristics in the different NMT States
The following table shows the possible communication in the respective
NMT states.
Communication Initialization Pre-Operational Operational Stopped

PDO X
SDO X X
SYNC X X
Time Stamp X X
EMCY X X
BootUp X
NMT X X X

Table 55: Communication in the different NMT States
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9.7 LSS/LMT Services
LSS stands for Layer Setting Services, LMT stands for Layer Management
and is an older designation.
LSS/LMT supports access to the basic parameter like

•  Baud Rate

•  Node ID

via the CAN network also without mechanical setting possibilities on the
Node. The communication is based on a Master/Slave relationship and
uses the COB-ID 2020 (07E4H, Slave to Master) and 2021 (07E5H, Master
to Slave).
The LSS/LMT Slave need to be in the NMT state Stop, to perform the
LSS/LMT services. The LSS/LMT Slave is able to take the following both
states

•  Operation Mode = Operating mode with valid parameters and

•  Configuration Mode = Configuration Mode.

Note: It is permitted to couple only one Node to the Master at a time.
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9.8 Emergency Telegrams
Emergency Telegrams are sent by the Node in case of a Node internal
event.
The Emergency Telegram has the following structure:
Byte 1 Byte 2 Byte 3 Byte 4 Byte 5 Byte 6 Byte 7 Byte 8

Error
Code
LSB

Error
Code
MSB

Error
Register

Comm.
Error

Device
Error

Emergency
Trigger

Info 0 Info 1

Table 56: Emergency Telegram (Structure)

•  Error Code (Byte 1 and 2): See section Emergency Telegram Error
Codes on page 112.

•  Error Register (Byte 3): Object 1001H. See device description of the
Node manufacturer.

•  Manufacturer specific error field (Byte 4 to 8): See device description
of the Node manufacturer.
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9.8.1 Emergency Telegram Error Codes
The meaning of the Error Codes are shown in the following table:
Error Code (Hex) Meaning

00xx No error or reset
10xx Generic error
20xx Current
21xx      Current, device input side
22xx      Current inside the device
23xx      Current, device output side
30xx Voltage
31xx      Mains voltage
32xx      Voltage, inside the device
33xx       Output Voltage
40xx Temperature
41xx      Ambient temperature
42xx      Device temperature
50xx Device Hardware
60xx Device Software
61xx      Internal Software
62xx      User Software
63xx      Data Set
70xx Additional Modules
80xx Monitoring
81xx      Communication
8110      CAN Overrun (Object lost)
8120      CAN in Error Passive Mode
8130      Life Guarding Error or Heartbeat Error
8140      recoverefrom bus off
82xx Protocol Error
8210      PDO not processed due to length error
8220      PDO length exceeded
90xx External Error
F0xx Additional Functions
FFxx Device specific

Table 57: Emergency Error Codes

Note: The table Emergency Error Codes is a common list. To see the exact
meaning of these codes we refer to the Node manufacturer.
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11 Glossary
COB-ID

Communication object identifier. Table in section COB-ID on page 98.

LMT

Layer Management.

LSS

Layer Setting Services.

NMT

Network Management. This contains the functions configuration,
initialization and supervision of the network devices.

FB1131

Fieldbus Configurator.
Configurations- and Diagnostic Tool.
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1 Overview FB1131
1.1 Main Functions

The main functions of the CANopen Fieldbus Configurator are:
Function Section Short Description

Configuration Overview Communication Types Overview communication types and
description of the configuration steps

Diagnostic Diagnostic Functions Extended device diagnostic
Project Information Set the project informationDocumentation
Print Print out the configuration

Table 1: FB1131 Main Functions
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1.2 Properties
FB 1131 is an universal Fieldbus Configurator
This means you can configure the most important fieldbus systems like
PROFIBUS, DeviceNet, and InterBus with the same tool.

FB 1131 is a global Fieldbus Configurator
You configure all devices with one tool. FB 1131 checks the dependencies
between the devices. FB 1131 only allows configurations that make sense.
In case of doubt FB 1131 will give you a warning.

FB 1131 documents your Fieldbus system
After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the detail of one
device.

FB 1131 uses standardized configuration files
Some protocols support standardized files containing information about all
features and limitations of the Slave device. FB 1131 uses these files for
the configuration.

FB 1131 is a diagnostic tool
After the configuration you can switch FB 1131 into the diagnostic mode.
You can watch all status information of the couplers, see protocol
dependent diagnostic information. In this case a Slave is not operating
correctly will be displayed in a different colour.
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2 Installation
2.1 System Requirements

• PC with 486-, Pentium processor or higher

• Windows 98/ME, Windows NT 4.0/2000/XP

• Free disk space: 30 - 80 MByte

• CD ROM drive

• RAM: min. 16 MByte

• Graphic resolution: min. 800 x 600 pixel

• Windows 95: Service Pack 1 or higher

• Windows NT: Service Pack 6 or higher

• Keyboard and Mouse
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2.2 Software Installation
Close all application programs on the system!
Insert the 907 AC 1131 CD in the local CD ROM drive. If "Autorun" is
enabled on the PC the CD menu will start automatically. Otherwise it is
started by starting the file "CD_Menu_Vxx.exe" in the root directory of the
CD. For example by the menu Start > Run and entering
"[X:]\CD_Menu_Vxx.exe" ([X] is the CD rom drive and Vxx stands for the
version number).
You reach the Installation menu of the CD by operating the Installation
907 AC 1131 Vxx button.
With the menu Notes for Installation you get a description of the
installation and the components of the 907 AC 1131, the programming
software, the Fieldbus Configurator 907 FB 1131, OPC Server.

Note: Administrator privileges are required on Windows NT/2000/XP
systems for installation of the Fieldbus Configurator 907 FB 1131!
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3 Getting Started – Configuration Steps
3.1 Overview Communication Types

Select from the following table the Ethernet protocol that you want to use.
The configuration steps are described in the given section.

Communication Described in section Page

Ethernet (TCP(UDP)
Open Modbus / TCP

Configuration Ethernet (TCP/UDP) / Open Modbus/TCP 11

Table 2: Overview Communication Ethernet Protocols

3.2 Configuration Ethernet Protocols

3.2.1 Configuration Ethernet (TCP/UDP) / Open Modbus/TCP
The following table describes the steps to configure an Ethernet coupler
with the Ethernet (TCP/UDP) and the Open Modbus/TCP protocol as it is
typical for many cases.

# Action Menu in the System Configurator Detail information in section Page
1 Create a new project File > New > Ethernet/Protocol Setting up the Ethernet

Configuration
13

2 Choose Ethernet coupler Insert > Device Insert Coupler (Device) 14

3 Set Device Assignment Settings > Device Assignment Device Assignment 17

4 Set Parameter Settings > Device Parameters Ethernet Parameter 22

5 Save project File > Save Save and Save As 37

6 Download Online > Download Downloading the Configuration 32

Table 3: Steps for Configuration of the Ethernet (TCP/UDP) and Open Modbus / TCP
coupler
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4 Configuration of Ethernet with FB 1131
4.1 Setting up the Ethernet Configuration

To create a new configuration, choose the File > New menu. This will offer
a selection list of fieldbus systems. Choose Ethernet/Protocol. If only the
Ethernet/Protocol system is installed, the configuration window will open
directly.
The name of the configuration file can be allocated when the configuration
is finished or with File > Save As.
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4.2 Coupler

4.2.1 Insert Coupler (Device)
In order to insert a coupler (device) into the configuration, choose the
Insert > Device menu or click on the symbol:
Symbol Insert > Device

Figure 1: Symbol Insert > Device

The dialog box opens, from which exactly one coupler can be chosen in the
list Available devices. By clicking at the Add the chosen coupler appears
in the right dialog Selected Devices.

Figure 2: Insert > Device

This example shows a 07 KT 97 Ethernet with the Description 07 KT 97
Ethernet, which is changeable in this field.
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4.2.2 Replace Device (Coupler)
If a coupler already exists in the configuration and should be replaced
against another coupler select the menu Insert > Device or click on the
"Insert device" symbol. A security question appears, if the device should be
replaced.

Figure 3: Security Question Replace Device

If you click the Yes button a new window opens, where you can replace the
existing coupler against another one.
In this window you select the coupler from the list Available devices by
clicking on it and by clicking the Add button this coupler is shown in the first
position in the list Selected devices. With OK you confirm the selection
and the coupler will be replaced.

Figure 4: Replace coupler (Device)



16  ••••  Configuration of Ethernet with FB 1131 FB1131 Ethernet Configurator

Copyright • ABB STOTZ-KONTAKT GmbH



FB1131 Ethernet Configurator Settings  ••••  17

Copyright • ABB STOTZ-KONTAKT GmbH

5 Settings
5.1 Device Assignment

5.1.1 TCP/IP Driver
The TCP/IP Driver builds up a connection to the coupler via TCP/IP and is
choosen via Settings > Device Assignment.
When the window opens or by a click on the button NetIdent Rescan the
local Ethernet network will be scanned for devices that support the
identification with the NetIdent protocol. Found and connectable couplers
are displayed in the table Board Selection (upper table). Exactly to one
coupler a connection can be build up, which is done by selecting the
checkbox in front of the IP Address.

Figure 5: Settings > Device Assignment > TCP/IP Driver
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Alternatively, the IP Address can be filled in at Add IP Address and be
added with the button Add. This way has to be used,

• when the coupler is located in an other Ethernet network and
reachable via an Ethernet gateway

• when the coupler does not support the NetIdent protocol.
When the coupler already has an IP Address, it is shown in the field IP
Address. If the shown IP Address is 0.0.0.0, an IP Address has to be
assigned to the coupler with the button Set IP Address.

Note: This IP Address is only temporarly adjusted. A permanent storage of
the IP Address takes place with a download of the configuration from the
FB1131 configurator.
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The following figure shows an assigned coupler.

Figure 6: Settings > Device Assignment > TCP/IP Driver

Couplers listed in the lower table are found in the local Ethernet network,
but can't be assigned, because they belong to an other device family.
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5.1.2 Gateway Driver
The Gateway Driver terminies how the Fieldbus Configurator
communicates with the device. This is set in the Device Assignment which
can be opened with the menu Settings > Device Assignment.

Figure 7: Settings > Device Assignment

After the selection of the Gateway channel or clicking the Connect button
FB 1131 tries to set up a connection to the selected controller.
If the connection was successful the configurable couplers are shown in the
field Device Information.
The desired coupler is selected by clicking on the field next to the name of
the coupler and confirming with the OK button.
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By clicking at the Gateway Configuration button a new window appears
where the Gateway channel can be selected or a new Gateway channel
can be configured.

Figure 8: Configure Gateway

To confirm the Channel selection click at the OK button.
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5.2 Ethernet Parameter
The Ethernet Parameter are the basis for the working communication. This
section contains information for setting the Ethernet Parameter and a
description for the individual parameter.

Parameter Described in section Page

IP Address IP Address 23

Ethernet Ethernet 24

Open Modbus/TCP Open Modbus/TCP 26

Table 4: Setting of the Coupler Parameter

If you have set an configuration and you want to set the Parameter select
the menu Settings > Device Parameter.
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5.2.1 IP Address

Figure 9: Settings > Device Parameter > IP Address

Description:
The description of the coupler is shown in FB 1131 as the name of the
device. The description is changeable in this field.

The handing over of the IP parameters (IP address, Net mask, Gateway)
can result in three ways.
DHCP:
The coupler gets the IP parameters from a DHCP server.
BOOTP:
The coupler gets the IP parameters from a BOOTP server.
IP address, Net mask and Gateway:
The IP parameters can be entered in this fields.
If more than one configuration way is activated (for example DHCP and
manually entered IP parameters), the device trys to process the different
configuration ways one after the other. As soon as it got an IP configuration
in one of this ways, the coupler starts with this parameters.
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5.2.2 Ethernet

Figure 10: Settings > Device Parameter > Ethernet

Description:
The description of the coupler is shown in FB 1131 as the name of the
device. The description is changeable in this field.
Auto detect:
If this option is selected an automatic detection of the Ethernet interface
results.
Interface:
Here the manually setting of the Ethernet interface can be done. The user
has the possibility to select Twisted Pair or AUI but at the moment just
Twisted Pair is supported. The description of this you find in section
Twisted Pair and AUI on page 65.
Auto negotiation:
If this option is selected, the speed of the interface is detected
automatically.
Duplex mode:
Duplex mode of the Ethernet interface. You can select between Full Duplex
and Half Duplex. The description of this you find in section Full Duplex and
Half Duplex on page 65.
Speed:
Transmission speed of the data: 10 Mbit/s or 100 Mbit/s.



FB1131 Ethernet Configurator Settings  ••••  25

Copyright • ABB STOTZ-KONTAKT GmbH

Set MAC address:
If this option is selected you activate the manual MAC address
configuration. If this option is not selected the card has the default address
which was set by the manufacturer.
MAC address (hex):
Here you can enter the manual settings of the MAC address of the device.
The address format is 6 byte in the Hex Code.
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5.2.3 Open Modbus/TCP

Figure 11: Settings > Device Parameter > Open Modbus

Description:
The description of the coupler is shown in FB 1131 as the name of the
device. The description is changeable in this field.
Server connections:
You can set up max. 12 Server connections simultaneously.
Telegram timeout:
The order is stopped by the application when no answer results from the
couple partner depending on the set time in this field.
Connect. remain open time:
The connection to the Server is maintained depending on the set time and
after expiration of this time it is stopped, if no new order was sent by the
application.
Send timeout:
This is the Send timeout for the TCP connection. Is only used internally. In
this field you type in the timeout, how long it is tried to take off the orders
via TCP/IP.
Connect timeout:
This is the connect timeout for the TCP connection. Is only used internally.
Here you give the timeout, how long the TCP Task tries to built up a
connection to the Server.
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Close timeout:
This is the close timeout for the TCP connection built up. This is only used
internally. In this field you type in the timeout, how long the TCP Task tries
to built up a connection.
Swap:
Data format, filling of the I/O data in the DPM. Motorola / Intel Format.
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5.3 Project Information
If the user creates his own project, the project information can be typed in
into the Settings > Project Information menu. Anybody can then read this
entry when this menu is called up.

Figure 12: Settings > Project Information

By clicking the OK button the Project Information is saved.
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5.4 Language
Choose the Settings > Language menu and the following window opens:

Figure 13: Settings > Language

Here you have the possibility of setting the language of the FB1131. Select
the desired language and confirm the entry with the OK button.

A message appears that the FB 1131 must be started again in order to
activate the selected language. Please carry this out.
After restarting the FB 1131, the language will have changed to the one
selected.

Note: Up to now not all languages are available for all FB 1131 modules!
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6 Online Functions
6.1 Introduction

In this section all the functions that directly influence Ethernet coupler.

Note: Please note that this also permits an interruption of the running
communication or that input and output can be switched ON or OFF.
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6.2 Online to the Coupler

6.2.1 Downloading the Configuration
In order to release the configuration and network access, a transfer
(Download) to the coupler must be carried out on the Online > Download
menu. A warning will appear that the communication on the
Ethernet/Protocol will be interrupted. This warning must be confirmed.

Figure 14: Security question before Download

Attention: The download overwrites the configuration in the coupler and
the communication with the connected devices is interrupted.

Figure 15: Online > Download

Before the Download is executed, the configuration is checked by the
Configurator.
The configuration is transferred into the selected coupler and is stored
there in FLASH memory in a zero voltage manner so that the configuration
is available when the voltage supply is switched off and on again.
After the download, the coupler carries out an internal restart (reset).
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6.2.2 Firmware Download
If you want to carry out a Firmware download, act as follow: Call up the
Online > Firmware Download menu.

A warning appears that the communication will be interrupted. This warning
must be confirmed by clicking at the Yes button.

Figure 16: Security question before Firmware Download

Select the new Firmware and retrieve it with Download into the coupler.
The Firmware is now retrieved.
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6.2.3 Firmware / Reset
First the desired coupler must be chosen with a left mouse click on the
symbol of the coupler. Then the Online > Firmware / Reset menu must be
called up and the name and the version of the Firmware are displayed.
The coupler is reset with the Reset button.

6.2.4 Device Info
First the desired coupler must be chosen with a left mouse click on the
symbol of the coupler. Then select the Online > Device Info menu in order
to obtain further information on the selected coupler.
The manufacturer date, the device number and the serial number of the
coupler is retrieved and shown.

Figure 17: Online > Device Info
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6.3 Diagnostic Functions
The following table shows diagnostic functions and their using in case of
Ethernet couplers.

Diagnostic Function Using

Diagnostic Functions Statistic information and State information of the Ethernet
coupler

Table 5: Overview Diagnostic Functions

6.3.1 Extended Device Diagnostic
The Extended Device Diagnostic helps to find communication and
configuration errors when the FB1131 menu functions are of no further
help.
Select the Online > Extended Device Diagnostic menu.

This menu opens a list of diagnostic structures. These contain online
counters, states and parameters.
Select the protocol which is used in your configuration in the following table.
In the given section you find the Extended Device Diagnostic for the
corresponding protocol.

Protocol Page

Extended Device Diagnostic Ethernet (TCP/UDP) /
Open Modbus/TCP

36

Table 6: Selection of the Protocol for the Extended Device Diagnostic
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6.3.1.1 Extended Device Diagnostic Ethernet (TCP/UDP) / Open Modbus/TCP

If an Ethernet (TCP/UDP) / Open Modbus/TCP configuration is loaded and
the menu Online > Extended Device Diagnostic is selected the following
window with the diagnostic structures of the Ethernet (TCP/UDP) / Open
Modbus/TCP configuration appears.

Figure 18: Online > Extended Device Diagnostic Etherent (TCP/UDP) / Open Modbus/TCP

Task/Taskstate Page

PLC_TASK Variables 60
OMB_TASK Task Information 61
OMB_TASK Client 62
OMB_TASK Server 63
OMB_TASK I/O 64
TCP_UDP_TASK Task Information 53
TCP_UDP_TASK Code Diag 54
IP_TASK Task Information 55
IP_TASK Ethernet Status 56
IP_TASK Ethernet Count 57
IP_TASK Packet Count 58
IP_TASK Code 59

Table 7: Ethernet (TCP/UDP) / Open Modbus/TCP Task States
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7 File, Print, Export, Edit and View
7.1 File

7.1.1 Open
An existing project can be opened with File > Open.

7.1.2 Save and Save As
When the file name is known, the configuration can be saved under the File
> Save menu, otherwise the File > Save As menu must be selected.

7.1.3 Close
The current project can be closed with File > Close.

7.2 Print
After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu. For
a page view, select the File > Page View menu.
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7.3 Export Functions

7.3.1 DBM Export
Select the File > Export > DBM menu in order to save the previously
saved project file in a DBM file (binary format). This DBM file can be
retrieved in the DOS Compro program. The configuration is stored in the
Project directory in the path of the FB 1131 Installation with the extension
*.DBM.

Attention: The file name may be long max. 8 characters.

7.4 Edit

7.4.1 Delete
To delete a coupler you have to select the menu Edit > Delete. Before FB
1131 deletes the coupler a security question appears. If you really want to
delete this coupler you have to confirm this question with Yes, and the
coupler will be deleted.

Figure 19: Security question delete device (coupler)

Note: When you delete a coupler the settings and the configuration of this
coupler get lost.
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7.5 View

7.5.1 Toolbars
In the menu View > Toolbars the user has the possibility to activate or
deactivate the Toolbars Standard and Fieldbus. If this function is
deactivated the toolbars are not shown.

7.5.2 Status Bar
In the menu View > Status Bar this bar can be activated (with hook) or
deactivated (without hook).
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8 Error Numbers
8.1 Possible PLC Error Messages to FB1131 Telegrams

Error Number Description

401 driver error in the control
402 slot number is not supported by the hardware
403 no coupler at the given slot
404 control not in STOP
405 configuration data invalid
406 coupler still configured by 907 AC 1131-internal PROFIBUS Configurator
407 answer timeout of the coupler

Table 8: Possible Control Error Messages to FB1131 Telegrams
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8.2 RCS Error Numbers (4 .. 93)
This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of Controller of series
90. The error number is returned in an answer message. Command
messages and answer messages are used to communicate between the
application (e.g. the Fieldbus Configurator) and the ABB Stotz-Kontakt
device. An example of this communication is the download of a
configuration.
Error Number Description

4 Task does not exist
5 Task is not initialised
6 The MCL is locked
7 The MCL rejects a send command because of an error
20 The user will download a database into the device that is not valid for

this device type.
21 Data base segment not configured or not existent
22 Number for message wrong during download
23 Received number of data during download does not match to that in the

command message
24 Sequence identifier wrong during download
25 Checksum after download and checksum in command message do not

match
26 Write/Read access of data base segment
27 Download/Upload or erase of configured data base type is not allowed
28 The state of the data base segment indicated an error. Upload not

possible
29 The access to the data base segment needs the bootstraploader. The

bootstraploader is not present
30 Trace buffer overflow
31 Entry into trace buffer too long
37 No or wrong licence. The OEM licence of the Fieldbus Configurator

allows only communication to devices that have the same licence inside
38 The data base created by the Fieldbus Configurator and the data base

expected by the firmware is not compatible
39 DBM module missing

Table 9: RCS error numbers (answer message) (4..39)
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Error Number Description

40 No command free
41 Command unknown
42 Command mode unknown
43 Wrong parameter in the command
44 Message length does not match to the parameters of the command
45 Only a MCL does use this command to the RCS
50 FLASH occupied at the moment
51 Error deleting the FLASH
52 Error writing the FLASH
53 FLASH not configured
54 FLASH timeout error
55 Access protection error while deleting the FLASH
56 FLASH size does not match or not enough FLASH memory
60 Wrong structure type
61 Wrong length of structure
62 Structure does not exist
70 No clock on the device
80 Wrong handle for the table (table does not exist)
81 Data length does not match the structure of this table
82 The data set of this number does not exist
83 This table name does not exist
84 Table full. No more entries allowed
85 Other error from DBM
90 The device info (serial number, device number and date) does already

exist
91 Licence code invalid
92 Licence code does already exist
93 All memory locations for licence codes already in use

Table 10: RCS error numbers (answer message) (40..93)
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8.3 Database Access Error Numbers (100 .. 130)
The following table lists the error numbers of the database access errors
Error Number Description

100 Database already opened
101 Dataset could not be opened
103 Error while opening database occurred
104 No valid path name
105 No connection to data base. Call function DbOpen().
106 Error in parameter
107 Error during opening a table
108 Nullpointer occurred
109 Table not opened. Call function OpenTable() first.
110 The first record is reached
111 The last record is reached
112 Unknown type in the record found
113 Data has to be truncated
114 No access driver installed on the system
115 Exception received
116 This table is set to read only
117 There is no data set in the table
118 The requested table could not be edit
119 An operation could not be completed
120 User gives an unexpected length in WritsDs().
121 An assertion failed
122 DLL not found
123 DLL couldn't be freed
124 Specified function not found in the DLL
125 ODBC Function returns an error
126 Count of data bytes in the record exceeds 1938
127 DBM32 DLL is not loaded
128 Field with the given index was not found
129 This table contains no records
130 Invalid character (' ') found in a Table or Column

Table 11: Database Access Error Numbers (100..130)
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8.4 Online Data Manager Error Numbers

8.4.1 Online Data Manager Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.
Error Number Description

1000 Driver OnlineDataManager not opened
1001 Initialization of the OnlineDataManager has failed
1002 No DriverObject found. OnlineDataManager Sub DLL not found.
1003 No DeviveObject found. Device not found.
1004 Application not found
1010 Application has requested an unknown event
1011 Application has requested an unknown function mode, operating mode.

Known function modes, operating modes are Reset, Download, Register
Server, Unregister Server.

1012 Application has requested an unknown command
1013 Message Server already exists
1014 Message Server not registered
1015 Device already in use
1016 Device not assigned
1017 Device has changed
1018 Command active

Table 12: Online Data Manager Error numbers (1000..1018)

8.4.2 Message Handler Error Numbers (2010 .. 2027)
The following table lists the error numbers of the Message handler of the
Online Data Manager.
Error Number Description

2010 Message handler: Messagebuffer empty
2011 Message handler: Messagebuffer full
2021 Message handler: Invalid Message ID (msg.nr)
2022 Message handler: No entry
2023 Message handler: Message already active
2024 Message handler: Wrong Application
2025 Message handler: Message Timeout
2026 Message handler: Wait for Delete
2027 Message handler: No cyclic Message

Table 13: Error Numbers of the Message Handler of the Online Data Manager (2010..2027)
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8.4.3 Driver Functions Error Numbers (2501 .. 2512)
The following table lists the error numbers of the Driver Functions of the
Online Data Manager.
Error Number Description

2501 OnlineDataManager Sub DLL not found
2502 Function missing
2503 'Read Thread' not created
2504 'Write Thread' not created
2505 'IO Thread' not created
2510 Function failed
2512 Assign reports error. Return neither OK or cancel

Table 14: Error Numbers of the Driver Functions of the Online Data Manager (2501..2512)

8.4.4 Online Data Manager Subfunctions Error Numbers (8001 ..
8035)

The following table lists the error numbers of the Subfunctions of the Online
Data Manager.
Error Number Description

8001 Driver not opened. E.g. CIF Device Driver
8002 Application has requested an unknown event
8003 Application has requested an unknown command
8004 Command has failed
8005 Command active
8006 Device invalid
8010 No device was assigned
8011 Device was already assigned
8020 Driver not connected
8021 Driver already connected
8030 Faulty 'GetState'
8031 Send error (PutMessage returns error)
8032 Send active (PutMessage active)
8033 Receive error (GetMessage returns error)
8034 Receive active (GetMessage active)
8035 IO Error (ExchangeIO returns error)

Table 15: Subfunction Error Numbers of the Driver Functions of the Online Data Manager
(8001..8035)



FB1131 Ethernet Configurator Error Numbers  ••••  47

Copyright • ABB STOTZ-KONTAKT GmbH

8.5 Data Base Functions Error Numbers (4000 .. 4098)
The following table lists the error numbers of the converting functions.
Error Number Description

4000 File does not exist
4001 Success in comprimizing
4002 Dataset does not exist
4003 Last respectively first entry reached
4004 Not enough memory
4005 File directory full
4006 Max number of entries reached
4007 No writing to this table possible, because the table is located in the

FLASH
4008 Table name does already exist
4009 File name does not exist
4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2
4011 Parameter ‘next’ wrong
4012 Not enough free space to copy data set
4013 Set is deleted
4014 Value for Index is wrong
4015 Access not allowed
4016 open_file used before init_file
4017 Drive is not ready
4018 Not enough drive memory
4019 File name or path does not exist
4020 Cannot create path
4021 Wrong path
4022 Wrong flag
4023 The delete path is the root path
4024 Path file exists
4025 Write error during write a file
4026 Error during create a file
4027 Error during close a file
4028 No DBM file
4029 Length of the read data is unequal of the file length

Table 16: Error numbers of converting functions (4000..4029)
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Error Number Description

4030 Path too long
4031 Directory changed
4032 Directory created
4034 Length of converting stream is 0
4035 Non equal data set found
4036 Non equal data set found
4037 Non equal data set found
4038 Data set has length 0
4039 The function DbmInit has assigned a Zero pointer during RCS

initialisation
4040 Printer not ready
4041 The data base is used from another function
4042 New length of data base is smaller than used
4043 Unknown access mode
4044 Old data base has to be converted
4045 Error while converting. Function not known
4046 Unknown type in set 0 found
4047 No float function available
4048 Function not in RCS module
4049 Check failed
4050 Checksum check failed
4051 More segments are existing in file, than in the structure FILE_INFO_T in

wMaxEintraege
4052 SegLen in structure FILE_INFO_T is smaller then the length in the file.

Return of function dbm_restore_data
4053 The header file holds an other information for a length than in the

segment itself
4054 Not enough memory for allocation on the PC
4055 No index for file handle in structure FLASH_DIR of RCS found
4057 File type 2 can not be printed because of too many definitions
4058 The definitions need too many lines to display them, than in the program

available
4059 An unknown format for the parameter. Valid is U, H, or S
4060 Unknown parameter type

Table 17: Error numbers of converting functions (4030..4060)
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Error Number Description

4061 The data base was transmitted into the FLASH
4062 Set 0 contains no structure definition
4063 Set 0 can not be deleted
4064 Error during execution of a ODBC data base access
4065 Initializing of DBM through RCS had no success
4066 Passed data length incorrect
4067 Sorting function not linked
4068 Error in function parameter
4069 Error from ODBC table
4070 No free handle available. Too many data base links are already opened
4071 Unknown data type found in the table
4072 Structure of table GLOBAL not correct or no such table existing
4073 No name of an ACCESS data base
4074 Download window can’t be created
4075 Download not fully performable

Table 18: Error numbers of converting functions (4061..4075)
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Error Number Description

4082 More than 32 tables should be created
4083 No entry in element szSourceFile
4084 ODBC connection initialisation not possible. This could happen when in

file ODBCINST.INI in section [Microsoft Access Driver (*.mdb)] is no
valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format
4086 Error in structure in the ACCESS data base that is in DBM format
4087 No data in a ODBC table
4088 No entry
4089 ODBC set length not valid
4090 Not enough data sets in ODBC table
4091 Table CreateTab not found
4092 Error in structure of table CreateTab
4093 No entry in element szSourceTable
4094 No entry in element szDestTable
4095 Entry in iSourceType of table CreateTab is wrong
4096 Entry in iTranslate of table CreateTab is wrong
4097 Function SQLAllocStmt reports an error
4098 ODBC source table not found
4099 ODBC data truncated
4100 Download timeout
4101 Library load error
4102 Library function error
4103 Error in description 'toggle'
4104 Error in description 'KB'
4105 Column does not exists
4106 ODBC structure different
4107 ODBC address error
4108 No CRC sum exists (table GLOBAL exists or old)
4109 Table GLOBAL is old
4110 Calculated CRC different to CRC in table GLOBAL
4199 Programming error

Table 19: Error numbers of converting functions (4082..4199)
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8.6 Converting Functions Error Numbers (5001 .. 5008)
The following table lists the error numbers of converting functions.
Error Number Description

5000 Function PackLongToByteShort: Not enough space in pvD (Number of
elements greater than reserved memory)

5001 Function PackLongToByteShort: Not enough space in pvD. Detected
during converting of pvS

5002 Function PackLongToByteShort: Not enough space in pvD
5003 Function StringToByte: Not enough space in pvD
5004 Function IntToByte: Not enough space in pvD
5005 Function LongToShort: Not enough space in pvD
5006 Function PackStringDumpToByteArray: Not enough space in pvD
5007 Function PackStringBumpToByteArray: A character was found, which is

not convertable into a HEX value
5008 Function PackStringDumpToByteArray: Number of character odd
5009 Function PackStringDumpToByteArray: Not enough space in pvD
5010 Function PackStringDumpToByteArray: The current data set needs to be

appended the previous one
5011 Function PackStringDumpToByteArray: No corresponding function to the

given number exist
5012 Converting error

Table 20: Error Numbers of data base functions (5000 .. 5012)
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9 Appendix
9.1 Extended Device Diagnostic

9.1.1 TCP_UDP_TASK Task Information

Figure 20: TCP_UDP_TASK Task Information

Variable Meaning

Task state State of the Task:
0 = Task not initialized
1 = Task is running
2 = Task initialized
3 = reports an error by initialization

Error count Number of appeared errors
Last error Last appeared error (Description see belonging manual)

Table 21: TCP_UDP_TASK Task Information
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9.1.2 TCP_UDP_TASK Code Diag

Figure 21: TCP_UDP_TASK Code Diag

Variable Meaning

Info count Counter for information reports
Warning count Counter for warning reports
Error count Counter for errors
Severity level Level of the last appeared error
Code Code of the last appeared error
Parameter Additional information to the error
Module Software-module
Line number Line number inside the software-module

Table 22: TCP_UDP_TASK Code Diag
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9.1.3 IP_TASK Task Information

Figure 22: IP_TASK Task Information

Variable Meaning

Task state State of the Task:
1 = Task is running
2 = initialization is running
3 = initialization has failed

Error count Counter for appeared errors
Last error Last appeared error
IP address IP-Address of the device
Net mask Net mask of the device
Gateway Gateway of the device

Table 23: IP_TASK Task Information
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9.1.4 IP_TASK Ethernet Status

Figure 23: IP_TASK Ethernet Status

Variable Meaning

MAC address (hex) MAC address of the device
Interface Actual known Ethernet interface
Speed Transmission rate
Duplex mode Shows the actual Duplex mode: Half-/Fullduplex
Twisted pair link State of the Twisted Pair connection

Table 24: IP_TASK Ethernet Status
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9.1.5 IP_TASK Ethernet Count

Figure 24: IP_TASK Ethernet Count

Variable Meaning

IRQ count Counter for interrupts of the Ethernet controller
Last event (hex) Last appeared interrupt type
Events OK Counter for known interrupt types
Events unknown Counter for unknown interrupt types
Frame recv OK Counter for received Ethernet frames
Frame recv missed Counter for missed Ethernet frames
Frame recv bad CRC Counter for Ethernet frames with CRC errors
Frame sent OK Counter for sent Ethernet frames
Frame sent errors Counter for send errors
Frame sent collisions Counter for sending collisions
Frame sent late collision
errors

Counter for late sending collisions

Table 25: IP_TASK Ethernet Count
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9.1.6 IP_TASK Packet Count

Figure 25: IP_TASK Packet Count

Variable Meaning

Packet recv TCP Counter for received TCP packets
Packet recv UDP Counter for received UDP packets
Packet recv ICMP Counter for received ICMP packets
Packet recv IP header err Counter for received IP packets with errors
Packet recv ARP Counter for received ARP packets
Packet recv unknown Counter for received packets of an unknown type

Table 26: IP_TASK Packet Count
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9.1.7 IP_TASK Code Diag

Figure 26: IP_TASK Code Diag

Variable Meaning

Info count Counter for information reports
Warning count Counter for warning reports
Error count Counter for errors
Severity level Level of the last appeared error
Code Code of the last appeared error
Parameter Additional information to the error
Module Software-module
Line number Line number inside the software-module

Table 27: IP_TASK Code Count
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9.1.8 PLC_TASK Variables

Figure 27: PLC_TASK Variables

Variable Meaning

PLC task version Version of the PLC task
Task state State of the Task:

0 = The task is not initialized
1 = The task is initialized and running
2 = The task is actually initializing
3 = Initialization error
4 = Task is initialized and waits for TCP Task

Watchdog time Watchdog time in milliseconds
Handshake mode The following PCL modes are supported by the device:

1 = buffered / device controlled
2 = inconsistent / uncontrolled
3 = buffered / host controlled

Event counter Counter for received events
Handshake counter Counter for Handshakes
Not ready event Number of Not ready events

Table 28: Open Modbus / TCP PLC_TASK Variables
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9.1.9 OMB_TASK Task Information

Figure 28: OMB_TASK Task Information

Variable Meaning

Task state State of the Task:
0 = The task is not initialized
1 = The task is initialized and running
2 = The task is actually initializing
3 = Initialization error
4 = Task is initialized and waits for TCP Task

Error count Number of occurred errors
Last error Last occurred error
Socket status Information about the actual used TCP socket:

1 = Socket 0 (Connection 0 Close/Open, Bit 0)
2 = Socket 1 (Connection 1 Close/Open, Bit 1)
4 = Socket 2 (Connection 2 Close/Open, Bit 4)
8 = Socket 3 (Connection 3 Close/Open, Bit 8)
16 = Socket 4 (Connection 4 Close/Open, Bit 16)

Cyclic event count Counter for cyclic events
Idle count Idle count

Table 29: OMB_TASK Task Information
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9.1.10 OMB_TASK Client

Figure 29: OMB_TASK Client

Variable Meaning

Messages sent to user Number of messages sent to the user
Messages received from
user

Number of messages received from the user

FC1 count Number of Function Calls for function code 1
FC2 count Number of Function Calls for function code 2
... ...
FC16 count Number of Function Calls for function code 16

Table 30: OMB_TASK Client
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9.1.11 OMB_TASK Server

Figure 30: OMB_TASK Server

Variable Meaning

Messages sent to TCP
task

Number of messages which were sent to the TCP task

Messages recv. from TCP
task

Number of messages which were received from the TCP task

FC1 count Number of Function Calls for function code 1
FC2 count Number of Function Calls for function code 2
... ...
FC16 count Number of Function Calls for function code 16

Table 31: OMB_TASK Server
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9.1.12 OMB_TASK I/O

Figure 31: OMB_TASK I/O

Variable Meaning

FC1 count Number of Function Calls for function code 1
FC2 count Number of Function Calls for function code 2
... ...
FC16 count Number of Function Calls for function code 16

Table 32: OMB_TASK I/O
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9.2 Full Duplex and Half Duplex
Full Duplex:
Full Duplex is the designation for a process of data transmission which
allows a simultaneously transmission of the data in both directions. That
means both devices can send and receive simultaneously.

Half Duplex:
In contrast to Full Duplex where two wires can be used to transmit data
(one for send and one for receive) the Half Duplex works mutually with one
channel. That means one the device can send and the other device can
receive.

9.3 Twisted Pair and AUI
Twisted Pair:
Twisted Pair cable are used for point to point connections and they need
four cores therefore two pairs of cores for separate towards and back
transmission. Partly this cable has to be crossed, for example by using two
repeaters. In view of faster network constellations everywhere four double
wires (eight wires) with Cat 5 cable should be used.
Twisted Pair is exclusively connected with RJ45 connectors.

AUI:
The interface between an Ethernet-Transceiver and an Ethernet-Interface
which is connected by a direct connection between the Transceiver and the
Interface or via an AUI cable.

9.4 MAC Address
(Media Access Control-Address) This is the hardware address of a
component in the network which can generate the data packet on its own.
The MAC Address is given by the manufacturer who has a reserved
memory location. The manufacturer guarantee that the address is unique.
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11 Glossary
FB1131

Ethernet Configurator.
Configurations- and Diagnostic Tool.
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