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About this manual1.

Copyrights1.1.

The information in this document is subject to change without notice and should not be
construed as a commitment by ABB Oy. ABB Oy assumes no responsibility for any
errors that may appear in this document.

In no event shall ABB Oy be liable for direct, indirect, special, incidental or consequential
damages of any nature or kind arising from the use of this document, nor shall ABB Oy
be liable for incidental or consequential damages arising from use of any software or
hardware described in this document.

This document and parts thereof must not be reproduced or copied without written per-
mission from ABB Oy, and the contents thereof must not be imparted to a third party
nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and
may be used, copied, or disclosed only in accordance with the terms of such license.

© Copyright 2006 ABB. All rights reserved.

Trademarks1.2.

ABB is a registered trademark of ABB Group. All other brand or product names men-
tioned in this document may be trademarks or registered trademarks of their respective
holders.

General1.3.

This manual provides thorough information on the Communication Gateway COM610
and the central concepts related to it. For more information on each topic related to a
specific protocol, refer to the list of related documents in 1.8, Related documents.

Information in this operator's guide is intended for operators who perform every-day
operations.

Document conventions1.4.

The following conventions are used for the presentation of material:
• The words in names of screen elements (for example, the title in the title bar of a

window, the label for a field of a dialog box) are initially capitalized.
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• Capital letters are used for the name of a keyboard key if it is labeled on the keyboard.
For example, press the ENTER key.

• Lowercase letters are used for the name of a keyboard key that is not labeled on the
keyboard. For example, the space bar, comma key, and so on.

• Press CTRL+C indicates that you must hold down the CTRL key while pressing
the C key (to copy a selected object in this case).

• Press ESC E C indicates that you press and release each key in sequence (to copy
a selected object in this case).

• The names of push and toggle buttons are boldfaced. For example, click OK.
• The names of menus and menu items are boldfaced. For example, the  File menu.

• The following convention is used for menu operations:  MenuName > Menu-
Item > CascadedMenuItem. For example: select File > New > Type.

• The Start menu name always refers to the Start menu on the Windows taskbar.
• System prompts/messages and user responses/input are shown in the Courier font.

For example, if you enter a value out of range, the following message is displayed:

Entered value is not valid. The value must be 0 to 30.

• You may be told to enter the string MIF349 in a field. The string is shown as follows
in the procedure:

MIF349
• Variables are shown using lowercase letters:

sequence name

Use of symbols1.5.

This publication includes warning, caution, and information icons that point out safety
related conditions or other important information. It also includes tip icons to point out
useful information to the reader. The corresponding icons should be interpreted as follows.

The electrical warning icon indicates the presence of a hazard
which could result in electrical shock.

The warning icon indicates the presence of a hazard which
could result in personal injury.

The caution icon indicates important information or warning
related to the concept discussed in the text. It might indicate
the presence of a hazard which could result in corruption of
software or damage to equipment or property.
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The information icon alerts the reader to relevant facts and
conditions.

The tip icon indicates advice on, for example, how to design
your project or how to use a certain function.

Terminology1.6.

The following is a list of terms associated with the Communication Gateway COM610
that you should be familiar with. The list contains terms that are unique to ABB or have
a usage or definition that is different from standard industry usage.

DescriptionTerm

An abnormal state of a condition.Alarm

An OPC service for providing information about alarms and
events to OPC clients.

Alarms and Events; AE

Part of a logical node object representing specific information,
e.g., status or measurement. From an object-oriented point of
view a data object is an instance of a class data object. DOs are
normally used as transaction objects; i.e., they are data struc-
tures.

Data Object; DO

A physical device that behaves as its own communication node
in the network, e.g. protection relay.

Device

Change of process data or an OPC internal value. Normally, an
event consists of value, quality and timestamp.

Event

A physical IEC 61850 device that behaves as its own commu-
nication node in the IEC 61850 protocol.

Intelligent Electronic Device

A communication protocol developed by Echelon.LON

A proprietary method of ABB on top of the standard LON pro-
tocol.

LON Application Guideline for
substation automation; LAG

Series of standards specifications aiming at open connectivity
in industrial automation and the enterprise systems that support
industry.

OPC

Named data item.Property

ABB proprietary communication protocol used in substation
automation.

SPA
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Abbreviations1.7.

The following is a list of abbreviations associated with the Communication Gateway
COM610 that you should be familiar with. See also 1.6, Terminology.

DescriptionAbbreviation

Alarms and EventsAE

Communication Engineering ToolCET

Data ObjectDO

Gateway, component connecting two communication networks togetherGW

Human Machine InterfaceHMI

International Electrotechnical CommissionIEC

Intelligent Electronic DeviceIED

LON Application Guideline for substation automationLAG

Local Area NetworkLAN

Network Control CenterNCC

Single Line DiagramSLD

Related documents1.8.

MRS numberName of the manual

1MRS756125COM600 User’s Guide

1MRS756566DNP LAN/WAN Master (OPC)

1MRS756567DNP Serial Master (OPC)

1MRS755496DNP LAN/WAN Slave (OPC)

1MRS755495DNP Serial Slave (OPC)

1MRS755564External OPC Client Access

1MRS755382IEC 60870-5-101 Slave (OPC)

1MRS752278IEC 60870-5-103 Master (OPC)

1MRS755384IEC 60870-5-104 Slave (OPC)

1MRS755321IEC 61850 Master (OPC)

1MRS755284LON-LAG Master (OPC)

1MRS756126Modbus Serial Master (OPC)

1MRS756445Modbus TCP Master (OPC)

1MRS752275SPA Master (OPC)

1MRS755497SPA Router (OPC)
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Document revisions1.9.

HistoryProduct revisionDocument version/date

Document created3.0A/16.10.2006

Document revised3.1B/21.12.2007

Document revised3.2C/17.06.2008
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Introduction2.

Product overview2.1.

Communication Gateway COM610 acts as an embedded communication gateway between
substation automation protection and control devices and Network Control Centers
(NCC).

COM610 uses an embedded operating system and runs in a dedicated industrial computer
without moving parts.

The products are configured using a separate engineering PC that is connected via the
local area network (LAN). For more information, refer to COM600 User's Guide.

Gateway Functionality

The gateway functionality provides a framework that enables the use of OPC server and
client components, such as OPC Client for IEC 60870-5-101 and OPC Server for LON
LAG 1.4. For more information, refer to COM600 User's Guide.
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Operation of the COM6103.

Opening a project in CET3.1.

To open a project in CET:

1. Select File > Open/Manage Project....
2. In the Open/Manage Project dialog, select the required location for the project:

• Projects on my computer
• Projects on network

3. Expand the projects list, by clicking on the + symbol, to select the required project.
4. Click Open Project

Gateway management3.2.

The Gateway Management tool enables you to transfer the configurations of the objects
to the COM600 computer.

To be able to use the Gateway Management Tool, the engineering computer must be
connected to the COM600 computer. The IP address of the used ethernet port in the
COM600 computer must be entered to the corresponding Gateway object property. For
more information, see COM600 User's guide.

To open the Gateway Management tool, right-click the Gateway object in Communication
Engineering Tool (CET) and select Management.

• To copy the configurations of all servers and clients to the Gateway computer, click
Update configuration.

• To restart all servers and clients with the latest configurations, click Reload config-
uration.

• To transfer only the changed configurations and to restart only the changed server
or client with new configurations, click Update & reload configuration.

License handling3.3.

The Gateway Management tool displays the license information for COM600 under
License Information. The license and the protocols it supports have been predefined
before the COM600 computer has been handed over by ABB.

The following information is shown in the window:
• owner of the license
• product revision
• protocols supported by the license.
• number of servers supported by the license.
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• number of clients supported by the license.
• if WebHMI is enabled.

To update the license with a new set of protocols, order a new license from ABB and
update it to COM600 with Communication Engineering Tool.

To update the license:
1. Open the Gateway Management tool.
2. Click Update License.
3. Browse for the new license file and click Open.

The license is COM600 specific and the COM600 computer verifies the compatibility
of the license. Also the servers and clients verify the license.
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Diagnostics4.

General about diagnostics4.1.

Communication Engineering Tool (CET) provides comprehensive functions for diagnos-
ing the operation of the Gateway. This includes communication diagnostics with monit-
oring the communication channel, diagnostic counters and IED specific communication
status and diagnostic counters. It is also possible to monitor and control process data and
follow the data flow on the Gateway using diagnostic functions of CET. Figure 4.1-1
displays a sample view of a diagnostic counter dialog. An example of an event log file
is displayed in Figure 4.1-2

SPAChnlDiag.jpg

Figure 4.1-1 An example of a SPA channel diagnostic counter dialog
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EventDial.jpg

Figure 4.1-2 An example of a SPA event log file

Data object diagnostics4.2.

You can monitor and control the data objects under the Gateway’s object tree with Data
object diagnostics.

To monitor and control the data objects:
1. Right-click the Gateway.
2. Select Data object diagnostics from the shortcut menu, see Figure 4.2-1. The Data

object diagnostic dialog opens.
3. Drag and drop data objects from the object tree to the Data object diagnostics.

or

1. Select a specific data object from the object tree.
2. Select Tools > Online diagnostics.
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DataObjDiagnos.jpg

Figure 4.2-1 Data object diagnostics

To change the value of a data object attribute:
1. Select a specific attribute.
2. Write a new value to the text box under the Write value button.
3. Click Write value to change the value.

To filter the displayed data object:
1. Click Excluded items.
2. Notepad opens. Write to Notepad the data object types you want to exclude from

the Data object diagnostics view.
3. Save the Notepad file by selecting File > Save.

Diagnostic services of OPC servers and clients4.3.

You can control and monitor the server and client channel and device communication
in the communication structure of the Project Explorer. You can take channels/subnet-
works and devices into use or out of use via the respective diagnostics function. You
can also monitor the channel/subnetwork and device communication with the help of
various diagnostic counters, and check the device status information, see Figure 4.3-1.

15

COM610 3.2COM600 Station Automation Series1MRS756122

Operator's Guide



LONClockMaster.jpg

Figure 4.3-1 An example of LON Clock Master online diagnostics

For more detailed information and instructions on controlling and monitoring channel
and device communication, refer to the respective user’s guide for the client or server
(see 1.8, Related documents).

Signal diagnostics4.4.

OPC clients have a diagnostic function which makes it possible to monitor the flow of
process data changes and commands. Activate the function by marking the Diagnostic
Events Enabled check box, located in the Online diagnostics function of the
IEC101/IEC104 Device. When the diagnostic function is activated, the IEC101 OPC
Client Alarm & Event server generates events with information about data changes and
commands.
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IEC101AEClient.jpg

Figure 4.4-1 IEC101 Slave OPC Client Diagnostic AE client

Diagnostic Web Server4.5.

The Diagnostic Web Server of the Gateway provides an overall view of the communic-
ation status of the Gateway and the possibility to monitor the diagnostic counters of the
communication channels/subnetworks and IED communication. Figure 4.5-1 displays
the gateway objects in a tree view.

A red cross over the Gateway icon in the object tree indicates that there is a fault in the
communication structure. Expand the tree to view the hierarchy deeper and to identify
the device with a missing configuration or causing the error. The properties of a certain
object in the communication structure can be seen on the right when clicking on the
object in the tree view.
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Webserver_a.jpg

Figure 4.5-1 An example of a web page from the Gateway diagnostic web server
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