MicroSCADA Pro SYS600 9.4
IEC 61850 System Design
Trace back information:
Workspace Main version a54
Contents

1 Copyrights ........................................................................................................ 7

2 Introduction .................................................................................................... 9
   2.1 This manual ............................................................................................ 9
   2.2 Use of symbols ................................................................................... 9
   2.3 Intended audience ............................................................................... 9
   2.4 Product documentation ..................................................................... 9
   2.5 Document conventions .................................................................... 10
   2.6 Document revisions ......................................................................... 11

3 Safety information ....................................................................................... 13
   3.1 Backup copies ..................................................................................... 13
   3.2 Fatal errors ........................................................................................ 13

4 Requirements ............................................................................................... 15
   4.1 Hardware requirements .................................................................... 15
   4.2 Software requirements ..................................................................... 15

5 Configuration ............................................................................................... 17
   5.1 Components of the IEC 61850-based system ................................... 17
       5.1.1 SYS600 base system ................................................................. 18
       5.1.2 External OPC DA Client ......................................................... 18
       5.1.3 IEC 61850 OPC Server .......................................................... 18
       5.1.4 IED connectivity .................................................................... 18
   5.2 Building the physical IEC 61850 network ......................................... 19
   5.3 Configuring the IED ........................................................................... 19
   5.4 IEC 61850 Redundancy ..................................................................... 19
       5.4.1 Installing DuoDriver ............................................................... 20
   5.5 Configuration environment ................................................................ 20
   5.6 Configuring the SYS600 base system ............................................. 20
       5.6.1 Configuring base system objects .......................................... 21
   5.7 Configuring with IET600 .................................................................. 24
       5.7.1 Introduction ............................................................................. 24
       5.7.2 Engineering workflow .............................................................. 25
           5.7.2.1 Application preparation ............................................... 25
           5.7.2.2 IET600 engineering ....................................................... 26
           5.7.2.3 IET Data Loader engineering .................................... 27
       5.7.3 IET Data Loader usage ............................................................... 31
           5.7.3.1 IET Data Loader Project handling .............................. 31
           5.7.3.2 Import IET600 export file .......................................... 34
5.7.3.3 Configuration data modification and verification .................................................... 35
5.7.3.4 Configure MicroSCADA system ................................................................. 47
5.7.4 IET Data Loader User Interface ................................................................. 52
5.7.5 Engineering information ............................................................................. 53
5.7.6 Important notes ............................................................................................. 54

5.8 Configuring without IET600 ........................................................................... 55
5.8.1 Configuring IEC 61850 OPC Server ............................................................. 55
  5.8.1.1 Creating a new project ........................................................................... 55
  5.8.1.2 Configuring IEC 61850 OPC Server ................................................... 55
  5.8.1.3 Importing IED configuration .................................................................. 56
  5.8.1.4 Time Synchronization .......................................................................... 58
5.8.2 Creating process objects ............................................................................... 58
  5.8.2.1 Importing SCL configuration .................................................................. 59
  5.8.2.2 Importing a language translation file ................................................... 64
  5.8.2.3 Addressing process objects .................................................................. 64
5.8.3 Configuring External OPC DA Client .......................................................... 66
  5.8.3.1 Starting External OPC DA Client Configuration Tool ................................ 66
  5.8.3.2 Connecting to IEC 61850 OPC Server ................................................. 67
  5.8.3.3 Auto-configuring OPC items for process objects ................................... 68
  5.8.3.4 Defining configuration for the IEC 61850 system .................................. 70
  5.8.3.5 Defining the event buffer ...................................................................... 71
  5.8.3.6 Configuring an item for Transparent XSAT ........................................ 72
  5.8.3.7 Configuring an item for Service Tracking ........................................... 72
5.8.4 Configuring an External OPC DA Client instance ...................................... 74
  5.8.4.1 IEC 61850 Hot Stand-by system topology ........................................... 74
  5.8.4.2 Starting External OPC DA Client instance ........................................ 75
  5.8.4.3 Stopping an External OPC DA Client instance ..................................... 76

5.9 Single-line diagram engineering ..................................................................... 76
  5.9.1 Adding objects into the display .................................................................. 76
  5.9.2 Adding Station Local/Remote Switch ....................................................... 78
  5.9.3 Editing data variables in the display ......................................................... 79

5.10 Configuring IEC 61850 Redundancy diagnostics ......................................... 80
  5.10.1 Local machine DuoDriver status diagnostics ...................................... 80
  5.10.2 IED DuoDriver status diagnostics .......................................................... 82

6 Testing configuration ......................................................................................... 85
  6.1 Testing IED and IEC 61850 OPC Server configurations ............................. 85
  6.2 Testing External OPC DA Client start-up ..................................................... 86
  6.3 Testing IED control commands using process display .................................. 87

7 Distributed system topologies ............................................................................ 89
8 IEC 61850 System recommendations ........................................... 91
9 Troubleshooting ......................................................................... 93
10 Conformance statements ............................................................ 95
11 Terminology .............................................................................. 99
12 Abbreviations ............................................................................ 101

Appendices

A IEC 61850 System Supervision Server ........................................ 103
   A.1 IEC 61850 SSS features ...................................................... 103
   A.2 IEC 61850 SSS start-up ................................................... 104
   A.3 Configuring IEC 61850 System Supervision Server .......... 104
      A.3.1 Installing IEC 61850 System Supervision Server ...... 104
      A.3.2 Starting IEC 61850 System Supervision Server ....... 104
      A.3.3 Stopping IEC 61850 System Supervision Server ...... 105
      A.3.4 Configuring IEC 61850 System Supervision Server ... 105
         A.3.4.1 Timer ......................................................... 105
         A.3.4.2 Update ....................................................... 106
   A.4 Testing IEC 61850 System Supervision Server ............... 108
   A.5 IEC 61850 System Supervision Server ACSI Conformance ... 108
1

Copyrights

The information in this document is subject to change without notice and should not be construed as a commitment by ABB Oy. ABB Oy assumes no responsibility for any errors that may appear in this document.

In no event shall ABB Oy be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB Oy be liable for incidental or consequential damages arising from the use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB Oy, and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license.

Copyright © 2016 ABB Oy. All rights reserved.

Trademarks

ABB is a registered trademark of ABB Group. All other brand or product names mentioned in this document may be trademarks or registered trademarks of their respective holders.

Guarantee

Please inquire about the terms of guarantee from your nearest ABB representative.

Third Party Copyright Notices

List of Third Party Copyright notices are documented in "3rd party licenses.txt" and included in SYS600 and DMS600 installation packages.
2 Introduction

2.1 This manual

This manual provides thorough information on the MicroSCADA Pro software and hardware installation: base systems, LAN connections, process communication systems, workplaces and peripherals.

This manual provides thorough information on the various configuration settings that have to be made in order to take your SYS600 system into use, focusing on describing how to configure SYS600 for an IEC 61850 system. The manual also describes how to use the configuration tools.

2.2 Use of symbols

This publication includes the following icons that point out safety-related conditions or other important information:

- The caution icon indicates important information or warning related to the concept discussed in the text. It might indicate the presence of a hazard which could result in corruption of software or damage to equipment or property.

- The information icon alerts the reader to relevant facts and conditions.

2.3 Intended audience

This manual is intended for engineers to support configuration and engineering of systems and/or applications.

2.4 Product documentation

<table>
<thead>
<tr>
<th>Name of the document</th>
<th>Document ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYS600 9.4 System Configuration</td>
<td>1MRS758100</td>
</tr>
<tr>
<td>SYS600 9.4 Application Design</td>
<td>1MRS758089</td>
</tr>
<tr>
<td>SYS600 9.4 External OPC Data Access Client</td>
<td>1MRS758101</td>
</tr>
<tr>
<td>SYS600 9.4 Process Display Design</td>
<td>1MRS758088</td>
</tr>
<tr>
<td>SYS600 9.4 Status Codes</td>
<td>1MRS758115</td>
</tr>
</tbody>
</table>
Other related documents:
- Microsoft Windows documentation
- PC/TCP documentation
- Product documentation of the used network adapter card
- Product documentation of the used PCLTA-10 card

2.5 Document conventions

The following conventions are used for the presentation of material:

- The words in names of screen elements (for example, the title in the title bar of a dialog, the label for a field of a dialog box) are initially capitalized.
- Capital letters are used for file names.
- Capital letters are used for the name of a keyboard key if it is labeled on the keyboard. For example, press the CTRL key. Although the Enter and Shift keys are not labeled they are written in capital letters, e.g. press ENTER.
- Lowercase letters are used for the name of a keyboard key that is not labeled on the keyboard. For example, the space bar, comma key and so on.
- Press CTRL+C indicates that you must hold down the CTRL key while pressing the C key (to copy a selected object in this case).
- Press ALT E C indicates that you press and release each key in sequence (to copy a selected object in this case).
- The names of push and toggle buttons are boldfaced. For example, click OK.
- The names of menus and menu items are boldfaced. For example, the File menu.
- The following convention is used for menu operations: Menu Name > Menu Item > Cascaded Menu Item. For example: select File > Open > New Project.
- The Start menu name always refers to the Start menu on the Windows Task Bar.
- System prompts/messages and user responses/input are shown in the Courier font. For example, if a value that is out of range is entered, the following message is displayed: Entered value is not valid
  The user may be told to enter the string MIF349 in a field. The string is shown as follows in the procedure: MIF349
- Variables are shown using lowercase letters: sequence name
## 2.6 Document revisions

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Revision number</th>
<th>History</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>16.5.2014</td>
<td>9.4</td>
<td>New document</td>
</tr>
<tr>
<td>B</td>
<td>3.6.2015</td>
<td>9.4 FP1</td>
<td>New chapter 5.7 &quot;Configuration with IET600&quot;</td>
</tr>
<tr>
<td>C</td>
<td>3.6.2016</td>
<td>9.4 FP2</td>
<td>Document updated</td>
</tr>
</tbody>
</table>
3 Safety information

This section has information on the prevention of hazards and taking backups from the system.

3.1 Backup copies

Taking backup copies

We recommend taking backup copies before making any changes, especially ones that might have side effects. Software and data need to be copied to another place.

Backup copying makes it easier to restore the application software in case of disk crash or other severe failure where stored data is lost. It is therefore recommended that backup copies are taken regularly.

There should be at least two system backup copies and two application copies. A new backup is copied over the oldest backup. This way the latest version is always available, even if the backup procedure fails.

Detailed information on how to take backup copies should be delivered to the customer with the application.

System backup

Usually a system backup is taken after the application is made. It should be taken again when changes are made to the SYS600 system. This is required when the driver configuration or the network setup is changed.

Application backup

An application backup is also taken at the same time with the system backup, after the application is made. It should be taken again when changes are made to the application, for example, if pictures or databases are edited or new pictures are added.

3.2 Fatal errors

A fatal error is an error that causes a breakdown or a locked situation in the SYS600 program execution.

Handling

In case of a fatal error:

1. Write down the possible SYS600 error messages.
2. Shut down the SYS600 main program. If this cannot be done in the SYS600 Control Panel, try to end the task in Windows Task Manager.
3. The data kept in the main memory at the moment of a fatal error is placed in the `drwtsn32.log` file with Windows 2003 Server, Windows XP and earlier. By default it is placed under `%SYSTEMDRIVE%\Documents And Settings\All Users\Application Data\Microsoft\Dr Watson`. Log and dump file paths can be checked with the `drwtsn32` application. (Start -> run -> drwtsn32.exe). Analyze and copy the data in these files.

Starting with Windows Server 2008 and Windows 7 the crash handling has changed. The location of the dump files can be read from the registry under the key `HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps`. The `DumpFolder` value tells the location of the dump files. Collect the data from this location.

4. Restart the system.

Report the program break-down together with the possible SYS600 error messages and the information from the `drwtsn32.log` file to the SYS600 supplier.

**Status codes**

Error messages in SCIL are called status codes. A list of status codes and short explanations for them can be found in SYS600 Status Codes.
4 Requirements

The installation and configuration of the devices that use the IEC 61850-8-1 protocol consist of:

- Hardware installation
- Software installation

4.1 Hardware requirements

The hardware components listed below are usually required in IEC 61850 systems. In addition to the hardware itself, this equipment may require the configuration of the appropriate driver in the appropriate operating system.

- Industrial computer SYS600C with network adapters
- Industrial network (ABB AFS6xx Switch)
- Time synchronization device with SNTP server (for example Meinberg)
- Print server

Print servers usually provide diagnostics information in Ethernet via the SNMP protocol. The proposed way to include this information into SYS600 is to convert it into OPC item updates using a third-party SNMP to the OPC Server component. The OPC item updates are then mapped to the SYS600 process database via External OPC DA Client.

4.2 Software requirements

The following software is required:

- IET Data Loader requires MicroSCADA Pro SYS600 9.4 Feature Pack 1 and newer

The following software is optional:

- IED configuration tools (for example PCM600 with IED specific Connectivity Packages)
- IEC 61850 system configuration tool (for example IET600)
5 Configuration

5.1 Components of the IEC 61850-based system

In a SYS600 system using IEC 61850, communication signals are transmitted from the IED to the IEC 61850 OPC Server. From the IEC 61850 OPC Server they are forwarded to the External OPC DA Client and the External OPC DA Client passes the signals to SYS600 base system.

The configuration of the SYS600 IEC 61850 system components (see Figure 5.1) is described in the following sections:

- Section 5.1.1 SYS600 base system
- Section 5.1.2 External OPC DA Client
- Section 5.1.3 IEC 61850 OPC Server
- Section 5.1.4 IED connectivity
- Appendix A IEC 61850 System Supervision Server

![Diagram of related components of the IEC 61850-based system](image)

Figure 5.1: Related components of the IEC 61850-based system
5.1.1 SYS600 base system

In the SYS600 base system an IED using IEC 61850 protocol is represented as a communication station. An External OPC DA Client is represented as a communication node connected to the base system via a communication link. The base system objects, that is link, node and station(s), are configured with System Configuration Tool. For more information see Section 5.6 Configuring the SYS600 base system.

Each signal in an IED can be represented by a process object in the base system. Each process object includes a number of attributes e.g. the actual value of the signal. Process objects are identified with unique addresses constructed from a station (Unit Number) and object address (Block and Bit number). Process objects are stored in process and report databases within the base system. Process displays and lists are used to display the process objects presenting the operator with the signals of the underlying system.

The process objects are created in to a SYS600 application using SCL Importer tool. Single-line diagram engineering is done with Monitor Pro Display Builder tool.

5.1.2 External OPC DA Client

External OPC DA Client (OPC DA Client) is a communication gateway used to receive signals in real time from IEC 61850 OPC Server through OPC Data Access and to pass them to the base system ACP protocol over TCP/IP.

External OPC DA Client is configured automatically during the base system process object configuration with SCL Importer or IET Data Loader. It can also be configured manually using External OPC DA Client Configuration Tool.

5.1.3 IEC 61850 OPC Server

IEC 61850 OPC Server is a communication gateway used to receive signals in real time from IEC 61850 IEDs through IEC 61850 and to pass them to the External OPC DA Client via OPC Data Access.

IEC 61850 OPC Server is configured using IET600/IET Data Loader tool or CET for IEC 61850 OPC Server.

5.1.4 IED connectivity

For the IED integration into SYS600 the following two engineering workflows are supported:

1. IET600 work flow

   Information about connected IED's is engineered in IET600 and imported to SYS600 with IET Data Loader. This includes configuration for process database, IEC61850 OPC Server, External OPC DA client and COM500i. Some parameters can be adjusted with IET Data Loader.
2. CET/SCL Importer workflow

IEC61850 SCL (SCD) file is created with PCM600 or with 3rd party SCL tool. The SCL file includes the information about the connected IED’s. SCL/SCD file is imported to CET to create IEC61850 OPC Server configuration and to SYS600 with SCL Importer to create the process database and External OPC DA client configuration.

When the process database is created, the process objects are connected to the Power Process Library functions. This enables the use of e.g. default event/alarm handling and pre-defined symbols and control dialogs in single line diagrams for different objects.

For the IED parameter setting, the PCM600 can be launched from an IED symbol in the single line diagram.

5.2 Building the physical IEC 61850 network

The devices in the IEC 61850 network should first become connected in system according to the wiring diagrams and layout pictures. Setting up the devices may require that their addresses and the protocols in question are configured according to the system requirements.

5.3 Configuring the IED

IEC 61850 IEDs are configured using the tools and instructions provided by the manufacturer.

IEC 61850 uses standardised XML based SCL (System Configuration description Language) configuration files for IEDs and systems. IED configurations are distributed as CID (Configured IED Description) files and system configurations as SCD (System Configuration Description) files. CID files are usually created by the IED configuration tools (e.g. ABB PCM600) and exported for use in system configurations. SCD files are usually created by system configuration tools (e.g. ABB IET600) by importing and linking an number of CID files and other related information.

To configure an IEC 61850 IED to the SYS600 system, a CID file or an SCD file including the IED description is required.

5.4 IEC 61850 Redundancy

Redundancy in the IEC 61850 devices is achieved by attaching two different, redundant networks by two ports to each device. Each device selects independently the network to use. The devices are the only non-redundant parts. IEC 62439-3 specifies the PRP (Parallel Redundancy Protocol), a redundancy in the nodes solution, in which nodes (devices) use both networks simultaneously. PRP is based on full duplication and parallel operation of two redundant networks. PRP nodes send signals to and receive signals from both
networks at the same time, providing bumpless recovery. This offers zero recovery time, making PRP suited for all real time applications.

Redundancy in the network (LAN) is achieved using RSTP (Rapid Spanning Tree Protocol). The RSTP standard provides at best a 2 second recovery time.

ABB DuoDriver (v3.0 or later) with PRP-1 (IEC 62439-3 (2012)) and PRP-0 (IEC 62439-3 (2010)) and compatible network interface cards are used to build IEC 61850 communication redundancy in SYS600. Using ABB DuoDriver and PRP-1 with SYS600 requires that the connected IEDs also support PRP-1 for communication redundancy.

PRP-0 and PRP-1 are not compatible. A single redundant network with DuoDriver can be used to communicate only via PRP-0 or PRP-1.

5.4.1 Installing DuoDriver

If IEC 61850 redundancy is used, install DuoDriver by executing the DuoDriver install package included in SYS600 installation (for example C:\SC\SETUP\DUODRIVER\SETUP.EXE). For more information, refer to the SYS600 DuoDriver 3.0 Installation Guide.

5.5 Configuration environment

In IEC 61850 based systems, the following components need to be configured:

- IED
- IEC 61850 OPC Server
- External OPC DA Client
- SYS600 process database and HMI

Figure 5.1 illustrates the software components, including their interrelationships and underlying communication architecture. The SYS600 base system, External OPC DA Client and IEC 61850 OPC Server are usually all located on the same computer.

The recommended order in which to configure a SYS600 IEC 61850 system is to first configure the base system objects, then the IEC 61850 OPC Server and finally the base system process objects. The IEDs need to be configured prior to configuring SYS600.

5.6 Configuring the SYS600 base system

SYS600 base system needs to be configured with addressing (node name, node number and station address) and a name for the running application (application name).

Configure the base system using System Configuration Wizard:

1. Open SYS600 Control Panel and expand the dialog.
2. Open the **Configuration** section and click **System Configuration Wizard**.
3. The System Configuration Wizard dialog appears. Follow the wizard and make the necessary configurations.
   For a single system use e.g. the following configuration:
   - Select Base System Type **Single System** and **Monitor Pro and OPC Data Access Server enabled** for OPC Data Access Server.
   - Use Node Name SYSTEM1, Node Number 9 and Station Address 209 for Base System Information.
   - Use Application Name MAIN for Application Information.
4. After completing the configurations, select **Start the application** and click **Finish**.

The Base System Node Number and Station Address are used when configuring CPI Node Properties for the External OPC DA Client.

### 5.6.1 Configuring base system objects

The SYS600 base system objects LAN link, External OPC DA Client node and IEC 61850 communication stations are created and configured with the System Configuration Tool. It is also possible to include the configuration of the SYS600 base system in the SYS_BASCON.COM file manually, but configuration using the System Configuration Tool is recommended.

To create the link, node and station using System Configuration Tool (LAN link LIN1, External OPC DA Client node NOD8 and station STA60 are created here as an example):

1. Start SYS600 Monitor.
2. Start System Configuration Tool (System Conf) from **System Configuration** tab in Tool Manager.
3. Open the active configuration for editing. 
   In the System Configuration Tool, select Configuration > Open Active.
4. The LAN link 1 LIN1 is created by default. It is not necessary to create a new one. 
   To add a new LAN Link:
   • Right-click MicroSCADA Configuration and select New.
   • Select Object Type LAN Link and click Insert.
   • Insert New Link Object Number X for the object and click OK to add LINX.
5. Create an External OPC DA Client node 8 NOD8.
   • Right-click Link 1 and select New.
   • Select Object Type IEC 61850 Node and click Insert.
   • Insert New Node Object Number 8 for the object and click OK to create NOD8.
6. Create a communication station 60 STA60.
   A single station should be used to represent a single IEC 61850 IED. To add more 
   station objects repeat this step with unique station numbers.
   • Right-click Node 8 and select New.
   • Select Object Type IEC 61850 Station and click Insert.
   • Insert New SPA Station Number 60 for the object and click OK to create STA60.
7. Enable System Self Supervision by selecting Options > System Self Supervision.
   For more information on System Self Supervision, see System Configuration manual. 
   Select the options:
   • Enabled and Create supervision routing options.
   • Run-time supervision routing enabled.
   • Click OK.
8. Select Configuration > Save Active to save the modified configuration.
9. Configuration of the LAN link, External OPC DA Client node and a single 
   communication station is now finished. The changes take effect the next time SYS600 
   is started. Possible configuration errors appear in the SYS600 Notification Window.
The contents of the SYS_BASCON.COM file are identical for both HSB systems, with the exception of the unique node and station numbers.
5.7 Configuring with IET600

5.7.1 Introduction

The MicroSCADA IET600 Data Loader tool loads data exported from the IET600 engineering tool, version 5.3 FP1 and later, to configure MicroSCADA/SYS600 applications using IEC 61850 communication.

Figure 5.4: IET Data Loader engineering scope

Based on the IET600 data the following SYS600 components are configured:

- External OPC DA client(s)
- IEC 61850 OPC Server(s)
- Process Database including the standard configuration (CD attribute)
- COM500i signal references
- Event handling objects used for generating event and state text in Event Display

The IET Data Loader tool replaces the following tools normally used for IEC 61850 system design:

- External OPC DA client configuration tool
- CET for IEC 61850 OPC Server
- OPC PO-List tool
- LOF import using Import/Export tool plus post-import scripts
• COM500i tool for cross reference engineering
• Standard Function installation and configuration tool

These tools are still part of the product but they do not play a major role in the IET Data Loader engineering workflow anymore. They can be used to verify the constructed configuration and databases, but to avoid inconsistencies they should not be used to modify any configuration file or database constructed by the IET Data Loader.

5.7.2 Engineering workflow

5.7.2.1 Application preparation

Some preparation work must be done on SYS600 application side in order to be able to use the IET Data Loader.

1. System configuration:
   All the necessary Links, Nodes and Station objects need to be configured with the System Configuration Tool

   ![System Configuration](image)

   *Figure 5.5: System configuration*

   For IEC 61850 communication setup the LAN link must be configured in the base system configuration file sys_bascon.com:

   ```
   #local LAN_link = 1 ; LAN link number
   ```

2. COM500i initialization and NCC communication:
   If the application contains gateway (COM500i) functionality for communication with an upper level system like Network Control Center (NCC) the COM500i package must be initialized and the NCC configuration must be done with the Signal X-Reference tool.
5.7.2.2 IET600 engineering

The IET600 import files for the IET Data Loader can be generated from the HMI tab. The MicroSCADA Loadfile(s) button must be selected to get the dialog for the export details.

As input for the IET Data Loader the sasmsc file format must be selected.
- sasmsc with SCD
This is the normal selection and mandatory for systems with IEC 61850 communication.

- sasmsc without SCD
  This option should only be selected if no changes in IET600 project have been done during incremental engineering process which causes SCD file update, e.g. some Process Object attributes have been changed or some COM500i cross reference data has been modified.

Detailed information about IET600 engineering can be retrieved from the IET600 user manual.

5.7.2.3 IET Data Loader engineering

The User interface for the IET Data Loader can be started from the Monitor Pro “Tools” menu:

![Figure 5.8: IET Data Loader UI launch](image)

In order to avoid conflicts only one instance can be started at a time.

The following figures shows the User Interface.
Figure 5.9: IET Data Loader User Interface

The user interface consists of three tabs and the output console at the bottom:

1. **Home tab**: To manage projects, import IET600 export files and start the write configuration process
2. **Communication tab**: Show the communication components and their properties for the target system based on IET600 export file imported data
3. **Application Objects tab**: Show the Process Objects which are created, modified or deleted on the target system based on IET600 export file imported data
4. The **output console** in the lower UI part provides notification to the user about actions taken during the engineering process.

**Step 1: Create an IET Data Loader project**

On first usage the tool asks to create a new project:
IET Data Loader is able to handle different projects. This is useful to engineer different applications located in one system.

**Step 2: Import IET600 export file**

The next step after the project has been created is to import the sasmsc file exported from IET600.

A more detailed description about the import options can be found in chapter 5.7.3.2.
Step 3: Import file verification

The Communication and the Application Objects tab can be used to verify the target system object properties.

If needed the Communication tab can be used to change communication object properties which are not part of IET600 engineering.

The Application Objects tab is for information only.

Step 4: Write configuration

During the write configuration process the following application configuration data is generated:

1. Process Objects indexes
2. Process Object groups configuration data (CD attribute)
3. Event Handling objects
4. Dummy Scale objects with 1:1 linear scale algorithm if it does not exist in the database
5. Language text database for status text
6. Optional COM500i cross-reference information for indications, commands and alarm groups. Event channels needed for signal routing related to COM500i are created if they do not exist.
7. Configuration file for each configured IEC 61850 OPC Server instance
8. Configuration file for each configured external OPC DA client instance
   - For the connection to each IEC 61850 OPC Server
   - Optional for the connection to 3rd party SNMP-OPC Server

The configured external OPC DA client and the IEC 61850 OPC Server instances are re-started automatically after the configuration process is ready.

A 3rd party SNMP-OPC Server must first be first installed on the target system before the IET Data Loader write configuration step.

To automatically start the OPC DA client instances the OPS_CALL commands must be added to the APL_INIT_1(H) command procedure as described in chapter 5.7.5.

The created status text database must be added to the application text database attribute in the base system configuration file sys_bascon.com.
5.7.3 IET Data Loader usage

5.7.3.1 IET Data Loader Project handling

At the first IET Data Loader start, the user must enter a name for the new project.

![Create Project](image)

*Figure 5.12: Create Project*

If more than one project exists, a selection box to choose the active project appears at IET Data Loader start. If only one project exists it is opened automatically.
Each project might contain the configuration data for one target application. Within the different iteration steps to engineer a complete system and application there is no need to create a new project, as the IET Data Loader tool offers the possibility to create rollback points at any stage of the engineering process. The imported data is always written to the application the used Monitor Pro session is connected to and the user has authenticated himself to.

E.g. if the user logs into the watchdog application from a Hot Stand-by system the data is written to the watchdog application.
1. In help of the Manage Projects dialog it is possible to:
   a. Open an existing project
   b. Create a new empty project
   c. Delete an existing project. This removes all the project files and if no backup exists there is no way to restore them.

   The external OPC DA client configuration files and the IEC 61850 OPC Server configuration files are not deleted as they are stored outside the project data structure. Also the created Application Objects (Process Objects, Event Handling Objects, Scale Objects) and the language text databases remain in the application.

2. At any time the current project data can be saved e.g. after some IET project files have been imported.

   There is no notification about unsaved data when exiting the user interface.

   The project data is automatically saved after the write configuration process has been completed.
5.7.3.2 Import IET600 export file

As the IET600 export file might contain more than one target system, e.g. one for the main HMI system and one for a gateway system, the one to be used in current IET Data Loader project needs to be selected during the import.

If the target system name defined in IET600 is equal to the computer name this step is decided automatically.

Possible target systems are:

- HMI (1), single system or first system of redundant setup using Hot stand-by
- HMI 2, second system of redundant setup using Hot stand-by
- Gateway (1) using COM500i, single system or first system of redundant setup using Hot stand-by
- Gateway 2 using COM500i, second system of redundant setup using Hot stand-by
- Other combinations of the above systems e.g. single HMI with gateway functionality

The target system names are defined in the IET600 project.

Afterwards it’s not possible to import a different target system name from a new or different IET600 export file. In order to be able to import data for a different target system a rollback to the initial IET Data Loader project state needs to be performed.

It is possible to import IET600 export files from different IET600 projects as long as the target system name stays the same. This might be needed in case of huge projects which cannot be handled in one IET600 project.

The following table describes the different import options.

<table>
<thead>
<tr>
<th>IET600 project name</th>
<th>Target system name</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always same</td>
<td>Same as computer name</td>
<td>This is the normal use case during incremental system engineering. <strong>OK</strong>: Update the existing project data. <strong>Cancel</strong>: No further action</td>
</tr>
<tr>
<td>Different than computer name</td>
<td>Different than computer name</td>
<td><strong>OK</strong>: The data for the selected target system is imported. If different than from previous import the data is overwritten. <strong>Cancel</strong>: No further action</td>
</tr>
<tr>
<td>More than one target defined and all different than computer name</td>
<td>More than one target defined and all different than computer name</td>
<td><strong>OK</strong>: The data for the selected target system is imported. If the selected target system is different from the previous one, the import will be rejected since there is already an active target system. <strong>Cancel</strong>: No further action</td>
</tr>
<tr>
<td>Different than from previous import</td>
<td>Same as computer name, same as from previous import</td>
<td><strong>Select and Open</strong>: This overwrites the previous imported project file. <strong>Add as new project</strong>: The added project file and the previous loaded are merged and handled as one IET project file.</td>
</tr>
</tbody>
</table>

During the import process some validation checks are done. The possible solution and result can be found from the following table.
### Table 5.2: Problem/Solution for import of IET600 export file

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Communication attribute <code>&lt;attribute name&gt;</code> has been modified locally for <code>&lt;IED name&gt;</code></td>
<td>- Keep modified value</td>
<td>OK</td>
</tr>
<tr>
<td></td>
<td>- Set value from imported file</td>
<td>OK</td>
</tr>
<tr>
<td>IED <code>&lt;IED name&gt;</code> removed from server <code>&lt;OPC Server name&gt;</code> by refresh</td>
<td>N/A <code>Informational message</code></td>
<td>No Action</td>
</tr>
<tr>
<td>Imported server <code>&lt;OPC Server name&gt;</code> removed from the configuration</td>
<td>N/A <code>Informational message</code></td>
<td>No Action</td>
</tr>
<tr>
<td>IO Exception while reading <code>&lt;file name&gt;</code></td>
<td>N/A <code>possible corrupt export file, try to re-export from IET600</code></td>
<td>No Action</td>
</tr>
<tr>
<td>No target system with the name <code>&lt;target system name&gt;</code> could be found in the SystemIdentifier file. Cannot update OPC Servers</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Process data parsing failed with: <code>&lt;error message&gt;</code> Process data from <code>&lt;Import file name&gt;</code> is ignored</td>
<td>Acknowledge <code>possible corrupt export file, try to re-export from IET600</code></td>
<td>Acknowledged</td>
</tr>
<tr>
<td>Same process object <code>&lt;LN:PIX&gt;</code> defined in multiple import files.</td>
<td>Ignore object from <code>&lt;import file name&gt;</code></td>
<td>Ignored</td>
</tr>
<tr>
<td>Server <code>&lt;OPC Server name&gt;</code> SNTP address</td>
<td>- Keep old SNTP Value</td>
<td>Previously configured value used.</td>
</tr>
<tr>
<td></td>
<td>- Set SNTP to <code>&lt;OPC Server name&gt;</code></td>
<td>SNTP configuration set.</td>
</tr>
<tr>
<td>Subnetwork &lt;subnetwork name&gt; removed from the server <code>&lt;OPC Server name&gt;</code></td>
<td>N/A <code>Informational message</code></td>
<td>No Action</td>
</tr>
<tr>
<td>Server <code>&lt;OPC Server name&gt;</code> removed</td>
<td>N/A <code>Informational message</code></td>
<td>No Action</td>
</tr>
</tbody>
</table>

After the selected IET600 export file has been imported successfully, the target properties can be verified from the Communication and the Application Objects tab.

#### 5.7.3.3 Configuration data modification and verification

Before the imported data is written to the system, the user can verify the imported data in help of the Communication and the Application Objects tab.

For manual modifications user is asked whether to keep the modified data or use the original data from the import.

> It is recommended to change only the attributes which are not part of IET600 project engineering.
### Table 5.3: Attributes which are part of IET600 project engineering

<table>
<thead>
<tr>
<th>Attribute name</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disturbance Recorder Delete Recordings</td>
<td>IED</td>
</tr>
<tr>
<td>Disturbance Recorder Enabled</td>
<td>IED</td>
</tr>
<tr>
<td>Disturbance Recordings Read Via FTP</td>
<td>IED</td>
</tr>
<tr>
<td>Disturbance Recorder Local Directory</td>
<td>IED</td>
</tr>
<tr>
<td>Disturbance Recorder Polling Period</td>
<td>IED</td>
</tr>
<tr>
<td>Disturbance Recorder Polling Period</td>
<td>IED</td>
</tr>
<tr>
<td>Disturbance Recorder Remote Directory</td>
<td>IED</td>
</tr>
<tr>
<td>Dynamically Create Data Sets</td>
<td>IED</td>
</tr>
<tr>
<td>Report Control Block Initialize</td>
<td>IED</td>
</tr>
<tr>
<td>Report Control Identity</td>
<td>OPC Server</td>
</tr>
<tr>
<td>Send Single Message MMS Writes</td>
<td>IED</td>
</tr>
<tr>
<td>1. Port Number</td>
<td>OPC Server</td>
</tr>
<tr>
<td>1. Synchronization Interval</td>
<td>OPC Server</td>
</tr>
<tr>
<td>1. Address for SNTP Server</td>
<td>OPC Server</td>
</tr>
</tbody>
</table>

### IEC61850 OPC Server properties

![Image of IEC61850 OPC Server properties](image)

*Figure 5.15: IEC61850 OPC Server properties*
### Table 5.4: OPC Server attributes

<table>
<thead>
<tr>
<th>Category</th>
<th>Attribute</th>
<th>Value Default [type, range]</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[010]Basic</td>
<td>Accepted Tree Delimiter</td>
<td>[String]</td>
<td>This option determines the tree delimiters accepted from the OPC clients.</td>
</tr>
<tr>
<td></td>
<td>Tree limiter</td>
<td>[String]</td>
<td>This option determines the tree delimiter used by the OPC server. The option value must always be a single character.</td>
</tr>
<tr>
<td></td>
<td>Server Initialization Time</td>
<td>0 [numerical, Min=0, Max=65535]</td>
<td>Server initialization time in seconds.</td>
</tr>
<tr>
<td></td>
<td>Enable OPC version 2.0 Optimizations</td>
<td>True [Boolean]</td>
<td>Specifies whether OPC version 2.0 optimizations are used.</td>
</tr>
<tr>
<td></td>
<td>Use Quality And Time OPC items</td>
<td>True [Boolean]</td>
<td>Specifies whether the q and t OPC items (quality and timestamp) are included to the data object</td>
</tr>
<tr>
<td></td>
<td>Enable reading of d-attribute (description) from IED</td>
<td>False [Boolean]</td>
<td>Specifies whether the d attribute (description) is read from IED. Normally d is not reported from the IED. It is only read if this operation is requested e.g. with Online Diagnostics. When set to false, the text of the data object Description property is used.</td>
</tr>
<tr>
<td>[020] SNTP Client</td>
<td>1. (2., 3., 4.) Address for SNTP Server</td>
<td>[String]</td>
<td>IP-address or node name for SNTP Server</td>
</tr>
<tr>
<td></td>
<td>1. (2., 3., 4.) Port Number</td>
<td>123 [numerical, Min=1, Max=65535]</td>
<td>TCP/IP port number</td>
</tr>
<tr>
<td></td>
<td>1. (2., 3., 4.) Synchronization Interval</td>
<td>15 [numerical, Min=0, Max=3600]</td>
<td>Time synchronization interval in seconds. If value is 0, no time synchronization is done</td>
</tr>
<tr>
<td></td>
<td>Enable Time Synchronization Client</td>
<td>False [Boolean]</td>
<td>Controls if time synchronization client is initially in use or not</td>
</tr>
<tr>
<td>[025] SNTP Server</td>
<td>Enable Time Synchronization Server</td>
<td>False [Boolean]</td>
<td>Controls if time synchronization server is initially in use or not</td>
</tr>
<tr>
<td></td>
<td>Port Number For Time Synchronization Server</td>
<td>123 [numerical, Min=1, Max=65535]</td>
<td>Port Number For Time Synchronization Server</td>
</tr>
</tbody>
</table>
### Category: Report Control Identity

**Report Control Identity**

**Value:** `Client1 [String]`

**Description:** Report Control Identity (ClientLN iedName) specifies which report control block instance is used by the OPC Server.

### Category: Server Originator Category

**Server Originator Category**

**Value:** `2 [Enumeration, "not-supported" value="0", "station-control" value="2", "remote-control" value="3"]`

**Description:** Specifies the default originator category that is used for IEC 61850 control services. This can be overridden by OPC client for DPC control.

### Category: Server Originator Identification

**Server Originator Identification**

**Value:** `ABB [String]`

**Description:** Specifies the default originator identification that is used for changing values and IEC 61850 control services.

### Category: System Event Level

**System Event Level**

**Value:** `0 - disabled [Enumeration, "Level0" value="0", "Level1" value="1", "Level2" value="2", "Level3" value="3", "Level4" value="4", "Level5" value="5"]`

**Description:** Level of system event that are sent from the OPC Server. Amount of events sent is cumulative, higher level also contains lower level events. System event level configuration at OPC Server level overrides definitions at subnetwork and device levels.

1. **Level 0** (normal operation and errors)
2. **Level 1** (time synchronization errors)
3. **Level 2** (time synchronization done)
4. **Level 3** (reported local updates from devices)
5. **Level 4** (reported unconfigured updates from devices)

### Category: [040] OPC Alarm and Event

**MappedEvent**

**Value:** `[String]`

### IEC 61850 Subnetwork properties

![IEC 61850 Subnetwork properties](image)

*Figure 5.16: IEC61850 Subnetwork properties*
### Table 5.5: Subnetwork attributes

<table>
<thead>
<tr>
<th>Category</th>
<th>Attribute</th>
<th>Value Default [type, range]</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[010]Basic</td>
<td>In Use</td>
<td>1 [Enumeration, &quot;In Use=&quot;1&quot;, &quot;Not In Use=&quot;0&quot;]</td>
<td>Controls if the device communication is initially in use or not.</td>
</tr>
<tr>
<td>[020]Communication Port</td>
<td>Communication Port</td>
<td>ETH0 [String]</td>
<td>Port for communication</td>
</tr>
<tr>
<td>[030]Communication Control</td>
<td>System Event Level</td>
<td>0- Disabled [Enumeration, &quot;Level0&quot; value=&quot;0&quot;, &quot;Level1&quot; value=&quot;1&quot;, &quot;Level2&quot; value=&quot;2&quot;, &quot;Level3&quot; value=&quot;3&quot;, &quot;Level4&quot; value=&quot;4&quot;, &quot;Level5&quot; value=&quot;5&quot;]</td>
<td>Level of system event that are sent from the OPC Server. Amount of events sent is cumulative, higher level also contains lower level events. System event level configuration at subnetwork level overrides definitions at device level.</td>
</tr>
<tr>
<td></td>
<td>TCP/IP Keepalive Time-out</td>
<td>15 [numerical, Min=1, Max=3600]</td>
<td>TCP/IP Keepalive time-out in seconds</td>
</tr>
</tbody>
</table>

### IED, Group view for batch editing

![IED Group view](image)

**Figure 5.17: IED group properties**

This view is a dedicated view for batch editing of IED attributes. Batch editing is described later in this document (Section 5.7.4 IET Data Loader User Interface).
### Table 5.6: IED attributes

<table>
<thead>
<tr>
<th>Category</th>
<th>Attribute</th>
<th>Value Default [type, range]</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[010]Basic</td>
<td>In Use</td>
<td>1 [Enumeration, &quot;In Use=&quot;1&quot;, &quot;Not In Use=&quot;0&quot;]</td>
<td>Controls if the device communication is initially in use or not</td>
</tr>
<tr>
<td></td>
<td>Simulation Mode</td>
<td>False [Boolean]</td>
<td>Is the device in simulation mode?</td>
</tr>
<tr>
<td></td>
<td>System Event Level</td>
<td>0- Disabled [Enumeration, &quot;Level0&quot; value=&quot;0&quot;, &quot;Level1&quot; value=&quot;1&quot;, &quot;Level2&quot; value=&quot;2&quot;, &quot;Level3&quot; value=&quot;3&quot;, &quot;Level4&quot; value=&quot;4&quot;, &quot;Level5&quot; value=&quot;5&quot;]</td>
<td>Level of system event that are sent from the IED. Amount of events sent is cumulative, higher level also contains lower level events. System event level configuration at subnetwork level overrides definitions at device level.</td>
</tr>
<tr>
<td>Category</td>
<td>Attribute</td>
<td>Value Default [type, range]</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------------------------------</td>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>[030] Communication Control</td>
<td>Configuration Revision Check Enabled</td>
<td>False [Boolean]</td>
<td>If enabled, checks configuration revisions from all logical devices (LDx.LLN0.NamPlt.configRev). If configuration revisions do not match between configuration and IED, communication to the IED is not established.</td>
</tr>
<tr>
<td></td>
<td>Configuration Revision Check Location</td>
<td>[String]</td>
<td>Location for checking configuration revision for IED before establishing communication. The format is Logical Device Name\Logical Node Name\Data Object Name\Attribute Name e.g. LD1\LLN0\NamPlt\configRev</td>
</tr>
<tr>
<td></td>
<td>Data Subscribe Method</td>
<td>MMS [Enumeration &quot;GOOSE&quot; value=&quot;GOOSE&quot; &quot;MMS&quot; value=&quot;MMS&quot; &quot;BOTH&quot; value=&quot;BOTH&quot;]</td>
<td>Specifies the method how data is subscribed.</td>
</tr>
<tr>
<td></td>
<td>Dynamically Create Data Sets</td>
<td>False [Boolean]</td>
<td>Specifies whether data sets and reporting is initialized dynamically.</td>
</tr>
<tr>
<td></td>
<td>Enable EntryID Check</td>
<td>False [Boolean]</td>
<td>Enable reporting EntryID check. Report EntryIDs are used as sequence numbers for buffered reporting. A gap in sequence numbers causes a restart of reporting starting from lost sequence number.</td>
</tr>
<tr>
<td></td>
<td>MMS Request Timeout</td>
<td>3000 [Numerical, Min=0, Max=65535]</td>
<td>Specifies the timeout for MMS Request in milli-seconds. If 0 it is not in use.</td>
</tr>
<tr>
<td></td>
<td>Report Control Block Initialize</td>
<td>True [Boolean]</td>
<td>Initialize and enable report control blocks</td>
</tr>
<tr>
<td></td>
<td>Send Single Message MMS Writes</td>
<td>False [Boolean]</td>
<td>Specifies whether MMS Write contains only one message at the time.</td>
</tr>
<tr>
<td></td>
<td>Use 32 Bit Entry ID</td>
<td>False [Boolean]</td>
<td>Specifies whether only 32 bits in Entry IDs for information report sequence checking/restarting is used in the IEC 61850 OPC Server.</td>
</tr>
<tr>
<td></td>
<td>Use Sequence Number Check</td>
<td>True [Boolean]</td>
<td>Specifies whether sequence number checking for information reports is enabled in the IEC 61850 OPC Server.</td>
</tr>
<tr>
<td></td>
<td>Discard Old Buffered Events</td>
<td>False [Boolean]</td>
<td>Disable requesting of all buffered events from IED buffers. Enabling this prevents requests for all available old events from IED BRCB buffers with setting the EntryID to zero. Disabling this may cause unnecessary event duplicates on startup and during the reporting of a synchronization failure. Enabling this may cause a loss of events.</td>
</tr>
<tr>
<td>[030] Transparent SPA</td>
<td>LD SPA Address</td>
<td>0 [Numerical, Min=0, Max=9999]</td>
<td>The SPA address of the device connected via TCP/IP.</td>
</tr>
<tr>
<td>LD = Logical Device name</td>
<td>LD SPA TCP Port</td>
<td>7001 [Numerical, Min=1, Max=65535]</td>
<td>SPA TCP Port</td>
</tr>
<tr>
<td></td>
<td>LD SPA TCP Timeout</td>
<td>3 [Numerical, Min=1, Max=65535]</td>
<td>SPA TCP Timeout in seconds</td>
</tr>
<tr>
<td>[040] Polling</td>
<td>Polling Timeout</td>
<td>0 [Numerical, Min=0, Max=3600]</td>
<td>Polling Timeout in seconds. If device doesn't support reporting, ST and MX attributes can be polled with this interval.</td>
</tr>
<tr>
<td>Category</td>
<td>Attribute</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------------------------------</td>
<td>------------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Disable Syncrocheck for All Controls</td>
<td>False [Boolean]</td>
<td>Disables syncrocheck condition check for all select and operate controls.</td>
</tr>
<tr>
<td></td>
<td>Interlock Override Supported</td>
<td>False [Boolean]</td>
<td>Specifies whether Interlock Override is supported by this IED.</td>
</tr>
<tr>
<td></td>
<td>Synchroncheck Override Supported</td>
<td>False [Boolean]</td>
<td>Specifies whether Synchroncheck Override is supported by this IED.</td>
</tr>
<tr>
<td></td>
<td>LD Station/Remote Switch OPC Path</td>
<td>[String]</td>
<td>OPC path of the station remote switch position to be used with this device. The format is #ProgID For OPC Server#Channel Name\IED Name\Logical Device Name\Logical Node Name\Data Object Name E.g. #ABB.IEC61850_OPC_DA_Server.Instance[1]\Channel1\IED1\LD1\GGIO1\loc</td>
</tr>
</tbody>
</table>

| [080] Authentication            | Password                                 | [String]               | Password used for authentication                                 |
|                                  | Disturbance Recorder FTP Username       | [String]               | FTP user name to be used with Disturbance Recorder functionality. |
|                                  | Disturbance Recorder Read Via FTP       | False [Boolean]        | Specifies whether disturbance recordings shall be read using FTP (False=MMS(IEC61850), True=FTP). |
| [096] Disturbance Recording     | Disturbance Recorder Delete Recordings   | False [Boolean]        | Specifies whether disturbance recordings are deleted from IED after upload. |
|                                  | Disturbance Recorder Enabled            | False [Boolean]        | Enables triggering of disturbance upload through event.          |
|                                  | Disturbance Recorder Event Trigger Enabled | False [Boolean]        | Enables triggering of disturbance upload through event.          |
|                                  | Disturbance Recorder Event Trigger Source | [String]               | OPC path of event triggering the disturbance recording upload. Requires a Boolean event 'true' with value change to trigger upload. If empty, LD\RDRE\RcdMade\istVal and LD\RDRE\ERcdStored\istVal item searched and used if found. Format LD\LN\DO\Attr (e.g. DR\RDRE1\ERcdStored\istVal). |
|                                  | Disturbance Recorder Local Directory    | [String]               | Specifies the folder where disturbance recordings will be stored in computer. If left empty "C:\COMTRADE\IEDName" will be used. |
|                                  | Disturbance Recorder Maximum Total File Size | 0 [Numerical, Min=0, Max=2147483647] | Specifies maximum size in kilobytes for folder where all read disturbance recordings are locally stored for this IED (0=no limit). |
|                                  | Disturbance Recorder Polling Period     | 120 [Numerical, Min=0, Max=2147483647] | Disturbance Recorder polling period in seconds (0=disabled). |
|                                  | Disturbance Recorder Remote Directory   | COMTRADE/ [String]     | Specifies the folder where all disturbance recordings will be locally stored in this IED (e.g. C:\COMTRADE). |
External DA client

Figure 5.19: External DA client properties
### Table 5.7: External DA client attributes

<table>
<thead>
<tr>
<th>Category</th>
<th>Attribute</th>
<th>Value Default [type, range]</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[010]OPC</td>
<td>OPC Server</td>
<td>[String, not editable, selectable]</td>
<td>For IEC61850 OPC Server, the name cannot be changed manually. For other OPC Servers, the name can be selected from the dropdown list showing all found servers other than IEC 61850 OPC Servers.</td>
</tr>
<tr>
<td></td>
<td>CLSID</td>
<td>[String, not editable]</td>
<td>For IEC61850 OPC Server, the Class ID cannot be changed manually. It is read from the <code>&lt;drive&gt;:\sc\prog\61850_OPC_Server\IEC61850 OPC Server\bin\instances.ini</code> file. For other OPC Servers, the Class ID will be filled automatically based on the OPC Server name selection.</td>
</tr>
<tr>
<td></td>
<td>Prog ID</td>
<td>ABB. IEC61850.OPC_DA_Server.Instance[x].1 [String, x=instance number, not editable]</td>
<td>For IEC61850 OPC Server, the Prog ID cannot be changed manually. For other OPC Servers, the Class ID will be filled automatically based on the OPC Server name selection.</td>
</tr>
<tr>
<td></td>
<td>Remote Host Name</td>
<td>[String]</td>
<td>Not supported</td>
</tr>
<tr>
<td></td>
<td>Disable Device Refresh</td>
<td>True [Boolean]</td>
<td>Enabling this flag changes the OPC item refresh requests from the External OPC Data Access Client to the OPC Server to cachetype instead of device type. Cache refresh is used to update the item values from the cache of the OPC Server. More details in the External OPC DA client manual.</td>
</tr>
<tr>
<td></td>
<td>Enable Auto Refresh</td>
<td>False [Boolean]</td>
<td>When this setting is active, the External OPC Data Access Client place all items in the active state constantly, which is necessary for it to work correctly with some OPC servers. The automatic refresh increases the memory and CPU usage and therefore it should be turned off for most of the OPC servers.</td>
</tr>
</tbody>
</table>
## Table of Parameters

<table>
<thead>
<tr>
<th>Category</th>
<th>Attribute</th>
<th>Value Default [type, range]</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[015] OPC</td>
<td>Enable Cyclic Buffering (ECB)</td>
<td>False [Boolean]</td>
<td>No Buffering: ECB and EEB = FALSE&lt;br&gt;When No Buffering is selected, External OPC Data Access Client does not buffer the events. Normal Buffering: ECB = FALSE and EEB = TRUE&lt;br&gt;When Enable Normal Buffering is selected, External OPC Data Access Client buffers the events so that the latest update is always stored into the buffer independently of the process object type. Normal buffering is the default setting. Circular Buffering: ECB = TRUE and EEB = FALSE&lt;br&gt;When Enable Circular Buffering is selected, External OPC Data Access Client buffers the events so that changes of switching device indications are always stored into the buffer as their own entries, which means that all the state transitions are stored. With measurement updates, the latest update is always stored into the buffer. More details in the External OPC DA client manual.</td>
</tr>
<tr>
<td>Keep Events (DeltaT)</td>
<td>0 [Numerical, Min=0, Max=99999]</td>
<td>This parameter determines the maximum time for keeping events in the buffer. When this time has elapsed and the event has still not been sent to SYS600, the event is removed from the buffer. By default, deltaT is equal to zero, which denotes infinity.</td>
<td></td>
</tr>
<tr>
<td>[020] CPI</td>
<td>Own Node Number</td>
<td>xx [Numerical, Min=1, Max=250]</td>
<td>OPC DA client node number as defined in sys_bascon.com or System Configuration tool. NODn:B</td>
</tr>
<tr>
<td>Own Station Address</td>
<td>xx [Numerical, Min=1, Max=255]</td>
<td>OPC DA client node station address: NODn:BSA</td>
<td></td>
</tr>
<tr>
<td>Base IP Address</td>
<td>127.0.0.1 [String]</td>
<td>Always local host IP address</td>
<td></td>
</tr>
<tr>
<td>Base Node Number</td>
<td>xx [Numerical, Min=1, Max=250]</td>
<td>Base system node number the OPC DA client is connected to: SYS:BND</td>
<td></td>
</tr>
<tr>
<td>Base Station Address</td>
<td>xx [Numerical, Min=1, Max=255]</td>
<td>Base system station address: SYS:BSA</td>
<td></td>
</tr>
<tr>
<td>Base Application Number</td>
<td>xx [Numerical, Min=1, Max=250]</td>
<td>Base system application number the OPC DA client is connected to: APL:BAN</td>
<td></td>
</tr>
<tr>
<td>Backup Node Number</td>
<td>xx [Numerical, Min=1, Max=250]</td>
<td>Not supported</td>
<td></td>
</tr>
<tr>
<td>Backup Station Address</td>
<td>xx [Numerical, Min=1, Max=255]</td>
<td>Not supported</td>
<td></td>
</tr>
</tbody>
</table>
### Category | Attribute | Value Default [type, range] | Description
--- | --- | --- | ---
| | Backup IP Address | 0.0.0.0 [String] | Not supported
| | Backup Application Number | xx [Numerical, Min=1, Max=250] | Not supported
| | MS Max Reconnections | 0 [Numerical, Min=0, Max=10] | The number of reconnection attempts to the primary SYS600. After these attempts are expired, External OPC Data Access Client is connected to the secondary SYS600 base system.
| | System Messages Enabled (SE) | 1 [Enumeration, 1,4] | Details description can be found from the external OPC DA client manual
| | Running Mode (RM) | 0 [Enumeration, 0, 1] | Details description can be found from the external OPC DA client manual

**UN mapping**

![UN mapping](image)

*Figure 5.20: UN mapping*

Station objects (Unit numbers) which cannot be automatically mapped to any OPC Server are listed in this view for manual mapping to any available OPC Server.
The Application Objects tab shows the Process Objects which are created, deleted or modified. The presented data is the result of the comparison between currently loaded IET data and the previously loaded one.

![Application Objects tab](image1)

Figure 5.21: Application Objects tab

This view does not allow changes to any Process Object attribute.

### 5.7.3.4 Configure MicroSCADA system

The configuration process can be started from the home tab’s “Configure MicroSCADA System” section.

![Configure MicroSCADA System](image2)

Figure 5.22: Configure MicroSCADA system

#### 5.7.3.4.1 Write Configuration

After “Write Configuration” button selection and confirmation the following configuration steps are executed:
1. Consistency check process objects. Manually modified Process Objects are detected.
2. Process Object, dummy scale objects and Event Handling object creation
3. SCIL text database generation for signal status text
4. IEC61850 OPC Server configuration data creation
5. Update and reload of every configured IEC61850 OPC Server instance
6. External OPC DA client configuration data creation
7. Restart of every configured external OPC DA client instance
8. Automatic save of current project data
9. Possibility to create some rollback point

Problems which might occur during the configuration process are listed in the “Select Solutions” dialog as shown in the below figure.

![Figure 5.23: Problem, solution dialog](image)

The table below lists all possible problems/errors which might occur during the configuration process. For most of the problems one or more solutions can be applied.

**Table 5.8: Write configuration problems and solutions**

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
<th>Result (applied solution)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process database</td>
<td></td>
<td></td>
</tr>
<tr>
<td>&lt;LN&gt; Event Channel referenced, but does not exist in Process Database</td>
<td>Acknowledge</td>
<td>Acknowledged</td>
</tr>
<tr>
<td>Event Handling Object &lt;LN&gt; cannot be removed because it is still referenced by process objects</td>
<td>Leave event handler in database</td>
<td>OK</td>
</tr>
<tr>
<td>Remove of Event handling object &lt;LN&gt; failed with status: &lt;Status message&gt;</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Problem</td>
<td>Solution</td>
<td>Result (applied solution)</td>
</tr>
<tr>
<td>---------</td>
<td>----------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Create/Modify of <code>&lt;LN:PIX&gt;</code> failed with status: PROF_EVENT_HANDLING_Does_NOT_EXIST</td>
<td>Create dummy event handler.</td>
<td>Dummy handler is created</td>
</tr>
</tbody>
</table>
| Create/Modify of `<LN:PIX>` failed with status: PROF_PHYSICAL_ADDRESS_OVERLAP | • Ignore<br>• Remove existing objects with address<br>• Clear address from existing objects<br>

*In case the addressing conflict solution fails. First step is to retry the configuration. If retrying the write doesn’t lead to database consistency with IET, the solution is to roll back to a point where there are no conflicts (possibly the first clean rollback) and re-import and re-configure.* | • Ignored<br>• Process object `<LN:IX>` removed<br>• Addresses cleared from `<LN:IX>` |
<p>| Missing event handler <code>&lt;LN&gt;</code> referenced by objects to be created | • Create dummy event handler&lt;br&gt;• Ignore process objects referencing the handler | Dummy handler is created&lt;br&gt;Skipped <code>&lt;LN:PIX&gt;</code> process objects with missing event handling object <code>&lt;LN&gt;</code> |
| <code>&lt;LN:PIX&gt;</code> Process Objects which need to be created already exist in Process Database | Overwrite Process Objects | Process Object is overwritten |
| Failed to delete empty process object group <code>&lt;LN&gt;</code> | N/A | No Action |
| Modify/Remove of <code>&lt;LN:PIX&gt;</code> failed with status <code>&lt;Status message&gt;</code> | N/A | No Action |
| Object <code>&lt;LN:PIX&gt;</code> cannot be removed because it is referenced by topology model | • Remove topology <code>&lt;NT model name&gt;</code> and process object&lt;br&gt;• Leave object in database | Topology and object <code>&lt;LN:PIX&gt;</code> deleted&lt;br&gt;OK |
| Object to be removed <code>&lt;LN:PIX&gt;</code> is contained in the topology. Topology must be stopped to import to complete. | • Delete topology&lt;br&gt;• Leave process object <code>&lt;LN:PIX&gt;</code> in the database. | Topology has been deleted&lt;br&gt;Process database change ignored |
| Scale Object <code>&lt;LN&gt;</code> couldn’t be removed because it is still referenced by process objects | Leave scale in database | OK |
| Missing scale <code>&lt;LN&gt;</code> | Create dummy linear 1:1 scale. | Dummy linear 1:1 scale will be created. |</p>
<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
<th>Result (applied solution)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Language text database</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>&lt;State text ID count&gt; Translations which need to be created already exist</td>
<td>Overwrite Translations</td>
<td>Translations staged for removal.</td>
</tr>
<tr>
<td><strong>COM500i/XREF import</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>COM500i not configured</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td></td>
<td>Configure COM500i in help of X-References tool</td>
<td></td>
</tr>
<tr>
<td>Signal X-References Tool is open and must be closed before COM500i configuration can be completed</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td></td>
<td>Close the COM500i X-References tool</td>
<td></td>
</tr>
<tr>
<td>COM500i Command/Indication XREF import file invalid. No COM500i XREF import is done.</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td></td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>COM500i commands/indications import failed</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Failed to clear COM500i command/indication XREFs</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Failed to merge COM500i XREF files. No COM500i/XREF import is done</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Merged COM500i Commands/Indications import file missing. Commands not imported.</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>XREF config missing from new IET project file</td>
<td>Remove existing XREF configuration</td>
<td>XREF configuration was deleted from MicroSCADA.</td>
</tr>
</tbody>
</table>

In case the COM500i XREF import fails or is aborted this might lead to some inconsistency in the COM500i configuration database as some part of the XREF information is already stored in the Process Object database.

Correcting the root cause of the import failure and importing a new IET export file followed by a write configuration will resolves this inconsistency.

Some Process Object attributes belonging to the COM500i package might get reported as manual modified. The reason is that they are used as dynamic attributes and changed during runtime. These “dynamic” attributes are overwritten during the write configuration process and can lead to a situation that wrong values are send to NCC. A MicroSCADA restart and
process data update is needed to get the “dynamic” attributes correctly initialized to their runtime values.

Examples:

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manually modified attributes (65, CX, R1) for BNCC1_GRP:P1 will be overwritten with values from import.</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Manually modified attributes (65) for BNCC1_GRP:AS:P1 will be overwritten with values from import.</td>
<td>N/A</td>
<td>No Action</td>
</tr>
<tr>
<td>Manually modified attributes (65) for BNCC1_GRP:PS:P2 will be overwritten with values from import.</td>
<td>N/A</td>
<td>No Action</td>
</tr>
</tbody>
</table>

Figure 5.24: Manual overwritten COM500i Process Objects

5.7.3.4.2 Rollback handling

A new rollback point can be created every time the configuration write process has been completed. It’s recommended to enter some descriptive name for the rollback point which make it easy to recognize the state of the engineering process at that time.

Figure 5.25: Create Rollback

If no rollback should be created the dialog can just be closed using the cancel button. If during the write configuration process some major problem arises it is possible to abort and choose a rollback point to restore to a known good configuration state.
After a rollback point has been selected and confirmed, the configuration data as it is stored in the rollback is automatically written to the system.

Not every small change during the incremental engineering process needs to be stored in a rollback point. As there is no way to delete any rollback point from the UI it is recommended to only create one in case of bigger changes.

It is possible to write the configuration data to a chosen rollback point at any time.

5.7.4 IET Data Loader User Interface

Most of the configuration data in the IET Data Loader User Interface is presented using a grid view.

The grid view is used for the communication objects detail view, application objects detail view and the console in the lower part of the UI.

The grid view includes:

Figure 5.27: Grid view details
1. Drag area for column grouping
2. Column title with sort options

![Attribute]

3. Filter field per column.
4. Editable cell data

Cell data edit activation is done by double-clicking the left mouse button. Depending on the selected cell data type, either a selection box, numeric spinner or an edit field appears.

The following batch editing schemes are possible:
1. Copy from one cell and paste to one cell
2. Copy from one cell and paste to several cells
3. Copy area and paste to area of same range

Copy/paste is implemented via keyboard using key combinations ctrl + C (copy) and ctrl + V (paste).

Data type and range checking is done when values are pasted. The old value is automatically returned to the cell if the value does not pass the checking.

Non-editable cells can also be selected and copied to the clipboard.

The User Interface can be closed using the dialog close (x) button.

5.7.5 Engineering information

OPC DA client / IEC61850 OPC Server start and stop

During the engineering process using IET Data Loader, all configured external OPC DA client instances and with it the IEC61850 OPC Server instances are started at the end of the write configuration process.

In order to establish the OPC communication during SYS600 startup, the external OPC clients need to be started with a SCIL OPS_CALL command.

In hot stand-by systems the OPC DA client start should be initiated from the watchdog application.

On MicroSCADA stop the external OPC DA clients should be stopped with the help of a command procedure connected to the pre-defined Event Channel APL_CLOSE.
For more details, read Section 5.8.4 Configuring an External OPC DA Client instance or the “SYS600_External OPC Data Access Client” manual, chapter 4.2.

Project data storage

All IET Data Loader project files are located in the directory <drive>\sc\sys\MIET\.

Each project owns one sub-directory.

The external OPC DA client configuration files are stored in the <drive>\sc\sys\active\sys_DAClients directory.

Language text data base

The status text data is stored in the SCIL text database file IET_TEXT.SDB in the application APL_ directory.

This SCIL database must be loaded to the application text database attribute APL:BTD to become active. This can be done in the base system configuration file sys_bascon.com:

```
; Application Object APL attributes
#local Apl_Modify = list(-
  TT = "LOCAL", ;Translation type
  AS = "COLD", ;Application state
  PQ = 5, ;Parallel1 queues
  AA = 10, ;Number of APL-APL servers (1..10)
  SR = 1, ;Shadowing maximum receive wait time in seconds
  HP = "DATABASE", ;History Logging Policy ("DATABASE", "EVENT_LOG", "NONE")
  TD = vector("APL_IET_TEXT.SDB") | IET text database for signal status text
```

Figure 5.28: Text database load definition

In case the same language text exists in the default application text database APL_/APL_TEXT.SDB this one has higher priority as it is loaded first.

IEC61850 OPC Server diagnostics

It is recommended to use a 3rd party OPC client program connected to the IEC61850 OPC Server instance in question for on-line diagnostic purposes.

1. Connect to the IEC61850 server instance
2. Browse the OPC server name space and add the Diagnostic counters items either on OPC Server, subnetwork level or on IED level

5.7.6 Important notes

If Process Objects which are in the current active NTC model need to be removed during the write configuration process, the NTC model must be removed first.

For small Process Object attribute modifications, e.g. during commissioning, the application import/export tool can still be used for the safe file import format .sfx.
5.8 Configuring without IET600

5.8.1 Configuring IEC 61850 OPC Server

IEC 61850 OPC Server is configured using the ABB CET for IEC 61850 OPC Server. With this tool, the hierarchically structured models of a substation or a system are built and loaded into configuration files of IEC 61850 OPC Server.

To start CET for IEC 61850 OPC Server:
1. Open MicroSCADA Pro Control System SYS600 shortcut from desktop.
2. Open 61850 OPC Server.
3. Double-click Communication Engineering Tool.

5.8.1.1 Creating a new project

To create a new project:
1. Start ABB CET for IEC 61850 OPC Server.
2. Select File > Open/Manage Project.
3. Click New Project and fill in the required project information.
4. Click Create.
5. Select the project and click Open.

5.8.1.2 Configuring IEC 61850 OPC Server

Creating and configuring IEC 61850 OPC Server:
1. Right-click the project and select New > Communication > Computer Node to add a computer node to the project.
2. Right-click the Computer Node and select New > IEC61850 > IEC61850 OPC Server to add an IEC 61850 OPC server (named OPCS1).
3. Right-click the IEC 61850 OPC Server and select New > IEC61850 > IEC61850 Subnetwork to add an IEC 61850 subnetwork (named Subnet1) to the IEC 61850 OPC server.
4. Right-click IEC 61850 Subnetwork and select New > IEC61850 > IEC61850 IED to add an IEC 61850 IED (named IED1) to the IEC 61850 subnetwork.

To view and configure properties for the created nodes, right-click the node and select Properties to open Object Properties.

The IEC 61850 OPC Server and IEC 61850 Subnetwork can be renamed if required. Names for the IEDs are unique within a system and are defined with the IED configuration tools.
5.8.1.3 Importing IED configuration

To import IED configuration:

1. Right-click the IEC 61850 IED and select **SCL Import**.
2. In the SCL Import pane, click **Select File**.
3. Select the IED SCL configuration file and click **Open**.
4. Select the IED and Accesspoint and click **Next**. Click **Import**.

The following import options are available:

- **Filter DOs that don’t belong to DataSet**: This option limits the amount of data objects being imported to CET Project Explorer. If a data object does not belong to any data set, it is not imported. Some IEDs can provide huge amounts of data that is not reported, that is, not spontaneously updated. It does not filter data objects from the configuration of the IEC 61850 OPC Server. Import performance is enhanced by checking this option.

- **Overwrite existing descriptions**: This option overwrites all existing descriptions on objects affected by the import operation. Select this option only if it is certain that the importable file contains better descriptions than the current configuration.

- **Import protocol configuration (sAddr)**: Imports the protocol-specific information. If this option is selected, both the object tree and protocol configuration are done. If this is not selected, only the object tree structure is created.

- **Overwrite limit settings**: This option imports limit settings for IEC 61850 OPC Server limit supervision from IED configuration.

- **Check Report Control Blocks for Client Identity**: This option checks the imported IED configurations for reporting dedications. IEDs with no report control blocks dedicated for this OPC server are not imported. It uses the OPC Server name and the property Report Control Identity and compares them to all IED report control block client dedications. Import performance is enhanced by checking this option.

- **Check configuration revisions**: This option checks the imported IED configurations for revision changes. IEDs with no revision change are not imported. It compares the current project revision attributes to imported configuration file revision information. Import performance is enhanced by checking this option.

- **Create Only IED Objects**: This option limits the Project Explorer to show imported elements down to IED level. Import performance is enhanced by checking this option.

IEC 61850 uses DataSets to group signals and Report Control Blocks (RCB) to control sending changes in dataset signals between the IED and the IEC 61850 clients. RCBs and datasets are configured with IED configuration tools. RCBs and datasets are located under IEDs Logical Devices Logical Nodes (usually LLN0).

To allow multiple IEC 61850 clients to receive the same data values from the IED, multiple instances of the report control blocks are be made available. The number of available report control block instances is specified by Report Enabled Max property. In CET the report control block instances are dedicated using RCB ReportClient items by specifying the client name in the ReportClients IED Name property value.
It is important to dedicate specific instances of the IED Report Control Blocks for specific IEC 61850 clients. Multiple IEC 61850 clients cannot enable reporting from a single report control block instance and it causes communication failures.

To enable IEC 61850 OPC Server to use a specific RCB instances and thus receive spontaneous events, the Report Control Identity object property of the OPC Server must match one of the Report Client fields in the device's RCB configurations. The RCBs without instances specified for the IEC 61850 OPC Server are discarded. For more information, see IEC 61850 Master Protocol (OPC) manual.

![Image of Report Control Identity and RCB dedication]

**Figure 5.29: Report Control Identity and RCB dedication**

### 5.8.1.3.1 Updating IEC 61850 OPC Server configuration

Once the IEC 61850 configuration in CET is ready the configuration needs to be updated to be taken in to use in the IEC 61850 OPC Server. To update IEC 61850 OPC Server configuration:

1. Right-click the Computer Node and select **Management**.
2. Click **Update configuration** to update the configuration.
3. Click **Reload configuration** to restart the IEC 61850 OPC Server with the new configuration. This is required if the IEC 61850 OPC Servers are already running.


The configuration is now updated and the IEC 61850 OPC Server is ready to be started.

### 5.8.1.4 Time Synchronization

IEC 61850 OPC Server can act as an SNTP client and server for time synchronization. For more information, see the IEC 61850 Master Protocol (OPC) manual.

#### 5.8.1.4.1 SNTP Client

When the IEC 61850 OPC Server is configured as a time synchronization client, it updates the operating system time of the workstation. SNTP Client supports maximum 4 alternative SNTP servers.

When using the SNTP Client, disable automatic time synchronization of the workstation operating system.

#### 5.8.1.4.2 SNTP Server

When the IEC 61850 OPC Server is configured as a time synchronization server, it responds to synchronization requests of the SNTP clients with the time of the workstation operating system.

In order for SNTP Server to work in the IEC 61850 OPC Server, the Windows time synchronization service (Windows Time) must be disabled since it occupies the SNTP server port of the workstation.

To set daylight saving time, enable Windows Date and Time Properties to automatically adjust the time for daylight saving changes.

### 5.8.2 Creating process objects

The SCL Importer is usually used in SYS600 IEC 61850 systems to create the application objects into the SYS600 process database from the SCL configuration files. The prerequisite is that the SCL files contain a Substation section, whose content is further applied to the Object Identification attribute values, which in turn are assigned to the process objects.
Before importing the SCL file, ensure that the Subnetwork field in SCL Importer contains exactly the same subnetwork name as the configured IED in the IEC 61850 OPC Server in CET (for example, text "Subnet1"). The subnetwork name appears later in the External OPC DA Client configuration. Also fill in the Substation, Voltage Level and Bay fields.

If the substation is given another name than TEMPLATE in the SCL file, SCL Importer assumes that Substation, Voltage Level, Bay and Subnetwork objects are already defined in the file. In this case, these fields are disabled. If Substation, Voltage Level, Bay and Subnetwork need to be redefined before importing, select the file type Configured IED Description Files (.cid) in the file selection dialog.

The object text for protection process objects can be, for example, translated into a selected language by describing it in the SCL file with a key, such as PTOC_NOC3LOW_OP. The translated object text is available after importing a language file that includes the values for the used keys, for example PTOC_NOC3LOW_OP="3I> trip". If the translated text is used in the SCL file, the related default language file (English) is delivered with the connectivity package.

5.8.2.1 Importing SCL configuration

The SCL Importer can be used to automatically generate the process objects and the External OPC DA Client configuration for the IED.

To import SCL configuration:

1. Open Tool Manager from SYS600 Monitor Pro > Tools > Engineering Tools > Tool Manager or by starting SYS600 Monitor.
2. Open SCL Importer from the Application Objects tab in Tool Manager.
3. Select Options > Import Settings and configure the options as in Figure 5.30 and click OK. The settings are stored and need to be configured only once.
4. To define the Active File, click '...' to locate the SCL file (.CID).
5. Click **Open** and fill in the Object Identification information as in Figure 5.31. Check that the Subnetwork name corresponds with the subnetwork name in CET configuration.
6. Click **Preview** to open a preview of the objects to be created, see Figure 5.32.
7. Click **Import** and fill in the unit numbers for the IEDs to be imported.
8. Click **OK** and configure the External OPC DA Client. Select the IEC 61850 OPC Server instance in which the IED is configured. Configure the External OPC DA Client configuration file name and the CPI node number.

9. Click **OK**. The process objects for the IED are created and the External OPC DA Client configuration is generated.
5.8.2.2 Importing a language translation file

To import a language translation file:

1. Open SCL Importer from the Application Objects tab in Tool Manager.
2. Click '...' to open the file type and name selection dialog.
3. Select the file type Connectivity Package Language Files (.txt) and locate the language file (for example C:\PROGRAM FILES\ABB\CONNECTIVITY PACKAGES\REF 541_3_5\2.0\COMMUNICATION\LANGUAGE SUPPORT\EN\IEC\EN_IEC.TXT).
4. Click Open.
5. Click Import and close the tool.

5.8.2.3 Addressing process objects

OPC PO List Tool facilitates the creation of mappings between OPC items and SYS600 process object addresses. OPC PO List Tool creates an output file in which the available process objects are listed and later recognized by the External OPC DA Client Configuration Tool.

The following phase of the configuration is skipped when using the automatic External OPC DA Client configuration option in SCL Importer.

To address process objects:

1. Open OPC PO List Tool from the System Configuration tab in Tool Manager.
2. Select Edit > Include All and select the station number selected in the base system configuration.
3. Click **OK** to accept the station number, see Figure 5.35.
4. Select **File > Save As...** and save the file with the default file name OPCPOLIST.PL by clicking **OK**. The **Save Objects List** appears, see Figure 5.36.

5. Select **Assign new block address and bit number** and click **Save**. The start range for the block is from 1 to 4094, depending on the number of the process objects on the list. If the start range is more than 4095, a notification message is displayed. The default start range is 1.

6. If **Assign new block address and bit number** is not selected above, the process objects do not contain the addressing information, and the dialog in Figure 5.37 is displayed when **Save** is clicked. Click **OK for All** to automatically generate all the block and bit addresses, and close OPC PO List Tool. The start range for the block...
is from 1 to 4094, depending on the number of the process objects on the list. If the start range is more than 4095, a notification message is displayed. The default start range is 1.

![Invalid process object address](image)

Figure 5.37: Invalid process object address

### 5.8.3 Configuring External OPC DA Client

External OPC DA Client is used for receiving communication from IEC 61850 OPC Server. The relationship to IEC 61850 OPC Server is defined when configuring External OPC DA Client.

Each External OPC DA Client configuration file usually contains the connection to one IEC 61850 OPC server. However, the related configuration to be included into each External OPC DA Client may also be a subset of the overall OPC Namespace found in IEC 61850 OPC Server. Consequently, External OPC DA Client may subscribe to only part of the IEC 61850 OPC Server signals representing only part of the system, for example OPC items related to only medium or high voltage process devices. One IEC 61850 OPC Server can thus serve several External OPC DA Client instances at runtime.

The following phase of the configuration is skipped when using the automatic External OPC DA Client configuration option in SCL Importer.

### 5.8.3.1 Starting External OPC DA Client Configuration Tool

To start External OPC DA Client Configuration Tool:

66
1. Open MicroSCADA Pro Control System SYS600.
2. Open External OPC DA Client and double-click **External OPC DA Client Configuration Tool**.

### 5.8.3.2 Connecting to IEC 61850 OPC Server

To connect to the OPC Server:

1. Select **File > New** to open the **Server Properties** dialog.
2. Click **Local Server**, if External OPC DA Client and IEC 61850 OPC Server are located on the same computer, as is the case in the typical IEC 61850 HSB system.
3. Click **Browse** to locate IEC 61850 OPC Server Data Access V2 on the list of available servers, see Figure 5.38. Click **OK**.

![Server Properties](image)

**Figure 5.38: Locating the server**

4. Click **Next** and fill in CPI Node Properties according to the previously made base system definitions, see Figure 5.39.

In the IEC 61850 HSB system, it is sufficient to define only the primary SYS600 settings. In this case, use the default Base IP Address 127.0.0.1.
5. Click Finish to finish CPI configuration and continue.

5.8.3.3 Auto-configuring OPC items for process objects

To auto-configure OPC items:

1. Select File > Auto Configure and click Browse to locate the PO List file previously created with OPC PO List Tool.
2. Click Open after locating the file, which by default is located in the folder \SC\SYSACTIVE\SYS_ with the name OPCPOLIST.PL.
3. Fill in Auto Configure and click Configure, see Figure 5.40.
Figure 5.40: Auto-configuring OPC items

4. If a warning appears, click Yes to continue the operation, see Figure 5.41. This is the case when External OPC DA Client Configuration Tool cannot validate the created OPC item in the IEC 61850 OPC Server.

Figure 5.41: Warning of validation failure

All the non-validated OPC items are found in the file with the extension .TRC in the folder \SC\SYS\ACTIVE\SYS_. When the auto-configuring is complete, the External OPC DA Client configuration is displayed as in Figure 5.42.
One or multiple OPC groups are defined for each communication station representing an IEC 61850 process device. For OPC groups containing items related to position indication and control commands, the update rate should be 0 ms. For OPC groups containing measurement values, however, an update rate of for example 1000 ms is accepted. The update rate setting specifies the interval time for External OPC DA Client's polling of OPC items from IEC 61850 OPC Server. An update rate of 0 ms means that no events are lost and the functionality is supported by IEC 61850 OPC Server.

### 5.8.3.4 Defining configuration for the IEC 61850 system

The **Disable Device Refresh** flag disables device refreshing within the External OPC DA Client so that the OPC Server is always trusted to have the latest data from the IED. When the flag is disabled, a device refresh issued by the External OPC DA Client can cause duplicate events. The **Disable Device Refresh** flag should always be enabled in IEC 61850 systems.

To define the configuration for the IEC 61850 System in External OPC DA Client Configuration Tool, right-click the CPI Node and select **Disable Device Refresh**, see Figure 5.43.
5.8.3.5 Defining the event buffer

In IEC 61850 HSB systems, define the event buffer as follows:

1. Right-click CPI Node and select **Buffering Settings**; see Figure 5.44.

![Figure 5.44: Event Buffering settings](image)

2. Under Buffering Type, click **Circular Buffering** and set the parameter **Keep events (deltaT)**.
   
   Keep events (deltaT) specifies the maximum amount of time in seconds for the events buffered by External OPC DA Client and should be adjusted to the switch-over time.

3. Click **OK** to close External OPC DA Client Tool, and save the configuration file.
5.8.3.6 Configuring an item for Transparent XSAT

Power Process Library included in SYS600 9.4 FP2 and later uses transparent XSAT for making the substitution to an IED. This feature is available in IEDs that support IEC61850 Ed2. To be able to utilize this feature, an item for Transparent XSAT needs to be configured for each STA object in an External OPC DA Client configuration.

To configure an item for Transparent XSAT

1. Select a group under an STA node.
2. Select Edit and Add item (or right-click to add an item).
3. Browse to item 'Subnetwork name\IED name\Attributes\Transparent XSAT.
4. Select Connect to MicroSCADA Custom STA Attribute.
5. Define Index = 0 and Name = XT.
6. Define Reg.type = VT_BSTR.

Figure 5.45: Transparent XSAT item

5.8.3.7 Configuring an item for Service Tracking

SYS600 9.4 FP2 supports IEC61850 Ed2 Service Tracking events. To enable this functionality, there needs to be one additional Process Object, a type of Bit Stream, added for each IED which is configured to use Service Tracking. These Process Objects should be connected to the event channel BGU_LTRK_EVENT:A. This event channel and the

72
related command procedure is automatically created by the Power process library. The command procedure will take care of the actual functionality as long as the Process Objects are correctly connected.

![Figure 5.46: Process object event channel connection](image)

In the External OPC DA Client configuration the Bit Stream process object is connected to the 'subnetwork\'IED\Attributes\Events item in IEC 61850 OPC Server.

![Figure 5.47: External OPC DA Client configuration](image)

The service tracking events in the Event Display are recognizable by:

1. Originator ID in the user name (US) attribute.
2. Comment text: "Service tracking event from: <Originator ID>".
In the command procedure BGU_LTRK_SUPPRESS:C the originator ID, which is by default the IEC 61850 client MAC-Address, can be translated to a more user-friendly name.

The service tracking events from the same client as from which the control was made can be suppressed with the command procedure BGU_LTRK_SUPPRESS:C.

5.8.4 Configuring an External OPC DA Client instance

5.8.4.1 IEC 61850 Hot Stand-by system topology

The configuration of the IEC 61850 communication system in the SYS600 HSB environment is presented in Figure 5.48. In HSB systems that include IEC 61850 process devices, the External OPC DA Client and the IEC 61850 OPC Server are usually both located on the same computer with the SYS600 base system.

![Figure 5.48: Topology of a typical HSB system with IEC 61850 process communication](image)

IEC 61850 process devices of a physical network are configured to have two masters, one in Computer A and another in Computer B. When a fault occurs in the primary base system (computer A), including the HOT application, the shadowing application in the stand-by base system (computer B) starts and takes over all the operational functions. In HSB systems, there is usually a need to minimize the switch-over time.

In Figure 5.48, the IEC 61850 OPC Servers and External OPC DA Clients are active both in the primary (including HOT application) and the stand-by (including the shadowing application) computer. This way, the latest data from IEC 61850 process devices is always available on the IEC 61850 OPC Servers. The changes are stored into the buffers of both External OPC DA Clients to prevent event loss during switchover.
When the main application is COLD the shadowing state of the application is HOT_RC, the buffering of the data updates is made in SYS600.

The External OPC DA Client should be located on the same computer as where the base system is running. The External OPC DA Client should be configured according to the application initialization procedures (APL_INIT_*), as defined in Section 5.8.4.2 Starting External OPC DA Client instance.

5.8.4.2 Starting External OPC DA Client instance

External OPC DA Client is normally started and stopped together with SYS600. Starting the External OPC DA Client also starts the IEC 61850 OPC Server to which it is configured to connect to. SYS600 base system command procedures need to be modified and created using the Object Navigator tool to configure the automatic startup of the External OPC DA Client and the IEC 61850 OPC Server.

In Hot Stand-by systems, the External OPC DA Client should be started from the watchdog (WD) application. In a standalone system it should be started from the main application. This startup logic is included into the command procedure APL_INIT_1 triggered from the applications event channel APL_INIT_1. The External OPC DA Client instance starts automatically when the SYS600 system is starting up.

To configure automatic startup for External OPC DA Client:

1. Open Object Navigator from Tool Manager > Application Objects tab.
2. Select Command Procedures from tree view.
3. Select Object > New to create a new command procedure. Use the name START_OPC_DA_CLIENT_INSTANCE and click OK.
5. In the SCIL Editor insert the following SCIL code:

```scil
#error ignore
@abbr = ops_call( "C:\sc\prog\OPC_Client\DA_Client\daopccl.exe -id iec61850 -start C:\sc\sys\active\sys\_OPCDAC.ini", 0 )
```

6. Exit SCIL Editor saving changes. Set command procedure in use by checking the In Use checkbox. Click OK to exit Command Procedure viewer.
7. In Object Navigator select Command Procedures from tree view. Select APL_INIT_1 and double-click it. Click Edit in Command Procedures viewer.
8. In the SCIL Editor add the following SCIL code:

```scil
; Start External OPC DA Client after a delay
#exec START_OPC_DACLIENT_INSTANCE;C
```

9. Exit SCIL Editor saving changes. Click OK to exit Command Procedure viewer.
5.8.4.3 Stopping an External OPC DA Client instance

When the External OPC DA Client is shutdown it also shuts down the IEC 61850 OPC Server if no other OPC DA clients are connected to it (e.g. CET Online Diagnostics). A SYS600 base system command procedure needs to be created and modified using Object Navigator tool to configure the automatic shutdown of the External OPC DA Client and the IEC 61850 OPC Server.

To configure automatic shutdown for External OPC DA Client:

1. Open Object Navigator from Tool Manager > Application Objects tab.
2. Select Command Procedures from tree view.
3. Select Object > New to create a new command procedure. Use the name STOP_OPC_DA_CLIENT_INSTANCE and click OK.
5. In the SCIL Editor insert the following SCIL code:

```scil
#error ignore
@abb = ops_call( "C:\sc\prog\OPC_Client\DA_Client\daopcl.exe -id iec61850 -stop", 0 )
```

6. Exit SCIL Editor saving changes. Set command procedure in use by checking the In Use checkbox. Click OK to exit Command Procedure viewer.
8. In the SCIL Editor add the following SCIL code:

```scil
; Stop OPC DA Client instance
#do STOP_OPC_DA_CLIENT_INSTANCE:C
```

9. Exit SCIL Editor saving changes. Click OK to exit Command Procedure viewer.

5.9 Single-line diagram engineering

Single-line diagram engineering is required to connect the process objects to process displays. This is done either by using Display Builder or Picture Editor, depending on whether Classic Monitor or Monitor Pro graphics are used in the system.

The overall documentation for Display Builder in Monitor Pro is included in SYS600 Process Display Design. For Picture Editor in Classic Monitor, see SYS600 Picture Editing.

This chapter provides an overall understanding of single-line diagram engineering related to Monitor Pro and some details related to IEC 61850 display engineering.

5.9.1 Adding objects into the display

To add objects into the display:
1. Start Display Builder from Monitor Pro by selecting **Tools > Engineering Tools > Display Builder**.
2. In Display Builder select **File > New** to create a new display.
3. Select **Actions > Object Browser** to open **Object Browser**.
4. In Object Browser select the main application and click **Select** to list all objects from the selected application.
5. Browse down and select **Bay** from the **Object Browser** list and double-click the **Bay** to add a Bay Local/Remote switch to the display, see Figure 5.49. Alternatively, drag and drop the item into the Display Builder workspace.

![Figure 5.49: Main view of Display Builder.](image)

Proceed in the same way to add position indications for the circuit breaker, disconnectors and the earth-switch. Also add phase current and neutral current measurements.

For process symbols representing IEC 61850 process devices, the polarity of the position indication is different compared to devices communicating via other protocols, such as LON and SPA. Consequently, value swapping is required for IEC 61850-related process symbols during single-line diagram engineering. Further, if an application's single-line diagram contains several IEC 61850 process symbols, it is recommended to adjust the default polarity...
of the position indication in Object Browser accordingly. For more information, see SYS600 Application Design.

6. Select File > Save As... to save the display, and close Display Builder.

For more information on process display engineering, see SYS600 Process Display Design.

5.9.2 Adding Station Local/Remote Switch

The Station Local/Remote switch is used by the process display at run-time. To add a Station Local/Remote switch to the application:

1. Open Object Navigator from Monitor Pro by selecting Tools > Engineering Tools > Tool Manager. Object Navigator is located on the Application Objects tab.
2. Select Process Objects and from the menu Standard Function > Install to open Standard_Function Tool.
3. Select SA_LIB > Process > Station and click Install, see Figure 5.50.
4. Fill in the correct information and click **Apply**.
5. Select the **Tools** tab and open Process Object Tool and click **Create All**.
6. Click **Close** and then **OK**.
   The process objects related to Station Local/Remote Switch have now been created into the application.
8. Close Object Navigator.
9. Start the Display Builder again and drag and drop the IEC 61850 item from Object Browser to add a Station Local/Remote switch to the display.

### 5.9.3 Editing data variables in the display

In Display Builder edit the data variables for bay and controllable objects in the display as follows:

1. Select **Edit > Data Variables**.
2. Change the value swapping for the data variables related to circuit-breaker position from 1 and 2 to None.
Make the same change to the data variables related to the disconnector and earth-switch.

When creating process displays that contain mainly symbols connected to IEC 61850-signals, it is recommended to change the default value of state indication value swapping, as values are swapped by default. When swapping is selected, the state indication value 1 coming from process objects is changed to 2 and the value 2 to 1. To take swapping out of use, change UsesReversedDoubleIndications in OBJNAV.INI to 0.

Figure 5.51: Defining data variables

3. Save the display file by selecting **File > Save As...** and close the Display Builder.

**5.10 Configuring IEC 61850 Redundancy diagnostics**

**5.10.1 Local machine DuoDriver status diagnostics**

DuoDriver offers a driver level diagnostics interface, which can be accessed from the IEC 61850 OPC Server. The IEC 61850 OPC Server uses API to obtain the diagnostics and offers data through its OPC interface. The DuoDriver interface status information
(boolean) is available through the OPC path Attributes\DuoDriver\Node name\NIC name\Working.

The IEC 61850 OPC Server does not require configuration. On startup, it checks if DuoDriver is installed and creates the OPC items for DuoDriver diagnostics for all instances of the DuoDriver. The DuoDriver diagnostics are available in all instances of the IEC 61850 OPC Server.

The status diagnostics are mapped to MicroSCADA process objects with the External OPC DA Client. Additional diagnostics for network debugging are made available in the DuoDriver Management and Configuration GUI.

A specific STA object should be created for DuoDriver local diagnostics. When the importing option Create Process Objects for DuoDriver Server status is enabled during an IED import, MicroSCADA SCL Import Tool configures the External OPC DA Client and adds MicroSCADA process objects for the local machine DuoDriver status diagnostics automatically (see Figure 5.52). The import tool checks from operating system registry if DuoDriver is installed, resolves DuoDriver instance names and NIC names, and creates the required process objects to the database. The created process objects need to be configured for the DuoDriver station.

![Figure 5.52: DuoDriver local diagnostics on MicroSCADA: Process Objects](image)

The local DuoDriver status information has a symbol for Monitor Pro for on-screen monitoring. The symbol can be added through Display Builders Object Browser.
5.10.2 IED DuoDriver status diagnostics

In the IEC 61850 IEDs, the status of the two interfaces of the DuoDriver is made visible by the IEC 61850. For IEC 61850 Edition 2 IEDs, the data is located in the logical node LCCH in data objects ChLiv (physical channel status) and RedChLiv (physical redundant channel status). A Single Point Status (SPS) CDC with boolean attribute stVal is used for ChLiv and RedChLiv. For IEC 61850 Edition 1 IEDs the data is located in the logical node LPHD in data object SrcSt. A Redundancy Supervision Status (RSS) CDC with boolean attributes stValA and stValB is used for SrcSt. The information is accessible to every IEC 61850 client connected to the IED and is mapped to MicroSCADA process objects through the IEC 61850 OPC Server and External OPC DA Client.

The IEC 61850 OPC Server is configured with CET and the DuoDriver status diagnostics are available through the OPC, if the data objects are found in the IED configuration.

MicroSCADA SCL Import Tool configures the External OPC DA Client and adds MicroSCADA process objects for the IED DuoDriver status diagnostics automatically. The import tool checks if the data objects are found in the IED configuration and creates the required process objects and mapping for the External DA Client configuration.

The IED DuoDriver status information has a symbol for Monitor Pro for on-screen monitoring. The symbol can be added through Display Builders Object Browser.
Figure 5.54: DuoDriver IED diagnostics on MicroSCADA: Monitor Pro Symbols
6 Testing configuration

6.1 Testing IED and IEC 61850 OPC Server configurations

Use the Online diagnostics window in CET for IEC 61850 OPC Server to test that the individual IEC 61850 process device signals are updated accordingly.

For example, to test that the circuit-breaker position indication is correctly updated in the system:

1. Open IED in the project structure.
2. Open the logical device and select the logical node circuit breaker (e.g. CTRL\CBCSWI120).
3. Right-click OPC Pos and select Online diagnostics, see Figure 6.1.

![Opening the Online diagnostics window](image)

**Figure 6.1: Opening the Online diagnostics window**

When the process device signal is changed for the circuit-breaker position indication by using a simulator, stVal is to be changed according to the position of the signal as in Table 6.1.

<table>
<thead>
<tr>
<th>Circuit breaker</th>
<th>stVal</th>
</tr>
</thead>
<tbody>
<tr>
<td>00 Undefined</td>
<td>0</td>
</tr>
<tr>
<td>10 Open</td>
<td>1</td>
</tr>
</tbody>
</table>

**Table 6.1: StVal settings**
6.2 Testing External OPC DA Client start-up

To test the External OPC DA Client start-up:

1. Open MicroSCADA Pro Control System SYS600.
2. Open External OPC DA Client and start External OPC DA Client Control Panel.
3. Click New and then Browse to specify the location of the External OPC DA Client Configuration file.
4. Select the correct file and click Open.
5. Click OK to close the dialog box.

External OPC DA Client instance is now starting up an instance according to the selected configuration. When an instance is successfully started, it is found in List of External OPC DA Client Instances, see Figure 6.2.
However, if an instance is not successfully started, the reason may be one of the following:

- CPI Node Properties of External OPC DA Client configuration does not match with the definitions defined in the base system. Verify that the configurations are identical in CPI Node Properties and the base system.
- IEC 61850 OPC Server has not been correctly configured. Use Management Tool in CET for IEC 61850 OPC Server to update and reload the configuration.

### 6.3 Testing IED control commands using process display

Start by testing that it is possible to control the Bay L/R symbols using the process display in Monitor Pro. If not:

1. Open Object Navigator and select the appropriate process object related to the Bay L/R standard function.
2. Select **Object > Standard Function Properties**.
3. Verify that the attribute LR_REMOTELY_CONTROLLABLE is set and click **Apply**.
4. Select the **Tools** tab to open Process Object Tool and click **Create All**.
5. Click **Close** and then **OK**.
6. Close the Object Navigator.
7. Select **Tools > Options**.
8. Change the system location to Substation control system and click **OK**.

The controllable symbols of the engineered display can now be tested. Verify that they interact with the system correctly.
7 Distributed system topologies

The proposed system topology for the IEC 61850 system is presented in Figure 5.48, including the SYS600 HSB pair with dedicated External OPC DA Client and IEC 61850 OPC Server components. Technically, it is also possible for either External OPC DA Client, IEC 61850 OPC Server or both to be located on different computers in the same office network.

Figure 7.1 describes a system topology with two Communication Front-ends with process images connected to a System Server through process image mirroring. The System Server in turn mirrors the complete process image to servers with different functionalities like Workstation, Archiving and Reporting and External system interface. All nodes that utilize mirroring have SYS600 installed. The Communication Front-ends have at least one IEC 61850 OPC Server and external OPC DA Client installed.

![Figure 7.1: Distributed topology, example 1](image-url)
8 IEC 61850 System recommendations

The recommendations for the IEC 61850 system are presented in Table 8.1.

Table 8.1: Recommended limits

<table>
<thead>
<tr>
<th>SYS600 PC</th>
<th>Number</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of IEDs</td>
<td>400</td>
<td>With IET Data Loader: 400 IEDs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>With CET:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- 190 IEDs with option &quot;Create only IED objects&quot; disabled for SCD import.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- 300 IEDs with option &quot;Create only IED objects&quot; selected for SCD import.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The maximum number of IEDs may vary depending on the size of the IED configuration.</td>
</tr>
<tr>
<td>Maximum number of IEC 61850 Clients (OPC Servers)</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>Maximum number of IEC 61850 System Supervision Servers</td>
<td>1</td>
<td>Requires MMS port 102 for TCP communication</td>
</tr>
<tr>
<td>IEC 61850 Client (OPC Server)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum number of IEDs</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td>Maximum number of Ethernet links</td>
<td>6</td>
<td>Several IEC 61850 clients can use the same Ethernet link.</td>
</tr>
<tr>
<td>Maximum number of IEC 61850 subnetworks</td>
<td>16</td>
<td>Several IEC 61850 clients can use the same subnetwork.</td>
</tr>
<tr>
<td>IEC 61850 System Supervision Server</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum number of OPC Server Connections</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Maximum number of OPC Client Connections</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Maximum number of IEC 61850 Client Connections</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>Maximum number of mapped OPC items</td>
<td>200</td>
<td></td>
</tr>
</tbody>
</table>
# Troubleshooting

The following chapter describes what is needed to know to effectively troubleshoot IEC 61850 systems.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>When the network cable is unplugged while using the parametrization or disturbance upload tool, the situation is not handled properly.</td>
<td>Ensure that the timeouts for External OPC DA Client and the IEC 61850 OPC Server have been correctly set.</td>
</tr>
<tr>
<td>When the SNMP OPC Server is connected to MicroSCADA Pro, the related process objects appear as not sampled, i.e. process object statuses and values are not reflecting the appropriate OPC items from the SNMP OPC Server.</td>
<td>Ensure that the System Messages Enabled (SE) attribute is defined as disabled (value 1) in the configuration. This attribute is defined in the CPI Node Properties dialog of the Configuration Tool.</td>
</tr>
<tr>
<td>When the IEC 61850 OPC Server is connected to MicroSCADA Pro, all the process objects appear as not sampled, i.e. process object statuses and values are not reflecting the OPC items from the IEC 61850 OPC Server.</td>
<td>If System Messages Enabled (SE) is defined as enabled (value 4) in the configuration of the External OPC DA client, ensure that the Device connection status items are added to the same configuration. For more information, see the External OPC Data Access Client manual. If the Device connection status items are correctly configured, or the System Messages Enabled (SE) is defined as disabled (value 1) and process objects are still not updated, check that the node and the application values in the CPI Node Properties dialog of the configuration tool are as expected. Furthermore, all STA objects configured to the External OPC DA Client must be configured to the base system with the same node number as the External OPC DA Client instance.</td>
</tr>
</tbody>
</table>
10 Conformance statements

For information on IEC 61850 OPC Server, see the IEC 61850 Master Protocol OPC manual.

The logical nodes supported by SA LIB and SCL Importer are listed in Table 10.1. When a logical node is supported, it is possible to create process objects into the SYS600 process database either with SCL Importer or by installing SA LIB objects using the Installation Tool.

All data attributes within a logical node are not necessarily supported.

Table 10.1: Logical nodes supported by SA LIB/SCL Importer

<table>
<thead>
<tr>
<th>LN</th>
<th>Description</th>
<th>Supported by SA LIB</th>
<th>Supported by SCL Importer</th>
</tr>
</thead>
<tbody>
<tr>
<td>LPHD</td>
<td>Physical device information</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>LCCH</td>
<td>Physical communication channel supervision</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>LLN0</td>
<td>Logical node zero</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>PDIF</td>
<td>Differential</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDIR</td>
<td>Direction comparison</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDIS</td>
<td>Distance</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDOP</td>
<td>Directional overpower</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDUP</td>
<td>Directional underpower</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PFRC</td>
<td>Rate of change of frequency</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PHAR</td>
<td>Harmonic restraint</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PHI2</td>
<td>Ground detector</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PIOC</td>
<td>Instantaneous overcurrent</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PMRI</td>
<td>Motor restart inhibition</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PMSS</td>
<td>Motor starting time supervision</td>
<td></td>
<td></td>
</tr>
<tr>
<td>POPF</td>
<td>Over power factor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PPAM</td>
<td>Phase angle measuring</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PSCH</td>
<td>Protection scheme</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PSDE</td>
<td>Sensitive directional earthfault</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LN</td>
<td>Description</td>
<td>Supported by SA LIB</td>
<td>Supported by SCL Importer</td>
</tr>
<tr>
<td>-------</td>
<td>--------------------------------------------------</td>
<td>---------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>PTEF</td>
<td>Transient earth fault</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTOC</td>
<td>Time overcurrent</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTOF</td>
<td>Overfrequency</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTOV</td>
<td>Overvoltage</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTRC</td>
<td>Protection trip condition</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTTR</td>
<td>Thermal overload</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTUC</td>
<td>Undercurrent</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTUV</td>
<td>Undervoltage</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PUPF</td>
<td>Underpower factor</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PTUF</td>
<td>Underfrequency</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PVOC</td>
<td>Voltage controlled time overcurrent</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PVPH</td>
<td>Volts per Hz</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PZSU</td>
<td>Zero speed or under-speed</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RDRE</td>
<td>Disturbance recorder function</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RADR</td>
<td>Disturbance recorder channel analogue</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RBDR</td>
<td>Disturbance recorder channel binary</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RDRS</td>
<td>Disturbance record handling</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RBRF</td>
<td>Breaker failure</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RDIR</td>
<td>Directional element</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RFLO</td>
<td>Fault locator</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RPSB</td>
<td>Power swing detection/blocking</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RREC</td>
<td>Autoreclosing</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>RSYN</td>
<td>Synchronism-check or synchronizing</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>CALH</td>
<td>Alarm handling</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>CCGR</td>
<td>Cooling group control</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CILO</td>
<td>Interlocking</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>CPOW</td>
<td>Point-on-wave switching</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CSWI</td>
<td>Switch controller</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>GAPC</td>
<td>Generic automatic process control</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LN</td>
<td>Description</td>
<td>Supported by SA LIB</td>
<td>Supported by SCL Importer</td>
</tr>
<tr>
<td>------</td>
<td>------------------------------------------</td>
<td>---------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>GGI O</td>
<td>Generic process I/O</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>GSAL</td>
<td>Generic security application</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IARC</td>
<td>Archiving</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IHMI</td>
<td>Human machine interface</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ITCI</td>
<td>Telecontrol interface</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ITMI</td>
<td>Telemonitoring interface</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ANCR</td>
<td>Neutral current regulator</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ARCO</td>
<td>Reactive power control</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ATCC</td>
<td>Automatic tap changer controller</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>AVCO</td>
<td>Voltage control</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MDIF</td>
<td>Differential measurements</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>MHAI</td>
<td>Harmonics or interharmonics</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>MHAN</td>
<td>Non phase related harmonics or interharmonics</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>MMTR</td>
<td>Metering</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>MMXN</td>
<td>Non phase related Measurement</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MMXU</td>
<td>Measurement</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>MSQI</td>
<td>Sequence and imbalance</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>MSTA</td>
<td>Metering Statistics</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SARC</td>
<td>Monitoring and diagnostics for arcs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SIMG</td>
<td>Insulation medium supervision (gas)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SIML</td>
<td>Insulation medium supervision (liquid)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SPDC</td>
<td>Monitoring and diagnostics for partial discharges</td>
<td></td>
<td></td>
</tr>
<tr>
<td>XCBR</td>
<td>Circuit breaker</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>XSWI</td>
<td>Circuit switch</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>TCTR</td>
<td>Current transformer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LN</td>
<td>Description</td>
<td>Supported by SA LIB</td>
<td>Supported by SCL Importer</td>
</tr>
<tr>
<td>-------</td>
<td>-------------------------------------------------</td>
<td>---------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>TVTR</td>
<td>Voltage transformer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>YEFN</td>
<td>Earth fault neutralizer (Petersen coil)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>YLTC</td>
<td>Tap changer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>YPSH</td>
<td>Power shunt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>YPTR</td>
<td>Power transformer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZAXN</td>
<td>Auxiliary network</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZBAT</td>
<td>Battery</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZBSH</td>
<td>Bushing</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZCAB</td>
<td>Power cable</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZCAP</td>
<td>Capacitor bank</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZCON</td>
<td>Converter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZGEN</td>
<td>Generator</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZGIL</td>
<td>Gas insulated line</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZLIN</td>
<td>Power overhead line</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZMOT</td>
<td>Motor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZREA</td>
<td>Reactor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZRRC</td>
<td>Rotating reactive component</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZSAR</td>
<td>Surge arrester</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZTCF</td>
<td>Thyristor controlled frequency converter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZTCR</td>
<td>Thyristor controlled reactive component</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address</td>
<td>An IP (Internet Protocol) address is a unique identifier for a node or host connection on an IP network. An IP address is represented as 4 decimal values separated by decimal points. This is known as dotted decimal notation, for example 140.179.220.200. The IP address and the subnet mask determine which part belongs to the network address and which part belongs to the node address.</td>
</tr>
<tr>
<td>Logical Device</td>
<td>Representation of a group of functions. Each function is defined as a logical node. A physical device has one or several LDs.</td>
</tr>
</tbody>
</table>


## Abbreviations

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACSI</td>
<td>Abstract communication service interface</td>
</tr>
<tr>
<td>ACP</td>
<td>Application Communication Protocol</td>
</tr>
<tr>
<td>BRCB</td>
<td>Buffered Report Control Block</td>
</tr>
<tr>
<td>CDC</td>
<td>Common data class</td>
</tr>
<tr>
<td>CET</td>
<td>Communication Engineering Tool</td>
</tr>
<tr>
<td>CID</td>
<td>Configured IED description</td>
</tr>
<tr>
<td>CPI</td>
<td>Communication Protocol Interface</td>
</tr>
<tr>
<td>DA</td>
<td>Data Access</td>
</tr>
<tr>
<td>DCOM</td>
<td>Distributed Common Object Model</td>
</tr>
<tr>
<td>DOI</td>
<td>Data object instance</td>
</tr>
<tr>
<td>FCD</td>
<td>Function capability description</td>
</tr>
<tr>
<td>HMI</td>
<td>Human-machine interface</td>
</tr>
<tr>
<td>HSB</td>
<td>Hot Stand-by</td>
</tr>
<tr>
<td>ICD</td>
<td>IED capability description</td>
</tr>
<tr>
<td>IEC</td>
<td>International Electrotechnical Commission</td>
</tr>
<tr>
<td>IED</td>
<td>Intelligent electronic device</td>
</tr>
<tr>
<td>IET</td>
<td>Integrated Engineering Tool</td>
</tr>
<tr>
<td>IP</td>
<td>Internet protocol</td>
</tr>
<tr>
<td>LAN</td>
<td>Local area network</td>
</tr>
<tr>
<td>L/R</td>
<td>Local/Remote</td>
</tr>
<tr>
<td>MMS</td>
<td>Manufacturing message specification</td>
</tr>
<tr>
<td>NIC</td>
<td>Network Interface Card</td>
</tr>
<tr>
<td>OPC</td>
<td>Open Platform Communication formerly known as OLE (Object linking and embedding) for process control</td>
</tr>
<tr>
<td>PRP</td>
<td>Parallel Redundancy Protocol</td>
</tr>
<tr>
<td>RCB</td>
<td>Report Control Block</td>
</tr>
<tr>
<td>RSTP</td>
<td>Rapid Spanning Tree Protocol</td>
</tr>
<tr>
<td>SCD</td>
<td>System configuration description</td>
</tr>
<tr>
<td>SCIL</td>
<td>Supervisory Control Implementation Language</td>
</tr>
<tr>
<td>SCL</td>
<td>System Configuration description Language (defined by IEC 61850)</td>
</tr>
<tr>
<td>SNMP</td>
<td>Simple Network Management Protocol</td>
</tr>
<tr>
<td>SNTP</td>
<td>Simple Network Time Protocol</td>
</tr>
<tr>
<td>SSS</td>
<td>System Supervision Server</td>
</tr>
<tr>
<td>Protocol</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>------------------------------------</td>
</tr>
<tr>
<td>TCP/IP</td>
<td>Transmission Control Protocol/Internet Protocol</td>
</tr>
</tbody>
</table>
Appendix A  IEC 61850 System Supervision Server

IEC 61850 SSS is a stand-alone executable OPC Client IEC 61850 server (OPCC_IEC61850.EXE) with a built-in OPC server for DCOM start-up and diagnostics.

IEC 61850 SSS enables mapping of SYS600 OPC Server items to IEC 61850 process objects and is configurable with SCL. To be able to generate events through IEC 61850, the SSS must receive the data changes from the OPC server with OPC item updates, as IEC 61850 does no explicit reading. IEC 61850 SSS requires an IEC 61850 license for SYS600. 

Figure A.1: OPC Server-related components

A.1  IEC 61850 SSS features

IEC 61850 SSS maps the following OPC items to IEC 61850 7-3 CDC attributes:

- Event update (UPDATE)
  - Creates an OPC group for mapped items with a group update rate of 0 ms.
  - Sends events received as OPC item updates to IEC 61850 clients with reporting service.
  - Value overrides (GOOD and BAD). The value GOOD overrides all updated values, whereas BAD is used in case of errors (disconnect).
- Event update timer (TIMER)
- Expects an update of a specified OPC item from OPC Server within timeout milliseconds.
- Creates an OPC group for mapped items with a group update rate of timeout milliseconds.
- Sends events received as OPC item updates to IEC 61850 clients with reporting service.
- If the OPC item update interval exceeds the timeout, the quality (the value of the q-attribute) of the CDC is set to BAD.
- Value overrides (GOOD and BAD). The value GOOD overrides all updated values, whereas BAD is used in case of errors (disconnect and timeout).
- On OPC Server disconnect, all the mapped CDC qualities are set to BAD.

The following values remain constant:
- Configured values for CDC attributes.

A.2 IEC 61850 SSS start-up

When IEC 61850 SSS starts up, it automatically performs the following tasks:

1. Reads the configuration (SCL, SYSTEMC.XML).
2. Builds an IEC 61850 namespace according to SCL.
3. Connects to SYS600 OPC Server (configured in SCL Communication ProgID).
4. Connects to OPC Items on SYS600 OPC Server (configured in SCL CDC sAddr).
5. Starts the IEC 61850 server for IEC 61850 clients.

A.3 Configuring IEC 61850 System Supervision Server

A.3.1 Installing IEC 61850 System Supervision Server

The SSS is configured and registered with CET for IEC 61850 OPC Server. To install IEC 61850 SSS, a System Supervision Server object needs to be added to the used IEC 61850 CET project for SYS600.

A.3.2 Starting IEC 61850 System Supervision Server

Configure OPC DA Client for IEC 61850 SSS OPC Server using OPC DA Client Configuration Tool, see Figure A.2 (for configuring OPC Data Access Client, also see Section 5.8.3 Configuring External OPC DA Client). SSS is registered with Prog ID: ABB.IEC61850_SLAVE_OPC_DA_Server.Instance[1].1.
Continue by configuring the OPC DA Client instance to start automatically when the SYS600 system is starting up. The same configuration principles can be followed as in Section 5.8.4.2 Starting External OPC DA Client instance.

A.3.3 Stopping IEC 61850 System Supervision Server

Stop IEC 61850 SSS by shutting down the SYS600 OPC DA Client instance configured for SSS. IEC 61850 SSS shuts down (provided that it was started through DCOM) when all OPC clients have been disconnected. The same configuration principles can be followed as in Section 5.8.4.3 Stopping an External OPC DA Client instance.

A.3.4 Configuring IEC 61850 System Supervision Server

There are two types of configurable mapped basic object types available: Timer and Update.

A.3.4.1 Timer

If configured as Timer, the values are received from the OPC Server, and the quality and timestamp are set according to the quality and timestamp of the received OPC item. If the timer expires or the OPC Server disconnects, the CDC value is set to 0 and the quality to BAD. The values can be overridden by good (Good Value) or bad (Bad Values) values. Good values are always used when updates are received from the OPC Server. Bad values are used if the timer expires or the OPC Server disconnects.

A Timer object creates an OPC group for mapped items with group update rate = Update Rate. It expects an update of the specified item within Time Out msec. If an update is
not received, the quality is set to BAD (and the value is updated with Bad Value, if configured). If an update is received, the value is updated (overridden by Good Value if configured).

A.3.4.2 Update

If configured as Update, the values are received from the OPC Server, and the quality and timestamp are set according to the quality and timestamp of the received OPC item. The indication value can be overridden by configuring a Good Value. This value is used for all updated values, that is, every updated value from OPC Server is overridden. If the OPC Server is disconnected, the CDC quality is set to BAD (if Bad Value is configured, the value is overridden).

The following example shows how to configure status information of the local DuoDriver to be reported by the IEC 61850 System Supervision Server. By default the SSS is configured to connect to the MicroSCADA OPC Server (ABB.MicroSCADA.OPC.Server.DA).

1. Start CET for IEC 61850 OPC Server and open the project created for SYS600.
2. Right-click the computer node and select New > SSS > SSS Server to add a System Supervision Server. Only one SSS Server is supported.
3. Right-click the SSS Server and select New > SSS > SSS Subnetwork to add a System Supervision Server Subnetwork. Only one SSS Subnetwork is supported.
4. Right-click the SSS Subnetwork and select New > SSS > SSS IED Template to add a System Supervision Server IED. Rename the SSS IED with a max 8 letter length name (e.g. Micro) without white space. Only one SSS IED is supported.

5. Right-click the SSS IED.SCADA.LLN0 and select New > Data objects > RSS to add a redundancy supervision status object. Rename as SrcSt. Select SrcSt Basic.
type Update and configure DuoDriver diagnostic item paths to OPC Item ID paths for stValA and stValB.

6. To enable spontaneous updates for the status items, the added data object needs to be included in the dataset. Open the dataset editor for dsSCADA by right-clicking the dataset and selecting **Dataset Editor**. Drag-and-drop the SrcSt to the Dataset Editor pane to include it in the dataset. Click **Apply**. The dataset cannot be empty when starting SSS.

7. Use the Management tool from the Computer Node to register and configure the SSS.
A.4 Testing IEC 61850 System Supervision Server

SSS diagnostics can be viewed with CET Online Diagnostics. Device Connection Status indicates the state of the connection to the OPC server (e.g. MicroSCADA OPC Server). This diagnostic is available for any OPC client, as an OPC item Attributes\Device connection status in the SSS OPC Server indicates the state of the connection to the OPC server (e.g. MicroSCADA OPC Server). The Reset function can be used to shutdown SSS.

- IEC 61850 System Supervision Server generates either the log file EventLog.txt, in case of OPC DA Client-related errors, or the log file mms.log, in case of SCL configuration or IEC 61850-related errors.
- In case of major errors, IEC 61850 System Supervision Server generates printouts to command prompt.

A.5 IEC 61850 System Supervision Server ACSI Conformance

The compliance with IEC 61850 in terms of service, modeling and engineering interfaces is defined as follows (those listed are supported):

- ACSI basic conformance statement
- Client-Server roles
  - Server side (of TWO-PARTY-APPLICATION-ASSOCIATION)
- SCSMs supported
  - SCSM: IEC 61850-8-1 used
- ACSI models conformance statement
- Server
  - Logical device
  - Logical node
  - Data
  - Data set
- Reporting
  - Buffered report control
  - Unbuffered report control
- ACSI service conformance statement
- Server
  - ServerDirectory
- Application Association
  - Associate
  - Abort
  - Release
- Logical device
  - LogicalDeviceDirectory
- Logical node
- LogicalNodeDirectory
- GetAllDataValues

• Data
- GetDataValues
- GetDataDirectory
- GetDataDefinition

• Data set
- GetDataSetValues
- GetDataSetDirectory

• Reporting
  - BRCB
    - Report
    - GetBRCBValues
    - SetBRCBValues
  - URCB
    - Report
    - GetURCBValues
    - SetURCBValues
Contact us

ABB Oy
Grid Automation Products
P.O. Box 614
FI-65101 Vaasa
Finland
Tel. +358 10 22 11
Fax. +358 10 224 1094

www.abb.com/substationautomation