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Application Note  
 

AC500 PLC and ABB ACS355 Drive via Modbus RTU with ABB 
Standard Library  
 
 

 Description 
This application note will take you through the hardware installation and configuration of ABB ACS355 
Drives and eCo PLC with Modbus RTU communication. The AC500 ABB‐specific ready‐made function 
blocks and visualizations from the PS553‐ DRIVES library will be used for the control of the drives.  

 Objectives: 
The personal computer will connect to PLC via Ethernet port and eCo PLC control drive via Modbus RTU 
connection.  Here is the equipment list for this application note 
 

Description Quantity 
PC with Automation Builder V1.x  software installed 1 
ABB eCo CPU PM556 ETH CPU 1 
CAT5 Ethernet Patch cable 1 
ACS355 Drive with FMBA-01 adapter card 1 
Twisted pair shielded cable for RS-485 connection 1 

 

 Connection diagram 
 
 

                                                                 
                                                                                                                                                   
 
                                                                                                                               
 
   
 
 
 
 
 
 
 
 
 
 

AC500 eCo ETH CPU 
 PC with Automation Builder 

 
 

ACS355 Drive 
 

Modbus RTU connection 
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 Wiring diagram: 
 

           ACS355 drive’s FMBA-01 adapter card 
 

 
 
 

AC500 eCo CPU’s COM2 Modbus RTU wiring diagram:  
 

 
 
 

4.1  Connect ACS355 drive’s pin 2 to PLC’s pin 2  
4.2  Connect ACS355 drive’s pin3 to PLC’s pin 3 
4.3  Connect ACS355 drive’s pin4 to PLC’s pin 7  
4.4  Connect the shield to drive’s pin 5 
4.5  Jumper PLC’s pin1 to pin 2 
4.6  Jumper PLC’s pin3 to pin 4  
4.7  Verify the wiring and terminators are active 

a. Jumpers on the FMBA-01 
4.8  Wire terminals 1&2 and 3&4 (optional) Using just the CPU, apply power to the  

PLC 
4.9  Launch Automation Builder and create a new project 
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 Create new PLC project in Automation Builder software tool: 
 

5.1 Double click on ABB Automation Builder software tool  icon on the desktop. 

(If Automation Builder icon is not available on your desktop, click Start, go to All 
Programs, select ABB folder and click on Automation Builder software tool.)  

 
5.2 The Automation Builder Screen will appear as shown below, if Internet access is 

available Automation Builder will show the default ABB homepage for PLC products  
 

5.3 Create a new project by clicking the New button or selecting the File > New Project  
 

5.4 Enter project name as shown in example below:  AC500 and ACS355 with Modbus RTU 
project 

 
5.5 Select the location to store the project in PC 

 
5.6 Select OK to start the project 

 

 Specifying the hardware configuration:   

 
To specify the hardware configuration, the I/Os and their symbolic names have to be defined. 
Configure your I/O by double clicking I/O (Onboard I/Os) and refer to the mapping tab 
window opened on the right side where you can give variable names to each I/O points. 
 
6.1 Double click AC500 (PM564-ETH) on the left to open this hardware menu 

 
6.2 Change the value of Check battery from ON to OFF ( if no battery present for this 

example)  

 
 

 Setup the Ethernet communication in Windows: 
Before you are able to download the compiled program the first time from the PC to the 
PLC, you have to setup the communication parameter. There are two options you can 
use to login to the PLC, either with Ethernet or serial with TK503 USB cable. 

 
For this exercise, we are using Ethernet connection for online access to this PLC. 
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Make sure that your PC address is in the same class as the CPU’s IP address. The 
factory setting of the CPU for IP address is 192.168.0.10. Then the IP of the PC should 
be 192.168.0.x, x should be different number than 10 so that it will not have an IP conflict 
with the CPU. Subnet mask should be 255.255.255.0. 
 
To change the IP address in your PC: 

 
7.1 Windows Control Panel > Network and Internet > Network and Sharing Center 
7.2 Click on Change adapter settings 
7.3 Select Local Area Connection (in this example is  PLC network connection below) 

and right click it to open the menu. 
 

        
 
Choose Properties ( the status is active when the Ethernet connection between PC and  
PLC is active) 
 
7.4  Select Internet Protocol Version 4 (TCP/IPv4) and double click to see properties. 
7.5  Type in your desired IP address and subnet mask then click OK. 

 

 
 

 Setup the IP address in Automation Builder software: 
8.1 Make sure the CPU’s RUN switch is STOP position 
8.2 Click IP-Configuration to access Scan tool 
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8.3 Click on Scan button for searching active PLC on the network 
8.4 Highlight the active IP address in the search window 
8.5 Change the IP address to new IP address such as 192.168.3.20 
8.6 Click on Send Configuration button to send new IP address to PLC.  

         
• The warning message window display is shown below for this change.   
• This screen shows the progress of IP address settings is sending to CPU. Wait about 

30 seconds for CPU to register new IP address (the RUN and ERR lights are flashing 
during this process). 

•  Click OK to accept this new IP address for this CPU. 

 
• Press “Scan” button again to verify the IP address of CPU. This window shows the 

Configured IP address sent to CPU successfully.  This IP address will be used in IEC 
61131-3 CoDeSys to download your PLC project to CPU. 
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       Modbus RTU setup in Automation Builder software 
9.1    Right click on COM2_None> Add Object 
9.2    Select COM2-Modbus then click Replace object to accept the changes. 
 

                   
 

9.3        Set the configuration as shown below 
 

            
 

9.4            Click File > Save Project to save the configuration settings for this lab. 
9.5            Right click on AC500.  
9.6            Click Create Configuration data to save the settings before go to CoDeSys window. 
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     IEC61131-3 Application (CoDeSys): 
 

10.1 Double‐click “Application” from the Device tree in the Automation Builder project to open 
CODESYS. 

 

                                              

10.2 Create the variables in Global variables tab 
• Double‐click “Global Variables” in the “Resources” tab (1) 

a. Create a global variable for the Modbus token handling of type 
“ACS_MOD_TOKEN_TYPE” (2).  This variable will be used for passing a token 
to all drives on the Modbus RTU line 

 

                
 

      Create PLC logic 
11.1   Compile your project, choose “Rebuild all” from the “Project” menu 

      
 
 
 
 
 
 
 
 
 

11.2 Right‐click “PLC_PRG” in the “POUs” tab and choose “Convert Object” 
11.3   Choose Target Language “FBD” and click “OK” 

 

                   
 

11.4 Right‐click in the POUs field and choose “Add Object” 
11.5 Set Type of POU to “Program” and Language of the POU to “FBD” 
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11.6 Give the new Program a suitable name 
11.7   Click “OK” 

 
 

                    
 

11.8 Double‐click “PLC_PRG” (1) to open the main program 
11.9 Select the dotted box (2) in Network 0001 and insert a box( 3) 
11.10 Naming of your new Program : Drive1 (PRG) in to call for it from the main program 

 

                    
 

    Create ACS_COM_MOD_RTU Function Block  
 

12.1 Double‐click your new program and add a box as described previously 
12.2 Press F2 while the block title is selected and choose “ACS_COM_MOD_RTU” from      

            “Standard Function Blocks” 
12.3 Click “OK”  
 
(Tip: uncheck the “Structured” box in the Input assistant). 
 

 

            
 
 

 
 
 
 



LVD-EOTN123U-EN REVA Page 9 of 15  
 

12.4 Give the instance of the drive access block a suitable name (1) 
12.5 Declare the variable of type “ACS_COM_MOD_RTU” (2)  

 

                       
 

     ACS_COM_MOD_RTU Function Block’s parameter setup 
 

13.1   Set EN to TRUE 
13.2 Set the com port to 1 
13.3   Set the slave ID to 1 
13.4 Set the drive type to 4 (ACS355) 
13.5 Set “ACS_COM_MOD_RTU” block input “NVAR_READ” according to number of 

parameters   
                    to be read 

13.6 Connect the global token (created earlier) to LINE_TOKEN 
13.7   Connect the variable DrivePointer to DRIVE_DATA 

 
 

a. Define  DrivePointer: ACS_DRIVE_DATA_TYPE 
 

                                        
 

Create ACS_DRIVES_CTRL_STANDARD Function Block 
 

• Create a second network (Ctrl +T) in the same program and add the block 
“ACS_DRIVES_CTRL_STANDARD” in the same way as for “ACS_COM_MOD_RTU” 

• Setup the block as shown below. 
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    ACS_DRIVES_CTRL_STANDARD Parameter setup 
 

• Connect the variable DrivePointer to DRIVE_DATA   
• Select DrivePointer: ACS_DRIVE_DATA_TYPE 

 
Note! The variable connected to “ACS_DRIVES_CTRL_STANDARD” → “DRIVE_DATA” must be 
the same as the one connected to “ACS_COM_MOD_RTU” → “DRIVE_DATA” and must be of 
type “ACS_DRIVE_DATA_TYPE” 
 

                                  
 
 

Here is the complete PLC codes for this project: 
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    Create the ACS_COM_MOD_RTU Visualization screen: 
15.1 Right‐click “Visualizations”    in the “Visualizations” tab (1) 
15.2 Choose “Add Object”, give the visualization page a suitable name 

a. E.g. Visu_Drive1 
15.3 From the new page, choose “Visualization” from the “Insert” menu and draw a box 
15.4 Select Visualization “ACS_COM_MOD_RTU_VISU_PH” 

 

              
 

15.5 Double‐click the new visualization object for Settings and click “Placeholder” 
15.6 Select the “Replacement” field and press F2 

 

                         
 
 
 
 
 

15.7    Select the function block as shown below 
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     The ACS_DRIVES_CTRL_STANDARD Visualization 
16.1 On the same page, create a visualization window for the drive control 
16.2 Repeat the previous steps to insert a visualization object 
16.3 Select Visualization “ACS_DRIVES_CTRL_STANDARD_VISU_PH” 

 

                  
 

16.4 Double‐click the new visualization object for Settings and click “Placeholder”. 
16.5 Select the “Replacement” field and press F2. 

 

                                      
  

16.6 Select the function block as shown below 
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16.7 The screen should look as shown below 
 

 
 

 Download program to PLC 
 

17.1   Save the program and choose “Communication Parameters” from the “Online” 
menu.  

17.2 Set communication Parameters according to your online connection 
17.3   The CPU’s IP address will be assigned per user’s choice. 
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17.4 Choose “Login” from the “Online” menu and in the following pop‐up window, click “Yes” 
17.5   Choose “Run” from the “Online” menu to start the PLC 
17.6 Check that the PLC goes to “RUN” mode 

 
Note!   If the PLC does not go to “RUN” mode, you might have some PLC errors that you need to reset. 
You can do that either by pressing the “DIAG” button on the PLC itself (not in the eCo series) followed 
by the “OK” button until all errors are reset. You can also do it in online mode by using the “diagreset” 
command from the “PLC Browser” in the CODESYS “Resources” tab. 

    Create boot project 
 

In  “online”  mode  (Login),  choose  “Create  boot  project”  from  the  “Online”  menu.  With this 
command, the compiled project is stored to the flash in such a way that the PLC will load it 
automatically when restarted 
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    Run The Program 
19.1 Go online 
19.2 verify the PLC is in run mode 
19.3 reset the Drive if needed 

a. Click on the start button  on  ACS_DRIVES_CTRL_STANDARD  block 
b. Enter a SPEED_REF  on ACS_DRIVES_CTRL_STANDARD block 
c. The speed ref is in counts (+/- 20,000) 
d. Refer to drive parameters 11.05 for scaling 

19.4 Verify the motor running status. 

    ACS355 drive’s parameters setup: 
20.1 Power up the drive 
20.2 Enter/verify the parameters as shown below 
20.3 Drive power down and power up for the new fieldbus settings to take effect! 

  
Parameter Description Value 

 
Comment 

98.02 COMM PROT SEL STD MODBUS Activates fieldbus module 

53.02 EFB STATION ID 1 Modbus RTU node address of the drive 

53.03 EFB BAUD RATE 19.2 kbit/s Transfer rate of the link. Same baud rate 
must 

       53.04 EFB PARITY 8 NONE 1 Parity and stop bits. Same parity and stop 
bits 

       
 

53.05 PROFILE ABB DRV FULL Communication profile “ABB Drives” 

53.10 EFB PAR 10 101 Actual speed feedback 
53.11 EFB PAR 11 303 Status Word 

10.01 EXT 1 COMMANDS COMM Fieldbus interface as source for start and 
 11.02 EXT1/EXT2 SEL COMM Fieldbus interface as source to switch to 
 11.03 REF1 SELECT COMM Fieldbus interface as source for speed 

reference 
11.05 REF1 MAX 1500rpm Max speed/frequency scaling value (used in 

function block/visualization input 
“SPEED_REF_MAX”). Must be less or equal 
to drive parameter max speed/frequency. 

16.04 FAULT RESET SEL COMM Fieldbus interface as source for fault reset 
53.12 Bus Voltage (107) 107 Actual value 

53.13 Temp Deg C (110) 110 Actual value 

53.14 AI-1 % (120) 120 Actual value 

53.15 Frequency (103) 103 Actual value 

53.16 Current (104) 104 Actual value 

53.17 Torque (105) 105 Actual value 

 
NOTE:  These parameter must be filled in or communications will not work correctly! 
 

20.4 Cycle the drive power 
20.5 Test the PLC codes with these parameters. 
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