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1. Introduction

Using this manual

You should read this manual when you start working with the Protocol Editing Tool 
(in this manual called POD tool) for the first time. The manual describes the 
functionality of the POD tool, which is one of the engineering tools that are available 
in CAP 505.

1.1. General

The Protocol Editing Tool is used for creating and editing Protocol Object 
Dictionary tables and sending and receiving them to/from a device which is 
connected to the base system computer. Protocol configurations can be created 
either from the beginning or by using an existing template. A set of standard 
templates for several protocols is distributed within the POD tool. 

The Protocol Object Dictionary is a cross-reference table between the relay 
application and the protocol. This table defines what information can be accessed 
from the device, using the protocol interface. Since a device is programmable and 
may run various application setups (different sets of function blocks), the protocol 
object dictionary is also fully re-configurable.

1.2. Communication protocols

Used communication protocols for sending and receiving the POD tables are either 
SPA or LON. This is defined in the General Object Attributes dialog in CAP 505. 
This means that you do not define which protocol should be used with the Protocol 
Editing tool.

1.3. User modes

There are two different POD tool user modes:

• Advanced mode, for product development

• Basic mode, for field configuration

In advanced mode it is possible to create new protocol images and modify the
structure of an existing configuration. In this mode the full range of POD tool 
functionality is available. In basic mode it is possible to edit POD table data, up
and download data from and to the device. This manual describes the function
of the POD tool when it is used in basic mode (field configuration).
B Automation 1
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1MRS751982-MUM Protocol Editing Tool
2. Using the Protocol Editing Tool

2.1. General

This chapter describes the different menus and functions in the Protocol Editing 
Tool and how to use these. 

2.2. Protocol configurations

There are three kinds of protocol configurations. These configurations are stored in 
three different places:

• “Work configuration”, which is stored in the \POD directory under the object 
home directory, e.g. in ..\OBJ0001\POD.

• “User templates”, which are stored in the \POD directory under the project 
directory OBJ000\Misc\. This is a common place where the users should sa
custom configurations.

• “Standard templates”, which are included in the object type configurations an
they are distributed with the SM/RED package. Users cannot save the custo
POD configuration to these locations.

2.3. Starting the Protocol Editing Tool 

The Protocol Editing Tool is started from the Project Navigator in CAP 505 (se
Figure 2.3.-1).

)LJ�������� 6WDUWLQJ�WKH�3URWRFRO�(GLWLQJ�7RRO�

If a work configuration is found in the project folder, this is opened automaticall
start-up.
B Automation 3
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When the POD tool is started a dialog pops up on the screen and the user is asked if 
there is a connection to the device or not. See Figure 2.3.-2. 

)LJ�������� 7KH�&RQQHFW����GLDORJ�SRSV�XS�ZKHQ�WKH�3URWRFRO�(GLWLQJ�7RRO�LV�
VWDUWHG

If you have a connection to the device and you click Yes, the tool will check if the 
configuration is consistent and the statusbar in the main dialog will be updated. 
(Consistency will be explained in Chapter 3.6.2.) 

If you do not have a connection to the device click No. If you click yes, without 
having a connection to any device, the following error dialog will pop up:

)LJ�������� 7KH�FKHFNVXP�HUURU�GLDORJ

2.3.1. Menus and toolbar

The toolbar and the menus are the same in both user modes (basic and advanced). 
Some menu options and toolbar buttons are disabled in basic mode because of the 
mode restrictions.

There are six user interface menus in the Protocol Editing Tool main view. The 
menus will all be presented in the following sections.
4 ABB Automation
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2.3.2. File menu

The following figure shows the POD tool file menu. The different menu functions 
are explained below.

)LJ���������� 7KH�ILOH�PHQX�LQ�WKH�32'�WRRO

! In basic mode it is not possible to create a new protocol image. This option is only 
allowed on the advanced level.

Open

By selecting this menu item you can open an already existing protocol 
configuration/template. You can either open one of the templates, or you can browse 
for another image on your system. The following toolbar button can be clicked 
instead of choosing “Open” from the File menu.

.H\ERDUG�HQWU\���&WUO!��2!

2.3.2.1. Save to project

This option saves the current configuration to the actual project in the object h
directory (..\OBJ\xxxx\POD) as a “work configuration”. This is a default directo
and you should not change any of the files in this directory with any external too
should be considered to be a protected directory.

.H\ERDUG�(QWU\���&WUO!��6!

You can also use the following toolbar button to save your configuration:

2.3.2.2. Save as

This option allows you to save the active file and to enter a new name for the 
This way you can easily save a copy of an already existing file. 
B Automation 5
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2.3.2.3. Export

This option allows you to export a complete protocol table or only the selected cells 
in it. It is saved as a text file. After exporting a table you can open its text file and 
edit it with an external tool, e.g. Microsoft Excel. The columns are separated with 
tabulator signs. You can also use the toolbar button which is shown below, to export 
table or just cells in it.

! You cannot import a protocol table after exporting and editing it in an external 
application. Importing is only allowed for the advanced user.

2.3.2.4. Page setup

This option changes the margins of a page (See Figure 2.3.2.4.-1). 

)LJ������������ 7KH�3DJH�6HWXS�GLDORJ

2.3.2.5. Print

You can use the following toolbar button to access the print dialog or choose the 
print command from the File menu:

More information about the print command can be found in Chapter .

2.3.2.6. Exit

This function exits the program. The program asks you whether you want to the save 
unsaved changes or not before exiting. Pressing the following toolbar button exits 
the tool.
6 ABB Automation
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2.3.3. Edit menu

The following figure shows the components of the Edit menu of the POD tool. The 
greyed functions are disabled when working in basic mode.

 

)LJ���������� 7KH�HGLW�PHQX

2.3.3.1. Active function blocks

Each signal belongs to a function block. The function blocks can be active or 
inactive (cell texts of InActive function blocks are in italic�. In the “Active 
Function Blocks” dialog, you choose which function blocks should be active an
inactive. The viewing options for visible functions block are found in the “Edit” 
menu.

You find more information about the active function blocks in Chapter 3.5.

2.3.3.2. Fast editing mode

If Fast Editing Mode is chosen, you can change the cell values of the chosen ce
one column at the same time. More information about the fast edit mode is fou
Chapter 3.3.3.

2.3.3.3. Select functions

The last four menu functions in the Edit menu are select functions. This means
rows are selected according to one of the below mentioned alternatives. The 
different alternatives are:

• Select rows of Active Function Blocks.

• Select rows of InActive Function Blocks.

• Select In Use rows, based on the “In Use” column data.

• Select NOT In Use rows, based on the “In Use” column data.

2.3.4. View menu

The view menu contains two toggle menu item groups 
B Automation 7
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With the functions in this menu you define which signals you want to view in the 
POD table. This method of showing the signals can be called virtual filtering. This 
means that the signals are only filtered out from the user view, not from the 
configuration. The view menu contains two toggle menu groups with the following 
options.

In the first group you have the following functions:

• Show In Use signals (Only “In Use” signals will be shown).

• Show NOT In Use signals (Only “Not In Use” signals will be shown).

• Show both (Both “In Use” and “Not In Use” signals are shown).

In the other group you have the following functions:

• Show signals of Active Function Blocks (Only signals that belongs to the act
function blocks list will be shown.)

• Show signals of InActive Function Blocks (Only signals that do not belong to 
active function blocks list will be shown.)

• Show both (Signals of both InActive and Active Function Blocks will be show

“Show both” is the default menu item for group one and “Show signals of Activ
Function Blocks” is the default for group two.

2.3.5. Transfers menu

The Transfers menu contains four different functions shown in the figure below 
Figure 2.3.5.-1). 

)LJ���������� 7KH�7UDQVIHUV�PHQX

2.3.5.1. Upload

The upload function transfers all the table cells to the computer.
8 ABB Automation
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You can also choose the upload button from the toolbar (see the figure below).

2.3.5.2. Download

Downloading means that you transfer a protocol table from the computer to the 
relay. 

Instead of using the Transfers menu you can choose downloading by clicking the 
Download toolbar button shown below. 

More information on uploading and downloading can be found in Chapter 3.6.2.

2.3.5.3. Automode

You activate or deactivate automode by choosing the function from the Transfers 
menu. More information on the automode command can be found in Chapter 3.6.3.

2.3.5.4. Store and HW reset

This function sends a command to the device and the protocol tables are stored in 
the device memory. Please see Chapter 3.6.4 for more information on this 
command.

2.3.6. Tools Menu

There is one function in the Tools menu (See Figure 2.3.6.-1.).

)LJ���������� 7KH�7RROV�PHQX

With the Customize function you can customize the tables and choose which 
columns to be shown in the main dialog. In the Customize window you can also 
choose how many rows should be visible. For more information see Chapter 3.1.1.1.

2.3.7. Help menu

)LJ���������� 7KH�+HOS�PHQX

There is only one item in the Help menu. When choosing this function the following 
dialog box will open:
B Automation 9
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The dialog box About POD Tool contains information on current version of the POD 
tool.

The two arrow buttons in the upper right corner are scroll buttons.

Scroll one page down.

Scroll one page up.
10 ABB Automation
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3. Protocol Editing Tool functionality

This chapter explains how to use the Protocol Editing tool (POD tool).

3.1. Main dialog

A typical view of the POD tool main dialog is shown in the following figure (see 
Fig. 3.1.-1).

)LJ�������� 7KH�32'�WRRO�PDLQ�GLDORJ�DW�WKH�EDVLF�OHYHO

Only the white columns are editable. The grey columns are non-editable.

All the tables from the protocol configuration are shown in the notebook. You can 
have more than one notebook page. How many you have is defined in the protocol 
image by the advanced users. 

Each table has two column groups: general columns and protocol specific attributes. 
The first group contains fictive data which is not present in the POD table inside the 
relay. This data is used only for description of the signals and arranging them in a 
user-friendly way. The second group represents real data which can be uploaded and 
downloaded from and to the relay.

The general group always includes three columns. The general group columns are:

• Signal name

• Signal state

• Identification

The identification column is meant for the user. In this column, the user can w
own signal names as identification for the different signals in the protocol table
B Automation 11
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The statusbar contains five fields:

1. Current path selected in the navigator tree

2. Status field of the consistency between the opened protocol table structures and 
the tables stored in the relay

3. Text indicating whether “autoload” mode is active or not
4. Object type of the object for which the POD tool is started
5. Protocol identification of the opened configuration.

3.1.1. Sorting

In basic mode the sorting is virtual. This means that the sorting function does 
sort the real protocol table. It is only viewed in a certain way. 

The current table can be sorted by different criterion:

• No sorting. The tree is empty.

• By function block. The function blocks are grouped and sorted in an alphabe
order. 

• In alphabetical order. The signal names in the “Identification” field are used a
sorting criteria (these names are defined by the user).

• By address. One of the Protocol attributes columns can be assumed as a “ad
column and used as a sorting criteria.

• By data type. One of the protocol attributes columns can be assumed as a “
type” column and used as a sorting criteria.

! The available sorting criteria is defined in the protocol image, which can only b
edited by the advanced user. 

The main dialog toolbar contains a panel with five buttons for the sorting functi

%XWWRQV )XQFWLRQDOLW\

No sorting. 

Sorting by function block.

Sorting in alphabetical order according to the signal identification.

Sorting by address number in numerical order.

Sorting by data type
12 ABB Automation
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3.1.1.1. Using the navigator tree

The navigator tree is built according to the sorting mode that is in use. 

No sorting

If the current sorting mode is “no sorting” the tree will be empty.

Other sorting modes

The main purpose of the navigator tree is to find a specific cell in a fast and ea
way. When an object is selected in the tree, the table is scrolled to the position
which the first row corresponding to the object will be selected.

The navigator tree has a root node and underlying objects, which correspond 
cell texts of a specific column. The table is sorted according to the cell texts in
specific column. This means that these cell texts are used as a sorting criteria

The following warning dialog will pop up if you edit one of the cell values in the
column which the sorting is based on. To update the sorted list, you must chan
another sorting mode and then change back to the original one.

)LJ������������ 7KH�LQYDOLG�VRUWLQJ�ZDUQLQJ�GLDORJ
B Automation 13
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3.1.2. Customizing tables view

The user can choose which columns should be visible in each table. This is defined 
in the “Customize” dialog which is opened from the Tools menu. See Fig. 3.1.2
In this dialog you can also define whether the navigator tree should be hidden
shown (the navigator tree can be found on the left side of the main dialog). 

)LJ���������� 7KH�&XVWRPL]H�GLDORJ

The check boxes on the notebook pages correspond to general or protocol sp
columns of the tables. The table titles are shown at the top of the pages. Pleas
that there might be columns that are not shown when the tool is in basic mode

By selecting or deselecting the “Show Tree Map” checkbox, the user chooses
whether the navigator tree should be shown or hidden. 

The user can also freeze general columns. If a general column is frozen, it is 
“locked” in one position and not scrolled horizontally when you scroll the horizon
scroll bar. 

The number of visible rows defines how many rows can be shown in the main
dialog. It defines how many rows are shown at a time without changing to ano
page. The smaller the number, the less rows are shown. If the number of rows
table is higher than the number of visible rows in the “Visible rows” field, you c
use the arrows in the top right corner of the main view to jump a section up or d

3.2. Opening a protocol template

When the POD tool is started, and a possible work configuration of the object 
been loaded and edited, it is possible to open another protocol configuration u
14 ABB Automation
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the menu File -> Open.. command, or the “Open” toolbar button. When you cho
“Open” the following dialog appears on the screen:

)LJ�������� 7KH�2SHQ�GLDORJ

Table 3.2.-1 Explanation of the table columns in the open dialog

The user can select a configuration from the object configuration (“work 
configuration”) directory, from the standard or user templates directory or from
custom directory.

If the user selects the “Look in:” option and types a path in the path field, then
following button should be pressed in order to update the configurations list. 

The custom path can also be specified with the File chooser after pressing the
“Browse..” button. 

The “consistency checking” check box will be enabled if the selected device 
supports consistency checking. 

When the check box is selected, the POD tool tries to read checksums from the
of channels of the device, and then compares them with the checksums read fro
protocol configuration files. The configuration is considered consistent if its 

Table Columns Explanation

Name The name of the configuration/template.

Protocol The name of the protocol.

Based on This field defines what device the configuration/template is 
suited for.

Table Value(s) Edited The date when the table was last edited.

Table Structure(s) Modified This field contains the checksum. The checksum is based 
on the time and date when the configuration/template was 
last edited (See Chapter 3.6.2 for more information).
B Automation 15
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checksum is the same as the value read from the channel corresponding to the 
protocol number of the configuration. Consistent configurations are shown in the list 
with white background color. Configurations that are colored grey, are used for 
inconsistent configurations. 

Inconsistency means that General values and Protocol attribute values might not 
match. The general values are stored in a file and the protocol attribute values are 
uploaded or downloaded from/to the device. (If a row was missing in the General 
columns, and protocol attribute values would be uploaded to the computer, there 
would be inconsistency as the row values in the table would not match.)

!
It is strongly recommended that you use a consistent configuration. If you still want 
to open an inconsistent configuration, it is recommended that you first upload the 
whole POD table from the relay. 

You can download a table in a normal way. The first time you download a table you 
have to download all cells in the table (if a POD table is inconsistent you can only 
download and upload all the cells in the table). Please see Chapter 3.6.1 for more 
information. After uploading an inconsistent table, the signal names will be lost. 
Therefore all function blocks and their signals can be considered inactive (the cell 
texts are therefore italic). In this case the settings in the “Active Function Block
dialog have no meaning.

If the "Show signals of Active Function Blocks" function is chosen, the table fie
seem to be empty. Choose "Show signals of InActive Function Blocks" from th
"View" menu in order to view the table. FB sorting is not possible in an inconsis
table.

Editing a table is done according to standard procedures. Since the signal nam
missing, you might need to refer to a protocol manual for guidance. 

3.3. Editing tables

Some of the columns in the main dialog tables are not editable at the basic lev
These columns are the “Signal name” and “Signal state” general columns. Som
the protocol specific attributes can also be read-only at the basic level. (This is
specified by the advanced level users in the protocol image.)

The tables in the main dialog can be edited in three different ways:

• Direct text edited in a table cell after double-clicking the cell or by pressing 
“Enter” when the cell is active.

• In an external dialog, which appears when a cell has been double-clicked. T
the case of e.g. the protocol specific column which is handled as “In Use” col
and the column types that require external dialog for editing (“Option group”,
“Switch group” etc.)

• In an external dialog after a couple of cells have been selected in the “Fast e
mode.
16 ABB Automation
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Which one of the methods is used depends on the column type, column display mode 
and “Fast edit” mode status. When some cells of the protocol specific columns 
been modified, the cell texts are shown with blue color. 

3.3.1. Column types

The current version of the POD tool supports the following editing types of the
protocol specific columns:

• Numeric

• String

• Option group

• Combination option group

• Switch group

• Hexadecimal

These types are used only while editing table cells and when presenting data 
user-friendly form. Internal protocol data is always stored in text form, e.g. 
“F000V001”, “10.267”, “123” etc.

! Column types are defined in the protocol image and they cannot be changed 
basic level. 

3.3.2. Column display modes

There are three different display modes of the protocol specific columns:

• advanced

• hexadecimal

• raw

Do the following to switch between these different modes:

� Select an editable cell or column.

� Click the right mouse button and choose “Display format..”

)LJ���������� 6HOHFWLQJ�WKH�'LVSOD\�IRUPDW
B Automation 17
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� Choose, from the pop-up dialog, the column display mode that you want and 
click OK.

)LJ���������� 7KH�&ROXPQ�GLVSOD\�PRGH�GLDORJ

All cell values in the edited column will have the same display mode. The settings 
work for the column where at least one cell has been selected.

While showing the data, the cell text is converted to a decimal value and this value 
is converted to a string in hexadecimal format. In case of a conversion error, 
“#VALUE!#” is shown in the cell.

In the “raw” mode, direct cell editing is used for all column types. The cell text 
shown in the table as it is.

A column in a table can be described in the protocol configuration as “In Use” 
column. For such a column, neither the column type nor the display format have
meaning. The cell data can have one or two representations (“Yes” or “No”). Ed
is done in a pop-up dialog with combo pop-down control.

3.3.3. Fast edit mode

The “Fast edit” mode is enabled/disabled from the edit menu or by checking/
unchecking the box in the upper right corner of the main view. See Fig. 3.3.3.-

)LJ���������� 7KH�³)DVW�HGLW�PRGH´�FKHFNER[

When this mode is enabled, a pop-up dialog appears on the screen when you
one or several cells in a column (see Fig. 3.3.3.-2). All the cell data is edited in
step. This concerns all general and protocol specific columns. 

)LJ���������� 7KH�³7H[W�HGLW´�GLDORJ
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The same pop-up dialog opens when you edit a single cell without using the “F
edit” mode. 

The “Fast edit” mode is disabled if you choose cells from more than one colum
a time. The “Text edit” dialog will not appear on the screen. “Fast edit” mode wo
only for one column at a time. The reason why the mode is disabled when choo
more than one column, is that different columns can have different types, and ed
of the cell values is therefore not possible.

7KH�IROORZLQJ�H[DPSOH�VKRZV�KRZ�WR�VHW�LQDFWLYH�IXQFWLRQ�EORFNV�RII�

� Select “Show Signals of InActive Function Blocks” from the “View” menu.

� Set Fast edit mode on

� Click the “In Use” column header

� Edit all fields in one step in the specific column

3.4. Exporting tables

The user can export all rows or selected rows from the current table to a text f
This can be done using the Export command from the File menu or by using t
Export toolbar button. The following dialog appears on the screen when Expor
chosen:

)LJ�������� 7KH�³([SRUW���´�GLDORJ

After pressing OK, a file chooser dialog opens, and the user can set the path 
text file. The text file contains the cell data of the exported rows in raw text for
(without any conversion) according to the column type or display mode. 

You will see some empty columns in the exported file. This is due to the advan
level functional needs. Some columns are only visible on the advanced level. T
columns will always be printed, although they are not visible at the basic level.
B Automation 19



1MRS751982-MUMProtocol Editing Tool CAP 505
3. Protocol Editing Tool 

functionality
User’s Guide

e 
 the 
n 

the 

 

ted 
3.5. Changing active function blocks

When selecting the Active Function Blocks from the Edit menu, the following 
window opens. In this window the user can choose which function blocks are active 
and which are inactive (cell texts of inactive function blocks are LWDOLF).

)LJ�������� 7KH�$FWLYH�)XQFWLRQ�%ORFNV�GLDORJ

Active function blocks are selected manually from the list. 

If you click the “Automatic selection according to configuration” check box in th
lower left corner, the function blocks will be selected automatically according to
relay configuration. The relay configuration is done with the Relay Configuratio
tool found in CAP 505. The function block list will be updated at the start-up of 
“Active Functions Blocks” dialog. 

After you have made your selections and pressed OK, the main tables will be 
redrawn. You can save the “Active Function Blocks” settings with the protocol
configuration by using the “Save” or “Save as” commands.

3.6. Communications

The POD tool provides the following communication operations with a connec
device:

• Uploading and downloading the POD tables.

• Reading and writing a checksum which is used for consistency checking.

• Sending “store” and “hardware reset” commands.

• Reading diagnostics variables.
20 ABB Automation
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3.6.1. Uploading and downloading the table cells

You can find the Upload/Download functions from the “Transfers” menu or fro
the toolbar buttons. When you choose Upload the following dialog opens:

)LJ���������� 7KH�8SORDG�GLDORJ

Changed cells are marked with blue text in the table.

)LJ���������� 7KH�'RZQORDG�GLDORJ

The first two options will be enabled only if the opened configuration is consist
If the consistency is unknown, they are disabled. If the configuration is inconsis
they are also disabled and, in case of uploading, the following warning dialog 
appears before the communication dialog opens:
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)LJ���������� 7KH�ZDUQLQJ�GLDORJ�ZKLFK�DSSHDUV�ZKHQ�XSORDGLQJ�DQ�LQFRQVLVWHQW�
FRQILJXUDWLRQ

If the user confirms the operation, all general columns will be cleared after full 
uploading. Please see Chapter 3.2 for more information.

! It is strongly recommended that you use a consistent configuration.

If some of the cells were modified and shown with a blue text color, the cell text 
becomes black after up/downloading.

3.6.2. Consistency checking

An opened configuration is assumed as “consistent” in the following cases:

• The checksum has been read from the protocol channel of the device and it 
same as the sum read from the protocol files.

• All the cells of all the tables have been downloaded and the checksum has b
sent to the device.

• If the checksum could not be read from the device after full uploading of the 
tables from the device, the configuration is also consistent.

If the object does not support the checksum verification, the opened configura
will be consistent only after uploading or downloading of tables.

The checksum will be recalculated for the opened configuration if the table struc
is modified (row or column count, row order changed). Modifying a table struct
is only allowed to the advanced user. This means that the checksum will not b
recalculated at the basic level. 

Current consistency status is shown on the status bar of the main dialog.

Upload2.tif
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3.6.3. Autoload mode

The “Autoload” mode can be activated by using the “Automode” command from
Transfers menu. In this mode, selected cells of protocol specific columns are 
uploaded automatically to the computer. When you have edited specific cells an
cell data is modified, the changed cell texts will be downloaded to the device 
automatically.

This mode will be disabled if the opened configuration is inconsistent with the P
tables stored in the device.

3.6.4. Store and hardware reset

What command (“Store” and “HW Reset”) you will have in the Transfers menu
depends on what device you are using. If the device requires both “Store” and 
Reset” commands to activate the POD table in the device, both will appear in 
menu. If the device requires only “Store” command, this will be the command fo
in the Transfers menu.

When the “Store” command is executed, the following dialog appears on the sc

)LJ���������� 7KH�³6WRUH´�FRPPDQG�GLDORJ

If the “Stop” button is clicked, the program does not wait for the relay to comp
its operation.

3.6.5. Reading diagnostics information

The diagnostics information is updated in the device after the conversion of th
visible POD table to the operational table. The visible table is the table that is 
downloaded to the device. The conversion is done during the device start up or
sending the “HW Reset” command.

After downloading all the tables to the device, the POD tool asks the user whe
to read the diagnostics information or not. (This happens only if the diagnostic
function has been enabled.) If the user answers yes, the POD tool performs d
needed operations (e.g. store or reset commands) before the diagnostics inform
is read. Please read the user manual for information on your device.

! The reading of diagnostics is enabled or disabled in the protocol image. This c
only be edited when the tool is in advanced mode.
B Automation 23



1MRS751982-MUMProtocol Editing Tool CAP 505
3. Protocol Editing Tool 

functionality
User’s Guide

 “In 

n then, 
 POD 
When the variables have been read, the result of the operation will be shown in the 
following dialog:

)LJ���������� 7KH�GLDJQRVWLFV�UHVXOWV�GLDORJ

Just after this dialog is shown, the POD tool starts asynchronously to read the
Use” column cells from all the tables that have a “In Use” column. When the 
operation has succeeded, the “Show data..” buttons are enabled. The user ca
by pressing these buttons, see details of errors during the visible->operational
tables conversion in a dialog (see Fig. 3.6.5.-2). 

)LJ���������� 7KH�GLDJQRVWLFV�GHWDLOV�GLDORJ
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3.7. POD binary file

A binary file will be created automatically when the Protocol editing tool is closed. 
This binary file is created as it may be useful in other CAP 505 tools.

3.8. Saving a protocol configuration

A protocol configuration can be saved in the “work” directory, in the “user 
templates” directory or in a custom place. The “Save to project” command from
File menu is used for saving the configuration in the “work” directory. With the
“Save as” command you can choose to save the configuration in the “user” 
directory or in another custom directory.

The user template is always stored in the active project. The template is proje
specific. If you want to use the same template in another CAP 505 project, yo
cannot save it in the work directory or the user templates directory. You have to
the template in a custom place in order to have access to it from other project

)LJ�������� 7KH�³6DYH�DV´�GLDORJ

A configuration can be chosen from the list or typed manually in the “Configura
Name:” text field. If a given configuration name already exists, the user will ge
notification of this when he presses the Save button. In the appearing confirm
dialog the user is asked to confirm or reject the operation.

If you want to save the configuration as a user template, you choose the “Use
Template” option and give a name for the configuration. The configuration will
stored in the project.

3.8.1. Taking backups

It is recommended that you take backups. You can save the backup in the “Us
template” directory (see Fig. 3.8.-1) or in a custom place. Choose the “Save in
option and browse to a directory where the configuration will be stored. 
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An opened configuration can be sent to the printer with the “Print” command fr
the File menu. After the print dialog opens, the user can choose the printer prop
and start printing.

In the view menu you define which signals to be shown in the table. Dependin
the settings here, you will have different printouts, since only the signals which
shown in the table, are printed.

The following information is included in the printout:

• The date and time of printing.

• The date and time of last configuration modification.

• Protocol type.

• Relay type and its version.

• Object identification.

• The signals that are shown in the table.
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About this chapter

This chapter contains information on how to send customer feedback.

Customer feedback database

Customer Feedback is a Lotus Notes database which ABB companies can use to 
report errors, make improvement proposals and queries related to products 
manufactured by ABB Substation Automation Oy. The Customer Feedback 
database is connected to the change management system of ABB Substation 
Automation Oy, which handles all error corrections and improvements made to the 
products. 

Please note that the Customer Feedback database is primarily intended for writing 
reports about released products. If you are using, for example, a beta release in a 
pilot project, this should be clearly stated.

Writing a customer feedback report

When writing a Customer Feedback report the following general instructions 
should be taken into consideration:

• Write the report in English.

• Write only one error report, query or improvement proposal in a Customer 
Feedback Report. 

• If you are reporting an error, try to isolate the error as well as possible. Desc
the sequence of events and actions causing the error. If any error messages
other debug information is provided by the system, please write it down. Incl
also information of the system, e.g. a system diagram, revision information a
configuration data.

• If you are making an improvement proposal, try to describe how the improve
function should work. Avoid providing solutions. Information about the 
importance of the improvement, e.g. number of projects that require the 
improvement, helps us to make the decision whether and when the improve
should be implemented.

To make a Customer Feedback Report, select Feedback Report from the Cre
menu. This opens an empty Customer Feedback document. Fill out the fields l
below. A question mark next to a field provides help for filling out the field.

� Subject. This should contain a short description of the issue. A more detaile
description can be given in the Description of Feedback field below. 

� The type of Feedback: Comment/Improvement, Query or Complaint/Error.

� Customer Information

� Reporting Information. This should contain detailed information about the 
product in question.

� The person who you want to send the feedback to and whether you want to
reply from that person or not.
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� Information related to internal handling of the report (not obligatory).

� Category

You can issue the report by clicking the Issue Feedback button. This will send the 
report to the selected person and change its status to “in progress”.

Actions

When ABB Substation Automation Oy receives a Customer Feedback report i
analysed by a sales person or a representative of the technical support. The an
may ask for additional information in order to complete the analysis. After the 
report has been analysed, the following actions will be taken:

• In case of a clear error the report will be moved to the change management 
system of ABB Substation Automation Oy. In this system the error will be 
analysed in detail and corrected in a future patch release or major release 
depending on the severity and impact of the error.

• In case of an improvement proposal the report will also be moved to the cha
management system where it will be considered as a requirement for future 
releases.

• In case of a query an answer will be provided.

When Customer Feedback reports are handled in the change management sy
the outcome can be one of the following:

No Actions This means that it is decided that the
report requires no further action. For 
example, if the problem is caused by 
configuration error, it belongs to this 
category.

Will be implemented in patch/current releaseThis means that the correction or
new feature will be available in the 
next official program release.

Moved to future release This means that the new feature w
be available in a new program releas
in the near future.
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