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The chapter "Introduction".
This chapter introduces you to the software product CAP 531*1.3.
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1 Introduction

This chapter describes:

• The CAP 531 operating environment

• Documentation

• Symbols and conventions used in this document

• A brief overview of CAP 531 and related configuration products

The Configuration and Programming tool CAP 531 enables configuration manage-
ment, programming, and error detection and correction for REx 5xx terminals.

1.1 Operating environment

CAP 531 runs under Microsoft® Windows™ 3.1, 3.11, Windows95 or Windows NT. 
So you must be familiar with these programs, which let you perform actions such as 
drag and drop, zoom, and scroll.

1.2 CAP 531 documentation

This User’s Manual describes CAP 531*1.3.

The CAP 531 documentation consists of these parts:

Part Item Description

Introduction This chapter.

Instructions Installation Installation instruction.

Instructions Help Instructions of how to use the help function.

Instructions Tutorial Shows how to use CAP 531 with a mouse. Use 
this to learn how a project is run with CAP 531. 
The Tutorial goes through the normal proce-
dures of a project.

Technical 
Description 

General
Project Tree
Work Sheet
Page Layout

Describes all parts of CAP 531. It contains the 
main topics in the context-sensitive help.

Customer feed-
back card

Software regis-
tration form

References

Index
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There is also an on-line context-sensitive help in the program. Press <F1> from any-
where in CAP 531 to get detailed reference information about all of CAP 531.

1.3 Conventions used in this document

This document uses these symbols

This document uses these conventions:

All terminals that work with CAP 531 are referred to as REx 5xx in this User’s Ma
ual. REx 5xx can be considered as any of the 500-terminals that can work with C
531.

1.4 Product overview

The ABB Network Partner Panorama concept comprise a full range of flexible an
functional terminal products for monitoring, protection, and control of all parts of 
power systems in electrical power networks. These terminals are configured with
CAP 531. CAP/REx 5xx is the CAP function library for a REx 5xx terminal.

1.5 IEC 1131 programming

The IEC 1131 standard includes several graphical and textual programming langu
The CAP 531 function block diagram (FBD) is one of the IEC 1131 languages. 

FBD is a graphical language. It is a widely used programming language that is us
create complicated networks with functions or function blocks. Networks are crea
with lines that connect or duplicate information. 

Symbol Indicates...

8 Actions performed with the mouse.

7 Actions performed with the keyboard.

Convention Indicates...

<ALT> That you must press the Alt key.

<CTRL> That you must press the Ctrl key.

<TAB> That you must press the Tab key.

<ALT> + <F4> That you must hold down the Alt key and press the F4 
key.

<CTRL> + <C> That you must hold down the Ctrl key and press the let-
ter c.

<Ê,Ç,È,É> That you must press one of the arrow keys.

< ENTER> That you must press the Enter key.
6 1MRK 511 056-UEN *1.3-03
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Fig. 1 Function block in the CAP 531 work sheet.

In CAP 531, all the functions in a terminal are called function blocks. A function block 
includes input and output parameters, a type name, and function block name. See
Fig. 1 

A function that is represented as a function block in CAP 531 can be a:

• protection function

• control function

• monitoring function

• logic function

The instance name makes the function block unique. Cycle time is the time betw
executions (8 ms in Fig. 1 ).

Each function block has an execution number (986 in Fig. 1 ). The execution num
tells you in which order the function blocks are executed.

Example: 

Function blocks with cycle time 8 ms are executed in the terminal every 8 ms and
cution number 986 is executed after execution number 985. All function blocks w
this cycle time are executed within a period of 8 ms.

Fig. 2 Function block diagram.

Execution number.

Instance name.
Cycle time.

Type name.

Setting.

Input parameter.
Output parameters.
71MRK 511 056-UEN *1.3-03
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Some settings are done in CAP 531. They are presented as inputs with magenta colour.

In Fig. 2 the Timer function block has a setting of a delay time set to 1.000 seconds. A 
setting can be both numbers (as for a timer) or names. 

!
Note !
Ensure that the function blocks in the configuration are executed consecutively to min-
imize delay. Select the logical function blocks (AND, OR etc.) in rising order, from left 
to right in the work sheet.
8 1MRK 511 056-UEN *1.3-03
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The chapter "Instructions".
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Installation

This chapter describes:

• Pre-installation requirements

• The README file

• Installation of CAP 531

1 Introduction

1.1 Pre-installation requirements

You need this hardware and software to install and use CAP 531:

1.2 The ‘Readme’ file

CAP 531 comes with a ‘Readme’ file, which might comprise last-minute updates 
were made after this document was printed. The file also includes important infor
tion about this version of CAP 531. 

Read the ‘Readme’ file before you start CAP 531.

Requirements

Hardware An IBM-compatible PC.
80486-type microprocessor or higher.
A minimum of 50 MHz.
VGA compatible monitor, min. resolution 800 x 600.
One 3.5 inch diskette drive, HD type, 1.44 MB.
A minimum of 10 MB available disk space.
A minimum of 8 MB RAM, 

(minimum 16 MB is recommended).
Keyboard.
Mouse is preferable.
Printer 300dpi. 

Software 
Installed in this 
order.

MS-DOS® 5.0 or higher.
MS® Windows™ 3.1 or 3.11.
or
Windows NT 4.0 or higher
or
Windows95
CAP 531 and CAP/REx 5xx libraries.
131MRK 511 056-UEN *1.3-03



ABB Network Partner Installation of CAP 531

Installation

Instructions
2 Installation of CAP 531

Follow these steps to install CAP 531:

1 Start Windows.

2 Insert diskette 1 into the diskette drive.

3 Select the ‘Run’ command from the Start menu or the File menu in the Pro-
gram Manager.

4 Type: a:\install in the command line box if the diskette is in drive A.

The dialogue box in Fig. 1 appears.

Fig. 1 The install information dialogue box.
14 1MRK 511 056-UEN *1.3-03
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5 Select OK or press <ENTER> to continue installation.

The dialogue box in Fig. 2  appears.

Fig. 2 The user registration dialogue box.

You must type in all fields. If you do not, the installation program does not continue. 
The serial number can be read on the diskettes.

When the Registration Information dialogue box in Fig. 3  appears:

Fig. 3 The Registration Information dialogue box.
151MRK 511 056-UEN *1.3-03
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6 Select <Yes> to continue or <No> to change the serial number you have 
entered.

Fig. 4 The Select CAP 531 Directory dialogue box.

7 Select <Next> to accept the default directory
or
Select a different directory and then select <Next>.

If the selected directory already exists, the dialogue box in Fig. 5  appears. 

Fig. 5 The directory already exists dialogue box.
16 1MRK 511 056-UEN *1.3-03
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8 Select <Yes> to continue with the selected directory name, or select <No> to 
change directory.

Fig. 6 The Select Programs Sub Menu dialogue box in Windows 95 and Windows 
NT4.

The icons that will be added are:

• CAP 531 1.3

• CAP 531 1.3 Readme

• Copy CAP modules from SMS structure

• Help for CAP 531 1.3

• Uninstall CAP 531 1.3
171MRK 511 056-UEN *1.3-03
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9 Select <Next> to continue, and the dialogue box in Fig. 7 appears.

Fig. 7 The Select Page Layout Directory dialogue box.

10 Select <Next> to accept the default path to the directory where the page lay-
outs (drawing forms) are stored
or
Select a different path, and then select <Next>.

If an earlier version of CAP 531 is installed on your computer, use the same page 
layout directory so that you can reuse your page layouts.
18 1MRK 511 056-UEN *1.3-03
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Fig. 8 The Select Project Directory dialogue box.

11 Select <Next> to accept the default path to the directory where the projects 
are stored
or
Select a different path, and then select <Next>.

 

Fig. 9 The Select Modules Directory dialogue box.
191MRK 511 056-UEN *1.3-03
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12 Select <Next> to accept the default path to the directory where the modules 
are stored
or
Select a different path, and then select <Next>.

When the dialogue box in Fig. 10 appears:

Fig. 10 The CAP 531 Installation dialogue box.

13 Select <Install> to install the program.

Fig. 11 The Insert New Disk dialogue box.
20 1MRK 511 056-UEN *1.3-03
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14 Insert disk 2 and select <OK> or press <ENTER>.

Fig. 12 The Insert New Disk dialogue box.

15 Insert disk 3 and select <OK> or press <ENTER>.

The installation is complete. You can now select to view the Readme file or leave the 
installation in Fig. 13.

Fig. 13 The View Read Me File dialogue box.

2.1 Previously installed CAP/REx 5xx modules

If you have previously installed CAP/REx 5xx modules, you must run ‘Copy CAP
modules from SMS structure’. Otherwise you cannot use them from CAP 531. If 
install older versions of CAP/REx 5xx, you will also need to run ‘Copy CAP modu
from SMS structure’ after the CAP/REx 5xx installation.

This is necessary for terminals of type:

• REx 5xx Ver 1.2

• REC 561 Ver 1.0 and 1.1

• REL 531 Ver 1.0.

Activate the ‘Copy CAP modules from SMS structure’ icon, and select the termin
type to copy. Close the program after copying the terminal with the ‘Abort’ comm
211MRK 511 056-UEN *1.3-03



ABB Network Partner Using help

Help

Instructions
Help 

This chapter describes the help functions in CAP 531.

3 Using help

The CAP 531 context-sensitive help includes topics that cover all parts of the program. 
The items in the Help menu are:

If you want help regarding what you currently work with, you select Current Object in 
the Help menu.

To get an overview of all topics, you can start the table of contents in Help. From the 
table of contents, you can select a topic. 

4 Other help actions

When you are in Help, you can select the menu bar, buttons, or the underlined words. 
The underlined words are hypertext jumps (links). Click on them to quickly go to other 
topics. You can also use the Search button, which displays a dialogue box that prompts 
you for search words. 

Menu item Select this command to...

Contents Open the Table of contents of the CAP 531 help.

Index Open the Index of the CAP 531 help.

Current Object Provides help on a selected object.

Current Window Provides help on the active window.

About CAP 531... Specifies the CAP 531 version number, copyright infor-
mation and user registration data.
22 1MRK 511 056-UEN *1.3-03
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5 Help on function blocks

It is possible to access help on the function blocks directly in the work sheet.

8 To access help on function blocks:

1 Mark the function block in the work sheet.

2 Double-click on the left or right mouse-button.

3 Select Help on FB type.

Note!
The help text might not be available on all function block types.
231MRK 511 056-UEN *1.3-03
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This chapter instructs the user how some typical tasks are performed when working 
with CAP 531*1.3.

6 Introduction

This tutorial chapter will follow all the steps in a project, from setup of the project 
structure to the downloading, debug and final documentation.

This chapter will show how to work with CAP 531 using a mouse. It is also possible to 
operate CAP 531 from the keyboard.

The steps that will be gone through are:

• Start CAP 531, build a project structure

• Insert a terminal

• Setup the communication parameters

• Insert work sheets or a template configuration

• Upload Options

• Function Selectors

• Work in the work sheets, make a configuration

• Variable, setting, text

• Copy, paste and save

• Compile

• Download

• Debug

• Compare Configurations

• Page Layout

• Print

• Exit from CAP 531
24 1MRK 511 056-UEN *1.3-03
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7 Quick Guide for using CAP 531

The table below describes the work order when you use the program. For detailed 
information on each step, please see the referenced chapter. For a full understanding of 
the program, we recommend you to go through the entire tutorial chapter.

Step To do... Reference 

1 Install CAP 531. See “Installation of CAP 531” on 
page  14.

2 Install CAP/REx 5xx and/or run Copy CAP 
modules from SMS structure.

See “Previously installed CAP/
REx 5xx modules” on page  21.

3 Start CAP 531. See “Start CAP 531” on page  
27.

4 Create the project tree or import from SMS. 
Insert terminals.

See “Create project tree” on 
page  27 and “Import SMS 
project tree” on page 28.

5 Setup the communication parameters. See “Communication Setup” on 
page  59.

6 Insert a work sheet or a template configura-
tion on the selected terminal.

See “Insert a new work sheet” 
on page  31 and “Insert a termi-
nal configuration template” on 
page 32.

7 Run Upload Options as soon as you have 
access to the terminal. This should at least 
be done before the download.
Run Terminal Options otherwise, if this is 
supported by the terminal.

See “Upload Options” on page  
34.
251MRK 511 056-UEN *1.3-03
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8 Use the Function Selector tool to select 
hardware and main functions in the termi-
nal. 

See “Use function selectors” on 
page  38

9 Open the work sheet. See “Open the work sheet” on 
page  41

10 Insert function blocks and connect them. See “Insert function blocks into 
work sheets” on page  42 and 
“Connect objects” on page 43.

11 Close the work sheet. See “Exit from work sheets” on 
page  45.

12 Compile the configuration. See “Compile and link work 
sheets” on page  57.

13 Run Upload Options before the first down-
loading to a terminal, if this has not been 
done earlier in the project.

See “Upload Options” on page  
34.

14 Download the configuration to the terminal. See “Download terminal config-
urations” on page  61.

15 Debug the configuration. See “Debug mode” on page  62.

16 Prepare the drawing form by the use of the 
Page Layout.

See “Start the Page Layout 
work” on page  66.

17 Print the configuration. See “Print” on page  80.

Step To do... Reference 
26 1MRK 511 056-UEN *1.3-03
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8 Getting started

8.1 Start CAP 531

8 To start CAP 531:

1 Double-click on the CAP 531 1.3 icon.

2 The latest opened project will open automatically and prompt for password. If 
the program is started for the first time, no project will open.

8.2 Start a project

You can do either of: 

• create a new project

• open an old project

• import a project from SMS

You can keep the project tree window visible during the entire time that you work w
CAP 531 so that you see which terminal you are working with.

You cannot close the project tree window, but you can minimize it.

8.3 Create project tree

You create a new project tree with ‘New Project’ in the File menu. Password for a
project is <NEW>. 

A project tree in CAP 531 can comprise organization, station, object, and termina
els. The structure is free, so a terminal can be placed directly under the project ico
In the work sheets you make the graphical configuration of the corresponding ter
nal. 

All items in the project tree, including the terminals are added with ‘Insert’ in the E
menu.
271MRK 511 056-UEN *1.3-03
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Fig. 14 Project tree.

8.4 Open a project

You can open a project that is already prepared. This project can be stored on any par-
tition in your computer system. 

This is done with the ‘Open Project’ command in the File menu. A password is 
required. This password is set by the creator of the project.

8.5 Import SMS project tree

You can import a project structure that you have created with SMS-BASE. When
structure has been imported into CAP 531, the structure can be changed and sto
any partition in your computer system. It is not possible to reexport the new struc
back to SMS-BASE.

1 Activate ‘Import SMS project’ in the File menu.

2 The file GLOBAL.CNF is asked for. This is normally available in 
C:\SMS\BASE. If this is the case, press <OK>.
The generated project tree is displayed.

If some terminals appear with red crosses, the corresponding CAP/REx module is 
missing, or the item has no correspondence with CAP 531. 

If a terminal appears with a red cross although the corresponding CAP/REx module is 
installed, you run ‘Copy CAP modules from SMS structure’ which is a separate p
gram in the CAP 531 program group. Activate the icon in this program group, an
select the terminal type to copy. Close the program after copying the terminal with
‘Abort’ command. Import the SMS project again, and the red crosses will disappe

Project
Organization
Station
Bay
Terminal

Work sheets
28 1MRK 511 056-UEN *1.3-03
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8.6 Edit the project tree

You can build up and change the project tree. You can have a project tree with a user-
defined number of levels. This editing is done with ‘Insert’, ‘Delete’, ‘Cut’, ‘Copy’ 
and ‘Paste’ in the Edit menu.

Fig. 15 Insert items in the project tree.

You can change the name of any item in the project tree with the ‘Object Propert
command in the Edit menu.

8.7 Password handling

Password of a new project is always <NEW> with access right 1. This means that th
person who creates a new project has the complete system rights to the entire pr
The creator can set a number of different passwords with different access levels 
(higher numbers).

Fig. 16 Password definition.
291MRK 511 056-UEN *1.3-03
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9 Start configuration work

You can start the configuration work with either of: 

• blank pages (new work sheet)

• an example/standard configuration (template)

• a saved and prepared work sheet

If you start the configuration work with blank work sheets, you start by inserting a
work sheet (‘Edit’ - ‘Insert’). 

If you start with an example or a standard configuration, you start by inserting a t
plate configuration (‘Edit’ - ‘Insert template’). 

If you start with a prepared work sheet, you start by inserting this work sheet
(‘Copy’/ ‘Paste’ in the project tree, or ‘Insert from’ in the work sheet).

You can work with a terminal only if the corresponding CAP/REx 5xx is installed.
This message appears if it is not installed:

This symbol can also appear if the CAP/REx 5xx is stored in the SMS structure. S
types of CAP/REx 5xx are always installed in the SMS structure. It is then neces
to run ‘Copy CAP modules from SMS structure’ which is a separate program that
ies the necessary information from SMS to the CAP structure where it can be see
from the CAP 531 program. The ‘Copy CAP modules from SMS structure’ progra
activated with a separate icon in the CAP program group.

1 Select the ‘Copy CAP modules from SMS structure’ icon.

2 Select the path to SMS-BASE, normally C:SMS\BASE.

3 Double-click on the terminal type (“CAP Module”) to be copied. Note that the 
terminal type must be shown in the top selection window.

4 This program is closed by activating <Abort>.

A terminal with either:

• no corresponding CAP/REx 5xx installed.
• CAP/REx 5xx not in the CAP structure.
• item has no relevance to CAP 531 (if imported 

from SMS).
30 1MRK 511 056-UEN *1.3-03
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9.1 Insert a new work sheet

If you start your configuration work without using any previously prepared configura-
tion, you start work by inserting a work sheet in the terminal.

8 To insert a new work sheet:

Fig. 17 Insert  dialogue box.

9.2 Add another work sheet

If you want to split up your configuration on several work sheets, you can add more 
work sheets to the terminal. This can be done in the same way as described above, 
which inserts the new work sheet as the bottom one in the terminal, or in the following 
way.

8 To add a work sheet:

1 Select the terminal in the Project Tree.

2 Select the ‘Insert’ icon on the toolbar. 
A dialogue box appears.

3 Select type: Work sheet.

4 Type a name for the work sheet. 

5 Select <OK> to confirm.

1 Select a ‘Work Sheet’ icon. You can insert the 
new work sheet above or below this selected 
work sheet. 
311MRK 511 056-UEN *1.3-03
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9.3 Insert a terminal configuration template

You can start your configuration work by using a previously prepared configuration 
(template). This prepared configuration can be a:

• standard configuration of a company.

• configuration coming from a previous project.

• example configuration, included in the CAP/REx 5xx program module.

For a more complex terminal with comprehensive configuration, it is a big advant
to start the work by using an old configuration as a template and only make nece
changes. 

Note that the default programming of terminals might differ from the example con
uration included in the corresponding CAP/REx 5xx program module. 

Use the ‘Insert Template’ command in the Edit menu to insert the templates.

!
Note!
The terminal must be without work sheets to start with. Otherwise the command is not 
active.

8 To insert a template:

2 Select the ‘Insert’ icon on the toolbar. 
A dialogue box appears, see Fig. 17.

3 Type a name for the work sheet. Select to place 
the work sheet above or below the selected one. 

4 Select <OK> to confirm.

1 Click on the terminal in the Project Tree to select 
it.

2 Select the ‘Insert Template’ command in the Edit 
menu, and the Insert Template dialogue box 
appears.

3 Select a template.

4 Select <OK> to confirm. ‘Update Version’ will run 
automatically.
32 1MRK 511 056-UEN *1.3-03
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9.4 Insert a work sheet from a file

You can use the ‘Insert From’ command to insert a stored work sheet into a new 
nal configuration.

8 To insert a stored work sheet:

1 Insert a new work sheet in the Project Tree.

2 Open the new, empty work sheet.

3 Make an insertion mark in the upper left corner of the work sheet by clicking 
with the left mouse button.

4 Select the ‘Insert From’ command in the Edit menu, and the Insert From dia-
logue box appears.

5 Select the directory and the file name of the stored work sheet.

6 Select <OK>.

Fig. 19 The Insert From dialogue box.
331MRK 511 056-UEN *1.3-03
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10 Upload Options

When you start to work with the configuration of a terminal, it is important that you 
use the correct set of functions. This is done by running:

1 Upload Options — if the terminal is available
or Terminal Options if this is supported by the terminal

2 Function Selector tool 

If the terminal is available, it is recommended to connect the PC to the terminal a
run ‘Upload Options’ in the On-line menu. You can connect the PC either to the fr
port of the terminal or to a rear SPA-port.

!
Note!
Before you start communicating to a terminal, see to that the communication setup in 
the On-line menu is correct. See “On-line functions” on page  59.

The ‘Upload Options’ command uploads from the terminal

• List of functions installed in the terminal

• Function selector information 

The terminal comprise the set of functions that were ordered for this terminal. By
ning Upload Options, the list of available function blocks in CAP 531 will match th
installed functions in the terminal. 

In CAP/REx 5xx, all possible function blocks are available that can be ordered in
terminal (standard or optional). To prevent that optional functions not included in 
terminal still are included in the configuration, you can upload the list of available
functions from the terminal (Upload Options), and replace the complete list of fun
tions that is provided by CAP 531. After uploading, Update Version runs automat
cally. The library used by CAP 531 for this terminal will be reduced according to t
terminal functionality.

Uploading also involves the uploading of the function selectors of the terminal. In
function selector it is possible to choose Uploaded data as input to the function s
tors. See the Function Selector chapter for more information.
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Fig. 20 A warning is displayed if the version differs.

If the warning in the Fig. 20  is displayed, the version of CAP/REx 5xx differs from 
the terminal.

Fig. 21 A warning is displayed if the library of elements differs.

The warning in the Fig. 21  is displayed if the list of available functions differs from 
the terminal and the corresponding library in CAP 531. This will be the normal case 
when you run ‘Upload Options’ for the first time from a certain terminal.

A message is displayed if no differences are found between the list of functions us
the terminal and the library list that is used in the tool.

8 To upload the list of functions and function selectors from the terminal:

1 Click on the terminal in the project tree to select it.

2 Check that the communication setup is correct by look-
ing at ‘Setup’ in the On-line menu.

3 Select ‘Upload Options’ in the On-line menu, and 
uploading starts by uploading the list of functions. A 
warning is displayed if contents differ.

4 Select ‘Replace’, and the list of functions is replaced 
and Update Version starts automatically.
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If a function appears in a work sheet, and this function is not available in the terminal, 
an error list is generated by the Update Version.

8 If error messages are displayed from Update Version, then:

1 Double-click on the error in the error list.

2 Double-click on the functions block and the Replace dialogue box appears.

3 Select the functions block for replacement, and then select <OK>. The func-
tions block is replaced.

4 Select the next error in the error list and repeat the above steps until all func-
tions block are replaced.

8 When all errors are corrected, then run ‘Update Version’ again manually:

10.1 Terminal Options

The Terminal Options command is available for some terminal types. See the Us
Manual of the CAP/REx 500 module for more information.

1 Click on the terminal in the project tree to select it.

2 Select ‘Update Version’ in the Make menu, and updat-
ing of the library starts.
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11 Function Selector

When you start to work with the configuration of a terminal, it is important that you 
use the correct set of functions. Some of these functions are selected in the ‘Fun
Selector’ in the Edit menu.

Note!
Not all types of the REx 5xx terminals uses the function selectors.

Function selectors are used to choose one of many possible function blocks for t
same function.

If the terminal is available, it is recommended to connect the PC to the terminal a
run ‘Upload Options’ before you run the ‘Function Selector’. In this way, the library
functions in the PC will match completely the library of functions in the terminal.

If you cannot connect the PC to terminal, you run the ‘Function Selector’ directly.

11.1 Example of function selectors

I/O module01 can be configured to be either of:

• BIM Binary Input Module.

• BOM Binary Output Module.

• IOM Input Output Module. 

This choice of modules gives different shape of the function block for the 
I/O module01.

Assume that you want to change the logical I/O module01 (IO01-) from being a 
Binary Input Module (BIM) to a Binary Output Module (BOM).
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Fig. 22 Compare the I/O module as BIM (left) or as a BOM (right — only a part
the function block is shown).

When you select a Binary Output Module in the Function Selector tool, the library is 
updated with the new function block, and only the selected module can be used in the 
configuration.

11.2 Use function selectors

8 To start the ‘Function Selector’:

Input data (data sources) to the Function Selector can be:

• Working data — displayed on the screen

• Default data — presented the first time for each terminal

• Uploaded data — comes from the terminal at Upload Options

1 Select the terminal in the Project Tree.

2 Select the ‘Function Selector’ in the Edit 
menu.

3 Select the ‘Load’ command in the File 
menu to select the data sources for the 
function selector tool.
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When the CAP 531 is opened, working data is displayed; it includes the last saved 
data. The CAP/REx 5xx product specifies the default data. Default and working data 
are equivalent before the working data is changed. Uploaded data consist of the func-
tion selectors that comes from the terminal while running ‘Upload Options’, which
an On-line function.

Fig. 23 The function selector.

The function selector contains these sections:

• Set Value (upper section), which you use to change the function selector val

• Selected Values (lower section), which gives you an overview of all function 
selector settings.

When you scroll the Value, you can see what types of function blocks that you ca
select. 
391MRK 511 056-UEN *1.3-03



ABB Network Partner Function Selector

Tutorial

Instructions
8 To change the Type_IO1 function selector for the I/O-module01:

1 Select Function Group: I/O-module01.

2 Use the Value scroll bar to change the value from BIM to BOM.

3 Select the ‘Set’ button, and the value changes in the Selected Values section.

4 Select the ‘Save’ button, and the new function is saved.

8 To close the function selector:

1 Select ‘Exit’ in the File menu.
40 1MRK 511 056-UEN *1.3-03



ABB Network Partner Work Sheet

Tutorial

Instructions
12 Work Sheet

12.1 Open the work sheet

You open the work sheet from the project tree. 

8 To open the work sheet:

Fig. 24 Work sheet called HMI.

12.2 Use work sheets

A work sheet can consist of several pages. You set the number of pages from the Work 
Sheet size (WS size) dialogue box on the Layout menu.

Fig. 25 Work Sheet Size dialogue box.

1 Double-click the left mouse button on the 
work sheet icon for the terminal, and the 
work sheet appears.
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You can use the work sheet to structure the different functions in the terminal configu-
ration, where each work sheet can represent one or several functions.

Select the ‘Page Border’ command in the Layout menu to display the page borde
size of the page and page orientation is set in the Page Layout with the ‘Paper O
tion’ command in the Layout menu.

12.3 Insert function blocks into work sheets

This section assumes that you want to insert an AND-function block called A001.

8 To insert this function block:

 

Fig. 26 Function Block dialogue box.

8 To use the Function Block dialogue box:

After insertion, the function block is no longer visible in the list of functions, becau
the function block can only be used once in the terminal.

1 Click the left mouse button to set an insertion mark in the 
work sheet.

2 Click the left mouse button on the Insert Function Block 
icon on the toolbar, and the Function Block dialogue box 
appears.

1 Select the type: AND.

2 There are more than one AND function block. Select one from the Instance 
list.

3 Select <OK> to confirm, and the function block is inserted at the insertion 
mark.
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12.4 Connect objects

If you insert function blocks or variables (objects) in your work sheet, you want to 
connect them to other function blocks.

Assume that you want to connect the AND-function block A001 with the Timer-func-
tion block TM01. First you must insert also TM01 by following the procedure 
described above. 

8 Connect two objects:

Fig. 27 The two objects is connected by using the connection mode.

1 Click the left mouse button on the Connect Objects icon on 
the toolbar. 

2 Position the cursor at the ON output (the blue circle) of the 
TM01 function block and click the left mouse button.

3 Move the cursor towards the INPUT1 input of the A001 
function block. Click the left mouse button whenever you 
want a new direction of the connection line.

4 Click the left mouse button when you reached INPUT1 (the 
green circle), and the connection is set.
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You can also connect objects by moving them close together:

8 To connect two objects:

You can now move one of the function blocks to a free position if desired.

Fig. 28 The function blocks, before the connection is set.

Fig. 29 The connection is set.

1 Position the cursor on the A001 function block.

2 Press and hold the left mouse button.

3 Move towards the function block TM01 so that the con-
nection points (blue and green circle) overlap.

4 Release the mouse button, and the connection is set.
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Fig. 30 A001 is moved to a free position with the present connection.

12.5 Save work sheets

Regularly save your changes while you work. If, for example, a power failure occurs, 
you risk losing data if you do not save it. 

In CAP 531, you can save changes in:

• all opened work sheets for one terminal.

• all opened work sheets for all terminals.

8 To save all opened work sheets for all terminals:

1 Select ‘Save All’ in the File menu, and the work sheet is saved.

!
Note!
Select the ‘Close All‘ command on the File menu to save and exit from all opened 
sheets.

12.6 Exit from work sheets

You close a work sheet by using the ‘Close Terminal’ command in the File menu.
451MRK 511 056-UEN *1.3-03



ABB Network Partner Variable, Setting, Text

Tutorial

Instructions

001 
13 Variable, Setting, Text

13.1 Variable

Variables are used in a configuration for the purpose to increase the readability of the 
configuration. It is a means to connect signals between function blocks without draw-
ing lines. The connection is instead made through names. You give the output of a 
function block a user-defined name (Variable), and you give the input of another func-
tion block the same name. The CAP 531 program interprets this as a connection. The 
Variable name can consist of up to 32 characters.

With the use of Variables, it is possible to connect signals to and from function blocks 
in different work sheets, and in different pages in the same work sheet.

13.2 Insert variables

You can insert variables into a work sheet in two ways:

• Directly connected to a function block

• In the work sheet without connection to a function block

Assume that you want to insert a variable that is directly connected to the AND A
function block.

8 Insert a variable at the input INPUT1:

Fig. 31 Variable dialogue box.

1 Click on the input INPUT1 to select it.

2 Click the left mouse button on the Variable icon on 
the toolbar, and the Variable dialog appears.
46 1MRK 511 056-UEN *1.3-03



ABB Network Partner Variable, Setting, Text

Tutorial

Instructions
8 To use the Variable dialogue box:

8 Insert a variable anywhere in the work sheet:

Fig. 32 Variable dialogue box.

8 To use the Variable dialogue box:

!
Note!
Use Copy and Paste to avoid mistyping of the Variable names. The input and output 
Variable must have identical names to be connected by the CAP 531.

1 Type the variable name, a text string of up to 32 
characters.

2 Select <OK>, and the variable is inserted at the 
INPUT1.

1 Click on the left mouse button to set an insertion 
mark in the work sheet.

2 Click the left mouse button on the Variable icon on 
the toolbar, and the Variable dialogue appears.

1 Type the variable name.

2 Choose if the Variable is to be connected to an OUTPUT 
or an INPUT on a function block.

3 Select <OK>, and the variable is inserted at the inser-
tion mark.
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13.3 Settings

A setting is, for example, a time delay or a name. The setting parameter name is dis-
played in magenta color on the work sheet. The program uses magenta color to high-
light a setting input. Settings can be numbers or text strings.

13.4 Insert settings

Assume that you want to set the T parameter to 2.50 seconds in Timer TM01.

8 To set the value:

After you set a value in the work sheet, you can move the value. The connection to the 
input parameter remains.

Fig. 33 The Parameter Setting dialogue box.

1 Click the left mouse button on the T param-
eter in TM01.

2 Click the left mouse button on the Setting 
icon on the toolbar, and the Parameter Set-
tings dialog box appears.

3 Change the value to 2.50.

4 Select OK, and the 2.50 value is displayed 
to the left of the T parameter.
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13.5 Insert Text (Comment)

Free text can be placed anywhere in the work sheet. This text can be used for different 
purposes. The configuration and the signals can be explained for the reader. This can 
also be used for temporary comments during the configuration work.

8 Insert a comment in the work sheet:

Fig. 34 Comment dialogue box. 

8 To use the Comment dialogue box:

1 Click on the left mouse button to set an insertion mark 
in the work sheet.

2 Click the left mouse button on the Text icon on the 
toolbar, and the Comment dialogue appears.

1 Type the text.

2 Press Font to change font, size and colour of the text.

3 Select <OK>, and the text is inserted at the insertion mark.
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14 Copy, Paste and Save in files

14.1 Clipboard functions

You can use standard MS Windows commands such as cut, copy and paste within a 
work sheet or between work sheets. You can apply this on function blocks, variables 
and text comments. It is also possible to use the clipboard functions in the project tree. 

If you try to copy an existing function block, the Replace dialogue box is displayed, 
because one function block (one instance) can only exist once in each terminal (see 
Fig. 35).

14.2 Replace function blocks

You can exchange a function block for another function block of the same type, for 
example, to change an execution order. Or you can totally change the function block 
type. 

Assume that you want to change AND A001 to OR O001.

8 To replace the function block:

1 Select the AND function block A001.

2 Click the left mouse button on the Replace icon on the tool-
bar, and the Replace dialogue appears. Or, position the 
cursor on the A001 function block and double-click the left 
mouse button.

3 Change the function block type to OR.

4 Select the O001 function block.

5 Select <OK>, and O001 replaces A001.
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Fig. 35 The Replace dialogue box.

Assume that you want to change a function block AND A001 to AND A005, which 
has a different execution number. Functions should be executed in consecutive order, 
to avoid additional time delay. Therefore you might want to change execution number 
of the logic function blocks.

8 To replace the function block:

14.3 Groups

You can group several function blocks by connecting them to get a structure of differ-
ent functions. You can also copy the group to a library to reuse the group in other ter-
minals in the same or other projects. The group is saved and reused as a file. It is not 
possible to copy and paste a group.

1 Select the AND function block A001.

2 Double-click the right mouse button.

3 Select the A005 function block.

4 Select <OK>, and A005 replaces A001.
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14.4 Create groups

Assume that you want to create a group that consists of Timer TM01 and AND A001, 
and that you want to store it under a new name called Delay 1.

8 To create a group:

Fig. 36 The Delay1 group.

!
Note!
You cannot create a group of function blocks with connections leading outside of the 
group. First you create the group, such as in Fig. 36. Then you can connect the func-
tion blocks in the group to other objects outside the group.

1  Click the left mouse button on the ‘Group’ icon on the 
toolbar to activate the group mode.

2 Select the area that you want to group: Press and hold the 
left mouse button and move the cursor over the objects 
that will be in the new group. A frame appears around the 
area that you selected.

3 Release the mouse button, and the ‘Group’ dialogue box 
appears.

4 Type Delay 1, which is the new group name.

5 Select <OK>.
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14.5 Save groups as files

You can save a group as a file. In this way you can use it for other terminal configura-
tions in the same project or other projects. You cannot use Copy and Paste on a group.

8 To save a group as a file:

Fig. 37 The Copy To dialogue box.

14.6 Insert groups from files

Use the ‘Insert From’ command to insert a stored group into a work sheet.

8 To insert a group:

1  Click the left mouse button on the group to select it.

2 Select the ‘Copy To …’ command in the Edit menu, and the 
Copy To dialogue box appears.

3 Select a directory and type a file name for the group.

4 Select <OK>.

1  Select the ‘Insert From’ command in the Edit menu, and 
the Insert From dialogue box appears.

2 Select the directory and the file name for the stored 
group.

3 Select <OK>.
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Fig. 38 The Insert From dialogue box.

If a function block in the group already exists in the terminal, the Replace dialogue box 
will be displayed, because one function block can only exist once in each terminal (see 
Fig. 35 ).

14.7 Save work sheets in files

In CAP 531 it is possible to save: 

• a complete terminal as a template

• a single work sheet

14.7.1 Save all work sheets in a terminal

All work sheets in a terminal can be stored as a template and can be reused in the
project or in other projects. It is also possible to create an internal standard as a 
for future configuration work, stored as a template.

8 To save a template:

1  Select the terminal (in the Project Tree).

2 Select the ‘Generate Template’ command in the Edit menu.

3 Write a template name and a description.

4 Select <OK>.
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14.7.2 Save work sheets as files

You can save a single work sheet as a separate file, which you can use in other termi-
nal configurations in the same project or in other projects.

8 To save a work sheet as a file:

Fig. 39 The Copy To dialogue box.

1 Open the work sheet that you want to save.

2 Select the ‘Mark All Objects’ command in the Edit menu.

3 Select the ‘Copy To …’ command in the Edit menu, and the 
Copy To dialogue box appears.

4 Select a directory and type a file name for the work sheet.

5 Select <OK>.
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14.7.3 Insert work sheets from files

You can use the ‘Insert From’ command to insert a single stored work sheet into a
terminal configuration.

8 To insert a stored work sheet:

Fig. 40 The Insert From dialogue box.

1  Insert a new work sheet in the Project Tree.

2 Open the empty work sheet.

3 Point with the cursor in the upper left corner in the work 
sheet.

4 Click on the left mouse button to set an insertion mark in 
the corner.

5 Select the ‘Insert From’ command in the Edit menu, and 
the Insert From dialogue box appears.

6 Select the directory and the file name for the stored work 
sheet.

7 Select <OK>.
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15 Compile and link work sheets

The program goes through the configuration in order to detect some types of errors and 
to prepare for downloading. This is done in a compilation procedure.

In CAP 531, you can compile the configuration in:

• One terminal 

• All terminals in the project

We recommend you to compile only one terminal at a time during the configuratio
work. This gives a better overview of the compilation errors.

8 To compile a terminal:

Fig. 41 The progress bar for compilation, which indicates the graphic compiler 
phase of compilation.

Compilation is performed in several phases, which you can see when working. Fi
 indicates the graphic compiler phase.

When compilation ends without detecting programming errors, the progress bar f
compilation disappears and the status bar displays this message: ‘Code generati
cessful’. 

During compilation for the first time, the compiler detects programming errors suc
duplicate variable names or typing errors. When errors occur, a message box dis
the number of detected errors. 

When you confirm the message box, CAP 531 displays an error list on your scre
shown in Fig. 42.

1 Select the terminal that you want to compile in the 
project tree.

2 Select the Compile Terminal icon on the toolbar, 
and the progress bar for compilation appears.
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Fig. 42 Error list with error messages.

To get help, highlight the error in the error list, and press <F1>. CAP 531 displays:

• The reason for the error

• Corrective measures that you can take to correct the error

Double-click with the left mouse button on the error in the error list to go directly t
the work sheet that contains the error. Normally, the line that contains the error is
lighted. If you cannot find the error list, it is accessible with ‘Error List’ in the Make
menu.

Note!
If the error is of type ‘Connector not found’, the program always marks an input s
nal. If the error is caused by a misprint of a Variable, the mistake might be on the
responding output signal connector, and not on the input which is marked by the 
program.

If an error occurs, it is important to run the compilation once again after the errors have 
been corrected. It is possible that another part of the compiler can detect more errors in 
a second compilation since the compiler can proceed further than the first time.

It is therefore necessary to repeat the compilation process until there are no errors from 
the compilation.
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16 On-line functions

It is possible to perform the following functions when being connected to the terminal:

• Upload Options

• Download Configuration

• Debug

• Compare Configurations

All on-line functions requires a connection between the PC and the terminal. You
connect the PC’s serial COM-port either to the front port or to a rear SPA-port of 
terminal. It is also possible to communicate via a telephone modem.

16.1 Communication Setup

Before you run ‘Upload Options’ or any other on-line task, it is necessary to check
communication setup. 

1 Select the terminal in the project tree.

2 Select the ‘Setup’ command in the On-line menu.

Fig. 43 Default settings for the front communication.

The default settings are prepared for front communication.The Baud rate and the Slave 
number must be set to the same as for the front port of the terminal. So this must be set 
both in CAP 531 and on the built-in HMI of the terminal. The COM-port number 
depends on the PC.
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You use a special cable for connecting your PC to the front of the terminal. This can be 
ordered from ABB Network Partner. It is plugged into the optical contact on the left 
side of the built-in HMI. The other end of the cable is plugged directly into the COM-
port of the PC.

If rear communication is used with a direct fibre connection (no modem), the setup 
should look like Fig. 44.

Fig. 44 Example of setup for rear communication.

The Baud rate and the Slave number must be set to the same as for the rear SPA port of 
the terminal. So this must be set both in CAP 531 and on the built-in HMI of the termi-
nal.

The other parameters are set depending on the communication channel, but if a direct 
(or a loop) fibre communication is used, the other parameters should not be changed 
from the example above. Note that the Flow control parameter is different between 
front and rear communication.
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16.2 Upload Options

You should always run ‘Upload Options’ as soon as you have access to the term
See “Upload Options” on page  34.

16.3 Download terminal configurations

You can download a configuration to the terminal after compilation.

CAP 531 starts the downloading by uploading the list of available functions, the v
sion and the serial number of the terminal. These are compared with the library ve
and the function library that are used by CAP 531. The serial number of the termin
compared the registered serial number of any previous communication to this term
in CAP 531. If no differences were found after the comparison, the download sta

A warning is displayed if the library version of CAP/REx 5xx differs from the term
nal. Some function blocks might have changed between the versions, so the func
ality cannot be guaranteed. You should then upgrade your CAP 531 with the corr
version of CAP/REx 5xx before you continue.

Fig. 45 A warning is displayed if the set of functions differs.

The warning message in Fig. 45  is displayed if the list of available functions diffe
between the terminal and the corresponding library in CAP 531. Interrupt the dow
loading procedure with ‘Cancel’ and run ‘Upload Options’ manually. After this 
‘Upload Options’ you can start the downloading procedure again. Then no warnin
message will appear.

!
Note!
If you download a configuration with unavailable functions included into your config-
uration, they will not be connected and the configuration in the terminal will not be 
identical with the configuration in CAP 531. You should therefore always press ‘C
cel’ when the warning message appears as in Fig. 45 .
611MRK 511 056-UEN *1.3-03



ABB Network Partner On-line functions

Tutorial

Instructions

 
ies in 

rison 
roce-

ase, 
he 

ate 
s. 

 can 
8 To download the configuration to the terminal:

The ‘Compare Configuration’ function starts automatically.If the downloading has
gone through as it should and there are no differences between the function librar
the terminal and in the configuration, no differences will be detected in the compa
process. If differences appear in the comparison list, then start the downloading p
dure again.

16.4 Upload configuration

This menu is active if the selected terminal can support this function. If this is the c
the entire configuration is stored in the terminal and can be uploaded to the PC. T
original configuration is in this way stored in the terminal and not in the PC.

16.5 Debug mode

After you compile the configuration and download it to the terminal, you can activ
the debug mode for error detection and correction (debugging) in the work sheet

First you open a work sheet and then set the work sheet in the debug mode. You
debug several work sheets at the same time.

Note!
CAP 531 will only debug visible signals. For fast updating of the signals, ensure that 
only signals that are of interest are displayed in the work sheet.

Ensure that the configuration in the terminal corresponds to the configuration in 
CAP 531, for example, by using ‘Compare Configurations’.

8 To set a work sheet in debug mode:

1 Click on the terminal in the Project Tree to select the 
terminal that you want to download.

2 Select ‘Download Config.’ in the On-line menu, and 
downloading starts by uploading the list of available 
functions.

1 Double-click on the work sheet in the project tree to 
select it for debugging. The work sheet opens.
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The status of different signals is indicated by different colors on a work sheet in debug 
mode. These colors represent different values:

It is necessary to have the Global Debug in the On-line menu marked active if you 
intend to debug a work sheet. The Global Debug works like a main switch to the debug 
functionality.

.

Fig. 46 Global debug affects the debug mode in all work sheets.

2 Click on the Debug icon on the toolbar. The work 
sheet switches to debug mode.

Colour Meaning

Red Boolean true (high)

Blue Boolean false (low)

Green Present analogue values

&
&
&
&

Work Sheet: HMI

Work Sheet: I_O

Work Sheet: REM

Work Sheet: BAY_RE

Global Debug marked

Debug mode active

Debug mode active

Debug mode active

Debug mode active
Debug ON

Debug ON

Debug ON

Debug ON in the HMI work sheet

in the REM work sheet

in the I_O work sheet

in the BAY_RE work sheet
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16.6 Compare Configurations

CAP 531 contains a tool that lets you compare the terminal configuration and the CAP 
531 configuration. You can compare CAP 531 configurations against previously 
uploaded terminal configuration or you can upload a new configuration from the ter-
minal and then make a comparison.

The main purpose of Compare Configurations is for the user to verify that the configu-
ration in the terminal is the same as the configuration is CAP 531.

8 To compare configuration when you are connected to a terminal:

Example:

Fig. 49  show the difference between Fig. 47  and Fig. 48 . Note here that TRUE and 
FALSE are defined by the FixedSignal function block.

Fig. 47 Configuration in the terminal.

Fig. 48 Configuration in CAP 531.

1 Click on the terminal in the project tree to select it.

2 Select the ‘Compare Configurations’ command in the 
On-line menu, and the Compare Configurations dia-
logue box appears.

3 Select the ‘Upload and Compare’ command in the File 
menu, and the upload starts. The comparison starts 
after the configuration is uploaded. A list displays the 
differences, see Fig. 49 .
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l 
Fig. 49 Comparison result given by Compare Configurations.

In this case, the variables TRUE and FALSE were connected to the outputs FIXD-ON 
and FIXD-OFF. 

The main purpose of Configuration Compare is for the user to verify that the configu-
ration in the terminal is the same as the configuration is CAP 531.

Note!
Do not confuse the ‘Compare Configurations’ upload of a configuration with the 
‘Upload Options’ command in the On-line menu, which uploads the list of termina
options and the function selectors.
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17 Start the Page Layout work

17.1 Introduction

The CAP 531 lets you create and print your own drawing forms that can comply with 
your internal layout standards. This is called the page layout.

The page layout includes a set of graphical tools for inserting lines and text in the 
headers and footers. 

A default page layout is included in CAP 531, which follows an ABB standard draw-
ing. This page layout is called DEFAULT.PLT. When you create your own standard 
drawing form, you normally start with a page layout that already exists and change this 
according to your needs.

Note!
Not all information is included in the *.plt files. Use the ‘Copy To…’ menu item an
the ‘Insert from…’ menu item to move page layouts between PCs.

17.2 Assign page layouts to work sheets, terminals or project tree

When you insert a work sheet, the default page layout is used automatically for this 
work sheet. If you want to use another page layout, you assign this page layout to your 
work sheet or your project tree. 

8 To assign the page layout to a work sheet:

1 Position the pointer on the work sheet icon in the 
project tree.

2 Double-click on the right mouse button, and the Prop-
erties dialogue box appears, see Fig. 50. Or you open 
the properties dialogue by highlighting a work sheet, 
and then select ‘Object Properties’ in the Edit menu.
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Fig. 50 The Properties dialogue box, which is used to assign a page layout.

Fig. 51 The Print Options dialogue box.

It is possible to assign a page layout to all work sheets in a terminal. To assign the page 
layout to a terminal, follow the steps for a work sheet, except that you double-click and 
highlight a terminal instead.

To assign a page layout to the project tree as such, highlight the project icon at the top 
of the tree, follow the same step 2 to 6 as described above for work sheets.

3 Select ‘Print Options’, and the Print 
Options dialogue box appears, see Fig. 51.

4 Select or type the name of the page layout that you want 
to assign.

5 Select <OK> in the Print Options dialogue box.

6 Select <OK> in the Properties dialogue box.
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Fig. 52 The default page layout.

17.3 Create a new page layout

Normally you start the page layout work by reusing an old page layout and change it. 
If however you want to start with a blank page, you can create a new page layout, 
where you can define everything from the beginning.

8 To create a new page layout:

1 Select ‘Page Layout’ in the File menu.

2 Select ‘Open Page Layout’.

3 Select the ‘New’ command in the File menu and an 
untitled page layout is displayed.
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Fig. 53 A new page layout.

Note that you must associate this new page layout with the work sheets that you want 
to print with this page layout. This is not done automatically when you create the new 
page layout.

17.4 Copy and insert page layouts

All necessary information for a page layout is stored in several files. Use the ‘Cop
To…’ command to copy this data to another directory. Use the ‘Insert From...’ co
mand to insert a page layout into a project.

8 To copy the page layout to the A: drive:

1 Select ‘Page Layout’ from the File menu.

2 Select ‘Open Page Layout’.

3 Select the ‘Copy To…’ command in the File menu of the 
Page Layout and the dialogue box appears.
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Fig. 54 The Copy To... dialogue box.

8 To insert the page layout from the A: drive:

Fig. 55 The Insert From... dialogue box.

4 Select the A: drive.

5 Select a directory and type a name, *.plt file name.

6 Select <OK>.

1 Select ‘Page Layout’ in the File menu.

2 Select ‘Open Page Layout’.

3 Select the ‘Insert From…’ command in the File menu of the Page Layout, 
and the Insert From dialogue box in Fig. 55 appears.

4 Select the A: drive.

5 Select a directory and a file name.

6 Select <OK>.
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18 Edit Page Layout

After you create a new page layout, you must define the:

• source area.

• cross reference area.

• part of the source area from where the cross references are taken.

18.1 Source area

The source area is the area where you want to place the contents of the work she
enclosed by a red rectangle.

Note!
The size of the source area affects what will be printed on each page. Some function 
blocks or variables might be cut off if the source area is changed after the configura-
tion is made.

8 To define the source area:

1 Select the Source area icon on the toolbar, and the 
pointer symbol becomes a rectangle.

2 Press and hold the left mouse button.

3 Move the cursor across the area that you want to 
define as the source area.

4 Release the mouse button, and the source area is 
drawn.
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Fig. 56 Page layout with a marked source area.

18.2 Cross reference area

The page layout can have two sections for cross-references: 

• The left legend contains cross-references for the inputs.

• The right legend contains cross-references for the outputs.

The two sections are parts of the cross reference area, drawn as one area also c
the source area in the middle. 

8 To define the cross reference area:

!
Note!
If you want cross references shown on both the right and left side of the source area, 
the cross reference area is drawn so that it covers the entire page, including the source 
area. See the DEFAULT.PLT for an example.

1 Select the Cross reference area icon on the 
toolbar, and the pointer symbol becomes a 
rectangle.

2 Press and hold the left mouse button.

3 Move the cursor across the area that you 
want to define as the area for cross refer-
ences.

4 Release the mouse button, and the cross 
reference area is drawn.
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18.3 Cross references from the source area

Some cross references are shown on the same page as the drawing with the configura-
tion. The remaining cross references are shown on a separate page.

The cross references of the input and output signals that ends close to the left and right 
side of the source area will be shown on the same page. The signals that ends on the 
middle of the source area will be shown on the consecutive page, which will only be 
used for cross references.

The part of the source area from where the cross references on the same page are taken 
is shown with red dashed lines.

Fig. 57 Page layout with the dashed line for the described part of the source area.

The size of this area can be increased by:

1 Mark the source area (click with the mouse in the middle of the 
source area).

2 Double click with the right mouse button (or select ‘Object 
Properties’ in the Edit menu).

3 Write a higher number in the ‘Width of the area’ in the ‘Left/
right cross references’ section.

4 Press <OK>.

5 The dashed lines will be moved.
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18.4 Objects

In CAP 531, you can insert different objects on your page layout, for example, lines, 
rectangles, bitmaps or text. 

8 To insert a line:

8 To insert a bitmap:

Fig. 58 Insert bitmap dialogue box.

1 Select the Line icon on the toolbar, and the 
pointer becomes the shape of a line.

2 Press and hold the left mouse button.

3 Move the cursor to draw a line.

4 Release the mouse button, and the line is drawn.

1 Select the Bitmap icon on the toolbar, and 
the pointer becomes the shape of a rectan-
gle.

2 Press and hold the left mouse button.

3 Move the cursor to area where the bitmap 
should be located.

4 Release the mouse button, and the Insert 
bitmap dialogue window is opened.

5 Select a bitmap file.

6 Press <OK>.

7 Change the size if necessary with ‘Object Properties’ in the 
Edit menu.
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19 Edit Environment Items

You can insert variable objects into your page layout. These are called environment 
items or environment variables, such as page numbers, your company’s name, a
other text. CAP 531 contains standard environment items, which are called syste
items.

You can create user-defined environment items, and you can add them to the list
standard environment items. You can assign these special attributes (scope) to e
environment item:

• All projects

• This project

• Terminal

• Work Sheet

Example:

Assume that an environment item is called prep_name (i.e. the name of the engineer 
preparing the configuration). Let us also assume that almost all the configuration
prepared by Smith. The configurations in one terminal was made by Jones instead. The 
environment item prep_name would then be given the assigned text Smith with sco
Project. This can be done anywhere in the project. The other name must be assig
from the specific terminal. You open one work sheet in the terminal and activate P
Layout in the File menu. Select Environment Setup, modify the assigned text to J
and change the scope to Work sheet.

!
Note!
It is very important from where you open the page layout and where you activate the 
Environment Setup. You see the assigned text and the scope of the items from where 
you are. If you open the page layout or activate Environment Setup from the Project 
tree, you only see the layout and setup of the tree, not of the work sheets.

After you edit the environment items, you can insert them into the page layout.

To edit environment items:

1 Select the Environment items icon on the toolbar. 
The pointer symbol becomes a T.

2 Position the pointer in a field, where you want to 
insert the environment item. The Settings Environ-
ment Text dialogue box appears.
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Fig. 59 Settings Environment Text dialogue box.

Fig. 60 The Environment Setting dialogue box.

1 Select the button <Config...> and the Envi-
ronment Setting dialogue box in Fig. 60 
appears.
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8 To add a new item:

Fig. 61 The Settings Environment Text dialogue box with the new item.

8 To change items:

Note that system items can only be changed with the Copy function.

1 Select the <Add> button to activate the row above the list 
box.

2 Type User name in the Variable field.

3 Type Smith in the Assigned Text field.

4 Change the ‘Scope of the Item’ to ‘All projects’.

5 Select <OK>, and the Settings Environment Text appears and 
the new item is displayed in the list box. Fig. 61 

1 Select the item that you want to change from the ‘Environ-
ment items’ list box.

2 Select the <Modify> button, and the cursor is displayed in the 
‘Assigned text’ field.

3 Type an Assigned text or change the text.

4 Change the scope if necessary.

5 Select <OK> and the item is changed.
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Pre-
To add items that are similar to existing ones, or to change a system item:

The assigned text of the environment item can be seen at print-out and with the ‘
view’ function. See the Print chapter for more information.

1 Select the environment item that you want to change from the 
list box.

2 Select the <Copy> button, and the contents of the selected 
item will be copied into the Variable and Assigned text fields.

3 Type a new Variable for the item.

4 Type a new Assigned text for the item if desired.

5 Change the ‘Scope of the Item’ if desired.

6 Select <OK>.
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20 Finish the Page Layout work

20.1 Save page layouts

Regularly save your work when working with the page layout so that you do not lose 
data if a power failure occurs.

Assume that you want to save the untitled page layout with the name sample.

To save page layout changes:

20.2 Exit from the page layout 

Close the page layout when you finish working with the page layout. A dialogue box 
prompts you to save or discard your changes.

To exit from the page layout:

Fig. 62 The CAP 531 page layout dialogue box.

1 Select ‘Save As...’ in the File menu, and the Save As 
dialogue box appears.

2 Type sample in the file name field.

3 Select <Save As>.

1 Select ‘Close’ or ‘Close All’ in the File menu. If you have 
not saved the page layout, the dialogue box in 
Fig. 62 appears.
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21 Print

It is possible to print:

• the project structure.

• all work sheets in a terminal.

• one work sheet.

• one page of a work sheet.

In all cases, it uses the page layout assigned to the work sheet or the project tree
can be verified with the ‘Preview’ command in the File menu.

The paper orientation is set in the ‘Print Setup’ command in the File menu. The p
size and orientation is also affected of the settings in the Page Layout. This is se
the ‘Paper Orientation’ command in the Layout menu.

21.1 Print work sheets

To print all pages in a work sheet:

To print one page in a work sheet:

21.2 Print a terminal

You can print all work sheets in one terminal. It is possible choose if the pages nu
bers should run consecutively in all work sheets or if each work sheet should hav
own numbering.

1 Ensure that the work sheet is in the active window.

2 Select the ‘Print’ command from the File menu.

3 Select <Yes> if you want the cross references to be 
printed.

1 Ensure that the work sheet is in the active window.

2 Select the ‘Preview’ command from the File menu.

3 Select ‘Cross References’ if you want cross references to 
other pages.

4 Use the ‘Next’ button to select page.

5 Press the ‘Print Page’ button and the page is printed.
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To print a terminal:

21.3 Print the project tree

You can print the project structure.

To print the project tree:

22 Exit CAP 531

You can exit from CAP 531 at any time. You do not need to close the windows. 

If you do not save your changes, a dialogue box prompts you to either save the changes 
or close the windows without saving.

To exit, save your work and then select the:

• ‘Exit’ menu item on the File menu.
The dialogue box CAP 531: Exit appears.

1 Select the terminal in the project tree.

2 Select the ‘Print terminal’ command in the File menu.

3 Select if ‘Scope of Page numbering’ should be ‘terminal’ 
or ‘work sheet’.

4 Select ‘Cross References’ if you want cross references 
between the pages.

5 Select <OK> and the terminal is printed.

1 Ensure that the project tree is in the active window.

2 Select the ‘Print’ command in the File menu, and the 
project tree is printed.
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The chapter "Technical descriptions".
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General Information

This chapter describes the CAP 531 program group, the CAP 531 interface and its dif-
ferent views.

1 The CAP 531 icons

After you install CAP 531, the icons in the new program group are displayed as in 
Fig. 1

Fig. 1 The CAP 531 Program group.

Icon Description

CAP 531 Starts CAP 531.

CAP 531 Readme Provides updates on changes since the last version and 
describes new features. Also describes how to use pre-
vious projects in the new version of CAP 531.

Copy CAP module from 
SMS

Used if you have previously installed CAP/REx 5xx mod-
ules. With this function you can reuse them in CAP 531 
Ver 1.3.

Help for CAP 531 Activates the general help.

Uninstall CAP 531 Used for removing the program from the computer.
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2 The CAP 531 interface

As shown in Fig. 2, the CAP 531 interface consists of these parts:

• Menu bar

• Toolbar

• Main screen

• Status bar

Fig. 2 User interface of CAP 531.

Menu bar

Toolbar

Main screen

Status bar
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2.1 Menu bar

The menu bar contains these menus:

The available menus and commands differ depending on the selected level in the 
project tree and also depending on the present view. The context-sensitive help 
explains exactly where different menus are available.

2.2 Toolbar

Click on the toolbar icons to quickly execute frequently used commands rather than 
selecting menus and commands from the menu bar. The toolbar is located below the 
menu bar. 

The general part is always there while some of the icons from the specific part differs 
for every view. The context-sensitive help displays the name of each icon.

Fig. 3 The different toolbars in CAP 531.

Menu Usage examples

File Manage and save all your work. Access the page layout of the view. Pre-
view and print a document. 

Edit Edit your project. Cut, copy, paste, and select objects. Open the Func-
tion Selector.

Object Insert objects that you can work with in the project tree, work sheet or 
page layout.

Layout Design your screen. Add page borders or insert a grid to better align 
objects in your work sheets.

Make Start project compilation and other functions after your configuration 
work.

On-line Upload and download commands. Enable debug mode.

Window Arrange the windows and icons on your screen.

Help Activate the on-line help.

The project tree toolbar

The work sheet toolbar

The page layout toolbar

Specific partGeneral part
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2.3 Status bar

When you work with CAP 531, the status bar displays different information in differ-
ent fields on the status bar:

Fig. 4 Status bar.

Information Mouse position Available RAM

Main information messages Messages for start-up process
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3 CAP 531 views

CAP 531 comprise these views:

3.1 Project Tree 

The project tree can have these levels:

• Project (always top level)

• Organization

• Station

• Bay

• Terminal

• Work Sheet

In the project tree, you can freely build up the structure and select the number of
els. From the project tree menu bar and toolbar, you can insert items and edit the
project tree, copy work sheets and copy terminals, and use find and global find.

If the terminal icon has a red cross, then CAP/REx 5xx is not installed, or the term
type has no relevance in CAP 531. So you cannot work on terminal type.

3.2 Work Sheet

The configuration work is done in work sheets. All functions in the terminal are 
entered in the work sheet as function blocks. All internal logical interconnections 
between the functions are drawn as lines between the function blocks.

From the work sheet menu bar and toolbar, you can perform actions, such as cu
paste, and find and replace to quickly create configurations.

You can debug the configuration in the work sheet. This is an on-line function tha
plays all signal levels of all internal signals in a terminal with different colours of t
lines in the work sheet.

View Used to...

Project tree Build up projects, organize terminals and work sheets. 

Work sheet Create the configuration, use debug at commission-
ing.

Page layout Create drawing forms for printed pages.
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3.3 Page Layout

The page layout is the drawing form of the configuration drawings. Use the page lay-
out to adjust the drawing format of the work sheet pages that you print. For example, 
you can adapt the header and footer, you can insert order number, terminal type, 
names, the printing date and time, or bitmap files.

You can also create different sets of objects (environment variables) that are used by a 
specific project or user. You use environment variables to assure that correct informa-
tion is printed on all pages in the project. They are also used to avoid the work to type 
the same information on the page layout for each work sheet.

From the page layout menu bar and toolbar, you can perform actions, such as cut and 
paste and find and replace. The Preview command on the File menu lets you view the 
results of your work before you print it.

You can assign a page layout to a project tree or a work sheet. 
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This chapter describes the project tree functionality and how to select functions, 
update versions, compile terminals, compare configurations and work on-line.

4 Icons in the Project Tree

The project structure is displayed as a tree, see Fig. 5. When you work with a project, 
the project tree is always open.

Icons within the project tree indicate the corresponding project tree levels, which are:

• Project (always top level)

• Organization

• Station

• Bay

• Terminal

• Work Sheet

The usage of these icons are freely programmable with the ‘Insert’ command in t
Edit menu. It is hence possible to insert the terminals directly inside the project ic

.

Fig. 5 An example of a structure in the project tree.
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4.1 Level Icons

Icon Icon name This icon represents...

Project The project. This is always included in a new project.
To display or hide the lower levels, double-click left 
mouse button on the icon.

Organization The organization, such as the company or the region. 

Station The station where the terminals to be configured are sit-
uated.

Bay The bay. To obtain a structure over the project that is 
easier to read, you can divide the stations into bays. 
You can in this way organize the terminal into the bay 
where they are allocated.

Terminal The terminal. The same icon is used for all types of ter-
minals. It is therefore necessary to type the terminal 
type in the name.

Work Sheet The work sheet. The configuration of a terminal is 
always done in a work sheet, organized inside the ter-
minal in the structure. The work sheet name is dis-
played beside this icon.
To edit a work sheet, double-click left mouse button on 
the icon.

No terminal No terminal. The correct terminal library is not installed 
for the corresponding terminal.
Install the correct CAP/REx5xx.

Project not com-
plete

A project tree imported from SMS is not complete. 

Undefined The level is not defined.
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4.2 Information Icons

Icon Indicates that...

All lower levels are visible.
To hide all lower levels, double-click left mouse button on the icon.

All lower levels are hidden.
To display all lower levels, double-click left mouse button on the icon.

There are no lower levels.

The asterisk appears at the terminal name and the work sheet name. 
Changes in the current work sheet are not compiled.
Compile the terminal and the asterisk (*) will disappear.
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5 Toolbar and Menu Bar

5.1 Toolbar

The toolbar contains icons that you use to get quick access to frequently used actions. 
You can also use the menus or shortcut keys.

The icons on the toolbar are explained in the Menu Bar chapter.

Call the Project Tree)

Compile Terminal

Zoom out

Zoom in

Delete
Insert

Show all lower levels
Cut

Copy
Paste

 Find

 Find and Replace
Global Find

Global Find 
and Replace
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5.2 Menu Bar

5.2.1 File Menu

Menu item Icon Short-cut 
key

Select this command to...

New Project Create a new project. The new project is called 
“Untitled” until it is saved with a name.

Open Project Open an existing project. This project can be 
stored on any partition in the computer system.

Import SMS 
Project

Import a project structure that is created in SMS-
BASE. Once imported, the structure can be 
edited and stored in CAP 531. The edited struc-
ture can not be seen from SMS-BASE or re-
exported to SMS-BASE.

Close Project <CTRL> + 
<F4>

Close a project. The project structure is stored 
automatically during the work.

Delete 
Project

Delete a stored project. Only closed projects can 
be deleted.

Compress 
Project

Store an entire project with its work sheets and 
page layouts in a single file. 

Decompress 
Project

Open a compressed project. Makes it possible to 
move an entire project with its work sheets from 
one computer to another with a diskette. 

Passwords Change or insert password for user’s with a 
lower access level to the project.

Page 
Layout

Open Page Layout shows the Page layout of the 
project tree. Use this to design a drawing form for 
the tree. 
Environment Setup lets you change, for exam-
ple, the date, company name, document number.

Preview Start the page preview function, which shows 
you how the pages will look like when they are 
printed.

Print <CTRL> + 
<P>

Print the project tree with the page layout for the 
tree.

Print 
Terminal

Print all work sheets in an entire terminal.

Printer Setup Switch to another printer or select a different for-
mat. CAP 531 supports all printer setups in the 
Windows Program Manager. CAP 531 page lay-
outs are based on the A4 size. So the results 
may be distorted if you use a printer with another 
format.

Exit <ALT> + 
<F4>

Quit CAP 531. After your selection, the standard 
CAP 531 Exit dialogue appears.
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5.2.2 Edit Menu

Menu item Icon Short-cut key Select this command to...

Delete <DELETE> Delete an item in the project tree. 
Note ! Every item inside (to the right of) the 
current item will also be deleted.

Insert <INSERT> Insert an item in the project tree.

Cut <CTRL> + <X> Cut all selected objects from the project tree 
and move them to the clipboard.

Copy <CTRL> + 
<C>

Copy all selected objects to the clipboard. 

Paste <CTRL> + <V> Paste objects from the clipboard into the 
project tree.

Generate Tem-
plate

Save the contents of an entire terminal con-
figuration. This lets you reuse the configura-
tion on other computers.

Insert 
Template

Insert the contents of an entire terminal con-
figuration, which you saved with the Gener-
ate Template command.

Find Search for a name or a character in an item 
name in the project tree. 

Find and 
Replace

Search for a name or a character in an item 
name in the project tree and replace it.

Global Find Search for a name or a character in any 
work sheet in the selected terminal.

Global Find 
and Replace

Search for a name or a character in any 
work sheet in the selected terminal and 
replace it.

Function 
Selector

Start the Function Selector

Terminal 
Options

Import a list of functions available in a cer-
tain terminal. The information is supplied on 
a diskette from ABB Network Partner.

Object Proper-
ties

<ALT> + 
<ENTER >

Change name and other properties of the 
selected item in the project tree.
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5.2.3 Layout Menu

5.2.4 Make Menu

Menu item Icon Short-cut 
key

Select this command to...

Toolbar Hide or display the toolbar. If this menu item 
is checked, then the toolbar is displayed. 

Status bar Hide or display the status bar. If checked, the 
status bar is displayed.

Zoom in Num < + > Increase the scale of the active window.

Zoom out Num < - > Decrease the scale of the active window.

Previous View Num < / >
or
Num < ÷ >

Switch to the previous view.

Default Size Num < * > Switch to the default size from an increased 
or decreased size so that the project tree is 
displayed in the default size.

Redraw <F3> Rebuild the content of the active window on 
the screen.

Expand Sub-
tree

<#> Hide or display the sub-tree. If checked, the 
sub-tree is displayed. 

Menu item Icon Short-cut 
key

Select this command to...

Compile All Compile an entire project, which means that 
you compile all terminals in the entire project. 
Normally, this is not used.

Compile Termi-
nal

Compile the selected terminal. 

Update Version Update the selected terminal’s library. The 
library’s contents will be reorganized to 
account for the new set of function blocks 
that can be used in the terminal.

Detect Warn-
ings

Display or hide warnings in the error list.
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5.2.5 On-line Menu

5.2.6 Window Menu

Menu item Icon Short-cut 
key

Select this command to...

Upload Options Upload the table of functions from the termi-
nal. This table of functions file includes all 
information about available functions in the 
terminal. 

Download Con-
figuration

Download the graphical configuration in CAP 
531 to the terminal.

Upload Config-
uration

Upload the graphical configuration to CAP 
531 from the terminal. This function is not 
always supported by the terminal. This 
depends on the type of terminal.

Compare Con-
figurations

View differences between the terminal con-
figuration and the graphical configuration in 
CAP 531.

Setup Change the communication setup to prepare 
for work on-line with the terminal.

Menu item Icon Short-cut 
key

Select this command to...

Tile Arrange all open windows side by side.

Cascade Arrange the windows so that they overlap 
(starting in the upper-left corner of the 
CAP 531 window). The title bar of each 
window remains visible.

Arrange Symbols Arrange the icons that are created if you 
minimize the windows.

Window list Switch to a different open window. Select 
the window name that you want to be 
active.

Error List View the error list if it is hidden. You can 
only show it if errors or warnings were 
detected.
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5.2.7 Help Menu

5.3 Other Short-Cut Keys

You can perform general actions by using shortcut keys and key combinations.

Menu item Icon Short-cut 
key

Select this command to...

Contents Open the Table of Contents of CAP 531 
help.

Index Open the Index of CAP 531 help.

Current Object Obtain help on a selected object.

Current 
Window

Provide help on the active window.

About CAP 531 Read information about CAP 531 such as 
version number and copyright information.

To Press

Access help <F1>

Exit CAP 531 <ALT> + <F4>

Go to parent/child level <Ç> or <È> keys

Move up/down in the tree <É> or <Ê> keys

Move to items on the same level <CTRL> + <É> or <Ê> keys
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6 The Project Tree Functions

6.1 Project Structure

You build up the project structure directly in the program, or you import a structure 
from SMS.

The project tree can consist of different items. These items can be:

• Organization

• Station

• Bay

• Terminal

• Work Sheet

These items are freely programmable. The only limitation is that work sheets can
be placed inside a terminal. Otherwise the user can freely build up the structure. 
terminal types that can be selected can be found in a list of terminals in the Inser
logue box.

6.2 Password handling

It is possible to set the access right to a project so that it is possible to restrict the 
to change the configuration of a project. The access level in the object properties
related to the password handling.

If a user has a certain access level, it is possible to access the items with the sam
access level or higher.

The access levels can be separated with different access to the system rights co
ing:

• Change Project

• Download Project

• Debug On-line

• Add/Change Password

In general, the password access levels are set so that a user with an access level
has access to all items with a higher access level. If a user only has an access le
to 10, this person can only access the items with access level 10 or higher. So the
the value, the more rights.
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All projects are password protected. A new project always has password ‘NEW’. 
then up to the creator of the project to change this password and to build up mor
access levels for other types of users that should not have the same access right
entire project as the person who created the project.

It is possible to set different access level to different work sheets. It is also possib
set a separate access level to the terminal other than the work sheets in the term

Example 1:

A terminal is given access level 5. The terminal has two work sheets, WS1 and 
WS2.The access level of WS1 is set to 1, and the access level of WS2 is set to 5
system rights are set equal for the two users.

Now if a user has access level set to 5 (linked to the password), the user can cha

• Terminal name.

• Page layout of the entire terminal with all its work sheets.

• Configuration in WS2.

• Access level for the terminal or WS2 to a higher value than 5.

But the user don‘t have any change possibilities (read-only) in WS1.

The user with access level set to 1 has all the possibilities above, but is also allow
make changes in WS1.

Example 2:

A terminal is given access level 1. The terminal has two work sheets, WS1 and W
The access levels of the work sheets are set to the same as in the previous exam
WS1 set to 1, WS2 set to 5. All system rights are set equal for the two users.

Now if a user has access level set to 5, the user can change:

• Configuration in WS2.

• Access level for WS2 to a higher value than 5.

• Page layout for WS2.

But the user don‘t have any change possibility when it comes to terminal name, p
layout for the terminal, nor any change possibilities in WS1.
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6.3 Import SMS Project

It is possible to import a project tree structure from SMS, so that the structure from 
SMS can be reused in CAP 531. It is possible to change the imported structure in CAP 
531. Once imported, it cannot be re-exported back to SMS. 

When you import a project from SMS, necessary information is stored in a file called 
‘global.cnf’. This is a file that is used by SMS and is found in the SMS file structure
SMS is stored at C:\SMS, then the ‘global.cnf’ file can be found at C:\SMS\BASE

6.4 Compress and Decompress Project

A complete project can be compressed, so that it can easily be stored on a diske
This is a useful tool if a project is to move from one PC to another. When a projec
compressed into a file, also the page layout is included.

6.5 Insert Items

Use this function to insert an item in the project tree.

To insert an item, you activate the ‘Insert’ command in the Edit menu.

This dialogue box appears when you insert an item.

6.6 Cut, Copy and Paste

It is possible to use Cut, Copy and Paste terminals and work sheets in the projec
The items that are pasted into the tree are always placed below the marked item

Table 1: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Name Specifies a name for the item. You can only use characters that 
are allowed in MS-DOS. A name can have up to 50 characters.

Type Specifies the type of item. The item can be of different types, 
shown with different icons: Organization, Station, Bay, Terminal 
or Work Sheet.

Terminal Type Specifies the type of terminal. This is active only if a terminal is 
selected.

Print options... Starts the Print Options dialogue box.

Mode Specifies if the new item will be inserted above, below or inside 
the current item.
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6.7 Delete Items

Use this function to delete items in the project tree.

To delete, select the:

1 Item that you want to delete.

2 ‘Delete’ command, and the delete dialogue box will appear.

Note !
Every item inside (to the right of) the deleted item will also be deleted.

6.8 Insert Template

Use this function to insert an entire terminal configuration. 

This configuration can be:

• an example configuration.

• a standard configuration already prepared.

• a configuration coming from another project or another terminal within the 
project. 

The example configuration is in some cases delivered with the CAP/REx module
example configuration is similar to the standard factory configuration of the termi
Note that there might be differences between the configuration of a certain termin
and the example configuration delivered with the CAP/REx module. 

When a standard configuration is prepared, you save it with the ‘Generate Templ
command.
1051MRK 511 056-UEN * 1.3-00



ABB Network Partner The Project Tree Functions

Project Tree

Technical descriptions

thout 
6.8.1 How to insert a template:

1 Select a terminal.

2 Select the ‘Insert Template’ menu item, and the Insert Template dialogue box 
appears.

!
Note !
To activate the ‘Insert Template’ menu item you must select an empty terminal wi
work sheets.

6.9 Generate Template

Use this function to save an entire terminal configuration. This lets you reuse the con-
figuration in other projects. It is also possible to create a standard configuration for a 
certain type of terminal that can be used as a base for further configuration adaptations 
to the specific application.

to generate a template:

1 Select a terminal in the project tree.

2 Select the ‘Generate Template’ command in the Edit menu, and the Generate 
Template dialogue box appears.

Table 2: Use this dialog to select a stored terminal template.

Field, button, or 
checkbox

Description

Terminal type Specifies the terminal.

Templates Specifies the terminal template.

Description Displays the comment for the template.
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6.10 Change the Object Properties

Properties of an object implies more information about the object. 

This can be:

• Name of a work sheet

• Printing information

• Type of terminal

• Access level

To change the properties for an object you can:

• Double-click the right mouse button on the desired object.

• Select the object and then select the ‘Object Properties‘ in the Edit menu.

• Select the object and then press <ALT> + < ENTER>.

The Object Properties dialogue box will then appear.

Table 3: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Terminal type Specifies the type of terminal to copy the template to. 
The default type is recommended.

Template name Specifies the name of the template.

Description Gives a description of the template. This description is 
displayed in the Insert Template dialog box.

Table 4: The fields in the Object Properties dialogue box

Field, button, or 
checkbox

Description

Name Specifies the name of your object.

Print Options... Opens the Print Options dialogue box, where the page layout 
is associated.

Access level The access level for the object. The access level is related 
with the password.
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7 Function Selector 

With the Function Selector tool you can adapt parts of the library of function blocks in 
the program to match the functions in the terminal. For some functions, the function 
block will have different shape depending on the selected options in the terminal.

7.1 Select functions and options

When you start to work with the configuration of a terminal, it is important that you 
use the correct set of functions. This is done by running:

1 Upload Options

2 Function Selector 

If the terminal is available, you should connect the PC to the terminal and run Upload 
Options. This function reads the function library of the terminal. After running Upload 
Options, the function library in the PC will match the library of the terminal when it 
comes to most of the functions. The rest of the functions will be updated with the 
Function Selector tool, where you can select to use data read from the terminal (during 
Upload Options) as input.

If the terminal is not available, you run Function Selector.

!
Note !
Not all types of terminals use function selectors. For these terminals, it is enough to 
run Upload Options in order to obtain a function library that matches the one in the 
terminal.

Use the function selector tool before you start configuration of the terminal.

Function selectors are used to choose one of many possible function blocks for the 
same function. This is for instance the case when it comes to input/output modules. 
The I/O module at a certain slot in the terminal can be of different types. The different 
types of I/O modules corresponds to different types of function blocks.
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7.2 Change the function selectors

Input data to the function selector tool can be:

• Working data — last saved data for this terminal

• Uploaded data — comes from the terminal at Upload Options

• Default data — presented the first time for each terminal

When the CAP 531 is opened, the default data on the terminal are shown as wor
data. The CAP/REx 5xx specifies the default data for the corresponding terminal 
Default and working data are equivalent before the working data is changed. Uplo
data consists of the terminal function selectors. Uploaded data is available after y
run Upload Options with the terminal connected on-line.

7.3 Menu Bar in Function Selector tool

7.3.1 File Menu

7.3.2 Edit Menu

Menu item Select this command to...

Load Import other function selector data than the displayed ones in 
the Function Selector tool.

You can select between:
- Working Data.
- Uploaded Data.
- Default Data.

• Working Data will present the latest stored function selec-
tors for this terminal.

• Uploaded Data will present the function selectors uploaded 
from the terminal at Upload Options.

• Default Data will present the default function selectors that 
are included in the CAP/REx 5xx corresponding to the ter-
minal.

Save Save the function selectors settings. The same function as the 
Save button.

Exit Quit the Function Selector tool.

Menu item Select this command to...

Undo Undo your last action.
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8 Update Version

8.1 Changes in the Function Library

If the version or the contents of the function library change, either in CAP 531 or the 
terminal, you have to run ‘Update Version’.

Examples of situations when the library changes:

• You install a new CAP/REx 5xx version.

• You run the ‘Function Selector’ tool and change data.

• You insert a template into the terminal.

• You run ‘Upload Options’ and a new set of functions are uploaded.

In most cases, ‘Update Version’ runs automatically by CAP 531. But in some cas
you must run ‘Update Version’ manually. This is mainly when a new CAP/REx 5x
version is installed. If you need to run ‘Update Version’, a message is displayed.

8.2 Update Version

A REx 5xx terminal has several options defining which functions will be available 
specific terminal. By default, a CAP/REx 5xx contains the complete set of functio
basic and optional, of a REx 5xx terminal. To match the function library with the fu
tion library in a certain terminal you must upload the terminal options. 

8 To update versions manually:

After ‘Update Version’ is executed, you might get an error list that indicates that so
function blocks were changed. 

Fig. 6 Example of an error list that contains errors that occurred after Update 
Version is run.

1 Click on the terminal in the Project Tree to 
select it.

2 Select ‘Update Version’ in the Make menu.
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Go through the list by double-clicking on each of the errors. The program will open the 
work sheet and indicate the parameter or the function block involved.

Run ‘Update Version’ again after you correct the errors. The library is updated if n
errors occur during the update.

Fig. 7 Confirmation box, updating was successful.
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9 Compilation

9.1 The Compilation Process

To compile means to translate and transform work sheet contents into special code that 
the terminal can read. To link means to create connections among the work sheets and 
to store the results, which you download to the terminal.

In CAP 531, you can compile:

• One terminal

• The entire project — normally not recommended

The linking will in both cases be done automatically after the compilation. We rec
mend you to compile only one terminal at a time during the configuration work. T
gives a better overview of the compilation errors.

Compilation occurs in several stages:

1 Different work sheets are compiled.

2 The compiled work sheets are linked.

3 The terminal code is generated.

9.1.1 Compile a terminal

You must compile the terminal if one or more work sheets in the terminal have 
changed. This is normally marked with a star at the work sheet name.

‘Compile Terminal’ Command:

1 Select the terminal you want to compile in the project tree.

2 Select the ‘Compile Terminal’ command in the Make menu.

Table 5: These principles apply during compilation:

If... Then...

You select ‘Compile All’ All terminals in the project are compiled. This is 
normally not recommended since the error list 
includes all errors from all terminals.

You select ‘Compile Terminal’ The specific terminal is compiled.

CAP 531 detects an error in the 
configuration or other external 
problem

Compilation stops, and the error list is displayed. 
Use this list to locate and correct errors.
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9.1.2 Correct Errors with the Error List

Compilation stops and the error list with messages is displayed if:

• The compiler encounters programming, memory, or file errors.

• Compilation process is aborted by user.

All errors are linked to context-sensitive help. Select an error from the error list, p
<F1>, and the help topic is displayed with an explanation of the error and differen
possible solutions to correct it.

To find and correct errors in the configuration after compilation:

1 Double-click left mouse button on the error in the error list, the work sheet 
containing the error will be opened and the error is highlighted.

2 Correct the error and repeat until all errors are corrected.

3 Compile again to see if any new errors are detected.

4 Repeat until the compilation gives the text ‘Code generated successfully’ at 
the status bar after compilation.

The error list is always available in the Windows menu. The switch ‘Detect Warnin
in the Make menu is normally switched off. When all errors are detected, it is rec
mended to switch on ‘Detect Warnings‘ and run a new compilation. The error list 
now also include the warnings.

9.1.3 Common errors

Common error messages from the compilation process are:

!
Note !
If the compilation error comes from a misprint or a forgotten variable, it is always the 
input connection that is marked in the error list. The misprint might however have 
occurred either on the input or on the corresponding output connection.

Error message You should ...

Input parameters 
not connected

Connect the input to an output or to a fixed signal, such as True 
or False (1 or 0) defined as output variables from the function 
block Fixed Signals

Variables not con-
nected

Type the correct name either for the input variable marked by 
the error list or the output variable that is to be connected to the 
input variable. 
The linker cannot find the output variable for this input.
The output variable might be misprinted or forgotten.
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10 On-line tasks

10.1 Introduction

CAP 531 lets you:

• Download the configuration to a specific terminal.

• Upload the terminal library contents, including information of the terminal 
library version and available functions in the terminal.

• Debug the configuration.

All on-line functions requires a PC connected to a terminal. This is done via the s
COM-port of the PC. You connect to either the front port or a rear SPA-port of the
minal.

10.2 Communication Setup

Before any communication with a terminal can start, the setup must be correct. T
done with ‘Setup‘ in the On-line menu. The most important parts of the setup tha
user must check are:

• Baud Rate

• Slave Number

These parameters must be set in both the CAP program and in the terminal, and
must be identical. If they are different in the CAP program and in the terminal, the
will be no communication.

The user selects if the PC will be using the front or the rear port of the terminal b
ting the Flow Control parameter to ‘RTS-Idle’ (for front port) or ‘None’ (for rear por
The default setting is adapted to front communication.

It is possible to make a simple test of the communication with the ‘Send Signal’ fu
tion. This is a SPA emulator for the communication with the terminal. The easiest 
to use this function is to:

1 Select ‘Send Signal’.

2 Type ‘RF’ in the ‘Message to send’ window.

3 Press <Send>.

If the communication works as it should, the ‘Messages Received’ window will sh
the sent out signal to the left, and the reply from the terminal to the right. The rep
from the terminal will be its type designation (e.g. REL511).

If the communication doesn‘t work, the slave message will be ‘Time Out’.
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10.3 Upload Options and Function Selectors from a Terminal

To prevent the use of function blocks in CAP 531 that are not available in the terminal, 
you can upload the a list of installed functions, and the function selectors from the ter-
minal.

To upload the list of installed functions and the function selectors from a terminal:

1 Select a terminal in the Project Tree.

2 Select the ‘Upload Options’ command in the On-line menu, and the upload 
will start.

Upload Procedure:

1 The list of functions and the terminal version number are uploaded from the 
terminal.

2 CAP 531 checks if the version number is the same as in the configuration.

3 If the version numbers don’t match, a dialogue box informs you about the dif-
ferences, waits for acknowledgment, and then checks if the contents are the 
same.

4 If the contents match, you are told this, and nothing further happens.

5 If the contents don’t match, then a message box appears asking you if you 
want to replace the list of functions in CAP 531.

6 Update Version starts automatically.

If functions are included in a work sheet that are not available in the terminal, an error 
list appears.

10.4 Download Configuration to a Terminal

After compilation the configuration can be downloaded to the terminal.

To download the new configuration to the terminal:

1 Select a terminal in the Project Tree.

2 Select the ‘Download Configuration’ command in the On-line menu.

Download Procedure:
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1 The list of functions and terminal version are uploaded from the terminal.

2 CAP 531 checks if the version number and the contents of the list of func-
tions are the same as in the configuration. It is also checked if the serial 
number of the terminal is the same as during the last downloading of this ter-
minal in the project tree.

3 If they match, then the download starts.

4 If the list of functions differ, a warning message is displayed and the down-
load procedure should be interrupted with <Cancel>. Run ‘Upload Options’ 
first. Then you start the download procedure again, and no warning message 
will appear.

Note that the program compares the list of available functions of the terminal with 
the complete list of function blocks of the selected terminal in the project tree. The 
complete list comprise not only the function that are used in the work sheets, but 
also the function blocks that still remains unused in the selection function list.

5 Uploading of the configuration for verification purpose starts automatically.

6 If the download was unsuccessful, list of differences will appear. Then start 
the downloading process once again.

11 Compare Configurations

CAP 531 contains a tool, Compare Configurations, that is used to compare the config-
uration in CAP 531 with the configuration in the terminal. The result is a list of the dif-
ferences between the configurations. 

The terminal configuration is saved in specific files used by Compare Configurations, 
that makes it possible to check differences between the terminal and the CAP 531 con-
figuration without having to upload the terminal configuration.

To find differences between the CAP 531 configuration and the terminal configura-
tion:

1 Select a terminal in the project tree that you want to compare.

2 Select the ‘Compare Configurations’ command in the On-line menu.

3 Select ‘Upload and Compare’ if the terminal is connected, or ‘Compare’ if the 
comparison should be done off-line (if the ‘Upload and Compare’ function 
has been run earlier).

 

Menu item Select this command to...

Compare Compare the configuration.

Upload and Compare Compare the configuration after upload.

Save... Save the result of the comparison, as a text file. This 
command opens a standard Windows save dialogue 
box.
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11.1 Compare

With the Compare command you compare the CAP 531 configuration with the latest 
uploaded configuration from the terminal. During the comparison the differences will 
be displayed. The comparison can be aborted with the <Cancel> button in the 
Progress box.

After compare, the number of comparisons and differences detected are displayed in a 
message box. 

Print... Print the result of the comparison. This command 
opens a standard Windows print dialogue box.

Print Setup Setup which printer you are going to use, opens the 
Windows print setup dialogue box.

Exit Quit Configuration Compare.

Menu item Select this command to...
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11.2 Upload and Compare

With the ‘Upload and Compare’ command, the configuration from the terminal is 
uploaded to CAP 531, then the comparison starts.

Upload and Compare will not replace CAP 531 configuration files.

!
Note !
You cannot upload the graphic configuration files with this command. You only upload 
the connections between the function blocks.

If the result of the comparison seems wrong, compile the terminal and run a new com-
parison.
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Work Sheet

This chapter describes the work sheet and how to operate them. 

12 Introduction

The configuration is done in work sheets. Work sheets are working areas where you 
make your configuration. 

Fig. 8 Work sheet called MMI.

13 Normal Mode and Debug Mode

You use the Normal mode when you work with the configuration in the work sheet. 
Then you can use all commands such as insert, connect, or delete.

You use the Debug mode to test the work sheet configuration. When you finish devel-
oping the configuration, you compile it. After compilation you use the work sheet in 
debug mode to test the configuration. In debug mode it is not possible to use the nor-
mal configuration commands.

In the debug mode you can monitor the status of every connection line in the visible 
part of the work sheets. The status is shown with colours.
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14 Toolbar and Menu Bar

14.1 Toolbar

The toolbar has icons that you use to get quick access to frequently used actions. You 
can also use the menus or shortcut keys. 

The rest of the icons are explained in the Menu Bar chapter.

Icon Icon name Select this icon to...

Call the project tree Get access to the project tree.

Compile Terminal Zoom out

Zoom inCall the project tree

The specific part of the toolbar

Zoom
range

Group
Text (comment)

Function Block
Variable

Setting
Replace function block

Copy

Global Find and 
Replace

Cut

Mark Objects
Connect Objects Global Find

Find and Replace
Find

Paste

Debug
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14.2 Menu Bar

14.2.1 File Menu

Menu Item Icon Short-cut 
key

Select this command to...

Close <CTRL> + 
<F4>

Close the active work sheet.

Close All Close all work sheets that are open. 

Save All <CTRL> + 
<S>

Save your changes in all work sheets. 

Close Termi-
nal

Close all work sheets that are connected to the 
active terminal.

Save Termi-
nal

Save your changes in all work sheets that are 
connected to the active terminal.

Page Layout Open Page layout shows the Page layout of the 
work sheet. Use this to design drawing forms. 
Environment Setup lets you change, for exam-
ple, the date, company name, document num-
ber.

Preview Start the page preview function, which shows 
you what the pages will look like when they are 
printed.

Print <CTRL> + 
<P>

Print the current work sheet.

Printer Setup Switch to another printer or select a different for-
mat. CAP 531 supports all printer setups in the 
Windows Program Manager. CAP 531 page lay-
outs are based on the A4 size. So the results 
may be distorted if you use a printer with another 
format.

Exit <ALT> + 
<F4>

Quit CAP 531. After your selection, the standard 
CAP 531 Exit dialogue appears.
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14.2.2 Edit Menu

Menu Item Icon Short-cut 
key

Select this command to...

Undo <CTRL>+ 
<Z>

Undo the last action that you performed.

Cut <CTRL> + 
<X>

Cut all selected objects from the work sheet 
and move them to the clipboard.

Copy <CTRL> + 
<C>

Copy all selected objects to the clipboard. 

Paste and 
Replace

<CTRL> + 
<V>

Paste objects from the clipboard into the work 
sheet.

Delete <DELETE> Delete an object in the work sheet. 

Copy To Save the content of the work sheet or a group 
as a file.

Insert From Insert the contents of a work sheet or a group 
which you have saved with the Copy To com-
mand.

Clear Work 
Sheet

Clear the contents of the work sheet.

Find Search for text string or a character in the 
active work sheet. 

Find and 
Replace

Search for text string or a character in the 
active work sheet, and replace it.

Global Find Search for text string or a character in all work 
sheets connected to the selected terminal.

Global Find 
and 
Replace...

Search for text string or a character in all work 
sheets connected to the selected terminal and 
replace it.

Mark All 
Objects

<F5> Select all objects in the work sheet.
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14.2.3 Object Menu

Mark Object <CTRL> + 
<M> or 
<ESC>

Switch to Mark Object Mode, which you use to 
select objects and mark inserting points in the 
work sheet. When you select this button, the 
cursor appears in its normal shape.

Connect 
Objects

<CTRL> + 
<L>

Switch to Connection Mode. Use this mode to 
connect objects. When you select this, the cur-
sor turns into the connection symbol.

Group <CTRL> + 
<G>

Switch to Group Mode. Use this mode to create 
a frame around objects. When you select this 
mode, the cursor turns into the group symbol.

Object Prop-
erties...

Double-click 
on the right 
mouse button

Start the properties dialog box for the selected 
object. Different dialog boxes appears depend-
ing on the type of object.

Replace 
Function 
Block...

Replace the selected function block with a new 
function block.

Menu Item Icon Short-cut 
key

Select this command to...

Menu Item Icon Short-cut 
key

Select this command to...

Function 
Block

<F> Insert a new function block into the work sheet.

Variable <V> Insert a variable.

Setting <P> Insert a setting onto a function block.

Text (Com-
ment)

<T> Insert comments in the work sheet.
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14.2.4 Layout Menu

14.2.5 Make Menu

Menu Item Icon Short-cut 
key

Select this command to...

Toolbar Hide or display the toolbar. If checked, then 
the toolbar is displayed.

Status bar Hide or display the status bar. If checked, 
the status bar is displayed. 

WS Size Change the number of pages in the work 
sheet.

Zoom Range Select an area on the screen to see details 
more clearly. 

Zoom In Num <+> Increase the scale of the active window.

Zoom Out Num < - > Decrease the scale of the active window.

Previous View Num < / >
or
Num <÷>

Switch to the previous view.

Default Size Num < * > Switch to the default size from an increased 
or decreased size so that the work sheet is 
displayed in the default size.

Redraw <F3> Rebuild the content of the active window on 
the screen.

Grid <F4> Create a grid in the work sheet. The grid can 
help you align objects more accurately. 

Page Borders <F6> Show the page borders, which are repre-
sented by blue dotted lines. The source area 
in the page layout defines the size of the 
page borders.
If you did not specify a special page layout 
for the work sheet from the Print options dia-
log box in the project tree, then the default 
page layout is used for the page borders.

Menu Item Icon Short-cut 
key

Select this command to...

Detect Warn-
ings

Display or hide warnings in the error list.
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14.2.6 On-line Menu

14.2.7 Window Menu

14.2.7.1 Help Menu

Menu Item Icon Short-cut 
key

Select this command to...

Debug on

Debug off

Switch debug mode on and off for the active 
work sheet. Note ! The ‘Global Debug’ com-
mand in the On-line menu must be active to 
enable any debug function.

Global Debug Switch on/off the possibility to set any work 
sheet in the entire project in debug mode. 

Menu item Icon Short-cut 
key

Select this command to...

Tile Arrange all open windows side by side.

Cascade Arrange the windows so that they overlap 
(starting in the upper-left corner of the 
CAP 531 window). The title bar of each 
window remains visible.

Arrange Symbols Arrange the icons that are created if you 
minimize the windows.

Error List View the error list if it is hidden. You can 
only show it if warnings or errors were 
detected.

Window list Switch to a different open window. Select 
the window name that you want to be 
active.

Menu item Icon Short-cut 
key

Select this command to...

Contents Open the Table of Contents of the CAP 
531 help.

Index Open the Index of the CAP 531 help.

Current Object Provide help on a selected object.

Current window Provide help on the active window.

About CAP 531 Read information about CAP 531 such as 
version number and copyright information.
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14.3 Short-Cut Keys

You can perform general actions by using shortcut keys and key combinations.

To Press

Access help <F1>

Selecting objects <SPACE>
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15 Use Work Sheets

15.1 Open a Work Sheet

You create your configuration in work sheets.

To open a work sheet:

1 Select a work sheet in the project tree.

2 Double-click the left mouse button or press < ENTER>.

All configuration is made in work sheets. You can split the configuration on several 
work sheets, where each work sheet represents one or several functions. 

15.2 Work Sheet Size

A work sheet can comprise several pages that are separated by page borders. You can 
set the size of the work sheet. A work sheet can comprise up to 12 pages (3*4) which is 
the default value.

The page size and orientation is set in the Page Layout with the ‘Paper Orientatio
command in the Layout menu.

!
Note !
We recommend you to display the page borders of the work sheet so you can see where 
you place the function blocks in the work sheet. This is important for the print-out.

If you reduce the work sheet size, so that some work sheet objects do not fit into
new size, the Check objects while changing WS size dialogue box appears.

Select this command in the 
Layout menu

To...

WS Size Set the number of pages, in height and width.

Page Border Display the page borders.
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15.3 Change Zoom Range

Use this function to select an area on the screen to see details more clearly. 

To select a zoom area:

1 Select the ‘Zoom Range’ command in the Layout menu.

2 Press and hold the left mouse button, and drag the mouse over the area to be 
zoomed. A frame is drawn over the area.

3 Release the mouse button when desired, and the area is zoomed.

You can go back with ‘Previous View‘ or ‘Default Size‘ in the Layout menu.

15.4 Clear Work Sheets

Use this function to clear the contents of a work sheet.

To clear the work sheet:

1 Select the ‘Clear Work Sheet’ command in the Edit menu, and the Clear Work 
Sheet dialogue box appears.

!
Note !
If you have cleared a work sheet, the content of the work sheet cannot be restored.

Table 6: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Delete Immediately deletes all necessary object to change the 
work sheet size.

Show Highlights the objects that have to be deleted.
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16 Objects

Function blocks, variables, settings and text comments are considered as objects in a 
work sheet.

16.1 Function Blocks

All functions in a terminal — basic and optional — are represented as function bl
in CAP 531. Both protection functions and pure logic are shown as function block

16.1.1 Insert Function Blocks

Use this function to insert a new function block into the work sheet.

To insert a function block:

1 Click in the work sheet where you want the new function block to be inserted.

2 Select the ‘Function Block’ command in the Object menu, and the Function 
Block dialogue box appears.

!
Note !
To avoid collision, position the insertion point far away from other objects.

To use this dialogue box when inserting a new function block:

Table 7: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Type Type of function block.

Instance The instance name of the function block. This name makes 
the function block unique if there are several function blocks 
of the same type.

Height Height of the function block. This is normally not changed. 
Do not set the height lower than the default one.

Formal Parameters Names and types of existing input and output parameters of 
the function block. This is only for information and cannot be 
changed.
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1 Select a function block from the ‘Type’ listbox.

2 If there are more than one function block available of the selected type, select 
a specific instance from the ‘Instance’ listbox.

3 Select a new height of the function block, or use the default one.

4 Select <OK>, and the new function block is inserted.

Note that now the selected function block (instance) no longer appears in the selection 
list. If the function block is deleted in the work sheet, it will reappear in the selection 
list.

16.1.2 Replace Function Blocks

Use this function to replace the selected function block with a new function block.

To replace the function block:

1 Select the function block in the work sheet.

2 Select the ‘Replace Function Block’ command in the Edit menu, and the 
Replace box appears.

To use this dialogue box when replacing function blocks:

1 Select a function block type from the ‘Type‘ list box.

2 Select a specific function block from the ‘Instance‘ list box, or use the default 
one.

3 Select OK, and the new function block is inserted.

Table 8: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Type Type of function block.

Instance The instance name of the function block. This name makes the 
function block unique if there are several function blocks of the 
same type.

Formal Parameters Names and types of existing input and output parameters of 
the function block. This is only for information and cannot be 
changed.
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16.2 Variables

Variables are used in a configuration for the purpose to increase the readability of the 
configuration. It is a means to connect signals between function blocks without draw-
ing lines. The connection is instead made through names. You give the output of a 
function block a user-defined name (Variable), and you give the input of another func-
tion block the same name. The CAP 531 program interprets this as a connection. The 
Variable name can consist of up to 32 characters.

With the use of Variables, it is possible to connect signals to and from function blocks 
in different work sheets, and in different pages in the same work sheet.

Another special application of Variables is the possibility to connect function block 
inputs to a fixed 1 (‘TRUE’) or a fixed 0 (‘FALSE’). This is done by using the functio
block called FixedSignals which have these signals as output connections. You g
these output connections a name, such as TRUE and FALSE. You can then reuse
fixed signals in the entire terminal as Variables.

Input and output Variables must have identical names to be considered as interco
nected by CAP 531. Therefore it is recommended to use the ‘Copy’/’Paste’ funct
when typing the variable names.

16.2.1 Insert Variables

To insert a variable:

1 Select an input or output of a function block, or click in the work sheet where 
you want the variable to be inserted.

2 Select the ‘Variable’ command in the Object menu, and the Variable dialogue 
box appears.

Table 9: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Name Name of the variable. CAP 531 recommends a name when 
you insert a new variable. You can use the recommenda-
tion or type a user-defined name of the variable.

Link If the variable is placed free in the work sheet and not 
directly to an input or an output of a function block, you 
select if the variable is to be connected to an input or an 
output.
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To use this dialogue box:

1 Type a name of the variable that you want.

2 Select Link to be input or output if necessary.

3 Select <OK>, and the variable will be inserted.

16.3 Settings

In general, no settings are done with CAP 531. There are however a few exceptions 
when it comes to settings that can be considered as close to the configuration. These 
settings are, for example, a time delay or a name. The setting parameter name is dis-
played in magenta colour on a work sheet. The program uses the magenta colour to 
highlight a setting input. Settings can be numbers or text strings.

16.3.1 Insert Settings

To insert a setting:

1 Select an input setting on the function block (with magenta colour).

2 Select the ‘Setting’ command in the Object menu, and the Parameter Settings 
dialogue box appears.

Table 10: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Name Name of the setting.

Value Setting value. 

Minimum value Lower range of allowed value.

Maximum value Higher range of allowed value.

Step Allowed step rate of the value.

Default Default value.

Description Description of the Value.
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16.4 Text (Comments)

Anywhere in a work sheet you can write free text. This improves the readability and 
the understanding of the configuration. The comments can inform the reader about 
functions and signals. It can also be used as a temporary notepad for the engineer while 
making the configuration.

You create a Text object for each line. You can choose colour and font for each Text 
object.

16.4.1 Insert Text (Comments)

To insert comments:

1 Click in the work sheet where you want the comment to be inserted.

2 Select the ‘Text (Comment)’ command in the Object menu, and the Comment 
dialogue box appears.

16.5 Delete Objects

Use this function to delete an object in the work sheet. An object can be a function 
block, a variable, a comment or a connection between function blocks.

To delete an object:

1 Select the object you want to delete.

2 Select the ‘Delete’ command, and the object will be deleted.

Table 11: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Comment Specifies the text that will be inserted. You can only insert 
one line at a time. If the text runs over several lines, you 
insert one text object for each line.

Font... Starts the Font selection dialog box, from which you can 
change the font face, size, and so on.
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If you try to delete a structure that will not result in a logical structure, the Delete Con-
trol dialogue box appears. An example is when you try to delete only one section of a 
connection line between objects.

• Select Delete, and the entire structure that must be deleted to cause a logica
assembly of objects in the work sheet will be deleted. In the example above o
connection line, the entire connection line between the objects will be delete

• Select Show, and the structure that must be deleted to cause a logical assem
objects in the work sheet will be highlighted. In the example of the connectio
line, each section of the connection line will be highlighted.

16.6 Object Properties

Under the ‘Object Properties’ item in the Edit menu, more information is available
any object in CAP 531. The Object Properties can also be accessed with double-
on the right mouse button.

Table 12: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Delete Deletes the smallest legal structure.

Show Highlights the smallest structure that will not cause any ille-
gal structure in the work sheet.
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17 Local Find and Replace

It is possible to search for text strings and objects in the project tree structure or in the 
active work sheet depending on which window is active when the function is activated. 
If the function is activated from the project tree, the entire project tree structure is 
searched. If the function is activated from a work sheet, only the active work sheet is 
searched.

17.1 Find

To search for a text string:

1 Select the ‘Find’ command in the Edit menu, and the Local Find dialogue box 
appears.

17.2 Find and Replace

Use this function to search for text string or a character and replace it.

To search and replace text:

1 Select the ‘Find and Replace’ command in the Edit menu, and the Local 
Replace dialogue box appears.

Table 13: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Find What Specifies the text string to search for.

Match Whole Word Only Requests that CAP 531 searches only for entire words. 

Match Case Requests that CAP 531 search with the case sensitive 
option, which means that bim and BIM is different.

Direction Specifies if the search should start from the top and go 
downwards, or from the bottom and go upwards in the 
work sheet.

Find Next Searches for the next occurrence of the text string.
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18 Global Find and Replace

It is possible to search for text strings and objects in all work sheets in a terminal. This 
makes it possible to search for objects such as function blocks or variables no matter if 
they are used in other work sheets.

All dialogue boxes are the same as for the Local Find and Replace function, but with 
the addition of the checkbox ‘Search Only In Marked Items’.

Table 14: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Find What Specifies the text string to search for.

Match Whole Word Only Requests that CAP 531 searches only for entire words.

Match Case Requests that CAP 531 search with the case sensitive 
option, which means that bim and BIM is different.

Replace with Specifies the new text string.

Find Next Searches for the next occurrence of the text string.

Replace Replaces the first entry.

Replace All Replaces all entries.
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19 Copy, Paste and Save

19.1 Cut Objects to the Clipboard

Use this function to cut the selected objects from the work sheet and move them to the 
clipboard.This function is accessed with the ‘Cut’ command on the Edit menu. Se
objects can be selected by dragging the mouse with the left mouse button presse

If you select objects to cut that will result in an illegal structure in the work sheet o
the clipboard, the Cut Control dialogue box appears.

19.2 Copy Objects to the Clipboard

Use this function to copy the selected objects to the clipboard. This function is 
accessed with the ‘Copy’ command on the Edit menu.

If you select objects to copy that will result in an illegal structure in the clipboard, t
the Copy Control dialogue box appears.

Table 15: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Cut Extends the highlighting to a logical assembly of objects 
and moves it to the clipboard. 

Show Cut Highlights the logical assembly of objects that will be 
deleted in the work sheet.

Show Copy Highlights the logical assembly of objects that will be cop-
ied to the clipboard.

Table 16: The fields in the dialogue box.

Field, button, or 
checkbox

Description

Copy Extend the highlighting to a logical assembly of objects and 
copies the collection to the clipboard.

Show Copy Highlights the logical assembly of objects that can be copied 
into the clipboard.
1371MRK 511 056-UEN * 1.3-00



ABB Network Partner Copy, Paste and Save

Work Sheet

Technical descriptions

 ter-
ction.

 
e that 
bjects 

 file 
19.3 Paste Objects from the Clipboard

Use this function to paste objects from the clipboard into the work sheet. This function 
is accessed with the ‘Paste and Replace’ command on the Edit menu.

If a function block already exists in the same terminal, the Replace dialogue box 
appears. For example if you try to copy a function block that only exists once in a
minal (only one instance), such as a breakerfailure protection or a fuse failure fun

19.4 Group Objects

Use this mode if you want to group a part of your work sheet, so you can use it in
another work sheet or in the same work sheet. For example if you have a structur
you want to appear in several work sheets, you draw a group frame around the o
and save it in a file to reuse it in the other work sheets. 

!
Note !
It is not possible to use a Copy - Paste function on a group.You always save the group 
in a file, and insert it again from this file.

To group objects:

1 Select the ‘Group’ command in the Edit menu, and there will be a rectangle 
added to the pointer symbol.

2 Position the pointer beside the first object.

3 Press and hold the left mouse button.

4 Drag the mouse, and a frame is displayed. The frame indicates how the group 
will look.

5 Release the mouse button, and the group dialogue box appears.

6 Type a name for the group, press <ENTER>, and the group is created.

When the group is selected, the border is black, and when it is not selected, the border 
is pink.

You can have groups with the same name in the work sheets.

To copy the group to a file you use the ‘Copy To’ command, and to insert a group
into the work sheet you use the ‘Insert From’ command.
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19.5 Copy Work Sheets to a File

Use this function to save the contents of the work sheet or a group.

With this command you create a special file that lets you, for example, create a tem-
plate for frequently used work sheets or groups.

You can only use this command when you have selected either the complete work 
sheet or a single group.

To copy the work sheet to a file:

1 Select the ‘Mark All Objects’ command in the Edit menu, or press <F5>.

2 Select the ‘Copy To...’ command in the Edit menu, and the Copy To dialogue 
box appears.

To copy the group to a file:

1 Select the group that you want to copy.

2 Select the ‘Copy To...’ command and the Copy To dialogue box appears.

The ‘Copy To...’ dialog is a standard Windows Save To dialogue box where you c
change the drives, directories, and file names. 

19.6 Insert Work Sheets from a File

Use this function to insert the contents of a work sheet or a group which you hav
saved with the ‘Copy To...’ command.

To insert a saved work sheet:

1 Open a new work sheet.

2 Click in the work sheet where you want the work sheet contents to be 
inserted (normally the upper left corner of the empty work sheet).

3 Select the ‘Insert From...’ command in the Edit menu, and the Insert From dia-
logue box appears.

To insert a saved group:

1 Click in the work sheet where you want the group to be inserted.

2 Select the ‘Insert From...’ command in the Edit menu, and the Insert From dia-
logue box appears.

The ‘Insert Item’ dialogue box is a standard Windows Open dialogue box where y
can change the drives, directories, and file names.
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20 On-line Debug

Use the debug mode to check how the terminal configuration is working. In this mode 
you obtain a window into the terminal, showing the present values of all internal sig-
nals. Based on these values you can see if the logic is acting correctly.

The status of different signals is indicated by different colours on a work sheet in on-
line mode. These colours represent different values:

!
Note !
‘Global Debug’ must be active before you can enter debug mode in any work she

It is necessary that the work sheets you open for debugging are compiled and down-
loaded into the terminal. If you have doubts whether the configuration in CAP 531 
completely matches the one in the terminal, you should run ‘Compare Configurati
to see if there are any differences.

Fig. 9 Logical representation of Debug modes.

Colour Meaning

Red Boolean true (high)

Blue Boolean false (low)

Green Present analogue values

&
&
&
&

Work Sheet: MMI

Work Sheet: I_O

Work Sheet: REM

Work Sheet: BAY_RE

Global Debug ON

Debug mode active

Debug mode active

Debug mode active

Debug mode activeDebug ON

Debug ON

Debug ON

Debug ON
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To start the debug mode, you:

1 Open the work sheets of the terminal. Note that the configuration in CAP 531 
must be exactly the same as in the terminal. This can be verified with the 
‘Compare Configurations‘ function.

2 Switch on the ‘Debug’ mode in the On-line menu. 
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21 Print 

The work sheets and the project tree are printed with the page layoust that are assigned 
to them. The page layout is the drawing form. If no new page layout is assigned to the 
work sheet, the program uses the default page layout, which is based on a standard 
ABB drawing.

21.1 Assign Page Layouts to Work Sheets or Project Trees

You can assign a page layout to the entire project or to individual work sheets. The 
default page layout is assigned to all new work sheets.

If you do not assign a page layout, the pages are printed with the CAP 531 default page 
layout.

To assign a page layout to a work sheet or a complete terminal, select the:

1 Desired work sheet or terminal in the project tree.

2 ‘Object Properties’ command and the properties dialogue box appears.

3 <Print Options> button, and the Print Options dialogue box appears.

4 Page layout that you want to assign to the work sheet, and press <OK>.

To assign a page layout to the project tree, select the:

1 Project (mark the top icon in the project tree).

2 ‘Object Properties’ command, and the Print Options dialogue box appears.

3 Page layout that you want to assign to the project, and press <OK>.

21.2 Use the ‘Preview’ command

The ‘Preview’ command lets you view the work sheet before you print it.

When you select the ‘Preview’ command, the page displayed is for the active win
Therefore ensure that the active window is the one you want to preview.

Table 17: The buttons on the Preview toolbar:

Button Select this button to...

Close Exit from the preview mode.

Previous View the previous page.

Next View the next page.

Layout Select another page layout.

Print Page Print the current page.
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22 Print Functions

You can print after you have assigned a page layout to a work sheet or project tree. 
You might need to change the printer setup, so check it first.

22.1 Printer Setup

Use this dialogue box to change the printer, if it is necessary. CAP 531 uses a printer 
setup dialogue from Windows, so the contents might differ in different versions of 
Windows.

The paper orientation is set with the ‘Printer Setup’ command in the File menu. T
paper size and orientation is also affected of the setting in the Page Layout. This
with the ‘Paper Orientation’ command in the Layout menu (when the Page Layou
shown in the active window).

22.2 Print the Project Tree 

You can print the project tree structure.

Activate the project tree window and select the ‘Print’ command in the File menu,
the project structure will be printed (not the work sheets in the structure).

22.3 Print Terminal

You can print all work sheets in a terminal from the project tree. The pages are th
numbered consecutively within a terminal or only within the work sheets. 

When the pages are numbered consecutively, all pages will be numbered from 1
the number of pages in the terminal. In the case with separate numbering in each
sheet, all first pages of each work sheet will obtain page number 1.

22.4 Print a Work Sheet

Note that the work sheet to be printed must be open and in the active window. It i
possible to print a work sheet from the project tree.
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22.5 Cross References

All cross references can be printed (optional). Some of the cross references are printed 
to the left side and right side of the drawing. The remaining cross references (if any) 
are printed on a consecutive page. This means that all cross references are printed and 
no references are left out.

The cross references printed on the configuration page come from signals that ends 
within the part of the source area that is specially assigned for this (the outer left and 
right area). The size of this area is set in the page layout.

Fig. 10 Example of print-out with cross references on the configuration page.

The cross references that cannot be printed on the configuration page due to lack of 
space are printed on an additional page.

The cross references that come from signals ending in the middle part of the source 
area are also printed on an additional page. 

Cross references
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Fig. 11 Example of additional page with cross references.

If the configuration page has the page number 6, the additional page has the page 
number 6a. This page is not shown in the Preview. This means that the total number of 
pages to be printed can be more than the total number of pages stated on the drawings.

.
Variables that comes from the previous configuration page 

More cross references
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Page Layout

This chapter describes how you can assign a page layout to your drawings. The chapter 
describes the menus available in the page layout view, how to edit layouts and how to 
insert objects into your drawings.

23 Introduction

The CAP 531 page layout lets you create and print your own page layouts that can 
comply with your internal layout standards as drawing forms.

The page layout includes a set of graphical tools for inserting lines, bitmaps and text in 
the headers and footers of the drawings. 

When you use environment variables on a page layout, you can reuse the page layout 
for the entire project. You can also assign different page layouts for different work 
sheets and for the project tree.

The default page layout that is included in CAP 531 uses ABB standards. When you 
receive the program and when you add a new terminal to a project, all work sheets 
have the default page layout, default.plt, assigned.

The page that you print contains different areas that you define with the page layout:

• Source area, which contains the configuration of the work sheet

• Left and right legend, which contains cross references

• Space for drawing illustrations

Different page layout files (*.plt) are stored in the page layout directory. You set th
path to the directory during installation.

To start the Page Layout:

1 Select ‘Page Layout’ in the File menu.

2 Select the ‘Open Page Layout’ command.

The Page Layout can be started from the project tree and from a work sheet. Note that 
when you open the page layout in the project tree, you see the page layout of the 
project tree itself and not of any work sheets. In order to see the page layout of a work 
sheet, you open the page layout from the work sheet.
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!
Note !
Not all information is included in the *.plt files. Use the ‘Copy To…’ menu item an
the ‘Insert from…’ menu item to move page layouts between PCs.

24 Toolbar and Menu Bar

24.1 Toolbar

The toolbar has icons that you use to get quick access to frequently used actions. You 
can also use the menus or shortcut keys. 

The rest of the icons are described in the Menu bar chapter.

Icon Icon name Select this icon to...

Call the project tree Get access to the project tree.

Compile Terminal Compile the active terminal configuration.
Note ! This command is only available from 
the project tree.

Compile Terminal

Zoom Out

Zoom In

Bitmap
Environment Items

Text
Call the

project tree

Rectangle
Cross Reference Area

SourceArea
Mark Several Objects

Mark Object
Zoom Range

Line
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24.2 Menu Bar

24.2.1 File Menu

Menu Item Icon Short-cut 
key

Select this command to...

New Create a new page layout window.

Open... Open a pre-defined page layout window.

Close <CTRL> + 
<F4>

Close the active page layout.

Close All Close all page layouts and work sheets that are 
open.

Save <CTRL> + 
<S>

Save the active page layout.

Save As... Save the current page layout with a new name.

Copy To... Save the current page layout to another path so 
you can use the same page layout on another 
computer.

Insert From... Open an already saved page layout, saved with 
the ‘Copy To...’ command.

Passwords Change or insert password for users with a lower 
access level to the project.

Printer 
Setup...

Switch to another printer or select a different for-
mat. CAP 531 page layouts are based on the A4 
size, so the results may be distorted if you use a 
printer with another format.

Exit <ALT> + 
<F4>

Quit CAP 531. 
148 1MRK 511 056-UEN * 1.3-00



ABB Network Partner Toolbar and Menu Bar

Page Layout

Technical descriptions
24.2.2 Edit Menu

24.2.2.1 Object Menu

Menu Item Icon Short-cut 
key

Select this command to...

Delete <DELETE> Delete the selected objects. No undo facility will 
be available.

Clear Page 
Layout

Clear the active page layout. A dialogue box will 
inform you that the current page layout will be 
deleted, and all changes will be lost.

Mark 
Several 
Objects

Switch to the Mark Several Objects mode. Use 
this mode to select more than one object.

Mark Object <CTRL> + 
<M>

Switch to the Mark Object mode. This is the 
default mode which you use to select only one 
object.

Object Prop-
erties...

<ALT> + 
<ENTER>

Start the properties dialogue box for the 
selected object. The properties are different 
from one object to another.

Menu Item Icon Short-cut 
key

Select this command to...

Source Area <S> Switch to the Source Area mode. Use this mode 
to draw the source area.

Cross refer-
ences

<C> Switch to the Cross reference mode. Use this 
mode to draw the cross reference area.

Rectangle <R> Switch to the Rectangle mode. Use this mode to 
draw rectangles.

Line <L> Switch to the Line mode. Use this mode to draw 
lines.

Text <T> Switch to the Text mode. Use this mode to write 
texts directly into the page layout.

#Text# <E> Switch to the Environment text mode. Use this 
mode to use the environment items.
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24.2.3 Layout Menu

Bitmap <B> Switch to the Bitmap mode. Use this mode to 
insert a bitmap.

Menu Item Icon Short-cut 
key

Select this command to...

Menu Item Icon Short-cut 
key

Select this command to...

Toolbar Hide or display the toolbar. If checked, the tool-
bar is displayed.

Status bar Hide or display the status bar. If checked, the 
status bar is displayed.

Paper Orien-
tation...

Edit the Paper Orientation and size.

Environment 
Setup...

Edit the Environment variables.

Zoom Range Select an area on the screen to see details more 
clearly. 

Zoom In Num < + > Increase the scale in the active window.

Zoom Out Num < - > Decrease the scale in the active window.

Previous 
View

Num < / >or 
Num < ÷ >

Switch to the previous view.

Default Size Num < * > Switch to the default size from an increased or 
decreased size so that the worksheet is dis-
played in the default size.

Redraw <F3> Rebuild the content of the active window on the 
screen.

Grid <F4> Create a grid in the page layout. The grid can 
help you align objects more accurately. Dots are 
used to display the grid.
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24.2.4 Window Menu

24.2.5 Help Menu

24.3 Short-Cut Keys

You can perform actions by using short-cut keys and key combinations.

Menu item Icon Short-cut 
key

Select this command to...

Tile Arrange all open windows side by side.

Cascade Arrange the windows so that they overlap (start-
ing in the upper-left corner of the CAP 531 win-
dow). The title bar of each window remains 
visible.

Arrange 
Symbols

Arrange the icons that are created if you mini-
mize the windows.

Window list Switch to a different open window. Select the 
window name that you want to be active.

Menu item Icon Short-cut 
key

Select this command to...

Contents Open the Table of Contents of the CAP 531 help.

Index Open the Index of the CAP 531 help.

Current 
Object

Provides help on a selected object.

Current Win-
dow

Provides help on the active window.

About 
CAP 531...

Specifies the CAP 531 version number, copy-
right information, and so on.

To Press

Access help <F1>

Selecting objects <SPACE>
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25 Objects in the Page Layout

25.1 Source Area

The source area is the area where the contents of your work sheet or project tree will 
be printed. A red rectangle always surrounds the source area. You can only have one 
source area for each page layout. It is marked with a red rectangle.

To define the source area:

1 Select ‘Source Area’ in the Object menu, and the pointer becomes a rectan-
gle.

2 Press and hold the left mouse button at the point where you want a corner of 
the source area.

3 Drag the mouse until you have the desired size for the source area.

4 Release the mouse button, and the source area is set.

Note !
The size of the source area affects what will be printed on each page. Some function 
blocks or variables might be cut off if the source area is changed after the configura-
tion is made.

Table 18: The objects in the page layout:

Object Description

Source Area The source area is the area that will be printed. It contains the config-
uration drawn in a work sheet. A red rectangle surrounds the source 
area. 

Cross refer-
ences

The legend area where the cross references will be printed. The cross 
references are automatically generated by the program.

Rectangle For drawing rectangles in the page layout.

Line For drawing lines in the page layout.

Text A text can be printed on each page. It contains, for example, your 
company’s name or other information.

#Text# A place holder or environment variable that you insert into the page 
layout. This can be a text that comprise different information on differ-
ent pages, such as work sheet name. This is described in a separate 
chapter.

Bitmap For inserting bitmaps into the page layout. You use it, for example, to 
insert logos or other symbols related to you company or project, All 
bitmap files have the extension *.bmp.
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The properties (‘Object Properties’ in the Edit menu) for the source area are:

Height and width values for the source area correspond to the work sheet size. So
work sheet is, for example, 301 x 301 and the zoom-in factor is 1, then the work 
contents is printed in a 1:1 scale. If the work sheet is larger than the source area
can use the zoom-in factor to reduce the objects size so that they fit into the sour
area.

25.2 Cross Reference Area

Cross references for variable inputs are printed on the left side of the page. Cross
ences for variable outputs are printed on the right side of the page. The area for 
cross references is freely drawn in the page layout. In the default page layout it c
the entire page. You can only have one cross reference area for each page layou

To define the cross reference area:

1 Select ‘Cross References’ in the Object menu, and the pointer becomes a rec-
tangle.

2 Press and hold the left mouse button at the point where you want a corner of 
the cross reference area.

3 Drag the mouse until you have the desired size for the cross reference area.

4 Release the mouse button, and the cross reference area is set.

Field, button, or 
checkbox

Description

Top/left Position of the upper left corner of the source area

Width Width of the source area.

Height Height of the source area.

Lines Number of lines to be printed on the page from the Project 
Tree.

Zoom in factor Zoom-in factor for printing of the configuration.

Left/right cross refer-
ences

Width of the cross reference part of the source area. Cross 
references from signals ending within this part are shown on 
the configuration page.
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The properties (‘Object Properties’ in the Edit menu) for the cross reference area

25.3 Cross References from the Source Area

Some cross references are shown on the same page as the drawing with the con
tion. The remaining cross references are shown on a separate page.

The cross references of the input and output signals that ends close to the left and
side of the source area will be shown on the same page. The signals that ends o
middle of the source area will be shown on the consecutive page, which will only
used for cross references.

The parts of the source area from where the cross references are printed on the 
page, are the ones between the red dashed lines and the red continuous lines.

Fig. 12 Page layout with the dashed line for the described part of the source area.

The size of this area is changed in the properties of the source area: 

Field, button, or 
checkbox

Description

Top/left Position of the upper left corner of the cross reference area

Width Width of the cross reference area.

Height Height of the cross reference area.

Lines Number of lines to be printed on the separate page of cross 
references.

Input signals that ends
between the red lines
are shown to the left

Output signals that ends
between the red lines 
are shown to the right
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1 Mark the source area.

2 Select ‘Object Properties’ in the Edit menu.

3 Change the figure in ‘Width of the area’ in the ‘Left/right cross references’ 
section.

4 Press <OK>.

25.4 Rectangles

To draw a rectangle:

1 Select ‘Rectangle’ in the Object menu, and the pointer becomes a rectangle.

2 Press and hold the left mouse button at the point where you want a corner of 
the rectangle.

3 Drag the mouse until you have the desired size for the rectangle.

4 Release the mouse button and the rectangle is set.

The properties (‘Object Properties’ in the Edit menu) for a rectangle includes:
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25.5 Lines

To draw a line:

1 Select ‘Line’ in the Object menu, and the pointer becomes a line.

2 Press and hold the left mouse button at the point where you want the start of 
the line.

3 Drag the mouse until you have the desired length for the line.

4 Release the mouse button and the line is set.

The properties (‘Object Properties’ in the Edit menu) for a line includes:

Field, button, or 
checkbox

Description

Top/left Position of the left corner on the top of the rectangle

Width Width of the rectangle.

Height Height of the rectangle.

Color Rectangle line colour.

Width Rectangle line width.

Style Line style: normal, dashed or dotted.

Field, button, or 
checkbox

Description

Start Position of the starting point of the line in the x and y direc-
tions.

End Position of the ending point of the line in the x and y directions.

Color Line colour.

Width Line width.

Style Line style: normal, dashed or dotted.
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25.6 Text

To insert a text:

1 Select ‘Text’ in the Object menu, and the pointer becomes the letter T.

2 Position the pointer at the place where you want to insert text, and the Set-
ting Text dialogue box appears.

The properties (‘Object Properties’ in the Edit menu) for a text includes:

25.7 Bitmaps

To insert a graphical element such as your company logotype:

1 Select ‘Bitmap’ in the Object menu, and the pointer becomes a rectangle.

2 Press and hold the left mouse button at the point where you want the corner 
of the bitmap.

3 Drag the mouse until you have the desired size for the bitmap.

4 Release the mouse button and the bitmap area is set.

5 The bitmap dialogue box appears, and the selected bitmap will be resized to 
fit in the area.

The properties (‘Object Properties’ in the Edit menu) for a bitmap includes:

Field, button, or 
checkbox

Description

Fixed text Text string to insert.

X-pos Position of the text in x direction.

Y-pos Position of the text in y direction.

Align Text alignment: right, left or centered.

Font... Set font. When you select this button, the Font settings dia-
logue box appears.

Field, button, or 
checkbox

Description

Top/left Position of the left corner on the top of the bitmap.

Width Width of the bitmap.

Height Height of the bitmap.
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26 Edit the Page Layout

26.1 Start to Work with the Page Layout

Open the page layout by selecting ‘Page Layout’ in the File menu, select ‘Open P
Layout’. This can be accessed both from the project tree and the work sheets. 

New terminals and work sheets are associated with the default page layout. If you
to use any other page layout, you must associate the terminal (which includes all
work sheets) or the specific work sheet with that page layout. This is done in ‘Ob
Properties’ in the Edit menu, select ‘Print Options’.

!
Note !
It is very important from where you open the page layout. If you open the page layout 
from the project tree, you open the page layout associated with the tree. If you open 
the page layout from a work sheet, you open the page layout associated with that work 
sheet.

26.2 Create a new page layout

Normally you start the page layout work by reusing an old page layout and chang
If however you want to start with a blank page, you can create a new page layou
where you can define everything from the beginning.

This is done with these steps:

• Select ‘Page Layout’ in the File menu 

• Select ‘Open Page Layout’

• Select ‘New’ in the File menu

When the new page layout is saved, you must associate the new page layout wit
project tree or the work sheets that you want to print with the new page layout.
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26.3 Insert a Page Layout 

If you want to reuse a saved page layout on the default page layout directory, you can 
select ‘Open’ in the File menu of the page layout.

If you want to reuse a saved page layout from another directory or a diskette, you
use the ‘Copy To...’ and ‘Insert From...’ commands in the File menu. It is not eno
to copy only the page layout file since more information is required than what is st
in the file.

You use the ‘Insert From...’ command to insert a page layout saved with the ‘Cop
To...’ command. 

26.4 Save the Page Layout

You use ‘Save As’ in the File menu to save the page layout in to the default page
out directory.

You use ‘Copy To...’ in the File menu to save the page layout file including the bitm
files and environment items into the specified directory. This can then be reused 
others.

26.5 Clear Page Layouts

You use ‘Clear Page Layout’ in the Edit menu if you want to clear the whole page
out.

Note !
If you answered Yes on the confirmation question, there is no way that the content of 
the page layout can be restored.
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26.6 Paper Orientation

It is possible to change the paper orientation and the paper size with ‘Paper Orie
tion’ in the Layout menu. It is possible to select between:

• ‘Portrait’ 

• ‘Landscape’ (default)

and it is possible to select between:

• A4 (default)

• A3

!
Note !
If you change the paper orientation, the page layout will be cleared

The paper orientation at printout is also controlled by the Print Manager in Windows. 
This is changed with the ‘Printer Setup’ command in the File menu.

26.7 Zoom Range

It is possible to zoom a selectable area. Then you can see a certain part of the page lay-
out more clearly. 

To select a zoom area:

1 Select the ‘Zoom Range’ command in the Layout menu.

2 Press and hold the left mouse button, and drag the mouse over the area to be 
zoomed. A frame is drawn over the area.

3 Release the mouse button when desired, and the area is zoomed.

When you go back, you can select ‘Previous View’ or ‘Default Size’ in the Layout
menu.
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27 Environment Items

You can insert variables into your page layout. These are called environment items or 
environment variables. Examples of such environment items are page numbers, your 
company’s name, and other text. The idea with these environment items is that in
mation that is repeated on several work sheets, the text is only typed once and c
ily be changed from one part of the project to another. 

A typical example can be the drawing number, where you might want to have a ce
drawing number on all work sheets for a terminal, but a different drawing number
another terminal.

Note !
Do not mix up the environment variables with the variables in the work sheets. Varia-
bles in a work sheet can be considered as connectables — i.e. name connectors

The different types of environment items are:

• System items that come with CAP 531, such as page numbers, date, printin
time. You cannot delete these items.

• User-defined items, such as project name and number, company name, dra
number etc.

Environment items can have different assignments (scopes). 

All these different assignments are:

• All Projects, means that assigned text for this environment item will be the sa
in all projects.

• Project, means that assigned text for this environment item is specific for the
active project.

• Terminal, means that the assigned text is specific for the active terminal.

• Work sheet, means that the assigned text is specific for the work sheet.

This means that in the case of the drawing number, the scope would be Termina
scope of an environment item such as Project (name of the project) would be Project. 
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Example:

Assume that an environment item is called prep_name (i.e. the name of the engineer 
preparing the configuration). Let us also assume that almost all the configuration is 
prepared by Smith. The configurations in one terminal was made by Jones instead. The 
environment item prep_name would then be given the assigned text Smith with the 
scope Project. This can be done anywhere in the project. The other name must be 
assigned from the specific terminal. You open one work sheet in the terminal and acti-
vate Page Layout in the File menu. Select Environment Setup, modify the assigned 
text to Jones and change the scope to Terminal.

!
Note !
It is very important from where you open the page layout and where you activate the 
Environment Setup. You see the assigned text and the scope of the items from where 
you are. If you open the page layout or activate Environment Setup from the Project 
tree, you only see the layout and the setup of the tree, not of the work sheet.

.

The environment items can be accessed in a number of ways:

1 Select ‘Page Layout‘ in the File menu.

2 Select ‘Environment Setup‘.

or:

1 Select ‘Page Layout‘ in the File menu.

2 Select ‘Open Page Layout‘.

3 Select ‘Environment Setup‘ in the Layout menu.

Table 19: The system items.

Variable Contains the...

Data Path Path to the project.

Date Printing date.

File Date Date that you saved the project.

File Time Time that you saved the project.

Page Page number.

Page/Total Page number and the number of total pages that will be printed.

Project Project name.

Time Printing time.

Total Pages Total number of pages.

WS Name Work sheet name.
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or:

1 Select ‘Page Layout‘ in the File menu.

2 Select ‘Open Page Layout‘.

3 Select one place holder (marker), such as #prep_name#.

4 Double click on the right mouse button.

5 Select <Config...>.

Field, button or 
checkbox

Description

Variable Specifies the item name.

Assigned Text Specifies the text to be inserted in the page layout. If you see: 
#System Item#, then a place holder (marker for this item) is 
inserted in the page layout. Select the Preview command to 
view the assigned text of these place holders.

Scope of the Item Specifies the assignments of the variable. 
The four buttons are:

1. All Projects

2. Project

3. Terminal

4. Work sheet

You can only select one of these buttons at the time. If you 
have set a Text for a Variable in the Project level you can set 
a new Text for the same Variable in the Work sheet level and 
that will be used for the corresponding terminal. The Variable 
that was set for the Project will be used in all other terminals 
and work sheets connected to the Project.

Add Allows you to add new items.

Modify Allows you to change the assigned text and the scope. 
This button will be disabled when you have selected a system 
item. They can only be modified with Copy.

Copy Copies the selected item into the Variable and Assigned Text 
boxes, and enables writing these boxes, it also enables the 
Assignment (scope) part of the box.

Delete Deletes the selected item in the list box. 
Note ! It is not possible to delete a system item.
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27.1 Add new items

1 Select <Add>, and the cursor is displayed in the Variable field.

2 Type a variable name and press <ENTER>.

3 Type an assigned text.

4 Select one of the buttons in the assignment (scope) part to make the item 
active for the Project, Terminal or only the Work sheet.

5 Select <OK> and the item is set.

27.2 Add items similar to existing ones

1 Select the item that you want to change from the list box.

2 Select the <Copy> button, and the contents of the selected item will be cop-
ied into the Variable and Assigned text fields.

3 Type a new Variable for the item.

4 Type a new Assigned text for the item if desired.

5 Change the Assignment (scope) for the item if desired.

6 Select <OK> and the item is set.

27.3 Change items

1 Select the item that you want to change from the ‘Environment items’ list 
box.

2 Select the <Modify> button, and the cursor is displayed in the ‘Assigned text’ 
field.

3 Type an Assigned text or change the text.

4 Change the scope if necessary.

5 Select <OK> and the item is changed.

Note that system items can only be changed with the Copy function (See ‘Add ite
similar to existing ones’).

27.4 Delete items

1 Select the item you want to delete from the list box.

2 Select <Delete>, and the environment delete message dialogue box appears.
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System and Error Messages

The following messages are sorted in alphabetical order.

Message Explanation Action

Access denied: file-
name.

A work sheet is opened several times. 
CAP 531 in Windows 3.11 does not 
allow editing in two copies of the same 
work sheet.

Close one of the work sheets.

Assignment wrong. A variable in a work sheet is not con-
nected.

Connect the variable.

Bitmap file too large for 
page layout.

The bitmap file that you tried to insert 
into the page layout is too big.

Insert a smaller bit map file.

Cannot change direc-
tory

The directory change could not be pro-
ceeded.

Close all other programs, and 
try again.

Cannot change drive. CAP531 couldn’t change the drive. Make sure to have access to 
the requested drive e.g. insert 
the diskette.

Can close only all ter-
minal work sheets. 
Use Close Terminal

An attempt to close only one work 
sheet from a terminal that has more 
than one work sheet opened.

Use ‘Close Terminal’ or 
‘Close All’ to close all work 
sheets that belong to the ter-
minal.

Cannot compress data. There has been an internal error while 
generation the compressed file.

Check your hard disk if there 
is a physical defect.

If error remains call technical 
support for CAP 531.

Cannot connect an out-
put to an output.

You tried to connect one output to 
another output.

Connect an output to an input.

Cannot delete object 
name.

When using Local Replace, a word 
must be specified to replace the exist-
ing word.

Type a word in the Replace 
field.

Cannot decompress 
PWT file.

There are files with the extension 
.PWT in directories where they should 
not be for a correct decompressing 
process.

1. Copy all files with the 
extension .PWT of this project 
to a saftey backup.

2. Delete all files with the 
extension .PWT of this 
project.

3. Restart decompressing.

Cannot decompress 
project.

There has been an internal error while 
decompressing the project.

Check your hard disk if there 
is a physical defect.

If error remains, call technical 
support for CAP 531.

Cannot replace. New 
expression exceeds 
range.

The text string in the Replace field is 
too long.

Type a shorter text string in 
the Replace field. 
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Cannot remove old 
compress file.

The old compress file could not be 
deleted because it has been write pro-
tected.

Remove the write protection 
of the old compress file.

Can’t create project. No space left on drive. Create space.

Can’t divide file in 
token.

Can’t divide file in token. Call technical support if the 
error remains.

Can’t get current direc-
tory.

The default current directory was not 
found.

Save all worksheets and 
restart CAP531.

Call technical support if the 
error remains.

Can’t insert object. An attempt to insert an object has 
failed. Only certain numbers of each 
object can be inserted in a work sheet.

Split the work sheet, and con-
tinue working in the new one.

Can’t open another 
instace of this editor.

Internal error. Call technical support for 
CAP531.

Can’t open file 
SELUPL.MFU.

The file doesn’t exist. Run ‘Upload Options’ in the 
On-line menu.

Can’t open file 
REx5xx.SEL

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure‘.

Can’t open file 
SELECT.MFU.

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Cannot open file zip.lst. The file zip.lst could not be opened. Reinstall CAP 531 on your 
computer. Compress the 
project again.

If the message appears a 
second time, call technical 
support for CAP 531.

Can’t open work sheet: 
filename.

The file is deleted or corrupt.

Too many files are open.

The disk might be defective.

Restore the file from the 
backup disk and compile the 
terminal.

Close some files or change 
the FILES=X in Config.sys to 
a higher value.

Check the disk and if neces-
sary, get it fixed.

Cannot open terminal 
data.

An error occured when trying to open 
the data of the terminal.

Make sure that the correct ter-
minal is installed.

Call technical support if the 
error remains.

Message Explanation Action
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Can’t process file. The disk is write protected.

The file is deleted.

The disk might be defective.

Not enough free disk-space.

Remove the write protection.

Restore the file from the 
backup.

Check the disk and if neces-
sary, get it fixed.

Free some disk-space.

Can’t process file com-
pleatly.

The disk is write protected.

The file is deleted.

The disk might be defective.

Not enough free disk-space.

Remove the write protection.

Restore the file from the 
backup.

Check the disk and if neces-
sary, get it fixed.

Free some disk-space.

Can’t save work sheet: 
filename.

The disk is write protected.

The disk might be defective.

Not enough free disk-space.

Remove the write protection.

Check the disk and if neces-
sary, get it fixed.

Free some disk-space.

Can’t upgrade lock. An internal error occurred during file 
handling.

Save all work sheets and 
restart CAP 531.

Call technical support for CAP 
531 if the error remains.

Channel number out of 
range.

There is an error in the CAP/REx5xx 
library. The channel number is greater 
than 255.

Call technical support for CAP 
531.

Collision. An object was moved to another 
object, and the objects overlap.

Move the objects so that they 
do not overlap.

Compile Status Error! 
Unknown variable: x, 
in file TOC.DEF.

The file is corrupted. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Compress file invalid or 
insufficient memory.

The compressed file has been dam-
aged.

There is not enough user memory.

Copy your compressed file 
from your backup.Restart 
your decompressing.

Close all other Windows 
applications.Check the 
dimension of your virtual 
memory in MS-Windows.

Connection already 
exists.

You tried to connect a line to a point 
where all possible connections are 
used.

Try to connect the line beside 
the desired connection.

Connection input to 
input.

You tried to connect one input to 
another input directly.

Connect an input to an output.

Message Explanation Action
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Connection invalid. You tried to connect a setting to an 
output. Settings can only be connected 
to setting parameters.

Connect the setting to a set-
ting parameter.

Connection missing. Some connections between object are 
not optional. A required connector is 
missing.

Connect the connector to a 
desired connection.

Connection only hori-
zontal possible.

You tried to connect a vertical line to 
an input or output.

Connect the line horizontally.

Connector connected 
to connector.

A connector is connected to a connec-
tor. The same connector cannot have 
two names.

Correct as necessary.

Connector defined 
more than once.

A connector is connected to an output 
parameter more than once.

Use another connector.

Connector is connected 
to an output without 
access right.

An output parameter is connected to a 
connector, but the output parameter is 
not in the specific terminal library.

Run ‘Update Version’ in the 
Make menu.

Connector not found. A connector is connected to an input 
parameter but is not connected to an 
output parameter. Example: a variable 
connected to an input that has no 
match on an output.

Connect the connector to an 
output parameter.

Couldn’t find a match 
for data-module in 
CHOICES.DSC

The data-module name is missing in 
the CHOICES.DSC file.

Call technical support for CAP 
531.

Couldn’t find corre-
sponding Spa Code: x 
in 
VALUES.VAL.

Spa Channel Code for x can’t be found 
in any VALUES.VAL file

Call technical support for CAP 
531.

Couldn’t find Spa Code 
x in file T2.DAT.

The Spa Code value x doesn’t exist in 
the T2.DAT file

Call technical support for CAP 
531.

Couldn’t find Signal 
Value x in file T3.DAT.

The Signal Value x doesn’t exist in the 
T3.DAT file

Call technical support for CAP 
531.

Couldn’t open file 
CHOICES.DSC.

The file doesn’t exist. Call technical support for CAP 
531.

Couldn’t open file 
CONTENTS.MFU.

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Couldn’t open file 
LDTRM2.LST.

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Couldn’t open file 
T2.DAT.

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Couldn’t open file 
T3.DAT.

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Couldn’t open file 
T4.DAT.

The file doesn’t exist. Install CAP/REx5xx or run 
‘Copy CAP module from SMS 
structure’.

Message Explanation Action
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Couldn’t open file VAL-
UES.VAL.

The file doesn’t exist. Call technical support for CAP 
531.

Data corruption: can’t 
recover.

A file is missing. CAP 531 tried to 
restore the data in this file. Some parts 
of the project are damaged.

Restore the configuration 
from the backup.

Data from an element 
could not be loaded 
from file.amt

The function block isn’t in the .amt file

The .amt file is corrupt.

Use another function block.

Restore the .amt file from the 
backup.

Data type wrong. The configuration contained a function 
block without parameter, where the 
data type is changed in the new 
library.

Replace the function block.

Different cycle times. A connection occurred between func-
tion blocks that have different cycle 
times.

Check if the function is valid. 

Different data types. The connection between different 
types of data cannot be made.

Connect input and output of 
the same type.

Disk full. There is not enough memory on your 
floppy or on your hard disk.

Insert an empty floppy disk.

Remove old, unnecessary 
files from your hard drive.

Disk not ready. There is no floppy disk in your drive.

The floppy disk in your drive is write 
protected.

Insert a floppy disk in the cor-
responding drive.

Remove the write protection.

End of zoom range. You have reached the end of the zoom 
range.

Stay within the zoom range.

Empty or invalid com-
press file.

You have entered a wrong path or a 
wrong filename and then started the 
compressing process.

Enter a correct path or file 
name.

Error reading Table. The table is corrupted. Restore the file from the 
backup.

Call tecnical support if the 
error remains.

Expected comment 
end.

The end od the file is maybe a com-
ment.

Ensure that there is a correct 
end of the file.

Feature is not avail-
able.

This function is not implemented in this 
version.

Call technical support for 
CAP531.

File error. The file is deleted.

This file is write protected.

Not enough free disk-space.

Restore the files from the 
backup, and compile all.

Check the write protection.

Free some disk-space.

Message Explanation Action
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File header error. An internal error occurred during file 
handling.

Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

File is no bitmap file. You selected a file that is either not a 
bitmap file or corrupt.

Select a file with a bmp exten-
sion, or fix the bitmap file.

Function block already 
used.

A function block is used more than 
once in this terminal.

Replace the function block.

Function block deleted. The configuration contains an function 
block that is not in the new library.

Replace the function block.

Function block has 
unconnected parame-
ters.

All input parameter must be con-
nected.

Connect the input parameter 
that is not connected.

Function block not 
found.

A function block, which is used, is not 
found in the library.

Run ‘Update Version’ in the 
Make menu.

Function Block not in 
library.

The function block you tried to insert 
belongs to another library.

Use the function block in the 
proper terminal.

Function not con-
nected.

A function is inserted but not con-
nected to other function blocks.

Delete the function or connect 
it.

Illegal constant. A value for a constant is incorrect. Correct the programming 
error.

Illegal direct repre-
sented variable.

Illegal direct represented varible or 
multielement variable.

Call technical support if the 
error remains.

Inconsistency between 
terminal options and 
tool used options! 

The flag for the used function block is 
not set.

Run ‘Upload Options’ in the 
On-line menu.

Initialization not possi-
ble.

A file is missing or is damaged after a 
system crash.

Restore the files from the 
backup.

Call technical support if the 
error remains.

Instance could not be 
loaded.

The function block instance can’t be 
found in the present library.

Use another library where the 
function block instance exists.

Instance missing. The configuration contains an function 
block that is not in the new library.

Replace the function block.

Instances would be 
used more than once.

The instances are used more than 
once in this terminal which is not 
allowed, you must delete the dupli-
cated instances.

Delete the duplicated 
instances.

Insufficient memory. There is not enough user memory. Close all other Windows 
applications.

Check the dimension of your 
virtual memory in MS-Win-
dows.

Message Explanation Action
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Internal error. This message usually appears after 
another error message. It means that 
something did not work properly during 
compilation.

Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

Invalid access level. You have specified an access level 
outside the limits(1..20) or lower than 
the level of your password.

Specify a new access level.

Invalid connection. It is not possible to connect:

Connector variable to SETTING 
parameter.

Connector variable to connector vari-
able.

SETTING value to connector variable.

SETTING value to non SETTING 
parameter.

Make a valid connection.

Invalid connector 
name.

The variable name you have entered 
starts with a #.

Remove the #.

Invalid current parame-
ter.

There is a connection between two 
outputs or two inputs.

Connect the input with an out-
put.

Invalid password The password is wrong. Type another password. 
Check with the creator of the 
project.

Invalid variable name. The name you have entered contains 
invalid characters or no characters at 
all.

Enter a valid name for the 
variable.

Invalid WS size. The work sheet size that you have 
entered is too big.

Change the width and/or 
height values. Max.size is 3 x 
4 pages.

Invalid name. You have specified an illegal name for 
an item. The name can only cosist of 
letters and digits, beginning with a let-
ter.

Specify a new legal name.

Invalid name for com-
press file.

You have forgotten to enter a name or 
you have entered the wrong name for 
the compressed file.

Enter a correct name for the 
compressed file.

Invalid path for com-
press file.

You have forgotten to enter a path or 
you have entered the wrong path for 
the compressed file.

Enter a correct path for the 
compressed file.

It is not possible to load 
or overwrite the project.

You have tried to save your project 
with the name TEMPLATE.PWT at the 
CAP531 installation directory.

Save your project with a dif-
ferent name, preferably at 
another directory.

Library not found. Cannot link the terminal because of 
missing library.

Install the required CAP/
Rex5xx.

If the error remains, call tech-
nical support for CAP531.

Message Explanation Action
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List of contents have 
changed.

The library must be updated. Run Update Version in the 
Make menu.

Maximum objects per 
work sheet: x used.

Too many objects are used in the work 
sheet. The object cannot be inserted.

Continue working in a new 
work sheet.

Maximum number of 
windows exceed. 
Please close a window.

Too many windows are open. Close one or more windows.

Missing crossrefer-
ence area in pagelay-
out.

You have tried to print a work sheet 
with a page layout that don’t has a 
cross reference area.

Add the cross reference area 
in the page layout.

Missing insert position. No insert position is set in the work 
sheet.

Click in the work sheet where 
you want the object to be 
inserted.

Missing file zip.lst. The zip.lst file is missing. Reinstall CAP 531 on your 
computer. Compress the 
project again.

If the message appears a 
second time, call technical 
support for CAP 531.

Missing name. There is no name specified for the 
item.

Specify a name.

Name already exists. There is already a work sheet in this 
terminal with the name you have spec-
ified.

Specify another name.

Name is too long. You have specified a name for an item 
in the insert dialog that is too long.

Specify a name with less 
characters than 50.

No access for parame-
ter.

An input parameter, which is not in the 
specific terminal library, is being used.

Run ‘Update Version’ in the 
Make menu.

No access right, Editor 
will be started in VIEW 
mode.

The access rights (according to the 
used password) are too low. You are 
not allowed to change anything in the 
work sheet that you have opened.

Change to another password 
or see to that the work sheet 
gets another access level.

No blanks allowed in 
text.

You have used blanks in the replace 
field.

Delete the blanks or replace 
them with underscores (_).

No group name speci-
fied.

You have not entered a name for the 
group.

Type a name for the group.

No page layout 
assigned for work 
sheet.

There is no Page Layout assigned to 
the work sheet that you are trying to 
print.

There is no source area in the 
assigned Page Layout.

Assign a Page Layout to the 
work sheet.
This is done in ‘Object Prop-
erties’ in the Edit menu. 
Select <Print Options>.

Insert a source area in the 
Page Layout.

No project name. No project name was given during 
startup.

Restart CAP531 with the cor-
rect project name.

Message Explanation Action
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Not valid structure in 
file zip.lst.

The file zip.lst has been damaged. Reinstall CAP 531 on your 
computer. Compress the 
project again.

If the message appears a 
second time, call for technical 
support for CAP 531.

Object not processed. An internal error occurred during com-
pilation of the work sheet. A structure 
in a work sheet is not compiled.

Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

Object type not sup-
ported.

Some types of objects may be used in 
the work sheet. But they cannot be 
compiled.

Change the structure and use 
a different object type.

Objects out of work 
sheet.

One or more objects are positioned out 
of the work sheet.

Move them inside the borders 
of the work sheet.

On-line debug can’t be 
started.

An internal error occurred when start-
ing the editor in debug mode.

Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

On-line debug can’t be 
stopped.

An internal error occurred when clos-
ing the work sheet in debug mode.

Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

Out of memory. Not enough memory to execute com-
mand.

Close all other Windows 
applications.

Check the size of the virtual 
memory in Microsoft Win-
dows.

Output line not found. An internal file is corrupt. Run ‘Generate Template’ 
from the Edit menu with the 
current configuration. Insert a 
new terminal in the tree and 
run ‘Insert Template’ to insert 
the configuration again.

Parameter deleted. The configuration contains a function 
block with a parameter that is not in 
the new library.

Replace the function block.

Parameter is con-
nected to an output 
without access right.

An output parameter is in use which is 
not in the specific terminal library.

Run ‘Update Version’ in the 
Make menu.

Parameter possible 
was inserted.

The configuration contains a function 
block without a parameter, which is in 
the new library.

Replace the function block.

Password already 
exists.

You have tried to create a password 
that already exists.

Create another password.

Message Explanation Action
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Printing aborted. The printout was aborted. Check the installation of the 
printer.

Printer error! Not 
enough memory.

Not enough memory to complete the 
printout.

Free more memory.

Printer error! Not 
enough disk space.

Not enough disk space to complete the 
printout.

Free more disk space.

Printer error! Please 
control printer installa-
tion.

Problems while printing. Check if the printer is ON, on-
line, and connected.

Printer not valid. A standard printer for CAP 531 was 
not specified in the printer setup dialog 
box.

Select from the Printer Setup 
list box, the printer that you 
want to use.

Project doesn’t exist. No project is stored at the selected 
path.

Select another project.

Project structure could 
not be saved.

No space left on drive. Create space.

Recursion. The structure that you created forms a 
closed loop. The beginning is con-
nected with the end of the same line.

Create a structure where the 
line is not connected to itself.

Terminal could not be 
appended.

A terminal could not be inserted in the 
project tree since no terminal type was 
selected.

Select a terminal type.
If no terminals are available, 
install 
CAP/REx 5xx or run ‘Copy 
CAP modules from SMS 
structure’.

The selected item is not 
a project.

You have tried to open a project file 
that doesn’t have the file extension 
.PWT.

Select the .PWT file for your 
project.

There are more than 
one line.

There is more than one line where you 
are trying to connect the line.

Connect the line to a single 
line.

The complete work 
sheet or only one group 
has to be marked.

You have not selected a group nor the 
whole work sheet.

Select either the whole work 
sheet (‘Mark All Objects’) or 
just one group (‘Group’).

There is an object but 
not a link.

You have tried to connect a line to an 
object that doesn’t have connections 
available at that specific point.

Connect the line to a different 
position.

There is no CAP mod-
ule installed in the path.

You have not marked a terminal type 
while running ‘Copy CAP modules 
from SMS structure’.

Mark a terminal type in the 
modules-library of SMS.

Too many connectors. The maximum number of connectors 
in the work sheet is 2048.

Adjust accordingly.

Too many error mes-
sages.

Too many error messages appeared 
during compilation.

Correct the visible errors in 
the list and recompile.

Timeout error. The communication with the terminal 
is not working.

Check the communication 
setup and physical connec-
tion.

Too many entries in 
VALUES.VAL.

The number of entries in the VAL-
UES.VAL file is limited to a maximum 
of 1024.

Call technical support for CAP 
531.

Message Explanation Action
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System and Error Messages
Too many libraries The maximum number of available 
libraries is 200.

Call technical support for CAP 
531.

Too many locks. An internal error occurred during file 
handling, which might be caused by 
too many open files.

Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

Unable to decode Spa 
Channel Code x in file 
T4.DAT

Spa Channel Code for x is missing in 
the T4.DAT file

Call technical support for CAP 
531.

Unable to determine 
desired connection.

You have tried to connect a line equi-
distant between two close objects.

Make the connection point 
closer to the object you want 
to connect to.

Unexpected: An unexpected error occured. Call technical support if the 
error remains.

Unknown error object. The jump (link) from the error list to the 
error is not available.

Restart CAP 531 and compile 
all again.

Call technical support if the 
error remains.

Variable name has to 
be entered.

A name for the variable is not inserted. Insert a variable name.

Version numbers dif-
fers.

The version differs from each others. Install the correct version of 
CAP/Rex5xx.

Call technical support if the 
error remains.

Work sheet not 
changed.

An internal error occurred in CAP 531. Save all work sheets and 
restart CAP 531.

Call technical support if the 
error remains.

Wrong I/O type. The configuration contains a function 
block without a parameter, where the I/
O type (input, output, or setting) defini-
tion is changed in the new library.

Replace the function block.

You have to update 
your version.

The library must be updated. Run ‘Update Version’ in the 
Make menu.

Message Explanation Action
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Reference publications

SMS-BASE User’s Guide - 1MRS 750 146-ESD
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ABB Network Partner Customer feedback report
Product:

ABB Network Partner AB would appreciate your comments on this product. Please 
grade the following questions by selecting one alternative per category. Your answer 
will enables us to improve our products.

How do you grade the quality of the product?

Exellent Poor

Total impression

Useability

Functionality

Human-man interface

Comments: __________________________________________________________

____________________________________________________________________

____________________________________________________________________

How do you grade the quality of the documentation?

Exellent Poor

Total impression

Layout

Illustrations

Readability

Easy to find 

Content structure

Comments: __________________________________________________________

____________________________________________________________________

____________________________________________________________________
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Suggestions for improvments:

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

_____________________________________________________________________

Please send this report to:

ABB Network Partner AB
Dept. MD4
S-721 71 Västerås
Sweden

By facsimile:

Send to + 46 21 321633
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Program:

This card registers your program and makes you eligible to receive information about 
future updates.

Name:

_____________________________________________________________________________________
Title:

____________________________________________________________________________________
Company: Dept.

____________________________________________________________________________________
Address:

____________________________________________________________________________________

____________________________________________________________________________________
City: State: Zip:

____________________________________________________________________________________
Phone:

____________________________________________________________________________________
Fax:

____________________________________________________________________________________

Program supplied by:

____________________________________________________________________________________
Adress:

____________________________________________________________________________________

____________________________________________________________________________________
City: State: Zip:

____________________________________________________________________________________
Phone:

____________________________________________________________________________________
Date of receival of the program:

____________________________________________________________________________________
Program serial Nr:

____________________________________________________________________________________

Fascimile:

Please send this registration card to ABB Network Partner AB, Sweden department  PS
(+46 21 32 17 36)

Software Registration Form
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Place 
Postage 

Here

ABB Network Partner AB
Department: PS
S-721-71 Västerås
Sweden

To be folded

Tape here
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A
access rights 102
assign

page layout 66, 142

B
baud rate 59
bay 28, 91
bitmaps

insert 74, 157

C
CAP 531

exit 81
help 22
installation 14
quick guide 25

CAP/REx 5xx 6, 30
change

function selectors 109
object properties 107
page layout 66
paper orientation 160
password 102
zoom range 128, 160

clear
page layout 159
work sheets 128

clipboard functions 50
colours

debug mode 63, 140
comment

insert 49
communication setup 59, 114
compare configurations 64, 116
compile

terminals 57, 112
compress project 104
configurations

compare 64, 116
download 61
upload 62

connect
objects 43

context-sensitive help 22
copy

objects 137
page layouts 69, 159
terminal 104
work sheet 104
work sheets to a file 139

copy CAP modules from SMS structure 21, 30
correct

errors 113
create

groups 52
page layouts 68, 158

cross reference area 72, 153
cross references 72, 144, 146

print 144
cut

objects 137
cycle time 7

D
debug mode 62, 119, 140

colours 63, 140
decompress project 104
default page layout 66
define

cross reference area 153
source area 152

delete
objects 133
project tree items 105
work sheets 105

download
configuration 62, 115

draw (page layout)
lines 156
rectangles 155

E
edit

environment items 75
page layouts 71
project tree 104

elements 43
environment

setup 161–164
environment items 161–164

add new items 77, 164
change system items 78, 164
change user-defined items 77, 164
copy 164
delete 164
modify 164
scope 75, 161
systems items 162

error list 58, 110, 113
error messages 165
errors

correct 113
example configuration 105
execution number 7
exit

CAP 531 81
page layout 79
work sheets 45

F
FBD 6
find 135
find and replace 135
flow control 60
front communication 114
function block 6, 7

insert 42, 129
replace 50, 130

function block diagram 6, 7
function selector 39, 108
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functions 6, 7

G
generate

templates 54, 106
global debug 140
global find and replace 136
global.cnf 104
group

create 52
insert from files 53, 138
objects 138
save as files 53, 138

H
help 22

I
icons 87

bay 94
CAP 531 87
no terminal 94
organization 94
project 94
station 94
terminal 94
undefined 94
work sheet 94

IEC 1131 programming 6
import SMS project 104
input parameters 7
insert

bitmaps 74, 157
comment 49
function blocks 42, 129
groups from files 53, 138
page layout from a file 159
page layouts 70
setting 48, 132
template 32, 105
text (comments) 49, 133
text in page layout 157
variables 46, 131
work sheet 31, 104
work sheets from files 56, 139

installation of CAP 531 14
instance name 7

L
lines (page layout)

draw 74, 156
local find and replace 135

M
menu bar 97–101, 121–125, 148–151

edit menu 98, 122, 149
file menu 97, 121, 148
help menu 101, 125, 151

layout menu 99, 124, 150
make menu 99, 124
object menu 123, 149
on-line menu 100, 125
window menu 100, 125, 151

modules
directory 20

O
objects

bitmaps 152
connect in work sheet 43
copy 137
cross references 152
cut 137
delete 133
group 138
in project tree 27, 91
lines 152
paste 138
properties change 107, 142
rectangle 152
source 152
text 152

on-line
debug 140
on-line tasks 114

open
page layout 146
projects 28
work sheets 127

organization 27, 91
output parameters 7

P
page border 42
page layout 92

assign to projects 66
clear 159
copy 69, 159
create 68, 158
cross reference area 72, 153
cross references 72, 146
directory 18
edit 71
environment items 75, 161–164
exit 79
insert 70
insert a rectangle 155
insert a text 157
save 79, 159
source area 71, 146

page numbering 80, 143
paper orientation

change 160
password 29, 102
paste

objects 138
preview

close 142
layout 142
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next 142
previous 142
print 142

print
a page of a work sheet 80
cross references 144
project tree 81, 143
setup 143
terminal 80, 143
work sheet 80, 143

print options 67
project 91

compress 104
decompress 104
directory 19
import 28
new 27
open 28

project tree 91
assign page layout 142
edit 104
icons See icons
print 81

properties
change object properties 107

Q
quick guide 25

R
readme 13, 87
rectangle

draw 155
objects 152

red cross 28, 94
replace

function blocks 130
requirements 13

S
save

groups as files 53
page layout 79, 159
work sheets 45, 54, 139
work sheets as files 55, 139

send signal 114
settings

communication 59
insert 48, 132

setup 59, 114
short-cut keys 101, 126, 151
size

work sheet 41
slave number 59
source area 71, 146, 152
standard configuration 105
station 27, 91
status bar 90
system items 162
system messages 165

system rights 102

T
table of functions

upload 34, 61
templates

generate 54, 106
insert 32, 105

terminal 6, 27, 91
compile 57
configuration 64
copy 104
download 62, 115
template 32, 105

terminal options 36
text (comments)

insert 49, 133
text in page layout

insert 157
objects 152

toolbar 89, 96, 120, 147
type name 7

U
update version 110
upload

configurations 62
table of functions 34, 61

upload and compare 64
upload options 34, 115
user registration 15

V
variables

insert 46, 131

W
windows 13
work sheet 41, 104, 119

assign page layout 142
clear 128
copy to a file 139
debug mode 62
delete 105
insert 31, 104
insert from files 56, 139
open 127
page border 42
print 80
save 45, 54
save as files 55, 139
size 41

WS size 41

Z
zoom range

change 128, 160
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SOFTWARE LICENSE

• This ABB Network Partner AB License Agreement (”License”) grants you the nonexclusive right to use one
copy of the enclosed software program (”SOFTWARE”) on a single computer (i.e., with a single CPU) at a
single location at any time. If you have multiple Licenses for the SOFTWARE you may have as many copies
of the SOFTWARE in use as you have Licenses.

• The software is owned by ABB Network Partner AB or its suppliers and is protected by Swedish copyright
laws, international treaty provisions, and all other applicable national laws. Therefore you must treat the
SOFTWARE as any other copyrighted material (e.g., a book or musical recording) except that if the software
is not copy protected you may either (a) make a copy of the SOFTWARE solely for backup or archival
purposes, or (b) transfer the SOFTWARE to a single hard disk provided you keep the original solely for
backup or archival purposes. You may not copy the Documentation accompanying the SOFTWARE.

• The License is effective until terminated. This License will terminate automatically without notice from
ABB Network Partner AB if you fail to comply with any provision of this License. Upon termination you
shall return the diskettes containing the SOFTWARE and all Documentation to ABB Network Partner AB and
destroy any copies of the SOFTWARE or any portions of it which has not been returned to ABB Network
Partner AB, including copies resident in computer memory.

• You may not rent, lease, lend, sell or give away the SOFTWARE, but you may transfer your rights under
this ABB Network Partner AB License Agreement on a permanent basis provided you transfer all copies of
the SOF TWARE and all written materials, and the recipient agrees to the terms of this Agreement. You
may not modify, adapt, translate, reverse engineer, decompile, disassemble, or create derivative works based
on the SOFTWARE. You may not modify, adapt, translate or create derivative works based on the written
materials.

LIMITED WARRANTY

• ABB Network Partner AB’s entire liability and your exclusive remedy shall be, at ABB Network Partner
AB’s option, either (a) return of the price paid or (b) repair or replacement of the SOFTWARE that does not
meet ABB Network Partner AB’s Limited Warranty and which is returned to ABB Network Partner AB with
a copy of your receipt. This Limited Warranty is void if failure of the SOFTWARE has resulted from
accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the
original warranty period or 30 days, whichever is longer.

• ABB Network Partner AB disclaims all other warranties, either express or implied, including but not limited
to implied warranties of merchantability and fitness for a particular purpose, with respect to the SOFTWARE,
accompanying Product Manual(s) and written materials. This warranty gives you specific legal rights.

• Neither ABB Network Partner AB nor anyone else who has been involved in the creation, production or
delivery of this product shall be liable for any direct, indirect, consequential or incidental damages (including
damages for loss of business profits, business interruption, loss of business information, and the like) arising
out of the use or inability to use such product even if ABB Network Partner AB has been advised of the
possibility of such damages. In any case, ABB Network Partner AB's entire liability under any provision of
this agreement shall be limited to the amount actually paid by you for the software.

ACKNOWLEDGEMENT

By opening the diskette package you acknowledge that you have read this agreement, understand it, and agree
to be bound by its terms and conditions. You also agree that it is the complete and exclusive statement of the
agreement between the parties and supersedes all proposals or prior agreement, oral or written, and any other
communications between the parties relating to the subject matter of the licence or limited warranty.

This Agreement is governed in all aspects by Swedish law. If any provisions of this Agreement are invalid or
unenforceable, all others will remain in effect.

IMPORTANT - READ CAREFULLY BEFORE OPENING

ABB Network Partner AB

1. Grant of License

2. Copyright

3. Term

4. Other Restrictions

Limited Warranty

Customer Remedies

No Other Warranties

No Liability for
Consequential  Damages

This legal document is an agreement between You, the user, and ABB Network Partner AB, Västerås, SWEDEN. By opening
the diskette package You indicate your acceptance of the terms and conditions of this agreement. If You do not agree to the
terms of this agreement, promptly return the unopened diskette package and other items which are part of the product for a full
refund. Your product is a single user version unless you have a written agreement with ABB Network Partner AB.

License Agreement

• ABB Network Partner AB warrants that the software will perform substantially in accordance with the 
accompanying Product Manual(s) for a period of 1 year from the date of delivery from ABB Network Partner AB, 
Västerås. ABB Network Partner AB does not warrant that the SOFTWARE is free from coding errors.



ABB Network Partner AB
S-721 71 Västerås
Sweden
Tel: +46 21 321300
Fax: +46 21 146918
www.abb.se/net
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