Contents

1. About this manual ........................................................................7
   1.1. Copyrights ...........................................................................7
   1.2. Trademarks ..........................................................................7
   1.3. Guarantee ............................................................................7
   1.4. General ...............................................................................7
   1.5. Use of symbols ....................................................................8
   1.6. Document conventions .......................................................8
   1.7. Terminology .......................................................................8
   1.8. Abbreviations ...................................................................9
   1.9. Related documents ............................................................9
   1.10. Document revisions .........................................................10

2. Trend Reports ..........................................................................11
   2.1. Getting started .................................................................11
       2.1.1. Starting Trend Reports .............................................11
       2.1.2. Selecting objects for the Trend Reports .....................11
       2.1.3. Preparing preconfigured Trend Reports ....................12
       2.1.4. Selecting preconfigured Trend Reports .....................12
   2.2. Trend Reports ....................................................................12
       2.2.1. Description .............................................................12
       2.2.2. Features/options .......................................................12
   2.3. Trend picture forms ...........................................................12
       2.3.1. Graphical form ........................................................12
           2.3.1.1. General functionality ..................................13
       2.3.2. Introduction to Trend Basket ..................................14
       2.3.3. Trend picture coordinates .......................................14
       2.3.4. Trend picture presentation modes .........................15
       2.3.5. Trend picture preconfigurations ..............................15
       2.3.6. Trend picture tools ..................................................15
       2.3.7. Miscellaneous .........................................................17
       2.3.8. Tabular form .............................................................17
           2.3.8.1. General functionality ..................................18
           2.3.8.2. Trend Parameters ........................................19
           2.3.8.3. Trend picture presentation modes .................19
           2.3.8.4. Trend picture tools .......................................19
   2.4. Presentation Mode ............................................................21
   2.5. Trend Basket .....................................................................22
       2.5.1. Functionality ...........................................................22
       2.5.2. Station Basket .........................................................22
           2.5.2.1. Trend Settings .............................................24
2.5.3. Trend Basket dialog ..............................................................25
  2.5.3.1. Selecting Trend Picture Preconfigurations ..........26
2.6. Preparing Trend Picture Preconfigurations ..........................27
2.7. Trend picture settings ..........................................................28
  2.7.1. Edit X-axis Parameters .....................................................28
  2.7.2. Edit Y-axis Parameters .....................................................29
  2.7.3. Edit Line Parameters .......................................................30
  2.7.4. Background colors .......................................................31
2.8. Zoom ..................................................................................32
2.9. Hairline ..............................................................................33
2.10. Save to ASCII File ..............................................................34
2.11. Enter Values ........................................................................35
2.12. Print Trend ..........................................................................36

3. Measurement Reports 2 ..........................................................39
  3.1. Overview ............................................................................39
    3.1.1. Description ..................................................................39
    3.1.2. Features/options ..........................................................39
  3.2. General description of reports .............................................41
    3.2.1. Features and options ....................................................41
  3.3. Functional description of reports .........................................42
    3.3.1. Tabular form .................................................................43
      3.3.1.1. General ...............................................................43
      3.3.1.2. Tools menu ..........................................................43
    3.3.2. Graphical form .............................................................45
      3.3.2.1. General ...............................................................45
      3.3.2.2. Graphical form coordinates ..................................45
      3.3.2.3. Tools menu ..........................................................46
    3.3.3. Detailed functionality ...................................................47
      3.3.3.1. Scrolling backward and forward in time .............47
      3.3.3.2. Note dialog ..........................................................48
      3.3.3.3. Editing of period values ......................................49
      3.3.3.4. Save To a File .......................................................51
      3.3.3.5. Summer time - normal time ................................52
  3.3.4. Settings in graphical form .................................................53
    3.3.4.1. Edit Y-axis parameters ..........................................53
    3.3.4.2. Background colors ................................................53
3.4. Functional description of Quick Report ....................................53
  3.4.1. Overview ........................................................................53
  3.4.2. Tabular form .................................................................55
    3.4.2.1. General ...............................................................55
    3.4.2.2. Tools menu ..........................................................55
3.4.3. Graphical form .................................................................57
3.4.3.1. General ..............................................................57
3.4.3.2. Tools menu ........................................................57
3.4.4. Detailed functionality ........................................................59
3.4.4.1. Report Basket ....................................................60
3.4.4.2. Preconfigurations ..............................................61

4. Fault and Power Quality Reports in LIB 510 .........................63
   4.1. General description .............................................................63
      4.1.1. Purpose ..............................................................63
      4.1.2. Report generation ..................................................63
      4.1.3. Fault and Power Quality Reports output ..................64
6.2. Tools .................................................................64
      4.2.1. Fault and Power Quality Report Configuration tool ..........64
      4.2.2. Fault and Power Quality Reports Browser tool ............64
4.3. Configuring Fault and Power Quality Reports .......................65
   4.3.1. Browsing process objects ...........................................65
   4.3.2. Setting filters ..........................................................66
   4.3.3. Adding/deleting report generation ................................67
   4.3.4. Setting cross-reference modules ..................................68
   4.3.5. Setting Breakers Scadacode ......................................68
   4.3.6. Setting report generation options ...............................69
   4.3.7. Enabling and disabling Fault and Power Quality Reports Generation .................................................69
4.4. Working with the Report function output ..................................70
   4.4.1. Report format ..........................................................70
   4.4.2. Browsing report files with the Fault and Power Quality Report Browser tool .................................................71
   4.4.3. Observing event list ..................................................72
   4.4.4. Printouts .................................................................72
   4.4.5. Sending reports to DMS 600 or Open++ Opera ..............73
5. Index .........................................................................................75
1. About this manual

1.1. Copyrights

The information in this document is subject to change without notice and should not be construed as a commitment by ABB Oy. ABB Oy assumes no responsibility for any errors that may appear in this document.

In no event shall ABB Oy be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB Oy be liable for incidental or consequential damages arising from use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB Oy, and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license.

Copyright © 2006 ABB Oy
All rights reserved.

1.2. Trademarks

ABB is a registered trademark of ABB Group. All other brand or product names mentioned in this document may be trademarks or registered trademarks of their respective holders.

1.3. Guarantee

Please inquire about the terms of guarantee from your nearest ABB representative.

1.4. General

This manual provides you information on LIB 510 operation phase, where the prepared and configured application is used and connected to the process. The focus of this manual is set on using the LIB 510 related functionality after a proper configuration. The manual applies to the use of the library in MicroSCADA 8.4.4 or later and MicroSCADA Pro. If there are any exceptions concerning the library usage in the different product releases, those are mentioned separately. Pictures shown are examples only, and they may represent older program versions.

ABB Oy regularly provides standard training courses on its main products. The training program is available on the Internet at http://www.abb.com/substationautomation. Contact your ABB representative for more information.
1.5. **Use of symbols**

This publication includes warning, caution, and information icons that point out safety related conditions or other important information. It also includes tip icons to point out useful information to the reader. The corresponding icons should be interpreted as follows:

- **The caution icon** indicates important information or warning related to the concept discussed in the text. It might indicate the presence of a hazard which could result in corruption of software or damage to equipment or property.

- **The information icon** alerts the reader to relevant facts and conditions.

- **The tip icon** indicates advice on, for example, how to design your project or how to use a certain function.

Although warning hazards are related to personal injury, and caution hazards are associated with equipment or property damage, it should be understood that operation of damaged equipment could, under certain operational conditions, result in degraded process performance leading to personal injury or death. Therefore, comply fully with all warning and caution notices.

1.6. **Document conventions**

SCIL code, SCIL programs and file names are written with capital letters using Courier font. For example,

```
#SET TMP:VB_PICTURE_START_ARGUMENT = VECTOR
```

System prompts and messages and user responses and input are shown in Courier font. For example, *Are you sure you want to exit?*

Menu names and menu items are boldfaced. For example, **File** menu.

The names of push buttons are boldfaced. For example, click **OK**.

The following convention is used for menu operations: **Menu Name > Menu Item > Cascaded Menu Item**. For example, select **File > Save as**.

Capital letters are used for the name of a keyboard key if it is labelled on the keyboard. For example, press the **ENTER** key.

Press CTRL+C indicates that you must hold down the CTRL key while pressing the C key.
1.7. Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base picture</td>
<td>Background picture (the base on which the standard functions are installed).</td>
</tr>
<tr>
<td>LIB 500</td>
<td>Application Library 500, the common platform (Base) for ABB application engineering within MicroSCADA.</td>
</tr>
<tr>
<td>LIB 510</td>
<td></td>
</tr>
<tr>
<td>LIB 520</td>
<td></td>
</tr>
<tr>
<td>LIB 530</td>
<td></td>
</tr>
<tr>
<td>LIB 542</td>
<td>Application Libraries used together with LIB 500.</td>
</tr>
<tr>
<td>SCS</td>
<td>Substation Control System (a system for monitoring and controlling a complete substation); in this document MicroSCADA.</td>
</tr>
</tbody>
</table>

1.8. Abbreviations

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BBONE</td>
<td>Backbone</td>
</tr>
<tr>
<td>DTU</td>
<td>Disconnector Terminal Unit</td>
</tr>
<tr>
<td>HDB</td>
<td>History Database</td>
</tr>
<tr>
<td>HSI</td>
<td>Human system interface</td>
</tr>
<tr>
<td>HV</td>
<td>High voltage</td>
</tr>
<tr>
<td>IT</td>
<td>Installation Tool</td>
</tr>
<tr>
<td>LAN</td>
<td>Local Area Network</td>
</tr>
<tr>
<td>LEC</td>
<td>Local engineering center</td>
</tr>
<tr>
<td>LON</td>
<td>Local Operating Network, communication protocol developed by Echelon</td>
</tr>
<tr>
<td>MV</td>
<td>Medium voltage</td>
</tr>
<tr>
<td>NCC</td>
<td>Network Control Center</td>
</tr>
<tr>
<td>POT</td>
<td>Process Object Tool</td>
</tr>
<tr>
<td>RMU</td>
<td>Ring Main Unit</td>
</tr>
<tr>
<td>RT</td>
<td>Representation Tool</td>
</tr>
<tr>
<td>SCT</td>
<td>Standard Configuration Tool</td>
</tr>
<tr>
<td>SDD</td>
<td>System Design Description</td>
</tr>
<tr>
<td>SPA</td>
<td>Data communication protocol developed by ABB</td>
</tr>
<tr>
<td>TCP/IP</td>
<td>Transmission Control Protocol/Internet Protocol</td>
</tr>
</tbody>
</table>

1.9. Related documents

<table>
<thead>
<tr>
<th>Name of the manual</th>
<th>Document ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAP, LIB, SMS, Tools for Relays and Terminals, User’s Guide</td>
<td>1MRS752008-MUM</td>
</tr>
<tr>
<td>MicroSCADA Pro LIB 500 *4.2 Operation Manual</td>
<td>1MRS755359</td>
</tr>
<tr>
<td>MicroSCADA Pro LIB 500 *4.2 Configuration Manual</td>
<td>1MRS755360</td>
</tr>
<tr>
<td>MicroSCADA Pro LIB 510 *4.2 Configuration Manual</td>
<td>1MRS755362</td>
</tr>
<tr>
<td>MicroSCADA Pro LIB 510 *4.2 MV Process Operation Manual</td>
<td>1MRS755363</td>
</tr>
<tr>
<td>MicroSCADA Pro LIB 510 *4.2 MV Process Configuration Manual</td>
<td>1MRS755364</td>
</tr>
<tr>
<td>MicroSCADA Pro SYS 600 *9.0, System Overview, Technical Description</td>
<td>1MRS751852-MUM</td>
</tr>
<tr>
<td>MicroSCADA Pro, SYS 600 *9.1, Application Objects, Technical Description</td>
<td>1MRS751848-MEN</td>
</tr>
<tr>
<td>MicroSCADA Pro, SYS 600 *9.1, Programming Language SCIL, Technical Description</td>
<td>1MRS751849-MEN</td>
</tr>
</tbody>
</table>
You can find information on the DR-Collector, RED and SPACOM Relay Setting Tools, Disturbance Draw Tool, Event Editor and Power Quality Monitoring Tool in the Tools for Relays and Terminals manual.

1.10. Document revisions

<table>
<thead>
<tr>
<th>Version</th>
<th>SW revision number</th>
<th>Date</th>
<th>History</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>*4.1</td>
<td>30.06.2004</td>
<td>Document created</td>
</tr>
<tr>
<td>B</td>
<td>4.1-1, 4.0.5-2</td>
<td>20.12.2004</td>
<td>RET 54x additions</td>
</tr>
<tr>
<td>C</td>
<td>*4.2</td>
<td>08.07.2005</td>
<td>Fault and Power Quality Reports in LIB 510 (Ch. 4)</td>
</tr>
<tr>
<td>D</td>
<td>*4.2-1</td>
<td>07.02.2006</td>
<td>Maintenance updates</td>
</tr>
</tbody>
</table>
2. Trend Reports

2.1. Getting started

This chapter may be used as guidance on how to get started with Trend Reports, giving some useful references to other sections in this manual.

2.1.1. Starting Trend Reports

Trend Reports can be started by selecting Trends from the Reports menu. After this, the submenu of Trends also becomes visible (see Figure 2.1.1.-1).

![Starting the Trend Reports](image)

**Fig. 2.1.1.-1** Starting the Trend Reports

2.1.2. Selecting objects for the Trend Reports

The procedure how to select objects for the Trend Reports is described in detail in Section 2.5.
2.1.3. **Preparing preconfigured Trend Reports**

The procedure how to prepare preconfigured Trend Reports is described in detail in Section 2.6.

2.1.4. **Selecting preconfigured Trend Reports**

The procedure how to select preconfigured Trend Reports is described in detail in Section 2.5.3.1.

2.2. **Trend Reports**

2.2.1. **Description**

This tool is used within the LIB 500 Applications for trend analyses and for showing measured values in form of a curve or a table.

2.2.2. **Features/options**

- Graphical trend presentation (up to 10 trends)
- Tabular trend presentation (up to 10 trends)
- Hairline function
- Color configuration
- Line styles
- Scalable axis
- Scrolling in X and Y directions
- On/off switching of each curve
- Process data logging activation from station picture
- Update interval options from 30 seconds to 10 minutes
- Calculation formulas; direct, mean, sum and difference
- Trend data saving to file (Excel compatible)
- Zoom function
- Save/Open preconfigurations
- Possibility to enter values manually to a trend
- Printout option
- Authorization support
- Help in all dialogs

2.3. **Trend picture forms**

There are two trend picture forms: graphical and tabular form. A trend picture form is selected from the **Tools** menu or by clicking the corresponding button in the trend picture toolbar.

2.3.1. **Graphical form**

A trend is a time-related follow-up of process data. All types of process objects can be illustrated as trends:
The trends can be presented in a graphical form as full-graphic curves or in a tabular form. These two forms share the same trends, that is, process data and the presentation mode, but otherwise these forms can be used independently. This section describes the functionality of the graphical form picture.

2.3.1.1. **General functionality**

In the graphical form of the LIB 510 trend picture up to ten trends, that is, process data logs, can be presented as full-graphic curves on a two-dimensional coordinate system that consists of a horizontal time (X) axis and a vertical value (Y) axis. The curves can be scrolled both in the X- and Y-directions and the parameters of both the
axes, as well as the line parameters of the trend curves can be changed. All the curves can be temporarily hidden from the screen. The graphical form picture includes a multitude of tools, which will be described later in this chapter.

If a data registration has an invalid or an erroneous status, the curves will be drawn in magenta. In case of a not sampled or an erroneous status, the trend curve is given a Y-coordinate corresponding to zero value. This is done in order to be able to draw continuous curves when some values cannot be read. Manually entered values are indicated by cyan color.

2.3.2. Introduction to Trend Basket

The Trend Basket is a link between the station pictures (the process data) and the trend picture. In the station picture the user can select the process data to be presented in the trend picture by opening the basket dialog from the Tools menu and by selecting the symbol (picture function) of the process data. This will be described in detail in the section dealing with the Trend Basket. Note that logging of the selected process data will start when the Trend Basket is closed with the OK button in the station picture.

When the trend picture is shown, the user can select the data to be displayed in it by using the Trend Basket. When the Trend Basket is closed, the selected trends are brought to the trend picture and the parameters of the coordinate system are set according to the parameters of the trends.

2.3.3. Trend picture coordinates

The horizontal (X) axis of the trend picture coordinates represents the time of the trend, and the vertical (Y) axis represents the value of the trend. The X-axis is divided into 27 intervals, which by default represent the longest time interval between the consecutive registrations of the trends. The time of every third interval point is labelled below the X-axis. The date corresponding to the origin of the coordinates is also shown on the lower left corner of the graphical drawing area. The length of the interval and the end time of the X-axis, the time value furthest to the right, can be set with the Edit X-axis Parameters tool.

The Y-axis is divided into 20 intervals. The quarter point values of the Y-axis are marked on the left side of the Y-axis. It must be noted that the trend picture does not recognize any units or scales, only the values registered in the report database. To avoid confusion, trends with different units should not be shown at the same time.

When trends are brought to the trend picture, the axes are given the following parameters by default:

- X-axis interval is set as the longest registration interval of the selected trends (the longest sampling interval).
- X-axis end time is set as the latest registration of the selected trends.
- Y-axis maximum is set as the biggest registered value of the selected trends added with approximately 5% of the Y-axis length.
- Y-axis minimum is set as the smallest registered value of the selected trends subtracted by approximately 5% of the Y-axis length.
2.3.4. **Trend picture presentation modes**

The trend picture has two presentation modes, updating and frozen. When it is in the updating mode, the trend picture reads the new values of the selected trends and presents them at regular intervals. The time interval is the shortest registration period of the trends and it cannot be changed. In this way the loss of information is minimized. In the graphical form the new values are added to the right, and the curves are scrolled to the left accordingly.

When in the frozen mode, the trend picture is not updated in order to make it easier for the user to concentrate on specific trend information. The mode is automatically set to frozen when:

- Picture is zoomed or scrolled
- Basket dialog is opened
- Hairline is shown

Otherwise the mode can be selected from the toolbar or by opening the presentation mode dialog from the **Tools** menu.

2.3.5. **Trend picture preconfigurations**

The current set-up of the trend picture can be saved to a file. This provides an easy and fast way to switch from one set-up to another. The set-up can be saved by using the Trend Picture Preconfigurations tool. These preconfigurations can be opened from the Preconfigurations option of the basket dialog. The trend picture can be opened to show a preconfiguration by the LIB 500 standard menu.

2.3.6. **Trend picture tools**

The graphical form picture has a set of tools, which can be selected either from the toolbar or from the **Tools** menu. In the following the functionality of these tools is shortly described. More detailed information can be found in the sections further on.

---

**Fig. 2.3.6.-1  Trend graphical form toolbar**

**Table 2.3.6-1  Toolbar buttons**

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Trend Basket</td>
</tr>
<tr>
<td>2</td>
<td>Tabular Form</td>
</tr>
<tr>
<td>3</td>
<td>Presentation Mode (toggles between the updating/frozen mode)</td>
</tr>
<tr>
<td>4</td>
<td>Preconfigurations</td>
</tr>
<tr>
<td>5</td>
<td>Edit line parameters</td>
</tr>
<tr>
<td>6</td>
<td>Zoom in</td>
</tr>
<tr>
<td>7</td>
<td>Zoom out</td>
</tr>
<tr>
<td>8</td>
<td>Show/erase grid</td>
</tr>
<tr>
<td>9</td>
<td>Scroll one screen (=X-axis length) left</td>
</tr>
<tr>
<td>10</td>
<td>Scroll one step (=X-axis interval) left</td>
</tr>
</tbody>
</table>
Table 2.3.6-1  Toolbar buttons

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>Edit X-axis parameters</td>
</tr>
<tr>
<td>12</td>
<td>Scroll one step right</td>
</tr>
<tr>
<td>13</td>
<td>Scroll one screen right</td>
</tr>
<tr>
<td>14</td>
<td>Scroll one screen (=Y-axis length) down</td>
</tr>
<tr>
<td>15</td>
<td>Scroll one step (=Y-axis interval) down</td>
</tr>
<tr>
<td>16</td>
<td>Edit Y-axis parameters</td>
</tr>
<tr>
<td>17</td>
<td>Scroll one step up</td>
</tr>
<tr>
<td>18</td>
<td>Scroll one screen up</td>
</tr>
<tr>
<td>19</td>
<td>Scroll Hairline one step (=pixel) left</td>
</tr>
<tr>
<td>20</td>
<td>Show/erase Hairline</td>
</tr>
<tr>
<td>21</td>
<td>Scroll Hairline one step right</td>
</tr>
<tr>
<td>22</td>
<td>Trend identification</td>
</tr>
<tr>
<td>23</td>
<td>Help (graphical form main help)</td>
</tr>
</tbody>
</table>

Table 2.3.6-2  Functions in the Tools menu

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend Basket</td>
<td>Opens the Trend Basket dialog from which the trends, that is, logged process data, can be selected and the preconfigurations can be opened.</td>
</tr>
<tr>
<td>Tabular Form</td>
<td>Switches the trend picture to show the trends in a tabular form. The graphical form can be returned by clicking the corresponding button in the tabular form picture, so the two forms can be toggled.</td>
</tr>
<tr>
<td>Presentation Mode</td>
<td>In this case the toolbar button and the corresponding Tools menu item function differently. The menu item opens the Presentation Mode dialog, where the user can set the trend picture mode to frozen or updating, whereas the toolbar button toggles between the modes. The current mode is indicated by a field in the lower right part of the picture.</td>
</tr>
<tr>
<td>Preconfigurations</td>
<td>Opens the Trend Picture Preconfigurations dialog by which the current trend picture set-up can be saved.</td>
</tr>
</tbody>
</table>
Each trend curve has a button on the Trends on Screen list on the right side of the picture. With these buttons each trend curve in the picture can be shown or temporarily hidden. The background color of the graphical drawing area can be selected from the combo box in the lower right part of the picture. When black is selected, the axis, grid and the hairline are drawn in white.

2.3.8.
Tabular form

The trends can also be presented in a tabular form. The two forms, graphical and tabular, share the same trends and the presentation mode, but otherwise these forms can be used independently. This section describes the functionality of the tabular form picture.
The tabular form of the LIB 510 trend picture contains a scrollable list, where up to ten trends can be presented one by one. One line of the tabular form corresponds to one data registration.

These lines contain:

- Index
- Time stamp
- Status
- Value

The default accuracy is three decimals. A set of trend parameters, for example minimum, maximum, sum and average is presented for each trend. The user can switch from one trend to another by clicking a button. The tabular form picture includes a multitude of tools, which will be described later in this manual.
If a data registration has an invalid or an erroneous status, the corresponding line will be drawn in magenta. In case of a not sampled or an erroneous status the value is not shown. Manually entered values are indicated by cyan color.

The Trend Basket can be used in a similar way as in the graphical form picture. When new trends are brought into the picture, the first trend on the Trend Curves list is brought to the tabular form picture list.

2.3.8.2. Trend Parameters

Figure 2.3.8.-1 shows the Trend Parameters. This dialog can be accessed by selecting Tabular Form from the Tools menu. On the right side of the list, there is a group of fields containing parameters that are read from the logged process object or calculated from the data. These parameters are updated every time the trend picture is updated. The sum and average of the values will be drawn in magenta if the trend data contains registrations with invalid or manually entered status. The unit of the process object will be shown only if the object is of analog or pulse counter type. The color of the trend number corresponds to the line color in the graphical form picture.

2.3.8.3. Trend picture presentation modes

The tabular and the graphical form pictures share the same presentation mode, that is, the updating and frozen mode.

Since a MicroSCADA datalog is of buffer (FIFO) type, the oldest value will be dropped out and newer values will be moved by one step at update, if the datalog is filled to its maximum length. In this situation the scrollbar does not move at update because the datalog scrolls by itself.

When in the frozen mode, the trend picture is not updated in order to make it easier for the user to concentrate on specific trend information.

The mode is automatically set to frozen when:

- There are no trends to show
- List is scrolled by the scrollbar or tools
- Basket or enter values dialog is opened

Otherwise the mode can be selected from the toolbar button or by opening the presentation mode dialog from the Tools menu.

2.3.8.4. Trend picture tools

The tabular form picture has a set of tools, which can be used either by the toolbar buttons or from the Tools menu. The functionality of these tools will be shortly described in the following pages. More detailed information can be found in the dialog’s Help function.
Fig. 2.3.8.4.-1  Trend Toolbar

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Trend Basket</td>
</tr>
<tr>
<td>2</td>
<td>Graphical Form</td>
</tr>
<tr>
<td>3</td>
<td>Presentation Mode (toggles between the updating/frozen mode)</td>
</tr>
<tr>
<td>4</td>
<td>Save trend to a file</td>
</tr>
<tr>
<td>5</td>
<td>Enter values</td>
</tr>
<tr>
<td>6</td>
<td>Print trend</td>
</tr>
<tr>
<td>7</td>
<td>Show previous trend</td>
</tr>
<tr>
<td>8</td>
<td>Show next trend</td>
</tr>
<tr>
<td>9</td>
<td>Scroll one page up</td>
</tr>
<tr>
<td>10</td>
<td>Scroll one page down</td>
</tr>
<tr>
<td>11</td>
<td>Go to the beginning</td>
</tr>
<tr>
<td>12</td>
<td>Go to the end</td>
</tr>
<tr>
<td>13</td>
<td>Help (tabular form main help)</td>
</tr>
</tbody>
</table>

Table 2.3.8.4-1  Toolbar buttons

Fig. 2.3.8.4.-2  Tools menu of the Trend tabular form

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend Basket</td>
<td>Opens the Trend Basket dialog from which the trends can be selected and the preconfigurations can be opened.</td>
</tr>
<tr>
<td>Graphical Form</td>
<td>Switches the trend picture to show the trends in a graphical form. The tabular form can be returned by clicking the corresponding button in the graphical form picture, so the two forms can be toggled.</td>
</tr>
</tbody>
</table>
Presentation Mode

Figure 2.4.-1 shows the Presentation Mode dialog, which can be accessed by selecting Presentation Mode from the Tools menu. With this dialog the operator can select the presentation mode of the trend picture from two options: updating and frozen. When the mode is set to updating, the trend picture is updated at regular intervals. The length of the interval is defined by the current set of trends as the shortest interval between registrations. If the mode is set to frozen, the trend picture will not be updated.

The two radio buttons in the upper part of the dialog can be used to select the mode. The OK button applies the changes to the trend picture, Cancel withdraws all the changes.

Table 2.3.8.4-2  Trend Tools menu functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Presentation Mode</td>
<td>In this case the toolbar button and the corresponding Tools menu item function differs. The menu item opens the Presentation Mode dialog, where the user can set the trend picture mode to frozen or updating, whereas the toolbar button toggles between the modes. The current mode is indicated by a field in the upper right part of the picture.</td>
</tr>
<tr>
<td>Save to File</td>
<td>With this dialog any range of a trend can be saved to an ASCII file. The default format of the file is .CSV, where the columns are separated by a semicolon (;). This file type can be read by a spreadsheet program, for example Microsoft Excel.</td>
</tr>
<tr>
<td>Enter Values</td>
<td>With this tool the user can manually enter values into a trend. To enter values, select the Enter Values button from the toolbar or the corresponding item from the Tools menu. Then click the line of the wanted registration on the list. The line is shown highlighted, the presentation mode is set to frozen and the Enter Value dialog is opened.</td>
</tr>
<tr>
<td>Print Trend</td>
<td>With this tool the user can print a trend to a matrix printer, which is configured as a transparent printer in MicroSCADA.</td>
</tr>
<tr>
<td>Show Next/Previous Trend</td>
<td>These buttons/items bring the next or the previous trend to the list. As stated before, the set of trends is the same as in the graphical form. When a new trend is shown, the list is scrolled to show the latest registrations.</td>
</tr>
<tr>
<td>Scroll Page Up/Down</td>
<td>Scrolls the list one page (32 lines) up or down.</td>
</tr>
<tr>
<td>Go to Beginning/End</td>
<td>Scrolls the list to show the first or the latest registration.</td>
</tr>
<tr>
<td>Show Toolbar</td>
<td>Shows and hides the toolbar. Even if the toolbar is hidden, the tools can be used by the Tools menu.</td>
</tr>
</tbody>
</table>
2.5. Trend Basket

2.5.1. Functionality

The Trend Basket is a link between the station pictures (the process data) and the trend picture. With the Trend Basket dialog, the user can select data from the station picture to be logged and shown in the trend picture.

LIB 500 enables simultaneous logging of 20 process objects by default. The maximum length of these data logs is 2880 registrations, which equals to 48 hours with the update interval of one minute. The update interval can be selected from five options ranging from 30 seconds to 10 minutes. The logging function, that is, how the value is calculated before registration, can also be selected (see Trend Settings section for details).

The Trend Basket consists of two dialogs. The first dialog is shown in the station picture and the second in the trend picture. The dialogs have a similar appearance but a slightly different functionality. These dialogs will be described in the following sections.

2.5.2. Station Basket

Figure 2.5.2.-1 shows the Trend Basket dialog opened in the station picture. Its purpose is to set process objects from the station picture to the trend data logs.
In order to avoid irregularity in the data logs the trends are cleared (all registrations are removed):

- When the process objects to be logged are changed
- When the update interval or the logging function is changed
- On request by a specific button in the settings dialog

The basket main dialog has two lists: the Objects list to the left contains the process objects selected or searched from the station picture and the Trend Basket list to the right contains the objects that are logged and can be presented as trends. On both of these lists, each object is presented with two text lines. The upper line contains the object id and the lower line contains the object text. These two line blocks are separated by a dashed line. An empty block (no text between the dashed lines) in the Trend Basket list refers to a free trend.

There are two ways to read process object information from the station picture:

- By searching objects
- By selecting objects

The former searches for all the process objects contained in the picture functions of a station picture and the latter reads in all the process objects within a single picture function.

To search objects, click the **Search Objects** button. This opens the Search Information dialog, see Figure 2.5.2.-2, where the user can select whether to bring all the measurement process objects only, or all the process objects within the current station picture into the Objects list.

Note that since a station picture can contain thousands of process objects, this function should be used cautiously.
Fig. 2.5.2.-2  Search Information dialog

To select process objects, click the Select Objects button and the wanted picture function. This brings the process objects within the picture function onto the Objects list.

Table 2.5.2-1  Other buttons on the dialog work as follows

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add All</td>
<td>Adds all the objects from the Objects list to the Trend Basket list. If duplicates (objects that already are in the Trend Basket list) are found, an information dialog will be shown.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the selected objects from the Objects list to the Trend Basket list. If duplicates are found, an information dialog will be shown. If the number of free data logs in the Trend Basket list is smaller than the number of objects in the Objects list, this button will not be available.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected objects from the Trend Basket list.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Removes all the objects from the Trend Basket list.</td>
</tr>
<tr>
<td>Settings</td>
<td>Opens a dialog where the update intervals and logging functions can be changed and the trend cleared.</td>
</tr>
<tr>
<td>OK/Cancel</td>
<td>OK starts the logging of the selected objects. Cancel withdraws all the changes.</td>
</tr>
</tbody>
</table>

2.5.2.1.  Trend Settings

With this dialog the user can change the update intervals and logging functions of the trends, and also set the trend to be cleared (all registrations removed).

Fig. 2.5.2.1.-1  Trend Settings of the station picture
The number of the trend corresponding to its position in the Trend Basket list of the basket main dialog and the trend name (the object id and object text of the process object) are shown on the upper part of the dialog. The next or the previous trend can be selected with the arrow buttons beside the trend number field.

The Logging Function can be selected from the combo box on the lower left part of the dialog. The Logging Function determines the calculation, which is performed before the registration of a process object value.

**Table 2.5.2.1-1  Logging Function options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct</td>
<td>No calculation, the value is directly registered</td>
</tr>
<tr>
<td>Mean</td>
<td>The registered value is the mean of the previously registered values</td>
</tr>
<tr>
<td>Sum</td>
<td>The registered value is the sum of the registered values</td>
</tr>
<tr>
<td>Difference</td>
<td>The registered value is the difference between the two consecutive values</td>
</tr>
</tbody>
</table>

The Update Interval determines the sampling interval of the trend. It can be selected from the combo box on the lower right part of the dialog. There are five options ranging from 30 seconds to 10 minutes. Note that several trends with a short update interval can load the system remarkably.

In order to avoid irregularity in the data logs, the trends are cleared when the logging function or update interval is changed. To avoid data loss, a confirmation dialog is shown when these parameters are changed.

On the right side of the trend number field, there is a toggle button by which the trend can be cleared at exit, that is, when the main dialog of the basket is closed with **OK**.

The **OK** button in this dialog sets the changes to the basket main dialog. Clicking **Cancel** withdraws all the changes.

### 2.5.3. Trend Basket dialog

Figure 2.5.3.-1 shows the Trend Basket dialog opened in the trend picture. Its purpose is to set data from the trend data logs to the trend picture.
The Trend Basket dialog has two lists: the Trend Basket list to the left contains the objects that are logged and the Trend Curves list to the right contains the objects that are currently shown in the trend picture. On both of these lists each object is described with two text lines. The upper line contains the object id and the lower line contains the object text. These two line blocks are separated by a dashed line. An empty block (no text between the dashed lines) in the Trend Basket list refers to a free trend.

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add All</td>
<td>Adds all the objects from the Trend Basket list to the Trend Curves list. If duplicates (objects that already are in the Trend Basket list) are found, an information dialog will be shown and the duplicate will be removed.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the selected objects from the Trend Basket list to the Trend Curves list. If duplicates are found, an information dialog will be shown and the duplicate will be removed.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected objects from the Trend Curves list.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Removes all the objects from the Trend Curves list.</td>
</tr>
<tr>
<td>View Settings</td>
<td>Opens a dialog where the update intervals and logging functions can be viewed.</td>
</tr>
<tr>
<td>Preconfigurations</td>
<td>Opens a dialog from which a preconfiguration can be opened.</td>
</tr>
<tr>
<td>OK/Cancel</td>
<td><strong>OK</strong> sets the selected objects to the trend picture. <strong>Cancel</strong> withdraws all the changes.</td>
</tr>
</tbody>
</table>

### 2.5.3.1. Selecting Trend Picture Preconfigurations

With this dialog the user can open any of the trend picture preconfigurations, provided that at least one has been saved.
The names of the saved preconfigurations are shown on the list. One of the preconfigurations can be selected with the mouse. Clicking **OK** opens the preconfiguration, and clicking **Cancel** closes the dialog without making any changes.

---

**Preparation of Trend Picture Preconfigurations**

With this dialog (See Figure 2.6.-1) the user can save the current trend picture setup as a named preconfiguration, which can be opened from the basket dialog or from the LIB 500 standard menu. The following parameters are saved: the current set of trends (logged process objects), the trend curve line parameters (line style, line color and line width), the X-axis and Y-axis parameters and the background color.

The existing preconfigurations are shown on the list. The name of the configuration (max. 15 characters) must be entered into the field above the list before the preconfiguration can be saved. When the preconfiguration is opened, its name is set as the trend picture title.
The existing preconfigurations can be deleted and renamed. To delete a preconfiguration, select the preconfiguration in the question from the list and click the **Delete** button. To rename a preconfiguration, select the right one from the list and click the **Rename** button. This opens a new dialog where the new preconfiguration name can be entered.

If you want to open a preconfiguration, the included process objects must be logged, that is, remain in the Trend Basket.

Clicking the **OK** button saves the preconfiguration, **Cancel** withdraws all the changes. Saving a preconfiguration requires at least Engineering (2) level user authorization.

**2.7. Trend picture settings**

**2.7.1. Edit X-axis Parameters**

Figure 2.7.1.-1 can be accessed by selecting **Edit Parameters > X-axis** from the **Tools** menu. With this dialog the user can edit the X-axis parameters of the LIB 510 trend picture. These parameters include the X-axis time interval and the X-axis end time (the time value furthest to the right on the X-axis).
Fig. 2.7.1.-1  *Edit X-axis Parameters dialog*

The Time Interval of the X-axis can be selected from the combo box on the lower part of the dialog. When the interval is changed, the end time of the X-axis remains the same and the trend curves are shown according to the new interval.

The end time of the X-axis can be set either by entering new values into the fields or by setting the values stepwise with the arrow buttons beside each field. If the entered value is invalid, the old value will be returned to the field.

The **OK** button sets the changes to the trend picture, **Cancel** withdraws all the changes.

### 2.7.2. Edit Y-axis Parameters

With this dialog the user can edit the Y-axis parameters of the LIB 510 trend picture. These parameters include the minimum and maximum of the Y-axis.
Fig. 2.7.2.-1 Edit Y-axis Parameters dialog

The minimum and maximum of the Y-axis can be set either by entering new values to the fields or by setting the values stepwise with the arrow buttons beside each field. These buttons increase or decrease the value by 10%. If the entered value is invalid, the old value will be returned to the field.

The Y-axis can be set to the left or right side of the trend picture according to the selection in the Show Y-axis drop-down list.

The OK button applies the changes to the trend picture, Cancel withdraws all the changes.

2.7.3. Edit Line Parameters

Figure 2.7.3.-1 can be accessed by selecting Edit Parameters > Lines from the Tools menu. With this dialog the user can edit the trend curve line parameters of the LIB 510 trend picture. These parameters include the line style, line color and line width.
Fig. 2.7.3.-1  Edit Line Parameters dialog

The arrow buttons beside the trend number field produce the line parameters of the next or previous trend on the dialog. The trend name (the object id and the object text of the logged process object) is shown in the two fields in the upper part of the dialog.

The line style can be selected from three options with the radio buttons in the lower left part of the dialog. A sample line is shown beside each button.

The line color can be selected from the color palette in the middle of the dialog. A set of ten predefined colors is offered.

The line width can be set either by entering the value into the field or stepwise with the arrow buttons beside the field. Line width values are valid from one to five pixels. If a non-valid value is entered, the old value will be returned.

The **OK** button applies the changes to the trend picture, **Cancel** withdraws all the changes.

### 2.7.4. Background colors

The background color of the graphical drawing area can be selected from the combo box (see Figure 2.7.4.-1) in the lower right part of, for example, Figure 2.9.-1. When black is selected for the background color, the axis, the grid and the hairline are drawn in white.
2.8. **Zoom**

Zooming in takes place as follows: first click the **Zoom In** button or the corresponding menu item and then select the wanted area inside the grid area by dragging with the mouse. A box (1) is shown to illustrate the selected area (See Figure 2.8.-1 and Figure 2.8.-2). Zooming out, which returns the previous view, is done by clicking the **Zoom Out** button/item.
2.9. Hairline

There are three ways to move the hairline:

1. By clicking the button on the top of the hairline and dragging it within the grid area
2. Stepwise by using the arrow buttons on both sides of the "H" button
3. By using the corresponding menu items.

When the hairline is moved, the trend values corresponding to the hairline time are shown in the fields on the right side of the picture (see Figure 2.9.-1).
2.10. **Save to ASCII File**

With this dialog the user can save the trend currently on the tabular form list to an ASCII file. The whole trend or a selected index range can be saved. The saved ASCII file contains the following data:

- Index
- Time stamp
- Status code (integer)
- Value

The default accuracy of the value is three decimals. In case of a not sampled or an erroneous status, the value is not saved. The default format of the file is .CSV, where the columns are separated by a semicolon (;). This file type can be read by a spreadsheet program, for example Microsoft Excel.

**Fig. 2.9.-1 Trend Hairline**
The existing file names are shown on the list and the directory (which is configurable) is shown under the list. The name of the file to be saved must be entered into the field above the list before the file can be saved. The maximum length of the name is ten characters. Selecting any name from the list with the mouse sets the selected name to the name field where it can be edited or the existing file can be overwritten.

Under the directory name there is a pair of radio buttons for selecting the Index Range. If the upper button is set, the whole trend will be saved. If the lower button is set, the trend will be saved according to the Index Range defined by the values in the fields next to the button. The first and the last index are given as default, but the wanted indexes can be entered into the fields.

The OK button saves the trend, Cancel only closes this dialog.

Saving a wide range of a trend can load the system temporarily.

2.11. Enter Values

With this dialog the user can enter values into a trend manually and one by one. If default colors are used, the manually entered values will be shown in blue in the tabular form and in cyan in the graphical form.
You can choose this option by clicking the toolbar button or by selecting **Enter Values** in the **Tools** menu (in the tabular form).

After you have chosen this option, select the right line on the list by clicking it with the mouse. This procedure opens the dialog shown below (Figure 2.11.-1).

![Enter Value dialog](image)

**Fig. 2.11.-1 Enter Value dialog**

The fields of this dialog show the Index, Time of Registration, Status and Value of the selected registration. The New Value field shows the current value as the default new value to be entered into the trend. If the current value does not exist due to an erroneous or not sampled status, the default new value will be zero. The new value can also be typed in the field.

Type a new value into the New Value field when the cursor is flashing. You can move the cursor to the right or left with the arrow keys on the keyboard. After you have changed the value, press the ENTER key and click **OK**. The whole line appears on the screen in blue with a changed status text “Man. Entered.”

The **OK** button applies the new value to the trend and sets the mode to updating, **Cancel** only closes this dialog. Note that the time of registration remains the same.

### 2.12. Print Trend

Figure 2.12.-1 shows the Print Trend dialog. It is used for printing the trend currently on the tabular form list to a matrix printer, which is configured as a transparent printer in MicroSCADA. The whole trend or a selected index range can be printed. The printout contains the index, time stamp, status text and value data. The default accuracy of the value is three decimals. In case of a not sampled or an erroneous status the value is not printed.
Fig. 2.12.-1 Print Trend dialog

A header is printed on the top and a page number at the bottom of each page. The header consists of the name of the trend and a time stamp indicating the time of printing.

Transparent printers found in the printer mapping vector of the current application can be selected from the “To:” combo box in the upper left part of the dialog. Note that if no transparent printers are found, the OK button of the dialog will not be available and the trend cannot be printed.

The user can set the wanted number of lines per page to be printed in the “Lines/Page” in the upper right part of the dialog. The default value is 63 and the range is from 1 to 999 lines per page.

Under the combo box there is a pair of radio buttons for selecting the Index Range. If the upper button is set, the whole trend will be printed. If the lower button is set, the trend will be printed according to the Index Range defined by the values in the fields next to the button. The first and last indexes are given as default, but the wanted indexes can be entered into the fields. The OK button prints the trend, Cancel withdraws all the changes.

Printing a wide range of a trend can load the system temporarily.
3. Measurement Reports 2

3.1. Overview

3.1.1. Description

The Measurement Reports 2 is used within the LIB 500 Applications for various types of time related reports, for example hourly, daily, weekly, monthly and yearly reports. The Measurement Reports 2 can be used, for instance, for:

- Reporting of energy (active, reactive)
- Reporting of current (for example bay level)
- Reporting of voltage (for example bay level)
- Reporting of frequency
- Reporting of temperature
- Reporting of district heating

Generally, reports are time-related follow-ups of process, metered, entered or calculated data. All types of data can be illustrated as reports. All the data for the reports are calculated and stored in real time. Report data is collected and calculated either cyclically or triggered by events. The most common method is to collect raw data from the process, and thereafter to refine it and store it in the report database.

The collection and calculation of report data can be initiated in the following ways:

- At predefined time intervals
- When a predefined event occurs
- As a result of a calculation
- Based on a condition
- On operator's request

3.1.2. Features/options

The Measurement Reports 2 is based on a divided system structure and it consists of the Report HSI, Report Base and Report Tool. Each component is independent from the others and provides a set of functions for installing, configuring, defining, and monitoring the user specific reports. The divided structure and independent components allow a dynamic and a wide variety of using reports.

The Measurement Reports 2 supports the following time related reports:

- Hourly Report (time resolution: 3 minutes)
- Daily Report (time resolution: 15 minutes)
- Daily Report (time resolution: 30 minutes)
- Daily Report (time resolution: 60 minutes)
- Weekly Report (time resolution: 1 day)
- Monthly Report (time resolution: 1 day)
- Yearly Report (time resolution: 1 month)
- Quick Report on a daily basis (time resolution: according to a period cycle)
- Quick Report on a weekly basis (time resolution: 1 day)
- Quick Report on a monthly basis (time resolution: 1 day)
- Quick Report on a yearly basis (time resolution: 1 month)

Each report picture is composed of a report base picture function and a number of report columns. The report base picture includes all the common functions (for example report header, type and unit) which are usable within the report pictures. The report columns consist of different types of data, for example points of time, measured, metered, manually entered or calculated values. All the data values within the report can be presented either in a tabular (numerical) or in a graphical form as full-graphic curves. A report picture can contain a maximum of 11 columns per report page, including the time column.

The Report Base includes a set of functions (for example database, data collection, calculation and storing methods), which provide an interface between the real time process and the report pictures. Within these functions the real time data from the process is collected, calculated and stored into the report database and then displayed in the report pictures.

The Report Tool includes a set of functions, which provide report specific tools for installing and configuring the Report Base (for example the configuration of the report object, calculation and database settings) and the Report HSI (the configuration of the report picture columns) when defining the user specific reports.

General features and options of the LIB 510 Measurement Reports 2 are:
- Improved architecture: Report HSI, Report Base and Report Tool
- Report presentations in a tabular (numerical) and in a graphical form
- Several report pages can be displayed within one report picture
- Special days supported through the Calendar Tool
- Configurable report objects
- Dynamic report object handling
- All types of process objects can be illustrated as reports
- Dynamic calculation operations enabled
- User specific definitions enabled
- Base period intervals configurable: 15, 30 or 60 minutes
- History length for the sampled values and period values configurable
- Forecast period area enabled on a daily basis
- Beginning of the day and week configurable
- Application specific definitions enabled
3.2. General description of reports

The Report HSI provides a user-friendly interface for data analysis and for showing values in a tabular (numerical) and in a graphical form. It can be used, for example, for monitoring measured, metered, entered or calculated values, showing the history of values, predicted future values, entering/correcting values, and so on.

3.2.1. Features and options

- Report header *
- Report type *
- Report unit *
- Report scale *
- Time column
- Report columns *
- Summary columns *
• Tabular presentation
• Graphical presentation
• Selecting a specific time from the history and the future (if the forecast period area is enabled)
• Scrolling backward and forward in the history and in the future (if the forecast period area is enabled)
• Editing of period values *
• Tagging of manually entered values *
• Tracing of edited values via the log file *
• Marking of values with status "unreliable", "manually entered" or "Error", in case of an erroneous status
• Note dialog
• Scalable axis (in a graphical form)
• Scrolling in the X and Y direction (in a graphical form)
• On/off switching of each curve (in a graphical form)
• On/off switching of grid (in a graphical form)
• Load-duration curves (in a graphical form)
• Report data saving to a file (ASCII and .CSV format)
• Printout option
• Multiple report pages *
• Report specific menu *
• Authorization support *
• Help files
• Quick reporting with preconfigurations (only within the Quick Report)

The ones marked with * are options within the report picture. These attributes can be configured by the user (for details, refer to the chapter about Measurement Reports 2 in the LIB 510 Configuration Manual, see “Related documents” on page 9).

3.3. Functional description of reports

All the reports can be presented in a tabular or in a graphical form as full-graphic curves. These two forms share the same report base, that is, report data, and presentation mode, but otherwise these forms can be used independently. This chapter describes the functionality of the tabular and the graphical form picture.

The whole functionality is described as it is in the Daily Reports, but the same functionality also applies to other standard reports. All the exceptions are notified separately.
3.3.1. Tabular form

3.3.1.1. General

In the tabular form of the report picture, up to ten measurements can be presented at the same time; each measurement is shown in an individually configured report column. Measurements can be based on the measurements of the process (consisting of one or several process data objects), metered, manually entered or calculated values.

The tabular form contains:

- Time column
- Report columns
- Summary columns

The default accuracy of report columns is two decimals, but they can also be individually configured column by column. A set of summary information, for example day energy, night energy, sum and maximum, are presented for each report column.

A set of summary information is dependent on the time relation of the report.

If a data registration has an uncertain or an obsolete status, the corresponding line will be represented with the character "?". Manually entered values are indicated with the character "m". An erroneous status is indicated with an "Error" message. In case of a not sampled or an erroneous status, the value is not shown.

If several report pages are enabled to be shown within the report picture, the current report page can be selected in the combo box in the upper right part of the picture.

Editing and entering values manually is possible only in the Daily Report within a period cycle. Editing or entering values will not change the time of registration. The color of the value depends on the time stamp of the value. Historical data is shown in black, current and predicted future data in white (if shown).

All the reports are also printable, for example, to the file in the ASCII or in the .CSV format (Excel compatible), or to the net printer. The tabular form also includes a multitude of tools, which will be described later in this chapter.

3.3.1.2. Tools menu

The tabular form picture has a set of tools, which can be selected either from the toolbar or from the Tools menu. The functionality of these tools is shortly described in the following pages.

Fig. 3.3.1.2.-1 Toolbar of the Daily Report tabular form
Table 3.3.1.2-1 Daily Report’s Tools menu functions

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Day</strong></td>
<td>Opens the Select Day dialog from which the wanted day in the report can be selected.</td>
</tr>
<tr>
<td><strong>Previous Day</strong></td>
<td>Goes to the previous day in the report. If the previous day is out of the history area, the Previous Day option will be dimmed.</td>
</tr>
<tr>
<td><strong>Next Day</strong></td>
<td>Goes to the next day in the report. If the next day is out of the history area, the Next Day option will be dimmed.</td>
</tr>
<tr>
<td><strong>Tabular/Graphical</strong></td>
<td>Switches the report picture to show the measurements in a graphical form. The tabular form can be returned by clicking the corresponding button in the graphical form picture, so it is possible to toggle between the two forms.</td>
</tr>
<tr>
<td><strong>Print to file (ASCII)</strong></td>
<td>With this option the current report day can be saved to an ASCII file, where the columns are tabulated in the same way as in the report picture.</td>
</tr>
</tbody>
</table>
3.3.2. Graphical form

3.3.2.1. General

In the graphical form of the report picture up to ten measurements can be presented as full-graphic curves on a two-dimensional coordinate system that consists of a horizontal time (X) axis and a vertical value (Y) axis. The curves can be scrolled both in the X and Y directions and the parameters of the Y-axis can be changed. All the curves can be temporarily hidden from the screen. The graphical form picture includes a multitude of tools, which will be described later in this chapter.

If a data registration has an invalid or an erroneous status, the curves will be drawn in magenta. In case of a not sampled or an erroneous status the curve is given a Y-coordinate corresponding to zero value. This is done in order to be able to draw continuous curves when some values cannot be read. Manually entered values are indicated in cyan color.

If several report pages are enabled to be shown within the report picture, the current report page can be selected in the combo box in the upper right part of the picture.

3.3.2.2. Graphical form coordinates

The horizontal (X) axis of the graphical form coordinates represents the time of the measurement, and the vertical (Y) axis represents the value of the measurement. The X-axis is divided into intervals of hours. The time of every third interval point is labelled below the X-axis.

The Y-axis is divided into 20 intervals. The quarter point values of the Y-axis are marked on the left side of the Y-axis. It must be noted that the graphical form does not recognise any units or scales, only the values registered in the report database. To avoid confusion, trends with different units should not be shown at the same time.
When trends are brought to the graphical form, the axes are given the following parameters by default:

- X-axis times are set to correspond with the current day of the report.
- Y-axis maximum is set as the biggest registered value of the selected measurements added with approximately 5% of the Y-axis length.
- Y-axis minimum is set as the smallest registered value of the selected trends.

### 3.3.2.3. Tools menu

The graphical form picture has a set of tools, which can be selected either from the toolbar or from the **Tools** menu. The functionality of these tools is shortly described in the following pages.

![Toolbar of the Daily Report graphical form](image1.png)

**Fig. 3.3.2.3.-1** Toolbar of the Daily Report graphical form

![Tools menu of the Daily Report graphical form](image2.png)

**Fig. 3.3.2.3.-2** Tools menu of the Daily Report graphical form
MicroSCADA Pro

Operation Manual

### Table 3.3.2.3-1 Daily Report's Tools menu functions

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Day</td>
<td>Opens the Select Day dialog from which the wanted day in the report can be selected.</td>
</tr>
<tr>
<td>Previous Day</td>
<td>Goes to the previous day in the report. If the previous day is out of the history area, the Previous Day option will be dimmed.</td>
</tr>
<tr>
<td>Next Day</td>
<td>Goes to the next day in the report. If the next day is out of the history area, the Next Day option will be dimmed.</td>
</tr>
<tr>
<td>Tabular/Graphical</td>
<td>Switches the report picture to show the measurements in a graphical form. The tabular form can be returned by clicking the corresponding button in the graphical form picture, so the two forms can be toggled.</td>
</tr>
<tr>
<td>Grid on/off</td>
<td>Shows or hides the grid. The curve values outside the grid area are cut regardless of whether the grid is shown or not.</td>
</tr>
<tr>
<td>Edit Y - Scale</td>
<td>Opens a dialog where the parameters of the Y-axis can be set.</td>
</tr>
<tr>
<td>Scroll Down</td>
<td>The curves can be scrolled vertically by the arrow buttons or by the corresponding Tools menu items. Scroll Down scrolls the curves one step (interval) down.</td>
</tr>
<tr>
<td>Scroll Up</td>
<td>The curves can be scrolled vertically by the arrow buttons or by the corresponding Tools menu items. Scroll Up scrolls the curves one step (interval) up.</td>
</tr>
<tr>
<td>Load-dur./Load Curve</td>
<td>Switches the measurement curves to the load duration curves. The load curves can be returned by clicking the corresponding button, so the two forms can be toggled.</td>
</tr>
<tr>
<td>Print to file (ASCII)</td>
<td>With this option the current report day can be saved to an ASCII file, where the columns are tabulated in the same way as in the report picture.</td>
</tr>
<tr>
<td>Print to file (.CSV)</td>
<td>With this option the current report day can be saved to an ASCII file. The default format of the file is .CSV, where the columns are separated by a semicolon (;). This file type can be read by a spreadsheet program, for example Microsoft Excel.</td>
</tr>
<tr>
<td>Print to printer</td>
<td>With this tool the user can print the current report day to a net printer, which is configured as a VS Printer in MicroSCADA. This option will be dimmed, if the X monitor is used.</td>
</tr>
<tr>
<td>Show Leap Hour</td>
<td>Opens the Show Leap Hour dialog in that specific day when the daylight saving time has been activated. Within the Show Leap Hour dialog the extra hour values can be seen and edited, if necessary.</td>
</tr>
<tr>
<td>Help</td>
<td>Opens the Help dialog.</td>
</tr>
</tbody>
</table>

### 3.3.3. Detailed functionality

#### 3.3.3.1. Scrolling backward and forward in time

The Measurement Reports provide the means for browsing backward and forward in time - one hour, day, month or year at a time. The browsing interval is related to the time relation of the report type. In addition, a distinct hour, day, month or year can be selected directly.
Scrolling backward in time

In order to browse backward one day at a time in the Daily Report, select the Previous Day button from the toolbar. The button is dimmed when it is not applicable. The Previous Day option is also available in the Tools menu. The maximum time for browsing backward in time is dependent on the length of history (for details, refer to the chapter about Measurement Reports 2 in the LIB 510 Configuration Manual see “Related documents” on page 9). When the length of history is exceeded, the option for browsing backward is not available.

Scrolling forward in time

In order to browse forward one day at a time in the Daily Report, click the Next Day button from the toolbar of the Daily Report tabular form. The button is dimmed when it is not applicable. The Next Day option is also available in the Tools menu. The maximum time for browsing forward in time is dependent on the time of the forecast period area. (for details, refer to the chapter about Measurement Reports 2 in the LIB 510 Configuration Manual, see “Related documents” on page 9) When the time of the forecast period area is exceeded, the option for browsing forward is not available.

Selecting a distinct day

In order to select a distinct day, open the Select Day dialog by clicking the Select Day button on the toolbar or by selecting the Select Day option from the Tools menu. As the dialog is opened, the current day is shown as default. To select a distinct day in the history, give a wanted day to the input field and press the ENTER key. Confirm the selection by clicking the OK button. If the Cancel button is clicked, the day before the selection will be preserved. When the given time is out of the history area or the given time is not properly given, an error dialog is presented and the day before the selection is preserved.

![Select Day dialog](image.png)

**Fig. 3.3.3.1.-1 Select Day dialog**

3.3.2.

Note dialog

Note marks can be freely added and placed into the report pictures. When a specified period is clicked in the Time column (See Figure 3.2.-1), a dialog is opened for displaying and writing a note for that specific period. The note dialog can be opened for every period in the report picture and all the notes are report picture specific (See Figure 3.3.3.2.-1). The opening of the note dialog requires at least Control (1) level user authorization.
A note can be written into the field by clicking on it. Confirm the changes by clicking the OK button. By clicking Cancel all the changes are withdrawn. A selected note mark can be removed by clicking the Remove Note button. If another time period is clicked while the note dialog is open, it is understood as "Cancel" and the dialog is opened for that new period.

If a certain time period contains any note marks, an exclamation mark (!) will be shown beside the time period in yellow.

![Note Dialog](image)

**Fig. 3.3.3.2.-1 Example of Note dialog**

### 3.3.3.3. Editing of period values

Data included in the Daily Reports can be corrected or edited with the Edit Value dialog (see Figure 3.3.3.3.-1), if the correction/editing mode is enabled. The corrected or edited values are stored into the report database, and other values (for example calculated) which are dependent on it are automatically recalculated using the new value.

Data included in the Daily Reports can be corrected or edited as follows:

- In order to edit one value at a time, select one item in the report column by clicking on it. If editing is enabled in the current column, the color of the values will be changed into brown and the Edit Value dialog will be opened (if not already open). Select the scrolling mode on, if you want to edit several values.
- In order to edit several values at a time, select an area to be edited. If editing is enabled in the current column, the color of the values will be changed into brown and the Edit Value dialog will be opened (if not already open).
- In order to copy one or several values, select one item or an area to be copied. Confirm the copy area by selecting More > Copy values.
- Enter a new value by first clicking the input field and then giving a new value by using the keyboard. Accept the new value by pressing ENTER. Complete editing by clicking the OK button. If the Cancel button is clicked instead of the OK button, the old value will be preserved.
- If paste (More > Paste values) is used instead of a new value, the copied values will be copied to the selected area. The length of the selected area must be equal...
to the length of the copied area. Complete the editing by clicking the **OK** button. If you click **Cancel**, all the changes will be withdrawn.

When the scrolling mode is on, the following value in the report is automatically selected for editing. This value can be edited or editing can be completed by first pressing the ESC key, and then clicking the **Cancel** button.

The editing of period values requires at least Control (1) level user authorization.

![Fig. 3.3.3.3.-1 Editing of period values in the Daily Report](image)

If the tracing of edited values is enabled in the selected column, all the edit information will be written into a log file at the same time when the corrected or edited values are stored into the report database. In order to view the log file, select **More > Show log file**. (Note that this option will not be available if the X-monitor is used.)
The following edit information will be written into a log file:

- Date and time
- Report object name (LN)
- Report object comment (CM)
- Edited time period
- Old value and status
- New value
- User name

The log file can consist of up to 1000 edited events. When the number of the edited events is exceeded, the report alarm object will be activated, the exceeded log file will be renamed (default path `/apl/<apl.name>/reports/fmu_edit.old`), and a new log file will be generated.

![Example of the log file](image)

**3.3.3.4. Save To a File**

By using the Save Report Page To File dialog (see Figure 3.3.3.4.-1) the current report page can be saved to an ASCII file, where the columns are tabulated in the same way as in the report picture. The current report page can also be saved to a .CSV file, where the columns are separated by a semicolon (;) by default (configurable). The file type of .CSV can be read by a spreadsheet program, for example Microsoft Excel.

The default format of the file is ASCII (.CSV format can be selected from the Tools menu). The existing file names are shown on the list and the directory (which is configurable) is shown under the list. The name of the file to be saved must be entered into the field above the list before the file can be saved. The maximum length of the name is ten (10) characters. Selecting any name from the list with the mouse sets the selected name to the name field where it can be edited or the existing file can be overwritten.

Under the directory name there is a pair of radio buttons for selecting the Save option. If the Over button is set, the current report page will be saved to a specified file and all the existing data will be overwritten. If the Append button is set, the current report page will be appended to a specified file.
The **OK** button saves the report page to a file, the **Cancel** button only closes this dialog.

![Save Report Page to File dialog](Image)

**Fig. 3.3.3.4.-1 Save Report Page to File dialog**

### 3.3.3.5. Summer time - normal time

If Daylight saving from the Application Settings is set in use, the system time will be automatically changed from normal time to summer time and vice versa. The change of time is taken into account in the LIB 510 Measurement Reports 2 as follows:

- In the autumn, the report values of the extra hour are automatically moved to the highest index or indexes (dependent on the base period) of the data object. The extra hour is taken into account when, for example, the day sums are calculated.
- In the Daily Reports the daylight saving note will be shown in the information bar in that specific day when the daylight saving time has been activated. The extra hour values can also be seen and corrected in that specific day by selecting the **Show Leap Hour** option from the **Tools** menu.

In the spring, the values of the hour in question will be unlogged.

When using the reports, it is recommended to define the point of the time change to be a few minutes past an even hour (when the execution delay time for period values is exceeded) in order to enable calculation update for period values before the time settings. It is also recommended that the time settings take place before the next period cycle routines are executed.
3.3.4. Settings in graphical form

3.3.4.1. Edit Y-axis parameters

The Edit Y-axis Parameters dialog can be opened by clicking the \( Y \) button on the toolbar of the Daily Report graphical form. With the Edit Y-axis Parameters dialog the user can edit the Y-axis parameters of the report when the graphical form is presented. These parameters include the minimum and maximum values of the Y-axis.

The minimum and maximum values of the Y-axis can be set either by entering new values into the fields or by setting the values stepwise with the arrow buttons beside each field. These buttons increase or decrease the value by 10%. If the entered value is invalid, the old value will be returned into the field.

If you click the **OK** button, the changes will be applied to the graphical picture. The **Cancel** button withdraws all the changes.

![Edit Y-axis Parameters dialog](image)

**Fig. 3.3.4.1.-1 Edit Y-axis Parameters dialog**

3.3.4.2. Background colors

The background color of the graphical drawing area (which is configurable) can be selected from the combo box in the lower right part of the picture. When black is selected for the background color, the axis and the grid are drawn in white.

![Background color of trend](image)

**Fig. 3.3.4.2.-1 Background color of trend**

3.4. Functional description of Quick Report

3.4.1. Overview

In addition to standard time related reports, the Measurement Reports also includes the Quick Report on daily, weekly, monthly and yearly basis. The Quick Report is basically a report browser, which is able to show all the report objects...
defined within the report application in the same report picture. The objects to be shown at a time can be selected through a report basket or from the report page list (the combo box in the upper right part of the picture) where all the preconfigurations are shown, provided that at least one has been saved.

When exiting from the Quick Report, the current set-up is saved as user specific. Next time when the user opens up the Quick Report, the last set-up is shown by default. The last set-up is marked with the character * on the report page list.

This chapter describes the functionality of the Quick Report picture. Generally, the Quick Report picture is like a standard Daily/Weekly/Monthly/Yearly Report; it includes the same functions and options, but it also has some added ones. The Quick Report can also be used without a predefined picture function installation.
3.4.2. Tabular form

3.4.2.1. General

In the tabular form of the Quick Report picture, all the selected report objects are shown in the report picture by the selection order. Up to ten objects can be displayed on the screen at the same time. If the selection consists of more than ten objects, the objects shown on the screen can be selected with the help of the vertical scroll bar.

The report column title is the same as the logical name of the report object. If the title bar is clicked with the mouse, the Comment Text dialog will be opened. The dialog shows the comment of the report object and also its type and unit. The default accuracy of the report columns is two decimals. A set of summary information (sum, mean, min. and max.) is presented for each report column.

If a data registration has an uncertain or an obsolete status, the corresponding line will be represented with the character "?". Manually entered values are indicated with the character "m". An erroneous status is indicated with an "Error" message. In case of a not sampled or an erroneous status the value is not shown.

For the Daily Quick Report, editing and entering values manually is possible for the following report object types (by default):

• Measured objects (MS, MM, MN, MX and MP) *
• Entered objects (EN)
• Gauge (meter) objects (GA) *

The tracing of edited values is also enabled for the report object types marked with *. The report object types are explained in more detail in the LIB 510 Configuration Manual, refer to the chapter about Measurement Reports 2 (see "Related documents" on page 9).

Editing or entering values will not change the time of registration. The color of the value depends on the time stamp of the value. Historical data is shown in black, current and predicted future data in white (if shown).

All the reports are also printable, for example to the file in the ASCII or in the .CSV format (Excel compatible) or to the net printer.

3.4.2.2. Tools menu

Fig. 3.4.2.2.-1  Toolbar of the Quick Report tabular form
Table 3.4.2.2-1 Quick Report Tools menu functions

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Day</td>
<td>Opens the Select Day dialog from which the wanted day in the report can be selected.</td>
</tr>
<tr>
<td>Previous Day</td>
<td>Goes to the previous day in the report. If the previous day is out of the history area, the Previous Day option will be dimmed.</td>
</tr>
<tr>
<td>Next Day</td>
<td>Goes to the next day in the report. If the next day is out of the history area, the Next Day option will be dimmed.</td>
</tr>
<tr>
<td>Tabular/Graphical</td>
<td>Switches the report picture to show the measurements in a graphical form. The tabular form can be returned by clicking the corresponding button in the graphical form picture, so the two forms can be toggled.</td>
</tr>
<tr>
<td>Print to file (ASCII)</td>
<td>With this option the current report day can be saved to an ASCII file, where the columns are tabulated in the same way as in the report picture.</td>
</tr>
</tbody>
</table>
3.4.3. Graphical form

3.4.3.1. General

In the graphical form of the Quick Report picture, all the report objects shown on the screen can be presented as full-graphic curves on a two-dimensional coordinate system that consists of a horizontal time (X) axis and a vertical value (Y) axis. The curves can be scrolled both in the X- and Y-directions and the parameters of the Y-axis can be changed. All the curves can be temporarily hidden from the screen.

Otherwise the functionality and options are as in the standard reports, which were described in Section 3.3.

3.4.3.2. Tools menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print to file (.CSV)</td>
<td>With this option the current report day can be saved to an ASCII file. The default format of the file is .CSV, where the columns are separated by a semicolon (;). This file type can be read by a spreadsheet program, for example Microsoft Excel.</td>
</tr>
<tr>
<td>Print to printer</td>
<td>With this tool the user can print the current report day to a net printer, which is configured as a VS Printer in MicroSCADA. This option will be dimmed, if the X monitor is used.</td>
</tr>
<tr>
<td>Report Basket</td>
<td>Opens the Report Basket dialog from which the report objects can be selected to be shown in the Quick Report picture.</td>
</tr>
<tr>
<td>Preconfigurations</td>
<td>Opens the Save Preconfiguration dialog by which the current Quick Report set-up can be saved.</td>
</tr>
<tr>
<td>Show Leap Hour</td>
<td>Opens the Show Leap Hour dialog in that specific day when the daylight saving time has been activated. Within the Show Leap Hour dialog the extra hour values can be seen and edited, if necessary.</td>
</tr>
<tr>
<td>Help</td>
<td>Opens the Help dialog.</td>
</tr>
</tbody>
</table>

Fig. 3.4.3.2-1 Toolbar of the Quick Report graphical form
Table 3.4.3.2-1  Quick Report Tools menu functions

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Day</td>
<td>Opens the Select Day dialog from which the wanted day in the report can be selected.</td>
</tr>
<tr>
<td>Previous Day</td>
<td>Moves to the previous day in the report. If the previous day is out of the history area, the Previous Day option will be dimmed.</td>
</tr>
<tr>
<td>Next Day</td>
<td>Moves to the next day in the report. If the next day is out of the history area, the Next Day option will be dimmed.</td>
</tr>
<tr>
<td>Tabular/Graphical</td>
<td>Switches the report picture to show the measurements in a graphical form. The tabular form can be returned by clicking the corresponding button in the graphical form picture, so the two forms can be toggled.</td>
</tr>
<tr>
<td>Grid on/off</td>
<td>Shows or hides the grid. The curve values outside the grid area are cut regardless of whether the grid is shown or not.</td>
</tr>
<tr>
<td>Edit Y-Scale</td>
<td>Opens a dialog where the parameters of the Y-axis can be set.</td>
</tr>
</tbody>
</table>
Table 3.4.3.2-1  Quick Report Tools menu functions

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll Down</td>
<td>The curves can be scrolled vertically by the arrow buttons or by the corresponding Tools menu items. Scroll Down scrolls the curves one step (interval) down.</td>
</tr>
<tr>
<td>Scroll Up</td>
<td>The curves can be scrolled vertically by the arrow buttons or by the corresponding Tools menu items. Scroll Up scrolls the curves one step (interval) up.</td>
</tr>
<tr>
<td>Load-dur./Load Curve</td>
<td>Switches the measurement curves to the load duration curves. The load curves can be returned by clicking the corresponding button, so the two forms can be toggled.</td>
</tr>
<tr>
<td>Print to file (ASCII)</td>
<td>With this option the current report day can be saved to an ASCII file, where the columns are tabulated in the same way as in the report picture.</td>
</tr>
<tr>
<td>Print to file (.CSV)</td>
<td>With this option the current report day can be saved to an ASCII file. The default format of the file is .CSV, where the columns are separated by a semicolon (;). This file type can be read by a spreadsheet program, for example Microsoft Excel.</td>
</tr>
<tr>
<td>Print to printer</td>
<td>With this tool the user can print the current report day/week/month/year to a net printer, which is configured as a VS Printer in MicroSCADA. This option will be dimmed, if the X monitor is used.</td>
</tr>
<tr>
<td>Report Basket</td>
<td>Opens the Report Basket dialog from which the report objects can be selected to be shown in the Quick Report picture.</td>
</tr>
<tr>
<td>Preconfigurations</td>
<td>Opens the Save Preconfiguration dialog by which the current Quick Report set-up can be saved.</td>
</tr>
<tr>
<td>Show Leap Hour</td>
<td>Opens the Show Leap Hour dialog in that specific day when the daylight saving time has been activated. Within the Show Leap Hour dialog the extra hour values can be seen and edited, if necessary.</td>
</tr>
<tr>
<td>Help</td>
<td>Opens the Help dialog.</td>
</tr>
</tbody>
</table>

3.4.4. Detailed functionality

This section describes the additional functionality, compared to the reports which are related to the standard time. Otherwise all the functions described in Section 3.3 apply to the Quick Report.
### 3.4.4.1. Report Basket

The Report Basket is the link between the report objects (defined within the report application) and the Quick Report picture. With the Report Basket dialog the user can select report objects from the report database to be shown in the Quick Report picture.

The main dialog of the basket has two lists: the Report Objects list to the left contains all the report objects, provided that the history of the period values is stored (defined within the report application). The Selected Objects list to the right contains the report objects that are currently selected and shown in the Quick Report. On both of these lists, each report object is presented on a separate line containing the logical name of the report object and the comment of the report object.

#### Table 3.4.4.1-1 Dialog buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add All</td>
<td>Adds all the objects from the Report Objects list to the Selected Objects list. If duplicates (objects that already are in the Selected Objects list) are found, an information dialog will be shown.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the selected objects from the Report Objects list to the Selected Objects list. If duplicates are found, an information dialog will be shown.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected objects from the Selected Objects list.</td>
</tr>
<tr>
<td>Remove All</td>
<td>Removes all the objects from the Selected Objects list.</td>
</tr>
<tr>
<td>OK/Cancel</td>
<td>OK applies the changes and shows the selected objects in the Quick Report picture. Cancel withdraws all the changes.</td>
</tr>
</tbody>
</table>

Adding or removing a report requires at least Control (1) level user authorization.
3.4.4.2. Preconfigurations

All the selected report objects that are currently shown in the Quick Report picture can also be saved as named preconfigurations. The saved preconfiguration can be selected to be shown in the Quick Report picture by selecting the preconfiguration in the report page list.

The existing preconfigurations are shown on the list. The user can enter the name of the configuration (max. 20 characters) to the field above the list. A name must be entered before the preconfiguration can be saved. When the preconfiguration is opened, its name is set as the report page title.

In order to delete any of the existing preconfigurations, select a preconfiguration to be deleted from the list and click the Delete button. To rename a preconfiguration, select one from the list and click the Rename button. This opens a new dialog where the new preconfiguration name can be entered. To select an existing preconfiguration, select one from the list and click the Select button.

The OK button saves the preconfiguration, Cancel withdraws all the changes. Saving, deleting or renaming a preconfiguration requires at least Control (1) level user authorization.

Fig. 3.4.4.2.-1 Save Preconfiguration dialog
4. Fault and Power Quality Reports in LIB 510

4.1. General description

4.1.1. Purpose

The Fault and Power Quality Reports system is a part of LIB 500 and LIB 510. It provides automatic generation of reports after an event, which can be a final trip or a special event for power quality registration\(^1\), comes from a relay. Fault and Power Quality Reports also contain tools for configuring and browsing fault and power quality reports. These tools can be opened from the LIB 500 menu by clicking Options > Fault and Power Quality Reports from the Header in a VS monitor, or optionally from the Tool Manager. See the picture below.

![Fault and Power Quality Reports in the LIB 500 menu](image.png)

To make any definitions and modifications with these tools, the user must have the Engineering (2) authorization level in the authorization group “MV_CONTROL”. Non-privileged users can use these tools only in the browsing mode.

4.1.2. Report generation

When a failure occurs, for example, regarding the primary equipment of the system, it activates a tripping in the relay. Based on this information, the Fault and Power Quality Reports functionality in LIB 510 can be used for recognizing the event generated in the relay and collecting the relevant fault or power quality report information from the relay in question to make further analysis due to situation.

To make this possible, the relay connected to the system should be configured to send the appropriate TRIP or power quality registration event to LIB 510. During report generation common options are read from the Fault and Power Quality Reports configuration files and relay specific part of the report is created in accordance with the relay parameter file. The configuration files and parameter files for the most common used function blocks are distributed with the Fault and Power Quality Reports function package. For more information, refer to the Fault and Power Quality Reports in the LIB 510 Configuration Manual (see “Related documents” on page 9).

\(^1\) Power quality registration is only supported in certain terminals. The first terminals having the support are the REF541/REF543/REF545 release 3.5 terminals.
4.1.3. Fault and Power Quality Reports output

The Fault and Power Quality Reports system produces four different types of output which can be separately configured: report files, printouts, events in the LIB 500 event list and values being sent to DMS 600 or Open++ Opera. The output files and printouts contain standard headers, measured data and comments. Only faults data, but no power quality values can be sent to DMS 600 or Open++ Opera.

The reports include constant data associated with the relay and with the type of the event, as well as dynamic data that is read from the relay after the fault occurs. Dynamic data contains measured values and other details specific for the situation (earth fault, short circuit, and so on).

Generated events in the LIB 500 Event list contain Date, Time, Object text, Substation, Bay and Device names and status. For fault reports the object text is "Fault Report" and the status text is "Generated". In case of power quality reports, the object text is dependent on the voltage variation; "Sag Report", "Swell Report", " Interruption Report" or "Concurrent Sag and Swell Report".

There is a standard list of parameters which is sent to DMS 600 or Open++ Opera. Which of them are sent in each case is specified in the parameter file of the relay in question.

4.2. Tools

The Fault and Power Quality Reports function package is distributed with two separate tools: one for configuring the Fault and Power Quality Reports system and the second one for browsing fault and power quality reports.

4.2.1. Fault and Power Quality Report Configuration tool

This tool is used to configure the Fault and Power Quality Reports system for the current application. The operator can add or remove report generation for each signal, specify cross-reference blocks for auto-reclosing modules and configure common report generation options. This tool is also used to install the application objects needed for the Fault and Power Quality Reports system. Those objects are installed when the tool is opened for the first time (refer to chapter “Fault and Power Quality Reports in LIB 510” in the LIB 510 Configuration Manual, see “Related documents” on page 9).

Report generation options, configured using this tool, define whether reports should be sent to a file, printer, event list, DMS 600 or Open++ Opera.

4.2.2. Fault and Power Quality Reports Browser tool

This tool is used for browsing reports. Each report consists of three parts: report header, dynamic data and comment. Users with sufficient privileges, authorization level control (1) or higher in the authorization group "MV_CONTROL", can edit and save comments to reports and print reports.
4.3. Configuring Fault and Power Quality Reports

4.3.1. Browsing process objects

The main dialog of the Fault and Power Quality Report Configuration tool shows tripping and power quality registration signal source objects (see Figure 4.3.1.-1). The user can operate by using the toolbar, menu bar and pop-up menu. The table contains five standard columns: Object Identifier, Signal Text, Module (function block that generates TRIP or power quality registration event), Cross-referenced Module, if any, for auto-reclosing function blocks and Report (cell text is "Yes" if this object will generate fault reports, otherwise "No"). The user can add a sixth column to the table in order to display a user-defined object attribute.

![Figure 4.3.1.-1 Fault and Power Quality Report Configuration tool](FRC_tool2)

The number of signals in the table is configurable. The maximum number of signals shown can be changed by selecting the Settings > Table rows... menu option. If the number of signals in the table is more than the setting value, the signals will be divided into different pages. The user can navigate the pages by using the First, Previous, Next and Last toolbar buttons. The toolbar commands are described in Table 4.3.1-1 below.
Process objects listed in the Fault and Power Quality Report Configuration tool are filtered by using a default filter, which is based on the RX attribute. Usually RX (27..30) substring should be "ITRP". This can be changed by selecting the option Default filter in the Settings menu. The following dialog appears after the option is selected:

<table>
<thead>
<tr>
<th>Toolbar button:</th>
<th>Corresponding menu command:</th>
<th>Functionality:</th>
</tr>
</thead>
<tbody>
<tr>
<td>File - Exit</td>
<td></td>
<td>Exits from the tool</td>
</tr>
<tr>
<td>Shows the first page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shows the previous page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shows the next page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shows the last page</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit - Add report</td>
<td></td>
<td>Adds a report</td>
</tr>
<tr>
<td>Edit - Remove report</td>
<td></td>
<td>Removes a report</td>
</tr>
<tr>
<td>Edit - Filter</td>
<td></td>
<td>Opens the Custom filter dialog</td>
</tr>
<tr>
<td>Settings - Report generation options</td>
<td></td>
<td>Opens the Report Generation Options dialog</td>
</tr>
</tbody>
</table>

**4.3.2. Setting filters**

Process objects listed in the Fault and Power Quality Report Configuration tool are filtered by using a default filter, which is based on the RX attribute. Usually RX (27..30) substring should be "ITRP". This can be changed by selecting the option Default filter in the Settings menu. The following dialog appears after the option is selected:

![Default filter settings](Default_filter_settings.fr)

**Fig. 4.3.2.-1** Default filter settings for fault reports
Default filter settings are defined separately for faults and power quality. Up to three conditions can be defined for the faults default filter in this dialog. An object is shown if at least one of these conditions is TRUE. Select the "Sags, swells and interruptions" option to include power quality registration source objects as well.

![Default filter settings for power quality reports](image1)

*Fig. 4.3.2.-2 Default filter settings for power quality reports*

The user can also define custom filters where objects are filtered by the Substation, Bay, Signal test and Module. The Filter dialog is accessible from the toolbar button or by selecting the option **Filter** in the **Edit** menu.

![Custom filters dialog](image2)

*Fig. 4.3.2.-3 Custom filters dialog*

The filters are saved in the configuration file in the user parameters directory.

### 4.3.3. Adding/deleting report generation

The user can add or remove report generation for one or more signals at once. At first, the table rows should be selected. Then report generation is added by selecting **Add report** in the **Edit** menu, or by using the toolbar button or a corresponding item from the table pop-up menu. Report generation for the selected objects can be removed by selecting **Remove report** in the **Edit** menu, or by using the corresponding toolbar button or pop-up menu item. The pop-up menu items are shown in Table 4.3.3-1 below.
The Fault and Power Quality Reports generation function requires a separate parameter file and a Project Manager object name for each module, which generates a trip event. If the selected module has no "own" parameter file, a cross-reference to another module should be defined. In this case, to complete the adding of report generation, the Module cross-reference dialog is raised (see also the following section). For more information about parameter files, refer to chapter “Fault and Power Quality Reports in LIB 510” in the LIB 510 Configuration Manual.

### 4.3.4. Setting cross-reference modules

The user can specify that during report generation the actual data has to be read not from the module (function block), which has generated the event, but from another function block. This is usually the case with the auto-reclosing function block.

Adding a cross-reference to another module can be done by selecting the option **X-Ref. block** in the **Edit** menu, or by using the corresponding pop-up menu item. This function is also activated automatically while adding report generation to an object, which does not have an "own" parameter file. In all the cases, the following dialog appears on the screen:

![Cross-reference dialog](image)

The actual object is the LIB_OBJECT_NAME that has been defined, when configuring the relay picture function. The actual block is the function block or module name from where the fault data is read.

### 4.3.5. Setting Breakers Scadacode

The Fault and Power Quality Reports generator sends variables to DMS 600 or Open++ Opera, if the corresponding option is turned on. One mandatory variable is circuit breaker identification (Scadacode in DMS 600 or Open++ Opera). This is created from the Logical Name (LN) and Index (IX) attributes of the breaker indication or station L/R process objects. One of these objects should exist in the application. If no objects are found according to the rules, the object LN and IX attributes can be set manually by selecting **Breakers Scadacode** in the **Edit** menu, or by using the corresponding pop-up menu item. The command activates the following dialog:
When the OK button is clicked, the Scadacode information is saved in the cross-reference file in the application parameters directory. If the LN field is left empty, then the corresponding cross-reference line for the tripping object, if it existed, will be removed from the file.

4.3.6. Setting report generation options

Report generation options can be configured with the following dialog. To open the dialog, click Settings > Report Generation Options, or use the toolbar button.

With this dialog the Fault and Power Quality Reports output can be configured: whether reports will be sent to a file, printer, Event list and DMS 600 or Open++ Opera. The printer number and root directory for the report files can be defined.

During fault report generation various parameters are loaded from the relay. There are two basic categories of the parameters: setting values and measured values. Setting values are, for example, maximum and minimum voltage, current, and so on. With the “Report generation options” dialog it can be defined whether the setting values will be included in the reports or not.

4.3.7. Enabling and disabling Fault and Power Quality Reports Generation

Report generation can be suppressed and restored for the tripping objects. After the menu command Settings > Enable/Disable is selected, the following dialog appears on the screen:
4.3.7. Enable/Disable dialog

This dialog allows the user to enable or disable the report generation for all signals, for which report generation has been added previously. Internally the tool calls a command procedure, which completes this action. This command procedure can also be used separately from this tool with custom filtering of the process objects. For more information, refer to the LIB 510 Configuration Manual.

4.4. Working with the Report function output

Report files are saved in the directory tree structured according to the Station and Bay names of the equipment, where the events have occurred. The Root directory of the tree is set by using the Fault and Power Quality Report Configuration tool. File names are generated by using the current date and time by the pattern YMMDD_HHMMSSSSS_nnn.log. User comments are stored in the same place in a file with .txt extension: YMMDD_HHMMSSSSS_nnn.txt.

4.4.1. Report format

The reports sent to the files or a printer include constant data associated with the relay and with the type of the event, and dynamic data that is read from the relay just after the fault occurs. Dynamic data contains measured values and other details specific for the situation (earth fault, short circuit, and so on).

Below is an example of the report sent to the file or a printer:

Report header:

*************** RELAY_TRIP_REPORT ***********************
Substation: Eastwick
Bay : Incoming 110kV
Device :

Unit Number: 6
Signal Text: TRIP signal from 3I>>> stage
Reg. Time: 00-03-01 16:12:06.462
Database Object: ESTH01_R1D:P130
Par. File: REF543.par

Relay-specific part:

------------- Setting Parameters -------------
[32S001] ** Unit did not respond ** Operate Mode
[32S002] ** Unit did not respond ** Start Current (0.10 ... 40.00) x In
[32S003] ** Unit did not respond ** Operate Time (0.05 ... 300.00) s

------------- Recorded Data1 -------------
[32V201] ** Unit did not respond ** Date (YY-MM-DD)
[32V202] ** Unit did not respond ** Time (hh:mm:ss.mss)
[32V203] ** Unit did not respond ** Duration (0.0 ... 100.0) %
[32V204] ** Unit did not respond ** IL1 peak (0.00 ... 60.00) x In
4.4.2. Browsing report files with the Fault and Power Quality Report Browser tool

The tool is used for browsing generated report files. Report text, comments and report lists are presented in the main window:

![Fault and Power Quality Report Browser dialog](image)

The report tree structure and the report names are shown in the left panel. The user can select another root directory of the report tree by clicking **File > Open**, or by using the corresponding toolbar button, and switch back to the default root directory by clicking **File > Open Default Root**.

When the user selects a report from the report list, its contents are loaded to the report panel. A comment, if it exists, is also loaded.

With the Control authorization level, the user can do the following actions with report files:
• Click **File > Print** or the corresponding toolbar button to print the selected report.
• Add and edit free-text comments to the selected report and save the modified comment in the file by clicking **File > Save** or by using the toolbar button. The report comment should be saved before selecting another report, otherwise the modifications will be lost.

The toolbar commands of the Fault and Power Quality Report Browser tool are shown in Table 4.4.2-1 below.

### Table 4.4.2-1 Toolbar commands of the Fault and Power Quality Report Browser:

<table>
<thead>
<tr>
<th>Toolbar button:</th>
<th>Corresponding menu command:</th>
<th>Functionality:</th>
</tr>
</thead>
<tbody>
<tr>
<td>File - Exit</td>
<td></td>
<td>Exits from the tool</td>
</tr>
<tr>
<td>File - Open</td>
<td></td>
<td>Selects the fault and power quality root directory</td>
</tr>
<tr>
<td>File - Print</td>
<td></td>
<td>Prints reports</td>
</tr>
<tr>
<td>File - Save</td>
<td></td>
<td>Saves report comments</td>
</tr>
</tbody>
</table>

### 4.4.3. Observing event list

If sending of the Fault and Power Quality Report events to the LIB 500 event list is enabled, the events produce rows in the event list in the following format:

<table>
<thead>
<tr>
<th>Date</th>
<th>Time</th>
<th>Station</th>
<th>Bay</th>
<th>Device (Signal Text)</th>
<th>Status</th>
</tr>
</thead>
</table>

For all the fault report events, "Signal text" is "Fault Report" and "Status" is "Generated". For all the Power Quality Report events, the "Signal text" is one of the following: "Sag Report", "Swell Report", "Interruption Report" or "Concurrent sag and swell Report". The event list can be seen in the LIB 500 start-up picture by clicking **Reports > Event List**, or by using the toolbar button. By default, Fault and Power Quality Reports events are also sent to the printer that is configured as PRI1 in the base system.

### 4.4.4. Printouts

There can be three different printouts produced by the Fault and Power Quality Reports. The first one is automatic printing of report header, dynamic contents and comments during report generation. This printout is done on the printer number that is configured with the Report Generation Options dialog. The second printout is a text line that is the same as in the LIB 500 event list that is sent to the printer number 1 in the base system. The third one is a manual printout from the Fault and Power Quality Report Browser. In this case, the user selects the printer from the Print dialog.
4.4.5. **Sending reports to DMS 600 or Open++ Opera**

The fault report information can be sent to DMS 600 or Open++ Opera, if the corresponding option is enabled. The information is sent as a list of parameters, which are specific for DMS 600 or Open++ Opera. The following parameters are always present in the list:

- Event time
- Event milliseconds
- Breakers Scadacode

Other parameters can be sent, if they are defined in the relay parameter file:

- Fault type
- Notation of all measurement values
- Phase information
- Short circuit currents
- Load current before fault

Power quality report information is not sent to DMS 600 or Open++ Opera.
5.

Index

Symbols
! .................................................................................................................. 49
* .............................................................................................................. 42, 43, 45
? ............................................................................................................... 43, 45

A
ASCII file ................................................................................................. 34, 51
Automatic generation of reports .......................................................... 63

B
Background color .................................................................................. 27, 31, 53
Browsing interval .................................................................................. 47

C
Calculation of report data ................................................................. 39
Collection of report data .................................................................. 39
Comment Text dialog ...................................................................... 55
Coordinates .......................................................................................... 14
Corrected values ................................................................................ 49
CSV file .................................................................................................. 51
Current data .......................................................................................... 43, 55
Current report page ............................................................................. 51

D
Daily report ............................................................................................ 39
Data logs ................................................................................................. 22
Data registration .................................................................................. 14, 55
Daylight saving ................................................................................... 52
Default accuracy .................................................................................. 36, 55
DMS 600 .................................................................................................. 64
DMS 600 or Open++ Opera .................................................................. 69, 73

E
Edit information .................................................................................... 51
Edited values ........................................................................................ 49
Editing and entering values manually ............................................. 43, 55
Editing period values ......................................................................... 49
Editing the trend curve line parameters .......................................... 30
Entered objects (EN) ............................................................................ 55
Entering values ...................................................................................... 35
Erroneous status .................................................................................. 14, 19, 34, 36, 43, 45, 55
Error ....................................................................................................... 43, 55

F
Fault and Power Quality Report Browser tool .................................. 64, 71
Fault and Power Quality Report Configuration tool ........................ 64
<table>
<thead>
<tr>
<th>Section</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fault and Power Quality Reports output</td>
<td>64</td>
</tr>
<tr>
<td>File names</td>
<td>35</td>
</tr>
<tr>
<td>Frozen mode</td>
<td>15, 19, 21</td>
</tr>
<tr>
<td><strong>G</strong></td>
<td></td>
</tr>
<tr>
<td>Gauge (meter) objects (GA)</td>
<td>55</td>
</tr>
<tr>
<td>General features</td>
<td>40</td>
</tr>
<tr>
<td>General options</td>
<td>40</td>
</tr>
<tr>
<td>Graphical form</td>
<td>13, 15, 35, 45, 57</td>
</tr>
<tr>
<td><strong>H</strong></td>
<td></td>
</tr>
<tr>
<td>Hairline</td>
<td>33</td>
</tr>
<tr>
<td>Header</td>
<td>37</td>
</tr>
<tr>
<td>Historical data</td>
<td>43, 55</td>
</tr>
<tr>
<td>Horizontal (X) axis</td>
<td>14, 45</td>
</tr>
<tr>
<td>Horizontal time (X) axis</td>
<td>45, 57</td>
</tr>
<tr>
<td>Hourly report</td>
<td>39</td>
</tr>
<tr>
<td><strong>I</strong></td>
<td></td>
</tr>
<tr>
<td>Index</td>
<td>18, 36</td>
</tr>
<tr>
<td>Index Range</td>
<td>35, 37</td>
</tr>
<tr>
<td>Interval</td>
<td>45</td>
</tr>
<tr>
<td>Invalid status</td>
<td>14, 19, 45</td>
</tr>
<tr>
<td>IX</td>
<td>68</td>
</tr>
<tr>
<td><strong>L</strong></td>
<td></td>
</tr>
<tr>
<td>Line color</td>
<td>27, 31</td>
</tr>
<tr>
<td>Line parameters</td>
<td>31</td>
</tr>
<tr>
<td>Line style</td>
<td>27, 31</td>
</tr>
<tr>
<td>Line width</td>
<td>27, 31</td>
</tr>
<tr>
<td>LN</td>
<td>68</td>
</tr>
<tr>
<td>Log file</td>
<td>50, 51</td>
</tr>
<tr>
<td>Logging function</td>
<td>24, 25</td>
</tr>
<tr>
<td><strong>M</strong></td>
<td></td>
</tr>
<tr>
<td>m</td>
<td>43, 55</td>
</tr>
<tr>
<td>Manually entered values</td>
<td>43, 45, 55</td>
</tr>
<tr>
<td>Maximum length of the name</td>
<td>35</td>
</tr>
<tr>
<td>Measured objects (MS, MM, MN, MX and MP)</td>
<td>55</td>
</tr>
<tr>
<td>Measurements</td>
<td>43</td>
</tr>
<tr>
<td>Monthly report</td>
<td>39</td>
</tr>
<tr>
<td><strong>N</strong></td>
<td></td>
</tr>
<tr>
<td>New Value field</td>
<td>36</td>
</tr>
<tr>
<td>Next Day button</td>
<td>48</td>
</tr>
<tr>
<td>Not sampled status</td>
<td>14, 19, 34, 36, 45, 55</td>
</tr>
<tr>
<td>Note dialog</td>
<td>48</td>
</tr>
<tr>
<td>Number of lines per page</td>
<td>37</td>
</tr>
</tbody>
</table>
MicroSCADA Pro
Operation Manual

O
Objects list ................................................................. 23
Obsolete status ......................................................... 43, 55
Open++ Opera .............................................................. 64
Output ................................................................. 64

P
Parameters ............................................................................ 19, 27
Point of time change ....................................................... 52
Pop-up menu items .......................................................... 68
Preconfigurations .............................................................. 26, 61
Predicted future data ......................................................... 43, 55
Presentation mode .......................................................... 19, 21
Previous Day button .......................................................... 48
Printing trends ................................................................. 36
Printouts .............................................................................. 64

Q
Quick Report ...................................................................... 53, 54
Quick Report on a daily basis ............................................. 39
Quick Report on a monthly basis ........................................ 40
Quick Report on a weekly basis .......................................... 40
Quick Report on a yearly basis .......................................... 40

R
Report Base ........................................................................ 40
Report Basket .................................................................... 60
Report column title .......................................................... 55
Report data ........................................................................... 39
Report files ........................................................................... 64
Report Generation Option .................................................. 72
Report HSI ........................................................................... 39, 40, 41
Report object ...................................................................... 53, 55, 57, 60, 61
Report object types ......................................................... 55
Report Objects list ............................................................ 60
Report page title ................................................................. 61
Report picture ................................................................. 40
Report Tool ......................................................................... 40
RX ...................................................................................... 66

S
Sampling interval ............................................................. 25
Saving the current trend picture set-up ................................ 27
Scadacode ............................................................................. 69
Scrollable list ....................................................................... 18
Scrolling backward and forward in time ............................. 47
Select Day button .......................................................... 48
Selected Objects list .......................................................... 60
Setting Breakers Scadacode ............................................. 68
Set-up ........................................................................... 54
Set-up of trend picture ..................................................... 15
Station Basket .................................................................. 22
Status .......................................................................... 18, 36
Summary information .................................................... 43, 55

T
Tabular form ..................................................................... 17, 35, 43, 55
Time Interval .................................................................... 29
Time of Registration .......................................................... 36
Time related reports .......................................................... 39
Time stamp ....................................................................... 18, 37
Toolbar of the Daily Report graphical form ....................... 46
Toolbar of the Daily Report tabular form ......................... 43
Toolbar of the Quick Report graphical form ...................... 57
Toolbar of the Quick Report tabular form ......................... 55
Toolbar of the Trend graphical form ................................... 15
Tools menu of the Daily Report graphical form .................. 46
Tools menu of the Daily Report tabular form ..................... 44
Tools menu of the Quick Report graphical form ................. 58
Tools menu of the Quick Report tabular form ................. 56
Tools menu of the Trend graphical form ........................... 16
Tools menu of the Trend tabular form ............................... 20
Transparent printers .......................................................... 37
Trend ........................................................................... 12, 23
Trend Basket ..................................................................... 14, 19, 22, 25
Trend Basket list ............................................................... 23, 26
Trend curve ...................................................................... 17
Trend Curves list .............................................................. 26
Trend name ...................................................................... 31
Trend Picture Preconfigurations dialog ............................... 27
Trend Reports ................................................................... 11
Trend Settings .................................................................. 24
Trend Toolbar .................................................................... 20

U
Uncertain status ............................................................... 43, 55
Update interval ................................................................. 22, 24, 25
Updating mode ................................................................. 15, 19, 21
User authorization ......................................................... 28, 48, 50, 60, 61
MicroSCADA Pro

Operation Manual

V
Value ................................................................. 18
Vertical (Y) axis ............................................. 14, 45
Vertical value (Y) axis ..................................... 45, 57

W
Weekly report ................................................... 39

X
X-axis end time ................................................. 28
X-axis parameters ............................................ 28
X-axis time interval .......................................... 28
X-axis times ...................................................... 46
X-monitor ........................................................ 50

Y
Y-axis maximum ............................................... 29, 46, 53
Y-axis minimum ............................................... 29, 46, 53
Y-axis parameters ........................................... 29
Yearly report ..................................................... 39

Z
Zoom box .......................................................... 32
Zooming in ....................................................... 32
Zooming out ..................................................... 32