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     Application Note  

 

   My First eCo PLC and CP600 Panel project 
 

 

1 Introduction: 
This application note shows you step-by-step to create a basic PLC program with ABB eCo PLC and CP635 
panel using Automation Builder software tool.  It also guides you to create hardware configuration, program 
and go online with PLC and HMI. 

2 Objective: 
In this application example, we use AC500 eCo PM564 ETH CPU with digital input simulator and CP635 
panel. The personal computer will connect to  PLC and HMI via 2 Ethernet ports on CP635 panel.  These 
ethernet ports work like an unmanaged switch for ethernet connection. 

Equipment list for this application note: 

Description Quantity 
PM564 ETH CPU 1 
CP635 Panel 1 
PC with Automation Builder V1.0 or later software installed 1 
Power Supply 120vac in/24vdc out, 1.25A 1 
CAT5 Ethernet patch cables 2 

 

        

 eCo PM556 ETH CPU       CP635 Panel 

 

 

 

   PC and PLC CAT5 cables 



LVD-EOTN119U-EN REVA Page 2 of 25  

3 Creating a new project: 

3.1 Double click on ABB Automation Builder software tool  icon on the desktop. 

(If Automation Builder icon is not available on your desktop, click Start, go to All Programs, select ABB 
folder and click on Automation Builder software tool.)  

 
3.2 The Automation Builder Screen will appear as shown below, if Internet access is available Automation 

Builder will show the default ABB homepage for PLC products  
 

3.3 Create a new project by clicking the New button or selecting the File > New Project  
 

3.4 Enter project name as shown in example below:  My First eCo PLC and CP600 panel project 
 

3.5 Select the location to store the project  
 

3.6 Select OK to start the project 
 

 

3.7 Click the + of PLC to open the popup menu.   
 

3.8 Click AC500-eCo then select AC500 PM564-ETH CPU 
 

3.9 Click on Add PLC to complete the selection 
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4 Specifying the hardware configuration:   
 
To specify the hardware configuration, the I/Os and their symbolic names have to be defined. Configure your I/O 
by double clicking I/O (Onboard I/Os) and refer to the mapping tab window opened on the right side where you 
can give variable names to each I/O points. 

 
4.1 Double click AC500 (PM564-ETH) on the left to open this hardware menu 

 
4.2 Change the value of Check battery from ON to OFF ( if no battery present for this example)  

 

4.3 To create I/O variable for the CPU, double click on the OBIO selection.  The I/O tab will open on your right 
window with 3 child tabs. The 1st tab is I/O configuration, click on the 2nd tab for I/O Mapping for this 
application example.   
 

• MotorRunning for Digital output DO0 channel 
          

 

  Note, if you made a mistake during the process, you can always undo by going to                                                  
Edit on the left hand top corner and click Undo. 
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5 Setup the Ethernet communication in Windows: 
Before you are able to download the compiled program the first time from the PC to the PLC, you have to 
setup the communication parameter. There are two options you can use to login to the PLC, either with 
Ethernet or serial with TK503 USB cable. 

 
For this exercise, we are using Ethernet connection for online access to this PLC. 
 
Make sure that your PC address is in the same class as the CPU’s IP address. The factory setting of the 
CPU for IP address is 192.168.0.10. Then the IP of the PC should be 192.168.0.x, x should be different 
number than 10 so that it will not have an IP conflict with the CPU. Subnet mask should be 
255.255.255.0. 

 
To change the IP address in your PC: 

 
5.1 Windows Control Panel > Network and Internet > Network and Sharing Center 
5.2 Click on Change adapter settings 
5.3 Select Local Area Connection (in this example is  PLC network connection below) and right click it to 

open the menu. 
 

  
 

   Choose Properties ( the status is active when the Ethernet connection between PC and  PLC is active) 
5.4  Select Internet Protocol Version 4 (TCP/IPv4) and double click to see properties. 
5.5  Type in your desired IP address and subnet mask then click OK. 

 

 

 



LVD-EOTN119U-EN REVA Page 5 of 25  

6 Setup the IP address in Automation Builder software: 
6.1 Make sure the CPU’s RUN switch is STOP position 
6.2 Click IP-Configuration to access Scan tool 

 

6.3 Click on Scan button for searching active PLC on the network 
6.4 Highlight the active IP address in the search window 
6.5 Change the IP address to new IP address such as 192.168.3.20 
6.6 Click on Send Configuration button to send new IP address to PLC.  

         

• The warning message window display is shown below for this change.   
• This screen shows the progress of IP address settings is sending to CPU. Wait about 30 seconds for 

CPU to register new IP address (the RUN and ERR lights are flashing during this process). 
•  Click OK to accept this new IP address for this CPU. 

                     

• Press “Scan” button again to verify the IP address of CPU. This window shows the Configured IP 
address sent to CPU successfully.  This IP address will be used in IEC 61131-3 CoDeSys to download 
your PLC project to CPU. 
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7 IEC-61131-3 Programming window- Task Configuration: 
 

From My First eCo PLC project windows, Right click on Application>Create Configuration to complile the 
hardware configuration for this project.  

    

 
After the Create configuration data complete, double click on Application to goto IEC-61131-3 
programming environment as shown on next section. 
 

7.1 Click on Resource tab to access to Global Variables > OBIO_Module_Mapping<R> window.  
Verify that the mapping variables for this exercise are correct and tranfered from Automation 
Builder OBIO configuration. 

 

7.2 Click on task configuration to goto settings 
7.3 Right click on Task configuration then select Append Task to add a task for this CPU. 
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7.4   The task set up parameters:  
Name: MainProgram 
Priority (0..31) = 10 
Type:  Cyclic 
Properties: T#10ms 

                             

• Right click on MainProgram > Append program call 

• Click on  then select PLC_PRG(PRG) 
 

            
 

8 Writing the program code in Ladder Diagram Editor: 
In this CoDeSys Program Organization Units (POUs) window, Structure text (ST) program is default, but it 
can be changed to Function Block Diagram (FBD), Ladder Diagram (LD), Instruction List (IL), Continuous 
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Function Chart (CFC) and Sequential Function Chart (SFC).  In this exercise, we will change it to Ladder 
Diagram (LD) editor. 

 

 

8.1  Click Project > Rebuild all to compile the PLC codes.   Make sure there is no error in the project! 

    

8.2 Right click POUs, select Convert Object… to convert it to LD editor 
8.3 Select LD then click OK to accept the changes. 

  

8.4 Double click on PLC_PRG(PRG) to go to Ladder Diagram editor.  

8.5 Click on the instruction set   

and insert  to the network rail below 
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8.6   Highlight  then hit Shift + F2 to open Declare Variable table.  Type Name: MotorStartPB,    
Type: BOOL and Class: Global_Variables  for this contact. 

8.7    Repeate this step for this  and select MotorStopPB for its variable tag as shown below. 
 

     

8.8  Insert another  then click Shift-F2 to access Declare Variable table.  Assign MotorTimeDone 
as variable name as shown below then click OK to accept the changes. 

            

8.9 Insert a coil ( ) to this network then press F2 to access to Input assistant table. Select 
MotorRunning from OBIO_Module_Mapping global variables. 
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The complete codes for network #1: 

    

8.10 Click on the rail of network1 then right click to open the pop-up menu (or Ctrl+T). Select  
 Network (after) to insert new network below the current one.  

         

8.11 On this network #2, add MotorRunning contact then right click on the network line to add  
 Timer(TON) from pop-up menu.  

8.12 Press Shift+F2 to enter Motor_timer1 as variable name for this timer.  

 

                                

8.13 Add ElapseTime for ET with Type: TIME for this variable. 
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The complete PLC codes for network #2. 

 

8.14 Add network #3, insert Motor_timer_done contact then add CTU function block by right 
click  
           on the network line. 

8.15 Add TIME_TO_REAL function block to convert from Time base to Real number for display  
            in HMI project. 
 

 
 

8.16 Click on Function Block… to select CTU for this counter Up function block. 

           

8.17 For this CTU, add CounterDone: BOOL and CounterValue: WORD to complete this 
            function block for this motor control logic. 

The complete network #2 look like below: 

 

 

8.18 Click Project > Rebuild all to complile this PLC logic.   
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Here is the complete PLC project for this application note: 
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9 Configure and dowload Symbol file to CPU: 
• Click on Resources tab>Target Settings to access to Target Settings tab 

Under General tab, activate the automatic Download symbol file option, the symbol file will be transferred 
in AC500 CPU flash memory with the project after download 
 

1. Click on the tab “General” 
2. Activate the checkbox “Download symbol file” and “ OK” 

 

      

 

In CoDeSys\Project\Options tab 

1. Activate the check box “Dump symbol entries” 
2. Click “Configure Symbol file…” 
3. Select “Global Variables” 
4. Activate the options shown below then OK twice to accept all the changes. 

                          
 

In CoDeSys\Project tab 

1. Select “Clean all” then “Rebuilt all”.   
2. After “Clean all” and “Rebuild all” operation the symbol files will create  automatically in project 

directory and they will be transferred in AC500 CPU with the download operation 
3. Click Online\login to download the updates to CPU. Once the download complete, click Create 

Boot Project to download the symbol file to CPU flash memory. Save and close CoDeSys 
project. 

 
 

ABB CoDeSys Ethernet protocol -  Export Symbol file    
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In Automation Builder project: 
1. Right click on “Application” 
2. Then select “Export” 
3. And select “Symbol file” 
4. Finally select the desired location path to save this symbol file on PC folder  

       

                    

 

10  CP600 Control Panel system settings 

Basic Unit Settings: System Settings:  System basic settings are available from Control Panel, which is 
accessible through the PB610 PanelBuilder 600 configuration mode. 

10.1   Press and hold your finger on the screen for a few seconds until the context menu  
appears. 

 

10.2   Touch on Show system settings to access the system settings tools. 
10.3   The system settings tool is a rotating menu through which you can scroll the menu 

tabs  
                            using Next and Back buttons. 
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The system settings tool includes the following entries: 

 Calibrate Touch: To calibrate the touch screen if needed 

 Display Settings: Backlight and brightness control 

 Time: Internal RTC settings 

 BSP Settings: Operating system version 

 Unit Operating Timers: Power up and activated backlight timers: Buzzer control, battery LED control 

NOTE: Settings selected and confirmed with the OK button in the upper right corner of the dialog are 
automatically saved to the registry. 

 

The system settings tool includes the following entries: 

 Calibrate Touch: To calibrate the touch screen if needed 

 Display Settings: Backlight and brightness control 

 Time: Internal RTC settings 

 BSP Settings: Operating system version 

 Unit Operating Timers: Power up and activated backlight timers: Buzzer control, battery LED control 

 Network: Enter or verify this IP settings= 192.168.3.62 - IP address for this panel 

NOTE: Settings selected and confirmed with the OK button in the upper right corner of the dialog are 
automatically saved to the registry. 

11 Create new CP600 Control Panel project in Automation Builder 
11.1 In Automation Builder project, right click on My First eCo PLC select Add object 
11.2 Select the CP600 Control Panel then Add object to create new CP600 Control Panel project. 

 

                       
 

11.3 Double click on Panel Builder 600 project, select New then Open from Import Project File menu 
11.4 Click on Project properties to open Project Widget for panel size selection 
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11.5 Click on  Show Advanced Properties icon to access all the properties of this control panel 
project. 

11.6 Click on Project Type to change to CP635 panel for this project. 
11.7 Confirm Landscape type for this panel and “Yes” to accept all the changes. 

                                            

12 PB610 Panel Builder 600 Project: 
This section describes the steps to create a simple PB610 Panel Builder 600 project. 

12.1   From Project View window, Double click on Protocol window 

12.2   Click the + icon to insert the new protocol 

12.3   Select ABB CoDeSys ETH under pull down menu as shown below 
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12.4   Enter the IP address: 192.168.3.35 and other values as shown in the table below 

            

 

13 Import tags import from AC500 PLC  
13.1 Double click on the Tags icon in the Project View to open the tag configuration 

13.2 Press the   Import tags button shown below to import the tags and click OK 

                   

13.3 The symbol file is placed in PC’s file location folder as shown below 
13.4 Select the Application.SYM and “Open” it 
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13.5 The accessible tags are shown on in the lower part of the tag editor 

13.6 Click  Import tags icon to import the highlight tags to tags data editor above. 

                            

13.7 Verify all the tags are imported into this window 
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14 Create template and screen for CP600 panel project: 
14.1 Right click on Template to create a template for this project. Add ABB logo and tiltle for this HMI 

screen as shown below.  
 

      
 

14.2 To add new page, right click on Pages node from project tree and select “Insert new page” and 
name it  “ Main page” then click OK to accept it. 
 

                
 

15 Create static and dynamic objects using Widget Gallery: 
 

15.1 Select the this button from the Widget Gallery, then drag and drop it on the Main page workspace.   
15.2 Label this button as Motor Start PB as momentary type, color: Green. 
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15.3 Click on  then select Attach To… to access the tags database.  Select MotorStartPB for this 
button then “OK” to accept it. 

          
 

15.4 Repeat these steps for Motor Stop PB as shown below: 
 

      
 

15.5 Open the widget gallery to select Light -Standard group then select this  for motor status light 
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15.6 Click on Color in Properties then select Add/Remove Color to modify color selection below.    
          Click  + or – to add or remove the number of color selection for this object. 
 

        
 

15.7 Select the MotorRunning from tag manager for this pilot light. 
 

 
 
 

15.8 Select Label from Text/Numeric widget gallery for this light.  Type “Motor Status” for this pilot light 
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16 Create the numeric display: 
16.1 Click on Widget Gallery then select Text/Numeric tool. Drag numeric display to Main Page 

working window. 
16.2 Select Countervalue for this numeric display object. 

        

 

16.3 Use the property Value to attach a tag to this widget. Click in the field, press + button and 
select Attach To… counter value. 

16.4 Add another numeric display for Motor Running timer with field value as ElapseTime_HMI as 
shown below.  
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Here is the complete HMI screen for this project: 

 

17 Save and download the PB610 Panel Builder 600 Project  
17.1    Click Save Project from File menu 

a.  

17.2    Select Run/Download or use the marked symbol to start download dialog 
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17.3   Select your CP635 panel’s IP address then download the project to the panel. 
 

 

17.4     You can test the CP600 application using the CP635 panel as shown below 

17.5    Use Start Simulator mode:  You can test the CP600 application using Online   

 Simulator.  Click on Start Simulator to go to this mode. 
 

   

17.6   Go Online with HMI: Uncheck Use Simulation to go online HMI and AC500 PLC. 

17.7   Here is the HMI Simulator screen online with this PM578 ETH CPU. 
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17.8   Click the short cut CP600 Windows Client on the desktop to activate this window below.  
Type  

this CP635 panel’s IP address: 192.168.3.11 in this panel address window.    

Press ENTER or click this circle symbol. 

 

   

 

  And this is the progress window for this CP600HMI Client connect to this CP635 panel over internet 
connection 

 

 

CP635 panel in Windows Client mode 

 

Congratulations!!! You are controlling this CPU using Windows Client over internet connection. 
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