The System Update Tool (SUT) is a wizard for installing a system revision for System 800xA on a node-by-node basis.

The System Update Tool will:

- Display the pre-installation instructions for the system and the node.
- Perform a maintenance stop on the node.
- Analyze the node to identify the affected software.
- Uninstall the base version of products that require it before installing the revision.
- Install the updated software in the correct order.
- Display the post installation instructions for the system and the node.
- Generate a node report.
- Support both 32-bit and 64-bit operating systems.
- Install SQL Server 2008 SP4.
- Update Oracle to the latest supported version including the critical patch update.

Related Documentation

The documents related to this user manual are:

- *System 800xA 5.1 Revision E Release Notes Fixed Problems* (2PAA114364*)
- *System 800xA 5.1 Revision E Release Notes New Functions and Known Problems* (2PAA114363*)
- *System 800xA 5.1 Manual Installation* (3BSE034678*)
- *System 800xA 5.1 Upgrade* (3BSE036342*)
- *System 800xA 5.1 Post Installation* (3BUA000156*)
- *System 800xA 5.1 Automated Installation* (3BSE034679*)
- *System 800xA 5.1, 5.0, 4.x, 3.1 Third Party Software* (3BUA000500)
Pre-Installation

It is recommended to back up the system before starting the installation. Refer to *System 800xA Maintenance (3BSE046784*) for more information.

Virus scanning must be disabled during installation of System 800xA software and updates.

Stop all third party and other non-800xA clients connected to the 800xA System (such as third party OPC DA, HDA, and AE clients that are accessing the 800xA System) as these will disturb the update.

1. Verify that all scheduled batches are completed or terminated.
2. If used, it is recommended to install Crystal Reports 2008.
   - **For Fresh Installation**: Install Crystal Reports 2008 SP5 full build package.
   - **For Upgrading Crystal Reports**: Refer to *Third Party Software used in 800xA 5.1 Revision E* on page 4.
3. Upgrading to Office 2013 or 2010 is optional since Office 2007 is still supported in the system revision. Refer to *Third Party Software used in 800xA 5.1 Revision E* on page 4.

**800xA for DCI**

Perform the following steps to shut down the full DCI system before updating 800xA for DCI nodes.

1. Select **Start > All Programs > ABB Industrial IT 800xA > 800xA OCS Systems > DCI > DCI Maintenance**.
2. Select **Basic > Full ABB 800xA for DCI <installed version> Shutdown**.
3. Click **Yes** to confirm the shutdown.
5. Start the Windows Task Manager and select **Processes**.
6. On the list of tasks verify that **DualWatchdog.exe** is still running.
7. Select the **DualWatchdog.exe** and click **End Process** to stop the task.
800xA for Harmony

Execute the following command in the 32-bit 800xA for Harmony nodes before starting the installation.

1. Open the Windows Command Prompt.
2. Enter: `regsvr32 %SystemRoot%\system32\atl.dll`

**Engineering Studio Add-Ins**

Before updating/upgrading the system from previous release to the latest release ensure the Engineering Studio Add-Ins are listed in **Active Application Add-Ins** in Microsoft Excel.

If the Add-ins are not listed, perform Step 3 through Step 5 to enable them in the Microsoft Excel:

1. Start Microsoft Excel.
2. Navigate to **File > Excel Options > Add-Ins > Active Application Add-ins.** Refer to Figure 1 to view the Engineering Studio Add-ins.

3. Select **COM Add-ins** from **Manage** drop-down and click **Go...** List of COM Add-ins window appears.
4. Select all the Engineering Studio Add-ins from the list and click **OK.**
5. View the Add-Ins in the **Active Application Add-ins** panel on the Excel Options window.

## Third Party Software used in 800xA 5.1 Revision E

Hot fixes, service packs, and updates for third party prerequisites that the 800xA System software has been found to be compatible with are listed in *System 800xA 5.1, 5.0, 4.x, 3.1 Third Party Software (3BUA000500)*. This document can be found in ABB SolutionsBank.

The following third party software are new or differently used in 800xA 5.1 Revision E:

### Microsoft Office Integration

800xA 5.1 Revision latest release supports the integration with 32-bit version of Microsoft Office 2007, 2010, and 2013. Specific service packs of Microsoft Office is supported for the release.

### Information Management

Complete the Office upgrade and if required add the ABB DataDirect (ABBDataDirect) add-in manually. For more information, refer to Step 6 in *Known Problems and Restrictions* on page 11.

### Engineering Studio

Complete the Office upgrade and if required add the Bulk Data Manager add-in manually. For more information, refer to Step 7 in *Known Problems and Restrictions* on page 11.

### SQL Sever 2008 SP4

The System Update Tool automatically updates the system with SQL Server 2008 SP4.
Oracle Updates

The System Update Tool automatically updates the Oracle to the 11R2 installation with the latest critical patch update (released in Jan 2012).

- Oracle 11R1 is updated to 11R2 with the latest critical patch update in the 800xA 5.1 Base System.
- The latest critical patch update is applied to the Oracle 11R2 installations in all other versions of 800xA System.

Crystal Reports 2008

The system revision supports all three versions of Crystal Reports as mentioned in both the scenarios. Crystal Reports is installed when users update the system revision in the following scenarios.

1. If Crystal Reports is installed for the first time - Install Crystal Reports 2008 Service Pack 5 (SP5), which is a full build installation package.
   
   Browse SAP Business Objects web site, navigate to Service Pack section of SAP Business Objects - Crystal Reports Runtime Packages to find the installation package.

2. If Crystal Reports was already installed on the following 800xA versions, then no change.

   **800xA 5.1 Revision A and 64-bit**
   
   – Crystal Reports 2008 SP3 Full Build +
   – Crystal Reports 2008 Fix Pack 3.3

   **800xA 5.1**
   
   – Crystal Reports 2008 Base +
   – Crystal Reports 2008 SP1 +
   – Crystal Reports 2008 SP2 +
   – Fix Pack 2.7
Microsoft has announced that from January 12 2016 they will only support one Internet Explorer version per operating system.

It is mandatory for users to update to latest Internet Explorer versions as mentioned in the Microsoft announcement to continue receiving Security Updates.

For System 800xA 5.1 Revision E this means that it will only support the following versions of Internet Explorer:

- **Internet Explorer 11** - On Windows 7 SP1 (32- and 64-bit), Windows Server 2008 R2 64-bit.
- **Internet Explorer 9** - On Windows Server 2008 SP2 32-bit.

Users running 32-bit 800xA Systems can have two Internet Explorer versions in the same system (IE 9 for Windows 2008 SP2 and IE 11 for Windows 7 SP1 32-bit).

For more information, refer to **System 800xA 5.1 - Ceased Internet Explorer Support - Update Product Update (3BSE083144)** in ABB Library.

To have a seamless update to Internet Explorer 11, perform the following steps:

1. Install Internet Explorer 11 mandatory pre-requisites (which include Updates, hotfixes and Security Updates) as provided in the link: [http://support.microsoft.com/kb/2847882](http://support.microsoft.com/kb/2847882) and restart the node.

2. Download and install Internet Explorer 11 and restart the node.

To have a seamless update to Internet Explorer 9

- Install Internet explorer 9 mandatory pre-requisites (which includes Updates, hotfixes and Security Updates) as provided in the link: [https://support.microsoft.com/en-in/kb/2399238](https://support.microsoft.com/en-in/kb/2399238)

- Download and Install Internet Explorer 9 and restart the node.

If Internet Explorer 9.0 or 11.0 is installed, all 800xA Systems with Revision A or older versions/revisions must be upgraded to 800xA 5.1 Revision E to enable Process Portal A workplace to function, as required.

Install the hotfix [https://support.microsoft.com/en-us/kb/3074850](https://support.microsoft.com/en-us/kb/3074850) to reduce the Memory usage in Internet Explorer 11 that is introduced with MS15-032.
System Update Tool

The System Update Tool can be run using the System Update Tool DVD or the zip file downloaded from ABB SolutionsBank.

The System 800xA 5.1 Revision E updates with System Update Tool is distributed as the following downloadable zip files from ABB SolutionsBank:

3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool_Part_1_of_4.zip
3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool_Part_2_of_4.zip
3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool_Part_3_of_4.zip
3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool_Part_4_of_4.zip

System Update Tool DVD

The System 800xA 5.1 Revision E is available on two separate disks.

Perform the pre-processing step to create the media from the two DVDs onto an user defined location in the local node and start the installation using the System Update Tool.

Creating the Media from DVDs

Perform the following steps to create the media using MediaReplicator tool.

1. Insert DVD6 Media and double-click on MediaReplicator. The System 800xA Media Integrator window appears.
2. Click Browse, select the path to copy the media content. Click OK.
3. Click OK, to copy the content to the selected folder. Insert the disc labeled 'DVD7' into <>\ and press OK message appears once DVD6 content is copied completely.

5. Insert DVD7 and click **OK** to copy the content. MediaReplicator closes automatically once the content is copied completely.

6. Remove DVD7 and start the Installation using the System Update Tool from the folder where the media is created.

**zip File Downloaded from ABB SolutionsBank**

Install WinZip 12 or higher version to extract the SUT zip file.

The System Update Tool can be used in the following ways when using the zip file downloaded from ABB SolutionsBank.

Extract the contents of the zip files to an arbitrary folder. Make sure the files are extracted to the same folder. The folder will then contain the following files:

- 3BSE084084-
  001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.zip
- 3BSE084084-
  001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.z01
- 3BSE084084-
  001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.z02
- 3BSE084084-
  001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.z03
- Read Me.txt

Extract the following zip file:

- 3BSE084084-
  001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.zip

that uses the following files:
Node Order

3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.z01
3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.z02
and
3BSE084084-001_System_800xA_5.1_RevE_Updates_with_System_Update_Tool.z03
to create the complete media.

- Extracted to removable media (DVD, USB drive, etc.) and with the removable media used on the node where the System Update Tool will be run.

  -or-

- Extracted to the hard drive of the node where the System Update Tool will be run.

  -or-

- Extracted and copied to a file server share.

Double Click SystemUpdateTool.exe from the folder System Update Tool on the removable media (DVD, USB drive, etc.).

Node Order

System revisions can be installed in a running redundant system on a node-by-node basis without stopping the entire system. This requires that the node types be updated in the following order:

1. Application Servers.
2. Connectivity Servers.
3. Aspect Servers (Primary Aspect Server last).
5. Domain Controller (if the system is part of a domain environment).

For Systems with 800xA for Harmony, refer to Known Problems and Restrictions for the node order.

Using a File Server Share

Security issues introduced in Internet Explorer (8.0, 9.0, and 11.0) make it necessary to perform the following in order to avoid constant Internet Explorer (8.0, 9.0, and 11.0) security warnings when installing the System software on a node.

1. Use the Engineering node as the file server share (preferred method).

2. Copy the contents of the system revision DVD to the hard drive of the Engineering node.

3. Map each node being updated to the Engineering node in order to install the revision.

4. Temporarily change the security settings in Internet Explorer (8.0, 9.0, and 11.0).
   a. Select:
      
      Tools > Internet Options
   b. Select the Security tab.
   c. Select the Local Intranet Zone. Do not change the security settings for any other zone.
   d. Click Custom level....
   e. Scroll down to Launching applications and unsafe files.
   f. Change the setting from Prompt to Enable.
   g. Change the setting back to default when the 800xA System software installation is complete.

It is mandatory to revert the settings back to the default.
**Known Problems and Restrictions**

The following manual procedures (if applicable) must be performed.

1. Once the node is updated to 800xA 5.1 Revision E, it is not possible to use the **Find Tool** in Plant Explorer Workplace until the **System Extensions** are applied. It is recommended to perform the Release Reservations operation before loading **System Extensions** from a node where 800xA 5.1 Revision E is not installed.

   In case, this is the last node to be updated to 800xA 5.1 Revision E in the system, ensure that all Reservations are Released before proceeding with the update as the **Find Tool** is not available after update to 800xA 5.1 Revision E to search for Reservations unless the **System Extensions** are applied.

2. Click **Keep Blocked** when the dialog box for the Firewall appears during the installation of Device Management FOUNDATION Fieldbus.

3. ABB DTM S900DP can only be updated with the logged in user the same as the user who installed the product.

4. The required third party software to upgrade from 800xA 3.1, 4.1, and 5.0 SP2 to 5.1 Revision E. The software are as follows:
   
   – Microsoft Office 2010 or 2013.
   
   – Crystal Reports 2008. For details on the Service Packs, refer to **Third Party Software used in 800xA 5.1 Revision E** on page 4.

5. SQL Server 2008 SP4 and Oracle updates are handled by the System Update Tool. All other third party software is not handled by the System Update Tool.

6. Remove the ABB DataDirect (ABBDataDirect) add-in from Microsoft Excel and add it manually when updating from 800xA 5.1 and 5.1 Revision A (32-bit) to higher version.

   Perform these steps on all 800xA nodes for every other user account except for the 800xA Installing User account.

   a. Start Microsoft Excel.
   
   b. Click the **File** button in the upper left corner.
   
   c. Select **Options** from the bottom of the menu.
d. Select Add-Ins from the left pane.

e. Click Go in the right pane.

f. Click Browse and use the Browse dialog box to find and select the ABBDataDirect.xla file located in:

C:\ProgramData\ABB\IM\DataDirect\Bin\n
This makes the DataDirect Add-in available in the Add-ins dialog box. Any add-ins listed in this dialog box may be added or removed from Excel by selecting or clearing the corresponding check box.

g. Select the DataDirect check box and click OK.

7. Perform these steps after updating from 800xA 5.1 and 5.1 Revision A (32-bit) to higher version.

For Office 2010, Step a through Step c are not applicable.


   The dialog box is visible only at the first launch of Excel after installing Office 2013.

   - b. Select the recommended settings and follow the instructions.

   - c. Close Microsoft Excel.

   - d. Browse and run RegVBAAddins.bat:

     C:\Program Files (x86)\ABB Industrial IT\Engineer IT\Engineering Studio\Bulk Data Manager\bin

8. If the system is upgraded from Internet Explorer 8.0 to Internet Explorer 9.0 or 11.0 on an 800xA for Harmony, follow the steps:

   - a. Upgrade Internet Explorer on the Domain Controllers. Follow the procedure provided by Microsoft to upgrade Internet Explorer.

   - b. Update the Group Policy. For more information, refer to the Group Policy Management subsection in the System 800xA Automated Installation (3BSE034679*) user manual.

   - c. Run the System Update Tool on the Domain Controllers.
d. In case of Online Update, update the nodes in the following order:
   - Application Servers.
   - Connectivity Servers (Redundant first and then primary).
   - Aspect Servers (Redundant first and then primary).
   - Clients.

Perform the following steps on the nodes being updated:

a. Upgrade Internet Explorer on the node.

b. Run the command to force out the Group Policy updates on the node.
   
   \texttt{gpupdate /force}

b. Log into Harmony Connectivity Servers and Harmony Configuration Servers once as the 800xA Service User account and logout.

d. Login to the 800xA Install account or other IndustrialITAdmin account.

e. Run the System Update Tool.

9. While upgrading the system from 800xA 5.1 to 800xA 5.1 Rev E (32-bit) using the System Update Tool, if the MOD connectivity servers along with the ABB PAS system services are present in the system, then during installation of ABB Batch Management product the Windows Package Manager displays a message to restart the system.

   Click \textbf{No} when prompted and continue with the installation.

10. Click \textbf{Yes} and \textbf{Yes To All} when the dialog window for the On Line Builder appears during the uninstallation of the 800xA for Advant Master. Ensure to uninstall the On Line Builder before starting the installation of 800xA for Advant Master.
Contact us

www.abb.com/800xA
www.abb.com/controlsystems