1. About this manual .................................................................5
  1.1. Copyrights .................................................................5
  1.2. Trademarks ..............................................................5
  1.3. General .................................................................5
  1.4. Related documents ..................................................6
  1.5. Document revisions ...............................................6

2. Installing Terminal Services ..............................................7
  2.1. Installing Terminal Services ........................................11
    2.1.1. Installing Windows 2000 Terminal Services ..........11
    2.1.2. Installing Terminal Server Client ......................13
    2.1.3. Changes to the Terminal Services installation in Microsoft Windows Server 2003 ................15
    2.1.4. Client Interface on Windows Server 2003 based computers .........................................16
    2.1.5. RDP 5.1 Client .................................................16
    2.1.6. Creating desktop icons ...................................20
  2.2. Licensing service installation ........................................24

3. System Administration .....................................................27
  3.1. Export & Import Tool .................................................27
    3.1.1. Using Export & Import Tool .............................28
      3.1.1.1. Opening and exiting Export & Import Tool ....28
      3.1.1.2. Exporting and importing objects ..............29
  3.2. Backup Tool ..........................................................34
    3.2.1. Configuration .................................................35
    3.2.2. Test .............................................................37
    3.2.3. Usage ..........................................................37
  3.3. SCIL Database Tool ..................................................39
    3.3.1. Creating a New SCIL Database File ....................40
    3.3.2. Creating New Section with Value ....................41
    3.3.3. Editing Section Value ....................................42
    3.3.4. Renaming Sections .........................................43
    3.3.5. Deleting Selected Content ..............................43
    3.3.6. Opening the SCIL Database File ......................43
    3.3.7. Saving SCIL Database File ...............................46
    3.3.8. Transferring information between two SCIL Database Tools .......................................47

4. Index .............................................................................49
1. About this manual

1.1. Copyrights

The information in this document is subject to change without notice and should not be construed as a commitment by ABB Oy. ABB Oy assumes no responsibility for any errors that may appear in this document.

In no event shall ABB Oy be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB Oy be liable for incidental or consequential damages arising from use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB Oy, and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license.

Copyright © 2004 ABB Oy
All rights reserved.

1.2. Trademarks

Registrations and trademarks used in this document include:

Windows: Registered trademark of Microsoft Corporation.

1.3. General

This manual provides information on the supported operating systems of this product; Terminal Services’ installation with its license installation and the new tools, which might be needed during the commissioning of the MicroSCADA system.

Software requirements for MicroSCADA Pro Base System are:

• Microsoft Windows 2000 Professional
• Microsoft 2000 Server
• Microsoft Windows XP Professional
• Microsoft Server 2003 Standard Edition

For further information refer to Microsoft documentation.

Software requirements for MicroSCADA Pro Workstations are:

• Windows NT 4.0 with Service Pack 3
• Windows 95 with Service Pack 1
1.4. Related documents

<table>
<thead>
<tr>
<th>Name of the manual</th>
<th>MRS number</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYS 600 *9.0 Installation and Commissioning Manual</td>
<td>1MRS751853-MEN</td>
</tr>
<tr>
<td>SYS 600 *9.0 System Administration Manual</td>
<td>1MRS751857-MEN</td>
</tr>
</tbody>
</table>

1.5. Document revisions

<table>
<thead>
<tr>
<th>Version</th>
<th>Revision number</th>
<th>Date</th>
<th>History</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>9.0</td>
<td>30.06.2004</td>
<td>Document created</td>
</tr>
</tbody>
</table>
2. Installing Terminal Services

Introduction

What is server-based computing?
With server-based computing it is possible to deploy, manage, support and execute applications completely on a server. The client devices, whether “fat or thin”, have instant access to it without application rewrites or downloads.

How does server-based computing work?
Server-based computing relies on three critical components:

1. A multiuser operating system that allows multiple concurrent users to log on and run applications in separate, protected sessions on a single server.

2. A remote presentation services architecture capable of separating the application's logic from its user interface, in such a way that only keystrokes, mouse clicks, and screen updates travel the network.

3. The Terminal Server product consists of four components: the Windows Server multiuser core, the Remote Display Protocol, the Windows-based client software and enhanced system administration tools.

Terminal Server: A multiuser server core that provides the ability to host multiple, simultaneous client sessions on Windows Server 4.0 (Terminal Server Edition) and on later versions of Windows Server (Windows Server 2000, Windows Server 2003).
Remote Display Protocol (RDP): A key component of Terminal Server is the protocol, which allows a client to communicate with the Terminal Server over the network. It is a multichannel protocol tuned for high-bandwidth enterprise environments. Furthermore, it supports three levels of encryption.

Terminal Server Client: The client software presenting or displaying the 32-bit Windows user interface on a range of desktop hardware.

Administration Tools: In addition to all the familiar Windows Server administration tools, Terminal Server adds the Terminal Server License Manager, Terminal Server Client Connection Configuration and Terminal Server Administration tools for managing the client sessions. There are two new objects, Session and User, which are also added to the Performance Monitor to allow tuning of the server in a multiuser environment.

Citrix MetaFrame Application Server

MetaFrame Application Server for Windows is Citrix's thin client/server system software for Microsoft's Windows Terminal Server. MetaFrame thin client/server system software incorporates Citrix's Independent Computing Architecture (ICA) protocol. Installing MetaFrame will not interfere with the functions of a computer running Terminal Server. This means that clients can connect and execute programs on the server regardless of whether they are running the Citrix ICA protocol, or the standard Terminal Server client using RDP. The main differences are in the features each protocol and its respective clients support.

For further information visit http://www.citrix.com.

The difference between Microsoft RDP and Citrix ICA

Windows 2000/2003 Terminal Services supports the native Microsoft Remote Desktop Protocol (RDP) as well as the Citrix Independent Computing Architecture (ICA) protocol (via the Citrix MetaFrame add-on). The following table provides an overview of the features available with each of these protocols:

Table 2.-1 Overview of the features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>RDP 5.1</th>
<th>ICA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clients</td>
<td>Windows CE-based thin client</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Windows XP Embedded-based thin client</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>ActiveX®</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Transport</td>
<td>TCP/IP</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>SPX, IPX, NetBEUI</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>WAN connection</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Dial-up, VPN, xDSL</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Direct dial-up (non-RAS)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Audio</td>
<td>System beeps</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Stereo Windows audio</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Local printing</td>
<td>Printing to a local printer attached to a thin client</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Local drive mapping</td>
<td>Local drives accessible from server-based applications</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>
Table 2.-1 Overview of the features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>RDP 5.1</th>
<th>ICA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local port redirection</td>
<td>Redirection of server ports (LPT/COM) to local client ports</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Cut and paste</td>
<td>Cut and paste of text and graphics between client and server</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>User-centric Session Access</td>
<td>Client remembers previous user’s logon name for each connection</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Connect to an active or disconnected session using a different screen resolution.</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Connect directly to an application rather than to an entire desktop.</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Server-based applications resize and minimize similar to local applications.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Application publishing</td>
<td>Advertise server-based applications directly to client desktops.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Resolution</td>
<td>16-bit color depth</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Load balancing</td>
<td>Pooling of servers behind a single server address and for increased availability.</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Remote control</td>
<td>Viewing and interacting with other client sessions (also called “shadowing”).</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Bitmap caching</td>
<td>Optionally cache display bitmaps in memory for improved performance.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Optionally cache display bitmaps to disk for improved performance.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Encryption</td>
<td>Multiple-level encryption for security of client communications.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td></td>
<td>Multiple-level encryption on Windows CE thin clients.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Automatic client update</td>
<td>Administrative means for updating client connection software from the server.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Pre-configured client</td>
<td>Predefined client with published applications, IP addresses, server names and connection options.</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>

Terminal Server system requirements:

Operating system:
- Microsoft Windows 2000 Server or

Base Requirements:
- 32-bit x86 microprocessor (such as Intel PentiumIII or higher)
- 1024x768 or higher resolution monitor, 256 colors
- One or more hard disks, with 1GB minimum of free hard disk space
- 256 MB of RAM, plus 10 MB for each typical user who is connecting
- Transmission Control Protocol/Internet Protocol (TCP/IP)
- (A high-density 3.5-inch disk drive plus a CD-ROM drive)
Processor and Memory Requirements:

Processor and memory requirements scale linearly up to four processors. For example, you can support double the number of users on a multiprocessor-capable Pentium system by doubling the number of processors and the amount of memory. For this reason, purchasing a multiprocessor system, even if you initially purchase only one processor, allows you to add capacity more easily as your requirements grow.

Other Peripherals:

Hard disk throughput affects also the performance of the device. The SCSI disk drives and adapters, especially devices compatible with Fast SCSI and SCSI-2, have significantly better throughput than the IDE or ESDI disk drives and adapters.

For the highest disk performance, consider using a SCSI RAID controller. The RAID (Redundant Array of Independent Disks) controllers place data on multiple disk drives automatically and can therefore increase disk performance and improve data reliability.

Although the Remote Desktop Protocol used with Terminal Server causes negligible network load, a high-performance network interface card (NIC) is recommended. This is particularly important, if many users require access to data stored on network servers or run client/server applications.

If a multiport asynchronous communications adapter is installed for supporting dial-in users, be sure to use an intelligent (microprocessor-based) adapter to reduce interrupt overhead and increase throughput.

Client System Requirements:

The minimum requirements for the 32-bit Terminal Server Client are:

- Personal computer with an 80486 or higher
- Windows 98, Windows XP, Windows 2000
- 1024x768 or higher resolution video adapter, 256 colors
- High-density 3.5-inch disk drive
- Network interface card (NIC) using the Microsoft TCP/IP protocol
- Microsoft serial mouse or 100 percent compatible

A Terminal Server Client can be used on a client PC to access a Terminal Server using the TCP/IP protocol from a network or by connecting via a Remote Access Service (RAS) connection.

Windows XP or Windows 2000 Professional does not contain Terminal Services.
2.1. Installing Terminal Services

2.1.1. Installing Windows 2000 Terminal Services

Open the control panel and double-click the Add/Remove Programs icon. When this is done, the Add/Remove Programs dialog is displayed. Then click the Add/Remove Windows Components button on the left-hand side of the dialog. See Fig. 2.1.1.-1.

![Add/Remove Programs dialog](add_prog)

Then the Windows Components Wizard is displayed. Scroll down the list to find Terminal Services and select it by placing a check in the box on the left of it. If you click the Details button, you will see that there are two sub-components: Client Creator Files and Enable Terminal Services. See the figure below.
The next dialog is displayed to install Terminal Services to run in one of two modes: Remote Administration or Application Server. In here, the Application mode is required. This also requires the Terminal Services Licensing service to be installed. A Terminal Services Client Access License is also required for non-Windows 2000 Professional clients. After selecting the mode, click Next to continue.

The following two dialogs concern the applications. In the first dialog, you can determine how much you would like to restrict the users from accessing the registry. Some applications store user settings in the registry, and will therefore need more permissions to it than others. In here, select Windows 2000 Users.
2.1.1. Installing Terminal Server Client

There are two methods to install the Terminal Server Client:

The Client Creator can be used to create disks for installing the client software on a user's computer. You can use these disks to distribute the appropriate Terminal Services Client to each user.
Fig. 2.1.2.-1 Create Installation Disks dialog

One of the directories created in Terminal Services installation is WINNT\system32\clients\tsclient.

By sharing this directory as read-only, you can install the Terminal Server Client over the network without using discs. This is done simply by running setup.exe from the net\win32 directory.

Fig. 2.1.2.-2 Installing the Terminal Server Client without using discs
2.1.3. Changes to the Terminal Services installation in Microsoft Windows Server 2003

When you install Windows Server 2003, you are not prompted to install Terminal Services. You can only enable or disable connections to the computer. By default, Terminal Services is installed when you install Windows Server 2003. When you install Windows Server 2003, the following options are displayed during the component installation:

- Terminal Services Licensing

This option is consistent with the Windows 2000 installation.

- Application Server

This option is referred to as Application Mode in Windows 2000 Terminal Services.

There are several new server features that provide improved management of Terminal Services and the Windows Server 2003 family: Improved Server Management, Remote Desktop for Administration, Connecting to the Console, Activating Remote Desktop and Terminal Services etc.

![System Properties dialog](image)

Fig. 2.1.3.-1 System Properties dialog
2.1.4. Client Interface on Windows Server 2003 based computers

Remote Desktop Connection

The Terminal Services Client, called Remote Desktop Connection (RDC), provides substantial improvements over previous releases, including greater functionality through a simplified user interface moving between a remote session and the desktop.

To update previous operating systems, the Client portion of Remote Desktop can be downloaded from Microsoft on a computer running any of the following operating systems:


By running this software, you can use other Windows platforms to remotely connect to a computer running Windows 2003 Server.

2.1.5. RDP 5.1 Client

The Remote Desktop Connection (RDC) Client icon is found as default under Communications. See the figure below.

Fig. 2.1.5.-1 Opening the Remote Desktop Connection Client icon

To use RDC, simply type the name of the remote computer and select Connect, as shown in Fig. 2.1.5.-2 below.
By default, a remote session is full-screen and high-color. The connection bar at the upper part of the full-screen RDC session enables you to move easily between the remote session and the local desktop.

**Customizing the Remote Connection**

To change the various options for configuring the remote connection, a tabbed property sheet exposes the controls for Display, Local Resources, Programs to run on connection, and other Experience settings, as shown in Fig. 2.1.5.-3.
To optimize performance over lower-bandwidth connections, you can choose your connection speed and strip away unneeded components of the remote session, for example, themes, bitmap caching and others. These choices are made by using the Experience tab of the RDC, as shown in Fig. 2.1.5.-4 below.
No Separate Connection Manager

Connection Manager is no longer necessary, because its functionality has been enhanced and integrated directly into the RDC. This enables users and administrators to save and open connection settings files, which can be used locally and/or deployed to other users. Passwords that are saved are securely encrypted, and can only be decrypted on the computer on which it was saved.

Automatic Reconnects

To better protect against network dropouts (especially in wireless and dial-up environments), RDC will automatically attempt to reconnect to a server when a network interruption caused the session to be lost.

Client Resource Redirection

Remote Desktop Connection supports a wide variety of data redirection types. For security reasons, each of these can be disabled by either the client or the server. A security alert is displayed when file system, port, or smart card redirection is requested; the user can cancel the connection or disable the redirection at that time.
Client Resource Redirection Features

2.1.6. Creating desktop icons

By selecting the connection and clicking the rightmost button on the dialog, the user can create a Start-up icon on the computer Desktop.

Fig. 2.1.5.-5  Remote Desktop Connection, Local Resources dialog
Fig. 2.1.6.-1  Creating a Start-up icon on the Desktop

Fig. 2.1.6.-2  Shortcut icon
**HSB Icons**

If MicroSCADA is configured as an HSB (Hot Stand By) system and you want to use only one icon on the client desktop, you can find the “Hot” one by clicking the icon on the desktop. When this is done, a command file (.bat) starts the MicroSCADA command procedure, which opens a dialog from the “HOT” system.

Once a minute, MicroSCADA is running command procedure (PROG_CHECK) that writes down the information on which one of the machines is "HOT". Both procedures run in WD (MicroSCADA Watch Dog) application in both systems.

![HSB system](image)

**Fig. 2.1.6.-3** HSB system

Command procedure PROG_OPEN:

```
#IF APL1:BAS=="HOT" #THEN @ops=ops_call("d:\sc\prog\exec\connection2.bat",0)
```

Command procedure PROG_CHECK:

```
#IF APL1:BAS=="HOT" #THEN #SET PROG_CHECK:CCM=DEC(1)
#ELSE #SET PROG_CHECK:CCM=DEC(2)
```

connection2.bat:

```
SET SCS_MS_WINDOWS_APPLICATION=1
SET SCS_MS_WINDOWS_MONITOR=0
SET SCS_MON_TYPE=LVS
SET SCS_X_TERMINAL_FONT=family:MicroSCADA1215-size:12
picn -laf windows -font"family:Arial-size:12" -face medium
```
Desktop icon starts the Connection.bat program.

**Remote Desktop Connection, Program settings dialog**

Connection.bat:

```
scilc -msa 2 -cmd "#IF DEC_SCAN(PROG_CHECK:2CCM)==1 #THEN #DO PROG_OPEN:2C"
```

Usage: SCILC [-msa <application> -cmd <SCIL command>]
2.2. Licensing service installation

To install the license service, choose Terminal Server Licensing during product setup, or at any time click the Add or Remove Programs icon on the Control Panel. Then click the Add/Remove Windows Components button.

![Add/Remove Components, Terminal Services Licensing](add_comp)

In Windows Server 2003, the licensing service can be installed on a workgroup based server, a member server or a domain controller.

During the installation of the Terminal Server Licensing service, you need to choose between the following modes of the license server:

- Your entire enterprise (enterprise license server)
- Your domain or workgroup (domain/workgroup license server)

Normally, your domain or workgroup is used. In this scenario, a license server is automatically discovered by any terminal server within the same subnet as the license server.

Licensing service activation

A license server must be activated in order to certify the server and allow it to issue client license tokens. A license server is activated using the Activation Wizard in the Terminal Server Licensing administration tool. To activate a license server, select Activate Server from the Action menu while the server is highlighted.
There are three connection methods to activate your license server:

- **Internet (Automatic):** The quickest and easiest way to activate and install licenses, which is also recommended by Microsoft. This method requires Internet connectivity from the device running the Terminal Server Licensing admin tool. Internet connectivity is not required from the license server itself. The internet method uses TCP/IP (TCP port 443) to connect directly to the Clearinghouse.

- **Web:** The Web method should be used when the device running the Terminal Server Licensing admin tool does not have internet connectivity, but you do have access to the Web by means of a Web browser from another computer. The URL for the Web method is displayed in the Activation Wizard.

- **Phone:** The phone method allows you to talk to a Microsoft Customer Service Representative to complete the activation or license installation transactions. The appropriate telephone number is determined by the country/region you choose in the Activation Wizard and is displayed by the wizard.

A license server must be activated only once. While waiting to complete the activation or license token installation processes, your license server can issue temporary tokens for clients that allow Terminal Server Licensing.
License purchase

The process for purchasing TS CALs for Windows Server 2003 remains the same as for purchasing other Microsoft Client Access licenses. Customers might purchase these licenses by obtaining a Microsoft License Pak (MLP), Microsoft Open License, or through one of Microsoft's volume licensing programs, such as Microsoft Select.

License installation

License tokens must be installed on your license server in order to deploy them to client devices. After you have purchased TS CALs, you can then install the corresponding license tokens by using the CAL Installation Wizard, which is located in the Terminal Server Licensing tool.

For more information, see Microsoft document Terminal Server Licensing.doc.
3. System Administration

3.1. Export & Import Tool

Introduction

The following common functionality is provided by this tool:

- Recognizing of all the application objects from the selected MicroSCADA application.
- Defining the common options for the exported and imported application objects.
- Exporting and importing application objects.

The common options for the exported and imported data are at the upper part of the dialog. The application objects to be handled are listed at the lower part of the dialog. The progress of operation is indicated by using the Progress Indicator component and the status bar fields. The user actions are operated by clicking the appropriate buttons in the tool.

The Export/Import Tool can also act as stand-alone tool and be consequently accessed directly via the Tool Manager.

Recognizing application objects

During the start-up of the tool, the list of MicroSCADA applications is read. The application, where the Application Object Export/Import tool has been started, is used as a default item.

The list of object types contains the following application objects, which are indicated with letters:

IX  Process Objects
X  Scale Objects
D  Data Objects
C  Command Procedures
T  Time Channels
A  Event Channels
UP  Free Type Process Objects
F  Free Type Objects
H  Event Handling Objects

It is also possible to select All Object Types item. When All Object Types is selected, the Application Object Export/Import tool operates with all the application objects found from the selected application.
Export & Import Tool composition

The Export/Import Tool is composed of a menu bar, a tabbed page containing search conditions, Import, Export and Close buttons and a tabbed page containing application objects to be handled. At the lowest part of the tool dialog, there is a status bar showing the number of processed application objects found and selected.

3.1.1. Using Export & Import Tool

3.1.1.1. Opening and exiting Export & Import Tool

Application Object Export/Import Tool can be started from the Object Navigator menu item by selecting Data > Export..., see Fig. 3.1.1.1.-1. In this case, the tool is started on export mode, i.e. it can only be used for exporting the application objects. Depending on the selected application objects in the Object Navigator, the common options in the Application Object Export/Import Tool become assigned as defaults.

Fig. 3.1.1.1.-1 Open the tool from the Object Navigator dialog
When Application Object Export/Import Tool is started from the Object Navigator menu item by selecting Data > Import, the tool is started on import mode, i.e. it can only be used for importing the application objects. When the import operation is finished, the selected Object Navigator view becomes updated.

![Fig. 3.1.1.-2 View of the Export & Import Tool started from Object Navigator](image)

Close the Export & Import Tool by clicking the Close button. The tool can also be closed by selecting Exit from File menu or by the keystroke Alt+F4.

### 3.1.1.2. Exporting and importing objects

With this tool it is possible to export and import application objects.
Exporting

The set of application objects to be exported need to be defined by using the common options for the exported data. The application objects that match the common options are listed in the Application Objects tabbed page. Those application objects that need to be exported can be selected on this page. When Select All is clicked, all the objects become selected. When Unselect All is clicked, none of the objects become selected. To select separate application objects from the list, hold the Ctrl key down while clicking the objects.

When the selection contains at least one application object, the Export button is enabled and when the button is clicked, a destination (export) file is created.

During the export operation, the progress indicator displays the operation progress, see Fig. 3.1.1.2.-1.

Defining common options for exported data

In addition to the application and object type definitions, it is possible to define other common options for the exported data.

Furthermore, it is possible to define Filter Condition for the application objects to be handled via this tool during the export. As a default, the Filter Condition is empty. E.g. if the Process Object’s type is selected and the Filter Condition LN=="KUI_SABAY1" is defined, all the process objects with Logical Name "KUI_SABAY1" become listed in the Application Objects tabbed page when OK or Apply is clicked in the Filter dialog, see Fig. 3.1.1.2.-2.
The existing Filter Condition is applied by selecting the condition from the drop-down list. The tool stores the 20 latest Filter Conditions in the filter history list. The filter history list is read in the tool during its start-up.

The file name to be used as a destination (Export) is defined by selecting the file with the File Chooser component (the button with three dots) on the right of the field. The default file name is assigned to the running application’s picture folder (logical path PICT is used), see Fig. 3.1.1.2.-3.

Fig. 3.1.1.2.-2 Filter dialog
Fig. 3.1.1.2.-3 File chooser dialog

Regarding the file handling options, it is possible to define either Overwrite or Append option. In the Overwrite option, the existing destination file becomes always overwritten. Whereas in the Append option, the new data is appended into the end of the existing destination file. When Read File is clicked, the source file defined by file name is read and the result is shown in the Application Objects tabbed page.

The Save Datalog Values option can be toggled on/off, depending whether the user wants to store the datalog values during the import operation. Default value is off.

Importing

The file name that contains the application objects is displayed in the common options. When the application objects are read from the export file, the progress indicator displays the operation progress. When all the application objects are read, they become listed into the Application Objects tabbed page. When Select All is clicked, all the objects become selected. When Unselect All is clicked, none of the objects become selected. To select separate application objects from the list, hold the Ctrl key down while clicking the objects.

When the selection contains at least one application object, the Import button is enabled, and when the button is clicked a source (import) file is read.

During the import operation, the progress indicator displays the operation progress, see Fig. 3.1.1.2.-4. If the file cannot be read, an appropriate notification dialog is displayed for the user.
An exception may occur, when the tool imports application objects. Due to an exception, the application object cannot be created or modified according to the import file. If one or multiple exceptions occur, they are listed in the Import Exceptions dialog, see Fig. 3.1.1.2.-5. This dialog displays the following information:

- **Type**: Letter that identifies the object type
- **Name**: Name of an object
- **Exception**: Context of exception (create new or modify an existing object)
- **Status**: SCIL status received from the system

*Fig. 3.1.1.2.-4  Import operation progress dialog*

*Fig. 3.1.1.2.-5  Import Exceptions dialog*
Functions of the dialog:

Button | Functions
--- | ---
Save As... | Opens the file chooser to specify the location for .log file to save the occurred exceptions. As a default, the file chooser is opened in the application's PICT folder, and the default file name is Default.log.

Close | Closes the dialog

**Defining common options for imported data**

In addition to the application and object type definitions, it is possible to define other common options for the imported data.

The file name to be used as a destination source (Import) is defined by typing the file name into appropriate field or selecting the file by using the File Chooser component (the button with three dots) on the right of the field. The default file name is assigned to the running application's picture folder (logical path PICT is used), see Fig. 3.1.1.2.-3.

Regarding the file handling options, it is possible to define either Overwrite or Append option. In the Overwrite option, the existing destination file becomes always overwritten. Whereas in the Append option, the new data is appended into the end of the existing destination file. When Read File is clicked, the source file defined by file name is read, and the result is shown in the Application Objects tabbed page.

The Save Datalog Values option can be toggled on/off, depending whether the user wants to store the datalog values during the import operation. Default value is off.

### 3.2. Backup Tool

**Introduction**

With Backup Tool you can make an online backup of the MicroSCADA application. MicroSCADA is running while the backup is made.

This tool makes a backup of the main application, not of the whole MicroSCADA. In other words, it makes a backup of everything located under \SC\APL\'main application name'.

This means that you always need a second backup of \SC, if you change SYS_BASCON.COM or other files located outside the application.

This backup makes a shadow of the application in an other application (shadow application). In normal use the shadow application is passive.

When the backup starts, it removes all the files in the shadowing application and after that, it copies files from the main application to the shadowing application.

If some changes are made on files, which are already copied, it copies them again. When the copying is ready, it freezes the shadow application and starts to copy the shadow application to the tape or to some other media.
3.2.1. Configuration

The configuration of Backup Tool requires the following steps:

1. Stop MicroSCADA
2. Copy the Sys_Bascon.bck to be the Sys_Bascon.com. The following definitions in Sys_Bascon.com are important for the shadowing and backup procedures. See Sys_bascon.bck in \sys\active\sys_folder.
3. Define the system node name, main application name and application numbers. Note that normally the main and watchdog application can be the same.

@SYSTEM = "SYS_A" ; System node name or TCP/IP address
@APL_NAME = "TUTOR" ; Name of main application
@APL_NUMS = (1,1,3) ; Application numbers in the following order: (Main, Watch-dog, Backup), application number must be <= 10

Base system shadowing must be set in use:

#CREATE SYS:B = List(-
  SA = 209,- ; Station address of base system
  ND = 9,- ; Node number of base system
  SH = 1,- ; SHADOWING ENABLED
  DN = 1,- ; Default NET node number
  ...

...
LAN link is needed:

```plaintext
#CREATE LIN:V = LIST(-
  ; Link to other SYS or LAN frontend (requires TCP/IP)
  LT = "LAN")
#CREATE LIN2:B = %LIN
```

Base system node is needed:

```plaintext
#CREATE NOD:V = LIST(-
  ; Node for Base System
  NN = %System,-
  LI = 2,-
  SA = 209)
#CREATE NOD9:B = %NOD
```

- Main and watchdog applications must have at least 2 parallel queues.
- Main and backup applications must have the shadowing attributes defined correctly.
- Main and watchdog applications must be set to HOT state, and the backup application to COLD.
- Application mapping must be made in main, watchdog and backup applications.

```plaintext
#CREATE APL:V = LIST(-
  ; ** Main Application **
  TT = "LOCAL",- ; Translation Type
  NA = %APL_NAME,- ; Name of application directory
  AS = "HOT",- ; Application state (COLD, WARM, HOT)
  PQ = 2,- ; Number of parallel queues
  SN = %APL_NUMS(3),- ; SHADOW APPLICATION
  SW = %APL_NUMS(2),- ; SHADOW WATCHDOG
  SC = 240,- ; SHADOW MAXIMUM CONNECTION TIME IN SECONDS

... #LOOP_WITH I = 1 .. LENGTH(%APL_NUMS)
@NUM = %APL_NUMS(%I)
#SET APL:VAP(%NUM) = %NUM
#LOOP_END
```

This watchdog application is not needed, if the main and watchdog applications are combined by selecting the watchdog application number to be the same as for the main application in vector "@APL_NUMS", in the beginning of the Sys_Bascon.com.

```plaintext
#CREATE APL:V = LIST(-
  ; ** Watchdog Application **
  TT = "LOCAL",- ; Translation Type
  NA = "WD",- ; Name of application directory
  AS = "HOT",- ; Application state (COLD, WARM, HOT)
  PQ = 2,- ; Number of parallel queues

... #LOOP_WITH I = 1 .. LENGTH(%APL_NUMS)
@NUM = %APL_NUMS(%I)
#SET APL:VAP(%NUM) = %NUM
#LOOP_END
```

4. Create a backup application:

```plaintext
#CREATE APL:V = LIST(-
  ; ** Backup Application **
  TT = "LOCAL",- ; Translation Type
  NA = SUBSTR("BCK" + %APL_NAME,1,8),- ; Name of application directory
  AS = "COLD",- ; Application state (COLD, WARM, HOT)
  SN = %APL_NUMS(1),- ; Shadow application = Main application
  SW = %APL_NUMS(2)- ; Shadow watchdog

...
5. Create a backup application with the MicroSCADA control panel.
6. Set the name to BCK, plus five first characters of the main application name (see the backup application definition in Sys_Bascon.com).

The name can also be something else, but it has to be the same as defined in the Sys_Bascon.com file.

7. Start MicroSCADA.
8. Enter the Tool picture, Base system, and System check if the shadowing object manager is installed. If not, press the key to install package.

This will create all the command procedures needed for the shadowing management.

9. Enter this backup tool again and select File > Save. Then it asks you to modify the backup command procedure name from SHADBACKUP to BCK_CREATE.

This creates the line @BCK_PROC = "BCK_CREATE" in the SHADGLOBAL command procedure.

10. Select File > Save again, and it asks you to create the following objects:
    BCK_START:C
    BCK_CREATE:C
    BACKUP_1:T
    BACKUP_2:T
    BACKUP_3:T

3.2.2. Test

- Click the Backup button and check that the shadowing function is working correctly.
- Select Base system from the tool picture and check that the shadowing on applications is sending and transmitting correctly.
- Watch the Notify window in case there are some error messages.
- If something has gone wrong and the shadowing does not stop, change the shadowing state in the Basesystem Configuration Tool to "NONE" for both main and backup application.

3.2.3. Usage

Information on how to use the backup.

Manual Backup:

Click the Backup button, and after that click Yes. The procedure takes about 1 1/2 hour with a medium application with reporting.

When you start a manual backup from this tool, it will trigger the command procedure BCK_START, which starts the backup.
Auto Backup:

When No Backup is selected, no automatic backup is made. If Once a month is selected, the time channel BACKUP_1 activates the start of backup.

If Once a week is selected, the BACKUP_2 activates the start of backup, and if Once a Day is selected then BACKUP_3 activates the start of backup.

As default, the time channels are started as shown in the following table. If there is a need to change the time, it can be done with the Time Channel Tool, which is opened from the application object navigator.

<table>
<thead>
<tr>
<th>Time Channel</th>
<th>Schedule</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>BACKUP_1</td>
<td>First day every month at 00:10</td>
<td>once a month</td>
</tr>
<tr>
<td>BACKUP_2</td>
<td>Every Friday at 18:01</td>
<td>once a week</td>
</tr>
<tr>
<td>BACKUP_3</td>
<td>Every day at 00:10</td>
<td>once a day</td>
</tr>
</tbody>
</table>

Backup Media:

It is possible to select where the application backup is created. When you select the Tape, it will be the NT Backup, which creates a backup of the backup application to a tape.

If the Directory is selected, the backup application is copied in that directory. The directory definition should be in the operating system format.

If Advanced is selected, it is possible to define a scil program, which creates the backup.

```
@t_Dir = parse_file_name("/APL/" + %apl_Name)
@Code = opx_call("Copy 't_Dir' H:\Backup", 0)
```

![Example of a advanced backup definition](Ad_backup_media)

**Fig. 3.2.3.-1** Example of a advanced backup definition.
General:
When the Backup has been started, this tool can follow the shadowing of the main application to the backup application.

When the shadowing is ready, and the backup creation command has been executed, it shows the following message, “Shadowing is ready. Backup will be created by operating system”.

This means that this tool does not have any connection to the creation of the backup, which is normally made by the operating system tools like NT Backup.

In the lower part of the tool dialog, there is an info bar, which shows different system messages. One of the fields shows when the last backup has been made.

During the installation, the standard template file, sys_bascon.bck, to be used together with online backup functionality is installed into the \sys\active\sys_ folder.

3.3. SCIL Database Tool

Introduction
In MicroSCADA, it is possible to create SCIL database files that may contain any SCIL data types. For more information on SCIL databases, see the Programming Language SCIL Manual. In the operating system’s file system, the SCIL database files are recognized by their file extension .SDB (SCIL Database file).

SCIL Database Tool provides the following functions for these files:

- Creating a new file
- Opening an existing file to display the contents of the file in a structured way
- Editing the file with regard to the sections, element names and their values
- Saving the file
- Copy and paste the contents of the file between two SCIL Database tools open at the same time
Fig. 3.3.-1  Main view of the SCIL Database Tool

The main view of the tool consists of the following parts, see Fig. 3.3.-1:

- Menubar
- Toolbar
- Area for displaying the file contents in a structured way

3.3.1. Creating a New SCIL Database File

When File > New is selected or the appropriate toolbar button is clicked, the contents of the SCIL Database File tree is cleared in the tool. If the current SCIL database file in the tool has been modified before creating a new file, the following dialog is displayed to the user, see Fig. 3.3.1.-1.
When Yes is clicked, the tool saves the current SCIL database file before clearing the contents of tree. If No is clicked, the contents of tree is cleared without saving the content of the current SCIL database file. If Cancel is clicked, the contents of tree is not cleared.

### 3.3.2. Creating New Section with Value

When root node Sections is selected in the tree, select Object > New from the menubar or click the appropriate toolbar button. Then the New dialog is opened, see Fig. 3.3.2.-1.
Type the section name in the Section text field, and the value in the Value text field. Here are some examples for entered values:

- TRUE
- 10
- "10"
- LIST(FIRST=1, SECOND=VECTOR(1,2,3), THIRD=TIME)
- VECTOR(TRUE, FALSE, 12)

Clicking OK or pressing ENTER creates a new section in the tool with the entered value and closes the New dialog. Clicking Cancel discards the entered section with value and closes the dialog.

### 3.3.3. Editing Section Value

When some section is selected in the tree, select Object > Edit from the menubar or click the appropriate toolbar button. Then the Edit dialog is opened, see Fig. 3.3.3.-1.

![Edit dialog](sdb_edit_dialog)

Modify the contents of the existing value in the text field. When OK is clicked or ENTER is pressed, the modified value is applied into tool and Edit dialog is closed. If the entered value does not follow the SCIL syntax (for more information on this, see the Programming Language SCIL manual), the message dialog (Fig. 3.3.3.-2 below) is displayed for the user. Clicking Cancel discards the entered value and closes the dialog.

![Incorrect value entered in the Edit dialog](sdb_edit_emor)

![The value can not be evaluated! - Error 115 SCIL_END_OF_LINE_INSTEAD_OF_OPERAND](sdb_edit_emor)
3.3.4. Renaming Sections

Select some existing section in the tree, and select Object > Rename from the menu or click the appropriate toolbar button. Then the Rename dialog is opened, see Fig. 3.3.4.-1.

![Rename dialog](sdb_rename_dialog)

Type another section name in the text field. Clicking OK or pressing ENTER accepts the entered section name in the tool and closes the Rename dialog. Clicking Cancel discards the entered new section name and closes the dialog.

3.3.5. Deleting Selected Content

Select some existing section or value in the tree, and select Edit > Cut or click the appropriate toolbar button. The selected content is deleted. However, it is possible to paste this section or value later, because it is saved to the clipboard of tool.

3.3.6. Opening the SCIL Database File

When File > Open is selected or the appropriate toolbar button is clicked, the File Chooser dialog is opened, see Fig. 3.3.6.-1.
The default folder for File Chooser is the active application’s PICT folder. The files, which have the .SDB extension are shown as default. When the SCIL Database file to be opened is located in another folder, use the File Chooser to select the appropriate drive and folder. To open the file, select the file name from the list or type the name of the file to the File name field. It is also possible to open the latest files from the tool’s file history list, located in the File menu of the tool.

When the file is opened, its contents is displayed in the tool in a structured way.

If the Text Database file (SYS_TEXT.SDB, APL_TEXT.SDB) or other Text Database files defined by the APL:BTD Text Databases attribute) are opened in SCIL Database Tool, the following dialog is displayed for the user, see Fig. 3.3.6.-2.
In this case, the tool disables the saving function. This is because, the Text Translation Tool should be used for localization purposes of these files. However, it is possible to edit the contents of this file, and save it to another file name.

When the file is opened in the tool, its contents is shown in the tree. Sections node of the tree displays the number of sections included in this file. As a default, the Sections node is expanded, thus displaying all the sections found from the file. The contents of each section becomes displayed, when the appropriate Section node in the tree is expanded.

For each section and element, the following information is displayed:

- Name of the section or element
- Data type of the section or element
- Value of the section or element

Section is identified in the tree with following icon.

The data types for element values are identified with icons according to the following Fig. 3.3.6.-3.
3.3.7. Saving SCIL Database File

When File > Save As is selected from the menubar, the Save As dialog is opened, see Fig. 3.3.7.-1. The files with .SDB extension are recognized as SCIL Database files and are listed in the default folder. Type the SCIL Database file in the text field, and click Save. Or select some existing file name in the list to replace the existing file. Clicking Cancel discards the operation and closes the dialog.
3.3.8. Transferring information between two SCIL Database Tools

It is possible to copy and paste section and value information between two parallel SCIL Database Tools. The purpose of this function is to provide easier engineering, when there is a need to reuse the data from one SCIL Database File to another. This can be done by the following way:

1. Start the first SCIL Database Tool from the Tool Manager.
2. Open the SCIL Database in this tool. Select some section name in the tree.
3. Select Edit > Copy from the menubar or click the appropriate toolbar button.

The contents of the selected section is copied to the clipboard of the first tool. After this is done, do as follows:

4. Start the second SCIL Database Tool from Tool Manager.
5. Select the root node of the tree, i.e. click the Sections item.
6. Select Edit > Paste from the menubar or click the appropriate toolbar button.

The contents of the copied section is pasted in the contents of the second tool, see Fig. 3.3.8.-1.

If an existing file has been modified in the tool, select File > Save from the menubar or click the appropriate toolbar button to save the file with the same name.
Fig. 3.3.8.-1 Transferring information between two tools
# 4. Index

**A**  
Activation Wizard ................................................................. 24  
Administration Tools ........................................................... 8  
All Object Types item ............................................................. 27  
Append option ........................................................................... 32  
Application Server ................................................................. 12, 15  
Auto Backup .............................................................................. 38  

**B**  
Backup Media ............................................................................. 38  

**C**  
CAL Installation Wizard .......................................................... 26  
Citrix Independent Computing Architecture ........................... 8  
Client Creator ............................................................................ 13  
Client Creator Files ................................................................. 11  

**E**  
Enable Terminal Services ......................................................... 11  
Experience settings ................................................................... 17  
export mode ............................................................................... 28  

**F**  
File Chooser component .......................................................... 31  
Filter Condition ......................................................................... 30, 31  

**H**  
Hot Stand By ............................................................................... 22  
HSB ............................................................................................. 22  

**I**  
Import Exceptions ..................................................................... 33  
import mode .............................................................................. 29  

**L**  
LAN link ..................................................................................... 36  
License installation .................................................................... 26  
license service .......................................................................... 24  
License tokens ........................................................................... 26  

**M**  
Manual Backup .......................................................................... 37  
MetaFrame Application Server ................................................. 8  
MicroSCADA Watch Dog ........................................................... 22  
Microsoft Remote Desktop Protocol ....................................... 8  
multiuser server core ............................................................... 7
## Installation and Administration Manual

<table>
<thead>
<tr>
<th>O</th>
<th>Object Navigator menu item</th>
<th>28</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>Overwrite option</td>
<td>34</td>
</tr>
<tr>
<td>P</td>
<td>PICT folder</td>
<td>44</td>
</tr>
<tr>
<td>P</td>
<td>Progress Indicator component</td>
<td>27</td>
</tr>
<tr>
<td>R</td>
<td>RDC</td>
<td>16</td>
</tr>
<tr>
<td>R</td>
<td>RDP</td>
<td>8</td>
</tr>
<tr>
<td>R</td>
<td>RDP 5.1 Client</td>
<td>16</td>
</tr>
<tr>
<td>R</td>
<td>Remote Administration</td>
<td>12</td>
</tr>
<tr>
<td>R</td>
<td>Remote Desktop Connection</td>
<td>16</td>
</tr>
<tr>
<td>R</td>
<td>Remote Display Protocol</td>
<td>8</td>
</tr>
<tr>
<td>S</td>
<td>Save Datalog Values option</td>
<td>32</td>
</tr>
<tr>
<td>S</td>
<td>SCIL Database File</td>
<td>43</td>
</tr>
<tr>
<td>S</td>
<td>SCIL Database File tree</td>
<td>40</td>
</tr>
<tr>
<td>S</td>
<td>SCIL database files</td>
<td>39</td>
</tr>
<tr>
<td>S</td>
<td>SDB</td>
<td>39</td>
</tr>
<tr>
<td>S</td>
<td>SDB extension</td>
<td>44</td>
</tr>
<tr>
<td>S</td>
<td>stand-alone tool</td>
<td>27</td>
</tr>
<tr>
<td>S</td>
<td>SYS_BASCON.COM</td>
<td>34</td>
</tr>
<tr>
<td>S</td>
<td>Sys_Bascon.com</td>
<td>35</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Server</td>
<td>7</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Server Client</td>
<td>8</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Server client</td>
<td>13</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Server Licensing</td>
<td>24</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Server Licensing administration tool</td>
<td>24</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Services</td>
<td>11, 12</td>
</tr>
<tr>
<td>T</td>
<td>Terminal Services Licensing</td>
<td>15</td>
</tr>
<tr>
<td>T</td>
<td>Text Database file</td>
<td>44</td>
</tr>
<tr>
<td>W</td>
<td>WD</td>
<td>22</td>
</tr>
</tbody>
</table>