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Introduction to the manual

Chapter overview

Reader

Contents

The chapter includes a description of the contents of the manual. It also contains
information about the intended audience, and related publications.

The reader of this manual is expected to know the block programming principle, use
of tasks (time levels) in real-time programming, data types, Boolean operations and
arithmetic functions.

The chapter Introduction to DriveSPC briefly lists the main features of the DriveSPC
program.

The chapter Installation of Drive SPC gives information on installing the DriveSPC
program.

The chapter Solution programming describes the Solution Programming method,
including function blocks, custom circuits, pins, time levels, user parameters and
template files.

The chapter Use of DriveSPC describes the usage of the DriveSPC program,
including user interface, program modification actions and the On-Line mode.

The chapter Menu commands describes the File, Program, CustomCircuit, Drive
and Help menu commands of the DriveSPC program.

The Appendix 1 summarises the use of the Ctrl, Alt, Shift and F3 keys.
The Appendix 2 describes the use of arrays and structures in solution programs.

The Appendix 3 describes the Parameter Manager window.

Related documents

DriveStudio User Manual

ACSM1 Base Program Firmware Manual

Introduction to the manual
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Introduction to DriveSPC

General

DriveSPC (Solution Program Composer) is a Windows-based tool for Solution
Programming. It can be used without a drive or with one or more drives.

Solution Programming (SP) is based on the use of function blocks like in other IEC
61131-3 tools.

Solution programs execute in drives.
With DriveSPC it is possible to:

make a connection to a drive. If more than one drive is connected to the PC, the
user can select the drive from the list of available drives.

upload the solution program from the connected drive and display it graphically
on the screen. All program information exists in the drive; no additional PC files
are required.

monitor actual values of the user-selected block pins on the screen in real time
modify the solution program on the screen
utilise hierarchical programming

download the program to the connected drive and start the execution of the
program in the drive

print program pages
save the program to a disk file

open a saved program file and display it graphically on the screen. The program
can be modified, downloaded, saved, and so on.

compare programs
protect programs with passwords

see descriptions of all blocks and block-related parameters

A page of a solution program is shown on the next page.

Introduction to DriveSPC
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Operating modes

Off-Line mode
« This is the default operating mode after the start-up of DriveSPC

« The mode can be used without or with a drive

« Inthe Off-Line mode it is always possible to:

O

O

O

O

open a program file and display it graphically on the screen
modify the program
print program pages

save the program to a disk file

. If one or more drives exists, it is additionally possible to:

O

O

O

connect to the user-selected drive
upload the program from the connected drive and display it

download the program to the connected drive and start the execution of the
program in the drive

remove the program from the connected drive

go to the On-Line mode

On-Line mode

. All value modifications of block-related parameters are automatically copied to
the connected drive

« Actual values of user-selected block pins are displayed on the screen in real time

Introduction to DriveSPC
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Installation of DriveSPC

DriveStudio must be installed before the installation of DriveSPC.

DriveSPC is designed to run under the Microsoft Windows XP, 2000 or Vista
operating environment on IBM-compatible PCs.

Note: You must have Administrator privileges to your PC.
Insert the DriveSPC CD-ROM into the CD drive of your PC.

Start the Control Panel program (Start > Settings > Control Panel) and double
click its Add/Remove Programs icon.

Click the Add New Programs button and follow the instructions that appear on the
screen (select file Setup.exe from the CD-ROM):

Installation of DriveSPC
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Chapter overview

The chapter describes the Solution Programming method.

Function blocks

Solution Programming is based on the use of function blocks like in other IEC
61131-3 tools.

Blocks can be divided into two main groups:

Firmware blocks are parts of the drive control firmware connectable by pin

parameters.

One instance of every firmware block always exists in every solution program. It

is not possible to add or remove firmware block instances.

Firmware block example:

AD2

28

<«— Block ID

Time level —»|T17 ci0 psac

(151

—= 153,07 A02 PTR
— 15,08 AC2 FILT
— 15,09 AC2 MAX
— 15,10 402 MIM
— 15,11 A2 MAX
— 15,12 402 MIM

TIME

SCALE
SCALE

2.09 AD2

" Time level

position
(execution
position)

Block IDs are assigned automatically by DriveSPC and their values never

change. All block IDs are unique.

Time levels are explained below. Time level position (15) above means that this
block is the 15™ block of time level TL7.

Normal blocks can be divided into two groups:

o Standard blocks always exist and one or more instances of these blocks can

be added to all solution progr

ams.

o Technology blocks are optional blocks. Their instances can be used in a
solution program only if the appropriate technology library is in the drive.

New technology blocks can be made on demand.

Solution Programming
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Normal block example:

Data type
(ifany) e “®  wle— Block ID
Time level — > |12 10 meee W [— Time level
— IM1 HY
aut L posmon_
~mz (execution
position)

Block IDs are assigned automatically by DriveSPC and their values never
change. All block IDs are unique.

Time levels are explained below. Time level position (1) above means that this
block is the first block of time level TL9.

The data type of some normal blocks (such as the block above) is user-
selectable when instances of these blocks are added to solution programs.

Some normal blocks have extensible pins. The user can specify how many
copies of extensible pins are added to the block when an instance of the block is
added to a program.

If a block is inside a conditional IF-ELSE branch, a little magenta square 3 is
displayed in its upper left corner.

In addition to the function blocks mentioned above, there are three virtual block
types ("virtual" means that these blocks are not actually executed when a solution
program is running in a drive):

Comment block for user's comment texts.

Comment block example:

Sirnple, easy-to-understand Solution Progeamn Cornposer enables the adding of
user-defined function block programs even on the Fastest time lewels of
the drive control,

It can be used for on-line signal menitoring and pararneter setting, too,

Reference parameter block for user parameters that can be written by users.

Reference parameter block example:

Sealed real ref

24.20 User parameter ¥
[REAL)

Signal parameter block for user parameters that can only be read by users.

Signal parameter block example:

Selector list sig

84,06 User parameter y

Solution Programming
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Custom circuits

In Hierarchical programming a number of blocks with their connections can be
represented as a single block.

Hierarchical programming in DriveSPC is based on the use of user-defined custom
circuits.

A Custom Circuit (CC) contains a user-defined collection of one or more function
block instances and their user-defined pin connections.

After a CC has been defined, one or more instances of it can be added to one or
more solution programs just like instances of normal function blocks.

Definition of custom circuits

The programming of CC definitions is made in the CC definition window in the same
way as the actual solution programming is made in the solution program window.

Every CC definition must include one or more user-specified external pins. These
are input and/or output pins in the CC definition that will be visible in the instances
of the CC definition. These pins make it possible to connect a CC instance to other
blocks of the solution program.

Instances of the defined custom circuits

Instances of the created CC definitions can be added to the solution program that
was in the solution window when these CC definitions were made.

If you want to add instances of a created CC definition to other solution programs,
save the CC definition to a disk file.

Now you can open some other solution program, read the CC file into this program
and add instances of the read CC definition to this program.

Instances of CC definitions look similar to normal function blocks and they are
added to solution programs in the same way as instances of normal blocks are
added to programs.

Changing used custom circuit definitions

If you have used instances of a CC definition in your solution program, you can still
make changes to this definition later on, as long as you do not change the
definitions of external pins.

If you want to change the data type of an external pin in a CC definition and this pin
is connected in one or more instances of this CC definition, you have to disconnect
this pin in these instances before the pin change.

If you want to change the number or input/output type of external pins, you have to
remove all instances of this CC definition from the solution program and add the
instances again after you have changed the external pins in the CC definition.

Solution Programming
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Time levels

Pins

Custom circuit archive folder

It is suggested that all custom circuit definition files are saved to the same folder.

The pathname of the folder that is used in the CC file save or read operation is
saved to the solution program and this folder is initially displayed in the next CC file
save/read operation.

Solution programs are real-time programs. Real-time programming is based on
tasks and the drive software contains several tasks. Tasks are called time levels
here. The length, or the execution interval, of some time levels is fixed but the
length of the other time levels can be changed by the user.

Every block and CC instance of a solution program resides in some time level. The
execution order and the time level of every firmware block instance is always fixed
but the execution order and the time level of a normal block instance and a CC
instance is specified by the user.

There is a predefined priority order between time levels. If the execution of the
blocks of a time level is not completed when a higher priority time level is scheduled
to start its execution, the execution of these lower priority blocks is suspended until
the blocks of the higher priority time level have been executed.

Note: It is very important that the total execution time of all blocks of a time level
does not exceed the length, or the execution interval, of this time level.
If it does, the drive software does not function correctly.

Input and output pins (connection points) of blocks are marked with a small
magenta bubble.

Pin parameters of firmware blocks

The input and output pins of all firmware blocks are parameters.
The type of an input pin parameter can be one of the following:

« Value.
This parameter is usually set to a constant value but some value parameters can
be connected to an output pin, too.

» Value pointer

Marked with character '<' inside the block, for example <1507 402PTR
This parameter is usually connected to an output pin but some value pointer
parameters can be set to a constant value, too.

» Bit pointer
Marked as value pointer above.
This parameter is either connected to a bit of an output pin or itis set to a
constant Boolean value FALSE or TRUE.
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User-selectable value type of an input pin parameter can be one of the following:

« Drive value (text Drive value is displayed in the pin)
The value of this pin parameter in not specified in the solution program.
When the program is downloaded, the current drive value of this parameter is
preserved during the download operation.

« Locked value (e.g. 1.25)
When the program is downloaded, this value or pin connection is set to the drive
parameter.
Locked parameter values can not be changed in the drive after download.

« Unlocked value (value is enclosed with angle brackets, e.g. [ 1.25 1)
When the program is downloaded, user can select one of the following two
alternatives:

o Allunlocked values and pin connections are set to drive parameters.
o The current drive values of all these parameters are preserved.

Unlocked parameter values can be changed in the drive after download.

Output pins
Every output pin has two pin names:
» Internal name is inside the block rectangle:
o Internal name of a pin of a normal block describes the function of the pin.

o Internal name of a pin of a firmware block is the parameter ID & name
combination of its pin parameter.

« External name is used in all pin connections:

o Default external name of an output pin of a normal block is xxx (nnn),
where xxx is the internal pin name and nnn is the block ID.

Users can replace these names with their own pin names.
CUTSTATE (49)

Example of a default pin name:

o External name of an output pin of a firmware block is always the name of its
pin parameter.

If the connected input and output pins are not on the same page, an arrowhead is
displayed at the output pin: —
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Input pins

Every input pin is either set to a constant value or connected to an output pin (or to
a bit of an output pin).

Below are input pin examples (all possible five cases are included):

« Input pin with a constant value:
10,000 %

« Input pin connected to an output pin of a normal block or a CC instance:
MEW FEEFEREMCE

(1/s
The external name of the connected output pin is above the input pin.
Page number and block ID of output pin's block are below the input pin.

« Input pin connected to an output pin of a firmware block:
[anr

(24209
The name of the pin parameter of the connected output pin is above the input
pin.
Page number of output pin's block and parameter ID of output pin's pin
parameter are below the input pin.

« Input pin connected to a bit of an output pin of a normal block or a CC instance:
STATUS BITS.12
(1rs
The external name and bit number of the connected output pin are above the
input pin.
Page number and block ID of output pin's block are below the input pin.

« Input pin connected to a bit of an output pin of a firmware block:
MoDE BITS.4
(121,01 DEFALLT)

The name and bit number of the pin parameter of the connected output pin are
above the input pin.

Page number of output pin's block, parameter ID of output pin's pin parameter
and the name of the bit, or bit number if no bit name exists are below the input

pin.
A wire is automatically drawn between the connected input and output pins if these

pins are on the same page.
Wire example:

alT CALCULATED MEW REF

TL? E00 pze

CALCULATED MEW REF
ENES

< 15.07 &

Boolean input pins can be inverted. Inverted pins are marked with a little bubble, for
example 4Oi”‘”
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User parameters
Drive firmware contains a fixed set of parameters.

Users can create parameters of their own by DriveSPC. User parameters are
needed if pin value setting and monitoring of programmed normal blocks is required
by other means than DriveSPC (e.g. by panel).

There are two basic user parameter types:

« Reference parameter. These parameters are connected to input pins of normal
blocks. Values of the connected input pins can now be set e.g. by panel.

« Signal parameter. These parameters are connected to output pins of normal
blocks. Values of the connected output pins can now be monitored e.g. by panel.

The definition of a user parameter contains two steps:

. Parameter is created in the Parameter Manager window of DriveSPC (see
Appendix 3)

« The created parameter is connected to a pin of a programmed normal block by a
parameter block.

Templates
Templates can be uploaded from drives.
A drive contains one or two templates:
. Empty template (this template exists always)

« Base solution (this template is optional)

Empty template

Empty template contains an empty solution program, i.e. instances of all firmware
blocks but no normal block instances.

Empty templates are used as starting points of completely new solution programs.

Base solution
A drive can contain a base solution when it is delivered to a user.
Base solution is a complete solution program designed for a certain purpose.

Base solutions can be used as such or they can be further enhanced by users.
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Programming procedure

First programming steps

If you are using a drive and you want to make a completely new program:
1. Connect to the drive

2. Upload empty template from the drive. All template information exists in the
drive; no additional PC files are required.

If you want to make a completely new program without a drive:
1. Open an empty template file

If you are using a drive and you want to use its program (or base solution) as a
base program:

1. Connect to the drive

2. Upload program (or base solution, if it exists) from the drive. All program
information exists in the drive; no additional PC files are required.

If you want to use an existing program as a base program:

1. Open the existing program file

Actual programming

Modify the program by:

adding instances of normal blocks
defining custom circuits and adding instances of them

connecting pins

Post-programming

Save the modified solution program
If you are using a drive and you want to run your new program in the drive:
1. Connect to the drive (if you have not yet connected)

2. Download the program to the drive. The drive is automatically restarted after
the download and the program is running in the drive.

3. If you want to monitor pin values on the running program, go to the On-Line
mode and select the pins you want to monitor
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Use of DriveSPC

Chapter overview

The chapter describes the use of DriveSPC.

Starting DriveSPC

You start the DriveSPC program by using the Start button in the Task Bar (Start >
Programs > DriveWare > DriveSPC if you have used the default settings in the
software installation).

User interface
The user interface of DriveSPC can be divided into two parts:
« Menu commands

« Mouse clicks on the screen

With menu commands you can, for example:

« open and save program files

« print program pages

. define, copy, save, read and remove custom circuits
« connect to a drive

» upload and download programs

« start the On-Line mode

Click the right button on your mouse to display a context-sensitive menu. The
commands in this menu depend on the program object, for example a block or a pin
you clicked on.

Menu example:

— 1
b  Connect to Input Pin... Ckrl+Click
Show Pin Connections... Alt+Click
Go to Connected Block... Alt+Click

Pin Parameter Information... F3

Zoom Ouk

Select the desired command from the menu.
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Click the left button on your mouse while holding down the Ctrl, Alt or Shift key to
quickly perform or start some most often needed actions; see Appendix 1. In this
way you can for example:

« make connections between block pins
« move blocks on the screen
« monitor pin values in real time

If the cursor is on a block or on a pin parameter when you press the F3 key, the
description of this block or parameter is displayed in a separate PDF window.

Solution program can be divided into several pages. Every page has a user-
specified number and a user-specified name.

There are tabs for all pages at the bottom of the screen. The number and optionally
the name of the page are shown in the tabs. If the page names are not displayed in
the tabs, they can be seen as a ToolTip when the cursor is moved on the tab. If the
page is empty, an asterisk is displayed in the corresponding tab before the page
number.

2 Digital I/0 EXSEL==RUEY ] B

1 Signals

Select the desired page by using the page tabs. Click the page tab with the mouse
or use the Home, Page Up, Page Down and End keys.

The currently selected page is displayed either in Full Fit mode (zoomed out) or in
Actual Size mode (zoomed in). You change the display mode by right-clicking
anywhere on the page and selecting Zoom In or Zoom Out. If you zoom in, the
page will be centred to the clicking point.

If the page on the screen is zoomed in, it can be dragged with mouse's left button.
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First programming steps

Making a completely new program
« Using the empty template of a drive as a starting point:
1. start DriveSPC
2. connect to the drive by selecting Drive > Connect

3. upload empty template from the drive by selecting Drive > Upload
Template

« Using some other empty template file as a starting point:
1. start DriveSPC
2. open the empty template file by selecting File > Open

Making a new program based on an existing program
« Using the program (or base solution) of a drive as a base program:
1. start DriveSPC
2. connect to the drive by selecting Drive > Connect

3. upload program from the drive by selecting Drive > Upload Program or
base solution (if it exists) by selecting Drive > Upload Template

« Using some other program file as a base program:
1. start DriveSPC

2. open the program file by selecting File > Open
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Actual programming (program modification)

After you have opened or uploaded the program or template, you can modify it as
follows:

« Specify the name, version and comment of your program

« Add or remove program pages

. Change the lengths, or execution intervals, of variable-length time levels
. Create, copy, save, read and remove custom circuit definitions

« Add, modify and remove instances of normal blocks and custom circuits
. Add, modify and remove instances of comment blocks

« Move block and custom circuit instances on the screen

« Connect input and output pins

« Set values of input pins

« Invert input pins

. Define data items of array/structure pins

« Specify names of output pins

« Specify scaling factors and unit texts of output pins

. Create new user parameters and parameter groups

« Add and remove user parameter blocks

« Specify the fields of the page header at the bottom of the pages

You can also perform the following programming-related actions:
. Display the execution sequence of block instances

« Go to the block connected to an input pin

« Show all connections of an output pin

« Go to a block connected to an output pin

« Highlight wires

« Zoom in and zoom out

. Show descriptions of blocks and pin parameters

« Protect program open/upload and/or program display with user-specified
passwords
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Program information
Select Program > Program Information to display a dialog box with the current
name, version and comment text of your solution program.

Program Information il

Program Mame:

IEompIete solutior]

Program Yersion;

Major; |1 [range = 1...255]
Total Mumber of Program Changes; 543
Mimar; |0 [range = [...255]

Pragran Comment:

Ok I Cancel |

You can now change the name, version and/or comment text.

Program pages
Select Program > Program Pages to display a dialog box with a list of the currently
existing program pages.

Page Numbers and Names

Pages:

»1 Signals

% E;g;tlglglfjnu ¥ Show Page Mames in Page Tabs

4 Drive Logic

5 Drive Control

& Speed Ref

7 Spesd Cl Add a Mew Page |
8 Torque Fef
9 Mator Cl
10 Protections
11 Position Fef |

12 Position Chl Change the Mumber/Mame of the Selected Page
13 Syncronization

14 Encoder

15 User 1 [EMPTY)
16 Uszer2  [EMPTY] Remove the Selected Empty Page |

ak. Cancel |

In the dialog box you can:
. add new pages and specify the numbers and names of new pages

. change numbers and/or names of the existing pages
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« remove empty pages

- specify whether page names are displayed in page tabs. If page names are not
displayed in the tabs, the name of the page can be seen as a ToolTip when the
cursor is moved on the tab.

Time levels

Select Program > Time Levels to display a dialog box with a list of the time levels
in the drive software.

Time Levels

Time Lewvels:

TLAZ 10 mzec (10 mgec - 1000 mzec]

Change Time Lenath |

Cancel I

The allowable time range is displayed in the time level line.

You can now change the length of the selected variable-length time level.
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Custom circuit definitions

Creating a new CC definition

Select Program > New Custom Circuit.
A dialog box is displayed:

Custom Circuit Information x|

Mamne of the Custom Circuit:

Werzion of the Custarn Cincuit:

tajor |1 [alue range = 1...255)

tinor: {0 [walue range = 0...255)

Comment of the Custom Circuit:

Cancel |

Specify the name, version and comment text of the new CC definition.
The names of CC definitions always end with the '*' character. If you do not write
this character to the end of the name, it will be appended automatically.

Click OK and the CC definition window opens. The window is initially empty and

the text =-=T=MEIREHITT s displayed at the top of the window

You can now start to program the CC definition.
The definition programming is done in the same way as the actual solution
programming in the solution program window.

Every CC definition must include one or more external pins. These are input
and/or output pins in the CC definition that will be visible in the instances of the
CC definition. These pins make it possible to connect a CC instance to other
blocks of the solution program.

To define an external pin, right-click on the input or output pin you want to be an
external pin (if input pin, it must be unconnected and without any value) and
select Define External Pin.

A dialog box is displayed:

Use of DriveSPC



34

Define External Pin x|

M ame of the External Pin:

Position af the External Pin:

|.ﬁ.l PID act

| k. I Cancel

The name you specify here will be seen inside the instance blocks of this CC
definition in the solution programs.

In addition to the pin name, you have to specify the pin position among other
external input or output pins. If no other external pins exist, number 1 is
displayed in the pin position list.

All currently defined external pins can be seen by the F5 key or by selecting
CustomCircuit > Custom Circuit Layout.
The instance block of the CC definition will be displayed in the CC block window:

Bl Custom Circuit Block x|
F
AL PIDZ =
&I _PID_act
=AI_PIC_act al_PID aut
AL PID 1 peset AL_PID _out:=
=&I_PID_I_pesat
=
| [,

To find out the location of an external pin in the CC definition window, click on
this pin in the CC block window.

When the CC definition is ready, select File > Return to Program. You will be
asked if you want to preserve the CC definition you have made.
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Modifying an existing CC definition

Select Program > Open Custom Circuit to display a dialog box with a list of the
currently-defined custom circuits:

Open Custom Circuik El

Select Cuztom Circuik;

A_PID
a_PID2

| Open I Cancel

Select the CC definition you want to open and click Open or double-click on the
desired CC.

The CC definition window opens with the CC definition you selected.
If needed, you can now modify the CC definition.

If you have used instances of this CC definition in your solution program, you
can still make changes to this definition, as long as you do not change the
definitions of external pins.

If you want to change the data type of an external pin in the CC definition and
this pin is connected in one or more instances of this CC definition, you have to
disconnect this pin in these instances before the pin change.

If you want to change the number or input/output type of external pins, you have
to remove all instances of this CC definition from the solution program and add
the instances again after you have changed the external pins in the CC
definition.
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Copying a CC definition

1. Select Program > Copy Custom Circuit to display a dialog box with a list of
the currently defined custom circuits:

Copy Custom Circuik ﬂ

Select Cuzstom Circuit;

|.-'1‘-.I FID

Copy I Cancel

2. Select the CC definition you want to copy and click Copy or double-click on
the desired CC.
A dialog box with the current name, version and comment text of the CC
definition to be copied is displayed:

Custom Circuit Information il

Mame of the Custarn Circuit:
IAI_PIDZ

Yerzsion of the Custom Circuit:

tajar |1 [value range = 1...255)

tinar: |0 [value range = 0...255)

Comment of the Custom Circuit:

Cancel |

3. Specify the new name, version and comment text of the copy of the CC
definition and click OK.
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Removing a CC definition

Select Program > Remove Custom Circuit to display a dialog box with a list of
those currently-defined custom circuits that are not used in the solution program:

Remove Custonn Circuikt El

Select Cuztom Circuik;

&l_PID
&l_PIDE

| Remowve I Cancel

Select the CC definition you want to remove and click Remove.

Saving a CC definition to a file

The save is needed only if you want to use a CC definition in other solution
programs.

1. Select Program > Save Custom Circuit to File to display a dialog box with
a list of the currently-defined custom circuits:
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Save Custom Circuik ﬂ

Select Cuzstom Circuit;

|.-'1‘-.I FID

Save I Cancel

2. Select the CC definition you want to save and click Save or double-click on
the desired CC. Another dialog box is displayed:

select Custom Circuit FOLDER 7| x|

Cave I \— CC Archive j i I.:._z.F ED-

Save

File narne: A_PIDZ.ce j Cancel

i

Define Pagzsward for CC File Read |

3. If you want that a password is needed when this CC file is read, click Define
Password for CC File Read and specify the password.
Select the desired CC archive folder and click Save.
Note: You cannot change the name of the CC file. Its name is always the
name of the saved CC definition with extension "cc".
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Reading a CC definition from a file

Select Program > Read Custom Circuit from File.
A dialog box is displayed:

Select Custom Circuit File id |

Lack in: | 2 CC Archive <] « @k B

3] AI_PID.cc

File name: || Read I
Files of type: | Custom Circuit [%.cc) =] Cancel |

Select the CC definition file you want to read and click Read.

If a CC definition with the same name already exists in the solution program but
instances of this CC definition are not used in the solution program, the existing
CC definition in the solution program is always overwritten.

If instances of this CC definition are already used in the solution program and
external pin definitions in the file are the same as in the existing CC definition,
the existing CC definition in the solution program is always overwritten.

If instances of this CC definition are already used in the solution program but
external pin definitions in the file are not the same as in the existing CC
definition, the existing CC definition in the solution program remains unchanged.
In this case, you have to remove all instances of this CC definition from the
solution program and add the instances again after you have read the CC
definition file.
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Block and CC instances

Adding a new instance of a normal block ora CC

1. Right-click on an empty page location and select Add Block, or alternatively
left-click while holding down the Ctrl key.
A dialog box with two lists is displayed. The first list contains block groups, of
which the first group is always All Blocks. The second list contains the blocks
and/or CCs of the selected block group. A grey block means that this block
cannot be added because there is not enough empty space.

x
Block Groups: Select Block
Al Blocks AR5 -
Avrithrmetic ADD
Bitztring AMD
Bitwize BGET
Comparizon BITAMD
Corvwersion BITOR
Counters BOOL_TO_DIMT
Edge % bistable BOOL_TO_INT
Feedback & alg BSET
Filkers COMMENT
Selection CRITSPEED
Switch & Demux CTD
Tirmers CTD_DINT
CTU
CTU_DINT
CTUD
CTUD_DINT
CYCLET
DATA COMNTAIMER
DEMU
DEMUS-MI d|
Ok, I Cancel

2. Select the block to be added.
The third list containing the time levels is displayed.
The time level list is not displayed if you are adding a block to a CC
definition. All blocks in a CC definition are in the same unspecified time level.
The actual time level is specified when you add an instance of the CC
definition to your solution program.
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Add Block x|

Elock Groups: Select Block Select Time Level

AllB
Arthmetic
Bitztring
Bitwize
Carmparizan
Conversion
Counters
Cuztam circuits
Edae & bistable
Feedback & alg
Filters

Selection
Switch & Demux
Timers

TLAT 1 mzec
TLaZ 10 mzec

Cancel |

Select the time level where you want to put the new block instance (if the
time level list exists) and the last list is displayed. The last list contains all
blocks that are currently in the selected time level. If no blocks exist in the
selected time level, number 1 is displayed in the list.

Add Block |
Block Groups: Select Block Select Time Level Select Block's Execution Position

AIB
Avithmetic
Bitztrirg
Bitwise
Comparizon
Carwersion
Counters
Customn circuits
Edge & bistable
Feedback & ala
Filters

Selection
Switch & Demnux
Tinners

1
TLAZ2 10 mgec

Cancel |

Select a block (or number 1 if there are no blocks) from the last list. Grey
blocks, if any, cannot be selected. The new block will be put before the
selected block in the execution order of the selected time level. If you select
the last block of the time level, you are asked to specify whether the new
block will be added before or after the selected block.

Finally, if the data type of the block to be added is user-selectable and/or if
the block contains extensible pins, a dialog box is displayed. If both data
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type and extension size are needed, the dialog box is as follows:

Block's Data Type and Pin Exte X|

Select Block's Data Tepe

DIMT
INT
REAL
REALZ4

Mumber of Extended Finz [0...31];

|1—
] I Cancel

6. Select the block's data type and/or the number of extended pins (i.e. the
number of pin copies) of extensible pins and click OK.

Displaying the execution sequence of blocks

Every block resides in some time level.

The execution position of a block in its time level is shown in parenthesis inside
the block:

iTLAE 10 rzec (17 I

If you right-click on a block and select Go to Next Block, DriveSPC goes to the
next block in the execution sequence.

If you now hold the Ctrl button down, you can continue going to the next blocks
by pressing the right arrow key.

If you right-click on a block and select Go to Previous Block, DriveSPC goes to
the previous block in the execution sequence.

If you now hold the Ctrl button down, you can continue going to the previous
blocks by pressing the left arrow key.

If you right-click on a block and select List Blocks, a dialog box is displayed with
a list of all blocks in the time level of the selected block:
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Blocksz of Time Level TLAZ [10 mzec):

B3 MOVE [page 1E)
E-54 IF  [page 15)
E-61 IF  [page 16)
B2 ABS [page 18]
53 ELSEIF  [page 16)
g8 Cd AMD  [page 1E)
E-E5 ELSE  [page 1E]
“-B6 OR [page 16)
57 ENDIF  [page 16]
- BB ADD [page 1E]
o 58 ELSEIF [page 16
B2 ADD  [page 16)
B-58 ELSE  [page1E]
B9 ®OR (page 16)
G0 ENDIF  (page 16)
-1 MOWE  [page 1]

Canizel |

Magenta colour is used with conditional blocks IF, ELSEIF, ELSE and ENDIF, if

these blocks are used in the selected time level.
You can compress or expand conditional branches by clicking on their minus or

plus buttons.

You can go to a block in the list by double-clicking on it in the list.

Changing the execution position of a normal block or CC instance

1. Right-click on the desired normal block or CC instance and select Change
Block Exec Pos, or alternatively left-click while holding down the Ctrl key.
If you are in the solution program window, a dialog box with two lists is
displayed. The first list contains the time levels, where the current time level
of the selected block is initially selected. The second list contains all blocks
that are currently in the selected time level, or number 1 if no blocks exist in
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the selected time level.
If you are in the CC definition window, a dialog box with one list is displayed.
This list contains all blocks that are currently in the CC definition.

Change Block's Execution Position x|

Select Time Level Select Elock's Execution Pozition in TLA1

TLAT 1 mzec !
TLAZ 10 mzec

Change Block Pos I

Cancel |

2. Select the desired time level from the first list (if it exists) and the desired
block from the second list. Grey blocks, if any, cannot be selected.

3. Click Change Block Pos.
The block whose execution position is to be changed will be put before the
selected block in the execution order of the selected time level. If you select
the last block of the time level, you are asked to specify whether the new
block will be added before or after the selected block.

Adding/removing pins of a normal block that contains extensible pins

1. Right-click on the desired normal block and select Add/Remove Pins.
A dialog box is displayed.

Block’s Pin Extension x|

Mumber of Extended Pinz [0...31]:
|
ak I Canzel |

2. Change the number of extended pins (i.e. the number of pin copies) and
click OK.
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Moving a block or CC instance to another location

There are two move methods available, the Menu command method and the
Quick method:

o To move a block to another location by using the Menu command method:

1. Right-click on the desired block or CC instance and select Move Block.
A help message box is displayed. If you do not want the message box to
be displayed during this DriveSPC session, select the check box.

2. Right-click on the desired green location of the desired page and select
Move Selected Block Here.

o To move a block to another location by using the Quick method:

1. Left-click on the desired block or CC instance while holding down the Alt
key.

2. Left-click on the desired green location of the desired page while holding
down the Alt key.

Removing an instance of a normal block or a CC

Right-click on the desired normal block or CC instance and select Remove
Block.

Displaying the description of a block or a CC

Move the cursor inside the rectangle of the desired block or CC instance and
press the F3 key.
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Comments

Adding a new instance of the Comment block

1. Right-click on an empty page location and select Add Comment Block.
A dialog box is displayed.

Comment Block x|

Comment Texrt [max 50 lines):

| =
Test Alignment—————————————
-DK.
" Left
" Center

" Right Cancel |

2. Write the desired comment text, select text alignment and click OK.

Changing the text and/or text alignment of a comment block

1. Right-click on the desired comment block and select Change Comment, or
alternatively left-click while holding down the Ctrl key.
A dialog box is displayed.
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Comment Block x|

Comment Text [max 50 lines):

Reference calculation ;I

Test Alignment
" Left
" Center

" Right Cancel |

2. Change the comment text and/or change text alignment and click OK.

Moving a comment block to another location

There are two move methods available, the Menu command method and the

Quick method:
o To move a comment to another location by using the Menu command
method:

1. Right-click on the desired comment block and select Move Block.
A help message box is displayed. If you do not want the message box to
be displayed during this DriveSPC session, select the check box.

2. Right-click on the desired green location of the desired page and select
Move Selected Block Here.

o To move a comment to another location by using the Quick method:
1. Left-click on the desired comment block while holding down the Alt key.

2. Left-click on the desired green location of the desired page while holding
down the Alt key.

Removing an instance of the Comment block

Right-click on the desired comment block and select Remove Block.
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Parameter blocks

Adding a new instance of a parameter block

1. Right-click on an empty page location and select Add Parameter Block.
A dialog box is displayed.

Parameter Block x|

Select Parameter

34.01_ Test name 1 -
a34.03 Test name 3

a24.05 PARAMETER MAME
34.07 Test name 7

34.09 Test name 3

2411 Test value phr

3412 Test bit ptr

34.20 ScRealPar

34.21 RealPar

a4.22 Test name 3

2310 Test bit ptr 2

8312 SCR1

83913 SCR2

83914 R3

8915 FN

] I Cancel |

2. Select the desired parameter and click OK.

Changing the parameter of a parameter block

1. Right-click on the desired parameter block and select Change Block's
Parameter, or alternatively left-click while holding down the Ctrl key.
A dialog box is displayed.
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Parameter Block x|

Select Parameter

34.01_ Test name 1 -
34.03 Test name 3

24.05 PARAMETER MAME
34.0¢ Test name ¥

34.09 Test name 9

34171 Test value ptr

24,12 Test bit phr

34.20 ScRealPar

34.21 RealPar

34,22 Test name 3

3310 Test bit ptr 2

8912 SCR1

8913 SCR2

3914 B3

2315 FN b

] I Cancel |

2. Select the desired parameter and click OK.

Moving a parameter block to another location

There are two move methods available, the Menu command method and the

Quick method:
o To move a comment to another location by using the Menu command
method:

1. Right-click on the desired parameter block and select Move Block.
A help message box is displayed. If you do not want the message box to
be displayed during this DriveSPC session, select the check box.

2. Right-click on the desired green location of the desired page and select
Move Selected Block Here.

o To move a comment to another location by using the Quick method:
1. Left-click on the desired parameter block while holding down the Alt key.

2. Left-click on the desired green location of the desired page while holding
down the Alt key.
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Removing an instance of a parameter block

Right-click on the desired parameter block and select Remove Block.

Displaying the description of the parameter of a parameter block

Move the cursor inside the rectangle of the desired parameter block and press
the F3 key.
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Pins

Connecting input and output pins

There are two pin connection methods available, the Menu command method
and the Quick method:

o To connect pins by using the Menu command method:

1. Right-click on the desired input pin and select Connect to Output Pin or
right-click on the desired output pin and select Connect to Input Pin.
A help message box is displayed. If you do not want the message box to
be displayed during this DriveSPC session, select the check box.

2. Right-click on the desired green pin and select Connect to Selected
Pin.

o To connect pins by using the Quick method:

1. Left-click on the desired input or output pin while holding down the Ctrl
key.

2. Left-click on the desired green pin while holding down the Ctrl key.

A wire is automatically drawn between the connected input and output pins if
these pins are on the same page. If they are not on the same page, an

arrowhead is displayed at the output pin: —

Wire example:

LT CALCULATED MEW REF

TLF 500 pze

CALCULATED MEW REF

G4 = 15.07 £

Connecting an input pin to a bit of an output pin

This bit connection is automatically used in the following two pin connection
cases:
- The input pin is a bit pointer pin of a firmware block
- The data type of the input pin of a normal block is Boolean and
the data type of the connected output pin is other than Boolean

There are two bit connection methods available, the Menu command method
and the Quick method:

o To connect a bit by using the Menu command method:
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1.

Right-click on the desired input pin and select Connect to Output Pin
(or Connect to Bit of Output Pin) or right-click on the desired output
pin and select Connect to Input Pin.

A help message box is displayed. If you do not want the message box to
be displayed during this DriveSPC session, select the check box.

Right-click on the desired green pin and select Connect to Selected
Pin.

A list of the bits of the selected output pin is displayed. Select the
desired bit and click OK.

o To connect a bit by using the Quick method:

1.

Left-click on the desired input or output pin while holding down the Ctrl
key.

Left-click on the desired green pin while holding down the Ctrl key.

A list of the bits of the selected output pin is displayed. Select the
desired bit and click OK.

A wire is automatically drawn between the connected input and output pins if
these pins are on the same page. If they are not on the same page, an
arrowhead is displayed at the output pin.

Setting the value of an input pin

1. Double-click on the desired input pin or right-click on the desired input pin
and select Set Value.
A dialog box is displayed. The content of the dialog box depends on the
selected input pin. One possible dialog box is shown below:

External Yalue X|

15.03 A07 MAY [md]

Current Yalue: 20000

e W alue: Im

kin Y alug: 0.000

bax Value: 22700

ak. I Cancel

2. Write the desired new value or select the new value from the value list (if
any) and click OK.
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Setting the input pin of a firmware block to its default value

Right-click on the desired input pin of a firmware block and select Set Default
Value.

Setting the input pin of a firmware block to drive value

Right-click on the desired input pin of a firmware block and select Drive Value.
Text Drive value is displayed in the pin .

When the program is downloaded, the current drive value of this parameter is
preserved during the download operation.

Locking the value/connection of an input pin of a firmware block

Right-click on the desired input pin of a firmware block and select Lock Value.
When the program is downloaded, this value or pin connection is set to the drive
parameter.

Unlocking the value/connection of an input pin of a firmware block

Right-click on the desired input pin of a firmware block and select Unlock Value.
Unlocked value is enclosed with angle brackets, e.g. [ 1.25 1.

When the program is downloaded, user can select one of the following two
alternatives:

o All unlocked values and pin connections are set to drive parameters.
o The current drive values of all these parameter are preserved.

Unlocked parameter values can be changed in the drive after download.

Removing the connection/value of an input pin of a normal block or CC instance

Right-click on the desired input pin of a normal block or CC instance and select
Disconnect (or Remove Value).

Inverting an input (Boolean) pin of a normal block

Right-click on the desired input pin of a normal block and select Invert Pin.
Inverted pin is marked with a little bubble, for example 1
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Defining the data items of an array/structure pin of a normal block or CC instance

There can be an array or a structure in an input or output pin of a normal block or

CC instance.
The definition of these arrays and structures is described in the Appendix 2.

Changing the name of an output pin of a normal block or CC instance

1. Right-click on the desired output pin of a normal block or CC instance and

select Change Pin Name.
A dialog box is displayed.

Cancel |

2.  Write the new unique name and click OK.

Defining the scaling factor and unit text of an output pin of a normal block or CC
instance

Scaling factors and unit texts are used in the On-Line mode. Scaling factors are
real numbers, for example 2.5.

1. Right-click on the desired output pin of a normal block or CC instance and
select Define Scaling Factor and Unit Text.
A dialog box is displayed.

Scaling Factor and Unit Texkt x|

Scaling Factor: I [real]

Init Tesxt: I

Cancel |

2. Write the desired scaling factor and unit text and click OK.

Use of DriveSPC



55

Saving the value of an output pin of a normal block or CC instance

If you want that the value of an output pin of a non-firmware block is retained
during the power down of the drive, right-click on the desired output pin and
select Power Down Save On.

Letter M will be displayed in this output pin.

Note: Only a limited number of output pins can be saved.

Going to the block connected to an input pin

Right-click on the desired input pin and select Go to Connected Block, or
alternatively left-click while holding down the Alt key.

Showing connections of an output pin

Double-click on the desired output pin or right-click on the desired output pin and
select Show Pin Connections, or alternatively left-click while holding down the

Alt key.
A dialog box is displayed with a list of the blocks whose input pins are connected

to the output pin.

output Pin x|

Connected to Blocks [double-chck to go to a block):

28 A02 [page 3)
46 SWITCHC [page 3
45 T [page 3]

ok |

Going to a block connected to an output pin

1. Double-click on the desired output pin or right-click on the desired output pin
and select menu command Go to Connected Block, or alternatively left-
click while holding down the Alt key.
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A dialog box is displayed with a list that contains the blocks whose input pins
are connected to this output pin.

output Pin_______ x|

Connected o Blocks [double-click to go to a block]:

28 A02 [page 3]
46 SWITCHC [page 3
45 GT [page 3]

OF. |

2. Select the desired block and click OK or double-click on the desired block.

Displaying the description of a pin parameter of a firmware block

Move the cursor to the desired pin of a firmware block and press the F3 key.
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All page headers at the bottom of the program pages contain the same field texts.

To change the texts of one or more header fields, right-click on the page header on
any page and select Change Header Fields.
A dialog box is displayed.

Header Fields

Bazed on ||

Title |

Cuistorner I

Cust. Doc. Mo. I

Drate I

Company |

Prepared I

Do, des. I

Approved I

Froject name I

Fiesp. dept. I

Doc. Mo I

Cancel |

Write the desired field texts and click OK.

Wires

A wire is automatically drawn between connected input and output pins if these pins
are on the same page. If they are not on the same page, an arrowhead is displayed

at the output pin: —

Wire example:

ouT

CALCULATED MEW REF

CALCULATED MEW REF

(3744

TLF 500 pze

= 15.07 £

To highlight a wire (or a wire network if several input pins are connected to the
same output pin), right-click on the desired wire and select Highlight Wire, or

alternatively left-click on a wire while holding down the Alt key.
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Passwords

The following actions can be protected with user-specified passwords:
« Program open/upload

« Display of the opened/uploaded program. This password does not prevent the
download of the opened/uploaded program to drive.

. Display of a custom circuit definition included in the current program

« Reading of a custom circuit definition file to a program

Note: Do not forget your passwords!

Password for program open/upload is defined with menu command Program >
Define Password for SP File Open.

Password for the display of the opened/uploaded program is defined with menu
command Program > Define Password for Program Display.

Password for the display of a custom circuit definition included in the current
program is defined with menu command CustomCircuit > Define Password for
CC Display.

Password for the reading of a custom circuit definition file to a program is defined
with button Define Password for CC File Read in the Save Custom Circuit File
dialog box.
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Post-programming

After you have made all program modifications, save the modified solution program
by selecting File > Save or File > Save As.

To print one or more program pages, select File > Print.

To save the current program page on the screen to a disk file in the Picture
(Enhanced Metafile) format, select File > Save Horz Picture As. The filename
extension of this file must be EMF.

Picture files are used by for example MS Office products. You can insert the saved
program page file to a Word document by using Word’s menu command Insert >
Picture > From File.

You can rotate the current screen 90 degrees counter-clockwise and save it to a
disk file by selecting File > Save Vert Picture As.

If you are using a drive and you want to run the new program in the drive:

1. Connect to the drive by selecting Drive > Connect (if you have not yet
connected)

2. Download the program to the drive by selecting Drive > Download Program.
The drive is automatically restarted after the download and the program is
running in the drive

3. To monitor pin values of the running program, go to the On-Line mode by
selecting Drive > On-Line.
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On-Line mode

To change the operating mode of DriveSPC from the Off-Line mode to the On-Line
Mode, select Drive > On-Line. The solution program of the drive is automatically
uploaded, saved to a user-specified folder and displayed on the screen.

Finally, the current values of all input pin parameters of all firmware blocks are read
from the drive and displayed instead of the originally uploaded pin parameter
values. If the read actual value of a pin parameter is not the same as its original

value, this pin parameter value is displayed on a yellow background, for
-100.000

example

Thetext PNHNE  gn4 the software load percentage of the drive are displayed

at the top of the DriveSPC window.
The background colour of the text is red if there is a fault in the drive or yellow if
there is a warning in the drive.

If you want to see the originally uploaded pin parameter values, press the F4 key or
select Drive > Display Original Program.

The text ORIGINAL PROGRAM is how displayed on the screen.

To view the actual pin parameter values again, press the F4 key or select Drive >
Display Actual Program.

To view a dialog box with a list of changed pin parameters, select Drive > List
Original/Actual Differences.

Program Differences x|

Changed Parameters [double-click to go to a block]:

32.05 MINIMUM TORD REF [block TORD REF MOD, page 8]
25,12 MIN TORE 5P CTRL [black SPEED CONTROL, page 7)
E5.07 PROFDEC1 [block PROFILE REF SEL. page 11]

55.15 PROF DEC 2 [black PROFILE REF SEL. page 11]

70.06 POS DECEL LIM (block POS REF LIM, page 11)

E0.0% POS2INT SCALE [block POS FEEDEACK, page 12)
50.09 POS RESOLUTION (block POS FEEDBACK, page 12)
5010 POS SPEED2INT [block POS FEEDBACK, page 12]
50.13 MINIMUM POS [block POS FEEDBACK, page 12]

13.03 A1 MIN [block A1, page 3)

12.05 AN MIN SCALE [block A1, page 3]

13.08 212 MIN [block A2, page 3)

13.10 212 MIN SCALE [block A12, page 3]

15.06 A0 MIM SCALE [block AQ1, page 3]

15.07 402 PTR [block 402, page 3]

20.02 MINIMUM SPEED [black LIMITS, page 10)

20.07 MINIMUM TORGUE [Hlack LIMITS, page 10]

34.06 LOCAL CTRL MODE [block REFERENCE CTRL, page §)
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To view a changed pin parameter, select the desired parameter and click OK or
double-click on the parameter.

Changing values/connections of input pins of firmware blocks

You can change values/connections of some input pins of firmware blocks as in the
Off-Line mode. In the On-Line mode these changes are automatically copied to the
corresponding parameters of the connected drive.

Note that the changed On-Line pin parameter values are lost from the program on
the screen when you go back to the Off-Line mode but they remain in the drive.
To change the actual On-Line pin parameter values currently on the screen to
programmed values of the drive:

1.
2.

Save the current program with actual values by selecting File > Save

Go back to the Off-Line mode by selecting Drive > Off-Line. The original
uploaded program is now restored to the screen.

Open the saved program file by selecting File > Open

Download the program to the drive by selecting Drive > Download Program

Pin value monitoring

Actual values of one or more output pins, and input pins connected to output pins
can be monitored in two value formats:

External value is the scaled value with unit text (black character color, for

example 2982¥ =)

External values can be used with pins of normal blocks only if scaling factors and
unit texts are defined for these pins.

Internal value (magenta character colour, for example —2%3.098 =) js the value

type actually used in the drive software

To monitor a pin value:

1.

Right-click on the desired pin and select Start Value Monitor, or alternatively
left-click on the pin while holding down the Shift key. If you select an output pin
of a firmware block, the displayed value is initially the pin's external value
(black). If you select an output pin of a normal block, the displayed value is
initially the pin's internal value (magenta).

e If no scaling factor and unit text are defined for an output pin of a normal
block in the uploaded program and you want to monitor the external value
of the pin, you have to define these before you start the monitoring of the
pin. Right-click on the pin and select Define Scaling Factor and Unit Text.
Note however that these On-Line definitions/changes are lost when you go
back to the Off-Line mode. If you want non-volatile scaling factors and unit
texts, specify these in the downloaded program.

If needed, change the value format by right-clicking on the pin and selecting
Monitor Internal Value or Monitor External Value.
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3. End the value monitoring of a pin by right-clicking on the pin and selecting Stop
Value Monitor, or alternatively left-click on the pin while holding down the Shift
key.

If you want to monitor internal values of a custom circuit instance, move the cursor
over the desired CC instance and press the F3 key.

The CC definition window of this instance opens and you can now monitor actual
pin values in this window.

Return to the Off-Line mode

Go back to the Off-Line mode by selecting Drive > Off-Line.
The previously uploaded program is restored to the screen.
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Menu commands

Chapter overview

The chapter describes the menu commands of DriveSPC.

File menu (solution program window)

Open
This command reads and displays the contents of a previously saved program file.
The filename extension of program and template files is always sSP.

The program name, program version, solution folder name and filename of the
opened file are displayed at the top of the DriveSPC window.

The opened program can be modified, printed, downloaded, and so on.

Save
This command saves the current program.

The solution folder name and filename are displayed at the top of the window.

Save As
This command saves the current program to a user-selected folder.

The solution folder name and filename will be updated at the top of the window.

Save Horz Picture As

This command saves the current program page to a disk file in the Picture
(Enhanced Metafile) format.

The filename extension of this file is always EMF.

Picture files are used by for example MS Office products.
You can insert the saved program page file to a Word document by using Word’s
menu command Insert > Picture > From File.

Save Vert Picture As

This command rotates the current program page 90 degrees counter-clockwise and
saves it to a disk file in the Picture (Enhanced Metafile) format.

The filename extension of this file is always EMF.
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Picture files are used by for example MS Office products.
You can insert the saved program page file to a Word document by using Word’s
menu command Insert > Picture > From File.

Print
This command prints one or more program pages.

The page number of the currently visible page is displayed in the Print dialog box
when you select Print.

Exit
This command stops DriveSPC.

If you have changed this program but you have not saved it, you will be asked if you
want to save it now.

File menu (CC definition window)

Save Horz Picture As

This command saves the current CC definition page to a disk file in the Picture
(Enhanced Metafile) format.

The filename extension of this file is always EMF.

Picture files are used by for example MS Office products.
You can insert the saved program page file to a Word document by using Word’s
menu command Insert > Picture > From File.

Save Vert Picture As

This command rotates the current CC definition page 90 degrees counter-clockwise
and saves it to a disk file in the Picture (Enhanced Metafile) format.

The filename extension of this file is always EMF.

Picture files are used by for example MS Office products.
You can insert the saved program page file to a Word document by using Word’s
menu command Insert > Picture > From File.

Print
This command prints one or more CC definition pages.

The page number of the currently visible page is displayed in the Print dialog box
when you select Print.

Return to Program

This command closes the CC definition window and returns to the solution program
window.
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If you have changed this CC definition, you will be asked if you want to preserve it.
Note: If you want to save this CC definition permanently, you must save the solution
program in the solution program window.

Program menu

Program Information
This command displays a dialog box with the current name, version and comment
text of your solution program.

Program Information il

Program M ame:

IEompIete solutior]

Program Yersion:

Major; |1 [range = 1...255]
Total Mumber of Program Changes; 543
Mimar; |0 [range = [...255]

Program Comment:

QK. I Cancel |

The program name and version are displayed at the top of the DriveSPC window,
too.

If needed, change these items and click OK.

Program Pages

This command displays a dialog box with a list of the currently-existing program
pages.
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Page Numbers and Names

Pages:

>1 Signals

% .EE;IELH}DD ¥ Show Page Mames in Page Tabs

4 Drive Logic

5 Drive Control

& Speed Ref

7 Speed Chl Add a Mew Page |
8 Torque Fef
9 Mator Cl
10 Protections
11 Position Fef

12 Position Chl Change the Mumber/Mame of the Selected Page |
13 Syncronization

14 Encoder

15 User 1 [EMPTY)
16 User 2 [EMPTY) Flemove the Selected Empty Page |

ak. Cancel |

If needed, you can:

« Add new pages and specify numbers and names of new pages
« Change numbers and/or names of existing pages

« Remove empty pages

. Specify if page names are displayed in page tabs. If page names are not
displayed in the tabs, the page name of the tab can be seen as a ToolTip when
the cursor is moved onto the tab.

Time Levels

This command displays a dialog box with a list of the time levels in the drive
software.

Menu commands



67

Time Levels

Time Lewvels:

TLAT 1 mzec [1 mgec - 9 mzec

TLAZ 10 mzec [10 mzec - 1000 mzec)

Change Time Length |

Cancel I

The allowable time range is displayed in the time level line.

To change the length of a variable-length time level, select the desired time level
and click Change Time Length.

New Custom Circuit

This command initiates the creation of a new CC definition in the CC definition
window.

Open Custom Circuit
This command opens a CC definition in the CC definition window for modification.

If you have used instances of the opened CC definition in your solution program,
you can still make changes to this definition as long as you do not change
definitions of external pins.

If you want to change the data type of an external pin in the opened CC definition
and this pin is connected in one or more instances of this CC definition, you have to
disconnect this pin in these instances before the pin change.

If you want to change the number or input/output type of external pins, you have to
remove all instances of this CC definition from the solution program and add the
instances again after you have changed the external pins in the CC definition.

Copy Custom Circuit

This command makes a copy of a CC definition.

Remove Custom Circuit

This command removes an unused CC definition.
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Save Custom Circuit to File

This command saves a CC definition to a disk file.
The filename extension of CC definition files is always ccC.

The save is needed only if you want to use this CC definition in other solution
programs.

Read Custom Circuit from File

This command reads a CC definition from a previously saved disk file to the current
solution program.

If a CC definition with the same name already exists in the solution program but
instances of this CC definition are not used in the solution program, the existing CC
definition in the solution program is always overwritten.

If instances of this CC definition are already used in the solution program and
external pin definitions in the file are the same as in the existing CC definition, the
existing CC definition in the solution program is always overwritten.

If instances of this CC definition are already used in the solution program but
external pin definitions in the file are not the same as in the existing CC definition,
the existing CC definition in the solution program remains unchanged.

In this case, you have to remove all instances of this CC definition from the solution
program and add the instances again after you have read the CC definition file.

Change Program's Template

Every solution program is based on a program template.

Templates are used as starting points of new solution programs. Templates contain
the definitions of the blocks and other programming components that are in the
drive software.

If a new drive software version is made where some programming components
have changed, a new template for this new drive software can be uploaded from
the new drive.

If you want to download your solution program to a drive but the program is not
based on the template that corresponds to the software of the drive, you have to
change the template of your solution program as follows:

1. Upload template from your new drive by selecting Drive > Upload Template
from Drive or, if the drive is not at hand now, obtain the template for the drive.

Open your solution program by selecting File > Open.

Select Program > Change Program's Template.
A dialog box is displayed.
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Look, in: IE} MNew Template j P EF -

File name: I

=] Dper
- Cancel
I ==

o

Files of type: I Mew Template [*. zp)

4. Select the new template and click Open.

5. The template change starts now and when it is ready, a dialog box is displayed:

Template Change

x|
The following program changes have been made:
Firrmware blocks have been inzerted to time level TLFT: :I
Mew page 3 has been added
Mew block has been added [block TORO REF SEL. block 1D 13, page 3] J
Mew block has been added [block TORO REF MOD, block 1D 14, page 3]
Firrmware blocks have been inzerted to time level TLF2:
Mew block has been added [block SPEED REF SEL, block 1D 15, page 3]
Firrmware blocks have been inzerted to time level TLF3:
Mew block has been added (block SPEED REF MOD, black 1D 18, page 3]
Firrmware blocks have been inzerted to time level TLF4:
Mew page 4 haz been added
Mew block has been added [block SPEED FEEDBACK., black ID 17, page 4)
Mew block has been added (block SPEED ERROR. block 1D 18, page 4]
Mew block has been added [block SPEED COMTROL, block. 1D 19, page 4)
Firrmware blocks have been inzerted to time level TLFS:
Mew block has been added [block PROFILE REF SEL. block ID 20, page 4)
Mew page b hag been added
Mew block has been added [block PROFILE GEMERATOR, black ID 21, page B)
Mew block has been added [block POS REF LiM, block 1D 22, page ) LI
Blean Rlamle bam bmewn added Thlaal BOC CORMTEOL Rlesle 10072 Aoas F1
Save the list above |
Click QK if you accept these changes or Cancel if you want to cancel the template change
oK | Cancel I

6. All program changes made by DriveSPC are listed in this box. If you want to
save this list to a disk file, click Save the list above.

7. If you accept these changes, click OK. The changed program will be saved.
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8. The changed program may contain conversion errors. Check the changed

program carefully and make the needed corrections (if any) before you
download it to the drive.

Compare Programs

This command compares the solution program on the screen with a user-selected
program.

List of program differences (if any) is displayed after the comparison.

Copy Page's Blocks

This command copies all non-firmware blocks of the current page to DriveSPC's
internal memory.

Paste Copied Blocks

This command pastes the blocks copied with command Program > Copy Page's
Blocks or CustomCircuit > Copy Page's Blocks to an empty page.

You can copy/paste blocks:

From a program page to another program page
From a program page to a page of a Custom Circuit definition
From a page of a Custom Circuit definition to a program page

From a page of a Custom Circuit definition to another page of a Custom Circuit
definition

From a solution program to another solution program

Parameter Manager

This command opens the Parameter Manager window (see Appendix 3).

Technology Library

In addition to the Standard block library that exists always, there are optional
Technology block libraries. A Technology library contains one or more new blocks
that are not in the Standard block library. Instances of these new blocks can be
used in a solution program only if the same Technology block library is in the drive.

This command opens a dialog and you can:

Add a Technology library to your program. A program can include no more than
one Technology library.

See information about the blocks of program's Technology library
Change the Technology library of your program

Remove Technology library from your program
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Define Password for SP File Open

If you want that a password is needed when this program is opened or uploaded,
select this command and specify the password.

Define Password for Program Display

If you want that a password is needed for the display of this program when it has
been opened or uploaded, select this command and specify the password.

This password does not prevent the download of the opened/uploaded program to
drive.

CustomCircuit menu

Custom Circuit Information
This command displays a dialog box with the current name, version and comment
text of the current CC definition.

Custom Circuit Information ll

Mame of the Custom Circuit:

L) PID

ergion of the Customn Cincuit:

Majar: |1 [walue range = 1...255)

Minor: |0 [value range = 0...255]

Carmment of the Custan Circuit:

Cancel |

The CC name and version are displayed at the top of the CC definition window, too.

If needed, change these items and click OK.

Custom Circuit Pages

This command displays a dialog box with a list of the current CC definition pages.
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Page Mumbers and Names

Fages

»1 Main Page

2 Speed calculation ¥ Show Page Names in Page Tabs

Add a Mew Page |

Lhange the Mumber/h ame of the Selected Page i

Remove the Selected Emply Page |

ak. Cancel |

If needed, you can:

- Add new pages and specify numbers and names of new pages
« Change numbers and/or names of existing pages

« Remove empty pages

. Specify if page names are displayed in page tabs. If page names are not
displayed in the tabs, the page name of the tab can be seen as a ToolTip when
the cursor is moved on the tab.

Custom Circuit Layout

This command (or the F5 key) displays the CC block window. The instance block of
the current CC definition is displayed in this window:

Bl Custom Circuit Block x|
F
AL PIDZ =
&I _PID_act
=AI_PIC_act al_PID aut
AL PID 1 peset AL_PID _out:=
=&I_PID_I_pesat
=
| [,

To find out the location of an external pin in the CC definition window, click on this
pin in the CC block window.
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Copy Page's Blocks

This command copies all blocks of the current page to DriveSPC's internal memory.

Paste Copied Blocks

This command pastes the blocks copied with command Program > Copy Page's
Blocks or CustomCircuit > Copy Page's Blocks to an empty page.

You can copy/paste blocks:

« From a program page to another program page

« From a program page to a page of a Custom Circuit definition
« From a page of a Custom Circuit definition to a program page

. From a page of a Custom Circuit definition to another page of a Custom Circuit
definition

« From a solution program to another solution program

Define Password for CC Display

If you want that a password is needed for the display of this custom circuit, select
this command and specify the password.

Drive menu

Connect

If there is a drive connected to your PC hardware, connect DriveSPC to the drive by
selecting Drive > Connect. If there is more than one drive connected to the PC
hardware, you select the drive from the list of available drives.

The identifier of the connected drive is displayed at the top of the DriveSPC
window.

Disconnect

If there are more than one drive connected to your PC and you want to change the
connection to another drive, disconnect the currently connected drive by selecting
Drive > Disconnect and make a connection to another drive by selecting Drive >
Connect.

Upload Program from Drive

This command uploads the previously downloaded solution program (if any) from
the connected drive, saves it to a user-specified folder and displays it on the
screen.

All program information exists in the drive; no additional PC files are required.
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The program name, program version, solution folder name and filename of the
uploaded program are displayed at the top of the DriveSPC window.

The uploaded program can be modified, printed, downloaded, and so on.

Upload Template from Drive

If there is a base solution in the drive, a dialog box is displayed and you can select
the template to be uploaded: either empty template or base solution.
Otherwise, the empty template of the drive is always uploaded.

The uploaded template is saved to a user-specified empty solution folder and
displayed on the screen.

All template information exists in the drive; no additional PC files are required.

The program name, program version, solution folder name and filename of the
uploaded template are displayed at the top of the DriveSPC window.

The uploaded template can be modified, printed, downloaded, and so on.

Download Program to Drive

This command downloads the current solution program to the connected drive.

The drive is always automatically restarted after the download. The downloaded
program is running in the drive after the restart.

Remove Program from Drive

This command removes the previously downloaded solution program from the
connected drive.

On-Line

This command changes the operating mode of DriveSPC from the Off-Line mode to
the On-Line mode.

When the operating mode is changed to the On-Line mode, the solution program of
the drive is automatically uploaded, saved to a user-specified folder and displayed
on the screen.

Finally, the current values of all input pin parameters of all firmware blocks are read
from the drive and displayed instead of the originally-uploaded pin parameter
values.

If the read actual value of a pin parameter is not the same as its original value, it is

displayed on a yellow background, for example S

Thetext TNHRE 544 the software load percentage of the drive are displayed
at the top of the DriveSPC window.

The background colour of the text is red if there is a fault in the drive or yellow if
there is a warning in the drive.
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Off-Line

This command changes the operating mode of DriveSPC from the On-Line mode to
the Off-Line mode.

The previously uploaded program is restored to the screen.

Display Original (or Actual) Program

This command (or the F4 key) displays the solution program either with the
originally uploaded pin parameter values or with the actual pin parameter values
that were read from the drive.

The text ORIGINAL PROGRAM is displayed on the screen if the originally uploaded
pin parameter values are currently on the screen.

List Original/Actual Differences

This command displays a dialog box with a list of changed pin parameters (the
originally-uploaded pin parameter values of these changed parameters are not the
same as the actual pin parameter values that were read from the drive).

Program Differences x|

Changed Parameters [double-click to go to a block):

2.05 MINIMUM TORG REF [block TORG REF MOD, page &)
2512 MIN TORG 5P CTRL [black SPEED CONTROL, page 7)
55.07 PROFDEC1 [black PROFILE REF SEL. page 11]

E5.15 PROF DEC 2 [block PROFILE REF SEL, page 11]

70.06 POS DECEL LIM (block POS REF LIM, page 11)

B0.05 POSZINT SCALE [block POS FEEDBACK. page 12
E0.09 POS RESOLUTION (block POS FEEDBACK, page 12)
5010 POS SPEED2INT [block POS FEEDBACK, page 12]
5013 MINIMUM POS [black POS FEEDBACK, page 12]
12.03 A1 MIN [block A1, page 3)

13.05 A1 MIN SCALE [block A1, page 3]

12,08 212 MIN (block A2, page 3)

1210 212 MIN SCALE [block A2, page 3]

15.06 A0 MIN SCALE [block AQ1, page 3]

15.07 A02 PTR [block 402, page 3]

20.02 MINIMUM SFEED [black LIMITS, page 10)

20.07 MINIMUM TORGUE [block LIMITS, page 10]

34.06 LOCAL CTRL MODE [block REFERENCE CTRL, page 8

If you want to see a changed pin parameter, select the desired parameter and click
OK or double-click on the parameter.
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Help menu

User Interface

This command (or the F1 key) displays the main index of the Drive SPC Help.

If you have highlighted a menu command, you get help information about the
command by pressing the F1 key.

Block/Parameter Information

This command (or the F3 key) opens the Firmware Manual of the drive in a
separate PDF window.

If the cursor is on a firmware block, on a normal block or on a pin parameter when
you press the F3 key, the description of this block or parameter is displayed in a
separate PDF window.

If the cursor is on a CC instance when you press the F3 key, the CC definition
window with the definition of the CC instance is displayed.
About DriveSPC

This command displays the DriveSPC information box.
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Appendix 1

Appendix overview

Input pin

Output pin

The appendix summarises the usage of the Ctrl, Alt and Shift keys with the left
mouse button and the use of the F3 key.

DriveSPC can be used without the Ctrl, Alt and Shift keys. These keys are
intended only to speed up the use of DriveSPC.

Ctrl Connect to the selected output pin (if any selected) or
select this pin for connection to an output pin (if no output pin selected)

Alt Go to the connected output pin (if any)
Shift Start/stop On-Line monitoring of this pin

F3 Ifan input pin of a firmware block:
Display the description of the pin parameter of this pin

Ctrl Connect to the selected input pin (if any selected) or
select this pin for connection to an input pin (if no input pin selected)

Alt Display a list of the connected input pins (blocks).
If desired, you can now go to a connected input pin.

Shift Start/stop On-Line monitoring of this pin

F3 Ifan output pin of a firmware block:
Display the description of the pin parameter of this pin

Block instance

Ctrl If a normal block or CC instance:
Change the execution position of this block instance

Alt Select this block instance for block move

F3 Display the description of this block

Empty screen location

Ctrl Add a new normal block instance here

Alt Put the selected block instance here (if any selected)
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Wire
Alt  Highlight this wire
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Appendix 2

Appendix overview

The appendix describes the definition of the data items of the array/structure that is
in an input or output pin of a normal block.

Array

An array is used when the data type of all data items is the same.

To define pin array data:

1. Right-click on the desired input or output pin of a normal block or CC instance
and select Define Pin Array Data.
A dialog box is displayed with a list of current array items (if any).

Array Data (DINT) x|

Mumber of Data ltems: |0 1.9

Array [ ata ltemns: | ﬂ

Mir ke b alue:
2147483648

b ax |tem W alue:
2147483647

FRead Data from File |

] 4 I Cancel |

2. Modify the items in the list by entering the data items manually to the list or read
the data items from a text file by clicking Read Data from File.
The filename extension of the file must be ARR.
Every data item in this file is in its own line, for example:
123.45
-7.1
45.9

3. After you have made the modifications, click OK.
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Structure
A structure is used when the data types of data items are not the same.
To define pin structure data:

1. Right-click on the desired input or output pin of a normal block or CC instance
and select Define Pin Structure Data.
A dialog box is displayed with a list of current structure items (if any). All
structure items are always 32-bit hexadecimal values.

Structure Data X|

MHurber of Data [tems: |0 1.19

Structure Data [HE= Dhwordz]: ﬂ

Read Data fram File

=
carcel_|

2. Modify the items in the list by entering the data items manually to the list (32-bit
hex values) or read the data items from a text file by clicking Read Data from
File.

The filename extension of the file must be STR.
Every 32-bit hex data item in this file is in its own line, for example:
12345
ABCDEF12
T6FF4
987A

3. After you have made the modifications, click OK.
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Appendix 3

Appendix overview

The appendix describes the usage of the Parameter Manager window.

Parameter Manager

Parameter Manager window is opened by menu command Program > Parameter
Manager.

i Parameter Manager = |E

Search: | [ Exit Parameter Manager ] [ English language ] [ Showe Firrnware group ]

IGr. |Gr0up narne |Gmup attributes | Add new group 1 I
[ = [ [z ]

|Gr. |No. |Parameter narne |Type |F\ttributes | Add copy Add new |
|

HEE [z [

The Search field at the top is used for parameter or group search. You can type
partial parameter or group name, or group and index number, and the parameter
list is moved to the location of the first found parameter or group.

If the Next and Prev buttons (after the Search field) are visible, they can be used to
search next and previous hits.

Language for all user-defined parameter texts is specified by the Language button
at the top of the window.

Groups are added to Parameter Manger by the following two buttons:

« A new group is created by the Add new group button in the header line of the
group after which the new group will be added.

« An existing firmware group is displayed for parameter addition by the Show
Firmware group button at the top of the window.

New parameters are added to a group by the two buttons in the header line of the
parameter after which the new parameter will be added:

« A completely new parameter is added by the Add new button.

« A copy of the clicked parameter is added by the Add copy button.
Every group and parameter contains two lines:

« Header line

« Value line

The parameter or group is copied, pasted or deleted by right-clicking its header
line.
Value items in a value line are set/changed by left-clicking the desired value area.
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Value items of groups

Group number
Group number is changed by left-clicking group's Gr field. A dialog box is displayed:

Group Number X|

Select Group Mumber

75
7B
I
78
73
20
a1
82

83 oK |

85
86
a7
a8

Cancel |

Select the desired group number and click OK.

Group name

Group name is specified by left-clicking group's Group name field. A dialog box is
displayed:

x

M ame: ||

Cancel |

Write the desired group name and click OK.
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Group attributes are set by left-clicking group's Group attributes field. A dialog box

is displayed:

Group Attributes

Select Group Attibute[s]
[Hd] GroupHide

X

Ok

Cancel

Select the desired group attributes (if any) and click OK.
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Common value items of parameters

Group number
Group number of a parameter is changed by left-clicking the parameter's Gr field. A
dialog box is displayed:

Parameter Group and/or Number |

Select Group Select Parameter Number

84 Uszer groupl ;I
25

29 Uszer group 2

B5.19 oK |

53.23 Cancel |

B2.32 k1

Select the desired group number and the desired parameter number in the selected
group and click OK.
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Parameter number (index) is changed by left-clicking the parameter's No. field. A

dialog box is displayed:

Parameter Mumber

Select Parameter Mumber

85.21 A

85.22
85.23
85.24
8525
2526

x|

85.27¥
85.28 Ok

85.29
85.30
8531

85,32 Cancel
85,33

85.34
85.35
B5.36
85.37
85.30
85.39
85.40

8541 [

Select the desired parameter number and click OK.

Parameter name

Parameter name is specified by left-clicking the parameter's Parameter name field.

A dialog box is displayed:

x

M ame: ||

coos|

Write the desired parameter name and click OK.
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Parameter attributes

Parameter attributes are set by left-clicking the parameter's Attributes field. A
dialog box is displayed:

Parameter Attributes x|

Select Parameter Attribute(z]

[Hd) Hide [<1]

[/ p] Wwirite protect [<1]

[ pR] Write prab. when running [<1]
SPw) S ave to Power down file [<2

< ']

oK. |

Cancel |

If there is string [<n] (e.g. [<1]) after an attribute's name, it means that a
maximum of one of the attributes marked with the same string (e.g. [<1]1) can be
selected.

If there is string [>n] (e.g. [>11]) after attribute's name, it means that at least one
of the attributes marked with the same string (e.g. [>1]) must be selected.

Select the desired parameter attributes (if any) and click OK.
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Parameter type

Parameter type is specified by left-clicking the parameter's Type field. A dialog box
is displayed:

Parameter Type X|

Select Type

|-Nnne-

Feal
Farmatted int
Selector list _
Packed Boolean " Signal
Y alue pointer

Bit piointer

Pozition

* Feference

Cancel |

Some parameter types allow the Reference/Signal selection.
Reference parameter is a parameter that can be written by users.
Signal parameter is a parameter that can only be read by users.

Select the desired parameter type (and Reference/Signal if applicable) and click
OK.

New type-specific value items (see below) are added to the parameter line after the
type selection.
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Type-specific value items of Scaled Real parameters

|Gr. |No. |Parameter name |Type |Min |Max |DeFauIt |Scale intemal |Sca|e panel |Fomat |Attrihutes | [ 1N | |
| ] | 17 |User parameter 1 |Scaled real ref |777 |777 |777 |777 |777 |777 |777 |
|
|

|Gr. |No. |Parameter name |Type |Sca|e intemal |Sca|e panel |Format |Attributes | [ 10 |
| ] | 1% |User parameter 2 |Scaled real sig |777 |777 |777 |777

Minimum value (Reference parameter only)

Minimum value is specified by left-clicking the parameter's Min field. A dialog box is
displayed:

Parameter Minimum ¥alue El

Min walue: || drn3ds

Cancel |

Write the desired value and click OK.

Maximum value (Reference parameter only)

Maximum value is specified by left-clicking the parameter's Max field. A dialog box
is displayed:

Parameter Maximum Yalue 5[

I ax walue: I dm™ 3z

cocs_|

Write the desired value and click OK.
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Default value (Reference parameter only)

Default value is specified by left-clicking the parameter's Default field. A dialog box
is displayed:

Parameter Default Yalue x|

Def walue: I drn3ds

Cancel |

Write the desired value and click OK.

Value scaling part 1/2: Scale internal

You have to specify how the parameter's internal values are displayed to users.
This is called value scaling and it is a two-step procedure.

The first step is started by left-clicking the parameter's Scale internal field. A dialog
box is displayed:

Internal ¥alue for Scaling x|

Part 142 af walue szaling:

Wit an internal value in the internal walue range aof this parameter.

[ntermal wallie: I

Cancel |

Write the desired value (e.g. 1234.5) and click OK.
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Value scaling part 2/2: Scale panel

You have to specify how the parameter's internal values are displayed to users.
This is called value scaling and it is a two-step procedure.

The second step is started by left-clicking the parameter's Scale panel field. A
dialog box is displayed:

Panel Yalue for Scaling x|

Part 242 of walue scaling:

Specify the dizplay of the intemal value [zpecified in part 142] in
panel.

Walue in panel:l

Cancel |

Write the desired value (e.g. 100) and click OK.

Example: If you wrote value 1234.5 in step one and value 100 in step two, it means
that parameter's internal value 1234.5 is displayed as value 100 to users.
All other internal values of this parameter are scaled in the same way.
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Value format is specified by left-clicking the parameter's Format field. A dialog box

is displayed:
x
Select Display mode Select Dizplay format Select Unit
Fanel format Integer [no decimalz) - Hone - -
Internal format Integer [1 decimal] A —
Scaled format Integer [2 decimalz) i
Integer [3 decimals) Hz
Integer [4 decimalz) poa
Integer [5 decimalz) %
Integer [B decimalz) h
Integer [7 decimalz) ]y
Integer [3 decimals) kh
Inteqer [9 decimalz) T
Ik it
s =
it
ki
W
kinh
F
Select Internal farmat I‘P:dE:-'v"h
mé'z
INT m"3h
DINT dm’3/s
REAL bar
REALZ4 kPa
G
PS5l
CFh
ft
GO
inHg
FPk
kb/s LI
T |

The meaning of the Display mode alternatives is as follows:

« Panel format is value format that includes scaling, selected Display format and

selected Unit (this format is used e.g. by panel).

« Scaled format is value format that includes only scaling.

« Internal format is the value format used by the internal program code.

Minimum, maximum and default values in the value line of this parameter are

displayed according to the selected Display mode.

Select the desired items from the lists and click OK.
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Type-specific value items of Real parameters

|Gr. |No. |Parameter name |T\,rpe |Min |Max |DeFau|t |Format

|Attributes | [ 10 ]

| ] | 20 |User parameter 4 |Rea| ref |777 |777 |777 |777

|Gr. |No. |Parameter narmne |T\,rpe |Format

|
& |
|
|

|Attributes | [ 10 ]

| a9 | 21 |User pararneter & |Rea| =ig |777

[

Minimum value (Reference parameter only)

Minimum value is specified by left-clicking the parameter's Min field. A dialog box is

displayed:

Parameter Minimum Yalue

drn”34s

Cancel |

kir wallie:; ||

x|

Write the desired value and click OK.

Maximum value (Reference parameter only)

Maximum value is specified by left-clicking the parameter's Max field. A dialog box

is displayed:

Parameter Maximum Yalue

dm ™35

Cancel |

b ax walue: I

X

Write the desired value and click OK.

Default value (Reference parameter only)

Default value is specified by left-clicking the parameter's Default field. A dialog box

is displayed:

Parameter Default ¥alue

Dref walue: I

dm ™35

Cancel |

X
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Write the desired value and click OK.

Value format

Value format is specified by left-clicking the parameter's Format field. A dialog box

is displayed:
x|
Select Display mode Select Dizplay format Select Unit
Panel format Integer [no decimalz) - Mone - "
Irternal format Inteqer [1 decimal] & [
Integer [2 decimalz) W
Integer [3 decimals) Hz
Integer [4 decimalz) poa
Integer [5 decimalz) %
Integer [B decimalz) h
Integer [7 decimalz) ]y
Integer [3 decimals) kh
Inteqer [9 decimalz) T
Ik it
s =
it
ki
W
kinh
F
Select Internal farmat I‘P:dE:-'v"h
REAL mi%;h
REALZ4 din™3s
bar
kPa
G
PS5l
CFh
ft
GO
inHg
FPk
kb/s LI
carcel_|

The meaning of the Display mode alternatives is as follows:

« Panel format is value format that includes selected Display format and selected
Unit (this format is used e.g. by panel).

« Internal format is the value format used by the internal program code.

Minimum, maximum and default values in the value line of this parameter are
displayed according to the selected Display mode.

Select the desired items from the lists and click OK.
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Type-specific value items of Formatted integer parameters

|Gr. |No. |Parameter name |T\,rpe |Min |Max |DeFau|t |Format

|Attributes | [ 10 ]

| ] | 22 |User parameter & |Formatted int ref |777 |777 |777 |777

|Gr. |No. |Parameter narmne |T\,rpe |Format

|
& |
|
|

|Attributes

| a9 | 23 |User pararneter 7 |Formatted int sig |777

[

Minimum value (Reference parameter only)

Minimum value is specified by left-clicking the parameter's Min field. A dialog box is

displayed:

Parameter Minimum Yalue

drn”34s

Cancel |

kir wallie:; ||

x|

Write the desired value and click OK.

Maximum value (Reference parameter only)

Maximum value is specified by left-clicking the parameter's Max field. A dialog box

is displayed:

Parameter Maximum Yalue

dm ™35

Cancel |

b ax walue: I

X

Write the desired value and click OK.

Default value (Reference parameter only)

Default value is specified by left-clicking the parameter's Default field. A dialog box

is displayed:

Parameter Default ¥alue

dm ™35

Cancel |

Dref walue: I

x|
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Value format
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Value format is specified by left-clicking the parameter's Format field. A dialog box

is displayed:

Parameter Formak

Select Display mode

Select Display format

X

Parel format
Internal farmat

Select Internal format

INT
DIMT

Integer [no decimalz]
PB Binary [3 digitz]
FB binar (4 digitz]
FE binary [5 digitz)
FB binar (B digitz]
FB binary [¥ digits]
FE binary [2 digitz)
FB binar [9 digitz]
FE binary (10 digitz)
PB hew [4 digits]

FB hex (8 digitz]
Hexadecimal [4 digitz)
Hewradecimal (B digitz]
Software version
Wheekly counter

Timne of the day

Drate
Time 24 h

k. I Cancel

The meaning of the Display mode alternatives is as follows:

« Panel format is the value format that includes the selected Display format (this
format is used e.g. by panel).

« Internal format is the value format used by the internal program code.

Minimum, maximum and default values in the value line of this parameter are
displayed according to the selected Display mode.

Select the desired items from the lists and click OK.
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Type-specific value items of Selector list parameters

|Gr. |No. |Darameter narne |Type |DeFauIt |Selection iterns |Attributes | [ 1N |

| 39 | 24 |User parameter § |Selector st ref |777 |777 |777

|Gr. |No. |Darameter narne |Type |Selection iterns |Attributes | [ 1N |

| 39 | 25 |User parameter 9 |Selector list sig |777 |777

Default value (Reference parameter only)

Default value is specified by left-clicking the parameter's Default field. A dialog box
is displayed with the list of user-specified selectable values:

Parameter Default ¥alue x|

Select Default Value

19=kin value
123=Default
4867=M ax value

Cancel |

Select the desired value and click OK.
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Selection items

Selectable values are specified by left-clicking the parameter's Selection items
field. A dialog box is displayed:

Parameter Yalues |
Walue List
Walus
x> Add Value >
Mame of the ' alue
Femove Value <« I
Ok | Cancel

In order to add a selectable value to the Value list, write the value in the Value field,
the value name in the Name of the Value field and click the Add Value button.

In order to remove a value from the Value list, select the item to be removed from
the list and click the Remove Value button.

When you have completed the Value list, click OK.
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Type-specific value items of Packed Boolean parameters

|Gr. |No. |Parameter namme |Type |Bit list

|Attributes

| ] | 26 |User parameter 10 |Packed Boalean ref |777

=

|Gr. |No. |Parameter namme |Type |Bit list

|Attributes

| ] | 27 |User parameter 11 |Packed Boalean sig |777

=

Bit list (Reference parameter)

Bit names and default bits are specified by left-clicking the parameter's Bit list field.

A dialog box is displayed:

Defavlt Marme Defavlt Marme
= = 15|
|_1|Start |'1?|
|_2|St0p |'1e|
N mREN
s | il
rs | =z
me | =22
=7 = 23
re | iy
= | =z |
=0 = 2 |
= =27
=z = 2
=1z 2|
™14 = a0
=15 il
ook | Cancel |

X

Write the desired bit names and select the desired default bits and click OK.
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Bit list (Signal parameter)

Bit names are specified by left-clicking the parameter's Bit list field. A dialog box is
displayed:

x
M ame M ame
= = 15|
= =7
I~z |Hunning |_18|
| =g
[l4 IStnpped il 2D|
=5 | =z
me | =2z
=7 = 23
e | 2|
= | = 25
= o = 25
=i =z
=iz |
=z |
™14 i
= 5| = e
[ o | Cancel |

Write the desired bit names and click OK.
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Type-specific value items of Position reference parameters

|Gr. |No. |Darameter narne |Type |Min |Max |DeFauIt |Attributes | [ 1N 1
| 21 | 28 |User patarneter 12 |Position ref |777 |777 |777 |777

|Gr. |No. |Darameter name |Type |Attn’hutes | [ 1N 1
| 23 | 29 |Llser patarneter 12 |Positi0n 5ig |777

Minimum value

Minimum value is specified by left-clicking the parameter's Min field. A dialog box is
displayed:

Parameter Minimum ¥alue 5[

Mir walue: || dm™ 3z

cocs_|

Write the desired value and click OK.

Maximum value

Maximum value is specified by left-clicking the parameter's Max field. A dialog box
is displayed:

Parameter Maximum Yalue El

I & walue: I drn3ds

Cancel |

Write the desired value and click OK.

Default value

Default value is specified by left-clicking the parameter's Default field. A dialog box
is displayed:
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Parameter Default Yalue x|

Def walue: I drn3ds

Cancel |

Write the desired value and click OK.
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Type-specific value items of Value pointer parameters

|Gr. |No. |Darameter narie |T\,rpe |DeFauIt |Dointer|ist |Attributes | [ 10 | |
| a9 | 30 |User patarneter 14 |\.-'a|ue pointer |7'” |777 |777 |

Default value

Default value is specified by left-clicking the parameter's Default field. A dialog box
is displayed with the list of user-specified selectable values:

Parameter Default ¥alue x|

Select Default Value

MULL
1.03 FREGQUENCY
201 DISTATUS

Cancel |

Select the desired value (value NULL means that no default value is required) and
click OK.
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Pointer list

Selectable pointer values are specified by left-clicking the parameter's Pointer list
field. A dialog box is displayed:

Parameter Lisk x|

Select Parameter Selected Parameters

=

SPEED ACT -

SPEED ACT PERC

FREQUENCY

CURRENT

CURRENT PERC

TOROUE

DCAVOLTAGE

ENCODER 1 SPEED

ENCODER 1 POS »» Add Par >>
ENCODER 2 SPEED
ENCODER 2 POS
POS ACT

POS 2ND ENC
SPEED ESTIMATED
TEMP INVERTER i Remowe Par << I
TEMP BC

MOTOR TEMP

MOTOR TEMP EST

USED SUPPLY wOLT

BR&KE RES LOAD

INVERTER POWER

ON TIME COUNTER

RUM TIME COUMTER

DI STATUS

202 RO STATUS |

R g N T T T S T R R R
PO Pl ol — L L L L L L L L oo

===l T P 0 0 00 ) O LT e D Pl — O 0D 00 ) O T e GO

(=
=
4

tame:

0K | Cancel |

In order to add a selectable pointer value to the Selected Parameters list, select a
parameter from the parameter list, write the desired name of this parameter to the
Name field and click the Add Par button.

In order to remove a parameter from the Selected Parameters list, select the item to
be removed from the list and click the Remove Par button.

When you have completed the Selected Parameters list, click OK.

Appendix 3



104

Type-specific value items of Bit pointer parameters

|Gr. |No. |Darameter namne |Type |DeFauIt |Dointer list |Attributes | Add copy Add new

| a9 | 31 |User patarneter 15 |Bit pointer |'«"«"«‘ |'«"«"«‘ |7'«'?

Default value

Default value is specified by left-clicking the parameter's Default field. A dialog box
is displayed with the list of user-specified selectable values:

Parameter Default ¥alue x|

Select Default Value

FaLSE FaLSE

TRUE TRUE

£.01.03 RUNMING
£.03.01 ZERO SPEED

Cancel |

Select the desired value and click OK.
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Pointer list

Selectable pointer values are specified by left-clicking the parameter's Pointer list
field. A dialog box is displayed:

Parameter Bit List x|

Select Parameter Select Bit Selected Parameter Bits

=

T.00 SPEED ACT -
102 SPEED ACT PERC
1.0% FREQUENCY
1.04 CURRENT

1.05 CURRENT PERC

1,05 TORGUE

1.07 DCMVOLTAGE

1,08 ENCODER: 1 SPEED :
1.09 ENCODER 1 POS >> AddPar Bi>> |
110 ENCODER: 2 SPEED
111 ENCODER 2 FOS
112 FOS ACT

113 POS 2ND ENC

114 SPEED ESTIMATED

115 TEMP INVERTER ﬂl
116 TEMP BC
117 MOTOR TEMP &dd TRUE »» |
118 MOTOR TEMPEST

119 USED SUPPLY WOLT

1.20 BRAKE RES LOAD

1.22 INVERTER POWER

126 ON TIME COUNTER

127 RUN TIME COUNTER,

20 DI STATUS

202 RO STATUS

203 DI0 STATUS

203 DI0 STATUS

203 DI0 STATUS

204 Al1

205 A1 SCALED =

M ame:

] | Cancel |

In order to add a selectable bit value to the Selected Parameter Bits list, select a
parameter from the parameter list, a bit from the bit list, write the desired name of
this parameter bit to the Name field and click the Add Par Bit button.

In order to add value FALSE to the Selected Parameter Bits list, write the desired
name of the FALSE value to the Name field and click the Add FALSE button.

In order to add value TRUE to the Selected Parameter Bits list, write the desired
name of the TRUE value to the Name field and click the Add TRUE button.

In order to remove an item from the Selected Parameters list, select the item to be
removed from the list and click the Remove Item button.

When you have completed the Selected Parameter Bits list, click OK.
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