Drive composer
Start-up and maintenance PC tool
User’s manual
## List of related manuals

<table>
<thead>
<tr>
<th>Drive firmware manuals and guides</th>
<th>Code (English)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACS880 primary control program firmware manual</td>
<td>3AUA00000085967</td>
</tr>
<tr>
<td>ACS580 standard control program firmware manual</td>
<td>3AXD50000016097</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Option manuals and guides</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>FENA-01/-11/-21 Ethernet adapter module user’s manual</td>
<td>3AUA00000093568</td>
</tr>
<tr>
<td>FSO-11 safety functions module user’s manual</td>
<td>3AUA00000097054</td>
</tr>
<tr>
<td>FSO-12 safety functions module user’s manual</td>
<td>3AXD50000015612</td>
</tr>
<tr>
<td>FSO-21 safety functions module user’s manual</td>
<td>3AXD50000015614</td>
</tr>
<tr>
<td>FPBA-01 PROFIBUS DP adapter module user’s manual</td>
<td>3AFE68573271</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tool manuals</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ACX-AP-x assistant control panels user’s manual</td>
<td>3AUA00000085685</td>
</tr>
<tr>
<td>Drive composer start-up and maintenance PC tool user’s manual</td>
<td>3AUA00000094606</td>
</tr>
<tr>
<td>Ethernet tool network for ACS880 drives application guide</td>
<td>3AUA00000125635</td>
</tr>
<tr>
<td>Adaptive programming application guide</td>
<td>3AXD50000028574</td>
</tr>
</tbody>
</table>

You can find manuals and other product documents in PDF format on the Internet. See section Document library on the Internet on the inside of the back cover.
User’s manual

Start-up and maintenance PC tool
Drive composer
# Table of contents

## 1. Introduction to the manual
- Purpose of the manual .......................................................... 11
- Applicability ........................................................................... 11
- Compatibility .......................................................................... 12
- Target audience ...................................................................... 12
- Contents of this manual ......................................................... 13
- Terms and abbreviations used in this manual ....................... 14

## 2. Overview of Drive composer
- Drive composer PC tool overview ......................................... 17
- Supported features .................................................................. 18
- Drive composer entry Vs pro .................................................. 19
- System requirements ............................................................. 21
- Drive composer hardware requirements .................................. 21
- Computer hardware requirements ......................................... 21
- Software requirements ......................................................... 21

## 3. Installation and uninstallation of Drive composer
- Determining the current Drive composer version ................. 24
- Installing Drive composer with the installer ....................... 25
- Uninstalling Drive composer with the installer ................. 28
- Registering Drive composer pro ........................................... 29
  - Registering Drive composer pro ........................................ 29

## 4. Connections
- Using Assistant control panel drivers .................................. 31
- Connecting to a drive with an Assistant control panel for the first time .................................................. 32
- Cable type ............................................................................. 32
- Connecting to drive with Assistant control panel ............. 32
- Changing the language settings ............................................ 35
- Connecting to a drive through an Ethernet network .......... 37
- Ethernet network connection .............................................. 37
- Creating an Ethernet network connection with Drive composer (pro) .......................................................... 37
  - Configuring the TCP/IP address with Windows XP ........ 38
  - Configuring the TCP/IP address with Windows 7 ........... 41
- Connecting network drives (pro) ....................................... 46
  - Panel bus network connection ........................................ 46
  - Creating a panel bus with Drive composer (pro) ............ 46
- Connecting to the panel bus with Drive composer (pro) .... 47
- Sharing connection (pro) ..................................................... 48

## 5. Main user interface components
- Drive composer UI overview ................................................ 50
- Title bar .................................................................................. 51
6. Parameter window

Parameter window overview ................................................................. 68
  Parameter window command icons ................................................. 69
  Parameter window: view parameters ............................................. 70
  Parameters list representation .................................................... 70
Navigating parameters and groups .................................................... 71
  Updating parameter values .......................................................... 71
  Hidden parameters ....................................................................... 71
  Alternate formats to view parameters .......................................... 71
  Viewing bit names ....................................................................... 72
Pointer parameters overview ............................................................. 74
  Inverting a bit pointer ................................................................ 75
  Setting fieldbus data in/out parameters ....................................... 76
Binary parameters ........................................................................... 78
Search for groups and parameters ..................................................... 79
Custom parameter window ................................................................. 80
  Custom parameter window features ............................................. 80
  Saving custom parameter window .............................................. 80
  Viewing copied parameter values ............................................... 81
  Adding parameters to a custom parameter window ....................... 81
Working with offline files ................................................................. 84
  Types of offline files ................................................................... 84
  Saving parameters to a parameter file .......................................... 84
  Opening a parameter file (entry) .................................................. 85
  Opening an offline file containing parameter values (pro) .............. 85
  Downloading parameter values to a drive ..................................... 85
  Comparing drive data (pro) ........................................................... 86
User set functionality (Pro) ............................................................... 88
  User set overview ...................................................................... 88
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>User set system requirements</td>
<td>88</td>
</tr>
<tr>
<td>Limitations</td>
<td>88</td>
</tr>
<tr>
<td>Starting the user set function</td>
<td>89</td>
</tr>
<tr>
<td>Creating user set</td>
<td>91</td>
</tr>
<tr>
<td>Active and unsaved user set</td>
<td>91</td>
</tr>
<tr>
<td>Saving user set</td>
<td>92</td>
</tr>
<tr>
<td>Copying user set parameter values</td>
<td>92</td>
</tr>
<tr>
<td>Removing user set</td>
<td>93</td>
</tr>
<tr>
<td>Show/hide user set</td>
<td>94</td>
</tr>
<tr>
<td>User set parameters limitation</td>
<td>94</td>
</tr>
<tr>
<td>7. Monitor window</td>
<td>95</td>
</tr>
<tr>
<td>Monitor window overview</td>
<td>96</td>
</tr>
<tr>
<td>Resizing the monitor window</td>
<td>97</td>
</tr>
<tr>
<td>Monitor window components</td>
<td>98</td>
</tr>
<tr>
<td>Configuration and control settings</td>
<td>99</td>
</tr>
<tr>
<td>Monitor controls</td>
<td>100</td>
</tr>
<tr>
<td>Active signal area overview</td>
<td>100</td>
</tr>
<tr>
<td>Zooming the graph</td>
<td>101</td>
</tr>
<tr>
<td>Panning the graph</td>
<td>101</td>
</tr>
<tr>
<td>Legend area functions</td>
<td>102</td>
</tr>
<tr>
<td>Graph area functions</td>
<td>103</td>
</tr>
<tr>
<td>Double cursor tool</td>
<td>103</td>
</tr>
<tr>
<td>8. Workspace handling</td>
<td>105</td>
</tr>
<tr>
<td>Workspace overview</td>
<td>106</td>
</tr>
<tr>
<td>Creating a custom parameter set and using it as a default workspace</td>
<td>106</td>
</tr>
<tr>
<td>9. Event logger</td>
<td>109</td>
</tr>
<tr>
<td>Event logger view</td>
<td>111</td>
</tr>
<tr>
<td>Fault data logger</td>
<td>111</td>
</tr>
<tr>
<td>10. Diagnostics</td>
<td>114</td>
</tr>
<tr>
<td>Support package</td>
<td>114</td>
</tr>
<tr>
<td>Creating a support package</td>
<td>114</td>
</tr>
<tr>
<td>Sending a support package to Drive Installed Base</td>
<td>115</td>
</tr>
<tr>
<td>Opening a support package (pro)</td>
<td>115</td>
</tr>
<tr>
<td>Drive application programming license</td>
<td>116</td>
</tr>
<tr>
<td>System info</td>
<td>116</td>
</tr>
<tr>
<td>Datalogger (pro)</td>
<td>116</td>
</tr>
<tr>
<td>Datalogger settings</td>
<td>118</td>
</tr>
<tr>
<td>Datalogger commands</td>
<td>118</td>
</tr>
<tr>
<td>Datalogger content configuration</td>
<td>118</td>
</tr>
<tr>
<td>Datalogger trigger configuration</td>
<td>120</td>
</tr>
<tr>
<td>Adding a trigger</td>
<td>120</td>
</tr>
<tr>
<td>Using the level triggers</td>
<td>121</td>
</tr>
<tr>
<td>Using bit mask trigger</td>
<td>121</td>
</tr>
<tr>
<td>Uploading triggered or stopped Datalogger data</td>
<td>121</td>
</tr>
<tr>
<td>Amplitude logger (pro)</td>
<td>123</td>
</tr>
</tbody>
</table>
Macro (pro) ................................................................. 124
Macro commands .......................................................... 125
  Macro language ......................................................... 125
  Simple example ....................................................... 125
Additional macro commands ............................................. 126
  Target ................................................................. 126
  Target name ......................................................... 126
  ParWrite .............................................................. 126
  ParWriteInt ........................................................... 127
  ParRead ............................................................... 128
  ParReadInt ............................................................ 128
  ParReadFromDevice .................................................. 129
  ParReadIntFromDevice ............................................... 129
  Wait ................................................................. 129
  EndMacro .............................................................. 130
  GotoMacro ............................................................ 130
  MessageBox .......................................................... 130

11. Control diagrams (pro)

Control diagrams overview ........................................... 131
Viewing control diagrams ............................................... 132

12. FSO configuration (pro)

Configuring FSO-12 and FSO-21 ....................................... 135
  Hardware connection .................................................. 136
  Setting the safety functions with Drive composer pro .......... 136
  Printing the safety functions configuration report (Online) .. 143
  Printing the safety functions configuration report (Offline) .. 147
Updating FSO firmware .................................................. 148
Changing FSO module password ....................................... 152
Reading FSO module parameters ..................................... 154

13. Other functions

Using Drive Installed Base service ................................... 156
  Registering an ABB drive to Drive Installed Base service .... 156
  Searching a registered ABB drive in Drive Installed Base ... 161
  Setting the Drive Installed Base server location ............... 163
  Creating a service report from Drive Installed Base .......... 164
  Create online service report ...................................... 165
  Creating offline report .............................................. 170
Drive backup ............................................................ 172
  Creating a backup of a drive ...................................... 172
  Creating a backup in drive parameter view ....................... 173
Restoring a drive ...................................................... 174
  Restoring a drive backup .......................................... 174
  Restoring a backup in the drive parameter view ................ 175
  Restoring a set of components/parameters settings (pro) .... 175
Recovery and prevention of FB14 fault in drive ..................... 177
  FB14 Recovery pack ................................................ 177
  FB14 Service pack .................................................. 178
  Sending FB14 Service pack event .................................. 181
14. Annexure A: Creating Drive Installed Base service report template

Creating a template for Drive Installed Base service report (Internal use only) ................. 204
Generic wizard step ................................................. 205
Components ......................................................... 205
  Common properties of components ........................................ 206
  ComboBox properties of components ..................................... 206
  DataGridView properties ............................................. 207
DataBindings ......................................................... 209
DataSource .......................................................... 209
DataTarget ........................................................... 210
  DataTarget objects ................................................... 210
  DataTarget examples ............................................... 211
Saving the DC wizard template in StepDesigner ................................. 212
Deploying a template file ........................................... 213
Localizing service report templates ...................................... 213
  Example: ............................................................. 213

15. Annexure B: Radius authentication

Example: Network configurations via Ethernet connection ................................. 216
ABB vendor specific attribute ........................................ 217
Supported user access levels ........................................... 217
Offline credentials .................................................... 217
  Default credentials: .................................................. 217
Introduction to the manual

Contents of this chapter

This chapter contains information on the applicability, compatibility, target audience and the purpose of the manual. It also describes the contents of the manual.

See topics:

- Purpose of the manual
- Applicability
- Compatibility
- Target audience
- Contents of this manual
- Terms and abbreviations used in this manual

Purpose of the manual

This manual describes the Drive composer PC tool and instructs how to use it in the commissioning and maintenance of ABB drives.

Applicability

This manual applies to the Drive composer PC tool, version 2.5 available in two different variants:

- Drive composer entry, DCET-01
- Drive composer pro, DCPT-01 (code: 3AUA0000108087).

You can download Drive composer entry for free by navigating to www.abb.com/drives and selecting Drive PC Tools. Drive composer pro includes all features and is available through ABB sales channels. Both versions require registration.

Note: In this manual, the features applicable only with Drive composer pro are indicated as "(pro)".
Compatibility

Drive composer is a software tool for all ABB common architecture drives and devices. The tool supports following drive families:

<table>
<thead>
<tr>
<th>ACSxxx</th>
<th>ACHxxx</th>
<th>ACQxxx</th>
<th>Others</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACS380</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>ACS480</td>
<td>ACH480</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>ACS530</td>
<td>ACH531</td>
<td>ACQ531</td>
<td>-</td>
</tr>
<tr>
<td>ACS560</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>ACS580</td>
<td>ACH580</td>
<td>ACQ580</td>
<td>-</td>
</tr>
<tr>
<td>ACS580MV</td>
<td>-</td>
<td></td>
<td>-</td>
</tr>
<tr>
<td>ACS860</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>ACS880</td>
<td>-</td>
<td>-</td>
<td>DCS880</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>DCT880</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>HES880</td>
</tr>
<tr>
<td>ACS6080</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**Drive composer version**

<table>
<thead>
<tr>
<th>Compatible features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drive composer entry</td>
</tr>
<tr>
<td>• Offers basic features common to all compatible drives.</td>
</tr>
<tr>
<td>• Connections to the drive with an Assistant control panel is common for all compatible drives and devices.</td>
</tr>
<tr>
<td>Drive composer pro</td>
</tr>
<tr>
<td>• Offers a variety of features and software modules. The features and software modules are based on the drive type.</td>
</tr>
<tr>
<td>• Recognizes the connected drive based on type code and firmware version and then adapts the availability of features accordingly. For example, if any of the feature is not applicable for the connected drive type, the drive composer UI does not display that particular module to the user.</td>
</tr>
<tr>
<td>• For non-recognized, but compatible drives, the same common basic features are available than with Drive composer entry.</td>
</tr>
<tr>
<td>• For ACS800 drives: Has limited support (parameter editing and monitoring) and requires DriveWindow 2.40 installation on the same PC.</td>
</tr>
</tbody>
</table>

Target audience

The reader is expected to be an automation engineering professional or an electrician and familiar with drive products and the concepts regarding their commissioning and operation, including the parameter system of ABB drives. Also a basic knowledge of Microsoft Windows operating system is needed.
## Contents of this manual

The manual consists of following chapters:

<table>
<thead>
<tr>
<th>Chapter name</th>
<th>What it contains</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to the manual</td>
<td>Provides information on the applicability, compatibility, target audience and the purpose of the manual.</td>
</tr>
<tr>
<td>Overview of Drive composer</td>
<td>Lists the main features of the Drive composer software and instructs how and where it can be run, and how to get help and additional information.</td>
</tr>
<tr>
<td>Installation and uninstallation of Drive composer</td>
<td>Describes how to install and uninstall the Drive composer software.</td>
</tr>
<tr>
<td>Connections</td>
<td>Describes how to make a connection with a drive through USB or Ethernet.</td>
</tr>
<tr>
<td>Main user interface components</td>
<td>Describes the main user interface components of the Drive composer PC tool, including the menus.</td>
</tr>
<tr>
<td>Parameter window</td>
<td>Describes how to use the parameter window.</td>
</tr>
<tr>
<td>Monitor window</td>
<td>Describes how to use the monitor window.</td>
</tr>
<tr>
<td>Workspace handling</td>
<td>Describes the workspace functionality.</td>
</tr>
<tr>
<td>Event logger</td>
<td>Describes how to use the event logger.</td>
</tr>
<tr>
<td>Diagnostics</td>
<td>Describes how to troubleshoot a drive with the Support package button of Drive composer and the data logger included in the drive.</td>
</tr>
<tr>
<td>Control diagrams (pro)</td>
<td>Describes how to use the control diagrams.</td>
</tr>
<tr>
<td>FSO configuration (pro)</td>
<td>Contains the configuration procedure of the FSO-12 and FSO-21 safety functions with Drive composer pro and provides an example of how to configure the optional FSO-12 and FSO-21 safety functions module. It also explains how to update the FSO firmware version.</td>
</tr>
<tr>
<td>Other functions</td>
<td>Describes common functions that are not associated with any view or window. For example, instructions on creating backup of a drive, using the Drive parameter conversion tool, using the PSL2 data viewer, recovery and prevention of FB14 fault, and so on.</td>
</tr>
<tr>
<td>Annexure A: Creating Drive Installed Base service report template</td>
<td>Describes how to create a DIB service report template. Applicable for ABB internal users only.</td>
</tr>
<tr>
<td>Annexure B: Radius authentication</td>
<td>Includes additional information about Radius authentication feature, for example, network configurations via Ethernet, supported user access level, and offline credentials.</td>
</tr>
</tbody>
</table>
# Terms and abbreviations used in this manual

<table>
<thead>
<tr>
<th>Term or abbreviation</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm limit of monitoring</td>
<td>You can set a low or high alarm limit for monitoring. Color(s) of the signal(s) change(s) on the monitoring graph area if the limit is reached.</td>
</tr>
<tr>
<td>Assistant</td>
<td>Provides predefined steps for setting the parameters of the drive. For example, the basic start-up assistant.</td>
</tr>
<tr>
<td>Assistant control panel</td>
<td>Control panel with an USB connector enabling a PC tool connection for common architecture drives. Assistant control panel is a generic name for ACS-AP-I and ACS-AP-S panels.</td>
</tr>
<tr>
<td>Autoscaling</td>
<td>Y-axis scaling is set automatically when this button is enabled. User-defined y-axis limits are then disabled. <strong>Note:</strong> Zooming is not possible in the Autoscaling mode.</td>
</tr>
<tr>
<td>Backup</td>
<td>Backup of the drive. Backup can be created with Drive composer or with control panel*. The Drive composer backup file (.dcparamsbak) includes all parameters, adaptive program and user sets. With a backup file from an old drive, you can quickly configure a new drive or restore configuration after firmware update. <strong>Note:</strong> Backup file does not include firmware, IEC program or license. * Refer to control panels user’s manual.</td>
</tr>
<tr>
<td>Basic control panel</td>
<td>Control panel with limited basic functionality used with common architecture drives.</td>
</tr>
<tr>
<td>Bit mask of monitoring</td>
<td>You can filter bits of the Status word and monitor them individually.</td>
</tr>
<tr>
<td>BOL</td>
<td>Business Online. A common customer interface with electronic integration and order entry to all ABB business units.</td>
</tr>
<tr>
<td>Common architecture drives</td>
<td>For example, ACS880, DCS880, ACS580, ACH580, ACQ580, ACS560 and ACS480.</td>
</tr>
<tr>
<td>Compare parameters</td>
<td>You can compare parameters between drives or between a drive and a file to find out differences.</td>
</tr>
<tr>
<td>Control diagrams</td>
<td>Graphical presentation of the drive reference chain or other function. Shows online values of a parameter, switch positions and signals. Parameters can be modified online. Functionality is not available for all drives.</td>
</tr>
<tr>
<td>Copy/Download parameters</td>
<td>Visible parameters of a parameter window or custom parameter window are copied/downloaded to a drive.</td>
</tr>
<tr>
<td>Cursor tool</td>
<td>Monitor window has a double cursor tool and the positions of cursors can be freely set in the monitor window. y2—y1 and x2—x1 differences are calculated.</td>
</tr>
<tr>
<td>Custom parameter window</td>
<td>You can create windows and drag drop (copy) parameters to these windows. You can also change parameter values in the window and save the changes for using in offline mode. The Filename extension for custom parameters is *.dccustparams.</td>
</tr>
<tr>
<td>Data file viewer</td>
<td>In the Demo/Offline mode, the monitor window can be used as a data file viewer when saved monitored data (*.dcmon) or data logger data is analyzed.</td>
</tr>
</tbody>
</table>
### Introduction to the manual

- **Data logger**: Signals are buffered inside a drive with a fast sample interval. Can be triggered and uploaded to the monitor window to be analyzed.

- **Demo/Offline**: In Demo mode you can only view the default parameter values and settings in a pre-configured file. The FSO configuration file can be edited only in demo mode (for offline configuration). In Offline mode you can set/view the saved parameter files offline.

- **Drive Installed Base**: Drive Installed Base (DIB) is a knowledge base containing information about drives. Drive composer is the client application for Drive Installed Base service which is used to register a drive and to create service reports.

- **DriveAP**: Adaptive Programming of a drive. Functionality of a drive can be modified by adding some IEC 61131 -based blocks. Adaptive Programming can be done also with an Assistant control panel. **Note**: Adaptive Programming is not available with all drives.

- **EDS**: Electronic Data Sheet. EDS files are simple text files used by network configuration tools to identify products and describe the properties of these products and to commission them on a network.

- **Event logger**: Consist of faults, alarms and events. Only faults stop the drive. Latest faults and all Electronic Data Sheet arms are also seen in the parameter interface group 4, **Warnings and Faults**.

- **FENA-11**: Ethernet adapter module for ABB drives.

- **LOC/REM**: LOC denotes local control of the drive, either with an Assistant control panel or with Drive composer PC tool. REM denotes that drive is remotely controlled by the fieldbus master PLC or by I/O connections.

- **Lock/Unlock parameter**: Parameter can be locked by a drive. You can only view the parameter values, but cannot modify them.

- **Macro script**: User-written sequence of macro statements for reading and writing parameters/signals. Filename extension for macro scripts is ".p".

- **Monitoring**: You can set parameters or signals to the monitor window. Values are collected with the sampling interval and drawn to a window.

- **NLS support**: National Language Support, the user interface (UI) of Drive composer can be easily modified by editing language files found in the LANG folder of the Drive composer PC tool.

- **Online/Offline**: In Online mode PC tool is connected with the drive. In Offline mode PC tool is not connected with the drive. In Offline mode it is possible to open parameter files, save monitored data, etc.

- **OPC server**: OPC DA server interface for Drive composer pro that allows other programs, such as Control Builder Pro (Advanced drive programming), to communicate with the drive.

- **RADIUS**: Remote Authentication Dial-In User Service. RADIUS is an authentication protocol to manage access to the Internet or internal networks, wireless networks, and integrated e-mail services.
Introduction to the manual

Refresh the parameter: Parameter values are updated when a group is opened. You can set parameters to the Auto-update mode or refresh the value manually. Signals are always updated automatically. In the parameter list, signals are shown in bold text.

Report: You can use report templates for energy savings, commissioning and maintenance. Templates can be modified.

Restore: You can restore the drive. You can select the parameters to be restored during the restore operation. For example, motor identification run results can be restored or deleted during the restore operation. Can be used for cloning drives.

Save parameters: Visible parameters of a parameter window or custom parameter window are saved to a file. Filename extension for saved parameters is *.dcparamsbak.

Note: Some values are not editable in the Offline mode.

Support diagnostics package: You can collect all data from a drive for troubleshooting purposes by clicking a button in Drive composer or on an Assistant control panel.

Workspace: Workspace consists of the user interface status, such as parameters shown in the custom parameter window(s) and their status. You can save the current workspace status to a file and restore it later. Custom parameter windows with their contents and the monitor window contents (signals selected, scalings, colors) are saved to a workspace. You can set one default workspace. Filename extension for the workspace is *.dcxml.
Overview of Drive composer

Contents of this chapter

This chapter briefly lists the main features of the Drive composer software and instructs how and where it can be run, and how to get help and additional information.

See topics:

- Drive composer PC tool overview ................................................................. 17
- Supported features .................................................................................. 18
- Drive composer entry Vs pro ..................................................................... 19
- System requirements .............................................................................. 21
- Drive composer hardware requirements ............................................... 21
- Computer hardware requirements ............................................................ 21
- Software requirements ........................................................................... 21

Drive composer PC tool overview

Drive composer is a 32-bit Windows application for commissioning and maintaining ABB common architecture drives.

The full version is called Drive composer pro and the limited version is called Drive composer entry. Both versions include a demo mode that allows you to test the user interface functionality, edit parameter files offline (pro) or open and analyze the saved or monitored files without connecting to a physical drive. You can edit the safety configuration file (with sanity check) only in demo mode for offline configuration.
Supported features

With Drive composer, you can:

- control a drive: start, stop, direction, speed/torque/frequency reference
- monitor the operation and status of a drive
- view and adjust drive parameters
- preview and add customized text to parameters
- monitor signals in numerical and graphical (trending) format
- work simultaneously with multiple drives like master and follower drives (pro)
- display control diagrams of a drive for parameter setting and diagnostic purposes (pro)
- create user-specific workspaces by customizing parameter windows
- configure the optional FSO-12, FSO-21 safety functions module (pro)
- handle workspaces
- create and execute macro scripts (pro)
- create and work with user set parameters (pro)
- use Ethernet-based fieldbus adapter modules for PC tool communication (one-wire solution, Profinet, Ethernet IP) (pro) or a drive-embedded Ethernet port
- use the USB port of an Assistant control panel for an USB connection
- use an OPC-based commissioning and maintenance tool (pro)
- connect to Drive Installed Base service portal and do following tasks: register a drive, search drive information, create service reports
- recover drive from FB14 fault state
- prevent FB14 fault
- check the status of Service pack installation
- limit access to certain operations of the drive with Radius authentication.
- update FSO module firmware
## Drive composer entry Vs pro

The table lists the features supported in the two versions of Drive composer.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Drive composer entry</th>
<th>Drive composer pro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Parameter window features</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search/ Modify/ Print parameters</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters changed by user (or automatically updated) have an orange background</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Save parameters to a file</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Copy/download parameters to a drive</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Customize parameter windows</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit parameters offline</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Compare parameters between parameter lists or drives</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Create and work with User set functionality</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Diagnostics and monitor window features</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Collect data for support service using Support package icon</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Monitor up to eight signals as a simple monitoring method for basic purposes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Monitor maximum 26 signals for professional analysis of a single drive or multidrive</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Save the monitored data to the hard drive of a PC</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Export monitored data to a PC using tab separated file</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>View contents of an event logger (faults, warnings)</td>
<td>Partly</td>
<td>Yes</td>
</tr>
<tr>
<td>View contents of System info (drive serial number, modules, versions, SW, etc.)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Restore or clone a drive using Backup/Restore feature</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Restore a set of components/parameter settings using Advanced restore feature</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Create a backup of complete multidrive with a single click using the Network Backup feature</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Use PC to analyze data logged in a drive by a data logger</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Create and execute macro scripts</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Connections</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Connect network drives via Ethernet or with a panel bus</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Connect point-to-point USB through a panel port</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Safety features</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configure safety settings to a safety functions module (FSO)</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Update FSO module firmware</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
## Overview of Drive composer

<table>
<thead>
<tr>
<th>Feature</th>
<th>Drive composer entry</th>
<th>Drive composer pro</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Other features</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use control diagrams of a drive for parameter setting and diagnostic purposes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>User interface is available in different languages</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Create and edit Adaptive programs</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Support Virtual drive smart components</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Connect to Drive Installed Base service portal to: register a drive, search for drive information, create service report</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Recover drive from FB14 fault state</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Recover and prevent FB14 fault without updating drive firmware</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Check the status of Service pack installation</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Configure RADIUS authentication</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Add customized text to parameter with drive text editor</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
System requirements

- Drive composer hardware requirements

<table>
<thead>
<tr>
<th>Cable type</th>
<th>For...</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB type A (PC) type mini B (panel) cable</td>
<td>connecting Drive composer entry/pro through the USB port of the control panel to a drive (maximum 3 meters)</td>
</tr>
<tr>
<td>Note: ABB recommends to use ferrite core cables.</td>
<td></td>
</tr>
<tr>
<td>Ethernet cable RJ45</td>
<td>connecting through FENA-11 or embedded Ethernet</td>
</tr>
</tbody>
</table>

- Computer hardware requirements

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer</td>
<td>IBM compatible PC</td>
</tr>
<tr>
<td>Processor</td>
<td>Intel i5 with at least 2.3 GHz</td>
</tr>
<tr>
<td>Memory</td>
<td>8G or higher</td>
</tr>
<tr>
<td>Display</td>
<td>1024 x 600 display resolution with 256 colors</td>
</tr>
<tr>
<td>Hard disk</td>
<td>At least 800 MB free hard disk space</td>
</tr>
<tr>
<td>Storage</td>
<td>CD drive</td>
</tr>
<tr>
<td>Communication port</td>
<td>One free USB port or Ethernet port</td>
</tr>
</tbody>
</table>

- Software requirements

<table>
<thead>
<tr>
<th>Software</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system</td>
<td>Windows 7 and Windows 10 (32- or 64-bit)</td>
</tr>
<tr>
<td>Framework</td>
<td>.Net framework 4.8 or higher</td>
</tr>
<tr>
<td>Adobe Acrobat Reader</td>
<td>Not applicable</td>
</tr>
</tbody>
</table>
Installation and uninstallation of Drive composer

Contents of this chapter

This chapter describes how to install and uninstall the Drive composer software.

See topics:

- Determining the current Drive composer version .......................................................... 24
- Installing Drive composer with the installer .................................................................. 25
- Uninstalling Drive composer with the installer ................................................................. 28
- Registering Drive composer pro ...................................................................................... 29
- Registering Drive composer pro ...................................................................................... 29
Determining the current Drive composer version

To know the version of the Drive composer PC tool, go to Help → About the product. The About the product dialog box displays the Drive composer version.

Figure 1. About the product dialog box
Installing Drive composer with the installer

**Note:**

- ABB recommends to uninstall all previous versions of Drive composer before you install a new version. See section Uninstalling Drive composer with the installer.
- Close all applications before starting the installation.

1. Run the setup.exe file from the folder where you unzipped the Drive composer files.
2. With Windows 7, right-click on the setup.exe file and select **Run as administrator**.

![Image](setup_as_administrator.png)

*Figure 2. Installing Drive composer: Run as administrator*

3. In the **Drive composer - Setup Wizard**, click **Next**.

![Image](setup_wizard.png)

*Figure 3. Installing Drive composer: Setup wizard window*
4. Choose a destination folder and click **Next**.

![Figure 4. Installing Drive composer: Destination folder window](image)

5. Click **Install** to start the installation.

![Figure 5. Installing Drive composer: Install window](image)
If Drive composer installation is complete, click **Finish**. Now Drive composer is ready for use.

![Installation completed window](image)

*Figure 6. Installing Drive composer: Installation completed window*

On running the application for the first time, it displays a notification seeking permission to collect the tool's usage data to send it to ABB. This is used for improving the performance and user experience. ABB does not collect any personal data. This is optional and is not mandatory to accept.

![Usage data collection and use](image)

You can enable or disable the usage data collection any time from **View → Settings**.
Uninstalling Drive composer with the installer

1. Go to Control panel → Programs → Program and features window and select the installed Drive composer pro program. Click Uninstall.

![Figure 7. Uninstalling Drive composer](image)

2. Click Yes to uninstall Drive composer pro application.

![Figure 8. Uninstalling Drive composer: Confirm removal of Drive composer](image)
Registering Drive composer pro

Drive composer pro includes a license and requires registration. During the first launch of the software, preferably you can register online. You can also make offline registration if Internet connection is not available on the PC where Drive composer is installed.

You can also run Drive composer pro for 30 days in fully functional evaluation mode.

- Registering Drive composer pro

During the first launch, Drive composer pro prompts to enter the registration code or the license key. Fill in the registration code and click **Activate**.

You can also later at any time, enter the registration code or the license key. Go to **Help → Enter license code** and fill in the registration code and click **Activate**.
Installation and uninstallation of Drive composer
Connections

Contents of this chapter

This chapter describes how to make a USB connection or an Ethernet connection to an ABB drive with Drive composer.

See topics:
- Using Assistant control panel drivers ................................................................. 31
- Connecting to a drive with an Assistant control panel for the first time .................. 32
- Cable type .............................................................................................................. 32
- Connecting to drive with Assistant control panel .................................................. 32
- Changing the language settings ............................................................................. 35
- Connecting to a drive through an Ethernet network ............................................... 37
- Ethernet network connection ............................................................................... 37
- Creating an Ethernet network connection with Drive composer (pro) ....................... 37
- Connecting network drives (pro) ............................................................................ 46
- Panel bus network connection .............................................................................. 46
- Creating a panel bus with Drive composer (pro) .................................................... 46
- Connecting to the panel bus with Drive composer (pro) ........................................ 47
- Sharing connection (pro) ....................................................................................... 48

Using Assistant control panel drivers

You can connect an ABB drive to an Assistant control panel (ACS-AP-x) through USB by installing the required USB device drivers. Drive composer installer installs the required drivers automatically, so no user actions are needed.

If the installer failed to install the drivers automatically, you can manually install the USB drivers by downloading the tool from software tools website:


Follow the instructions provided with the drive package.
Connecting to a drive with an Assistant control panel for the first time

- **Cable type**

  To establish a connection between Drive composer and drive,
  - connect a USB type A (PC) type mini B (panel) cable to the USB port of the computer and the USB port of the Assistant control panel (ACS-AP-x panel).
  - use a USB cable of maximum length three meters.
  - use separate USB/485 adapter if the drive is used without an Assistant control panel or with a Basic control panel.

- **Connecting to drive with Assistant control panel**

  1. Connect your PC to the Assistant control panel with a USB cable.

     ![Diagram](image)

     **Figure 9. USB connection between Assistant control panel and PC**

     The following text appears on the Assistant control panel screen: “USB connected”.

     **Note**: The Assistant control panel cannot be used when it is connected to a PC.

  2. Launch Drive composer by double-clicking **Drive composer entry/pro.exe**.

  3. Click **Connect** if you want to connect to the drive or click **Demo** if you want to choose the Offline mode.

    ![Image](image)

    **Figure 10. Connecting to a drive: Connect/Demo button**
You can also select the dedicated connections to the drive:

<table>
<thead>
<tr>
<th>Connections</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DDCS enabled (ACS800 only)</td>
<td>Connects to the drive through DDCS (fiber optic) communication. This option is applicable only with ACS800 drive type.</td>
</tr>
<tr>
<td>USB/COM enabled</td>
<td>Connects to the drive through USB connection. Use this option only when you want to connect to the drive through serial connection, example, USB cable to the ACS-AP-x panel.</td>
</tr>
<tr>
<td>Ethernet enabled</td>
<td>Connects to the drive through Ethernet network.</td>
</tr>
<tr>
<td>Virtual drive enabled</td>
<td>Connects to the Virtual drive smart component. This option is applicable only when Virtual drive is installed in the PC.</td>
</tr>
<tr>
<td>Comm settings</td>
<td>Opens a dialog where you can configure the connections in more detail</td>
</tr>
</tbody>
</table>

**Note:**

- The status LED starts flickering in the Assistant control panel to indicate data transfer between drive and PC. The LED keeps blinking as long as there is a PC tool connected to the drive. The welcome dialog box is shown on the screen indicating that the application is initialized.
- First time connection, parameter texts are loaded from the drive and this may take a few minutes depending on the drive type.

If Drive composer is connected online with the drive, the drive parameters are loaded and following window displays.

![Figure 11. Connecting to a drive: Parameters loaded](image)

If you have a single drive and a point-to-point connection, refer to chapter Parameter window.
If Drive composer failed to connect online with the drive, the Drive not found message appears. Make sure that all the instructions displayed in this window are satisfied.

![NO DRIVE FOUND!](image)

Please make sure:
- Drive is powered on.
- Cable is properly connected between the drive and PC.
- Desired connection type is selected in Welcome window.
- COM port is correct in Settings when using USB connection.

**Figure 12. Drive not connected**

4. Go to **View → Settings** to check your COM settings and click **View → Refresh** (Ctrl+R) to reconnect Drive composer to the drive.
Changing the language settings

To change the language settings of the Drive composer UI,

1. Go to View → Settings.

![Image showing View → Settings]

Figure 13. Changing language settings: View → Settings

2. In the Settings window, choose the required language for the Drive composer UI.

![Image showing Settings window]

Figure 14. Language settings
• **Drive composer default language**—selects the default language of the menu or button text in Drive composer.

• **Drive default language**—selects the default language for parameters.

By changing language settings you can always use the same language when you connect Drive composer to the drive.

3. After changing the language settings, click **View → Refresh (Ctrl + R)** or restart the Drive composer application.

**Note:** Some elements might require application restart to update the selected language.
Connecting to a drive through an Ethernet network

- **Ethernet network connection**

Some ABB drives have control boards with an embedded Ethernet port and some drives in which the Ethernet connection is made with the FENA Ethernet adapter module. For the installation of the adapter module, see *FENA-01/-11/-21 Ethernet adapter module user’s manual* (3AUA0000093568 [English]).

**Note:** Configure the PC/Ethernet Switch firewall to allow a connection for Drive composer pro (port http 80 and UDP), otherwise disable firewall.

- **Creating an Ethernet network connection with Drive composer (pro)**

1. Connect the FENA module to a drive.
2. Create a point-to-point connection from Assistant control panel or Drive composer to each drive.
3. If you will use only one adapter module with the drive, enable FENA by setting parameter 50.01 FBA A enable to *Enable* and parameter 50.21 FBA A Timelevel sel to *Fast* (or *Monitoring* for Tool network only).
4. If you will use two fieldbus adapters with the drive and FENA is installed as FBA B, enable FENA by setting parameters 50.31 FBA B enable to *Enable* and 50.51 FBA B Timelevel sel to *Fast* (or *Monitoring* for Tool network only).
5. Set a static IP address for each drive. See *FENA-01/-11/-21 Ethernet adapter module user’s manual* (3AUA0000093568 [English]).

![Figure 15. Ethernet connection: IP settings of the drive with Drive composer](image)

6. Refresh the settings with parameter 51.27 FBA par refresh.

**Note:** Refreshing the Node setting will lose the communication to the drive. To re-establish the connection with the drive, select **View → Refresh**.

7. Name each drive to facilitate the recognition of drives when creating an Ethernet network connection.

   In the **System info** tab, type the **Drive name** and click **Set**.

![Figure 16. Ethernet connection: Naming a drive with Drive composer](image)
Note: The drive name changes only after you refreshed the view. The previous names in other existing workspaces are not affected.
If you use Assistant control panel, name the drive from the Setting menu of the panel.

8. Configure the TCP/IP address of your PC. In this example the TCP/IP address is 192.168.0.1. For more information on configuring the TCP/IP address, see
- Configuring the TCP/IP address with Windows XP or
- Configuring the TCP/IP address with Windows 7.

Configuring the TCP/IP address with Windows XP

1. Go to Control panel → Network and Internet Connections → Network Connections.

2. In the Network Connections window, double-click the required connection.

![Figure 17. Configuring TCP/IP address: Network Connections window](image-url)
3. Click the **Properties** button. The Local Area Connection Status dialog box appears.

![Figure 18. Configuring TCP/IP address: Local Area Connection Status](image)

4. Select **Internet Protocol (TCP/IP)** and click **Properties**.

![Figure 19. Configuring TCP/IP address: Local Area Connection Properties](image)
5. Select **Use the following IP address** and type the IP address and the subnet mask. Click **OK**.

![Internet Protocol (TCP/IP) Properties](image)

*Figure 20. Configuring TCP/IP address: Use IP address*

TCP/IP address configuration is completed.
Configuring the TCP/IP address with Windows 7

1. Go to Control Panel and click View network status and tasks.

![Figure 21. Configuring TCP/IP address: Win 7 Control Panel](image)

2. Click Change adapter settings on the left pane. A Network connections window displays.

![Figure 22. Configuring TCP/IP address (Win 7): Adapter settings](image)

3. Double-click Local Area Connection.

![Figure 23. Configuring TCP/IP address (Win 7): Local Area Connection](image)
4. Click **Properties**.

![Local Area Connection Status](image)

**Figure 24. Configuring TCP/IP address (Wind 7): Local Area Connection Status**

5. Select **Internet Protocol Version 4 (TCP/IPv4)** and click **Properties**.

![Local Area Connection Properties](image)

**Figure 25. Configuring TCP/IP address (Win 7): Local Area Connection Properties**
6. Select **Use the following IP address**, type the IP address and subnet mask and click **OK**.

![Figure 26. Configuring TCP/IP address (Win 7): Use IP address](image)

7. Connect the RJ45 cable between the FENA module and PC. Alternatively, connect all drives and PC to the same Ethernet switch.
8. Open command prompt (cmd.exe) and ping all the drives that you have configured.

![Image of command prompt with ping command]  
**Figure 27. Configuring TCP/IP address (Win 7): Ping drives**

**Note:** Open http port 80 of the firewall in your computer to enable Drive composer pro to communicate with drives.

9. Open Drive composer pro. In the Welcome window, make sure **Ethernet enabled** is checked and click on **Comm settings** button.

![Image of Drive composer pro with Ethernet enabled]  
**Figure 28. Configuring TCP/IP address (Win 7): Ethernet enabled**
10. In the Drive Ethernet Configuration Tool window, click Scan → Scan Network. Make sure Auto configuration mode is checked.

Figure 29. Configuring TCP/IP address (Win 7): Communication settings

Drive composer scans all the COM ports and Ethernet ports to find drives. If problems arise, see Ethernet tool network for ACS880 drives application guide (3AUA0000125635 [English]).
Connecting network drives (pro)

Panel bus network connection

You can connect all ABB drives with an ACS-AP-x panel using a daisy-chain connection through the control panel ports as a network either for a PC tool or a panel bus connection.

Note: Some ABB drives control boards (for example, ZCU-13) do not have any daisy-chain connectors. For those drives, a panel bus connection can be created with FDPI-02 option modules. See *FDPI-02 diagnostics and panel interface user’s manual* (3AUA0000113618 [English]) for more information.

Figure 30. Connecting network drives: Creating a panel bus

Creating a panel bus with Drive composer (pro)

1. Create a point-to-point connection from the Assistant control panel or Drive composer to each drive.

2. Set an independent node ID for each drive (with parameter 49.01 Node ID number). The node ID must be between 1…32.

3. Refresh the settings (with parameter 49.06 Refresh settings). Note: Refreshing the Node setting will lose the communication to the drive. To re-establish the connection with the drive, select View → Refresh.

4. With parameter 49.05 Communication loss action, define how the drive reacts to a control panel (or PC tool) communication break by selecting No action.

5. Give a name for each drive to facilitate the recognition of drives when creating a panel bus connection.

Figure 31. Creating a panel bus: Panel port settings
In the System info tab, type the **Drive name** and click **Set**.

![Image of System info tab](image)

**Figure 32. Creating a panel bus: Naming a drive**

**Note:** The drive name changes only after you refreshed the view. The previous names in other existing workspaces are not affected.

If you used Assistant control panel, name the drives through the Setting menu of the panel.

6. Remove all panels connected to drives.

7. For connecting the drives in a daisy-chain, connect a standard RJ45 (straight CAT5) cable on the left-hand side connector of the Assistant control panel in the first drive (the left-hand side drive in figure Connecting network drives: Creating a panel bus on page 46).

   **Note:** Heavy-industry type RJ45 male connectors do not fit into the drive side female RJ45 slot

8. Connect a standard RJ45 (straight CAT5) cable from the right-hand side connector of the Assistant control panel in the first drive to the left-hand side connector of the Assistant control panel in the second drive.

9. Continue chaining the rest of the drives as described above.

10. If there is a long distance between the first and last drive in a panel bus, set the resistor to the ON position in the last node.

### Connecting to the panel bus with Drive composer (pro)

1. Connect a USB cable between the Assistant control panel and your PC.

2. Double-click **Drive composer pro.exe** to launch Drive composer.

   The status LED starts flickering on the Assistant control panel.

3. Drive composer starts scanning all selected networks and loads the connected drives.

4. Make sure you see all drives in the Drives list.

   **Notes:**
   - If you see a missing drive, close the PC tool and try again. If you still do not see all drives, check Group 49 Panel port communication for the settings of the missing drives.
   - Drive composer does not automatically open any parameter window or other object.

5. Select and click a drive from the Drive list.
Sharing connection (pro)

1. Go to View → Settings.

2. In the Settings screen, select the option Share connection with Automation Builder to enable simultaneous connection to the same drive from both applications.

3. Click Save to save the new settings.

4. You may be prompted to restart Drive composer. Click OK, to restart.
Main user interface components

Contents of this chapter

This chapter describes the user interface (UI) components and how to use them.

See topics:

Drive composer UI overview .............................................................. 50
Title bar .......................................................................................... 51
Closing the application ..................................................................... 51
Alternate methods to close the application .................................... 51
Saving the workspace with unsaved changes .............................. 52
System menu .................................................................................. 53
Menu bar ...................................................................................... 54
Using the menu bar ................................................................. 54
File menu ...................................................................................... 54
Edit menu .................................................................................... 56
View menu .................................................................................... 56
Tools menu .................................................................................... 58
Help menu .................................................................................... 60
Drive control panel ........................................................................ 61
Drive control panel buttons/items description ......................... 61
Using the drive control panel to start the drive ...................... 62
Drives list panel ........................................................................... 63
Drives list panel: status indication ........................................... 64
Working area .................................................................................. 65
Using the working area .............................................................. 65
50 Main user interface components

Drive composer UI overview

The Drive composer user interface consists of the following parts.

Figure 34. Overview of the user interface

1. **Title bar**
2. **Menu bar**
3. **Drive control panel**
4. **Drives list panel** (see also Drives list panel: status indication)
5. Status panel (including the output view of the selected drive).
6. **Working area** for parameter windows, event logger, control diagrams, assistants etc.
Title bar

The title bar is located at the top of the main window. It consists of the following parts:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
</tr>
<tr>
<td>System menu icon. See description in <strong>System menu</strong>.</td>
<td>Application name and version number (Drive composer entry/pro)</td>
<td>Name of the workspace (if there is an active workspace)</td>
<td>Minimize button—has the same function as Minimize in the System menu. With this button, you can reduce the main window to the task bar or a sub-window to the bottom of the window area.</td>
</tr>
<tr>
<td>5</td>
<td>Maximize/Restore Down button (the name depends on the status of the maximized window)—has the same function as Maximize or Restore in the System menu.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Close button—has the same function as <strong>Close</strong> in the System menu. With this button, you can end the Drive composer session. See also description of <strong>Closing the application</strong>.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Closing the application

When you close the application, system prompts to confirm. Click **Ok** to close the application. Before closing, Drive composer may:

- warn you about releasing control of the drive if the drive is controlled locally by Drive composer
- prompt you to save the workspace with unsaved changes. See **Saving the workspace with unsaved changes**.
- remind you to save your monitor data
- remind you of unfinished printing.

**Note:** If you disconnect the cable from the drive before closing Drive composer there might be a long delay in operation.

### Alternate methods to close the application

You can also close Drive composer by

- double-clicking the **System menu** icon
- selecting **Close** in the System menu
- selecting **Exit** in the File menu
- pressing the shortcut key Alt+F4.
Saving the workspace with unsaved changes

You can close Drive composer without saving the changes to workspace.

1. Go to View → Settings.
2. In the Settings window, check the option Save workspace on exit.

Figure 35. Save workspace on exit function

The function that prompts to save the workspace with unsaved changes is disabled.
System menu

You can open the System menu by

- left- or right-clicking the System menu icon
- pressing the shortcut key Alt+space bar
- right-clicking within the non-button area of the title bar.

The System menu contains the following commands:

![System menu](image)

**Figure 36. System menu**

### System menu commands description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore</td>
<td>Restores the window to its size and position which it had before it was maximized. This command is the same function as Maximize/Restore Down button in the title bar when the window is maximized.</td>
</tr>
<tr>
<td>Move</td>
<td>Allows moving the window with arrow keys. To stop moving the window, press ENTER. To cancel the move, press ESC. This function can also be performed by dragging the title bar.</td>
</tr>
<tr>
<td>Size</td>
<td>Allows resizing the window with arrow keys. To stop resizing the window, press ENTER. To cancel resizing, press ESC. This function can also be performed by dragging any of the sides or corners of the window.</td>
</tr>
<tr>
<td>Minimize</td>
<td>Reduces the window to the task bar or to the bottom of the window area. This command is the same function as the Minimize button in the title bar.</td>
</tr>
<tr>
<td>Maximize</td>
<td>Enlarges the window to fill the available space. This command is the same function as the Maximize button in the title bar when the window has not been maximized.</td>
</tr>
<tr>
<td>Close</td>
<td>Ends the Drive composer session. This command is the same function as the Close button in the title bar.</td>
</tr>
</tbody>
</table>
Main user interface components

Menu bar

The menu bar is located below the title bar. It contains the following drop-down main menus:

- File
- Edit
- View
- Tools
- Help.

Using the menu bar

- Click on a menu name to execute a command
- Use arrow keys to navigate between the menus
- Press ENTER to execute a highlighted command
- Press ESC to close a menu
- Use also shortcut keys to execute the commands.

File menu

The File menu is always located in the menu bar. See description in File menu commands description.

![File menu](image)

Figure 37. File menu → New

![File menu](image)

Figure 38. File menu → Open
### File menu commands description

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-command</th>
<th>Description</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New..</td>
<td>Custom parameter set</td>
<td>Creates a new parameter set window. You can also set this window as the default.</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open..</td>
<td>Open the latest saved workspace</td>
<td>Opens the latest saved workspace.</td>
<td>Ctrl+L</td>
</tr>
<tr>
<td>Open Workspace</td>
<td></td>
<td>Opens a new window where you can select the saved workspace to be opened.</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Custom parameter file</td>
<td></td>
<td>Opens a new window where you can open the saved custom parameter file.</td>
<td>Alt+W</td>
</tr>
<tr>
<td>Monitor file</td>
<td></td>
<td>Opens a window to open the parameter file for monitoring.</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>Parameter file</td>
<td></td>
<td>Opens a new window where you can select the saved parameter file to be opened.</td>
<td>Alt+P</td>
</tr>
<tr>
<td>Open support package</td>
<td></td>
<td>Opens a new window where you can select the saved support package file to be opened.</td>
<td>-</td>
</tr>
<tr>
<td>Save workspace</td>
<td>-</td>
<td>Saves the active workspace of a file.</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Save workspace as default</td>
<td>-</td>
<td>Saves the active workspace to default workspace. The default workspace opens automatically when Drive composer is opened.</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Exit</td>
<td>-</td>
<td>Ends the Drive composer session.</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Print</td>
<td>-</td>
<td>Prints the parameter screen.</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Print real-time monitor view (pro)</td>
<td>-</td>
<td>Prints the monitor screen.</td>
<td>-</td>
</tr>
</tbody>
</table>
Edit menu

The Edit menu is always located in the menu bar.

![Edit menu](image1)

*Figure 39. Edit menu*

The menu contains the language commands with which you can select the language for the Drive composer user interface.

**Note:** Restart the Drive composer to see the language changes.

View menu

The View menu is always located in the menu bar.

![View menu](image2)

*Figure 40. View menu*
### View menu commands description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal text font size</td>
<td>Selects normal font size. <strong>Note:</strong> The change in the font size does not affect the size of the monitor window font.</td>
<td>Ctrl+F7</td>
</tr>
<tr>
<td>Large text font size</td>
<td>Selects larger font size.</td>
<td>Ctrl+F8</td>
</tr>
<tr>
<td>The largest text font size</td>
<td>Selects the largest font size. You can also change the font sizes using the following A-letter icons.</td>
<td>Ctrl+F9</td>
</tr>
<tr>
<td>Tabs</td>
<td>Changes working area to be viewed as tabs. <strong>Note:</strong> The monitor window cannot be tabbed.</td>
<td>Alt+T</td>
</tr>
<tr>
<td>Floating windows</td>
<td>Changes working area to a separate window. <strong>Note:</strong> The monitor window cannot be a floating window.</td>
<td>Alt+F</td>
</tr>
<tr>
<td>Tile horizontally</td>
<td>Changes floating windows to be tiled horizontally.</td>
<td>Alt+H</td>
</tr>
<tr>
<td>Tile vertically</td>
<td>Changes floating windows to be tiled vertically.</td>
<td>Alt+V</td>
</tr>
<tr>
<td>Cascade</td>
<td>Changes floating windows to cascade. You can resize and freely locate the cascaded windows in the working area.</td>
<td>Alt+C</td>
</tr>
<tr>
<td>Settings</td>
<td>Defines language and connection configuration. Enables to • save workspace settings • disable local control • share connection to the same drive Allows to • select temporary file location • set the appropriate Drive Installed Base server location.</td>
<td>-</td>
</tr>
<tr>
<td>Disconnect</td>
<td>Disconnects Drive composer from the drive.</td>
<td>Ctrl+Q</td>
</tr>
<tr>
<td>Refresh</td>
<td>Creates a new connection between Drive composer and the drive, which means, uploading parameter information from a single drive and creating a new connection with multidrives.</td>
<td>Ctrl+R</td>
</tr>
</tbody>
</table>
Main user interface components

## Tools menu

The Tools menu is located in the menu bar. The commands of the Tools menu may vary between different software versions and drives.

![Tools menu](image)

### Tools menu commands description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Safety Configuration Report (pro)</td>
<td>Prints safety functions configuration report if FSO module is installed.</td>
<td>-</td>
</tr>
<tr>
<td>Backup network (pro)</td>
<td>Creates backup of all connected drives in a PC tool network.</td>
<td>-</td>
</tr>
<tr>
<td>Compare drive data (pro)</td>
<td>Compares parameters of two drives or a parameter file and a drive or two parameter files.</td>
<td>-</td>
</tr>
<tr>
<td>PSL2 data logger (pro)</td>
<td>Uploads PSL2 data logger files from the drive flash memory to PC local hard drive. This option is applicable only in BCU-x2 control unit. See Using the PSL2 data logger (pro) on page 189.</td>
<td>-</td>
</tr>
<tr>
<td>PSL2 Data Viewer (pro)</td>
<td>Opens and views contents of the uploaded PSL2 data logger files in the PC local hard drive. See Using the PSL2 data viewer (pro) on page 191.</td>
<td>-</td>
</tr>
<tr>
<td>Drive Text Editor (pro)</td>
<td>Allows reading texts from the drive to make changes and to update texts to the drive. See Using the Drive text editor on page 183.</td>
<td>-</td>
</tr>
<tr>
<td>Drive Parameter Conversion Tool (pro)</td>
<td>Converts parameters. See Using the Drive parameter conversion tool (pro) on page 186.</td>
<td>Ctrl+Alt+P</td>
</tr>
<tr>
<td>EDS Export (pro)</td>
<td>Creates EDS files of a connected drive.</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Application symbols (pro)</td>
<td>Shows symbols exported from Control Builder Plus application to the drive. The application list will remain empty if drive does not have Control Builder Plus.</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Keyboard shortcut</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Macro (pro)</td>
<td>Sets parameter values to multiple networked drives when custom window functionality is not sufficient. See Macro (pro) (page 124) and Macro commands (page 125).</td>
<td>Alt+M</td>
</tr>
<tr>
<td>Register drive</td>
<td>Registers an ABB drive in the Drive Installed Base service (DIB) portal. See Registering an ABB drive to Drive Installed Base service (page 156).</td>
<td>-</td>
</tr>
<tr>
<td>Search drive from Drive Installed Base</td>
<td>Retrieves information of a registered ABB drive in Drive Installed Base. You will need access permissions to Drive Installed Base portal. See Searching a registered ABB drive in Drive Installed Base (page 161).</td>
<td>-</td>
</tr>
<tr>
<td>Create service report</td>
<td>Creates service report of a registered ABB drive in Drive Installed Base. You will need access permissions to Drive Installed Base portal. See Creating a service report from Drive Installed Base (page 164).</td>
<td>-</td>
</tr>
<tr>
<td>FSO firmware loader</td>
<td>Updates FSO firmware version to the current version. You will need access to FSO module. See Updating FSO firmware (page 148).</td>
<td>-</td>
</tr>
</tbody>
</table>
Main user interface components

Help menu

The Help menu is always located in the menu bar.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content</td>
<td>Opens Drive composer user manual as a PDF file.</td>
<td>F1</td>
</tr>
<tr>
<td>Firmware manual</td>
<td>Opens firmware manual of the connected drive type in a separate window as a PDF file. If you selected a parameter or some other significant item when you clicked this command or pressed F3 key, the appropriate chapter in the firmware manual is displayed. You can also read the firmware manual of the connected drive by clicking on the i button.</td>
<td>F3</td>
</tr>
<tr>
<td>Make support package</td>
<td>Creates a single file that can be sent to the local ABB support contact if you need any support.</td>
<td>-</td>
</tr>
<tr>
<td>Enter licence code (pro)</td>
<td>Registers the Drive composer license code, during the first-time launch of the software. See steps for Registering Drive composer pro on page 29.</td>
<td>-</td>
</tr>
<tr>
<td>About the product</td>
<td>Displays Drive composer software version and copyright text.</td>
<td>-</td>
</tr>
</tbody>
</table>
Drive control panel

The drive control panel is located below the menu bar. It has buttons for controlling a connected drive. It also shows the status of the drive.

![Drive control panel buttons/items](image)

### Drive control panel buttons/items description

<table>
<thead>
<tr>
<th>Item no.</th>
<th>Button name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>-</td>
<td>Name and node number of the currently controlled drive.</td>
</tr>
<tr>
<td>2</td>
<td>-</td>
<td>Motor icon (clockwise open circle arrow) for drive status indication. For description, see Drives list panel: status indication (page 64)</td>
</tr>
<tr>
<td>3</td>
<td>Control</td>
<td>Allows controlling the selected drive through Drive composer or allows releasing control of the drive.</td>
</tr>
<tr>
<td>4</td>
<td>Reset fault</td>
<td>Sends a reset command to the drive. If the fault is not active, the drive clears it.</td>
</tr>
<tr>
<td>5</td>
<td>Start</td>
<td>Starts the currently controlled drive. A motor connected to the drive starts rotating according to the set reference value.</td>
</tr>
<tr>
<td>6</td>
<td>Stop</td>
<td>Stops rotation of the motor connected to the currently controlled drive.</td>
</tr>
<tr>
<td>7</td>
<td>Coast stop</td>
<td>Coasts the currently controlled drive to stop.</td>
</tr>
<tr>
<td>8</td>
<td>Reference</td>
<td>Allows entering a new reference value. The Reference field will show the current reference value used in the drive. When you click the Reference field, a tooltip shows the minimum and maximum limits for the reference and current/actual reference value.</td>
</tr>
<tr>
<td>9</td>
<td>Set</td>
<td>Enforces the value in the reference value field to the currently controlled drive. You can also perform the same command by pressing ENTER.</td>
</tr>
<tr>
<td>10</td>
<td>Active reference</td>
<td>Displays the active reference value.</td>
</tr>
<tr>
<td>11</td>
<td>Step</td>
<td>Activates step cycle with the reference value.</td>
</tr>
</tbody>
</table>

For reverse direction, set the value manually with negative (-) sign.
Main user interface components

Using the drive control panel to start the drive

1. Set the drive parameter values necessary to start the drive. See firmware manual of the drive.
2. Click Control button.
   The control box indicator changes to LOC.
3. Enter a reference value and press ENTER or click the Set button.
4. Click Start.
   The drive starts. The indicator box arrow changes to green.

Note: Limit settings in parameter group 30 affect the reference limits.
Drives list panel

The drive list panel shows all connected drives and open files. The drives status is indicated with a motor icon (clockwise open circle arrow). For description of status, see *Drives list panel: status indication*.

![Drive list panel: Connected drives and context menu items](image)

*Figure 44. Drive list panel: Connected drives and context menu items*

When you click on a connected drive type, a pop-up window/context menu appears with different drive view types.

<table>
<thead>
<tr>
<th>Drive view</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameters</td>
<td>See <em>Parameter window</em>.</td>
</tr>
<tr>
<td>Amplitude logger</td>
<td>See <em>Amplitude logger (pro)</em>.</td>
</tr>
<tr>
<td>Datalogger</td>
<td>See <em>Datalogger (pro)</em>.</td>
</tr>
<tr>
<td>Adaptive Programming</td>
<td>See <em>Adaptive programming</em>.</td>
</tr>
<tr>
<td>Diagrams</td>
<td>See <em>Control diagrams (pro)</em>.</td>
</tr>
<tr>
<td>System info</td>
<td>See <em>System info</em>.</td>
</tr>
<tr>
<td>Event logger</td>
<td>See <em>Event logger</em>.</td>
</tr>
<tr>
<td>Backup/restore</td>
<td>See <em>Using Drive Installed Base service</em> and <em>Restoring a drive</em>.</td>
</tr>
<tr>
<td>Register drive</td>
<td>See <em>Registering an ABB drive to Drive Installed Base service</em>.</td>
</tr>
<tr>
<td>Search drive from Drive Installed Base</td>
<td>See <em>Searching a registered ABB drive in Drive Installed Base</em>.</td>
</tr>
<tr>
<td>Create service report</td>
<td>See <em>Creating a service report from Drive Installed Base</em>.</td>
</tr>
</tbody>
</table>

You can open those views either as new tabs or floating windows. If an active window is associated with a drive or a file, the corresponding tree item is highlighted in the drive list.
### Drives list panel: status indication

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stopped drive</td>
<td>A Grey circle arrow indicates a stopped drive.</td>
</tr>
<tr>
<td>Running drive</td>
<td>A green circle arrow indicates a running drive.</td>
</tr>
<tr>
<td>Faulty drive</td>
<td>A red circle with a white cross (x) indicates a faulty drive.</td>
</tr>
<tr>
<td>Alarm</td>
<td>An orange background means that a drive has an alarm.</td>
</tr>
<tr>
<td>Broken connection</td>
<td>A red broken line (— / ——) means that the connection to a drive has broken.</td>
</tr>
<tr>
<td>RADIUS authentication enabled</td>
<td>A lock symbol next to the Drive name means drive is enabled with RADIUS authentication and you must login for specific operations of the drive.</td>
</tr>
</tbody>
</table>
Working area

The working area shows the following views:
- Parameter windows
- Custom parameter windows
- Event logger
- System info
- Control diagrams
- Assistants, and so on.

Using the working area

In the working area, you can
- use either tabs or floating windows
- adjust the size of the working area by dragging the white separating line up/down
- adjust the size of the drive list to the left/right
- resize the windows that are not maximized by dragging any corner
- scroll the content using scroll bars on the side or bottom of a window.

The user interface is tabbed by default. You can change the order of tabs by dragging them. You can open tabs for a single drive or for multiple drives.

![Figure 45. Working area: Tabbed user interface]

You can set the working area to a floating window. For example, parameter window, event logger, system info, etc. can be shown as floating windows. You can also tile the floating windows vertically or horizontally, or cascade using the View menu commands.
Figure 46. Working area: Floating windows
Parameter window

Contents of this chapter

This chapter describes the parameter and custom parameter windows.

See topics:

Parameter window overview .......................................................... 68
Parameter window command icons ............................................... 69
Parameter window: view parameters .............................................. 70
Parameters list representation ....................................................... 70
Navigating parameters and groups ............................................... 71
Updating parameter values ......................................................... 71
Hidden parameters ...................................................................... 71
Alternate formats to view parameters ......................................... 71
Viewing bit names ....................................................................... 72
Pointer parameters overview ....................................................... 74
Inverting a bit pointer .................................................................. 75
Setting fieldbus data in/out parameters ...................................... 76
Binary parameters ....................................................................... 78
Search for groups and parameters .............................................. 79
Custom parameter window ............................................................ 80
Custom parameter window features .......................................... 80
Saving custom parameter window .............................................. 80
Viewing copied parameter values .............................................. 81
Adding parameters to a custom parameter window ...................... 81
Working with offline files ............................................................. 84
Types of offline files ................................................................... 84
Saving parameters to a parameter file ......................................... 84
Opening a parameter file (entry) .................................................. 85
Opening an offline file containing parameter values (pro) ............. 85
Downloading parameter values to a drive .................................. 85
Comparing drive data (pro) ........................................................... 86
User set functionality (Pro) ........................................................... 88
Parameter window overview

The parameter window view displays parameter groups, parameters and their values for the associated drive or a file. The working area can show several parameter windows. The headline of each parameter window shows which drive it belongs to.

- With Drive composer entry, the parameter window opens only when the drive is connected.

- With Drive composer pro, the parameter window opens by clicking on the selected drive in the drive list panel and selecting Parameters.

![Parameter window: Open drive parameters](image)
## Parameter window command icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Expands/collapses parameter groups. When parameter groups are expanded, all parameter values are read once from the drive.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Saves parameters to a file. Saves visible parameters to a file. File extension is dcparams(bak).</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Enables User set function and allows to add, remove, copy and save User set parameters.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Enables you to search parameter lists with a keyword. Search is activated/deactivated by clicking the Filter check box. When the Filter check box is unchecked all parameters are seen. <strong>Note:</strong> If parameter groups have not been expanded, the first search takes about 30…60 seconds.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to select/deselect columns to be seen in a parameter window.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Parameters are updated only when a group is opened. With the Enable updating function it is possible to set all open and visible groups to be updated automatically. Parameters that have been set to be updated automatically have a yellow background.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to download parameters from a file to a drive. With a custom parameter window allows downloading offline values to a drive.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Enables you to change the window target, which is useful if you have Drive composer pro and you have to check certain parameters of another drive. Included only in custom parameter windows.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Provides you with a list of all user-changed parameters if you click the check box. These parameters have an orange background.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Allows you to add or remove one parameter or signal or several parameters or signals to/from a custom parameter window.</td>
</tr>
</tbody>
</table>
Parameter window: view parameters

The parameter window contains different types of parameters. Some of these types are identified by colors or bold fonts as shown in the table below:

<table>
<thead>
<tr>
<th>Illustration</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>20.3 Ext1 In1 source</td>
<td>D1 Normal parameters</td>
</tr>
<tr>
<td>1.1 Motor speed used</td>
<td>0.00 rpm Signals (bold)</td>
</tr>
<tr>
<td>10.21 RO status</td>
<td>Bit names of a parameter can be seen by double-clicking on the parameter. New window opens.</td>
</tr>
<tr>
<td>11.6 DIO1 output source</td>
<td>P.10.1.1 Parameter value is set from another parameter, for example, parameter group 10, index 1, bit 1.</td>
</tr>
<tr>
<td>11.6 DIO1 output source</td>
<td>P.10.1.1 - Parameter value is an inverted bit of another parameter, group 10, index 1, bit 1.</td>
</tr>
<tr>
<td>20.1 Ext1 commands</td>
<td>In1 Start User has changed the value of a parameter (shown with an orange background).</td>
</tr>
</tbody>
</table>
Note:
- The most common type is the regular parameter.
- Parameters are normally readable and writable. However, when the drive is running, some parameters may be write-protected.
- The parameter view shows: Parameter names, values, units, default values and different user sets. The number of user sets depends on the drive type.
- The value of a parameter is read only once. If it is necessary to update this value, right-click and select Refresh the parameter.
- You can set all visible parameters to update automatically by clicking the Enable updating button.
- You cannot modify values of signals. If you attempt to modify a signal, an error is indicated. Signals are updated cyclically in the parameter window.
- Parameter signals are also updated frequently, but you can modify these values.

Navigating parameters and groups

- **Updating parameter values**
  Parameter values are updated if they are modified.
  - To modify a parameter value, double-click the parameter or press ENTER on the highlighted parameter.
  - To update a parameter group value, right-click the group name and select Refresh group parameters.

- **Hidden parameters**
  In special cases, hidden parameters and groups become available by modifying some parameter values. The View → Refresh command updates the whole parameter table. For example, group 51 FBA A Settings: When the adapter module is enabled in group 50, you can see parameter names by selecting View → Refresh.
  Note: Close the parameter window before refreshing and open again after refreshing.

- **Alternate formats to view parameters**
  There are five alternative formats in which parameters are shown: default, binary, hexadecimal, integer and float format.
  To change the format of a parameter, right-click and select either Use default format, Use binary format, Use hexadecimal format, Use integer format or Use float format.
  You can change the widths of the columns by dragging the vertical lines between the column headers.
Viewing bit names

To see the bit names of certain binary parameters, double-click the value field box. For example, see the below parameter *10.1 DI status*.

![Parameter window](image)

*Figure 49. Navigating parameters and groups: Parameter bit names*

To reset a parameter, right-click and select **Reset to default**.

Parameter values are read once when a group is opened. You can set independent parameters from different groups to the Auto-update mode by right-clicking and selecting **Add to auto-update**. The parameters that are updated automatically are seen with a yellow background as shown in the following figure.

**Note:** Signals are automatically updated cyclically.
Parameters or signals can be sent to the monitor window by right-clicking them and selecting **Send to monitor**. Parameters can be copied to a custom parameter window by right-clicking them and selecting **Copy**. In addition, you can drag and drop parameters to a custom parameter window.
Pointer parameters overview

Pointer parameter is a special type of parameter that reads value from the parameter it points to. Depending on the pointer parameter, value or bit pointer, its target can be another parameter or one of its bits. You can assign Active (false) or Inactive (true) status to some pointer parameters.

Figure 51. Pointer parameters: Constant value

Typically, common settings are offered as a selection list. If the selection list does not offer the correct pointer, you can set the pointer by selecting Other... from a selection list. Select a parameter from the list for a value pointer and then its bit from 0 to 31 for a bit pointer.

You can also enter a value manually by selecting the Edit manually check box. Use the value form P.#.#.#, where the first # is the parameter group number, the second # is the parameter number and the third # is the bit number without leading zeros (for example P.2.1.2). The constant values are Active (false) or Inactive (true).
**Inverting a bit pointer**

In the Set pointer parameter window, select Invert value check box.

Figure 52. Pointer parameters: Inverting a bit pointer value

The inverted bit pointer value is shown with the minus sign at the end of the parameter.

Figure 53. Pointer parameters: Inverted bit pointer value with minus sign
Setting fieldbus data in/out parameters

Process data transferred to and from the drive/PLC is set with parameter groups 52 and 53. With an ACS880 drive it is possible to select the data type for each selected parameter/signal in these groups.

1. Double-click FBA data in/out parameter and select Other.

![Figure 54. Setting fieldbus data in/out parameters: Select data type](image-url)
2. Select the format in which the value is handled: 16-bit, 32-bit or floating point format.

![Parameter window](image)

**Figure 55. Setting fieldbus data in/out parameters: Select format**

In the parameter window the selections are shown inside brackets: [16], [32] or [F].

**Figure 56. Setting fieldbus data in/out parameters: Formats shown inside brackets**

**Note:**

- The floating point or 32-bit value reserves two slots in the configuration. Consequently, if you try to select a value for parameter 52.04 as in the figure above, a Parwrite failed error message appears. See the scalings of parameters/signals in *ACS880 primary control program firmware manual* (AUA0000085967 [English]).

- Always check the parameter mapping from the manual of the used fieldbus protocol. Example, FENA-01/-11/-21 Ethernet adapter module user's manual (3AUA0000093568 [English]) or FPBA-01 PROFIBUS DP adapter module user's manual (3AFE68573271 [English]).
**Binary parameters**

Binary parameters have a special meaning for each of their bits. These parameters are modified in a special Set binary parameter dialog. You can modify the value numerically in binary, hexadecimal or decimal format.

- One way to modify the value in the field is, double-click the value field for each bit. Some bits may be greyed out or disabled to edit.
- Another way to modify a bit is to type the bit value directly to the New value [bin] / [hex] / [dec] field.

You can view the binary format of signal values in a similar dialog.

![Binary parameter editor](image)

*Figure 57. Binary parameter editor*
**Search for groups and parameters**

You can search the names of parameters and groups inside the parameter window. The search result is a list of all parameters matching the search text criteria. For example, all torque-related parameters can be found by entering search criteria “torque” in the Enter keyword field and clicking the Filter check box. To uncheck the Filter box, click it again.

**Figure 58. Search groups and parameters: example**

**Note:** The first search takes about 30…60 seconds, because Drive composer goes through the whole parameter structure. The next searches are fast. All searches are in memory of the PC as long as Drive composer is on.
Custom parameter window

In Drive composer you can customize parameter windows by:
• dragging and dropping parameters/signals
• changing parameter values
• copying from the main parameter window or from any other custom parameter window
• renaming custom parameter windows.

For example, you can
• collect all the typical parameters used in a quick start-up to one window or
• create separate windows for separate functions (example: references, limits, ACS880 I/O).

Custom parameter window features

The Custom parameter window
• opens automatically when a connection to a drive is made because they are saved with the workplace.
• can be used both in tabbed and floating windows environment.
• can also be opened separately.

Saving custom parameter window

To save a separately opened custom parameter window to a file, select Save parameters to file. Note that changed values in the Offline value column are also saved. You can use the saved file for parameterization of another drive. You can also send this file to other users to open the file with Drive composer and view the parameters list.

Note: When you saved a custom parameter window, the actual drive values of the Value column are copied to the Offline value column. During loading, the values in the Offline value column are shown in comparison with the current actual values. From the saved customer parameter window file you can copy the values of the Offline value column to another drive by clicking the Download to device button.

![Download to device button](image)

Figure 59. Custom parameter window: Download to device button
Viewing copied parameter values

In a network of drives, you can create a custom parameter window including parameters/signals selected from different drives. To have a view where all parameters are from one drive, click the Change drive button and select the drive.

To see the value of a parameter/signal used in another drive, right-click the parameter/signal and select Change drive.

Adding parameters to a custom parameter window

The following example shows how to:

• create a new custom parameter window
• add parameters to a custom parameter window
• modify the Offline value column in the custom parameter window
• copy/download parameters to a drive.

1. Click File → New → Custom parameter set.
2. Name the custom parameter window.

![Name of window](image)

Figure 62. Custom parameter set: Name of window

3. Click **Add** button to add parameters/signals to the new custom parameter window or copy/paste from other parameter window.

![Add parameter](image)

Figure 63. Custom parameter set: Add parameter

4. For example, select minimum and maximum speed values from the parameter group **30 Limits** and click **Apply changes**.

![Add minimum and maximum values](image)

Figure 64. Custom parameter set: Add minimum and maximum values
5. The **Value** column shows the values of connected drive. Enter values in the **Offline value** column to be same as **Value** column or you can type new values.

![Figure 65. Custom parameter set: Change Offline values](image)

6. Click on **Save parameters to file** icon to save the custom parameter window.

![Figure 66. Custom parameter set: Save parameter to file](image)

Drive composer saves to file the values in the **Offline value** column. If the **Offline value** column was empty, then values in the **Values** column is saved.

7. When connecting the next drive open the created custom parameter window by clicking **File → Open → Custom parameter file**.

You can now see the online values of the new drive.

8. Copy the offline parameter values to a new drive by clicking on **Download to device** icon.

![Figure 67. Custom parameter set: Copy offline parameter values to a new drive](image)
Working with offline files

- **Types of offline files**

There are two types of offline files containing parameter information.
- **Parameter file** is an offline file containing all parameter values.
- **Support package** is an offline file package that contains a collection of drive information, including all parameter values. You can open a support package file using Drive composer pro. For further information on support package, see chapter *Diagnostics* on page 113.

- **Saving parameters to a parameter file**

1. Connect Drive composer to a drive and open the parameter window.
2. In the parameter window, click **Save parameters to file** icon.

![Figure 68. Save parameters to file](image)

3. Select a folder, enter a name for the *dcparamsbak* file and click **Save**.

![Figure 69. Save parameters to file: Save the dcparamsbak file](image)
Opening a parameter file (entry)
To open a parameter file and view the parameter values offline, proceed as follows:
1. Connect to a drive.
2. Go to File → Open → Parameter file.
3. Parameter window displays.

Opening an offline file containing parameter values (pro)
To open a file and view the parameter values offline, proceed as follows:
1. Connect to a drive.
2. Go to File → Open → Parameter file / Open Support package.
3. New item appears under File drives.
4. Select Parameters to open parameter window.

Downloading parameter values to a drive
**Note:** The operation do not perform full restore. Only visible parameters and ID run results are copied to a drive when the download command is used. Also, drive type and software version are not checked when downloading parameter values from an offline file to a drive. For further information on Restore function, see chapter Other functions on page 155.
To download offline parameter values to a drive, proceed as follows:
1. Open an offline parameter window.
2. If you have multiple drives connected online, click Change drive to select a drive you want to download the parameters.
3. Download the parameter values to a drive by clicking the **Download to device** icon.

![Parameter window](image)

**Figure 73. Downloading parameter values: Download to device icon**

4. If you get a message indicating that the upload of parameter values is going on, click **OK**.

You will get a report of the operation at the end of the restore operation.

5. Check the parameters that are failed during the restore operation.

### Comparing drive data (pro)

**Note:** Both versions of Drive composer have **Not at default** function for listing user-changed parameters. The **Compare drive data** function compares parameter values.

With Drive composer pro you can compare parameters between

- two drives
- two parameter files
- drive and parameter file.

1. Go to **Tools → Compare drive data (Alt+C)**.

![Compare drive data](image)

**Figure 74. Comparing drive parameters**

2. In a PC tool network, select drives from **Drive A** and **Drive B** drop-down menus.

3. To open a parameter file for comparison, click **Open**.

4. To see the parameter list without differences, deactivate **Show differences** check box.

5. Click **Start compare**.

**Note:** The operation may take some time to compare two different parameter structures.
The following figure shows an example of the result.

![Parameter window](image)

**Figure 75. Comparing drive parameters: Result of comparison**

6. To export the result to a text (*.txt) file, click the **Export**.

**Note:** Click the >> << buttons to copy parameter values from Drive A to Drive B.
User set functionality (Pro)

User set overview

User set or user parameter set functionality is an interface to work with user set parameters. The user set parameters can be saved to the permanent memory of the drive and recalled using specific parameters. Digital inputs allow switching between the user sets. Multiple user sets can be used to control multiple motors through a single drive.

With the User set function, you can:
- create user sets (see page 91)
- save user sets (see page 92)
- compare user set values side-by-side
- copy parameter values between user sets (see page 92)
- delete user sets (see page 93).

User set system requirements

The User set functionality is available only if the following requirements are satisfied:
- PC must have the configurations listed in System requirements on page 21.
- Virtual drives software must be installed in your PC, otherwise the User set function is hidden.
- You must have a valid Virtual drives license.
- You must register the Virtual drives license with ABB license manager. Note that ABB license manager is installer together with the Virtual drives software.

Limitations

The User set function
- is supported only in ACS880 drive
- works only in the parameter window from where it was enabled.
- works only in one parameter window, i.e., you must disable the function (if enabled) in any other parameter window to allow the function in the current window.
Starting the user set function

To start or stop the user set function,

1. In the Drive composer pro Welcome window, make sure that the Virtual drive enabled option is not checked. Click Connect.

2. Open the Parameters file or the parameters backup file. The User set function is visible in the parameter window tool bar.

3. Click the User set drop down menu. By default the User set function is disabled.
4. Click on the **Enable** switch.
   - If drive firmware version or the parameter backup file is deviated from the virtual drive, then drive composer notifies that User set parameters may be incompatible for editing. Note that small deviations may not affect the User set functionality. Click **Yes**, to proceed.

   ![Error dialog](image)

   The minor version of the drive firmware is not compatible with Virtual drive.
   There might be incompatible parameters for User set editing. Do you want to continue?
   
   - No
   - Yes

   - If drive firmware version is not compatible with the virtual drive version, then User set functionality can not be started. Click **OK**, to close the window. You can either update the Virtual drive version or contact your local ABB representative for support.

   ![Error dialog](image)

   Error
   The drive firmware is not compatible with the Virtual drive. Please update the compatible Virtual drive firmware to enable User set editing.
   
   - OK

5. User set initialization starts. If initialization is complete, click **OK**.

   ![Success dialog](image)

   User sets for ACS880 [0][1] have been initialized.
   
   - OK

6. User set function is enabled. The enable switch color appears in blue.

   ![User set function enabled](image)

   **Note:** To disable or stop the User set function, click the enable switch again. The switch color appears in Grey.

   If user sets was configured in the connected drive or saved in the parameter backup file, the available user set is displayed in different columns next to each other.
Creating user set

1. In the User set menu, click Add.

2. From the user set options, select the appropriate option and click OK.

- Uses defaults—takes the parameter values from defaults
- Copy from parameter values—copies the current parameter values
- Copy from user set—copies from another user set.

The new user set is displayed in the parameter window.

Note: If the maximum number of supported user sets is reached, the Add option is disabled in the user set menu. The maximum number of user sets is determined by the drive firmware. For example, the current virtual drive firmware version 2.82 supports four user sets.

Active and unsaved user set

The active user set is highlighted in blue in the header row of the parameter window. To change the active user set, configure parameter 96.11 User set save/load = Load user set X.

The unsaved user set is highlighted with * symbol in the header row of the parameter window.
## Saving user set

1. In the User set menu, click **Save**.

2. User sets are saved. Click **OK**.

### Note:
- When all user sets are saved, the Save option is disabled in the User set menu.
- If there are unsaved user sets at the time of disabling the user set function, closing the parameter window or exiting Drive composer, a reminder appears to save the unsaved user set(s).
- You can also save user sets using parameter 96.11 *User set save/load*. ABB recommends to save user sets using the Save option in the User set menu.

## Copying user set parameter values

You can copy specific parameter values between user sets.

### Note:
Parameter(s) in the backup file only can be used as the source of copy operation.

1. In the parameters window, select the parameters to copy.

   ![Parameter window](image)

   - **Note:** If no parameters are selected, the Copy parameter option will be disabled.

2. In the User set menu, click **Copy parameters**.
3. In the Copy parameters window, select the source and destination parameters. Click OK.

![Copy parameters window]

The selected values in User Set1 is copied to User Set2.

---

**Removing user set**

1. In the User set menu, click Remove.

![User set menu]

**Note:** The Remove option is disabled if no user sets are available.

2. Select user set(s) to remove and click Remove.

![Remove user sets dialog]

The selected user set is removed.
Show/hide user set

You can show/hide a user set in the columns list.

1. In the Parameter window, click **Select columns**.

2. Check/uncheck the desired User set to show/hide.

User set parameters limitation

- Parameters not valid for user set are disabled and appears as Grey boxes. For information of invalid user set parameters, see the firmware manual.
- All signal parameters are disabled, by default.

- User set parameters with different unit/min/max/default values are displayed in different rows.
Monitor window

Contents of this chapter

This chapter describes the monitor window and its use.

See topics:

Monitor window overview ................................................................. 95
Resizing the monitor window ............................................................ 96
Adding parameters/signals for monitoring ........................................ 97
Monitor window components ............................................................ 98
Configuration and control settings .................................................... 99
Monitor controls .............................................................................. 100
Active signal area overview .............................................................. 100
Zooming the graph .......................................................................... 101
Panning the graph ........................................................................... 101
Legend area functions ....................................................................... 102
Graph area functions ........................................................................ 103
Double cursor tool ........................................................................... 103

Monitor window overview

In Drive composer you can monitor the operation of connected drives. In the online mode, the monitor window shows signal values in graphical or numerical format. The monitor data can be saved to a file for later use.

With Drive composer entry you can monitor up to 8 signals.

With Drive composer pro you can monitor up to 26 signals. If Drive composer pro is used with an ACS880 drive, it is possible to monitor 1 signal per 1-ms time interval.

The monitor window is always a tabbed window, in other words, there is only one monitor window available.
User-made monitoring settings (selected signals, y-scalings for signals, pen colors, number of grids etc.) are saved by default. In other words, when you open the tool, there are always the latest settings available.

### Resizing the monitor window

When you start Drive composer the monitor window is in the minimized position and you have to lift it in the following way before you can start monitoring.

- You can resize the monitor window by clicking the title bar with the primary mouse button and dragging it upwards.

![Figure 76. Resizing monitor window](image)

- You can resize the monitor window with the Minimize, Maximize and Split monitor buttons included in the Monitor menu bar.
- You can lift the monitor window by clicking the arrow buttons in the title bar.
Adding parameters/signals for monitoring

There are two ways to add parameters/signals to the monitor window:

- Right-click a parameter/signal in the parameter window and select **Send to monitor**.

![Send to monitor command](image)

**Figure 77. Monitor window: Send to monitor command**

- Click the **Add signal** icon on the configurations and control area in the monitor window.

![Configuration and control area icons](image)

**Figure 78. Monitor window: Configuration and control area icons**

Select parameters from the Drive parameters list by double-clicking them or select a parameter and click **Add** button. You can add maximum of 26 parameters in Drive composer pro and eight parameters in Drive composer entry.

**Note:**

- With Drive composer pro you can select signals/parameters from different drives. Change the drive from the Drive list as shown in the following figure.
- In the PC tool network via Ethernet or with a panelbus, ABB recommends you to select **Disable polling** to enable the best sampling result for monitoring. The status of the drive(s) cannot be read before you have unselected **Disable polling**.
Figure 79. Monitor window: Drive list

The selected signals appear in the legend area.

To change the scalings of the y-axis of selected parameters/signals, click the Min or Max column in the legend area.

Active signals can be changed from the pull-down menu on the left side of the graph area.

All the other signal scalings are performed on the right side of the legend area. The right side y-scalings can be hidden by removing the check mark from the Y-scale column check box.

Figure 80. Monitor window: Changing pen color and style in the legend area

You can change the color and thickness of the pen only after you have minimized, that is hidden the legend area with the Arrow button on the left (see the figure above).

To change the scalings of the y-axis for selected parameters/signals, click the Min or Max column in the legend area.

Monitor window components

The monitor window consists of the following parts:

- Configuration and control settings
- Graph area
- Y-axis
- X-axis
- Legend area
- Limit, color settings.
## Configuration and control settings

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Icon](image1.png) | Opens the saved monitored file to the graph area, which can be done only after monitoring has been stopped. File extension is *.dcemon or *.dcpmon.  
**Note:** If you have an online connection and want to start a new monitoring session after viewing opened monitored data, you can click the Monitor configuration icon. |
| ![Icon](image2.png) | Saves the accumulated monitor data to a monitored data file. File extension is *.dcemon for the entry version and *.dcpmon for the pro version. |
| ![Icon](image3.png) | Chart configuration can be used to set the colors for grids, number of grids, background color, color of alarm pen etc. |
| ![Icon](image4.png) | Opens the Monitor settings window where you can modify the monitor settings and the select the sample interval time for monitoring. You can also set the method for starting and/or stopping monitoring (by hand/time). You have to select the HD where the saved data is stored.  
**Note:** The monitored data is saved cyclically to the selected file.  
Created monitoring configuration can be saved and restored from Monitor settings window. |
| ![Icon](image5.png) | Allows you to create an arithmetic signal for monitoring by using two signals used in monitoring. Available operations are ADD, SUB, MUL and DIV.  
**Note:** Remember to save settings in a workspace. |
| ![Icon](image6.png) | Opens a dialog where you can add or remove one signal or several signals from the monitor configuration.  
**Note:** You can use the Add signal function only when monitoring has been stopped. |
| ![Icon](image7.png) | Shows the signal values in text format. Only the values seen in graph area are included in the numeric signal value list. |
| ![Icon](image8.png) | Copies the monitoring graph to a clipboard. |
| ![Icon](image9.png) | Scales the y-axis automatically.  
**Note:** Zooming is not possible in the Autoscaling mode. |
| ![Icon](image10.png) | Resets both x- and y-axis zooming to original 100%. |
| ![Icon](image11.png) | You can export the monitored data in csv format to a PC. Exported data can analyzed with other tools. Use the Tab key for delimiting the columns. File extension is *.dcexp. |
| ![Icon](image12.png) | Aligns signals. |
| ![Icon](image13.png) | Selects or changes the drive. |
| ![Icon](image14.png) | Zooms in the x- and/or y-axis up to 1000%. |
Monitor controls

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Starts recording data in the selected drives and displaying it on the screen.</td>
</tr>
<tr>
<td></td>
<td>Pauses monitoring on the screen but monitoring continues on the background. When you click the Pause icon again, all values are seen and monitoring continues normally.</td>
</tr>
<tr>
<td></td>
<td>Stops recording data in the selected drives. The graph or numerical values remain on the screen. The graph can be saved for later purposes.</td>
</tr>
</tbody>
</table>

Active signal area overview

The Active signal area consists of functions that can be done with the selected active signal. The signal can be changed from the pull-down menu.

Figure 81. Monitor window: Active signal area

The main functions are the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Icon](image) | Allows you to see the measuring points of the active signal. See figure Monitor window: Measuring points for active signal.  
**Note:** This functionality works only if you have zoomed in enough in the graph area, that is, if the length of the x-axis is short enough. |
| ![Icon](image) | Allows you to see the numeric values of the measuring points for the active signal. See figure Monitor window: Measuring points for active signal.  
**Note:** This functionality works only if you have zoomed in enough in the graph area. |
| ![Icon](image) | Searches to the left. The following search conditions can be selected from the pull-down menu: Above, Below or Either. See figure Monitor window: Search functionality. |
| ![Icon](image) | Searches to the right. The following search conditions can be selected from the pull-down menu: Above, Below or Either. See figure Monitor window: Search functionality. |
Zooming the graph

To enlarge the graph and take a closer look at the details, follow these steps:

1. To set the starting corner for the enlargement, place the mouse cursor in the graph area and press down the primary mouse button.
2. Drag to the opposite desired corner, and release the button.
   The part of the graph that was inside the selection rectangle zooms out to fill the graph area.
3. To reset the zoom tool, click the Reset zoom icon.

You can also use the zooming tool by selecting independent values from x and y pull-down menus.

**Note:** Monitoring is paused during zooming. To continue monitoring, click the Reset zoom icon shown in the figure below.

Figure 84. Monitor window: Zoom tool

Panning the graph

The graph can be panned by dragging the graph with the right mouse button pressed down.
Legend area functions

The legend area shows selected signals. You can perform the following actions in the legend area:

- Change the color of the pen, thickness and style of the pen by minimizing the legend area and setting the values of each signal. See figure Monitor window: Legend area functions.
- Make signals visible or invisible by clicking the check box in the Visible column.
- Set a bit mask for monitoring. When you double-click the value in the Mask column, a new window opens allowing you to select bits for monitoring.
- Make Y-scalings visible or invisible by clicking the check box in the Y-scale column.
- Set values for y-axis scaling. You can modify the minimum and maximum values by clicking them and entering a new value. Press Enter to enforce the new value or press Esc to restore the value.
  
  **Note:** If you do not see immediate changes in the graph area, check that autoscaling is not enabled.
- Set alarm limits for monitored signals. The color of a signal changes when the limit in the Alarm low or Alarm high column is reached. The color and style for the pen are selected from Chart settings.
- See the double cursor tool, y1 and y2 values and y2—y1 and x2—x1 differences.

![Figure 85. Monitor window: Legend area functions](image)
Graph area functions

The monitor window and data logger window have similar graph area facilities for displaying signal values. Their usage is described here. Before Drive composer starts monitoring online, the OnLine monitor text is seen in the graph area. When monitor files are viewed, the DataFile Viewer text is seen in the monitor window.

The graph area shows the selected signal values with different colors. The x-axis represents Time and can be set from 1 to 120s. You can change the values in online monitoring mode. Scalings of the y-axis are changed in the legend area.

For data logger files, an orange arrow-head on the x-axis indicates where triggering has occurred. Data can be combined from several files to one graph.

- Double cursor tool

With the cursor tool, you can see the exact values of the signals at two positions in the graph area. You can move the position of cursors by clicking the primary mouse button down on the red cursor tool icon and moving it. While the mouse button is pressed down, you can move the cursor line to the left and right.

The time stamp of the cursor tool is shown in the header of the cursor tool. This is shown for the active signal. The time stamp changes if active signal is changed. The values for y1 and y2 are shown in the legend area. Signal value differences are shown in the column y2—y1. The time difference for x2—x1 is also shown in the figure below.

![Figure 86. Monitor window: Double cursor tool](image)
Workspace handling

Contents of this chapter
This chapter describes the workspace functionality.
See topics:

Workspace overview

Workspace consists of the user interface status, such as parameter windows and custom parameter windows.
The current workspace status can be saved to a file and restored later.

Note:
• You cannot save/restore the following status data:
  • drive control status
  • If a drive is controlled locally with Drive composer when the workspace is saved, the workspace is saved without the change in the drive control status.
  • content, status and zooming levels of a stopped, paused or running monitor.
• Do not edit a workspace or graph file. The workspace (.dcxml) and monitored data (.dcmon) files can contain binary data. For example, if the default workspace file is corrupted, Drive composer does not open. If Drive composer does not open, delete your default (.dcxml) file from the PC and open Drive composer again.
Creating a custom parameter set and using it as a default workspace

1. Make a connection to a drive.
2. Resize the monitor window to half of the screen.
3. Create a new custom parameter window by clicking File → New.. → Custom parameter set and name it “Own limit window”.

4. In the File menu, click Save workspace to save the workspace.
5. Create another custom parameter window and name it “Own reference window”.
6. Select floating windows by clicking View → Floating windows.
7. Enter keyword “Limit” in the Enter keyword field of the main parameter window.
8. Select parameters in the main parameter window and drag and drop or copy them to custom parameter window Limit.
9. Clear the search result and enter keyword “ref” in the Enter keyword field.
10. Select parameters in the main parameter window and drag and drop or copy them to custom parameter window Own reference window.
11. Close the main parameter window.
12. Click Event logger icon in the drive list on the left.
13. Click **File → Save workspace** and name it “OwnWorkspaceFor_ACS880”.

![Image of workspace save dialog]

**Figure 88. Creating workspace: Name your workspace**

14. Close the connection to the drive and make a new connection.

15. Click **File → Open.. → Open workspace** and open the workplace that you have saved.

![Image of workspace open dialog]

**Figure 89. Creating workspace: Open workspace command**

The workspace is ready to use for commissioning and maintaining drives. The workspace can also be saved as a default workspace which opens automatically when Drive composer is started.
Event logger

Contents of this chapter
This chapter describes the event logger and fault data logger view and its use.

See topics:
- Event logger view ................................................................. 109
- Fault data logger ............................................................... 111

Event logger view
The event logger view displays the event logs of a connected drive. The event logs can be faults (stopping the drive), alarms or events. With some drives there can be more data of a fault in the monitor window.

Note: Fault logger data can also be seen from other faults than the latest active faults.
1. In the drive list, click on a connected drive and select **Event logger**.

![Event logger](image)

**Figure 90. Event logger**

The event logs of the connected drive appears in a separate tab.

![Event logger view](image)

**Figure 91. Event logger view**

The event logger always relates to a single drive and resides in its window. The Icon column shows the following alarm and fault icons:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Indicates...</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Red circle with white cross" /></td>
<td>drive has a fault</td>
</tr>
<tr>
<td><img src="image" alt="Yellow triangle with exclamation mark" /></td>
<td>drive has an alarm</td>
</tr>
<tr>
<td><img src="image" alt="Grey circle/triangle" /></td>
<td>fault or alarm has disappeared from the drive</td>
</tr>
</tbody>
</table>

The time stamp for faults, alarms and events comes from the drive. You can view the sorted list of faults, alarms and events by clicking the header of the Fault column.
**Fault data logger**

The Fault data icon in the Event logger view shows that the drive has fault data that can be seen with a monitor component. The icon is visible only if the drive sports the functionality.

1. In the Event logger window, click on the icon. The message “Please wait. Loading fault data” appears. The data is loaded after the message box disappears.

2. When Drive composer prompts to save the fault data, click Yes.
3. Give a file name for the monitor file. The file is saved with .dcpmon extension.

**Note:** You can continue the normal monitoring by clicking the Monitor configuration icon in the Monitor controls box of the Data Logger window. The message “This operation will change monitor into measuring mode and restore the last used configuration. Data on display will be lost. Do you want to continue” appears.
If you clicked Yes, the monitor settings window appears. Select necessary settings and click **OK**.

Figure 93. Event logger: Monitor settings window
Diagnostics

Contents of this chapter

This chapter describes how to troubleshoot a drive with the Support package button of Drive composer and a Datalogger included in the drive. It also includes how to register an ABB drive to the Drive Installed Base (DIB) portal and create service reports.

See topics:

- Support package ................................................................. 114
- Drive application programming license .................................. 115
- System info ........................................................................ 116
- Datalogger (pro) .................................................................. 116
- Amplitude logger (pro) ............................................................ 123
- Macro (pro) .......................................................................... 124
- Macro commands ................................................................. 125
Support package

Support package is an offline package file that contains, for example, full parameter backup, system information, and event logger contents. The main purpose is to collect troubleshooting data and send it to the support personnel for analysis.

**Creating a support package**

By clicking the Support package button, you can create and save a support package file (.dcsupport format). You can also do this function from Help → Make support package.

![Support package button](image)

*Figure 94. Support package button*

**Sending a support package to Drive Installed Base**

After you saved the support package file (.dcsupport) in your PC, Drive composer prompts to send the package to Drive Installed Base. Select the server location and click Next.

![Sending offline template](image)

If package is sent, in the completed message window, click OK.
Opening a support package (pro)

You can open a Support package file in Drive composer pro by selecting File → Open → Open support package, a new File drive appears. There is similar menu available with online drives.

For further information on each module, see section System info on page 116, chapters Parameter window on page 67 and Event logger on page 109.

Drive application programming license

The drive application programming license N8010 is required for downloading and executing the program code on the ACS880 drive. In DriveComposerPro, select System info tab. Check if the appropriate license is loaded to the drive. If the required license code is not available, contact your local ABB representative.

Figure 95. System info command
System info

The System info tab provides basic information about the drive and its options, for example, drive type code and firmware version. You can also check the status of Service pack installation. See *Checking the status of Service pack* (page 182).

![System info](image)

**Figure 96. System info**

You can also set the time for the drive and name the drive.

Datalogger (pro)

ABB drives have Datalogger(s) that can record data from various signals of a drive even if the drive is not connected to a PC. A Datalogger is operated with the Datalogger view.

![Datalogger configuration](image)

**Figure 97. Datalogger configuration**

The data collecting can be stopped with a specific stop command or automatically when a triggering condition is true in the drive. After data collection stops you can read and study the data in Drive composer pro.
The Datalogger view resembles the monitor window. Normally the Datalogger view provides data from a single drive.

![Datalogger view](image)

*Figure 98. Datalogger view*
Datalogger settings

The Datalogger settings window contains the following functions:

- Datalogger commands
- Datalogger content configuration
- Datalogger trigger configuration

Datalogger commands

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄</td>
<td>Start button records data in the current logger of the drive until Datalogger is triggered or stopped.</td>
</tr>
<tr>
<td>🔴</td>
<td>Stop button ends recording immediately without any post trigger recording.</td>
</tr>
<tr>
<td>❗️</td>
<td>Trigger button triggers the associated logger in the drive. Trigger Datalogger is displayed in Datalogger status with trigger code 15.</td>
</tr>
<tr>
<td>🔄</td>
<td>Upload button moves data from the drive to PC and draws it to the monitor window. Datalogger replaces any previous data in monitor window.</td>
</tr>
<tr>
<td>🔄</td>
<td>Apply button applies monitored signal and Datalogger sampling settings.</td>
</tr>
</tbody>
</table>

Datalogger content configuration

With the Datalogger content configuration you can determine which Datalogger of a drive is used.

![Datalogger content configuration](image)

**Figure 99. Datalogger content configuration**

<table>
<thead>
<tr>
<th>Datalogger configuration commands</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logger</td>
<td>Determines which logger settings are modified. A drive has user logger(s) and factory logger(s). Factory logger settings cannot be modified.</td>
</tr>
<tr>
<td>Sampling interval</td>
<td>Determines in microseconds how often the logger reads samples of the signal values. The time level shows the available lengths of the internal cycle time of the drive. Sample interval is formed from multiplier (1-65535) and time level selection.</td>
</tr>
</tbody>
</table>
To add parameters to the logger, proceed as follows:

1. In the Datalogger screen, click \( \text{Add} \) to add parameters.

2. Select a parameter in the Drive parameters list and double-click or click Add. The parameter is added to Selected parameters.

3. To remove the parameter from Selected parameters, select the desired parameter and click Remove.

4. Click Apply changes after making the changes.

<table>
<thead>
<tr>
<th>Datalogger configuration commands</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Post trigger count</td>
<td>Specifies how many samples are stored after the triggering condition occurs when the value is smaller than Datalogger total space count. The Datalogger total space count depends on drive type, selected signal types and total signal count. If the post trigger count value is bigger than Datalogger total space count, the triggering point is not visible anymore in the Datalogger.</td>
</tr>
<tr>
<td>Sampling time</td>
<td>Shows the minimum sampling time with a selected number of signals and a selected sample interval.</td>
</tr>
<tr>
<td>Logger signals panel</td>
<td>Shows a list of signals selected to record. You can add/remove a signal by clicking the Add signal icon.</td>
</tr>
</tbody>
</table>

Figure 100. Parameter window

**Note:** The maximum number of signals that a logger can record at one time depends on the drive. Add button is disabled when maximum number of parameters are reached.
Datalogger trigger configuration

Datalogger has four triggers that can be configured to stop the Datalogger. After Datalogger has triggered, the Datalogger samples post trigger the amount of new samples.

![Datalogger trigger configuration](image)

**Figure 101. Datalogger trigger configuration**

- **Adding a trigger**

1. To modify the conditions of a trigger, select the trigger from the **Trigger** drop-down menu.
   - Trigger 1 is normally used for user logger 1, Trigger 2 for user logger 2 etc.
2. Choose the type for the triggering condition from the **Type** drop-down menu.
   - Following are the alternatives (however, not all of them are available at all times):
     - **Bit mask** stops according to the bit mask of the selected signal.
     - **Disabled** can temporarily disable a trigger condition.
     - **Falling edge** level stops according to the selected signal, triggering level and hysteresis values.
     - **Fault** stops when the drive reports a fault.
     - **Event** stops when the drive reports an event.
     - **Rising edge** level stops according to the selected signal, triggering level and hysteresis values.
     - **Warning** stops when the drive reports a warning.
3. If you use Rising edge level or Falling edge level as the type for the triggering condition, see *Using the level triggers*.
4. Click **Apply**.
Using the level triggers

When condition Rising edge level is used, the function wakes up when the actual value of the triggering signal is below the triggering level - hysteresis. Similarly, when condition Falling edge level is used, the function wakes up when the actual value of the triggering signal is above the triggering level + hysteresis.

| Rising edge | Triggering signal is below the triggering level when the Datalogger is started: Triggering occurs when the signal goes above the triggering level. Triggering signal is above the triggering level when the Datalogger is started: Triggering occurs when the signal goes above the triggering level, but before that the signal must go below the triggering level - hysteresis. |
| Fallback edge | Triggering signal is above the triggering level when the Datalogger is started: Triggering occurs when the signal goes below the triggering level. Triggering signal is below the triggering level when the Datalogger is started: Triggering occurs when the signal goes below the triggering level, but before that the signal must go above the triggering level + hysteresis. |

Using bit mask trigger

Bit mask trigger reads signal value and masks out user selected bits with given mask. Masking is done by using a logical AND operation. Masked value is compared to user given bit values selection. When masked value and bit values match, Datalogger is triggered.

- **Uploading triggered or stopped Datalogger data**

  1. In the Datalogger view select a logger from the **Logger** drop-down menu. If the logger status is stopped or triggered, data can be uploaded.
  2. Click **Upload** to upload data to the monitor window.

    **Note:** If you want to continue normal monitoring after using the Datalogger, click **Monitor configuration** icon and select a sampling interval for monitoring.

*Figure 102. Continue monitoring after using the Datalogger*
3. Click **Add signal** icon to add signals for monitoring.

![Figure 103. Uploaded Datalogger data](image)
Amplitude logger (pro)

ABB drives have an amplitude loggers that can record data from various signals of a drive. The results of an amplitude logger 1 (current) are displayed by the following curve. Each parameter represents an amplitude range and shows what portion of the samples fall within that range.

**Note:** Dataloggers or amplitude loggers are not available for all ABB drives.

![Amplitude logger](image)

Figure 104. Amplitude logger
**Macro (pro)**

ABB drives have Macro functionality that can automatize a task or sequence of tasks. You can use macros if the set parameter value to multiple networked drives when the Custom window functionality is not sufficient. You can also use macros for tasks which require logical or conditional parameterization of a drive.

- Go to **Tools → Macro**.

![Figure 105. Macro command](image)

A Macro screen is displayed.

![Figure 106. Macro](image)
Macro commands

- Macro language

Macro language is based on PAWN. For general programming guidelines, refer to PAWN manual.

Note: Some PAWN features are disabled for security reasons, such as file operations and other external IO functions.

Simple example

Macro tries to read parameter 1.1 value from each target in 100 network channels.

```plaintext
main()
{
    for(new i = 0; i < 100; i++)
    {
        //note the channels are indexed instead of nodes
        //this should be modified according network topology

        //change target
        Target(i+1,1)
        new targetName[100]
        //get target name
        TargetName (targetName)

        //read parameter 1.1 value
        new Float:val0101 = ParRead(1,1);
        //output to console
        printf "%s(%d,%d): %f\n", targetName, 1, 1, val0101 ;
    }
}
```
## Additional macro commands

### Target
Changes the target of the macro command after target command is issued.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target (Channel, node)</td>
<td>0 if success, 1 if failed</td>
<td>Target (1, 10)</td>
</tr>
</tbody>
</table>

### Target name
Command reads the current target name as string.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
</table>
| TargetName (string)  | 0 if success, 1 if failed | //reserve name string  
                          |              |  
                          |              | new name[100]     |
                          |              | if(TargetName(name)==0) |
                          |              | {                     |
                          |              | printf "target name is %s\n" name |
                          |              | }                     |

### ParWrite
Command writes parameter value to current target.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
</table>
| ParWrite (group, index, value) | 0 if success, 1 if failed | //write value 1 to group 12 index 16  
                          |              | main ()     |
                          |              | {           |
                          |              | ParWrite (12, 16, 1) |
                          |              | }           |

**Note:** The command does not write pointer or bit pointer type parameter values. Use the ParWriteInt command to write pointer or bit pointer type parameter values.
## ParWriteInt

Command writes parameter value to current target.

### Syntax

ParWriteInt (group, index, value)

### Returns

0 if success, 1 if failed.
If an error was detected, the error message appears in the log.

### Example

```c
//write parameter 06.17.b0 to parameter 06.60
main ()
{
    ParWriteInt (6, 60, 1073743377)
}
```

To get the integer value 1073743377,

1. In Drive composer offline mode, set parameter 06.60 User status word 1 bit 0 sel = 06.17.b0

   ![Image](image1.png)

2. Right-click the value and set Integer format.

   ![Image](image2.png)

Value P6.17.0 appears in integer format as 1073743377.
ParRead
Command reads the parameter value to current target.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
</table>
| ParRead (group, index) | Parameter value or 0 if failed. If an error is detected, the error message appears in the log. | //Read value of the parameter in group 10 index 5  
main ()  
{  
new Float.val = ParRead(10,5);  
printf “Value of (%d,%d): %f\n”, 10,5, val105;  
}

Note: The command does not read pointer or bit pointer type parameter values. Use the ParReadInt command to read pointer or bit pointer type parameter values.

ParReadInt
Command reads parameter value to current target from the same source as in the parameters window. The values are cached and refreshed on a notification or every half a second, if you selected the Enable updating option in the parameters window. When real time values are required, you can use the command ParReadIntFromDevice.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
</table>
| ParReadInt (group, index) | Parameter value casted to integer or 0 if failed. If an error is detected, the error message appears in the log. | //Read value of the parameter in group 7 index 11  
main ()  
{  
new val = ParReadInt (7,11);  
printf “Value of (%d, %d) : %d\n”, 7,11, val;  
} |
**ParReadFromDevice**

Command reads the parameter value to current target directly from drive.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ParReadFromDevice (group, index)</td>
<td>Parameter value or 0 if failed. If an error is detected, the error message appears in the log.</td>
<td>//Read value of the parameter in group 1 index 11 each second. main() { new Float:val; do { val = ParReadFromDevice(1, 11); printf &quot;Value of (%d,%d):%f\n&quot;, 1, 11, val; Wait(1000); } while (1); }</td>
</tr>
</tbody>
</table>

**ParReadIntFromDevice**

Command reads the parameter value to current target directly from the drive.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ParReadIntFromDevice (group, index)</td>
<td>Parameter value casted to integer or 0 if failed. If an error is detected, the error message appears in the log.</td>
<td>//Read value of the parameter in group 7 index 11 each second. main() { new val; do { val = ParReadIntFromDevice(7, 11); printf &quot;Value of (%d,%d):%d\n&quot;, 7, 11, val; Wait(1000); } while (1); }</td>
</tr>
</tbody>
</table>

**Wait**

Command delays the macro execution for given time in milliseconds.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wait (milliseconds)</td>
<td>0 in all cases</td>
<td>//wait 0.1 seconds Wait(100)</td>
</tr>
</tbody>
</table>
EndMacro
Command ends the macro execution.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>EndMacro()</td>
<td>0 in all cases</td>
<td>//End execution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EndMacro()</td>
</tr>
</tbody>
</table>

GotoMacro
Command changes the macro execution. Currently running macro execution is terminated.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>GotoMacro(string)</td>
<td>0 in all cases</td>
<td>//Change execution to macro jeejee</td>
</tr>
<tr>
<td></td>
<td></td>
<td>new macrofilename[100]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>macrofilename = &quot;jeejee.p&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>GotoMacro(macrofilename)</td>
</tr>
</tbody>
</table>

MessageBox
Command shows message box with ok button.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Returns</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>MessageBox (string)</td>
<td>0 in all cases</td>
<td>//show messagebox</td>
</tr>
<tr>
<td></td>
<td></td>
<td>new message[100]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>message = &quot;dingalongdangdong&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MessageBox (message)</td>
</tr>
</tbody>
</table>
Control diagrams (pro)

Contents this chapter
This chapter describes the use of control diagrams that help in understanding the behavior of a drive.

See topics:
- Control diagrams overview ................................................................. 131
- Viewing control diagrams ................................................................. 132

Control diagrams overview
Control diagrams provide a graphical presentation of, for example, the control chain of a drive, the speed and torque control chains and the logic of Start and Stop functions. With these diagrams it is possible to see parameter values related to certain functions. Diagrams also illustrate the position of switches according to parameter values, which helps to understand how the drive logic works. The values of parameters can be changed via control diagrams. A control diagram consists of two levels. The top level shows an overview of the diagrams and connections between them.

Note:
- Control Diagrams are drive-specific and they are not available for all drive types.
- When you connect a drive for the first time, it takes sometime to upload control diagrams from the drive. If Control Diagrams are not found in the drive, Drive composer asks to upload diagrams from the local source (PC).
Viewing control diagrams

1. In the drive list, click on a connected drive and select **Diagrams**.

![Diagram 1](image1.png)

*Figure 107. Control diagrams: Selecting from the drive tree*

2. The top level of a control diagram consists of several diagrams and appears in a separate tab. See the example screen below. To open a specific diagram, click on a top level control diagram box.

![Diagram 2](image2.png)

*Figure 108. Control diagrams: Top level*
The lower level control diagram appears in a separate tab. See the example diagram below.

![Control diagrams: Lower level](image)

*Figure 109. Control diagrams: Lower level*

To navigate back to the top level of a Control Diagram, click the *Diagrams top* icon. To navigate through the reference chain, click the buttons circled in the figure above.

To zoom the control diagrams, use the zooming tool in the top left-hand corner of a Control Diagram.

![Control diagrams: Zooming tool](image)

*Figure 110. Control diagrams: Zooming tool*
FSO configuration (pro)

Contents of this chapter

This chapter contains the configuration procedure of FSO-12 and FSO-21 safety functions with Drive composer pro and provides an example of how to configure these optional FSO safety functions modules.

See topics:

- Configuring FSO-12 and FSO-21......................................................... 135
- Hardware connection. ........................................................................ 136
- Setting the safety functions with Drive composer pro .................. 136
- Printing the safety functions configuration report (Online) .......... 143
- Printing the safety functions configuration report (Offline) .......... 147
- Updating FSO firmware ..................................................................... 148
- Changing FSO module password ...................................................... 152
- Reading FSO module parameters .................................................... 154

Configuring FSO-12 and FSO-21

The safety configuration of FSO-12 and FSO-21 safety functions module is available only in Drive composer pro, DCPT-01 (code: 3AUA0000108087).

Note:

- Only trained persons are allowed to configure the safety functions.
- Stop the drive before configuring the safety functions modules. You cannot download/upload the configuration file to/from safety functions module or change the password when the drive is modulating.
- You need a password to copy the configuration to the safety functions and also to validate the safety parameter settings.
- You can open a dcsafety file in Demo mode of Drive composer pro.
For detailed information about FSO-12 and FSO-21, see the respective safety functions module user’s manual:
- FSO-12 safety functions module user’s manual (3AXD50000015612 [English]).
- FSO-21 safety functions module user’s manual (3AXD50000015614 [English]).

**Hardware connection**

The hardware connection is common for both FSO-12 and FSO-21 safety functions module. For instructions on the hardware connections, see FSO-12 safety functions module user’s manual (3AXD50000015612 [English])/ FSO-21 safety functions module user’s manual (3AXD50000015614 [English]).

The following configuration description assumes that all hardware-related connections are made properly and the ID run procedure of the drive is completed.

**Setting the safety functions with Drive composer pro**

**WARNING!** The motor must be stopped. Safety configuration file can be edited (and sanity checked) in demo mode for offline configuration. Edit and save the file to PC without connecting to the drive/FSO.

1. Power up the drive. Make sure that the motor is not running. See *Working area* on page 65.
2. Right-click on drive and select **Safety settings**.

![Figure 111. FSO configuration: Selecting safety settings with FSO module]
In online mode with FSO installed, the safety configuration already available in the drive is displayed (see figure below). In offline mode the view is always empty before opening the safety file.

You can switch between **Graphical view** and **Parameter view**. See Figure 112. FSO configuration: Graphical view and Figure 113. FSO configuration: Parameter view.

**Figure 112. FSO configuration: Graphical view**

**Figure 113. FSO configuration: Parameter view**
3. Click **Read settings from drive**.

**Note:** When you upload the safety settings from FSO module to PC tool, the FSO goes into Configuration state and indicates a fault. You can exit the Configuration state by rebooting the FSO module if you do not want to download the settings but want to keep the existing setting.

The Fault **FSO general fault: 7A8B** appears on the drive.

![Figure 114. FSO configuration: FSO general fault due to configuration state](image)

4. Type the password (8 numbers). The factory default password is “12345678”.

![Figure 115. FSO configuration: Enter password](image)

**Note:** You can change password by clicking **Change password** (see figure FSO configuration: Parameter view). Make sure the drive is not modulating. The password must contain 4…8 digits. Do not forget the new password; otherwise you have to do a factory reset to the FSO which clears the configuration and resets the parameters to the factory defaults.

5. Configure the safety parameters. Set the following safety function parameters:

   - **General parameters:** Check that the motor parameters are correct.
   - **I/O:** Check that I/O parameters are set according to the installation (wiring) plan. Remove diagnostic pulsing from any unused I/O. The test pulses are off by default. Check possible safety relays and cascade connections.
   - **Safety functions:** Check all safety settings. You must at least check and set the STO and SSE related settings, regardless of whichever FSO safety functions you use. The FSO activates the STO and SSE functions (also in internal fault situations). The FSO uses the STO and SSE functions for making the system safe. All other functions are used only for monitoring the drive.

**Notes:**

- Graphical view cannot be used for setting safe IO, cascade function or for SBC function (see Figure 112. FSO configuration: Graphical view). Instead use the Parameter view (see Figure 113. FSO configuration: Parameter view).
- Parameter groups (200, 91 and 92) that include common parameters to drive and FSO are referred with group numbers and index numbers.
- Group names like FSOGEN, STO and so on have only index numbers (see Figure 119. FSO configuration: Edit parameters).

For examples of configuration settings and list of group names, see FSO safety functions module User’s manual.
6. In graphical view, double-click a function or the **General settings** tile to activate the safety function and open the general settings.  
**Note:** You can view the filtered tiles view with the **Filter functions by setups**. Click one of these filtering options to filter other tiles away from the view.

![Figure 116. FSO configuration: Filter function in graphical view](image)

7. In the opened tile view, configure the function or general settings group by editing all necessary parameters.

![Figure 117. FSO configuration: Configure function or general settings group](image)

After editing is completed, click **Done** to close or to stop editing. Click **Reset** if you want to reset to default.  
**Note:** In Graphical view the SAR settings are combined with safety function parameters. Using the reset option for parameters that are used crosswise (e.g. SAR1 is used with SS1 and SLS functions) resets the particular settings for both functions. The function works the same in parameter view in which the parameters are in separate groups.
8. In the Graphical view, enable/disable the function or general settings group using the slider switch.

![Slider switch enabled](image1.png)  
![Slider switch disabled](image2.png)

*Figure 118. FSO configuration: Enable/disable function*

9. In Parameter view, double-click on the value field and change all necessary configuration settings to match the safety configuration.

![Parameter view](image3.png)

*Figure 119. FSO configuration: Edit parameters*

10. Test your safety configuration when the motor is running.
11. Right-click on drive and select **Parameters** to check the values in parameter group 200.
   You can also validate the safety function parameters using the signal monitoring feature. See the instructions for **Adding parameters/signals for monitoring**. It is possible to check the ramp times and the status of bit changes in the time domain.

![Figure 120. FSO configuration: Parameter group 200](image)

12. Check the values in online mode while testing the safety functions.
   If there are unexpected values, right-click the parameter and select **Refresh the parameter**.
13. After testing save the FSO configuration to PC. In Parameter view, click Save to file.

![Figure 121. FSO configuration: Saving the safety settings](image)

The file is saved as dcsafety format and the File written successfully dialog appears. Click Ok.

14. Click Apply settings to drive.

15. Enter the password to apply the settings to the drive and click Ok.

The following Validate dialog appears. Click Yes.

![Figure 122. FSO configuration: Validate dialog](image)

**Note:** If you do not want to download the changes in safety parameters, you can boot FSO without downloading to FSO using Reboot FSO (see figure FSO configuration: Saving the safety settings).

16. Click Ok to close the dialogs.

![Figure 123. FSO configuration: Safety configuration ok message](image)
Printing the safety functions configuration report (Online)

With the FSO module installed, you can print the online safety functions configuration report.

1. From the Safety settings view, click Print report.

![Safety configuration report: Print Report](image)

2. Select a print template and click Continue.

![Safety configuration report: Select print template](image)

3. Fill in the Drive and FSO version information. Click Next.

![Safety configuration report: Drive and FSO information](image)

The next screen(s) contain different aspects of safety configuration such as configured safety functions, commissioning checklist, and so on.
The List of configured safety functions and acknowledged methods appears. Click **Next**.

![Figure 127. Safety configuration report: List of configured safety functions](image1)

In the FSO commissioning checklist, click on the check boxes to mark configurations are ok. Click **Next**.

![Figure 128. Safety configuration report: FSO commissioning check list](image2)
In the FSO changes/repair details, type the required details and click **Next**.

Figure 129. Safety configuration report: FSO changes/repair

4. In the final screen fill in the required details and click **Print preview**.

Figure 130. Safety configuration report: Print preview
5. Select the required printer settings and click **Print**.

![Safety configuration report: Printer settings](image)

*Figure 131. Safety configuration report: Printer settings*

The configuration and commissioning report is printed based on the selected printer settings.
Printing the safety functions configuration report (Offline)

To print a FSO safety functions configuration report in the Offline mode, you must have a saved safety file. See section Setting the safety functions with Drive composer pro (page 136).


Figure 132. Print safety configuration report: Tools menu

2. Select the saved file to print and click Continue.

Figure 133. Print safety configuration report: Select print template

Continue from step 3 in section Printing the safety functions configuration report (Online), page 143.
Updating FSO firmware

To know the FSO firmware version and to update the FSO firmware, you will need access to the FSO module.

1. Click **Tools → FSO firmware loader**.

   ![Tools → FSO firmware loader](image1)

   *Figure 134. Tools → FSO firmware loader*

2. Select the required drive. Click **OK**.

   ![Select drive](image2)

   *Figure 135. Select drive*

3. If you changed the FSO module default password, the Log in window appears. Enter the new password and click **Log in**.

   ![Log in](image3)

   *Figure 136. FSO login with changed password*
4. Wait while Drive composer checks for FSO firmware version.

![Figure 137. Checking FSO firmware version](image1)

5. The FSO firmware loader shows the current version and the update version (if available). Click **Next** to continue with updating the FSO firmware.

![Figure 138. Updating FSO firmware](image2)

6. Accept the terms and conditions to continue. Click **Confirm**.

![Figure 139. FSO firmware update terms and conditions](image3)
7. Follow FSO firmware update instructions. Click **Start**.

![Figure 140. Start FSO firmware update](image)

8. Wait while the FSO firmware update is in progress.

![Figure 141. FSO firmware update in progress](image)

9. After the FSO configuration backup, firmware download, and firmware verification is completed, the firmware update for the selected FSO is successful. Click **Next**.

![Figure 142. FSO firmware is successful](image)
10. Accept the Disclaimer conditions to continue. Click **Confirm**.

**Figure 143. FSO firmware update: Disclaimer conditions**

11. FSO firmware loader displays the updated firmware version as current version. Click **x**, to close the loader window.

**Figure 144. FSO firmware updated**
Changing FSO module password

1. Right-click on drive and select Safety settings.

![Safety settings](image1)

*Figure 145. Safety settings*

2. In the Safety settings window, click Change password.

![Change password](image2)

*Figure 146. Safety settings: Change password*

3. In the Change password dialog, type the old or default password and type the new password. Click OK.

   **Note:** The password should contain 4...8 numbers. For more information, see FSO module manual.
4. Wait while the password change is in progress and the parameters are reloaded. Click OK.

Figure 147. FSO password change in progress

5. Click OK, to confirm the password change. You can test the new password, for example, to log in to FSO module (see section, Updating FSO firmware) or to read FSO drive parameters (see section, Reading FSO module parameters).

Figure 148. FSO password changed
**Reading FSO module parameters**

To read the FSO module drive parameters:

1. In the Safety settings window, click **Read settings from drive**.

![Figure 149. Safety settings: Read settings from drive](image1)

2. Type the FSO module password. Click **OK**.

3. Wait while Drive composer is updating the safety parameters file and displays the safety settings dashboard. Click **Parameter view** to switch to parameter window and vice versa.

![Figure 150. Safety settings: Graphical and parameters view](image2)
Other functions

Contents of this chapter

This chapter describes common functions that are not associated with any view or window.

See topics:

- Using Drive Installed Base service ................................................................. 156
- Drive backup .................................................................................................. 172
- Restoring a drive ........................................................................................... 174
- Recovery and prevention of FB14 fault in drive ........................................... 177
- Using the Drive text editor ............................................................................ 183
- Using the Drive parameter conversion tool (pro) ........................................ 186
- Using the PSL2 data logger (pro) ................................................................... 189
- Using the PSL2 data viewer (pro) ................................................................. 191
- Adaptive programming .................................................................................... 193
- Locking user interface . ................................................................................ 194
- RADIUS authentication ................................................................................. 198
Using Drive Installed Base service

Drive Installed Base (Drive Installed Base) is a knowledge base for all information about drives. Using Drive Installed Base service you can,

- register an ABB drive through Drive composer (see page 156)
- obtain the required drive information (see page 161)
- create service reports (see page 164).

Registering an ABB drive to Drive Installed Base service

1. From the drive context menu select Register drive, or go to Tools → Register drive.

Figure 151. Register drive

If you used the drive context menu, make sure that drive composer is connected online with the drive for successfully registering the drive. If you used Tools → Register drive, you can register the drive when drive composer is either in online/offline mode with the drive.

2. In the Drive registration tab, type the drive serial number (for example, 32400110) and click Validate. You can see the drive serial number on the type designation label or see the drive’s hardware manual for more information.

Figure 152. Register drive: Drive serial number
Drive composer connects to Drive Installed Base portal (external website) and validates the serial number with an associated type code. If the number is valid, the drive type code is automatically filled. For example, PCB, CT BOARD.

![Figure 153. Register drive: Drive type code](image)

**Note**: You can register a serial number for first-time only. If attempted second time, the message "*This serial number has been already registered*" is displayed.
3. Enter drive location details in the appropriate fields.

![Register drive: Drive location details](image)

<table>
<thead>
<tr>
<th>Field name</th>
<th>Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site country</td>
<td>Name of country where the drive is located, for example, India.</td>
</tr>
<tr>
<td>Company name</td>
<td>Name of company where the drive is located. For example, ABB India.</td>
</tr>
<tr>
<td>Site name</td>
<td>Site name where the drive is located.</td>
</tr>
<tr>
<td>Site city, Site postal code</td>
<td>Name of city and postal code where the drive is located.</td>
</tr>
<tr>
<td>Site address</td>
<td>Site address.</td>
</tr>
<tr>
<td>Plant/Building, Area/Room</td>
<td>Optional. Plant /building name and area/room where the drive is located.</td>
</tr>
</tbody>
</table>
4. Type name and email address of the drive owner or the contact person details. Phone number is optional.

![Drive owner/ contact person form]

*Figure 155. Register drive: Drive owner details*

5. Type/select drive information in the appropriate fields.

![Drive information form]

*Figure 156. Register drive: Drive information*
6. Check and accept the Terms and conditions, and click **Next**.
7. Check the summary of registered information and click **Save**.

![Registration was completed successfully](image)

**Figure 157. Registering drive completed**

The “Registration was completed successfully” message is displayed. You will also receive an email to the registered email address.
Searching a registered ABB drive in Drive Installed Base

You can search for information about an ABB drive that is registered in Drive Installed Base service portal. **Note**: Make sure you have access permissions to Drive Installed Base service portal.

1. From drive context menu select **Search drive from DIB** or go to **Tools → Search drive from DIB**.

![Search drive from DIB](image)

**Figure 158. Search drive from Drive Installed Base**

- If you used the drive context menu, Drive composer extracts the drive serial number directly from the connected drive. Otherwise the “**Drive has not got serial number**” message is displayed.

- If you used **Tools → Search drive from DIB**, Drive composer asks for serial number.

2. Type the serial number and click **Ok**.

![Enter serial number](image)

**Figure 159. Search drive from Drive Installed Base: enter serial number**

- If the serial number matches with the drive data in Drive Installed Base, Drive composer downloads all data related to the drive and opens in a separate tab.

![Product info](image)

**Figure 160. Search a drive from Drive Installed Base: Product info tab**

- If you typed a wrong serial number or if the drive was not registered in Drive Installed Base, the message „Authorization failed, do you want to log in again“ or “Drive has not got serial number” is displayed.
3. Click **Product info**, to view the drive information, for example, serial number, type code, commissioning date, etc.

4. Click **Service history**, to view the maintenance history of the drive, for example, event or service type, date of service, name of service engineer, etc. You can download the attached service report file, if the file was added to the report.

5. Click **Recommended services**, to view the recommended drive services.

6. Click **Components**, to view the details of service components.
Setting the Drive Installed Base server location

The drive data is stored only in two server locations: Europe and China. The default location is Europe. For drives located in China, select China and for drives located in countries other than China, select Europe.

1. Go to View → Settings.
2. In the Settings window, select the appropriate Drive Installed Base server location. Example: Europe.

![Settings: Use Drive Installed Base server location](image)

Figure 164. Settings: Use Drive Installed Base server location

3. Click Save.

The Drive Installed Base server location is set to the selected country.
Creating a service report from Drive Installed Base

You can create a service report for an ABB drive registered in Drive Installed Base, if you have access permissions to the Drive Installed Base portal.

Note: The service report templates are predefined. However, if it is necessary to change the template, contact your local ABB representative.

1. Click on the drive list, select Create service report or go to Tools → Create service report.

![Create service report from Drive Installed Base](image1)

Figure 165. Create service report from Drive Installed Base

2. In the Service reporting page, click Select.

![Service report page: Select drive serial number](image2)

Figure 166. Service report page: Select drive serial number

3. Select the appropriate drive. Click Ok.

![Service report page: Select drive type](image3)

Figure 167. Service report page: Select drive type

4. In the Service reporting page, type the drive serial number.
5. In **Select service type** field, select the necessary service type, for example, *ACS880-01 Cooling fault - Code 4290*.

   **Note:** Drive composer downloads the selected service type. If downloading failed due to network error, you can use the previously downloaded Service pack.

6. If the registered drive serial number and service type matched with the Drive Installed Base data, you can *Create online service report* or *Creating offline report*. See sections below.

### Create online service report

**Note:** The contents in the report page are based on the service type and some contents in the wizard may be filled with information from the drive if the serial number matched with the drive.

In the below steps, see an example report of *ACS880-01 Cooling fault*.

1. Click on the drive list, select **Create service report** or go to **Tools → Create service report**.

2. Wait while Drive composer connects to the Drive Installed base.

3. In the service reporting page, click **Select** to select a connected drive or enter the drive serial number.

4. Click **Report online**.

![Create online service report: Report online](image)

*Figure 168. Create online service report: Report online*
5. In the General Info page, fill the necessary information. Click **Next**.

**Note:** All mandatory fields in this page and in the consecutive pages are marked with an asterisk (*) and appear with a red border around each field.

![General Info page](image)

**Figure 169. Create service report: General Info page**

6. In the End customer page, type details of location where the drive is installed. Click **Next**.

![End customer page](image)

**Figure 170. Create service report: End customer page**
7. In the Fault page, select the appropriate date when the fault occurred. You can update information of up to four fault codes. Click **Next**.

![Figure 171. Create service report: Fault Info page](image)

<table>
<thead>
<tr>
<th>Fault 1</th>
<th>Fault 2</th>
<th>Fault 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date of fault</td>
<td>Date of fault</td>
<td>Date of fault</td>
</tr>
<tr>
<td>Fault code</td>
<td>Fault code</td>
<td>Fault code</td>
</tr>
<tr>
<td>4290</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Warranty order number (required if fault under warranty)</td>
<td>Warranty order number (required if fault under warranty)</td>
<td>Warranty order number (required if fault under warranty)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Description of fault</td>
<td>Description of fault</td>
<td>Description of fault</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
8. In the Onsite check list, check and confirm that all actions are completed. All actions in this list are mandatory. Click Next.

![Onsite check list](image)

*Figure 172. Create service report: Onsite checklist page*

9. The consecutive pages for Material data are optional. You can fill up to five material data. Type the information if necessary and click Next.

![Material Info page](image)

*Figure 173. Create service report: Material Info page*
10. In the Components list, confirm that the listed components are available in the drive. Check against the listed component to report to Drive Installed Base service. Click Send.

![Figure 174. Create service report: Components list](image)

11. Read and accept the privacy terms and conditions. Click Next.

![Figure 175. Privacy terms and conditions](image)

12. If report is sent, the message "Sending to Drive Installed Base completed" appears. Click OK.

![Information](image)

If report sending failed, Drive composer prompts to save the report as Offline reports, which you can try sending later. See Creating offline report.
Creating offline report

Note: The contents in the report are based on the service type and some contents in the wizard may be filled with information from the drive if the serial number matched with the drive.

1. In the service reporting page, click Create offline report.

A service report is generated and appears in the Offline reports table.

2. Select the report and do the necessary actions:
   - Click Edit, if it is necessary to modify the report. See section Create online service report (step 3 onwards).
   - Click Send, if the report is ready to send to Drive Installed Base.
   - Click Remove, to delete a report. Confirm the message “The offline report has not been sent to Drive Installed Base. Are you sure you want to remove it and lose all changes?”

3. If you clicked Send, read and accept the privacy terms and conditions. Click Next.
4. If report is sent to Drive Installed Base service portal, the message "Sending to Drive Installed Base completed" appears. Click OK.

If report sending failed, Drive composer prompts to save the report as Offline reports, which you can try sending later.
Drive backup

Creating a backup of a drive

1. Click on a connected drive and select Backup/restore.

![Backup command]

2. Select the file location for the backup and give a name for the backup file.

![Backup/restore: select backup file location]

3. Click Backup to start the backup process. The backup process takes a few minutes.

You can also create a backup in the drive parameter view. See Creating a backup in drive parameter view.
Creating a backup in drive parameter view

1. In the parameters view, click on **Save parameters to file** icon.

   ![Figure 178. Create backup in drive parameter view](image)

2. Select a file location in your computer for the backup and give backup file name. Click **Save**.

   The backup process takes a few minutes.
Restoring a drive

- **Restoring a drive backup**
  1. Click on a connected drive and select **Backup/restore**.

![Figure 179. Restore command](image)

2. Select the backup file to restore to the drive.

![Figure 180. Backup/restore: select restored backup file location](image)

3. Click **Restore**.
   All available components are restored from the backup file and all unavailable components are preserved in the drive. A detailed status appears in the Restore report.

![Restore report](image)
4. You can also save the report as text file. In the Restore report window, click **Save report to text file** and save the file in your PC.

5. Save the file in your PC. Click **Cancel** to close the report.

**Restoring a backup in the drive parameter view**

1. Open a parameter backup file. Click **Download to device** icon.

![Figure 181. Backup/restore: Restore in drive parameter view](image)

All available components are restored from the backup file and all unavailable components are preserved in the drive.

**Restoring a set of components/parameters settings (pro)**

With the **Advanced restore** function you can restore separate items or group of items in the backup file.

1. Click on a connected drive and select **Backup/restore**.

2. Click **Advanced restore** to select a restored backup file.
3. Select a saved backup file and click **Open**.

4. In **All Items**, you can select single item(s) or a total group to restore. Click right arrow (>>) to move the selected items to **Selected items**.

   ![Backup/Restore window](image)

   **Note**: The message “Please remove the selected items to restore disabled items.” appears inside the restore window only when you selected
   
   • single item(s) and all other items are disabled
   • a group item and all single items are disabled.

5. Click **Restore**.

   The selected items are restored from the backup file and a restored successfully message appears. Non-selected items are preserved in the drive.

   **Note**:
   
   • The parameter values that are not written to the drive are listed in the restore report after the restore process.
   • The drive does not allow to restore the grey items in the advanced list.
Recovery and prevention of FB14 fault in drive

When the fault FB14 is active, the drive’s control panel displays the fault message (see figure below).

![Control panel display of FB14 fault](image)

**Figure 182. Control panel display of FB14 fault**

Drive composer can be used to remedy this fault by:

1. recovering the drive (see *FB14 Recovery pack*) and
2. preventing the fault (see *FB14 Service pack*).

You can check the status of Service pack installation in the System info window. See *Checking the status of Service pack* (page 182).

**FB14 Recovery pack**

1. If there is FB14 fault active in the drive, Drive composer detects this and prompts to recover the fault using FB14 Recovery pack. Click *Start downloading* to run the Recovery pack. Follow instructions in the note and wait while downloading is in progress.

![FB14 Recovery pack](image)

**Figure 183. FB14 fault active**

**Note:** If downloading the Recovery pack failed, follow instructions in *FB14 Recovery and Service pack failure*. 
2. After installation is completed, drive is recovered and FB14 fault is reset.

![Figure 184. FB14 Recovery pack successful](image)

The drive may be functional now, but the fault root cause still exists in the drive. Proceed with installing **FB14 Service pack**, to completely prevent the FB14 fault.

**FB14 Service pack**

3. In the Recover drive window, click **FB14 Service pack**.

![Figure 185. Download FB14 Service pack](image)
4. In the FB14 Service pack window, click **Continue**. Follow instructions in the Note.

![FB14 Service pack Installation recommended](image1)

**Figure 186. Install FB14 Service pack**

5. Before installing the Service pack, Drive composer creates a parameter backup. Check **Parameter backup**.

![FB14 Service pack Installation recommended](image2)

**Figure 187. FB14 Service pack installation**

6. If you prefer to change the backup folder, browse to select a new folder and click **Start**.

**WARNING!** Do not interrupt the drive during backup and loading process, this may cause severe damage to the drive.

7. Wait while Drive composer completes parameter backup and downloading. Follow instructions in the note.

![FB14 Service pack Installation](image3)

**Figure 188. FB14 Service pack installation completed**
8. After installation is complete, Drive composer sends the Service pack update event to ABB server. Later this information is maintained in the Drives Installed Base. Click **Next**.

![Figure 189. FB14 Service pack installation DONE!](image)

9. A thank you message appears to acknowledge the Service pack installation. You can continue using the drive with the parameter backup saved in your PC. To access the saved location, click on the link **Open file location**.

![Figure 190. Send Service pack report](image)

See also,
- **Sending offline FB14 Service pack event**
- **FB14 Recovery and Service pack failure**
- **Checking the status of Service pack**
Sending FB14 Service pack event

After the FB14 Service pack installation and update is completed, Drive composer automatically sends the service information to ABB server. The server is updated periodically to transfer the service information to Drives Installed Base (Drive Installed Base) in which the Drive history is maintained. See figure FB14 Service pack installation DONE!.

Sending offline FB14 Service pack event

If network was offline during FB14 fault remedy, the ".... no connection to ABB server" message appears. Drive composer saves the event report locally and confirms if the report can be sent at the next start whenever the drive is online.

FB14 Recovery and Service pack failure

If the Recovery and Service pack process failed, Drive composer opens the default mail client with filled message, for example, drive ID and Drive composer version. You can check the filled details and send the mail to ABB global technical support to help diagnose the cause of failure.

Figure 191. FB14 Recovery and Service pack failure: email notification

Note: Drive ID is filled only when the Service pack installation fails. Drive composer attaches the log file to the mail. But you can also attach the backup file.
### Checking the status of Service pack

You can check the status of Service pack installation from the System info window.

![System info: Service pack update status](image)

**Figure 192. System info: Service pack update status**

The following status appears in the System info window:

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update Available (Recommended)</td>
<td>indicates that the drive requires Service pack installation. ABB recommends to install the Service pack to prevent any possible fault in the future.</td>
</tr>
<tr>
<td></td>
<td>To install,</td>
</tr>
<tr>
<td></td>
<td>1. Click on the status.</td>
</tr>
<tr>
<td></td>
<td>Note: Make sure that the drive is powered on and USB cable is connected between drive control panel and PC.</td>
</tr>
<tr>
<td></td>
<td>2. Follow the instructions on how to proceed with installation. See, <a href="#">FB14 Service pack</a>, step 7 onwards.</td>
</tr>
<tr>
<td>Updated</td>
<td>indicates that Service pack is installed in the drive, and no further action is required.</td>
</tr>
<tr>
<td>Not Required</td>
<td>indicates that the memory unit or drive firmware includes the FB14 fault remedy and drive does not require Service pack installation.</td>
</tr>
</tbody>
</table>
Using the Drive text editor

You can manage user editable texts using the Drive text editor. The function allows to read texts from the drive, to make changes and to update texts to the drive.

1. Select **Tools → Drive Text Editor**.

2. Select the drive to work with and click **Ok**.

The Drive text editor is started and attached to the selected drive.
3. Click **Read**, to read the data from the drive and make the changes in the column **Localized text**. Also, select the **Enable** check box to display the contact information in the panel.

**Notes:**
- The changed text appears as highlighted until it is saved.
- The contact info appears in the preview even if the **Enable** check box is not selected.

![Drive text editor: Localized text](image1)

**Figure 195. Drive text editor: Localized text**

4. Click **Preview**, to review the changes.

![Drive text editor: Preview localized text](image2)

**Figure 196. Drive text editor: Preview localized text**
5. In the Drive text editor window, click **Apply**.
   The changes are written to the drive and the message *Parameters changed. Parameters are reloaded* appears.

   ![Drive text editor: Parameters changed successfully]

   *Figure 197. Drive text editor: Parameters changed successfully*

6. Click **OK**.
Using the Drive parameter conversion tool (pro)

The parameter files of ACS800/ACS600 ABB drive types commissioned and maintained with DriveWindow can be accessed with Drive composer via the Drive parameter conversion tool.

**Note:** Not all ACS800/ACS600 drives and software are supported.

1. Go to **Tools → Drive parameter conversion tool.**

![Drive Parameter Conversion Tool](image)

*Figure 198. Drive parameter conversion tool*
2. In the Drive Parameter Conversion Introduction screen, click **Next**.

*Figure 199. Drive parameter conversion: Introduction*
3. Browse and select appropriate source and destination drive parameter files.

![Image](image1.png)

Figure 200. Drive parameter conversion: Browsing source and destination file

**Note:** Select an empty parameter file with default values. You must create an offline parameter file (of the destination drive family) to select here.

4. Select a file name to save the target file. Click **Next**.

**Note:** Do not overwrite the empty file.

5. Answer **Yes**.

The Conversion report shows the parameters which are converted successfully and failed. Read the report carefully and fix the parameter values manually for which the conversion was not successful.

![Image](image2.png)

Figure 201. Drive parameter conversion: Results
Using the PSL2 data logger (pro)

With BCU-x2 control unit, you can upload the PSL2 data logger files from the drive flash memory to PC local hard drive. The files contain real time data from the converter modules that help in fault tracing and analysis.

**Note:** The files can be uploaded from drive to local computer only. You cannot read the contents or open the files. For any further assistance contact ABB customer support.

### Uploading PSL2 data logger files

1. Go to **Tools → PSL2 data logger.**

```
<table>
<thead>
<tr>
<th>Tools</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Safety Configuration Report</td>
<td></td>
</tr>
<tr>
<td>Backup network</td>
<td></td>
</tr>
<tr>
<td>Compare drive data</td>
<td></td>
</tr>
<tr>
<td>PSL2 data logger</td>
<td></td>
</tr>
<tr>
<td>PSL2 Data Viewer</td>
<td></td>
</tr>
<tr>
<td>Drive Text Editor</td>
<td></td>
</tr>
<tr>
<td>Drive Parameter Conversion Tool</td>
<td>Ctrl+Alt+P</td>
</tr>
<tr>
<td>EDS Export</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Macro</td>
<td>Alt+M</td>
</tr>
<tr>
<td>Register drive</td>
<td></td>
</tr>
<tr>
<td>Application symbols</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Search drive from DIB</td>
<td></td>
</tr>
<tr>
<td>Create service report</td>
<td></td>
</tr>
<tr>
<td>F90 firmware loader</td>
<td></td>
</tr>
</tbody>
</table>
```

*Figure 202. PSL2 Data logger*
190 Other functions

2. Move the PSU data logger file(s) that you want to upload to the right side box. Use the right arrow (>>) or the left arrow (<<) button.

![Figure 203. PSU datalogger file: select files](image)

3. In the Upload directory field, click ⬇️ and select an upload folder in your PC local hard drive.

4. Click **Upload**...
   The selected files are transfered to your local folder.
Using the PSL2 data viewer (pro)

You can open and view contents of the uploaded PSL2 data logger files in the PC local hard drive. The files contain real time data from the converter modules that help in fault tracing and analysis.

- Viewing PSL2 data logger files

1. Go to Tools → PSL2 Data Viewer.

   PSL2 Data Viewer screen with PSL2 plotting tools appears. The plotting area is empty by default. See PSL2 Data Viewer instructions below to open and save the plot.

Figure 204. PSL2 Data viewer screen

- PSL2 Data Viewer instructions

The PSL2 plotting tools can be used to plot current and DC voltage using the uff or csv file. The table below describes how to use the plotting tools. Match the below instructions with the above PSL2 Data viewer screen.

<table>
<thead>
<tr>
<th>Action</th>
<th>Instruction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening uff or csv file.</td>
<td>In the PSL2 Data Viewer window, click Open file icon and select the file to open.</td>
</tr>
<tr>
<td>Saving the plot as csv file.</td>
<td>Click Save to CSV icon.</td>
</tr>
<tr>
<td>Saving the plot into different file formats.</td>
<td>Click Save plot icon.</td>
</tr>
<tr>
<td>Selecting number of channels to view in the plot.</td>
<td>Select number of channels in the Number of visible channels drop-down list.</td>
</tr>
<tr>
<td>Viewing the selected channels.</td>
<td>See in Selected channel drop-down list.</td>
</tr>
<tr>
<td>Action</td>
<td>Instruction</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Aligning selected channels on the same axis</td>
<td>Click on <strong>Use only one axis</strong> check box. Use this option to draw all selected channels on the same axis.</td>
</tr>
<tr>
<td>Setting minimum and maximum values of X-axis and Y-axis</td>
<td>Set required minimum and maximum values in the below fields and click on <strong>Update axis</strong> button.</td>
</tr>
<tr>
<td></td>
<td>• Y-axis min</td>
</tr>
<tr>
<td></td>
<td>• Y-axis max</td>
</tr>
<tr>
<td></td>
<td>• X-axis min</td>
</tr>
<tr>
<td></td>
<td>• X-axis max</td>
</tr>
<tr>
<td><strong>Note:</strong> The min/max values of X-axis and Y-axis are equal in all visible plots.</td>
<td></td>
</tr>
<tr>
<td>Scaling X-axis and Y-axis automatically</td>
<td>Click on <strong>Auto Scale</strong> button. The largest and smallest values of data are scaled to Y-max Y-min respectively.</td>
</tr>
<tr>
<td><strong>Note:</strong> This action does not maintain the same scale in every parallel axis.</td>
<td></td>
</tr>
<tr>
<td>Resetting min/max values of Y-axis to default values</td>
<td>Click on <strong>Default Scale</strong> button. The graph is reset to the updated default values.</td>
</tr>
<tr>
<td>Updating calculation parameters to plot and recalculate the data</td>
<td>Set current and voltage values in <strong>Curr meas range [A]</strong> and <strong>DC meas range [V]</strong>. Click on <strong>Update</strong> button.</td>
</tr>
<tr>
<td>Viewing different plots</td>
<td>Click on the tabs to view the required plot:</td>
</tr>
<tr>
<td></td>
<td>• Total Current and DC SI</td>
</tr>
<tr>
<td></td>
<td>• Sum currents %</td>
</tr>
<tr>
<td></td>
<td>• Phase X current diff %</td>
</tr>
<tr>
<td></td>
<td>• Sum current filtered %</td>
</tr>
<tr>
<td></td>
<td>• DC voltage diff %</td>
</tr>
<tr>
<td></td>
<td>• Module currents % and DC %</td>
</tr>
<tr>
<td>Inside the plot you can also do the following actions using keypad and mouse:</td>
<td>• use the right mouse button to move (pan) the plot up/down. The x-/ y-axis moves accordingly.</td>
</tr>
<tr>
<td></td>
<td>• use the mouse wheel to zoom the plot. Zooming multiple channels works best when the cursor is placed on an empty space i.e. top of upper axis, below the lower axis, or between the axis.</td>
</tr>
<tr>
<td></td>
<td>• mark a rectangle with Ctrl+Right mouse button or Ctrl+Left mouse button to zoom the marked area</td>
</tr>
<tr>
<td></td>
<td>• hold the Left mouse button to view the plot tracker</td>
</tr>
<tr>
<td></td>
<td>• press ‘A’ key to reset the axis to set values</td>
</tr>
<tr>
<td></td>
<td>• press Ctrl+C to copy the bitmap of plot.</td>
</tr>
</tbody>
</table>
Adaptive programming

Adaptive programming is a feature to control the operation of a drive by parameters. Each parameter has a fixed set of choices or a setting range. The parameters make programming easy, but the choices are limited. You cannot customize the operation further.

The Adaptive programming makes easy customizing possible without the need of a special programming tool or language. The program is built of function blocks.

Figure 205. Adaptive programming

For further information on Adaptive programming, refer Adaptive programming application guide in List of related manuals.
Other functions

Locking user interface

A user interface lock function is implemented to notify the device lock states, for example, when parameter system is locked or when file downloading is disabled.

The function prevents you from:
• uploading device data, when file download function is disabled or when parameter system is locked
• creating device backup when the device is in protected state.

The function is implemented in DCPT-01 and DCET-01. See below sections that describe the lock states visible in different pages or views in the Drive composer.

Lock state in System info page

Go to the System info page by right clicking on the selected drive in the drive list and select System info. The different lock states displayed in the System info page are listed below.

<table>
<thead>
<tr>
<th>Device lock state</th>
<th>Lock state messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial state</td>
<td><strong>Set</strong> button is enabled.</td>
</tr>
<tr>
<td>Parameter system is locked</td>
<td><strong>Set</strong> button is disabled. When you mouse hover the button, the tooltip “Parameters are locked on drive” appears.</td>
</tr>
<tr>
<td>File download is disabled</td>
<td><strong>Set</strong> button is disabled. When you mouse hover the button, the tooltip “File downloading is disabled on drive” appears.</td>
</tr>
</tbody>
</table>

Lock state in parameter view

The user interface lock states are displayed in the following parameters view:
• Parameters view for online drive (see page 68)
• Custom parameter view (see page 80)
• Offline parameter view (see page 84)
• File parameter view (see page 68)

In the parameters view, the device lock states, i.e. Parameter system is locked or the File downloading is disabled, are accessible when you mouse hover the below two buttons:
• Save parameters to file
• Download to device

The table below lists the different device states displayed in the parameters view. The example screens are from the custom parameter view.
Note: The two buttons listed above may be hidden and may not be visible in all views. When data in the view is loaded for different drives, the drive which is connected may not show the correct state of the buttons until you change the drive.

<table>
<thead>
<tr>
<th>Device lock state</th>
<th>Lock state messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial state</td>
<td><strong>Save parameters to file</strong> and <strong>Download to device</strong> buttons are enabled.</td>
</tr>
<tr>
<td></td>
<td><strong>Save parameters to file</strong> button is enabled. <strong>Download to device</strong> button is</td>
</tr>
<tr>
<td></td>
<td>disabled. When you mouse hover the disabled button, the tooltip “Parameters are</td>
</tr>
<tr>
<td></td>
<td>locked on drive” appears.</td>
</tr>
<tr>
<td>Parameter system is</td>
<td><strong>Save parameters to file</strong> button is enabled. <strong>Download to device</strong> button is</td>
</tr>
<tr>
<td>locked</td>
<td>disabled. When you mouse hover the disabled button, the tooltip “Parameters are</td>
</tr>
<tr>
<td></td>
<td>locked on drive” appears.</td>
</tr>
<tr>
<td>File download is</td>
<td><strong>Save parameters to file</strong> button is enabled. <strong>Download to device</strong> button is</td>
</tr>
<tr>
<td>disabled</td>
<td>disabled. When you mouse hover the disabled button, the tooltip “File downloading</td>
</tr>
<tr>
<td></td>
<td>is disabled on drive” appears.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Lock state in Backup/Restore page

Go to the Backup/Restore page by right clicking on the selected drive in the drive list and select **Backup/Restore**. The different lock states displayed in the Backup/Restore page are listed below.

<table>
<thead>
<tr>
<th>Device lock state</th>
<th>Lock state messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial state</td>
<td>All buttons, <strong>Backup</strong>, <strong>Restore</strong> and <strong>Advanced restore</strong> are enabled.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> <strong>Advanced restore</strong> button is available only in Drive composer pro,</td>
</tr>
<tr>
<td></td>
<td>DCPT-01 (code: 3AUA0000108087).</td>
</tr>
<tr>
<td>Parameter system is</td>
<td><strong>Backup</strong> button is enabled. <strong>Restore</strong> and <strong>Advance restore</strong> buttons are</td>
</tr>
<tr>
<td>locked</td>
<td>disabled. When you mouse hover the disabled buttons, the tooltip “Parameters are</td>
</tr>
<tr>
<td></td>
<td>locked on drive” appears.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> <strong>Advanced restore</strong> button is available only in Drive composer pro,</td>
</tr>
<tr>
<td></td>
<td>DCPT-01 (code: 3AUA0000108087).</td>
</tr>
</tbody>
</table>
Other functions

Lock state in Safety settings page (pro)

Go to the Safety settings page by right clicking on the selected drive in the drive list and select Safety settings. The different lock states displayed in the Safety settings page are listed below.

**Note:** The lock state messages are visible only in Drive composer pro, DCPT-01 (code: 3AUA0000108087).

<table>
<thead>
<tr>
<th>Device lock state</th>
<th>Lock state messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>File download is disabled</td>
<td><strong>Backup</strong> button is enabled. <strong>Restore</strong> and <strong>Advance restore</strong> buttons are disabled. When you mouse hover the disabled buttons, the tooltip “File downloading is disabled on drive” appears.</td>
</tr>
<tr>
<td><strong>Note:</strong> <strong>Advanced restore</strong> is available only in Drive composer pro, DCPT-01 (code: 3AUA0000108087).</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Device lock state</th>
<th>Lock state messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial state</td>
<td>Buttons enabled:</td>
</tr>
<tr>
<td></td>
<td>• Read settings from drive</td>
</tr>
<tr>
<td></td>
<td>• Apply settings to drive</td>
</tr>
<tr>
<td></td>
<td>• Print report</td>
</tr>
<tr>
<td></td>
<td>• Reboot FSO</td>
</tr>
<tr>
<td></td>
<td>• Change password</td>
</tr>
<tr>
<td></td>
<td><strong>Load from file</strong> is always enabled.</td>
</tr>
<tr>
<td></td>
<td>Save to file is enabled only when data is read.</td>
</tr>
</tbody>
</table>

| Parameter system is locked               | Buttons disabled:                                                                  |
|                                          | • Read settings from drive                                                          |
|                                          | • Apply settings to drive                                                           |
|                                          | • Print report                                                                      |
|                                          | • Reboot FSO                                                                       |
|                                          | • Change password                                                                  |
|                                          | When you mouse hover the disabled buttons, the tooltip “Parameters are locked on drive” appears. |
|                                          | **Load from file** is always enabled.                                               |
|                                          | Save to file is enabled only when data is read.                                    |
Lock state in Drive text editor (pro)

Go to Tools → Drive Text Editor. Select the drive to work with and click Ok. The Drive text editor screen appears.

The different lock states displayed in the Drive text editor are listed below.

**Note:** The lock state messages are visible only in Drive composer pro, DCPT-01 (code: 3AUA0000108087).

<table>
<thead>
<tr>
<th>Device lock state</th>
<th>Lock state messages</th>
</tr>
</thead>
</table>
| Initial state     | **Read** button is always enabled.  
|                   | **Apply** button is enabled only when text is changed in the Localized text column. |
| Parameter system  | **Read** button is always enabled.  
| is locked         | If you changed text in the Localized text column, the changes are not effective and the **Apply** button is disabled. When you mouse hover the disabled button, the tooltip “Parameters are locked on drive” appears. |
| File download is  | **Read** button is always enabled.  
| disabled          | If you changed text in the Localized text column, the changes are not effective and the **Apply** button is disabled. When you mouse hover the disabled button, the tooltip “File downloading is disabled on drive” appears. |

Buttons disabled:
- Read settings from drive
- Apply settings to drive
- Print report
- Reboot FSO
- Change password.

When you mouse hover the disabled buttons, the tooltip “File downloading is disabled on drive” appears.

**Load from file** is always enabled.

**Save to file** is enabled only when data is read.
RADIUS authentication

- **RADIUS authentication overview**

  With RADIUS authentication function you can protect drive data by limiting access to certain operations of the drive. The function is accessible via Drive composer PC tool when the drive is connected to the RADIUS server, for example, via USB or Ethernet connection. The function is activated in the drive with parameter 59.30 Radius authentication enable. When the function is enabled, Drive composer will prompt to login to the drive before you make changes to the drive data.

  **Note:** If drive is not enabled with RADIUS authentication function, the drive operations are not limited and all functionalities are available.

  For information about the RADIUS server and configuring the drive, see in below sections. See also Annexure B: Radius authentication (page 215).

- **RADIUS protocol overview**

  Remote Authentication Dial-In User Service (RADIUS) is a commonly used networking/authentication protocol to manage access to the Internet or internal networks, wireless networks, and integrated e-mail services. The protocol operates using UDP communication with synchronous request-response manner. For more information, see RADIUS in Wikipedia.

- **RADIUS authentication prerequisites**

  Make sure
  
  • you are connected to the RADIUS server (Drive composer ↔ Drive ↔ RADIUS server), for example, via USB or Ethernet connection. See Example: Network configurations via Ethernet connection (page 216).

  • you have defined the required user access levels to the RADIUS server. See definition of ABB vendor specific attribute (page 217). Information of all authenticated users is located in the RADIUS server.
Configuring RADIUS authentication and offline credentials

In Drive composer, you can configure drive authentication details and offline credentials.

1. Go to View → Settings.

2. In the Settings window, Radius config is enabled if you logged in with Service access level. Click Radius config.

3. In the RADIUS settings window,
   - enter the shared secret password (authentication details). See description below. Default password = SharedSecret
   - select target RADIUS server
   - upload offline credential XML file. See description below.

   Click Save.
Note: The configuration if effective for all drives using the selected RADIUS server.

Shared secret
Secret password to encrypt the authentication request sent by drive to RADIUS server.

Note: The shared secret password of drive and server should match to correctly process the authentication requests from the server.

Upload offline credentials
• Offline credentials are available in an XML file format and are used as backup to login when the connection to RADIUS server failed and drive failed to authenticate access. If you have the required access level (Service level), then you can create a new list of offline credentials and send to the drive via Drive composer. Go to View → Settings → Radius config.
  • If the drive was able to send the authentication request to RADIUS server within the defined RADIUS communication timeout, then drive will check if given user name and password is available in the offline credentials list. If the credentials matched with that of drive, Drive composer prompts to login to the drive just like the RADIUS server based authentication.
  • If drive was not able to send the request, e.g. network cable was disconnected, then offline authentication is not executed.

Activating RADIUS authentication function
You can enable RADIUS authentication function, when drive authentication feature is disabled.

1. Make sure,
   • the drive is connected to RADIUS server over Ethernet connection. See Example: Network configurations via Ethernet connection.
   • your user access level is Service. See Supported user access levels.

2. In Drive composer’s parameter window, configure the following parameters in group 59 Gen Embedded Ethernet. For more information, see technical document of RADIUS parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>59.04 Emb Eth IP settings</td>
<td>IP settings, e.g. Static IP</td>
</tr>
<tr>
<td>59.05 Emb Eth IP address</td>
<td>IP address of the drive</td>
</tr>
<tr>
<td>59.06 Emb Eth subnet mask</td>
<td>Subnet mask of the drive. This value must match with the subnet mask of your PC.</td>
</tr>
<tr>
<td>59.07 Emb Eth gateway</td>
<td>Gateway address of the drive used to communicate with other devices in the network. This value is also the IP address of your PC or the router in the network.</td>
</tr>
<tr>
<td>59.30 Radius authentication enable</td>
<td>Activates RADIUS authentication function in the drive. The function can be activated only when parameters 59.04...59.07 have valid values. For example, if IP address is 0.0.0.0, a write failed error occurs while activating the function.</td>
</tr>
<tr>
<td>59.32 Radius server IP address</td>
<td>IP address of RADIUS server.</td>
</tr>
<tr>
<td>59.33 Radius server port</td>
<td>UDP port of RADIUS server</td>
</tr>
</tbody>
</table>
If RADIUS authentication function is activated,
• drive moves to unauthenticated state
• drive navigation feature is locked
• Drive composer closes all drive related views
• Drive composer prompts to login to the drive before you make any changes to the drive data. See Login with RADIUS authentication.

### Disable RADIUS authentication

You can disable RADIUS authentication with parameter 59.30 when you are still logged in to RADIUS server. The authentication and offline credentials are disabled, but the drive will still be in logged in state and you can continue working with the drive.

### Login with RADIUS authentication

If the connected drive is enabled with RADIUS authentication,
• a lock symbol appears next to the drive icon to indicate that drive is locked for editing and
• a login button appears at the top-right corner. The first drive in the drive list requests authentication. You can also login using the drive navigation list and select the drive to authenticate.
1. Click the **Login** button.
2. In the login window, enter the drive username and password.

![Login window](image)

**Note:** Login is successful only when the credentials of drive match with that of RADIUS server. If the credentials are not matching, you may have to shut down the RADIUS server and login to the drive using offline credentials (i.e. service user access level). For default offline credentials, contact your local ABB representative.

If login was successful:
- drive is accessible and the lock symbol changes to indicate the current drive state
- drive control toolbar is enabled and
- drive related views can be opened.

**Note:** After successful login to one drive, the same credentials are automatically used to unlock other drives.

### Drive backup and restore

The RADIUS authentication parameters 59.30...59.35, Shared secret and Offline credentials are not part of drive backup and thus cannot be restored to drive. If a drive is restored from a backup file, the existing values of RADIUS parameters, Shared secret and offline credentials are preserved.
Annexure A: Creating Drive Installed Base service report template

Contents of this chapter

This chapter describes the factors to consider when creating a service report template file for Drive Installed Base (DIB).

See topics:

- Creating a template for Drive Installed Base service report (Internal use only) ........................................... 204
- Generic wizard step.................................................................................................................................................. 205
- Components .......................................................................................................................................................... 205
- Common properties of components ....................................................................................................................... 206
- ComboBox properties of components .................................................................................................................. 206
- DataGridView properties ......................................................................................................................................... 207
- DataBindings ......................................................................................................................................................... 209
- DataSource ............................................................................................................................................................ 209
- DataTarget ............................................................................................................................................................. 210
- Saving the DC wizard template in StepDesigner ................................................................................................ 212
- Deploying a template file ....................................................................................................................................... 213
- Localizing service report templates .................................................................................................................... 213
Creating a template for Drive Installed Base service report (Internal use only)

**Note:** Service report templates are created by authorized ABB personnel only. If you need to create template, contact your local ABB representative.

You can create a template file for Drive Installed Base service report using the Step Designer tool. You will need necessary permissions to access the tool. The tool has different steps (see page 205) and components (see page 205), but not all of them are used in the Drive Installed Base service reporting template.

The project file *(SDDIBTemplate.xml)* is located in the Drive Installed Base service portal. The file contains all currently supported components and databindings (see page 209). See descriptions in below sections.

The example screens show General Information for service actions.
Generic wizard step

The Generic wizard step is used in the Drive Installed Base template structure. Currently, the template supports only this step.

The table below lists the sections and properties of the Generic wizard step used in the Drive Installed Base service report.

<table>
<thead>
<tr>
<th>Section</th>
<th>Property</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration</td>
<td>Display Name (presented as “Title” in Drive Installed Base service report)</td>
<td>Mandatory to fill this value.</td>
</tr>
<tr>
<td></td>
<td>Description</td>
<td>Appears below “Title”</td>
</tr>
<tr>
<td>DC Wizard Printing</td>
<td>AddToReport</td>
<td>Determines that page is visible on print preview.</td>
</tr>
</tbody>
</table>

Components

The table below lists the components used in Drive Installed Base service reports.

<table>
<thead>
<tr>
<th>Component</th>
<th>Presented as ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>CommentsControl</td>
<td>multiline text component</td>
</tr>
<tr>
<td>NumericTextBox</td>
<td>numeric component</td>
</tr>
<tr>
<td>CheckBox, ThreeStateCheckBox</td>
<td>checkbox</td>
</tr>
<tr>
<td>Note: Accepts numeric values only.</td>
<td></td>
</tr>
<tr>
<td>TextBox, BinaryTextBox, StringTextBox, HexTextBox</td>
<td>one-line text components</td>
</tr>
<tr>
<td>Filechooser</td>
<td>user file selectable component</td>
</tr>
<tr>
<td>ComboBox</td>
<td>drop-down list</td>
</tr>
<tr>
<td>DataGridView</td>
<td>table</td>
</tr>
</tbody>
</table>
Common properties of components

The following properties are common for the components defined in Drive Installed Base service report.

<table>
<thead>
<tr>
<th>Section</th>
<th>Property</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration</td>
<td>DataBinding</td>
<td>Defines data input and output of the component. See also DataBinding xx.</td>
</tr>
<tr>
<td></td>
<td>DefaultValue</td>
<td>Defines default value of the component. This value is used if source databinding is not defined.</td>
</tr>
<tr>
<td></td>
<td>Display Name</td>
<td>Appears as “Title” in service report. This is a mandatory value.</td>
</tr>
<tr>
<td></td>
<td>enabled (value)</td>
<td>Defines that component is read-only</td>
</tr>
<tr>
<td></td>
<td>enabled (expression)</td>
<td>Not supported</td>
</tr>
<tr>
<td></td>
<td>ValueRequired</td>
<td>Defines if value must be filled. True = Value is required before navigating to the next page. False = Value is not required</td>
</tr>
<tr>
<td>DC Wizard Printing</td>
<td>AddToReport</td>
<td>Determines the print preview of service report page.</td>
</tr>
<tr>
<td></td>
<td>BlankLineAfter</td>
<td>Adds one empty line in print report after this component.</td>
</tr>
<tr>
<td></td>
<td>OmitIfEmpty</td>
<td>Does not print the component if there is no value.</td>
</tr>
<tr>
<td></td>
<td>PageBreakAfter</td>
<td>Adds page break in print report after this component.</td>
</tr>
</tbody>
</table>

ComboBox properties of components

You can use the following combo box property to define the components in Drive Installed Base service report.

<table>
<thead>
<tr>
<th>Property</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>PossibleValues (value)</td>
<td>Shows values in the drop down list. Selecting a value opens a new editor. You can add, change or remove a value. See example screen below. In the new editor, you can define name and value of the property. Data in the Value field is sent to Drive Installed Base service. Make sure that this data is synchronized with the expected data value.</td>
</tr>
<tr>
<td>PossibleValues (expression)</td>
<td>Not supported</td>
</tr>
</tbody>
</table>
DataGridView properties

You can use the following data grid view property to define components in Drive Installed Base service report.
Annexure A: Creating Drive Installed Base service report template

<table>
<thead>
<tr>
<th>Property</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCWizardColumns</td>
<td>Defines columns in the table. Selecting a column value opens a new editor. You can add, change or remove a column value. See example screen below.</td>
</tr>
<tr>
<td></td>
<td>In the new editor, you can define the column properties:</td>
</tr>
<tr>
<td></td>
<td><strong>Column property</strong></td>
</tr>
<tr>
<td>DataBinding</td>
<td>Defines data input and output. See also <em>DataBindings</em> (page 209).</td>
</tr>
<tr>
<td>Enabled</td>
<td>Enables read-only column mode.</td>
</tr>
<tr>
<td>Name</td>
<td>Defines column header text.</td>
</tr>
<tr>
<td>PossibleValue</td>
<td>Defines possible values if column type is DropDown. <strong>Note</strong>: This property is not supported for other column types.</td>
</tr>
<tr>
<td>Type</td>
<td>Defines following data types: String, Numeric, Date, CheckBox, DropDown</td>
</tr>
</tbody>
</table>

**Note**: Columns defined are not visible in StepDesigner, but are visible only in Drive Installed Base service report wizard.
DataBindings

DataBindings define how to fill the component with data and to where the filled data must be sent. The Drive Installed Base service report includes two types of DataBinding properties:

- **DataSource**
- **DataTarget**

You can fill the properties using existing DataBinding properties in the StepDesigner tool. See the sample format below:

```
{DataSourceBinding}{DataTargetBinding}
```

The format is converted to:

```
DataSource = "DataSourceBinding"
DataTarget = "DataTargetBinding"
```

If value in "DataBinding" does not match with the previous format, the value is assigned to "DataSource" property and "DataTarget" remains empty.

### DataSource

DataSource is a DataBinding property that defines how component data must be filled if you started the service report wizard for the first time and default value was empty.

See the data source list supported by Drive composer PC tool:

<table>
<thead>
<tr>
<th>Property</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>DateTimeNow</td>
<td>Defines current date</td>
</tr>
<tr>
<td>Par.G.I</td>
<td>Drive parameter group and index. For example, Par.1.11, means that Drive composer reads value from parameter group 1 and index 11 of the selected drive.</td>
</tr>
<tr>
<td>Info.ID</td>
<td>System info ID number or drive info defined by ID. For example, Info.1, means that Drive composer reads drive serial number.</td>
</tr>
<tr>
<td>UserEmail</td>
<td>Email ID of user logged in to Drive Installed Base service.</td>
</tr>
<tr>
<td>Drive</td>
<td>Data object received from Drive Installed Base service. For example, Drive.SerialNumber—reads drive serial number Drive.EndCustomer.Name—reads end customer name Drive.Site.StreetAddress—reads site address where the drive is installed</td>
</tr>
</tbody>
</table>
DataTarget

DataTarget is a DataBinding property that defines how to send value of current component to Drive Installed Base service. Drive composer sends the value to multiple object types of Drive Installed Base service.

DataTarget objects

The table below list the objects created based on DataTarget definitions:

<table>
<thead>
<tr>
<th>Object</th>
<th>Subtypes</th>
</tr>
</thead>
<tbody>
<tr>
<td>MaintainedComponent (collection of objects)</td>
<td>-</td>
</tr>
</tbody>
</table>
DataTarget examples

<table>
<thead>
<tr>
<th>If DataTarget = ...</th>
<th>Value fills this property</th>
</tr>
</thead>
<tbody>
<tr>
<td>DriveComposerServiceEvent.SerialNumber</td>
<td>SerialNumber in object type DriveComposerServiceEvent</td>
</tr>
<tr>
<td>ServiceEventEndCustomer.Name</td>
<td>Name in object type ServiceEventEndCustomer, which is defined as property EndCustomer in object type DriveComposerServiceEvent</td>
</tr>
<tr>
<td>ServiceEventWarranty.ResponsibleUnit</td>
<td>ResponsibleUnit in object type ServiceEventWarranty, which is defined as property Warranty in object type DriveComposerServiceEvent</td>
</tr>
</tbody>
</table>

The objects defined as collection, use the DataTarget in two ways:

**Fault.Code**—value from this component fills property **Code** in object type **Fault**. If you added more than one component, Drive composer sends only the value of first component in the page to Drive Installed Base service.

**Fault.Code|1...3**—based on components with three different bindings three objects of Fault type are created. You can define more than one collection element on one page.
Saving the DC wizard template in StepDesigner

After you designed a service report template with the StepDesigner tool using components, databindings, etc., save the template file to Drive composer reporting wizard format (.dcwiz) and set the file as custom printing template file format (.xaml). The custom printing template defines the common appearance of printed pages like header, footer, etc.

To save the template file,

1. In StepDesigner, go to **File → Save DC Wizard template**.

![Figure 205. Save DC Wizard template](image)

   The file is saved in .dcwiz format.

2. Click **Yes**, to set the file as custom printing template file (.xaml format) or click **No**, to use the default printing template.

![Figure 206. Set custom printing template](image)

**Note:**
- The template must contain a `ContentControl` named "cc".
- ABB recommends that you use the same name for both files for better identification.
Deploying a template file

The Service reporting (create_service_report.html) module contains all service report template files. You can see a range of entries in the Select service type list. Each entry refers to a template file.

To deploy a template file,

1. Create a template structure in StepDesigner tool. See Creating a template for Drive Installed Base service report (Internal use only) on page 204.
2. Save the file to StepDesigner format.
3. Create a .dcwiz file. See steps for Saving the DC wizard template in StepDesigner. ABB recommends that you use the same name for both files for better identification.
4. If you have multiple templates, repeat steps 1...3.
5. Create a zip file of the multiple files.
6. Upload the zip file to Drive Installed Base service portal. If you do not have the necessary permissions, you can request the Drive Installed Base team to upload the files.

Localizing service report templates

Consider the following points,

- Whenever you change the language settings in Drive composer, see the localized templates list in service types of Service reporting (create_service_report.html) module.
- Language files are recognized by their file names. For example,
  - File.dcwiz or File_en.dcwiz refers to English template file.
  - File_pl.dcwiz refers to Polish template file.
  - File_fi.dcwiz refers to Finnish template file.
- When you selected a language, all properties (Display Name, Description, Name, etc.) are translated to their respective languages.
- When you selected a language, the files matching that language selection are only visible. If a particular language file does not exist, then English version is displayed as default.

Example:

The below example cases show the list of files visible when you selected a language. The template file is a zip file of following files.
- File.dcwiz
- SecondFile.dcwiz
- ThirdFile_en.dcwiz
- File_fi.dcwiz
- FourthFile_fi.dcwiz

<table>
<thead>
<tr>
<th>Case</th>
<th>If language selected is...</th>
<th>The Select service type dropdown lists the following files:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Case 1</td>
<td>English</td>
<td>- File</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- SecondFile</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- ThirdFile_en</td>
</tr>
<tr>
<td>Case</td>
<td>If language selected is...</td>
<td>The Select service type dropdown lists the following files:</td>
</tr>
<tr>
<td>-------</td>
<td>---------------------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>Case 2</td>
<td>Finnish</td>
<td>• File.fi</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• SecondFile</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ThirdFile_en</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• FourthFile.fi</td>
</tr>
</tbody>
</table>
Annexure B: Radius authentication

Contents of this chapter

This chapter describes any additional information needed for Radius authentication.

See topics:

- Example: Network configurations via Ethernet connection ................................. 216
- ABB vendor specific attribute ............................................................................. 217
- Supported user access levels ............................................................................... 217
- Offline credentials ............................................................................................... 217
- Default credentials: ............................................................................................ 217
### Example: Network configurations via Ethernet connection

The table below lists the possible Ethernet configurations for Radius server authentication. See also *[RADIUS authentication](page 198)*.

<table>
<thead>
<tr>
<th>Connection type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Single drive - single server</strong></td>
<td>Drive composer PC tool is connected to a drive which is connected to the Radius server.</td>
</tr>
<tr>
<td><strong>Multiple drives - single server</strong></td>
<td>Drive Composer PC tool is connected to multiple drives via router and each drive is connected to a single instance of Radius server, thus each drive has the same set of users, who can authenticate.</td>
</tr>
<tr>
<td>(Recommended)</td>
<td></td>
</tr>
<tr>
<td><strong>Multiple drives - multiple servers</strong></td>
<td>Drive composer PC tool is connected to multiple drives via a router and each drive is connected to a separate instance of Radius server. This type of connection may cluster accessibility, and thus administration of drives and user credentials needs to be handled with care when settings are changed. It is also possible to have different set of authentication credentials in separate instances of Radius servers, which may allow login to all drives, or just to some drives.</td>
</tr>
<tr>
<td><strong>Multiple drives - multiple servers</strong></td>
<td>With Multiple drives - multiple servers connection (see in above row), there may be instances of server failure, for example, due to multiple requests at the same time. This kind of fault occurrences or server load can be overcome using a load balancer. For example, when the Radius server receives multiple requests, and if the first instance fails, then the second instance is activated automatically and allows to login.</td>
</tr>
</tbody>
</table>
ABB vendor specific attribute

Each user’s access level defined by the Radius server is based on the ABB vendor specific attribute defined for vendor id: 43194. The attribute contains one sub-attribute (id 1) containing a numeric value (uint32) defining the user access level. If this user access level is missing from the Radius server, drive will ignore the response as invalid.

The vendor specific attributes are defined based on the used Radius server and how it is configured. For more information, see the Radius server manual.

### Supported user access levels

<table>
<thead>
<tr>
<th>Value</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>None</td>
<td>User is defined in the Radius server, but login is disabled.</td>
</tr>
<tr>
<td>100</td>
<td>Basic</td>
<td>Login allowed, but cannot reconfigure Radius settings.</td>
</tr>
<tr>
<td>200</td>
<td>Service</td>
<td>Allows login and can change Radius settings using Drive Composer.</td>
</tr>
</tbody>
</table>

You cannot login with any other user access levels other than the above list. For more information about ABB vendor specific attribute, see Drives Wikipage.

**Offline credentials**

Offline credentials are used to connect to drives when the drive is not able to connect to the Radius authentication server.

Offline authentication is enabled only when:
- Radius authentication is enabled and Radius server configuration is valid in drive settings.
- Drive is able to send Radius Access-Request to Radius server without errors.
- Radius server does not respond at all (within the receive timeout of the drive).

By default the drive has at least one offline user credential to allow offline authentication. The offline credentials are defined in an XML format. For access to the XML file, contact your local ABB representative.

### Default credentials:

User name = *localuser*

Password = *localpassword*

User access level = *Service*

You can redefine the offline user credentials via Drive Composer. Go to **View → Settings → Radius config**.

**Note:**
- There may be limitations in the length of username and password. Follow the standard regulations.
- If the encoded output file cannot be read by drive, drive will discard it and use the default offline credentials defined in the drive.
Annexure B: Radius authentication
Further information

Product and service inquiries
Address any inquiries about the product to your local ABB representative, quoting the type designation and serial number of the unit in question. A listing of ABB sales, support and service contacts can be found by navigating to abb.com/searchchannels.

Product training
For information on ABB product training, navigate to new.abb.com/service/training.

Providing feedback on ABB Drives manuals
Your comments on our manuals are welcome. Navigate to new.abb.com/drives/manuals-feedback-form.

Document library on the Internet
You can find manuals and other product documents in PDF format on the Internet at abb.com/drives/documents.