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About this manual1.

Copyright1.1.

This document and parts thereof must not be reproduced or copied without written per-
mission from ABB, and the contents thereof must not be imparted to a third party, nor
used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and
may be used, copied, or disclosed only in accordance with the terms of such license.

Warranty

Please inquire about the terms of warranty from your nearest ABB representative.

http://www.abb.com/substationautomation

Disclaimer1.2.

The data, examples and diagrams in this manual are included solely for the concept or
product description and are not to be deemed as a statement of guaranteed properties.
All persons responsible for applying the equipment addressed in this manual must satisfy
themselves that each intended application is suitable and acceptable, including that any
applicable safety or other operational requirements are complied with. In particular, any
risks in applications where a system failure and/ or product failure would create a risk
for harm to property or persons (including but not limited to personal injuries or death)
shall be the sole responsibility of the person or entity applying the equipment, and those
so responsible are hereby requested to ensure that all measures are taken to exclude or
mitigate such risks.

This product is designed to be connected and to communicate information and data via
a network interface, which should be connected to a secure network. It is sole responsib-
ility of person or entity responsible for network administration to ensure a secure connec-
tion to the network and to establish and maintain any appropriate measures (such as but
not limited to the installation of firewalls, application of authentication measures,
encryption of data, installation of anti virus programs, etc) to protect the product, the
network, its system and the interface against any kind of security breaches, unauthorized
access, interference, intrusion, leakage and/or theft of data or information. ABB is not
liable for damages and/or losses related to such security breaches, unauthorized access,
interference, intrusion, leakage and/or theft of data or information.

This document has been carefully checked by ABB but deviations cannot be completely
ruled out. In case any errors are detected, the reader is kindly requested to notify the
manufacturer. Other than under explicit contractual commitments, in no event shall ABB
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be responsible or liable for any loss or damage resulting from the use of this manual or
the application of the equipment.

Conformity1.3.

This product complies with the directive of the Council of the European Communities
on the approximation of the laws of the Member States relating to electromagnetic
compatibility (EMC Directive 2004/108/EC) and concerning electrical equipment for
use within specified voltage limits (Low-voltage directive 2006/95/EC). This conformity
is the result of tests conducted by ABB in accordance with the product standards EN
50263 and EN 60255-26 for the EMC directive, and with the product standards EN
60255-1 and EN 60255-27 for the low voltage directive. The product is designed in
accordance with the international standards of the IEC 60255 series.

Trademarks1.4.

ABB is a registered trademark of ABB Group. All other brand or product names men-
tioned in this document may be trademarks or registered trademarks of their respective
holders.

General information1.5.

This manual provides thorough information on Grid Automation Controller COM600
(later referred to as COM600) and the central concepts related to it. The manual provides
information about COM600 features, installation and unistallation instructions for the
Station Automation Builder 600 (SAB600), and configuration and operation instructions
for SAB600. For more information on each topic related to a specific protocol, refer to
the list of related documents in 1.10, Related documents.

Document conventions1.6.

The following conventions are used for the presentation of material:
• The words in names of screen elements (for example, the title in the title bar of a

window, the label for a field of a dialog box) are initially capitalized.
• Capital letters are used for the name of a keyboard key if it is labeled on the keyboard.

For example, press the ENTER key.
• Lowercase letters are used for the name of a keyboard key that is not labeled on the

keyboard. For example, the space bar, comma key, and so on.
• Press CTRL+C indicates that you must hold down the CTRL key while pressing

the C key (to copy a selected object in this case).
• Press ESC E C indicates that you press and release each key in sequence (to copy

a selected object in this case).
• The names of push and toggle buttons are boldfaced. For example, click OK.
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• The names of menus and menu items are boldfaced. For example, the  File menu.
• The following convention is used for menu operations: MenuName > Menu-

Item > CascadedMenuItem. For example: select File > New > Type.
• The Start menu name always refers to the Start menu on the Windows taskbar.

• System prompts/messages and user responses/input are shown in the Courier font.
For example, if you enter a value out of range, the following message is displayed:

Entered value is not valid. The value must be 0 - 30 .

• You can be asked to enter the string MIF349 in a field. The string is shown as follows
in the procedure:

MIF349
• Variables are shown using lowercase letters:

sequence name

Use of symbols1.7.

This publication includes warning, caution, and information icons that point out safety-
related conditions or other important information. It also includes tip icons to point out
useful information to the reader. The corresponding icons should be interpreted as follows.

The electrical warning icon indicates the presence of a hazard
which could result in electrical shock.

The warning icon indicates the presence of a hazard which
could result in personal injury.

The caution icon indicates important information or warning
related to the concept discussed in the text. It may indicate
the presence of a hazard which could result in corruption of
software or damage to equipment or property.

The information icon alerts the reader to relevant facts and
conditions.

The tip icon indicates advice on, for example, how to design
your project or how to use a certain function.

9

COM600 series 5.11MRS756125

User's Manual



Terminology1.8.

DescriptionTerm

An abnormal state of a condition.Alarm

An OPC service for providing information about alarms and
events to OPC clients.

Alarms and Events; AE

COM600 as a generic name for COM600S IEC and COM600F
ANSI products

COM600 Series; COM600

An OPC service for providing information about process data to
OPC clients.

Data Access; DA

Part of a logical node object representing specific information,
for example, status, or measurement. From an object-oriented
point of view, a data object is an instance of a class data object.
DOs are normally used as transaction objects; that is, they are
data structures.

Data Object; DO

The data set is the content basis for reporting and logging. The
data set contains references to the data and data attribute val-
ues.

Data Set

A physical device that behaves as its own communication node
in the network, for example, protection relay.

Device

Change of process data or an OPC internal value. Normally, an
event consists of value, quality, and timestamp.

Event

A physical IEC 61850 device that behaves as its own commu-
nication node in the IEC 61850 protocol.

Intelligent Electronic Device

Representation of a group of functions. Each function is defined
as a logical node. A physical device consists of one or several
LDs.

Logical Device; LD

The smallest part of a function that exchanges data. An LN is
an object defined by its data and methods.

Logical Node; LN

Series of standards specifications aiming at open connectivity
in industrial automation and the enterprise systems that support
industry.

OPC

Representation of a connection to the data source within the
OPC server. An OPC item is identified by a string <object
path>:<property name>. Associated with each OPC item are
Value, Quality, and Time Stamp.

OPC item

Named data item.Property

The report control block controls the reporting processes for
event data as they occur. The reporting process continues as
long as the communication is available.

Report Control Block
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Abbreviations1.9.

DescriptionAbbreviation

Alarms and EventsAE

Data AccessDA

Data ObjectDO

Gateway, component connecting two communication networks togetherGW

Web Human Machine InterfaceWebHMI

International Electrotechnical CommissionIEC

Intelligent Electronic DeviceIED

Local Area NetworkLAN

Logical DeviceLD

Logical NodeLN

Network Control CenterNCC

Object Linking and EmbeddingOLE

OLE for Process ControlOPC

Protection & ControlP&C

Programmable Logic ControllerPLC

Program Organization UnitPOU

Request To SendRTS

Substation AutomationSA

Substation Configuration DescriptionSCD

Substation Configuration LanguageSCL

Sequential Function ChartSFC

Single Line DiagramSLD

eXtended Markup LanguageXML

Related documents1.10.

MRS numberName of the manual

1MRS756125COM600 User’s Manual

1MRS756705COM600 Operator's Manual

1MRS756740COM600 HMI Configuration Manual

1MRS756739COM600 Data Historian Operator's Manual

1MRS755001COM600 Sequence Control Configuration Manual
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MRS numberName of the manual

1MRS758689Master Protocols (Ethernet based) Configuration and Operation
Manual

1MRS758690Master Protocols (Ethernet based) Technical Reference Manual

1MRS758691Slave Protocols (Ethernet based) Configuration and Operation
Manual

1MRS758692Slave Protocols (Ethernet based) Technical Reference Manual

1MRS756567DNP 3.0 Serial Master (OPC) User's Manual

1MRS755495DNP 3.0 Serial Slave (OPC) User's Manual

1MRS755382IEC 60870-5-101 Slave (OPC) User's Manual

1MRS756703IEC 60870-5-101 Master (OPC) User's Manual

1MRS752278IEC 60870-5-103 Master (OPC) User's Manual

1MRS756738COM600 Logic Processor User's Manual

1MRS756126Modbus Serial Master (OPC) User's Manual

1MRS756913Modbus Serial Slave (OPC) User's Manual

Document revisions1.11.

HistoryProduct revisionDocument version/date

Document created3.0A/16.10.2006

Document revised3.0B/22.1.2007

Document revised3.0C/8.6.2007

Document revised3.1D/21.12.2007

Document revised3.2E/17.6.2008

Document revised3.3F/13.2.2009

Document revised3.4G/6.11.2009

Document revised3.5H/30.6.2011

Document revised4.0J/18.6.2012

Document revised4.1K/13.3.2015

Document revised5.0L/24.5.2017

Document revised5.1M/26.3.2018
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Introduction2.

General information about the COM600 series2.1.

The COM600 product series are versatile Substation Management Units that help realize
smart substation and grid automation solutions in industrial and utility distribution net-
works.

They get deployed together with protection and control IEDs, substation devices such
as RTUs, meters and PLCs in dedicated cabinets and switchgear.

The COM600 product is an all-in-one unit that functions as:
• Communication gateway
• Web Human Machine Interface (WebHMI)
• Automation controller
• Real-time and historical data management unit

The COM600 product series use process information and device data, acquired over
Ethernet or serial communication protocol interfaces to execute specific substation
functions and applications. Thus, they are critical building blocks to realize substation
secondary system solutions and in the process solving diverse customer needs.

COM600 product series variants and rationale2.2.

To facilitate substation and grid automation solutions in IEC and ANSI market areas, a
variant-based system similar to Relion® 615 and 620 series is being followed from
COM600 5.0 release.

The main reasons for such an approach are the following:

• To ensure all COM600 product series features are advantageously used in end-cus-
tomer projects in the medium voltage substation automation domain.

• To ensure an optimum feature set to be bundled together to realize specific applica-
tions required in IEC and ANSI market areas.

• To ensure a future-proof product approach.

This release then comprises of two variants, based on the primary intent or application
are defined as follows:
• COM600S IEC – COM600 for substation automation, analysis and data management

(for IEC markets)
• COM600S IEC is a substation automation, analyzer and data management unit

that integrates devices, facilitates operations, manages communication and runs
analysis applications pertinent to equipment or operations in utility or industrial
distribution substations.

• COM600F ANSI – COM600 as distribution automation controller (for ANSI markets)
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• COM600F is a dedicated distribution automation controller unit that runs dis-
tributed grid and feeder applications for ANSI power networks and inherits all
core features of the COM600 series.

Overview of COM6002.3.

COM600 provides gateway functions for mapping signals between protection and control
IEDs in industrial or utility substations and higher-level systems. It further includes an
optional WebHMI that provides data and information from the substation to the users.

COM600 gathers data from protection and control IEDs and from process devices using
different communication protocols. The supported protocols can be combined freely in
one station computer, limited only by the number of hardware interfaces and the license.
COM600 uses web technology to display data to different users in a professional and
user-friendly manner. The web technology is further used to transfer information to a
network control center (NCC) or distributed control system (DCS).

COM600 benefits from the potential of the IEC 61850 standard by using the IEC 61850-
6 substation configuration language (SCL) and IEC 61850 -7 communications modeling
regardless of protocol used. As the IEC 61850 data modeling is used for all communic-
ation protocols the gateway cross-reference is done in the same way regardless of the
protocol, for example IEC 61850-8-1 or DNP3. '

With the optional WebHMI, COM600 can be used for efficient substation visualization,
monitoring, and control. The supported browsers are Microsoft Internet Explorer, Mozilla
Firefox® and Google Chrome. Measured values from process devices are displayed on
the WebHMI. Single-line diagrams can be used to view any available measured values
from the process devices.
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Features3.

Gateway functionality3.1.

The Gateway functionality provides a framework that enables the use of OPC server and
client components, such as OPC Client for IEC 60870-5-101 and OPC Server for IEC
61850. This manual presents the principles that are common to the protocols available
at the moment as well as to those that will be applicable in the future. For protocol-specific
information , refer to the respective client and server user’s manuals.

COM600_Conceptual_View.png

Figure 3.1-1 Conceptual view of COM600 Gateway

1. Network Control Center (NCC)
2. Engineering PC with Station Automation Builder 600 (SAB600)
3. COM600 with embedded operation system, OPC client(s) for NCC connection(s),

OPC server(s) for process connection
4. Protection and control devices

Normally, there is one OPC client per NCC connection. If you want to create several
NCC connections with the same protocol, use multiple instances.
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COM600 consists of OPC Data Access (DA) server and client components. OPC Servers
are used mainly for master/client protocol stacks to provide access to the data in the
devices in the protocol. OPC Clients are used for slave/server protocol stacks to enable
external systems to access data available in the OPC Servers.

GWComponents.jpg

Figure 3.1-2 Example of COM600 Gateway components

WebHMI3.2.

WebHMI functions3.2.1.

The WebHMI enables the user to access the COM600 computer via a web browser.

The features of WebHMI include:
• Substation, Voltage Level and Bay Single Line Diagram views
• Busbar coloring
• Event lists
• Alarm lists
• Parameter settings
• Disturbance data upload
• System supervision
• Breaker and switch control
• Measurement display
• User management
• Data historian (optional feature)
• Disturbance data viewer (locally in COM600 computer)
• GOOSE Analyzer (optional feature)
• Sequence Control
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• Documents linked to primary device objects (text, image, and so on)
• Substation analytic reports
• Fault location, circuit breaker condition monitoring (optional feature)

sld_example.png

Figure 3.2.1-1 Example view of the COM600 WebHMI

The WebHMI can be accessed:

• locally via an optional local WebHMI screen
• locally by connecting your laptop to COM600 via LAN
• remotely through the internet or over LAN/WAN

Predefined user account3.2.2.

The predefined COM600 user account also works as a WebHMI administrator user
account. It’s not possible to modify it in any way from the WebHMI though. It cannot
be deleted, it’s not possible to change its user group and its password must always be
changed from SAB600.

OPC server3.3.

The OPC server component consists of a Master/Client Protocol Stack, OPC DA/AE
Server, and Configuration SCL.
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The protocol stack component implements the protocol functions, such as handshaking
signal handling, message coding/decoding, check sum calculations, polling logic, protocol
level timers, and so on. The OPC server/protocol handler implements the functionality
for publishing and updating data on the OPC interfaces and protocol conversion between
the OPC and the protocol stack using the common IEC 61850 data model.

The configuration of the OPC server and the protocol stack is handled using a configur-
ation parser. The OPC server is configured using SAB600. The configuration information
is exported to an SCL/XML configuration file according to the IEC 61850 SCL specific-
ation. When the OPC server is started, the configuration information is read from the
file.

ServerConcept_a.bmp

Figure 3.3-1 Conceptual view of OPC server

OPC client3.4.

The OPC client software consists of a Slave/Server Protocol Stack, OPC DA Client,
Configuration SCL, OPC Data Access Server and Alarm&Event server components for
diagnostic and control.

The protocol stack component implements the protocol functions, such as handshaking
signal handling, message coding/decoding, check sum calculations, polling logic, protocol
level timers, and so on. The OPC client/protocol handler implements the functionality
for data subscription from the OPC servers and protocol conversion between the OPC
and the protocol stack using the common IEC 61850 data model.

The configuration of the OPC client and the protocol stack is handled using a configura-
tion SCL. The OPC server is configured using SAB600. The configuration information
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is exported to the SCL/XML configuration file according to the IEC 61850 SCL specific-
ation. When the OPC client is started the configuration information is read from the file.

ClientConcept_b.bmp

Figure 3.4-1 Conceptual view of OPC client

Logic Processor3.5.

COM600 offers an straightforward approach to the languages specified by the IEC 61131-
3 standard for programmable logic controllers (PLC). The programmable logic processor
in COM600 is offered as a selectable software option. The PLC programming system
enables programming and execution of automation tasks. In addition, the IEC 61131-3
programming in COM600 offers on-line and off-line functionality for engineering and
diagnostics.

The Logic Processor OPC Server transfers information between CodeSys SP runtime
and other COM600 components, such as OPC servers, slave clients, and WebHMI.
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Logic Processor.bmp

Figure 3.5-1 Functional overview of Logic Processor

CoDeSys SP runtime system is manufactured by 3S-Smart Software Solutions GmbH
(www.3s-software.com).

Data Historian3.6.

The COM600 data historian is a real-time database designed and optimized for process
information management and extensive history recording. The data historian is based
on ABB’s cpmPlus Knowledge Manager software. It combines the benefits of an easy-
to-use real-time database with industrial reliability, performance, and real-time function-
ality to provide an excellent platform for process information management.
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The data historian can be used for accurate process performance monitoring by following
process and equipment performance calculations with real-time and history values.
Better understanding of the process behaviour by joining time-based process measure-
ments with production and maintenance events helps the user to understand the process
dynamics. It further provides required information for learning how to keep the process
running. High performance and reliability, together with maintenance-free operation,
provide a solid platform for trending.

The optional data historian functionality offers means of storing, analyzing and
presenting process data.

IEC 61850 data modeling3.7.

To simplify protocol conversion and signal mapping in the gateway, each component
uses a common data model. The data model is based on common data classes and services
specified in the IEC 61850 standard. Each client and server component is a separate
program. The components interact with each other only via OPC interfaces. This means
that they can be developed and used independently as a part of the gateway as long as
they conform with the OPC DA and common data model specifications.

Protection and control products are connected to the gateway via OPC interfaces. Although
OPC provides means to access data on devices, it does not specify the semantics of the
data. This means that the same information is available in different formats depending
on which device and communication protocol is used. In addition, services, such as
breaker operation, vary among devices and protocols.

These differences complicate the reuse of gateway applications. To overcome this
problem, all the applicable data and services are remodeled in OPC servers according
to the data and service model specified in the IEC 61850 standard. This provides a pro-
tocol and device independent interface between the applications and the process. Fig-
ure 3.7-1 presents an overview of the IEC 61850 model usage.
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IECmodelling.jpg

Figure 3.7-1 Overview of IEC 61850 model usage

The smallest unit in the IEC 61850 modeling is a data attribute which is linked to an
OPC item in the OPC server. A data attribute can be, for instance, the state value of a
double point object (stVal), quality information (q), or timestamp (t). In the OPC server,
some of the services are also mapped to the same level as the attributes. This means that,
for example, control services (such as ctlOperOn, ctlOperOff) for operating a double
point object are available as OPC items.

For different types of data, the IEC 61850 standard defines over 30 common data classes
including a set of mandatory and optional attributes and services. For example, common
data classes are defined for Controllable double point (DPC), Single point status (SPS)
and Measured value (MV).

Furthermore, the standard defines approximately 90 functional groups of data, based on
common data classes. These groups are called logical nodes. Examples of logical nodes
are controllable switch (CSWI) and distance protection (PDIS).

Logical nodes can be further grouped under logical devices (LD), forming logical groups
within a physical device (IED), see Figure 3.7-2.
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SAB600_IEC61850_Data_Modelling.png

Figure 3.7-2 IEC61850 data modelling

Station/Remote switch function3.8.

The COM600 gateway provides a common Station/Remote (S/R) switch functionality
for OPC servers and clients. The S/R switch is used to determine whether the objects in
a logical device of an IED can be controlled within the station, or remotely via a gateway.

A station can have one or more S/R switches. The switches are either physical switches
or software switches in a simulated IED of an OPC server. The S/R switches are modeled
using the IEC 61850 SPS, SPC, DPS, DPC, INS, or INC data class.

Each IED or logical device in an IED is linked with an S/R switch during the configuration
process. If a logical device has no linking information configured, the linking information
of the IED is used instead. At runtime, an OPC server publishes the logical device S/R
switch linking information for the OPC clients of the COM600 gateway. Each time an
OPC client sends a command to a device, it first checks the S/R switch position to
determine whether the operation is allowed or not. The COM600 gateway OPC client
is allowed to operate only if the S/R switch is in remote position.

A COM600 gateway OPC client has the operation modes disabled and enabled for S/R
switch handling. When the switch is in the enabled mode, the values for S/R switch
position failures are Allow controls if position unknown and Reject controls if position
unknown.

WebHMI is considered a local station WebHMI, if it uses the local display of the COM600
computer, or if the IP address of the WebHMI client is in the range specified with a
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Station IP Address Filter property in the Gateway object. Otherwise WebHMI is con-
sidered a remote WebHMI. The state of the station/remote switch controls whether the
operations are allowed from WebHMI or not.

The station/remote switch for the WebHMI is configured with the SLD editor by
inserting the Station Switch Indicator symbol to the substation SLD and specifying the
data object for the position information. If a real switch indication is not available, it is
possible to use a simulated data from a virtual IED. This can be done by creating an IED
configuration in the communication structure and setting the simulation mode of the IED
to true.

Edition 1 supports only Loc setting.

The new settings to be supported from Edition 2 are the data objects Loc, LocSta and
MltLev.

Loc functions similar to the current bay switch, when any relevant Loc is in Local position
then no control will be allowed from the COM600 WebHMI. Loc can be found on the
LN for used for the control operation (e.g. CSWI), in the LLN0 LN for the logical device
and in the LN for the switchyard equipment (e.g XCBR) used by the control LN.

LocSta is similar to the current station switch in semantics and it can be found in the
same places as Loc. However, only one LocSta instance will be checked (as opposed to
all relevant Loc instances), the one that is closest to the LN being operated, as it’s possible
to have different settings on different levels. The innermost one will take precedence.
LocSta for the switchyard equipment LN (if any) will not be checked, as the WebHMI
only operates on the LN above it.

MltLev can be used to allow operation from both local and remote WebHMI users at
the same time when LocSta.stVal = FALSE. Normally this means that only remote
WebHMI users will be allowed to operate, but if MltLev.setVal = TRUE, then both local
and remote WebHMI users may operate at the same time.

There’s no need to use the new LocKey data object in
COM600, Loc value will automatically follow LocKey value.

COM600 Watchdog3.9.

The COM600 computer has a built-in hardware watchdog function. The function can be
enabled with SAB600 from the Gateway object properties. When enabled, the watchdog
monitors the COM600 software. If the COM600 software fails to send the keep-alive
triggering to the watchdog within a certain time, the watchdog restarts the COM600
computer.
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External watchdog for COM6003.10.

COM600 can be configured to send periodically a command to an IED connected to
COM600. This function can be used to monitor the health of COM600. For example,
SACO 16D2 can be connected with SPA protocol to COM600 and configured to create
an alarm if no command from COM600 is received within specified time. Configuration
of an external watchdog device is described in 6.8, Configuring external watchdog for
COM600.

Network Fault Tolerance for COM6003.11.

COM600 can be configured to provide a certain level of tolerance against network failure
by using either the ABB DuoDriver feature or the Intel Teaming Feature, Switch Fault
Tolerance. These features are available when the optional dual port PCI Ethernet network
adapter is used.

DuoDriver

DuoDriver implements the Parallel Redundancy Protocol (PRP) for Ethernet as specified
in IEC 62439 DIS. PRP is based on duplicated networks, where each message is sent
via both networks, the receiver node accepts the first received message and discard the
duplicate. Message replication and discard function is done by the DuoDriver and it
hides the two networks from the upper level applications. In PRP there is practically no
switch over time in the case of one of the network fails as every message is always sent
to both networks. The diagnostic data can be further used on COM600 WebHMI and
gateway applications. See 6.9, Installing and configuring Duo Driver for installation and
configuration details.

Switch Fault Tolerance

The Switch Fault Tolerance feature of the Intel network adapter requires the Teaming
Feature to be enabled.

Teaming Features include Failover protection, increased bandwidth through aggregation,
and balancing of traffic among team members. Teaming Modes are AFT, SFT, ALB,
RLB, and EtherChannel*/3ad (LA/FEC/GEC/3ad). Only Failover protection using SFT
is supported by COM600.

Queuing of Process Data Updates3.12.

This section describes the common queue mechanism for OPC Clients (slave protocols)
in COM600. There can be additional queuing mechanisms on different levels of the
protocol stacks, that are specific for the protocol, which are not described here.
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Process data updates are queued in the OPC Clients of COM600. Each OPC Client has
its own queues independent from other clients, which prevents disturbances on one client
connection from interfering with other connections. There are four separate queues for
different type of data with configurable length.

• High Priority
• command replies/confirms
• internal protocol stack control commands
• protocol stack database initialization commands

• State Indications
• binary data and other state indications

• Measurements
• analog data

• Interrogated
• interrogation-related data and commands

Queue logic

For high priority and interrogated queues the oldest message is skipped when the queues
fill up. Generally these queues should never fill up since they contain a limited number
of updates (proportional to the number of OPC items).

When the state indication queue is full, the new updates are always skipped until there
is free space in the queue.

When the measurement queue is full, an older update is always skipped when a new
update is pushed the queue.

The updates are skipped according to the following logic:
• If an item has two or more updates, the oldest update is skipped
• If no item has two or more updates, the oldest update in the queue is skipped.

For measurements, older updates for an item are also skipped when the queue reaches
a configurable percent of the maximum capacity (but only if there is an item with multiple
outstanding updates to send).

Queue priorities

If a high priority queue contains an update, it is always sent first. After that, the interrog-
ated queue is checked. If none of these queues has updates, the state indications and
measurements are checked in round-robin fashion.
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Queue capacities

The capacity (maximum size) of each queue is independently configured. If one queue
fills up, capacity from another, possibly non-full queue is not used.

Event Printer3.13.

COM600 Event Printer enables printing of events as they arrive to COM600. The same
event information is presented on the COM600 WebHMI event list and printed on the
event printer. It is possible to customize the printout, for example, by selecting the
printed columns and their lengths. Alarming events can be marked with a configurable
symbol. For more information about the configuration of the Event Printer, see
6.4.5.3, Configuring COM600 event printer.

Currently supported printer models are Fujitsu DL3750+ and
DL3850+. Any dot matrix printer should work, but their
compatibility with COM600 cannot be guaranteed. If local
special characters are needed, check that the printer character
set supports them.

Event Printer is connected to a serial communication port (RS-232) of COM600 with a
null-modem cable (to be purchased separately).

For diagnostic purposes, Event Printer generates the following non-printable supervision
events to the WebHMI event list.

Table 3.13-1 Supervision events
DescriptionEvent

The event printer is incorrectly configured, the
events cannot be printed.

Failed to print event

Operating system print job limit reached. Pos-
sible reasons are that events are occurring
faster than the printer is able to print, or the
printer is offline. Printed events are still queued
in the internal printing queue.

Too many outstanding printing jobs, printer
problems?

Internal printing queue full. Possible reasons
are that events are occurring faster than the
printer is able to print, or the printer is offline.
New events will be discarded from the printing
queue, until there is place in the queue. The
size of the queue is configurable.

Printing queue is full, incoming events will no
longer be printed
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GOOSE Analyzer3.14.

The GOOSE Analyzer functionality in COM600 can be used throughout the entire life
cycle of the IEC 61850 substation automation system. It supports the commissioning,
maintenance and upgrade phases of the IEC 61850 system by means of communication
diagnosis enabling features, communication status follow-up and storing of GOOSE
events for auditing purposes.

GOOSE Analyzer consists of a server and a WebHMI. The GOOSE Analyzer server
includes a real-time analysis engine for diagnosing live GOOSE packets (messages) over
the connected subnetwork and outputting GOOSE events and GOOSE diagnostic events
to the historical database.

With the GOOSE Analyzer WebHMI, you can view the GOOSE connection diagram
with a real-time diagnosis and event list, query historical events, build GOOSE testers,
view reports and plot specific network load trend graphs.

Sequence control3.15.

COM600 offers a possibility to create control sequences. The sequence control feature
allows you to create sequences in the Logic Processor environment using the sequence
control library and control breakers through them. The created sequences can be controlled
using COM600 WebHMI. This feature requires the Logic Processor option. Configuration
sequences are described in the COM600 Sequence Control Configuration Manual.
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Technical data4.

Mechanical properties4.1.

COM600_connectors.png

Figure 4.1-1 COM600 interfaces shown in a high voltage model. The COM600 low voltage model
includes the same interfaces but without the AC text.

The technical data of COM600 is presented in the following tables.

Table 4.1-1 Dimensions
ValueDescription

10.45in (265.43mm)

12.38in (314.45mm) with mounting bracket

Width

4in (101.6mm)

4.68in (118.87mm) with mounting bracket

Height

9in (228.6mm)Depth

12lbs (5.44kg)Weight

Table 4.1-2 Power Supply
Type 2Type 1Description

24 - 60 V DC110 - 230 V AC 50 and 60Hz

125 - 250 V DC

Nominal Input
Voltage Un

50 ms at UnHold-up Time

19…72 V DC85…264 V AC

110…375 V DC

Input Voltage
Range

~45W @ max CPU load 1)Power Consump-
tion
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Type 2Type 1Description

10A/125VFuse type

1) Without option cards.

Table 4.1-3 Hardware
ValueDescription

Processor Intel Core i5-4590T Haswell Quad-Core 2.0GHz LGA
1150

Processor

System Memory 8 GB DDR3 204-Pin SO-DIMMSystem memory

Hard Drive 128GB Solid State DriveHard Drive

Lithium batteryReal Time Clock Battery

Table 4.1-4 Interfaces
ValueDescription

Serial Interfaces 3x RS-232; 2x RS-232/422/485 ConfigurableSerial interfaces

Ethernet Interfaces 2x GbE RJ-45Ethernet interfaces

Display Interfaces 1x VGA; 1x DVI-D; 1x Display PortDisplay interfaces

1x USB 2.0; 1x USB3.0USB

1x Line-out; 1x MIC-inAudio

Table 4.1-5 Optional PCI Extensions
ValueDescription

8x RS-232/422/485 ConfigurableSerial interfaces 1)

2x GbE RJ-45Ethernet interfaces 2)

2x 100FX LCFiber Optic Interfaces 3)

1) Operating temperature = 0 to 55° C; Storage temperature = -20° C to 85° C; Relative Humidity
= 5 to 95% (non-condensing)

2) Operating temperature = 0 to 55° C; Storage temperature = -40° C to 70° C; Relative Humidity
= 90% (non-condensing) at 35° C

3) Operating temperature = 0 to 50° C; Storage temperature = -25° C to 70° C; Relative Humidity
= 5 to 95% (non-condensing)

Table 4.1-6 Operating System
DetailsDescription

Windows Embedded Standard 8Operating System
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Table 4.1-7 Inspection of Mechanical Structure
ReferenceDescription

IEC 61850-3:2013 6.1Markings of Mechanical Struc-
ture

IEC 61850-3:2013 6.11, IEC 60529Degree of Protection by
Enclosure

IEC 61850-3:2013 6.6.1, IEC 60255-27Clearance and Creepage Dis-
tances

Table 4.1-8 Insulation Tests
ReferenceDescription

IEC 61850-3:2013 6.6.4, IEC 60255-27Dielectric Test

IEC 61850-3:2013 6.6.3, IEC 60255-27Impulse Voltage Test

IEC 61850-3:2013 6.6.6, IEC 60255-27Insulation Resistance

IEC 61850-3:2013 6.6.5, IEC 60255-2Protective Bonding Impedance

Table 4.1-9 Electromagnetic Compatibility Tests
ReferenceDescription

According to IEC 60601-1-2, IEC 61850-3:2013

• +/- Volts = 6 kV
• +/- Volts = 8 kV

Electrostatic Discharge
Immunity:

• Contact Discharge
• Air Discharge

According to IEC 61000-4-3:2010, IEC 61850-3:2013

Severity = 10V/m

Start Frequency = 80 MHz

Stop Frequency = 3,000 MHz

Modulation = 1kHz, 80%

Radiated Electromagnetic Field
Immunity

According to IEC 61000-4-4:2012, IEC 61850-3:2013

Amplitude = 2 kV

Amplitude = 1 kV

Amplitude = 1 kV

Electrical Fast Transient/Burst
Immunity

• Power Supply
• RJ-45 Port
• Serial Port

According to IEC 61000-4-5:2005, IEC 61850-3:2013

Test Level = 2 kV Line to Ground, 1kV Line to Line

Test Level = 1 kV Line to Ground, 0.5kV Line to Line

Test Level = 1 kV Line to Ground

Surge Immunity

• Power Supply
• RJ-45 Port
• Serial Port
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ReferenceDescription

According to IEC 61000-4-6:2008, IEC 61850-3:2013

Test level = 3 Vrms

Frequency Range = 0.15 MHz to 80 MHz

Conducted Radio Frequency
Immunity

According to IEC 61000-4-18:2009, IEC 61850-3:2013

Test Voltage = 0.5 kV

Test Voltage = 1 kV

Damped Oscillatory Waves

• Transverse
• Common

According to IEC 61000-4-11:2004, IEC 61850-3:2013

30% for 0.1 s

60% for 0.1 s

100% for 0.05 s

Voltage Dips, Interruptions and
Variations

According to CISPR 22:2010, IEC 61850-3:2013

Class A

Conducted Emissions

According to CISPR 22:2010, IEC 61850-3:2013

Class A

Radiated Emissions

Table 4.1-10 Environmental Conditions
ReferenceDescription

-10° C to 55° C 1)Operating Temperature Range

5 to 95% 1)Relative Humidity Range, Non-
Condensing

-40° C to 85° C 1)Storage Temperature

1) Without option cards. See table 4.1-5 for more information.

Table 4.1-11 Environmental Tests
ReferenceDescription

According to IEC 60068-2-2:2007, IEC 61850-3:2013

16h at 55° C

Dry Heat Test - Operational

According to IEC 60068-2-1:2007, IEC 61850-3:2013

16h at -10° C

Cold Test - Operational

According to IEC 60068-2-2:2007, IEC 61850-3:2013

16h at 85° C

Dry Heat Test - Storage

According to IEC 60068-2-1:2007, IEC 61850-3:2013

16h at -40° C

Cold Test - Storage
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ReferenceDescription

According to IEC 60068-2-2:2007, IEC 60068-2-1:2007, IEC
60068-2-14:2009 IEC 61850-3:2013

5 Cycles, 3h Dwells at Upper (55° C) and Lower (-10° C) Tem-
peratures, 1 C/min Ramp Rate

Temperature Change Test

According to IEC 60068-2-78:2001, IEC 61850-3:2013

10d at 40° C, 93% Relative Humidity

Damp Heat Steady State Test

According to IEC 60068-2-30:2005, IEC 60068-2-78:2001, IEC
61850-3:2013

6 Cycles (12 h + 12 h)

Upper Limit = 40° C, 93% Relative Humidity

Lower Limit = 25° C, 96% Relative Humidity

Damp Heat Cyclic Test

Table 4.1-12 Mechanical Tests
ReferenceDescription

According to IEC 60255-21-1, IEC 61850-3:2013

Class 1

Class 1

Vibration Tests

• Vibration Response Test
• Vibration Endurance Test

According to IEC 60255-21-2, IEC 61850-3:2013

Class 1

Class 1

Class 1

Shock and Bump Tests

• Shock Response Test
• Shock Withstand Test
• Bump Test

According to IEC 60255-21-3, IEC 61850-3:2013

Class 1

Seismic Test

• Single Axis Sine Sweep
(Method A)

Table 4.1-13 EMC Compliance
ReferenceDescription

61850-3:2013 – Communication networks and
systems for power utility automation – Part 3:
General requirements

Complies with 61850-3:2013

Table 4.1-14 Product Safety
ReferenceDescription

61850-3:2013 – Communication networks and
systems for power utility automation – Part 3:
General requirements

Complies with 61850-3:2013
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Table 4.1-15 RoHS Compliance
ReferenceDescription

2011/65/EUComplies with RoHS Directive

Software properties4.2.

The software properties of COM600 are presented in the following tables.

Table 4.2-1 Communication protocols
Slave protocolMaster protocol

DNP3 LAN/WANDNP3 LAN/WAN

DNP3 SerialDNP3 Serial

External OPC

IEC 60870-5-101IEC 60870-5-101

IEC 60870-5-103

IEC 60870-5-104IEC 60870-5-104

IEC 61850-8-1 Proxy (MMS & GOOSE)IEC 61850-8-1 (MMS &
GOOSE)

Modbus SerialModbus Serial

Modbus TCPModbus TCP

SNMP

SNTPSNTP

Table 4.2-2 Hardware requirements for SAB600
RecommendedMinimumHardware

SSD 128 GBFree hard disk space

Table 4.2-3 Supported operating systems 1)

Description

Microsoft Windows Server 2008 R2 (64-bit)

Microsoft Windows Server 2012 R2 (64-bit)

Microsoft Windows Vista (32-bit) SP2

Microsoft Windows 7 (32-bit/64-bit) SP1

Microsoft Windows 8 (32-bit/64-bit)

Microsoft Windows 8.1 (32-bit/64-bit)
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Description

Windows 10 (32-bit/64-bit)

1) Microsoft® .NET Framework 4.6.1 is required for running SAB600. The software is automatically
installed during the installation of SAB600 if not already available on the PC.

Table 4.2-4 Supported web browsers (WebHMI)
VersionDescription

10.0 or laterMicrosoft Internet Explorer

54.0 or laterGoogle Chrome

45.0 or laterMozilla Firefox

Other web browsers (except IE8 and older) will likely work but have not been tested.

Mounting of COM600 computer4.3.

The COM600 computer is designed for mounting at a control panel.

To mount the COM600 computer to the wall-mount kit:
1. See Figure 4.3-1 for mounting instructions.
2. After the brackets have been installed, fasten four screws on each bracket.
3. After fastening the two brackets on the bottom lid of COM600 computer, the wall-

mount kit installation is finished.

COM600_mounting.png

Figure 4.3-1  Mounting diagram of the COM600 computer
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For mechanical properties of the COM600 computer, see 4.1, Mechanical properties.

Setting up the COM1 or COM2 port for RS-232/RS-4854.4.

By default the COM1 and COM2 ports are configured to RS-232 mode. The mode of
the port (RS-232/RS-485) can be changed via the BIOS setup of the computer.

RS-485 mode can only be used with the Modbus serial master
protocol. For more information on configuration settings, see
Modbus Master User's Manual.

To change the mode of the port:
1. Connect a local keyboard and display to the COM600 computer.
2. Restart the computer and press the Del key during restart to access the BIOS setup.
3. Select Integrated Peripherals from the main SETUP menu. Use the cursor keys

for moving and enter key for selection.
4. Select SuperIO Device from the next menu.
5. On the SuperIO Device configuration page, go to the COM1 or COM2 Select

parameter and press ENTER. Now you can choose between RS-232 and RS-485.
6. Press the F10 key to save the changes and exit the BIOS setup.

Pinout of COM port when RS-485 mode is used:

DB9 connector:
1. TX-/RX-
2. N/A
3. TX+/RX+
4. N/A
5. GND
6. N/A
7. N/A
8. N/A
9. N/A

Disposing of COM6004.5.

Definitions and regulations of hazardous materials are country-specific and change when
the knowledge of materials increases. The materials used in this product are typical for
electric and electronic devices.

All parts used in this product are recyclable. When disposing of cast-off COM600 or its
parts, contact the local entrepreneurs who are authorized and specialized in handling
electrical/electronic waste. These partners can sort the material by using dedicated sorting
processes and dispose of the product according to the local requirements.
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Table 4.5-1 Materials of COM600 parts
MaterialPartCOM600

Aluminium

Steel (SECC)

PC2, PP3

Top cover, heat sink

Other covers, screws

Plastic parts

Case

Various

Various

Lithium

Compact flash disk

Modules inside the case

Battery

Modules

CardboardBoxPackage

Steel (SECC), PBT1

PC2, PP3

Accessory kit

DVD

Attached material

1. Polybutylene terephthalate
2. Polycarbonate
3. Polypropene
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Installation5.

About this section5.1.

This section describes the installation and uninstallation of SAB600, the installation of
the touch screen, and modifying and setting up of the COM600 computer. For more
detailed instructions on installation of the gateway components, refer to the 1.10, Related
documents.

It is forbidden to install SAB600 to the COM600 device.

Requirements for SAB6005.2.

The hardware requirements for SAB600 and supported operating systems are listed in
4.2, Software properties.

Installing SAB6005.3.

The SAB600 installation DVD includes the SAB600 software and different versions of
the CoDeSys programming environment dependent to the COM600 version. In the
installation wizard you can select, which software you want to install. For installation
of the CoDeSys programming environment, see Installing CoDeSys programming
environment.

To install SAB600:

1. Close all open programs and insert the SAB600 installation DVD to the CD-ROM
drive of your PC.

2. The installation program should start automatically. If the installation does not start,
open the program by browsing to the DVD drive, and start COM_600.exe. The
installation wizard includes the options to install the SAB600 software and different
versions of the CoDeSys programming environment. Select the software that you
want to install.

3. Wait for the Wise Installation Wizard to extract the installation files to your PC.
4. The SAB600 installation program opens. Click Next.

At any stage of the installation, you can return to the previous window by clicking
Back, or exit the Installation Wizard by clicking  Cancel.

5. Read the License Agreement, then check the option I accept the license agreement
and click Next to continue the installation.
If you check the option I do not accept the license agreement, the Next button is
not available and you cannot continue the installation.

6. Select the folder where you want to install SAB600.
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• To select the default folder shown at the bottom of the window, click Next.
• To select another folder, click Browse, select a new the folder, and click Next.

The default installation folder is C:\Program Files (x86)\ABB\COM600_2.
7. Select the desired installation type.

• Typical: This option is recommended for most users.
• Complete: All SAB600 features are installed.
• Custom: Use this option to choose which SAB600 features you want to be

installed.
8. Click Next to start the installation.

You can follow the progress of the installation in a window that also shows the dir-
ectory path where the files are copied. At this point, you can still cancel the install-
ation by clicking Cancel.

9. A window opens showing that SAB600 has been successfully installed. Close the
window and finish the installation by clicking Finish.

10. The installation wizard will next install the Microsoft SQL Server, if it is not already
installed on your PC.

11. Restart your computer.

Start SAB600 by selecting Start > Programs > ABB > Station Automation Builder
600 > SAB600 from the Windows task bar.

Installing CoDeSys programming environment

The SAB600 installation DVD includes also the CoDeSys programming environment.
In the installation wizard you can select, which software version you want to install.

1. Close all open programs and insert the SAB600 installation DVD to the CD-ROM
drive of your PC.

2. The installation wizard includes the options to install the SAB600 software and
CoDeSys programming environment. To install the CoDeSys programming envir-
onment, select the correct version and continue with the installation by clicking
Next.
The installation program should start automatically. If the installation does not start,
open the program by browsing to the DVD drive, and start setup.exe.

3. Continue with the installation by clicking Next on every page of the wizard.
4. When the installation wizard asks for the folder where to install the CoDeSys pro-

gramming environment, select C:\Program Files (x86)\3S CoDeSys 35SP9P4.
5. It is recommended to install all the features listed on the opening page.
6. Continue the installation and when completed, click Finish.

Updating SAB6005.4.

If you have replaced an old COM600 with newer version, update your project that contains
that Gateway object. The project is updated by a conversion wizard. The conversion can
be activated in two ways after you have installed the latest SAB600 software.
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Please run installation always with “Run as Administrator”
option, even if user has administrator rights.

To convert a project:
1. Open the old project in the new SAB600. The conversion wizard is launched auto-

matically. Follow the wizard instructions.
2. If the conversion wizard was canceled, you can run the conversion by right-clicking

on the Gateway object and selecting Convert project. Follow the wizard instructions.
3. Check the Gateway object properties to see if the COM600 version is the latest

version to confirm the conversion.

You can use SAB600 5.0 to configure COM600 versions 4.1
or later.

Setting up the COM600 computer5.5.

Accessing the COM600 computer5.5.1.

Local and Remote LAN ports

The COM600 computer has by default two LAN ports, a local port (LAN 1) and a remote
port (LAN 2), see Figure 4.1-1.

There are two firewall profiles: Private (home and work) and Public. The Private profile
is intended for a local substation LAN with substation protocols and SAB600 configur-
ation allowed. The Public profile is intended for remote LAN connection.

You cannot preconfigure a specific profile for a specific network adapter. Therefore,
you must select the correct profile when configuring COM600 and connecting it to the
network. The operating system tries to identify the connected network based on the
configured default gateway. If the default gateway is found, you can select the firewall
profile to be used for the network in Network Connections – open settings for the net-
work and turn sharing off to use Public profile or turn sharing on to use Private profile.
Network connections can be opened by clicking the network icon in the system notific-
ation area (systray) of the Windows Task bar.

For convenience a script has been added to configure the COM600 default network
profiles for the local and remote LAN connections. When the LAN connections to be
used are connected to their networks, then just run C:\Program Files\COM610 GW
SW\Common\bin\configure_network_types.cmd. This will set the Private profile for local
LAN connection and Public profile for the remote LAN connection.
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If no default gateway is configured or found, the network is considered unidentified. For
unidentified networks the firewall profile is selected based on the local security policy
settings. By default unidentified networks use the Public firewall profile. All unidentified
networks use the same profile.

To change the profile used for unidentified networks:
1. Select Control Panel > Administrative Tools > Local Security Policy.
2. Browse to Network List Manager Policies and modify the Location type in the

Unidentified Networks properties.

For more information about firewall configuration, see Microsoft Windows 8 Firewall
documentation.

By default, response to the ping command is blocked by the
firewall. To allow ping response, change the Allow incoming
echo requests configuration setting in the firewall's Advanced
ICMP Settings.

Table 5.5.1-1 shows the default IP addresses for the LAN ports.

Table 5.5.1-1 Default IP addresses for the LAN ports
IP AddressMaskGatewayLAN Port

Local Area Con-
nection (Local)

192.168.2.11255.255.255.0Not definedLAN 1

Local Area Con-
nection (Remote)

10.0.0.11255.255.255.0Not definedLAN 2

Some tasks, for example changing the IP addresses or adding users, require access directly
to the COM600 computer either locally or via the remote desktop software.

Accessing the COM600 computer:
• Locally by connecting a USB keyboard, a USB mouse, and a display to the computer.
• Remotely with the remote desktop program via LAN. By default the security settings

allow the remote desktop connection only via the interface reserved for the local
use.

Regional settings

The default regional setting is English (United States).

Remote desktop

You can use the COM600 computer as a local console from an engineering computer
with remote desktop.
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The COM600 computer can be restarted remotely by running restart.bat command from
the root of C drive. It is also possible to just click the Windows desktop, press Alt - F4
and then use the opened “Shut Down Windows” dialog. Restart or shutdown can be
selected from dropdown list.

Due to security reasons, the remote desktop access to COM600 computer is by default
disabled. To allow remote desktop access, you must enable and configure the settings
in the COM600 computer.

To allow remote desktop access:
1. In COM600 computer select Start -> Control Panel -> System.
2. In the System Properties dialog, select Remote tab page.
3. Select the Remote desktop access check-box.

Built-in user accounts

The following user account is predefined in the COM600 computer:
• Username: COM600
• Password: aEc2006rs

This is the main account of the COM600 computer. It is used for configuration purposes.
Processes of the COM600 computer are run under this account. It will also work as a
WebHMI user account and has in that context WebHMI administrator user rights.

Connecting configuration computer with SAB600 to COM600 computer

With COM600 version 3.4 or newer the COM600 user is not
anymore required in the SAB600 computer. Also the commu-
nication between SAB600 and COM600 computer is now
based on .NET remoting, which uses fewer ports to enable
easier access through firewalls.

For improved security, disable access from SAB600 to COM600 after the configuration
work is finished by disabling the port used by SAB600 in COM600 firewall exception
settings, or by disabling the remoting service in the COM600 computer (if firewall is
not used).

To disable access using firewall configuration:
1. Select Control Panel -> Windows Firewall -> Advanced settings -> Inbound

Rules.
2. Double-click SAB600 on the list and change the Action property to Block the

connection.

To disable access by disabling the remoting service:
1. Select Control Panel -> Administrative Tools -> Services -> ABB COM600

Remoting Server.
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2. Right-click and select Properties.
3. Stop the service and change the startup type to Disabled.

Alternatively, the remoting service can also be dis-
abled/enabled from the WebHMI. This is done from Commu-
nication – Security Settings – Configuration service. If the
COM600 product variant is using other configuration services
in addition to ABB COM600 Remoting Server, this option
will disable/enable these as well.

To configure the network settings:
1. Configure the network settings of the configuration computer and the COM600

computer to allow them to communicate with each other. This is done by configuring
the IP addresses of the computers into the same subnetwork. By default, the commu-
nication from SAB600 to the COM600 computer will use TCP port 8080. Make
sure that the port is opened in the firewall of the SAB600 computer. For callbacks
from COM600 computer another port is required. This is used by the spontaneous
updates in the online diagnostic tools. By default, the software reserves a free port
for the callbacks automatically.

2. Connect either a crossover LAN cable between the computers or connect both
computers to a network switch. Use the LAN port used for local use in COM600
computer.

3. Create a project and add the Gateway object to the communication structure.
4. Type the IP address of the COM600 computer LAN port used for configuration to

the IP address property of the Gateway object.
5. Right-click the Gateway object and select Management. Verify that the communic-

ation with the COM600 computer is working properly. The first time you open the
management tool, you are required to change the COM600 user password. Click
Change password to change the password in the COM600 computer.

The COM600 user password must always be changed as
described above to ensure that the password is changed cor-
rectly for each component in the COM600 computer.

If you lose the password, you cannot access the COM600
computer either locally or remotely.

The user must run the GAT Server Config utility in the
COM600 computer after the IP address is changed if the
GOOSE Analyzer is used.

Setting the remoting communication parameters
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To change the port number used for the communication from SAB600 to the COM600
computer:
1. Modify the Port Number property of the Gateway object in the SAB600 project.
2. In COM600 computer, select Start -> All Programs -> ABB -> SetRemotingPara-

meters.
3. Set the port number in Set Remoting Parameters utility.
4. Click Apply.

If multiple network adapters are used in COM600, you must specify the one used for
the SAB600 communication. In the Set Remoting Parameters utility, select the IP address
of the COM600 network adapter used for the SAB600 communication.

To change the port number used for the callbacks from COM600:
1. Close the SAB600 program.
2. In SAB600 computer, select Start -> Programs -> ABB -> Station Automation

Builder 600 -> Set Remoting Parameters.
3. Set the port number in the Set Remoting Parameters utility.
4. Click Apply.
5. Restart the SAB600 program.

If multiple network adapters are used in SAB600 computer, you must specify the one
that is used for the COM600 communication. In the Set Remoting Parameters utility,
select the IP address of the SAB600 network adapter used for the COM600 communic-
ation.

SAB600_Set_Remoting_Parameters.png

Figure 5.5.1-1 Setting Remoting Parameters in SAB600
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Configuring COM600 without keyboard and mouse5.5.2.

A headless COM600 is delivered without a local display and keyboard. It is configured
using the web interface, remote desktop, and SAB600. In order to configure the COM600,
it should have the factory default settings.

Configuring a headless COM600:

1. Start the COM600 computer.
2. Connect the engineering computer to the COM600 computer with a web browser.

Use the Local LAN port (192.168.2.11). Login as COM600 user with the default
password.

In order to connect, you may have to temporarily change
the IP settings of the engineering computer to use the
same subnet as the COM600 computer.

3. In the COM600 WebHMI, navigate to Communication > Security Settings >
Remote desktop settings. Select one of the allow connections options and click
Apply. Remote desktop connections will now be enabled for the COM600 computer.

config of headless com600 - sec settings.png

Figure 5.5.2-1 Security settings

4. Connect with remote desktop from the engineering computer to the COM600 com-
puter using the same Local LAN port.

5. In the COM600 remote desktop session, configure Windows Firewall as described
previously in Local and Remote LAN ports to use the Private profile for the Local
LAN port. This is necessary to allow SAB600 to connect later on.

6. If necessary, change the network and IP settings for the COM600 computer:
If the IP address used for the remote desktop connection is changed, the remote
desktop session will freeze. In this case, just close it and reconnect to the new

a.
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IP address. Make sure to write the new IP address up before applying so it’s
not forgotten!

b. If the IP settings of the engineering computer were temporarily changed in step
2, then change them back here so they are compatible with the new IP settings
of the COM600 computer.

c. If the new COM600 IP address will be used for SAB600 connections, connect
again with remote desktop and run the Set Remoting Parameters utility from
the COM600 desktop to select and apply the new IP address.

Now you can connect SAB600 from the engineering computer to the COM600 computer
for further configuration.

If remote desktop connections to COM600 computer are no
longer needed, they can be disabled using the Security Set-
tings in the COM600 WebHMI.

Uninstalling SAB6005.6.

To uninstall SAB600:

1. Open the Add or Remove Programs dialog by selecting Start > Settings > Control
Panel > Add or Remove Programs in the Windows task bar.

2. Select SAB600 and click Remove.

The uninstallation only removes SAB600 so that you can
install a new version and update the software. It does not
remove the Microsoft SQL Server and .Net Framework.
Removing these programs may infect the functionality of other
ABB applications installed on your PC.

Uninstalling CoDeSys

1. To open the Add or Remove Programs dialog, select Start > Settings > Control
Panel > Add or Remove Programs in the Windows task bar.

2. Select CoDeSys and click Remove.
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Turning off COM600 computer5.7.

To turn off a COM600 computer when a local display, keyboard and mouse are connected
to the COM600 computer:
1. Login as a user that has administrator privileges to COM600 WebHMI (if COM600

browser is used).
2. Select Start menu > Shut down, or select CTRL+ALT+DEL and click Shut down

in the bottom right corner power button symbol.

If the remote desktop session is active, run the shutdown.bat located in the C:\ of the
COM600 computer. It is also possible to just click the Windows desktop, press Alt - F4
and then use the opened “Shut Down Windows” dialog. Shutdown can be selected from
the dropdown list.

If no desktop is available, press the front panel power button briefly and wait until the
computer shuts down.
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Configuration6.

Opening a project in Station Automation Builder 6006.1.

This section describes the configuration tasks common to all OPC servers, and gives an
overview of the configuration tasks related to OPC clients.

All the possible configuration scenarios are not included in
this manual. Refer to the corresponding user’s manuals listed
in 1.10, Related documents for more detailed instructions.

Configuration and maintenance6.2.

SAB600 is used to configure and maintain COM600. Communication networks are
described in the Communication structure of the Project Explorer window. The structure
is built using OPC server/client, communication channel/subnetwork, and device objects.
These objects have communication properties that can be accessed via the Object Prop-
erties window. The properties define for example the communication port, bit rate, timing
parameters, unit addresses, and so on .

The substation structure of SAB600 is used to configure the WebHMI functions of the
COM600 products. The substation structure presents the functional view of the substation.
It includes substation, voltage level, bay, busbar, and conducting equipment objects.

The Single line diagram is a graphical presentation of the process objects in the substation.
The Single line diagram can be edited on different levels. The bay layout can be con-
figured by opening the SLD Editor from a bay object. When the SLD Editor is opened
from a voltage level object, it is possible to assign the positions of the bays within a
voltage level. The position of the voltage levels in the complete substation single line
diagram is done by opening the SLD editor from the substation object.

Substation objects are linked to communication structure objects by using the Data
Connection tool. For example, the circuit breaker object in the substation structure is
linked to the CSWI logical node in the communication structure. The link between the
structures is also used on the event list, to present the events using the names according
the substation structure.

Process data accessible on the devices is modeled according to the IEC 61850 standard.
In the communication structure this is seen as logical devices (LD), logical nodes (LN)
and data objects (DO). It is possible to insert an empty device into the structure and then
manually add and configure LD, LN, and DO objects. It is also possible to use pre-con-
figured object types of the devices, which have the objects defined and configured to
add efficiency. The device configuration can also be imported from an IED SCL
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description. Data objects include configuration properties, that contain cross-referencing
information between protocol and the OPC/IEC 61850.

Process data is connected to a Gateway client using a Cross-References function available
in the client IED object. Data objects that are transferred to the client are dragged from
the servers on the structure to the function tool. Cross-referencing information is filled
in the function window. The Cross-References function supports import and export with
Microsoft Excel.

When the structure is complete and all the objects have been set up properly the config-
uration is downloaded to COM600 using the Gateway Management function available
on the Gateway object.

The Logic Processor function is programmed with a separate programming editor.

Recommended Maximum Configuration6.3.

We have analyzed the recommended maximum configuration for COM600 for IEC
61850 Communication with WebHMI and Data Historian configured.

Based on this configuration we recommend the following amount of connected IEDs or
maximun load of 90 load units, as shown in the table below.

Load UnitIED CountIED Family

1,560611 series

245615 series

330620 series

190630 series

190670 series

It is also recommended not to exceed the amount of 30 IEDs per IEC 61850 OPC Server
Instance.

For example if project consist following combination of devices:

Load UnitIED CountIED Family

4020615 series

2020630 series

155620 series

7545Total
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This means that Maximum Load Unit count of 90 has not been exceeded. Count of 45
IEDs in system means that IEDs should be divided between two IEC61850 OPC Server
instances. For more information, see 4.1, Mechanical properties.

Configuration process6.4.

Overview of configuration process6.4.1.

Before you can start using COM600, build and configure the communication and substa-
tion structure of your project in SAB600.

Start SAB600 and open and name a project.

1. Select File > Open/Manage Project....
2. In the Open/Manage Project dialog, select the required location for the project:

• Projects on my computer
• Projects on network

3. Select New Project on the left.
• Enter a Project Name. The Description is optional.

4. Click Create.
5. Click Open Project.

A project can have only one COM600 configuration.

Figure 6.4.1-1 shows an example view of SAB600 including an object tree in the Com-
munication structure on the left and property window displaying the object properties
on the right.
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SAB600_Example_View.png

Figure 6.4.1-1 Example view of SAB600

The configuration can be divided into three tasks:

1. Building the object tree and configuring the object properties for OPC servers
(process communication).

2. Building the substation object tree and configuring the object properties for WebHMI
functions.

3. Activating COM600 with a new configuration.

First, build an object tree by adding objects to the object tree. Building the object tree
can be done using the COM600 Configuration Wizard (see 6.4.2, COM600 Configuration
Wizard ) or building each part separately (see 6.4.3, Building and configuring object
structures). For more information refer to the respective user’s manual listed in
1.10, Related documents. Connectivity packages for certain protection and control
products usually contain preconfigurations and tools to facilitate the building of the
object tree.

COM600 Configuration Wizard6.4.2.

To configure COM600 with COM600 Configuration Wizard:
1. Define the IP address and port number of the COM600 device on the Communica-

tion Page of the wizard.
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SAB600_Wizard_Communication.png

Figure 6.4.2-1 COM600 Configuration Wizard Communication Page

2. Define the desired functionality of the COM600 device on the Product Selection
Page of the wizard. If the COM600 device is already reachable through the network,
you can read available functionality from the device. Options readable from the
device include master and server protocols and other functionality such as Data
historian and Logic programming.
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SAB600_Wizard_OrderCode.png

Figure 6.4.2-2 COM600 Configuration Wizard Product Selection Page

3. Add the desired protocols on the Server Page of the wizard. If you have created
IEC 61850 protocol settings earlier with an external tool such as PCM600, it is
possible to import the SCD file. For legacy protocols, such as SPA, the import option
is not available.
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SAB600_Wizard_Server.png

Figure 6.4.2-3 COM600 Configuration Wizard Server Page

4. If you have created a COM600 configuration for Condition Monitoring & Protection
related applications, import the associated file. The wizard will configure the
necessary functionalities automatically.
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SAB600_Wizard_ProductSpecific.png

Figure 6.4.2-4 COM600 Configuration Wizard Product Specific Server Page

5. Select the desired slave protocols on the Client Page of the wizard.
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SAB600_Wizard_Client.png

Figure 6.4.2-5 COM600 Configuration Wizard Client Page

6. You can include preconfigured or additional servers to the configuration on the
Optional Servers Page of the wizard. Preconfigured servers contain a skeleton
configuration that can be used.

56

1MRS756125COM600 series 5.1

User's Manual



SAB600_Wizard_OptionalServers.png

Figure 6.4.2-6 COM600 Configuration Wizard Optional Servers Page

7. Check the selected configuration options on the Summary Page of the wizard. Click
Finish to start the configuration process.
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SAB600_Wizard_Summary.png

Figure 6.4.2-7 COM600 Configuration Wizard Summary Page

8. After the wizard has generated the structures, it will ask you to fill in properties for
functionalities such as SNTP OPC Server, if they have been selected in the wizard.
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SAB600_Wizard_Property.png

Figure 6.4.2-8 COM600 Configuration Wizard Property Page

After the wizard has finished the configuration process, the created project is opened
automatically.
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SAB600_Wizard_ProjectCreated.png

Figure 6.4.2-9 COM600 Configuration Wizard complete

Building and configuring object structures6.4.3.

Naming conventions6.4.3.1.

Objects in the communication structure shall follow the nam-
ing conventions defined in the IEC 61850-7-2, chapter Naming
Conventions.

OPC servers6.4.3.2.

Start the configuration work from the server objects. Before an OPC client can be taken
into use, configure an OPC server for the process communication.

The object tree is built in the communication tab of SAB600. There are several possible
ways to build an object tree. One of them is to build the object tree by adding objects in
logical order starting from the OPC server object. You can either use basic or pre-defined
objects. Using basic objects means that you have to configure the objects manually. If
objects are pre-defined, they are preliminary configured and all the necessary child
objects are automatically added.

Add the objects in the following order:
1. OPC server object
2. Channel/Subnetwork object depending on protocol
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3. Device object
4. Logical device object(s)
5. Logical node object(s)
6. Data objects.

If you want to connect events or scales to data objects or
device connection status event classes to device objects at this
point, make sure that you have already created and configured
the event and scale objects.

For more detailed information on adding objects to the object tree, refer to the appropriate
protocol manual (see 1.10, Related documents).

Substation structure for WebHMI6.4.3.3.

Configuring the substation is the main task in configuring WebHMI functionality. If
connectivity packages or IED SCL description files with substation structure information
are used, most of the substation structure can be built automatically when the IEDs are
added to the communication structure. If no substation structure information is available
the structure must be built manually.

Before you can create a substation structure, you have to create
a communication structure with OPC Server and communica-
tion channel objects, IEDs, Logical Devices, Logical Nodes
and Data objects.

For more detailed information, see COM600 HMI Configuration Manual.

OPC clients6.4.3.4.

The object tree is built in the communication structure. Before an OPC client can be
taken into use, configure an OPC server for the process communication.
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SAB600_OPC_Client_Example_View.png

Figure 6.4.3.4-1  Example of OPC client communication structure

The OPC client object is added to the same hierarchy level as the OPC server, see Fig-
ure 6.4.3.4-1. Below the OPC client object, you can add only channel and device objects.
The data objects are linked using the Cross-References function from the servers to the
client and further to the NCC. The Cross-References function can be also used to con-
figure the parameters of the data objects.

Add the objects in the following order:
1. OPC client object
2. Channel/Subnetwork object depending on protocol
3. Device object.

Configuring object properties6.4.3.5.

After the objects have been added, configure the object properties.

To configure an object:
1. Select an object in the object tree of the Communication structure.
2. The object properties appear now in the Object Properties window, see Figure 6.4.3.5-

1. You can see the selected object on the left and the available properties on the
right.
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SAB600_Object_Properties_Example.png

Figure 6.4.3.5-1  Example of object properties

3. Select the property you want to configure. Depending on the property value type,
configuring is always done either by
• selecting a predefined value from a drop-down combo box, or
• entering a text string or a numerical value in a text field.

With SCL import function, you can import new objects with configurations from an
existing file. Right-click the device and select SCL Import from the shortcut menu.

To import a new configuration file:
1. Click Choose File.
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2. Browse to a new configuration file from the appearing dialog.
3. Select the file and click Open.
4. Select the device to import from the drop-down list. You can preview the configur-

ation on the right.
5. Click Import.

The new preconfigured objects appear in the object tree. If the configuration file is large
the import can take time. To import a configuration file for a different device, right-click
the device, select SCL Import again and repeat the steps.

For detailed information about the SCL Import function, see 6.4.3.6, SCL Import function.

SCL Import function6.4.3.6.

You can import the communication structure under OPC Server or a single IED object.
If an OPC Server configuration file is used, the whole communication structure is
imported. Configurations for single IEDs can be imported by selecting the SCL Import
function under an IED object.

The file extensions for the import files can be .icd, .cid, .iid, .scd, .sed, or .xml.

To import a configuration file:
1. Right-click the OPC Server or IED and select SCL Import from the shortcut menu.

SAB600_SCLImport_Example.png

Figure 6.4.3.6-1 Example of IEC 61850 OPC Server SCL Import

2. Click Select File.
3. Browse for a new configuration file from the opening dialog.
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4. Select the file and click Open.
5. In the dropdown menu, select the OPC Server, subnetwork or IED, and accesspoint

(depending on whether the SCL import has been selected from OPC Server or IED
object) to be imported.

SCLImport_OPCServer.png

Figure 6.4.3.6-2 Selecting OPC Server to be imported

6. Click Next to proceed to communication options.
7. Select the desired communication options in the Communications Options page.
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SCLImport_communicationOptions.png

Figure 6.4.3.6-3 Communication options

You can select the following options:
• Filter Data Objects that don't belong to DataSet: By selecting this option,

you can enhance performance. This option limits the amount of data objects
being created in SAB600, meaning that if a data object does not belong to any
data set, it will not be created in to the SAB600. Some IEDs can provide large
amounts of data that is not reported (that is, not updated) in COM600 WebHMI.

• Overwrite existing descriptions: This option overwrites all existing descriptions
of objects affected by the import operation.

Select this option only if you know that the imported
file contains better descriptions than your current
configuration.

• Import protocol configuration (sAddr): When selecting this option, both the
object tree and protocol configuration will be created. If you do not select this
option, only the object tree structure will be created.

• Overwrite Limit settings: This option overwrites all configured unit and limit
configurations and assigns them values from the SCL file.
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• Check Report Control Block for Client Identity: This option imports IEDs
from the file in which the Report Control Blocks' client identity matches the
selected OPC Server.

• Check Configuration Revisions: By selecting this option, the configuration
revision attributes of the project are compared with the SCL file to be imported.
If differences are found, the IED configuration will be updated. If no differences
are found, the IED configuration will not be updated. This will improve the
performance of the import, as only the IEDs with changed configuration will
be imported.

Not every option in the SCL Import function is
available for all protocols.

8. Click Next to proceed to the Substation Options page or Import if you do not want
to change options in the following pages.

Additional SCL import options

In the following are presented the SCL Import options for the following pages: Substation
Options, Configure Alarm and Event Template, Configure Parameter Filtering Tool
Template, Configure SLD Template, Configure Summary Table Template. You can
choose the options you want or proceed to Import without changing the options.

Substation Options
1. On the Substation Options page, the following option can be selected:

Import substation information:This option imports the substation structure.
If you only want to import the communication section, do not select this option.

•

• For each IED, you can select which substation, voltage level, and bay is
imported. You can select them in a dropdown menu. You can edit the names
by double-clicking the object name (or pressing Enter or Ctrl + E when the
object is selected) in the tree view on the Substation page. Select the edited
name by pressing Enter or cancel the edit by pressing Esc.
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SCLImport_substationOptions.png

Figure 6.4.3.6-4 Substation options

2. Click Next to proceed to the Configure Alarm and Event Template page or Import
if you do not want to change options in the following pages.

Configure Alarm and Event Template
1. Select the Alarm and Event Template for IEDs on the Configure Alarm and

Event Template page.
2. Select the Use Template checkbox if you want to use the Alarm and Event Template

when the IED is imported. You can select one of the predefined templates in the
dropdown menu to set the alarm and event handling for the imported objects. There
are two template options:
• General Phase Tripping: By selecting this template, protection functions are

configured to send general alarms and events regardless of which phase is
activated. Depending on the device, phase-specific information may be provided.

• Single Phase Tripping: By selecting this template, protection functions are
configured to send phase A, B, or C-specific alarms and events, depending on
whether the device provides phase-specific information.
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SCLImport_AETemplate.png

Figure 6.4.3.6-5  Alarm and Event Template

You can also create your own templates if you are familiar with the issue:
• Browse to C:\PCMDataBases\COM600\TemplateManager.
• Copy the AETemplatephasetrippingmapping.xml file from the folder

to the directory and give it a meaningful name.
• Open the file in an XML editor.
• Enter the name of the new template in the AETemplateName element.
• Add or modify mappings in the LNClass and DO elements. Use the

information in the file as a guide.
3. Click Next to proceed to the Configure Parameter Filtering Tool Template page or

Import if you do not want to change options in the following pages.

Configure Parameter Filtering Tool Template
1. Select the parameter filtering tool for IEDs on the Configure Parameter Filtering

Tool Template page.
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SCLImport_PFTTemplate.png

Figure 6.4.3.6-6 Parameter Filtering Tool Template

You can use the Parameter Filtering Template to set predefined parameters for the
IED.
• If you want to use the parameter filtering tool template when importing the

IED, select the Use Template checkbox.
• Select a template in the dropdown menu. The dropdown menu shows the tem-

plates that are stored in C:\PCMDataBases\COM600\TemplateManager.
You can also browse for a template in another location.

• You can create templates by using the Export function in the Parameter Fil-
tering Tool.

2. Click Next to proceed to Configure SLD Template page or Import if you do not
want to change options in the following pages.

Configure SLD Template
1. Select the SLD template for IEDs on the Configure SLD Template page.
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SCLImport_SLDTemplate.png

Figure 6.4.3.6-7  SLD Template

You can use the SLD template to set the predefined substation structure for the IED.
• If you want to use the SLD template when importing the IED, select the Use

Template checkbox.
• Select a template in the dropdown menu. The dropdown menu shows the tem-

plates that are stored in C:\PCMDataBases\COM600\TemplateManager and
the name of which start with "SubstationTemplate". You can also browse for
a template in another location.

• You can create templates by using the CID Export function under IED object.
2. Click Next to proceed to the Configure Summary Table Template page or Import

if you do not want to change options in the following pages.

Configure Summary Table Template
1. Select the Summary Table Template for IEDs on the Configure Summary Table

Template page.
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SCLImport_SSTTemplate.png

Figure 6.4.3.6-8  Summary Table Template

You can use the Summary Table Template to set predefined summary tables for
IEDs in Substation and Bay objects.
• If you want to use the Summary Table template when importing the IEDs, select

the Use Template checkbox.
• Templates stored in C:\PCMDataBases\COM600\TemplateManager are

shown in the tree view on the left side of the Configure Summary Table Tem-
plate page. You can move the templates under the chosen Substation or Bay
object by using the arrow buttons. When you select a template that you have
moved, you will see the IEDs under that object.

• You can create Summary Table templates by using the Summary Table Con-
figuration Tool under the Substation and Bay objects.

2. Click Import to import the selected file.

The new preconfigured objects appear in the object tree. If the configuration file is large,
the import may take some time.

System Consistency Check6.4.3.7.

System Consistency Check is intended to be used with IEC 61850 protocol to check that
the IED configurations currently used in the COM600 project are consistent with the
compared IED configurations. According to the IEC 61850 standard, IEDs can have two
configuration revisions: one for data model and one for reporting. Configuration revision
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for data model is modeled on the LD0\LLN0\NamPlt\configRev object. It is the most
important indicator of the configuration revision. Additionally, each Report Control
block has a confRev attribute that defines the revision and the DataSet of RCB. System
Consistency Check checks each LDs LLN0\NamPlt\configRev and confRev of each
RCB.

The GUI tool is divided into two tabs: the first tab gives an overview of the project with
the configuration consistency status of the IEDs. The second tab is used for setting the
options for the update procedure. Additionally, by clicking Details, a dialog on consist-
ency differences is shown.

Choose between the offline and online mode by selecting the corresponding radio button.
When the tool is started, it will automatically perform the offline check. In the offline
mode, the IED configuration revisions used in the SAB600 project are compared to the
specified IED configuration files. When the IED configuration file is imported to SAB600,
the file name and location are saved, and the information is later used by the System
Consistency Check tool. To enable the correct result of the comparison, always store the
changed configuration files with the same name to the same location as the originals. If
the location or the file name has changed, you can browse the new file with the Browse
button. If the configuration is inconsistent, click the Details button for more detailed
information.

In the online mode, configuration revisions are read from the IEDs and compared to the
current SAB600 project configuration. To use the online mode, the IEDs must be con-
nected to the same network with the computer running SAB600. After you have selected
the online mode, start the check by clicking the Start check button. Interrupt the check
by clicking the Stop Check button. For certain IEDs, it is possible to fetch the configur-
ation file from the IED, such as SPA-ZC 40x. To enable this, the FTP user and password
properties need to be correctly configured in the IED object.
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SAB600_SCC_View.png

Figure 6.4.3.7-1 System Consistency Check view

SAB600_SCC_Options.png

Figure 6.4.3.7-2 System Consistency Check Options view
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SAB600_SCC_Details.png

Figure 6.4.3.7-3 System Consistency Check Details view

The Details view shows added or deleted LDs and RCBs. Additionally, it shows the
modifications to the content of LD or RCB.

Cross-References function6.4.3.8.

Data objects are added differently for OPC clients than for the upper level objects. Drag
and drop the data objects you need from an OPC server to the slave. You also can select
an upper level (server, channel, and so on) object and drag and drop it into the Cross-
References function. As a result, all the data objects within the selected object appear
in the Cross-References function and can be connected to the slave OPC client.
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SAB600_Cross_References.png

Figure 6.4.3.8-1  Cross-References function

In the Cross-References function, you can use a filter file to leave out some of the data
objects to be connected to the slave device.

Select the filter file from the drop-down menu under Active Filter. If there are no filter
files listed in the drop-down menu, you can create your own filter file by clicking Modify
Filter File.

You can also modify an existing filter file to meet your needs. The Cross-References
table allows you to view the data objects by type. Use the tabs in the upper part of the
table to do this. Under the General tab, you can see all the data objects and their property
values. Here you can sort the data objects by clicking the column heading (Object Name,
Description, 61850-Type, and so on).

You can also export the cross-references table to and import a table from Microsoft
Excel.

Clicking Save connects the data objects to the slave device. After that you can change
the data object values either in the Object Properties function or in the Cross-References
function.

Some properties visible on the Excel sheet depend on the sub-
type of the object. Therefore, it is important to select the cor-
rect sub-type.

76

1MRS756125COM600 series 5.1

User's Manual



For more detailed instructions on configuring the data object properties in the Cross-
References function, refer to the slave protocol user’s manuals listed in 1.10, Related
documents.

Template based Cross-Referencing

The purpose of this functionality is to provide a template functionality for slave
addressing for IED types.

There are four different functions:
• Enable checkbox - enables template functionality
• Restore default - restores built in default template in use
• Open template - opens currently active template
• IED Indexes - shows cross referenced IEDs base addresses

SAB600_Cross_Reference_General.png

Figure 6.4.3.8-2 Cross-References view

When template functionality is enabled, dropped data objects are compared to the data
in the template. If matching data is found, the address properties are modified according
to template.
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SAB600_Cross_Reference_Base_Address.png

Figure 6.4.3.8-3  Base addresses

Base addresses

The Base Address determines the base address value for each signal in template. The
default value is determined by either the last digit of the IP address property or the Station
Address property of IED.

[Baseaddress] *1000 + signal address value = address value in Cross References.

For example:
 TMW_Anvil IED Base Address= 61
 QA1CSWI1.Pos Indication index = 301
 61*1000 + 301 = 61301
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SAB600_Cross_Reference_Uplink_Addresses.png

Figure 6.4.3.8-4  Uplink addresses

Filter Functionality in Uplink Address Table

• Import - Imports another template file from hard drive
• Export - saves current template file to hard drive
• CID Import - creates base template based on datasets in imported CID file
• Apply - takes current template in use
• Cancel leaves functionality without taking it in use.

You can use different filters to change the visibility of the rows in the datagrid of the
tool control. The filter can be used in any column.

SAB600_Cross_Reference_Uplink_Address_Filter.png

Figure 6.4.3.8-5 Uplink Address Table Filter
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Adding Row in Uplink Address Table

You can add rows to the template by editing values of the cells in rows marked with *.

SAB600_Cross_Reference_Uplink_Address_AddRow.png

Figure 6.4.3.8-6  Adding Row to Uplink Address Table

Editing values

Ideally you don't have to add any signals to the template manually.

All cells are editable, but you are supposed to edit only the Index columns. These columns
represent signal addresses to be for that IED type.
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CID Import Signal Selector

SAB600_Cross_Reference_Uplink_Address_Signal_Selector.png

Figure 6.4.3.8-7  Signal Selector

You can create templates based on CID files by using the CID Import feature. When a
CID file is imported by using this feature, you are shown the Signal Selector form in
which you can define the logical nodes from datasets that contain values of interest. The
selected logical nodes will be added to the template and the ones not selected are left
out of the template.

Functions of Signal Selector form:
• Export XML

 Saves template based on user selections to hard drive in XML format.
• Apply

 Adds rows based on user selection to current template.

SLD Editor6.4.3.9.

SLD Editor tool can be used to draw a graphical presentation of the process objects in
the substation. The Single line diagram can be edited on bay, voltage and substation
levels.
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SAB600_SLD_Editor_open.png

Figure 6.4.3.9-1 Opening SLD Editor

In the bay level SLD Editor you can add Switchgear objects, transformers and other
objects to a single line diagram and connect them together as single line diagram. Also
generic SLD extension objects like measurements, buttons, annotations and alarm
indicators can be added.
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SAB600_SLD_Editor_bay.png

Figure 6.4.3.9-2 Drawing bay level single line diagram

In the voltage level SLD Editor you can assign the positions of the bays within voltage
level and add SLD extension objects.
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SAB600_SLD_Editor_voltage_level.png

Figure 6.4.3.9-3 Voltage level single line diagram

The position of the voltage levels in the complete substation single line diagram can be
modified by opening the SLD Editor from substation object.

Alternative SLD views

Alternative SLD views in SLD Editor can be used for grouping the single line diagram
to smaller parts for easier viewing of large diagrams in COM600 WebHMI. Alternative
SLD views can be created on bay, voltage level and substation levels using Add View
button in SLD Editor tool. The alternative SLD view dialog contains selections for cre-
ating substation, bay or custom views depending on the level where SLD Editor has been
opened. The substation view contains all substation objects and the bay view all objects
in the bay where it has been created. For custom view you can select which objects will
be shown. Alternative views cannot have objects that are not included in a master view
except SLD extension objects like buttons and measurements.
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SAB600_alternative_SLD_view.png

Figure 6.4.3.9-4 Creating alternative SLD view

COM600_alternative_SLD_view.png

Figure 6.4.3.9-5 Alternative SLD view in COM600 WebHMI
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Configuration of Station/Remote switch6.4.4.

Each IED and logical device in the OPC Server has a configuration parameter defining
the OPC node path for the S/R switch that is used for that IED/logical device. If a logical
device does not have an S/R switch path configured, the path defined in the IED is used
instead. At run-time, the S/R path of a logical device can be read from the OPC Server;
the LD S/R switch path is located in the LD node. The OPC server that has the S/R switch
position information must have at least one signal mapped to the OPC client using this
information.

With IEC 61850, the control commands from COM600
WebHMI and from slave protocols are always sent using the
fixed originator category configured in the Server Originator
Category property of the IEC 61850 OPC Server object. Due
to this some IEDs (e.g. REF615) need to be configured with
Station Authority check disabled to allow controls with the
originator category used by COM600.

The S/R switch OPC path points to an OPC node modeled according to one of the sup-
ported IEC 61850 data classes. The stVal OPC item of the S/R object presents the state
of the S/R switch, 1 = station and 0 = remote. If the stVal item has the vartype VT_BOOL,
VARIANT_TRUE is interpreted as 1 and VARIANT_FALSE as 0.

Several IEDs/LDs can share the same S/R switch OPC path, or each IED/LD can have
an own S/R switch OPC path. The OPC node pointed by the path can be located in an
OPC server providing the S/R information from a physical switch or from a simulated
software switch.

The WebHMI is considered to be local or remote based on the IP-address of the web
client. The gateway object has a configuration property which defines the addresses that
are handled as local. It can be either a single IP address or using wild cards a range of
IP addresses.

Alarms and events6.4.5.

Alarm and event definitions6.4.5.1.

For information on creating and configuring alarm and event definitions, see COM600
HMI Configuration Manual.

Configuring Alarm groups6.4.5.2.

Alarms can be grouped using the Group Alarm Configurator tool.
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To create an alarm group:

1. Create virtual Application OPC server.
2. Create Virtual Subnetwork.
3. Create Virtual IED.
4. Create Virtual LD.
5. Create LN.
6. Create GroupAlarm SPS object

If you are going to create several Group Alarm objects, rename each object with a
unique name within LN.

7. Open Group Alarm Configurator.

Drag and drop the data objects, which shall belong to the alarm group to Group Alarm
Configurator tool. You can use data objects from any of the OPC servers of COM600.
The data objects of following types can be used as a member of alarm group: ACD,
ACT, SPS, SPC, DPS, DPC, ENS, ENC, INS, or INC. When the objects are inserted to
the tool, they have by default the alarming states configured according the event definition
linked to the object. If no event definition is linked to an object, it does not have any of
the states as alarming. Alarming states can be manually specified in the tool by checking
the corresponding check box of the state.

When the objects have been added and the alarm states are configured, accept the con-
figuration by clicking apply.

The logic of the alarm group is configured with the Group Alarm Logic Property of the
object. There are three choices:

• AND
Alarm group is active if all signals belonging to the alarm group are active. Signal
changes which does not change alarm group state or quality does not cause an update
in the alarm group object.

• Dynamic OR
Group alarm is active if any of the signals belonging to the alarm group is active.
Any signal state change causes an update of the alarm group object even if the state
or quality of the alarm group does not change.

• Static OR
Group alarm is active if any of the signals belonging to the alarm group is active.
Signal changes, which do not change the alarm group state or quality, does not cause
an update in the alarm group object.

The handling of the source signal quality is configured with the Signal Handling property.
There are three choices:

• Group Quality Follows Signal Quality
Group alarm is calculated using only the signals with good/known quality. The
group alarm has the quality of the signal with the worst quality in the group.

• Unknown Signal States Treated As Alarming
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If the alarm group contains any signal with bad or unknown quality then the alarm
group is active. The quality of the group alarm is always good.

• Unknown Signal States Ignored
Group alarm is calculated using only the signals with good/known quality. If no
signals have good/known quality then the group alarm is inactive. The quality of
the group alarm is always good.

Group Alarm object is an SPS data object, which has value true when the group alarm
is active and value false when it is inactive. The object can be further used in the COM600
WebHMI or it can be forwarded to external systems using the slave protocol cross-refer-
ence tool.

Configuring COM600 event printer6.4.5.3.

To configure Event Printer in COM600 computer:
1. Open Control Panel -> Devices and Printers.
2. Select Add a printer. Configure a local printer connected to a serial port. Select

the "Generic / Text Only" printer model. Follow instructions in the dialogs.
3. To change the printer and serial port configuration after the printer has been added,

right-click the printer icon and select properties. In the serial port configuration, it
is recommended to change the Flow control setting to "Xon /Xoff".

To configure Event Printer in SAB600:
1. Click the Gateway object in the communication tree.
2. In the Object properties window, change the Event Printer Enabled value to True.
3. Configure the event printer values shown in the following table.

Table 6.4.5.3-1 Event printer values
DescriptionValueProperty

Text displayed in columns 1 -
7.

Date

Time

BayDevice

ObjectText

EventText

Quality

AlarmIndicator

Column Name

Specifies whether column
should be truncated if actual
value overflows width.

False

True

Column Truncate

Width of columns 1 - 70...1000Column Width

Defines the string which identi-
fies alarms.

*Event Printer Alarm Indicator
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DescriptionValueProperty

Specifies the code page that is
used to convert strings (event)
to be printed into bytes that are
sent to the printer.

Event Printer Code Page

Specifies whether the event
printer functionality is in use.

False

True

Event Printer Enabled

The name of the printer used
by the COM600 operating sys-
tem. The name is specified,
when the printer is configured
in the COM600 computer.

Event Printer Name

Specifies the maximum number
of events in the print queue that
are waiting to print.

0...1000Max Printing Queue Size

Specifies the maximum number
of characters printed to one
line.

1...180Maximum Line Length

The configured string is split by
a space and each individual
number (0 - 127) is converted
to the corresponding ASCII
character.

0 - 127Printer Init Command

Specifies how the line overflow
is handled. If the value is True,
the extra characters are left
out. Otherwise, the extra char-
acters are printed on the next
line.

False

True

Truncate Lines

Saving configuration6.4.6.

You can save the current configuration to the hard drive in SAB600 by selecting File >
Save Project or clicking the Save button.

Many of the tools in SAB600 also have the Save button that allows you to save the
configuration either to RAM or hard drive.

SaveButton.png

Figure 6.4.6-1 Save button

It is faster to save the configuration to RAM than to the hard drive, and you can use
saving to RAM to speed up the configuration process in large configurations. Note that
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it is recommended to save the configuration to the hard drive at regular intervals to avoid
possible data loss.

The configuration is always saved to the hard drive when the
SAB600 project is closed or the configuration is uploaded to
the COM600 device using the Management tool.

Using scales6.4.7.

General information about using scales6.4.7.1.

You have to use scaling if a measurement value provided by the device is not as such
suitable for the applications, and you need to change the provided value to another.

With a scale you can convert one value to another by using a scaling algorithm. OPC
servers support two types of scales: Stepwise Linear and Look-up Table. The Stepwise
Linear scale multiplies the value to be converted with a scale factor and adds an offset
value to the result, and the Look-up Table scale uses a look-up table to find the required
value.

Before you can connect a scale to a data object, add and con-
figure the scale in SAB600. Add and configure the scales
before adding and configuring any other objects.

Creating scales6.4.7.2.

To create scales:
1. Right-click Scale Definitions in SAB600, see Figure 6.4.7.2-1.
2. Select  New -> Scales.
3. Select the scale to add (a Look-up Table or Stepwise Linear).
4. The new scale appears in the Scale Definitions. Enter a unique name for the scale

by right-clicking it and selecting Rename. It can be configured and connected to a
data object.
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SAB600_Creating_Scales.png

Figure 6.4.7.2-1 Creating scales

Configuring scales6.4.7.3.

To configure scales:
1. Select the scale you want to configure in the object tree.
2. The object properties appear now in the Object Properties window, see Figure 6.4.7.3-

1.
3. You can assign the scale with parameter values.
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SAB600_Editing_Scales.png

Figure 6.4.7.3-1 Object properties of the scales

Table 6.4.7.3-1 Scales
DescriptionValue or value range/ DefaultProperty/Para-

meter

Basic

Look-up Table and
Stepwise Linear

Value to be scaled-01 In Value

Scaled value-01 Out Value

Value to be scaled-02 In Value

Scaled value-02 Out Value

Value to be scaled-03 In Value

Scaled value-03 Out Value

Value to be scaled-04 In Value

Scaled value-04 Out Value

Value to be scaled-05 In Value

Scaled value-05 Out Value
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DescriptionValue or value range/ DefaultProperty/Para-
meter

Value to be scaled-06 In Value

Scaled value-06 Out Value

Value to be scaled-07 In Value

Scaled value-07 Out Value

Value to be scaled-08 In Value

Scaled value-08 Out Value

Value to be scaled-09 In Value

Scaled value-09 Out Value

Value to be scaled-10 In Value

Scaled value-10 Out Value

After you have performed all the necessary configurations, see 7.1, Activating COM600
with new configurations.

Project revision6.5.

Project revision6.5.1.

When using COM600 5.0 and above, users can associate a version number to project
configuration being loaded into COM600 by using the Project Revision Handling feature
available in SAB600. This allows for easier and more defined management of application
configuration loaded into COM600.

The version number will be automatically incremented whenever:
• New objects are added to communication/substation structure through an Add action.
• Existing objects in communication/substation structure are renamed through a

Rename action.
• Existing objects in communication/substation structure are deleted through a Delete

action.
• Properties of existing objects are changed by editing through Object Properties

view.
• Tool specific configuration is changed. This includes tools like SLD Editor and

Topic Generator.

Project version history6.5.2.

To view project revisions, select File > Project Version History in the SAB600 menu.
This menu item is enabled only when a project is used fror a Gateway 5.0 or above object.
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SAB600_launch_project_version_history.png

Figure 6.5.2-1 Launching Project Version History

The Project Version History window lists all revisions that are deemed worthy to be
marked for historical review purposes. Figure 6.5.2-2 shows Project Version History
window displaying all revisions made.

SAB600_project_version_history.png

Figure 6.5.2-2 Project Version History dialog

Note that not every automatic change in project version causes a revision entry in Project
Version History. The user can open this window at any point to create a revision entry
whenever deemed appropriate and add revisions, as shown in Figure 6.5.2-3. The user
can also change the version number as per choice, and subsequent automatic increments
in project version number will commence from the chosen number.
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SAB600_project_version_add_revision.png

Figure 6.5.2-3 Add Revision entry

Project version verification6.5.3.

When the user initiates an upload of a project configuration to COM600 through SAB600's
Gateway Management tool, SAB600 performs further validation using project version
numbers to ensure that the user does not unintentionally or accidentally upload a config-
uration to COM600. The validation includes:
1. Validating if the existing configuration in COM600 is from the same project. If not,

the user is prompted for further action through a warning message window, see
Figure 6.5.3-1. Click OK to continue uploading the configuration, or Cancel to
cancel the upload.

SAB600_project_mismatch_warning.png

Figure 6.5.3-1 SAB600 Project Mismatch warning message

2. Validating if the existing version of the project configuration is the same as the
version being downloaded. If not, user is prompted for further action through a
warning message window. Click OK to continue uploading the configuration, or
Cancel to cancel the upload.
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SAB600_project_version_mismatch_warning.png

Figure 6.5.3-2 SAB600 Project version mismatch warning message

After the validation, if the project configuration being uploaded from SAB600 is found
to be the same as the existing configuration, the user is shown a message window. Click
OK to continue uploading the configuration, or Cancel to cancel the upload.

SAB600_project_version_match.png

Figure 6.5.3-3 SAB Project version match message

SAB600 project backup and retrieval6.6.

SAB600 project backup and retrieval6.6.1.

When using COM600 5.0 and above, SAB600 includes a project revision feature that
allows the user to take a backup of the current project and upload it to COM600. The
backup can be retrieved later for further use.

Project backup to COM600 device6.6.2.

When using COM600 5.0 and above, you can use Gateway Management tool to upload
a backup of the configuration along with the configuration being loaded into COM600.
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To create a project backup and upload it to COM600:
1. Launch SAB600 and open an existing project.
2. Open Gateway Management tool.
3. Click Update, reload and backup configuration.
4. Click OK in the subsequent warning message window showing a project/version

mismatch
5. Click Finish after backup has been created and uploaded to COM600.

SAB600_create_project_backup.png

Figure 6.6.2-1 Creating Project Backup

Retrieving a project from COM600 device6.6.3.

When using COM600 5.0 and above, you can retrieve an existing backup of the project
configuration from COM600.

Retrieve Using SAB600

To retrieve a project backup from COM600:
1. Launch SAB600.
2. If an existing project is opened by default, close the project by selecting File > Close

Project.
3. Select File > Retrieve Project Backup. The Retrieve Backup Configuration window

opens.
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SAB600_launch_retrieve_project_backup.png

Figure 6.6.3-1 Launch Retrieve Project Backup

4. Enter the IP address of COM600 and click OK.

SAB600_retrieve_backup_configuration.png

Figure 6.6.3-2 Retrieve Backup Configuration

5. After the project has been successfully retrieved, it will be loaded into SAB600.
You can now open the project.

98

1MRS756125COM600 series 5.1

User's Manual



SAB600_backup_retrieval.png

Figure 6.6.3-3 Processing backup retrieval

Retrieve Using WebHMI

The projects backed-up from the SAB600 management tool can be retrieved from the
COM600 unit via its WebHMI.

This feature is available in the Communication structure.
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COM600_Retrieve_configuration.png

Figure 6.6.3-4 COM600 retrieve configuration

All backed-up SAB600 projects can be downloaded from the “Retrieve configuration”
node. Clicking on the project node(s) will download the corresponding PCMP file to the
user’s computer.

Project backup and restoring locally6.6.4.

To back up the SAB600 project:
1. Select File > Open/Manage Project.
2. Select the project you want to back up.
3. Select Export Project.
4. The File window opens. Select the location where to export the database.

To restore your backup:
1. Select File > Open/Manage Project.
2. Select Projects on my computer.
3. Select Import Project.
4. The File window opens. Choose the exported database you want to import.

SCL Export6.7.

Export the configuration files of the COM600 OPC Servers and Clients in SCL format
using the SCL Export function in the Gateway object. This function can be used to
transfer the configuration information to other systems and tools.
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To export configuration files in SCL format:
1. Right-click the server object in the Communication tree and select SCD Export.
2. The SCD Export window opens.
3. Click Export and select the location where you want to save the SCL file. Click

OK.

Both the communication view and substation view configurations are exported.

To export just the communication view:
1. Right-click the Gateway object in the Communication tree and select SCL Export.
2. The SCL Export window opens. Select whether you want to export all configurations

or a certain OPC Server or Client configuration.
3. Click Export and select the location where you want to save the SCL file. Click

OK.

CID Export

Export the configuration files of IEDs in CID format.

To export configuration files in CID format:
1. Right-click the IED in the Communication tree and select CID Export.
2. A Windows Explorer window opens. Rename the file, if necessary, and browse to

the location where you want to save to file.
3. Click Save.

Both the communication view and substation view configurations are exported.

Configuring external watchdog for COM6006.8.

The communication to the IED used as a watchdog is configured as with any IEDs using
SAB600. The IED is configured with SPC or INC type of data object to which the cyclical
command is sent.

To configure COM600 to use an IED as an external watchdog:

1. Right-click on the Gateway object and select Properties.
2. Enter the Command OPC Item Path in the following format:

Node#ProgID For OPC Server#Channel Name\IED Name\Logical Device
Name\Logical Node Name\Data Object Name\Data Attribute Name

Other properties are set according to the preference of the user, but they can be left as
they are by default. These are:

• Command Write Value
The value that is written to the command OPC item. The default value is 1.

• Command Write Interval
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How often the command is sent. The default value is 5 seconds.

Installing and configuring Duo Driver6.9.

Duo Driver is available when the optional LAN card is installed in COM600.

Before the installation, it is recommended to rename Intel(R) PRO/1000 MT Dual Port
Server Adapter ports to DUO Line A and DUO Line B. Open the Network Connections
dialog and select the Properties for the Duo Driver devices. Configure static IP address
on DUO Line A and a dummy IP address on DUO Line B. The IP address of the DUO
Line A is used for the pair.

To install the Duo Driver:
1. Run the Duo Driver Setup Wizard file, C:\DuoDriver\setup.exe (in the COM600

computer).
2. Click Next.
3. In the Select Installation Folder dialog, click Install.
4. Setup for Duo Driver dialog opens. Enter a name for the Duo Driver Instance. Choose

network adapters to be used in the pair with the Adapter A and Adapter B selection.
Select or enter the common MAC address to be used with the adapters. After con-
figuring the options, click Add Virtual Adapter to accept the configuration.

5. In the following dialogs, click Done and Finish to finalize the installation. If you
need to modify the configuration, re-install the Duo Driver.

By default DuoDriver Virtual Adapter name has # character
in it. Remove # from the name as it causes problems with the
OPC naming.

Installing Intel Teaming feature to COM6006.10.

The Teaming feature is available only if a LAN optional card has been installed in
COM600.

Teaming Features include Failover protection, increased bandwidth through aggregation,
and balancing of traffic among team members. Teaming Modes are AFT, SFT, ALB,
RLB, and EtherChannel*/3ad (LA/FEC/GEC/3ad). However, only Failover protection
using SFT is supported by COM600. SFT uses two (total) adapters connected to two
devices (that is, switches) to provide a fault tolerant network connection if the first
adapter, its cabling or the device (switch) fail. This is determined by a link failure.

To use the SFT connect Intel(R) PRO/1000 MT Dual Port Server Adapter network ports
to two devices (that is, switches). Spanning tree protocol must be switched on in the
devices (switches). Do not put clients on the link partner switches, as they do not pass
to the partner switch at fail.
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To install Intel Teaming Feature:
1. Install advanced network services. Run C:\Intel\PROWinx64.exe and follow the

installation instructions.

Intel PROSet drivers are installed by default in the image,
so select Modify and then check the Advanced Network
Services to install those as well.

2. Open Control Panel.
3. Click Device Manager.
4. Expand Network adapters and double-click Intel(R) Ethernet Connection I217-

LM.
5. The Properties windows appear. Select the Teaming tab.

COM600_Intel_Teaming.png

Figure 6.10-1 Opening the Teaming tab

6. Select Team this adapter with other adapters and click New Team.
7. Specify a name for the team and click Next.
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COM600_Intel_New_Team_Wizard.png

Figure 6.10-2 New Team Wizard

8. Unselect Intel(R) Ethernet Connection I217-LM  adapter and select both Intel(R)
PRO/1000 MT Dual Port Server Adapters. Click Next.

9. Select Switch Fault Tolerance to a team mode and click Next.

COM600_Intel_Switch_Fault_Tolerance.png

Figure 6.10-3 Switch Fault Tolerance selection

10. Click Finish to start installation
11. Configure the Team. Click OK to close the Properties dialogs.
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The Team is now made. One virtual network adapter (named “Local Area Connection
3”) appears into Control Panel > Network connections. Configure the IP address for
this adapter.

For more information about Intel Teaming feature, see Intel documentation.

Configuring Data historian6.11.

Preparing COM600 for Data Historian6.11.1.

The following operations must be performed in the COM600 computer as the adminis-
trator user to prepare COM600 for Data Historian feature.

Configuring website security certificate

Data Historian uses the COM600 WebHMI security certificate by default and needs this
to be properly configured before Data Historian can be used from other computers. For
more information, see 7.3.1, Using web site security certificates.

Setting the time zone of RTDB

The time zone of the RTDB is by default GMT and it must be set before taking the Data
Historian feature into use.

To set the time zone:
1. Select Windows Start Screen -> All Apps (right-click background to show it) -

> Data Historian -> Change Time Zone. (Can also just open Start Screen and then
write “time” to find it faster.)

2. The following file browser dialog opens.
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COM600_RTDB_Timezone.png

Figure 6.11.1-1 Time Zone Definition

3. Select the time zone from the list and click Open.
4. Reboot the computer so that the service processes notice the new setting.

The setting is stored in a system environment variable.

Preconfiguring Vtrin Client Environment

To change the default layout and views for Vtrin users, log in to Vtrin with the COM600
WebHMI administrator user name and password. The administrator user has full access
to Vtrin functions and objects.

Enabling Vtrin into use

To be able to use the Data Historian Vtrin tool, Vtrin must be installed on the client
computer. When clicking the Data Historian menu item in WebHMI for the first time,
the Vtrin client is installed.
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HMI_Data_Historian_menu.bmp

Figure 6.11.1-2 Data Historian menu item shown in WebHMI

The TLS connection between COM600 and the client com-
puter must be set up properly before VTrin can be installed
on the client computer. This may involve either installing a
well-known certificate on the COM600 or installing the default
self-signed certificate on COM600 to the client computer.

To enable the Vtrin installation to client computers, select Start -> All Apps -> Data
Historian -> Change Vtrin IP Address on the COM600 computer.

If the IP address of the COM600 computer is changed, change
the Vtrin IP Address again.

Configuring Data Historian measurements and signals6.11.2.

In Data historian configuration measurements and signals from devices are selected for
history information. The trends can then be investigated in COM600 WebHMI. The
function includes several configuration parameters.

To configure Data historian:
1. Right-click the Gateway object and select Data Historian Configuration from the

shortcut menu.
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SAB600_DataHistorian_Configuration.png

Figure 6.11.2-1 Opening Data Historian Configuration tool

2. The Data Historian Configuration dialog opens.

SAB600_DataHistorian_Configuration_Tool.png

Figure 6.11.2-2 Data Historian Configuration tool

3. Drag and drop data objects to the Data Historian Configuration tool, where they are
displayed as rows. Some of the rows are write-protected. You can modify the values
in the Cycle, Minimum Value, Maximum Value, Description, Unit, and History
Levels columns, although the values are set according to the values defined for the
data object.

4. You can modify the editable values. Check the values for the History Levels column
from COM600 Data Historian Operator's Manual.
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5. Select the desired signals for the configuration with the checkboxes in the Selected
column. With Select and Unselect you can select or unselect multiple rows at the
same time.

6. Save the configuration in the SAB600 project by clicking Apply.

The configuration is activated to COM600 as described in 7.1, Activating COM600 with
new configurations.

Security event list backup6.12.

You can take a backup of the COM600 Security event list either manually using a bat
file or automatically by setting the Windows task scheduler to take an automatic backup
at certain intervals.

You can take a manual backup by using the COM600EventStoreBackup.bat script.
The script is located at C:\Program Files\COM610 GW SW\Common\bin folder in
the COM600 computer.

Note that you need admin rights to the computer run the script and perform the backup
successfully.

The script takes an input parameter, which indicates the folder of which the backup is
taken. When the input is valid, the script copies all the security event list files to the
intended backup location.

The source folder for the security event list files is specified in the gwConfig.ini file
located at C:\Program Files\COM610 GW SW\Common\bin.

To take a manual backup of a COM600 Security event list:
1. Log into COM600 computer operating system.
2. Open command prompt as an administrator by choosing Start/>Run/>Cmd.
3. Change the runtime directory to C:\Program Files\COM610 GW SW\Com-

mon\bin., like for example, cd “C:\Program Files\COM610 GW SW\Com-
mon\bin”

4. Launch the COM600EventStoreBackup.bat script and specify the intended backup
location. For example, COM600EventStoreBackup.bat “C:\COM600_Secur-
ity_Events_Backup” .

5. Wait until the backup script is finished.
6. Close the command prompt window.

To make the backup automatic, you can set the Windows task scheduler to automatically
perform the backup function at certain intervals.

The task is named “\COM600\COM600EventStoreBackup” in the Windows task
scheduler. It is disabled by default.
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When enabled, the task launches the COM600EventStoreBackup.bat script with the
intended backup location as the input parameter.

To automatically backup COM600 Security event list
1. Log into COM600 computer operating system.
2. Launch Windows Task Scheduler from Control Panel>Administrative Tools.
3. Locate the COM600EventStoreBackup task as in shown in the picture below.

KUVA
4. Right click the COM600EventStoreBackup task and select Properties to enable

the task and set the time interval for task execution.
5. In the following COM600EventStoreBackup Properties dialog, select the Triggers

tab.
6. Double click the Daily Trigger entry to setup time interval for task execution and

click Ok. Make sure to check the Enabled check box to enable the task.
7. To edit the backup location for the task, choose the COM600EventStoreBackup

Properties dialog and select the Actions tab.
8. Double click on the Start a program action item to launch the Edit Action dialog.
9. Edit the textbox for Add arguments (optional) to change the intended backup

location and click Ok.
10. Click Ok in the COM600EventStoreBackup Properties for any changes made to

the properties of the task.
11. Check the backup result in the Windows event log using Windows Event Viewer

tool. You can open it by choosing Control Panel/ > Administrative Tools.

.

SAB600 user management6.13.

SAB600 user management6.13.1.

This chapter describes the user authentication for SAB600.

SAB600 supports both authenticated and anonymous users. The following chapters
describe the functionality in both use cases. By default, no authentication method is
enabled.

It is recommended not to use administrator accounts by
default, but to create limited user accounts that only allow to
perform the tasks related to the user role.

Activating user authentication

The system engineer can enable or disable user authentication. When user authentication
is disabled, all users have full rights to operate. User authentication also defines whether
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user login is needed or not. To start user management, go to Tools in the main menu and
select Options.

User authentication is also used to control login function. To set user management, go
to Tools in the main menu and select Options.

The SAB600 administrator account has to be created before authentication can be enabled.
The user can select the name for the administrator account and by default the account
does not have a password.

Create a password for the administrator account immediately
after is is created.

To activate user authentication:
1. Go to System Settings folder.
2. Select or unselect Use Authentication to enable or disable user authentication.
3. Select PCM Authentication or Windows Authentication under Authentication

Method.

Windows Authentication is the recommended authentic-
ation method.

Windows Authentication uses the current user's Windows account to determine if
the user is allowed to log in to SAB600. If Windows Authentication is selected, it
is checked that all user accounts contain the Windows account name that is used to
log in the user.
PCM Authentication uses user name and password specified in the user management
of SAB600.

User categories6.14.

Creating user categories6.14.1.

User management in SAB600 is based on user accounts and user categories. Each user
account is mapped to one user category that defines the permission to access certain
functions. There are three default user categories:

• System Engineer: administrator for the system, has full rights to perform any
function and can define the user accounts

• Application Engineer: can access most of the functions, has read and write access
to the IED engineering processes

• Operator: can perform certain simple tasks, has read-only access to certain func-
tionality of the SAB600
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Check the settings for each of the user categories from SAB600/Options/Category
Manager.

Only System Engineer users can create user categories.

To create a user category:
1. Select Tools > Options.
2. Go to the Category Manager folder.
3. Click Add New Category. The Add New Category window opens.
4. Fill in a name for the user category.

The name of each user category must be unique.

5. Specify the rights to perform different functions in the Functions And Rights field.
6. Click OK to save the settings.

Deleting a user category6.14.2.

Only System Engineer users can delete user categories.

The System Engineer category cannot be deleted.

To delete a user category:
1. Select Tools > Options.
2. Go to the Category Manager folder.
3. Select the user category from the drop-down list.
4. Click Delete Category to remove the user category.
5. Click Yes to confirm the operation.

If you try to delete a category that has any members, you will be asked to confirm the
action. If the category is removed, the user accounts remain but they are no longer mapped
to any user category. Any changes to the categories are saved to the system configuration
data.
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Modifying an existing user category6.14.3.

Only System Engineer users can change the access rights of
existing user categories.

The access rights of the System Engineer category cannot be
changed.

To modify user categories:
1. Select Tools > Options.
2. Go to the Category Manager folder.
3. Select the user category from the drop-down list to access the Functions and Rights

field.
4. Change the user rights by selecting one of the user levels in the drop-down list.

The Functions and Rights field is divided into different sections for specifying the
user rights of a specific tool component or function.

User management6.15.

User management6.15.1.

This chapter explains how to manage SAB600 users. For IED user management, see
IED's Cyber Security Deployment Guidelines.

Creating users6.15.2.

You need to define the following info when creating a new SAB600 user:
• User name (mandatory)
• Real name of the user
• User category

Windows account can be used to log in automatically. Multiple
Windows account names can be used for a single SAB600
account. Windows account names are separated by a semicolon
(;). These Windows account names are only used for login if
the administrator has enabled Windows authentication.

To create a new user:
1. Select Tools > Options.
2. Go to the User Manager folder.
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The default Real Name is System Administrator.
3. Click Add new user in the User Profile field. The Add new user window opens.
4. Fill in User name and select User Category from the drop-down list. The user name

must be at least three characters long.
5. Click OK.

The new user name has to be a member of a user category to have permission to SAB600
functions, for more information see 6.14.1, Creating user categories.

Deleting a user6.15.3.

Only users with System Engineer rights can delete a user.

The System Engineer account cannot be deleted.

To delete a user:
1. Select Tools > Options.
2. Go to the User Manager folder.
3. Select the user you want to delete from the drop-down list.
4. Click Delete user in User profile.

Changing password6.15.4.

To change SAB600 password:
1. Select Tools > Options.
2. Go to the User Manager folder.
3. Click Set Password under User Preferences. The Set Password window opens.
4. Type in your old password.
5. Type in the new password.

The password must meet the following requirements:
• At least 8 characters long
• Starts and ends with an alphabetic character of European languages
• Contains at least one special character ~!@#$%^*_-+=`|\(){}[]:<>,.?/
• Contains at least one number 0-9
• Contains at least one uppercase character
• Contains at least one lowercase character

6. Retype the new password.
7. Click OK.
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The validity of the password is checked and the new password is saved to the data-
base.

Data access password6.16.

SAB600 needs a connection to PCMSERVER instance of SQL Server. The password
for this connection is generated automatically by the installation. The password complies
with de facto password complexity requirements as stated below. It is recommended to
change the automatically generated password.

System engineer user can change the data access password. This password is not used
by a user but by SAB600 itself.

To change the data access password:
1. Select Tools > Options.
2. Go to the System Settings folder.
3. Click Set Data Access Password. The Set Password window opens.
4. Type in the old password.
5. Type in the new password.

The password must meet the following requirements:
• At least 8 characters long
• Starts and ends with an alphabetic character of European languages
• Contains at least one special character ~!@#$%^*_-+=`|\(){}[]:<>,.?/
• Contains at least one number 0-9
• Contains at least one uppercase character
• Contains at least one lowercase character

6. Retype the new password.
7. Click OK.
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Operation7.

Activating COM600 with new configurations7.1.

After the configurable objects in the object tree have been created, the configuration
must be transferred to the COM600 computer. This is done by using the Management
function.

To activate the COM600 configuration
1. Right-click the Gateway object in SAB600 and select Management.
2. The Management dialog opens.

SAB600_Gateway_Management.png

Figure 7.1-1 Gateway management function

• To update COM600 with the SAB600 project configuration and create backup,
click Update, reload and backup configuration.

• To update COM600 with the SAB600 project configuration, click Update &
reload configuration.

• To request COM600 software to restart and reload current configuration, click
Reload configuration.

• To change the password of the COM600 user in COM600 computer, click
Change password.

License handling7.2.

The COM600 Management tool displays the license information for COM600 under
License Information. The license and the protocols it supports have been predefined
before the COM600 computer has been handed over by ABB.

The following information is shown in the window:
• owner of the license
• product revision
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• protocols supported by the license.
• number of servers supported by the license.
• number of clients supported by the license.
• if WebHMI is enabled.

To update the license with a new set of protocols, order a new license from ABB and
update it to COM600 with SAB600.

To update the license:
1. Open the Management tool from the Gateway object in SAB600.
2. Click Update License.
3. Browse for the new license file and click Open.

The license is COM600 specific and the COM600 computer verifies the compatibility
of the license. Also the servers and clients verify the license.

Using web site security certificates7.3.

Using web site security certificates7.3.1.

Use of web site security certificates is necessary in order to ensure the secrecy and
integrity of communication between COM600 and the web browsers that connect remotely
to it. They will also verify that the user actually connects to COM600 and not another
server impersonating it.

Make sure to check that the certificate is valid when connecting with a web browser.

By default COM600 comes with a self-signed certificate. It is recommended to get a real
certificate from a recognized certificate authority instead if possible.

If the self-signed certificate is used instead, then it must be installed to every client
computer that is used to connect to COM600. See below for details.

COM600 also makes use of the web site certificate when
opening the Data Historian and GOOSE Analyzer WebHMIs
from the WebHMI. If the certificate is not correctly set up at
that point this will fail.
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Creating self-signed certificates7.3.2.

By default, COM600 has a certificate tied to the factory default
computer name. You need to create a new self-signed certific-
ate only if the name of the COM600 computer is changed.

After the self-signed certificate is re-created it also needs to be re-exported to every
COM600 client computer.

To create a new self-signed certificate:
1. In the COM600 computer, select Start > Control Panel > System > Computer

Name.
2. Change the computer name by clicking Change and by typing the new name in the

Computer Name Changes dialog.

Do not use the underscore character '_' in the computer
name.

3. In the COM600 computer, open an administrative command prompt and go to dir-
ectory C:\Program Files\COM610 GW SW\Common\bin.

4. Create and install a new certificate with the command COM600SelfSSL.cmd.
5. Add the COM600 computer to the same domain as the client computer (in the

Computer Name Changes dialog), or add the COM600 computer information to the
client computer hosts file (...\system32\drivers\etc\hosts).

By default the COM600 IP addresses are not included in the
created self-signed certificate and so cannot be used to connect
securely. This can be changed by providing “ip” as the first
command argument and then the IP addresses to be added
when running COM600SelfSSL.

For example:

COM600SelfSSL ip 192.168.2.11 10.0.0.1 10.0.200.1

It is generally preferable to connect using the COM600 computer name, and in that case
this is not necessary.

Using self-signed certificates with Internet Explorer 77.3.3.

To use a self-signed certificate with Internet Explorer (IE) 7:
1. Export the certificate from the COM600 computer.
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a. Select Start > Control Panel > Administrative Tools > Internet Information
Services.

b. In the tree view, select the computer and then Web Sites.
c. Right-click Default Web Site and select Properties.
d. In the Properties dialog, select Directory Security > View Certificate > Details

> Copy to File.
e. Click Next > No, do not export private key > DER encoded binary X.509

(.crt) > Next.
f. Type the file name.

2. Copy the exported certificate file to the client computer running IE.
3. In the client computer, start IE.
4. Select Tools > Internet Options > Content > Certificates.
5. Select Trusted Root Certification Authorities > Import.
6. Select the previously exported certificate file from COM600.
7. Place the certificate to Trusted Root Certification Authorities as suggested.
8. Use the COM600 computer name to access COM600 WebHMI from IE7.

Using self-signed certificates with Internet Explorer 8,9,10 and
11

7.3.4.

This method assumes the initial connection to COM600 can
be trusted also without a valid certificate. You can also use
the more complicated method above if that is not the case.

To use self-signed certificates with IE8 - 11:
1. In the client computer, start Internet Explorer with Run as Administrator.
2. Browse to the COM600 computer with the computer name.

Ignore the certificate warnings.
3. Click Certificate Error at the top of the screen and select View certificates.
4. In the Certificate dialog, click Install Certificate > Next.
5. Select Place all certificates in the following store > Browse.
6. Select the Show Physical Stores checkbox.
7. Select Trusted Root Certificate Authorities > Local Computer.
8. Click OK > Next > Finish > OK.
9. Restart IE.

Using self-signed certificates with Mozilla Firefox7.3.5.

To use self-signed certificates with Mozilla Firefox:
1. Start the Firefox browser.
2. Browse to the COM600 computer with the computer name.

Firefox warns that the connection is untrusted.

119

COM600 series 5.11MRS756125

User's Manual



3. Click Add Exception.
4. Click Confirm Security Exception.

Using self-signed certificates with Google Chrome7.3.6.

Google Chrome will use the same security certificates as Internet Explorer, so installing
it for IE will install it for Chrome as well.

Diagnostics7.4.

General information about diagnostics7.4.1.

SAB600 provides comprehensive functions for diagnosing the operation of the Gateway.
This includes communication diagnostics with monitoring the communication channel,
diagnostic counters, and IED-specific communication status and diagnostic counters. It
is also possible to monitor and control process data and follow the data flow on the
Gateway using diagnostic functions of SAB600. Figure 7.4.1-1 displays a sample view
of a diagnostic counter dialog. An example of an event log file is displayed in Figure 7.4.1-
2.

SAB600_Subnet_Online_Diagnostics.png

Figure 7.4.1-1 An example of IEC 61850 subnetwork online diagnostics
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EventDial.jpg

Figure 7.4.1-2 An example of a SPA event log file

Channel online diagnostics with Analyzer7.4.2.

The Analyzer function is available in the channel diagnostics for most of the protocols.
The Analyzer function shows transmitted and received telegrams in hex format. In
addition, it can show control signal changes for serial communication protocols.

The Analyzer function requires a Telnet software to be installed on the SAB600 computer.
In Windows 7, Telnet is an optional Windows feature that needs to be activated. In 64-
bit Windows 7, the telnet.exe file needs to be copied from the System32 folder to the
SysWOW64 folder.

By default, the Analyzer function uses the Telnet port 50000. You can change the port
in the Online diagnostics dialog. By default, the port is not opened in the COM600 fire-
wall. To enable the Analyzer function, add a rule for the port to the COM600 firewall
configuration.

Data object diagnostics7.4.3.

You can monitor and control the data objects under the Gateway object tree with Data
object diagnostics.

To monitor and control the data objects:
1. Right-click the Gateway object in SAB600.
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2. Select Data object diagnostics from the shortcut menu, see Figure 7.4.3-1. The
Data object diagnostic dialog opens.

3. Drag and drop data objects from the object tree to the Data object diagnostics.

Or

1. Select a specific data object from the object tree.
2. Select Tools > Online diagnostics.

SAB600_Data_Object_Diagnostics.png

Figure 7.4.3-1 Data object diagnostics

To change the value of a data object attribute:
1. Select a specific attribute.
2. Write a new value to the text box under the Write value button.
3. Click Write value to change the value.

To filter the displayed data object:
1. Click Excluded items.
2. Notepad opens. Write to Notepad the data object types you want to exclude from

the Data object diagnostics view.
3. Save the file as a .txt file by selecting File > Save.

Diagnostic services of OPC servers and clients7.4.4.

You can control and monitor the server and client channel and device communication
in the communication structure of the Project Explorer. You can take channels/subnet-
works and devices into use or out of use via the respective diagnostics function. You
can also monitor the channel/subnetwork and device communication with the help of
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various diagnostic counters, and check the device status information, see Figure 7.4.4-
1.

SAB600_IEC61850_IED_Online_Diagnostics.png

Figure 7.4.4-1 An example of IEC 61850 IED online diagnostics

For more detailed information and instructions on controlling and monitoring channel
and device communication, refer to the respective user’s manual for the client or server
(see 1.10, Related documents).

Signal diagnostics7.4.5.

OPC clients have a diagnostics function which makes it possible to monitor the flow of
process data changes and commands. Activate the function by marking the Diagnostic
Events Enabled check box, located in the Online diagnostics function of the
IEC101/IEC104 Device. When the diagnostics function is activated, the IEC101 OPC
Client Alarm & Event server generates events with information about data changes and
commands.
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SAB600_AE_Client_Diagnostic.png

Figure 7.4.5-1 Example of Diagnostic AE client

Diagnostic Web Server7.4.6.

The Diagnostic Web Server of the Gateway provides an overall view of the communic-
ation status of the Gateway and the possibility to monitor the diagnostic counters of the
communication channels/subnetworks and IED communication. Figure 7.4.6-1 displays
the gateway objects in a tree view.

A red cross over the Gateway icon in the object tree indicates that there is a fault in the
communication structure. Expand the tree to view the hierarchy deeper and to identify
the device with a missing configuration or causing the error. The properties of a certain
object in the communication structure can be seen on the right when clicking the object
in the tree view.
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COM610_HMI.jpg

Figure 7.4.6-1 An example of a web page from the Gateway diagnostic web server
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Appendix 1

Goose from COM600 to RIO

This tutorial describes how GOOSE communication is established between COM600
and RIO600.

GOOSE from RIO600 to COM600

Binary input status information from RIO600 is transferred to COM600.

Create project in PCM600
1. Create a new project.
2. Add the RIO600 IED to the project.
3. Set the RIO600 IP address and technical key.

IEC 61850 Engineering in PCM600
1. Open the IEC 61850 Configuration tool.
2. Create a Goose control block (RIO_GCB) and connect it to the Data Set (Bin-

aryDS_1). Set a unique MAC address, APP ID and Application ID to this GCB.
3. Save and close the IEC 61850 Configuration tool.
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Finalize configuration in PCM600
1. Write configuration to RIO600.
2. Export the SCD file from PCM600.

Configure GOOSE receive in SAB600
1. Create a new IEC61850 OPC Server.
2. Import the previously exported SCD file.
3. Select Subnetwork properties, and make sure that Communication Port is set to the

network adapter interface which is used to communicate with RIO600 (ETH0 Local
by default). Set the IP Address to the value which is used by COM600 on this
interface.

4. In Data Subscribe Method to GOOSE in RIO600 IED object properties. See image
below.

5. Update and reload the configuration from the Gateway management tool to COM600.
6. Use data object Online diagnostics to verify that status information is correctly

updated.

Notice that SAB600 must be paired with an actual COM600
device so that the network interface controller information is
correctly available in the Subnetwork properties.
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GOOSE from COM600 to RIO600

This tutorial describes how binary status information from the Logic Processor can be
sent to RIO600 binary outputs via the IEC61850 Proxy Server of COM600.

Prerequisite is that the Logic Processor IED and needed data points have been configured.

Create IEC6180 Proxy server in SAB600
1. Add the IEC61850 Proxy Server OPC Client to the SAB600 Project.
2. Launch the Proxy Config Tool from the IEC61850 Proxy Server context menu,

select Logic Processor IED and press Save.

3. Create Dataset GOOSE_DS for Proxy IED.
4. Open the Dataset Editor and mark the Enable daName for GOOSE check box.
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5. Drag and drop data objects from the Logic_Processor_IEDLD1 to the Dataset table.
Click Apply.

6. Create a Goose Control Block, set a unique MAC address, APP ID and GoID and
assign the GCB to a previously created GOOSE Dataset.

7. Update and reload the configuration from the Gateway management tool to COM600.
8. Export the CID file from IEC61850 Proxy Server IED object.

Subscribing GOOSE in PCM600
1. Create a Generic IEC61850IED in PCM600.
2. Import a CID file and select options:

• Replace unknown IED types with generic IEC 61850 object type
• Ignore PCM Object Type
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3. Open the IEC 61850 Configuration tool and subscribe the COM600 GOOSE signals
for RIO600

4. Open the Signal Matrix Tool and assign GOOSE signals to the GOOSE receive
functions to be used in the Application Configuration.

5. Write configuration to RIO600.
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