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NOTICE
This document contains information about one or more ABB products and may include a description 
of or a reference to one or more standards that may be generally relevant to the ABB products. The 
presence of any such description of a standard or reference to a standard is not a representation that 
all of the ABB products referenced in this document support all of the features of the described or ref-
erenced standard. In order to determine the specific features supported by a particular ABB product, 
the reader should consult the product specifications for the particular ABB product.

ABB may have one or more patents or pending patent applications protecting the intellectual property 
in the ABB products described in this document.

The information in this document is subject to change without notice and should not be construed as 
a commitment by ABB. ABB assumes no responsibility for any errors that may appear in this document.

Products described or referenced in this document are designed to be connected, and to communicate 
information and data via a secure network. It is the sole responsibility of the system/product owner to 
provide and continuously ensure a secure connection between the product and the system network 
and/or any other networks that may be connected.

The system/product owners must establish and maintain appropriate measures, including, but not lim-
ited to, the installation of firewalls, application of authentication measures, encryption of data, installa-
tion of antivirus programs, and so on, to protect the system, its products and networks, against security 
breaches, unauthorized access, interference, intrusion, leakage, and/or theft of data or information.

ABB verifies the function of released products and updates. However system/product owners are ulti-
mately responsible to ensure that any system update (including but not limited to code changes, con-
figuration file changes, third-party software updates or patches, hardware change out, and so on) is 
compatible with the security measures implemented. The system/product owners must verify that the 
system and associated products function as expected in the environment they are deployed.

In no event shall ABB be liable for direct, indirect, special, incidental or consequential damages of any 
nature or kind arising from the use of this document, nor shall ABB be liable for incidental or conse-
quential damages arising from use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from 
ABB, and the contents thereof must not be imparted to a third party nor used for any unauthorized pur-
pose.

The software or hardware described in this document is furnished under a license and may be used, 
copied, or disclosed only in accordance with the terms of such license. This product meets the require-
ments specified in EMC Directive 2004/108/EC and in Low Voltage Directive 2006/95/EC.
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About this User Manual

General 

This User Manual describes Topology Designer, the engineering tool for system-
wide Topology Diagrams. It also describes the use of Topology Designer as a 
Topology Status Viewer in operation and maintenance of a plant.

Topology Diagrams visualize the control system topology including live system 
status information of hardware unit objects. User can configure Topology Diagrams 
to include any further accessible system or plant information.

Section 1, Introduction provides an introduction to Topology Designer and 
Topology Status Viewer.

Section 2, Configuration describes configuration and application procedures with 
Topology Designer and Topology Status Viewer.

For a quick start user can read Features of Topology Designer on page 14 and 
Getting Started on page 23 (including Application Tutorial on page 31) first.

Any security measures described in this User Manual, for example, for user 
access, password security, network security, firewalls, virus protection, etc., 
represent possible steps that a user of an 800xA System may want to consider 
based on a risk assessment for a particular application and installation. This risk 
assessment, as well as the proper implementation, configuration, installation, 
operation, administration, and maintenance of all relevant security related 
equipment, software, and procedures, are the responsibility of the user of the 
800xA System.

Topology Designer shares its Graphic Editor Reference with Function Designer. 
For more information, refer to System 800xA Engineering, Function Designer 
(3BDS011224*), section Graphic Editor Reference.
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User Manual Conventions
Microsoft Windows conventions are normally used for the standard presentation of 
material when entering text, key sequences, prompts, messages, menu items, screen 
elements, etc.

Feature Pack

The Feature Pack content (including text, tables, and figures) included in this 
User Manual is distinguished from the existing content using the following 
two separators:

Feature Pack Functionality ______________________________________________________________________

<Feature Pack Content>

___________________________________________________________________________________________

Feature Pack functionality included in an existing table is indicated using a 
table footnote (*) :
*Feature Pack Functionality

Feature Pack functionality in an existing figure is indicated using callouts.

Unless noted, all other information in this User Manual applies to 800xA Systems 
with or without a Feature Pack installed.

Warning, Caution, Information, and Tip Icons

This User Manual includes Warning, Caution, and Information where appropriate to 
point out safety related or other important information. It also includes Tip to point 
out useful hints to the reader. The corresponding symbols should be interpreted as 
follows:     

Electrical warning icon indicates the presence of a hazard that could result in 
electrical shock.

Warning icon indicates the presence of a hazard that could result in personal 
injury.
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Although Warning hazards are related to personal injury, and Caution hazards are 
associated with equipment or property damage, it should be understood that 
operation of damaged equipment could, under certain operational conditions, result 
in degraded process performance leading to personal injury or death. Therefore, 
fully comply with all Warning and Caution notices.

Terminology
A complete and comprehensive list of terms is included in System 800xA System 
Guide Functional Description (3BSE038018*). The listing includes terms and 
definitions that apply to the 800xA System where the usage is different from 
commonly accepted industry standard definitions and definitions given in standard 
dictionaries such as Webster’s Dictionary of Computer Terms.

Released User Manuals and Release Notes 
A complete list of all User Manuals and Release Notes applicable to System 800xA 
is provided in System 800xA Released User Documents (3BUA000263*).

System 800xA Released User Documents (3BUA000263*) is updated each time a 
document is updated or a new document is released. It is in pdf format and is 
provided in the following ways:

• Included on the documentation media provided with the system and published 
to ABB SolutionsBank when released as part of a major or minor release, 
Service Pack, Feature Pack, or System Revision.

Caution icon indicates important information or warning related to the concept 
discussed in the text. It might indicate the presence of a hazard that could result 
in corruption of software or damage to equipment/property.

Information icon alerts the reader to pertinent facts and conditions.

Tip icon indicates advice on, for example, how to design your project or how to 
use a certain function
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• Published to ABB SolutionsBank when a User Manual or Release Note is 
updated in between any of the release cycles listed in the first bullet. 

A product bulletin is published each time System 800xA Released User 
Documents (3BUA000263*) is updated and published to ABB SolutionsBank.
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Section 1  Introduction

Product Overview
Topology Designer is the engineering tool that easily allows the user to configure 
the following:

• On-screen graphical diagrams (Topology Diagrams) displaying the control 
system topology of the 800xA system, the updated status of the devices and 
additional system and hardware unit information.

• Aspects representing hardware unit objects by graphical symbols extended 
with topology related data (Topology Components) in the diagrams.

Configuration of the Topology diagrams is supported by standard diagram skeletons 
and templates and ready-made Topology components delivered with Topology 
Designer.

Topology Diagrams with updated status information are a valuable help in problem 
tracing and maintenance of a plant.

With Topology Designer used as Topology Status Viewer an operator or a 
maintenance employee can inspect and navigate these diagrams on Operator 
Workplaces.

Product Scope

Topology Designer is an option to System 800xA. It is delivered as a part of the 
Engineering Studio product, which is the base for 800xA Engineering Workplaces. 
It is integrated in the Plant Explorer, available in Engineering Workplace or Plant 
Explorer Workplace. 

Topology Designer provides:

• Viewing control system topology including live status information in graphical 
diagrams



Features of Topology Designer Section 1  Introduction

14 3BDS011225-600 C

 

• Vertical navigation - top down, bottom up - throughout the control system 
hierarchy.

• Documenting control system topology in graphical diagrams.

• Aspect System Integration, navigation to other aspect systems through context 
menus.

• Facilities to create homogeneous graphical representations for different aspect 
systems.

• Design tool for Topology Diagrams and Topology Components.

Topology Designer is optimized for hierarchies and instances of hardware related 
object types within Control Structure as provided by the system extension 
AC 800M Connect.

Features of Topology Designer

User can create and design diagrams through Topology Designer to view and 
document control system topology for plants on different levels. Topology 
Diagrams display a consistent view to Aspect Objects within Control Structure and 
data available within referenced aspect systems.

Loading the Topology Designer system extensions equips the Hardware Unit Object 
Types for AC 800M on CPU, Communication Interface and I/O board level 
(currently for S800 I/O only) with Topology aspects which hold Topology 
components. The graphical symbols of the components visually represent these 
hardware units. These symbols are designed in the Component view and can be used 
in the Diagram view.

Topology Designer does not support creation of instances of AC 800M Connect 
control object types in the Control Structure (Insert > Object... or Drag and Drop 
from Object Type Structure). It does not also support Edit > Cut, Copy, Paste or 
Paste Special, and Delete on such instances.

For these object types Topology Designer currently only supports to configure 
Topology Components and the use of existing instances of these object types in 
Topology Diagrams. Use Plant Explorer or Control Builder M Professional or 
Bulk Data Manager to built the hardware related parts of Control Structure.
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The automatic placement of symbols and the correct connection in Topology 
Diagrams is supported by Snap Points, Ports and special Connector Symbols 
working together with symbols for AC 800M and I/O modules.

Further standard Skeletons for Topology Diagrams (in Diagram view) on Controller 
and on Network level are available. 

If the corresponding skeleton is opened on the Topology aspect of the Controller 
object then a Topology Diagram is automatically obtained displaying the Controller 
and its I/O as shown in Figure 2.

Figure 1. Connector Symbols Examples for Electrical Modulebus
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If a Topology aspect is created and the corresponding skeleton is opened on the 
Control Network object then a Topology Diagram is obtained populated with the 
Controllers of the Control Network. 

Figure 2. Topology Diagram on Controller Level

While opening the controller level diagram, the I/O hardware is not connected 
with the controller. Instead it appears as a separate hardware unit at the Controller 
level, Plant Network level, and Control Network level. 

If it is connected manually at the Controller level, then it appears connected in 
other levels also. 
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If a Topology aspect is created and the corresponding skeleton is opened on a higher 
level object, for example an additional Plant Network object created in Control 
Structure, the diagram can contain additionally the symbols for network objects like 
clients, servers, etc. 

In the Control Network and Plant Network case, user can finalize the corresponding 
diagram by arranging and connecting the controller symbols and other symbols. 
From the Controller symbols user can call up the Controller Topology Diagrams.

Prerequisite is that the objects representing the clients, servers and eventually 
other network components have been created in or inserted into Control Structure 
in the hierarchy below the Plant Network object and are prepared with Topology 
Components that provide corresponding symbols.

The controller IP address does not appear in the Diagram view of Topology 
Diagram at controller level. It gets updated on manually updating the IP address 
in the Aspect Properties dialog at the controller level.

Figure 3. Topology Diagram on Plant Network Level
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When the corresponding OPC server is operating and the controllers are running the 
live hardware status information of the Hardware Units is displayed in the Topology 
Diagrams.

In addition to using the pre-configured Topology components of corresponding 
object types and skeletons user can:

• add Topology aspects to objects and object types as required and configure the 
Component view with symbols specifically

• and build Topology Diagrams with free layout by manual arrangement of 
symbols and connecting lines.

If any Hardware Unit object types which are not supported in Topology Diagrams 
are to be used, such Topology components must be configured.

If the hardware unit and structure information is to be presented in a standardized 
layout with other purposes, then configure the skeletons. For example, I/O board 
connection diagrams for plant documentation.

Topology Status Viewer

To view and navigate Topology Diagrams (for example as shown in Figure 2 and 
Figure 3) from a Graphic Display on Operator Workplaces, include an Aspect Link 
to the top Topology aspect in Control Structure into this Graphic Display.

As an operator or a maintenance person (with Operator Role) user can inspect the 
live status information in the diagrams and navigate in the hierarchy of diagrams:

1. Click the Aspect Link button in the Graphic Display to open the pop-up 
window with the Topology Diagram.

2. Set Window > Workbook Mode for the pop-up window.
(Workbook mode is set by default.)

3. Switch on View > Subscribe for Live Data.

4. Use the object context menu item Goto Child Diagram (for example on a 
controller object shown in the diagram) to navigate to a child diagram.

5. Use the object context menu item Goto Parent Diagram (for example on an 
object shown in the diagram) to navigate to the parent diagram.
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6. Navigate through the collection of opened Topology Diagrams using the 
Workbook tabs.

Additionally user can print the Topology Diagrams but the status of the hardware 
components does not appear in the printout.

Supported Hardware Libraries

Topology Designer currently supports the following AC 800M Connect Hardware 
Libraries using extension libraries:

• ABBProcPnlCI851HwLib

• ABBProcPnlCI854HwLib

• BasicHIHwLib

• BasicHwLib

• CI851PROFIBUSHwLib (CI only)

• CI852FFh1HwLib (CI only)

• CI853SerialComHwLib (CI only)

• CI854PROFIBUSHwLib (CI only)

• CI855MB300HwLib (CI only)

• CI856S100HwLib (CI only)

• CI857InsumHwLib (CI only)

• CI858DriveBusHwLib (CI only)

• CI860FFHSEHwLib (CI only)

• CI865SattIoHwLib

• CI868IEC61850HwLib

• CI871ProfinetHwLib

• S800CI801CI854HwLib

• S800CI830CI851HwLib

• S800CI830CI854HwLib
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• S800CI840CI854HwLib

• S800IoModuleBusHwLib

• S900IoCI854HwLib

• S900IoCI851HwLib

• SerialHwLib

Prerequisites and Requirements
For more information on the installation prerequisites and requirements, refer to 
System 800xA Installation and Upgrade Getting Started (2PAA111708*).

For more information on the post installation procedures (including system 
creation), refer to System 800xA, Post Installation (2PAA111693*).

Product Verification
User can verify the product version through Control Panel > Programs > 
Programs and Features. If the Version tab is not visible, then follow the steps to 
view the Version tab:

1. Right-click any available tab (such as Name, Publisher, etc).

To get the Topology Designer functions in your system install the Topology 
Designer feature available as part of Engineering Workplace System Function.



Section 1  Introduction Product Verification

3BDS011225-600 C 21

 

2. Select More..., see Figure 4.

3. Select the Version check box.

4. Click OK.

The version details are displayed below the Version tab.

Follow the above procedure to view other tabs such as Support Link, Support 
Telephone, Help Link, etc. User can also verify the product version from the Plant 
Explorer through About IndustrialIT.

Further, the specific product’s version can be verified through its Help > About 
menu command. For example, Function Designer’s version details can be verified 
through its Help > About menu command from the Diagram or Component view. 
The version details are displayed as shown in Figure 5.

Figure 4. Context Menu to Access More Information
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Reporting Problems

User can report problems to the local ABB supplier. Ensure to report problems with 
the relevant information, such as the product version designation and build number, 
the description of the problem scenario, and the detailed description of the error 
messages that appear.

Figure 5. About Function Designer, Diagram View Window



3BDS011225-600 C 23

 

Section 2  Configuration

Getting Started

Application Start-up

Topology Designer runs integrated in Plant Explorer. Double-click the Plant 
Explorer Workplace or Engineering Workplace icon on the screen.

In Plant Explorer select the required aspect object in Control Structure, etc. Create 
or select a Topology aspect on this object, and Topology Designer appears as a 
preview window. If preview is not enabled right-click the Topology aspect, select 
Diagram view or Component view and Topology Designer appears as a popup 
window.

User Interface

The user interfaces available for Topology Designer are the preview window present 
within Plant Explorer and the Topology window. Indicator in any case is the 
Topology suffix in the drop-down list on top of the window area, respectively the 
corresponding window title.

Engineering Workplace is the recommended workplace, as it adds useful 
engineering commands and functions to the Advanced context menu of aspect 
objects, for example Bulk Data Manager and I/O Allocation.
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Click the topology aspect of the required object to access the preview window that 
offers complete functionality for working with topology diagrams.

Figure 6. Topology Designer as Preview in Plant Explorer
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Double-click the Topology aspect to access Topology Designer in a separate 
window, that can be maximized to use the complete screen. Alternatively, right-click 
the topology aspect and choose Diagram from the context menu. Choose 
Component from the context menu to directly open the topology aspect’s 
Component view..

Recommended User Interface Settings

Topology Designer menus, toolbars, and windows can be displayed within the 
preview window of Plant Explorer as well as in any Plant Explorer overlap window. 

Figure 7. Topology Designer as Popup (Overlap) Window
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User can set Topology Designer user interface preferences (see Preference Settings 
below) such that inside the preview window only minimal set of menus, toolbars 
and windows is displayed, whereas within Plant Explorer popup window all user 
interface controls and windows are displayed.

Preference Settings

Topology Designer stores recent settings and preferences according to their scope:

• User interface preferences including customized toolbar settings and dockable 
windows are stored per user and per view in a workspace in the Windows 
registry. The first time that Topology Designer is run, none or only a minimum 
number of toolbars and no dockable windows are visible by default. The 
windows and toolbars can be arranged as desired. Next time Topology 
Designer is run on the same view, the window/toolbar workspace gets restored. 
There are four separate workspaces:

– Plant Explorer preview window, Component View

– Plant Explorer preview window, Diagram View

– Plant Explorer popup window, Component View

– Plant Explorer popup window, Diagram View

If a previous version is already installed, some newly added toolbar buttons 
may not be initially visible. To return to the default toolbars, and to make all 
toolbar buttons visible, use the menu command View > Toolbar > Customize. 
Select each toolbar and click Reset. Do this for the component view and the 
diagram view, both in preview and in popup window of Plant Explorer.

If some toolbar buttons are still not visible, open the Workplace Operating 
System / Server Operating System registry (run regedit) and delete the following 
keys:

HKEY_CURRENT_USER\Software\ABB Automation Products 
GmbH\EngineerIT\TDDiagramDesigner

HKEY_CURRENT_USER\Software\ABB Automation Products 
GmbH\EngineerIT\TDComponentDesigner

Recent Topology Component / Diagram settings like zoom factor, grid properties, 
default component properties, are stored in the Topology Parameter aspect. These 
settings are maintained as per the Topology Component / Diagram.
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Exiting Topology Designer

If a Topology Diagram is edited, the data is saved using File > Save or File > Save 
All before user closes Topology Designer.

Any attempt to exit Topology Designer before saving data will lead to a warning 
query message box like the one shown in the upper left area of Figure 8. 

If user selects No, then a warning query message box appears as in the lower right 
area of Figure 8.

Creating a New Topology Aspect

To create a new topology aspect:

1. In Control Structure, either:
Right-click an Aspect Object in Plant Explorer to open its context menu and 

Figure 8.  Attempt to Exit Topology Designer Without Saving Changes.

Topology Designer can only rollback the graphic part of the changes.

To avoid possible inconsistencies always leave the second Warning box with No 
and the first query box with Yes or Cancel.
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select New Aspect...
Or: 
Right-click the background of the Aspects list of the Aspect Object and select 
New Aspect... from the context menu.

2. In the New Aspect dialog, select the List presentation check box. 

3. Navigate to and select Topology aspect.

4. Click Create.

Creating a New Topology Diagram

In general, newly created topology aspects have an empty Diagram view. To create a 
new Topology Diagram:

1. Right-click the topology aspect in the Aspect list.

2. Select Diagram to open the Diagram view.

3. In Topology Designer, click File > New to create a new topology diagram or to 
overwrite an existing diagram.

4. In the Templates and Skeletons dialog select either a template (copy or 
reference), a skeleton (copy) or a blank diagram, see Templates and Skeletons 
below.

5. Click OK.

6. Reserve and edit the diagram.

Templates and Skeletons

The Templates and Skeletons dialog offers the following options (see Figure 9): 

• Copy or reference a predefined template for the master page layer with header 
and footer like A3, A4 portrait / landscape.

• Copy a predefined skeleton for the logic layer with snap ports for topology 
components.

• Blank diagram.



Section 2  Configuration Creating a New Topology Diagram

3BDS011225-600 C 29

 User can add additional templates and skeletons or customize installed ones in 
Object Type Structure under Object Types\Topology Planning\Diagram Templates 
and Object Types\Topology Planning\Diagram Skeletons (Figure 10).

Also refer to property Name.Description of that object type groups, Creating a 
Template on page 43, and Creating a Skeleton on page 48.

Figure 9. Templates and Skeletons Dialog
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 If user references a template, the diagram’s master page layer is read-only.

• Header/footer entries like author, document number, cannot be edited inside the 
diagram, but are referenced as aspect properties from a Topology Diagram 
Document aspect in the Object Type Structure, see Figure 11.

• Diagram instances with referenced templates get automatically updated when 
the template changes.

If user copies a template or skeleton, the diagram’s master page layer is writable.

• Header/footer entries like author, document number, can be edited directly 
inside the diagram, but can also be referenced as aspect properties from another 
aspect, by default from a Topology Diagram Document aspect in the same 
object, see Figure 11.

Figure 10. Diagram Skeletons and Templates in Object Type Structure
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• Diagram instances with copied templates do NOT get automatically updated 
when the template changes. 

Application Tutorial

Topology Status Viewer

Perform the following steps to configure a Topology Diagram to view the status for 
the whole plant:

1. On every Controller object: Open the Topology aspect, open Diagram view and 
add a new Diagram based on the skeleton for the Controller level (AC 800M 
Single / AC 800M Redundant). Processor Modules and the Hardware Units 
below by default have Topology aspects with pre-configured Component 

Figure 11. Footer Texts with References to Topology Diagram Document Properties
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views. The symbols of these Topology components are placed by default on the 
diagram. Save the diagram.

2. To reserve an entity Controller or Project or Hardware Library from Topology 
Designer:

Click File > Reserve <entity>.

To release reservation of an entity:

Click File > Release Reservation <entity>.

3. Insert / create objects representing clients, servers and eventually other network 
components in the Control Structure above the Control Network level (refer to 
the hints in Build upper Network Levels on page 33).

4. Create Topology aspects and configure the Component view for the objects to 
be represented in the hierarchy above the controllers. 

5. If applicable add texts/labels to the new Components with aspect property 
references that subscribe to status information. Or include other elements with 
access to and representation of status information, for example ActiveX 
controls.

6. On the object representing the plant add a Topology aspect and create a new 
Topology Diagram from the skeleton Plant Network. It is populated 
automatically with the Topology components in the Control Structure hierarchy 
below the plant object down to the Controller objects.

7. Arrange the symbols of the Topology components and connect them as 
required. Add additional labels/ texts / graphical symbols as required. Save the 
diagram.

8. Switch on Subscribe for Live Data in the View menu. Live Data status 
information appears. Prerequisites are: OPC servers are operating and 
Controllers are running.

9. To view and navigate such Topology Diagrams (as already shown in Figure 2 
and Figure 3) from a Graphic Display on Operator Workplaces, include an 
Aspect Link to the top Topology aspect in Control Structure into this Graphic 
Display.

10. Then operators or a maintenance persons (with Operator role) can inspect the 
live status information in the diagrams and navigate through the hierarchy of 



Section 2  Configuration Application Tutorial

3BDS011225-600 C 33

 

diagrams as already described in Features of Topology Designer on page 14:

Build upper Network Levels

The following subsections provide additional hints to add the objects to the Control 
Structure and to apply the delivered skeletons on upper network levels.

Create Network Topology

Below the Root object of Control Structure the upper network topology with 
maximum levels can be modelled as:

Intranet (optional)
Client Server Network or Plant Network (optional)

Control Networks

The nodes (clients, servers, routers, etc.) can be added later at the corresponding 
level.

For 800xA client and server nodes user can do this by inserting the representing 
objects from the Node Administration Structure into the Control Structure below a 
corresponding parent object, for example Client Server Network or Plant Network 
object.

For objects that are not by default provided by the system structures user can create 
objects of generic object type or design own object types.

In both cases user must add a Topology aspect and configure it within Component 
view.

Figure 12. Example for Upper Network Topology
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Add Topology Diagram on System Level

The topology diagram for upper network levels (down to Control Network) is 
recommended to be created on the topmost aspect object within Control Structure, 
which typically corresponds to the root object or in an own Client Server Network 
object or Plant Network object created below the root object.
Perform the following to add a topology diagram:

1. Add a Topology aspect to the Aspect Object.

2. Select File > New to assign a template or a predefined skeleton.

Figure 13. Create Topology Diagram on Control Network or Plant Network Level
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Create Controller Clusters

The Control Network (according MMS specification) can be subdivided into several 
network areas, for instance to keep the most time-critical communications within 
smaller areas and thereby improve performance.

The CBM integration into Plant Explorer provides the concept to organize 
controllers into Control Projects. Those controllers working on the same 
application and/or having closer communication should be organized into the same 
project.

It is recommended to use the Control Project concept to define controller clusters 
working in same network area.

Create Nodes

The nodes should be created below that network level it belong to. If a node serves a 
router between 2 network levels, it is recommended to create it below the lower 
level.

Figure 14. Use of Control Projects within Network Topology
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Figure 15 displays the nodes ServerA and ServerB have routing functionality 
between Client Server Network and Network 1. So the server nodes are created 
below Network 1 object.

If there are several areas, all controllers collected in one area should belong to one 
Control Project (including those with router functionality to upper level).

Finalize Network Topology Diagram

When the Topology Diagram is opened for the first time, all network and node 
objects (having Topology aspects with configured Component view) will be pre-
placed within the diagram and must be arranged manually (if no skeleton with 
predefined placement was used). For example, refer to Figure 3 in Features of 
Topology Designer on page 14.

Figure 15. Example for Controllers within Control Structure
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Build I/O and Bus Topology for Controllers

The following subsections describes how to add objects to the Control Structure and 
how to apply the delivered skeletons at the controller level.

Create Topology Diagrams to Controllers

When creating the controllers, a Topology aspect is copied as default to the 
controller object. 

Perform the following steps to add a Topology Diagram to controller:

1. Double-click the Topology aspect.

2. Select File > Template to assign the corresponding skeleton.

Create I/O Modules

I/O modules can be created through the Plant Explorer, CBM (for few modules) or 
through BDM (for bulk modules). The modules are automatically updated into the 
Topology Diagram during next open (if placement was predefined within skeleton). 
If the Topology Diagram was open during creation, it can synchronized, i.e. show 
and snap the modules, by pressing SHIFT+S.k

Figure 16. Assign Skeleton
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Create Topology Diagrams for Fieldbusses

Topology Diagrams for fieldbuses must be defined on Topology aspects related to 
corresponding interface modules. (CI854 for PROFIBUS, CI860 for 
FOUNDATION Fieldbus, etc.).

The workflow corresponds to that for controller, but user should select skeletons 
AC 800M PB FF Single/Redundant instead. The fieldbus remote stations with their 
coupler (e.g. CI840) are placed at arbitrary positions on the template. The final 
positioning and adding of the bus lines has to be done manually.

Figure 17. Update Modules into Controller Diagram

If the object type supports CBM - DTM Data Synchronization, the I/O-module 
configuration (parametrization) has to be done with the DTM. Otherwise 
configuration (parametrization) can be done in Plant Explorer, CBM or Bulk Data 
Manager.
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Example of AC 800M with local I/O and 1 PROFIBUS station:

Allocate Field Devices

Field Devices are assumed to be defined from the Functional Structure. They are 
allocated to fieldbuses (PROFIBUS, etc.) by assigning them in addition into the 
Control Structure. They are automatically updated at the correct location into the 
Topology Diagrams if placement is predefined within the skeleton.

Finalize Topology Diagrams

After having completed the Control Structure, it might be necessary to do some final 
adaptation within Topology Diagrams for controllers:

• Remove obsolete parts remaining from the skeleton.

• Re-arrange the placement of buses/modules/devices.

Figure 18. AC 800M PROFIBUS Configuration
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Build Topology Component Object Types

If user-defined Topology Component Object Types are required, for example if 
other Hardware Libraries that are currently supported shall be extended with 
Topology aspects, user should:

• analyze the delivered Topology Components for AC 800M and S 800 I/O
(examine the corresponding object types of the Hardware Libraries in the 
Object Type Structure under Object Types / Control System / AC800M/C 
Connect / Libraries / Hardware)

• and follow the workflow given in Creating a New Topology Component on 
page 66.

Use library extensions to bring the Topology aspects into object types of the 
Hardware Libraries, as it is done for the supported Hardware Libraries Supported 
Hardware Libraries on page 19.

Topology Diagrams
Topology Diagrams are provided as Aspect Objects with a Topology aspect 
containing the diagram. They are edited in Topology Designer’s Diagram view on 
the Topology aspect.

Refer to Creating a New Topology Aspect on page 27 and Creating a New Topology 
Diagram on page 28.

Topology Diagrams are based on Diagram Templates on page 43 or Diagram 
Skeletons on page 47.

Topology component object types are instantiated in the Diagram view of Topology 
Designer. 

• User can do that through the menu command or through drag-and-drop. For 
details on inserting and creating components, refer to System 800xA 
Engineering, Function Designer (3BDS011224*).

• When a new Topology Diagram is opened on a parent object the child 
Topology Component objects get inserted automatically in this diagram. 
Depending on the kind of diagram user might have to arrange the symbols of 
the Topology Components on the diagram.
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User further configures Topology Diagrams connecting ports of the graphical 
symbols of Topology Components. For more details, refer to Topology Diagrams in 
System 800xA Engineering, Function Designer (3BDS011224*) manual.

For structured information access user can build a hierarchy of Topology Diagrams, 
refer to Vertical Navigation on page 42.

Change Type

Changing Type of Component Instances

To change the type of an aspect object a function can be invoked by the object verb 
Change Type …. To support this functionality in Topology Diagrams as well a 
Change Type … context menu entry is available when one single component 
instance is selected.

When invoking the Change Type function a dialog pops up that allows the user to 
select the new object type.

During the execution of the Change Type function the aspect properties of the 
component instance are exchanged keeping the values for matching property names. 
This ensures that connections between objects are preserved where possible.

The symbol of the changed component instance is updated in any open diagram. 

For details regarding the Connections/Networks, refer to System 800xA 
Engineering, Function Designer (3BDS011224*). User needs to use the 
Topology aspect or Topology component symbol instead of the Function aspect 
or Function component symbol as applicable in the workflows.

It is possible to change the type of an aspect object to another aspect object type 
(in the Plant Explorer and Topology Diagrams) and the type of a symbol object to 
another symbol object type (in Topology Diagrams only).

Conversions from aspect object type to symbol object type or vice versa are not 
supported.

Be aware of the fact the Change Type covers all aspects of the object type and 
ensure that the user knows and can accept the changed behavior of all aspects.



Vertical Navigation Section 2  Configuration

42 3BDS011225-600 C

 

Changing Number of Ports

Certain objects have an aspect property NumberOfInputs which controls the 
number of single ports (or port groups). The value of this aspect property is set by 
the user when creating an object instance in a Topology Diagram. When creating an 
object instance in the Plant Explorer (or through Bulk Data Manager, etc.) a default 
value for this parameter is used.

In order to change the value of the NumberOfInputs aspect property a new context 
menu entry Number Of Inputs… is introduced when a single component instance 
(which has this aspect property) is selected in a Topology Diagram. 

When invoking the Number Of Inputs function the following dialog pops up:

Figure 19. Dialog Number of Inputs 

Changing the value of the NumberOfInputs aspect property is possible through the 
Aspect Properties dialog or through Bulk Data Manager.

When the value of the NumberOfInputs aspect property has been changed the 
symbol of the according component instance is updated in any open diagram. As the 
values of other existing aspect properties remain untouched port connections are 
kept when increasing the value. When decreasing the value of NumberOfInputs 
the superfluous dependent port related aspect properties (and according 
connections) are removed.

This functionality is not available in the Plant Explorer.

Vertical Navigation

For a better overview on topology diagrams, it is possible to built a hierarchical 
Control Structure with parent-child diagrams. Topology relevant units on a lower 
level can be summarized in a separate diagram and displayed on an overview 
diagram on higher level as a single topology component with input and output ports 
/ parameters.
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Diagrams on lower level are also called child diagrams. They can be opened from a 
(parent) diagram by choosing View > Goto Child Diagram or Goto Child 
Diagram from the context menu.

Diagrams on upper level are also called parent diagrams. They can be opened from 
an child diagram by choosing View > Goto Parent Diagram or Goto Parent 
Diagram from the context menu.

Navigation from the child to the parent diagram can also be achieved by using the 
Topology Designer window in Workbook mode or by opening the Parent Diagram 
view from the aspect context menu on the Topology aspect of the child diagram.

This is called vertical navigation - top down, bottom up, throughout the hierarchy in 
the Control Structure.

Diagram Templates
A template defines the diagram frame and footer including a logo. All the parts of a 
template are defined on Master Page Layer in diagram view of a Topology aspect.

Creating a Template

Create an Aspect Object Type within Object Type Group Diagram Templates of 
Topology Planning subtree.
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It is recommended to set the object type to Explicit Object Type within Object 
Type Definition aspect.

Figure 20. Create a Topology Diagram Template
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Insert a Topology aspect and create a diagram view through File > New.

Template Layout Guidelines

Recommendations for lines:

• For thick lines use 0.7 mm width (ISO 5457).

• For medium lines use 0.5 mm width.

• For thin lines use 0.35 mm width.

• Avoid using rectangle or polygon, use instead polyline
Reason: easy selection of included graphics.

Recommendation for text properties within A3L:

• For label texts use ARIAL, Bold, 10 points.

• For normal text use ARIAL, regular, 12 point.

• For titles use ARIAL regular, 16 points.

• For document number use ARIAL, regular, 22 points.

Figure 21. File > New to Create a Diagram View
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Property References used in Standard Template

The A3L Standard template is built according to definitions in 9ADA 354 (IEC 
layout) and ISO 5457, second edition. 

Following property references are used (pre-configured):

The property naming is harmonized with those within Document Manager, refer 
to System 800xA Engineering, Engineering Studio (3BDS011223*).

Table 1. Property References used in Standard Template  

Aspect Property References Description

Topology aspect properties

DocId Document identity number

RevisionIndex Revision Index

DocDCCNo Document kind classification code

SheetNo Start number for first sheet in diagram

NextSheet reference to first sheet in next diagram

DocDCCName Document kind name

Title1 Document title 1

Title2 Document title 2

Title3 Document title 3

DocDes1 Document designation 1

DocDes2 Document designation 2

BasedOn Based on

Replaces Replaces

Owner Name of legal owner

RespDept Responsible department

Lang Language code

Status Status of document (Approved, Draft)

PrepName Name of preparing person
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Diagram Skeletons
Diagram Skeletons are used as a pattern for a certain type of Topology Diagram, for 
example: AC 800M Controller (single or redundant), PROFIBUS, Control Network, 
etc.

Using connector symbols it can be enabled for fully automatic generation of a 
Topology Diagram.

PrepDept Department of preparing person

PrepDate Prepared date

ApprName Name of approving person

ApprDept Department of approving person

ApprDate Approved date

RevIdx1,2,3 Revision index in revision list row 1,2,3

RevNote1,2,3 Revision note in revision list row 1,2,3

RevDate1,2,3 Revision date in revision list row 1,2,3

RevName1,2,3 Revision name in revision list row 1,2,3

Structure Aspect Properties

Control Structure.ARD Absolute control reference designation

Location Structure.ARD Absolute location reference designation

Project.Customer Settings aspect properties

Project Name 1 Project name 1

Project Name 2 Project name 2

Project Name 3 Project name 3

Table 1. Property References used in Standard Template  (Continued)

Aspect Property References Description
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Creating a Skeleton

Perform the following to create a Topology Diagram skeleton:

1. Create an Aspect Object Type within Object Type Group Diagram Skeletons 
of Topology Planning subtree (use optionally sub-groups to organize 
skeletons).
Note: It is recommended to set the object type to Explicit Object Type within 
Object Type Definition aspect.

2. Create a Topology aspect at Object Type.

3. Create diagram view through File > New and add template.

Figure 22. Explicit Object Type within Object Type Definition Aspect

Insert

Insert the template by reference, so that late adaptations to the template can be 
made and all diagrams based on that template are adapted automatically.



Section 2  Configuration Use of Connector Symbols

3BDS011225-600 C 49

 
Use of Connector Symbols

Connector symbols are used within skeletons:

• to predefine the insertion points for components (modules, computers, 
devices...) into diagram through snap ports and

• to allow definition of connecting lines representing buses and nets through 
connect ports at connector symbol.

Connector symbols are only inserted into the diagram and do not have a direct 
relation to aspect objects within Plant Explorer. They may graphically represent (for 
example) modems, which are not available as aspect objects within Control 
Structure.

Figure 23. Create Diagram View through File > New and Add Template
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The following figures show the use of connector symbols within any type of 
skeletons: 

Figure 24. Connector Symbols within AC 800M Controller Skeleton

Figure 25. Connector Symbols within Control Network Skeleton
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Creating Connecting Lines

Connecting lines are drawn by pointing to a connect port of a symbol and dragging 
the line to another connect port. As default the connecting lines are adjusted by an 
auto routing algorithm. The auto routing parameters can be configured through 
Autorouting tab within Options dialog (called through Edit > Options)

In some cases the auto routing algorithm may not work as required. In such cases 
the vertices of a connecting line can be pinned.

To pin a vertex:

1. Select a connecting line.

2. Move the cursor to a vertex.

3. Press CTRL+SHIFT and click to the vertex.

A pinned vertex is colored with red. Move the pinned vertex as required. A vertex 
can be unpinned similarly.

Figure 26. Configuration of Autorouting
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Perform the following steps to move the selected line in the above example to the 
final location:

1. Add an auxiliary vertex to the selected line (use CTRL+ALT and click to the 
required location).

2. Drag the line on the auxiliary vertex to the final position.

3. Fix the line by an additional pinned vertex.

Layout of Connecting Lines

Depending on Connection Type (see Properties for Snap Ports on page 76) different 
line settings should be used:

• Intranet settings

– color:  (light grey)

– width: 1 mm (10 mm for 1:10 scale)

Figure 27. Use of Pinned Vertices on Connecting Lines

Figure 28. Use of Auxiliary Vertex to Move Line
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• Client Sever Network settings

– color:  (blue)

– width: 1 mm (10 mm for 1:10 scale)

• Control Network settings

– color:  (red)

– width: 1 mm (10 mm for 1:10 scale)

• Optical Modulebus settings

– color:  (dark grey)

– width: 1 mm (10 mm for 1:10 scale)

• PROFIBUS settings

– color:  (R:204, G: 153, B:255)

– width: 1 mm (10 mm for 1:10 scale)

• FOUNDATION Fieldbus settings

– color:  (R:0, G:204, B:153)

– width: 1 mm (10 mm for 1:10 scale)

• LON settings

– color:  (R:204, G:0, B:153)

– width: 1 mm (10 mm for 1:10 scale)

• HART I/O settings

– color:  (black)

– width: 0.5 mm (5 mm for 1:10 scale)

Aspect Properties
Aspect properties can be defined in Component view and in Diagram view for the 
selected topology component or topology diagram. User can define properties that 
get inherited from the object type, or properties that get copied on object 
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instantiation. Inherited properties are stored within the topology aspect, and copied 
properties are stored within the Topology Parameter aspect. 

Use the Aspect Properties Dialog to create, edit, or delete aspect properties. Their 
scope depends on the selection:

Adding an Aspect Property

Perform the following to add an Aspect Property:

1. Select the object to which an Aspect Parameter (for example a symbol’s port) is 
to be added.

2. Open the (Aspect) Aspect Properties Dialog:

– Either right-click and select Aspect Properties from the context menu.

– Or select Edit > Aspect Properties menu command.

3. Right-click the free background of the Parameters dialog and select Add 
Property from the context menu. 

A new empty row is inserted.

4. Enter the required values into the fields using the drop-down lists provided for 
the fields Access Type and Data Type.

5. Click Ok/Apply.

Table 2. Scope of Aspect Properties

View Object Scope

Component view Selected port Aspect properties for the selected port

Any other selected 
object

Aspect properties for the whole 
component

Diagram view Selected port Aspect properties for the selected port

Selected topology 
component

Aspect properties for the selected 
component

Any other selected 
object

Aspect properties for the whole diagram
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Removing an Aspect Property

Perform the following to remove an Aspect Property:

1. Select the object from which the required Aspect Property is to be removed.

2. Open the (Aspect) Aspect Properties Dialog:

– Either right-click select Aspect Properties from the context menu.

– Or select Edit > Aspect Properties menu command.

3. Right-click the row containing the Aspect Property that is to be deleted.

4. Select Remove Property from the context menu.

5. Click OK/Apply.

Aspect Properties Dialog

Use this dialog to display, add or remove aspect properties of an object, with scope 
diagram, component, port.

Access this dialog through Edit > Aspect Properties menu command or through 
Aspect Properties from the context menu of the object.

Figure 29. Aspect Properties Dialog
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• Name

Defines the name of the property/parameter. User can edit the name directly in 
the Name cell. Copied and inherited properties/parameters share the same 
name scope. Do not use a dot ‘.’ in the name, as a dot is used as a separator for 
structured properties. 

• Data Type

Defines the data type of the property/parameter. User can select the data type 
from a drop-down list.

In addition to the default data types Integer, Real, String, and Boolean two 
additional enumerations are listed: 
– Port Direction (noDirection, in, out, inout, plug, socket)

– DataType (only used for compatibility with old diagrams)

The enumerations are defined on the Topology Aspect category as Topology 
Enumeration aspect, refer to Figure 30. 

Figure 30. Enumeration Definition on Aspect Category
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Port Direction defines the direction of a port parameter:
– noDirection: general port parameter with no specific direction.

– in: Input parameter in the sense of a IEC61131-3 Var_Input.

– out: Output parameter in the sense of a IEC61131-3 Var_Output.

– inout: In-Out parameter in the sense of a IEC61131-3 Var_InOut.

– plug: snap port, provides direct connectivity to socket of other symbols.

– socket: snap port, provides direct connectivity to plug of other symbols.

DataType is no longer used, but needed to upgrade topology diagrams created 
with former versions of Topology Designer.

Additional enumeration data types can be added by adding further ‘Topology 
Enumerations’ aspects to the Topology aspect category, i.e. to
[Aspect System Structure]Topology Designer/Topology/Topology. 

• Access Type

Defines the access type for the property/parameter. User can select the access 
type from a drop-down list.
– None: Property/parameter is neither readable nor writable from other 

aspect systems or Bulk Data Manager. Used internally in Topology 
Designer only.

– Read: Property/parameter is readable from other aspect systems and from 
Bulk Data Manager, but not writable.

– Write: Property/parameter is writable from other aspect systems and from 
Bulk Data Manager, but not readable.

– Read & Write: Property/parameter is readable and writable from other 
aspect systems and from Bulk Data Manager.

Read and write permission of individual properties/parameters equals the 
read/write permission of the Topology aspect or Topology parameter aspect.

• Inherited

Defines whether the property/parameter is inherited or not. 
– Inherited properties/parameters are stored within the Topology aspect 

which is typically inherited from an object type.
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– Copied properties are stored within the Topology Parameter aspect which 
gets typically copied from an object type.

• Value

Defines the value of the parameter.

• Publish via Parent Diagram

This is an enhanced setting allowing to read/write component 
properties/parameters through the parent diagram. Mainly used when copying 
diagrams or setting diagram parameters through Bulk Data Manager.

Aspect Property/Parameter References

Instead of setting static text into a text or label component, user can define 
references to any aspect property / parameter. By that, the text or label subscribes to 
and displays dynamic data, e.g. live data from an OPC data provider, a PID gain 
factor, or some document property field defined in a Document aspect. 

The text or label components on a topology diagram are automatically updated 
when the subscribed aspect property changes. So, always consistent and up-to-date 
topology diagrams are obtained. 

Perform the following to set a parameter reference in a text or label component:

1. Open the Component Properties dialog and click the Field page.

2. Choose Property Reference option in the Field Code group box.

3. Click  to open the Aspect Property Reference dialog.

4. Select Structure, Select Object, Aspect, and Property from the 
corresponding list box. The Reference String text box displays the selection.

5. Select the Reference Type and click OK/Apply. The Aspect Property 
Reference dialog is closed.

6. Click Add to enter the selected parameter reference into the Field text box.

7. Click OK.
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Aspect Property Reference

Use the Property Reference dialog to define the Reference String for the required 
aspect property.

Open this dialog from the Component Properties’ Field page by clicking the 
button behind the Aspect Property Reference text box:

For more information on usage of Parameter References in Topology Designer, refer 
to Property References on page 60.

For details on the syntax for aspect property references, refer to System 800xA 
Engineering, Engineering Studio (3BDS011223*).

Figure 31. Aspect Property / Parameter Reference Dialog
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Property References

Application Scope

Property references are used within Text and Label elements to obtain the aspect 
data through property referencing mechanisms. Property references can be added to 
the levels:

• Components.

• Templates.

• Skeletons (within labels).

• Diagrams (within labels) Property references are added to Text/Label elements 
through Component Properties dialog

Figure 32. Property Reference for a Text/Label Element
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Property References to Aspect Properties

Property references can be defined through Aspect Property Reference dialog. On 
Topology Designer side property references must be encapsulated by “$”

It is possible to add several property references to same Text/Label element or to 
mix it with static text:

Example: Object Name: $.:Name:Name$

Property References to Topology Aspect Properties

When referencing from component/diagram to properties belonging to same 
Topology aspect, use the short syntax $<name>$ 
(Example: $IP_Number$)
This is faster than using $.:IP_Number$

Figure 33. Calling Property Reference Dialog
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Using Visual Basic Script Expressions

It is possible to use VB Script expressions together with property references.
A VB Script expression must be encapsulated with
<vbs> expression </vbs>

Example using VB Script expression
The example consists of a property references (enclosed by ‘$’ characters) that 
addresses the object name and takes only the 5 left most characters

<vbs>Left("$.:Name.Name$", 5) </vbs>

Within VBScript expressions only functions, operators and constants can be used. 
For a detailed description on how to write VBScript expressions visit Microsoft 
website. Within VBScript expressions all function for the object with name DM (= 
VB Extensions of Document Manager) can be used. Currently the following 
functions are available:

• Function FormatDate(expression, format)
The FormatDate function has the following parameters
     expression:Any valid string expression.
     format: A valid name or user defined-format
The function takes the string expression and formats it according the format 
specified in the format parameter.
Refer to the example above for how to use the FormatDate function of the 
object dm.
For a detailed description on what formats are valid, visit Microsoft website 
and look for the VisualBasic Format function.

• Function Matches(text,pattern)
The Matches function has the following parameters
     text: Any string.
     pattern: Any string which can additionally contain wildcards 
Wildcards
     ? - Any single character. 
     * - Zero or more characters. 
     # - Any single digit (0–9). 
     [charlist] - Any single character in charlist. 
     [!charlist] - Any single character not in charlist.
The Matches function takes the text parameter and checks wether it is like the 
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pattern parameter.
For more details, visit Microsoft website to get a description of Visual Basic 
like operator.

• Function IfThenElse(condition, if-case, else-case)

The IfThenElse function has the following parameters
     condition: Any valid boolean expression.
     if-case: Any valid expression of either type
     else-case: Any valid expression of either type

The function IfThenElse evaluates the condition and return the if-case 
expression if the condition is true and returns the else-case expression if the 
condition is false.
For more details, visit Microsoft website to get a description of Visual Basic if 
function.

• Function FormatSignal (name, cut-app-flag, cut-ext-flag)

Function FormatSignal uses parameters
.....name: variable name according CBM and I/O allocation needs
.....cut-app-flag: Boolean, cuts application from name if TRUE
....cut-ext-flag: Boolean, cuts “_VAR” extension from name if TRUE.

• Function OnError (prop-ref, error-text)

Function OnError uses parameters
.....prop-ref: any property reference
....error-text: text to be returned instead, if property reference fails.

Example using DM Functions
<vbs>DM.OnError("$.:Location Structure:ABS$","+")</vbs>
returns “+”, if Location Reference Designation does not exist.
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System Status Display

Property references can be used within any element to hide it.

This functionality is selected through the Component Properties dialog

The condition 
<vbs>(DM.OnError( "$.:Property Translations 
Extended:S_STATUS$" ,"-1") )= "0" </vbs>
shows this graphical element only, if the value of 
Property Translations Extended:S_STATUS is 0.
If Property Translations Extended:S_STATUS can not be evaluated 
(e.g. OPC status is Bad), the value is forced to -1 by DM.OnError... and 
therefore the element is hidden as well.

Figure 34. Component Properties Dialog
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The status display of CPU and IO-modules is done by colored circles in the 
graphical symbol:

• RED : F  failure (S_STATUS = 1)

• YELLOW : W  warning (S_STATUS = 2)

• GREEN : R  run (S_STATUS = 0)

Example of PM module with status display. 

The left picture shows the component in Object Type Structure, the right picture in 
the Control Structure with online status display.

Figure 35. PM Module with Status Display
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It is difficult to select these circles by mouse for editing because they are invisible 
and positioned at the same place. Use menu Edit > Components..., then select one 
of them (they are mostly named Ellipse, Ellipse1 and Ellipse2) and continue with 
Properties...

Topology Components
Topology Components are provided as Aspect Objects with a Topology aspect 
containing the component. They are edited in the Component view of the Topology 
aspect in Topology Designer. Typically Object Types are used to provide Topology 
components.

Topology component object types can be instantiated in the Diagram view of 
Topology Designer. 

• User can perform that through menu command or through drag-and-drop. For 
details on inserting and creating components, refer to System 800xA 
Engineering, Function Designer (3BDS011224*).

• When user opens a new Topology Diagram on a parent object the child 
Topology Component objects are inserted automatically in this diagram. 
Depending on the kind of diagram user might have to rearrange the symbols.

Creating a New Topology Component

1. Select a topology aspect from the Aspect list of Plant Explorer or create a new 
Topology aspect and open its Component view. In general, newly created 
topology aspects have an empty Component view.

2. Use the File > New menu command to create a new topology component or to 
overwrite data from an already existing one.

3. Reserve the diagram and create a fixed graphical symbol with ports, and a fixed 
parameter set.

4. Select File > Save.

Defining Topology Component Object Types

Perform the following to define a topology component Object Type:
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1. Choose the Object Type Structure from Plant Explorer of the Engineering 
Studio Workplace window.

2. Browse to the location where the new topology component Object Type is to be 
located.

3. Create a new object type using New Object dialog which is opened through the 
corresponding context menu command.

4. Create a new Topology aspect using the New Aspect dialog. Select the 
topology aspect from the aspect list and click Create.

5. Open the Component view on this aspect.

6. Use File > New.

7. Design the symbol of the topology component using the graphical editor 
facilities.

a. Draw the required shape (refer to General Symbol Design Rules on page 
72).

b. Add Texts/Labels, if needed with Property References (refer to Property 
References on page 60).

c. If required add Connection Ports (refer to Definition of Connect Ports on 
page 73).

d. If required add Snap Ports (refer to Definition of Snap Ports on page 76).

8. Add aspect properties for the ports and other elements. For general information 
refer to Adding an Aspect Property on page 54, specific information is given in 
Definition of Connect Ports on page 73, and Definition of Snap Ports on page 
76.
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9. Configure the Object Type Definition of the Topology Component object type 
accordingly, refer to Object Type Definition and Usage on page 68.

10. Select File > Save.

Object Type Definition and Usage

Aspect Control

If an Object Type is created with a Topology aspect (a Topology Component Object 
Type or a Topology Diagram Object Type) there are three options that determine 
how the Topology aspects behave at creation of an instance Aspect Object from an 
Object Type.

• The Topology aspect is inherited:
This is the recommended way for objects using only the Component view of 
Topology aspects and/or the object can be combined with various skeletons.
Note: This is used as standard setting within object type groups provided with 
Topology Designer.

• Or the Topology aspect is copied:
This is the recommended way for objects using always (also) the Diagram view 
of Topology aspects and a specific skeleton (at least as default) should be 
assigned.

• Or the Topology aspect can be used as template:
This is the recommended way for objects having optional Topology aspects 
(and are therefore optionally shown in diagrams).

For more information on how to create object types, refer to System 800xA, System 
Planning (3BSE041389*) and System 800xA, Configuration (3BDS011222*).

To define Topology Components for hardware units or modify existing ones take 
special care of the information given in Topology Aspects for Controllers, I/O 
and Interface Modules on page 78, Topology Aspects for Client/Servers on page 
80, and Topology Aspects for Connector Symbols on page 81.
User should further analyze the delivered Topology Components for AC 800M / 
S 800 I/O in the Object Type Structure under 
Object Types / Control System / AC800M/C Connect / Controller Hardware.
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Topology Component Object Type instances typically comprise both inherited and 
copied data. User might inherit e.g. the symbol and interface definition from an 
object type, but store component properties including connections in a separate, 
copied aspect. So Topology Designer uses two aspects:

• The Topology aspect, which is typically inherited for most object types.

• The Topology Parameters aspect, which must be copied, because it is the 
container for all instance specific parameter values.

User can define a Topology aspect as default aspect, refer to System 800xA 
Operations, Operator Workplace Configuration (3BSE030322*).

Inherited Topology Components

If a new topology component object is created in a topology diagram, the settings of 
the Object Type Definition aspect defines how the topology component instance 
gets updated if its type changes.

• To inherit properties from the object type to the object instance, the option 
Inherit when object is created has to be set. Then, modifications of this aspect 
will automatically result in updating all object instances, which includes all 
inherited components in topology diagrams.

• To copy properties, set the option Copy when object is created. Then, aspect 
properties will be copied on creating the object but modifications will not have 
any effect on the object instances.

Perform the following to adjust/modify the Aspect Control properties:

1. Open the Object Type Structure dialog by selecting the Goto Type command 
from the context menu of the component whose object type aspect controls 
shall be changed.
Alternatively, user can open the Object Type Structure in the Engineering 
Studio Workplace and select the required object type.

2. Click/Double-click the Aspect Object type Definition to open the Object Type 
Definition dialog/preview.

3. Open the Aspect Control page and select the required Aspect. 

4. Set the Copy/Inherit options as required.
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The following figure displays indicators for a inherited component:

• Read Only within the brackets in the Component Properties dialog.

• READ flag in the status bar of the Engineering Studio Workplace.

Overridden Components

User can prevent inheritance on components by disabling the corresponding option 
Inherit when object is created on the Aspect Control page of the Object Type 
Definition dialog.

To interrupt the inheritance for a topology component, user can override the setting 
done for the topology component type (object type) by doing as follows:

1. Select the topology component object instance from the Control Structure.

2. Click right on the topology aspect from the aspects list to open the aspect 
context menu.

3. Choose Override. 

Figure 36. Indicators for Inherited Components: Read Only, READ Status

After having executed Override, the inheritance link to the topology component 
type can be restored using Delete Override.
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Create Info

User can define if a topology component (Aspect Object type) is instantiated as 
Aspect Object in the Control Structure, or as symbol object in the topology diagram 
only. For it, set the corresponding Create Info options in the Object Type 
Definition Aspect:

1. Open Plant Explorer of Engineering Studio Workplace.

2. Select the object type from the Object Type Structure.

3. Choose the object type’s aspect with the category name Object Type 
Definition (for example, PID Type Definition).

4. Choose the page Create Info.

5. Check the options Can be created as root, Can be created in all Structures 
and Explicit Object Type of the Structure Info group box and modify them in 
the following way:

– To define a topology component Aspect Object, the first two options must 
be set (selected) and Explicit Object Type must not be set (cleared).

– To define a topology component symbol object, the first option must not 
be set (must be cleared) and the two other options must be set (selected). 
See Figure 37.

For simple layout objects like adapters, connectors and so on, the Create Info 
options are not set, so these topology component symbol objects are created and 
stored on topology diagram only.
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General Symbol Design Rules

For good appearance and visibility of symbols of Topology Components in 
Topology Diagrams some general design rules must be considered:

• The symbols should be designed in way, that it can be used in a 2.5 mm grid 
system (25 mm grid system for 1:10 scaled drawings). So if applicable the 
upper and left borders of the symbol should be on multiples of 2.5 mm (resp. 
25mm). 
Note: the optimal placement of connect ports must be considered with higher 
priority than symbol borders.

• On top of the symbol 5mm (50 mm for 1:10 scale) should be reserved text 
(attribute or label).

Figure 37. Create/Structure Info for Topology Component Symbol Objects
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• Insert an invisible rectangle at 0,0 to fix the 0 point as origin of the symbol 
(important for snap to grid).

• Designations and technical information must appear at symbol with 2.5 mm 
size. Therefore use Arial font with 12 point size (resp. 120 point for 1:10).

• Within symbol the color black (for lines, areas and even text) should be avoided 
(creates too much contrast in printouts. Use instead dark grey (100, 100, 100).

Definition of Connect Ports

Ports can be added to symbols and provide connectivity to other symbols through 
connecting lines.

Following rules must be considered for naming and property settings:

• Connect ports can be defined as input and output. As criteria (what is input and 
what is output) must be considered:

– Ports placed on right hand or bottom side of a symbol are regarded as 
output.

– Ports placed on left hand side or top side of a symbol are regarded as 
input.

Figure 38. Size of Designations and Technical Information
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– To a net only one output should be connected, but several inputs can be 
connected (actually not checked).

• Use the Component Properties dialog of the Port, General page, to enter the 
names.

– Input ports should be named IN1, IN2, IN3, etc.

– Output ports should be named OUT1, OUT2, OUT3, etc.

• For each port 2 properties on aspect level must be defined. 
Use Edit > Aspect Properties:

– <portname> : will be used later for linking
must be of type STRING and must not be inherited.

– <portname>.Direction : specifies the port direction,
has to be of type Port Direction and set to in or out.

Figure 39. Specify Port Direction
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Following rules need to be considered for placement of connect ports:

• Connecting lines within diagram should be drawn within 2.5 mm grid system.
To achieve this purpose within symbols inserted with 1:10 scale:

– At horizontal symbol borders it has to be placed on multiples of 25 mm in 
x direction.

– At vertical symbol borders it has to be placed on multiples of 25 mm in y 
direction.

• Parallel buses/nets need to be drawn within 2.5 mm distance (relative to middle 
of line) (25mm for 1:10 scale).

• Bus/net lines should appear with thickness between 1 mm and 1.5 mm. To get 
no overlapping between line and symbol, the ports must have a distance of 
around 0.5 mm to symbol border (5 mm for 1:10 scale).

Figure 40. Bus/Net Lines Thickness



Definition of Snap Ports Section 2  Configuration

76 3BDS011225-600 C

 

Definition of Snap Ports

Snap Ports can be added to symbols and provide direct connectivity to other 
symbols (without use of connecting lines). This provides also the functionality to 
place symbols automatically within a Topology Diagram skeleton.

Type of snap ports

It is distinguished between:

• Socket - provides optional symbol connectivity to plug (need not to be 
connected).
Example: Processor module provides sockets to local I/O and interface boards.

• Plug - provides symbol connectivity to socket. Must be connected when 
diagram is finished.
Example: I/O module must be connected to processor, modem or previous I/O 
module.

Naming conventions for Snap Ports

Snap Ports are identified by a Name, which is composed by an alphabetical and 
numerical part.

• Sockets should be named Socket1, Socket2, Socket3, etc.

• Plugs should be named Plug1, Plug2, Plug3, etc.

• If several plugs/sockets exist it should be numbered beginning with topmost 
and left most ports, continuing in clockwise sense.

Properties for Snap Ports

For each snap port some properties on aspect level must be defined. 
Use Edit > Aspect Properties. 

Mandatory properties:

<port> must be identical to name of snap port (Example: 
Socket1).
must be of type STRING, not inherited
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<port>.Command Specifies the rule associated to snap port

• Find: referenced object is snapped when opening 
diagram (through “Parent”, “Child”).

• PrevSibling: previous object on same level is 
snapped (only for “Plug”).

• NextSibling: next object on same level is snapped 
(only for “Socket”).

• Parent: object is snapped to parent (only for “plug”).

• Child: referenced child object is snapped (through 
“<port>.Parent”, “<port>.Child”).

<port>.Direction Must be set to “plug” (if plug) or “socket” (if socket).

Optional/depending properties

<port>.Parent Identifies the parent of object, if <port>.Command = 
“Find”

It includes just the name path in Control Structure for 
addressing. User can use

• <Diagram> to address relative to diagram relate 
object and

• <Component> to address relative to component 
relate object.

Example: “<Diagram>.Hardware.0.11”
addresses processor module within controller diagram

<port>.Child Identifies object relatively to parent object to be inserted 
on snap port, if <port>.Command = “Find” or “Child”.

Example: “101” addresses module 101 below parent.

<port>.ConnectionType specifies type of connection/interface. Only snap ports 
with same value for connection type can be connected to 
each other. Examples:

• ControlNet.

• PROFIBUS.

• ModuleBus.
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 Topology Aspects for Controllers, I/O and Interface Modules

The corresponding Topology aspect are installed to related object types within 
AC 800M Connect subtree of the Object Type Structure.

The aspects are actually inherited from object type.

For interface and HART I/O modules a default diagram view may be added already 
in object type. In this case the Topology aspect must be set to Copy. 

Figure 41. Snap Port Properties Definition



Section 2  Configuration Topology Aspects for Controllers, I/O and Interface Modules

3BDS011225-600 C 79

 

Following rules apply to symbol layout related I/O module components:

• Symbols are drawn with original size.

• For S800 I/O: 

– The symbols include also the MTU (Mounting Terminal Unit) graphic 
part.

– Connections to previous/next module are defined through the plug/socket 
snap ports using <port>.Command = “PrevSibling” resp. “NextSibling”. 

Figure 42. Design Principles for I/O Module Symbols
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Topology Aspects for Client/Servers

The corresponding Topology aspect is added to related object types provided with 
Topology Designer. The aspects are inherited from object type for nodes like clients 
or servers.

Following rules apply to symbol layout related client/server Component view:

• The size of the symbol should be between 150 mm (for “light” components) 
and 300 mm (for “heavy” components), which corresponds to a downscale 
between 1:2 and 1:4.

• Insertion point to connector symbol is made through snap port of type plug.

Figure 43. Object Type for Server
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Topology Aspects for Connector Symbols

Connector symbols are used to:

• define within diagram skeletons the insertion points for Topology Components 
related to Aspect Objects within Control Structure.

• and pre-define connecting lines (representing net/bus topology) within diagram 
skeletons.

The corresponding Topology aspect is added to related object types provided with 
Topology Designer. 

Because those symbols are instantiated only within Topology Diagram (and not as 
Aspect Objects), it must be set to Explicit Object Type within Object Type 
Definition aspect 

Figure 44. Connector Symbol used within Plant Networks
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Bulk Data Manager Support
Bulk Data Manager is described in detail in System 800xA Engineering, 
Engineering Studio (3BDS011223*). This section addresses some functionality 
useful when copying topology diagrams or topology components, or when setting 
property values through Bulk Data Manager.

Topology Designer publishes its internal properties through the Topology aspect, 
the Topology Parameters aspect. Few of the internal properties are listed below:

• Internal properties like DiagramSaveTime, ComponentSaveTime, 
ObjectTypeSaveTime that are used internally to subscribe to changes and to 
update open diagrams.

• Diagram properties like DiagramIsBad and DiagramSize.

• Component name properties like ObjectName, ObjectDescription, 
ControlBuilderName, ControlBuilderDescription.

• Component properties like AspectObject and NumberOfInputs.

• Component positioning properties like Position.Page or Position.X.

• Port parameter properties like In1, In1.Direction, In1.DataType, In1.initVal, 
In1.Inversion, and In1.Visible.

• Variable properties like VariableDataType and VariableAttributes.

All copied and inherited diagram properties are published through the Topology 
aspect of the diagram. All copied and inherited component and port properties 
including connect strings are published through the Topology aspect of the 
component- even if the data is physically stored inside the Topology Parameters 
aspect, refer to Table 3.

Table 3. Properties get published through...  

Property ... gets published via

Copied diagram property • Diagram’s Topology aspect

• Diagram’s Topology Parameters aspect

Inherited diagram property • Diagram’s Topology aspect
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 The number and kind of published properties varies for each Topology aspect.

Preparation of bulk data sheets to modify or copy complete Topology diagrams can 
be a time consuming task. It is necessary to add Topology aspects from different 
components, and to filter out relevant properties which should be modified during 
copy, e.g. initial values for set points.

This is improved by the Publish via Parent Diagram setting in the Aspect 
Properties / Parameters dialog, see Figure 29. All component and port properties 
marked as “Publish as” are additionally published through the Topology aspect of 
the parent diagram. So user can quickly define the most important 
properties/parameter of a diagram (template), add just the diagram’s Topology 
aspect to a bulk data sheet, and copy them through Bulk Data Manager while setting 
individual properties/parameter.

Copied component/port 
property

• Component’s Topology aspect

• Component’s Topology Parameters aspect

Copied component/port 
property marked as “Publish 
as”

• Parent diagram’s Topology aspect

• Parent diagram’s Topology Parameters 
aspect

• Component’s Topology aspect

• Component’s Topology Parameters aspect

Inherited component/port 
property

• Component’s Topology aspect

Inherited component/port 
property marked as “Publish 
as”

• Parent Diagram’s Topology aspect

• Component’s Topology aspect

The IAfwBulkData (XML) interface is not supported by Topology Designer.

Table 3. Properties get published through...  (Continued)

Property ... gets published via
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Revision History

 

 The following table lists the revision history of this User Manual. 

Updates in Revision Index A
The user manual has been updated for 800xA 6.0 release, based on PRCs.

The revision index of this User Manual is not related to the 800xA 6.0 System 
Revision.

Revision 
Index

Description Date

A Updated for 800xA System Version 6.0 December 2014

B Updated for 800xA System Version 6.0.1 October 2015

C Updated for 800xA System Version 6.0.3 September 2016
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Updates in Revision Index B
The following table shows the updates made in this user manual for 800xA System 
Version 6.0.1. 

Updates in Revision Index C
The following table shows the updates made in this user manual for 800xA System 
Version 6.0.3. 

Updated Section/Sub-section Description of Update

Section 1, Prerequisites and Requirements Added the following information:
For more information on the installation prerequisites 
and requirements, refer to System 800xA Installation 
and Upgrade Getting Started (2PAA111708*).

About this User Manual, Released User 
Manuals and Release Notes

Changed the user manual name from:
System 800xA Released User Manuals and Release 
Notes (3BUA000263*)
To:
System 800xA Released User Documents 
(3BUA000263*)

Updated Section/Sub-section Description of Update

Section 1, Introduction, Prerequisites and 
Requirements

Changed the note from:
To get Topology Designer functions for AC 800M in 
your system, the system extensions Topology 
Designer and Topology Designer for AC 800M have 
to be loaded.
To:
To get the Topology Designer functions in your sys-
tem install the Topology Designer feature available as 
part of Engineering Workplace System Function.
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