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Introduction

Contents of this chapter
This chapter contains information on the compatibility, target audience and purpose
of this guide. It also refers to a list of related documents for more information.

Compatibility
This manual applies to Virtual drive version 1.5 or later. The virtual drive feature is
compatible with ACS380, ACS480 and ACS580 control programs. It also supports the
ACS880 drive application programs.

To access the virtual drive feature, you need:

• Drive Composer pro PC tool version 2.9.1 or later. You can download the latest
version from the download section of the ABB Drive Composer home page.

System requirements

￭ Hardware requirements

For...Cable type

connectingDriveComposer entry/pro through the
USB port of the control panel to a drive (maximum
3 meters)

USB type A (PC) type mini B (panel) cable

Note: ABB recommends to use ferrite core cables.

connecting through Ethernet adapter module or
embedded Ethernet

Ethernet cable RJ45

1
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￭ Computer hardware requirements

SpecificationHardware

IBM compatible PCComputer

Intel i5 level CPU with 2.3 GHz or higherProcessor

8GBMemory

One free USB port or Ethernet portCommunication port

￭ Software requirements

SpecificationSoftware

Windows 10, Windows 11 or laterOperating system

Microsoft .NET Framework 4.8.2 or higher
Visual C++ Redistributable Packages for Visual
Studio 2015.

Framework

Target audience
The reader is expected to be an automation or electrical engineering professional and
familiar with drive products and the concepts regarding their commissioning and
operation, including the parameter system of ABB drives.

Purpose of the guide
This guide describes how to install the virtual drives application and activate the
licenses. It also describes the virtual drive launcher and instructs how to use it in the
commissioning and maintenance of ABB drives.

Related documents

CodeManual

Drive firmware manuals and guides

3AXD50000029275ACS380 machinery control program firmware manual

3AXD50000047399ACS480 standard control program firmware manual

3AXD5000001609ACS580 standard control program firmware manual

3AUA0000085967ACS880 primary control program firmware manual

Tools manuals

3AUA0000094606Drive Composer Start-up and maintenance PC tool User’s manual

3AXD50000422128Virtual drives quick installation and start-up guide

Option manuals and guides

3AUA0000093568FENA-01/-11/-21 Ethernet adapter module user’s manual

3AFE68573271FPBA-01 PROFIBUS DP adapter module user's manual

3AXD50000158607FMBT-21 Modbus/TCP adapter module user's manual

3AXD50000158621FEIP-21 EtherNet/IP fieldbus adapter module user's manual

3AXD50000158614FPNO-21 PROFINET fieldbus adapter module user's manual

8 Introduction
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Terms and abbreviations

DescriptionTerm

Type of control unitBCU
Customer Identity and Access ManagementCIAM
Digital inputDI
Frequency converter for controlling AC motorsDrive
Electromagnetic compatibilityEMC
Electromagnetic interferenceEMI
Optional TTL incremental encoder interface moduleFEN-01
Optional absolute encoder interface moduleFEN-11
Optional resolver interface moduleFEN-21
Optional HTL incremental encoder interface moduleFEN-31
Optional Ethernet adapter moduleFENA
Optional Ethernet adapter module for EtherNet/IP™, Modbus TCP and
PROFINET IO protocols

FENA-01

Optional Ethernet adapter module for EtherNet/IP™, Modbus TCP® and
PROFINET IO® protocols

FENA-11

Optional Ethernet adapter module for EtherNet/IP™, Modbus TCP and
PROFINET IO protocols, 2-port

FENA-21

Optional analog I/O extension moduleFIO-11
Functionalmock-up interface. An open standard that defines a container and
an interface for exchangingdynamicmodels using a combinationof XML files,
binaries, and C-code zipped into a single file.

FMI

Functional mock-up unit. A file containing simulation model that adheres to
FMI standard.

FMU

Optional thermistor protection moduleFPTC-01
Optional ATEX-certified thermistorprotectionmodule forpotentially explosive
atmospheres

FPTC-02

Physical size of the drive or power moduleFrame, frame size
Optional functional safety modulesFSO-12, FSO-21
Insulated gate bipolar transistorIGBT
Invertermodule(s) under control of one control unit, and related components.
One inverter unit typically controls one motor.

Inverter unit

Common term for drive module, inverter module, supply module, brake
chopper module etc.

Power module

Radio-frequency interferenceRFI
Safe torque off (IEC/EN 61800-5-2)STO
Supply module(s) under control of one control unit, and related components.Supply unit

Cybersecurity disclaimer
This product is designed to be connected to and to communicate information and
data via a network interface. It is Customer's sole responsibility to provide and
continuously ensure a secure connectionbetween theproduct andCustomernetwork
or any other network (as the casemay be). Customer shall establish andmaintain any
appropriate measures (such as but not limited to the installation of firewalls,
application of authentication measures, encryption of data, installation of anti-virus
programs, etc) to protect the product, the network, its system and the interface
against any kind of security breaches, unauthorized access, interference, intrusion,
leakage and/or theft of data or information. ABB and its affiliates are not liable for
damages and/or losses related to such security breaches, any unauthorized access,
interference, intrusion, leakage and/or theft of data or information.

Introduction 9
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Installing Virtual Drives

Contents of this chapter
This chapter describe how to install the ABB Virtual Drives application.

Downloading offline/virtual drives installer
The latest version of the Virtual Drives package can be downloaded from the How to
Get Started section on the ABB Ability™ Virtual Commissioning for drives homepage.

To download the Virtual Drives installer, do the below steps:

1. Install the latest version of Drive Composer pro.

2. Get a free promotional license for ABB Ability™ Virtual Commissioning for Drives.
For support, contact your local ABB representative.

3. Downloadand install Offline or Virtual Drives packages, see sectionOffline/Virtual
drive package loader (page 43).

You can also download the latest installation files from ABB library - ABB virtual drive
installer, or contact your local ABB representative.

2
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Installation procedure
Launch the virtual drive installation executable file. The Installation manager wizard
appears. Follow the instructions in the wizard to complete the installation.

￭ Online installation
Online installation of ABB Virtual Drives requires internet access as installation data
is downloaded during setup.

1. In the Virtual Drives start page, click Install ABB Virtual Drives.

2. In the License page, read and agreee the license agreement. Click Next.

3. In the Selection page, select Virtual Drives and click Download and Install.

12 Installing Virtual Drives



Data download and installation starts.

4. In the Finish page, click Finish to close the installation manager wizard.

After successful installation, get the license with ABB Drives License Manager. See
chapter Activating virtual drive license (page 15). After activating the license, start
Drive Composer pro and navigate to Tools menu to start the Virtual drive launcher.
See chapter Offline/Virtual Drive Launcher in Drive Composer pro (page 23).

Installing Virtual Drives 13



￭ Offline installation
Anoffline installation of ABBVirtual Drives is necessary if youwant to install the virtual
drive on a remote computer without internet access. Offline installation allows to
download installation data with a computer that provides internet access (e.g. to a
shared folder, USB stick etc.). Later, this data can be used for installing virtual drives
on the desired system.

To install ABB virtual drives offline, do the below steps:

1. In the start page, click Prepare Offline Installation ABB Virtual Drives.

2. Click Download. Data download starts.

3. Wait until download is completed, then specify a directory to download the data
(e.g. shared folder or USB stick).
Data is downloaded to the specified folder.

4. Click Finish to close the installation manager wizard.

Execute offline installation

1. On the remote computer, open the previously defined directory and execute
start_menu.exe.
Installation manager wizard starts and guides you through the installation.

2. Click Install ABB Virtual Drives Offline.

3. Click Install to start the installation.

4. Click Finish to end the wizard.

After successful installation, get the license with ABB Drives License Manager. See
chapter Activating virtual drive license (page 15). After activating the license, start
Drive Composer pro and navigate to Tools menu to start the Virtual drive launcher.
See chapter Offline/Virtual Drive Launcher in Drive Composer pro (page 23).
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Activating virtual drive license

Contents of this chapter
This chapter contains information on activating the virtual drive license.

Licensing
A valid license is required to activate the virtual drive. To activate the license on virtual
drive, use ABB Drives License Manager. You can activate the license using online and
offline modes.

Note: For an active license, contact ABB sales team. If you do not have ABB drives
license manager, contact your ABB local representative.

3
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Activating license
To activate license, do the below steps:

1. Start ABB Drives License Manager.

2. Select product to activate (eg. Virtual Drives).

3. Select the option, I have an activation key, and enter the key. Click Next.

4. Select the option, PC locked: single PC license and click Next.

16 Activating virtual drive license



5. Choose an activation mode and click Next.

• Online activation: Select this option if the PC is connected to the Internet,
and the same PC is used to activate the license.

• Offline activation: Select this if youwant to activate the license in a different
PC and the PC is not connected to Internet., and the PC cannot be connected
to Internet. With this selection, you can download an activation response file
for an offline PC.

For information on online activation, see section Online activation (page 18).
For information on offline activation, see section Offline activation (page 19).

Note: If license activation fails, check the Internet connection (firewall or proxy) is not
blocking ABB Drives Licenses manager.exe or Codemeter.exe to get access to ABB
external license server. You canusepublic Internet connection (mobile phonehotspot)
to access license server.

Activating virtual drive license 17



Online activation
The activation data can be sent to ABB License server if the PC is connected to the
Internet.

For online activation, do the below steps:

1. Enable Online activation and click Next.

Activation procedure starts.

The activation is successful message appears.

2. Click Ok to end the wizard.
The product license is activated.

18 Activating virtual drive license



Offline activation
The activation data cannot be sent to the licensing server if the PC does not have
Internet access. In this case, the offline activation file is created. This file can be used
to transfer activationdata to the licensing server fromanother PCwith Internet access.

Pre-requisite: Get the product activation key from the ABB sales team.

1. From your browser of the PC that has an Internet connection, navigate to Drive
Tools - Offline Activation.
a. In the Upload activation request window, select the activation file from your

computer and click Upload request and continue.

b. In the Download activation request window, click Download activation
response to download the response file.

c. Store the file to a shareable location. For example, a USB drive or a shared
folder.

2. Run ABB Drives License Manager from the start menu.

3. Enable Offline activation and click Next.

Activating virtual drive license 19
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4. Enter the license request file name, click Save and save it in the file system that
is accessible from the PC that has an Internet connection.

5. Return to the offline PC and start ABB Drives License Manager.

6. Click Browse and select the activation response file from the shared location and
click Next.
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ABB Drives License Manager is activated successfully.

7. Click Finish to get the activation response receipt file.

8. Enter a file name and store the activation receipt file to a shareable location.

9. In the PCwith Internet availability, navigate to Drive Tools - Offline Activation and
upload the activation receipt file from the shareable location.
Offline license activation is successfully completed.

Activating virtual drive license 21
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Offline/Virtual Drive Launcher inDrive
Composer pro

Contents of this chapter
This chapter describes the main features of Offline/Virtual Drive Launcher in Drive
Composer pro.

4
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Overview
ABB Virtual Drives are digital representations of the variable speed drives including
the motor. This software is used for configuring, validating and simulating the ABB
virtual drives.Offline drives are thedigital representationof variable speeddrives and
do not require a motor model. They are used for configuring, validating, and backing
up/restoring parameters.

ABBoffersOffline/Virtual drive launcher as aplugin forDriveComposer pro, a start-up
and maintenance tool for ABB drives. The tool enables the user to set up, start, and
connect to Offline/Virtual drives, set parameters, input signals and check if the
expected response is available to run initial tests.

You can start Offline/Virtual drive launcher by navigating to Tools → Virtual drive
launcher. The figure below shows the main user interface of virtual drive launcher.

The below figure shows the main user interface for launching and configuring virtual
or offline drives.
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The working area can be used either with a tab or a floating window. You can select
View → Tabs to use the tabs in the working area or View → Floating windows to use
a floating window in the working area.

• Drive size - Displays Drive size online version for selecting an optimal motor and
drive.

• Version - Displays virtual drives version and available targets.

• Refresh - Rescans all connected Offline/Virtual drives and real drives (All drives
menupane in theDriveComposer (pro). You can also refreshusing themainmenu
View→ Refresh (Ctrl+R).

• Disable all - Disables all the virtual drives.

• Enable all - Enables all the virtual drives.

• Delete drives - Provides option to select which drives to be deleted and then by
clicking Confirm button deletes the drives.

• Add new Virtual drive - Enables to add new Offline/Virtual drive.

Offline/Virtual Drive Launcher in Drive Composer pro 25



Adding new Offline/Virtual drive
To add a new Offline/Virtual drive, do the below steps:

1. Go to Tools→ Virtual drive launcher or press Ctrl +L.

The Offline/Virtual Drive Launcher window opens.

2. Click Add new drive.

3. Enter the desired drive name in the Given name field.

4. Enter virtual drive ID, otherwise it is generated automatically. For example, ID #1,
ID #2 etc.

5. Configure virtual drives using the tabs. For further information on tabs, see Drive
configuration.

6. Click Create new drive.

The new offline or virtual drive is created.

Similarly, you can create multiple virtual drives as needed by repeating steps 1 to 6.
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Drive configuration
Drive configuration functionality depends on the drive family and firmware selected.

￭ Basic settings
In the Offline/Virtual Drive Launcher window, from the Basic settings tab, you can
create a new offline/virtual drive. You can select the required Drive series, Control
program type and Loading package versions from the available list.

All selections are mandatory.

1. Drive series: Shows the list of available drive series.

2. Control program type: Shows the list of control program types available for the
selected drive series.

3. Loading package version: Shows the list of firmware or loading package versions
available for the selected drive series and control program type.

￭ Construction & rating
The Construction & rating tab consists of Drive type, Construction, Voltage and Size
(in amperes) selections. You can select the desired selection from the drop-down list
to create a new virtual drive. All the selections are mandatory.

1. Drive type: Shows the list of available drive types.

2. Construction: Shows the list of drive construction options applicable for the
selected drive type.

3. Voltage/IP Class: Shows the list of available supply voltage range/IP class.

4. Size (in amperes): Shows the list of drive sizes (in amperes).

5. Ratings: shows the filtered ratings of a voltage sub class of different drive sizes.
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Construction/rating: offline drive

Construction rating: virtual drive
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￭ Load
The Load tab consists of Load model, Inertia and External load model options. The
data is used to configure parameters of simulated load for virtual drive. All the
selections are optional.

• Loadmodel: Selects the loadmodels, such as Inertial load, Hoist load, and Flexible
shaft load. For more information, see section Functional mock-up units (FMU
models) (page 31).

• Inertia: Enter the load inertia in kgm2. If there is a gear between the load and the
motor, then the load inertia must be reduced on the motor side.

Note:
The value is applicable only for Inertia load model.

• External load model: Enables/disables external load model. The External load
model is used to estimate speed value, using e.g. Robot studio. The estimated
value is fed back to the virtual drive. The interface block can be used in Robot
studio.
If you select External load model, then the application ignores the selected load
model and considers only variables provided through external sources.

Load models are currently applicable to ACS880 virtual drives , (add the load section
text from offline drive that load models are not applicable to offline drives)

Note: The load tab is not applicable for offline drives.
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￭ Motor
TheMotor tab consists of Motor electrical data andMotor mechanical data. The data
is used to configure parameters for virtual drive.

• Motor electrical data: Input theNominal torque,Maximumtonominal torque ratio,
Nominal cosphii and Efficiency.

• Motor mechanical data: Input the Inertia, Mechanical friction and Windage.

Note:Motor tab is not applicable to offline drives.
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￭ Functional mock-up units (FMUmodels)
The loadmodels available in the Loadmodeldrop-downare FunctionalMock-upUnits
(FMUmodels). As per the FunctionalMock-up Interface (FMI) standards, three variable
types are available in FMUmodels. The three variable types are Input, Output and
Parameter variables.

For example, the Inertial load FMUmodel consists of following variables:

• two input variables: MotorTorqueSI and AdditionalLoad

• one output variable: MotorSpeedSI, and

• zero parameters

In a FMU load model, the motor torque (input) and motor speed (output) variables
are mandatory and other extra inputs and output variables are optional.

Note:Bydefault, virtual drive consists of threepre-packagedFMUmodelswith correct
FMU variables mapped to the matching virtual drive variables.

For example,

• In Inertial load model, the virtual drive variable MotorTorqueSI is mapped to the
FMUmodel variable MotorTorqueSI. The name is kept same for Inertial load to
ensure backward compatibility with the previous virtual drive versions.

• For Hoist load, the virtual drive variable MotorTorqueSI is mapped to the FMU
model variable MotorTorqueNm. Note that the name in FMUmodel is different
thanwhat virtual drive expects. Sowhilemapping, we define virtual drivewith the
required variable (MotorTorqueNm).

Note: In the pre-packaged model all mappings are configured and cannot be edited.
If necessary, you can create custommodels and configure the variables. For more
information, see section Custom load model (page 34).

Inertial load

This is the default load model. The required variables are pre-defined and cannot be
edited.
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Hoist load

The required variables for hoist operation is configured. If required, parameters values
can be changed. You need to restart the virtual drive after changing the parameters.

Note: You cannot change the parameters of a running virtual drive.

Flexible shaft load

The required variables for flexible shaftmachines are defined. If required, parameters
values can be changed. You need to restart the virtual drive after changing the
parameters.

Note: You cannot change the parameters of a running virtual drive.
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Supported FMI standards

Virtual drive implements the FMI (Functional Mock-Up Interface) 2.0 co-simulation
standard. virtual drive only accepts:

• FMUmodels that are compatible with Windows (.dll), and

• has x86 architecture (must be 32-bit .dll files).
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￭ Custom load model

WARNING!Use this feature only if you have knowledge on FMUmodels and its
configuration.

The custom load model allows you to manually configure the FMU variables with the
virtual drive variable.

Note: Virtual Drive implements the FMI 2.0 co-simulation standard and accepts FMU
models that are compatible with Windows (.dll) and have x86 architecture (must be
32-bit .dll files).

To create a custom FMUmodel

1. Navigate to the icon tray. Right-click on the virtual drive icon → Install and select
Load FMUmodel.

2. Browse the FMUmodel (.FMU) on your computer and clickOpen. For information
on supported models, see section Supported FMI standards (page 33).

If the import is successful, a success message appears. Else, an error message is
displayed.

3. Restart Drive Composer pro and Virtual drive manager, or create a new virtual
drive.

The new FMUmodel appears in the Load model drop-down.

4. Select the uploaded custom FMU load model from the Load model drop-down
and in the Variables section, map the FMU variables to the virtual drive variables.
The available variables are listed in the table below:
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DescriptionNameType

Motor torque in Nm.MotorTorqueSIInput (double)

Note: This variable is mandat-
ory

Motor speed in RPM.MotorSpeedSIOutput (double)

Note: This variable is mandat-
ory

Additional load controlled by
the IO Console variable Load
torque. Theunit dependson the
FMUmodel, as the value of the
IO console Load torque is
passed directly to the FMU.

For hoist load, the unit is kg. For
Interial load and Flexible Shaft
load, the unit is Nm.

AdditionalLoadInput (double)

Boolean or Double (1.0 / 0.0)
representingwhether thebrake
is open or not.

MotorBrakeOpenInput (boolean or double)

Motor inertia in kgm2.MotorInertiaInput (double)

Encoder 1 position.Enc1PositionRadOutput (double)

Encoder 2 position.Enc2PositionRadOutput (double)

5. If required, define the parameters. Parameters are input variables which are set
at the beginning of simulation and need not be changed. You can enter any
constant value. The values are used by the FMUmodels when the virtual drive
starts.

Note: Virtual drive tool supports up to 100 FMU parameters. The drive can also
support up to 150 parameters based on the performance of the computer used.
If you usemore than 200 parameters, the tool crashes or becomes unresponsive.
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￭ Deleting custom FMUmodel

Note: ABB recommends this procedure only for advanced users.

To completely remove the information of a FMUmodel,

1. Delete the FMUmodel from the
%LOCALAPPDATA%\ABB\VDrive\Workspace\CustomLoad location.

2. Restart VirtualDriveManager and Drive Composer pro.

Note: If the deleted FMUmodel was used in any virtual drive, then you need to
configure the load model again to a valid option to start the instance.

￭ Options
The Options tab defines Slot configuration selections on the control board You can
select the desired selection from the drop-down list. All the selections are optional.

• Slot configuration: Shows the list of available optional modules. For example,
FPNO-21, FMBT-31, FEIP-21, FPBA-01 and None.

Note: Check the actual placement of the FPNO-21, FMBT-21, FEIP-21, and FPBA-01
optionmodules corresponding to the real drive and offline or virtual drives. Especially
if the parameter backup is made with an offline or virtual drive, it will be restored to
the real drive.
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￭ Settings
The Settings tab consists of System log level selections.

• System log level: Shows the list of System log level options. For example, Off,
Error, Warning or Info.

The Settings tab consists of Offline/Virtual drive log level selections.

• Drive log level: the drive log level is applicable to a drive instance and the setting
allows user to capture detailed textual logs of the drive software. For example,
Off, Error, Warning or Info.

Refresh
The Refresh option initiates the discovery procedure for all the offline or virtual drives
and connected real drives. When you create or delete virtual drives, click Refresh to
refresh the list of all the virtual drives in the drive navigation window.

In addition, if you modify virtual drive configurations (load, motor, options, settings,
etc.) of an already connected drive, after pressing Apply and restart, you also need
to press the Refresh button to establish a new connection from Drive Composer pro
to your instance.
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Note: Clicking the refresh button will refresh all drives.

Duplicate drive
Duplicatedriveoptionallowsyou to create anewvirtual drivewith similar configuration
to an already created instance. To duplicate a drive, make sure the drive is disabled.

1. Select the virtual drive instance to duplicate.

2. Click on Duplicate drive.

3. Specify Drive name and Drive ID.
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4. Click on Copy.

Enabling/disabling Offline/Virtual drives
You can enable or disable all created virtual drives by clicking on Enable All orDisable
All button.

You can also enable or disable virtual drives individually using Enable / Disable the
drive switch from the configuration area after selecting the drive from virtual drive
instance list.
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Deleting the Offline/Virtual drives
To delete virtual drives:

1. Click Delete drives.

2. Select the check boxes for all the virtual drives to be deleted.

3. Click Confirm.

40 Offline/Virtual Drive Launcher in Drive Composer pro



Closing Drive Composer pro
When you try to close Drive Composer pro while offline or virtual drives are enabled,
the tool displays a warning message.

• Click Yes to disable virtual drives and close Drive Composer pro.

• ClickNo to closeDriveComposerproand to resumeoperationof the virtual drives
after restarting Drive Composer pro.

• Offline drive disables by default.
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IO console
The IO console in virtual drives shows the input and output signal terminals of the
drive, representing the state of a simulated control board.

To launch IO console, right-click on virtual drive and select IO console. The IO console
screen appears.

You can view IO console screen in a separate window by clicking onOpen as separate
window.

Using IO console, you can:

• force analog and digital inputs.

• view the status of relays, digital and analog outputs.

• define the value of actual load torque in Nm.

The IO console is not supported in case of offline drives.
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Offline/Virtual drive package loader
You can download and install drive packages fromABB cloud using theOffline/Virtual
drive package loader feature. To install the drive packages, do the below steps:

1. Go to Tools→ Offline/Virtual drive package loader.

2. In the Offline/Virtual drive package loader window click Log In.

3. In the Customer Identity Access Management (CIAM) login window, enter your
ABB email address and click Login.
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On successful login the Offline/Virtual drive package loader window appears.

4. To load available packages, click New Packages→ Refresh.
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5. The available packages are loaded from the cloud. Select the required packages
and click Install to begin the installation.

The packages are downloaded from the cloud and installed. If installation is
successful, the Virtual Drive Packages Installed Successfully! message appears.
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6. To view all installed packages, click Installed Packages.

A list of all installed packages appears with details of installation status, release
date, package name, code and version. The status appears green if the installed
package is active.
You can click x to close the window.
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Further information
—

Product and service inquiries
Address any inquiries about the product to your local ABB representative, quoting the type
designation and serial number of the unit in question. A listingof ABBsales, support and service
contacts can be found by navigating to www.abb.com/contact-centers.

Product training
For information on ABB product training, navigate to new.abb.com/service/training.

Providing feedback on ABB manuals
Your comments on our manuals are welcome. Navigate to forms.abb.com/form-26567.

Document library on the Internet
You can find manuals and other product documents in PDF format on the Internet at
www.abb.com/drives/documents.
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