NOTICE

The information in this document is subject to change without notice and should not be construed as a commitment by ABB Inc. ABB Inc. assumes no responsibility for any errors that may appear in this document.

In no event shall ABB Inc. be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB Inc. be liable for incidental or consequential damages arising from use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB Inc., and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license.

This product meets the requirements specified in EMC Directive 89/336/EEC and in Low Voltage Directive 72/23/EEC.

Copyright © 2004 ABB Inc.
All rights reserved.

Release: October 2004
Document number: 3BUF001132D1

TRADEMARKS

Registrations and trademarks used in this document include:

Windows Registered trademark of Microsoft Corporation.
Enterprise Historian Trademark of ABB Inc.
# TABLE OF CONTENTS

## Section 1 - Introduction
- Product Overview ..............................................................................................................5
- Prerequisites and Requirements ........................................................................................5

## Section 2 - Functionality
- Fixed Problems .................................................................................................................6

## Section 3 - Installation
- Introduction .......................................................................................................................8
- Updating the Enterprise Historian Version 2.2/1 Platform ...............................................8
  - Backing Up Your System ..........................................................................................8
  - Adding /cdrom with sam ......................................................................................9
  - Preparing the CD-ROM for Installation .................................................................10
  - Instructions for Station(s) to be Updated ..............................................................10
  - Post Installation .....................................................................................................13
    - Log File Update .................................................................................................13
- Updating the Operator Station 1.9/1 Platform .................................................................14
  - Backup ..................................................................................................................14
  - Adding /SD_CDROM with sam ............................................................................14
  - Preparing the CD-ROM or DVD-ROM for Installation ........................................15
  - Instructions for Station(s) to be Updated ..............................................................15
  - Finishing Instructions .........................................................................................18
    - Optional User Log ............................................................................................19
Section 1 Introduction

Product Overview

These release notes describe patch 8 for Enterprise Historian History Services version 2.4/1 for the HP-UX platform.

This patch can be applied to systems with:

- Enterprise Historian version 2.2/1
- MOD 300 OS1.9/1Pm where m = any patch.

The patch can be applied to History version 2.4/1. Patches 1 through 7 were included in the 2.4/1 base release.

The problems fixed by this patch are described in Section 2, Functionality. Instructions for installing this patch are provided in Section 3, Installation.

Prerequisites and Requirements

The History Services software on the Enterprise Historian or Operator Station platform must be at Version 2.4/1 to install this patch.
## Fixed Problems

Table 1 describes the problems that are fixed by patch 8.

<table>
<thead>
<tr>
<th>ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3184</td>
<td>Batch 300/TCL duplicate message problem. After a duplication PDL could not match the end times with the correct start times and the last entry did not have an end time. Added a queue of the last x messages that come into the hsModInterface process. The HS_PDL_DUPCHECK_ON environment variable enables this feature. This variable must be set to a number from 1 to 999, which will be used to determine the size of the queue which typically should need to be no more than about 10 to 20. Once this variable is set the next time history restarts, the hsModInterface process will begin checking for duplicate messages. As the root user, edit the file <code>ocsEnvironment</code> located in: /home/ocsmgr/etc and add the following line in the same location as the other variables (using 20 for example): <code>export HS_PDL_DUPCHECK_ON=20</code></td>
</tr>
<tr>
<td>3104</td>
<td>The hsArchive crashed when archiving PDL data. A problem was found with an oracle query that was overwriting the stack. This was caused when PDL archive had 1 byte of memory on the stack that could be set to zero. The location was random and could be anything from an address to a variable on the stack. Now, a corrected macro is called to look at the indicator variable to see if the value is null, and with null terminating the string properly.</td>
</tr>
<tr>
<td>3098</td>
<td>Modify Node List on Composite Log Display did not show connect nodes. You can now configure distributed logs for an EH Connect Node using the History Builder on the Consolidate Node and the Connect Node will be represented in Modify Node list in the Composite Log window.</td>
</tr>
</tbody>
</table>
Table 1. Problems Fixed by History 2.4/1 Patch 8

<table>
<thead>
<tr>
<th>ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3086</td>
<td>The message dialog in DataDirect could not retrieve diagnostic messages and a query returned no data. The msgtype_id table in Oracle was lacking message type #7 which represents diagnostic messages. It is now added.</td>
</tr>
<tr>
<td>3084</td>
<td>hsCollection spun with 100% CPU after an upgrade. At an earlier stage in hsCollection, bMoreData was set before the request for TTD data was made. If the TTD was configured improperly, it was possible for the response to return with zero value and never catch up. However, collection kept trying to catch up by sending requests over. To correct the problem, if no values are returned and the bMoreData bit is set, the bit is cleared and an error message is logged. The clearing of the bit will prevent the 100% CPU usage. Examine the $HS_LOG/hsCollection0.log for errors. Logs configured incorrectly should be deleted or deactivated.</td>
</tr>
<tr>
<td>3083</td>
<td>When hsDBMaint was used to correct a corrupt HSFF file, all state files (hscSnapshot and hssSTorage) were deleted and the report_entry table was truncated. The behavior has been changed to only truncate the report entry table and delete the state files when all_logs are specified.</td>
</tr>
<tr>
<td>3070</td>
<td>hsPDLMaint and hsDBMaint did not work properly when checking the restored PDL tables.</td>
</tr>
<tr>
<td>3031</td>
<td>Having &quot;_IP&quot; characters show up in the name of a PPA object (O3_IPT_LPT_LK_W), to which a message log is attached, no longer interprets these characters as the IP address of the History node when saving composite log name in Oracle.</td>
</tr>
</tbody>
</table>
Section 3 Installation

Introduction

Please review all the instructions, and your ABB Support terms and conditions, for precautions, scope of license, restrictions, and limitation of liability and warranties, before installing this software.

In case of difficulties, please contact the Technical Support Group via SUPPORTLINE:
in the U.S. - (1-800-HELP-365);
International - (1-614-224-5888).

This patch can be applied to systems with Enterprise Historian version 2.2/1, or MOD 300 OS1.9/1Pm. The History Services software on the Enterprise Historian or Operator Station platform must be at Version 2.4/1 to install this patch. Refer to the applicable update procedure based on the platform where you are installing the patch:

Updating the Enterprise Historian Version 2.2/1 Platform

Backing Up Your System

It is strongly recommended that you perform a full backup of your system and application data before installing any new software. For information on backing up your station, please refer to the Enterprise Historian for HP-UX Version 2.2/1 Administrator's Guide.
The following procedures must be performed when you are installing the patch from CD-ROM:

- Adding /cdrom with sam on page 9
- Preparing the CD-ROM for Installation on page 10

These procedures prepare the CD-ROM reader to load the patch to the local station.

If you received the software depot by some other means, disregard these two procedures and go directly to Instructions for Station(s) to be Updated on page 10.

### Adding /cdrom with sam

If you are installing from CD-ROM, the /cdrom directory must exist before adding this patch to the system. Check to see if the /cdrom directory exists by entering `ls /` and looking for the /cdrom directory name. If it does not already exist, follow the instructions below for adding the /cdrom directory with sam. If it does exist, skip these instructions and continue on to Preparing the CD-ROM for Installation below.

To add the /cdrom directory:

1. In an HP terminal window, log on as the root user by entering: `su root`
2. Enter `sam`
3. Within SAM Areas window, select Disks and File Systems
4. Within SAM Areas: Disks and File Systems window, select Disk Devices
5. Within Disk Devices window, select CD from SCSI list of devices
6. Under Actions, Select ‘Add’ -> Not Using the Logical Volume Manager
7. Within ‘Add CD_ROM Disk’ window, enter /cdrom as Mount Directory:
8. In ‘When to mount’ area, deselect ‘Now’. Leave ‘At every system boot’ selected.
9. Click OK.
10. File -> Exit
11. File -> Exit SAM.
Preparing the CD-ROM for Installation

If you are installing from CD-ROM, the /cdrom filesystem must be mounted before adding this patch to the system. To see if it is mounted, enter `bdf` at the UNIX prompt, and look for information about the /cdrom filesystem in the command output. If the filesystem is not mounted, follow the instructions below to mount it. If it is mounted, skip this section and proceed to Instructions for Station(s) to be Updated below.

1. In an HP terminal window, log on as the root user
2. Insert the Patch ABB-PHSU_241008 CD-ROM into the CD-ROM drive
3. Enter `mount /cdrom`

If the mount fails with the following message:

```
mount: /cdrom was either ignored or not found at /etc/fstab,
```

follow the instructions in Adding /cdrom with sam on page 9.

4. Enter: `swreg -l depot /cdrom`

   This command only needs to be entered one time before loading the first station.

Instructions for Station(s) to be Updated

Before installing, you will need to stop all software on the Station (including Enterprise Historian software):

1. Open a terminal window and log in as the root user.
   Enter `su root` (super user).
2. Enter `/opt/advant/Startup/bin/IMSstop -v`

   If the Station with Enterprise Historian software is shut down in an uncontrolled way, the relational database may crash and the data may become corrupt. If the station has to be rebooted, use the HP-UX shutdown command. This command executes the IMSstop script.

3. If you are loading from a “.depot” file, go to Step 4.
### Section 3 Installation

**Instructions for Station(s) to be Updated**

If you are loading from CD-ROM, insert the Patch ABB-PHSU_241008 CD-ROM into the CD-ROM drive, then

a. Load the patch by entering:

```
/usr/sbin/swinstall -s <hostname>:/cdrom
```

<hostname> is hostname or IP address of Advant Station with CD-ROM drive attached.

b. Go to Step 6.

4. Put the file you have received (ABB-PHSU_241008.depot) on the Enterprise Historian, for example under the /tmp directory.

5. Enter:

```
/usr/sbin/swinstall -s /tmp/ABB-PHSU_241008.depot
```

This brings up the “SD Install - Software Selection (station)” window.

If you get an error dialog indicating that “The current session cannot be saved....Make sure that the HOME Environment variable is set”, click OK to continue. This error may occur at this point, or later in the process.

6. Under the **Actions** menu select **Match what Target Has**.

   This will select the proper licensed options on your system to update (including History, and/or PDL and/or SPC).

   Ignore errors regarding fileset dependencies. Exit the dialog to continue the installation.

7. Under the **Actions** menu select **Install (Analysis)**.

8. After analysis is complete, select the **Logfile** button to bring up the swagent.log file.

   Search for the correct date and time heading. Check for any messages that begin with ERROR or WARNING. When satisfied, select **OK** to exit the log file.

9. Select **OK**, then **Yes** to begin the installation.
10. When the installation has completed, again select the **Logfile** button to bring up the swagent.log file in the window. Search for the correct date and time heading. Check for any messages that begin with **ERROR** or **WARNING**. When satisfied, select **OK** to exit the log file.

Select **DONE** to finish the installation.

11. Under the **File** menu select **Exit** to end the swinstall process.

12. If you are loading from CD-ROM, remove the CD from the drive.

13. Execute the **swlist** command in an HP terminal window to view the History version. Verify the version is 02.04.01.08, **Figure 1**.

14. As root user restart IMS processes. Enter:

   `/opt/advant/Startup/bin/IMSstart`

15. Perform the post installation procedures as described in **Post Installation** on page 13.

---

**Figure 1. Verifying the History Version**
Post Installation

Log File Update

Whenever a patch is installed on a system, you should edit the Text File `user_update.log` found in the `/var/adm/sw` directory. At the end of the file, add “History Version 2.4/1 Patch 8 Installed”, the date, and description if desired. Any other changes made to the product, such as custom memory pool changes may also be added.

The file should be created if it does not exist. You may make the file name more application specific, such as `user_update_EH2.2-1.log`, and rename the file at each software update step along the way.

The purpose of the text file is to prevent the deletion of certain user critical changes during a reloading or updating of a machine.
Updating the Operator Station 1.9/1 Platform

Backup

You should backup your Operator Station before upgrading. If necessary, you can use this backup to restore your data. For information on backing up and restoring your OS, please refer to the Advant® Station 500 Series with AdvaCommand 1.9/1 AdvaBuild 2.9/2 User’s Guide.

The following procedures must be performed when you are installing the patch from CD-ROM:

- Adding /SD_CDROM with sam on page 14
- Preparing the CD-ROM or DVD-ROM for Installation on page 15

These procedures prepare the CD-ROM reader to load the patch to the local station.

If you received the software depot by some other means, disregard these two procedures and go directly to Instructions for Station(s) to be Updated on page 10.

Adding /SD_CDROM with sam

These instructions must be performed to prepare the CD-ROM or DVD-ROM reader to load the software to the local station or remote stations. These instructions need only be performed one time before loading one or more stations.

The /SD_CDROM directory must exist before adding this update CD-ROM to the system.

Check to see if the /SD_CDROM directory exists by entering `ls /` and looking for it. If it does not already exist, follow the instructions below for adding the /SD_CDROM directory with sam. If it does exist, skip these instructions and continue on to Section , Installation.

These instructions must be performed to add the /SD_CDROM directory.

1. In an HP terminal window, log on as the `root` user.
2. Enter `sam`
3. Within SAM Areas window, select Disks and File Systems
4. Within SAM Areas: Disks and File Systems window, select Disk Devices
5. Within Disk Devices window, select CD from SCSI list of devices
6. Under menu item Actions, Select ‘Add’ -> Not Using the Logical Volume Manager
7. Within ‘Add CD_ROM Disk’ window, enter /SD_CDROM as Mount Directory:
8. In ‘When to mount’ area, deselect ‘Now’. Leave ‘At every system boot’ selected.
9. Click OK.
10. File -> Exit
11. File -> Exit SAM.

Preparing the CD-ROM or DVD-ROM for Installation

1. In an HP terminal window, log on as the root user
2. Insert the Patch ABB-PHSU_241008 CD-ROM into the drive
3. Enter `mount /SD_CDROM`
4. Enter: `/SD_CDROM/upgrade/register_depot`
   
   This command only needs to be entered one time before loading the first station. It registers the directories containing the software to be loaded.

Instructions for Station(s) to be Updated

These instructions must be performed on each station that is to have the update installed.

1. If the station you are updating is an X-terminal host, do step a through step d before you go to step 2. If the station you are updating is not an X-terminal host, go directly to step 2.
   a. You need to stop the AdvaCommand software at every X-terminal connected to the host. Therefore, at each X-terminal running AdvaCommand remotely from the host, press <Ctrl-D> and enter `stopsession` in the command field.
b. On the X-terminal host station press <Ctrl-D> and enter `quit` in the command field.

c. Suspend the AdvaCommand Auto Startup Interface by clicking on the `Suspend` button.

d. On the X-terminal host, open an HP terminal window.

2. In an hpterm window, Log on as `root` (super user).

3. Shutdown the Advant Station and X server by entering:

   `/sbin/init.d/advaCommand stop`

   This shuts down the Operator Station completely, and after a few seconds the X server will shut down.

   If a USB keyboard is directly connected to a PCI RTAB with USB port, a PS2 keyboard MUST be connected to proceed.

4. Once the X server is stopped you may have to press the `<Enter>` key to see the login prompt.

5. Log on as `root` (super user).

6. If you are loading from a “.depot” file, go to Step 7.

   If you are loading from CD-ROM, insert the Patch ABB-PHSU_241008 CD-ROM into the CD-ROM drive, then

   a. Load the patch by entering:

      `/usr/sbin/swinstall -s <hostname>:/SD_cdrom`

   `<hostname>` is hostname or IP address of Advant Station with CD-ROM drive attached.

   b. Go to Step 10.

7. Ensure that all volumes in `/etc/fstab` are mounted. To do this, compare the contents of the fstab file with the output of the bdf command. Comment out any volumes that are not mounted.
Section 3  Installation

Instructions for Station(s) to be Updated

8. Put the file you have received (ABB-PHSU_241008.depot) on the station where you are installing the patch, for example under the /tmp directory.

9. Enter:

    /usr/sbin/swinstall -s /tmp/ABB-PHSU_241008.depot

This brings up the “SD Install - Software Selection (station)” window.

If you get an error dialog indicating that “The current session cannot be saved.... Make sure that the HOME Environment variable is set”, click OK to continue. This error may occur that this point, or later in the process.

10. Under the Actions menu select Match what Target Has.

    This will select the proper licensed options on your system to update (including History, and/or PDL and/or SPC).

11. Under the Actions menu select Install (Analysis).

12. After analysis is complete, select the Logfile button to bring up the swagent.log file.

    Search for the correct date and time heading. Check for any messages that begin with ERROR or WARNING. When satisfied, select OK to exit the log file.

13. Select OK, then Yes to begin the installation.

14. When the installation has completed, again select the Logfile button to bring up the swagent.log file in the window.

    Search for the correct date and time heading. Check for messages that begin with ERROR or WARNING. When satisfied, select OK to exit the log file.

    Select DONE to finish the installation.

15. Under the File menu select Exit to end the swinstall process.

16. If you are loading from CD-ROM, remove the CD from the drive (see Finishing Instructions).
17. Enter the reboot command:

   reboot

18. At the Operator Station Startup Interface window, open HP terminal windows as required to complete Finishing Instructions on page 18. Exit all HP terminal windows when done.

19. Execute the `swlist` command in an HP terminal window to view the History version. Verify the version is 02.04.01.08, Figure 2.

![Figure 2. Verifying the History Version](image)

20. Follow the start-up procedures as described in Advant Station 500 Series with AdvaCommand 1.9/1 / AdvaBuild 2.9/2 User’s Guide.

**Finishing Instructions**

These instructions must be performed to remove the CD-ROM from the reader after loading the upgrade to the local station or remote stations.

1. In an HP terminal window, log on as the `root` user

2. Enter `umount /SD_CDROM`

3. Remove CD-ROM from the reader.

Whenever an upgrade is installed on a system, you should check for ERROR in the following text files. Further checks can be reviewed the `swinstall.log` and `swagent.log`. 
Optional User Log

At the end of the `user_update.log` file, add the upgrade names that you have installed, the date, and description if desired. Any other changes made to the product, such as custom memory pool changes may also be added.

The file should be created it if it does not exist. You may make the file name more application specific, such as `user_update_os1.9-1.log`, and rename the file at each software update step along the way.

The purpose of the text file is to prevent the deletion of certain user critical changes during a reloading or updating of a machine.