SOFTWARE MANUAL

Installation and licensing
Automation Builder
## Table of contents

1 Overview ................................................................................................................................. 4
   1.1 Installation and licensing workflows ............................................................................... 4
   1.2 License overview............................................................................................................... 5
      1.2.1 License model........................................................................................................... 5
      1.2.2 Activation keys and licenses..................................................................................... 6
      1.2.3 Included features per edition................................................................................... 8
      1.2.4 Order codes for Automation Builder engineering suite......................................... 8
      1.2.5 Order code for Panel Builder 600 (PB610) standalone............................................. 8
      1.2.6 System libraries......................................................................................................... 8

2 Installation of Automation Builder .......................................................................................... 9
   2.1 Preconditions..................................................................................................................... 9
      2.1.1 System requirements................................................................................................. 9
      2.1.2 Creating project archives before installation......................................................... 9
      2.1.3 Check internet connection and firewall settings.................................................... 11
   2.2 Installing Automation Builder on an online PC.............................................................. 12
   2.3 Installing Automation Builder on an offline PC.............................................................. 12
   2.4 Installing additional tools and libraries........................................................................... 14
   2.5 Migration of third party devices....................................................................................... 16

3 Licensing .................................................................................................................................. 19
   3.1 Starting the licensing process.......................................................................................... 19
   3.2 Registration....................................................................................................................... 19
   3.3 Activating Automation Builder license............................................................................ 20
      3.3.1 Online activation....................................................................................................... 23
      3.3.2 Offline activation........................................................................................................ 23
   3.4 Activating additional tools and libraries.......................................................................... 25
      3.4.1 Activating the Panel Builder 600 and PC-runtime license....................................... 25
      3.4.2 Activating Solution library license............................................................................ 26
   3.5 Managing your licenses.................................................................................................... 26
      3.5.1 Identifying the installed license.................................................................................. 27
      3.5.2 Selecting the license used on Automation Builder startup..................................... 27
      3.5.3 Checking licenses with CodeMeter control center.................................................. 29
      3.5.4 Setting dedicated network servers in search list...................................................... 30
      3.5.5 Restarting license check with a dongle bound license.............................................. 32
      3.5.6 Removing trial license to remove expiring message.................................................. 33
      3.5.7 Network licenses....................................................................................................... 34
      3.5.8 License borrowing manager...................................................................................... 39
      3.5.9 Transferring an Automation Builder license............................................................ 41
      3.5.10 Generating license information file for support....................................................... 53

4 Frequently asked questions and Support ............................................................................... 55
   4.1 Frequently asked questions............................................................................................... 55
   4.2 Special settings for internet security software “F-Secure”............................................... 58
      4.2.1 Compatibility mode..................................................................................................... 58
      4.2.2 Adding CodeMeter to whitelist............................................................................... 58
   4.3 Support............................................................................................................................. 58
      4.3.1 Main information........................................................................................................ 58
      4.3.2 Installation log file...................................................................................................... 58
      4.3.3 License activation support information...................................................................... 59
4.3.4 Automation Builder log files
1 Overview

1.1 Installation and licensing workflows

The following overview describes how to get and activate an Automation Builder edition, library or add-on.

Download Automation Builder from www.abb.com/automationbuilder. The setup is a couple of Megabytes.

Start the setup on your PC, read the end user license agreement and select the options you want to install. According to your selection more software packages will be downloaded.

After successful installation start Automation Builder. You will be asked to enter your user data. For details on the data we are storing please refer to the privacy statement as part of the end user license agreement.
After registration you can activate different kinds of licenses, e.g. a free premium trial to get familiar with the powerful features of Automation Builder.

Contact your ABB sales contact to purchase a commercial license of Automation Builder, libraries and add-ons. You will receive a letter containing the activation code. Enter this code in Automation Builder to activate an Automation Builder license.

1.2 License overview

1.2.1 License model

From Automation Builder 1.1 onwards a freemium license model is used.

A basic license enables a free IEC 61131-3 programming of simple PLC systems.

The standard license includes integrated engineering for PLC, drives, panels, motion, and robotics.

The premium license includes engineering productivity and collaboration enhancements.

In Automation Builder 1.2 the licensing is extended in scope and license types. Selected libraries are now included to the general Automation Builder licensing mechanism. Project Version Control is available as an additional license to Automation Builder standard and premium edition.

In Automation Builder 2.0 the licensing model with three editions is kept. It was also simplified: Now premium edition has floating license enabled and standard has only non-floating.

Automation Builder 1.x licenses can be used for Automation Builder 1.x version profiles that are delivered within Automation Builder 2.x releases. Automation Builder 2.x licenses include licenses for Automation Builder 1.x version profiles. This means: when purchasing the latest license, all preceding versions are included:
ABB is committed to support our customers’ installed system base. Following a software product life cycle we want to maximize the useable life of our customers’ system investment and provide our customers with the confidence that there is a well-defined support for, and a path forward for existing ABB systems. ABB’s product life cycle policy provides advanced notification of planned changes in product availability and support.

You can find the lifecycle document for Automation Builder describing the current life cycle status for Automation Builder versions, service packs and licenses in the ABB Library.

To ensure a smooth transition from Automation Builder 1.x to Automation Builder 2.x licenses, we provide upgrade paths and an attractive campaign for switching to a premium edition.

<table>
<thead>
<tr>
<th>From Automation Builder 1.x</th>
<th>To Automation Builder 2.x</th>
<th>Upgrade License type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard</td>
<td>Standard</td>
<td>DM201-TOOL-UPGR</td>
</tr>
<tr>
<td>Premium</td>
<td>Premium</td>
<td>DM203-PREM-UPGR</td>
</tr>
</tbody>
</table>

## 1.2.2 Activation keys and licenses

There is difference between the activation key and a license.
Activating means getting a license from our systems and placing it into a license container. During activation a so-called license container will be created in the background. This container can be placed on a PC or on a DM-KEY (USB dongle) – depending on your selections during activation. The license type defines whether a license can be shared in a network or not. Single licenses reside in the license container it was assigned during activation. Network licenses are shared among different license containers – automatically and fully managed by Automation Builder.

You have to make the following decisions

1. During ordering you need to decide whether you want to have a single license or network license. This cannot be changed afterwards.
2. During activation and independent from the license type you need to decide whether the license container shall be PC bound or USB bound

Automation Builder supports all combinations

- Single license placed into a PC container: “Personal tool”, this is presently the most common variant. Both, the trial and basic licenses are single licenses bound to your PC.
- Single license placed into a USB container: „Dongle based“, this is also very common to share a license among a group of people or between different computers where Automation Builder shall be used. As the license is bound to a portable USB device it can be carried around.
- Network license placed into a PC container: „office only“, this variant is a good choice for system administrators wanting to centralize their license management. As the network license can float between different computers, you don’t have to bother with the license when your PC is broken down or a complete image is deployed in case of training setups.
- Network license placed into a USB container: „office and on-site“, this variant allows both, sharing a license when you are in the office as well as taking it with you to use Automation Builder outside the office, e.g. on-site during commissioning.

You can even have combinations of the above. Some licenses as “Single” and bound to a PC for your personal use only, others floating around placed on DM-KEYs so that you can share them and take them away.
For better transparency we recommend to have only one Automation Builder edition as network licenses. As the sharing is happening automatically and the licensing mechanism tends to be greedy it could happen that premium editions are blocked by “Standard users” first and are not available to those who really require premium features.

1.2.3 Included features per edition

An overview to features contained per edition can be found on the Automation Builder download page: Automation Builder download page

1.2.4 Order codes for Automation Builder engineering suite

To purchase a license please contact your local ABB sales representative.

An overview of the Order codes can be found in the main catalog "PLC Automation".

1.2.5 Order code for Panel Builder 600 (PB610) standalone

The Panel Builder 600 (PB610) license is included in a standard or premium license of the Automation Builder.

Starting with Automation Builder 1.1 it is possible to install Panel Builder 600 PB610 as a standalone version without installation of Automation Builder. The software package can be obtained from the “Additional tools” section in the Automation Builder setup.

For order information please see the main catalog "PLC Automation".

1.2.6 System libraries

System libraries are included in all editions.

Additional Solution Libraries have to be purchased and installed separately Chapter 2.4 “Installing additional tools and libraries” on page 14.

1.2.6.1 Application libraries and examples

Further libraries and examples can be found in the Automation Builder menu under “Help Online application examples”.

- Applications Libraries add further functionality to AC500 PLC's. They are well tested larger library packages with application example(s) and documentation, have limited support and are free of charge.
- Applications Examples explain functionality by using, e.g., standard Automation Builder libraries and functions in simple examples. They are tested in the described example configuration and functionality only and also come with documentation and are free of charge.

Applications Libraries and Examples help to minimize valuable programming and testing time for specific applications.

The examples for Solution Libraries can be found in the Automation Builder menu under “Help Project examples”.

Overview
License overview > System libraries

For better transparency we recommend to have only one Automation Builder edition as network licenses. As the sharing is happening automatically and the licensing mechanism tends to be greedy it could happen that premium editions are blocked by “Standard users” first and are not available to those who really require premium features.
2 Installation of Automation Builder

2.1 Preconditions

2.1.1 System requirements

For the current system requirements of the Automation Builder, please refer to the latest published release notes.

The latest published release notes can also be found in the Automation Builder menu under “Help ➔ Automation Builder Release Notes”.

For Automation Builder 2.x the system requirements are:

- 1 gigahertz (GHz) or faster 32-bit (x86) or 64-bit (x64) processor
- 8 GB RAM
- 5-18 GB available hard disk space depending on the selected feature set (in addition to Operating System (OS) and other applications)
- Supported operating systems:
  - Windows 10 (32/64 Bit) Professional / Enterprise
  - Windows Server 2012 R2 64 bit (all devices have to be directly accessible by the server; requires enabled .Net Framework 3.5)
  - Windows Server 2019 (all devices have to be directly accessible by the server; requires enabled .Net Framework 3.5)
    Note: Windows 7 is no longer supported.
- Network licenses are required for use of Automation Builder on Windows Server operating systems.

2.1.2 Creating project archives before installation

To ensure a smooth upgrade of your projects created with former Automation Builder versions please create project archives of these projects.

1. In the Automation Builder menu select “File ➔ Project Archive ➔ Save/Send Archive…” to create an archive which includes all ABB and third party devices.
1. In the Automation Builder menu select “File ➔ Project Archive ➔ Extract Archive…” to open an archived project.

Otherwise, by just opening the *.project files some devices (e.g. CS31 Bus) might be missing.

Also this will provide the third party device description to Automation Builder automatically. So it’s not necessary to install all these third party device description manually.

2. Select the information you want to include.

3. Enter a file name and location for your archive.

Opening archived projects
2. Select which content you want to extract from your archive.

2.1.3 Check internet connection and firewall settings

Please check that you have a working internet connection.

Best practice is to open an internet site in parallel and leave that open during download or licensing process.

In case of errors please check if your firewall has maybe blocked Automation Builder and adapt the firewall settings.

If you have any problems with your internet connection or proxy authentication or firewall settings, then choose the offline installation and licensing % Chapter 2.3 “Installing Automation Builder on an offline PC” on page 12.
2.2 Installing Automation Builder on an online PC

☐ Make sure you meet the latest system requirements © Chapter 2.1.1 “System requirements” on page 9.

☐ If you are planning on updating the Automation Builder, please make sure to create project archives © Chapter 2.1.2 “Creating project archives before installation” on page 9.

☐ Have a working internet connection on the PC you want to install the Automation Builder on © Chapter 2.1.3 “Check internet connection and firewall settings” on page 11. If that is not the case proceed with an offline installation © Chapter 2.3 “Installing Automation Builder on an offline PC” on page 12.

1. Go to abb.com/plc/automationbuilder/platform/software to access the download page of Automation Builder.
2. In the “Latest Automation Builder” section, select “Automation Builder x.x. Download” (x.x = latest version). This downloads the installer on your PC.
3. Open the downloaded installer and select “Install Automation Builder”
4. Keep the default type of installation to “Premium Edition”.
5. Select the software packages to be installed.
6. Click “Download and install” and follow the instructions of the setup.

2.3 Installing Automation Builder on an offline PC

To install the Automation Builder on an offline PC, you first have to create an offline installation package on an online PC, then copy the offline installation package to the offline PC and install the Automation Builder.
Make sure you meet the latest system requirements Chapter 2.1.1 “System requirements” on page 9.

If you are planning on updating the Automation Builder, please make sure to create project archives Chapter 2.1.2 “Creating project archives before installation” on page 9.

1. On an online PC go to abb.com/automationbuilder to access the homepage of Automation Builder.
2. In the “Downloads” section, select “Download Automation Builder”.
3. In the “Latest Automation Builder” section, select “Automation Builder x.x. Download” (x.x = latest version). This downloads the installer on your PC.
4. Open the downloaded installer and open “Installer Options and Additional tools”
5. Select “Prepare Offline Installation Automation Builder”.
6. Keep the default type of installation to “Premium Edition”.
7. Select the software packages to be installed.

- The here checked components are available in the offline installation package.
- Which components will be finally installed needs to be selected when performing the offline installation on the offline PC itself.
- So it might be better to select more / all components for this offline installation package to have the choice at the installation later on.
8. Select “Download” and a directory where the offline installation package will be saved.
9. Transfer the offline installation package to the offline PC.
10. Install the Automation Builder and follow the instructions of the installation manager.

2.4 Installing additional tools and libraries

Sometimes the installation and activation of additional tools, e.g. OPC Server, Panel Builder 600, is needed without the whole installation of the Automation Builder Suite. They can be installed separately and independent of the Automation Builder.

Various additional tools are available, e.g.
- ABB License Manager
- CODESYS OPC DA Server
- IP Configuration Tool
- MultiOnlineChange Tool
- Control Panel – CP600
- Panel Builder 600 Runtime for PC

The additional tools have to be installed in the same way, as the Automation Builder § Chapter 2.2 “Installing Automation Builder on an online PC” on page 12 § Chapter 2.3 “Installing Automation Builder on an offline PC” on page 12.
1. In the Automation Builder setup menu under “Installer Options and Additional tools” select “Install Additional Tools” or “Prepare Offline Installation Additional Tools”

2. Select the tools you want to install.
   
   In the tab “Packages” you can see which components will be installed.

3. Select “Download and install”
After installing additional Solution Libraries their licenses needs to be activated using an activation key. *(Chapter 3 “Licensing” on page 19.)*

### 2.5 Migration of third party devices

After an update of Automation Builder the device repository contains only ABB devices. The third party devices which were installed into previous versions of Automation Builder are not automatically installed in the newest version profile. This has to be triggered by the user.

*The feature “Migrate third party devices” is available as of Automation Builder 2.1.1.*

1. Click “Tools” in the main menu of Automation Builder.
2. Click “Migrate third party devices” in the drop-down list.
   - The window *Version profile selection* appears.
3. Select a version profile in the drop-down list containing previous Automation Builder / Control Builder Plus profiles. The active profile does not appear in the list.

- After selection of a previous version profile, all the third party devices which have been installed inside this version profile are listed.

It is not possible to select or deselect some third party devices. Importing will affect all the third party devices which are listed in the list view.
4. Select [Import].

During the migration the message window displays success or failure of device migration.

In case of failure during the migration the affected third party device description has to be installed manually via main menu “Tools ➔ Device Repository ➔ Install”.

In the status bar, the third party device which is on Migrating: <...> is displayed on the left side.

The import operation can be cancelled by clicking the “Click here to CANCEL this operation” link on the right side of the status bar. This becomes effective when the migration of the just migrating third party device is finished.

5. To close the dialog select the [Close] button of the Version profile selection.
3 Licensing

3.1 Starting the licensing process

Depening on what kind of license you want to activate there are three different starting points:

1. Close and save all open projects in the Automation Builder.
2. In the Automation Builder menu select “Tools → Install additional license”.

To activate a license for a standalone tools

- Automation Builder License Manager must be installed % Chapter 2.4 “Installing additional tools and libraries” on page 14.
- From the windows start menu: “Windows start menu → ABB → Automation Builder”.

3.2 Registration

On first startup of Automation Builder you are asked to register. The registration information is stored on your PC and shared with ABB.

In case of future support requests, your registration details enable ABB support team to handle your questions quickly.
For details please refer to the Privacy Statement of the Automation Builder End User License Agreement.

1. Start Automation Builder for the first time.
2. Optionally fill out the registration form.
   By making use of entering your contact data during the registration, you provide ABB with your personal data and state that you are interested in receiving notifications in case of severe vulnerabilities or other security issues. Your data may therefore be used for establishing contact with you.

3. Continue the license activation.

### 3.3 Activating Automation Builder license

- Automation Builder software must be installed successfully.
     - A licensing wizard starts and guides you through the licensing procedure.
  2. If you purchase a license that is locked to a flash drive, plug in the device and select [Next].
Activation key

Enable this option and enter the key. For further information on how to receive this key, contact ABB sales team.

Trial license

You can test Automation Builder software with a trial version in premium edition. In this case no activation key is required.

Basic license

You can install Automation Builder software in basic edition. In this case no activation key is required.

Offline activation

This is required in case of unavailability of internet on the PC. Refer to Chapter 3.3.2 "Offline activation" on page 23.

3. Choose an activation mode and select [Next].
4. Select the license lock mode according to your purchased license and select [Next].
   - If you hold a single PC license, choose PC locked option to license and lock Automation Builder software to the current PC.
   - If you hold a license for portable Automation Builder software, plug a USB drive, enable Portable option and choose your USB drive from the drop-down list. With this, a portable Automation Builder license is created, which allows to operate Automation Builder software on any PC.
5. Select the activation mode and select [Next].
   - Select “Online Activation” Chapter 3.3.1 “Online activation” on page 23 if the PC has access to the internet else
   - Select “Offline Activation” Chapter 3.3.2 “Offline activation” on page 23.

3.3.1 Online activation

The activation data can be sent to ABB License server if the current PC contains internet access.

1. Enable “Online Activation” and select [Next].
   - Activation procedure starts. A successfully ended licensing procedure ends with a success message.
2. Select [OK] to end the wizard.
   - Automation Builder license is activated and starts.

3.3.2 Offline activation

The activation data cannot be sent to the licensing server if the PC does not have internet access. In this case, the offline activation file is created. This file can be used to transfer activation data to the licensing server from another PC with internet access.
1. Enable “Offline Activation” and select [Next].
2. From the file system choose a shareable location (e.g., a shared folder or a USB drive).
   • Enter a file name and select [Save]. An activation file is created and stored to the selected directory.

   Do not close (Cancel) or proceed (Next) the wizard. The license activation is made from a PC with internet availability.

3. Transfer the activation file to a PC with internet availability.

   • Follow the instructions.

   Default language can be changed with the drop-down menu on the right side of the screen.

   ⇒ You will receive an activation response file.

5. Store the activation response file to a shareable location (e.g. a shared folder or a USB drive).
6. Transfer the activation response file to the offline PC.
7. On the offline PC select [Browse] and select the activation response file from the shareable location.

   ⇒ Due to security reasons an activation receipt file is created.
8. Enter a file name and store the activation receipt file to a shareable location (e.g. a shared folder or a USB drive).
9. Transfer the activation receipt file to a PC with internet availability.
10. Upload the activation receipt file from the shareable location to the registration website http://lc.codemeter.com/32838/depot.
11. On your offline PC enable “I want to continue an offline activation: Import an activation response file” and select [Next] to launch Automation Builder.
3.4 Activating additional tools and libraries

Sometimes the installation and activation of additional tools, e.g. OPC Server, Panel Builder 600, is needed without the whole installation of the Automation Builder Suite. They can be installed separately and independent of the Automation Builder.

3.4.1 Activating the Panel Builder 600 and PC-runtime license

The following chapter explains the specialities of installation and / or activation compared to the Automation Builder installation and activation.

If the Panel Builder 600 license was not activated before the first start of Panel Builder 600 an error message will appear.

To activate the license:

1. Start ABB Automation Builder License Manager.
2. Fill out the registration form (optional).
3. Enter your purchased license key.
4. Follow the next steps according to your needs. (PC or dongle bound, online or offline activation).
3.4.2 Activating Solution library license

3.4.2.1 Activating your Solution library license

To activate the purchased license of solution libraries, e.g., Water Pumping library or Temperature Control, please follow the below explained steps:

- Activated Automation Builder license.
- 1. Start Automation Builder.
- 2. Close any open projects.
- 3. Select “Tools ➔ Install additional license”.
- 4. Follow the license wizard and activate your purchased license code in online or offline mode. The principle is the same as activating the Automation Builder license Chapter 3.3 “Activating Automation Builder license” on page 20.

If you do not have the right license for your library you will receive an error during compilation of your IEC 61131-3 application.

3.4.2.2 Checking your activated Solution library license

To check whether or which Solution library licenses you have activated, it is necessary to use the CodeMeter Control Center.

The solution library licenses have separate product codes, that will be added into an already existing Automation Builder license. So there will be no separate CmContainer in the CodeMeter for them.

1. Open the CodeMeter Control Center via “Windows start menu ➔ CodeMeter ➔ CodeMeter Control Center”.
2. Select “WebAdmin”.
3. Select “Container ➔ All Licenses”.
4. Select the CmContainer and browse down searching for the library / product code.

3.5 Managing your licenses

After installing and licensing the Automation Builder you can manage your licenses in various ways.
3.5.1 Identifying the installed license

Since Automation Builder Version 1.1.1 the title bar or Automation Builder shows a license information:

![Automation Builder 2.5 - Premium](image)

Be aware of the following rule for this information:

The info in the menubar is taken in this order from the first found license:

- local licenses (on PC)
- on dongle (USB key)
- network licenses (since AB1.2)

So if a local license is only basic and a dongle with premium is inserted:

- the information in the menubar is basic
- the functionality is premium (the highest available)

To check your installed licenses, the CodeMeter Control Center tool can be used. Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29.

3.5.2 Selecting the license used on Automation Builder startup

You can select, which license the Automation Builder should use on startup.

To select which license should be used:

1. In the Automation Builder menu select “Tools ➔ Options”. ➔ The Options window is opened.
2. In “Startup settings” under “License” select which license should be used.

- Default: The most comprehensive available license will be selected
- Use only local license: Network licenses will never be selected
- Display licenses selection dialog if shared licenses are available: On every Automation Builder startup, you will be asked to select a license
3. To apply the setting select “OK”.

---

**Licensing**

Managing your licenses > Selecting the license used on Automation Builder startup
**3.5.3 Checking licenses with CodeMeter control center**

1. Open the CodeMeter Control Center via the “Windows start menu ➔ CodeMeter ➔ CodeMeter Control Center”.

2. In the CodeMeter Control Center window you can see the different license “tickets” / “CmContainers” that are installed on your PC.
   To see more details, open the CodeMeter WebAdmin by selecting “WebAdmin”
3. Select “Container ➔ All Container”

⇒ Here the details of the license containers can be checked.

3.5.4 Setting dedicated network servers in search list

In case of a new installation CodeMeter will check for licenses also in the network. If there is a run-out or wrongly installed license found, the service is closed without any further hint. This looks like Automation Builder starts and closes after a few moments.

To set the search for licenses to your local machine only follow these steps:

1. Open the CodeMeter Control Center. See Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29

2. Open the CodeMeter WebAdmin by selecting “WebAdmin”
3. Select “Configuration ➔ Basic ➔ Server Search List”

4. Select “add new Server”
5. Enter "localhost" in the Server's names field
6. Select “Add”
7. Confirm by selecting “Apply”
   ➡️ The "localhost" is added to the Server Search List

8. Restart the license check
9. Add more servers to the search list by entering the IP-Adress or name of the license servers you know.

### 3.5.5 Restarting license check with a dongle bound license

In case of using a dongle bound license it might be necessary to restart the check for license on the PC, e.g. if the dongle was removed and reinserted.
1. Open the CodeMeter Control Center. See Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29

2. Select “Process ➔ Restart CodeMeter Service”

### 3.5.6 Removing trial license to remove expiring message

If an unlimited license is installed after having a trial license activated, the warning message for expiring date of the trial license still pops up at the startup of the Automation Builder.

To avoid this message the trial license can be removed.

**CAUTION!**
- If you remove a license from your PC it will be permanently lost.
- Be aware that the trial license includes all premium functionalities, which will not be available any more if your unlimited license is not a premium license, e.g. standard.
1. Check for the Trial CmContainer number in CodeMeter WebAdmin Interface

2. Search CmContainer number in CodeMeter Control Center

3. Remove this selected license in CodeMeter Control Center

### 3.5.7 Network licenses

Starting from Automation Builder 1.2.0 network licenses can be used with Automation Builder. This allows sharing of licenses between team members, easy switchover between several workstations with a single license and allows centralized administration (ordering, registration, activation).

The Automation Builder License Manager and CodeMeter need to be used to configure the Network server.

- In a typical office LAN (Local Area Network) setup on Client side the default settings of the Automation Builder (and CodeMeter) are sufficient to get the Network Licenses working.
- If an opened Automation Builder is loosing contact to the network server (e.g. due to network problems) Automation Builder will prompt the user to restore the network. After 30 minutes without connection to the network server Automation Builder will fall back to basic edition. Opened editors for non-basic features stay open and usable. So your work will not be lost in case of troubles with the network.

### 3.5.7.1 Setting up a network license

The following setup works in typical environments.

### 3.5.7.1.1 Configuring a network license server

- Network license must be registered.
Automation Builder license must be activated.

1. Launch CodeMeter WebAdmin as described in Chapter 3.5 “Managing your licenses” on page 26

2. Select “Configuration ➔ Server ➔ Server Access”

3. Enable Network Server
   
   Keep the default port settings. These should work in most cases.

4. Select “Apply”

5. For the changes to take effect, restart CodeMeter Control Center see Chapter 3.5.5 “Restarting license check with a dongle bound license” on page 32
NOTICE!

- In case you want to control usage of network licenses please refer to Chapter 3.5.7.3 “View network server license usage” on page 37.
- Activation keys for network licenses are valid for one network license each. This one license can be shared among many people but only one Automation Builder instance at the same time. If you want to run more than one Automation Builder instance at the same time you have to activate more than one network license. This means you have to purchase and enter more than one activation key (one per license).

3.5.7.2 Configuring the client side

The default settings of Automation Builder and the CodeMeter (on client side) are sufficient in most cases to get the network licenses working. In case of problems accessing the network license, please set the server search list on the client side.

3.5.7.2 View network server licenses

On the Network Server side you can find information on existing network licenses and their current allocation.
1. Launch CodeMeter WebAdmin. See \% Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29

2. Select “License Monitoring ➔ All Licenses”

### Available Licenses on 'OVAEXPWIN10'

<table>
<thead>
<tr>
<th>Product Code</th>
<th>Name</th>
<th>Feature Map</th>
<th>License Quantity</th>
<th>User Limit (Remained)</th>
<th>Re-User Limit</th>
<th>Exclusive</th>
<th>Shared</th>
<th>Available</th>
</tr>
</thead>
<tbody>
<tr>
<td>096</td>
<td>R&amp;D unbound license</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>999</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1000</td>
<td>CSV Device Import Exp</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1001</td>
<td>CSV I/O Mapping Import Export</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1002</td>
<td>ECAD Import Expert</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1003</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1004</td>
<td>Project Compare</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1005</td>
<td>Project Script</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1006</td>
<td>Automation Builder Premium 2.x</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1007</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1008</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1009</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1013</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1014</td>
<td>-</td>
<td>0x3</td>
<td>1</td>
<td>0 (0)</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

Information last updated on 2020-12-09 10:36:15

Current Server: localhost (127.0.0.1) WebAdmin Version: 7.10

### 3.5.7.3 View network server license usage

1. Launch CodeMeter WebAdmin. See \% Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29

2. Select “License Monitoring ➔ Sessions”

### Sessions

<table>
<thead>
<tr>
<th>Client</th>
<th>Computer License (128-17149280)</th>
<th>3000460 : ABB Automation Products GmbH</th>
<th>12000 : Virtual Commissioning</th>
<th>Access Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
<tr>
<td>localhost</td>
<td>ABB R&amp;D non-bind License (128-17149280)</td>
<td>3000460 : ABB Automation Products GmbH</td>
<td>12000 : Virtual Commissioning</td>
<td>Station Share</td>
</tr>
</tbody>
</table>

Information last updated on 2020-12-09 10:41:34

Current Server: localhost (127.0.0.1) WebAdmin Version: 7.10
3.5.7.4 Controlling network server license usage

On the Network Server side you can define settings managing the client access to CodeMeter License Server on a network.

1. Launch CodeMeter WebAdmin. See Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29

2. Select “Configuration ➔ Server ➔ Server Access”

3. Add entries of PCs you want to share licenses with by adding client computers and IP addresses for accessing CodeMeter License Server on a network.
3.5.8 License borrowing manager

The license borrowing manager allows you to borrow a network license for offline use and return it.

```
The license borrowing manager is not part of the default software distribution, but will be handed out on request.
```

```
The license borrowing manager is only supported by Automation Builder 2.2.3 and later.
```

3.5.8.1 Borrowing a network license

- Network access to the license server required.
- Opened the license borrowing manager.
  1. Select the license you want to borrow.
  2. Select “Borrow License”.
  3. Select the target CmContainer.
     Alternatively a new CmContainer can be created.
  4. Select the end of the borrowing period.
5. Select “OK”.
   ⇒ The license has sucessfully been borrowed.
   The list of available licenses has been updated.

3.5.8.2 Returning a network license

**Automatical return of a license**

Network licenses will be returned automatically after the expiration of the maximum borrowing period. No licenses server access is required.
Manual return of a network license

- Network access to the license server required.
- Opened the license borrowing manager.
  1. Select a borrowed license.

![License Borrowing Manager](image)

  2. Select “Return License”

→ The license has successfully been returned.

3.5.9 Transferring an Automation Builder license

3.5.9.1 General

It is possible to transfer normal licenses from a PC to another PC or dongle (DM-Key).

This is not possible for ABB internal or temporary licenses, e.g. the 30 day Trial license.

The process consists of two main steps:

1. Return the actual license from the actual PC
2. Reactivate the license on the new PC

3.5.9.2 Getting activation code

For all license transfer processes the activation code is required. It is available from the license paper from purchasing the license.

For Automation Builder licenses purchased April 2020 or later, the activation code is available from the activated license:
1. Open CodeMeter Control Center and navigate to the "WebAdmin".

2. Identify the right product code.

   Automation Builder editions consist of multiple product codes. The activation ID is available from the product code containing the edition name, e.g. "Automation Builder Standard".

3. Select product code to access the product code details. Under "License Information" you can find the activation code.
3.5.9.3 Returning an Automation Builder license

- You need the License Activation code of the license you want to return.
- Go to the following website: http://lc.codemeter.com/32838/depot-return/index.php

The website is also available through the Automation Builder menu under “Help ➔ Return of Automation Builder license”.

- Insert your Activation code in the field “Ticket”
- Select “Next”
4. Select “Re-Host License”

If the CmContainer is found, continue with Online licenses transfer \ Chapter 3.5.9.3.1 “Online license transfer” on page 44

If the CmContainer is not found, continue with Offline license transfer \ Chapter 3.5.9.3.2 “Offline license transfer” on page 46

3.5.9.3.1 Online license transfer

Wait till the CmContainer is found, then select “Deactivate Selected License Now”
Re-Hostable Licenses

To re-host licenses from one CrmContainer to another CrmContainer:
1. Make sure that the CrmContainer with Serial 120-17656564 is connected to this computer. If this CrmContainer is not connected to the computer, connect it now and click "Reclaim for CrmContainer."
2. Select the licenses you want to re-host.
3. Click "Deactivate Selected Licenses Now".
4. After the successful deactivation of the selected licenses, you can activate them again in another CrmContainer.

<table>
<thead>
<tr>
<th>Name</th>
<th>Activated On</th>
<th>CrmContainer</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSQ01-TOOL – Standard license</td>
<td>2021-06-28 14:32:30</td>
<td>120-17656564</td>
<td>Activated</td>
</tr>
</tbody>
</table>

Deactivate Selected Licenses Now

Online License Transfer

Starting license transfer.
Creating license request.
Downloading license update.
Importing license update to CrmContainer.
Creating receipt.
Uploading receipt.

License transfer completed successfully!

OK
3.5.9.3.2 Offline license transfer

If the CmContainer is not found on this PC, select file-based license transfer workflow.

The instructions will lead you through the main steps of the offline license transfer:
1. On the offline PC open the CodeMeter Control Center.

2. Select “License Update”.

3. Select “Create a license request file”.

Welcome to the CmFAS Assistant!

The CodeMeter Field Activation Service (CmFAS) assistant helps you adding, changing and deleting licences from the license management system CodeMeter.

With the CmFAS assistant you can create license request files, which you can send to the vendor of the software by email. You can also import the received license update files with the CmFAS assistant into the license management and create a receipt of the import for the vendor.
4. Select a location to store the license request file.
5. Transfer the license request file from the offline PC to an online PC.
6. On the online PC choose the license request file and select "Upload Request And Continue Now".

7. Select “Download License Update File Now”.
8. Save the license update file to a location on your computer.
9. Transfer the license update file from the online PC to the offline PC.
10. On the offline PC open the CmFAS Assistant.
11. Select “Import license update”.

12. Select the license update file, to import the new license to the offline PC
13. To confirm a successful license transfer return to the online PC and select “Next”.

14. On the offline PC open the CmFAS Assistant.
15. Select “Create receipt”.
Please select the desired action

- **Create license request**
  Choose this option if you want to create a license request file in order to send it to the vendor of the software.

- **Import license update**
  Choose this option if you received a license update file from the software vendor and want to import this file.

- **Create receipt**
  Choose this option if you want to confirm the successful import of a license update file for the software vendor.

16. Choose a location to save the license receipt file.
17. Transfer the license receipt file from the offline PC to the online PC.
18. On the online PC choose the license receipt file and select “Upload Receipt Now”.

After a successful license transfer you will receive the following message:

3.5.10 Generating license information file for support

To create a license information file which includes all license information for the support:

1. Select “Windows start menu ➔ CodeMeter ➔ Tools ➔ DmDust”.
   ⇒ The explorer window opens and shows the folder where the created log file “CmDust-Result.log” is stored.
2. Please attach this file to any support request regarding your licenses.

3.5.10.1 Log files

Sometimes more detailed log files are needed to analyze a situation. Then please also zip the following folder and attach it to your support request.

C:\ProgramData\CodeMeter\Logs
This folder includes

- CmActDiagLogyyyy-mm-dd-hhmss.log
- CodeMeteryyyyy-mm-dd-hhmss.log

To make it easier to distinguish when the files were created, they are named as follows:

- yyyy – year, mm – month, hh – hour; mm – minutes, ss – seconds.
4 Frequently asked questions and Support

4.1 Frequently asked questions

Q = Question
A = Answer / Explanation
H = Help / Hint how to solve

<table>
<thead>
<tr>
<th>Q1: The installation or download failed. I see red icons on all selected components</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: The internet connection to the download server was not established.</td>
</tr>
<tr>
<td>H: ● Open an internet connection to a site outside your company (to establish proxy authentication). ● Check the firewall settings to see if Automation Builder was blocked to download files. If so adapt the firewall settings. ● Do an offline installation ● Save the install log file and send it to ABB support. See &quot; Chapter 4.2 “Special settings for internet security software “F-Secure”&quot; on page 58</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q2: Which Components or which Editions should I install? Can I add special components later on?</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: It is possible to add components later on, independent of the activated license.</td>
</tr>
<tr>
<td>H: ● If you choose to download an offline installation package, it might be better to select all / more components for the download. The choice, which components will be installed is made at the installation process. ● If you want to use Basic and your previous purchased Panel Builder see Q6</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q3: How big is the installation package?</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: The amount of downloaded data depends on the selected components and version profile.</td>
</tr>
<tr>
<td>H: ● For the current system requirements of the Automation Builder , please refer to the latest published release notes.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q4: Activation wizard tells me that I have no internet connection. But the PC is connected to the internet</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: The license server maybe did not answer within a certain time (5s).</td>
</tr>
<tr>
<td>H: ● Choose the “Retry” option ● Open an internet connection to a site outside your company. (to establish proxy authentication) ● If the wizard asks to save a *.xml file, do so and continue the offline licensing described in &quot; Chapter 3.3.2 “Offline activation” on page 23. ● Try to do a complete offline activation – see &quot; Chapter 3.3.2 “Offline activation” on page 23</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q5: Activation wizard tells me that the activation is not possible. But the PC is connected to the internet and the connection works with external websites</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: Probably some IT security components block the online communication to our license server. The root cause typically is very specific with respect to the (company) IT landscape. Further investigations can be done based on the following information: The license manager uses HTTP requests on Windows HTTP standard port to the URL <a href="http://lc.codemeter.com/32838">http://lc.codemeter.com/32838</a>. It uses the proxy settings as defined in the internet explorer</td>
</tr>
<tr>
<td>H: Try to do a complete offline activation – see &quot; Chapter 3.3.2 “Offline activation” on page 23</td>
</tr>
<tr>
<td>Q6:</td>
</tr>
<tr>
<td>-----</td>
</tr>
<tr>
<td>A:</td>
</tr>
<tr>
<td>H:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q7:</th>
<th>After the installation of Automation Builder 1.1 I cannot open the Panel Builder 600 anymore. I have activated a basic license.</th>
</tr>
</thead>
<tbody>
<tr>
<td>A:</td>
<td>If the Panel Builder was installed with Automation Builder 1.1 it requires a valid license higher than basic.</td>
</tr>
</tbody>
</table>
| H:  | ● Upgrade the license to standard or higher.  
● If you had a purchased standalone Panel Builder 600 version earlier: Install this one again. An Update installation file to version 1.90.0.975 can be downloaded from the ABB website. Link: [http://new.abb.com/plc/control-panels/cp600/software](http://new.abb.com/plc/control-panels/cp600/software) and check for “Software” in the “Download related documents for Software” section. After this installation Panel Builder can be opened standalone again. |

<table>
<thead>
<tr>
<th>Q8:</th>
<th>The activation of the USB-key (dongle) does not work</th>
</tr>
</thead>
<tbody>
<tr>
<td>A:</td>
<td>If you try to activate an ABB internal license key to a dongle: this is not foreseen and does not work. If you try an offline activation: the wizard will not give a success message. (Fixed in Automation Builder Version 1.1.1)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q9:</th>
<th>The system does not recognize my dongle bound license</th>
</tr>
</thead>
<tbody>
<tr>
<td>A:</td>
<td>In case of using a dongle bound license it might be necessary to restart the check for license on the PC, e.g. if the dongle was removed and reinserted.</td>
</tr>
</tbody>
</table>
| H:  | ● Restart the CodeMeter Service Chapter 3.5.5 “Restarting license check with a dongle bound license” on page 32.  
● The offline activation of normal licenses must be exit by “cancel” or the “x”. Activation will nevertheless be done. Check with by CodeMeter. This will be fixed with Service Release Automation Builder 1.1.1 |

<table>
<thead>
<tr>
<th>Q10:</th>
<th>How can I check, which license is activated?</th>
</tr>
</thead>
<tbody>
<tr>
<td>H:</td>
<td>Open the CodeMeter tool Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q11:</th>
<th>The Automation Builder does not open any more. How can I activate my purchased or a basic license? I get an error message: “The trial period has elapsed. Reactivating the license is not allowed.”</th>
</tr>
</thead>
<tbody>
<tr>
<td>A:</td>
<td>After the trial period the trial license was activated another time. This prevents Automation Builder to startup.</td>
</tr>
<tr>
<td>H:</td>
<td>● Open the CodeMeter tool Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29 and delete all licenses. Then Automation Builder will start up with the License Activation Wizard again.</td>
</tr>
</tbody>
</table>

| Q12: | Is a separate license needed for a virtual machine? |
A: The license is bound to a PC. As each virtual machine is like an own PC, all different virtual machines need a separate license.

Some information to the use of virtual machines.

- Each virtual machine is like an own PC system and needs an own license.
- One way to use several virtual machines with one license key is to bind the license to a dongle.
- It is possible to activate a license to the PC and add a dongle to it at the same time. Both licenses are used to cover the needed features. (E.g. if a standard license is bound to the PC and a premium is bound to the dongle.)
- Before you start the Automation Builder in the virtual machine, check if the dongle is available.
- This can be done in the explorer window or in the CodeMeter tool. (see Chapter 3.5.3 “Checking licenses with CodeMeter control center” on page 29)
- If the dongle is not available try to plug off and in again, while the virtual machine is running.
- If the license is bound to a virtual machine on a PC directly it is NOT possible to move this virtual machine to another PC using the same activation key.
- If you want to copy or move the virtual machines with an Automation Builder Installation to another PC, do this before you license this Automation Builder installation.
- However if you had it already licensed, then delete the license in CodeMeter and restart Automation Builder again to activate another license key. How to do this see Chapter 3.5.6 “Removing trial license to remove expiring message” on page 33

Q13: I want to upload the activation request file (*.xml) but get an error message “internal error” “0x18080001”

A/H:
- you might have pressed the upload button another time while delivery process was still ongoing:
  - then the license must be activated manually.
  - Please send the activation request file (*.xml) file to plc.support@de.abb.com
- you try to upload the activation file of internal additional safety license key “QQW64-…”-B644E”
  - this can not be activated offline.
  - Please send the activation request file (*.xml) file to plc.support@de.abb.com
- you might had test or development licenses on your PC
  - Please delete all those licenses from CodeMeter (see Chapter 3.5.6 “Removing trial license to remove expiring message” on page 33) and retry

Q14: I have installed Drive Composer Pro with Automation Builder 1.1 and now I can not update it to next version

A: Automation Builder Installation and Updates will offer the latest version of Drive Composer Pro from the time of release.
   For Automation Builder 1.1 this was Drive Composer Pro V1.6.3
   The service pack 1 – Automation Builder 1.1.1 will include Drive Composer Pro V1.8.1
   For Automation Builder 1.2.2 this was Drive Composer Pro V1.11.2.5
   Remark: the integration will only work, if you also select the Drive Composer Pro at the moment of installation.

H: To update the Drive Composer Pro independently of the actual used Automation Builder version, please uninstall Drive Composer Pro via Windows Control Panel and then install it again standalone. The Drive Composer Pro plugin for Automation Builder will still be available.

Q15: I have installed and activated Automation Builder on a Windows Server but can not open it via Remote Desktop session

A: Automation Builder requires a network license for execution on Windows Server operating systems.

Q16: How can I move my Automation Builder license to another PC?
4.2 Special settings for internet security software “F-Secure”

“F-Secure” software can lead to a complete CodeMeter service interruption, which leads to the situation that an activation can not be finished successfully or the installed licenses are not recognized any more.

Please try this guide as indicated below, whereas the second alternative seems to be the most trustfully solution, since ultimately what has to be done is to do exclude CodeMeter.exe from the scanning process instead of reducing the general security level.

4.2.1 Compatibility mode

F-Secure has a so called “DeepGuard” function, which seems to trigger an advanced process monitoring. To avoid this, activate the compatibility mode within the DeePGuard configuration. The CodeMeter.exe should work without issues afterwards.

4.2.2 Adding CodeMeter to whitelist

Other possibility, and in our opinion the best alternative is to include the CodeMeter.exe into the so called WhiteList for F-Secure. After this no more problems should appear at all.

To add the CodeMeter.exe in the WhiteList please do the following:

F-Secure configuration ➔ Virus- and Spyware Scanning ➔ Exclude files from scanning (or similar) (this should be an entry with blue letters down in the middle of the app.) ➔ Objects ➔ checkmark on “exclude objects”™ and select CodeMeter.exe from the directory: „C:\Program Files (86)\CodeMeter\Runtime\bin“.

4.3 Support

If the installation or license activation does not succeed and however the Help and Hints in the “Frequently asked question” section does not solve the problem, contact your local ABB support.

Please always provide the following main information and add the support packages described below.

4.3.1 Main information

- Your name, company name, and contact data
- Operating system of your PC
- Time and your location (time zone) when the problem occurred. So support can check log files on server.
- Was this the first installation or did you had a previous installation of Automation Builder (Control Builder Plus) on your PC installed?

4.3.2 Installation log file

If your installation failed and hints in Q1 did not help:

Table:

<table>
<thead>
<tr>
<th>A:</th>
<th>Licenses can be returned (and thus moved to another PC) via <a href="http://lc.codemeter.com/32838/depot-return/index.php">http://lc.codemeter.com/32838/depot-return/index.php</a></th>
</tr>
</thead>
<tbody>
<tr>
<td>H:</td>
<td>For returning a license, entering of the activation key is required.</td>
</tr>
</tbody>
</table>
• Open the “Show Log” via the button at the end of the installation screen.
• Save the log file and send it with a description and main information to local ABB PLC support.

The installation log file is also automatically stored under
C:\Users\<user>\AppData\Roaming\AutomationBuilderInstaller\Log\AutomationBuilder-Installer.log

Other Installation log about the beginning of platform installation can be found under
C:\Program Files\ABB\AutomationBuilder\ABB_Setup.log
or
C:\Program Files (x86)\ABB\AutomationBuilder\ABB_Setup.log

4.3.3 License activation support information
If your license activation did not succeed and hints in the frequently asked questions section did not help:
• Generate a license information file for support like described in § Chapter 3.5.10 “Generating license information file for support” on page 53
• If you use a USB-key (dongle) be sure to have it plugged in.
• Very important: add your time zone and the time at which you tried to active the license to the E-Mail, so that ABB support can check the server logs for that UTC time.

4.3.4 Automation Builder log files
Can be found here C:\Users\<user>\Documents\AutomationBuilder\Logs