TS3 Manager

= T53 Manager ¥.1.0.0

User’s Guide

4t Ik ip
FLipap

TS3 Manager

1SDH000670R0003

L3852

EN




1

2

4

SUMMARY

g0 [8 [ u o] o 4
First RUN Operations .......ccviiieiiiiiiiiciieireseresr v e e e e e 5
2.1.  Text Editor Selection..........coovviiiiiiiiiiiiee e, 5
2.2. Firmware Uploader Selection.........cocoveiviieiiiiinninnnennennns 6
BasiC Operations........cccovviiiiiiiieiiiree e e 7
3.1. Initializing the Communication..........ccccoveiveviniinninninnnennns 7
3.2, DeVviCe Id ..o 9
3.3. TSI INfO.cuiiiiiiiii e 9
3.3.1. Date & TiME.....civvriiiiiiiirr 10
3.4.  RepOrt OVEIVIEW ....cuiiieiiiiireieceiren s esen e es e e neennes 10
3.5.  Communication Management........cccoveivvienieirenrnnenrenennes 11
3.5.1. Network Type Selection ........cccovviiiiiiiniiic e, 11
3.5.2. Communication Parameters Setup........cceevvvviiivniinnniennn, 11
3.6. Firmware Update .......cooiiiiiiiiiiiiee e 12
3.7. Closing the TS3 Manager ......c.ccovvvveiiiieiennenneneennsenneaens 13
Reports Management.......covviviiiiiiniiirinrrrs s 14

F TS3 Manager | 1SDH000670R0003 | L3852 | 2/26




4.1.  Report From DevVICe .....cviveiiiiiiiiiiireereirrec e 14
4.1.1. REPOIt DiSPIay....ccvuiiiiiiiiiiiiiini e er e e 14
4.1.2. Generating a Report Text File........cocevvviiiiniiiiiniiiiccnecnees 16
4.1.3. Editing a Report Text File....cccooviiiiiiiiiiiieee 20
4.1.4. Clearing the Reports from the TS3 Memory .........cccceeeeee 20
4.1.5. Generating @ Reports Backup........ooceveeiiiininiiinninieennnineens 22

4.2.  Report From BacKup.......oveeiieiiiiieiiiiieieecenennesnsensen e 24

4.3.  Report EXitiNg.....cccovvieiiiiiiiicirr e 26

F TS3 Manager | 1SDH000670R0003 | L3852 | 3/26




1 Introduction

= T53 Manager ¥.1.0.0

Figure 1-1: Main Window

The TS3 Manager is a remote control program for the TS3 test set that allows a complete
management of the report functions of the device.

Using the software, you can control all the report capabilities that are available from the
local keyboard of the TS3 machine.

However, remote reports management performed using the TS3 Manager, have several
unique features that you cannot replicate from the TS3 device keyboard.
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Using the TS3 Manager, you can:

Save the reports to a file on the PC

Generate reports in a text format, selecting only the reports you actually need
Perform reports clean up on the TS3, automatically generating a backup file that
you can use later

Navigate the reports on screen with an intuitive and user friendly interface

Edit and view text reports using an editing program of your choice

VV VVV

Another feature of the TS3 Manager enables you to update the TS3 firmware from inside
the program, running the TS3 Firmware Uploader.

2 First Run Operations

2.1. Text Editor Selection

When you first run the TS3 Manager, you will have to select the path to a text editing
program of your choice. This will allow you to see the text reports directly from the TS3
Manager.

To select the text editor, you will use a window like the one below:

=l Select the Text Editor M= E

Text Editar;

i

| (] | | Cancel |

Figure 2-1: Text Editor Selection Window

Clicking on the browse button EI you can select the path to the text editing program.
[oc |

Pressing you confirm your choice; pressing the TS3 Manager will not store the
path, but it will ask for it every time you restart the program.

If you need to change the text editor, it is sufficient to select
Options => Text Editor Selection from the main menu, as shown below, to open the path
selection window.

File - Report - Communication - Firnware Update -

Text Editor Selection

Figure 2-2: Text Editor Selection Menu Item
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2.2, Firmware Uploader Selection

Another selection is required at the first program run. You will have to point to the
directory where the TS3 Firmware Uploader is installed:

=l Select the Firmware Uploader =] B

Firrmware L ploader:

Figure 2-3: Firmware Uploader Selection Window

Clicking on the browse button H you can select the i ath to the Firmware Uploader

program. Pressing you confirm your choice; pressing the TS3 Manager will not
store the path, but it will ask for it every time you restart the program.
If you need to change the path, it is sufficient to select

Update Firmware => Firmware Uploader Selection from the main menu, as shown below,
to open the path selection window.

I T53 Manager v.1.0.0
File - FReport - Communication - REIGEEERGEGY - Options

Ilpdate Firmware

Firmware Uploader Selection

Figure 2-4: Firmware Uploader Selection Menu Item
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3 Basic Operations

3.1. Initializing the Communication

To initialize the communication between the PC and the TS3 device, you must have the
interface driver correctly installed and operating, and, of course, the USB cable connected.
Besides,éou must know the device id of your TS3, usually 1, and input it in the dedicated

ﬁeldDevice |d: 1

To input the device id, you can type it directly in the input field, or use the arrows @ to
increment or decrement the value. The range of the device id is from 1 to 32.

Once these conditions are satisfied, you must press the button to start
the communication between the TS3 device and the TS3 Manager.
The window used to set the communication parameters opens, remaining grayed out

while the program scans the COM ports of your PC:

= Imitiahize Communications

Figure 3-1: Greyed Out Communication Parameters Input Window
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When the TS3 Manager terminates its COM ports analysis, the input fields of the
communication parameters are enabled, and the window switches to normal colours:

= Imitiahize Communications

g cows |
o s

E, | rohe |

Figure 3-2: Communication Parameters Input Window

You must select the communication port used by the TS3 device, clicking on the
Communication Fort @ COMT input field, to obtain the COM ports list. You can also use the

e arrows to the left of the field to scroll between the ports.
The greyed out COM ports are not available, and you must select, between the enabled ones, the
specific port used by the TS3.

You must set the other communication parameters to the values shown in Figure 3-2:
Communication Parameters Input Window above.

The TS3 Manager retains the communication parameters between sessions, so you will
not need to change them, unless you change the driver parameters at the operating system level.

Click to confirm your choices, or not to start the communication between

the TS3 Manager and the test set.

When the communication parameters input window closes, if you pressed , the
software tries to open the communication channel with the TS3.

If the communication successfully establishes, the _ button changes to

. In any moment, you can press it to close the connection with the TS3 test
set.
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3.2. Device Id

The device id field changes its appearance when the communication is ON.

In this status, the device 1d is not editable, and it looks like this: Device Id !

Although you cannot change the device id used by the TS3 Manager to communicate
with the test set, you can change the test set device id.

To do this, point to the device id input area, and press Ctrl-Click (press Ctrl on the
keyboard and, contemporarily, the left button of the mouse).

The device id input window appears:

I+l Device I1d Setup [_[O] <]

MHew Device |d: :) a

| (] 4 | |Eancel|

Figure 3-3: Device Id Input Window

Pressing , the new device id will be written into the TS3 device ROM, and the
communication will continue using the new device id. You will have to use the new device id to
connect to the TS3 in the future.

Pressing the TS3 device id will remain unchanged.

3.3. TS3 Info

When the communication switches ON, the TS3 Manager immediately requires the
identification data from the TS3 device, showing it in the TS3 Info data structure:

b odel; TS53
Senal Mumber: JI10 01558
Firrnmare ersion: 1.02

Wiorking Hours: 150

Diate & Time: | 164072008 21:05:14

Figure 3-4: TS3 Info Data Structure

The TS3 Manager continuously exchanges data with the test set, updating the
Working Hours: 150 and the Date & Time: 16072008 21:05:14 fields
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3.3.1. Date & Time

To change the date and time of the TS3 remotely, point to the date and time field and
press Ctrl-Click.
The Date & Time Input Window opens:

! I} .Input the System Date and Time. ..

Figure 3-5: Date & Time Input Window

Pressing D Today , the operating system date is automatically inserted in the date input
field Drate: [ /hbd DD

Pressing 4 N':'W, automatically inserts the operating system time in the input field
Tirne: [HH.k.55]

The & Today&Now button, when pressed, combines the effects of the two buttons
described before.
3.4. Report Overview

To display the reports stored in the TS3 test set, select the corresponding item from the
main menu:

Figure 3-6: Report From Device Menu Item

To manage the reports stored in a backup file, select Report => From Backup from
the main menu:

8 Report B8

Fram

Figure 3-7: Report From Backup Menu Item

The report management window will open and you will operate at the report management
level. Detailed description of the report management options and operations are explained in the
dedicated chapter.
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3.5. Communication Management

3.5.1. Network Type Selection

To select the network type, go to the Communication => Select Network Type
main menu option:

File - Report - EEpegie=i=el - Fimware Update - Options

Set Parameters b

AT TOND

Figure 3-8: Network Type Selection Menu Item

The network selection window appears:

> Select Network Type. .. M[=] B3
Metwork, Tope: :-jl Senal
| (] I | Eancell

Vi

Figure 3-9: Network Selection Window

You can select the network from the list Network Type: ’) Bl

Currently, only the Serial network is available, but future releases of the TS3 device

could include other types of network.
If you press h, you will be able to input the communication parameters that

correspond to the selected network.

Selecting the serial network the corresponding parameters setup window will open, and
you will be able to input the values appropriate for your TS3 device (see Figure 3-2:
Communication Parameters Input Window, and the following instructions).

Pressing , you simply return to the main window.

3.5.2. Communication Parameters Setup

You can modify the communication parameters selecting
Communication => Set Parameters:

File - Report - EEge=umgl - Firmware Update - Ophions

Select Metwork Type
“ Set Parameters B e A ﬁ : T e o

Figure 3-10: Communication Parameters Setup Menu Item
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The only available choice is currently Serial. In the future, other communication
protocols could be available.
Selecting Serial the parameters setup window will open, and you will be able to input
the values required to connect to your TS3 device (see Figure 3-2: Communication Parameters
Input Window, and the following instructions).

3.6.

Firmware Update

To update the firmware of your TS3 test set, select
Firmware Update => Update Firmware from the main menu:

Figure 3-11: Firmware Update Menu Item

You will be asked to shut down your TS3 device:

F= T53 Firmware Update

Figure 3-12: Firmware Update Confirmation Window

If you press , the action will abort, and you return to the main window.
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Pressing , the TS3 Firmware Uploader program opens:

[=2] T53 firmware uploader M|E E3 |

File  About

File |

File type I tdastes @+

Checksum I Slave

|
[com 15

Figure 3-13: FW Uploader Program Window

Follow the instructions of the uploader program manual to update the firmware of the
TS3 test set ( see par 10 of ISDH000670R0002 ).

When you leave the uploader program, the TS3 Manager returns to the main window,
with the remote connection shut down.

You will need to restart the connection using the button.

3.7. Closing the TS3 Manager

To close the TS3 Manager, press the button or select File => Exit from the

main menu:

- Report - Communication - Firmware Update - Opliohs

[Ea |
AL EP ED AN TN

Figure 3-14: File Exit Main Menu Item
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4 Reports Management

4.1. Report From Device

If the communication is ON, you can select Report => From Device from the main
menu:

Fil: - IGE=d  Communication - Fimwars Update - Oplions

From B ackup . ﬂ A hF Tﬁﬂ

Figure 4-1: Report From Device Main Menu Item

4.1.1. Report Display

The report management window opens, showing the last report stored in the TS3 test set:

ii}] Reports Management [_ O] -]
File - FRepart - Backup

Fepart Mr.: Report Text:

ol e8 LEE $ACE T33 =
Test Report
= Report Mumber..........: 68
I Ta3 derial Nuwber.. -: TJ10101955
- T3 Firmware Version...: 1.02
Apttodieh ABEAe e e s -: 10407708
RS, ABHNEE o oo o oo o o A ey
Tested Belay. . oeveaan.a: ARL
! Test Descriptioh.......: ARl
Belay Serial MNumber H

ITeStee i evnnerannnasanas 497 4
[EhAsetsies H ]

Trip Time... ol Ak
Stopped By.... . Timeout
Frequency : 60 Hz

Exclude Empty Fields: ‘

Figure 4-2: Report Management Window

At the top left of the report display tab, you can see the report number input field
Report Mr.:

U] 8 You can select the displayed report using this control.

You may also navigate through the reports using the navigation buttons.
Everyone of them is associated to a key, which you can press instead of clicking the
corresponding button, when you are not pointing to any specific object on screen.
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A table describing the button action, and the corresponding key, follows:

Button Key Action

Ny Home Display first report
=1 Top

n Page Up Go up by 5 reports per click (decreasing report number)
L1 Page Up
-1y Up Arrow Go up 1 report (decreasing report number)
= Up

f Down Arrow Go down 1 report (increasing report number)
L1 Down

’} Page Down Go down by 5 reports per click (increasing report number)
_L Page Down

f End Display last report
.==1 Bottom

Figure 4-3: Report Navigation Buttons and Keys
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If you do not want to include the fields that don’t contain data into the report, press the
Ewzlude Empty Fields: .' button

The lines that do not show data will disappear from the report.
For example, the report showing in Figure 4-2: Report Management Window will show as
below:

I Reports Management

Figure 4-4: Report without Empty Fields

4.1.2. Generating a Report Text File

To generate a text file containing one or more reports, select Report => New from the
menu, or press Ctrl-N:

Figure 4-5: Report Text File Generation Menu Item
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The report generation input window appears:

EE Save Reports | (O] =]
File

"

Start Report Mumber: ©J| 8 . End Report Mumber: .;-JJ B3 | All Reports I

Formatted Text | | Current Bepaort Only |

FReport Format: -

Figure 4-6: Report Generation Input Window

By default, the input fields are set to generate a text file containing only the currently
displayed report.

Start Repaort Nurmber: .’j 1 End Repart Mumber: :j 63

You can set the and the to
include a group of test reports in the text file.

All Beportz

Pressing the | | button, you will select all the test reports in the TS3 test set,
and include them in the text file with a single click.
To include only the report that was displayed when you selected the report generation item from

the menu, press the| Currert Beport Ol by tton,

The Report Format field lists all the formats available for the text file:

> Repart Farmat: :j Farmatted Tesxt

With this format selected, the text file generated starts every test report with a
two lines header.

Every field of a single report occupies one line, and has a header, and, if
applicable, a trailer.

The test reports are separated by a dashed line.

1

> Repart Farmat: .j Tab Separated Table

This format is similar to the precedent, but the header of every test report field is
separated by a tab from the value and trailer of the field itself.

This format is particularly suitable for inclusion as a table in a Microsoft®
Word™ document.

n

> Report Format; :j Comma Separated Values

In this format, the first line contains the headers of the test report fields, separated
by commas.

Then, every test report occupies a single line, composed of the field values,
separated by commas.

You should use this format when you want to include the reports in a Microsoft®
Excel™ sheet.
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If you actually want to generate a text file report, press L_ The report
formatting window opens:

= Formatting Report(s]... _ (O] =]

Formatting Report 7 of 9.

Flease Wait. .

Figure 4-7: Report Formatting Window

Once the formatting process ends, you can select the file name:

Save_in:l — Ts3 j ﬁl

T53 01 Reparts 2008-05-15 1230035 - 2.txt
T53 01 Reparts 2008-05-15 123035 k=t

..............................................

.............................................

File name: ITSS 01 Reports. tat ] I
Save as ype: ITe:-:t Files [*.tat) j Cancel |

Figure 4-8: Report File Save Dialog Window

Pressing LI, the file will be saved. ﬂl will lead you back to the report

generation input window.
If the file is a new one, it is written to disc, and you return to the report saving input
window.
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If the file already exists, you can select between four options, whose meanings are

explained in the following window:

>l Save the Report... !EI

The file "TS3 01 Reports. bt already exists.
Pleaze zelect one of the following actions:

Stack: Add the report ta the top of the file
Feplace: Replace the old file

Append: Add the report ta the end of the file
Cancel Abaort the save aperation

Stack, | | Heplacel | Append | | Caricel

Figure 4-9: Report Existing File Save Options Window

Pressing , the file saving aborts.

If you press , the generated report text file will replace the existing one.

Clicking , the new file content will lay on top of the existing one.
Lo |

With you add the new file content to the end of the existing one.

If you want to see immediately the result of the text report generation, or if you don’t
remember exactly the content of an existing report text file, you can see it in a text editor using

the File => Open option of the report generation input window:

E xit Clrl+F4 |

Figure 4-10: Report Generation Input Window File Open Menu Item

You can select the file to see from the dialog window:

Select the Report file to load

Lookin [ 3753 = =i
T53 01 Reparts 2008-05-15 1230035 - 2.txt
T53 01 Reparts 2008-05-15 123035 k=t

File name: ITSS 01 Reports. tat ] I
Filez of wpe: ITe:-:t Filez;.Comma Separated Values Filez [*.tj Cancel |
o

Figure 4-11: Report File Open Dialog Window

If you press ﬂl, the operation aborts.
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If you press LI, provided you selected a text editing program (see Figure 2-1:
Text Editor Selection Window), the file will show in the text editor window.
The text editor window is independent from the TS3 Manager one, so you can open more files if
you want.

To end the report text file generation, press or select File => Exit from the
menu:

Open  Chl+0 |

Figure 4-12: Report Generation Input Window File Exit Menu Item

4.1.3. Editing a Report Text File

You can edit an existing report text file selecting the Report => Edit menu item or
pressing Ctrl-0O from the report display window:

File -

- Backup
Mew  Chil+td

Repart Text:
ABE SACE TS3 =l

Figure 4-13: Report File Edit Menu Item
The procedure is the same that is described from Figure 4-11: Report File Open Dialog
Window above.
4.1.4. Clearing the Reports from the TS3 Memory

To clear the reports contained in the TS3 memory, select Report => Clear in the
report display window:

syl - Backup
Mew  Chl+N

Edit  Chl+D

Feport Text:
LEE SACE T33 =

Figure 4-14: Report Clear Menu Item
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To successfully clear the reports, you must know the necessary password, and input it in
the window below:

Fs Clear Heports

Figure 4-15: Report Clear Password Input Window

If you press , the reports will not be cleared.

Pressing , the first operation that the TS3 Manager performs is saving the reports
to a backup file, showing the following window:

ks Downloading Report[s]. ..

Figure 4-16: Report Clear Backup Creation Window

If the password you entered was wrong, the reports will not be cleared, and the following
dialog box appears:

F= Reports Mot Cleared

Figure 4-17: Report Clear Password Wrong Dialog Box

Pressing , the report display window closes, and you return to the main TS3
Manager window.
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If the password was correct, the backup name dialog will open, showing the path to the
automatically generated reports backup file:

I Reports Cleared !EI

Reports were backed up ta file:

E:ALabYIE'W YWiorkzhLenoneReporthB ackuphTS3 01 Reports 2008-07-21 194915 pthal

Figure 4-18: Report Clear Backup File Name Dialog Box

Once again, pressing , closes the report display window, and leads you back to
the main TS3 Manager window.

When the reports successfully clear from the TS3 test set memory, you will not be able to
access the report display functions choosing Report => From Device.

If you try to manage reports from the TS3, when no report is stored, you will see the
following dialog box:

[ =]

Mo report found

Figure 4-19: No Report Dialog Box
Pressing , you will automatically return to the TS3 Manager main window.

4.1.5. Generating a Reports Backup

To backup the reports contained in the TS3 test device, from the backup display and
management window, pressing Ctrl-Shift-N or select Backup => New:

File - Feport - JEElSAT]

MEen ChleShit [

Fieport Mr.: Fieport Text:
o 7 AEE SACE T53 =

Figure 4-20: Report Backup New Menu Item
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The report backup download window opens:

I+ Downloading Report(s]... [_[O] <]

Backing Up Report 10 0f 12.

Flease Wait. .

Figure 4-21: Report Backup Download Window
At the end of the download, you can save the backup file using the dialog box:

sovein] 37 SRR

T53 01 Reparts 2008-05-15 12,3035 rpthak
T53 01 Reparts 2008-05-15 19.31. 32 ipthak

File narme; T53 01 Reports 2008-07-21 20.47.39.rpthak)

Save as wpe: |Reparts Backup Files [* rpthak) j Cancel |

Figure 4-22: Report Backup File Save Dialog Window

The TS3 Manager suggests a default file name, with the format
TS3 [Device Id] Reports [yyyy-mm-dd hh:mm:ss].rptbak, where [Device Id] is the device id of
the TS3, and [yyyy-mm-dd hh:mm:ss] is the date and time of the backup, but you can change it
if you prefer.
The filename extension should be maintained as ‘.rptbak’. You can change it, but, if you do it,
the program will not recognize automatically the file as a reports backup one.

Pressing L the backup file is stored to disc.

Pressing ﬂ the task aborts.

Once the reports are stored in a backup file, you can use this file to perform the same
report operations that you can do downloading the test reports directly from a TS3 test set.

This allows you to obtain report text files whenever you need them, even if the reports
stored in the TS3 machine are cleared willingly or by mistake.
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4.2. Report From Backup

You can generate report text files from an existing reports backup file selecting
Report => From Backup from the main window of the TS3 Manager:

Fil: - |GE==d  Communication - Fimware Update - Oplions
From Device

W CACC TCD

Figure 4-23: Report From Backup Main Menu Item
You select the backup file to use in the backup load dialog window:

Select the Reportz Backup file to load

=&l @ sl EE

Look in: I — T=3

T53 01 Reparts 2008-05-15 19.31. 32 ipthak
T53 01 Reparts 2008-07-21 20.41.39.pthak

File narme; ITSS M1 Reportz 2003-05-15 12,30 35 rpthak, ] I

Files of ype: IHepnrts Backup Files [*.rptbak) j Cancel |
&

Figure 4-24: Report Backup Load Dialog Window

. C I . .
Pressing ﬂl you return to the main window.
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If you press LI, the backup management window opens:

ii}] Reports Management [_ O] -]
File - FRepart - Backup

Repart Wi Report Text
o 8 LEE $ACE T33 =
Test Report
= Report Number..........: 16
I T&83 derial Nuwber......: JJ10101355
- T3 Firmware Version...: 1.01
Test Date..............: 15/05/08
RS, ABHNEE o oo o oo o .1 19:30:29
Tested Belay.. ... : AR
! Test Description... JJ AR
Belay Serial Number SLC
Oser Name.......... TUA S0FELLA
Notes.oioeiannneiannnant B
B4
c4
D4
E4
e e I e e 1247 &
[EhAse e n
TEE T P e e N S = s
Stopped B¥........c.0..: Timeout
A (g BUERAE (e ) e OO e 1 p e SR A
|
el el ‘ Repcrts Backp Fied bt %%?ﬂf;ﬁj:ﬁmks@enone\ﬁeport\Backup\TSB\TSB 01 Reports 2008-05-15

Figure 4-25: Report Management Window with Backup File Loaded

When the report management is from a backup file, at the bottom right of the window you
can see the path of the backup file in use:

. E:ALabvIEw Works'"enonehReportB ackuphTS34T53 01 Reports 2003-05-15
Reports Backup File: % 19’3 32 pthak

Figure 4-26: Report Backup File in Use Display Field

The operations you can perform are the same that you can do when the reports are
downloaded directly from a connected TS3 device.
The only exception concerns creating a new backup file, since you cannot download reports
from the TS3 device, while you work with reports backup files.

When you work with backups, you can always open another backup file pressing

Ctrl-Shift-0 or selecting Backup => Open:

File - FReport -

; e B HifEER [

Fieport Mr.: Fieport Text:

’

i L ABE SACE TS3 =

Figure 4-27: Report Backup File Open Menu Item
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4.3.

Report Exiting

1]8

To exit from the report management window, press , or select File => Exit:

- Repart - Backup

T
‘ Fiepart Mr.: Fieport Text:
o 18 ABB SACE T33 =
Figure 4-28: Report Backup File Exit Menu Item
to return to the main TS3 manager window.
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