DigiVis 500 Graphics Builder

Engineering Manual

Version 1.0 SP1
NOTICE

The information in this document is subject to change without notice and should not be construed as a commitment by ABB. ABB assumes no responsibility for any errors that may appear in this document.

In no event shall ABB be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB be liable for incidental or consequential damages arising from use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB, and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license.

Copyright © 2012 ABB
All rights reserved.

Release: January 2012
Document number: 2PAA104345R0201

TRADEMARKS

All rights to copyrights and trademarks reside with their respective owners.
Table of Contents

About This Book
Use of Warning, Caution, Information, and Tip Icons ............................................................. 13
Typographic Conventions ........................................................................................................... 14
Terminology .............................................................................................................................. 14
Related Documentation ........................................................................................................... 14

Section 1 - Project Manager
Starting the Project ................................................................................................................... 15
  Starting DigiVis 500 Graphics Builder .............................................................................. 17
  Operation ............................................................................................................................ 17
  Menu Structure of the Project Manager .......................................................................... 18
Editing Projects ....................................................................................................................... 18
  Status Line ....................................................................................................................... 19
  Creating New Projects ....................................................................................................... 20
  General Information on the Project ................................................................................ 20
  Open a Project ................................................................................................................... 24
  Hard Disk Memory Requirements ...................................................................................... 25
  Exporting a Project ............................................................................................................. 25
  Exporting a Backup ............................................................................................................ 25
  Importing a Project ............................................................................................................. 27
  Import Backup ................................................................................................................... 27
  Closing the Project ............................................................................................................. 29
  Saving a Project ................................................................................................................ 29
  Save Project As .................................................................................................................. 30
  Deleting a Project .............................................................................................................. 30
  Editing the Project Header ................................................................................................. 30
  Editing a Project Comment ............................................................................................... 31
# Table of Contents

- Setting up an Online Connection ................................................................. 31
- Releasing an Online Connection ................................................................. 31
- Exiting DigiVis 500 Graphics Builder .......................................................... 31

## Project Management Options ................................................................. 32
- Run Security Lock ....................................................................................... 32
- Tag Names .................................................................................................. 33

## Miscellaneous ......................................................................................... 35
- DigiVis 500 Graphics Builder Version ......................................................... 35
- Monitoring of Data Base Errors ................................................................. 35

## Toolbar Buttons ....................................................................................... 35

## Section 2 - Project Tree

### Structure of the Project Tree ................................................................. 39
- Status Line ................................................................................................. 40
- Menu Structure of the Project Tree in Configuration Mode ..................... 40
- Project Objects ......................................................................................... 43

### Configuring the Project Tree ................................................................. 45
- Inserting Project Objects ........................................................................... 47
- Assigning Project Object Names ............................................................... 47
- Searching in the Project Tree .................................................................... 47
- Expand, Full expand, Compress ............................................................... 48
- Moving, Deleting Objects ......................................................................... 48
- Undo ......................................................................................................... 51
- Exporting and Importing blocks ............................................................... 51
- Pool for Unneeded Objects ...................................................................... 52
- Access Rights and User Groups ............................................................... 53
- Display Target Stations ............................................................................ 55
- Area Definition ......................................................................................... 56

### Configuring the Project Objects ............................................................ 57
- Configuration (CONF) ................................................................................ 57
- Configuring the Communication Links ..................................................... 59
- Resources ................................................................................................ 60
- Operator Station D-OS ............................................................................. 60
Table of Contents

OPC Server (OPC-S) ........................................................................................................ 63
OPC Regular Patterns (Configure Pattern) ................................................................. 69
Common Display Pool P-CD ..................................................................................... 70
Programs on the Operator Station: Displays, Reports and Logs ............................ 71
Structure Node (STRUCT) ......................................................................................... 72
Pool of Graphic Macros (P-MAC) ............................................................................. 72
Macro Structure Nodes (STRUCT) ........................................................................... 72
Graphic Macros (MAC) .............................................................................................. 72
General Functions of the Project Tree ....................................................................... 73
Documentation ........................................................................................................... 73
Check, Check all ......................................................................................................... 74
Show Error List ........................................................................................................... 77
Object Header ............................................................................................................. 77
Comments on a Project Object .................................................................................. 77
Network ....................................................................................................................... 78
Project Tree Options ................................................................................................ 78
Long or Short Form in the Status Line ..................................................................... 78
Colors in the Project Tree .......................................................................................... 79
Initial Filter for Variable and Tag List ....................................................................... 79

**Section 3 - Commissioning**

Starting Commissioning .......................................................................................... 82
Commissioning Procedure ....................................................................................... 83
Switching Between Commissioning and Configuration ......................................... 84
Faster switch from Commissioning to Configuration Mode ..................................... 86
Commissioning User Interface ................................................................................ 86
Differences between Commissioning and Configuration modes .............................. 87
State Displays in the Project Tree ............................................................................. 89
Representation of the Side Effects Caused by Configuration Changes ................... 89
Project Version .......................................................................................................... 90
Time Settings ............................................................................................................ 93
Loading the Project ................................................................................................. 95
Load Whole Station ................................................................................................. 95
Table of Contents

Load Message Configuration................................................................. 96
Load Selected Objects ........................................................................... 96
Load Changed Objects .......................................................................... 96
Display of Changes in the Project Tree .................................................. 97
Displaying and Writing Values in a Window .......................................... 97
Enter Variable ...................................................................................... 100
Show Value Window ............................................................................ 104
Show Trend Window ............................................................................ 105
Writing a Value .................................................................................... 106

Section 4 - Documentation

Documentation Manager ........................................................................ 109
Changing the Column Width ............................................................... 110
Menu Structure Documentation .......................................................... 110
Documentation ..................................................................................... 111
Compilation of the Drawing Header / Footer ....................................... 114
Project-Wide Drawing Header / Footer ................................................. 114
Program-Specific Drawing Header / Footer .......................................... 119
Automatic Allocation of Object Parameters ....................................... 120
Bitmaps in the Drawing Footer ........................................................... 120
Define the Documentation Job ............................................................. 121
Detail of the Print Job ........................................................................... 122
Documentation Scope ........................................................................... 138
Viewing Selected Documentation Scope ............................................. 138
Sorting the Output ................................................................................ 138
Selecting the Project Tree Objects ....................................................... 139
Selecting Notify Print Errors .............................................................. 140
Printing Documentation ........................................................................ 140
Print File .............................................................................................. 141
Printer Setup ...................................................................................... 143
Comment Field Editing ........................................................................ 144
Export Comment Field ........................................................................ 144
Import Comment Field ....................................................................... 145
Table of Contents

Tables

Description of the Fields or Contents

Field Names in the Drawing Footer / Header

Variables for Drawing Footer/ Header Inscriptions

Fonts, National Languages and Bitmaps in the Drawing Footer / Header

Presetting the Field Contents and Titles

Section 5 - OPC Items

Calling up the OPC Item List

Structure of the OPC Item List

Context Menu

Editing OPC Item List

Synchronize

Filtering of OPC Item List

Sorting of OPC Item List

Assign Variable

Standard Library of Tag Types

Tag Instantiation

Instantiate All

Section 6 - Reports

General Description of Reports

Excel Reports Configuration

Defining Excel Report Template

Execute Reports in DigiVis 500 Operations

Section 7 - Variables

Overview of simple data types

String data types

Calling up the variable list

Structure of variable list

Menu structure variable list

Editing variable list
Table of Contents

Exit .......................................................................................................................... 208
Search in variable list .............................................................................................. 208
  Define search criteria .............................................................................................. 209
Edit list entries ........................................................................................................ 210
  Undo ......................................................................................................................... 211
  Insert new variable in list ......................................................................................... 211
  Edit a field in the list .............................................................................................. 212
  Delete field ............................................................................................................. 213
  Delete unused variables .......................................................................................... 213
System .................................................................................................................. 214
Cross-references ..................................................................................................... 214
Options .................................................................................................................. 215
  Adjust colors ............................................................................................................ 215
  Save column settings ............................................................................................ 215
Back ....................................................................................................................... 215

Section 8 - Tags
  Calling Tag List ........................................................................................................ 218
  Structure of Tag List ................................................................................................ 218
  Menu Tag list .......................................................................................................... 220
  Changing tag list entries .......................................................................................... 220
Editing the Tag List .................................................................................................. 221
  Normal view and station view .................................................................................. 221
  Exit ......................................................................................................................... 222
Searching in the Tag List .......................................................................................... 223
  Define search criteria .............................................................................................. 223
Editing tag list entries ............................................................................................. 225
  Undo ......................................................................................................................... 226
  Insert new tag ......................................................................................................... 226
  Edit field ................................................................................................................. 227
  Delete field ............................................................................................................. 228
  Delete unused tags ............................................................................................... 228
  Station access .................................................................................................... 233
Table of Contents

Plant areas ................................................................................................................................. 234
System ........................................................................................................................................ 235
Cross references ....................................................................................................................... 235
Options ........................................................................................................................................ 236
  Set colors .................................................................................................................................. 237
  Save column settings .............................................................................................................. 237
Back ............................................................................................................................................ 237

Section 9 - Messages
  Display of the Message Line During Operation ...................................................................... 239
  Components of the Message List ............................................................................................. 242
Message Types .......................................................................................................................... 243
  Priority Levels .......................................................................................................................... 243
Acknowledgment of Messages .................................................................................................... 244
  Filtering Messages .................................................................................................................... 245
Acoustic Messages and Control Room Horn ............................................................................... 245
  Acknowledgment in the Control Room ..................................................................................... 246
Local Message Processing ........................................................................................................... 246
  Display Tab .............................................................................................................................. 248
  Filter Tab ................................................................................................................................ 251
  Control Room Horn Tab ............................................................................................................. 252

Section 10 - Standard Displays
  Automatic Display Allocation .................................................................................................... 256
  Call up the Display Access ....................................................................................................... 256
  Structure of the Parameter Definition Mask – Display Access ................................................. 257
  Display Access Editor ............................................................................................................... 257
Overview Display ....................................................................................................................... 259
  Create a New Overview Display ............................................................................................... 260
  Overview Display Configuration ............................................................................................... 260
Group Display ............................................................................................................................ 262
  Create a New Group Display .................................................................................................... 263
  Group Display Configuration .................................................................................................... 263
# Table of Contents

Trend Display ............................................................................................................................. 264
  Create a New Trend Display ........................................................................................................ 265
  Trend Display Configuration ......................................................................................................... 265
  WEB Display Configuration ......................................................................................................... 275

**Section 11 - Graphic Display**

Graphic Editor Interface ............................................................................................................. 278
  Additional Features of the Graphic Editor .................................................................................. 279
  Menu Line .................................................................................................................................... 280
  Draw Area .................................................................................................................................... 281
  Toolbox ....................................................................................................................................... 281
  Status Line .................................................................................................................................. 283

Basic Settings for the Draw Area .................................................................................................. 283
  Hardcopy .................................................................................................................................... 283
  Snap / Grid ................................................................................................................................. 284
  Toolbox ....................................................................................................................................... 284
  Limiting the Draw Area ............................................................................................................... 285
  Update Display Size ................................................................................................................... 285
  Threaded Cursor ......................................................................................................................... 285
  Background Color ...................................................................................................................... 285
  Color Selection ........................................................................................................................... 286

Drawing Static Graphic Objects .................................................................................................... 287
  Line ........................................................................................................................................... 289
  Rectangle .................................................................................................................................... 289
  Polyline ....................................................................................................................................... 290
  Polygon ....................................................................................................................................... 291
  Ellipse ......................................................................................................................................... 291
  Text ............................................................................................................................................ 292
  Arc ............................................................................................................................................... 293
  Circle Segment ........................................................................................................................... 294
  Bitmap ......................................................................................................................................... 295

Animate, Dynamic Graphic Objects ............................................................................................. 296
  Creating a Dynamic Graphic Object ............................................................................................ 298
Delete Dynamic Graphic Objects ............................................................... 298
Moving and Sizing of Dynamic Objects ..................................................... 298
General Parameters for Dynamic Graphic Objects ................................ 298
Tab: Process Value .................................................................................. 300
Tab: Scale ............................................................................................... 301
Tab: Bit allocation .................................................................................. 302
Tab: Display ............................................................................................ 304
Tab: General ................................................................................................ 307
Configuring an Action ........................................................................... 308
Write Variable Operation ......................................................................... 314
Selection of Messages ............................................................................. 321
Tab: Tooltip ............................................................................................. 323
Tab: Positions (only for graphic symbol) .................................................. 324
Bar graph ................................................................................................ 325
Fill area ................................................................................................... 327
Alphanumeric Display ............................................................................ 328
Graphic Symbol ...................................................................................... 333
Self-Animated Object .............................................................................. 335
Trend Window ........................................................................................ 336
Selection Area ........................................................................................ 341
Button, Button Field, Radio Button ....................................................... 342
Tab Control ............................................................................................. 349
List of the Dynamic Objects in a Graphic Display ................................ 350
Reedit ...................................................................................................... 350
Reediting Allocated Static Objects ......................................................... 351
Macro ....................................................................................................... 352
Library Functions .................................................................................... 353
Draw Macro ............................................................................................ 354
Create Macro .......................................................................................... 355
Edit Macro ............................................................................................... 355
Define Macro Parameters ......................................................................... 355
Specifying Parameters for a Macro Instance ......................................... 360
Table of Contents

Resolve Macro .............................................................................................................................. 361
Macro: Resolve all Layers ........................................................................................................... 361

Editing and Changing Display Objects .......................................................................................... 362
Move a Graphic Object using the Mouse ......................................................................................... 363
Move a Graphic Object using the keyboard ..................................................................................... 363
Selecting Multiple Graphic Objects ................................................................................................. 363
Edit ................................................................................................................................................. 365
Change Attributes ......................................................................................................................... 372

Display Options for Graphics in the Draw Area ............................................................................. 378
View ................................................................................................................................................ 378
Simulation ....................................................................................................................................... 378
Redraw ............................................................................................................................................. 379
Zoom ................................................................................................................................................ 379
Visible region .................................................................................................................................. 379

General Handling Functions .......................................................................................................... 380
Save ................................................................................................................................................ 380
Plausibility check .............................................................................................................................. 380
Export to a file ................................................................................................................................ 381
Export to clipboard as a bitmap ........................................................................................................ 381
Import ............................................................................................................................................... 381
Exit the graphic editor ...................................................................................................................... 384
Copy, Rename and Delete Graphic Displays .................................................................................. 384

Appendix - Color Tables ............................................................................................................... 384
Appendix - Graphic Macro Library ................................................................................................. 389

Section 12 - Logs
Event Logs ....................................................................................................................................... 403
State Logs ........................................................................................................................................ 403
Logs in an Operator Station ............................................................................................................. 403
Signal Sequence Log ....................................................................................................................... 404
Construct Signal Sequence Log ...................................................................................................... 404
Signal Sequence Log Configuration ................................................................................................. 404
General Data Tab - Signal Sequence Log 1 and N ........................................................................... 405
## Table of Contents

Logs Tab – Signal Sequence Log 1 and N .............................................................. 407
Format Tab – Signal Sequence Log 1 and N.......................................................... 409
Data Export Tab – Signal Sequence Log 1 and N................................................... 411
Operation Log ........................................................................................................... 414
  Construct Operation Log ....................................................................................... 414
  Operation Log Configuration ................................................................................ 415
Text Layout on Parameter Definition Mask – Operation Log................................. 417
Printing Tab - Operation Log .................................................................................. 419
File Transfer Tab – Operation Log.......................................................................... 420
Header and Footer Lines in Logs ............................................................................. 421

### Section 13 - DigiBrowse

DigiBrowse - General Description ........................................................................... 423
DigiBrowse Installation ............................................................................................ 423
  Starting DigiBrowse ............................................................................................. 424
  Requirements for receiving data through FTP Export ............................................. 424
Menu Structure DigiBrowse .................................................................................... 425
Call-up of the DigiBrowse Archive Manager ............................................................ 427
Archive Display ....................................................................................................... 427
Editing Files ............................................................................................................ 436
General Settings ..................................................................................................... 438
Window Settings ..................................................................................................... 439

### Appendix A - Glossary

Index
Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Use of Warning, Caution, Information, and Tip Icons

This publication includes **Warning**, **Caution**, and **Information** where appropriate to point out safety related or other important information. It also includes **Tip** to point out useful hints to the reader. The corresponding symbols should be interpreted as follows:

- Electrical warning icon indicates the presence of a hazard which could result in *electrical shock*.

- Warning icon indicates the presence of a hazard which could result in *personal injury*.

- Caution icon indicates important information or warning related to the concept discussed in the text. It might indicate the presence of a hazard which could result in *corruption of software or damage to equipment/property*.

- Information icon alerts the reader to pertinent facts and conditions.

- Tip icon indicates advice on, for example, how to design your project or how to use a certain function.

Although **Warning** hazards are related to personal injury, and **Caution** hazards are associated with equipment or property damage, it should be understood that operation of damaged equipment could, under certain operational conditions, result in degraded process performance leading to personal injury or death. Therefore, comply fully with all **Warning** and **Caution** notices.
Typographic Conventions

All text entries, shortcuts, prompts, system messages, menu items, screen elements and so on, comply with the Microsoft Windows conventions.

Terminology

You will find a complete and comprehensive glossary at the end of this Manual. This glossary contains terms and abbreviations that are unique to ABB or have a usage or definition that is different from standard industry usage. Please make yourself familiar with the glossary.

Related Documentation

The following list gives an overview of the documentation relating to the DigiVis 500 system.

<table>
<thead>
<tr>
<th>Title</th>
<th>Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting Started</td>
<td>2PAA104347R0203</td>
</tr>
<tr>
<td>Operators Manual, DigiVis 500 Operations</td>
<td>2PAA104346R0201</td>
</tr>
</tbody>
</table>

The manuals listed above are for the DigiVis 500 system only. These manuals should be supplemented by the AC500 related documentation (PS501 CD, Documentation).
Section 1  Project Manager

General Description of Project Management

Project management is started through the dialog in the DigiVis 500 Graphics Builder software application.

DigiVis 500 Graphics Builder is the tool for configuring, commissioning and documenting the user programs and displays in a DigiVis 500 system.

The system configuration is saved as a project file and is located in a preset project directory. To process a project, you must first open a project file. You then have unrestricted access to all project data within the project file.

The project name and file name of the project file can be selected independently from one another.

From the Project Manager function, you can save, rename or delete projects. The actual configuration and commissioning of the project takes place in the project tree which you can access from the Configuration! or Commissioning! menus.

The documentation of the project takes place in the project tree through menu Project > Documentation. If there is an old project which you can use to base a new project on, it can be imported into the current database. You can also import project parts. For more information, refer to Section 2, Project Tree.

Starting the Project

The DigiVis 500 Graphics Builder is launched under Windows from the corresponding program group.

Start > Programs > ABB Industrial IT > DigiVis 500 > Graphics Builder
Once the program has finished loading, the About box is displayed. This window can also be called at any time from the menu Help > About.

XXX is the latest version of the released build. For latest version number, refer to DigiVis 500 Release Notes.

**Demo Mode**

A hard key is required in order to work with DigiVis 500 Graphics Builder. This enables you to use the functions of DigiVis 500 Graphics Builder and/or DigiVis 500 Operations as per your order.

DigiVis 500 Graphics Builder passes automatically to demo mode if no hard key has been found. Demo mode runs for 100 days and may be used for evaluation and presentation purposes only. During this time, all kinds of operations such as save, export and so on, are allowed. At the end of this period the software stops functioning, and if necessary it can be reinstalled.

Without hard key the usage of this software is not allowed for professional purposes.
Starting DigiVis 500 Graphics Builder

Once DigiVis 500 Graphics Builder has been called, the project management module is reached by clicking > **OK**. New projects can be created here, and existing projects can be called up, saved or deleted.

**Operation**

DigiVis 500 Graphics Builder provides all the functions required for creating, editing and commissioning a project. The menu allows the operator to select the various project processing options.

All operator actions may be carried out by means of mouse or keyboard. For mouse operation the most important and frequently-needed functions are also made available through toolbars and shortcut menus. The buttons on the toolbar as well as the contents of the shortcut menus are dependent on the current state of project processing.

The toolbar buttons are used to initiate general (for example, object-independent functions), while the functions on the shortcut menu relate to the object currently being processed. The shortcut menu is called up with a single click of the right mouse button. For an explanation of the button symbols, refer to **Toolbar Buttons** on page 35.
Menu Structure of the Project Manager

Project [Menu]
- Export
- Export Backup
- Close
- Save
- Save As
- Delete
- Header
- Comment
- Online
- Offline
- Exit

Configuration!
Commissioning!
Options
- Login (Security Lock)
- Logout (Security Lock)
- Change password (Security Lock)
- Run Security Lock (Security Lock)
- TagNames
- Start Diagnostic Server*
- Stop Diagnostic Server*

Help
- Contents
- Overview
- About

* - To be used only by authorized L3 support personnel. Do not use these options unless asked to do so.

Editing Projects

DigiVis 500 Graphics Builder can be run in two different operating modes. The first mode is Configuration in which you can structure, configure and document the project. Configuration can be processed off-line. This means that no control system needs to be connected to configure all the project objects. The hardware can be ordered later or can be already installed while the user program is still being
configured. The second mode is **Commissioning**. When selecting **Commissioning**! a connection is automatically set up to the process and operator stations through the system bus. Also refer to **Section 2, Project Tree**.

**Status Line**

Depending on the user interface, the **status line** displays the following information:

- Path of the selected project Eg. [C:\Program Files\ABB Industrial IT\DigiVis 500\proj,project:ojal2017_13_11_2008]
- User or responsible operator logged into DigiVis 500 Graphics Builder. If Security Lock is not installed, the display **NOLOCK** appears.
Creating New Projects

> Project > New

A file name (max. 256 characters) should be specified in the Create project window. The system adds the extension .pro. The previously active directory is called. The default directory for projects on the hard disk is \<DigiVis 500_Installation_Folder>\proj.

Through > Save the project file will be created and the project header will be called up.

General Information on the Project

Once a project has been created, the operator is prompted to enter general project parameters in a dialog, the project header. These details will later be printed in the project documentation in the drawing header/footer of a sheet.

For more information, refer to Section 4, Documentation.
Enter the following information which will apply to the entire project:

**Project name**  Max. 12 characters, the project name need not be the same as the name of the project file (.pro)

You can only change the file name if you select > **Save As**.

**Project manager**  name, max. 27 characters

**Project no.**  max. 6 characters

**Project orderer**  max. 27 characters

**Project order no.**  max. 12 characters

**Project password**  The password must contain at least 4 but no more than 8 characters. The password can be modified using the **Change** button. In order to reopen the project enter the correct password.
Auto Backup Config

Opens the configuration dialog for Automatic backup of project.

Project size

The current size of the project file (*.pro) is displayed in kBytes.

Version

The project creation date is displayed.

Project comment

max. 34 characters

Edit drawing header / footer

Assign specific system variables (F2) to the boxes in the drawing header or footer. Refer to Section 4, Documentation.

Edit header / footer titles

Here you can change the titles in the drawing headers or footers of each window. Refer to Section 4, Documentation.

OK

Saves all entries in the database. The dialog box closes.

Cancel

Closes the dialog box without saving any entries.

Configuring Automatic Backup

Project > Header > Auto Backup Config
In the dialog box that opens, select one of the operator stations configured in the project or enter the IP address of an external PC where the backup of a project file should be located.

If no operator station is configured in the project, add a D-OS (Operator Station) resource in the project tree.

**Perform backup automatically on every save**

- [ ] Backup is performed automatically as per Configured Backup on every save
- [ ] The System displays the following Message Box on every save.

Yes:
Backup of the project will be taken
No:
No Backup will be taken.

**Configure Backup > OK**

Project file is saved in compressed form on the operator station in the `<DigiVis 500_Installation_Folder>\proj` under the file name `filename.zip` or on the FTP Server (Microsoft Peer Web Services), corresponding to the home directory and path.

**Open a Project**

> Project > Open

Select a file name from the *Open Project* window and confirm by choosing the *OK* button. Access to the directory is defaulted during installation. The directory you selected previously is called. The default directory for projects on the hard disk is `<DigiVis 500_Installation_Folder>\proj`.

When you open a project, the project file (.PRO), a file with the extension .LOG and a file with the extension .BAK are all created.

The file with the extension .LOG is a temporary file, in which the steps of a project work session are logged. Its purpose is to prevent the loss of changes made to the project during a session if Windows should crash. If this happens, you can restore the database after you restart DigiVis 500 Graphics Builder and reproduce the state at the time of the crash. The file with the extension .BAK is a compressed backup file of the saved project file. When you exit DigiVis 500 Graphics Builder and you select No from the *Save* menu item, the file is expanded and the extension .BAK is replaced by the extension .PRO.

The temporary project file with the extension .LOG increases incrementally with every change in the project and is only reset to zero Kbytes when the project is saved.
Hard Disk Memory Requirements

During a session on an open project, there are three files open: the project file (.PRO), a temporary project file (.LOG) and a backup file (.BAK).

The project file size is dependent on the size of the project and quickly reaches several 10 Mbytes of space requirements on your hard disk.

We recommend at least five times the file size of a plausible project for the temporary requirements of free hard disk space.
A project which has been subjected to a plausibility check is about three times larger than the one which has not.

Exporting a Project

> Project > Export

This function exports the entire content of the current project to a file. As file format is to be selected Unicode export file (*.csv). A csv file can then be reloaded using Import. You can assign a file name in the “Project Export” window that is opened.

Access to the directory is by default. The previously active directory is called. The default directory for export files is the <DigiVis 500_Installation_Folder>\export.

Where possible, only plausible projects should be exported. Only thus can it be ensured that all data are correct and consistent.

Exporting a Backup

You can save an additional project file to an operator station or through FTP export on an IP address in order to have a backup on the running machine. If necessary, maintenance personnel can access the backup.

> Project > Export backup
In the list box that opens, select one of the operator stations configured in the project or in the window enter the IP address of an external PC where the backup of a project file should be located.

If no operator station is configured yet in the project, add a D-OS resource in the project tree.

Choose the OK button to set up an on-line connection automatically to transfer the project over the system bus to the operator station. The project file is then saved in compressed form on the operator station in the `<DigiVis 500 _Installation_Folder>\proj` under the file name `Backup.zip`, or on the FTP Server (Microsoft Peer Web Services), corresponding to the home directory and path.
Importing a Project

> Project > Import

This function imports the content of a project from a csv file previously generated with Export. The new project name is first displayed in the window. You can then save the project under this project name after the import routine has ended. When you confirm the file name of your choice, another window opens from which you can select the csv file you want from a directory of your choice.

Access to the import directory is by default. The previously active directory is called. The default directory for import files on the hard disk is <DigiVis 500_Installation_Folder>\export.

Any changes in the .csv file are not released and could possibly destroy your project database.

Import Backup

If you have no updated project file on the engineering station, you have the option of importing a backup of the project file.

> Project > Import backup

One condition for an import is that a backup was already exported to an operator station or that a backup file with the name Backup.zip exported through FTP-Export is located in the <DigiVis 500_Installation_Folder>\export. No projects are allowed to be open. Any open projects must be closed before the import commences.
In the window, enter resource ID and IP address of the operator station where the project file backup is located.

> OK

An on-line connection is automatically established and the project is transferred from the corresponding station through the system bus. The project file has been saved in compressed form under the file name Backup.zip in the <DigiVis 500_Installation_Folder>\export.

The IP address is part of the TCP/IP installation and can be changed under Windows XP/Windows 7 Professional SP1, 32-bit in the properties dialog, “Internet log (TCP/IP)” of the network adapter (Control panel > Network connections). The resource ID is assigned during DigiVis 500 Operation setup and may be changed through the program group ABB Industrial IT >DigiVis 500 >Configure.

Windows 7 Professional SP1, 32-bit is referred to as Windows 7 throughout the Engineering Manual.
## Closing the Project

> Project > Close

If you have made any changes to the project, you are normally asked whether you want to save these changes. If the Backup is not configured then the system displays a message asking the user if a backup should be created or not (refer to Exporting a Backup on page 25).

**Yes** Saves and closes an open project. The project file (.pro) is updated, and the temporary file (.log) and the backup file (.bak) are closed. The DigiVis 500 Graphics Builder user interface is then available for further projects.

**No** All changes made during the entire session are rejected. The backup file (.bak) is expanded and overwrites the project file (.pro)

**Cancel** Returns to the Project Manager

## Saving a Project

> Project > Save

When you select the Save command without giving any further instructions, you save all the changes which you have made after opening the project with Open. This includes the plausibility checks on project objects, loading the objects to a station or changing a configuration. The default directory for projects is the `<DigiVis 500_Installation_Folder>\proj`. The project remains open and can be edited.

The save function resets the temporary file (.LOG) and deallocates storage.
Save Project As

If you want to change the project name, use the Save As... command.

- It is possible to change the file name of a project (for example, in the File Manager). The project name continues to exist and can be changed in the project header.

  > Project > Save As

Select a file name from the Save Project as window and confirm by choosing the OK button. Access to the directory is by default. The previously active directory is called. The default directory for projects is the `<DigiVis 500_Installation_Folder>\proj`.

Deleting a Project

- > Project > Delete

When you choose the OK button, all the files associated with the project are deleted. The only exceptions are the files created using the Export or Export block commands.

Editing the Project Header

The project header contains general information on the project which can be output with the project documentation.

- Select Project Manager > Project > Header

The window Configuration: Project Parameters opens. The project size is also displayed in Kbytes as well as the date of creation and date when last saved. Refer to General Information on the Project on page 20. For the items referring to drawing header and footer, refer to Section 4, Documentation.

The window contains the data that was entered while creating the new project.
Editing a Project Comment

Select **Project Object > Project > Comment**

Use the Comment editor to create or modify a free text for the project, to import this text, or to output it as a hardcopy. Additionally, it is possible to import and export Unicode TXT files.

To Export or Import comments for the project

Select **Edit-- > Export / Import**

Setting up an Online Connection

When setting up an online connection, you set up a communication link to the connected stations through the system bus.

The connection is automatically dialed when the function **Commissioning** is executed.

Releasing an Online Connection

When you release the online connection, the communication link to the connected stations is released through the system bus.

Exiting DigiVis 500 Graphics Builder

> **Project** > **Exit** > **Save changes** > **OK**

When you confirm this command, the open project is saved and closed. The project file is saved and DigiVis 500 Graphics Builder is terminated, and the system returns to the Windows User Interface.
Project Management Options

Using the menu item Options you can call up the following commands:

- Login
- Logout
- Change password
- Run Security Lock
- Tag names
- Allow DigiVis write access on version error
- Start Diagnostic Server
- Stop Diagnostic Server

Run Security Lock

Security Lock is an add-on package for DigiVis 500 Graphics Builder or DigiVis 500 Operations to permit the assignment of user rights and the definition of user groups.

Group specific rights can be awarded to the user groups for:

- Configuration
- Commissioning
- Operator interventions.

Every user identifies herself/himself by a password, which can be changed by her/him only.

If Security Lock is installed on an engineering station, the user must enter her/his password before starting to edit or modify a project.

In the project tree, access rights edit or modify can be awarded to individual or several project objects simultaneously in an operator station. This will determine whether a DigiVis 500 Operations user may only view or also operate the specified displays. The same applies to logs or trend displays.
In the same way as displays and logs, access rights can be awarded to tag names in the tag list.

After installing Security Lock, you must first log in before you can work using DigiVis 500 Graphics Builder or DigiVis 500 Operations.

As long as no user has logged in, the rights assigned to the guest group are activated. Standard users are:

- **NOLOCK**
  - No license for Security Lock

- **Guest**
  - No one has logged in (for example, on starting DigiVis 500 Operations)

- **System**
  - Operator action by system (may appear in log)

The **Login**, **Logout**, **Execute Security Lock** and **Change Password** actions can be recorded in the logbook file under DigiVis 500 Graphics Builder. The **Login**, **Logout**, and **Change Password** menu options can only be executed if Security Lock has been installed.

Refer to **DigiVis 500 Engineering Manual, Security Lock**.

---

**Tag Names**

> Options > Tag names

The syntax check in a project does not permit a tag name to start with a number (according to IEC 61131-3). In certain process sectors (for example, in the power generation sector), this regulation may be bypassed.

Special characters (! § $ % & / ( ) = ? £ ß { } \ ’ # + ~ - _ . : ; |) and umlauts can be used in tag names only if check for IEC conform names is deactivated through **Options > Tag names**.
Strict tag names

Error on violation

- All tag names must conform to the IEC naming conventions (defaults).

Warning on violation

- Names that do not conform to IEC conventions are allowed, but a warning is issued.

Ignore violation

- Tag names are not checked.
  The setting chosen is stored both in the project database and the CSV export file. This ensures that the same name checking procedure is used each time a project is either opened or imported (for example, to a different DigiVis 500 Graphics Builder PC).

Name length

12 / 16 Characters

The length of tag names can either be 12 characters or 16 characters. Without this adjustment the names have to be changed manually to get the project checked.

Cutting long names

at start / at end

If there is not enough space for displaying the whole tag name the name is cut in the display. The complete name can be shown by using the ToolTip.

Start and Stop Diagnostic Server

These options are to be used only by L3 support personnel.
Miscellaneous

DigiVis 500 Graphics Builder Version

Using the menu option Help > About the window described in Starting the Project on page 15 can be opened.

Monitoring of Data Base Errors

While you work with DigiVis 500 Graphics Builder, the database is constantly monitored. Once a problem has been detected, the user is immediately asked to close the project. Thus, except for a few changes, the database can be restored.

Toolbar Buttons

- Change to configuration mode
- Change to commissioning mode
- Check selected object with all accompanying sub objects
- List all check messages of selected object and the accompanying sub objects
- Save current project or project part momentarily being edited or modified.
- Export current project
- Call online help system
- Edit the general data (header data) of the selected object
- Call up the variable list
- Call up the tag list
- Define search criteria in variable list or tag list
- Sort variable list or tag list
- Activate filter
- Back to the program from which the current program has been called
Hardcopy the monitor content
Show values window
Show trend window
Define Debug windows
Insert a new object above the selected object
Insert a new object below the selected object
Insert a new object into the next hierarchical level
Offline
Load changed objects into selected station
Show all cross references of selected variable or tag
Toggle display of drawing grid
Select all graphic objects of the graphic display
Return to the parameter mask of the dynamic graphic object
Change between graphic display and graphic pool
Call up the library functions for graphic macros
Edit a graphic macro
Section 2  Project Tree

General Description - Project Tree

The project tree provides an overview of the project objects in a project. The individual elements or objects are known as project objects.

The uppermost element in a project is the Configuration CONF, which is the sum of all project objects in a DigiVis 500 system.

The first structural level below configuration is formed by the resources, which represent the various different stations in a project. For the operation and observation of the process there are the D-OS (Operator station) resources, for integrating data from external systems there are OPC-S (OPC Server) resources and for hosting all tag types there are Tag Libraries.

Each OPC Server is equipped with 10 connections for data exchange with operator stations.

There are also additional structural elements such as the Graphic macro pool P-MAC and the Common display pool P-CD.

According to the different tasks of these resources, additional project objects are available on the next levels for configuration:

**Operator stations D-OS**

For operation and observation of the process, the D-OS resources can be selected for the operator stations using the DigiVis 500 Graphics Builder software, Standard operating facilities (for example, faceplates), are provided for all known tags and variables on the operator stations. In addition, graphic displays, trend displays, reports and logs can be configured and structured for the DigiVis 500 operator stations.
OPC-Server OPC-S

Configuration of an **OPC-Server OPC-S resource** in the project tree enables data to be integrated into a DigiVis 500 system.

**Tag Library**

The **Tag library (TAG-LIB)** node in the project tree is located below the configuration (CONF) node. The Tag Types are arranged in the **Tag Library** node in the project tree. The user has to import the standard Tag Type Library that is delivered with DigiVis 500 system.

**Common Display Pool P-CD**

Displays and logs set up under this project object should in principle be available on all DigiVis 500 operator stations. In fact the objects from the display pool are loaded only on those stations that have also been granted access to the process data needed in these displays, reports and logs.

**Graphic Macro Pool P-MAC**

Below this element all graphic macros are defined that can be used in the graphic display.

**Project Pool**

Alongside the DigiVis 500 Graphics Builder project there is a project object **POOL**. This project pool can be used to temporarily store any project components as required. Any unchecked or unneeded configurations can be stored here and then completed or re-integrated into the project at a later point in time.

All the project objects are represented in a tree structure. A node is shown in front of each object. The color of the nodes is used to represent their processing state, and branches can also be recognized from the symbols. Sections of the project tree can be compressed as required, and this allows the overall structure to remain clear even in sizeable projects.

The DigiVis 500 Graphics Builder contains two project processing states, **Configuration** and **Commissioning**. During configuration there must be no link in existence to the stations in the project. When switching to commissioning, a network link is established to all configured stations. The configured and plausibility-checked user programs can be downloaded from the project tree to all connected operator stations.
The import and export functions that have been implemented can be used to exchange parts of the configuration with other projects. Checks are carried out when importing whole and part projects to ensure that all the labels within a project are unique.

If you want to award different user rights to various user groups to operate or configure the projects, Security Lock allows you to do this. Security Lock is an add-on package for both DigiVis 500 Graphics Builder as well as DigiVis 500 Operations. Refer to DigiVis 500 Engineering Manual, Security Lock.
Status Line

- Depending on the user interface, the status line displays the following information:
- Selected object in short or long form
- User or responsible operator logged into DigiVis 500 Graphics Builder. If Security Lock is not installed, the display NOLOCK appears.

Menu Structure of the Project Tree in Configuration Mode

All descriptions below refer to the configuration mode.

<table>
<thead>
<tr>
<th>Project</th>
<th>Save</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Documentation</td>
</tr>
<tr>
<td></td>
<td>Check</td>
</tr>
<tr>
<td></td>
<td>Check all</td>
</tr>
<tr>
<td></td>
<td>Show error list</td>
</tr>
<tr>
<td></td>
<td>Header</td>
</tr>
<tr>
<td></td>
<td>Comment</td>
</tr>
<tr>
<td></td>
<td>Network</td>
</tr>
<tr>
<td></td>
<td>Commissioning</td>
</tr>
<tr>
<td></td>
<td>Exit</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Search</th>
<th>Undo</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Program</td>
</tr>
<tr>
<td></td>
<td>Insert above, Insert below, Insert next level</td>
</tr>
<tr>
<td></td>
<td>Expand, Full expand, Compress, Cut, Copy, Paste, Delete</td>
</tr>
<tr>
<td></td>
<td>Export block, Import block</td>
</tr>
<tr>
<td></td>
<td>Access rights (only on Security Lock), User groups (only on Security Lock)</td>
</tr>
<tr>
<td></td>
<td>Display target station</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>System</th>
<th>Variable list</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tag list</td>
</tr>
<tr>
<td></td>
<td>Local message processing</td>
</tr>
<tr>
<td></td>
<td>Display access</td>
</tr>
<tr>
<td></td>
<td>Communication configuration</td>
</tr>
</tbody>
</table>
Display of Project Object States

The following states which are generated by subjecting them to a plausibility check can be detected by displaying the nodes of the individual project objects.

- The path is closed; there are no more branches.
- The path is open.
- The path is closed; there are side effects below the displayed level.
- There are no more branches.
- (Pink) Object has been changed; a plausibility check has not yet been performed or errors were found during the plausibility check.
- Path with arrow: During the plausibility check, objects modified compared to the previous configuration state were detected.
- (Flooded green) Plausibility check completed correctly.

<table>
<thead>
<tr>
<th>Area definition</th>
<th>Show all objects</th>
<th>Show selected objects</th>
<th>OPC Item List</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options</td>
<td>Hardcopy</td>
<td>Long status line</td>
<td>Color settings</td>
</tr>
<tr>
<td></td>
<td>Lock/Unlock Tag Type</td>
<td>No initial variable/tag filter</td>
<td></td>
</tr>
<tr>
<td>Help</td>
<td>Contents, Overview</td>
<td>About</td>
<td></td>
</tr>
</tbody>
</table>
Color Settings of Nodes

The colors of the nodes are preset and you can modify them in the project tree using: > Options > Color setting.

Close
Accepts the modified color settings and exits the dialog.

Select color
Opens a window for you to change the color state. Use Define color to compose your own colors.

Reset all
Resets all changed color settings to a default setting. The following colors can be set by default:

- green: Checked and correct objects
- pink: Not checked or correct objects
- black: Connecting lines
- black: Expand + and compress - signs
- red: Mandatory parameter fields
- green: Drawing footer fields
- pink: Drawing footer parent fields
- yellow: Task must be stopped for Incremental download
- red: Resource must be stopped for incremental download
- red: Resource/Task running partially
- yellow: Current and configured value are different

Reset
Resets the currently selected color state to the default setting.
Project Objects

The junction beside the node shows the processing sequence of the project objects on the corresponding level.

General Project Objects

<table>
<thead>
<tr>
<th>Name</th>
<th>Content</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First line</td>
<td>The assigned project name appears here.</td>
<td></td>
</tr>
<tr>
<td>(CONF)</td>
<td>Configuration</td>
<td>The configuration level grouping all resources and permitting data transfer.</td>
</tr>
<tr>
<td>(VIS)</td>
<td>Operator station</td>
<td>An operator station is a resource permitting operation and observation on a PC using the DigiVis 500 Operations program package.</td>
</tr>
<tr>
<td>(OPC-S)</td>
<td>OPC Server</td>
<td>Using an OPC Server, data from the controller is imported as OPC Items into the DigiVis 500 project via an OPC interface.</td>
</tr>
<tr>
<td>(P-CD)</td>
<td>Common display pool</td>
<td>Displays, reports and logs set up under this project object should in principle be available on all operator stations. In fact the objects from the display pool are loaded only on those stations that have also been granted access to the process data needed in these displays, reports and logs.</td>
</tr>
<tr>
<td>(P-MAC)</td>
<td>Pool of graphic macros</td>
<td>Below this element all graphic macros are defined that can be used in the graphic display.</td>
</tr>
<tr>
<td>TAG-LIB</td>
<td>Tag Library</td>
<td>Library which hosts Tag Types.</td>
</tr>
<tr>
<td>Pool</td>
<td>“Memory” for implausible project objects or project objects no longer required for processing, which can be returned to the process if required.</td>
<td></td>
</tr>
</tbody>
</table>
### Process Object for Graphic Macro Pool (P-MAC)

<table>
<thead>
<tr>
<th>Name</th>
<th>Content</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(MAC)</td>
<td>Graphic macro</td>
<td>Graphic macro which is available for creating a graphic display.</td>
</tr>
<tr>
<td>(STRUCT)</td>
<td>Structure node</td>
<td>Structural element. To enable a better overview, graphic macros of the graphic pool can be grouped.</td>
</tr>
</tbody>
</table>

### Project Objects of a D-OS Operator station

<table>
<thead>
<tr>
<th>Name</th>
<th>Content</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(STRUCT)</td>
<td>Structure node</td>
<td>Structural element of the operator station. To provide a clearer overview the displays and logs from an operator station can be grouped together with this project element.</td>
</tr>
<tr>
<td>(OVW)</td>
<td>Overview display</td>
<td>Display for the rapid selection of displays and/or logs. Up to max. 4 x 24 displays or logs can be entered in an overview display.</td>
</tr>
<tr>
<td>(GRP)</td>
<td>Group display</td>
<td>A group display is a group of several faceplates. It offers the user the possibility of displaying associated tags in a display.</td>
</tr>
<tr>
<td>(FGR)</td>
<td>Graphic display</td>
<td>Display of freely grouped static and dynamic display objects generated by the graphics editor.</td>
</tr>
<tr>
<td>(TR_D-OS)</td>
<td>Trend display</td>
<td>The trend display is for the graphic display of values across a time axis. A total of max. 6 trends can be displayed in one trend display.</td>
</tr>
<tr>
<td>(WEB)</td>
<td>WEB display</td>
<td>When calling up a WEB display in DigiVis 500 system, the local WEB browser is started and the link to the configured WEB page is activated.</td>
</tr>
<tr>
<td>(OPL)</td>
<td>Operation log</td>
<td>Cyclical, manual or event-related log containing max. 200 selected variables which are logged within a configurable text.</td>
</tr>
<tr>
<td>(SSL1)</td>
<td>Signal sequence log 1</td>
<td>Logging of system errors, fault messages, switching messages, operator instructions and operator actions with continuous printout.</td>
</tr>
</tbody>
</table>
Configuring the Project Tree

Process objects of a TAG Library

<table>
<thead>
<tr>
<th>Name</th>
<th>Content</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(SSLN)</td>
<td>Signal sequence log N</td>
<td>Logging of system errors, fault messages, switching messages, operator instructions and operator actions in a log file. Printing is possible at the end of logging or manually.</td>
</tr>
<tr>
<td>(REPORT)</td>
<td>Excel Report</td>
<td>A report is configured in DigiVis 500 Graphics Builder to acquire one or more samples of a set of variables.</td>
</tr>
</tbody>
</table>

Configuring the Project Tree

Starting the Project Tree

After a new project has been created or an existing project has been selected in DigiVis 500 Graphics Builder the project can then be configured or - if already configured - commissioned.

> Project > Open > Configuration

The project structure is generated by selectively inserting the available project objects.
Configuring the Project Tree

Section 2  Project Tree
Section 2  Project Tree

Inserting Project Objects

Select the insertion position in the project tree

> **Insert above** inserts a new object before the selected object on the same level in the hierarchy

> **Insert below** inserts a new object under the selected object on the same level in the hierarchy

> **Insert next level** inserts a new object one level lower in the hierarchy

Depending on the object selected in the project tree, the associated “Object selection” window opens.

> Position pointer on object type and choose **OK** with the left mouse button

Assigning Project Object Names

Object names are assigned in the header of an object. You must assign each object with a unique name. All uppercase and lowercase letters, figures and the special character “underscore” (_) are permitted. An object name can be up to max. 12 characters long, with the exception of the resources for which only 4 characters are allowed.

The object header can be edited by selecting:

> **Object > Project > Header**  
(refer to Display Target Stations on page 55)

Using the comment editor, you can produce a free text several pages long for each object. This comment can then be output with the project documentation.

> **Project > Comment**  
(refer to Section 1, Project Manager)

Searching in the Project Tree

> **Search** > Specify a name or a part of a name

The name to be searched for is entered either in full or in part in a dialog. The names of all objects in the project tree are checked. The first object found is marked in the
project tree. If the **Search** button is pressed repeatedly, all objects whose name contains the character string entered will be found. The search is case-sensitive.

**Expand, Full expand, Compress**

To enhance the clarity of the project tree, individual project sections can be opened or closed. This is done by selecting the nodes ahead of the objects.

**Expand**

This is only possible if the node is selected with [+] The node is displayed by one level

> Select node > **Edit** > **Expand**

**Full expand**

This is only possible if the node is selected with [+] The node is fully expanded.

> Select node > **Edit** > Full **Expand**

**Compress**

Only possible if the node is selected with [−]. The node is minimized to an object.

> Select node > **Edit** > **Compress**

**Moving, Deleting Objects**

Using the menus in the project tree, you can cut, copy, insert or delete single or blocks of objects and specify paths or sub-paths. An exception to this rule is the project name. You can use the mouse to move objects without using the menus.
Individual objects

> Select by clicking the left mouse button on the name of the appropriate project object

Cut

Removes the object and saves it in the clipboard for you to insert later.

> Select project object > Edit > Cut

Copy

Saves the object in a clipboard for you to insert later at another position.

> Select project object > Edit > Copy

Paste

Before using the Paste command, you must first have copied or cut an object. If the insertion position is not permitted, the Paste command in the menu is dimmed (highlighted in gray).

> Select insertion position > Edit > Insert

The Paste window opens for you to define the insertion position: Above, Below and, if necessary, Level.

You must specify a unique name for each object which you copy or paste.

Delete

Deletes the objects you select from the project database. Any objects below the selected object are deleted along with it if they have also been selected; otherwise these objects are moved into the pool.

> Select project object > Edit > Delete
Moving, Deleting Objects

You are not asked if you really want to delete the objects if the node is displayed thus:

If the node is displayed thus , the delete window opens and you are asked: “Delete object? Programs are moved to the pool”

You can undo the delete operation with > Edit > Undo.

You cannot undo a delete operation after you have saved the project.

Cut and Insert (Move)

> Select object a second time by clicking the left mouse button and holding the mouse button down.

> Move mouse to insertion position.

An icon appears, indicating whether insertion is permitted or not permitted .

Release the mouse button at the position you want.

The Move window opens for you to define the insertion position: Above, Below, and if necessary, Level.

Several Objects (Block)

The objects you select are placed together in a frame and highlighted (in color) for further processing.

You can handle blocks in the same way as individual objects (see above). However, there is a difference in mouse and keyboard operation.

> First select the object you want by clicking with the left mouse button and holding the left mouse button down.

> Move the mouse to the next (second next, and so on.)

> Release the mouse button at the position you want
Undo

> Edit > Undo

Undoes only the last action you executed.

Exporting and Importing blocks

You can reuse project sections in the existing project or in other projects by exporting and importing blocks.

Export Block

> Select block in project tree by dragging the mouse > Edit
> Export block

Exports the entire content of the block you selected to a PRT file which you can reload by using the Import block command. You can specify the file name in the Export Partial Project window that opens. Access to the directory is by default. The previously active directory is called. The default directory for DigiVis 500 Graphics Builder export files is on the hard disk <DigiVis 500_Installation_Folder>\export>

While exporting a block

If the node in front of the selected object is compressed then while exporting the block all the objects below it are exported or else

only the selected object is exported.

Import block

> Edit > Import block

Imports the content of the block from a PRT file which you previously generated by using Import Block to the pool. From there, you can move the entire block or even
individual objects to the position you want in the project tree. Access to the
directory is by default. The previously active directory is called. The default directory
for DigiVis 500 Graphics Builder import files on the hard disk is <DigiVis
500_Installation_Folder>\export

When importing a block, collisions may occur at tag and variable names.
Automatic renaming is controlled through two entries in the Windows
XP/Windows 7 registry. Registry changes are only possible if you have
administrator rights. Unqualified changes of the Windows registry may cause
serious system stability problems.

Under HKEY_LOCAL_MACHINE\SOFTWARE\Hartmann & Braun\Freelance\DigiTool\SETUP you will find the entries “AutoRenameEAM” and
“AutoRenameMSR” with the values 0 or 1. Value 0 means that names are usually
not changed when importing. Variable names are always retained and tag names
only if there are no collisions. If an imported tag name already exists in the
project, the name of the imported module is extended by ...00. An additional
import would result in ...01, and so on.

If one of the entries AutoRenameEAM or AutoRenameMSR has the value 1, a
dialog window is opened during importing, asking you whether the names
concerned should be changed.
If the answer is yes, the names are extended by ...00. An additional import would
result in ...01, and so on.
If the answer is no, variable names are retained, tag names are removed if
collisions occur in the existing project.

By retaining the names in imported project sections, it is easy to link several
project sections.

**Pool for Unneeded Objects**

The pool is a “memory” for incorrect project objects or for project objects no longer
needed in processing and which you may want to return to the process. You can save
individual objects or entire structures. The processing options in the pool are
identical to those in the higher-order process level.

If you import objects into the project, they are saved in the pool and you must
then move them from there to the resource of your choice.
Access Rights and User Groups

You can only assign certain access rights to various user groups if you installed Security Lock. The separate software package is not part of DigiVis 500 Graphics Builder or DigiVis 500 Operations.

Refer to **DigiVis 500 Engineering Manual Security Lock**.

**Access Rights to DigiVis 500 Graphics Builder**

The following access rights are available to each of max. 16 user groups:

- **No access** The user cannot configure or commission the project.
- **Configure** The user can configure the project.
- **Commission** The user can execute all commissioning functions such as load operator station. This definition applies to each project which is processed on the corresponding DigiVis 500 Graphics Builder PC.

You can modify these rights in a dialog box in **Security Lock**. Refer to Section 1, Project Manager and **DigiVis 500 Engineering Manual Security Lock**.

**Access Rights to DigiVis 500 Operations in Security Lock**

The following access rights have been defined for DigiVis for the installed user groups:

> Edit > Access Rights
Access Rights and User Groups

Section 2  Project Tree

No access

The user cannot operate or observe on the operator station.

Visualize

The user may open displays and logs but not operate them.

Operate

The user can not only open displays and logs but also operate values, states of visualized variables and tags.

Inherit

Inherits the Access Rights setting from the higher-order objects.

Propagate

Propagates access rights to all lower-order objects.

User Groups

Security Lock can create up to max. 16 user groups (user profiles) each containing max. 1000 users. The user groups defined by Security Lock on the engineering station (local station) can be assigned to target stations in the project tree. A target station in this case means all operator stations in the project.

> Edit > Access groups (hidden)
Section 2  Project Tree

Display Target Stations

> Adopts the selected group at the local engineering station for the operator stations.

>> Adopts all the groups in the local engineering station for the operator stations.

Add  Adds a new user group for the operator stations.

Access groups assigned to target stations in the project tree must also be made known to each operator station using Security Lock.

Del  Deletes user group from the selected operator station.

At the operator station (PC with DigiVis 500 Operations), the user only sees the user’s name of the access rights in the status line. The user’s actions are also logged in the signal sequence log.

Display Target Stations

Once an object from the Common display pool P-CD has been selected, Display target stations displays a list of operator stations that this program has been loaded to.

> Select project object in display pool > Edit > Display target stations(hidden)
Area Definition

A name with up to 16 characters can be assigned to all plant areas. If no dedicated names are specified, the plant areas will be designated “Area A” to “Area O”. In the tag list, plant areas are always described with their long names, while during filter selection in DigiVis 500 Graphics Builder, the abbreviations “A” to “O” are displayed together with the long names. In DigiVis 500 Graphics Builder with the new user interface, the used plant areas are always displayed with their long names. In the classic user interface, the short designations of the plant areas are still used due to restricted space.

> System > Area definition... (hidden)

No names can be changed in the first two lines:

In DigiVis 500 Operations, all messages originating from the system are combined under “system”.

Measuring points not assigned to any plant area are combined under “No area”.
The first column of the following lines lists the possible plant areas from A to O to which new names can be assigned.

> Double-click the appropriate plant area > edit appropriate name in the second column (maximum 16 characters)

## Configuring the Project Objects

When you add a new object to the project tree, first assign a name to the object and, if necessary, a short comment. You can modify these parameters later in the menu. Depending on the object, you can display additional information, such as:

- Type of object
- Version (date, time of creation or last modification)
- Number of subordinate objects

You can define a drawing header or footer for all objects. Refer to Section 4, Documentation.

> Select project object > Project > Header (hidden)

## Configuration (CONF)

The Configuration object summarizes information relating to the entire user program, and thus all subordinate project resources. The configuration contains Common display pool (P-CD), OPC Server (OPC-S), Operator Station (D-OS), Tag Library (TAG-LIB). The communication links of all stations of the DigiVis 500 Project can be configured at this project object.
Name  Max. 12 characters
Version  Date and time of object creation
Number of resources  Number of resources configured in the project tree
Short comment  Max. 159 characters
Faceplate arrangement strategy  If several faceplates are shown on a DigiVis 500 operator station, they can be arranged in tile or cascade mode. Here the default setting for all DigiVis 500 Stations is defined.
Access  Configuration whether the DigiVis 500 Operations user is allowed to switch the faceplate display mode between cascade and tile.
Drawing Header / Footer  Refer to Section 4, Documentation.
Timezone  Set the time zone and daylight saving time for the whole project.
The dialog for setting the time zone and daylight saving time is structured in the same way as the Windows XP/Windows 7 dialog.

### Configuring the Communication Links

For data exchange between the operator stations and OPC Server. Used to assign Operator station (D-OS) to the desired OPC Server (OPC-S).
> System > Communication configuration (hidden) will call up the dialog.

Matrix field All the OPC-Servers (OPC-S) are listed in the left column, and all the Operator stations (D_OS) with their names as defined in the project tree are listed in the top row. Each field of this matrix represents a connection between a OPC Server and an operator station.

✓ Connection in online mode should establish a link between the OPC Server and the operator station.

Up to 10 links can be configured in each row of the matrix.

Resources

The first structural level below configuration is formed by the resources, which represent the various different stations in a project. For operation and observation of the process there are the resources D-OS (operator station), for integrating data from the controller there is the OPC Server resource, for hosting Tag Types there is Tag Type library.

There are also additional structural elements such as the pool of graphic macros P-MAC and the Common display pool P-CD.

It is also possible to configure more than one resource on a PC. For example, a Operator Station D-OS resource and an Engineering PC can be operated simultaneously on the same PC, provided these two resources have different resource IDs so that they are addressable by the system.

Operator Station D-OS

The D-OS resource is provided for operation and observation of the process by an operator station using DigiVis 500 Operations software. Insertion of Operator station (D-OS) is indicated by the code VIS.

Standard operating facilities (for example, faceplates), are provided for all known tags and variables on the operator stations. In addition, graphic displays, trend dis-
plays, reports, WEB displays and logs can be configured and structured for the DigiVis 500 operator stations.

> Select operator station object in **project tree > Project > header**

**Configuration: Resource D-OS**

- **Name**: max. 4 characters.
- **Short text**: max. 12 characters.
- **Version**: Date and time the object was created.
- **Number of displays**: Number of displays and logs configured in the resource.
Number of signals:
Number of OPC signals used by the DigiVis 500 system. Refer to DigiVis 500 Getting Started Manual, Section 3, Licensing.

D-OS password:
Enter a password that allows the operator to exit from DigiVis 500 Graphics Builder. If no password is specified, any operator can close DigiVis 500 Graphics Builder.

Diag. password: Enter a password that allows the operator to switch to the DigiVis diagnostic mode. If no password is specified, the default password “diag” can be used to switch into diagnostic mode.

Display cycle time:
The display cycle time determines the frequency with which the data in the message page, system display and the faceplates on the operator station is updated.

Flash rate
The frequency with which flash colors are updated in the displays.

Overview display

OVW
The configured overview display is displayed as an overview display in DigiVis 500 Operations.

FGR
A graphic display is shown as overview display in DigiVis 500 Operations. Enter the name of the graphic display directly or choose it from the list.

Default picture type
A certain default display type or <no> default display type can be selected for each operator station. If no default display type is assigned in the display access, the display assigned to this type is used as default display.

Short comment
Max. 159 characters

Drawing header and footer
Refer to Section 4, Documentation and Documentation on page 73.
The OPC Server node is used to configure third-party OPC Servers in DigiVis 500 system. The following parameter mask is used to configure the OPC-S node in the project tree.

**Name** Max. 4 characters
**Short text** Max. 12 characters
**Version** Date and time of object creation
**Location** Specifies the computer on which the OPC software is installed.
**Computer** Name of the computer where OPC Server is running.
**Port No** Port of the computer.
**Short comment** Max. 159 characters

**Drawing Header and Footer**
Refer to Section 4, Documentation.
Alarm mapping

DigiVis 500 Graphics Builder provides the user with the option of mapping the attributes of the OPC AE Items to the DigiVis 500 system attributes.

User can specify the OPC AE severity Range to be mapped for each DigiVis 500 priority. The range can be defined in the columns Start of OPC Range and End of OPC Range as shown below.
Alarm Severity

_DigiVis 500 Severity_

The following priority levels are available in the DigiVis 500 system for grouping of OPC severities.

<table>
<thead>
<tr>
<th>Priority Level</th>
<th>Message Type</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>S1-S3</td>
<td>System message</td>
<td>System messages have the highest priority level and are subdivided into 3 message groups S1-S3.</td>
</tr>
<tr>
<td>1</td>
<td>Fault message</td>
<td>Messages of this type are used to indicate faults (for example, Alarm limit setting being violated).</td>
</tr>
<tr>
<td>2</td>
<td>Fault message</td>
<td>“</td>
</tr>
<tr>
<td>3</td>
<td>Fault message</td>
<td>“</td>
</tr>
<tr>
<td>4</td>
<td>Switch message</td>
<td>Messages of this type are used to indicate switch events (for example, valve open/closed).</td>
</tr>
</tbody>
</table>

_Start of OPC Range_

Lower limit of severity range

_End of OPC Range_

Upper limit of severity range

_Alarm Attribute_

This window is used to map the OPC alarm attributes to the DigiVis 500 Graphics Builder attributes. OPC Server provides the following standard attributes for each OPC Item:

- Category
- Condition
- Sub condition
These attributes are available for mapping to DigiVis 500 Alarm attributes.

The constraints of the DigiVis 500 alarm attributes have to be taken into consideration while mapping the OPC alarm attributes.

The DigiVis 500 system alarm attributes are

- Tag name
- Short text
- Long text
- Message text
- Limit type
- Dimension
- Value
The user can select the OPC attributes for mapping to each of the DigiVis alarm attributes, by selecting from the dropdown list as shown above. In addition to the OPC alarm attributes, two more selections are possible: <default>, <empty>. The default values for the Alarm attribute mapping are as follows:

<table>
<thead>
<tr>
<th>DigiVis 500 alarm attri.</th>
<th>default mapping</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag name</td>
<td>&lt;default&gt;</td>
</tr>
<tr>
<td>Short text</td>
<td>&lt;default&gt;</td>
</tr>
<tr>
<td>Long text</td>
<td>&lt;default&gt;</td>
</tr>
<tr>
<td>Message text</td>
<td>&lt;default&gt;</td>
</tr>
<tr>
<td>Limit type</td>
<td>&lt;default&gt;</td>
</tr>
<tr>
<td>Dimension</td>
<td>&lt;default&gt;</td>
</tr>
<tr>
<td>Value</td>
<td>&lt;empty&gt;</td>
</tr>
</tbody>
</table>

If the user selects <default> mapping for an attribute, depending on the OPC Item definition in DigiVis 500 (for example, Tag, Variable and others), corresponding fields are mapped as shown in the table below:

<table>
<thead>
<tr>
<th>OPC Item definition -&gt; DigiVis 500 attributes</th>
<th>Tag-Alarm (AE item is used in a tag instance)</th>
<th>Variable-Alarm (AE item string is used as a DA item string in a variable)</th>
<th>Free-Alarm (AE items string is used nowhere)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Priority</td>
<td>Severity mapping</td>
<td>Severity mapping</td>
<td>Severity mapping</td>
</tr>
<tr>
<td>Status</td>
<td>OPC status</td>
<td>OPC status</td>
<td>OPC status</td>
</tr>
<tr>
<td>Time stamp</td>
<td>OPC time stamp</td>
<td>OPC time stamp</td>
<td>OPC time stamp</td>
</tr>
<tr>
<td>Area [16]</td>
<td>Tag definition</td>
<td>&quot;No Area&quot;</td>
<td>&quot;No Area&quot;</td>
</tr>
<tr>
<td>Tag name [16]</td>
<td>Tag definition</td>
<td>Variable name</td>
<td>End of OPC source string</td>
</tr>
<tr>
<td>Short comment [12]</td>
<td>Short comment from tag definition</td>
<td>&quot;.....&quot;</td>
<td>&quot;.....&quot;</td>
</tr>
<tr>
<td>Long comment [90]</td>
<td>Long comment from tag definition</td>
<td>Beginning of variable comment</td>
<td>Beginning of OPC message text</td>
</tr>
<tr>
<td>Value [12]</td>
<td>&quot;.....&quot;</td>
<td>&quot;.....&quot;</td>
<td>&quot;.....&quot;</td>
</tr>
</tbody>
</table>
This `<empty>` attribute is assigned to the DigiVis 500 system alarm attribute “Value” as there is no corresponding attribute available from a standard attributes of a OPC Server.

For information on the message list format, refer to DigiVis 500 Operations Operators Manual, Section D, Messages.
The default templates provided for AC500 and Freelance can be used with CoDeSys OPC Server and Freelance OPC Server respectively without any additional modifications.

For other OPC Servers, select Custom and configure the patterns.

There is a difference in the way in which various OPC Server expose their DA and AE items of function blocks.

CoDeSys OPC Server uses “.” as a separator and exposes DA items using this separator in the form “PLC.TaskName.TagName.selector”.

Freelance OPC Server uses “/” as separator and exposes its DA items in the form “TagName/Selector”.

OPC Regular Patterns (Configure Pattern)
AE item patterns are also different for different Servers. CoDeSys OPC Server exposes AE items like “PLC.TaskName.TagName.selector” with condition “LIMIT_EXCEED”.

Freelance OPC Server exposes AE items with only tag name (without selectors) and condition.

For example:

CoDeSys OPC Server Alarm Item

PLC1.Task1.PID1.ACTUAL.LIMIT_EXCEEDED

This dialog gives the user the option to set regular expression patterns to identify various parts in DA and AE items for a particular OPC Server.

*Templates*  Pre-defined template for Freelance and AC500 OPC Servers.

---

**Common Display Pool P-CD**

Displays, reports and logs set up under this project object should in principle be available on all operator stations. In fact the objects from the display pool are loaded only on those stations that have also been granted access to the process data needed in these displays, reports and logs.

Any modifications to displays in the general display pool must be loaded separately into all the operator stations.

Once an object from the display pool has been selected, *Display target stations* can be chosen from the shortcut menu to display a list of operator stations that this program has been loaded to.
Programs on the Operator Station: Displays, Reports and Logs

In principle displays, reports and logs are programs in an operator station. Displays are updated cyclically.

> Select object in project tree > Project > Header

<table>
<thead>
<tr>
<th>Configuration: Graphic display FGR</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td><strong>Version</strong></td>
</tr>
<tr>
<td><strong>Type</strong></td>
</tr>
<tr>
<td>OPL</td>
</tr>
<tr>
<td>FGR</td>
</tr>
<tr>
<td>GRP</td>
</tr>
<tr>
<td>SSL1</td>
</tr>
<tr>
<td>SSLN</td>
</tr>
<tr>
<td>TR_D-OS</td>
</tr>
<tr>
<td>OVW</td>
</tr>
<tr>
<td>STRUCT</td>
</tr>
<tr>
<td>REPORT</td>
</tr>
<tr>
<td>WEB</td>
</tr>
</tbody>
</table>

*Display cycle time*

Time for repeated update of the values of a display, report or log.
Processing sequence
 Indicates the node position of this project object relevant to the operator station.

Short comment Max. 159 characters

**Structure Node (STRUCT)**

Structural element of the operator station. To provide a clearer overview the displays, reports and logs from an operator station can be grouped together with this project element.

The name must be no longer than 12 characters.

> Select operator station in project tree > Edit > Insert next level > Structure node > Specify name

**Pool of Graphic Macros (P-MAC)**

Below this element all graphic macros are defined. A macro MAC can be created directly here in the project tree or implicitly when generating a graphics image with the graphics editor.

The name must be no longer than 12 characters.

> Select configuration CONF in project tree> Edit > Insert next level > Macro pool P-MAC > Specify name

**Macro Structure Nodes (STRUCT)**

Structural element for grouping graphic macros.

The name must be no longer than 12 characters.

> Select macro pool in project tree> Edit > Insert next level > Structure node > Specify name

**Graphic Macros (MAC)**

A MAC graphic macro can be created below the “pool of the graphic macro” in the project tree or implicitly when generating a graphic display with the graphic editor.
General Functions of the Project Tree

Save

> Project > Save

This function saves the project during configuration. The project is saved to the project file.

Documentation

> Select level > Project > Documentation

The project documentation function is started. The documentation is carried out for the selected objects. In the documentation settings you can select whether only the selected objects or also the subsidiary objects shall be documented.

For information on compilation of documentation jobs and the scope of documentation, refer to Section 4, Documentation.
Check, Check all

If the **plausibility check** is initiated from the uppermost project node, the DigiVis 500 Graphics Builder generates the current CSV file (required for the CBF Viewer) in the background. Since the time required to generate a CSV file may become relatively long with large projects, the CSV file generation has been associated with the check of the uppermost project node. For example, if you select the CONF node and start the plausibility check from there, no CSV file will be generated.

During commissioning, it may make sense to initiate several plausibility checks from the CONF node (or lower) and only occasionally, but at least once in the end, from the uppermost project node. The generated CSV file is then loaded to the DigiVis 500 Operations PC with the download to the DigiVis 500 Operator Station.

**Check all** is used to check the selected object and all objects positioned below it for correctness (or plausibility). **Check** is used to check only those objects in the project tree that are not yet correct. Program code is generated automatically for all correct objects, and this can be loaded to the relevant stations during the subsequent commissioning phase. Incorrect objects are displayed accordingly in the color set for that purpose.

In the case of long error lists it is advisable to perform plausibility checking in smaller sections. Each node of the project tree can be checked separately. Individual blocks within a program can also be checked.

> Select level > **Project** > **Check**

The selected object and the subordinate incorrect objects are checked for plausibility (for example, errors, missing entries or contradictions). The errors are listed in a window and must then be eliminated.

> Select project object > **Project** > **Check all**

The object selected and all the subordinate objects are checked for plausibility. The errors are displayed in an error list and must then be eliminated. The plausibility check can take a few minutes.
Jumping Directly to Error Points after Plausibility Check

After a plausibility check list has been newly created with Check or Check all, all errors that have been detected are displayed for the user in a list box.

- Double-clicking the left mouse button on a marked message or the Current Error and Next Error buttons triggers a jump to the object causing the error.
- A marked object is identified through being depicted in the “system selection” color (light blue) or being framed with a border.
- In so far as is possible for the editor concerned, the marked object is positioned in the middle of the screen.

The destination of a jump is exactly the same whether the plausibility check was called up in the project tree or the editor. If jumping to an editor page which previously contained a selection (only possible after a plausibility check within an editor), this selection is lost by the plausibility check jump.

Classes of Plausibility Errors

Three classes of plausibility errors are distinguished:

Error
- Some problem will occur.
- The project cannot be loaded in this state.
- The error must be corrected.

Warning
- The configuration is inconsistent, but the project can be loaded.
- The person responsible for configuration must decide whether the error needs to be rectified or whether the project can run effectively despite this message.

Hint
- Contains information for the user which does not necessarily need to be followed.
- No action is generally required on the part of the person carrying out the configuration process. S/he is merely being informed that certain inaccuracies
have been discovered by the system or that minor adjustments have been carried out.

**Structure of the Plausibility Check Messages**

The messages are formed as follows:

<Number> <Label for class of error> <Message text>

The following arrangements apply to the various different error classes:

[xxxx.2.xxxxx] Error: < Message text >

[xxxx.3.xxxxx] Warning: < Message text >

[xxxx.4.xxxxx] Hint: < Message text >

**Error List Display**

- The classification of an error can be recognized both from its number and the introductory text.
- The different message classes can be selectively faded in or out.
For the whole time the project is being processed the most recent setting of the check boxes is preserved.

**Show Error List**

> Select level > **Project** > **Show error list**

The error list contains all the errors in the selected objects occurring after a plausibility check. The list can be printed out via the Documentation function.

Refer to **Section 4, Documentation**.

**Object Header**

The general parameters of an object can be modified at any time. It is the same as specified when the object was added. Choose an object:

In some objects such as resource, selection is by double-clicking the mouse. On other objects such as graphic display, trend display or reports you can access the editor or extended parameter-definition dialog directly.

> **Project** > **Header**

Refer to **Configuring the Project Objects** on page 57.

**Comments on a Project Object**

> **Project** > **Comment**

Use the comment editor to create or modify a free text for each object.

This multi-page text can also be used to describe the program or the process technology and can be output together with the object using the Documentation function.

Refer to **Section 1, Project Manager, Editing a Project Comment** on page 31.
**Network**

Via the **Network setting** the resources are assigned the communication addresses, so-called resource-ID’s. The stations’ IP addresses or host names which the resources are assigned are also specified in the network setting.

> Project > Network

**Project Tree Options**

**Hardcopy**

> Options > Hardcopy

Dumps the screen contents to the printer.

**Long or Short Form in the Status Line**

> Options > Long State Line

**Long format:** For example, the project object Reactor is selected. The status line then reads **doku_vis/conf/V_GR/Reactor**, that is, the names of the project objects are displayed.

**Short format:** For the same example, the short format will display **C01/R08/B04**.

**Abbreviations:**

- C: Configuration level
- R: Resource
- B: Program, Display
- S: Structure node

The **short form** is the default setting.
Colors in the Project Tree

> Options > Color settings

The colors of nodes, connecting lines, mandatory parameters and fields can be modified in the drawing footer. The default settings for the colors can be restored if necessary.

Refer to Display of Project Object States on page 41.

Initial Filter for Variable and Tag List

> Options > No initial variable/tag filter

This option is used to define the handling of filter criteria when closing or calling up the variable and tag list:

Menu alternative activated:
No filters are active when calling up the list, the whole list will be shown.

Menu alternative NOT activated:
The filter settings in the variable and tag list are saved when closing the list and when calling up the list again they are executed.
Section 3 Commissioning

General Description – Commissioning

Commissioning is an operating mode of DigiVis 500 Graphics Builder which offers a range of other functions in addition to the loading of project objects. Only when the project objects have been configured and checked for plausibility, can they be loaded into the operator station and started as part of the commissioning process.

When a project is commissioned for the first time, the complete project must be loaded into the respective station.

Later, only changes need to be loaded. Changed project objects are loaded and started in accordance with selections made in the project tree. Although they share a common user interface, configuration and commissioning are two separate processes. For commissioning, a system bus (Ethernet) connection must be established from the engineering station to the operator station(s). It is then possible to switch directly between configuration and commissioning modes.

After loading a project with **Load whole station**, additional configuration changes may be loaded incrementally. A configuration change consists of the creation of, deletion of or a change to a project object. A configuration change which effects other project elements is said to have **side effects**.

The user is made aware of the occurrence of side effects by the way in which the concerned object nodes are displayed in the project tree. If an OPC item that is used in a Trend display is deleted then this causes a side effect on the project object Trend display (for example, Operator station D-OS and/or P-CD nodes). In this case the trend archiving is stopped.

Version checking ensures that the project running on the Engineering Station and the Operator Station are one and the same. If changed objects are not downloaded then this is indicated by arrows in front of the object.
Commissioning of the programs is facilitated in all cases by a global value and trend window. The user can track analog and binary values from one program or another.

**Starting Commissioning**

Unlike configuration, commissioning can only be performed once a connection to the OPC Server has been established through the (Ethernet) system bus. Communication is set up automatically when **Commissioning**! is selected.

> Call project manager > **Commissioning**!

Alternatively:

> Call project tree > **Project** > **Commissioning**!

It is possible to switch between configuration and commissioning modes directly from the project tree.

Detailed information on installation of the system bus connection can be found in the Mounting and Installation instructions.
Connection Requirements

- Ethernet card correctly installed in the engineering station.
- “Internet log (TCP/IP)” added to the network configuration.
- System bus cable connected correctly to the stations to be commissioned.
- Resource IDs and IP addresses entered correctly in the stations.
- All resource IDs or IP addresses are unique.

Commissioning Procedure

- The project objects must have satisfied plausibility checks.
- Call up Commissioning
- Select a resource, then the project objects to be loaded from the project tree.
Switching Between Commissioning and Configuration

Direct switching between commissioning and configuration modes is possible.

Switching from Commissioning to Configuration

- Project > Configuration

It is necessary to switch to configuration when, for example:

- Objects are to be added or changed
- Variable changes are to be performed, such as adding new variables or changing data types.
- Extra tags or variables are to be configured in a resource
Switching from Configuration to Commissioning

> Project > Commissioning

After a switch from commissioning mode into configuration mode, it is not permissible to switch from the program directly back to commissioning. The reason is possible side effects which any changes made might have on other objects, such as displays. Visible indication of side effects is provided only in the project tree display; hence a switch to the project tree is required before a return to commissioning.

It is necessary to switch to commissioning when, for example:

- After plausibility checks, objects are flagged for loading with an arrow symbol
- Tag parameters are to be corrected on a running system
Faster switch from Commissioning to Configuration Mode

A quick switching from commissioning to configuration mode has been implemented through the new menu item Configuration or the toolbar button available in the following editor/list displays:

- Variables list
- Tag list.

The mode change always applies to the entire DigiVis 500 Graphics Builder system. Thus, switching from the commissioning to the configuration mode within an editor causes that if one subsequently moves to the project tree, it will also be in configuration mode.

When changing mode, the current selection, the current display section, the current search filter and the current sort sequence are all retained within the editors or lists.

If dialogs such as the ‘Define debug window’, then the values and trend windows will be closed.

The ‘Back’ path stored is likewise retained when the mode is changed.

Commissioning User Interface

Project Tree

In commissioning mode, as in configuration mode, the project tree forms the starting point for all further operations.

Unlike in configuration mode, state information such as ‘running’ or ‘stopped’ is kept for the individual project objects.

It is clearly indicated which objects need to be loaded. These project objects are shown preceded by an arrow. If a compressed branch contains at least one subordinate object that needs to be loaded, then an exclamation mark precedes the visible representative (top most object) of that branch.
For more information, refer to Section 2, Project Tree.

**Differences between Commissioning and Configuration modes**

**Functions of Configuration**

Menu options displayed in bold can only be used during **Configuration**, not during **Commissioning**.

<table>
<thead>
<tr>
<th>Project</th>
<th>Save</th>
<th>Options</th>
<th>Hardcopy</th>
<th>Long status line</th>
<th>Color settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documentation</td>
<td>Check</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Check all</td>
<td>Show error list</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Header</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Comment</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Commissioning</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network, Configuration</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Exit</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search</td>
<td>Undo</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td>Program</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Differences between Commissioning and Configuration modes

Section 3  Commissioning

Insert above
Insert below
Insert next level
Expand
Full expand
Compress
Cut
Copy
Paste
Delete
Export block
Import block
Access rights (only on Security Lock)
User groups (only on Security Lock)
Display target station
System
Variable list
Tag list
Local message processing
Display access
Communication configuration
Area definition
Show all objects
Show selected objects
OPC Item List

Commissioning functions

Menu options displayed in bold can only be used during Commissioning, not during Configuration.

<table>
<thead>
<tr>
<th>Project</th>
<th>Header</th>
<th>Options</th>
<th>Hardcopy</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Network</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configuration</td>
<td>Exit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td>Program</td>
<td>Help</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Expand</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
State Displays in the Project Tree

In contrast to configuration, state information is maintained on project objects during commissioning. This state information appears after each project object in brackets (like the object types) and is updated as it changes. The state information reflects the state of the object in the DigiVis 500 system. If arrows should appear before the nodes, these project objects must first be loaded or reloaded into the station because of a configuration change. An exclamation mark indicates that other objects at levels below the one so marked need to be updated because of changes in their configuration. The color of the node in the display provides information about the effects of its configuration change on other objects. Higher-level information may also need to be updated in the station.

In commissioning, nodes are displayed in the same formats as in configuration.

Refer to Section 2, Project Tree, Display of Project Object States on page 41.

Representation of the Side Effects Caused by Configuration Changes

Switching to configuration and carrying out a configuration change can affect the higher-level resource (side effects).

The configuration change must therefore be loaded into the higher-level resource.
After the plausibility check, all modified objects are always flagged with an arrow symbol next to the affected node in the project tree. If the project tree is compressed, an exclamation point shows that one or more affected nodes exist below the marked object. Refer to Display of Changes in the Project Tree on page 97.

- Programs modified with no side effects are represented by a green node.
- **Added objects** are shown along with the side effects produced.

**Project Version**

**Version Check**

The following version control check is carried out by DigiVis 500 Graphics Builder in order to check which project is loaded in the selected operator station and whether or not this project corresponds to the project currently open in DigiVis 500 Graphics Builder. Information on the individual project versions can be displayed as follows:

> Load > Version data...

The information can be deduced from the number of times individual project objects or the entire project have been downloaded into the Operator station and undergone parameter changes.

The true project version number is stored in system variables. These system variables hold the project version.
This information is used internally by DigiVis 500 Graphics Builder to ensure that the Engineering PC and the Operators PC have the same version of the project and on each download the same instance of the DigiVis 500 Graphics Builder is used to load the project into a particular operator station.

**Show all Objects**

All objects configured for the project are displayed.

> System > Show all objects

<table>
<thead>
<tr>
<th>Obj. no</th>
<th>State</th>
<th>Type</th>
<th>Project tree object</th>
</tr>
</thead>
<tbody>
<tr>
<td>237</td>
<td>CLEAN</td>
<td>VRS</td>
<td>C01/R09</td>
</tr>
<tr>
<td>512</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>513</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>514</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>515</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>516</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>517</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>518</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>519</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>520</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>521</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>522</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
<tr>
<td>523</td>
<td>CLEAN</td>
<td>GLBL</td>
<td>C01/R09</td>
</tr>
</tbody>
</table>

**Obj. no** Object number

**State**

- **CLEAN** The object is correct and has been loaded into the station.
- **DIRTY** The object version in the engineering station does not match the object version in the station.
- **CREATE** Object not yet loaded into station.
- **DELETE** Object deleted from project database, but still present in station.

**Type**

- **VAR** Variable block
DEL  Undefined object
VRS  Version info
ACC  Access rights
ICON Selection icon in the overview display
GLBL Global object
RSC  Resource object
DST  Daylight saving time table

*Project tree object*
Path in the project tree

*Max. number of objects*
Number of objects possible in a project

*Number of free objects*
Number of additional objects possible

**Load**  Load all selected objects
**Cancel**  Exit from the object list

All Objects not being CLEAN or DEL will be cold started when loaded!

**Show Selected Objects**
Only the objects below a project object selected in the project tree are displayed.

> System > Show selected objects
The setup of this window is basically identical to that of the list of all objects. The only difference is that instead of the project tree path, a brief description of the object is displayed. This description is generated in a fixed form by the system. Refer to Show all Objects on page 91.

**Time Settings**

**System Time, Local Time and Time Zone**

**System Time** Current time kept by the station, used for internal transfer time stamps. System time is equal to Greenwich Mean Time GMT (UTC).

**Local Time** In addition to System Time, for each station a Local Time is defined. The local time takes account of time zones as follows:

**Local Time = System Time - Time Zone**

The default setting, a time zone offset of 0h, is Greenwich Mean Time (GMT). The relation of the local time to GMT is always set upon installation. In the station the local time is available in the system variable name.DateTime (name = resource).
**ActualTime**  The local time with any daylight saving time shift applied is the **current time**, that is the time which the user sees on his or her watch. This time is used when setting the DigiVis 500 time-of-day in commissioning and is generally the time used at the DigiVis 500 user interface.

**TimeZone**  The time zone (TZ) is calculated from the difference between the Greenwich mean time (GMT) setting and the local time (TZ = GMT - Local Time). For Germany TZ is equal to \(-1\) (at 13:00 GMT it is 14:00 in Germany, \(13 - 14 = -1\)).

**Writing DT Variables**  
Activation of daylight saving time only effects the display of time points. When operating on a variable, the user must specify whether the edited time is a daylight saving time or not. A daylight saving time must be identified by an “S” following it. If this “S” is missing, the time value input is interpreted as local time. If an “S” is specified for a time when daylight time is not in effect, a message is sent to the user requesting a correction.

For example:  Input “..16:00..” produces 16:00 at the station; an input of “..16:00..S” produces (daylight saving time in Germany) 15:00.
Loading the Project

During loading, the user program is loaded into the operator station.

Through **Load > Selected objects** all the selected project objects in the project tree are loaded; through **Load > Changed objects** only changed objects are loaded.

When the system is running, all changes are brought up to date through **Changed objects**. The side effects are indicated in the project tree by displaying the affected nodes in different colors. Refer to **Section 2, Project Tree, Display of Project Object States** on page 41.

Load Whole Station

All parts of the user program associated with the selected resource are loaded.

Loading the whole station loads the current project in the operator station.

> **Load > Whole station**

Regardless of which project object within the resource is selected, on **Load > Whole station** the complete station (D-OS) is deleted and reloaded. The user must ensure that this resource belongs to the loaded project. The result of the system’s version check is merely displayed without interrupting the loading operation.

If the time zone of the project does not match that of the DigiVis 500 Graphics Builder PC, a dialog box is displayed which draws attention to the discrepancy.

Yes  The download operation is canceled.

No  The download operation is continued.
Load Message Configuration

The station-specific (local) message configuration is loaded into the selected station. This includes specifications of message and acknowledgment handling, audible warning (horn) control and relating to the message list and message line.

> Load > Message configuration

Load Selected Objects

Loading selected project objects without their message configuration parts or variables.

Loading of objects entails initialization of the objects concerned. This process erases all previous information concerning the object. Programs running in other objects which rely on information from the objects being loaded can thus react in ways which, under certain circumstances may be undesirable. For example, if the export attribute of a variable is changed, then this variable will be reloaded and its value will be reset to the initial value. It is therefore important to be very sure that the loading of changed objects does not have a negative influence on the process being controlled.

> Load > Selected objects

Load Changed Objects

The smallest loadable unit of a project is the object. There are visible project objects, such as the resource, and there are hidden objects such as variables and messages.
When **Load > Changed objects** is executed, only the project’s changed objects are loaded.

Loading of objects entails initialization of the objects concerned. This process erases all previous information concerning the object. Programs running in other objects which rely on information from the objects being loaded can thus react in ways which, under certain circumstances may be undesirable. For example, if the export attribute of a variable is changed, then this variable will be reloaded and its value will be reset to the initial value. It is therefore important to be very sure that the loading of changed objects does not have a negative influence on the process being controlled.

**Load > Changed objects**

### Display of Changes in the Project Tree

After the plausibility check, all modified program blocks are always flagged with an arrow symbol next to the affected node. If the project tree is compressed, an exclamation point shows that one or more affected nodes exist below the marked object. Programs modified with no side effects are represented by a green node.

The indication of changes will be passed from the affected object in the project tree to the resource node. Only the most far-reaching side effect will be displayed.

Refer to **Display of Project Object States** on page 41 and **Section 2, Project Tree**.

### Displaying and Writing Values in a Window

During commissioning, it is important to be able to carry out online checks on parameter changes during processing.

The commissioning window makes it possible to observe a variable. This enables the user to intervene in an online process from the engineering station.
Displaying and Writing Values in a Window

Section 3 Commissioning

Variable window

Define debug windows
Settings established for debug and trend windows

Show value window

Show trend window
Make it possible to display the process signals and variables requested in the form of values and trends

- The Enter variable and Write value options below are available in commissioning mode > variable list > windows

Enter variable Variables are introduced into the value or trend window
Write value Enables the one-time write of a binary value

The value window can display numeric data - which can also optionally be displayed in a trend window - and strings.

The values for the value and trend windows are updated once per second.
Both windows can be displayed simultaneously. They remain on screen when switching programs.

This enables variables from other programs to be inspected in conjunction with the program being viewed.

Depending on the application from which it has been started, the **Window** menu opens up a variety of possibilities.

<table>
<thead>
<tr>
<th></th>
<th>Project tree</th>
<th>Variables list</th>
<th>Tag list</th>
<th>Program</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define debug window</td>
<td>✔️</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Show value window</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>
Enter Variable

The menu command **Enter variable** can be selected from within the variable list.

> Select variable (through mouse click) > **Window** > **Enter variable** > **Define debug window**

The selected variable is added to the variable list in the commissioning window. The **Define debug** window appears on the screen and the variable can be assigned a display format.

As soon as a variable is entered, it has a sequence number appended to. This number reflects the order in which variables are entered.

**Define Variable Windows**

This part of the program is where a variable is allocated a display format. The variable to be processed is first selected in the list with a mouse click. Now the display format for the **value window** and **trend window** can be selected. Entries can be added to the variable list by calling the menu item **Enter variable** or directly by double-clicking on the variable.

These entries may be saved and reloaded.
> Window > Define debug windows...

**OK**  
Save entries and exit from **Define debug windows**.

**Cancel**  
Exit from **Define debug windows** without saving entries

**Execute**  
Activate entries in the value and trend windows without exiting **Define debug windows**.

**Reset**  
Cancel the last entry.

**Up**  
Shift the selected variable **up one position in the list**. The variable’s sequence number remains unchanged.

**Down**  
Shift the selected variable **down one position in the list**. The variable’s sequence number remains unchanged.

**Delete**  
Delete the selected variable from the variable list in the value and trend windows.

**Delete all**  
Delete all variables from the trend and value windows.

**Load conf.**  
Load a stored configuration, selected from a list.
### Save conf.
Save the current configuration, (followed by a prompt for a name under which to save it).

### Data format
Display format for selected variables in the value window. After the required variables have been selected, all the valid data format options appear here on the screen. An appropriate display format for a variable can be chosen by clicking on the relevant format. In the value window, a variable can be displayed simultaneously in all the data formats offered.

(Displaying a **variable of data type DT** in a format that differentiates daylight-saving time: if the value of the variable falls within daylight-saving time, then this value is increased by the daylight-saving time difference (1 hour in Germany), and the value is flagged by appending an ‘S’).

### Display
Determine the type of display of the variable. The variable can be displayed in the value window and/or trend window. Select by clicking on the appropriate check box.

**Value window**
- [✓] Variable will be displayed in the value window; data display formats available for the variable will be listed.
- [ ] Variable will not be displayed in the value window.

**Trend window**
- [✓] Variable will be displayed in the trend window, the **Trend options** menu will be called up.
- [ ] The variable will not be displayed in the trend window.

**Info** Variables of the data type string and date (DT) cannot be displayed in the trend window.

**Trend options** Calls up **Trend options** menu
Trend Options

> Window > Define debug windows > Trend options

**Color**  
Choice of color for display of selected variables in the trend window.

**Interpolation**  
Three different interpolation methods are available: None, linear and staircase

**Display region**  
Choose one of the two variable windows, in which the selected variable should appear. The Y-axis of both windows extends from 0-100%. The upper window is five times as high as the lower window. Each X-axis covers 150 values. Both trend windows are displayed simultaneously on the screen. The **Lower** window can display a maximum of 4 different signals, while the **Upper** one can display up to 18.

A maximum of 20 variables can be selected for display. If all the 20 values are entered in the variable windows and **Show trend window** is executed, the engineering station will be overloaded. A routine is then executed which declares these variables invalid.
**Show Value Window Section 3  Commissioning**

**Band**
This is where limits are entered for the display of selected variables in the trend window. Data must be entered in an appropriate format for the variable.

**Show Value Window**

![Value window](di1652us.bmp)

> **Window > Show value window**

The current values of variables can be displayed in the value window. Each variable is displayed in a format depending on its data type. Variables of the BOOL data type are displayed with the logical state “True” or “False”. Variables of the data type REAL, INT, TIME and WORD are shown with their value, and variables of the STRING data type are shown with their text content.

The value window consists of five columns. From left to right on the screen, they have the following function:

- **Input (sequence) No.**, from Define debug
- **Data type**,
- **Variable name**,
- **Value or State**
- **Comment**

The setting of **UseDaylightSavingTime** is ignored for the display of DT variables in the value window. In commissioning mode, the user can always see the actual variable contents. (UseDaylightSavingTime is only taken into account in dialogs for setting the clock under DigiVis 500 Graphics Builder).
Show Trend Window

> Window > Show trend window

In the trend window, process signals covering a time span of 1,000 seconds can be displayed. At any one time, a time span of 150 seconds is visible. The trend window has no “memory”: upon leaving the trend window, the values recorded are lost.

In the lower border of the window is a push button used for scrolling back the display. By activating this button it is possible to see earlier signal sequences.
Writing a Value

Window > Write value

Write value can be used to assign a new value to a variable. When making such an entry, care must be taken to ensure that the entry is in the correct data format (as defined for the variable).

When Write value is called up, the window is displayed in the middle of the screen. If there is a value or trend window already displayed, the Write value window will be located behind that window. The value or trend window must be repositioned or closed before the Write Value window can be used.

The variable is overwritten only for one cycle. If, in the next program cycle the variable is rewritten, the value specified here, in commissioning, is overwritten.
Section 4  Documentation

General Description – Documentation

All configured objects can be documented from DigiVis 500 Graphics Builder. Likewise, provision has been made to ensure easy location of individual documents as well as precise incorporation into an overall plant documentation.

A common layout has been used for all documents. It is possible to incorporate the company logo into the document header or footer. Document handling is facilitated
by a flexible sorting on the resulting documents, as well as by a complete table of contents for all project parts output.

An unequivocal designation of the document type (Doc. Type) using the document identification key facilitates location of documents. An automatically inferred documentation identification (Doc ID) refers to the functional environment (=) through the program name and to the location environment (+) through the cabinet identifier. Specification or output is possible through the customer drawing number.

A direct cross-reference can be found in the program sheet, while the cross-reference list constitutes a supplement to the program sheet for larger scopes, so that all references can be easily located. On displaying variables, the allocated resource can always be recognized. If an input or output channel is allocated directly to a variable, the former is displayed also.

Whenever possible, a tabulated presentation is chosen in order to reduce the quantity of paper used. Otherwise, presentations are made in masks, making it easier to read them.

In tabulated form:

- Object attributes of dynamic graphic displays

In mask form:

- Logs and trends
- Network adjustment

Documentation output is controlled by the print job (for example, a job must always be selected for printing out). The contents of the print job are defined in such a job. Each print job is valid for all projects on the engineering station.
Documentation Manager

Editing the Documentation Manager

The documentation manager menu can be accessed in one of the following ways:

Select project tree > **Project** > **Document**
Marked objects in the project tree are selected for documentation.
Alternatively:
Out of displays (FGR)

> **Program** > **Documentation**
The current display is selected for documentation.

<table>
<thead>
<tr>
<th>Name</th>
<th>Comment</th>
<th>Last revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDU</td>
<td>Documentation Project</td>
<td>03/03/2009 13:47:59</td>
</tr>
<tr>
<td>Display</td>
<td>Operator Station Displays</td>
<td>03/03/2009 13:36:50</td>
</tr>
<tr>
<td>Docu</td>
<td>Documentation Project</td>
<td>03/03/2009 13:38:48</td>
</tr>
<tr>
<td>Tag_List</td>
<td>Tag List</td>
<td>03/02/2009 15:33:46</td>
</tr>
<tr>
<td>Vari_List</td>
<td>Variable List</td>
<td>03/02/2009 15:34:07</td>
</tr>
</tbody>
</table>

On entering the documentation manager, the print jobs available are shown beneath the menu line. The blank table lines represent the free print jobs.

The documentation jobs are structured in the following manner:

**Name**  job name, max. 12 characters, must begin with a letter, no special characters, no blanks.
Changing the Column Width

If the mouse pointer is placed on a column separation line, the mouse pointer changes to a horizontal arrow. With the left mouse button pressed, the column width can now be changed. This change is saved on quitting the document and is thus available for subsequent calls.

Menu Structure Documentation

Documentation:

Documentation
Insert new documentation job
Print
Print file
Printer setup
Comment
Preview
Export contents
Exit

Detail!

Edit
Field
Delete Field
Cut
Copy
Paste
Delete

Options
Hardcopy
Sort fields
Project scope
Notify print errors
Insert new documentation job

Place cursor on a blank line

> Documentation > Insert new documentation job

> Enter a documentation name into the field Name

Copy new documentation job

Place cursor on an existing line

> Documentation > Insert new documentation job

The contents of the already selected documentation job are accepted for the new one. In the following mask the new name must be entered or be taken from the old name.

A new documentation job can be created also by copying an old documentation job and saving it under a new name. All definitions concerning the documentation contents are also copied and can be modified later.

Comment

Project > Documentation > Documentation > Comment

A long comment can be made here on the selected print job, describing the contents.
For information on describing the contents of comment, refer to Section 1, Project Manager, Editing a Project Comment on page 31.

Export contents

Project > Documentation > Documentation > Export contents

The table of contents of the selected job is saved in a CSV format with file extension *.dco. The file name and directory can be selected in a Windows menu, with the project directory being presented as a default and the first 8 characters of the documentation job name as file name. This file can be opened in table form with (for example, Excel), and worked on further.

Exit

Project > Documentation > Documentation > Exit

Exit the documentation menu, return to the project tree.
Compilation of the Drawing Header / Footer

General Information

In order to enter data into the drawing header/footer, the header and footer mask has been divided into several horizontal levels, so as to enhance the clarity of layout.

Project-Wide Drawing Header / Footer

A drawing header/footer system-wide valid for the project is defined on the project level. All settings made in the header or footer are saved in the project.

Project manager > Project > Header

The texts entered into the upper section of the mask are allocated to the drawing footer or header. Refer to Section 1, Project Manager, General Information on the Project on page 20.
Editing the Drawing Header

> Project manager > Project > Header > Edit Drawing Header

Ok
Exit header entries, entries are saved.

Cancel
Exit header entries, entries are rejected.

Reset
All entries are accepted by means of the defaults from the file FRAMES.INI.

Merge
All variables are accepted with the defaults from the file FRAMES.INI (for example, all fixed texts are preserved).

Clear
All field contents are deleted.

Export
The current entries of the header are written into the file FRAMES.INI and are hence the new defaults for Reset and Merge.

By using Clear and then Export you will lose all entries!

Select
From the list field of the FRAMES.INI file a section can be selected. Its contents or default settings are then activated, when Reset or Merge is pressed.
**Preview**  
A preview showing the contents as they are printed is superimposed. The appearance of inserted bitmaps can thus be evaluated.

**Titles**  
The titles defined by the user are superimposed, giving a brief description of the field or of its intended contents. The field designation (for example, F52) is entered into the fields in which the user has not entered a header title designation.

**Editing the Header Title**

Project manager > Project > Header > Edit header title

Title designations, which can later be superimposed on the header inscription mask, can be entered into this mask.
Editing the Drawing Footer

Project manager > Project > Header > Edit Drawing Footer

**Ok**  Exit footer entries, entries are saved.

**Cancel**  Exit footer entries, entries are rejected.

**Reset**  All entries are accepted by means of the defaults from the file FRAMES.INI.

**Merge**  All variables are accepted with the defaults from the file FRAMES.INI (for example, all fixed texts are preserved).

**Clear**  All field contents are deleted.
Export

The current entries of the footer are written into the file FRAMES.INI and are hence the new defaults for Reset and Merge.

By using Clear and then Export you will lose all entries!

Select

A section from the file FRAMES.INI can be selected from the list field. Its content or pre-settings can then be activated when Reset or Merge are used.

Preview

A preview showing the contents as they are printed is superimposed. The appearance of inserted bitmaps can thus be evaluated.

Titles

The titles defined by the user are superimposed, giving a brief description of the field or of its intended contents. The field designation (for example, F24) is entered into the fields in which the user has not entered a footer designation.
Editing the Footer Title

Project manager > Project > Header > Edit footer title

Title designations, which can later be superimposed on the footer inscription mask, are entered into this mask.

Program-Specific Drawing Header / Footer

The project-specific frame inscription is valid initially for all sheets printed out from DigiVis 500 Graphics Builder. Each program features a menu item Program, Header. Both the drawing header and drawing footer can be defined under this menu item. However, each modification effected on this level is valid only for this one object.

An entry deviating from the default from the file FRAMES.INI is recognized by the fact the yellow field color changes to green. Hence, the fields Date and Name are program-specific in the following example.
Automatic Allocation of Object Parameters

To change entries, the cursor must be placed on a field and the required entry made. In the case of the fields for the header and footer inscription, a list of the frame inscription variables available in DigiVis 500 Graphics Builder (Documentation variables) can be called additionally with key F2. On selecting a variable, a corresponding explanatory text appears in the lower section. For a list of the variables, refer to Variables for Drawing Footer/ Header Inscriptions on page 152.

Bitmaps in the Drawing Footer

It is possible to implement bitmaps in the drawing footer, header and in the cover page.

The bitmaps are used from the directory <DigiVis 500_Installation_Folder> \bitmaps.

Refer to Fonts, National Languages and Bitmaps in the Drawing Footer / Header on page 154.

Any other bitmaps can be implemented with #bitmap name, if they are saved in the <DigiVis 500_Installation_Folder>\bitmaps directory.
Define the Documentation Job

Creating a New Print Job

The easiest way to create a new print job is to select the field NAME with a double-click of the mouse and enter an unequivocal name. Then an explanatory text can be entered into the field COMMENT: In the field LAST REVISION, the date and time are entered automatically by the system. Now the menu item Detail is selectable and the documentation scope required under this job is selected.
**Detail of the Print Job**

> Project > Documentation > Documentation > Detail

### Documentation scope

**All selected objects on the same level**

All objects located on the same project tree level as the selected junctions are documented.

**All successive objects**

All objects underneath the present selection in the project tree are documented. The documentation scope is thus also determined by the selection in the project tree. By selecting, a summary of the desired documentation contents (sheet type) can be indicated for the previously selected job. The >> field is enabled if the appropriate sheet type was selected. The significance of the individual sheet types will now be described.
Cover Page

If this field is selected, a cover page is output before the documentation job, featuring all data relevant to the project, such as name, comment, date, project number and so on.
Index

If this field is selected, a table of contents is output before the documentation job, featuring a list of all documents printed out, according to the specified order. Refer to Sorting the Output on page 138.
Documentation Settings

If this field is selected, a sheet is output featuring the settings selected for the print job.

<table>
<thead>
<tr>
<th>Formular</th>
<th>Contents</th>
<th>S Sort order:</th>
<th>Wildcard</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Coverpage</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Index</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>All levels</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Project tree</td>
<td>Full expanded</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Headers</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Programs</td>
<td>Contents</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>CE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parametrisation data</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Comments</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Variable list</td>
<td>List</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CE List</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>X</td>
<td>Name</td>
</tr>
<tr>
<td></td>
<td>Comment</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Data type</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Station name</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Export</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Group type</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Process image</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Initial value</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OPC Address</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

1019us.eps
Project Tree

> Project > Documentation > Detail > Project tree > >>

Documentation of the project tree can be effected in the present state (for example, parts blanked out) or as a whole. Furthermore, if required, the comments or header information can also be output for the project tree elements to be documented.

Program Documentation

> Project > Documentation > Detail > Select Programs > >>
The programs selected in the project tree are documented with their contents. A wide variety of sheet types can be selected in a documentation job.

Program contents
Graphic displays. The documentation form depends on the program type. It corresponds to the screen display in the corresponding program.

Cross references
The cross reference of the variables of the associated program are documented. Cross references list the variables if they have several sources or targets and cannot be displayed.

Parameter Data
The parameter data for the resources of the program are documented.

Comment
Comment sheets are output for the programs.

Variables List

> Project > Documentation > Detail > Variables list > >>

Specify which parts of the variables lists are to be printed.
Select the required fields:

All the selected variables are printed as a list, featuring supplementary information such as comment, type, resource and so on.

It is also possible to define how the list is **Sorted**.

It can be sorted according to **Variable name, Data type or Resource**

The list size can be limited by a selection with wildcards.

The variables which have a cross reference into the selected part of the project tree are printed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Comment or component name</th>
<th>Type</th>
<th>Res.</th>
<th>X</th>
<th>Module</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>FI701</td>
<td>X-Wert FIC701</td>
<td>REAL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FI702</td>
<td>X-Wert FIC702</td>
<td>REAL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FIC702MA</td>
<td>Status Hand/Auto</td>
<td>BOOL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FY701</td>
<td>Y-Wert FIC701</td>
<td>REAL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FY702</td>
<td>Y-Wert FIC702</td>
<td>REAL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>W000_var</td>
<td>W für FIC701,FIC702</td>
<td>REAL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>auto_2</td>
<td>Pulssignal für BA:Automatik</td>
<td>BOOL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>hand</td>
<td>Pulssignal für BA:Hand</td>
<td>BOOL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
<tr>
<td>track_zu</td>
<td>Track: Zuflußregler</td>
<td>BOOL</td>
<td>PS01</td>
<td>N</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Section 4  Documentation

Detail of the Print Job

*Type*  
Data type as REAL, BOOL or WORD

*D-OS*  
Allocation of resource

*OPC address*  
Name of the OPC Server with which the variable is associated

**Variables Cross Reference List**

> Project > Documentation > Detail > Variables crossreference > >>

A crossreference list of the variables used in programs and displays can be output. The same selection window is displayed as for the variables list. Refer to Program Documentation on page 126.
### Variable name
- max. 16 character

### Comment
- max. 34 character

### Type
- Data type as REAL, BOOL...

### D-PS
- Allocation of resource

### X
- Enable variable for reading other resources

### DocId
- Document type

### DocKz
- Document identification

### Type
- Display type (FGR, OVW)

### A
- Source or sink of variables, R = Read, W = Write.
Tags List

Specify which parts of the tag list are to be printed.
Select the required fields.
All the selected modules are printed as a list, featuring supplementary information such as comment, type name, resource and so on.
It is also possible to define how the list is sorted. It can be sorted according to Tag name, Type name, Area.
The list size can be limited by a selection with wildcards.
### Name
Tag name, max. 12/16 characters

### A
Plant area (A-O)

### R
Processing state
+ Block being processed (processing).
- Block not being processed (processing).
? Block undefined (processing)

### Short/long text
max. 12/30 characters

### Type name
Brief designations of the function block type

### L
S = Standard tag library

### P
# Block not checked for plausibility
@ Block checked for plausibility
Tags Cross References

> Project > Documentation > Detail > Tags cross reference > >>

The dialog box is the same as for the tags list. Refer to Variables Cross Reference List on page 130.
<table>
<thead>
<tr>
<th>Tag name</th>
<th>Name of the function block, max. 12/16 characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short/long text</td>
<td>max. 12/30 characters</td>
</tr>
<tr>
<td>Type name</td>
<td>Brief designations of the function block type</td>
</tr>
<tr>
<td>D-PS</td>
<td>Allocated resource</td>
</tr>
<tr>
<td>R</td>
<td>Cross reference code, ? = no CR, + = CR exists</td>
</tr>
<tr>
<td>DocId</td>
<td>Document type</td>
</tr>
<tr>
<td>DocKz</td>
<td>Document identification</td>
</tr>
</tbody>
</table>
Network

> Project > Documentation > Detail > Select Network

Message Configuration

> Project > Documentation > Detail > Select Message Configuration
Plausibility Check Errors

> Project > Documentation > Detail > Plausibility check errors > >>

The plausibility check errors can be output. If the field *Warnings and hints* is selected, messages are output additionally.

Display Access

> Project > Documentation > Detail > Display access > >>

The display allocations are documented as tables.
### Tag name
Tag name of the allocated tag

### Display name
Display names of the displays which are allocated to the tag

### Default
Yes if the display is defined as the default display

### Item List

- Project
- Documentation
- Detail
- Item List

---

**Item List**

<table>
<thead>
<tr>
<th>Tag name</th>
<th>Display name</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend_10</td>
<td>TREND_10</td>
<td>N</td>
</tr>
<tr>
<td>L1120_G1</td>
<td>AK11</td>
<td>N</td>
</tr>
<tr>
<td>L1200_G1</td>
<td>Trend_11</td>
<td>N</td>
</tr>
<tr>
<td>L1300_G1</td>
<td>Trend_12</td>
<td>N</td>
</tr>
<tr>
<td>L1400_G1</td>
<td>Trend_13</td>
<td>N</td>
</tr>
<tr>
<td>L1500_G1</td>
<td>Trend_14</td>
<td>N</td>
</tr>
<tr>
<td>L1600_G1</td>
<td>Trend_15</td>
<td>N</td>
</tr>
<tr>
<td>L1700_G1</td>
<td>Trend_16</td>
<td>N</td>
</tr>
<tr>
<td>L1800_G1</td>
<td>Trend_17</td>
<td>N</td>
</tr>
<tr>
<td>L1900_G1</td>
<td>Trend_18</td>
<td>N</td>
</tr>
<tr>
<td>L2000_G1</td>
<td>Trend_19</td>
<td>N</td>
</tr>
<tr>
<td>L2100_G1</td>
<td>Trend_20</td>
<td>N</td>
</tr>
</tbody>
</table>

---

**Stat. Revision Name Norm**

<table>
<thead>
<tr>
<th>Date</th>
<th>Resp.</th>
<th>Check</th>
<th>Norm</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Title**

DISPLAY ACCESS

**Custom.D. No.**

123456789012

**PL6**

Customer

Product Management

Origin

Project Management

Cre.f.

Cre.b.

Title

DISPLAY ACCESS

**Display Access**

**Copyright DIN 34"
Documentation Scope

Hard Disk Requirement

If several sheets are generated (for example, an entire project), please ensure that there is enough space available on the temporary disk. Three sheets are always combined for one print job for the Windows print manager. This ensures that already at the time of creating the print job for DigiVis 500 Graphics Builder, the first data can be transferred to the printer. Generation of the print data and output to the printer are hence effected with a slight delay and the first temporary data can be deleted again.

Viewing Selected Documentation Scope

> Project > Documentation > Documentation > Preview

A table of contents of the sheets that have been selected in the previously selected documentation job is displayed as shown in the following table.

<table>
<thead>
<tr>
<th>DocID</th>
<th>DocKz</th>
<th>OBJID</th>
<th>Title1</th>
<th>Title2</th>
<th>Function</th>
<th>Custom.D.No.</th>
<th>Date0</th>
<th>Check</th>
</tr>
</thead>
<tbody>
<tr>
<td>EAA10</td>
<td>COV</td>
<td></td>
<td>COVERPAGE</td>
<td></td>
<td></td>
<td>123456789012</td>
<td>30.05.00</td>
<td></td>
</tr>
<tr>
<td>EAB12</td>
<td>MAC</td>
<td></td>
<td>SETTINGS</td>
<td>DOCUMENTATION</td>
<td></td>
<td>123456789012</td>
<td>30.05.00</td>
<td></td>
</tr>
<tr>
<td>EEC10</td>
<td>TAG</td>
<td></td>
<td>TAG LIST</td>
<td></td>
<td></td>
<td>123456789012</td>
<td>30.05.00</td>
<td></td>
</tr>
<tr>
<td>EFP15</td>
<td>CR_V</td>
<td></td>
<td>CROSS-REFERENCE</td>
<td>VARIABLE LIST</td>
<td></td>
<td>123456789012</td>
<td>30.05.00</td>
<td></td>
</tr>
</tbody>
</table>

Sorting the Output

Start in Window “Configuration: Documentation”

> Project > Documentation > Options > Sort fields
Sorting of the output can be defined. Documentation output can be sorted according to a maximum of 5 criteria (64, 20, 20, 12, 3 characters). The field contents of the drawing footer can be selected as sorting criteria. Refer to Field Names in the Drawing Footer / Header on page 149. The standard setting of DigiVis 500 Graphics Builder is shown in the example.

Each sorting criterion set here automatically becomes a column in the table of contents when printing out. Sorting to date is not possible!

Selecting the Project Tree Objects

Start in Window “Configuration: Documentation”

> Project > Documentation > Options > Project scope
In this mask a selection of the project tree objects From - To (only in the order of the project tree objects) can be made for the printout, if this has not already been selected itself for printout in the project tree.

**Selecting Notify Print Errors**

> Project > Documentation > Options > Notify print errors

At this point, you determine whether errors appearing in connection with the printing of the project documentation, such as printing errors, missing objects (for example, bitmaps) and invalid or undefined field functions in drawing header/footer, are displayed on the screen.

The following error message appears:

![Error Message]

**Printing Documentation**

**Print**

Start in Window “Configuration: Documentation”

> Project > Documentation > Documentation > Print

![Print Window]
Start printing to a file or directly to the printer.

**Yes**  
The output is effected to the standard printer entered in Windows. Depending on the printer option, the print quality can still be adapted and the number of required copies entered. Printing can be aborted with Cancel. Using the Setup button, another printer type other than the standard printer can be selected if necessary, refer to **Printer Setup** on page 143. A message box is displayed as a further indication that the printer is set to DIN A4 landscape format.

**No**  
It is possible to print to file. If this option is selected, a window opens and the path, file name of the target file can be edited here. Default setting for the file name: name of the print job with the extension “.DPD”; Default setting for the path: “\DigiVis 500\PROJ”, refer to **Print File** on page 141.

**Cancel**  
Cancel printing

The maximum amount of hard disk space available must be kept in mind.

Refer to **Hard Disk Requirement** on page 138. The preview function should be used to get a survey of the print scope. Refer to **Viewing Selected Documentation Scope** on page 138.

**Print File**

Start in Window “Configuration: Documentation”

> Project > Documentation > Documentation > Print file
Print out a previously generated print file: The file to be printed is selected in a special Windows selection box. The files will be saved with the extension .DPD.
Printer Setup

Start in Window “Configuration: Documentation”

> Project > Documentation > Documentation > Printer setup

Select the printer. If a printer other than the standard printer is to be used, Special Printer is selected and the associated button is clicked with the mouse pointer. Now the required printer can be selected. Under Options fine adjustments can be made for the selected printer, see Windows documentation for this purpose.

The selected paper format (DINA4, letter) is supported. Default: landscape format.

Adjustments for the page layout can be changed under DigiVis 500 Graphics Builder > Configure, page layout.
Comment Field Editing

Edit Comment Field

Project > Documentation > Comment > Edit > Text input

The text contents of the comment field can be changed.

Export Comment Field

> Project > Documentation > Comment > Edit > Export

The text content of the comment field is saved as a text file *.txt, and serves as a basis for new print job comments. This text file is stored in unicode format.
Import Comment Field

> Project > Documentation > Comment > Edit > Import

The text content of an originally exported comment field (saved as a text file *.txt) is inserted into the selected print job. Existing entries are completely overwritten. At this point, any desired text can be inserted as long as it is changed into unicode format.
## Tables

### Document Types

<table>
<thead>
<tr>
<th>Term</th>
<th>Type</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Documentation-Description Documents</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Title-/cover pages</td>
<td>EAA10 COV</td>
<td>Title page</td>
</tr>
<tr>
<td>Directories</td>
<td>EAB11 IND</td>
<td>Table of Contents</td>
</tr>
<tr>
<td></td>
<td>EAB12 MAC</td>
<td>Setting the documentation job</td>
</tr>
<tr>
<td><strong>General Technical Information Documents</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gen.techn. doc.</td>
<td>EDY10 MAN</td>
<td>Project tree</td>
</tr>
<tr>
<td></td>
<td>EDY12 OBJ</td>
<td>Head confi./resource</td>
</tr>
<tr>
<td></td>
<td>EDY19 OBJ</td>
<td>Comment</td>
</tr>
<tr>
<td></td>
<td>EDY20 HWM</td>
<td>Tree view</td>
</tr>
<tr>
<td></td>
<td>EDY22 NET</td>
<td>Network</td>
</tr>
<tr>
<td></td>
<td>EDY30 SYS</td>
<td>Graphic view</td>
</tr>
<tr>
<td></td>
<td>EDY33 MOD</td>
<td>Module parameters</td>
</tr>
<tr>
<td><strong>Technical Requirements and Dimension/Design Documents</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tag lists</td>
<td>EEC10 TAG</td>
<td>Tag list</td>
</tr>
<tr>
<td></td>
<td>EEC11 CR_T</td>
<td>Cross-reference tag list</td>
</tr>
<tr>
<td><strong>Function-Description Documents</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Signal descriptions</td>
<td>EFP10 VAR</td>
<td>Variables list</td>
</tr>
<tr>
<td></td>
<td>EFP15 CR_V</td>
<td>Cross-reference variable list</td>
</tr>
<tr>
<td>freely available</td>
<td>EFQ10 I/O</td>
<td>I/O components</td>
</tr>
<tr>
<td>freely available</td>
<td>EFL10 OV</td>
<td>Overview display</td>
</tr>
<tr>
<td></td>
<td>EFL15 OV</td>
<td>Overview display cross references</td>
</tr>
<tr>
<td>Term</td>
<td>Type</td>
<td>Name</td>
</tr>
<tr>
<td>--------</td>
<td>------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>EFL19</td>
<td>OV</td>
<td>Overview display comment</td>
</tr>
<tr>
<td>EFL20</td>
<td>GRU</td>
<td>Group display</td>
</tr>
<tr>
<td>EFL25</td>
<td>GRU</td>
<td>Group display cross-reference</td>
</tr>
<tr>
<td>EFL29</td>
<td>GRU</td>
<td>Group display comment</td>
</tr>
<tr>
<td>EFL50</td>
<td>FGR</td>
<td>Graphic display (graphic)</td>
</tr>
<tr>
<td>EFL53</td>
<td>FGR</td>
<td>Graphic display (parameters)</td>
</tr>
<tr>
<td>EFL55</td>
<td>FGR</td>
<td>Cross-references graphic display</td>
</tr>
<tr>
<td>EFL59</td>
<td>FGR</td>
<td>Comment graphic display</td>
</tr>
<tr>
<td>EFL70</td>
<td>TR_D</td>
<td>Trend display</td>
</tr>
<tr>
<td>EFL73</td>
<td>TR_D</td>
<td>Trend display chart parameters</td>
</tr>
<tr>
<td>EFL75</td>
<td>TR_D</td>
<td>Trend display cross-references</td>
</tr>
<tr>
<td>EFL79</td>
<td>TR_D</td>
<td>Trend display comment</td>
</tr>
<tr>
<td>EFL81</td>
<td>MSG</td>
<td>Local message processing</td>
</tr>
<tr>
<td>EFL82</td>
<td>DSP</td>
<td>Display allocation</td>
</tr>
<tr>
<td>EFM10</td>
<td>ERR</td>
<td>Plausibility check error</td>
</tr>
<tr>
<td>EFR10</td>
<td>SSL1</td>
<td>Signal sequence log automatic</td>
</tr>
<tr>
<td>EFR13</td>
<td>SSL1</td>
<td>Signal sequence log parameter auto.</td>
</tr>
<tr>
<td>EFR15</td>
<td>SSL1</td>
<td>Signal sequence log cross-ref. auto.</td>
</tr>
<tr>
<td>EFR19</td>
<td>SSL1</td>
<td>Signal sequence log comment auto.</td>
</tr>
<tr>
<td>EFR20</td>
<td>SSLN</td>
<td>Signal sequence log, manual</td>
</tr>
<tr>
<td>EFR23</td>
<td>SSLN</td>
<td>Signal sequence log parameter manual</td>
</tr>
<tr>
<td>EFR25</td>
<td>SSLN</td>
<td>Signal sequence log cross-ref. manual</td>
</tr>
<tr>
<td>EFR29</td>
<td>SSLN</td>
<td>Signal sequence log comment manual</td>
</tr>
</tbody>
</table>
Description of the Fields or Contents

All fields used in the documentation must be unequivocal (for example, each field is given a serial number F1-F62). This is used for describing the field titles, if no other entry has been made. For a definition of the fonts used, refer to Fonts, National Languages and Bitmaps in the Drawing Footer / Header on page 154.

Drawing Footer:
### Section 4  Documentation

#### Field Names in the Drawing Footer / Header

- The following table shows the correlation between:
  - Field designation (FIELD)
  - Default variable (CONTENTS)
  - Default title (TITLE)
  - Description or contents of the field according to DIN (COMMENT)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>CONTENTS</th>
<th>TITLE</th>
<th>COMMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>F0</td>
<td>Sta1</td>
<td></td>
<td>State 1 of printout</td>
</tr>
<tr>
<td>F1</td>
<td>Sta2</td>
<td></td>
<td>State 2 of printout</td>
</tr>
<tr>
<td>F2</td>
<td>Sta3</td>
<td></td>
<td>State 3 of printout</td>
</tr>
<tr>
<td>F3</td>
<td></td>
<td>Sta</td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F4</td>
<td>$ObjDate</td>
<td></td>
<td>Revision1</td>
</tr>
<tr>
<td>F5</td>
<td></td>
<td></td>
<td>Revision2</td>
</tr>
<tr>
<td>F6</td>
<td></td>
<td></td>
<td>Revision3</td>
</tr>
<tr>
<td>F7</td>
<td>Revision</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F8</td>
<td></td>
<td>Date1</td>
<td>Date1 of revision</td>
</tr>
<tr>
<td>FIELD</td>
<td>CONTENTS</td>
<td>TITLE</td>
<td>COMMENT</td>
</tr>
<tr>
<td>-------</td>
<td>------------</td>
<td>---------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>F9</td>
<td>Date2</td>
<td>Date1 of revision</td>
<td></td>
</tr>
<tr>
<td>F10</td>
<td>Date3</td>
<td>Date1 of revision</td>
<td></td>
</tr>
<tr>
<td>F11</td>
<td>Name</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F12</td>
<td>Norm1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F13</td>
<td>Norm2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F14</td>
<td>Norm3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F15</td>
<td>Norm</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F16</td>
<td>Date</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F17</td>
<td>Resp</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F18</td>
<td>Check</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F19</td>
<td>Norm0</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F20</td>
<td>$ObjCDat</td>
<td>Date0</td>
<td>Compilation date</td>
</tr>
<tr>
<td>F21</td>
<td>$PrjMan</td>
<td>Resp</td>
<td></td>
</tr>
<tr>
<td>F22</td>
<td>$ObjS</td>
<td>Check</td>
<td>Checked by</td>
</tr>
<tr>
<td>F23</td>
<td></td>
<td>Norm0</td>
<td></td>
</tr>
<tr>
<td>F24</td>
<td>Customer</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F25</td>
<td>#Logocust.bmp</td>
<td>Customer logo (bitmap) or text</td>
<td></td>
</tr>
<tr>
<td>F26</td>
<td>Origin</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F27</td>
<td></td>
<td>Origin</td>
<td>Original of</td>
</tr>
<tr>
<td>F28</td>
<td>Cre.f.</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F29</td>
<td></td>
<td>Cref</td>
<td></td>
</tr>
<tr>
<td>F30</td>
<td>%LogoComp</td>
<td>Company logo (bitmap)</td>
<td></td>
</tr>
<tr>
<td>F31</td>
<td>Cre.b.</td>
<td>Fixed text in frame</td>
<td></td>
</tr>
<tr>
<td>F32</td>
<td></td>
<td>Creb</td>
<td></td>
</tr>
</tbody>
</table>
## Field Names in the Drawing Footer / Header

<table>
<thead>
<tr>
<th>FIELD</th>
<th>CONTENTS</th>
<th>TITLE</th>
<th>COMMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>F33</td>
<td>Title</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F34</td>
<td>$DocTypeName1</td>
<td>Title1</td>
<td>Drawing name1</td>
</tr>
<tr>
<td>F35</td>
<td>$DocTypeName2</td>
<td>Title2</td>
<td>Drawing name 2</td>
</tr>
<tr>
<td>F36</td>
<td>Custom.D.No.</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F37</td>
<td>$PrjOrdNr</td>
<td>Custom.D.No.</td>
<td>Customer drawing number</td>
</tr>
<tr>
<td>F38</td>
<td>==</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F39</td>
<td>$PrjName</td>
<td>Localization</td>
<td>Installation site</td>
</tr>
<tr>
<td>F40</td>
<td>Proj.No.</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F41</td>
<td>$PrjNr</td>
<td>Proj.No.</td>
<td>Project number</td>
</tr>
<tr>
<td>F42</td>
<td>&amp;</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F43</td>
<td>$DocT</td>
<td></td>
<td>Key to documentation type</td>
</tr>
<tr>
<td>F44</td>
<td>Doc.T.</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F45</td>
<td>$ObjKz</td>
<td></td>
<td>Object designation</td>
</tr>
<tr>
<td>F46</td>
<td>=</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F47</td>
<td>$ObjFunct</td>
<td></td>
<td>Function name of object</td>
</tr>
<tr>
<td>F48</td>
<td>+</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F49</td>
<td>$ObjLoc</td>
<td></td>
<td>Location of object</td>
</tr>
<tr>
<td>F50</td>
<td>P.</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F51</td>
<td>$PgNr</td>
<td></td>
<td>Sheet number</td>
</tr>
<tr>
<td>F52</td>
<td>%LogoLeft</td>
<td></td>
<td>Logo (bitmap) in upper left of header</td>
</tr>
<tr>
<td>F53</td>
<td>%LogoRight</td>
<td></td>
<td>Logo (bitmap) in upper right of header</td>
</tr>
<tr>
<td>F54</td>
<td>Name:</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F55</td>
<td>Comment:</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F56</td>
<td>$ObjName</td>
<td></td>
<td>Name of object (Path in the project tree)</td>
</tr>
</tbody>
</table>
### Variables for Drawing Footer/ Header Inscriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>CONTENTS</th>
<th>TITLE</th>
<th>COMMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>F57</td>
<td>$ObjComm</td>
<td></td>
<td>Comment of object</td>
</tr>
<tr>
<td>F58</td>
<td>Start:</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F59</td>
<td>End:</td>
<td></td>
<td>Fixed text in frame</td>
</tr>
<tr>
<td>F60</td>
<td>$DocStart</td>
<td></td>
<td>Start of selected print scope</td>
</tr>
<tr>
<td>F61</td>
<td>$DocEnd</td>
<td></td>
<td>End of selected print scope</td>
</tr>
<tr>
<td>F62</td>
<td>$ObjId</td>
<td></td>
<td>Type of editor</td>
</tr>
</tbody>
</table>

### Variables for Drawing Footer/ Header Inscriptions

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>$</td>
<td>Avoids overriding through the project name</td>
</tr>
<tr>
<td>$DocEnd</td>
<td>End of the selection range in the project tree (depends on the documentation job)</td>
</tr>
<tr>
<td>$DocStart</td>
<td>Start of the selection range in the project tree (depends on the documentation job)</td>
</tr>
<tr>
<td>$DocT</td>
<td>DIN number of the current documentation type (Hardcoded, language dependent).</td>
</tr>
<tr>
<td>$DocTypeName1</td>
<td>First part of the name of the current documentation type. (Hardcoded, language dependent).</td>
</tr>
<tr>
<td>$DocTypeName12</td>
<td>Name of the current documentation type. (Hardcoded, language dependent)</td>
</tr>
<tr>
<td>$DocTypeName2</td>
<td>Second part of the name of the current documentation type. (Hardcoded, language dependent).</td>
</tr>
<tr>
<td>$ObjCDat</td>
<td>Creation date of the current documentation object. (If available)</td>
</tr>
<tr>
<td>$ObjComm</td>
<td>Short comment to the current documentation object. (If available)</td>
</tr>
<tr>
<td>$ObjDate</td>
<td>Date of the current documentation object. (If available)</td>
</tr>
</tbody>
</table>
### Command | Function
--- | ---
$\text{ObjFunct}$ | Name of the current project tree object. (If available)
$\text{ObjId}$ | Short Id to the current documentation object. (hardcoded, language dependent, typically 3 capital letters)
$\text{ObjKz}$ | Documentation identifier of the current object.
$\text{ObjLoc}$ | Localization of the current object.
$\text{ObjName}$ | Name of the current documentation object. (For example, name of the project tree object).
$\text{ObjS}$ | State of the current documentation object. (CORRECT, INCORRECT)
$\text{PgNr}$ | Current page No. of the print job.
$\text{PrintDate}$ | Date of the print issue.
$\text{PrjComm}$ | Comment of the current project. (Editable in the project header)
$\text{PrjDate}$ | Date of the current project. (As shown in the project header)
$\text{PrjMan}$ | Manager of the current project. (Editable in the project header)
$\text{PrjName}$ | Name of the current project.
$\text{PrjNr}$ | Number of the current project. (Editable in the project header)
$\text{PrjOrd}$ | Orderer of the current project. (Editable in the project header)
$\text{PrjOrdNr}$ | Order number of the current project. (Editable in the project header)
$\text{LogoComp}$ | Default bitmap for your company.
$\text{LogoCover}$ | Default bitmap for your cover page.
$\text{LogoCust}$ | Bitmap for customer project
$\text{LogoLeft}$ | Default bitmap for the upper left corner.
$\text{LogoRight}$ | Default bitmap for the upper right corner.
Allocation of displays (only BMP files are permitted) is carried out in the Windows Registry. Refer to Fonts, National Languages and Bitmaps in the Drawing Footer / Header on page 154.

**Fonts, National Languages and Bitmaps in the Drawing Footer / Header**

The fonts or the bitmaps used are defined in the Windows Registry.
Section 4 Documentation  Fonts, National Languages and Bitmaps in the Drawing Footer / Header

BitmapDefaultDir=<DigiVis 500_Installation_Folder>\bitmaps
Directory containing the bitmaps

BitmapDir=<DigiVis 500_Installation_Folder>\bitmaps
Temporary directory

Font0=Arial, Italic, Size 20
in example A

Font1=Courier New, Size 22
in example B

Font2=Courier New, Size 22
in example C

Font3=Courier New Bold, Size 40
in example D

Font4= Courier New, Size 30
in example E

Font5=Courier New Bold, Size 60
in example F

Font6=Courier New Bold, Size 100
inscription of cover page

Font7=Courier New Bold, Size 50
Inscription of cover page

Frame_Default_File=<DigiVis 500_Installation_Folder>\exe\frames.ini
path and file with the default field entries

Frame_Default_Sect=FRAMEUS
languages section in the file Frames.ini

LogoComp=LogoComp.bmp
Name of bitmap for company logo

LogoCover=LogoCove.bmp
Name of bitmap for cover logo

LogoLeft=LogoLeft.bmp
Name of bitmaps for the upper left corner

LogoRight=LogoRigh.bmp
Name of bitmap for the upper right corner
Using Fonts in the Drawing Footer

Using Fonts in the Drawing Header
Presetting the Field Contents and Titles

The presets for the field contents or titles are located in the file FRAMES.INI. Hence in the English version the section FRAMESUS is used as default. But another section can also be selected.

Refer to Fonts, National Languages and Bitmaps in the Drawing Footer / Header on page 154.

Generally the file is located in the directory `<DigiVis 500_Installation_Folder>\exe` and can be edited with any ASCII editor (for example, EDIT of DOS or the EDITOR of WINDOWS).

The editor used must not append any control characters to the file!

The lines with the code FIELD_CONT_Pxx (xx=0..62) define the required field contents for the printout. The lines with the code FIELD_TITLE_Pxx (xx=0..62) specify a title for the fields. The title text can be superimposed at any time while entering the field contents to be printed, in order to show the user which entry is to be made in the fields.
Section 5  OPC Items

General Description - OPC Items

OPC items are the variables that are exposed by the OPC Server(s) configured in the DigiVis 500 system. The OPC Items dialog is used to browse the OPC items from the OPC Server(s), instantiate the OPC Items using Tag Types and to assign variables to Items in the variable list.

The OPC items could be of two types: Data Access and Alarm and Events items.

The column widths in the list can be adjusted with the mouse, holding the left button down. However the total length of the columns cannot be made wider than the OPC items dialog.

Calling up the OPC Item List

> System > OPC Item list

The OPC item list is called using the menu item System.
Structure of the OPC Item List

The OPC Item list is structured as follows:
The DA items are displayed in the left hand side window of the *OPC Items* dialog and the AE items in the right hand side window.

### DA Items

- **Server Name**  
  OPC Server name, max. 4 characters

- **Item Name**  
  OPC DA data item name

- **Data Type**  
  OPC item data type, refer to Section 7, Variables.

- **Access Right**  
  Access rights can be of the following 3 types
  - **R** Indicates a read access on the DA item
  - **W** Indicates a write access on the DA item
  - **RW** Indicates a read as well as write access on the DA item

- **Tag Name**  
  Name of the Tag using the OPC DA item, max. 16 characters.
**AE Items**

*Server Name*  
OPC Server name, max 4 characters

*Item Name*  
OPC AE data item name

*Condition*  
Type of alarms for the AE items

*Tag Name*  
Name of the Tag using the OPC AE item, max 16 characters.

---

**Context Menu**

**OPC Item List > Right click in OPC item list window**
Select all the items in a window

Context menu (right mouse button) > Select All

Select all the Items in the OPC Item List window from where the context menu is called.

Deselect all the items in a window

Context menu (right mouse button) > Deselect All

Deselect the Items selected in the OPC Item List window
Creating a new OPC item

Context menu (right mouse button) > New

Create a new Item in the OPC Item List window

Copy an OPC Item

Context menu (right mouse button) > Copy

Copies the selected OPC Item into the clipboard.

Paste an OPC Item

Context menu (right mouse button) > Paste

Pastes the clipboard data into the item list.

The pasted Item name is similar to the original name but appended with “_1”. It can then be renamed provided the Item name assigned exists in the OPC Server.

Browse the OPC items

Context menu (right mouse button) > Browse
Browse the OPC Items from a specific OPC Server.

Once an OPC Server is selected Import OPC items dialog is displayed. This dialog lists the OPC items that are available for browsing (for example, the OPC items that are not already added to the OPC items list).
Select the OPC items by tick marking the check box in front of it > **OK**

The OPC items dialog is updated with the new OPC items that are selected.

**Remove an OPC Item**

Context menu (right mouse button) > **Remove**

Deletes the selected OPC Item from the OPC Item List.

**Export the OPC item**

Context menu (right mouse button) > **Export**

Items of the Project Database are written into a file of type *OPC data item format* (*.dai)*.
Import the OPC item

Context menu (right mouse button) > **Import**

Import the OPC item(s) from an existing *.dai file

**Editing OPC Item List**

The OPC Item List editor can be used to modify the *Item Name, Server Name, Data Type* and *Access right* for an existing Item in the List.
To modify the Server Name

Click on the cell in the Server Name column corresponding to the OPC Item
>Change the Server name from the drop down list

The Server name is changed.

To modify the Item Name

Double click on the cell in the Item name column > change the item name

To modify the Data Type

Click on the cell in the Data Type column > select the Data type from the drop down list

For information on the available Data Types, refer to Section 7, Variables.

To modify Access Rights

Click on the cell in the Access Rights column > select the access right from the combo box
Synchronize

This option is used to synchronize the project database with the OPC Server.

During *Synchronization* the OPC Items in the OPC Item List, which do not have a corresponding OPC Item in the OPC Server, will be deleted.
The OPC item lists can be filtered using masks for specified columns. As soon as the user changes the filter mask for a column, both DA and AE item lists will be updated immediately using the filter.

Filter mask can be specified for Server name, Item name, Tag Name, Data type and Access Rights.
The item lists can be sorted using values in a specified column. As soon as the user clicks on the header of a specific column of one of the lists, the item list will be rearranged immediately according to the values of the items in this column. The current sort order (down or up) for the column will be shown in the header. The sort order for this column will be toggled by next sorting.

The user clicks on the header of the one of the columns in the DA/AE list; DA/AE list is sorted using values of the column.

**Assign Variable**

This button is used for creation of variables from OPC Items.

OPC items > Select the OPC item(s) > Assign Variable
The following **two** lists are displayed in this dialog:

- Objects to rename
- Objects to update

**Objects to rename**

These are the OPC items that are not assigned to a variable or are not part of a Tag Type.
Structure of the list

*Item name*

OPC item name

*Preview name*

Displays a preview of the new name as a result of pattern renaming, while modifying the old name of the OPC item.

*New name*

Predefined with names derived from the OPC Item. Maximum limit is 16 characters.

*Include in patterning*

If the checkbox for Include in patterning is selected then the pattern specified in the pattern rename dialog box gets updated in the New name column.

The system assigns a predefined *New name* for an OPC Item by scanning the Item name from right to left until a separator or a space is encountered.

After *Pattern rename > Execute*, the values in the *Preview name* column are updated in the *New name* column.

The new name assigned to a OPC item should be unique.

**Constraints on the characters used in the new name**

- Only the symbols “_” and “paragraph symbol” are allowed.
- Blank spaces are not allowed.
- A variable name consisting of only integers is not allowed.

Errors in the new *name column* are highlighted in RED.
Error Indications:

Error 1: Text in red

The variable name already exists.
Error 2: Cell in red

The new name contains characters that are not allowed.

In the above image the renaming of the OPC item “OPCS/PLC10..AIC_TIME2” has generated an error because the new name “AIC TIME2” is invalid as the special characters “and” are not allowed.

**Include in patterning**

Checking this option against an OPC item includes it in the patterning. When *Execute* button is pressed then the Preview Name for that variable is updated in the *New name* column.
In the above screenshot **Include in patterning** checkbox is selected for some of the OPC Items. When **Execute** button is pressed only the **Preview name** of these OPC Items are updated in the **New name** column. This is indicated in the following screenshot.
The **Include in patterning** checkbox is disabled automatically when an OPC item is manually renamed in the **New name** column.
Objects to update

These are the OPC items that are already assigned to a variable.

Filter

Filters by Server name
Filters the Object to rename list by the OPC Server

Filter by Original name
Filters the Object to rename list by the OPC item name. This filter is similar to windows search function.

Hide renamed
Hides the OPC items that are already renamed.

Show only errors
Shows only the items with errors

Show excluded
Shows the items whose names the user does not wish to change.

Show included
Shows the items whose names the user wishes to change. By default all items are included for renaming.

Exclude

All
Unchecks the Include in Patterning checkbox for all the OPC items.
None
Checks the *Include in Patterning* checkbox for all the OPC items.

Renamed
Unchecks the *Include in Patterning* checkbox for all the renamed OPC items.

Invert
Inverts the current state of the *include in patterning* checkbox.

Pattern Rename
Renames the OPC item based on a defined pattern. This is based on the standard pattern renaming algorithm.

Old Name
The name of the OPC item which is to be renamed.

New Name
The new name for the OPC item.

Use regular expression

- Only the wild card algorithm can be used for selecting a group of OPC items to be renamed.
- The pattern rename algorithm is used to select the OPC items. It is possible to group characters within an OPC Item name string and the New name can be defined based on combinations of these groups.
Execute

By pressing execute the New name for the OPC item will get updated by the Preview Name if the Include in Patterning check-box is enabled in the Objects to rename window.

Undo

Will undo the last renaming of a OPC Item

Patterning Algorithm

The following are a few of the elements used in the pattern matching:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>defines a group</td>
</tr>
<tr>
<td>[]</td>
<td>defines a range of characters</td>
</tr>
<tr>
<td>.</td>
<td>every character</td>
</tr>
<tr>
<td>*</td>
<td>multiples of character</td>
</tr>
<tr>
<td>^</td>
<td>exclude a character or set of characters</td>
</tr>
<tr>
<td>.d</td>
<td></td>
</tr>
<tr>
<td>+</td>
<td></td>
</tr>
<tr>
<td>-</td>
<td></td>
</tr>
</tbody>
</table>
The following screenshots contain a few examples to illustrate the use of the patterning algorithm.

Example 1:
Example 2:
Example 3:

To rename an OPC Item: Specify if an expression will be used by checking or unchecking the *Use regular expression* option > Type an expression or a wild card value in the *Old name* field > Type the desired rename pattern in the *New name* field > *Execute*. 

💡
Discard All
Will undo the renaming of the OPC items (clears the contents of the New name column in the Objects to rename window).

OK
After clicking on OK, a variable with the name in the new name column will be created in the Variable list. For information on variable, refer to Section 7, Variables.

Cancel
Exits from the OPC Items dialog.

Standard Library of Tag Types
A standard library of Tag Types specifically developed for DigiVis 500 system will be delivered along with the DigiVis 500 software.

Import the standard Tag Type library under the CONF node.

Project Tree > Select CONF node > Edit > Import block > browse and select the AC500 Standard TagTypeLibrary V1.0.prt file in the <DigiVis 500_Installation_Folder> \export folder.

The imported block moves to the POOL

Tag Instantiation
Select the OPC item(s) > Instantiate Tags

The button “Instantiate Tags” starts the instantiation proposal process for the items selected in the OPC Item list.
Selected items are sorted in groups by finding suitable Tag Types for them.

The results are shown in the **Instatiate Tags** dialog as above.

The Tags are grouped in 2 categories:

- **OPCS**
  - The selected Items are categorized according to their *Tag Types* under each OPC Server

- **Unknown**
  - OPC items in the no-match list
This dialog has a hierarchical tree view in the top-left side window:

**OPC Server /Tag Types/ Tags**

Every tree node has a tri-state check box indicating if the items under the node are completely, partially or not considered for the Instantiation.

In the top-right side window children or items contained in the selected tree node are shown.

**Ambiguous Tags**

Tags suiting more than one Tag Types are listed along with the various Tag Types. Every Tag in this list will be shown along with a drop down list of the various Tag Types that can be assigned to the Tag. User can then select the Tag Type from the drop down list.

**Cancel**

Exits from the *instantiate Tags* dialog without instantiating any Tags.

**OK**

Click on *Apply > OK*

After clicking on OK the rename dialog for Tag name will be displayed. This dialog will give the user the option of renaming Tags. For more information on renaming dialog refer **rename dialog of Assign Variable**.

The Tag Type is instanced with the Tag name. The *Tag name* columns in the OPC Items dialog will be updated after the Tag instantiation.
Instantiate All

*OPC items* dialog > **Instantiate All**

The button “Instantiate All” is used to instantiate tags with all items in the lists. All the OPC items except Ambiguous Tags will be instantiated. Rename dialog for Tag name will be displayed. This dialog will give the user the option of renaming Tags. For more information on renaming dialog refer *rename dialog of Assign Variable*. For modifying Tag Type refer to [Section 8, Tags](#).

When all the unique Tags are instantiated and if “Instantiate All” button is pressed, a message box indicating the result of the Instantiation will be displayed.

All Tag Types that are modified (for example, new selector added or the data type of the selector changed) have to be reinstantiated.

Creating of Customized Tag Types is not supported. Standard Tag Types are recommended to use from the available Tag Type Library in DigiVis 500. If Customized Tag Types are required, contact respective ABB Sales Organization.
Section 6  Reports

General Description of Reports

Reports are used to acquire and store data in user defined Microsoft Excel templates. A report is configured in DigiVis 500 Graphics Builder to acquire one or more samples of a set of variables. The reports functionality of DigiVis 500 supports storing acquired values in .xls/.xlsx format. Both configuration and display of such Excel based reports is possible. Excel reports are configured and edited in the Project Tree under the operator station resource or in the Common display pool (P-CD).

> Select an operator station resource or P-CD in the project tree

> Edit > Insert next level > Excel Reports

Excel report configured in the Common display pool (P-CD) are available to all operator stations.

Reports are downloaded to DigiVis after they are configured in Graphics Builder. The execution of the reports in DigiVis takes place depending on the configuration of reports in Graphics Builder.
**Name**  Max. 12 characters

**Version**  Date and time of object creation

**Type**  Type of the object being configured.

**Display cycle time**  Time for repeated update of the values of a report.

**Processing sequence**  Indicates the node position of this project object relevant to the operator station.

**Short comment**  Max. 159 characters.
Excel Reports Configuration

Double click on the Excel Report in the Project Tree > *Parameters: Report RPT* or select the Excel Report > right click > Edit.

General Data

**Name**
The name of the Excel Report. The name is specified when the Report node is inserted in the project tree and cannot be changed here.

**Short text**
A Short text can be assigned to the Excel Reports. Up to 12 characters can be entered.

**Long text**
A Long text can be assigned to the Excel Reports. Up to 30 characters can be entered.

Short and long text are output with the documentation of the project. In addition these texts can be configured for the header and footer of the printed report.
**Start/Stop**

*Automatic*  
Generation of the Excel Reports is done automatically on start of the DigiVis 500 Operator Station.

*Manual*  
Generation of the Excel Reports is to be done manually on start of the DigiVis 500 Operator Station.

**Define Template**  
Defines the template to be used for generation of the Excel Reports.

**Filing**

*in .. files*  
The number of Excel Report files which are generated on DigiVis 500 Operations PC are fixed. The value must be between 1 and 400.

For example, if the Restart after is specified as 1 day and In .. files is defined as 10 in Excel Reports of Graphics Builder, then 10 files are generated in 10 days.

*named*  
The name of the Excel Report file, which is stored on DigiVis 500 Operations PC hard disk. A preset name is assigned to the report. A new name can also be specified.

For example, if the name of the report is “report 1”, then in order to get 10 files each file will be appended with 001,002,...,010.

**Start Time**  
The Start Time is the time at which the Excel Report generation must be started.

For example, Start Time is configured as DT#2008-10-01-06:00:00.000 in Excel Reports of Graphics Builder. The Excel Report will be generated in manual or auto mode in DigiVis only when the configured start time is attained or reached.

**Cycles**  
No of cycles for the Excel Report generation.

For example, if Cycles = 2, and cycle time = 8 hours: first reading will be taken at 00:00 hours and the second reading will be taken at 8:00 hours.
**Cycle time**

The time of each cycle. For Excel Report generation, the time after which the next reading will be acquired in the report.

**Restart after**

Restart the generation of Excel Reports after a specified amount of time.

Restart after = Cycles * Cycle time.

For example, Restart after is configured as T#1h0m0s, the number of Cycles defined is 60, and Cycle time is T#0h1m0s in Excel Reports of Graphics Builder. The Excel Report with 60 Entries will be generated in DigiVis. The generation of new Excel Report file will be started after one hour.

**Printing Tab - Excel Reports**
Print to

*Printer 1 / 2* Two printer channels are available for report output on to printers. Select the printer by activating the corresponding radio button in front of it.

Print

*Manual* The printing of reports can be activated **manually** by the operator at the operator station.

*Automatic* Printing takes place automatically after completion of logging of values in the report

Delete Log files

*Automatic* When the **automatic delete** option is selected and the configured number of files is exceeded, the oldest report file is overwritten by the current file, just before the Restart after time is about to start. In this case it will delete it after one day before the next cycle starts. If the **automatic delete** option is not selected then **Excel Report generation is stopped** as soon as the max. number of files has been reached, and it gives a system message indicating that the amount of files is exceeded.

*Manual* By checking this option the operator can select individual report files and delete them from DigiVis 500 Operations.

File Transfer Tab – Excel Reports

This tab is used to define parameters for copying the stored Excel Reports to other data carriers, primarily external devices, for data protection and archiving purposes.
If a copy of the report file is to be transferred from the DigiVis 500 PC to another PC and how it is to be done is specified here. The PC selected to receive the archives must have a network communication link to the DigiVis 500 PC and an FTP Server (for example, Windows XP/Windows 7 “Internet Information Server (IIS)”) must be installed. For information on FTP, refer to DigiVis 500 Getting Started Manual.

Archives are normally sent to a target station which is not identical with the DigiVis 500 PC. A further possibility is to export the archive files to a Windows drive on the DigiVis 500 PC. This drive can be mapped on to another PC in the Windows network. In this case the station address is its own TCP-IP address.

**Automatic file transfer (FT) after file completion**

The mode of file transfer is specified here.

**Enable/disable**

- **Enable FT on DigiVis start**
  
  File transfer starts automatically on start of DigiVis 500 Operations.
File transfer has to be started manually after DigiVis 500 Operations is started.

**Manual controlled**

- The operator at the operator station can enable or disable file transfer.
- File transfer cannot be enable or disabled by the operator.

**Manual FT**

**Access**

- The operator at the operator station can start the file transfer at any time by pressing the File trans button.
- The operator is not given the option of spontaneously starting the File transfer.

**Target**

The target station to which the data is to be transferred should be specified here.

- **Station**: IP address of the target computer. If the DigiVis 500 PC is to be used as export target then its own IP address must be entered here.

- **Path**: If the archive files are to be copied to a specific directory, the complete directory name must be specified here. If IIS is used on the target station then path preselection is possible. For example, the path C:\ARCHIV\STATION\SFP for the target computer can mean that it diverts all archives that are received to the preset path C:\ARCHIV, and the incoming archive contributes the path information \STATION1\SFP.
The files that are transferred are temporary and are overwritten the next time the corresponding archive is exported. The target path to the archive storage must exist and should not be write-protected.

**File**

The export files are stored with this file name under the Target Path. For example, STATION1\SFP\SFP_MANUFACTURE. This file is overwritten in every export.

Path and file name together can have a max. length of 100 characters.

**Directory [8.3]**

The export files are transferred in DOS format – for example, to a PC with WfW Operating System and active FTP Server. The file name corresponds to the export date in the format ‘YMMDDHHm.mss’ (for example, 70528162.320).

The file name contains no information about the archive type. Choose a suitable path name to ensure that it is recognizable afterwards.

**Directory**

The export files are stored in the directory shown under Target Path with their original name (defined in General Tab). The export date in the format ‘.YYMMDDHHmmss’ is also appended to the name (separated by a period).

For example, SFP MANUFACTURE.970528162320. Path and file name together may have a total length of 100 characters.

**FTP timeout**

In order to prevent the system from becoming congested a maximum time should be entered here within which a transfer must be completed. If timeout is exceeded, it causes a system alarm in DigiVis 500.

**User name**

Enter a user name which is known to the FTP Server of the target station.

**Password**

The password corresponds to the user password for the target station.
Defining Excel Report Template

**General** > Click on *Define Template*

Clicking on the *Define Template* button launches the Excel application. The functions that are used for data acquisition can be defined. A cell may contain a function or normal XLS/XLSX content. Only one function is allowed per cell.

Functions are defined using the syntax `<GetValue(variable, next position)>`

- **variable**  name of a variable in the variable list
- **next position**  NEXT_RIGHT, NEXT_LEFT, NEXT_DOWN or NEXT_UP

For example, `<GetValue(amount, NEXT_RIGHT)>`

The following is the screen shot of a report that uses a function for data acquisition.

The first Excel file that is launched is empty.

After generation, the template should be saved before closing the Excel application.

**Check**

Checks the Excel Report with respect to the following
- All variables used are correct (for example, allocated to a valid OPC Server and have a valid OPC Address).

- All functions contain a correct next position parameter

**OK** Checks the data in the report, saves the data to the database, commits the transaction and closes the dialog.

**Cancel** Aborts the transaction, closes the dialog.

**Save** Checks the data, saves the data to database, commits the transaction and opens a new transaction.

**Reset** Resets all the parameters defined in the dialog.

**Help** Opens the Help file for Excel Report.

---

### Execute Reports in DigiVis 500 Operations

Reports are downloaded to DigiVis 500 Operations after they are configured in DigiVis 500 Graphics Builder. The execution of the reports in DigiVis 500 Operations takes place depending on the configuration (for example, *Manual* or *Automatic*) of the reports in Graphics Builder.

When the execution time of a report is reached (for example, Cycle Time), a new copy of the template is stored in “\&lt;DigiVis 500_Installation_Folder\&gt;\reports” and the list of variables is acquired once. When all values are received (or a timeout is reached), the next execution time is calculated. If the next execution time is still before the stop time (for example, Start Time + (Cycle Time*Cycles)) of the report, the functions in the XLS/XLSX file are moved to the next position as per the next position parameter that is defined. The previous position is filled with the actual value for the variable.
Configuration example:

If the user specifies a Start Time that is in the past

Start time = DT#2009-01-01-08:00:00.000; Cycle time = T#1h0m0s; Cycles = 8;
Restart after = T#24h0m0s

Case 1:

When the report is configured and started at 0930 hours then

One set of values for the variable are acquired once at 0930 hours and the next set
of values is taken at 1000 hours (which is the third cycle). The remaining five
cycles follow original configuration until 1600 hours.

The next report is taken at 0800 hours the following day (which is the first cycle).
The remaining cycles follow original configuration of the report.

Case 2:

When the report is configured and started at 1800 hours then

The report acquisition starts at 0800 hours the following day (since all acquisition
cycles of last restart are completed). The remaining cycles follow original
configuration of the report.

If the calculated next execution time is beyond the stop time then no more samples
will be taken and the functions will not be copied to the next position.
There are no functions in the XLS/XLSX file after the last sample. DigiVis 500 Operations shows all the configured reports in a single list.

For information on viewing reports, refer to *DigiVis 500 Operations Operators Manual, Section K, Reports.*
Section 7 Variables

General Description - Variable list

Variables are used for storing and processing information. Various different data types are available in the system (for example, BYTE, WORD, INTEGER, REAL, DATA & TIME).

The system enters all the variables for a project in the variable list.

The column widths in the list can be adjusted with the mouse, holding the left button down. However a column cannot be made wider than its maximum permissible number of characters. Search criteria can be defined and activated. The total number of entries in the list is shown in the status line as well as the number currently displayed. You can tell from these numbers how many variables satisfy the active criteria.

Overview of simple data types

The following applies for the representation of REAL numbers: due to the internal display, only 7 significant positions can be determined during conversion to displayable characters. Very high and very low numerical values are shown as exponents.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Bit</th>
<th>Value range</th>
<th>Explanation</th>
<th>Input formats Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>REAL</td>
<td>32</td>
<td>±1.175494351E-38 ... ±3.402823466E38</td>
<td>Floating point value IEEE(1) format</td>
<td>0.0, 3.14159, -1.34E-12, -1.2234E-6, 12.6789E10</td>
</tr>
<tr>
<td>DINT</td>
<td>32</td>
<td>-2 147 483 648 ... +2 147 483 647</td>
<td>Double integer value with sign</td>
<td>-34355, +23456</td>
</tr>
</tbody>
</table>
String data types

Variables of data type STRING are used to display any texts. The variables can be edited, texts thus filed can be used to describe certain states or provide information.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Bit</th>
<th>Value range</th>
<th>Explanation</th>
<th>Input formats, Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>INT</td>
<td>16</td>
<td>-32 768...+32 767</td>
<td>Integer value with sign</td>
<td>3, -3, 12345</td>
</tr>
<tr>
<td>UDINT</td>
<td>32</td>
<td>0...4294 967 295</td>
<td>Double integer value without sign</td>
<td>123456787, 4566</td>
</tr>
<tr>
<td>UINT</td>
<td>16</td>
<td>0...65 535</td>
<td>Integer value without sign</td>
<td>4000, 66</td>
</tr>
<tr>
<td>DWORD</td>
<td>32</td>
<td>0...4294 967 295 (0...2^{32}-1)</td>
<td>Double word</td>
<td>0, 655, 2#0000000000000001, 8#0000 0000 0074, 16#0000 00FF</td>
</tr>
<tr>
<td>WORD</td>
<td>16</td>
<td>0...65 535 (0...2^{16}-1)</td>
<td>Word</td>
<td>2, 554, 2#0000 0000 0000 0001, 8#0000 004, 16#00FF</td>
</tr>
<tr>
<td>BYTE</td>
<td>8</td>
<td>0...255 (0...2^{8}-1)</td>
<td>Byte</td>
<td>0, 55, 2#0000 0011, 8#377, 16#0A</td>
</tr>
<tr>
<td>BOOL</td>
<td>8</td>
<td>0.1 (FALSE, TRUE)</td>
<td>Boolean value</td>
<td>0, 1, FALSE, TRUE</td>
</tr>
<tr>
<td>DT</td>
<td>32</td>
<td>1970-01-01-00:00:00.000 ... 2099-12-31-23:59:59.999</td>
<td>Date+time value</td>
<td>DT#1994-02-14-10:00:00.00</td>
</tr>
<tr>
<td>TIME</td>
<td>32</td>
<td>+24d20h31m23s648ms ... -24d20h31m23s648ms</td>
<td>Time value</td>
<td>T#22s T#3m30s T#14m7s</td>
</tr>
</tbody>
</table>

(1) IEEE Institute of Electrical and Electronic Engineers; American Association of Experts.

String data types

Variables of data type STRING are used to display any texts. The variables can be edited, texts thus filed can be used to describe certain states or provide information.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Byte</th>
<th>Explanation</th>
<th>Entry formats, Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>STR8</td>
<td>8</td>
<td>8 character text</td>
<td>FC 1100</td>
</tr>
<tr>
<td>STR16</td>
<td>16</td>
<td>16 character text</td>
<td>TIC1234</td>
</tr>
</tbody>
</table>
Section 7 Variables

Calling up the variable list

The variable list is called by menu item **System** or the relevant toolbar button.

### Structure of variable list

The status line shows the current number of entries thus: `<entries> of <total entries>`. Where search filters are active this enables you to see how many variables meet the search criteria.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Byte</th>
<th>Explanation</th>
<th>Entry formats, Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>STR32</td>
<td>32</td>
<td>32 character text</td>
<td>P11400 too low</td>
</tr>
<tr>
<td>STR64</td>
<td>64</td>
<td>64 character text</td>
<td>Boilers temp. too high</td>
</tr>
<tr>
<td>STR128</td>
<td>128</td>
<td>128 character text</td>
<td>Generator2 speed to high</td>
</tr>
<tr>
<td>STR256</td>
<td>256</td>
<td>256 character text</td>
<td>Automation unit malfunctioning</td>
</tr>
</tbody>
</table>

The string variables reserve memory as the other variables in the 32 Kbytes RAM of the resource.
The variable list is structured as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Comment</th>
<th>Type</th>
<th>Res.</th>
<th>OPC address</th>
</tr>
</thead>
<tbody>
<tr>
<td>C213_INT4_CH4</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT4_CH5</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT4_CH6</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT4_CH7</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT4_CH8</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT4_CH9</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT4_VALUE</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.4.C213_INT4</td>
</tr>
<tr>
<td>C213_INT5_CH1</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.5.C213_INT5</td>
</tr>
<tr>
<td>C213_INT5_CH10</td>
<td></td>
<td>INT</td>
<td>OPCS</td>
<td>HA_RED.INT_COUNT.5.C213_INT5</td>
</tr>
</tbody>
</table>

Name       Variable name, max. 16 characters  
Comment    Comment on variable, (max. 33 characters)  
Type       Data type, refer to Overview of simple data types on page 203  
Res.       A variable is always allocated to one resource.  
OPC address Address or name of a variable on the OPC Server.

Variables displayed in red have no references within the project.

Menu structure variable list

Variable list       Sort 
Exit  
Search       Type ahead  
Define  
Edit       Undo 
Insert new variable  
Field  
Delete field 
Delete unused variable  
Cut
Editing variable list

Sort

> Variable list
> Sort > Select sort criteria

The variable list is output to the screen according to the preselected sort criterion.
Search in variable list

Type ahead

The Type ahead function enables variables to be searched for by name. When this function is chosen from the menu or shortcut menu a dialog is displayed containing an input field. When a name or the beginning of a name is entered, the list scrolls automatically to the first matching entry.
Define search criteria

> **Search** > **Define** > combine up to 10 search criteria in a dialog.

Entries in the list can be searched and displayed on the monitor according to specified search criteria. For this purpose a dialog is displayed containing 10 identical tabs. These tabs allow search criteria to be defined independently for the 10 different columns in the variable list. Wildcards may be used - “*” (for several characters) and “?” (for any single character).

Each of the 10 search criteria can be activated and deactivated separately on the tab or using the relevant toolbar button.

**Name**  
Activates the search criteria according to Name.

**Activate**  
Activates the search criteria on this tab. After this dialog is closed, all the active search criteria are evaluated and a list is displayed containing entries that satisfy all such criteria.

**Data type**  
All data types can be configured as search criteria. The name must be declared as it is displayed in the list in the type column.

**Resource**  
All the names of the software resources configured in the project can be configured as search criteria. The name must be declared as it is displayed in the list in the STAT column.
Do not show unused variables
All variables that are defined but not used in a program can be shown or hidden.

Variables that are created by OPC items and not used in a Graphic display are still counted as signals for licensing.

The project options in the main menu are used to specify whether or not the search filter activation is retained on exiting the variable list. The search filter configuration is stored along with the project.

Activated search criteria can be recognized in the status line by the number of entries displayed and by the corresponding toolbar buttons that are pressed. The configured search criteria are indicated in the form of tool tips on the toolbar buttons.

Edit list entries

> Edit

A number of functions are provided for editing the individual list entries. For example, Undo can be used to undo the last action, new entries can be inserted, entries can be deleted, cut or copied. Blocks or variables can also be imported and exported.
Section 7 Variables

Undo

> Edit > Undo

The last change is undone and the old status restored. If Undo cannot be performed, the menu item cannot be chosen (displayed in gray).

Insert new variable in list

> Edit > Insert new variable

After the menu item Insert new variable has been chosen, a window is displayed. The parameters for the variable must be entered in this window.
Edit a field in the list

Depending on the field selected, the new value can either be entered directly or modified by means of a dialog.

When Search is activated (for example, the list is not displayed in its entirety), it is not possible to insert any new variables.

**Edit a field in the list**

> Select required field by double-clicking (the selected field is emphasized with a border). Cursor is positioned at the last entry position.

or

> **Edit > Field**

> Cursor-click or arrow key on entry position within the field,

> Enter changes.

Name Enter variable name, max. 16 characters.

Data type Select data type from a list of data types.

Resource Enter the resource by means of a selection list.

Comment Comment in the form of free text.
**Delete field**

Certain entries in fields cannot be explicitly deleted using this command. In the case of the variable list the fields Name and Type fall into this category.

If a whole line in the list is selected, then the variables may be deleted.

> Click on required field (highlighted by a border, cursor positioned at last entry position) > **Delete** button.

The text parts of a list entry can be deleted directly with the cursor. This is achieved by clicking on the field, positioning the cursor at the beginning of the section to be deleted, selecting the area for deletion by holding down the left mouse button, and lastly removing the text thus selected by pressing the **Delete** button.

**Delete unused variables**

All entries with no cross-references (these variables are identified by a red color) are deleted following a query for confirmation.

> **Edit** > **Delete unused variables**

![Confirm Deletion of Variable]

**Yes**

The variable that is displayed is deleted.

**Delete all**

All unused variables (all variables in red) are deleted.

**No**

The variable that is displayed is not deleted, and the next variable is displayed.

**Close**

Quits the query mask.
System

Tag list

Opens the Tag list. For description refer to Section 8, Tags.

Cross-references

All cross-references for a variable can be shown in a list through Cross-references. Cross-references are references to this variable in displays, logs and so on, in other words to places in which this variable is used.

> Select field > Cross-references or F5 button.

A window displays the names of affected programs.

Show Cross References of Variable

PROGRAM CH3

is used in the following programs:

<table>
<thead>
<tr>
<th>Filter</th>
<th>Read/Write</th>
<th>Read</th>
<th>Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Program name</th>
<th>Resource</th>
<th>Read access</th>
<th>Write access</th>
</tr>
</thead>
<tbody>
<tr>
<td>ST12</td>
<td>VIS</td>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

Show program

Calls the program and pre-selects this variable.
**Show declaration**

The variable list remains selected, the chosen variable selected.

**Filter**

A filter enables just those variables to be displayed that are being edited using the appropriate programs in read or write mode.

---

**Options**

**Hardcopy**

> Options > Hardcopy

The contents of the screen are output to the printer.

**Adjust colors**

> Options > Colours

The variable list offers the facility of a free choice in defining the colors of unused variables.

**Save column settings**

> Options > Save column settings.

The column setting is saved.

---

**Back**

> Back

Returns to the display called previously.
Section 8  Tags

General Description - Tag List

All tags configured in a project are organized by the system and made available to the user in the tag list.

These lists gets updated when a instantiation is done in OPC item list.

For information on Tag Instantiation, refer to Section 5, OPC Items. Existing data may be output to data media or imported from these media.

Data files are in ASCII text format with CSV (comma separated values).

Search criteria can be defined and activated. The total number of search criteria is displayed in the status line along with the number of entries currently displayed in the list. It is thus possible to see how many tags satisfy the active search criteria.
Calling Tag List

> System > Tag list

Structure of Tag List

Tag list is structured as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>I</th>
<th>Res.</th>
<th>Area name</th>
<th>Short text</th>
<th>Long text</th>
<th>Type name</th>
<th>L</th>
<th>P</th>
</tr>
</thead>
<tbody>
<tr>
<td>BOOL_CH1</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>BOOL</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>BOOL_CH2</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>BOOL</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>BOOL_CH3</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>BOOL</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>BOOL_CH4</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>BOOL</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>CTU_2</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>CTU</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>Catalog</td>
<td>I</td>
<td>-----</td>
<td>No Area</td>
<td></td>
<td></td>
<td>HISTR</td>
<td>S</td>
<td></td>
</tr>
<tr>
<td>Gen1</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>GEN</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>HA_CONTROL1</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>HA_CONTROL</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>HA_CS31_Diag_1</td>
<td>S</td>
<td>OPCS</td>
<td>No Area</td>
<td></td>
<td></td>
<td>HA_CS31</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td>HWSYS</td>
<td>S</td>
<td>-----</td>
<td>No Area</td>
<td></td>
<td></td>
<td>HWSYS</td>
<td>S</td>
<td>Q</td>
</tr>
<tr>
<td>LibRoot</td>
<td>T</td>
<td>-----</td>
<td>No Area</td>
<td></td>
<td></td>
<td>HW_LIB_ROOT</td>
<td>S</td>
<td>Q</td>
</tr>
</tbody>
</table>

Name: Tag name, max. 16 characters
Object type of entry:

- **T**: Standard name. Name of a hardware structure object and all unused tags or objects are labeled with 'S'.
- **T**: Template name. All template entries in the hardware structure are labeled with ‘T’

**Area Name**

- Plant area of tag, max. 15 plant areas (A...O) possible.

**Resource**

- OPC Server name.

The plant area assignment is preserved in project export and import, but not in block export and import.

**Short text**

- Short text for tag, max. 12 characters

**Long text**

- Long text for tag, max. 30 characters

**Type Name**

- Abbreviated text for the parent object.

**Library type**

- **S**: Standard library type
- **T**: Tag Type.

**Configuration errors**

- **#**: Configuration for the block is not correct.
  - Configuration errors were reported when the plausibility check for this block was called last.
- **@**: Plausibility check for the block without error.
  - No configuration errors were reported when the plausibility check for this block was called last.

Refer to Section 2, Project Tree.
### Menu Tag list

<table>
<thead>
<tr>
<th>Tag list</th>
<th>Sort</th>
<th>System</th>
<th>Variable list</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Normal view</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Station view</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Exit</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Search</th>
<th>Type ahead</th>
<th>Cross references!</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Define</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Edit</th>
<th>Undo</th>
<th>Options</th>
<th>Hardcopy</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Insert new tag</td>
<td>Color</td>
<td>Save column settings</td>
</tr>
<tr>
<td></td>
<td>Edit field</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Delete field</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Delete unused tags</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Back!</th>
<th>Help</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>Overview</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>About</td>
</tr>
</tbody>
</table>

### Changing tag list entries

Change of Tag Names is possible in the tag list.

- Select desired field with double click
- Change the name of the Tag

After the changes are made user needs to load the changed objects.
Editing the Tag List

Sort

Tag list > Sort > Select sort criterion

The variable list or tag list entries are output to the screen according to the preselected sort criterion.

Name, alphabetic order
- Sorted alphabetically according to name

Area and name
- Sorted according to plant area

Module type
- Sorted according to module type
  Alphabetical sorting of module types: first the standard library (S) then Tag Type (T)

OK
- Sorting is activated.

Cancel
- Sort action is aborted.

Normal view and station view

As well as the normal view, a station view can also be selected.

> Tag list > Station view
ACCESS = Yes (X) can be specified for the individual operator stations, allowing this tag to be available in the tag list for the relevant operator station. Access of the Tag to the relevant operator station can be changed as follows:

**Edit > Station access**

alternatively

Double click on
Access(=XYes) > station access dialog > Uncheck if required.

**Exit**

**Tag list > Exit**

Back to project tree structure.
Searching in the Tag List

Type ahead

> Search > Type ahead

The Search ahead function enables you to search for tags by name. After this function has been chosen from the menu or the shortcut menu, a dialog appears containing an input field. When a name or the beginning of a name is entered here the list scrolls automatically to the first matching entry.

Define search criteria

> Search > Define > Compile up to 10 search criteria in a dialog

A search can be performed for entries in the list that conform to the specified search criteria, and these can then be displayed on the screen. For this purpose, a dialog is displayed with 10 identical tabs. The use of wildcards is permitted, such as “*” (for more than one character) and “?” (for any single character).

Each of the 10 search criteria can be activated and deactivated separately on the tab or by means of an appropriate toolbar button.
Activate search criteria on this tab. After this dialog is closed all the active search criteria are evaluated, and a list is displayed containing entries for which all the criteria are satisfied.

**T**  
Define object type as search criterion. Valid inputs are **S**, **T** and *.

**Area**  
Define plant area as search criterion. The plant areas used in the project may be displayed in a list and selected.

**Type name**  
Define type name as search criterion. The module types used in the project may be displayed in a list and selected. The name may also be specified using wildcards.

**P**  
Define status of the plausibility check as a search criterion. Valid inputs are #, @ and *.

**Access by station**  
This search criterion is satisfied if read and/or write access has been defined for the variable for the selected station.
Show unused tags

All those tags that have been defined but not used in a program can be either shown or hidden.

Tags for which access rights have been assigned through a gateway, but which are not being used in a program, count as unused tags.

Show only tags with faceplates
Displays tags which has faceplates. Under Project Options on the main menu you can set a parameter to specify whether or not the search filter activation is retained on exiting the tag list. The search filters configuration is stored along with the project.

Activated search criteria may be recognized by the correspondingly depressed toolbar button. The configured search criteria are displayed as ToolTips using the toolbar button. The number of inputs in the whole list that meet the selected search criteria is displayed in the state line.

Editing tag list entries

> Edit

Various menu options are available for editing the individual tag list items. You can undo an action, insert new tags, delete, cut or copy items, and so on. Also, text blocks can be imported or exported.
Undo

> Edit > Undo

The last change is withdrawn and the text is shown as it was before the last change. If it is not possible to undo something, then the menu item cannot be selected (reverse highlight).

Insert new tag

> Edit > Insert new tag

If the cursor is located on an empty field (for example, at the end of the list), a new tag may be entered directly into the individual fields in this line of the list.

If the cursor is on a list entry, a window will appear. The selected name appears as the default for the old name and the new name. The new name must then be changed by entering the desired new name. All the other data is taken over from the tag which was selected previously.
Section 8  Tags

Edit field

Old
The name of the selected tag for information only.

New
This shows the name of the selected tag as the default and may be changed by entering the desired new name.

OK
The tag selected is taken over.

Cancel
The existing tag is not changed.

Next
Not assigned for tag entries. Jumps during import to the next line in the list that is already occupied.

When searching is activated (for example, the list is not displayed fully), it is not possible to enter any new tags. When inserting a block, the tags inserted must be assigned new names. The Next button enables certain tags within the block to be skipped and not be re-included in the list.

Edit field

> Select desired field with double click (highlight box), the cursor appears at the last item of entry
> Cursor click on item of entry in field
> Enter changes

The text contents of the selected field may be changed. After the change has been made, a further window may appear, requesting confirmation of whether the change shall apply throughout the project or just in specific programs. Refer to Changing tag list entries on page 220.
Delete field

Entries in the fields Name, T, Type name, L and P cannot be deleted with this command.

The tag may be deleted by selecting an entire line in a list.

> Select desired field (highlight box, cursor appears at the last item of entry)

> **Delete** button

A warning is displayed, indicating the usage of Tag.

Confirm the deletion by clicking on **Delete** button.

Delete unused tags

In the tag list, unused measuring points are displayed in **red**.

The unused tags can be shown or hidden in the search filter for the tag list.

**Cut**

Select block > **Edit** > **Cut**

Text blocks which have been defined are removed from the text and saved in the buffer.

The text in the buffer can then be incorporated again at any item using the **Insert** command.

**Copy**

Select block > **Edit** > **Copy**

Text blocks which have been defined are copied and saved in the buffer.

This text may then be incorporated again at any item using the **Paste** command.
**Paste**

Select block > **Edit** > **Paste**

A text block which has been copied or cut is saved in the buffer and may be inserted at the desired item marked by the cursor.

Variable names or tag names have to be changed, so the same window appears as in the menu item Insert new tag.

**Delete**

Select block > **Edit** > **Delete**

A text block which has been defined will be deleted from the text after a query.

![Delete Tag window](image)

**Cancel** Back to the corresponding list

**Don’t delete** Selected variable/tag is not deleted

**Delete** Selected variable/tag is deleted

**Show program** Go to selected program
Export

> Highlight block > Edit > Export block

A defined block is saved as a file on a data storage medium. An additional window appears into which the file path and file name must be entered. This file may be read into other projects using Import.

Import

> Edit > Import

A file stored using Export block can be copied back from a data storage medium. Another window is displayed in which the path, filename and file type should be entered.

If, when importing tags to a project, tag names are found which are the same as tag names already existing in the project, those being imported will be treated as new tags. Refer to Insert new tag on page 226.

Files exported using DigiVis 500 Graphics Builder or text files can be imported depending on the file types concerned.
Tag import also offers the option of importing files into the tag list that have been created by external applications (for example, Microsoft Excel). These files have the extension **csv** or **txt**.

The files for import must be text files in Unicode format, and they should be structured as follows: Each line of the import file should contain the tag name, short text and long text. The tag type is not yet defined at this point.

These three text items are separated by a list separator, which can be either a comma ‘,’ or a semicolon ‘;’. The different separators must not be combined within the same line. In the event that a text item itself includes the list separator, the text or the list separator should be enclosed in quotation marks (“ ”). The end of the file is marked by a line break.

For example:

```
TIC1304;Boiler 4;Temp. boiler 4
FIC1205;Air “;” K5;“Air flow; K5”
```
When files are imported the system checks to see whether tag names conform to the existing criteria; any tag that does not conform will not be accepted for import. The short text must be no more than 12 characters in length. If it is any longer than this, characters after the twelfth one will be ignored during import. The long text can be a maximum of 30 characters in length, and, like the short text, no more than the maximum permissible number of characters will be read in during import.

Neither the short text nor the long text may contain list separator characters unless these are enclosed in quotation marks. Failure to observe this rule will result in the tag import routine interpreting the character as a separator and the following character as the start of the following field. If a line contains more than two list separators, then any characters between the third list separator and the end of the line will be ignored. If, on the other hand, a line contains less than two separators, then the tag will be rejected and not imported.

If format errors are detected in the import file during import, then the import process will be abandoned at that point.

When new tags are being entered, tag type defaults to ‘----’ and library type to ‘-’. The tag type can be assigned directly in the tag list or alternatively this can be done while Instantiating Tag Types (refer to Section 5, OPC Items, Tag Instantiation on page 184).
Station access

> Select block > Edit > Station access

For each operator station, certain tags which should not be operated on this station can also be filtered. If no access is given for a specific Tag then this Tag can no longer be accessed from the Operator Station.

Refer to Normal view and station view on page 221.
Plant areas

> Mark block > Edit > Areas

Areas of Selected tags
All the areas already assigned in the marked block are shown.

Areas already used in the project
All the areas which are already used in the project.

New assignment to area
Assign new area to a selected block.

Access rights

Select block > Edit > Access rights

If the add-on package Security Lock is installed, individual tags or selected blocks of tags can be locked here for certain user groups. On the relevant operator station the tag can then only be inspected, or also controlled, or not called at all.
User groups

Select block > Edit > User groups

If the add-on package Security Lock is installed, individual user groups can be assigned here to certain resources. Refer to DigiVis 500 Engineering Manual Security Lock.

System

Variable list

Switch to the variable list. For information on variable list, refer to Section 7, Variables.

Cross references

Cross references of a tag can be displayed in a list by means of Cross references. Cross references are references relating to these tags in displays, listings and so on (for example, locations where these tags are used).

Select field > Cross References

A window displays the names of the relevant programs
**Show program** Calling a program with pre-selection of this tag or calling the module to which the tag is allocated.

**Show Declaration** Tag list remains selected, the selected tag marked.

---

**Options**

**Hardcopy**

> Options > Hardcopy

The screen contents may be output to a printer. A window shows the printer in use, print quality and the number of copies required. Changes to these settings may be made by selecting SETUP.
Set colors

> Options > Colours

It is also possible in the tag list to freely specify color preferences for any unused tags.

Save column settings

> Options > Save column settings

The column width setting is stored.

Back

> Back!

Back to previous screen.
Section 9 Messages

General Description - Messages

The task of message processing in DigiVis 500 Graphics Builder is to configure the method of processing and displaying messages in DigiVis 500 system.

Messages are used by the OPC Server and other stations in the DigiVis 500 system to notify the operator stations of changes in the process operation. Such changes may be faults or states in the process or also error functions of the DigiVis 500 system itself.

The DigiVis 500 system makes available the message types system message, fault message and switch message. These types of message can be classified into different priority levels, one system level (level 0) and four process levels (1-4). The individual priority levels are displayed in different colors.

Local message processing comprises of the configuration of the station-specific settings for message list, message line and horn activation. This has to be done separately for each operator station.

Display of the Message Line During Operation

The message line is always visible in DigiVis 500 Operations. Thus the operator at the operator station can immediately ascertain incorrect behavior in the process and take appropriate action.

The message line contains fields for the display of messages and buttons for selecting items for acknowledging the control room horn.
Display of the Message Line During Operation

Section 9 Messages

It can be displayed in three different views:

Standard view of the message line

It contains several message points with tag names and message point information.

Area view of the message line

Each plant area has its own place in the message line. For each plant area the number of the associated messages present is displayed; the plant area is displayed in the priority color of the most important message; the most important message is shown in the tooltip. When a specific plant area button is selected a message list specific to the plant area will be opened.

List view of the message line

The 4 most important messages are displayed in the same format as on the message page. When you double-click on the message, the faceplate that belongs to the message will be opened.

Depending on the selected view the message line may contain a button for point acknowledging or visually acknowledging messages in the message line, a field for displaying an overflow of the message line and the number of all messages contained in the message list.

Depending on the configuration of the type of acknowledgment, the display of the message line changes.

For visual acknowledgment is indicated. For point acknowledgment is indicated.
### Message fields

On these fields the arriving messages are displayed. The display in the message field contains two lines.

This field is designated the overflow field. The area has a yellow background if there are more messages than can be displayed in the message line. The number below this indicates the total number of messages.

The displayed messages are acknowledged. This is a **visual acknowledgment** only; The number of messages is not affected by this.

The displayed messages are **point acknowledged**.

The number of messages is updated if necessary.

This field is used to acknowledge the control room horn and is activated when a message with a horn associated with it comes in. Clicking on this field will acknowledge the control room horn.

Only the Horn field is displayed when a **Area view** of message line is selected.
The **message list** consists of a **header**, the **list with** the current **messages**, and the **operating element area** with four buttons and three checkboxes.

In the **header**, the total number of messages is indicated. On the right hand side, colored boxes indicate if any messages exist outside the currently displayed page. If a box is highlighted with its priority color, messages of that priority are not visible on the screen. Three checkboxes are available to filter the messages. If you select a checkbox, the associated messages will be shown.

In the **Message List** the fault and switch messages can be displayed in the **Value format**, **Long format** and in the **Long/Limit format**. The formats differ in the type of information presented to the operator. For system messages coming from the operator level, a fixed display format is available.
In the operating element area messages can be acknowledged, the sound file configured for a message can be played back and the display format can be selected.

## Message Types

In the DigiVis 500 system, messages are divided into the following message types according to their importance to the process:

<table>
<thead>
<tr>
<th>Message type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System messages</td>
<td>System messages have the highest priority level and are subdivided into three message groups S1 to S3. The priority level of a system message coming from the OPC Server can be configured or changed. For a list of the system messages, refer to <a href="#">DigiVis 500 Operations Operators Manual, Section V, System Messages</a>.</td>
</tr>
<tr>
<td>Fault messages</td>
<td>Fault messages have priority levels 1 to 3. Messages of this type are used to indicate (for example, alarm limit settings being violated).</td>
</tr>
<tr>
<td>Switch messages</td>
<td>Switch messages have priority level 4. Messages of this type are used to indicate switch events (for example, valve open/closed).</td>
</tr>
</tbody>
</table>

## Priority Levels

DigiVis 500 messages which arrive from the OPC Server can be of varying importance for the problem-free running of the process. The DigiVis 500 system offers five different priority levels for messages. Five (1 System message, 3 fault messages, 1 switch message) display colors are allocated to these.

<table>
<thead>
<tr>
<th>Priority level</th>
<th>Message type</th>
<th>Display color</th>
</tr>
</thead>
<tbody>
<tr>
<td>S1-S3</td>
<td>System message</td>
<td>blue</td>
</tr>
<tr>
<td>1</td>
<td>Fault message</td>
<td>red</td>
</tr>
<tr>
<td>2</td>
<td>Fault message</td>
<td>orange</td>
</tr>
</tbody>
</table>
### Acknowledgment of Messages

#### Types of Acknowledgment

Two types of message acknowledgment are possible, **visual acknowledge** and **point acknowledge**.

- **Visual acknowledge** does not replace **point acknowledge**, it is an additional function.

#### Priority level | Message type   | Display color |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Fault message</td>
<td>yellow</td>
</tr>
<tr>
<td>4</td>
<td>Switch message</td>
<td>yellow</td>
</tr>
</tbody>
</table>

The same color is used in the message line, message list and faceplates to indicate the priority level of a message.

The colors indicated here are default settings of the DigiVis 500 system. The display colors of the various message priorities can be changed to take account of particular country- or company-specific requirements. Since a modification of this kind affects the overall appearance of DigiVis 500 operations and has safety-relevant aspects, this change should only be made in collaboration with the responsible commissioning engineer or service engineer.
Section 9 Messages

Filtering Messages

<table>
<thead>
<tr>
<th>Type of acknowledgment</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual acknowledge</td>
<td>In case of visual acknowledge the messages are marked as “viewed”. This type of acknowledgment has no effect on the current state of the message in the OPC AE Server. This is available in the message line. By visual acknowledge in the message line all listed entries are deleted. However, they are still present in the message list.</td>
</tr>
<tr>
<td>Point acknowledge</td>
<td>This type of acknowledge is available in the message list, faceplates and the graphic displays, in case of appropriate configuration also in the message line. It performs an acknowledgment of the message in the OPC AE Server. This changes the status of the message.</td>
</tr>
</tbody>
</table>

Acknowledgment in the Message Line and Message List

Depending on configuration, acknowledgment in the message line is by means of visual acknowledge or point acknowledgment. The acknowledgement type being active can be recognized by the mode of display of the button:
Visual acknowledge: ![Visual Acknowledge]
Point acknowledge: ![Point Acknowledge]

Only point acknowledge is available in the message list.
The appropriate buttons can be found in the operating element area.

Filtering Messages

The operation dialogs of the message lists offer options for filtering messages. These are filters for plant areas, priority levels. The filter settings assumed on selection of the relevant list can be configured. This filter setting can only be made more restrictive if modified in operation.

Acoustic Messages and Control Room Horn

One control room horn can be connected to each operator station for alarming in the control room. One sound file can be configured for each priority level. Refer to Local Message Processing on page 246.
Acknowledgment in the Control Room

Acknowledging in the message line

The **Acknowledge horn** button is activated when messages with sound files configured are received by the DigiVis 500 Operator station. Clicking on this button will deactivate the control room horn for that particular message type until another message of that type is received by the Operator station.

Acknowledging in the message list

The **stop audio** button is used to acknowledge the control room horn from the message list.

Local Message Processing

The local settings apply to individual operator stations. These include the settings for the message line, message list and horn activation.

Select **Operator station** in the project tree > **System** > **Local message processing**

Alternatively:

**double-click on operator station** in the project tree
**General data**

**Name**
Name of operator station

**Message buffer length**
This number defines the number of possible entries in the message list at the operator station. A minimum of 10 entries must be configured and a maximum of 2000 can be configured. The default setting when opening local message processing dialog is 2000.

**Level of the message buffer for reacquisition after overflow**
This number defines the nominal level of the message list after an overflow. After an overflow has occurred, entries in the message list are deleted in accordance with a positive-displacement algorithm. This is repeated until the level within the message list corresponds to the value stated here.
The positive-displacement algorithm is composed of the following steps:

1) Deletion of event messages.
2) Deletion of active, acknowledged messages. First the oldest message is deleted and then more recent messages are deleted consecutively. Deletion begins with priority level 4 and continues consecutively to priority level 0.
3) Deletion of the oldest inactive, unacknowledged message. Otherwise the same as 2).
4) Deletion of the oldest inactive, unacknowledged message. Otherwise the same as 2).

If the number of messages in the message list exceeds 2000 then a S1 message: “Message list overflow” is displayed at the operator station. Acknowledging this message will remove it from the message list. Overflow alarms cannot be monitored for outgoing condition.

Display Tab

Message list
Display of

Selecting Value, Long text and Long text/limit specifies the output format of a message in the message page / message list at the control station.

Formats

A choice of three display formats is available for fault and switch messages:

<table>
<thead>
<tr>
<th>Value:</th>
<th>Priority</th>
<th>Time</th>
<th>Plant area</th>
<th>Tag name</th>
<th>S-Text</th>
<th>ST-Text</th>
<th>Type</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Long</td>
<td>Priority</td>
<td>Time</td>
<td>Plant area</td>
<td>Tag name</td>
<td>S-Text</td>
<td>L-Text</td>
<td>Date</td>
<td></td>
</tr>
<tr>
<td>Long text/limit</td>
<td>Priority</td>
<td>Time</td>
<td>Plant area</td>
<td>Tag name</td>
<td>S-Text</td>
<td>L-Text</td>
<td>Type</td>
<td>Date</td>
</tr>
</tbody>
</table>
System messages coming from the operator level have a fixed display format as follows.

<table>
<thead>
<tr>
<th>System message</th>
<th>Group</th>
<th>Time</th>
<th>Plant area</th>
<th>Tag name</th>
<th>Fault text</th>
<th>Date</th>
</tr>
</thead>
</table>

Abbreviations:

- **Sound**: Label identifying messages connected with a configured sound file.
- **Priority**: Priority of the message with indication of whether incoming or outgoing.
- **Group**: System message group; specified by system.
- **Time**: Time of occurrence of the message. The resolution is 1/1000s.
- **Plant area**: Plant area to which the tag name is allocated.
- **Tag name**: Name of the tag which generated the message.
- **S-Text**: Short text for the tag.
- **L-Text**: Long text for the tag.
- **ST-Text**: Status text of the message.
- **Measured value**: Measured value registered when the message was generated (for example, limit value).
- **Dim**: Dimension of the measured value.
- **Type**: Every message has a message type. For limit values, the message type is the limit value type (for example, HH for the second high limit value).
- **Date**: Only shown with the first message and after a date change. A date change is indicated by a horizontal red line.
- **Fault text**: Explains the fault which has occurred in the case of a system message.
**Message order**
Defines which of the messages (the latest or the oldest one) is to appear **at the topmost position** of the message page.

**Message line**
**Supported types**
Defines which of the three views of the message line (area, list, standard) are to be selectable in DigiVis 500 Operations and which one of the three is to be the default setting.

**Message order**
Defines whether the latest or the oldest message is to appear in the message line in standard view **at the top on the left** or in list view **at the top**.

**Acknowledge type**
With **Acknowledgement type** it is possible to choose between **visual acknowledge** and **acknowledge** (point acknowledgment).
In case of **visual acknowledgment**, will appear in the message line. Messages are only visually acknowledged in the message line and must be acknowledged in the message list.
In case of **point acknowledgment**, will appear in the message line. Messages in the message line are acknowledged normally.

**Priority filter preset**
Here you can choose whether a preset priority filter is to be used for the next call-up of a message list.

**Use last**
If a (plant related) message page is called up, the messages will be filtered according to the priority filters set last.

**Select all**
When a message page is called up, the messages of all priorities are displayed.
Filter Tab

The filters set here determine the way in which the message line, message list are displayed.

**Message filter**  Determines which messages appear in the message list. Settings can be configured for the system message groups and priority levels.

**Station filter**  DigiVis 500 system messages from the selected operator station will be displayed.

**All stations**  All configured resources will be shown in the adjacent list.

**Connected only**  Only those resources to which a connection has been configured will be displayed in the adjacent list.

**Area filter**  Determines from which areas messages will be displayed.
Control Room Horn Tab

The notification that an event has occurred can be made by a sound board in the DigiVis 500 Operations (control room horn).

Messages

For system messages and priority levels 1 to 4 it is possible to indicate whether the control room horn is to sound when messages are Coming or Going or for both.

Tone type

For each priority, several types of sound files (WAVE files) may be entered with or without extensions. These files will be played back in succession and with no interval. The system loads the files from the DigiVis 500 standard directory <DigiVis 500_Installation_Folder>\wave. It is also possible to indicate the whole path with directory and file names, such as c:\winnt\media\.... The entry may have a maximum number of 100 characters. In accordance with the Play sound files in setting, the
DigiVis 500 system will play the selected files for coming and going messages.

The sound files configured here, are not marked by the sound symbol at the beginning of a line in the message list.

**Play sound files in**

In addition to the sound files configured here for the various priorities, audio files can also be configured for individual process messages. The following three alternatives can be used to control their processing under DigiVis 500 Operation.

*Priority order, oldest mesg/
Priority order, newest mesg*

The audio files of the most important message are repeated until the message is acknowledged or superseded by a more important message.

*Time order*

The audio files of all incoming messages are played back once, each in the order in which the messages arise.

(Refer to [DigiVis 500 Operations Operators Manual, Section D, Messages, Messages with sound files](#)).

*Sound board*

✅ The sound system of the DigiVis 500 Operations PC is active.

☐ The sound system of the DigiVis 500 Operations PC is inactive. Configured sound files will not be played.

*Pause between two messages*

The minimal interval interposed between audio files for different messages or between repetitions of the same sound file for a particular message.

*Area filter*

Determines, from which areas messages control the control room horn.
Section 10  Standard Displays

Display Access

General Description - Display Access

The display access is a convenient means of quickly calling up the displays assigned to the selected tag during process operation, thus obtaining selective information on the plant status.

After having selected the desired tag in DigiVis 500 Operations you can select the directly callable displays through the Context menu:

• the overview display “<Name> (Over.)”,
• the message list “Messages (Mess.)”
• the faceplate “<Tag name>”.

Configuring the display access you can assign additionally to each tag the control aspect (see below), a selected display of each display and log type, as well as an “External aspect” to call up any document or application.

One display of the following display and log types can be assigned to each tag:

• Graphic display (FGR),
• Group display (GRP),
• Trend display (TR_D-OS),
• Signal sequence log (SSL),
• Operation log (OPL),
• WEB display (WEB).
If one of these displays is configured as default display, the associated entry will appear as the topmost one in the context menu; therefore the display can be selected extremely fast.

Refer to DigiVis 500 Operations Operators Manual, Section C, Operating Philosophy.

Automatic Display Allocation

With the default setting display allocations can be specified automatically by the system. This serves to reduce the effort for configuration.

When display allocation is called up, and when a plausibility check is carried out on an operator station, the tags, displays and logs contained in the configuration database are checked. For each tag, usage is established in the instances of all display types and log types.

When usage of a tag is discovered, the display or log is indicated as an entry for the display allocation. If no usage nor cross reference is found, this is indicated by the entry “<auto>”.

If the corresponding tag is used in such a type of display at a later point in time, the display will automatically be assigned to the tag.

Call up the Display Access

After selecting a D-OS resource (station or P-CD) in the project tree, the displays and logs stored there can be assigned to a tag.

If the common display pool P-CD is selected, the chosen display access applies for all operator stations of the project. However, if the display access is chosen at a later date for an operator station resource, the settings previously defined in the P-CD are overwritten for this resource.

> Select in the project tree resource operator station or P-CD
> System > Display access
Display Access Editor

The **tag** which the displays, reports and logs are assigned to is selected through the windows **Tag type** and **Tag name**. The type is selected in the window **Tag Type**. A list of all the tags of this type that are present in the system appears in the window **Tag Name**. Having selected one of the tag names from the window **Tag name**, for each display/log, report type you can enter one of the displays and logs provided by selecting it.

**Select tag**

- **Tag type** List of all tag types
- **Tag name** List of all tags of one type with their names
**Pictures**

One display, report or log of each type can be assigned to each tag. When you press the edit field, a list of the available displays is displayed for selection.

<auto>

Automatic display access of this display, report or log type for the selected tag. This entry will only be displayed, if the selected tag is not being used in any of the displays. If the entry <auto> is selected, the data base will be checked automatically and the display name of the first reference found will be entered in the field.

<empty>

No display allocation of this display or log type for the selected tag.

<name>

The display name of the configured allocation is displayed. The allocation may be done automatically by the system or by selection of the user from the list.

---

**External aspect**

**Description**

Entry of any text. This text will be displayed as the bottom entry in the context menu of the tag in DigiVis 500 Operations.

**Command**

Entry of any command line call-up, such as Notepad ReadMe.txt. With it documentations or Excel files can be linked to tags.

If this possibility is used, the free access to the Operating System from DigiVis 500 Operations cannot be avoided any more.

---

**Auto configure**

The automatic display allocation (cross references checked by the system) is implemented again for the selected tag. As a result, allocations that might have been configured before will be deleted.

**Cross reference**

The list of cross references is displayed for the selected tag.

---

**Default display**

> Click on display type or

> select **Default display** from the context menu for the display name

Display type is designated with (V)

If several display types have been entered for one tag name, it is possible to designate a certain display type. The latter is then in the first place of the context
menu under DigiVis 500 Operations. In all cases, only one of the entered displays can be designated as a default display. To change the default designation, simply click another display type.

Overview Display

General Description – Overview Display

During a DigiVis 500 project, one overview display can be configured for every operator station. It consists of 16 lines with 6 columns each. A maximum of 96 displays can be represented and selected as symbols.

Existing displays, reports and logs can be listed in a plant-specific manner, using a selector list. A freely assignable plant text and the line headers are used to enhance clarity.
Create a New Overview Display

An overview display is created and edited in the project tree below a resource operator station or in the Common display pool (P-CD). (Refer to Section 2, Project Tree).

> Select resource operator station or P-CD in the project tree
> Edit > Insert next level > Overview display

If an overview display is configured in the Common display pool (P-CD), this overview display will be available in all operator stations.

Overview Display Configuration

> Double-click on the name of the overview display in the project tree

Displays and logs, which had been entered into the overview display but were later deleted, are displayed in red in the configuration mask and are reported as non-existent in the error list during a plausibility check.

Caption text Max. 48 characters

Tabs Page 1 to Page 4

The overview display is configured on 4 pages with 4 lines each.

<1...4> Line Header. Max. 77 characters per line
The numbers specified here depend on the particular page and/or tab.

Segment Name of the display or log entered (six per line)

**Enter display names**

> Select overview display segment > Call up context menu > Select display type and display name from the selector list > OK

Alternatively:

> Select overview display segment > Enter display name > ENTER

The display list may also be called up pressing the function key F2. In the window that appears, all the displays and logs available at this operator station are displayed classified by display types.

If the display name is entered directly, the system will check whether or not the corresponding display exists. The name of an existing display will appear in black, the one of a non-existent display in red.

**Abbreviations in the Display selector list**

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REPORT</td>
<td>Excel Report</td>
</tr>
<tr>
<td>OPL</td>
<td>Operator plant log</td>
</tr>
<tr>
<td>FGR</td>
<td>Free graphic display</td>
</tr>
<tr>
<td>GRP</td>
<td>Group display</td>
</tr>
<tr>
<td>SSL1</td>
<td>Signal sequence log 1 (direct output to the printer)</td>
</tr>
<tr>
<td>SSLN</td>
<td>Signal sequence log N (manual output to the printer)</td>
</tr>
<tr>
<td>TR_D-OS</td>
<td>Trend display</td>
</tr>
<tr>
<td>WEB</td>
<td>WEB display</td>
</tr>
</tbody>
</table>

**Plausibility check**

The overview display is checked for syntactical and contextual errors. If errors are found, they are displayed in a list. Implausible display and log names are shown in red in the configuration mask, plausible ones are shown in black.
Group Display

General Description – Group Display

For each group display you may enter a short and a long text which are displayed in DigiVis500 Operations in the title line next to the display name. This way a group display can be assigned to a process segment. Existing tags can be entered using the selector list. Accordingly, the standardized representations of tags (faceplates) become an integral part of the group display.

In group displays five tags can be shown next to each other and two faceplates one on top of the other. If all the displays cannot be shown completely in the display area, a horizontal scroll bar will be shown below the group display.
Create a New Group Display

A group display is created and edited in the project tree below a resource operator station or in the Common display pool (P-CD). (Refer to Section 2, Project Tree).

> Select resource operator station or P-CD in the project tree

> **Edit > Insert next level > Group display**

If a group display is configured in the Common display pool (P-CD), this group display will be available in all operator stations.

Group Display Configuration

> Double-click on the name of the group display in the project tree

Tags that had been entered but were later deleted, are displayed in red in the configuration mask and are reported as non-existent in the error list during a plausibility check.

Configuration of a group display

![Configuration: Group Display](image)

**Short text**  Max. 12 characters

**Long text**  Max. 30 characters

In DigiVis, short text and long text are displayed, additionally to the display and/or log name, in the title line

The **blue area** is the scroll area. No faceplates may be placed here.
Enter a Tag

> Select group display segment > Call context menu
> Select > Select function type and name from the selection list > OK

Alternatively:

> Select group display segment > Enter tag name > ENTER

The tag selection list can be called up through the menu item Select in the context menu or pressing the function key F2. In the window, which now appears, all the tags configured so far are listed according to Tag Types.

Plausibility Check

The group display is checked for syntactical and contextual errors. If errors are found, they are displayed in a list. Implausible tags are displayed in red in the configuration mask, the plausible ones are displayed in black.

Trend Display

General Description – Trend Display

The trend display makes it possible to graphically display the development of process variables for a period of time. Up to six process variables can be depicted in each trend display. The number of trend displays per operator station is unlimited.

A trend display can be used to visualize the data acquired by any process variables.

Any six variables from the DigiVis 500 system may be specified for configuring a free trend display. An additional variable with the data type DATE&TIME can also be configured for each process variable. The value of this variable is used as a time stamp for the process value.

For variables read from an OPC Server into the DigiVis 500 system, the OPC-Server time stamp that was supplied with them is used.
Create a New Trend Display

A trend display is created and edited in the project tree below a resource operator station. (Refer to Section 2, Project Tree).

> Select resource operator station or P-CD in the project tree
> Edit > Insert next level > Trend display

Trend Display Configuration

> Double-click on the name of the trend display in the project tree

The trend display configuration comprises one parameter definition dialog with five tabs.
Acquisition Tab

![Parameters: Trend Display TR_D-OS]

**General data**

- **Name**: Trend display name, editable in the project tree.
- **Short text**: Max. 12 characters
- **Long text**: Max. 30 characters

The short and long texts are also printed along with the project documentation.

**Use variable acquisition**

Parameter specifies based on independent process variables.

**Sample time**

In the time interval configured, the process variables are read and stored as trend data.
Variables 1 ... 6

**Variable**  
Name of the free trend variable. The function key **F2** is used to call up the list of known variables in the system.

**Time stamp variable**  
Name of the process variable whose value is used as the time stamp for the variables entered under **value**. The function key **F2** is used to call up the list of known variables of data type DT in the system. If no separate time-stamp variable is specified, then for variables from a DigiVis 500 Engineering Station, the associated system variable `<resource_name>.DateTime` is used; in the case of variables read from an OPC Server into the DigiVis 500 system, on the other hand, the **OPC-Server time stamp** that was supplied with them is used.

---

**Display Tab**

Colors  
Selection of colors for foreground, background and window of the trend display (3 colors).

Values window  
Selection whether up to three or all the trends in the value area of the trend display are shown.
**Variable description**

For display in the trend display **name, short text, dimension** and a **tag** are assigned to each trend. The number of trends is equal to the number of connected inputs on the trend acquisition module or the number of entered trend variables.

**Name**
The **Name** assigned to the trend.

**Short text**
The **Short text** assigned to the trend.

**Dimension**
**Dimension** assigned to the trend. The **Dimension** can be entered directly or can be selected from an existing list, using the arrow keys or mouse.

**Allocated tag**
Tag name whose faceplate can be called up in DigiVis 500 Operations by double click.

**Color**
Color selection for each trend curve. All colors available for graphic displays are available.
Default settings for color:

<table>
<thead>
<tr>
<th>Trend</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>signal red</td>
</tr>
<tr>
<td>2</td>
<td>signal yellow</td>
</tr>
<tr>
<td>3</td>
<td>signal blue</td>
</tr>
<tr>
<td>4</td>
<td>signal green</td>
</tr>
<tr>
<td>5</td>
<td>signal cyanide</td>
</tr>
<tr>
<td>6</td>
<td>medium magenta</td>
</tr>
</tbody>
</table>

The text entries or text selection for Name, Short text and Dimension are depicted in DigiVis 500 Operations with the trend. These entries are not mandatory.
Position Tab

The parameter definition of position comprises the time range for depiction on the X-axis, the definition of scaling on the Y-axis and band start / band end for up to six trends.

**Time gaps**

Maximum time interval between two successive time stamps of a value. The values in this internal are interpolated (refer to *DigiVis 500 Operations Operators Manual, Section H, Trend Display, Interpolation*). Entry is made according to IEC 1131-3 time format.

If no time gap detections is configured DigiVis 500 Operations will display three times the cycle time as gap. For example, with a cycle time of 10s a data gap of 30s will be displayed as a gap in the trend even if no gap detection is configured.

**Time axis**

The time axis specifies the scale on the X-axis for the trend depiction in DigiVis 500 Operations. Entry is made according to IEC1131-3 time format. The **maximum value is around** T#24d20h31m23s.

For example, T#2147s or T#24d20h31m23s

**Band start**

The **Band start** specifies the value for the scale start of the Y-axis for depicting an individual trend. See display “Example of the trend depiction” on the following page.
Values are entered as real numbers. The value range is between 0.0 and ±9999999999.9. The value for the band start must be less than the value for the band end.

%  The percentage value specifies the position of the scale start for Band start % on the Y-axis. See figure below. The percentage values must be entered as integers. The value range is between 0 and ±5000%.

Band end  The Band end specifies the value for the scale end of the Y-axis for depicting and for the individual trend. See figure below. Values are entered as real numbers. The value range is between 0.0 and ±9999999999.9. The value for the band end must be greater than the value for the band start.

%  The percentage value specifies the position of the scale end for Band end % on the Y-axis. See figure below. The percentage values must be entered as integers. The value range is between -5000 and +5000%.

Example of a trend display:

![Trend Display Diagram](di131.bmp)

The following settings have been chosen for the parameter definition of the position:

- Band end: -10.0
- Band start %: 20
- Band end: 110.0
- Band end %: 80
Archive Tab

A decision is made whether the trend data archiving is to be enabled on the operator station. If Enable archiving is selected, specify the following: Archive duration, Start up mode and if you want to Delete the old archive. On the operator station only one trend display with a fixed size configured for an archive file (as ring memory).

Enable archiving
✓ The trend data are archived as a function of the Start up mode.

Delete old archive
✓ The old archive will be deleted on restarting the operator station (new start of DigiVis 500 Operator Station).
☐ Archiving is resumed with a chronological gap after a restart.

If archives do not match after a restart (for example, the number of trends have changed in the meantime), the old archive is saved as a file. The old archive files are assigned a serial extension from 001 to 999.

Archive duration
The Archive duration is entered according to the IEC 1131-3 time format. The entry can be made in days, hours, minutes and seconds. Inputs less than 1 s lead to error.
Maximal $24855d = 68$ years
For example,
T#24855d or T#24d20h31m23s
Apart from the input field for the archive duration, the maximum hard disk requirements for archiving on the operator station are given in kilobytes.

The size of the trend file is determined by the archive duration. This size can never be exceeded by the Trend file since data are stored in a ring memory. This means that on reaching the archive duration, the oldest data are always overwritten again by the current data.

Archive name
The file name for the trend archive file on the operator station hard disk can be specified.

File Transfer Tab

File Transfer
Here it is decided whether - and in what way - a copy of the trend
file should be transferred from the DigiVis 500 Operations PC to another PC in the Digivis 500 net. The PC that is to receive the archives must be a communications subscriber in the net (network card and installed FTP Server, refer to **DigiVis 500 Getting Started Manual**. It is also possible to export the Archive file to a Windows drive of the DigiVis 500 Operations PC.  

To **visualize the trend archive data** and to convert them into the CSV format, the DigiVis 500 supplementary program **DigiBrowse** can be used for this PC.

**File transfer (FT)**

*Start export at*  
Cyclical transfer enabled as soon as the configured time is reached. Make entry in the DT format.

- ✔ Start time for the cyclical data transfer
- □ No cyclical data transfer.

*Reexport every*  
Here it is determined at which time periods data transfer is effected. Make entry in the TIME format.

- □ incremental  
  Only the data acquired since the last data transfer are transmitted.

- ✔ complete  
  All archived data are transmitted.

*Access manually export (once, complete)*

- ✔ The operator at the operator station can enable file transfer.
- □ File transfer cannot be enabled manually.

**Target**  
Here the **target of the file transfer** must be defined. As a target a PC connected to the DigiVis 500 network is used. Ideally, the supplementary package **DigiBrowse** should be installed on this PC to permit visualization of archive files of the trend and of logs.

**Station**  
Specification of the IP Address of the target computer. If you operate your 800F system in a **network**, you should obtain the IP addresses from your network manager, as this address must be chosen **unambiguously throughout the world**. If you want to use the **DigiVis 500 Operations PC** as file transfer target, its IP address must be given here.
Path
If the archive files are to be copied into a specified directory, the complete directory name must be given here. It is important to enter a backslash \ as last character. For example, if only C:\temp is given as directory, the file c:\tempXXXX.001 is generated on the target computer, with the Xs denoting the first four characters of the configured archive name.

It must be noted that the target station is responsible for further processing of the files during export. The copied file is only temporary and is overwritten again with the next export of the corresponding archive.

File
The Export files are saved in the file name given under target path.

Directory (8.3)
The export files are saved in the directory given under the target path with names generated by the system using the current date and time. The file name has a length of 8 characters with a 3 characters extension.

Directory
The export files are saved in the directory given under the target path with a name generated by the system using the given name and the current date and time.

Suffix for incremental / complete
In order to distinguish between files containing complete or incremental data sets, either ‘_INC’ or ‘_FULL’ is appended to the basic file name. This suffix prevents a situation from occurring where complete and incremental files are allowed to overwrite one another.

FTP timeout
FTP services are synchronous services. To prevent blocking the system, a maximum time, in which an FTP service must have been executed, must be specified.

User name
This user name must be entered. If necessary, this name is checked by the FTP Server.

Password
This password can be defined when setting up the receiving PC. This ensures that only the subscriber who knows this password can store files in the PC. In this manner abuse or manipulation by non-authorized subscribers can be prevented in open nets.
General Description – WEB Display

Create a New WEB Display

The WEB display will start the local web browser. That way the DigiVis 500 Operations user could get access to files on the local machine or on other machines within the company’s network or in the global internet. Please take into consideration the risks and dangers associated with that!

A WEB display is created and edited in the project tree below a resource operator station or in the Common display pool (P-CD). Refer to Section 2, Project Tree.

> Select resource operator station or P-CD in the project tree

> Edit > Insert next level > WEB display

If a WEB display is configured in the Common display pool (P-CD), this WEB display will be available in all operator stations.

WEB Display Configuration

> Double-click on the name of the WEB display in the project tree
**General data**

*Name*  
WEB display name, editable in the project tree

*Short text*  
Max. 12 characters

*Long text*  
Max. 30 characters

*URL*  
Address of the web-page.
Section 11  Graphic Display

General Description – Graphic Display

In addition to the standard displays, custom graphic displays for observation and operating the process can be used on an operator station. These graphic displays can be created with the graphic editor in the DigiVis 500 Graphics Builder. The state of a process can be depicted in numerous respects with such graphic displays. The static and dynamic graphic objects available make possible a varied graphic representation of the running process. Use of the various animation options makes it possible for the plant operators to observe process events in context at all times.

Each graphic display consists of static and dynamic elements. The static elements are made up of basic objects, such as lines, circles, texts and bitmaps. Available as dynamic elements are special graphic objects (such as alphanumeric displays and bar graphs) with which current process values can be displayed, either as numeric values or graphically. Operable elements form another category; they can be used to trigger a display switch, call up a tag allocation faceplate, acknowledge a message or write values to process variables. The state of the dynamic display elements in DigiVis 500 is determined by the assigned variables and messages from the common DigiVis 500 database.

Graphic symbols can be created from several single graphic objects. These new objects can then be processed further, just like any single graphic object. Graphic objects may also be defined as macros and stored in macro libraries. These libraries can be used as often as required, even in other projects.

The size of the draw area can be adjusted to suit the monitor settings (640x480, 1024x768, 1280x1024 or 1600x1200 pixels). The standard size of the draw area consists of 10240 x 6184 pixels. The size ratio, as well as the current position of the cursor in the drawing area, are displayed in a toolbox.

Further functions include the editing of two displays simultaneously. The second display, called the graphic pool, possesses the same graphic characteristics as the
other display and is always loaded simultaneously with the project. In the graphic pool display, complete displays, partial displays or graphic symbols can be temporarily saved for later use. The contents of the graphic pool are retained when another display is selected.

A number of 3D-effect graphic objects have been pre-prepared to help create complex process displays. These graphic objects can be found in the exported graphic displays Aggregates.dmf, Alphanumeric.dmf, CompController.dmf as well as Objects1.dmf and Objects2.dmf on the installation CD; a readme.txt file is also included.

### Graphic Editor Interface

The graphic area consists of the title line, the menu line, the draw area with the toolbox and the status line.

- **Title line**
- **Menu line**

- **Draw area with grid switched on, crosshairs and toolbox.**

- **Status line with user name**
Additional Features of the Graphic Editor

Graphic editor behavior is based on that of standard Windows programs. In addition, the graphic editor offers a number of special functions to simplify the preparation of a graphic display and its incorporation into the project database.

Cursor keys The cursor arrow keys can be used for precise positioning of the cursor in the draw area. With each key actuation the cursor is moved in the corresponding direction by exactly one screen pixel. When the grid is switched on, the cursor is moved by one grid unit. Refer to Snap / Grid on page 284.

F2 key Call up a selection list.
If a selected configuration mask field is to be filled in with a reference to some project element, the name of that element can, in general, either be typed in directly or chosen from a list of all possible entries. This list can be called up by pressing the F2 key.

Example 1: When during configuration, the name of a process variable is expected, the list called up by pressing F2 contains all process variables that have been configured in the current project.

Example 2: When configuring a dynamic graphic object, the name of an associated static object is expected. Pressing F2 brings up a list of all static graphic objects that are available in the graphic display.

F5 key Display cross references
If the F5 key is pressed in an edit field containing a variable name, the list of cross references for that variable will be displayed. It is then possible to branch directly to any of the programs shown in the list.

Tool tip If the cursor is moved over a graphic object which has had a name assigned to it, the name and type of the object is displayed in the form of a tool tip.

ESC key As long as an object has not yet been defined completely, the configuration can be abandoned by means of the ESC key. The unfinished object is deleted and the graphic editor is set in standard mode.
**Menu Line**

<table>
<thead>
<tr>
<th>Menu Line</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Display</strong></td>
<td>Saves graphic display, performs plausibility check of the graphic display, indicates error list, indicates header, exports and imports graphic displays, exits the graphic editor, returning to the project tree.</td>
</tr>
<tr>
<td><strong>Draw</strong></td>
<td>Creates static graphic objects such as lines, rectangles, text and so on, inserts bitmaps.</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Undoes or repeats last action, groups graphic objects to form new objects, or ungroups them again, cuts, pastes, deletes, copies and doubles graphic elements, mirrors, rotates, arranges or aligns graphic objects, places graphic objects in the foreground or background, switches to the graphic pool display.</td>
</tr>
<tr>
<td><strong>Change</strong></td>
<td>Changes attributes of lines, areas, texts and text contents. Shifts or deletes points of polygons and polylines. Assigns names to graphic objects. Selects the background color for the display.</td>
</tr>
<tr>
<td><strong>Macro</strong></td>
<td>Loads or saves a macro library, used for creating, editing and inserting macros.</td>
</tr>
<tr>
<td><strong>Animate</strong></td>
<td>Reeds dynamic objects, creates dynamic objects, such as bar graphs, fill areas, and so on.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td>Shows the complete display without editor help markings, redraws graphic, simulates self-animated objects, selects setting of zoom and visible region.</td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td>Hardcopy, Set grid setting, Determine toolbox position, Limit and update display size, Activate threaded cursor.</td>
</tr>
<tr>
<td><strong>Back</strong></td>
<td>Returns to calling point.</td>
</tr>
<tr>
<td><strong>Help</strong></td>
<td>Calls up the on-line help system.</td>
</tr>
</tbody>
</table>
Draw Area

The draw area is the user’s actual working area for creating and editing displays. It is located between the menu line or tool bar and the status line and fills the entire screen widthwise. With the toolbox switched on, the visible draw area may be restricted as a result of overlapping. Using the zoom function it is possible to zoom in or out on a section of the display being edited. The Overview function shows an area corresponding to 9 x the drawing size. The actual draw area is shown in the center, marked with a border.

The coordinates on the draw area run from left to right and from top to bottom. The coordinate origin is at the top left-hand corner. The coordinates of the moving graphics cursor are shown in the toolbox. In addition, the coordinates are used to indicate the position of display objects in the parameter dialogs and are shown there.

Toolbox

Information about the current graphic display is shown in the toolbox. This window can be positioned with the Options > Toolbox menu item. It can be placed at the right, left, top or bottom of the screen and it can be hidden with the off setting. Wherever it is originally positioned, it can be moved about freely on the screen.
**Names:** A graphic name or the term “Pool” (for graphics pool) shown in red indicates that the corresponding display is the visible one. It is possible to toggle between the two displays with the Page ↓ or Page ↑ keys or with the help of the menu.

**Display size:** Selected resolution of the X- or Y- coordinates.

**Display:** Displays the currently selected Zoom setting and x/y coordinates of the cursor position.

**Line:** Changes the global line attributes (line thickness, color and style). All subsequent lines receive these attributes. When selecting or drawing a line, the text Line disappears and a line with the pre-selected attributes is displayed on this button.

**Area:** Changes the global Area attributes (foreground/background color, fill pattern). All subsequent graphic items receive these attributes. When selecting or drawing one of these items, the text Area disappears and a rectangle with the selected color and fill is displayed on this button.

**Text:** Changes the global text attributes, such as foreground/background color and type size. All subsequent texts receive these attributes. When selecting or entering text, the text type and color selected is displayed on this button.
Changes of individual graphic objects are carried out in the Change menu. The selection windows are described in detail in the corresponding section of this document.

The second section of the toolbox contains one button for selecting and one button for each type of graphic object. After an object type has been selected, any number of objects of the same type can be drawn one after another. This drawing mode ends when a different object type is selected or the selection button is clicked.

Status Line

The status line forms the lower border of the draw area. In it, the editing processes or the execution instructions of the actions selected are summarized. The name of the graphic display and the USER name are shown at the right most end.

Basic Settings for the Draw Area

The settings for the draw area are made through the Options menu.

Hardcopy

> Options > Hardcopy > Display only
> Windows print options mask (install printer if necessary)
> OK

The draw area is output to the printer.

> Options > Hardcopy > Whole screen,
The whole screen is output to the printer.

Snap / Grid

> Options > Snap/Grid.

Grid size from 1 to 20.

Snap active, or grid visible, respectively.

In order to achieve more uniform positioning, it is possible to display a Background grid. There is an option of 5 fixed grid sizes. The grid setting applies both to the graphic and to the graphic pool displays. While a display is being constructed the grid can be altered and switched on and off.

When Snap is activated, only the grid points are available for positioning, that is the user does not have to click on the desired grid point exactly, but only sufficiently near it. The grid point nearest to the cursor is then selected. The grid and snap settings are independent of each other, that is a grid may be defined without snap being activated, or snap may be activated without a visible grid.

Toolbox

> Options > Toolbox > Off, Right, Left, Top or Bottom.

If Off is selected the toolbox is not visible. Right, Left, Top and Bottom cause the toolbox to be positioned along the respective edge of the screen.

For a description of the toolbox, refer to Toolbox on page 281.
Limiting the Draw Area

> Options > Ruler > 640x480, 1024x768, 1280x1024, 1600x1200 or Off

The area in DigiVis 500 operations available for a graphic display varies, depending on the resolution setting of the monitor. The standard size (10240 x 6728 virtual pixels) is optimized for a monitor resolution of 1280 x 1024. For the monitor resolutions 640 x 480, 1024 x 768 and 1600 x 1200 pixels, a limitation line can be shown in the lower section of the graphic display. This enables graphic objects to be positioned perfectly in the draw area available.

The preferred Resolution is 1280 x 1024.

Update Display Size

> Options > Update display size

This menu choice is used for adapting graphic displays from earlier versions of the software to the new standard display size.

Threaded Cursor

> Options > Threaded cursor

Crosshairs with their intersection point at the cursor arrow are switched on. They extend over the entire draw area in the graphic display.

Background Color

> Change > Background color.

Each graphic display and the graphic pool display may be assigned its own draw area background color. The background color can be set in the menu Change.
After selecting **Background color**, a window appears showing the available colors. To enable these colors to be accessed more quickly they are subdivided into a number of color groups. For background color, the following color groups are allowed **Static colors**, **Media colors** and **Free colors**.

### Color Selection

During the process of creating a graphic display, colors are specified for the background, the static graphic objects and the states of the dynamic graphic objects. All such color settings are made in the same **color selection** dialog box. This window is called up from within the different alteration masks.

All the available colors are subdivided into various different color groups. The groups can be shown and hidden separately, and a direct jump to a particular color is also possible.

Each group can be used in any application, except display background.

The **special colors** group is an exception. The **transparent** option can only be selected for line attributes, as a text background and for animation; it has the effect that the lines or graphic objects are displayed as transparent.

The **Original colors** setting can only be used in animation. Here, the original colors of the graphic object remain intact and are not altered by any animation color settings.
Section 11  Graphic Display

Drawing Static Graphic Objects

**Special colors**
- **Transparent** ✅ no **color**, that is transparent.

**Original colors**
- ✅ the colors of the static graphic object are used.

**Groups**
- Selection of the various color groups displayed in the color selection window.

**Static colors**
- ✅ general colors.

**Message colors**
- ✅ colors to display alarms.

**Signal colors**
- ✅ colors to display signals.

**Media colors**
- ✅ colors that are displayed flashing off and on.

**Free colors**
- ✅ colors for display of color graphs.

**Go to**
- After entering the **color groups** (✅) the buttons **Static**, **Message**, **Signal**, **Media**, **Free** are activated and can be selected. Following selection, the selection is positioned at the start of the selected **color** group in the **color selection** dialog box.

**Drawing Static Graphic Objects**

The following static graphic objects are available: Line, rectangle, polyline, polygon, ellipse, arc, circle segment, text, bitmap. All static graphic objects are under the **Draw** menu.

Graphic objects are displayed with their various attributes such as color, width, style. Attributes can be altered through the toolbox or the **Change** menu. After drawing one graphic object you must select the type of the object to be drawn next from the **Draw** menu. Pressing the **F8** key you can select another object of the type just completed.
The appearance of the objects is determined by their attributes.

<table>
<thead>
<tr>
<th>Graphics editor attributes</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line color</td>
<td>237 colors and invisible</td>
</tr>
<tr>
<td>Line style</td>
<td>continuous, dashed, dotted, dash-dotted</td>
</tr>
<tr>
<td>Linewidth</td>
<td>6 widths</td>
</tr>
<tr>
<td>Arrow</td>
<td>left / right / arrows on both sides</td>
</tr>
<tr>
<td>Rounded Corners</td>
<td>the corners can be rounded off in four stages</td>
</tr>
<tr>
<td>Foreground and Background</td>
<td>237 colors each</td>
</tr>
<tr>
<td>Fillpattern</td>
<td>15 patterns and invisible</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Text attributes</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>text size in pixels</td>
</tr>
<tr>
<td>Text_direction</td>
<td>horizontal or vertical</td>
</tr>
<tr>
<td>Text style</td>
<td>Bold and/or italic and/or underlined</td>
</tr>
<tr>
<td>Fix point</td>
<td>Start, middle, end, top, bottom</td>
</tr>
<tr>
<td>Char. font</td>
<td>at present Arial, Courier New, Lucida Console and MS Sans Serif</td>
</tr>
<tr>
<td>Foreground color</td>
<td>237 character colors</td>
</tr>
<tr>
<td>Background color</td>
<td>237 colors and invisible</td>
</tr>
</tbody>
</table>
Line

> **Draw > Line**
> Mark starting point with mouse click, a construction line appears, and its end point follows the cursor arrow
> Mark end point by mouse click.

A line here means the shortest connection between two points.

Lines are specified with the attributes **line color**, **line style**, **line width** and **line arrow**.

Rectangle

> **Draw > Rectangle**
> Mark starting corner point by clicking mouse, a frame appears, and its end corner point follows the cursor arrow
> Mark end point by clicking mouse.
A rectangle is a graphic item having four sides and four right angles. A square is a particular form of rectangle.

Rectangles are specified with the attributes **line color**, **line style**, **line width**, **rounded corners**, **foreground color** and **background color** and **fill pattern**.

Polyline

> **Draw > Polyline**
> Mark starting point by clicking mouse, a construction line appears, and its end point follows the cursor arrow
> Mark end point of the section by clicking mouse; this point now becomes the starting point of the next section
> Mark end point of the next section by clicking mouse
> Mark end point of the polyline by double-clicking.

A polyline consists of any number of construction points. In each case the points are connected by lines. By activating the right-hand mouse button, the last end point is deleted and a new point can be defined.

It is possible to subsequently alter the construction points of existing polylines (see Change > Points).

Polylines are specified with the attributes **line color**, **line style**, **line width**, **arrow** and **rounded corners**.
Polygon

> **Draw > Polygon**
> Mark start by clicking mouse, a construction line appears, and its end point follows the cursor arrow
> Mark end point of the section by clicking mouse; this point now becomes the starting point of the next section
> Mark end point of the next section by clicking mouse, an area is formed
> Mark end point of the polygon by double-clicking.

A polygon is a closed frame which, like the polyline, can consist of any number of construction points. The first and the last point of the polygon are always connected.

By activating the right-hand mouse button, the last point can be deleted and a new point can be defined.

It is possible to subsequently alter the construction points of existing polygons (see **Change > Points**).

Polygons are specified with the attributes **line color**, **line style**, **line width**, **rounded corners**, **foreground color** and **background color** and **fill pattern**.

Ellipse

> **Draw > Ellipse**
> Mark starting point by clicking mouse, a frame appears, and its end point follows the cursor arrow,
> Mark end point by clicking mouse.

The starting point lies outside the ellipse and is the corner of an invisible rectangle which bounds the ellipse. The size, position and form of the ellipse or circle is determined by moving the cursor away from the starting point.
The ellipse is a closed graphic item. A special form of the ellipse is the circle.
Ellipses are specified with the attributes line color, line style, line width, foreground color and background color and fill pattern.

Text

> Draw > Text
> Mark starting point by clicking mouse, a text input window appears. The starting point is one of the frame's corners or center points, depending upon the settings in the text attributes dialog box.

Words, fixed numeric values or special characters can be displayed as single line.

Texts are specified with the attributes size, alignment, attributes, fix point, character font, foreground and background color.
Section 11  Graphic Display

Arc

> **Draw > Arc**

> Mark starting point by clicking mouse, draw circle or ellipse
> Finish it by clicking mouse,
> Mark starting point of the arc by clicking mouse, move the cursor clockwise: arc gets larger, move the cursor anti-clockwise: arc gets smaller,
> Mark end point of the arc by clicking mouse,

Subsequent changing of the arc size is not possible.

The arc is part of the circumference of an ellipse or a circle. The start and end points are connected by a curve.

Arcs are specified with the attributes **line color**, **line style**, **line width** and **arrow**.

**Construction of an Arc:**

1st step
Draw circle, press left mouse button

2nd step
Fix the starting point, press left mouse button

3rd step
From the starting point, define the arc by pulling the mouse left or right along the circle

4th step
Click the left mouse button to end the construction
Circle Segment

> **Draw > Circle Segment**
> Mark starting point by clicking mouse, draw circle or ellipse,
> Finish it by clicking mouse,
> Mark starting point of the circle segment by clicking mouse,
Moving the cursor clockwise: Circle segment gets larger,
Moving the cursor anti-clockwise: Circle segment gets smaller,
> Mark end point of circle segment by clicking mouse.

Subsequent changing of the segment size is not possible.

The circle segment represents a certain part of a circle or ellipse diagram. It is a closed graphic item.

Circle segments are specified with the attributes **line color**, **line style**, **line width**, **foreground color** and **background color** and **fill pattern**.

**Construction of a circle segment:**

1st step: Draw circle, press left mouse button
2nd step: Fix the starting point, press left mouse button
3rd step: From the starting point, define the circle segment by pulling the mouse left or right along the circle
4th step: Click the left mouse button to end the construction
> **Draw > Bitmap**

> Mark the upper left-hand corner of the insertion position with a mouse-click, whereupon the bitmap dialog will appear.

---

### Bitmap

- **Stretch X (%)**: Bitmap scaling on x-axis (%)
- **Stretch Y (%)**: Bitmap scaling on y-axis (%)

> With the standard stretch values of 100% on each axis, the bitmap is imported with its original size, that is with no distortion.

- **Transparent**: Throughout the whole bitmap, all instances of the upper-left-pixel color are replaced with ‘invisible’, that is the bitmap is imported with a transparent background color.

- **Preview**: Displays the selected bitmap
- **Import**: Opens the dialog for selecting a bitmap file.
- **Export**: Opens the dialog for writing the selected bitmap to a file.

Bitmap files can be imported in BMP format. No other formats are supported at present. If the DigiVis 500 Graphics Builder PC is being operated with the 256
colors setting and a bitmap is imported with more color information, then the colors in the bitmap are mapped onto the static colors of the graphic editor.

Imported bitmaps can be moved, scaled, mirrored and named. The contents of a bitmap cannot be altered in the graphic editor.

**Animate, Dynamic Graphic Objects**

The class of dynamic objects includes objects used in DigiVis 500 Operations both for depicting/observing process dynamics and for operating the plant (for example, operating on process variables). These objects will be called **observation objects** and **operation objects** respectively. All these objects are located under the **Animate** menu. The variables used here for animation of the graphic display can be newly generated from within the graphic editor or, if already configured, can be selected from the variable list with the **F2** key.

For depicting changing process states, the most commonly used dynamic graphic objects are the following: **Bar graphs**, **Fill areas**, **Alphanumeric displays**, **Graphic symbols**, **Self-animated objects** and **Trend windows**.

The following techniques are available to animate observation objects:

- Display the current value of a variable numerically in any format desired.
- Display the contents of a string variable as text.
- Display a configured message text.
• Display different static graphic objects as a function of the configured message type.
• Depict analog values with bar graphs or arbitrarily shaped fill areas, representing, for example, levels in containers.
• Have graphic objects move in the graphic display as a function of an analog value.
• Have the graphic attributes of an object (colors, line width) change as a function of binary process values.
• Have the graphic attributes (colors, line width) of an object change as a function of messages.

The dynamic graphic objects most commonly used for plant operation actions in graphic displays are the following: **Selection areas**, **Buttons**, **Button fields**, **Radio buttons** and **Tab controls**.

These operation objects can be configured to trigger the following actions in DigiVis 500 Operations:

• Call up a faceplate,
• Switch to any other display,
• Write a fixed value to a variable,
• Write an operation value to a variable,
• Acknowledge a message.

These operation actions can also be initiated by a display object.

In DigiVis 500 Operations, when a graphic display is updated, all dynamic objects are placed in front (on top) of any static display elements. This can be altered by making the static elements part of a dynamic object and designating them as foreground or background components within that object. Such grouping makes it possible, for example, to display scale markings on a bar graph.
Creating a Dynamic Graphic Object

> **Animate** > Select type of dynamic graphic object,
> For a new **Bar graph, alphanumeric display, Selection field, Button, Button field, Radio button or Trend window** click mouse to indicate the desired object position.
> Parameter definition dialog is displayed

The editing functions under the Edit menu are only partly usable on dynamic graphic objects.

The system automatically assigns a name for each new dynamic object, and the name is shown in the general section of the parameter definition dialog. It can be changed by the user at any time. Object names must be unique within a graphic display.

Delete Dynamic Graphic Objects

> Select dynamic graphic object > **Edit** > **Delete**.

Alternatively:

> Select dynamic graphic object > Press **DEL key**

Moving and Sizing of Dynamic Objects

On selecting a dynamic graphic object, a frame appears surrounding it. Just as in the case of static graphic objects, the dynamic object can be changed in size or moved about.

All objects used inside this object will be moved and sized accordingly.

General Parameters for Dynamic Graphic Objects

Six tabs are provided in the parameter dialog for the dynamic graphic objects **Bar graph, Fill area, Alphanumeric display, Selection field, Graphic symbol and Self-animated object**; they are described here for all objects.

The parameter definition dialogs of the dynamic graphic objects **Button, Button field, Radio button, Trend window and Tab control** are each described separately.

The general section of the dialog shows both the object name and the object type.
Object name  Shows the name of the dynamic graphic object.

Object type  Shows the type of graphic object

BG = Bar Graph    SEL = Selection Field,
FA = Fill Area    BUT = Button
AD = Alphanumeric Display    BTF = Button Field,
SA = Self-Animated Object    BTR = Radio Button
GS = Graphic Symbol    TC = Tab Control
CUO = Trend Window

Process Value Tab

Details of the process variables that are to be displayed with this graphic object. Definition of the display of this object in the graphic editor.

Scale Tab

The area to be displayed is defined for an animation with an analog value. The limits are specified either by constants or by other process variables.

For bar graphs and fill areas, the fill direction and position of the reference line are defined.

Bit Allocation Tab

A dynamic object may have up to 3 dynamic process states assigned to it. These binary values are linked in DigiVis 500 Operations bit-wise, so that the object can be displayed in up to 8 states.

There are two options for defining a binary process state:

- any process value whose data type is BOOL
- existing messages

Display Tab

Up to 8 object display states are defined for DigiVis 500 Operations, corresponding to the binary process values.
General Tab

Static objects can be configured specifically as foreground or background objects for the dynamic object.

When a dynamic object in DigiVis 500 Operations is clicked on, this can also be used to trigger an action (for example, a change of display or the writing of a process variable).

Positions Tab (only for graphic symbol)

A graphic symbol can be either moved continuously across an area in the graphic display or displayed at up to 8 chosen positions in the graphic display. This area or these positions are defined on this tab.

Tooltip Tab

With this tab tooltips can be configured for the dynamic objects. Depending on the respective object, there are various tooltip possibilities which are available.

Tab: Process Value

**Display variable**

Enter the name of a process variable or select it from the list through F2 key.
Section 11  Graphic Display  

**Message text**  
☑ In place of a process value, the specified text of a message will be displayed. Checking this box will make the **Message** button available. The input field will be colored gray and the text *
<Message text>* displayed. (Only available with **alphanumeric display** graphic objects)

**Message**  
Choice of the message point, the text of which is to be displayed in the alphanumeric display. (Only available with **alphanumeric display** graphic objects)

**Display value (GED)**  
On quitting the parameters mask, the graphic object is displayed on the screen as it is to appear with the value specified. An arrow in the graphic object indicates that the scaling has been violated.

**Tab: Scale**

The scaling of the display, the fill direction and the position of the reference line are specified in this parameter dialog.

**Scaling**  
**Start/End**  
The display range (0 – 100%) can either be specified by giving a constant or as a variable name (selection list available with **F2**).
**Filling**

*Horizontal/Vertical*

Direction in which the dynamic graphic object is to be filled.

*Reference line (%)*

The reference line of the bar graph is given in percent; it defines the value 0 in the bar graph drawing area or the fill area.

---

**Tab: Bit allocation**

Dynamic objects of type **bar graph, alphanumeric display, fill area** and **graphic symbol** may have up to 3 dynamic process states assigned to them. These binary values are linked in DigiVis 500 Operations bit-wise, so that the object can be displayed in up to 8 states.

There are two options for defining a binary process state:

- any process value whose data type is BOOL
- existing messages

---

**Variables/functions**

*Bit1, Bit2, Bit3:*

Either a process variable or a set of message points with a select function can be assigned to each of three bit variables. The number of bit variables configured will determine the number of graphic
object states that need to be specified.
1 Bit-Variable = 2 states of the dynamic object have to be specified.
2 Bit-Variables = 4 states of the dynamic object have to be specified.
3 Bit-Variables = 8 states of the dynamic object have to be specified.

Data input field
Depends on the state of the Messages check box:
The binary process state is defined by a variable of type BOOL. Enter the name of a process variable or select it from the list through F2 key.

or
The binary process state is defined by a set of message points. The F2 key calls up a dialog for selecting a message function.

Messages:  □ A set of message points is used to define a binary process state. If the check box is selected, the Set button becomes available, and the text <all messages> is displayed.

Set
Choose a set of message points from among all existing message points in the project.

After pressing the F2 key in an input field for a bit variable with messages, an additional dialog box appears. The choice made there determines which message status will be used for evaluation.

From the set of configured messages, those whose message state is ‘active’ are evaluated.
<all messages>
From the set of configured messages, those whose message state is not ‘inactive, acknowledged’ are not evaluated (for example, all active messages and all the inactive, unacknowledged messages).

<not acknowledged messages>
From the set of configured messages, those whose message state is ‘unacknowledged’ are evaluated.

**Tab: Display**

Animation of a graphic object with binary process states means that the graphic object will be displayed with changing graphic attributes. In addition to specifying pre-set colors, it is possible to configure an object to take on the color of a message. The message color is determined by the message priority.

It is first determined which of a set of messages are active or pending. Then with the function **most important message**, **latest message**, **oldest message** or **highest priority message** exactly one message is singled out. Both the foreground and background color of this message, each with or without acknowledgment information, can be used for displaying the object. In DigiVis 500 Operations, the process of singling out a message and updating the graphic object with the current colors of that message is repeated once per update cycle.
Section 11  Graphic Display

Variable/Function
Bit1, Bit2, Bit3

Display the configured bit variables and functions.

Table

<table>
<thead>
<tr>
<th>Bits</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>000</td>
<td>C</td>
</tr>
<tr>
<td>001</td>
<td>C</td>
</tr>
<tr>
<td>010</td>
<td>C</td>
</tr>
<tr>
<td>011</td>
<td>C</td>
</tr>
<tr>
<td>100</td>
<td>C</td>
</tr>
<tr>
<td>101</td>
<td>C</td>
</tr>
<tr>
<td>110</td>
<td>C</td>
</tr>
<tr>
<td>111</td>
<td>C</td>
</tr>
</tbody>
</table>

State
Numbering of the states available for the graphic object.

Display
On quitting the parameters mask, the dynamic object is displayed with the attributes of the selected line in the graphic display.

Msg.
This button is available when the state of the graphic object is determined by messages. When it is selected, a dialog appears in which a message can be singled out.

Border/Fill
Click mouse on desired color field or press Tab key repeatedly until focus is on the desired color field, then press Spacebar.

It is possible to change the border and fill color settings for the dynamic graphic object. The setting of the desired colors is made out with the color selection parameter window Color Selection (refer to Color Selection on page 286). With the setting invisible, the
border or area is displayed transparent, with *Original colors*, the colors of the static graphic object are used. If the state of the graphic object is influenced by messages, then, in the second color dialog (Message colors) the object can be configured to take on colors from the messages it depends on (see below).

**Display**  
Switch to the graphic display (operative only with certain dynamic graphic objects).

**Object name**  
> Click field > Press **F2**,  
> Names of the static graphic objects that are not yet in use are output,  
> Select and **OK**,  
> Name of selected graphic object is shown in this field.

or

> Click the desired field under *Object name*  
> Use the **Display** button to change to the graphic display,  
> Select existing or newly created static graphic object which is not yet in use  
> Return to parameter definition through > **Edit** > **Return to object**  
> Name of the graphic object is entered in the field (If a static graphic object without a specified name has been selected, this object is automatically assigned a system-generated name).
Assignment of a message color to a dynamic graphic object.
**Objects in foreground / background**

Overlapping of static and dynamic graphic objects. Static graphic objects can be placed in front of or behind dynamic objects. After pressing one of these two buttons, the corresponding graphic level is activated. Static graphic objects can be selected or created at that level. Return to the parameters mask through > **Edit** > **Return to object**. After completion of parameter definition, the edited graphic objects are *grouped*, connected with each other (share a common frame).

Grouped graphic objects can be ungrouped as follows:

1. Select dynamic object, > **Animate** > **Reedit**
2. Select **Objects in foreground** or **Objects on background**, graphic level is activated,
3. Click on an unoccupied area (no item should be selected),
4. **Return to object**.

The connection between the dynamic and static objects is removed.

**Action**

When a dynamic graphic object is selected in DigiVis 500 Operations, an action such as a display change, calling up a tag allocated faceplate, operation of a variable or acknowledgment of a message can be made to occur. It is also possible to operate a variable or acknowledge messages.

**Comment**

Free-form text can be entered to describe the graphic object (max. 33 characters).

**Configuring an Action**

An action can be specified for all dynamic graphic object types except **trend window**. In DigiVis 500 Operations, this action will be triggered by a single click on the object. An exception is the call-up of a tag allocated faceplate: the tag is selected with a single click and the associated faceplate is called up with a double click.

One of the following actions can be configured for any dynamic graphic object:

- No action
- Show display
- Open faceplate
- Write variable
- Accept or cancel operation

> Press the button **Action** in the parameter definition mask

After selecting an *action type*, only the fields associated with the respective action remain accessible. An entry can be made directly or through the selection list by pressing the **F2** key.

**Action type**  Selects an action type to be configured

**Show display**  When the graphic object is selected in DigiVis 500 Operator Station, the display entered here will be called up.

**Show facplate**  When the graphic object is selected in DigiVis 500 Operator Station, the faceplate associated with the tag entered here will be called up.
**Write variable**  When the graphic object is selected in DigiVis 500 Operator Station, the current value entered in the Value field, will be written to the variable. In DigiVis 500 Graphics Builder entering the name of a variable in the write variable field enables the Operation button. Refer to Write Variable Operation on page 314.

**Write set of variables**

When the graphic object is selected in DigiVis 500 Operator Station, the current values entered in the respective Value fields, will be written to the variables. In DigiVis 500 Graphics Builder the Operation button will get enabled.

If any OPC Server is not accessible or if any controller linked to a particular OPC Server is down and if the user tries to write a value into a variable, then the write operation is not possible for the entire set of variables. This feature is built in to ensure consistency of data.

**Acknowledge**  Selecting the action Acknowledge message(s) enables the button Messages and the check box Operation needs to be confirmed in
the field acknowledgement. Refer to Selection of Messages on page 321.

✅ Operation needs to be confirmed: If this check box is marked, an acknowledgement by the operator will be required.

**Acknowledge operation**

For the writing of variables and acknowledging of messages it may be specified that the write action is discontinued only when a second key is pressed additionally to the change of value; corresponding to the OK or ENTER key. If the action Accept operation is selected, the graphic object will receive the function of an ENTER key.

**Cancel operation**

An operation that has to be accepted pressing the OK or ENTER key, can be ended by selecting the action cancel operation. All pending actions will be canceled. If this action is selected, the graphic object will receive the function of an ESC key.

**Acknowledgment of Messages**

DigiVis 500 Operations can be made to acknowledge messages when an object is selected.

It is possible to so configure a dynamic object, that when it is selected in DigiVis 500 Operations, messages which are not visible in the display will be acknowledged.
Acknowledgment messages are only sent to message points for which an entry in the message page is available. Which of the specified message points are to be acknowledged when the graphic object is selected, must be specified with the acknowledgment function.

From all message points configured under **Messages** are acknowledged:

- **all messages** all message points.
- **most important message**
  The most important unacknowledged message is determined using the following algorithm:

<table>
<thead>
<tr>
<th>Criterion A: Message status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1: active, not acknowledged</td>
</tr>
<tr>
<td>Step 2: not active, not acknowledged</td>
</tr>
<tr>
<td>Step 3: active, acknowledged</td>
</tr>
</tbody>
</table>

All messages being equally important according to Criterion A are
sorted according to:

<table>
<thead>
<tr>
<th>Criterion B: priority</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
</tr>
<tr>
<td>Step 2</td>
</tr>
<tr>
<td>Step 3</td>
</tr>
<tr>
<td>Step 4</td>
</tr>
<tr>
<td>Step 5</td>
</tr>
</tbody>
</table>

All messages being equally important according to Criteria A and B are sorted according to:

<table>
<thead>
<tr>
<th>Criterion C: Acknowledgment strategy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
</tr>
<tr>
<td>Step 2</td>
</tr>
<tr>
<td>Step 3</td>
</tr>
</tbody>
</table>

From all messages being equally important according to Criteria A, B, and C the oldest message will be determined.

**highest priority message**
The message with the highest priority. If more than one message with the same priority exists, the ‘most important’ will be determined.

**newest message**
The message with the most recent time stamp. If more than one message with the same priority exists, the ‘most important’ will be determined.

**oldest message**
The unacknowledged message with the time stamp furthest in the past. If more than one message with the same priority exists, the ‘most important’ will be determined.
Write Variable Operation

After specifying a process variable for writing by an operator from a DigiVis 500 Operator Station, the type of operation and associated operations log entry format must be specified. The value to be written to the variable is either fixed as a configuration setting or to be entered by the DigiVis 500 Operations user.

After a graphic object is selected in DigiVis 500 Operations, an operation dialog is displayed next to it or on the bottom of the screen. When the operation dialog is called up, the current value of the process variable to operate is read and displayed as default value. The component values can be changed individually and then transmitted to the OPC Server by a write command.

Only one operation procedure can be configured per graphic display for a given process variable. It is not possible, for example, to configure one graphic object with an input field and another graphic object with discrete values. It is possible, however, to configure a variable to receive a value from the user through one graphic object and to receive a fixed value through another graphic object.

The dialog which appears when **Operation** is chosen for configuring the writing to a process variable, depends on the data type of the variable.
Configuration for Operating a Variable

**Variable**
Shows the name of the associated process variable.

**fix/operate**
Choose whether the variable is to receive a fixed value or a value obtained from the DigiVis 500 Operations user. If fix is selected, entries may be made in the Text for variable, Dimension, Fixed value and Lock fields.

**increment**
This option allows for incremental process value changes. The step width changes while the button is being pressed. For configuration, refer to Configuring Operation: Increment on page 317.

**touch**
A configured value is written while the button is being pressed. For configuration, refer to Configuring Operation: Touch on page 319.
Type  Shows the data type of the variable.

Component  For structured data types only. 
One element of the structured variable is selected at a time from the selection list. The operation of each component is configured separately. In DigiVis 500 Operator Station the operation of the components is carried out one after another.

write/don’t write component  For structured data types only. 
Whether or not it shall be possible to operate a component in DigiVis 500 Operator Station is specified here for each component.

Text for variable  Input any text. 
This text is entered as the variable name in the operation log.

Dimension  Input any text. 
In the operation log this text is entered after the old and new values.

Fixed value  Input is only possible here if fix operation has been chosen. This value is directly written to the OPC Server, without requiring any further entries from the DigiVis 500 Operations user.

Operation needs to be confirmed  Can only be selected together with the Fixed value edit field. 
The changed process value is calculated on the basis of the absolute value or as a percentage of the scaling.

☑ The value configured as Fixed value is only written to the OPC Server if, after having clicked the object with the mouse the ENTER button or an OK button in the graphic display is additionally actuated.

☐ The value configured under Fixed value is directly written into the OPC Server upon a mouse-click on the object in DigiVis 500 Operator Station.

continuous  DigiVis 500 Operator Station will obtain the value using an input field and, if applicable, the scroll bar.

discrete  For entering a value, up to six alternative options are displayed.

Min/Max  Validity range for entered value.
**Lock**

The operation of a value can be locked in conjunction with a BOOLEAN variable. When the operation menu is called up, this variable is first read and operation refused if it has the value TRUE. Also, writing a fixed value can be prevented by the configuration of a Lock variable.

**negate**

The value of the variable defined in Lock is negated for the purposes of locking out operation, that is to lock out operation, the variable must have the value FALSE.

**Configuring Operation: Increment**

This option allows for incremental process value changes. When selecting an object, the associated process value is increased or decreased within its scaling by the calculated difference. This new value is directly transmitted to the process, that is no further confirmation is required. Continuous pressing of this button - that is holding down the left mouse button for a longer time period - permanently repeats this procedure. With this, the process value is changed continuously and not in a single step as it would after entering a new value. The step width changes with the time for which the button is held down.
**Direction**  Direction of the progression of values (up/down)
The current process value is incremented or decremented, depending on the configured parameter setting.

**absolute values**

The changed process value is calculated on the basis of the absolute value or as a percentage of the scaling.

- Calculate process value changes in absolute values.
- Calculate process values changes as percentage values of the scale.

**Change rate**  The longer the button is held down, the more the process value may change. With the values for *Initial slope, Maximum slope* and *Time to maximum* the curve to be used for this calculation is specified.
**Repeat**  Frequency with which a new value is calculated and written to the OPC Server (100 ms, 500 ms, 1 s).

**Configuring Operation: Touch**

**Value on pressed button**
Entry of a constant value which is written as long as the button is pressed (while holding the mouse button down).

**Value on releasing button**
Entry of a second constant value (optional), which is written once when the button is released.
Write Variable Operation

**Repeat**  Frequency with which a new value is calculated and written to the OPC Server (100 ms, 500 ms, 1 s).

**Configuring Operation: Discrete**

When selecting *discrete* instead of *continuous* a choice of up to 6 fixed values can be offered to the DigiVis user for selection.

Value (must be compatible with data type of the variable to be operated). When invoking the operation dialog, the variable to be written is read and the text associated with the value is selected. When DigiVis 500 Operations initiates the write action, the value that was configured for the selected text will be written to the variable.
**Text**

Input any text. The text is displayed to the user, and the corresponding value is entered in the operation log.

**Lock**

The availability of every individual value can be locked, in dependence of a BOOLEAN variable. When the operation menu is invoked, this variable is read, and the value is not shown or indicated as not available, if this variable has the value of **TRUE**.

**negate**

The value of the variable defined in **Lock** is negated for the purposes of locking out operation of a radio button, that is to lock out operation of the radio button, the variable must have a value of **FALSE**.

---

### Selection of Messages

All allocated tags in the project that have a faceplate and at least one message point are listed. Using the buttons in the column headings, the list can be sorted by different entries. Search criteria can be entered in the input fields above the list.

Each line in the list is provided with a checkbox in which to mark the chosen message points.
Search criteria input fields:

- **Tag**
  - Tag name

- **Area**
  - Plant area

**Access by client**
The name of an operator station can be given as a search criterion, that is only the tags available on this station are listed.

**L**
- Library type

**Show message points**
Every message point of the listed tag is shown on a line of its own.

**Column labels:**

- **Tag**
  - Tag name

- **L**
  - Type of library
    - (S: Standard, U: User defined, E: Special)

- **Plant area**
  - Plant area

- **Message point**
  - Message points

- **P**
  - Message priority

- **Message**
  - Configured message text

- **Type**
  - Message type

- **Search**
  - The list is redrawn, taking any entries in the search criteria fields into account.

- **Select all**
  - All message points in the list are selected.
  - The selections remain even after entry of new search criteria provides a new list of message points.

- **Unselect All**
  - The selection of all message points is undone. This procedure is independent of the search criteria in effect and the contents of the displayed list.

- **Select marked items**
  - All message points with marked check boxes are selected.
**Unselect marked items**

All message points with marked check boxes are unselected.

---

**Tab: Tooltip**

Enable tooltip

If you select this check box, the subsequent check boxes will be enabled. If several tooltip variants are configured, these tooltip variants will be indicated one below the other in a tooltip in DigiVis 500 Operations.

Current process value

In DigiVis 500 Operations the name of the display variable and the current process value are indicated in the tooltip:

Value (*<Name*>): *<current value>*

Configured action

The action triggered by clicking on the object, will be indicated as a tooltip:
Load Display <Name>
Open Faceplate <Name>
Write Variable <Name>
Acknowledge Message (s)
Accept Operation
Cancel Operation

**Message data**
In the tooltip the message information is given which is used to display the object as shown below.

![tooltip.bmp](tooltip.bmp)

**Text**
In the input field you may enter any text of several lines which will appear in the same format in the tooltip.

---

**Tab: Positions (only for graphic symbol)**

![tu0906gr.bmp](tu0906gr.bmp)

**continuous**

**x-, y-coordinates**

Enter the x/y coordinates of max. movement. The movement range is produced from the process variable and the scaling. The movement vector set determines the movement of the graphic symbol when the value of the variable is equal to the end of the
scale. When the variable value is equal to the start of the scale, the
graphic symbol is displayed in the design position.

> click on x- or y- field, > switch to the graphic display through the Display
button,
> Determine position with cursor.

<table>
<thead>
<tr>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch to the graphic display, Return through &gt; automatic return to the parameter definition by double-clicking.</td>
</tr>
</tbody>
</table>

**discrete**

<table>
<thead>
<tr>
<th>All positions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter all positions</td>
</tr>
</tbody>
</table>

> Switch to the graphic display through the All positions button,
> Click positions > **Automatic return** to the parameter screen,
> Coordinates are entered.

<table>
<thead>
<tr>
<th>Single position</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter a single position</td>
</tr>
</tbody>
</table>

> Select x- or y- field, > Enter the x/y-position or
> Switch to the graphic display through the Single position button,
> Click on desired position
> automatic return to the parameter screen
> Coordinates are entered.

**Bar graph**

> Animate. > **Bar graph**
> A mouse-click fixes the position of the top left-hand corner; by dragging the mouse (rectangle), the size of the bar graph can be adjusted. Another click of the mouse at this point concludes the construction of the bar graph,
> Enter data in the parameter definition masks,
> Display the bar graph without construction frame.
A current process value can be displayed as a rectangular column. The minimum and maximum values of the column can be given as constants or as other process values. The column can be filled vertically or horizontally. The reference line of the bar graph is given in percent; it defines the value 0 in the bargraph draw area.

The line style, line width, pattern and colors for the background are defined with > Change > Line attributes/Area attributes or through the toolbox with the Line or Area buttons.

The color settings for the border and the areas are made in the color table parameter windows (refer to Tab: Display on page 304). The colors can be made to change as a function of binary variables and/or messages.

For configuration, refer to Tab: General on page 307, Tab: Process Value on page 300, Tab: Scale on page 301, Tab: Bit allocation on page 302, Tab: Display on page 304 and Tab: Tooltip on page 323.
A fill area is linked to a polygon. The area bounded by the polygon is filled in dependence of the current process value. Minimum and maximum values associated with the fill area are set as constants or configured as other process values. The area can be filled vertically or horizontally. The fill area reference line is given in percent.

The line style, line width, pattern and colors for the background are defined with > Change > Line attributes/Area attributes or through the toolbox with the Line or Area buttons.

The color settings for the borders and the flooded area are made in the color selection parameter windows (refer to Tab: Display on page 304). The colors can be made to change as a function of binary variables and/or messages.

The static object polygon can no longer be selected individually, but only as a fill area. Assigning a different polygon to a given fill area makes the previously assigned polygon available again as static graphic object.

For configuration, refer to Tab: Process Value on page 300, Tab: Scale on page 301, Tab: Bit allocation on page 302, Tab: Display on page 304, Tab: General on page 307, Tab: Tooltip on page 323.

Description of parameters specific to fill areas

Display options

Display  The switch to the graphic display is compulsory. An existing polygon can be selected or a new one created. Return to the parameter definition mask through > Edit > Return to object.
Alphanumeric Display

> Animate. > Alphanumeric display
> A mouse-click fixes the position of the top left-hand corner and, by dragging the mouse (rectangle), the size of the alphanumeric display can be adjusted. Another click of the mouse at this point concludes the construction of the alphanumeric display,
> Enter data in the parameter definition masks,
> Display the text without construction frame.

The current contents of a process value will be displayed either numerically or as text in any format desired. All system data types can be represented.

Even the display of a configured message can be realized with an alphanumeric display.

The size, alignment and the fix point can be set with
> Change > Text attributes or through the Toolbox with the Line or Field button.

The color settings for texts and background are made in the color selection parameter window (refer to Tab: Display on page 304). The colors can be made to change as a function of binary variables and/or messages.

For configuration, refer to Tab: Tooltip on page 323, Tab: Process Value on page 300, Tab: Bit allocation on page 302, Tab: Display on page 304, Tab: General on page 307.

Description of parameters specific to alphanumeric displays

**Display**

**Format**

A separate format can be specified for each of the up to 8 states that the alphanumeric display can assume.

> Click on format area > Press F2 > Select format > OK

A window is opened, and the various output formats are indicated
for selection, including formats conforming to the IEC Standard. Custom formats can also be created. For details see below.

**Select and Create Custom Formats**

After selecting the table column *Format* on the **Display** tab and pressing **F2**, the **Select Format** window shows the standard default data formats for the relevant data type. The desired format can be selected, then accepted with **OK**.

![Select data format](d6540uk.bmp)

**Format**

- **fixed**
  - Default format for the data type; the **Add**, **Edit** and **Delete** buttons cannot be selected.

- **user-defined**
  - Display user-defined formats; the **Add**, **Edit** and **Delete** buttons are selectable.

With the settings *fixed* and *user defined* you can switch between the format displays. In the user defined display mode, a new format can be specified using the **Add** button. A selected format can be deleted with the **Delete** button or be called up through the **Edit** button and changed in another window.
Name of the new format

Format
Desired formatting. In the Format field you can enter the letter f for the desired format, that is ff.ffff for two digits to the left and four digits to the right of the decimal point.
‘-’ serves as a wild card for negative numbers, and a display with a leading sign is indicated by ‘+’.

OK
Adds the new format to the existing format list.

Examples of fixed data formats:
The Standard format is available for each data type, see table:

The following applies to the representation of Real numbers: Due to internal representation constraints, conversion of real numbers to displayable values cannot be made to more than 7 significant digits. Because of this fact, in the standard format, the number of decimal places is adjusted as a function of the numeric value. Very large and very small values are displayed in exponential notation.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Name</th>
<th>Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>REAL</td>
<td>Float</td>
<td>+f.ffffffE+ee</td>
<td>-4.670000E-19</td>
</tr>
<tr>
<td></td>
<td>Fixed point 1</td>
<td>f.f</td>
<td>3.1</td>
</tr>
<tr>
<td></td>
<td>Fixed point 4</td>
<td>f.fff</td>
<td>3.1415</td>
</tr>
<tr>
<td>Data type</td>
<td>Name</td>
<td>Format</td>
<td>Example</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------</td>
<td>-------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>BOOL</td>
<td>BOOL (Standard)</td>
<td>b</td>
<td>TRUE</td>
</tr>
<tr>
<td></td>
<td>Decimal</td>
<td>+fff</td>
<td>1</td>
</tr>
<tr>
<td>INT, UINT, DINT, UDINT</td>
<td>Binary</td>
<td>2#ffffff</td>
<td>2#101010</td>
</tr>
<tr>
<td></td>
<td>Octal</td>
<td>8#ffffff</td>
<td>8#605301</td>
</tr>
<tr>
<td></td>
<td>Decimal (Standard)</td>
<td>+fff</td>
<td>-145</td>
</tr>
<tr>
<td></td>
<td>Hexadecimal</td>
<td>16#ffffff</td>
<td>#16#F90C</td>
</tr>
<tr>
<td>TIME</td>
<td>Duration (Standard)</td>
<td>T#fhfmffsffms</td>
<td>T#1h35m50s8ms</td>
</tr>
<tr>
<td></td>
<td>hh:mm:ss.sss</td>
<td>hh:mm:ss.sss</td>
<td>15:36:55:041</td>
</tr>
<tr>
<td></td>
<td>hh:mmm</td>
<td>hh:mmm</td>
<td>15:36</td>
</tr>
<tr>
<td></td>
<td>ss.sss</td>
<td>ss.sss</td>
<td>55.041</td>
</tr>
<tr>
<td>DT</td>
<td>Time of day (Standard)</td>
<td>DT#yyyy-mm-dd-hh:mm:ss.sss</td>
<td>1998-09-15-14:36:55,041</td>
</tr>
<tr>
<td></td>
<td>Summertime / wintertime (*) (1)</td>
<td>DT#yyyy-mm-dd-hh:mm:ss.sss a</td>
<td>1998-09-15-15:36:55,041S</td>
</tr>
<tr>
<td></td>
<td>hh:mm:ss.ssssa (*)</td>
<td>hh:mm:ss.ssssa</td>
<td>15:36:55.041S</td>
</tr>
<tr>
<td></td>
<td>hh:mm:ss.sss</td>
<td>hh:mm:ss.sss</td>
<td>14:36:55.041</td>
</tr>
<tr>
<td></td>
<td>dd-mm-yy</td>
<td>dd-mm-yy</td>
<td>15-09-98</td>
</tr>
<tr>
<td>STRING</td>
<td>Pure string Pur</td>
<td>s:0:0:n,n</td>
<td>ABCDEFG 12345</td>
</tr>
<tr>
<td></td>
<td>String (Standard)</td>
<td>s:0:0:y,y</td>
<td>‘ABCDEFG$N12345’</td>
</tr>
</tbody>
</table>

(1) If the time to be displayed is in summertime, the value is increased by the summertime differential and flagged with S, both in DigiVis 500 Operations PC and in the graphic editor.)
Examples of user defined data formats:

<table>
<thead>
<tr>
<th>Data type</th>
<th>Format</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>REAL</td>
<td>[+</td>
<td>-]f.ff...[E[+</td>
</tr>
<tr>
<td>INT, UINT, DINT, UDINT</td>
<td>[+</td>
<td>-]fff...</td>
</tr>
<tr>
<td>BYTE, WORD, DWORD</td>
<td>0f</td>
<td>07</td>
</tr>
<tr>
<td>TIME</td>
<td>see fixed data format</td>
<td></td>
</tr>
<tr>
<td>DT</td>
<td>see fixed data format</td>
<td></td>
</tr>
<tr>
<td>STRING types</td>
<td>s:L(S):Z:I:T(1) (2)</td>
<td>High, Low</td>
</tr>
</tbody>
</table>

(1) Control characters:
$R$ Carriage Return (CR),
$N$ Line Feed (LF),
$L$ Carriage Return and Line Feed corresp. $R$N,
$T$ Tabulator,
$ff$ Hex-coded ASCII character, that is ‘$41’ synonymous with ‘A’,
$’$ Apostrophe (‘),
$\$$ Dollar sign ($).

(2) Control characters for use with strings:
L: Number of displayed characters. Default: all
S: Position of the first character to be displayed. 1. Character 1 occupies position 0. Default: 0. Z:
Line to be displayed, for all lines enter 0. Default: 0
I: Display of control characters and margin delimiters; Options y or n. Default: y
T: Interpret tab signs, options y or n. Default: n

Example:

<table>
<thead>
<tr>
<th>Format</th>
<th>STRING variable</th>
<th>Output STRING variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>s:</td>
<td>‘ABCDEFG$N12345’</td>
<td>‘ABCDEFG$N12345’</td>
</tr>
<tr>
<td>s:11</td>
<td>‘ABCDEFG$N12345’</td>
<td>‘ABCDEFG$N’</td>
</tr>
<tr>
<td>s:10,5</td>
<td>‘ABCDEFG$N12345’</td>
<td>EFG$N1234</td>
</tr>
<tr>
<td>s::2</td>
<td>‘ABCDEFG$N12345’</td>
<td>‘12345’</td>
</tr>
<tr>
<td>s:2,1</td>
<td>‘ABCDEFG$N12345’</td>
<td>A</td>
</tr>
<tr>
<td>s:2,1:2</td>
<td>‘ABCDEFG$N12345’</td>
<td>2</td>
</tr>
</tbody>
</table>
A graphic symbol is used to animate static graphic objects. As with the other
dynamic objects, a maximum of 3 binary process states, and consequently eight
different states can be configured for this object. Two colors and one static object
are defined for each state. The static objects can be single objects or groups
containing several objects (SGM). It is thus possible, that is to display a line in a
variety of different colors and also to select completely different representations for
the various different states.

The following **Animate options** are available:

**Do not move**
The static elements of the graphic symbol are output on the
defined xy coordinates. The coordinates are determined by
positioning the graphic objects in the graphic display.

**Discrete move**
The pre-set coordinates at which the graphic symbol is
displayed are a lookup function of binary variables (maximum
of 3). Customized colors can also be specified for the different
states (maximum of 8).
**Continuous move**
The graphic symbol is moved continuously between two x/y coordinate points as a function of an analog signal. Up to 3 binary variables can also be set in order to define a maximum of 8 different color and display states for the graphic symbol.

When a graphic symbol is moved, all associated items are always moved together.

- > Animate. > **Graphic symbol**
  - > Fill in the parameter masks,
  - > In the mask **Display** select one of the object names and then the **Display** button,
  - > In the graphic display select a graphic object or object segment (SGM) or create a new one,
  - > Return to the parameter definition mask through > **Edit** > **Return to object** > **OK**.

For configuration, refer to Tab: Tooltip on page 323, Tab: General on page 307, Tab: Bit allocation on page 302, Tab: Display on page 304. Depending on the animation type refer also Tab: Scale on page 301, Tab: Process Value on page 300.

**Color Table**

By configuring a maximum of 3 binary variables, the graphic symbol can be displayed in up to 8 states. For each of these states, a static graphic object and a color combination is specified (refer to Tab: Display on page 304).

- **Object name**
  - > Click field > Press F2,
  - > Names of the static graphic objects not yet in use are output.
  - > Select and **OK**,
  - > Name of the selected graphic object is shown in this field.

or

- > Click the desired field under **Object name**
  - > Press the **Display** button to switch to the graphic display,
  - > Select existing or newly created static graphic object which is not yet in use
  - > Return to parameter definition through > **Edit** > **Return to object**
  - > Name of the graphic object is entered in the field (If a static graphic object without a specified name has been selected, a system-generated name will automatically be assigned to this object).
Self-Animated Object

> Animate > Self-animated object
> Fill in the parameter definition masks,
> In the mask Display select one of the object names and then the Display button,
> In the graphic display select a graphic object or object segment (SGM) or create a new one,
> Return to parameter definition through > Animate > Return to object
> OK.

Up to 8 static graphic objects will be displayed in turn for 125 or 250 ms each.

When selecting an existing self-animated object, a construction frame is drawn around the displayed symbol. The symbol is displaceable. When a graphic symbol is displaced, all associated items are always displaced together.

If the View all check box is ticked in the Display parameter definition mask, all the elements of the selected object that are being used will appear in the display, and - when selected - will be surrounded by a common construction frame.

For configuration, refer to Tab: Tooltip on page 323, Tab: Bit allocation on page 302, Tab: Display on page 304, Tab: General on page 307.

Description of defining parameters specific to self-animated objects

The variables have different meanings in the bit variables dialog.

Visible/Invisible Depending on the value of a process variable, the graphic object is either shown or not shown in the graphic display sequence.

On/Off Depending on the value of a process variable the intermittent display of static objects is switched either on or off.

Fast/Slow The speed of animation is made to change with the value of a process variable.

Display

Up to 8 static objects and color combinations can be assigned to a self-animated object. Depending on the values of the specified process variables, the next object appears in the graphic display every 125 or 250 ms, the animation is started or stopped, or the display of a given object is included or not.
Trend Window

Display up to 6 trends within a trend window.

A Trend window can be positioned and sized at will within a graphic display. Up to 6 trends may be displayed in one window. These trends have no history (display of the measured values commences when the corresponding graphic is called up). The color can be set separately for each trend, as it can for the Trend window foreground and background. Standard scaling is specified but can be changed within DigiVis 500 Operator Station.

The Trend window can be shown with or without 3-D formatting.

The trend data are captured according to the cycle time defined for the graphic. A maximum recording time can be set in TIME format.

The Trend window cannot be moved in DigiVis 500 Operator Station. No trends can be added in DigiVis 500 Operator Station.
Trend Window Parameters

After selecting the **Tooltip** button the **Activate Tooltip Tab** appears. For the trend window only the check box **Text** is available.

**Trends**
List of variables specified for display in the Trend window.

**Insert**
On selecting the **Insert** button, the **Trend data** window appears, where the trend variable can be entered with its characteristics.

**Edit**
On selecting a specified variable (click on variable under **Trends**) and pressing the **Edit** button, the **Trend data** mask appears with the entries for that trend variable. The entries can be changed in this window.

**Delete**
On selecting a specified variable (click on variable under **Trends**) and pressing the **Delete** button, the variable is deleted from the Trend window.

The display of the scaling axis on the left is determined by the settings for the variable selected when exiting this dialog box.
**Time axis**

*Record duration*

Specify the max. duration for which the trend can be captured without leaving this graphic display. Thereafter each new value overwrites the earliest value. Entry is in TIME format (max. approx. value depends on cycle time of the display). For example, a graphic display with cycle time of 1s, the maximum duration of each trend window is about 2h15m.

**Display duration**

Specify the visible time range in the Trend window. Entry is in TIME format (max. approx. 24 days).

**Colors**

*Background*

Specify the background color of the Trend window.

*Foreground*

Specify the foreground color (scaling, raster) of the Trend window.

*Window*

Specify Trend area color for the Trend window. Click on color field and color selection through the **Color Selection** parameter definition window (refer to **Color Selection** on page 286), select color and confirm with **OK**. Selected color is displayed in the color field.

**Display**

Depiction of Trend window in the graphic display.

*3D*

✓ Trend window in 3-D formatting.

☐ Trend window without 3-D formatting.

**Scale below**

✓ The time axis is displayed under the trend window.

☐ Trend window displayed without time axis.

**Scale left**

✓ Scaling is displayed in physical dimensions to the left of the Trend window. The scaling values used are those which were configured for the variable selected in the trends list upon exiting this dialog box.

☐ Trend window without left scaling.

**Scale right**

✓ Scaling is displayed as percentage to the right of the trend window.

☐ Trend window without right scaling.
Operation
Operation of the Trend window from within the graphic display.

Inplace
☑ Operation from within the graphic object.
☐ Operation from outside the graphic object.

Buttons per row
Indication of the visible trends per line.

Single curve operations
☑ on the bottom part of the trend window on the left, a set of buttons is displayed to displace the Y axis of the marked trend.
☐ in the trend window there are no buttons for operation displayed.

Time
☑ on the bottom part of the trend window on the right a set of buttons is displayed to displace the X axis of the marked trend.
☐ in the trend window there are no buttons for operation displayed.

Trend Window Variables Parametrization
Insert new Trend window variable
> Press the Insert button in the Trend window parameter definition mask.

Change existing trend variable
> Select an existing variable,
> Press the Edit button in the Trend window parameter definition mask,
> In the mask Trend data the variable can be configured.
Variable Enter trend variable. Enter directly or select through the F2 key.

Comment A comment with up to 19 characters may be entered; it will be displayed to the left of the scaling and be visible only if Scale left is selected. Visible only if Scaling left has been checked off (the size of the trend window within the graphic display is defined by the maximum length of the comments for all entered variables).

Tag allocation Enter the name of a tag. It will be possible to call up this tag directly in DigiVis 500 Operator Station through the Trend window. Enter the tag name directly or select it through the F2 key.

Value range

Min. Start of scale range in physical units.

Max. End of scale range, in physical units.

Color Specify trend color for the Trend window. Click on color field and color selection through the Color Selection parameter definition window (refer to Color Selection on page 286), select color and confirm with OK. Selected color is displayed in the color field.

Interpolation Specify trend depiction.

None ○ No interpolation is performed,

Linear ○ Trend is interpolated in a linear fashion,
Section 11  Graphic Display

Selection Area

- **Stairs**  • Trend is depicted in discrete steps.
- **Marker**  Specify depiction of individual measured values.
- **None**  • Individual measured values are not marked,
- **Point/Pixels**  • Individual measured values are marked with points,
- **Rectangle**  • Individual measured values are marked with rectangles.

<table>
<thead>
<tr>
<th>Interpolation</th>
<th>Marker</th>
<th>Point/Pixels</th>
<th>Rectangle</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>invisible</td>
<td>.</td>
<td></td>
</tr>
<tr>
<td>Linear</td>
<td>.</td>
<td>.</td>
<td></td>
</tr>
<tr>
<td>Steps</td>
<td>.</td>
<td>.</td>
<td></td>
</tr>
</tbody>
</table>

d0559uk.bmp

**Selection Area**

> **Animate > Selection area**

> A mouse click fixes the position of the top left-hand corner and, by pulling the rectangle, the size of the selection area can be specified. Another click of the mouse at this point concludes the procedure,
> > Enter data in the parameter mask,
> > Display the select field without frame.
A selection area enables tag faceplates to be called up in graphic displays. It is also possible to change over into another specific display (graphic, group display, trend) or to write a fixed or operated value to a process variable or to acknowledge messages. In case of selection the configured action will be carried out.

The field and the border of the selection area can be displayed visibly and colored or they can lie transparent underneath other graphic objects.

On selecting the select field in the graphic display, a frame appears. The select field can then be resized and moved.

For configuration, refer to Tab: Tooltip on page 323, Tab: Display on page 304, Tab: General on page 307

**Button, Button Field, Radio Button**

> Animate > **Button** (or **Button Field** or **Radio button**),
> Upper left corner of the button is positioned with a mouse click,
> Define button size by moving the mouse, terminate by clicking the mouse,
> Enter data in the parameter definition mask,
> Display the button with a frame.

These buttons can cause displays or faceplates to be called up, variables to be set to preset numeric values, messages to be acknowledged or states to be displayed.
All the buttons, button fields and radio button fields can be displayed in a variety of different formats (rectangle, rectangle with rounded corners, 3D-rectangle, ellipse).

When a button is configured, either text can be specified for the button or any static graphic object can be defined as the button symbol. For each separate button, the text or button symbol, as well as the text and button colors are specified in the button/radio button configuration. The size, orientation and font for the text can be set or changed separately from the definition of button parameters using the text attribute settings.

A **button press** under DigiVis 500 Operations does not require any additional confirmation, and can write a process variable or call up a faceplate or display. A button can be linked with any variable and displayed as either pushed or unpushed, as well as in different pairs of colors.

A **button field** consists of one or more buttons with an associated confirm button. When entering the parameters, the confirm button is always automatically displayed alongside. A button field can comprise up to 25 separate buttons. The buttons in a button field can be configured completely independently of one another. By pressing a button under DigiVis 500 Operations, a value can be entered or a faceplate or display called up. The action is not actually performed until the confirm button is pressed.

A **Radio button field** can comprise up to 25 buttons. All the keys in a **radio button field** are linked with the same process variable. A value for this variable can be preset for each key. When one of these keys is pressed under DigiVis 500 Operations, the value configured is written to the process variable. If the process variable is set to one of the configured values, this can be displayed on the corresponding key. With a radio button it is not possible to call up faceplates or graphics and there is no confirm button.

Changing the text attributes of a button, button field or radio button:

> Select **button** (or **button field** or **radio button**),
> **Change** > **Text attributes** or through **Toolbox** text,
> Enter or change text displays
> Accept with **OK**,
> Button text appears as it was entered.
Set Button Parameters

![Button Window](tu0550us.bmp)

**ToolTip**  
After selecting the **ToolTip** button the **Activate Tooltip Tab** appears. The only available check boxes for that button are **Configured action** and **Text**.

**Variable**  
The value of these variables will determine the text and color with which the button is displayed, as defined below.

**Value**  
Reference value for determining the display format:  
Variable <> Value or Variable = Value.

**Button type**  
Display format of the button in the graphic display.  
- As a rectangle.  
- As a 3D rectangle  
- As an ellipse.  
- As a rectangle with rounded corners.
**Variable <> Value**

When the variable shown has a value different from the reference value, the button will be displayed with the text or object, text color and button color specified here.

**Variable = Value**

When the variable shown is the same as the reference value, the button will be displayed with the text, text color and button color specified here. Entries are not accepted here until a variable name and its reference value have been specified. (Variable, Value).

**Text/Button object**

Determines whether button text or a graphic object is to be used for displaying the button, followed by:
- Specification of the text to be shown on the button, or
- The name of a static graphic object, either entered directly or selected after switching to the graphic display through the Display button.

**Color**

Colors are selected for the border, button background and (if applicable) for the text through the parameter definition mask Color Selection (refer to Color Selection on page 286).

**Show pushed**

- ☑ Button is shown as pushed.
- ☐ Button is shown as not pushed.

**Action**

Calls up the Action parameter definition mask, refer to Configuring an Action on page 308.

**Action needs confirmation**

If an action has been configured which requires a confirmation before it can be executed - checkbox Action needs confirmation selected when configuring this action - you can select a foreground and background color for this state (action has been triggered, but is not yet written) so that the button will clearly indicate that a confirmation is required. Refer to Color Selection on page 286.
Set Parameters for Button Field

Rows/Columns  Number of button rows and columns, max. 5 each.  The button display is modified accordingly.

OK caption / OK button object  
Text or graphic object for confirm button (pre-set to OK).

Button  Diagrammatic representation of the buttons, excluding the confirm button. A mouse click on a button opens the mask for specifying the button parameters.

Colors  Color definition is relevant to all button texts and the background of all buttons.

Unmarked/Marked  Respective color settings for button texts and buttons when the button is not selected or selected.
A mouse click on the upper color field selects the text color, and a click on the lower color field selects the button color, both selections being performed in the Color Selection parameter definition mask (refer to Color Selection on page 286).
Section 11  Graphic Display

Good day

Section 11  Graphic Display

Pushed  The button is shown as pushed.

Button type  Display format of the button in the graphic display.

Set Parameters for Radio Button Fields

Variable  The process variable associated with all the buttons in the radio button field. For details of select fields, refer to Configuring an Action on page 308.

Rows/Columns  Number of button rows and columns, max. 5 each.

Button  Diagrammatic representation of the buttons. A mouse click on a button opens the mask for specifying the button parameters. For details of select fields, refer to Set Parameters for Button Field on page 346.

Colors  Color definition is relevant to all button texts and the background of all buttons.

Variable <> Value / Variable = Value  Respective color settings for the buttons and button texts when the

2PAA104345R0201  347
value of the associated variable is different from or the same as the specified value.

A mouse-click on the upper color field selects border and text color, while a click on the lower color field selects the button background color, both through the Color Selection color selection parameter definition mask (refer to Color Selection on page 286).

**Pushed**

☑ The button is shown as pushed.
☐ Pushed, the button is shown as not pushed.

**Button type**

Display format of the button in the graphic display.

**Set Parameters for Individual Buttons Using the Button Parameter Definition Mask**

The procedure is basically the same as configuring an individual button (refer to Button, Button Field, Radio Button on page 342) but the following special considerations must also be taken into account:

**Variable**

Not used for buttons in a button field, but for radio buttons, the associated variable is shown here.

**Value**

For radio buttons, the reference value of the associated variable is shown here.

**Without function**

☑ The selected button is eliminated optically and functionally from the button field.
☐ The button is displayed with the selected color and with the text entered.

**Action**

Calls up the Action parameter definition mask. Refer to Configuring an Action on page 308.

**Variable = Value**

No function
Tab Control

> Animate > Tab Control
> A mouse click fixes the position of the top left-hand corner and, by pulling the
rectangle, the size of the Tab Control can be specified. Another click of the
mouse at this point concludes the procedure,
> Enter data in the parameter definition mask,
> Display the Tab Control with frame.

The Tab Control exists as a new dynamic object. Up to 8 tabs can be administered
in this element. To each tab a group of static and/or dynamic graphic objects can be
assigned.

By selection of one of these up to 8 tabs the assigned graphic object is put into the
display foreground in DigiVis 500 Operations.

Set Parameters for Tab Control
List of the Dynamic Objects in a Graphic Display

Section 11 Graphic Display

Tab for Tabs

Tab Number of possible tabs (1–8)

Display Specifies which tab is displayed first.

Heading Indicates the heading of the corresponding tab (can be selected freely).

Object name Indicates the name of the associated graphic object.

Display The button is used to select the graphic object or object group to be displayed on the marked tab. The object is selected and switching through “Return to object” to the field “Object name” its name is entered there.

General Tab

For General Tab, refer to Tab: General on page 307.

List of the Dynamic Objects in a Graphic Display

> Animate > Reedit... > Display of the object list

The tree structure of the object list is used for displaying all dynamic graphic objects in the current graphic display, and for selecting one of them. After an object has been selected, it can then be modified using the appropriate parameter definition dialog.

Reedit

A graphic object must be selected before its parameters can be changed. This can occur in two ways: select the object in the graphic display and double-click on it, or use the alternative through the Reedit... menu.

> Select animated graphic object > Animate > Reedit
> Animate > Reedit... > Display object list

All the dynamic graphic objects are displayed in the object list with their type and name. A dynamic object that has been previously selected is preselected in the list. After an object has been selected, clicking on OK or double-clicking on the list entry will call up the parameter definition mask for the selected object.
Reediting Allocated Static Objects

Static objects that have been allocated to a dynamic object are no longer directly available in the graphic display. This applies to objects that have been configured as foreground or background objects as well as to objects used in defining the dynamic object states (graphic symbol, Tab Control or fill levels). These objects which have already been assigned can be modified through the following procedure taking the graphic symbol as an example:

> Click on the graphic symbol and select the Display tab
> Position the cursor in the field containing the name of the object to be modified
> Switch to the graphic display using the **Display** button

The static object can now be modified using the usual functions.

The graphic editor is still in “Define parameters for a graphic symbol” mode. This mode can be clearly recognized in the menu: the menu item **Back** and most of the toolbar buttons are disabled. This mode must be exited using the menu command **Edit / Return to object**.

A corresponding procedure can be used to retrospectively modify foreground and background objects as well as polygon figures that have been assigned to a fill level.

An additional step is required in order to retrospectively modify a message type symbol: the message type symbol must be detached from the graphic symbol. To avoid losing the parameters of the graphic symbol in this process, a new static object is defined for the duration of the editing process.

> Click on the graphic symbol and select the **Display** tab
> Position the cursor in the field containing the name of the object to be modified
> Switch to the graphic display using the **Display** button
> Draw any static object
> Return to graphic symbol parameters through **Edit / Return to object**
> Exit parameter definition for graphic symbol with **OK**.

The message type symbol can now be modified with the usual functions.
After all the changes have been carried out:

> Select graphic symbol and invoke tab **Display**
> Position cursor in the filed with the name of the newly drawn object
> Switch to the graphic display using the **Display button**
> Select the changed message type symbol. (the newly drawn object will be deselected at this point)
> Return to parameter definition for graphic symbol through Edit > **Return to object** > Exit parameter definition for graphic symbol with **OK**.

The newly drawn object is now once more freely available, and can be deleted.

---

**Macro**

Graphic objects can be grouped together and stored as a macro. Macros are available anywhere in an entire project and can be used as many times as desired in graphic displays. Subsequent changes to a macro effect all displays in which the macro was used.

A macro consists of any combination of static and dynamic graphic objects. All attributes of the objects contained in the macro can be defined as macro parameters. Each time a macro is used, these attributes, which are part of the macro definition are stored; all the values specified as parameters can be individually adjusted at each instance of the macro’s use.

Macros can be saved in libraries and thus be made available for other projects. Similarly, macro libraries can be loaded, in order to make one or all of their macros available in the current project. Library files have the extension .BOL.

During the installation of DigiVis 500 Graphics Builder two macro libraries are copied into the directory `<drive>:\ABB Industrial IT\DigiVis 500\macros`. The graphics in the standard macro library `hb_sym01.bol` are described in **Appendix - Graphic Macro Library** on page 389. The library `ufp_sym1.bol` contains macros that simplify the creation of user-defined faceplates.
Library Functions

> Macro > Library functions...

**Library**
Path and filename of the most recently loaded macro library.

**Project**
In the left portion of the dialog, the graphic macros available in the project are listed. An icon with red background displayed on top of a macro name indicates a macro that was used in the project.

**Library**
In the right portion, the contents of the most recently loaded macro library are listed.
Load  A macro library can be loaded from a data carrier. After loading, the macros in the library are displayed in the right portion of the dialog.

Save  After entering a directory and filename all macros listed in the right portion of the dialog are saved on the data carrier. The dialog display is not changed.

>  All marked graphic macros of the project (left portion of the dialog) are copied to the library list (right portion).

>>  All graphic macros of the project (left portion of the dialog) are copied to the library list (right portion).

<  All marked graphic macros in the library list (right portion of the dialog) are copied for use in the project (left portion).

<<  All graphic macros in the library list (right portion of the dialog) are copied for use in the project (left portion).

DEL  All marked graphic macros are deleted from the list. In the project list, only macros can be deleted which have not been used in the project.

---

**Draw Macro**

>Macro > **Draw**

> A window opens under which macros are defined by name,

> Select macro > **OK**,

> Position the top left corner of the macro with a mouse-click.
Create Macro

> Select one or more graphic objects in the graphic display
> **Macro > Create macro...**

The list of all macros available in the project will be displayed. The name of the new macro must be entered in the input field above the list. After entry of a valid name, the dialog is concluded and the selected objects are displayed with a common frame. The individual objects are no longer available: they have been replaced by a macro reference.

Edit Macro

> **Macro > Edit...**

The list of all macros available in the project will be displayed. If a macro had been selected in the graphic display, then that macro will be shown selected in the list. After a macro is chosen from the list, the graphic editor is called up in macro edit mode (**macro editor**, **MED**).

In the graphic display the background color is changed and only the graphic objects belonging to the macro will be shown.

All graphic editor functions are available in the macro editor (MED). Any combination of static and dynamic graphic objects can be added to or deleted from the macro. Similarly, all attribute changes and animations possible with the graphic editor are also allowed.

Define Macro Parameters

The **parameters** of a macro are set with the macro editor (MED). All graphic attributes defined to be parameters can be adjusted individually in each instance of
the macro’s use. All values which are not defined to be parameters remain the same in all instances and not be varied.

All animation (display and bit variables) must be defined to be parameters.

> Macro > Parameter...

In the right portion of the dialog all attributes of all named objects are listed. Dynamic objects always have names, so their attributes always appear in the list. Static objects whose attributes are to made adjustable as macro parameters must be given names (Change > Define object name, refer to Object name define on page 377).

Graphic attributes are displayed with the name of the object and a system-assigned designation for the attribute: <Objectname>.<Attribute designation>.

In the left portion of the dialog, the macro parameters are listed. For each macro parameter, the object attributes which will take on that parameter value are shown.

**New Parameter**

A new entry in the left dialog field is created with a standard name. The standard name can be changed.
Delete Parameter

The macro parameter selected in the left dialog field is deleted. The attributes which were assigned to the deleted parameter are transferred to the right portion of the dialog.

<

A graphic attribute in the right portion of the dialog is assigned to the macro parameter which is selected in the left portion. The macro parameter data type is determined when it is assigned its first attribute. Any number of attributes of the same type can be assigned to a macro parameter. Attributes which have been assigned to a macro parameter no longer appear in the right portion of the dialog.

>

The assignment of an attribute to a macro parameter is undone. The attribute selected in the left portion of the dialog is disassociated from the macro parameter and reappears in the list of attributes in the right portion.

The following attribute designations are used in the system:

When used in dynamic objects, the designators are extended by sequence numbers (usually 1–8 or for objects in a trend window, 1–6) or, for button fields, by <column> and <line number>, refer to General Parameters for Dynamic Graphic Objects on page 298.

<table>
<thead>
<tr>
<th>Attribute designator</th>
<th>Object type</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>BG, FA, AD, SEL, SA, GS, BUT, BTF, TC</td>
<td>Action which can be triggered by this object in DigiVis 500 Operator Station</td>
</tr>
<tr>
<td>Bit variable_1..3</td>
<td>BG, FA, AD, SA, GS</td>
<td>Bit variables which control attribute changes in the object</td>
</tr>
<tr>
<td>Caption, Caption_1..2</td>
<td>TXT, BUT, BTF, BTR, CUO</td>
<td>Static text, button text or trend graph labeling</td>
</tr>
<tr>
<td>Faceplate_1..6</td>
<td>CUO</td>
<td>Tag faceplates assigned to the curves</td>
</tr>
<tr>
<td>Attribute designator</td>
<td>Object type</td>
<td>Meaning</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Windowcolor_1..3</td>
<td>CUO</td>
<td>Trend window colors: 1: Background color, 2: Grid and labeling color 3: Graph area background color</td>
</tr>
<tr>
<td>Fillcolor, Bordercolor</td>
<td>BG, FA, SA, GS, SEL, BUT, BTF, BTR</td>
<td>Border and fill color</td>
</tr>
<tr>
<td>Fillpattern</td>
<td>PIE, ELP, PLG, REC, BG, FA, SEL</td>
<td>Fillpattern</td>
</tr>
<tr>
<td>Trendcolor_1..6</td>
<td>CUO</td>
<td>Curve colors</td>
</tr>
<tr>
<td>Line_start</td>
<td>ARC, LIN, PLN</td>
<td>Starting end of line: round or with arrow</td>
</tr>
<tr>
<td>Linewidth</td>
<td>ARC, PIE, ELP, LIN, PLG, PLN, REC, BG, FA, SEL</td>
<td>Line width</td>
</tr>
<tr>
<td>Line_end</td>
<td>ARC, LIN, PLN</td>
<td>Ending end of line: round or with arrow</td>
</tr>
<tr>
<td>Line_color</td>
<td>ARC, PIE, ELP, LIN, PLG, PLN, REC, BG, FA, TC</td>
<td>Line color</td>
</tr>
<tr>
<td>Line_rounded</td>
<td>ARC, LIN, PLG, PLN, REC, BG, FA, SEL</td>
<td>Rounding of corners</td>
</tr>
<tr>
<td>Line_style</td>
<td>ARC, PIE, ELP, LIN, PLG, PLN, REC, BG, FA, SEL</td>
<td>Type of line: solid or dotted, ...</td>
</tr>
<tr>
<td>Max_Duration</td>
<td>CUO</td>
<td>Maximum trend collection period</td>
</tr>
<tr>
<td>Reference</td>
<td>BG, FA</td>
<td>Bar graph and fill area reference line</td>
</tr>
<tr>
<td>Text_direction</td>
<td>TXT, AD, BUT</td>
<td>Text direction: horizontal or vertical</td>
</tr>
</tbody>
</table>
## Define Macro Parameters

<table>
<thead>
<tr>
<th>Attribute designator</th>
<th>Object type</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character font</td>
<td>AD, BTF, BTR, BUT, TC</td>
<td>Character font of the text: Arial, Courier New, Lucida Console or MS Sans Serif</td>
</tr>
<tr>
<td>Character size</td>
<td>TXT, AD, BUT, TC</td>
<td>Text size: 8, 12, 20 or 26 point</td>
</tr>
<tr>
<td>Scale_start, Scale_end</td>
<td>BG, FA</td>
<td>Scale range for object or curve</td>
</tr>
<tr>
<td>Scale_start_1..6, Scale_end_1..6</td>
<td>CUO</td>
<td>Scale range for curves</td>
</tr>
<tr>
<td>Std_Duration</td>
<td>CUO</td>
<td>Trend display duration</td>
</tr>
<tr>
<td>Tab Control_1..8</td>
<td>TC</td>
<td>Tab Control</td>
</tr>
<tr>
<td>Text_alignment</td>
<td>TXT</td>
<td>Text alignment: top or bottom</td>
</tr>
<tr>
<td>Text_bold</td>
<td>TXT, AD, BUT</td>
<td>Bold text</td>
</tr>
<tr>
<td>Text_fixpoint</td>
<td>TXT, AD, BUT</td>
<td>Text justification: start, center, end</td>
</tr>
<tr>
<td>Text_italic</td>
<td>TXT, AD, BUT</td>
<td>Italic text</td>
</tr>
<tr>
<td>Text_underlined</td>
<td>TXT, AD, BUT</td>
<td>Underlined text</td>
</tr>
<tr>
<td>Textcolor, Background</td>
<td>TXT, AD, TC</td>
<td>Text color and background color</td>
</tr>
<tr>
<td>Tooltip</td>
<td>AD, BTF, BTR, BUT, CUO, FA, GS, SA, SEL, TC</td>
<td>Tooltip</td>
</tr>
<tr>
<td>Variable</td>
<td>BG, FA, AD, BUT, BTR</td>
<td>Display variable</td>
</tr>
<tr>
<td>Variable_1..6</td>
<td>CUO</td>
<td>Variables for trend monitoring</td>
</tr>
<tr>
<td>Background color, Foreground color</td>
<td>PIE, ELP, PLG, REC, BG, FA, SEL, TC</td>
<td>Fill pattern colors</td>
</tr>
<tr>
<td>Value</td>
<td>BUT, BTR</td>
<td>Button value, used for state display</td>
</tr>
</tbody>
</table>
Specifying Parameters for a Macro Instance

A macro is inserted into the graphic display with its default settings. All attributes which were defined in the MED to be parameters can be individually adjusted for each instance of the macro’s use. When a macro is selected in the graphic display, all the macro’s parameters and their current values are listed.

> Macro > Parameter...

The selected macro parameter can be specified for the present instance of the macro. Depending on the type of parameter, the appropriate mask is called up. Only those entries relevant to the specification of the macro parameter are available. All attributes which were assigned to this macro parameter in the MED will take on the new parameter value. The new value will be shown in the list.
Resolve Macro

With a macro selected in the graphic display > Macro > Resolve will disassociate the macro objects. All elements of the macro will be displayed with their own construction frames and can be changed individually.

Macro: Resolve all Layers

Resolve all layers upon selection of several objects in the graphic display and > Macro.

Whilst Resolve macro only applies to the previously selected macro, the Resolve on all layers menu item ungroups all selected objects like the graphic symbol or tab control, including all underlying grouped macros.
Editing and Changing Display Objects

Changing the Size of a Graphic Object

Changing the size without altering the height-to-width ratio

> Select > place cursor arrow on a corner handle > Press mouse button and drag > Frame gets larger or smaller > Release mouse button
> Graphic item/symbol is resized.

Changing height or width using the Mouse

> Select > place cursor arrow on an edge-center handle
> Press mouse button and drag,
> Frame gets larger or smaller
> Release mouse button,
> Graphic item/symbol is redisplayed.

Changing height or width using the keyboard

> Position the cursor above the object > Select the object using the space key > Position the cursor above the selection marker > Resize the object using the space key + arrow keys.

Each graphic object—be it a static, dynamic, combined object or a macro—is displayed with its attributes at its assigned position. When selected, a frame with marks (handles) at the corners and edge center points surrounds the graphic item. (Exceptions are horizontal or vertical lines, on which only the two end points are marked). A cursor click outside this rectangle deselects the graphic object, and a click within the rectangle selects it again. If one clicks one of the corner handles of the frame, the cursor arrow changes. With the mouse button depressed, the frame can then be enlarged or reduced while maintaining its height-to-width ratio. After releasing the button, the graphic object is displayed within the new frame. Clicking on an edge-center handle allows the height or width of the object to be changed independently.
Move a Graphic Object using the Mouse

> Select > Cursor arrow into the center > Press mouse button and drag.

After clicking on a graphic object, its frame is displayed. By positioning the cursor inside the frame and keeping the left-hand mouse button depressed, the cursor changes into a cross. While the mouse button is depressed, the rectangular outline of the graphic can be moved about the entire draw area. On releasing the mouse button, the item is redisplayed at this point.

Move a Graphic Object using the keyboard

> Position the cursor above the object > Select the object using the space key > Move the object using the space key + arrow keys.

When moving several graphic objects (refer to Selecting Multiple Graphic Objects on page 363), a common frame surrounds them all. They can then be moved in exactly the same manner as a single graphic object.

Selecting Multiple Graphic Objects

> **SHIFT** key and mouse click on each of the desired graphic objects.

or

> Position cursor outside the graphic objects to be selected,
> With the left mouse button depressed, drag a marking rectangle over the area.

or

> Call up shortcut menu with right mouse button
> **Select > All / all static objects / all dynamic objects**

In order to change attributes of several graphic objects together, it is possible to select various graphic objects at once. With the **SHIFT** key depressed, the desired graphic objects can be clicked. Several graphic objects can also be selected together with a marking rectangle. In doing so, only those graphic objects are included which lie completely within the marking.
Each graphic object is displayed with its frame. Alterations of the line and area attributes effect all selected objects.

If several graphic objects have been selected and if one then wants to select a single one of them, click on the free draw area with the left mouse button (all graphic objects will be deselected) and proceed as above.

Several objects can be selected and moved together. As a result, it is possible that individual objects are moved outside of the visible drawing area. If the selection is then canceled, these objects cannot be selected with the common procedures. The plausibility check generates a message, that the graphic contains objects outside the visible area.

Use the following procedure to delete these objects from the graphic display:

- Edit > Select all > all objects in the drawing are selected.
- Press SHIFT key and left mouse button to select all visible objects.
- Press DEL key or select Edit > Delete to delete all objects that are not visible in the display.

After all static objects have been selected the display background can be stored as a bitmap with Display > Export > As bitmap to clipboard (or CTRL + B).

In order to achieve the shortest possible display build-up times under DigiVis 500 Operator Station you are strongly advised to store and continue using the static part of the display as a bitmap after the editing is finished. In a new graphic display this bitmap is imported as a background, and the animation is performed in the foreground of this bitmap.
Edit

Under the menu **Edit** are listed the items which facilitate the creation and modification of displays.

**Return to Object**

> Edit > Return to object...

For some graphic objects (message type symbol, fill area, graphic symbol, self-animated object, button) there is the possibility of switching to the static graphic section from the parameter definition mask pressing the **Display** button during configuration. The **Return to object** menu item must be selected in order to return to the parameter definition mask.
Edit  

Section 11  Graphic Display

Undo

> Edit > Undo

This is a one-level function and undoes the last change made to the graphic object.

Repeat

> Edit > Repeat

The last action can be repeated, that is deleting the end point of a polyline or drawing graphic objects of the same type one after the other, without having to select the type again under Draw.

Select single object

If several graphic objects have been selected and one wants to select a single one of these, then click on the free draw area with the left mouse button (all graphic objects will be deselected) and proceed as above.

> Click graphic object.

Every graphic object selected is marked by a frame.

Select all

> Sweep over the whole drawing area with the left mouse button pressed.

All graphic objects in the drawing area are displayed with their frames. Alterations of the attributes impinge on all the graphic objects selected.

Select graphic objects in the background

If the CTRL key is held down and the mouse clicked, all covered graphic items/symbols can be selected in turn and then edited.
Group

> Select graphic objects > **Edit > Group**.

Several graphic objects can be grouped to form a new graphic object with a common frame. Alterations of size, attributes or movement now apply to the newly created graphic object.

No combined graphic objects can be used for the creation of macros. If necessary, a grouped graphic must be broken down into its elements (Menu item **Edit > Ungroup**).

Ungroup

> Select combined graphic object > **Edit > Ungroup**

Grouped graphic objects are dispersed into their individual graphic objects. In doing so, the common frame disappears and all the components of the combined graphic objects are displayed separately with their frames.

Graphic objects which are connected with one another through animation cannot be broken down into their elements with this menu item. To separate them, refer to **General Parameters for Dynamic Graphic Objects** on page 298.

Cut

> Select one or more graphic objects > **Edit > Cut**

The selected graphic objects are removed from the draw area and saved in a buffer memory (not the standard Windows clipboard).

With **Paste** the saved objects can be reinserted into the graphic one or more times.
Copy
> Select one or more graphic objects > **Edit > Copy**

The selected graphic objects are copied and saved in a buffer memory (not the standard Windows clipboard).

With Paste the saved objects can be inserted into the graphic one or more times. The copied object is copied to match the original and displayed as it was when selected. It can be moved to any position. Refer to Move a Graphic Object using the Mouse on page 363.

Paste
> **Edit > Paste**

The graphic objects which were saved in the buffer memory (not the standard Windows clipboard) through a Cut or Copy command can be inserted into the draw area.

Items are inserted at the location from which they were cut or copied.

Delete
> Select one or more graphic objects > **Edit > Delete**

The selected graphic objects are removed from the draw area.

Duplicate
> Select one or more graphic objects > **Edit > Duplicate**

The selected graphic objects are duplicated on the draw area and not saved in the buffer memory. The duplicate is displayed slightly offset from the original and is
selected. It can then immediately be positioned as required (refer to Move a Graphic Object using the Mouse on page 363).

**Rotate**

> Select one or more graphic objects > **Edit** > **Rotate**

Each of the selected graphic objects is rotated 90 degrees counterclockwise around the center point of its frame.

Texts are rotated around their fixed reference points.

**Mirror**

> Select one or more graphic objects > **Edit** > **Mirror** > **Horizontal** or **Vertical**

The selected graphic items are mirrored horizontally or vertically, as desired. The imaginary mirror axis passes through the center point of the surrounding frame.

Texts cannot be mirrored. If text exists in a grouped graphic object, its position is mirrored but not the text itself.

**Overlap**

Serves to determine which of superimposed graphic objects lies in the foreground or background.

It should be noted here that in a graphic display under DigiVis 500 Operations, all static items are located in the background behind any dynamic objects as a result of the cyclical redisplay of those dynamic objects. There is, however, one exception. Refer to **Animate, Dynamic Graphic Objects** on page 296.

**Foreground**

> Select graphic object > **Edit** > **Overlap** > **Foreground**

The selected graphic object is displayed on top of the other graphic objects. It may cover the other items partly or entirely.
Background

> Select graphic object > **Edit > Overlap > Background**

The selected graphic object is displayed underneath the other graphic items. It may be partly or completely covered.

**In front of symbol**

> Select graphic object > **Edit > Overlap > In front of symbol**,
> A small window with **OK** and **Cancel** buttons appears,
> Select the graphic object in front of which the object first selected is to be inserted,
> Accept with **OK** in the superimposed window.
> **Cancel** can be used to abort the process at any time.

In case of several overlapping graphic objects, the overlap sequence can be specified here.

**Behind symbol**

> Select graphic object > **Edit > Overlap > Behind symbol**,
> A small window with **OK** and **Cancel** buttons appears,
> Select the graphic object behind which the object first selected is to be inserted,
> Accept with **OK** in the superimposed window.
> **Cancel** can be used to abort the process at any time.

In case of several overlapping graphic objects, the overlap sequence can be specified here.

**Align**

> Select one or several graphic objects > **Edit > Align > Left/ Horiz. centered/ Right/ Top/ Vertically centered / Bottom/ Distr. horizontally/ Distr. vertically**

The selected graphic objects are aligned to the left, horizontally centered, to the right, towards the top, vertically centered or towards the bottom or distributed horizontally or vertically. Reference point is always the object selected last.
To graphic pool

> Edit > To graphic pool

The command is used to switch to the graphic pool. If graphic objects are selected, they are also added to the graphic pool, being inserted at the same location as in the graphic display.

In this process, some graphic objects may be covered up and must be moved. Refer to Move a Graphic Object using the Mouse on page 363.

To display

> Edit > To display

Switch to the graphic display. If graphic objects are selected, they are accepted into the graphic display and inserted at the same location as in the graphic pool.

In this process, some graphic objects may be covered up and thus need to be moved. Refer to Move a Graphic Object using the Mouse on page 363.

Switch contents display/pool

> Edit > Switch contents display/pool

The entire contents—including background color—of the graphic display and the graphic pool are exchanged.

Insert pool in display

> Edit > Insert pool in display

The complete display contents of the graphic pool are accepted into the graphic display. The background color of the graphic display is retained.

In certain cases, graphic objects may be covered up in this process and thus need to be moved. Refer to Move a Graphic Object using the Mouse on page 363.
Change Attributes

The various line, area and text attributes, as well as the text content of the selected graphic objects can be altered. If similar graphic objects or grouped graphic objects comprised of several graphic objects of the same type have been selected, then all attributes are changed together. However a general alteration of attributes, which will effect subsequent graphic objects, must be made through the Toolbox.

Several objects can be selected and moved together. As a result, it is possible that individual objects are moved outside of the visible drawing area. If afterwards the selection is canceled, these objects cannot be selected any more with the common procedures. The plausibility check generates a message, that the graphic contains objects outside the visible area.

Use the following procedure to delete these objects from the graphic display:

> **Edit** > **Select all** > All objects in the drawing area are selected.
> Deselect all visible objects pressing the **SHIFT** key and the left mouse button.
> **Edit** > **Delete** or press the **DEL** key to delete all objects not visible in the graphic display.
Line attributes

> Change > Line attributes

The graphic object line with the attribute invisible is not particularly useful. It can be obtained, if required, through > Edit > Select all.

The line attributes of the selected graphic objects are altered in a dialog window.

![Line Attributes dialog window](tu0751us.bmp)

**Color**

The attribute **Line color** is available both for all static graphic objects, with the exception of text and bitmaps, and for the dynamic objects bargraph, selection field and fill area. You can choose any of the 237 colors or *invisible*. Refer to **Color Selection** on page 286.

**Width**

The attribute **line width** applies to all static graphic objects with the exception of text and bitmaps, and also to the dynamic objects bargraph, selection field and fill area. 6 width sizes can be selected.

Dimensions like 1P, 5P and so on, are abstract and depend on the screen resolution; they do not refer to the pixel size.

**Style**

The attribute **line style** applies to all static graphic objects with the exception of text and bitmaps, and also to the dynamic objects bargraph, selection field and fill area. *Continuous, dashed, dotted, or dash-dotted* can be selected.
**Line start / Line end**

The attribute **line start/end** only applies to the static graphic objects line, polyline and arc.
An arrow can be selected at the start and/or end.
The size of the arrow depends on the line width.

**Rounded Corners**

The attribute **rounded corners** applies to the static graphic objects rectangle, polyline and polygon, and to the dynamic objects bar graph, selection field and fill area.
*None, small, medium or large* can be selected.

**Area Attributes**

> Change > Area attributes

The area attributes apply to the static graphic objects rectangle, polygon, ellipse and circle segment and to the background of the dynamic graphic objects bar graph and fill area. The attributes of an area are changed in a dialog window. In the bottom left-hand corner of that window a preview of the selected area attributes is shown.

![Area Attributes dialog window](tu0752us.bmp)

**Color** Any of 237 colors each can be selected for **foreground** and **background**.
The color settings have no effect with the pattern setting **invisible**, and the background color chosen has no effect with a filled pattern.
Refer to **Color Selection** on page 286.

**Pattern** Any of 15 patterns or **invisible** can be selected.
For the pattern ‘black bars’, the fill area is displayed in the fill color selected for the foreground.
For the pattern **invisible**, the underlying graphic items/symbols are visible.

**Points**

The construction points of the graphic objects polyline and polygon can be moved or deleted.

**Delete**

> Select graphic object **polyline** or **polygon**, > **Change** > **Points** > **Delete** >

Click the point to be deleted The graphic object remains selected and is redisplayed in the altered form.

**Move**

> Select graphic object **polyline** or **polygon**, > **Change** > **Points** > **Move** > Click the point to be moved and move it to the desired position with left mouse button pressed. (The frame disappears). > Releasing the left mouse button completes the action. The graphic object remains selected and is displayed with the shifted points.

**Text edit**

> **Change** > **Text edit**

Selected texts can be altered. An input window with the existing text appears in which text can be added or deleted. The text attributes are not effected.

If a combined graphic object contains several texts, the texts are presented for modification one after the other.

**Text attributes**

> **Change** > **Text attributes**
Text attributes apply to the static graphic object text and to the dynamic objects alphanumeric display, button, button field and radio button field. The attributes of selected texts can be changed in a dialog window.

**Character font**
- Arial, Courier New, Lucida Console, or MS Sans Serif can be selected

**Color**
- Any of 237 colors can be selected for foreground and background. In addition, *invisibility* may be selected as background.

**Size**
- Choice of text size in pixels.
- Display created with the Graphic Editor are independent from the screen resolution. Therefore the font size is not identical with size used in other Windows applications.
- The font size can be increased/decreased by changing a text object with the mouse. Likewise the font size of texts configured within a graphic symbol, a macro, or within foreground or background objects in dynamic graphic objects is automatically adjusted when the encompassing objects are changed in size.

**Alignment**
- There is a choice between horizontal and vertical text.

**Fix point**
- Point used for positioning a text. It is situated on the frame at the site specified horizontally at start, middle or end and vertically by top or bottom. The Rotate and Horizontal/vertical Alignment
functions turn the text around this point.
The selections Top and Bottom are only available for the object Text.

Start  ○  left frame edge
Middle ○  horizontal center of frame
End ○  right frame edge
Top ○  upper frame edge
Bottom ○  lower frame edge.

Character attribute
Additional choice for text output between Bold, Italic and Underlined.

Object name define

> Select individual or combined graphic object, > Change > Object name define...

A name must be unique in a graphic display.

Graphic objects can be provided with names (max. 12 characters). Using these names for the dynamic or graphic symbols they can be moved, shifted or exchanged. If a name has already been assigned to the selected graphic object, that name will be displayed and can be changed.

Background color

For information on background color, refer to Background Color on page 285.
Display Options for Graphics in the Draw Area

Under the View menu are the various options relating to viewing graphics on the screen.

View

> View > View display
> Displays the graphic with no grid, no toolbox and no frame. Most of the menu choices are disabled.
> To return for further editing,
> View > View display,
> Display the graphic and enable the menus prior to quitting; or click mouse within the draw area.

View allows the graphic currently being created to be viewed at zoom level 1 (full display) and without the distraction of the editing tools (snap, frame, toolbox). In this state most of the menu functions are disabled. Selection from menu or pressing the Spacebar once returns to a state in which editing can be performed.

Simulation

> View > Simulation
> Switch simulation on or off and select the simulation speed.
> All self-animated graphic objects are shown in the graphic display with the chosen simulation attributes.

When in View the simulation attributes come into play for all self-animated objects; when the graphic editor is in View the simulation attributes can also be modified.
Section 11 Graphic Display

Redraw

> View > Redraw
> Graphic is redisplayed on the screen with no change to the zoom level.

The graphic is reconstructed. This is necessary, if the current display of the graphic on the screen does not correspond to the real graphic (parts of the frame may, for example, have been left behind).

Zoom

> View > Zoom
> Select zoom level 1 to 4 or Overview
> Display the graphic with a dashed rectangle
> Use the mouse to move the rectangle over the desired region of the graphic
> Click mouse, and that region will be displayed at the selected zoom level

A graphic display is usually displayed with Zoom switched off (Zoom 1-fold) as a whole graphic in the draw area. For easier editing it is possible to display a section of the graphic with 2-, 3- or 4-fold enlargement. The selected zoom level is indicated in the toolbox under Display. After selection of the zoom level the whole graphic display is shown, and a dashed rectangle superimposed for selecting the desired visible region.

Through View > Visible region or a right mouse-click it is possible to display a different region of the screen.

The Overview function shows an area corresponding to 9 x the drawing size. The actual draw area is shown in the center, marked with a border. This function enables objects located completely or partially outside the applicable draw area to be displayed and identified.

Visible region

> View > Select visible region
or click on the right mouse button > Graphic is displayed with a dashed rectangle,
> Use mouse to move rectangle and position it over the desired region,
> Click mouse to display this region with the selected zoom level.
In order to select a display region (for zoom level > 1), Select visible region makes a rectangle appear in the draw field. This rectangle can be moved around the draw area. Following a mouse click or after pressing the Spacebar, the area located underneath it will be displayed enlarged by the selected zoom level.

General Handling Functions

All functions necessary for the general handling of graphics are located under the Display menu.

Save

> Display > Save...

Save graphics is either carried out explicitly with Save or at a prompt when quitting the graphic display. During the creation of a graphic display it is advisable to occasionally save in order to keep data loss as low as possible in the event of any unexpected problems with the PC. The buffer display is always saved automatically as well.

Plausibility check

> Display > Check

The entire graphic display with its static and dynamic graphic items, macros and parameter inputs undergoes a plausibility check for errors, missing inputs or contradictions. Any errors are listed in a window and must be remedied afterwards.
A listed error message from the plausibility check can be selected with a double-click on the message with the left mouse button or by pressing the relevant screen button. Either of these actions has the effect of selecting the appropriate graphic object for editing.

**Export to a file**

> Display > Export > To file...,
> Specify file type: Industrial IT metafile or bitmap file
> Enter path and file name > OK.

Individual graphic displays can be exchanged between different projects through files. A file is created with Export. After invoking Export a window is opened in which the filename and path should be entered. As export data type you can choose between the Industrial IT file format with the extension DMF or a bitmap file with the extension BMP.

**Export to clipboard as a bitmap**

> Display > Export > As bitmap to clipboard

The graphic display is saved on the Windows clipboard as a bitmap, and is thus available for further processing by other Windows applications. If graphic objects are selected, these are saved as a bitmap; if no object is selected the complete graphic display is saved.

**Import**

> Display > Import
> Enter path and filename with extension, .DMF or .DXF
> OK, graphic display is loaded.

To import an Industrial IT graphic metafile (extension .DMF) created under Export or a file created in AutoCAD (extension .DXF) into a project, Import must be selected. After selection, a window is opened, where the path must be entered and
the filename entered or selected. The corresponding graphic display is loaded and shown.

An import file can be imported only into a blank graphic display.

**Instructions for loading AutoCAD files**

The graphic files created with AutoCAD exist in the Data Exchange Format (.DXF) and will be converted automatically into the Industrial IT Metafile Format (.DMF) during the loading process.

To be convertible, the AutoCAD version must be at least Release 10 or 11.

The following items from the full range supported by the AutoCAD language can be converted:

Shapes, polynets defined with the polyline item, B-Splines and 3D-Polylines, 3D-Face and viewport items are not convertible.

<table>
<thead>
<tr>
<th>Line</th>
<th>Period</th>
<th>Circle</th>
<th>Arc</th>
<th>String</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solid</td>
<td>Text</td>
<td>Polyline</td>
<td>Block</td>
<td>Macros</td>
</tr>
</tbody>
</table>

The DXF script size (font size) is converted according to the DMF coordinate sizes. The resultant font size is compared with the displayable script sizes defined in DigiVis 500 Graphics Builder and assigned to the size most closely matching the size to be converted. The DMF text attribute “RefPoint, Start” is assigned to the DXF text attributes “Aligned” and “Adapt”.

Only text with rotation angles of 0, 90, 180 and 270 degrees can be converted properly; the closest angle is assigned in all other cases.

All AutoCAD elements are converted irrespective of their assigned layer. Individual layers cannot be blanked out.

Blocks that are rotated or reflected are not converted properly.

Instance Objects (SECTION ENTITIES) of any type showing negative coordinates, are not converted. An exception here is the element objects of a block.
User Coordinate Systems (UCS), external references (XREF) and nested blocks (Insert instruction in block) are not supported.

During conversion, a log file with the file name DXF2DMF.LOG is created or updated. Non-convertible elements, non-supported objects and conversion errors are logged in this file. The path name of the DXF source and the line number within the DXF file are recorded, followed by an error description text.

**Color Conversion of AutoCAD Files**

In order to map AutoCad colors to DigiVis 500 colors a color conversion table—which can, if necessary, be changed—is entered in the Windows XP/Windows 7 registry editor under the [ACADCOLORS] entry.

If no such entry exists, a standard conversion table is used which assigns only the AutoCAD color numbers 1-8 to the corresponding DMF color numbers. In this case, the DMF color black is assigned to the AutoCAD colors number 9 to 255.

Whether the [ACADCOLORS] entry is used, depends on whether the color setting in the main menu of DigiVis 500 Graphics Builder **Options / Color table / is set to** **Compatible** (to Version 2) or **Standard** (new color table for Version 3.3).

The conversion tables consist of two components. The first entry in **Table Entries** denotes the number of color assignment entries to follow in the conversion table. The color assignment entries have the following format:

```
colxx=lacadcolor,hacadcolor,dfmcolor
```

where:

- **xx** Index of the entry in the color assignment table; must be smaller than the **TableEntries** entry.
- **lacadcolor** Lower AutoCAD color number of the range to which the DMF color number is assigned. The lower limit is included in the range.
- **hacadcolor** Upper AutoCAD color number of the range to which the DMF color number is assigned. The upper limit is included in the range.
- **dfmcolor** Assigned DMF color number.

The following must be noted when changing the color assignment entries:

- The index indicated by **xx** must be smaller than the value specified in the **TableEntries** entry. A color assignment table is always generated with **TableEntries**
entries. **Lacadcolor** must be smaller or equal to **hacadcolor**, and they must be in the range between 0 and 255. Overlapping ranges should be avoided. Refer to **Appendix - Color Tables** on page 384.

**Exit the graphic editor**

> Display > Exit...
> Exit the graphic editor and call up the project tree.

or

> Back! > Exit the graphic editor and return to the previous menu.

On quitting a graphic the following query appears: “Save graphic display?”

<table>
<thead>
<tr>
<th>Yes</th>
<th>Graphic is saved.</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Graphic is not saved.</td>
</tr>
<tr>
<td>Return</td>
<td>Remain in the graphic.</td>
</tr>
</tbody>
</table>

**Copy, Rename and Delete Graphic Displays**

Naming, renaming and copying a free graphic must be carried out in the project tree.

**Appendix - Color Tables**

The following tables list the colors available for graphic displays.

The color tables have three entries for each color:

- Sequence number = display rank in the graphic editor,
- Internal color number, used, for example, when converting AutoCAD files into files for the graphic editor,
- Designator (name) used for the color in the graphic editor.
Color table standard.

<table>
<thead>
<tr>
<th>Static colors</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>White</td>
<td>21</td>
</tr>
<tr>
<td>2</td>
<td>12</td>
<td>Grey93</td>
<td>22</td>
</tr>
<tr>
<td>3</td>
<td>13</td>
<td>Grey80</td>
<td>23</td>
</tr>
<tr>
<td>4</td>
<td>14</td>
<td>Grey68</td>
<td>24</td>
</tr>
<tr>
<td>5</td>
<td>16</td>
<td>Grey58</td>
<td>25</td>
</tr>
<tr>
<td>6</td>
<td>15</td>
<td>Grey48</td>
<td>26</td>
</tr>
<tr>
<td>7</td>
<td>17</td>
<td>Grey35</td>
<td>27</td>
</tr>
<tr>
<td>8</td>
<td>7</td>
<td>Black</td>
<td>28</td>
</tr>
<tr>
<td>9</td>
<td>8</td>
<td>Lightblue</td>
<td>29</td>
</tr>
<tr>
<td>10</td>
<td>9</td>
<td>MediumBlue</td>
<td>30</td>
</tr>
<tr>
<td>11</td>
<td>10</td>
<td>Blue</td>
<td>31</td>
</tr>
<tr>
<td>12</td>
<td>11</td>
<td>DarkBlue</td>
<td>32</td>
</tr>
<tr>
<td>13</td>
<td>18</td>
<td>LightMagenta</td>
<td>33</td>
</tr>
<tr>
<td>14</td>
<td>19</td>
<td>MediumMagenta</td>
<td>34</td>
</tr>
<tr>
<td>15</td>
<td>20</td>
<td>Magenta</td>
<td>35</td>
</tr>
<tr>
<td>16</td>
<td>21</td>
<td>DarkMagenta</td>
<td>36</td>
</tr>
<tr>
<td>17</td>
<td>4</td>
<td>LightGreen</td>
<td>37</td>
</tr>
<tr>
<td>18</td>
<td>5</td>
<td>MediumGreen</td>
<td>38</td>
</tr>
<tr>
<td>19</td>
<td>72</td>
<td>Green</td>
<td>39</td>
</tr>
<tr>
<td>20</td>
<td>6</td>
<td>DarkGreen</td>
<td>40</td>
</tr>
</tbody>
</table>
### Message colors

<table>
<thead>
<tr>
<th>Message colors</th>
<th>Signal colors</th>
</tr>
</thead>
<tbody>
<tr>
<td>41 36 RGB1(PrioS1-3)</td>
<td>49 64 SigBlue</td>
</tr>
<tr>
<td>42 32 RGB2(Prio1)</td>
<td>50 65 SigCyan</td>
</tr>
<tr>
<td>43 33 RGB3(Prio2)</td>
<td>51 67 SigRed</td>
</tr>
<tr>
<td>44 34 RGB4(Prio3/4)</td>
<td>52 68 SigGreen</td>
</tr>
<tr>
<td>45 35 RGB5</td>
<td>53 69 SigDarkGreen</td>
</tr>
<tr>
<td>46 37 RGB6</td>
<td>54 70 SigYellow</td>
</tr>
<tr>
<td>47 38 RGB7</td>
<td>55 79 SigOrange</td>
</tr>
<tr>
<td>48 39 RGB8</td>
<td>56 190 SigMagenta</td>
</tr>
<tr>
<td>57 66 SigBrown</td>
<td>58 67</td>
</tr>
</tbody>
</table>

### Media colors

<table>
<thead>
<tr>
<th>Media colors</th>
<th>Free colors</th>
</tr>
</thead>
<tbody>
<tr>
<td>58 44 Flash1(PrioS1-3)</td>
<td>86..104 144..162 Grey1..Grey19</td>
</tr>
<tr>
<td>59 40 Flash2(Prio1)</td>
<td>105..123 163..181 Blue1..Blue19</td>
</tr>
<tr>
<td>60 41 Flash3(Prio2)</td>
<td>124..139 48..63 Cyan1..Cyan16</td>
</tr>
<tr>
<td>61 235 RGB3(Prio2alt.)</td>
<td>140..142 232..234 Cyan17..Cyan19</td>
</tr>
<tr>
<td>62 42 Flash4(Prio3/4)</td>
<td>143..161 100..118 Magenta1..Magenta19</td>
</tr>
<tr>
<td>63 236 RGB4(Prio3alt.)</td>
<td>162..180 81..99 Green1..Green19</td>
</tr>
<tr>
<td>64 43 Flash5</td>
<td>181 119 Yellow1</td>
</tr>
<tr>
<td>65..67 45..47 Flash6..Flash8</td>
<td>182..196 129..143 Yellow2..Yellow16</td>
</tr>
<tr>
<td>68..76 120..128 Flash9..Flash17</td>
<td>197..199 191..193 Yellow17..Yellow19</td>
</tr>
<tr>
<td>77..84 182..189 Flash18..Flash25</td>
<td>200..218 213..231 Brown1..Brown19</td>
</tr>
<tr>
<td>85 71 Flash26</td>
<td>219..237 194..212 Red1..Red19</td>
</tr>
<tr>
<td>238</td>
<td>Bluish grey: Faceplate</td>
</tr>
</tbody>
</table>
### Media colors

<table>
<thead>
<tr>
<th></th>
<th><strong>Free colors</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>239 Bluish grey: Operation</td>
</tr>
<tr>
<td></td>
<td>240 Bluish grey: Animate</td>
</tr>
<tr>
<td></td>
<td>241 Button color</td>
</tr>
</tbody>
</table>

**Color codes and descriptions; Color table compatible.**

### Message colors

<table>
<thead>
<tr>
<th></th>
<th><strong>Signal colors</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>33 Prio1_Freq_1</td>
<td>65 SigBlue</td>
</tr>
<tr>
<td>34 Prio2_Freq_1</td>
<td>66 SigCyan</td>
</tr>
<tr>
<td>35 Prio3_Freq_1</td>
<td>67 SigBrown</td>
</tr>
<tr>
<td>36 Prio4_Freq_1</td>
<td>68 SigRed</td>
</tr>
<tr>
<td>37 Prio5_Freq_1</td>
<td>69 SigGreen</td>
</tr>
<tr>
<td>38 Prio6_Freq_1</td>
<td>70 SigDarkGreen</td>
</tr>
<tr>
<td>39 Prio7_Freq_1</td>
<td>71 SigYellow</td>
</tr>
<tr>
<td>40 Prio8_Freq_1</td>
<td>72 SigYellow_4Hz</td>
</tr>
<tr>
<td>41..48 Prio1..Prio8_Freq_2</td>
<td><strong>Free colors</strong></td>
</tr>
<tr>
<td>49..56 Prio1..Prio8_Freq_3</td>
<td>145...193 Free_1...Free_49</td>
</tr>
<tr>
<td>57..64 Prio1..Prio8_Freq_4</td>
<td></td>
</tr>
</tbody>
</table>

### Static colors

<table>
<thead>
<tr>
<th></th>
<th><strong>Free colors</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1 White</td>
<td>9 Lightblue 17 Grey58 25 MistyRose3</td>
</tr>
<tr>
<td>2 Lemon Chiffon1</td>
<td>10 Medium-Blue 18 Grey35 26 LightPurple</td>
</tr>
<tr>
<td>3 Lemon Chiffon2</td>
<td>11 Blue 19 LightMagenta 27 Purple</td>
</tr>
</tbody>
</table>
## Static colors

<table>
<thead>
<tr>
<th></th>
<th>Color</th>
<th></th>
<th>Color</th>
<th></th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Lemon Chiffon3</td>
<td>12</td>
<td>DarkBlue</td>
<td>20</td>
<td>MediumMagenta</td>
</tr>
<tr>
<td>5</td>
<td>LightGreen</td>
<td>13</td>
<td>Grey93</td>
<td>21</td>
<td>Magenta</td>
</tr>
<tr>
<td>6</td>
<td>Medium Green</td>
<td>14</td>
<td>Grey80</td>
<td>22</td>
<td>DarkMagenta</td>
</tr>
<tr>
<td>7</td>
<td>DarkGreen</td>
<td>15</td>
<td>Grey68</td>
<td>23</td>
<td>MistyRose1</td>
</tr>
<tr>
<td>8</td>
<td>Black</td>
<td>16</td>
<td>Grey48</td>
<td>24</td>
<td>MistyRose2</td>
</tr>
</tbody>
</table>

## Media colors

<table>
<thead>
<tr>
<th></th>
<th>Color</th>
<th></th>
<th>Color</th>
<th></th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>73</td>
<td>Med.col 1_0 (YellowGreen)</td>
<td>75</td>
<td>Med.col 3_0 (SilverGrey)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74</td>
<td>Med.col 2_0 (FieryRed)</td>
<td>76</td>
<td>Med.col 4_0 (Orange cadmium)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>75</td>
<td>Med.col 3_0 (SilverGrey)</td>
<td>77</td>
<td>Med.col 5_0 (Pastel orange)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>76</td>
<td>Med.col 4_0 (Orange cadmium)</td>
<td>78</td>
<td>Med.col 6_0 (Red violet)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>77</td>
<td>Med.col 5_0 (Pastel orange)</td>
<td>79</td>
<td>Med.col 7_0 (Ochre brown)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>78</td>
<td>Med.col 6_0 (Red violet)</td>
<td>80</td>
<td>Med.col 8_0 (Sky blue)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>79</td>
<td>Med.col 7_0 (Ochre brown)</td>
<td>81</td>
<td>Med.col 9_0 (Deep black)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>80</td>
<td>Med.col 8_0 (Sky blue)</td>
<td>82...96</td>
<td>Med.col 8_0 (Sky Blue)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>73</td>
<td>Med.col 1_0 (YellowGreen)</td>
<td>97...120</td>
<td>Med.col 1_2...23_2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>74</td>
<td>Med.col 2_0 (FieryRed)</td>
<td>121..144</td>
<td>Med.col 1_3...23_4</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Appendix - Graphic Macro Library

### Tanks 1

<table>
<thead>
<tr>
<th>tank01</th>
<th>tank02</th>
<th>tank03</th>
<th>tank04</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="d3003uk.bmp" alt="tank01" /></td>
<td><img src="d3003uk.bmp" alt="tank02" /></td>
<td><img src="d3003uk.bmp" alt="tank03" /></td>
<td><img src="d3003uk.bmp" alt="tank04" /></td>
</tr>
</tbody>
</table>

### Tanks 2

<table>
<thead>
<tr>
<th>tank11</th>
<th>tank12</th>
<th>tank13</th>
<th>tank14</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="d3004uk.bmp" alt="tank11" /></td>
<td><img src="d3004uk.bmp" alt="tank12" /></td>
<td><img src="d3004uk.bmp" alt="tank13" /></td>
<td><img src="d3004uk.bmp" alt="tank14" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>tank15</th>
<th>tank16</th>
<th>tank17</th>
<th>tank18</th>
<th>tank19</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="d3004uk.bmp" alt="tank15" /></td>
<td><img src="d3004uk.bmp" alt="tank16" /></td>
<td><img src="d3004uk.bmp" alt="tank17" /></td>
<td><img src="d3004uk.bmp" alt="tank18" /></td>
<td><img src="d3004uk.bmp" alt="tank19" /></td>
</tr>
</tbody>
</table>
Section 11 Graphic Display

Appendix - Graphic Macro Library

Heat exchanger

heated01
heated02
heated03
heated04
heated05
heated06
heated07
heated08
heated09
heated10
heated11
heated12
heated13
heated14
heated15
heated16

di3007uk.bmp

Heat generators / furnaces

heatedg01
heatedg02
heatedg03
heatedg04
heatedg05

di3008uk.bmp
Section 11  Graphic Display

Appendix - Graphic Macro Library

Processing and modulating machines

<table>
<thead>
<tr>
<th>process01</th>
<th>process02</th>
<th>process03</th>
<th>process04</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>process05</th>
<th>process06</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

d3019uk.bmp

Pumps

<table>
<thead>
<tr>
<th>pump01</th>
<th>pump02</th>
<th>pump03</th>
<th>pump04</th>
<th>pump05</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>pump08</th>
<th>pump09</th>
<th>pump06</th>
<th>pump07</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

d3020uk.bmp
### Dosing Systems

- **dosing01**
- **dosing02**
- **dosing03**

```
d3023uk.bmp
```

### Drive Units/Machines

- **drive01**
- **drive02**
- **drive03**
- **drive04**
- **drive05**

```
d3024uk.bmp
```
A file containing the complete set of graphic objects can be found in the DigiVis 500 Software CD at the location \LANG\US\BONUS\3dlib.
Section 12 Logs

General Description of Logs

Logs are used for displaying and permanently logging information and messages from the process and from the DigiVis 500 system. Logs are output on a printer, screen or storage device (through data transfer). A distinction is made between two different types of log – event logs and state logs.

Event Logs

Event logs are used for logging events such as messages, faults, switching activities and operator interventions (incl. user names, if Security Lock installed). Logging is effected spontaneously when an event occurs.

The signal sequence log is used for acquisition of events and is therefore classified with the event logs. A further distinction is made between signal sequence log 1 and signal sequence log N. Data of signal sequence log 1 are output continuously on a printer. By contrast, data of the signal sequence log N are output only on completion of logging or per manual intervention.

Various different types of messages can be logged: process messages and system messages are generally used to indicate events and faults, while a sequence of event log can be used to log switching events in the field with a resolution of 2 ms.

State Logs

State logs are used for cyclic logging of process states. These include the cyclic acquisition of the state of a tag or the logging of sequences within the process.

Logs in an Operator Station

A maximum of four operation logs, one signal sequence log 1 and three signal sequence logs N can be set up for each operator station. (The display and operation of
the logs on an operator station is described in the manual *DigiVis Operation and Observation*).

The various logs are all programs in the operator station resource of the project tree. Logs can be set up, deleted, moved and copied in the project tree.

### Signal Sequence Log

#### Construct Signal Sequence Log

Signal sequence logs are constructed and edited in the project tree under an operator station resource or in the Common display pool (P-CD), for detailed description refer to *Section 2, Project Tree*.

- Select Operator Station resource or P-CD in the project tree
- Edit > Insert next level > Signal sequence log

If a signal sequence log is configured in the Common display pool (P-CD), then this signal sequence log is available in all operator stations.

#### Signal Sequence Log Configuration

- Double-click the name of the signal sequence log in the project tree

The definition of parameters for signal sequence log 1 or signal sequence log N is virtually identical; they are therefore described together. Where differences do arise, these are shown separately.

The configuration of the signal sequence logs 1 and N consists of a parameter definition dialog with 4 tabs.
**General Data Tab - Signal Sequence Log 1 and N**

**Parameters: Signal sequence log SSL**

**General data**

**Name**  
The name of the signal sequence log. The name has been fixed in the project tree and cannot be changed here.

**Short text**  
A Short text can be assigned to the signal sequence log. Up to 12 characters can be entered.

**Long text**  
A Long text can be assigned to the signal sequence log. Up to 30 characters can be entered.  
Short and long text are output with the documentation of the project. In addition these texts can be configured for the header and footer of the printed log, refer to Header and Footer Lines in Logs on page 421.

**Start/Stop**

**Automatic**  
Logging is automatically started by starting DigiVis 500 Operations.
The operator can start and stop logging on the operator station. This refers only to the log previously selected on the operator station.

the number of log files are fixed, which are created on DigiVis 500 Operations PC. The value must be between 1 and 400.

the name of the log file, which is filed on DigiVis 500 Operations PC hard disk. The preset name can be accepted, or a new one given.

The recording period per log file can be defined with this field. Entries are made in the IEC 1131-3 format. The value must be between 0 and 2147483 s.

For example, T#2147483s or T#24d20h31m23s

The value must be between 3 and 32767. Default 1000 events.

The size which log files can attain is displayed in this field. This amount of storage should be available on the DigiVis 500 PC.
The printing of logs can be activated manually by the operator at the operator station.

**Print to Channel 1 / 2**

Two printer channels are available for log output on the printer. The printer channel is selected by activating the corresponding option button.

**Delete log files**

**Automatic**

When the automatic delete option is selected and the configured number of files is exceeded, the oldest log file is overwritten by the current file.

If the automatic delete option is not selected then logging is suspended as soon as the max. number of files has been reached.
Manual
The operator can select and delete individual log files.

Record event from
Local resource VIS
Events on the operator station are logged. These include events such as switching operations and operator actions.

Stat. filter
Activates logging of events such as messages and faults on the corresponding resource.

Connection
Indicator showing that a connection is configured to the corresponding operator station.

Filter
Either all configured stations or only connected stations are included in the events selection list.

Areas
Messages from the selected areas are set in the signal sequence log. For easier pre-configuration, the buttons “All” and “No” can be used to activate or deactivate all plant areas.

Kind of messages
Configures which messages are to be recorded in the log: process messages, system messages and sequence of events.

Enhancements to Parameter Definition Mask 2 in Signal Sequence Log N
Unlike signal sequence log 1, data of signal sequence log N are not printed continuously. Hence the parameter definition mask 2 differs from signal sequence log 1.

Printing
Automatic
Printing takes place automatically after completing the logging.
Delete log files
Printed files only

Only printed log files can be deleted manually.

Format Tab – Signal Sequence Log 1 and N

Logging format

Empty  no logging
Value   value-based output format for messages (no display of long text)
Long text long text-based output format for messages (no display of process value and dimension)
All      Combined output of value-based and long text-based format (only allowed for 132 characters per line)

Active going / inactive going
The logging format can be assigned for incoming and outgoing messages of message groups S1 to S3 and priority steps 1 to 4. Here one can select between Empty, Value, Long text and all.
**Operat.** If operator interventions should be logged, a format other than Empty must be provided at Operat.

In the event of intervention, a format other than Empty must be set.

If the optional program Security Lock is installed on the operator station, the logged user name at this particular time will also be listed during the logging of every operator intervention.

**Logging format of acknowledge from**

*Message line / list*

The format for a message acknowledgement is ascertained separately according to the place of acknowledgement – message line and message list.

**Page layout** Defines page layout for the printout. The *Lines per page must* be entered, and is between 10 and 100 lines. The number of characters per line can be defined as 80 or 132 characters, according to the paper format.

**Header / Footer**

The contents of the log header and footer are freely definable. They can include both static text and dynamic process variables. There is also a collection of globally preset variables. The default is a commonly used form of the layout. Refer to Header and Footer Lines in Logs on page 421.

Changes in the header and footer lines generally lead to a change in size of the log. When the log is downloaded to DigiVis 500 Operations the file size is checked. A log whose file sizes have been changed is treated as new log. All existing log files are renamed, and therefore no longer displayed in DigiVis 500 Operation PC. The files may only be viewed using the archive browser.
Data Export Tab – Signal Sequence Log 1 and N

Defining parameters for the signal sequence log through parameter definition mask 4 includes copying the stored logs to other data carriers, primarily external devices, for data protection and archiving purposes.

**File transfer**

Specifies whether and how a copy of the log file is to be transferred from the DigiVis 500 PC to another PC. The PC selected to receive the archives must have a network communication link to the DigiVis 500 PC and an FTP Server (for example, Windows XP/Windows 7 “Internet Information Server - IIS”) must be installed.

Archives are normally sent to a target station which is not identical with the DigiVis 500 PC. A further possibility is to export the archive files to a Windows drive on the DigiVis 500 PC. This drive can be mapped on to another PC in the Windows network. In this case the station address is its own TCP-IP address.
The DigiVis 500 add-on **DigiBrowse** can be used on the archiving PC to **visualize the log archives and convert them** to CSV format.

**Automatic file transfer (FT)**

The mode of file transfer enabling or disabling is specified.

**Enable/disable**

*Enable FT with DigiVis 500 Operations start*

- ✔ As soon as DigiVis 500 Operations is started, file transfer is enabled.
- □ File transfer is not automatically enabled when DigiVis 500 Operations is started.

**Manual controlled**

- ✔ The operator at the operator station can enable or disable file transfer.
- □ File transfer cannot be enabled or disabled manually.

**Trigger**

This area in the parameter mask is used for specifying how data transfer is to be triggered.

**After file completion**

This mode is the default setting for the signal sequence log.

**Cyclic, Cycle time**

- ☐ This time parameter is used to specify the cyclical time interval between copies of the log file being written to the specified target station. Entered in time format (for example, T#10h).

**Manual FT**

**Access**

- ✔ The operator at the operator station can start the file transfer at any time by pressing the *File trans.* button.
- □ File transfer cannot be started spontaneously. The **FILE TRANS** button in the signal sequence log operating dialog is shown grayed out (it cannot be selected).

**Target**

The **target for the data to be transferred** should be specified here. Ideally the target station will also have the **DigiBrowse** software installed on it, so that the trend and log archive files can be displayed and further processed.
**Station**

IP address of the target computer.

If the **DigiVis 500 PC is to be used as export target**, its own IP address must be entered here.

**Path**

If the archive files are to be copied to a certain directory, the complete directory name must be specified here. When using the Internet Information Services on the target station, a path preselection is possible so that only a backslash \ is entered, possibly followed by the rest of the path branch. For example, the path `C:\ARCHIV\STATION\SFP` for the target computer can mean that it diverts all received archives to the preset path `C:\ARCHIV`, and the incoming archive contributes the path information `\STATION\SFP`.

It should be noted that when transferring data the target computer is responsible for any additional manipulation of the files. The copied file is only temporary and is overwritten the next time the corresponding archive is exported.

The target path to the archive storage must be present and may not be write-protected.

**File**

The export files are stored with the file name entered under Target Path.

For example, `STATION\SFP\SFP_MANUFACTURE`. This file is overwritten in every export. Path and file name together may have a total length of 100 characters.

**Directory [8.3]**

The export files are transferred in DOS format – for example, to a PC with WfW Operating System and active FTP Server. The file name corresponds to the export date in the format `‘YMMDDHHm.mss’` (for example, `70528162.320`).

The file name contains no information about the archive type. Choose a suitable path name to ensure it is recognizable afterwards.

**Directory**

The export files are stored in the directory shown under Target Path with their original name (from parameter definition mask 1). The export date in the format `‘.YMMDDHHmmss’` is also appended to the name (separated by a period).
For example, SFP MANUFACTURE.970528162320. Path and file name together may have a total length of 100 characters.

_Suffix for incremental / complete_

☑ In order to distinguish between files containing complete data sets and those containing incremental data sets, the suffixes ‘_INC’ or ‘_FULL’ are appended to the basic file names. This extension renders it impossible for files to be lost by overwriting one another.

_FTP timeout_

FTP utilities are synchronous utilities. In order to prevent the system from becoming congested a maximum time should be entered here within which a transfer must be completed. If timeout is exceeded, it causes a system alarm in DigiVis 500.

_User name_

Enter a user name which is known to the FTP Server of the target station.

_Password_

The password corresponds to the user password for the target station.

**Operation Log**

**Construct Operation Log**

Operation logs are constructed and edited in the project tree under an operator station resource or in the Common display pool (P-CD), for detailed description refer to Section 2, Project Tree.

> Select Operator Station resource or P-CD in the project tree

> Edit > Insert next level > Operation log

If an operation log is configured in the Common display pool (P-CD), then this operation log is available in all operator stations.
Operation Log Configuration

> Double-click the name of the operation log in the project tree.

The configuration of an operation log consists of a parameter dialog with 3 tabs.

General Tab – Operation log

In the project tree > Select operation log > Double click left mouse button

**General data**

**Name**

The **name** of the signal sequence log. The name has been fixed in the project tree and **cannot** be changed here.

**Short text**

A **Short text** can be assigned to the signal sequence log. Up to 12 characters can be entered.
**Long text**

A **Long text** can be assigned to the signal sequence log. Up to 30 characters can be entered.

Short and long text are output with the documentation of the project. In addition, these texts can be **configured for the header and footer of the printed log**, refer to **Header and Footer Lines in Logs** on page 421.

**Start/Stop**

**Automatic**

Logging is automatically started by starting DigiVis.

**Manual**

The operator can start and stop logging on the operator station. This refers only to the log previously selected on the operator station.

**Text...**

Configuration operation log text, refer to **Text Layout on Parameter Definition Mask – Operation Log** on page 417.

**Filing**

*in .. files*

Specifies the number of log files which are created on the DigiVis 500 PC. The value must be between 1 and 400.

*named*

The name of the log file, which is filed on DigiVis 500 PC hard disk. The preset name can be accepted, or a new one given.

**Cycles**

With the start of logging, the data is written cyclically to the file according to the entered cycle time. The value must be between 1 and 32767.

**Cycle time**

This field specifies the interval between two recordings. Entries are made in the IEC 1131-3 format. The value must be between 0 and 2147483 s.

For example, T#2147483s or T#24d20h31m23s.

The recording time in a file is calculated from the number of cycles x cycle time.

**Required disk space for this log**

The size which log files can attain is displayed in this field. This amount of storage should be available on the DigiVis 500 PC.
Parameter definition mask Text comprises a **text field** and an **operator line**. In the text field, any text can be mixed with the formatted output of variables in the operation log. Up to 200 variables are permitted per operation log. The number of lines and columns are defined by the page layout in the parameter definition mask 2.

Using the conventional windows mouse and key commands, text can be marked, cut, copied and inserted within the text field.

**Check** One can test whether errors have been made during text entry or dynamization.

Each dynamic entry must consist of a variable and a display format.
**Variable**  
During **Variable** a variable is selected, and its current value should be recorded in the log. Dynamic entries are shown in square brackets.

To retrospectively assign a different value to a format, position the cursor between the square brackets and push Dynamic.

Place mouse cursor in text field > **Variable** > Select variable > **OK**

**Format**  
A variable is assigned to a display format (for example, the number of digits after decimal will be defined).

To assign later an other format to a variable, take position between the square brackets and push Format.

Position mouse cursor in text field > **Format** > select format > **OK**

**Print preview**  
The forthcoming **Print preview** of the operation log is displayed. Only the format specification and text are still visible in the print preview. The square brackets and the variable names are not displayed.

Variable names cannot be changed in the print preview display.

Back to the Edit Display **Edit**.

**Print as table**  
The operation log is printed out in tabular form. This means that the part with the dynamic area is repeated, indeed it is repeated as many times as the page layout allows.
**Print to**

*Channel 1 / 2* Two printer channels are available for log output on the printer. The printer channel is selected by activating the corresponding *option* button.

**Print**

*Manual* The printing of logs can be activated *manually* by the operator at the operator station.

*Automatic* Printing takes place automatically after completing the logging.

**Delete log files**

*Automatic* When the automatic delete option is selected and the configured number of files is exceeded, the oldest log file is overwritten by the current file.

If the automatic delete option is not selected then **logging is stopped** as soon as the max. number of files has been reached.
The operator can select and delete individual log files.

**Printed files only**

Only printed log files can be deleted manually.

**Page layout**

Defines page layout for the printout. The number of **Lines per page** must be entered and is between **10 and 100 lines**. The number of characters per line can be defined as **80 or 132 characters**, according to the paper format.

**Header / Footer**

The contents of the log **header** and **footer** are freely definable. They can include both static text and dynamic process variables. There is also a collection of globally preset variables. The default is a commonly used form of the layout. Refer to **Header and Footer Lines in Logs** on page 421.

Changes in the header and footer lines generally lead to a change in size of the log. When the log is downloaded to DigiVis 500 the file size is checked. A log whose file sizes have been changed is treated as new log. All existing log files are renamed, and therefore no longer displayed in DigiVis 500 Operations. The files may be viewed using the archive browser.

**File Transfer Tab – Operation Log**

This parameter definition mask corresponds to the parameter definition mask of the Signal Sequence Log. Refer to **Data Export Tab – Signal Sequence Log 1 and N** on page 411.
Header and Footer Lines in Logs

In project tree > Select log > Button Header or Footer

Hint concerning variable... and format...
The selection of variables is identical to the procedure for the dynamization of log text (for example, a variable and its output format are specified [Format\VarName]). When a log file is started under DigiVis 500, the configured variables are read once, converted to the specified format and entered in header or footer line.

Variable... Selecting a process variable (from list)
Format... Selecting a display format (from list).

To assign later an other format to a variable, take position between the square brackets and push Format.

Field... Selecting a project-specific field (from list)
Print preview The forthcoming Print preview of the operation log is displayed. Only the format specification and text are still visible in the print preview. The square brackets and the variable names are not displayed.

Variable names cannot be changed in the print preview display.
The following elements can be incorporated in text for headers and footers:

- Static text that appears unchanged in the header and footer line on each page
- Field references, referring to the DigiVis 500 Graphics Builder documentation
- Variables.

Field references

Project-specific fields (expanded from the project description into static text during the plausibility check):

- \$PrjComm: Project comment
- \$PrjDate: Date of the project, the format “dd.mm.yy” (length: 8 characters) must be specified
- \$PrjMan: Manager of current project
- \$PrjName: Name of project (length: 8 characters)
- \$PrjNr: Project number
- \$PrjOrd: Project order
- \$PrjOrdNr: Order number of project
- \$ProtType: Log type
- \$ProtST: Short text of log
- \$ProtLT: Long text of log
- \$ProtName: Name of log

Dynamic fields (expanded into static text at run time of the log file):

- \$ProtStart: Start time of log file
- \$ProtStop: Stop time of log file

Dynamic fields (expanded into static text when log file is printed out):

- \$PgNr: Page number (max. length: 3 characters)
- \$PrintDate: Time of printing, consisting of the date and time
Section 13  DigiBrowse

DigiBrowse - General Description

DigiBrowse is an additional program for the DigiVis 500 system and requires a license.

DigiBrowse permits viewing archived trend, log files and reports without the use of DigiVis 500 Operations. The data can be presented in graphic form or as tables. The graphic presentation can be scaled as desired, to facilitate examination of particular past process events. In addition, it is possible to convert the data to ASCII format, making it readable by other programs, such as, for example, data base or spreadsheet programs.

The transfer of archive files from the different operator stations is either automatic, manual or event-driven, as configured in DigiVis 500 Graphics Builder. It is also possible to configure for files archived at a Operator Station to be transferred to the PC on which DigiBrowse is installed.

DigiBrowse Installation

Running the DigiVis 500 setup on a PC, will install the DigiBrowse software.

If the DigiBrowse option was deselected from the Feature tree while running the setup then DigiBrowse will not be installed on the system.

In this case, run the DigiVis 500 setup using the “Custom” option and select the DigiBrowse component.
Starting DigiBrowse

**Requirements for receiving data through FTP Export**

The PC which is to receive the archives must have a network communication link with the DigiVis 500 Operations PC. The ‘Microsoft Peer Web Services’ including the FTP service must also be installed on target stations with the Windows XP/Windows 7 Operating System.

Start > System Control > Network > Services > Add Microsoft Peer Web Server

The Services are supplied as part of the Windows XP/Windows 7 package. Once installed they start up automatically when you log on to Windows XP/Windows 7 Operating System.

FTP Export is configured in the parameter-setting dialogue for trend displays or logs at the relevant operator station.

The Station is determined by the IP address input for the target computer (for example, “172.16.1.24”). If the archive files are being copied to a directory, the full name of the directory must be given. A default path is entered in Peer Web Services at the target station.

Start > Programs > Microsoft Peer Web Services (Common)

When setting parameters for the trend display or log, you need only enter a backslash\, possibly followed by the rest of the branch of the path. For example, the path C:\ARCHIV\STATION1\SSL for the target computer may mean that it diverts all input archives to the default path C:\ARCHIV and the incoming archive contributes the path information \STATION1\SSL.

It should be noted that the **target computer is responsible** for further file processing in data transmission. **The copied file is only temporary** and is overwritten next time the relevant archive is exported.
The path to the archive store at the target station needs to be kept available and must not be write-protected.

In the FTP Export File setting the export file is stored once, with the filename given in the target path, for example: STATION1\SSL\SSL_PRODUCTION. The file is overwritten each time an item is exported. The path and filename together may have length of 100 characters.

In the Directory [8.3] setting export files are transmitted in DOS format - for example, to a PC with a WfW Operating System and activated FTP Server. The filename corresponds to the export date, in the format ‘YMMDDHHm.mss’ (for example, 70528162.320).

The filename does not contain any information about the type of archive. Choose a path name which will ensure that it is recognized later.

In the Directory setting export files are stored in the directory specified in the target path, under their original name (from parameter mask 1). This name is followed by the export date - separated by a dot - in the format ‘.YYMMDDHHmmss’.

For example, SSL_PRODUCTION.970528162320.

The path and filename together may have a length of 100 characters.

The user name and password must correspond to a valid user of the target station (refer to Windows XP User Manager).

**Menu Structure DigiBrowse**

<table>
<thead>
<tr>
<th>File</th>
<th>Open</th>
<th>Window</th>
<th>Trend Hardcopy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close</td>
<td></td>
<td>Cascade</td>
<td></td>
</tr>
<tr>
<td>Export</td>
<td></td>
<td>Tile horizontal</td>
<td></td>
</tr>
<tr>
<td>Move</td>
<td></td>
<td>Tile Vertical</td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td>Arrange Icons</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td></td>
<td>Close All</td>
<td></td>
</tr>
<tr>
<td><strong>Exit</strong></td>
<td>Refresh File Manager F5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>View</strong></td>
<td><strong>Help</strong></td>
<td><strong>Contents F1</strong></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Archive Manager</td>
<td>Help</td>
<td>Contents F1</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Goto</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td>Default view List/Trend</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Default view List/Trend</td>
<td>Switch trend-list</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Switch trend-list</td>
<td>Trend options</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Trend options</td>
<td>Search path</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search path</td>
<td>Column width</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column width</td>
<td>Archive manager</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Archive manager</td>
<td><strong>Format</strong></td>
<td><strong>Fade in</strong></td>
<td></td>
</tr>
<tr>
<td>Format</td>
<td>Column</td>
<td>Fade in</td>
<td></td>
</tr>
<tr>
<td>Column</td>
<td>Fade out</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fade out</td>
<td>Fade in all</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fade in all</td>
<td>Read defaults</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Read defaults</td>
<td>Define</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Call-up of the DigiBrowse Archive Manager

After being called up, a file manager appears listing the available archive files (for example, the archive found in the configured search path). Refer to Search Path on page 438.

The available files and their directories are shown in the left window. Only filed archives found by following the set search path are displayed.

In the right window, information is listed relating to the different versions of the selected archive which can be examined.

Archive Display

Trend or tabular presentation

- Select archive from right-hand column > Double click left mouse button

Tabular presentation is preselected for the logging and trend archives. However trends can also be shown as curves.

- Options > Switch Trend_List

Selecting this option changes the presentation of the archive currently selected. If another option is chosen the presentation changes again.

The current setting only applies to newly opened windows. Windows which are already open retain the existing presentation.
Tabular presentation

In tabular presentation of a trend the following entries are shown:

- number and status of record
- date/time of recorded variables in TIME format,
- values of variables (max. 6).

Trend presentation

The desired section of the archive can be brought into view using the scroll bars. With the graphical presentation, the scale factor can also be adjusted.
Individual trends can be selected using the above name fields. The name field for a selected trend appears raised and the scaling appears in the color for the trend. The trend can then be processed as follows, using the buttons at the bottom.

**ZOOM X+**  Shortens the time interval per raster.

**ZOOM X-**  Lengthens the time interval per raster.

**ZOOM Y+**  Reduces the scale for the Y axis.

**ZOOM Y-**  Enlarges the scale for the Y axis.

**Trend Options**

> Options > Trend Options
**Colours**  Colors in the graphics window can be controlled with the **FOREGROUND, BACKGROUND AND WINDOW BUTTONS.** **RESET** restores colors to their original values.

**Name_1..6**  These buttons give the name of the variable recorded. Only buttons which apply can be seen, according to the number of channels recorded. When a variable is selected its scale is shown on the **Y** axis.

The **Y** axis can be scaled channel by channel in this mask. The form of presentation can also be controlled.

**Y-Scaling**  With band start and band end the scaling of the **Y** axis can be set for this trend. The position on the **Y** axis of the band start and band end
can be set between 0% and 100% using the **band start%** and **band end%**.

The band start setting must always be less than the band end. This also applies to the band start% and band end%. The percentage values can be less than 0% and more than 100%. In this case the part of the trend not between 0% and 100% will be displayed as a line above 100% or below 0%.

Band start and band end must be entered as real values. The value range is between 0.0 and ±999999999.9.

The percentage values for band start and band end must be entered as integer values between 0 and ±5000%

**Interpolation**  There is a choice between None, Linear and Steps.

<table>
<thead>
<tr>
<th>Interpolation</th>
<th>Marker</th>
<th>Points/Pixels</th>
<th>Rectangle</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>invisible</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Linear</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Steps</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Marker**  Can be set as None, Pixels or Rectangle.

If None is selected for both the interpolation and the marker, the trend is invisible!

**Colour**  The color for the display of the trend and the Y axis scaling is determined after marking SELECT. RESET is for standard color.

For more information, refer to DigiVis 500 Operations Operators Manual, Section H, Trend Display, Changing options.

**Signal Sequence Log SSL1/SSLN**

The signal sequence logs are generally found in the `<DigiVis 500_Installation_Folder>\sfp` directory. Double clicking on a file opens a window in which the files contents are displayed.
The following data are displayed in the table:

- Record number and status of the entry,
- Date and time when the items were recorded, in TIME Format,
- Signal content (format dependent).

The entries for the various events are found between the time markers. Events with priority values from 1 to 4 can be displayed with format **Empty (none)**, **value**, **LongText** and **All**. Which events are displayed with which format is specified during configuration.

There are special formats for **operator actions**, **logging events** and **messages of priority level 0** (system errors).

**Format Empty**

No entry is generated
Format Value
M T-ST AR TAG. S-TEXT M-TEXT TYPE

Format Long
M T-ST AR TAG. S-TEXT L-TEXT M-TEXT

Format All
M T-ST AR TAG S-TEXT L-TEXT M-TEXT TYPE

Format System Error
M T-ST TAG SYS-M-TEXT (Format Value, Long, All)

Format Operator Action
O T-ST OPERATOR VAR-NAME S-TEXT O-VALUE N-VALUE (Format Value, Long, All)

Format Log Event
! T-ST P-NAME S-TEXT EVENT (Format Value, Long)
! T-ST P-NAME S-TEXT L-TEXT EVENT (Format All)

Abbreviations
M Message such as switch message, error message, system error. Messages with priority levels 1 to 4 are displayed with a sign signifying incoming(+) and outgoing(-). Acknowledged messages can be identified by the symbol <.
T-ST Time stamp
AR Area A .. O, empty if not configured
TAG Tag name.
S-TEXT Configured short text for tag.
L-TEXT Configured long text for tag.
M-TEXT  Configured message text for message.
TYPE  Configured message type.
VAR-NAME  Variable name
P-NAME  Log name
B  Symbol for operator action
OPERATOR  If the optional program DigiLock is installed, the Name of operator initiating this intervention will appear at this point.

In the basic version without DigiLock, **NOLOCK** is stated as standard operator name. For all actions from DigiVis 500 Operations, **SYSTEM** is stated as the standard operator name.

!  Symbol for log event
O-VALUE  Old value of variable
N-VALUE  New value of variable.
EVENT  Log event such as Start, Stop, Print, Delete and Export.

Refer to **DigiVis 500 Operations Operators Manual, Section L, Logs.**

![Information symbol]

Graphical presentation of the log files is not possible.

**Operation Log (OPL)**

The operation logs are generally found in the `<DigiVis 500_Installation_Folder>\bpr` directory. Double clicking on a file opens a window in which the contents of the archive are displayed.
The table has the following entries:

- Record number and status,
- Date and time when the variables were recorded, in TIME Format,
- Unused,
- Names of up to 200 variables,
- Table of the recorded values of the variables.

Refer to **DigiVis 500 Operations Operators Manual, Section L, Logs**.

Graphical presentation of log files is not possible.
Editing Files

Opening Files

> File > Open

Choose the archive file to be opened. Default filing of archives is done in the DigiVis 500 directory under \sfp, \BPR or \CURV.
Closing Files

> File > Close

Closes the selected window.

Export

> File > Export

The contents of the archive can be converted to ASCII format (.CSV), so that they can be read into a data bank or spreadsheet program.

Deleting Files

> File > Delete

After confirmation, the archive file selected in the file manager will be deleted.
General Settings

Search Path

> Options > Search Path

Paths can be entered for use by the archive manager. The archive manager will search all paths entered for valid archive files and will list available archive in the table. Path entries are separated by semicolons.

Column Width

> Options > Column width

The width of the columns for the tabular display of archive files can be changed. The individual values are separated by semicolons.
**Window Settings**

![Window Settings](di4216uk.bmp)

**Trend Hardcopy**

Used to take the print out for the opened Trend window, printer must be configured or else it throws the following message

> Window > Trend Hardcopy

![Trend Hardcopy](Trend Hardcopy.bmp)

**Cascade**

> Window > Cascade

All open windows are positioned in cascade.
**Tile Horizontal**

> Window > Tile Horizontal

All open windows are lined up horizontally.
Tile Vertical

> Window > Tile Vertical

All open windows are lined up vertically.
**Arrange Icons**

> Window > Arrange Icons

If any windows were shrunk to icons, the corresponding icons are arranged.

**Close All**

> Window > Close All

All open windows will be closed.

**Refresh File Manager**

> Window > Refresh File Manager

The contents of the file manager display will be rebuilt (for example, the files in the archive directories will be reread).

**List of Open Windows**

> Options

The names of the files displayed in the open windows are listed at the bottom of the options menu. When a number of windows are open, an easy way to bring one to the foreground is to click on the desired archive here.
Section 13 DigiBrowse

Window Settings
### Appendix A  Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access</td>
<td>Parameters from preconfigured displays that either authorize or prevent certain sizes, values or actions for the user.</td>
</tr>
<tr>
<td>Acknowledge</td>
<td>Operator action whereby one or more messages is/are acknowledged as seen and understood. Every action performed by the logged-in operator can be logged in the signal sequence log.</td>
</tr>
<tr>
<td>Acknowledge button</td>
<td>Button in the message line that enables the most recently received messages in the message line (VA, visual acknowledge) or message list (A, acknowledge) to be acknowledged without having to call up the message list.</td>
</tr>
<tr>
<td>Alarm</td>
<td>An alarm is an event at a point of measurement or in the system with an associated message at the operator station.</td>
</tr>
<tr>
<td>Alphanumeric display</td>
<td>A dynamic symbol from the graphic editor for displaying analog values on the operator station.</td>
</tr>
<tr>
<td>Analog variable</td>
<td>Generic term for all non-digital variables with numeric formats such as real, integer, double integer or word.</td>
</tr>
<tr>
<td>Archive</td>
<td>An archive is the file in which the data from a trend display or log are saved. Depending on how data is logged, in this way large volumes of data can be generated under certain circumstances.</td>
</tr>
<tr>
<td>Area attributes</td>
<td>Area attributes include the color and fill pattern of the graphic objects like rectangle, polygon, ellipse and arc. These area attributes can be changed when making a display dynamic.</td>
</tr>
<tr>
<td><strong>Automatic</strong></td>
<td>Operating mode in which processing is carried out automatically through the program’s control settings. The operator is not allowed to do any input in automatic mode. For operator input you must change to manual operating mode.</td>
</tr>
<tr>
<td><strong>AutoCAD</strong></td>
<td>CAD program from Autodesk, produced in versions running on a variety of computers.</td>
</tr>
<tr>
<td><strong>Autoexec.bat</strong></td>
<td>File name (autoexecuted batch file) of a batch file executed when a computer is booted up with the DOS Operating System and/or MS Windows.</td>
</tr>
<tr>
<td><strong>Background</strong></td>
<td>The background is the static part of a free graphic display.</td>
</tr>
<tr>
<td><strong>Background color</strong></td>
<td>A separate background color can be selected for the draw area for each graphic display and for the graphic pool.</td>
</tr>
<tr>
<td><strong>Band</strong></td>
<td>The band is the value range of a variable that is displayed in a trend display. The limits of this range - the band start and band end - are configurable.</td>
</tr>
<tr>
<td><strong>Band end</strong></td>
<td>The band end defines the value for the end of the scale on the Y-axis in the single trend display.</td>
</tr>
<tr>
<td><strong>Band start</strong></td>
<td>The band start defines the value for the start of the scale on the Y-axis in the single trend display.</td>
</tr>
<tr>
<td><strong>Bargraph</strong></td>
<td>Dynamic symbol used by the graphic editor. The bargraph represents analog values by filling a rectangular column either from the top, bottom, right or left.</td>
</tr>
<tr>
<td><strong>Block</strong></td>
<td>A combination of several separate objects to form a single object with the same processing possibilities.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Block export</td>
<td>Combined objects (&gt; block) can be written to file. The data will be saved as Unicode file. The file extension specifies the type of data or the editor used to export the file. With “Import block” data saved this way can be imported into another part of the project or into a different project.</td>
</tr>
<tr>
<td>Block import</td>
<td>The content of a file saved with ‘Block export’ can be imported into the current project.</td>
</tr>
<tr>
<td>Button</td>
<td>A dynamic symbol from the graphic editor. Buttons can be used to call up displays or tags, enter default values for variables or display states.</td>
</tr>
<tr>
<td>Button field</td>
<td>A button field comprises one or more buttons. When one of the buttons is activated, the action must be confirmed.</td>
</tr>
<tr>
<td>Button type</td>
<td>Form of the button in the graphic display as a rectangle, in 3-D, as an ellipse or as a circle.</td>
</tr>
<tr>
<td>Colors</td>
<td>The colors, which cannot be changed through the Windows interface, can be adjusted separately in DigiVis 500 Graphics Builder in the project tree and program editors.</td>
</tr>
<tr>
<td>Combine</td>
<td>Function of the graphic editor enabling several objects to be configured jointly.</td>
</tr>
<tr>
<td>Comment</td>
<td>Full description to increase understanding can be added to the project and all project objects in the project tree, that is notes on how variables should be used, on a program’s functionality or in general on the process field.</td>
</tr>
<tr>
<td>Commissioning mode</td>
<td>Operating mode on the engineering station in which there is an on-line connection to a operator station *Configuration</td>
</tr>
<tr>
<td>Common display pool</td>
<td>The common display pool (VISP-CD) is a project tree object enabling all operator stations configured in the project to access the shared displays.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Configuration mode</td>
<td>Operating mode on the engineering station in which user programs can be configured or modified. No on-line connection to an operator station is necessary in order to use configuration mode. *Commissioning mode.</td>
</tr>
<tr>
<td>Configure</td>
<td>Engineering station operating mode in which user programs can be configured or modified. Configuration can be carried out in the absence of an on-line link to a DigiVis 500 Engineering station. See also commissioning.</td>
</tr>
<tr>
<td>Connection</td>
<td>On-line connection from the engineering station to the OPC Server and the operator stations (D-OS) through the system bus (Ethernet/TCP/IP).</td>
</tr>
<tr>
<td>Control room horn</td>
<td>A control room horn can be configured along with the field horn. This is done by entering a wave file (requiring a sound board) in the local event processing. When an event occurs with the configured priority entered, this wave file is executed.</td>
</tr>
<tr>
<td>Corner</td>
<td>A linear attribute in the graphic editor. Corner rounding allows the corners of polygons, rectangles or continuous lines to be displayed with a rounded form.</td>
</tr>
<tr>
<td>Correct (1)</td>
<td>Correcting (patching) is used to change the parameters for the selected tag during commissioning. In contrast with writing, the changed parameters are saved in the project.</td>
</tr>
<tr>
<td>Correct (2)</td>
<td>The state Correct is only assigned if no errors have been detected in the project tree or program when running plausibility checks on the selected project objects. A program object cannot be loaded into a station unless it has passed a plausibility check.</td>
</tr>
<tr>
<td>Crosshairs</td>
<td>In the graphic editor one of the display formats of the mouse cursor is termed crosshairs; here there is a horizontal and a vertical line each extending across the entire draw area. The point of intersection of the two lines corresponds to the cursor position.</td>
</tr>
<tr>
<td>Cross-references</td>
<td>Cross-references show which programs or displays the selected variable or tag is used in.</td>
</tr>
</tbody>
</table>
### CSV format
A standard ASCII format (comma-separated values) used as an export format for DigiVis 500 Graphics Builder projects or parts of a project.

### Cut
In contrast with deleted objects, the selected objects can be and actually are re-inserted into the program through Insert.

### Data bank recovery
If the PC crashes in the course of a DigiVis 500 session, the latest position in the configuration can be recovered.

### Data format
The data format specifies how a data type is displayed in the operation interface, that is how many places before and after the decimal point (for example, fff.ff for 340.05).

### Data type
Data types are assigned to variables either directly in the program or through a variable declaration in the variable list. Along with the basic data types such as REAL or BOOL, user-defined data types can also be set up (structured variables).

### Daylight-saving-time
DigiVis 500 clock can be adjusted automatically to daylight-saving-time. A function block is provided for this purpose; this function block converts a variable of type Date and Time (DT) to daylight-saving-time.

### Default display
The default display is a display with a special significance for the display selection dialog in the context of display allocation. This allows a specific display to be called up for each tag when F11-key is pressed.

### Default text
Text messages set up during configuration that are incorporated into the log, the alarm list or the hints list when particular events occur; these text messages may also be displayed in the dialog line.

### Delete
When program objects are deleted they are removed from the program permanently and the program is set to state Incorrect. When objects are deleted in the project tree they are removed permanently from the project.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demo mode</td>
<td>If DigiVis 500 Graphics Builder or DigiVis 500 Operations is operated</td>
</tr>
<tr>
<td></td>
<td>without a hard key, then the application will automatically start in demo</td>
</tr>
<tr>
<td></td>
<td>mode. In demo mode the software is fully functional and will run for</td>
</tr>
<tr>
<td></td>
<td>100 days. At the end of this 100-day period the software is no longer</td>
</tr>
<tr>
<td></td>
<td>functional.</td>
</tr>
<tr>
<td>Design points</td>
<td>When a graphic object is selected, it is displayed with design points.</td>
</tr>
<tr>
<td></td>
<td>Such an object can be resized by clicking on one of these points and</td>
</tr>
<tr>
<td></td>
<td>dragging it while keeping the left mouse button pressed.</td>
</tr>
<tr>
<td>Diagnostics</td>
<td>A number of diagnostic tools are running during operation, and these</td>
</tr>
<tr>
<td></td>
<td>make it easier to trace a problem in the event of a malfunction. When an</td>
</tr>
<tr>
<td></td>
<td>error occurs, a system error message results. There are also diagnostic</td>
</tr>
<tr>
<td></td>
<td>options available through the diagnostics interface.</td>
</tr>
<tr>
<td>Dialog area</td>
<td>The dialog area is used for displaying either the operation dialog for</td>
</tr>
<tr>
<td></td>
<td>operating a tag or the display selection dialog for rapid selection of</td>
</tr>
<tr>
<td></td>
<td>related displays.</td>
</tr>
<tr>
<td>Dialog box</td>
<td>The dialog box is used to display messages or hints to facilitate both</td>
</tr>
<tr>
<td></td>
<td>configuration and operation tasks.</td>
</tr>
<tr>
<td>DigiBrowse</td>
<td>Software package for a log station which enables trend and log archives</td>
</tr>
<tr>
<td></td>
<td>to be displayed.</td>
</tr>
<tr>
<td>DigiVis 500 Graphics Builder</td>
<td>Software package for the engineering station which enables overall</td>
</tr>
<tr>
<td></td>
<td>configuration of the user program including the operation and observation</td>
</tr>
<tr>
<td></td>
<td>level</td>
</tr>
<tr>
<td>DigiVis 500 Operations</td>
<td>Software package for the operator station that enables operation and</td>
</tr>
<tr>
<td></td>
<td>observation of the process with the aid of numerous standard functions.</td>
</tr>
<tr>
<td>DigiVis 500 system</td>
<td>The sum of all the DigiVis 500 components. DigiVis 500 Graphics Builder,</td>
</tr>
<tr>
<td></td>
<td>DigiVis 500 Operations, add-on packages, hardware components, engineering</td>
</tr>
<tr>
<td></td>
<td>station. OPC Server</td>
</tr>
<tr>
<td>Directory</td>
<td>During installation, directories are set up in advance for the storage of</td>
</tr>
<tr>
<td></td>
<td>DigiVis 500 specific data.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Discrete</td>
<td>Dynamic graphic objects are output on defined x/y coordinates in conjunction with a maximum of 3 binary variables.</td>
</tr>
<tr>
<td>Display</td>
<td>The sum of the static and dynamic graphic objects and graphic symbols with the associated background color. The display name is allocated in the project tree of DigiVis 500 Graphics Builder.</td>
</tr>
<tr>
<td>Display access</td>
<td>Display access in DigiVis 500 Graphics Builder allocates displays to tags, these displays can then be called in DigiVis 500 Operations by means of the display selection dialog.</td>
</tr>
<tr>
<td>Display format</td>
<td>The display format determines the format in which a variable’s value is displayed in the operation interface.</td>
</tr>
<tr>
<td>Display object</td>
<td>Display objects can be simple or complex, static or dynamic symbols that can be created using the graphic editor and have parameters defined. A display object contains information for displaying the graphic symbol on the operator station.</td>
</tr>
<tr>
<td>Display selection</td>
<td>An operator action that alters the content of the display area of the operation interface.</td>
</tr>
<tr>
<td>Display selection dialog</td>
<td>Display of the operation line which enables displays to be called up rapidly. These displays are held in a fixed order which can only be changed using DigiVis 500 Graphics Builder. Clicking the right mouse button in the dialog area toggles between the operation dialog and the display selection dialog.</td>
</tr>
<tr>
<td>Documentation</td>
<td>DigiVis 500 Graphics Builder provides various different forms of documentation for the user programs (project tree, hardware structure, program lists, parameter data,…). The content, form and scope of the documentation can be freely selected.</td>
</tr>
<tr>
<td>Documentation header</td>
<td>For each documentation job a comment can be generated using the documentation header editor; the purpose of this is to provide an explanation of the documentation content of a job.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Documentation job</td>
<td>A documentation job is a defining list specifying the user program areas that are to be documented.</td>
</tr>
<tr>
<td>Documentation management</td>
<td>When entering the documentation management system, below the menu line there appears a list of available print jobs. Blank lines in the list represent unallocated print jobs.</td>
</tr>
<tr>
<td>Documentation scope</td>
<td>All project objects positioned on the currently selected level of the project tree are documented.</td>
</tr>
<tr>
<td>D-OS or VIS resource</td>
<td>The displays and logs that are to be displayed on a DigiVis operator station are configured in the project object D-OS or VIS resource.</td>
</tr>
<tr>
<td>Draw area</td>
<td>The draw area is the user’s actual working area for creating and editing displays.</td>
</tr>
<tr>
<td>Drawing footer / header</td>
<td>DigiVis 500 documentation is printed out with a drawing footer and drawing header. This makes it possible for the drawing footer to be defined for the project and for each project object. At the same time system variables and bitmaps can be assigned to the individual fields.</td>
</tr>
<tr>
<td>Duplicate</td>
<td>A selected graphic object or symbol is duplicated on the drawing surface without being saved in the clipboard as with copying. The duplicate copy is displayed on top of the original but in a slightly shifted position; it is also ready-selected.</td>
</tr>
<tr>
<td>Dynamic</td>
<td>When a display is made dynamic the static display, created using the graphic editor, has variables and tags from the user program introduced into it. This is achieved by accessing a shared database, thus helping to avoid errors in data entry.</td>
</tr>
<tr>
<td>Edit</td>
<td>Menu item under DigiVis 500 Graphics Builder which enables fields, elements or programs to be edited. Edit includes functions such as the calling of programs or displays, general parameters, and the pasting, copying or deletion of fields or element.</td>
</tr>
<tr>
<td><strong>Engineering station</strong></td>
<td>PC or laptop with MS Windows and DigiVis 500 Graphics Builder software. Used by the system operator for configuration, commissioning, and documentation.</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Error</strong></td>
<td>Errors are reported when a program is checked for plausibility and found to be syntactically incorrect.</td>
</tr>
<tr>
<td><strong>Error list</strong></td>
<td>All plausibility errors are added to an error list. This error list contains all the errors for the currently selected level in the project tree.</td>
</tr>
<tr>
<td><strong>Error message</strong></td>
<td>An error is reported if the system has encountered an error in the user program. In this case a system error message is generated with a message priority of 0.</td>
</tr>
<tr>
<td><strong>Ethernet</strong></td>
<td>Serial bus system to DIN/ISO 8802, Part 3 (IEEE 802.3). Used for the system bus.</td>
</tr>
<tr>
<td><strong>Ethernet board</strong></td>
<td>PC plug-in board for connecting engineering station and operator station to Ethernet system bus.</td>
</tr>
<tr>
<td><strong>Event</strong></td>
<td>An event triggers a message or a control action.</td>
</tr>
<tr>
<td><strong>Event-controlled</strong></td>
<td>A logging process or the transfer of a file is initiated by an event.</td>
</tr>
<tr>
<td><strong>Exit</strong></td>
<td>The menu choice Exit is used for leaving the current editor.</td>
</tr>
<tr>
<td><strong>Expand</strong></td>
<td>The project tree can be displayed either in expanded or compressed format by selecting the junctions. This has the effect of either opening up or closing down individual levels thus enabling the individual program parts to be displayed in a manageable way.</td>
</tr>
<tr>
<td><strong>Export</strong></td>
<td>Any parts of a project or program can be exported for use in other projects or programs. The export format used is CSV.</td>
</tr>
<tr>
<td><strong>Extension</strong></td>
<td>All DigiVis 500 files are saved in the directory in which DigiVis 500 Graphics Builder or DigiVis 500 Operations is installed. This is generally a directory named DigiVis 500. The different types of files can be distinguished from one another by their extensions (for example, .pro, .csv and so on).</td>
</tr>
<tr>
<td>Glossary Term</td>
<td>Definition</td>
</tr>
<tr>
<td>---------------</td>
<td>------------</td>
</tr>
<tr>
<td>Faceplate</td>
<td>A faceplate is used for operation and observation of a tag. This shows the current status from the related process. It can be incorporated into any other display.</td>
</tr>
<tr>
<td>Fault message</td>
<td>Messages of priority 1 (red), 2 (yellow) and 3 (orange) for showing faults such as violations of limit values in the operation interface.</td>
</tr>
<tr>
<td>Field</td>
<td>In lists such as the tag list individual fields can be edited. If changes are made to specific fields such as Name or Type, they must be confirmed before being adjusted automatically and across the whole system.</td>
</tr>
<tr>
<td>Fill level</td>
<td>A dynamic symbol from the graphic editor. The fill level symbol is used to represent analog values with a polygon being filled either (optionally) from the bottom or top, from the left or right.</td>
</tr>
<tr>
<td>Fill pattern</td>
<td>Area attribute of a graphic object or symbol which allows the hatching style of the area to be modified.</td>
</tr>
<tr>
<td>Flash</td>
<td>Flashing refers to the cyclical pulsing of display objects.</td>
</tr>
<tr>
<td>Font type</td>
<td>Text attribute in the graphic editor.</td>
</tr>
<tr>
<td>Foreground</td>
<td>Brings a selected graphic object to the front. In this way the object is overlaid on top of any other graphic objects occupying the same position. *Overlap</td>
</tr>
<tr>
<td>Format</td>
<td>In DigiVis 500 a distinction is made between the logging format and the data format. (Logging formats can be assigned to incoming and outgoing messages of priority levels 1 to 4) as well as to incoming operator actions. Data formats are used in graphic displays and operating logs, and they control the representation of different data types in the DigiVis 500 Operations displays.</td>
</tr>
<tr>
<td>Free Colors</td>
<td>Colors in graphic editor used to display color courses.</td>
</tr>
<tr>
<td><strong>FTP</strong></td>
<td>When trend archives or log files are transferred from an operator station to another subscriber on Ethernet, the transfer protocol used is FTP (File Transfer Protocol). The transfer may be manual, cyclical or event-controlled.</td>
</tr>
<tr>
<td><strong>Function key</strong></td>
<td>The function keys (F1 - F12) form a standard part of the keyboard, and some of them have standard functions assigned to them.</td>
</tr>
<tr>
<td><strong>Graphic display</strong></td>
<td>Free graphic displays can be created with the -&gt; Graphic editor to visualize and operate the process at the operator station. Several static and dynamic -&gt; graphic objects are available.</td>
</tr>
<tr>
<td><strong>Graphic editor</strong></td>
<td>An editor as part of DigiVis 500 Graphics Builder to create graphic displays.</td>
</tr>
<tr>
<td><strong>Graphic object</strong></td>
<td>Elements of the -&gt; Graphic editor to create free graphic displays to visualize and operate the process at the operator station. Static objects are line, rectangle and ellipse; dynamic objects are bar graph, alphanumeric display, trend window,...</td>
</tr>
<tr>
<td><strong>Graphic pool</strong></td>
<td>Buffer used to exchange parts of graphic displays within a project.</td>
</tr>
<tr>
<td><strong>Graphic region</strong></td>
<td>The graphic region is the region in the editor in which the program itself is configured.</td>
</tr>
<tr>
<td><strong>Graphic symbol</strong></td>
<td>A special graphic object, used to make static objects dynamic, for example to change the color of a line.</td>
</tr>
<tr>
<td><strong>Graphics animation tool</strong></td>
<td>Standard component of the graphics editor enabling the display objects to be animated. The DigiVis 500 operating dialog is configured by the process of making it dynamic.</td>
</tr>
<tr>
<td><strong>Grid</strong></td>
<td>In order to allow more accurate positioning in the graphics editor a background grid can be included in the display. The Grid command can be used to switch on and off the row and column grid lines in the display area. When grid is on, a tick appears in front of the menu choice.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Group display</td>
<td>A group display is a combination of several faceplates. It provides the user with the opportunity to display related tags in the same display. After a displayed faceplate has been selected, the corresponding tag can then be operated.</td>
</tr>
<tr>
<td>Hard disk requirement</td>
<td>The amount of hard disk space needed for a trend archive or a log file is calculated, during the configuration. If it is established at that point that the free storage capacity on the fixed disk is not sufficient, an appropriate message is issued.</td>
</tr>
<tr>
<td>Hard key</td>
<td>Running DigiVis 500 Graphics Builder requires a hard key (for parallel or USB port). These enable the licensed version of the program to be used along with the licensed options. Installation of the hard key does not impair the functioning of the printer.</td>
</tr>
<tr>
<td>Header</td>
<td>Parameter window for a project or project tree object in which universal details like name, short comment and so on. The drawing header and footer for documenting the parts of the user program are also configured in the header.</td>
</tr>
<tr>
<td>Horn</td>
<td>A control room horn can be configured for each message priority level using the Local Message Processing option in DigiVis 500 Graphics Builder.</td>
</tr>
<tr>
<td>Host name</td>
<td>A name identifying the computer. Each name must be unique within the DigiVis 500 network. No other PC in the DigiVis 500 network may have the same name.</td>
</tr>
<tr>
<td>Icon</td>
<td>Windows terminology. Represents a program or a link that is started with a double-click.</td>
</tr>
<tr>
<td>Import</td>
<td>In order to re-use parts of other programs or projects, such previously-exported sections can be imported. When importing on the project level, these units are deposited in the project pool. The format used for import is the CSV format.</td>
</tr>
</tbody>
</table>
## Incorrect

The focus is displayed at the left-hand end of the state line. Once the focus has been selected, objects in the window can then be selected using the arrow keys.

A plausibility check can be used to ascertain whether the selected project objects are correct. Each newly created project object in the project tree that has yet to pass a plausibility check or has not yet been correctly configured is assigned the state Incorrect. Every entry made in a program, display or log similarly leads initially to state Incorrect.

## Insert

One or more **program objects** that have been previously copied or cut are inserted at any position in the program.

## Interface

The term interface refers to the point where two systems meet. The different features of the two systems are made compatible with one another through the interface, that is - (change example) Modbus interface.

## Internet address

**IP address**

## Interpolation

The trend display and the representation therein between two captured values can appear in three varying forms: with no interpolation (whereby only the data point is shown), as a line connecting two points, or as a staircase.

## Invisible

Attribute of an area in the graphic editor. Such an area has no color, but is invisible, that is transparent.

## IP address

Address of an Ethernet subscriber in accordance with TCP/IP. Every Ethernet subscriber is assigned an IP address.

## Junction

Graphical representation of a **(project object)** in the project tree, indicating the object’s state.

## Keyboard

Input device of operator and engineering station. Standard AT keyboard layout (MF2). Keyboards to IP 65 available on request.

## Laptop

Portable personal computer. Preferably used for engineering station.
<table>
<thead>
<tr>
<th><strong>Level</strong></th>
<th>The project’s structure is provided by the levels in the project tree. Project objects of the same type are all held on the same level.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>License options</strong></td>
<td>The license options specify the range of functions which the currently-installed version of DigiVis 500 Graphics Builder is entitled to use. * hard key.</td>
</tr>
<tr>
<td><strong>Limit value</strong></td>
<td>Limit values form one of the basis for generating alarm messages. Limit values are thus declared in the operation interface and/or in a log, that is when a particular value is exceeded). Particular events are specified depending on the type of limit value. The message is generated with, amongst other attributes, a specific priority and a message text.</td>
</tr>
<tr>
<td><strong>Line attribute</strong></td>
<td>The attributes of a line are its color, weight, line type, line start and end and the corner style. The border color of graphic symbols can also be changed in the context of making them dynamic.</td>
</tr>
<tr>
<td><strong>Line start / end</strong></td>
<td>Attribute of graphic object line. It is displayed either with or without an arrow (optional).</td>
</tr>
<tr>
<td><strong>Line style</strong></td>
<td>Attribute of the graphic object line. The line or border color can be displayed either as dashes, semicolons or a continuous line.</td>
</tr>
<tr>
<td><strong>Line type</strong></td>
<td>Attribute of graphic objects. The line or border color can be displayed either as dashes, semicolons or a continuous line.</td>
</tr>
<tr>
<td><strong>Load</strong></td>
<td>Transfer of programs or sections of programs in commissioning that have passed the plausibility check without revealing any errors. In addition the objects or levels in the project tree are selected and transferred automatically to the assigned resource by the load procedure.</td>
</tr>
<tr>
<td><strong>Log type</strong></td>
<td>Three different types of logs are provided: the signal sequence log (SSL, SSLN), operation log (OPL)</td>
</tr>
<tr>
<td><strong>Logs</strong></td>
<td>Logs are used for documenting events, states and sequences from the process. The data they capture can be saved on the hard disk in the operator station, printed out on the printer or displayed on the monitor.</td>
</tr>
<tr>
<td>Glossary Item</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Long text</td>
<td>A text entry up to 30 characters in length for providing a brief description of a function block or preconfigured display.</td>
</tr>
<tr>
<td>Macro</td>
<td>A graphic symbol composed of one or more graphic objects or symbols that share a common name. This unit can be used over and over again and can be retrieved from the macro pool and saved in a macro library.</td>
</tr>
<tr>
<td>Macro libraries</td>
<td>Project-independent collection of macros, created using the graphic editor and copied from the macro pool into the library.</td>
</tr>
<tr>
<td>Macro pool</td>
<td>The collection of all the macros in the project. The macros in the pool can be copied into a macro library from where they can be used in other projects.</td>
</tr>
<tr>
<td>Mandatory parameters</td>
<td>Mandatory parameters are essential details of function blocks such as tag name, scale start and scale end, and the link with an input or output variable such as process value, controller correcting variable or other function-specific parameters.</td>
</tr>
<tr>
<td>Manual</td>
<td>Operating mode in which the tag can be operated from within DigiVis.</td>
</tr>
<tr>
<td>Media Colors</td>
<td>Contain Colors that flash of their own accord.</td>
</tr>
<tr>
<td>Message</td>
<td>Certain process states and/or events can be configured as messages. When that event occurs a message is then sent to the operator station. Such messages are configured in the OPC Server or can originate in the operator station.</td>
</tr>
<tr>
<td>Message box</td>
<td>The message boxes in the message line contain the first five still-to-be-acknowledged messages with priority 0 to 3.</td>
</tr>
<tr>
<td>Message Colors</td>
<td>Colors for message display.</td>
</tr>
<tr>
<td>Message filter</td>
<td>Definition of which message priorities are displayed in the message list.</td>
</tr>
<tr>
<td>Message line</td>
<td>The message line forms part of the operation interface and is included above every display on the operator station. The message allows the operator to log the most recently received messages without having to switch to the message list.</td>
</tr>
</tbody>
</table>
Appendix A  Glossary

Message list  
In the message list the messages sent from the OPC Server and system messages from the engineering station to the operator station are displayed and managed.

In the message list a message can be selected and/or acknowledged, and the display assigned to a message can also be called up through the display selection dialog. In this way one can quickly obtain detailed information relating to the selected message.

Message order  
Definition of the position of the newest message in the message list. Thus, when set to ‘Display newest message at top’, any newly-arrived message will appear at the top of the message list.

Message overflow box  
A box in the message line used to indicate that the message line contains more than 5 messages.

Message page  
A page from the message list that can be displayed on the operator station.

Message priority  
5 different priority levels are used, with priority 0 being reserved for system errors, 1 to 3 for fault messages and 4 for switch messages.

Message text  
Additional output text of a message in the message box and in the message list.

Message types  
In DigiVis 500 messages are subdivided into the following message types based on their significance for the process: system errors, fault messages and switch messages.

Monitor resolution  
Number of pixels that can be displayed on the monitor. The recommended monitor resolution for DigiVis 500 Operations is 1280 x 1024.

Mouse  
Hand-operated device used for moving the cursor around on the screen. The left-hand mouse button is used for selecting objects from the graphic display. The right-hand mouse button enables the display selection dialog in DigiVis 500 to be operated.

Multicolored  
Area attributes setting through which the colors of the static graphic symbol are adopted when the symbol is made dynamic.
### Appendix A Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>In the graphic editor a symbol name can be assigned to a graphic object. Names are textual labels for objects within the project. A name should be unique within the project, and every object must be given a name.</td>
</tr>
<tr>
<td>Natural sequence</td>
<td>Sort criterion that lists the variables or tags in chronological order of configuration.</td>
</tr>
<tr>
<td>Network</td>
<td>Function in the hardware structure which allows the station numbers and IP addresses on the system bus (Ethernet/TCP/IP) to be viewed and configured.</td>
</tr>
<tr>
<td>Network address</td>
<td>IP address*</td>
</tr>
<tr>
<td>Network board</td>
<td>Plug-in Ethernet card in the PC for connecting to the system bus.</td>
</tr>
<tr>
<td>Object list</td>
<td>A list of all the selected project objects.</td>
</tr>
<tr>
<td>On line</td>
<td>Commissioning is an operating mode of DigiVis 500 Graphics Builder, which works only with an on line connection to the DigiVis 500 operator stations.</td>
</tr>
<tr>
<td>Operation dialog</td>
<td>Operation of a display or point of measurement is enabled through the dialog area. Clicking the right mouse button in the operation line toggles between the operation dialog and the display selection dialog.</td>
</tr>
<tr>
<td>Operation log</td>
<td>Cyclical, manual or event-related logging of up to 200 variables within a configurable text.</td>
</tr>
<tr>
<td>Operator</td>
<td>The person who holds responsibility at any given point in time for controlling process events through the control system.</td>
</tr>
<tr>
<td>Operator action</td>
<td>An operator action is an action on the part of the operator through which a process state or process value is changed from the operator station.</td>
</tr>
<tr>
<td>Operator interface</td>
<td>The operation interface is the sum of all the display objects and operating objects at the operator station.</td>
</tr>
</tbody>
</table>
### Appendix A  Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator intervention</td>
<td>Intervention in the process by the operator. An operator intervention can only be carried out if the access parameter has been set to ‘Yes’ for this task. Furthermore, the operating rights for the operator currently logged in must be allocated.</td>
</tr>
<tr>
<td>Operator station</td>
<td>PC with MS Windows and DigiVis 500 Operations software. Used for operation and monitoring, alarms, trends, archives and reports.</td>
</tr>
<tr>
<td>Overlap</td>
<td>Function of the graphic editor for moving graphic objects either to the foreground or the background when they are overlapping one another.</td>
</tr>
<tr>
<td>Overview display</td>
<td>Preconfigured display for quick selection of displays and/or logs.</td>
</tr>
<tr>
<td>Page layout</td>
<td>Specification of the output format of a log.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Parameters are configurable attributes effecting the processing of DigiVis 500 displays and logs.</td>
</tr>
<tr>
<td>Parameter mask</td>
<td>Dialog window through which parameters can be entered and modified.</td>
</tr>
<tr>
<td>Plausibility check</td>
<td>A project tree function whereby only those project objects that have not yet satisfied a plausibility check are checked. The state Correct is a requirement for the subsequent commissioning of the project. Incorrect project objects are displayed in the color selected for this purpose.</td>
</tr>
<tr>
<td>Plausibility check errors</td>
<td>Any errors detected by the plausibility check on the selected project objects that render commissioning impossible are displayed together in the error list. Along with the plausibility check errors, warnings are also issued in the case of less serious problems.</td>
</tr>
<tr>
<td>Points</td>
<td>Design points for the graphic objects line and polygon can be repositioned, deleted or added.</td>
</tr>
<tr>
<td>Pool</td>
<td>An area of the project tree containing incorrect project objects or project objects that are no longer required in the sequence but which one might want to reintroduce into the process under certain circumstances.</td>
</tr>
</tbody>
</table>
### Appendix A Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>The position of graphic symbols can be shifted either continuously or in discrete steps within the display area according to an analog variable.</td>
</tr>
</tbody>
</table>
| Preconfigured display | Along with the free graphic displays created using the graphic editor there is also a series of preconfigured displays; to display these in DigiVis 500 Operations you only need to configure a tag and a few parameters.  
The preconfigured displays in DigiVis 500 are the overview display, group displays, trend displays and system display. The faceplates for each tag and the logs can also be displayed without any need for further configuration. |
| Print job             | The output of documentation is always controlled by a so-called print job, that is there must always be a job selected before printing. The content of the print task is defined in this job.                               |
| Printer               | Printers can be connected to the operator and to the engineering station. Different printer types can be used; inkjet printer (b/w or color), depending on the requirements.                                   |
| Printer setup         | Printer selection, setting of options, see also Windows Print Manager.                                                                                                                                      |
| Project documentation | All the components of a project can be documented directly. This is achieved by assembling the required documentation types in a documentation job.                                                            |
| Project name          | A single project name is assigned to all the various parts of the user program. This project name will be used later for documentation purposes and also forms the file name for configuration.             |
| Project object        | The smallest unit of a project that can be loaded on the operator station is a project object. Some of these project objects are visible, such as: configuration and resources.  
There are also invisible objects such as process image, variables and messages. |
| Project tree          | An organizational tool used for structuring a project in the form of a tree.                                                                                                                                  |
Project version  The project version is made up of three parts as follows: Part 1 (major) states the number of bootstraps; Part 2 (minor) is incremented by 1 every time program sections are loaded; Part 3 (patch) states how often parameters have been corrected. All three parts can be read through system variables.

Radio button field  A dynamic symbol from the graphic editor allowing up to 25 values to be preset by selecting a radio button.

Redundancy transfer  A transfer has taken place between the active and passive CPU module / between the active and passive AC 800F. A redundancy transfer is ‘bumpless’, that is all the states in the user program are maintained.

Reference point  Coordinates of a static/dynamic display object in a graphic display with particular related functions such as mirroring.

Reference window  The reference window is a rectangular screen region containing information on the graphic display and is the same size as a faceplate in DigiVis 500 Operations.

Reflect  Function of the graphic editor whereby one or more graphic objects can be displayed as either a horizontal or vertical mirror image.

Report  Reports are used to acquire and store data in user defined MS Excel templates.

Report printer  The report printer is the printer connected to the operating station. A maximum of 2 printers can be connected to one operator station.

Resource  → D-OS or VIS resource, OPC Server

Rotate  Graphic editor function whereby one or more graphic objects are turned through 90 degrees counter-clockwise about the point central to the design points.

Save  Saving is the transaction whereby changes are saved in the project database or project file.
### Appendix A  Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>The Save As facility enables changes to be saved under a different project name.</td>
</tr>
<tr>
<td>Screen</td>
<td>An alternative term for the operator station monitor, which can be used for operating tasks.</td>
</tr>
<tr>
<td>Security Lock</td>
<td>Software package for the engineering station which enables access rights to be configured for specific user groups on the operator station.</td>
</tr>
<tr>
<td>Selection</td>
<td>Operating technique from the operation interface. Selection is used to activate displays or to select tags for operation.</td>
</tr>
<tr>
<td>Selection area</td>
<td>A dynamic symbol from the graphic editor. The selection area can be used to configure display calls. By selecting a selection area in DigiVis, the tag entered is called up or the current display on the operator’s screen is replaced.</td>
</tr>
<tr>
<td>Selection list</td>
<td>Selection lists provide a way of accessing the project database in order to insert variables,</td>
</tr>
<tr>
<td>Short comment</td>
<td>A text entry in a project object’s header which may be up to 159 characters in length. Unlike the fuller comment for a project object, only short comments can be entered here.</td>
</tr>
<tr>
<td>Short term archive</td>
<td>When a trend display is selected, the short-term archive for the individual signals is displayed first. The short-term archive holds 200 values, that is max. 6 x 200 values per trend display. For older values the system will then automatically return to access the archive file.</td>
</tr>
<tr>
<td>Short text</td>
<td>A text entry up to 12 characters in length as a brief description of a function block or preconfigured display.</td>
</tr>
<tr>
<td>Side effects</td>
<td>A configuration change which effects other project elements is said to have side effects</td>
</tr>
<tr>
<td>Signal colors</td>
<td>Special signal colors are made available in the graphic editor’s color table to enable event states to be displayed consistently in the operation interface.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Signal sequence log</td>
<td>Configurable logging of system errors, fault messages, switch messages</td>
</tr>
<tr>
<td></td>
<td>and operator actions.</td>
</tr>
<tr>
<td>Signal sequence log 1</td>
<td>Logging of system errors, fault messages, switch messages and operator</td>
</tr>
<tr>
<td></td>
<td>actions with continuous printing.</td>
</tr>
<tr>
<td>Signal sequence log N</td>
<td>Logging of system errors, fault messages, switch messages and operator</td>
</tr>
<tr>
<td></td>
<td>actions, recording these in a log file.</td>
</tr>
<tr>
<td>Software error</td>
<td>An error has occurred in the software that is preventing normal process-</td>
</tr>
<tr>
<td></td>
<td>ing.</td>
</tr>
<tr>
<td>Sort</td>
<td>Lists can be re-ordered through sorting.</td>
</tr>
<tr>
<td>Sort criterion</td>
<td>The sorting order is defined by the sort criterion. Sorting can be per-</td>
</tr>
<tr>
<td></td>
<td>formed in configuration order (the natural order) or by individual col-</td>
</tr>
<tr>
<td></td>
<td>umns.</td>
</tr>
<tr>
<td>Sound board</td>
<td>Plug-in card for a PC that plays back acoustic files (wave files).</td>
</tr>
<tr>
<td>Start characteristics</td>
<td>Definition of the response of the system software at system startup.</td>
</tr>
<tr>
<td>State line</td>
<td>The state line shows the name of the program running and its current</td>
</tr>
<tr>
<td></td>
<td>plausibility state. The status 'plausible' is only assigned if the pro-</td>
</tr>
<tr>
<td></td>
<td>gram has been checked for plausibility without any errors resulting. If</td>
</tr>
<tr>
<td></td>
<td>Security Lock is installed, then the user name will also be displayed.</td>
</tr>
<tr>
<td>State log</td>
<td>The function of state logs is to record process states cyclically. This</td>
</tr>
<tr>
<td></td>
<td>includes the cyclical logging of the state of a tag or the logging of</td>
</tr>
<tr>
<td></td>
<td>sequences in the process.</td>
</tr>
<tr>
<td>Static colors</td>
<td>General colors from the graphic editor’s color palette.</td>
</tr>
<tr>
<td>Subnet mask</td>
<td>Masking in the main network for a possible lower-level network.</td>
</tr>
<tr>
<td>Switch message</td>
<td>Priority 4 message (yellow) for reporting switching events such as Pump</td>
</tr>
<tr>
<td></td>
<td>On; not to be confused with a fault message.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>System bus</td>
<td>All stations are linked through the system bus. This system bus is based on the Ethernet standard with the TCP/IP transfer protocol.</td>
</tr>
<tr>
<td>System log</td>
<td>Archive file in which all actions on the engineering station are logged.</td>
</tr>
<tr>
<td>System message</td>
<td>System errors have the top priority of 0. Messages with this priority cannot be either configured or changed by the user. System errors generate messages about error states in the system itself.</td>
</tr>
<tr>
<td>System time</td>
<td>The system time is synchronized for all stations. The system time can be set throughout the entire system from the engineering station.</td>
</tr>
<tr>
<td>Tag</td>
<td>A tag is a grouping of related OPC items. Tag types are used to instantiate tags out of the OPC item list.</td>
</tr>
<tr>
<td>Tag list</td>
<td>All the tags that are instantiated in the system are listed in the tag list.</td>
</tr>
<tr>
<td>Tag Type</td>
<td>Tag Type are used to instantiate tags out of the OPC item list.</td>
</tr>
<tr>
<td>Tag Type Library</td>
<td>The Tag Type Library [TAG-LIB] is the container for preconfigured Tag Types.</td>
</tr>
<tr>
<td>TCP/IP</td>
<td>Transmission protocol for Ethernet system bus. In accordance with layers 2 to 4 of the ISO/OSI seven-layer model.</td>
</tr>
<tr>
<td>Text attributes</td>
<td>Describes the format in which text appears. Font size, font, text orientation and colors can all be selected.</td>
</tr>
<tr>
<td>Time synchronization</td>
<td>Time synchronization of the stations are done as per standard windows time synchronization. OPC Server time stamps the messages that originate from it.</td>
</tr>
<tr>
<td>Trend</td>
<td>A trend is used to represent values in graphical form using a time axis. The values are acquired from OPC Server and then transferred to the operator station.</td>
</tr>
<tr>
<td>Trend display</td>
<td>The trend display is used to display values graphically using a time axis. A maximum of 6 trends can be shown in one trend display.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Trend window</td>
<td>Trend display on the engineering station that, like the value window, can be called up when in commissioning mode.</td>
</tr>
<tr>
<td>Undo</td>
<td>This function, which appears under Edit, can be used to reverse the last change, that is deletion of an object).</td>
</tr>
<tr>
<td>Value</td>
<td>Numeric value of a variable that must be entered in a specific format depending on data type.</td>
</tr>
<tr>
<td>Value window</td>
<td>Display in the commissioning phase allowing several variables in a variety of numeric formats to be displayed together.</td>
</tr>
<tr>
<td>Variable</td>
<td>A simplified presentation of the OPC Item as it is provided by the OPC Server can be assigned to a variable for further usage in the Graphics Builder configuration.</td>
</tr>
<tr>
<td>Variable list</td>
<td>The variable list contains all the variables assigned to a system.</td>
</tr>
<tr>
<td>Variable window</td>
<td>A dialog within commissioning that enables one or more variables to be allocated to the value display or trend display.</td>
</tr>
<tr>
<td>Version control</td>
<td>This information is used internally by DigiVis 500 Graphics Builder to ensure that the Engineering PC and the Operators PC have the same version of the project and on each download the same instance of the DigiVis 500 Graphics Builder is used to load the project into a particular operator station.</td>
</tr>
<tr>
<td>Version error</td>
<td>There could be discrepancies in the program between the Engineering PC and the Operators PC. These version differences are reported irrespective of the resource’s run state, in other words even when it is Stopped.</td>
</tr>
<tr>
<td>Visual acknowledgment</td>
<td>Only the messages in the message line are acknowledged. The message itself remains in the message list and must also be acknowledged there.</td>
</tr>
<tr>
<td><strong>Warning</strong></td>
<td>Errors detected during the plausibility check of project objects that are not serious enough to prevent execution; the objects, however, are either incompletely configured or could be configured more simply.</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Write</strong></td>
<td>Transaction from DigiVis 500 Operations or the engineering station whereby a modified parameter from a tag is written to the OPC Server. Unlike correction, such changes are not saved in the project file.</td>
</tr>
<tr>
<td><strong>Zoom</strong></td>
<td>4 zoom levels are provided in the DigiVis 500 graphic editor, each of these levels displaying the selected zoom region with greater magnification than the preceding level.</td>
</tr>
<tr>
<td><strong>Zoom region</strong></td>
<td>The zoom region is used to select the screen region to be displayed in the graphic editor’s display area.</td>
</tr>
</tbody>
</table>
Index

A

A (Column) 219
ABA 219
Access rights 53, 54
Acknowledgment 245
   From message line 245
   From message list 245
Acknowledgment of messages 244
Acquisition of variables 266
AutoCAD color conversion 383

B

Background color of a graphic display 285
Backup file 25
Block
   Export 51
   Import 51

C

Check 74
   Graphic display 380
Color groups, Graphic editor 287
Color selection for graphic objects 286
Colors 79
Comment 206
Commissioning 81
   Project tree 86
Commissioning/Configuration (changeover) 86
Common display pool 43
Communications connections 59
Compress 48
CONF 43
Configuration 43

CONF 57
Cross references 235
Cross-references 214
CSV (comma separated values). 217

D

Data Types (Variable list) 203
Daylight saving time 58
Define debug windows 100
Demo mode 16
D-GS resource 60
Diagnostic password 62
Display access
   Call up 256
   Configuring 257
Display pool
   Show target station 55, 70
Document types 146
Documentation 108
   Changing the column width 110
   Cover page 123
   Crossreference
      Tags 133
      Variables 129
Documentation settings 125
Drawing footer 114
Drawing header 114
Header title 116
Index 124
Manager 109
Menu Structure 110, 111
Scope 122, 138
Tags list 131
Index

Variables list 127
D-OS 43
D-OS resource 60
D-POOL Global display pool 60
D-PS resource 60
Draw area in the graphic editor 281

E

Edit field 212
Edit list entries 210
Editing of graphic objects 365
Editing the project header 30
Enable/disable file transfer 195, 412
Error list 77
Expand 48
Export 230
  Backup 25
  Graphic display to a file 381
  Graphic display to clipboard 381
  Project 25
Export backup 25

F

Fault message 243
FGR 44
Field contents 157
Field names
  drawing footer 149
  drawing header 149
Field titles 148
Flash rate 62
Free colors, Graphic editor 287
Full expand 48

G

Global display pool D-POOL 60
GMT 94
Graphic display 44, 71
Graphic editor interface 278
Graphic macro 44

Standard library 389
Graphic macro pool 43, 44
Graphic macros 72
Graphic object
  Alphanumeric display 328
  Arc 293
  Bar graph 325
  Button 342, 349
  Button field 342, 349
  Dynamic objects 298
  Ellipse 291
  Fill area 327
  Graphic symbol 333
  Macro 352
  Polygon 291
  Polyline 290
  Radio button field 342, 349
  Self-animated object 335
  Static objects 287
  Text 292
  Trend window 336
Graphic object editing
  Background objects 308
  Bit allocation 302
  Button field parameters 346
  Button for button field or radio button field 348
  Button parameters 344
  Change attributes 372
  Color groups 287
  Color selection 286
  Color table
    Graphic symbol 334
    Self-animated object 335
Copy 368
Cut 367
Display 304
Foreground objects 308
Foreground/Background 369
Free colors 287
General parameters for dynamic objects 298
Graphic symbol
    Discrete move 333
    No move 333
Group 367
Media colors 287
Menu overview 365
Message colors 287
Objects
    Group 367
    Select object in background 366
Overlap 369
Points
    Deleting 375
    Moving 375
Radio button field parameters 347
Reedit graphic object 350
Scale
    Bar graph 301
    Fill area 301
Self-animated object
    Fast/slow 335
    On/off 335
    Visible/invisible 335
Signal colors 287
Size of a graphic object 362
State change 302
Static colors 287
Trend data parameter setting 339
Trend window parameters 337
Ungroup 367

Graphic pool 371
Graphics editor
    Activate snap 284
    Animate 296
    Background color 285
    Check graphic display 380
    Copy graphic display 384
    Delete graphic display 384
    Display 378
    Draw area 281
Dynamic objects 298
    of graphic display 350
Exit 384
Export a graphic display
    to a file 381
    to the clipboard 381
General processing functions 380
Graphic editor interface 278
Hardcopy 283
Import graphic display 381, 382
Limiting the draw area 285
Menu overview 280
Redraw graphic 379
Rename graphic display 384
Save graphic display 380
Select zoom level 379
Show grid 284
Simulation 378
Standard macro library 389
Static objects 287
Status line 283
Threaded cursor 285
Toolbox 281
    Show / hide 284
Update display size 285
View display 378
Visible region 379

Group display 44, 71
Create 263
Group-specific rights (Security Lock) 32
GRP 44

H

Hardcopy 78
    in the graphics editor 283

I

Import
    AutoCAD file 382
    Backup 27
Graphic display 381
Project 27
Import AutoCAD files 382
Importing a backup 27
Incorrect objects 74

Limiting the draw area 285
Load
  Message configuration 96
  selected objects 96
Local message processing 246
Local time 93
Logs
  General description 403
  Headers and footers 422
Long text 219

MAC 44
Macro edit mode 355
Media colors, Graphic editor 287
Menu Structure 110
Menu structure 40
Message colors 243
Message colors, Graphic editor 287
Message fields 241
Message Filters 245, 251
Message line
  display 239
  Message order 250
  Parameter settings 250
Message List 247
  Message order 250
  Parameter settings 247
  Structure 242
Message list nominal level 247
Message types 243

New print job 121
No initial variable/tag filter 79
Node 89
Nodes 41
Normal view 220, 221

Objects of the resource 91
OPC address 206
OPC server 43, 63
OPC server resource 60
OPC-S 43
Operate IT CS resource 60
Operator actions 408
Operator plant log 44, 71
Operator Station 43
Operator station programs
displays and logs 71
OPL 44
Overview display 44, 71
  Create 260
  New 189, 404, 414
OVW 44

P-CD 43
P-FB pool of user FBs 60
Plant areas 219, 245
Plausibility check 75
P-MAC 43, 72
Pool 43, 52
Pool of graphic macros 43, 72
Pool of user FBs P-FB 60
Positive-displacement algorithm 247, 248
Print 140
Print job 108
Priority levels 243, 245
Programs, displays and logs 71
Project
Close 29
Creating new 20
Delete 30
Export 25
Import 27
Open 24
Save 29
Project documentation 73
Project manager menu structure 18
Project objects 41
  moving, deleting 48
Project tree
  Search 47

R
Related documentation 14
Resource
  D-GS 60
  D-OS 60
  D-PS 60
  OPC server 60, 63
  Operate IT CS 60

S
Search
  Project tree 47
Security Lock access right 32
Security Lock password 32
Short text 219
Show target station 55, 70
Show trend window 105
Show value window 104
Side effects 97
Signal colors, Graphic editor 287
Signal sequence log 71
  File transfer 195, 412
  Signal sequence log 1 44
  Signal sequence log N 45
Sort 221
Sound board 252
SSL1 44
SSLN 45
Starting the Project 15
Static colors, Graphic editor 287
Station view 220, 221
Status line 39
  Graphics editor 283
  Project tree 19, 40
String variables 204
STRUCT 44
Structure node 44, 72
Structure node (STRUCT) 72
Switch message 243

T
Tag list
  Area 219
  Column A 219
  Column C 219
  Column P 219
  Library type 219
  Long text 219
  Name 218
  Object type 219
  Plausibility state 219
  Short text 219
Tag name 218
Threaded cursor 285
Time scheduler display
  Create 275
Time zone 58
Time-stamp variable 267
Toolbar buttons 35
Toolbox in the graphic editor 281, 284
TR_D-OS 44
Trend data acquisition 266
Trend data acquisition block 266
Trend display 44, 71
  Create 265
Trend variable 267
Type 161, 206
Type of tag list entry 219

U
Update display size 285
User groups
  Configuration 54

V
Variable description 268
Variable list 203
  Comment 206
  OPC address 206
  Structure 160, 205, 206
  Type 161, 162, 206
Variable name 161, 162, 206
Variables for drawing footer 152
Version check 90
Visual acknowledgment 245