Motor control and protection unit
MCUSetup user guide
# Table of contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>4</td>
</tr>
<tr>
<td>Target group</td>
<td>4</td>
</tr>
<tr>
<td>Use of warning, caution, information and tip icon</td>
<td>4</td>
</tr>
<tr>
<td>Terminology</td>
<td>5</td>
</tr>
<tr>
<td>Related documentation</td>
<td>6</td>
</tr>
<tr>
<td>Related software version</td>
<td>6</td>
</tr>
<tr>
<td>Document revision history</td>
<td>6</td>
</tr>
<tr>
<td><strong>Overview</strong></td>
<td>7</td>
</tr>
<tr>
<td><strong>Installation</strong></td>
<td>8</td>
</tr>
<tr>
<td><strong>Configuration</strong></td>
<td>11</td>
</tr>
<tr>
<td><strong>Using MCUSetup</strong></td>
<td>14</td>
</tr>
<tr>
<td>Program/modify and read/write parameters of MDx</td>
<td>15</td>
</tr>
<tr>
<td>Program/modify parameters of M10x</td>
<td>16</td>
</tr>
<tr>
<td>Import/export parameters files from/to disk</td>
<td>19</td>
</tr>
<tr>
<td>Access/update values from/to M10x unit</td>
<td>20</td>
</tr>
<tr>
<td>Read the serial number of M10x</td>
<td>21</td>
</tr>
<tr>
<td>Operator panel simulator</td>
<td>21</td>
</tr>
<tr>
<td>Printing of parameter setting</td>
<td>21</td>
</tr>
<tr>
<td><strong>User management</strong></td>
<td>22</td>
</tr>
<tr>
<td><strong>Trouble Shooting</strong></td>
<td>23</td>
</tr>
<tr>
<td><strong>Parameterization aid</strong></td>
<td>26</td>
</tr>
</tbody>
</table>
General

Target group
The objective of this user manual is to provide the technical information for MCUSetup. This manual should be studied carefully before parameterizing or operating the motor control unit. It is assumed that the user has a basic knowledge of control, protection, monitoring and communication functions.

This document should be used along with M10x parameter description, which provides detailed information about parameters and their applications.

Use of warning, caution, information and tip icon

This publication includes Warning, Caution, and Information icons where appropriate to point out safety related or other important information. It also includes Tip icons to point out useful hints to the reader. The corresponding symbols should be interpreted as follows:

- The electrical warning icon indicates the presence of a hazard that could result in electrical shock.
- The warning icon indicates the presence of a hazard that could result in personal injury.
- The caution icon indicates important information or warnings related to the concept discussed in the text. It might indicate the presence of hazard that could result on corruption of software or damage to equipment/property.
- The information icon alerts the reader to pertinent facts and conditions.
- The tip icon indicates advice on, for example, how to design your project or how to use a certain function.

Although Warning notices are related to personal injury, and Caution notices are associated with equipment or property damage, it should be understood that the operation of damaged equipment could, under certain operational conditions, result in impaired process performance leading to personal injury or death. It is, therefore, imperative that you comply fully with all Warning and Caution notices.
## Terminology
List of terms, acronyms, abbreviations and definitions used in the document:

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CD</td>
<td>Compact disc</td>
<td>A compact disc (also known as a CD) is an optical disc used to store digital data.</td>
</tr>
<tr>
<td>CD-ROM</td>
<td>Compact disc read only memory</td>
<td>CD-ROM is a pre-pressed compact disc that contains data accessible to, but not writable by, a computer for data storage and music playback.</td>
</tr>
<tr>
<td>PC</td>
<td>Personal computer</td>
<td>A computer whose original sales price, size, and capabilities make it useful for individuals.</td>
</tr>
<tr>
<td>USB</td>
<td>Universal serial bus</td>
<td>USB is a specification to establish communication between devices and a host controller (usually personal computers).</td>
</tr>
</tbody>
</table>
Related documentation
1TNC 911105  M10x Parameter Description
1TNC 911107  M10x Parametering Cable Driver Installation Guide

Related software version
The content of this document is related to MCUSetup V5.4.
The described functions are designed but may not be fully implemented in all details. Please refer to the current system guides and release notes regarding possible restrictions.

Document revision history

<table>
<thead>
<tr>
<th>Revision</th>
<th>Description of change</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>M0201</td>
<td>First issue</td>
<td>10/2003</td>
</tr>
<tr>
<td>M0202</td>
<td>Update for the combination of M10x-P and M10x-M version</td>
<td>06/2006</td>
</tr>
<tr>
<td>M0203</td>
<td>Update to new template</td>
<td>10/2010</td>
</tr>
<tr>
<td>M0204</td>
<td>Released for M10x products with new hardware</td>
<td>01/2013</td>
</tr>
<tr>
<td>M0205</td>
<td>Released for MCUSetup version 5.1</td>
<td>07/2013</td>
</tr>
<tr>
<td>M0206</td>
<td>Release for MCUSetup version 5.4</td>
<td>09/2016</td>
</tr>
</tbody>
</table>
Overview

MCUSetup is a PC-based software that operates in a Win2K/XP/Win7/Win8 environment to set parameters of motor control Unit (M10x).

MCUSetup software can run online and offline. When it is run offline, files can be saved to local disk for online uploading.
System requirements

- **Software requirements**

  MCUSetup requires Microsoft Windows 2000, XP, Win 7 or Win8 as its operating system.

- **Hardware requirements**

  MCUSetup requires a PC with a 80486 (or higher) processor and at least 8 MB of RAM.

  MCUSetup occupies approximately 10 MB of memory on the hard disk. Ensure that there is enough free memory on the hard disk to store the configuration data.

  A VGA monitor or other monitor with a screen resolution >= 800 x 600, supported by Microsoft Windows is required.

  A printer must be available for printing parameters. All graphic printers supported by Windows are suitable.

Installation of MCUSetup:

1) Log in with the account that has authority to install software.
2) Insert the CD into the CD-ROM drive.
3) Click **Install MCUSetup** to run the installation program.
• Click **Next**.

• Choose the destination folder for MCUSetup files, and click **Next**.
Click **Install**.

Click **Finish** to exit the Setup Wizard.
Configuration

Configuring MCUSetup
Connect the RS232/485 converter module to the communications port via USB port. Plug the mini-USB port plug into parameterization port in the MD front panel. Plug the USB into the USB port of the computer.

The converter kit for parametering described above must be installed with driver before preparing for parameterization. For more details, please refer to the document: Programming cable driver install guide.

1) Start the MCUSetup software. The M10x to PC communications status is displayed on the bottom right of the MCUSetup window.

2) To configure communications, select the Tools > Communication > Com Setting menu item. The communication settings window appears, containing the various communications settings for the local PC. Modify these settings and click OK to return to the main screen.

3) To select another communication port, disconnect the communication by select the Tools > Communication > Interrupt menu item before selecting the Tools > Communication > Com Setting menu item. After modification is complete, select the Tools > Communication > Buildup menu item to establish the communication.
Description of menus and icons

File
- New
- Save
- Import
- Export
- Create a new parameters file
- Save parameters to the file
- Load the parameters from a file
- Export the parameters to an existing or new file
- Export the parameters to an Excel file
- Print the parameters
- Display a preview on screen
- Change the printer settings
- Log off the user ID in use
- Close this window
- Exit the MCUSetup program

Tools
- Parameter Template
- User Management
- Communication
- MD Simulation
- Select the parameter template of M101 or M102
- Manage user
- Operate the communication port
- Open the operator panel simulator

Parameterisation
- Access
- Update
- ISP
- Read
- Serial No.
- Security
- Clear
- Read
- Time synchronize
- Read parameters from device
- Download parameters to device
- In system program for FW update
- Read serial number from device
- Only the manufacturer can use this function for encryption software.
- Administrator to clear energy, maintenance timer, maintenance hours, thermal capacity
- Read three phase current of last trip, SOE and maintenance
- Time setting

View
- Toolbar
- Status Bar
- Manage display in Toolbar
- Manage display in Status Bar
ISP function is used for updating the firmware of M10x by manufacturer.

Smart icons are buttons that perform specific tasks, such as importing, exporting parameter settings, printing, building up communication, etc. Smart Icon is positioned under menu bar. A flying box is shown to indicate the function when mousing over the icon.
After the successful installation of the software, start the MCUSetup either by clicking the MCUSetup icon on the program group or from the Start menu. As long as the program is activated, a login dialog box shows up.

Click on the **Start** button on the top window to start MCUSetup software for enhanced M10x (1TNA920 xxx), i.e. M10x-M firmware V3.x and M10x-P firmware V5.x.

Click on the **Start** button on the bottom window to start the software for old M10x (1TNA911xxx) and the new hardware (1TNA920xxx) with backwards compatible firmware, i.e. M10x firmware V2.x and M10x-P firmware 4.x.

At the Login window, enter the user ID and password to login as an authorized user of MCUSetup. For the first login, use the default user ID -- Administrator and password -- admin (not case sensitive) and start the MCUSetup with default data.

It is necessary to change the default password for administrator, only by the authorized administrator of MCUSetup. Later the administrator can create the new users. (explanation below).

Be sure to remember the new password. Otherwise, login will be blocked.

Press **OK** to finish the login.
After login, MCUSetup's main screen is displayed:

With MCUSetup running, it is possible to:

- Program/modify and read/write parameters of MDx
- Program/modify parameters of M10x
- Program/modify parameters of AO11
- Import/export parameters files from/to disk
- Access/update values from/to M10x unit
- Operate panel simulator
- Read the serial number of M10x
- Print parameter settings
The following example illustrates how to program or modify parameters from MCUSetup:

1) Running MCUSetup

2) Connect MD with computer via parametering cable

3) Select Tools > MD LED. The following window is shown, allowing the user to set the separate indication color and function for 4 LEDs on MDx.

![MD LED Window](image)

4) Select Tools > MD21 Display option. This window will be displayed, allowing the user to select required display information on LCD of MD21.

![MD Display Window](image)

5) After program/modify, click the Write button to download the parameter to MDx.

6) Click Read button to upload the parameter from MDx.
The following example illustrates how to program or modify parameters from MCUSetup:

1) Running MCUSetup

2) Select the **Tools > Parameter template > M101-M** or select **M101-M** on main screen. The following window is shown, prompting the user for motor information data.

3) For numerical parameters (in the above example, motor power rating and nominal current), click the up/down arrow key at the end of the dialog box to increment/decrement the parameter by its step value. Alternately, click the mouse point anywhere inside the parameter box to display a numerical keypad showing the last value, range and step of the parameter values being modified.

![Numerical Parameter Keypad](image)

Enter the new value by clicking on the numerical keys.

Click **OK** to exit the keypad and keep the new value.

Click **Cancel** to exit the keypad and keep the old value.

4) For parameters requiring a non-numerical value (in the example above, motor ID, type and frequency), for motor ID, enter character through the keyboard directly. As for motor type, user can select single phase or three phase by clicking the radio button. For system frequency, user can select 50Hz or 60Hz by clicking the radio button.

5) Click **Default** button to revert to default values.
The following example illustrates how to program or modify parameters of AO11 from MCUSetup:

1) Running MCUSetup

2) Select the Tools > Parameter template > AO11 or select AO11 on main screen. The following window is shown, prompting the user for motor information data.

3) For numerical parameters (in the above example, Max. and Min.), click the up/down arrow key at the end of the dialog box to increment/decrement the parameter by its step value. Alternately, click the mouse point anywhere inside the parameter box to display a numerical keypad showing the last value, range and step of the parameter values being modified.

Enter the new value by clicking on the numerical keys. Click OK to exit the keypad and keep the new value. Click Cancel to exit the keypad and keep the old value.

4) For parameters requiring a non-numerical value (in the example above, AO type) user can select 0-20mA or 4-20mA by clicking the radio button.

5) Click Default button to revert to default values.
To export parameters of the device being parameterized to an MCU file for later use:

1) Select the **File > Import** menu item.

2) MCUSetup launches the **Open** window. Select the folder which contain parameters files (*.mcu). Then select a parameter file from which parameters are to be imported. When the user clicks Open the parameters will be imported.

To import the parameters from an MCU file to the device being parameterized:

1) Select the **File > Import** menu item.

2) MCUSetup launches the **Open** window. Select the folder which contain parameters files (*.mcu). Then select a parameter file from which parameters are to be imported. When the user clicks Open the parameters will be imported.

Select the **File > Save** menu item to keep saving parameters to the existing file.
Select the **Parameterisation > Update menu item**. MCUSetup will prompt to confirm or cancel the parameter update.

Click **Yes** to store the new parameters into the M10x unit’s internal memory. Click **No** to cancel.

If the parameters are received successfully, the successful message will be displayed:

![Successful message](image)

If the parameters are not received successfully, this message will be displayed:

![Failed message](image)

In another case, if the communication is not established, this message will be displayed:

![Communication error](image)

In these instances, the user must update the parameters again. Select the **Parameterization > Access** menu item. The MCUSetup will read the parameters from the M10x and display them in the main window.
To access the operator panel simulator, select the **Tools > MD Simulation** menu item:

MD is the operator panel equipped by M10x as a device accessory. It is used to display the running information of the motor in switchgear level and perform simple controls of the motor, i.e., start and stop, via the buttons.

The MD simulation offers the same functionality as the MD panel, displaying the motor running status and controlling the motor from MCUSetup.

---

**Read the serial number of M10x**

Every M10x device is given a serial number before delivery from the manufacturer. The serial number of the device can be read by selecting the menu item **Serial no > Info**.

---

**Printing of parameter setting**

With MCUSetup’s print tool, the user can specify printer properties, control rendering and adjust size.

1) Select the **File > Print setup** menu item to configure the printer’s properties.

2) Select the **File > Print preview** menu item to display the active document as it would appear when printed. When this command is given, the main window will be replaced with a print preview window in which one or two pages will be displayed in their printed format.

3) Select the **File > Print** menu item to print the parameters.
For the security of control system, the function of user management is provided in MCUSetup tool.

Users are divided into three groups:
- Operator: to examine the parameters
- Manager: to set the parameters
- Administrator: to manage users aside from the manager’s authority

Select the Login > User management menu item, to display the following dialog box:

1) Create new user
   Click the Create button, and the user information dialog box will appear:

   Enter the username and password, select the authority of the user, then click OK to save the user information. Only an authorized user can perform this operation.

2) Edit user information
   Select the user to be changed from the list of users. This shows a notebook view and displays the permission currently assigned. The user can change the user ID, password and permission, and save changes. Only an authorized user can perform this operation.

3) Delete user
   Select the user to be deleted from the list of users. Click Delete to delete the user. Before deleting the user, the user will get a message prompting for confirmation. Only an authorized user can perform this operation.
A fault message window indicates abnormal application on MCUSetup. More fault causes can be identified and corrected using this information.

<table>
<thead>
<tr>
<th>Fault message</th>
<th>What to do</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="MCUSetup" /></td>
<td>The user id or the password entered is incorrect. Check the user ID and password.</td>
</tr>
<tr>
<td><img src="image2.png" alt="MCUSetup" /></td>
<td>A user with the given user id already exists. Use another user ID instead.</td>
</tr>
<tr>
<td><img src="image3.png" alt="MCUSetup" /></td>
<td>Communication Problem, Please check the communication port and connection! Check the connection between parameterization cable and MDx.</td>
</tr>
<tr>
<td><img src="image4.png" alt="MCUSetup" /></td>
<td>The connection isn’t ready! Check the connection is build up, make sure that the interrupt icon is light.</td>
</tr>
<tr>
<td><img src="image5.png" alt="MCUSetup" /></td>
<td>The parameter are not transmitted successfully. Check the connection between parameterization cable and MDx.</td>
</tr>
<tr>
<td>Fault message</td>
<td>used by USB parametering cable</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td><img src="image1" alt="MCUSetup" /></td>
<td>Check the FW and HW of MCU and make sure that the connected MCU is M10x-M FW 3.x or M10x-P FW 5.x.</td>
</tr>
<tr>
<td><img src="image2" alt="MCUSetup" /></td>
<td>Check the FW and HW of MCU.</td>
</tr>
<tr>
<td><img src="image3" alt="Warning!" /></td>
<td>Revise Alarm level to make sure that the value less than or equal to Trip level.</td>
</tr>
<tr>
<td><img src="image4" alt="Warning!" /></td>
<td>Revise Alarm level to make sure that the value more than or equal to Trip level.</td>
</tr>
<tr>
<td><img src="image5" alt="Warning!" /></td>
<td>Revise the input value with the available range.</td>
</tr>
<tr>
<td>Fault message</td>
<td>used by USB parametering cable</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td><img src="MCUSetup.png" alt="Image" /> DI Type must be DC24V! Please reconnect.</td>
<td>Check DI type of MCU.</td>
</tr>
<tr>
<td><img src="MCUSetup.png" alt="Image" /> DI Type must be AC240V/110V Please reconnect.</td>
<td>Check DI type of MCU.</td>
</tr>
</tbody>
</table>
Parameterization aid

For more parameterization details, please refer to the MCUSetup help or M10x’s parameter description file.
Contact us

ABB Low Voltage Systems
Local contacts at
www.abb.com/mns

Argentina
Tel. +54112295500

Australia
Tel. +61297537170

Benelux
Tel. +31104078663

Brazil
Tel. +551124328010

Canada
Tel. +15144203100

China
Tel. +865926038118

Czech
Tel. +420543145111

Denmark
Tel. +4544504450

Egypt
Tel. +20226251300

Estonia
Tel. +3726801800

Finland
Tel. +358102221999

France
Tel. +33388556700

Germany
Tel. +496203712816

Greece
Tel. +302102891807

India
Tel. +918022948905

Italy
Tel. +3903714531

Kazakhstan
Tel. +77272583838

Korea
Tel. +82415292467

Malaysia
Tel. +60356284888

Mexico
Tel. +525536019708

Norway
Tel. +4735582000

Poland
Tel. +48713858300

Qatar
Tel. +97444253888

Russia
Tel. +74957772220

Saudi Arabia
Tel. +96612653030

Singapore
Tel. +6567765711

South Africa
Tel. +27102025000

Spain
Tel. +34934842121

Sweden
Tel. +4621325000

Switzerland
Tel. +41844845845

Thailand
Tel. +6626651000

Turkey
Tel. +902165816800

UAE
Tel. +97143147500

United Kingdom
Tel. +441915144555

USA
Tel. +16174816047