System 800xA Engineering
Engineering Studio Function Designer

System Version 6.0
NOTICE

This document contains information about one or more ABB products and may include a description of or a reference to one or more standards that may be generally relevant to the ABB products. The presence of any such description of a standard or reference to a standard is not a representation that all of the ABB products referenced in this document support all of the features of the described or referenced standard. In order to determine the specific features supported by a particular ABB product, the reader should consult the product specifications for the particular ABB product.

ABB may have one or more patents or pending patent applications protecting the intellectual property in the ABB products described in this document.

The information in this document is subject to change without notice and should not be construed as a commitment by ABB. ABB assumes no responsibility for any errors that may appear in this document.

Products described or referenced in this document are designed to be connected, and to communicate information and data via a secure network. It is the sole responsibility of the system/product owner to provide and continuously ensure a secure connection between the product and the system network and/or any other networks that may be connected.

The system/product owners must establish and maintain appropriate measures, including, but not limited to, the installation of firewalls, application of authentication measures, encryption of data, installation of antivirus programs, and so on, to protect the system, its products and networks, against security breaches, unauthorized access, interference, intrusion, leakage, and/or theft of data or information.

ABB verifies the function of released products and updates. However system/product owners are ultimately responsible to ensure that any system update (including but not limited to code changes, configuration file changes, third-party software updates or patches, hardware change out, and so on) is compatible with the security measures implemented. The system/product owners must verify that the system and associated products function as expected in the environment they are deployed.

In no event shall ABB be liable for direct, indirect, special, incidental or consequential damages of any nature or kind arising from the use of this document, nor shall ABB be liable for incidental or consequential damages arising from use of any software or hardware described in this document.

This document and parts thereof must not be reproduced or copied without written permission from ABB, and the contents thereof must not be imparted to a third party nor used for any unauthorized purpose.

The software or hardware described in this document is furnished under a license and may be used, copied, or disclosed only in accordance with the terms of such license. This product meets the requirements specified in EMC Directive 2004/108/EC and in Low Voltage Directive 2006/95/EC.

TRADEMARKS

All rights to copyrights, registered trademarks, and trademarks reside with their respective owners.

Copyright © 2003-2016 by ABB.
All rights reserved.

Release: September 2016
Document number: 3BDS011224-600 C
# Table of Contents

## About this User Manual
- General ............................................................................................................................ 13
- User Manual Conventions ............................................................................................... 14
  - Feature Pack .................................................................................................................. 14
  - Warning, Caution, Information, and Tip Icons ............................................................ 14
- Terminology ..................................................................................................................... 15
- Released User Manuals and Release Notes .................................................................... 15

## Section 1 - Introduction
- Product Scope .................................................................................................................. 20
- Prerequisites and Requirements ...................................................................................... 21
- Product Verification ......................................................................................................... 22
- Getting Started ................................................................................................................ 23
- Reporting Problems ........................................................................................................ 23

## Section 2 - Configuration
- Function Components and Diagrams .............................................................................. 29
  - Preference Settings ........................................................................................................ 30
  - Object Type Definition and Usage ............................................................................... 36
  - Aspect Properties/Parameters ....................................................................................... 37
  - Defining Function Components (Component View) ...................................................... 52
  - Function Components with XML Type Description (Component View) .................. 54
  - Customizing a Function Component Type ..................................................................... 61
  - Aspect Objects and Symbol Objects ............................................................................ 69
  - Object Type Definition Create Info ............................................................................. 71
  - Inherited Function Components .................................................................................. 74
Cross Communication Procedure .................................................................196
On-line Display ..............................................................................................200
Watch Window ............................................................................................208
Force Dialog ..............................................................................................215
Field Device Integration .................................................................................216
    Introduction ............................................................................................216
    HART Devices ......................................................................................217
    PROFIBUS Devices .............................................................................222
    FOUNDATION Fieldbus .................................................................227
    Error Messages ....................................................................................235
    PROFINET Devices .............................................................................236
    IEC61850 Devices .............................................................................241
Bulk Data Manager Support and Bulk Operations ......................................246
Import / Export (AFW-Files) ........................................................................277
    Export / Import Function Diagram .....................................................277
    Export / Import Application ...............................................................279
    Export / Import IO Allocation .............................................................281
    Export / Import Project .......................................................................282
    Segmentation of AFW-Files ...............................................................283
    Engineering Repository ......................................................................284
    Application Change Management ......................................................285

**Section 3 - Graphic Editor Reference**

Exploring the Windows User Interface ..........................................................287
    Main Window Handling ........................................................................288
    Diagram/Component View ....................................................................288
    Diagram/Component Document Windows ...........................................290
    Dockable Windows/Toolbars ...............................................................292
Changing the Location of Docked Windows/Toolbars ..................................294
Working with Menus ....................................................................................295
    File Menu ............................................................................................296
    Edit Menu ...........................................................................................307
    View Menu .........................................................................................313
Pan ..........................................................................................................................409
Selecting Components .............................................................................................410
Selecting Symbols ....................................................................................................413
Selecting Ports ...........................................................................................................417
Selecting Connections ............................................................................................421
Layout of Components ............................................................................................424
Grid ...........................................................................................................................424
Move ..........................................................................................................................426
Size ...........................................................................................................................428
Align ...........................................................................................................................428
Rotate ..........................................................................................................................430
Flip .............................................................................................................................431
Order ..........................................................................................................................431
Group .........................................................................................................................434
Cut/Copy/Paste/Delete Components ...........................................................................435
Cut and Paste .............................................................................................................436
Copy and Paste .........................................................................................................437
Paste Options ............................................................................................................441
Delete ..........................................................................................................................445
Defining Component Properties ...............................................................................447
Ambient Properties ..................................................................................................447
Component Properties ..............................................................................................454
Default Properties ....................................................................................................477
Layers ..........................................................................................................................483
Layer Properties ........................................................................................................483
Pages ............................................................................................................................486
Measurements and Size ............................................................................................487
Page Setup ..................................................................................................................492
Select Master Page Template ....................................................................................492
Templates and Skeletons ............................................................................................494
Insert/Delete Page .....................................................................................................495
Page Comments .........................................................................................................496
Section 4 - Error Messages

Appendix A - Restored Functionalities

Single Control Modules ................................................................. 525
  Creation of an SCM based Function Diagram ............................... 525
  Implicit Casts ............................................................................ 527
  Connection/Networks ................................................................. 530
  Connection Mapping ................................................................. 532
MMS Cross Communication.............................................................. 555
  MMS Communication Overview .................................................. 556
  Export / Import of MMS Generated Function Diagrams from Engineering System to Production System ................................................................. 593
Multiple Allocatable Groups and Multiple Code Blocks ....................... 594
Mapping Aspect Objects ................................................................. 594
Grouping Function Components into Allocatable Groups ...................... 595
Vertical Navigation ........................................................................ 612
Variable Creation ........................................................................... 616
Explicitly and Implicitly Defined Variables .......................................... 616
Labelling Split Connections ............................................................... 617
Building up Control Structure .......................................................... 619
Allocating Allocatable Groups .......................................................... 620
Referencing Devices ........................................................................ 626
Synchronization between Control Builder Name aspect and Name aspect ...... 627

Appendix B - Diagram Upgrade
Function Designer Diagram Upgrade .................................................... 635

Appendix C - Update Page Connector

Revision History
Updates in Revision Index A ............................................................... 651
Updates in Revision Index B ............................................................... 652
Updates in Revision Index C ............................................................... 655

Index
Any security measures described in this User Manual, for example, for user access, password security, network security, firewalls, virus protection, etc., represent possible steps that a user of an 800xA System may want to consider based on a risk assessment for a particular application and installation. This risk assessment, as well as the proper implementation, configuration, installation, operation, administration, and maintenance of all relevant security related equipment, software, and procedures, are the responsibility of the user of the 800xA System.

This User Manual describes Function Designer, the configuration tool for Function Diagrams. It serves as an application and reference manual for Function Designer provided with Engineering Workplace of System 800xA.

The User Manual also describes the use of Function Designer as a diagnostic and commissioning tool.

Section 1, Introduction describes briefly about Function Designer.

Section 2, Configuration describes configuration and application procedures with Function Designer.

Section 3, Graphic Editor Reference describes the graphic editor of Function Designer in detail.

Appendix A, Restored Functionalities provides information for specific Engineering Studio functionalities or features available in Function Diagrams restored to Engineering Studio 800xA 5.1.

Basic Function Designer functionalities and workflows are explained in System 800xA Engineering, Function Designer Getting Started (3BDS100968*).
For details on Bulk Data Manager and IO allocation, refer to *System 800xA Engineering, Engineering Studio (3BDS011223*)*.

**User Manual Conventions**

Microsoft Windows conventions are normally used for the standard presentation of material when entering text, key sequences, prompts, messages, menu items, screen elements, etc.

**Feature Pack**

The Feature Pack content (including text, tables, and figures) included in this User Manual is distinguished from the existing content using the following two separators:

Feature Pack Functionality

<table>
<thead>
<tr>
<th>Feature Pack Content</th>
</tr>
</thead>
</table>

Feature Pack functionality included in an existing table is indicated using a table footnote (*):

*Feature Pack Functionality

Feature Pack functionality in an existing figure is indicated using callouts.

Unless noted, all other information in this User Manual applies to 800xA Systems with or without a Feature Pack installed.

**Warning, Caution, Information, and Tip Icons**

This User Manual includes Warning, Caution, and Information where appropriate to point out safety related or other important information. It also includes Tip to point out useful hints to the reader. The corresponding symbols should be interpreted as follows:

- Electrical warning icon indicates the presence of a hazard that could result in *electrical shock*.
Warning icon indicates the presence of a hazard that could result in *personal injury*.

Caution icon indicates important information or warning related to the concept discussed in the text. It might indicate the presence of a hazard that could result in *corruption of software or damage to equipment/property*.

Information icon alerts the reader to pertinent facts and conditions.

Tip icon indicates advice on, for example, how to design your project or how to use a certain function.

Although Warning hazards are related to personal injury, and Caution hazards are associated with equipment or property damage, it should be understood that operation of damaged equipment could, under certain operational conditions, result in degraded process performance leading to personal injury or death. Therefore, fully comply with all Warning and Caution notices.

## Terminology

A complete and comprehensive list of terms is included in *System 800xA System Guide Functional Description (3BSE038018*)*. The listing includes terms and definitions that apply to the 800xA System where the usage is different from commonly accepted industry standard definitions and definitions given in standard dictionaries such as Webster’s Dictionary of Computer Terms.

## Released User Manuals and Release Notes

A complete list of all User Manuals and Release Notes applicable to System 800xA is provided in *System 800xA Released User Documents (3BUA000263*)*.

*System 800xA Released User Documents (3BUA000263*)* is updated each time a document is updated or a new document is released. It is in pdf format and is provided in the following ways:

- Included on the documentation media provided with the system and published to ABB SolutionsBank when released as part of a major or minor release, Service Pack, Feature Pack, or System Revision.
• Published to ABB SolutionsBank when a User Manual or Release Note is updated in between any of the release cycles listed in the first bullet.

A product bulletin is published each time System 800xA Released User Documents (3BUA000263*) is updated and published to ABB SolutionsBank.
Section 1  Introduction

Function Designer is the engineering portal for plant oriented functional planning with Aspect Objects. It provides a graphical user interface to easily engineer, document, and maintain the complex AC 800M control strategies.

Figure 1. Example Function Diagram
Function Designer is used to create Function Diagrams as shown in Figure 1, which are interlinked by Function aspects of the objects in the Functional Structure. These objects represent Process Functions or Process Sequences of the plant.

Function Diagram can be accessed in **Diagram view** from the Function aspect. User can insert and graphically connect block symbols on a Function Diagram. The block symbols represent Function Component Aspect Object types.

The standard library object types of AC 800M Connect and HART Device Integration are provided as ready-made Function Component Aspect Object types.

A Function Diagram can have a complete process control loop with all its Function Blocks / Control Modules, Field Devices, CBM_Signal objects (engineering signals) and their signal connections, see Figure 1. It can be enriched by textual comments, schematic drawings, and ActiveX components.

Sequences can be included into Function Diagrams and their steps, transitions, and actions can be configured in additional Function Diagrams.

Configuration data can be generated for a Function Diagram after allocating it to an application in Control Builder M.

From 800xA 5.1 onwards, the newly created Function Diagrams are available within a **Diagram** folder in the Control Builder and Control Structure. Function Diagrams restored to 800xA 5.1 are available as Single Control Modules (SCM), as shown in Figure 2.
Diagrams can be connected between applications or across controllers using communication variables. User can also manually assign the I.P address for controllers to enable communication across aspect directories.

The diagrams can be downloaded using Control Builder Professional. They can be tested in Function Designer using Online Display and Watch Window functions and Control Builder Professional online functions.

Function Diagrams can be printed in bulk for plant documentation on paper or electronic media.
Copying, allocating, generating configuration data of Function Diagrams can be done in bulk using Bulk Data Manager.

User can design graphical (block) symbols representing Function Component Aspect Object types from the **Component view** of the Function aspect and perform the engineering from the Object Type Structure.

**Product Scope**

Function Designer is a component of Engineering Workplace of System 800xA.

By default Function Designer supports the functional planning approach for the engineering of AC 800M applications with local and remote S800/S900 I/O, HART devices, and PROFIBUS devices using the standard libraries of AC 800M Connect, HART Device Integration, and PROFIBUS Device Integration.

Scope of Function Designer is extendable due to the ability to configure user defined Function Components.

If environment support is enabled in the Configuration Wizard, Function Designer can be used in Engineering environment and in Production environment.

Function Designer can be used to configure applications in **Configure and Deploy** method. Applications configured with Function Designer can be downloaded through **Load Evaluate Go** method.

**Configure and Deploy**

**Configure and Deploy** allows modifications to be performed in the Engineering environment without affecting the running process until the modifications are deployed to the Production environment for immediate execution.

Separate license is required to enable the **Configure and Deploy** functionality.

For more information on **Configure and Deploy**, refer to *System 800xA Engineering, Engineering and Production Environments (3BSE045030*)*.
Prerequisites and Requirements

Prerequisites, requirements, and the installation procedures are explained in System 800xA Installation and Upgrade Getting Started (2PAA111708*).

Post installation procedures (including system creation) are explained in System 800xA, Post Installation (2PAA111693*) manual.

The following system extensions related to Function Designer have to be loaded:

- AC800M Connect.
- ABB CI Extension for AC800M Connect.
- ABB Engineering Base.
- ABB DM & PM Application.
- ABB Signal Extension for AC800M Connect.
- ABB Function Designer for Fieldbus Builder PROFIBUS/HART.
- PROFIBUS & HART Device Integration Library - Basics.
- ABB Function Designer.
- ABB Function Designer for AC800M Connect.
Product Verification

User can verify the product version in Workstation Operating System through Control Panel > Programs > Programs and Features. If the Version tab is not visible, then follow the steps to view the Version tab:

1. Right-click any available tab (such as Name, Publisher, etc).
2. Select More..., see Figure 3.

3. Select the Version check box.
4. Click OK.

Figure 3. Context Menu to Access More Information
The version details are displayed below the **Version** tab.

Follow the above procedure to view other tabs such as **Support Telephone, Help Link**, etc.

User can also verify the product version from the Plant Explorer through **About Industrial IT**.

Further, the specific product’s version can be verified through its **Help > About** menu command. For example, Function Designer’s version details can be verified through its **Help > About** menu command from the Diagram or Component view. The version details are displayed as shown in **Figure 4**.

![Figure 4. About Function Designer, Diagram View Window](image)

**Getting Started**

For information on getting started and tutorial instructions, refer to *System 800xA Engineering, Function Designer Getting Started (3BDS100968)*.

**Reporting Problems**

User can report problems to the local ABB supplier. Ensure to report the problems with the relevant information, such as the product version designation and build number, the description of the problem scenario, and the detailed description of the error messages that appear.
Section 2  Configuration

The following definitions are essential while working with Function Designer, and during its integration with Control Builder M Professional/AC 800M, and with Fieldbus Builder PROFIBUS/HART:

- Function Diagram
- Symbols
- Function Component
- Function Component Type
- Communication Variable
- Allocatable Group
- Mapping Aspect Objects

Function Diagram

A Function Diagram includes one or more function components and symbols. A diagram is displayed in the preview area or in a new window.

Symbols

The Function Diagram contains symbols in its default logic layer, which are rectangular blocks with icons, labels, and 0…n input, and 0…n output ports.

Function Component

Function components are symbols which have function-related aspect data to other aspect systems.
For example, to:

- Controller configuration aspect system Control Builder Professional/AC 800M Connect:
  A function component may represent one of the following instances:
  - System function.
  - System function block.
  - System control module.
  - Sequence (Either IEC 61131-3 Sequence or Sequence2D (based on library SeqStartLib).
  - User-defined function block.
  - User-defined control module.
  - I/O signal.

- PROFIBUS-, HART-configuration aspect systems:
  A function component may represent a field device.

- HSI aspect system:
  A function component may represent an HSI function.

- Function Designer aspect system:
  A function component may represent:
  - A child Function Diagram on lower level. For more information, refer to Vertical Navigation on page 612.
  - An off-diagram reference, which is a connection or cross-link to other Function Diagrams. For more information, refer to Horizontal Navigation on page 99.
  - An on-page connector, which is a label representing a sink/source of connection on the same page to avoid too many crossings.
  - An off-page connector, which is a page cross-reference with label representing a sink/source of connection between different pages. For more information, refer to Off Page Connector on page 453.
  - An explicitly declared local variable. For more information, refer to Explicitly and Implicitly Defined Variables on page 133.
Section 2 Configuration

- A splitter or joiner block. For more information, refer to Splitter and Joiner on page 157.

**Function Component Type**

Function components are instances of function component types defined in Object Type Structure. The object type definition also defines if a function component is instantiated as Aspect Object, or as symbol object in the Function Diagram only (see also Object Type Definition Create Info on page 71).

According to this, function components can be:

- Aspect Objects both visible in Functional Structure and in a Function Diagram.
- Symbol objects only visible in the Function Diagram.

Figure 5 shows an example.:

![Function Diagram with Function Component Aspect Objects and Symbol Objects](image)

**Figure 5. Function Diagram with Function Component Aspect Objects and Symbol Objects**

**Communication Variable**

Communication Variables are used to connect various diagrams which are placed in the same or across applications / controllers.

Communication variables can not be used for SIL based applications.
Allocatable Group

Every bundle of function components, which will be assigned later on in the Control Structure, is regarded as an allocatable group. An allocatable group describes a group of components which are or will be allocated to the same Aspect Object. By default, each object having a function diagram also has an allocatable group aspect.

- **Assigning Complete Function Diagram Logic to One Allocatable Group:**
  
  By default, an allocatable group aspect is automatically generated for each diagram object (aspect object with function aspect and non-empty Diagram view). This allows the user to allocate the whole function diagram to the Control Structure later on. Then, all logical components belonging to that function diagram can be allocated to one application / task on a controller.

Mapping Aspect Objects

Each allocatable group can belong to only one Function Diagram. It is not possible to assign logic of different Function Diagrams into the same allocatable group.

For AC 800M controllers, each allocatable group creates a Diagram or an I/O signal.
Function Components and Diagrams

If the user uses Control Builder M (CBM) function blocks, control modules, and data types in Function Designer, CBM must be running and a control project with the corresponding library must be open.

Otherwise, if the user tries to insert such objects in a Function Diagram, user will receive an error message as shown below:

![Error Message]

[OK]
Preference Settings

Function Designer can save the recent settings and preferences as described below:

- **Function Settings**

  System wide settings like visibility of port parameters, instantiation kind, and rules are stored within the Function Settings aspect, see Figure 6.

  - The Function Settings **DefaultIsVisible**, **InitvalueIsVisible**, **NameIsVisible**, and **DescriptionIsVisible** hide corresponding port parameters on instantiation of Function Blocks and control modules. The default settings in Figure 6 automatically hide port parameters of control modules with default or initial values (need not to be connected), ‘Name’ and ‘Description’ and show other parameters which need to be connected.

  - The function setting **InstantiateComponents** sets the instantiation kind. According to that setting, new components in a function diagram are either created as function component aspect object, visible in Functional Structure, or as function component symbol object, visible on the diagram only.

  - The function setting **DefaultName** determine the name pattern used on instantiation of variables, diagram references, diagram parameters, field devices, IO signals, functions, function blocks and control modules. $\text{ObjectName}_\text{1}$ generates a default name that takes the object type name, and a unique running number 1,2...N. E.g. PidLoop1.

If symbols are instantiated in a Function Diagram with a naming convention different from the default naming pattern, then any further instantiations of the same component uses the new naming pattern as the default for that particular Function Diagram.

- By default, the function setting **CachingEnabled** is set to False. This setting enables diagram modifications to be saved to the aspect directory. If the function setting **CachingEnabled** is set to True, caching is enabled and diagram modifications are not saved to aspect directory until File > Save is performed.
In Function Settings aspect set **DisplayDetailsOnGenerateConfigData** property to ‘true’, in order to display a working dialog indicating the progress and a Cancel button. On cancel, the generation of the current diagram/group is finished before the build process is aborted. By default **DisplayDetailsOnGenerateConfigData** property is ‘false’.

In Function Settings aspect set **ConnectDependentLibrariesOnGenerateConfigData** property to ‘true’, in order to avoid errors in Control Builder due to dependent libraries. By default **ConnectDependentLibrariesOnGenerateConfigData** property is ‘false’.
Depending on the **Object Type Definition Create Info** and **Function Settings** an instantiated object will be placed only in the function diagram as symbol object or additionally in the Functional Structure as an Aspect Object.

Depending on the **Function Settings** default names for field devices, IO signals, function blocks and control modules are prefixed by the diagram name $DiagramName - or not.

For example to change the given default settings (see Figure 6) you could set:

```
[Object Type Structure]Object Types/Functional Planning/Settings:
Function Settings.InstantiateComponents = AccordingTypeDefCreateInfo
Function Settings.DefaultName.FieldDevice = $DiagramName_$ObjectName
Function Settings.DefaultName.IO Signal = $ObjectName
Function Settings.DefaultName.Function Block = $ObjectName
Function Settings.DefaultName.Control Module = $ObjectName.
```
Two new Function Setting properties are included for memory optimization. Set `VarCrossRef_Include_DiagRef` to **False** to use the memory optimally.

Table 1 indicates the Function Designer behavior when the setting `VarCrossRef_Include_DiagRef` is set to True or False.

**Table 1. Settings for VarCrossRef_Include_DiagRef**

<table>
<thead>
<tr>
<th>VarCrossRef_Include_DiagRef &gt; True</th>
<th>VarCrossRef_Include_DiagRef &gt; False</th>
</tr>
</thead>
<tbody>
<tr>
<td>If <strong>VarCrossRef_Include_DiagRef</strong> is set to True:</td>
<td>If <strong>VarCrossRef_Include_DiagRef</strong> is set to False:</td>
</tr>
<tr>
<td><img src="image1.png" alt="Screenshot of True" /></td>
<td><img src="image2.png" alt="Screenshot of False" /></td>
</tr>
<tr>
<td>2. The connected reduced diagram reference detail (name) appears in the yellow reference (refer screenshot below):</td>
<td>2. The connected reduced diagram reference detail (name) does not appear in the yellow reference (refer screenshot below):</td>
</tr>
<tr>
<td><img src="image3.png" alt="Screenshot of True" /></td>
<td><img src="image4.png" alt="Screenshot of False" /></td>
</tr>
</tbody>
</table>

The value of the sub property **No_Of_Diag** indicates the number of connected diagrams loaded simultaneously per transaction for updating the modified properties of the diagram variable. It is recommended to use the default value (5).

**No_Of_Diag** sub property is applicable only if `VarCrossRef_Include_DiagRef` is set to **False**.

Two new Bool Animation color settings are added in the Function Settings to indicate various connection line colors based on the value transfer between the...
ports. Color settings are explained in Table 2:

Table 2. Bool Animation Color

<table>
<thead>
<tr>
<th>Name of the Function Setting</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>BoolAnimation_Value_1 (True)</td>
<td>Green(^{(1)}) (or) Red</td>
</tr>
<tr>
<td>BoolAnimation_Value_0 (False)</td>
<td>Red (or) Blue</td>
</tr>
</tbody>
</table>

\(^{(1)}\) The supported combinations are:
1. If BoolAnimation_Value_1 (True) is Green, BoolAnimation_Value_0 (False) should be Red.
   OR
2. If BoolAnimation_Value_1 (True) is Red, BoolAnimation_Value_0 (False) should be Blue.

In rare cases, if a diagram input reference is connected to multiple output references, then the links may not be animated as per function settings.

Config Data For SFC

Default: False

If Config Data For SFC is set to True, then SFCXRefDataMapper is created while generating config data.

This setting is used by SFC viewer feature pack version to navigate from action window.

Diagram Suffix String

Default: Diagram Suffix String is _FD

Naming convention of the Diagram name is _ (underscore) followed by any character.

This setting is used by SFC viewer feature pack version to navigate from action window.

The SFC Viewer Feature Pack release version needs to be installed to configure Config Data For SFC and Diagram Suffix String.
• **Workspace in Function aspect**

Recent function component / diagram settings like zoom factor, grid properties, default component properties are stored in a workspace within the Function aspect. These settings are individually maintained per function component / diagram.

• **Windows registry**

User interface preferences including maximized popup window, customized toolbar settings and dockable windows are stored per user and per view in a workspace in the Windows registry. The first time *Function Designer* is run, default toolbars and dockable windows are visible. The windows and toolbars can be rearranged as desired. Next time *Function Designer* is run, the same view, and the window/toolbar workspace gets restored.

There are four separate workspaces:

– Plant Explorer preview window, Component view
– Plant Explorer preview window, Diagram view
– Plant Explorer popup window, Component view
– Plant Explorer popup window, Diagram view

If a previous version is installed, few newly added toolbar buttons may not be initially visible. To return to the default toolbars, and to ensure all toolbar buttons visible, use the menu command **View > Toolbar > Customize**. Select each toolbar and click **Reset**. Do this for the Component view and the Diagram view, both in preview and in popup window of Plant Explorer.

If some toolbar buttons are still not visible, open the Workstation Operating System / Server Operating System registry (run regedit) and delete the following keys:

HKEY_CURRENT_USER\Software\ABB Automation Products GmbH\EngineerIT\FuDiagramDesigner

HKEY_CURRENT_USER\Software\ABB Automation Products GmbH\EngineerIT\FuComponentDesigner
Object Type Definition and Usage

To have Function aspects on the Object Types, for example to provide function component object types, there are three ways to use the Function aspects.

On creation of an Aspect Object from the Object Type which includes a Function aspect, it may be:

- used as a *template* - the Function aspect is not copied. If a Function aspect is created later, the one which was created on the Object Type will be copied.
- used as a *copy* - the Function aspect is copied.
- *inherited* - the Function aspect will not be copied but inherited.

For more information on the concepts of object types, refer to *System 800xA, System Planning (3BSE041389*)*. For more details on how to create object types, refer to *System 800xA, Configuration (3BDS011222*)*.

Function component instances typically comprise of both inherited and copied data. The symbol and interface definition might be inherited from an object type, but store component properties including connections in a separate, copied aspect. Therefore, Function Designer uses the following two aspects:

- The Function aspect that is typically inherited.
- The Function Parameter aspect that is typically copied.

Function Designer automatically creates, copies, and deletes the Function Parameter aspect and the Function aspect. Do not create, copy, or delete the Function Parameter aspect manually.
Aspect Properties/Parameters

Aspect properties/parameters can be defined in Component view and in Diagram view for the selected function component, function diagram or port. You can define properties that get inherited from the object type, or properties that get copied on object instantiation. Inherit ones are stored within the function aspect, and copied ones within the Function Parameter aspect.

Use the Aspect Properties Dialog (Ports Tab) dialog to create, edit, or delete aspect properties. Their scope depends on the selection:
Table 3. Scope of Aspect Properties / Parameters

<table>
<thead>
<tr>
<th>View</th>
<th>Object</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component view</td>
<td>Selected port</td>
<td>Aspect properties for the selected port</td>
</tr>
<tr>
<td></td>
<td>Any other selected object</td>
<td>Aspect properties for the whole component</td>
</tr>
<tr>
<td>Diagram view</td>
<td>Selected port</td>
<td>Aspect properties for the selected port</td>
</tr>
<tr>
<td></td>
<td>Selected function component</td>
<td>Aspect properties for the selected component</td>
</tr>
<tr>
<td></td>
<td>Any other selected object</td>
<td>Aspect properties for the whole diagram</td>
</tr>
</tbody>
</table>

Aspect Properties/Parameters Dialog

Double-click an aspect object or variable to invoke the Aspect Properties dialog. Access the Aspect Properties dialog through the Edit > Aspect Properties menu command.

There are three different tabs based on the selection:

- Component Tab

![Figure 8. Aspect Properties Dialog (Component Tab)](image-url)
The Component tab appears only if called on a function component only. Use it to edit or inspect the following fields of the component:

- **Name**
- **Control Builder Name** (this field is dimmed and unavailable for editing)
- **Description**
- **Data Type** (for Variables, Diagram Parameters and Diagram References only)
- **Number of Inputs** (for certain components e.g. AND, ADD, OR... which have got the possibility to control the number of single ports or port groups)
- **Initial value**
- **Aspect Object** property (for all function component to switch between Aspect Object and Symbol Object)
- **Attributes** (for Variables, Diagram Parameters and Diagram References only)

- **Ports Tab**

![Aspect Properties Dialog (Ports Tab)](image)

*Figure 9. Aspect Properties Dialog (Ports Tab)*

**Ports** tab appears only if called on a function component (for the ports of the component) or on the diagram background (for the diagram parameters).
The **Ports** tab can be used to edit or inspect the following properties:

- **Name** (this field is dimmed and unavailable for editing)
- **Description** (this field is dimmed and unavailable for editing)
- **Data Type** (this field is dimmed and unavailable for editing)
- **Direction** (this field is dimmed and unavailable for editing)
- **Value** (the connection at the port; for ports of direction **inout** fields show up (the left one for the input, the right one for the output))
- **Initial Value**
- **Inverted** (for boolean input ports only)
- **Visible** (checked for visible ports, unchecked for hidden ports)
- **Publish As** (a name that should be used to access the value property from the parent diagram; “-” or an empty string if the value property is not published (for more details see Bulk Data Manager Support and Bulk Operations on page 246); for ports of direction **inout** fields show up (the left one for the input, the right one for the output))

• **All Tab**

![Aspect Properties Dialog](image)

*Figure 10. Aspect Properties Dialog (All Property Page)*
All tab appears only if called on a function component (for all properties of the component) or on the diagram background (for all properties of the diagram). Use it to edit or inspect the following properties of the ports:

- **Name**
  
  Defines the name of the aspect property/parameter. The name can be directly edited in the Name cell. Copied and inherited properties share the same name space.

Do not use a dot ‘.’ in the name, as a dot is used as a separator for structured properties.

- **Description**
  
  Defines the description of an aspect property. Enumerated data types use this description internally “Internal, do not edit...”. Port parameters selected in a diagram indicate their description in a tooltip.

- **Data Type**
  
  Defines the data type of the aspect property. The data type can be selected from a drop-down list.

Do not take this data type as the data type of port parameters. Port parameters define a set of properties

- `<Parameter>`
- `<Parameter>.DataType`
- `<Parameter>.Direction`
- ...

see Table 6. E.g. ‘Value = 3.14’, ‘Value.DataType = real’. The port parameter data type is ‘real’, whereas the data type of the properties ‘Value’ and ‘Value.DataType’ is ‘String’.

Besides the following default data types:

- Integer
- Real
- String
• Boolean

Two additional enumerations are listed:

1. **Port Direction** (noDirection, in, out, inout, plug, socket)

2. **DataType** (only used for compatibility with old diagrams)

The enumerations are defined on the Function Aspect category as Function Enumeration aspect, see Figure 11.

Function Designer does not support Re-Authentication or Double Authentication of Aspect Properties.

---

**Figure 11. Enumeration Definition on Aspect Category**

**Port Direction** defines the direction of a port parameter:

- **noDirection**: general port parameter with no specific direction.
- **in**: Input parameter in the sense of a IEC61131-3 Var_Input.
- **out**: Output parameter in the sense of a IEC61131-3 Var_Output.
- **inout**: In-Out parameter in the sense of a IEC61131-3 Var_InOut.
plug: snap port, reserved for future use in Function Designer.
socket: snap port, reserved for future use in Function Designer.

**DataType** is no longer used, but it is needed to upgrade Function Diagrams created with former versions of Function Designer.

Additional enumeration data types can be added by adding further Function Enumerations aspects to the Function Aspect category, which is to [Aspect System Structure]Function Designer/Function/Function.

– **Access Type**

Defines the access type for the aspect property. The access type can be selected from a drop-down list.

**None:** Property is neither readable nor writable from other aspect systems or Bulk Data Manager. Used internally in Function Designer only.

**Read:** Property is readable from other aspect systems and from Bulk Data Manager, but not writable.

**Write:** Property is writable from other aspect systems and from Bulk Data Manager, but not readable.

**Read & Write:** Property is readable and writable from other aspect systems and from Bulk Data Manager.

Read permission and write permission of individual properties equals the read/write permission of the owning Function aspect or Function Parameters aspect.

– **Inherited**

Defines whether the property is inherited or not.

Inherited properties are stored within the Function aspect which is typically inherited from an object type.

Copied ones are stored within the Function Parameters aspect which gets typically copied from an object type.

– **Value**

Defines the value of the parameter
– **Publish as**

This is an enhanced setting allowing to read/write component properties/parameters through the parent diagram. It is mainly used when copying diagrams or setting diagram parameters through the Bulk Data Manager. For more details see Bulk Data Manager Support and Bulk Operations on page 246. Enter the name that should be used to access the property from the parent diagram. Enter “-” or an empty string if the property should not be published.

**Predefined Aspect Properties**

The following aspect properties are predefined:

*Table 4. Predefined Properties for Components*

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ComponentSaveTime (String)</td>
<td>Used internally to update open component views and diagram views with component instances. Always disabled for modifications.</td>
</tr>
<tr>
<td>ParameterSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>ObjectTypeSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>ObjectTypeSaveInst (String)</td>
<td></td>
</tr>
<tr>
<td>InterfaceSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>InterfaceSaveTypeSaveInst (String)</td>
<td></td>
</tr>
<tr>
<td>XMLTypeSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>AutoParametersSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>SymbolInstanceSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>ReferenceSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>AllocGroupsSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>DiagramReferenceType (String)</td>
<td>Used internally to indicate the direction of diagram references and to update variable data types.</td>
</tr>
<tr>
<td>VariableDataTypeIDs (String)</td>
<td></td>
</tr>
<tr>
<td>VariableDataTypeSaveTimeInst (String)</td>
<td></td>
</tr>
<tr>
<td>InstantiatedByDesignerVersion (String)</td>
<td>Function Designer version string that instantiated the component. Always disabled for modifications.</td>
</tr>
</tbody>
</table>
**Table 4. Predefined Properties for Components (Continued)**

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NumberOfInputs (Integer)</td>
<td>Current number and data type of inputs. Only available for components which support a variable number of inputs, e.g. AND (3).</td>
</tr>
<tr>
<td>TypeOfInputs (String)</td>
<td></td>
</tr>
<tr>
<td>VariableDataType (String)</td>
<td>Data type, type group (library or application) and attributes for local variables, diagram parameters, and diagram references. The read-only VariableDataTypeGroup property gets automatically updated on library connection changes on open diagram.</td>
</tr>
<tr>
<td>VariableDataTypeGroup (String)</td>
<td></td>
</tr>
<tr>
<td>VariableAttributes (String)</td>
<td></td>
</tr>
<tr>
<td>CrossCommunication (String)</td>
<td>Used for input diagram references that need cross communication because of connections across different applications. See Prerequisites on page 195.</td>
</tr>
<tr>
<td>CrossCommunication.CycleTime (String)</td>
<td></td>
</tr>
<tr>
<td>CrossCommunicationValid (String)</td>
<td></td>
</tr>
<tr>
<td>ComponentHidden (Bool)</td>
<td>If set to true, components are hidden on a diagram. Used e.g. for signal groups.</td>
</tr>
<tr>
<td>AspectObject (Bool)</td>
<td>If set to true, component is an aspect object and thus visible both in the diagram and its child in the diagram. If set to false, component is a symbol object visible on the diagram only.</td>
</tr>
<tr>
<td>ObjectTypeName (String)</td>
<td>These read-only properties equal the object type name and the object type group (for library or application defined types). They get automatically updated on:</td>
</tr>
<tr>
<td>ObjectTypeGroup (String)</td>
<td>• Change Type (symbol objects only)</td>
</tr>
<tr>
<td></td>
<td>• Library connection changes (aspect objects at once, symbol objects on open diagram)</td>
</tr>
<tr>
<td>ObjectName (String)</td>
<td>For aspect objects, these properties equal Name.Name and Name.Description. For symbol objects, these properties define name and description, respectively.</td>
</tr>
</tbody>
</table>
Table 4. Predefined Properties for Components (Continued)

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ControlBuilderName (String)</td>
<td>For aspect objects (CBM function blocks and control modules), these properties equal Control Builder Name.Name and Control Builder Name.Description. For symbol objects, these properties define CB name and description, respectively.</td>
</tr>
<tr>
<td>ControlBuilderDescription (String)</td>
<td></td>
</tr>
<tr>
<td>Position.Page (String)</td>
<td>Page number and top-left position of a component, given in units of the diagram’s measurements (0.01mm or 0.001 inch). These properties are written on <strong>File &gt; Save</strong> diagram. On open diagram, the position and page number of a component is synchronized against these properties. This is useful to bulk position components by e.g. Bulk Data Manager, refer to <strong>Create Diagram(s) through Bulk Data Manager</strong> on page 273.</td>
</tr>
<tr>
<td>Position.X (String)</td>
<td></td>
</tr>
<tr>
<td>Position.Y (String)</td>
<td></td>
</tr>
<tr>
<td>Position.Unit (String)</td>
<td></td>
</tr>
</tbody>
</table>

Table 5. Predefined Properties for Diagrams

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DiagramSaveTime (String)</td>
<td>Used internally to update open Diagram views. Always disabled for modifications.</td>
</tr>
<tr>
<td>ParameterSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>ContentsSaveTime (String)</td>
<td></td>
</tr>
<tr>
<td>DelCompSymbolId (String)</td>
<td></td>
</tr>
<tr>
<td>DiagramIsBad (Boolean)</td>
<td>Boolean value indicating that recent diagram check has failed. Always disabled for modifications.</td>
</tr>
<tr>
<td>InstantiatedByDesignerVersion (String)</td>
<td>Function Designer version string that instantiated/created the diagram. Always disabled for modifications.</td>
</tr>
<tr>
<td>DiagramSize.Width (String)</td>
<td>Diagram width and height, given in units of the diagram’s measurements (0.01mm or 0.001 inch). These properties are written on <strong>File &gt; Save</strong> diagram.</td>
</tr>
<tr>
<td>DiagramSize.Height (String)</td>
<td></td>
</tr>
<tr>
<td>DiagramSize.Unit (String)</td>
<td></td>
</tr>
</tbody>
</table>
Adding an Aspect Property

Perform the following to add an aspect property:

1. Select the object to which an aspect property (for example a symbol’s port) is to be added.

2. Open the Aspect Properties dialog by one of the following methods:
   – Double-click the required component.
   – Right-click and select Aspect Properties... from the context menu.
   – Choose the Edit > Aspect Properties menu command.

3. Select the All tab (A new aspect property can be added only from the All tab)

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Parameter&gt; (String)</td>
<td>Port parameter value. Holds connection string, see Connections/Networks on page 87.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.In (String)</td>
<td>Port parameter value for inout parameters. Holds connection string, see Connections/Networks on page 87.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.Out (String)</td>
<td>Port parameter value for inout parameters. Holds connection string, see Connections/Networks on page 87.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.DataType (String)</td>
<td>Port parameter data type, e.g. “RealIO”.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.Direction (Port Direction)</td>
<td>Port parameter direction, e.g. “in”.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.Initval (String)</td>
<td>Port parameter instance specific initial value.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.InitvalOfObjectType (String)</td>
<td>Port parameter initial value defined at the object type.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.Inverted (Boolean)</td>
<td>True if port is inverted. Only available for invertable ports, see Inversion on page 97.</td>
</tr>
<tr>
<td>&lt;Parameter&gt;.Visible (Boolean)</td>
<td>True if port is visible, false if port is hidden, see Change Type on page 82.</td>
</tr>
</tbody>
</table>
4. Right-click the free background of the **All** tab.

5. Select **Add Property** from the context menu. A new empty row is inserted.

6. Enter the required values into the fields using the drop down lists offered for the fields **Access Type**, **Data Type** and **Value**.

**Figure 12. Adding an Aspect Property**

---

**3BDS011224-600 C**
7. Perform steps 3 - 5 three times (for <portname>, <portname>.Datatype and <portname>.Direction) to define all the necessary properties of a port.

8. Click OK/Apply.

Removing an Aspect Property

Perform the following to remove an aspect property:

1. Select the required object from which the aspect property has to be deleted.
2. Open the Aspect Properties dialog by one of the following methods:
   – Right-click and select Aspect Properties... from the context menu.
   – Choose the Edit > Aspect Properties menu command.
3. Select All tab (An aspect property can be deleted only from the All tab).
4. Right-click the row containing the aspect property which is to be deleted.
5. Choose Remove Property from the context menu.
6. Click OK/Apply.

Aspect Property References

Instead of setting static text into a text or label component, references can be defined to any aspect property / parameter. By that, the text or label subscribes to and displays dynamic data, e.g. live data from an OPC data provider, a PID gain factor, or some document field defined in a document aspect.

The text or label components on a function diagram are automatically updated when the subscribed aspect property changes. So consistent and up-to-date function diagrams are obtained.

Perform the following to set a property reference in a text or label component:

1. Select the required object.
2. Right-click and select Component Properties... from the context menu to open the Component Properties dialog.
3. Select the Field tab.
4. Choose the Aspect Property Reference option in the Field Code group box.
5. Click ☐ to open the Aspect Property Reference dialog.

6. Select Structure, Select Object, Aspect and Property from the corresponding list box. The Reference String text box displays the selection.

7. Choose the Reference Type and click Apply.

8. Click OK.

The Aspect Property Reference dialog is closed.

9. Click Add to enter the selected parameter reference into the Field text box.

10. Click OK.
Aspect Property Reference

Use the **Property Reference** dialog to define the **Reference String** for the required aspect property. Click [ ] in the **Component Properties Field** page, to open the **Aspect Property Reference** dialog:

![Aspect Property Reference Dialog](image)

**Figure 13. Aspect Property / Parameter Reference Dialog**

For more information on the syntax for aspect property references, refer to *System 800xA Engineering, Engineering Studio (3BDS011223)*.
Defining Function Components (Component View)

Function components can be defined in Function Designer’s component view.

Perform the following to define a function component:

1. Choose Object Type Structure from the structure browser of Engineering Workplace or Plant Explorer Workplace.
2. Browse to the location where the new function component is to be located.
3. Use the New Object... context menu to create a new object type using the New Object dialog.
4. Use the New Aspect... context menu to create a Function aspect for the Object Type.
5. Select the Function aspect from the list of aspects, and open the Function Designer’s Component view.
6. Use the File > New command to define a new function component.
7. Design the symbol of the function component using the graphical facilities of Function Designer.
8. Add aspect properties, if any. Refer to Adding an Aspect Property on page 47.
9. For each (input/output) parameter of the function component, add at least the following aspect properties:
   a. Parameter Name
   b. Parameter Direction (in, out, in-out, none)
   c. Parameter Data Type
A complete function component including graphical symbol, ports, and aspect properties can be defined and this feature is available for:

- CBM_Signals.
- Diagram parameters.
- Diagram references.
- HART devices.

Perform the following to map a graphical port with such a parameter:

1. Open the port’s **Component Properties** window.
2. In the **General** tab, enter the name of the required parameter.
3. Click **OK**.

*Figure 14. Aspect Properties*
Function Components with XML Type Description (Component View)

The following object types use an alternative to the complete definition of a function component including graphical symbol and aspect properties:

- CB system functions, refer to Figure 16
- CB system procedures
- CB function blocks, refer to Figure 17
- CB control modules, refer to Figure 18
- Variables

The Function aspect of these types store an XML type description with

- Type name
- Type description
- Interface description (parameters, data type of parameters)
- Optional extensible parameters

**Figure 16. XML Type Description of an add (real) Function**

**Figure 17. XML Type Description of a CTU Function Block**
On instantiation, aspect properties get automatically created from that XML type description, and a graphical symbol gets automatically calculated from a component template.

The component template is also stored within a Function aspect. It can be defined at one of the following four levels:

1. at the type.
2. at the parent type group.
3. at any parent of the type.
4. at the aspect category.

This also equals the search order for component templates. First a component template is searched at the type, then at its parents, and then at the aspect category.

The component template definition includes the following graphical components, see Figure 19:

- Label InstanceName.
- Text TypeName.

Figure 18. XML Type Description of a MotorUniM Control Module
- Rect MainComponent.
- Rect ShadowComponent (optional).
- Polygon HiddenPortsIndicator.
- Text InputPortName.
- Port InputPort.
- Text OutputPortName.
- Port OutputPort.
- Text InoutPortName.
- Port InoutInputPort.
- Port InoutOutputPort.

Figure 19. Component Template for Function Block Types

The XML type description for CB system functions and procedures is stored within the functions and procedures Function aspect. The corresponding object type group
[Object Type Structure]Object Types\Control System\AC800 M/C Connect\System Functions and a component template gets loaded by the system extension Function Designer for AC800M Connect.

The XML type description for CB function blocks and control modules is automatically retrieved from the corresponding CB library if a Function aspect gets created.

**Libraries**

For each base library loaded by an AC 800M system extension, Function Designer system extensions add corresponding Function, Function Parameter, and Object Type Definition Extension aspects through a corresponding extension library. The Object Type Definition Extension aspect is needed to add aspects to an already released library. To save the additional aspects for further use an extension library is recommended. See Figure 20.

- AC800M Connect gets extended by Function Designer for AC800M Connect system extension.

For restored Function Diagrams, browse to Connected Library > Connect Library in Control Builder M and connect the latest version of BasicLib.

Perform the following for user-defined libraries with function blocks and control modules:

1. Open a Control Builder project and add the required library.
2. In the Library Structure create an extension library for the newly added library.
3. In Object Type Structure, add a Function aspect for each function block and control module type of the library. Use Bulk Data Manager to perform this action in bulk operation.

The Function Parameters aspect gets automatically created together with the Function aspect. An Object Type Definition Extension aspect gets automatically created if the library was already closed/released. If the library is still open, no Object Type Definition Extension aspect is necessary.

4. Optionally add function component templates to the types or to the parent type group.
5. Release Reservation for the extension library.
6. Export the extension library (either in Open or Closed or Released state, according to further usage) by using the Export Library button in the Config View on the Extension Library Version Definition aspect. See Figure 20.

The XML type description stored in the Function aspect gets automatically updated on interface changes. Instances also get automatically updated on interface changes. For instance, if:

- there is a user-defined control module type MyCMT with two inputs and one output parameter.
- there are two instances MyCM1, MyCM2.

MyCMT.Function aspect holds a corresponding XML type description and inherits an aspect property `InterfaceSaveTime`. Instances copy that property as `InterfaceSaveTimeInst`. The instances MyCM1 and MyCM2 also display a symbol.

If the type’s internals are only changed (add some glue logic or some internal variable), Function Designer detects that the interface is not changed. The inherited property `InterfaceSaveTime` is not modified and the instances, MyCM1 and MyCM2 are not updated.
If the types interface are changed (add/delete some parameter or change its data type), Function Designer detects that change and updates the inherited property `InterfaceSaveTime`. On opening the Function Diagram, the instances and their symbols MyCM1 and MyCM2 are updated due to the mismatch of the `InterfaceSaveTime` and `InterfaceSaveTimeInst` properties. The diagram state gets modified due to the changed interface, see Instance Specific Initial Values on page 160.

The above scenario is applicable for interface changes due to changes in connected libraries. In such a case, aspect object instances get updated due to an internal Change Type. Symbol objects get updated on open diagram.

Do not delete and recreate the Function aspect in order to update a type. If the Function aspect is recreated, the InterfaceSaveTime property gets reset, and all diagrams will change their state to modified, even if the interface of the type did not change.

An update of the XML type description can be forced by the Function aspect verb Update XML Type Description.

Do not use Delete from All Structures in Object Type Structure.
Data Types

Variables of library- or application defined (structured) data type calculate their graphical symbol on the base of a variable component template and the selected DataType aspect. Variable instances get automatically updated on an open diagram in case of:

- changes in the data type definition.
- changes due to connected libraries.

This is done by the aspect properties VariableDataTypeSaveTimeInst and VariableDataTypeIds. The latter points to the DataType aspect.

Customizing a Function Component Type

The default function component type can also be customized by any of the following methods:

- Adding a Function Icon.
- Copying and Modifying an Existing Function Component.
- Creating a Complete Function Component Definition.

Adding a Function Icon

A Function icon aspect supports the display of Function icon picture components in the block representation of Functions, Function Blocks, and Control Modules as shown in Figure 22.

![Figure 22. Function Block with Function Icon](image)

To add a Function icon:
1. In the Object Type Structure navigate to the object type to be equipped with the Function icon.

2. Create a Function Icon aspect.

3. Open the Function Icon aspect.

4. Click **File > New**.

5. Select **Component**.

6. In the empty Function Component window draw the icon symbol.

7. Open the Aspect Properties dialog and add the new aspect property PictureComponentType (Data Type = String, Value = Centered).

8. Additionally the properties PortNameVisibility (Data Type = Boolean) and TypeNameVisibility (Data Type = Boolean) may be needed to define the layout of standard function like AND, OR, etc. where no port and type names are displayed.

9. Click **OK**.

10. Click **File > Save**.


12. Open the Function Settings aspect and insert the new property UseFunctionIcon (Value = True, Type = Boolean).

13. Click **Apply** and **Cancel**.

As a result an instance of the object type on a function diagram will show the configured Function Icon, for example as shown in Figure 22.

Allowed values for the PictureComponentType property are:

- **Centered**: The icon is positioned at the center of the main component.
- **XCentered**: The icon is only centered horizontally (relative to the main component) and keeps its y position as defined.
- **YCentered**: The icon is only centered vertically (relative to the main component). In contradiction to Centered is it located nearby the port names and therefore reduces the width of the resulting symbol (but leading to an asymmetric layout).
Function Icon aspects shall be collected in the extension libraries as described in Libraries on page 58.

**Copying and Modifying an Existing Function Component**

For more information on copying and modifying an existing function component, refer to the sub section “Creating a Signal Group Object Type (includes copying / changing the graphical symbol)” in System 800xA Engineering, Function Designer Getting Started (3BDS100968*).

**Creating a Complete Function Component Definition**

As an example in this subsection we will change the representation of the function component type ValveUniM located in the ProcessObjExtLib (Process Object Extended Control) library of the AC800M Connect system extension. Changing the function component type will automatically update all instantiated function components with inherited (not overridden) Function aspect.

The object type exists and has a Function aspect. The view of the graphics, e.g. the components symbol definition and or the ports are to be changed. Prerequisite is that the Extension Library that extends the corresponding AC800M Connect library is in state Open.

The Function aspect (Component view) of control module type ValveUniM only defines a XML type definition. To add a customized function component definition (fixed symbol) for the representation in a function diagram, do as follows:

1. Select the function aspect from the Aspects of ‘ValveUniM’ list.
3. Choose **Component** and click **OK**. A new window is opened in *Function Designer* to define the (fixed) graphical symbol.

![Window for defining a function component's fixed graphical symbol](image)

**Figure 23. Creating Complete Function Component Definition (Fixed Symbol)**

In *Function Designer* Component view, use the menu and/or toolbar commands (see *Working with Menus* on page 295/*Working with Toolbars* on page 357) to build up/modify the symbol for representing the function component in function diagrams. **Table 7** lists some toolbar buttons which can be used for creating/modifying a symbol. The final customized symbol is displayed in **Figure 24**.

**Table 7. Tools for Creating a Symbol**

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Tool for drawing the box" /></td>
<td>To use for drawing the box (rectangle).</td>
</tr>
<tr>
<td><img src="image" alt="Tool for adding line ports" /></td>
<td>To use for adding line ports for connections to the symbol.</td>
</tr>
</tbody>
</table>
To customize the symbol:

1. The Component view of the function component type should be still open. If not, right-click the Function aspect in the Aspects of list of the Workplace window and choose Component from the context menu.

2. Click and draw a box as body for the valve symbol.

3. Right-click the rectangular area to open the context menu and select Component Properties. The Component Properties dialog appears.

4. Choose the Fill page in the Component Properties dialog and set the colors according to the following figure.
5. Click and draw line ports for the input and output connections.

6. Click and insert text components for designating the ports according to the parameter name of the corresponding control module, function, or function block.

7. Set the references between the (line) ports and the parameters of the corresponding control module, function, or function block by entering the parameter names (used also as port designation in the previous step) into the Name field of the General page on the ports Component Properties dialog.

Figure 25. Setting symbol color.
Section 2  Configuration
Customizing a Function Component Type

8. Click \( \underline{A} \) and add a text component (symbol name) with an aspect property reference to ValveUniM’s Name Aspect. Changes in the instance name are automatically reflected in Function Diagrams. Perform the following and also refer to Figure 27:

   a. Open the Field page on the Component Properties dialog.

   b. Choose Aspect Property Reference and click on \( \underline{B} \). The Aspect Property Reference window is opened, the ValveUniM control module type is selected.

   c. Choose the Name Aspect’s Name Property and as Reference Type relative to same obj, then click OK.

   d. In the Component Properties dialog, click Add, then OK.

Figure 26. Setting the port name to the designation used in the symbol.
Figure 27. Setting a Reference to the Symbol Name
Aspect Objects and Symbol Objects

Function components get instantiated

- either as aspect objects (visible in the diagram and in Functional Structure, optionally in Control Structure)
- or as symbol objects (stored and visible only in the diagram).

Symbol objects reduce the number of aspect objects. It is possible to switch the kind of existing instances from aspect to symbol object or vice versa:

- Either by component Aspect Object. Can be applied to a single or multi-selection of components in a Function Diagram
- Or by aspect property AspectObject, useful for bulk operations through Bulk Data Manager.

Table 8 lists objects that can be instantiated as symbol objects and as aspect objects.

Table 8. Symbol Objects and Aspect Objects

<table>
<thead>
<tr>
<th>Default Symbol Objects</th>
<th>Default Aspect Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>CB system functions</td>
<td>CB function blocks</td>
</tr>
<tr>
<td>CB system procedures</td>
<td>CB control modules</td>
</tr>
<tr>
<td>Variables</td>
<td>CBM IO signals</td>
</tr>
<tr>
<td>Splitters</td>
<td>(significant data in aspects like Signal</td>
</tr>
<tr>
<td>Joiners</td>
<td>Parameter)</td>
</tr>
<tr>
<td>Diagram references</td>
<td>HART devices</td>
</tr>
<tr>
<td></td>
<td>(significant data in aspects like Fieldbus</td>
</tr>
<tr>
<td></td>
<td>and Device Management)</td>
</tr>
</tbody>
</table>

Both aspect objects and symbol objects support the aspect properties listed in Table 9.
The instantiation kind for new instances on a diagram is determined by the Function Settings: **InstantiateComponents** property. It can take the values described in Table 10.

### Table 9. Symbol Object and Aspect Object Properties

<table>
<thead>
<tr>
<th>Aspect Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ObjectName</td>
<td>Equals .:Name.Name for aspect objects</td>
</tr>
<tr>
<td>ObjectDescription</td>
<td>Equals .:Name.Description for aspect objects</td>
</tr>
<tr>
<td>ControlBuilderName</td>
<td>Equals .:Control Builder Name.Name for aspect objects</td>
</tr>
<tr>
<td>ControlBuilderDescription</td>
<td>Equals .:Control Builder Name.Description for aspect objects</td>
</tr>
</tbody>
</table>
| AspectObject          | Set to true for aspect objects
                        | Set to false for symbol objects.                 |

### Table 10. Function Settings: **InstantiateComponents**

<table>
<thead>
<tr>
<th>InstantiateComponents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccordingCB</td>
<td>Default from 800xA 4.0. Functions, procedures, variables and diagram parameter get instantiated as symbol object.</td>
</tr>
<tr>
<td>AccordingCBAAlarmOwnerFlag</td>
<td>Function blocks and control modules get instantiated as in CB: If they hold the AlarmOwner or the InstantiateAsAspectObject flag, they get instantiated as aspect object.</td>
</tr>
<tr>
<td></td>
<td>E.g. an TOn gets instantiated as symbol object, a MotorUniM as aspect object.</td>
</tr>
<tr>
<td>AccordingTypeDefCreateInfo</td>
<td>Default in 800xA 3.1. See Object Type Definition Create Info on page 71.</td>
</tr>
<tr>
<td></td>
<td>Functions, procedures, and variables get instantiated as symbol object.</td>
</tr>
<tr>
<td></td>
<td>Diagram parameter, function blocks and control modules get instantiated as aspect object.</td>
</tr>
<tr>
<td></td>
<td>E.g. a TOn gets instantiated as aspect object.</td>
</tr>
</tbody>
</table>
Objects created outside Function Designer are always instantiated as aspect object:

- Plant Explorer New Object dialog
- Bulk Data Manager

They can be changed into symbol objects by the Aspect Object or the AspectObject aspect property.

Always generate configuration data after adding or deleting any blocks created using Function Designer, which is used inside the Control Module Types.

In case error messages associated with unconnected ports appear during configuration data generation and user can not navigate to the respective blocks from the error message; then reopen the Function Diagram and delete the respective blocks before regenerating configuration data.

### Object Type Definition Create Info

In case Function Settings: `InstantiateComponents` (see Table 10) equals `AccordingTypeDefCreateInfo`, the `Create Info` options in the `Object Type Definition` aspect determines if an object gets instantiated as an aspect object or as a symbol object:

1. Open Engineering Workplace or Plant Explorer Workplace.
2. Select the object type from the Object Type Structure.
3. Select the object type’s Aspect with category name `Object Type Definition` (for example, CBM_AIS Type Definition).
4. Select `Create Info` tab.
5. Check the options **Can be created as root**, **Can be created outside Structures** and **Can be created in all Structures** of the `Structure Info` group and modify them in the following way:

<table>
<thead>
<tr>
<th>InstantiateComponents</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AsAspectObject</td>
<td>Instantiate all objects as aspect object.</td>
</tr>
<tr>
<td>AsSymbolObject</td>
<td>Instantiate all objects as symbol objects. Exceptions are listed in Table 8.</td>
</tr>
</tbody>
</table>

Table 10. Function Settings: `InstantiateComponents` (Continued)
To define instantiation kind aspect object, all **Structure Info** options must be selected, and **Explicit Object Type** must be cleared. See Figure 28.

Figure 28. Create/Structure Info for Instantiation Kind Aspect Objects

To define instantiation kind symbol object, clear the **Structure Info** options and select **Explicit Object Type**. See Figure 29.

For glue logic like AND, OR and so on, the **Create Info** options are not set, that means such functions are instantiated as symbol objects and created and stored on function diagrams only.
Figure 29. Create/Structure Info for Instantiation Kind Symbol Object
Inherited Function Components

If a new function component is created in a Function Diagram, the settings of the Object Type Definition aspect or Object Type Definition Extension aspect (for example, CBM_AIS Type Definition) define how the instance gets updated if its type changes.

- Set the option Inherit to All Instances for the Function aspect in the Aspect Control tab of the Object Type Definition aspect (for example, CBM_AIS Type Definition), to inherit the component’s symbol definition from the object type to the instance. Modifications of the symbol definition - and thus of the

Figure 30. Aspect Control for Components with Inherited Function Aspect
Function aspect- will automatically result in an update of all existing object instances. In this case, the already existing components of the Function Diagrams are automatically drawn/printed using the updated symbol definition.

- Set the option **Copy to All Instances** for the Function aspect in the **Aspect Control** tab of the **Object Type Definition** aspect (for example, CBM_AIS Type Definition), to inherit the component’s symbol definition from the object type to the instance. In this case, the function aspect will be copied on object instantiation. Later modifications on the type will have no effect on an already existing object instance.

- The Function Parameters aspect holding copied aspect properties and connect strings gets typically copied to all instances. However, formal instances of diagram types inherit the Function Parameters aspect in order to prevent modifications of the generated control module type.

Perform the following to adjust/modify the Aspect Control properties (as shown in Figure 30):

1. Open the **Object Type Structure** dialog by choosing the **Show Type** command of the component for which the object type definition aspect control is to be changed.
   Alternatively, open the Object Type Structure in the Engineering Workplace and select the object type.

2. Select **Object Type Definition** aspect.

3. Open the **Aspect Control** tab and select the corresponding **Aspect**.

4. Set the **Copy/Inherit** options as required.
Figure 31 displays indicators for an inherited component, which is a component with an inherited Function aspect:

- **Read Only** hint in the Component Properties dialog.
- **READ** indicator in status bar of Function Designer. Double-click the indicator to get more detailed information such as “This component is read-only because its Function aspect is inherited”.

**Figure 31. Indicators of Inherited Components**
Labels on Inherited Components

Function Designer symbols (object types) can additionally use labels to define some property references. Component instances display informations such as the component name with such labels. As labels can be moved and modified at an instance, they are not inherited like the graphical symbol itself.

The following label modifications done at the object type are reflected at the instances on open diagram, if the label instances have not been modified manually:

- Fill properties.
- Line properties.
- Font properties.
- Text field properties.
- Text alignment.

Overridden Components

User can override inheritance of individual components as follows:

1. Select the function component (symbol) from Functional Structure.
2. Right-click the Function aspect from the Aspects list and select Override from the context menu.

![Override inheritance setting done in Aspect Control of function component.](image)

**Figure 32. Override Inherited Function Component**

When the user overrides an aspect, the aspect gets copied from the object type to the component instance. User can undo Override by the **Delete Override** command. In that case, the copied aspect gets deleted, so that the inherited one is seen again from the component instance.

Close and re-open the diagram to see the effect of **Delete Override**.

3. Modify the symbol definition in Component View.
Figure 33. Diagram with Overridden Symbol
Default Aspect

User can define an aspect of an Aspect Object as default aspect. This default aspect will appear as uppermost entry in the context menu of the specific Aspect Object.

Perform the following to define an aspect (for instance: Function aspect) as the default aspect:

1. Select the Function aspect from an Aspect Object within the Plant Explorer.
2. Right-click and select Details... from the context menu.
3. Choose the Aspect Info tab in the Details dialog.
4. Select the Default aspect check box.
5. Click Apply.
6. Click OK.
Figure 34. Defining Aspect as Default Aspect
### Instantiating Function Components in Diagram View

User can instantiate Function components in the Diagram view of Function Designer through the menu command or through drag-and-drop. For more information, refer to Inserting/Creating Components on page 390.

If a library object like Control Module type or Function Block type created using Function Designer is instantiated in Control Structure, then in Function Structure, the object is at root level since it has no parent.

### Change Type

#### Changing Type of Component Instances

The Change Type functionality is available for symbol objects and aspect objects. For aspect objects change type is only possible to a type of same kind. User can change a Function to a Function, Procedure to a Procedure, Function Block to a Function Block, and Control Module to a Control Module type. Connections and aspect properties are preserved as much as possible by keeping values for matching property names.

1. In Diagram view, right-click a component and select the **Change Type** command from the context menu. The menu command is disabled in case you selected an aspect object.
2. Select the new object type from dialog **Change Type**:

![Change Type dialog](image)

**Figure 35. Dialog Change Type**

**Changing Number of Inputs**

Certain components e.g. AND, ADD, OR... define an aspect property **NumberOfInputs** which controls the number of single ports (or port groups). The value of this aspect property is explicitly set when creating an object instance in a Function Diagram. When creating an object instance in Plant Explorer (or through Bulk Data Manager, etc.) a default value for this parameter is used.

Follow the steps below to change the number of inputs:

1. Right-click a component in Diagram view and select **NumberOfInputs** … command from the context menu. This menu command is not available in case a component without modifiable number of input parameters is selected.
2. Select the new value from the **Number of Inputs** dialog as shown in Figure 36.

![Figure 36. Dialog Number of Inputs](image)

Changing the value of the **NumberOfInputs** aspect property is also possible through the **Aspect Properties** dialog (Component tab and All tab). It is recommended to use the Component tab from the Aspect Properties dialog or the Number Of Inputs … command. When changing the value of the NumberOfInputs aspect property in the All tab of the Aspect Properties dialog or instead it might be necessary to close and reopen the diagram to update the symbol.

As the values of other existing aspect properties remain untouched, port connections are kept when increasing the value. When decreasing the value of NumberOfInputs the superfluous dependent port related aspect properties (and related connections) are removed.

While invoking the **Number of Inputs / Number of Outputs** dialogs, on functions or function blocks supporting extensible parameters (e.g. **In1..InX** for logic function **OR**), it may display a value different from the current configuration. This does not affect the configuration and the graphical representation.

**Show/Hide Ports**

By default, newly instantiated components do not display all port parameters.
Symbols with hidden ports are marked by a small black triangle displayed in the lower left corner, see Figure 37.

The hidden ports can be revealed by the following steps:

1. Select a component in Diagram view with hidden ports.
2. Right-click the component and invoke the Show Hidden Port(s) command from the context menu.
3. Show Hidden Ports dialog appears as shown in Figure 38.

Figure 37. MotorUniM with Hidden Ports

Figure 38. Show Hidden Ports Window
4. Select the **Sort Hidden Ports** check box to sort all port names in ascending order or alternatively, shortcut ALT+R can be used.

5. Select the **All Hidden Ports** check box or select the required port from the **Select Ports to Show** list.

6. Click **OK**.

Alternatively, user can set the **Visible** properties of the port parameters in the component’s **Aspect Property** dialog (Ports tab), as shown in **Figure 39**, or through Bulk Data Manager.

![Aspect Properties](image)

**Figure 39. Port Parameters of MotorUniM**

For information on how to configure the default visible ports of a function block, refer to the subsection Configuring Default Visible Ports in *System 800xA Engineering, Function Designer Getting Started (3BDS100968)*.
User can hide individual ports by the following steps:

1. Select the ports to be hidden from the Diagram view of the required component.
2. Right-click on the port and invoke the **Hide Port(s)** command from the context menu.

**Connections/Networks**

A **port** of a function component symbol references an aspect property/parameter by its name. For more information, refer to **Function Components and Diagrams** on page 29.

This aspect property holds the **connect string**. A connect string can be of type **constant**, e.g. 123, or ‘def’, or of type **variable**, e.g. abc. It can be edited by any of the following methods:

- in the drop-down combo box of the **Connection** toolbar,
- in-cell in the connector symbol displayed at the port,
- in the **Aspect Properties Dialog (Ports Tab)**,
- or in Bulk Data Manager.

If there are two ports on a diagram connected to the same variable, e.g. abc, a connection link is automatically created and routed. If the ports are located in different pages, **off-page connector** symbols are automatically created on both pages. **CB project constants** use the same syntax as variables. But, they behave like constants and are not connected through links or off-page connectors.

Do not create a project constant in Control Builder M while a Function Diagram is open. Otherwise, if a project constant is connected twice on different ports the Function Designer is drawing a short circuit line. User must close and re-open the Function Diagram to get the proper connection displayed.

In Function Diagrams for simple connection between same variables, code generation error occurs. That is, a connection between input port of one block to input port of another (or) output port of one block to output port of another, results in an error.

A **network** is a set of 1:1, 1:N connections between ports. A connection network has 1 source and 1...N sinks, and is defined by its unique network name, that equals
the connect string of type variable. All network components, i.e. all links and off-page connectors, share the variable/network name as component name property. The variable/network name is also accessible by a label attached to network links. Automatically created links get the default variable/network names link, link1, link2...

Consider the following examples:

- Figure 40 shows symbol port S1:In1 connected to constant 123, and symbol ports S2:In1 connected to variable abc and S2:In2 connected to string constant ‘def’. The connect strings are reflected in the ports aspect property, and in Bulk Data Manager. If user changes the connect string in the aspect property dialog, or in Bulk Data Manager, the diagram gets automatically updated.
Figure 40. Connection to Constant and to Variable
In Figure 41, S1:Out was connected to variable abc. A 1:1 network with one connection link gets automatically created, connecting S1:Out with S2:In1. The link is labeled abc, and the links name property equals abc. This is also reflected in the aspect properties, and in Bulk Data Manager. And vice versa, user can automatically create networks with links by updating connect strings in the aspect properties dialog, or in Bulk Data Manager, see also Create Diagram(s) through Bulk Data Manager on page 273.

Figure 41. 1:1 Network
• In Figure 42, S3:In1 was connected to variable abc. A 1:N network, N = 2, gets automatically created with two links named abc.

Figure 42. 1:N Network (N = 2)

In Figure 43, S2 was moved from page 1 to page 2. Off-page connectors with page references get automatically created. Page referencing is not reflected in the aspect properties nor in Bulk Data Manager, i.e. S1:Out and S2:In still hold the connect string abc. In other words, off-page connectors are also automatically created when connecting symbols on different pages by updating aspect properties, e.g. in Bulk Data Manager.
Interconnected function components can be moved to other pages considering the following connection rules:

1. **1:1 connections between pages:**

   1:1 connections between Function Components can be performed based on the direction rules in Figure 78. Inout (Out) connection to other pages is not possible (refer to figure below).

![Figure 43. 1 : N Network with Off-Page Connectors](image-url)
2. 1:N Connections between pages  
   a. 1:N connections between pages can be created between System Functions, Function Blocks and Control Modules or between Variables like CBM signals, Local Variables and Communication Variables. Mixed networks are possible using Move block, Splitter / Joiner blocks between Off-Page connectors and variables.  
   b. Each Off Page connector sink needs a corresponding Off Page connector source as displayed in the figure below.

![Diagram](image-url)

*Figure 44. Connection Between Off Page Connector Sink and Off Page Connector Source*

It is not possible to allot a connection on a destination page, to several other destination ports on the same page. For instance, refer to Figure 44 it is not allowed to create a connection from AND(4).In1 to AND(7).In1 directly.

**Guidelines for using Page Connectors**

A few guidelines for using the page connectors are listed below:

- Connecting an empty diagram reference to a page connector results in an error on generating the Configuration Data.
• Connecting an InOut port of a Function Block or Control Module to Out port of another Function Block or Control Module through a page connector may result in an error during generation of Configuration Data.

• The following page connections are not suggested:
  a. OUT port of a block to INOUT port of a block through a page connector.
  b. INOUT of a block IN port of a block through a page connector.
  c. INOUT-INOUT port of a block through a page connector.

These are not allowed in Function Diagrams due to connection rules of Control Builder M.

• When a connection is made from Out port of a Function Block or Control Module to InOut port of another Function Block or Control Module through a page connector, and if the port name and data type name are same, it results in an error during generation of Configuration Data.

An Update Page Connector Utility is available in the Function Designer menu to correct Page Connector errors after a rename of Function Diagrams or its blocks. For more information, refer to Appendix C, Update Page Connector.

**Connect Using Keyboard**

Perform any of the following methods below to enter a connect string:

• Select a port in the Function Diagram, edit the connect string in the drop-down combo box of the Connection toolbar, and press <Enter> key or click **Enter connect string**, as shown in Figure 45.

• Select a port in the diagram and select an already existing connect string from the drop-down combo box of the Connection toolbar, see Figure 45.

• Select a connector symbol displayed left or right at a port in the diagram, in-cell edit the connect string, and press <Enter> key.

• Select a function component symbol in the diagram and edit its connect strings in the **Aspect Properties Dialog (Ports Tab)** or **Aspect Properties Dialog (Component Tab)** dialog.
- Update connect strings in Bulk Data Manager.

![Connection Toolbar](image)

_Figure 45. Connection Toolbar_

To connect two function component ports on the same or on different pages using keyboard:

1. Navigate to the first port by using the cursor keys in Network traversal mode and mark it by ‘Numpad - ’ refer to _General Accelerator Keys_ on page 387.

2. Navigate to the second port by using the cursor keys in Network traversal mode.

3. Press ALT + Numpad to connect the selected port to the marked one.

4. In case of connecting ports on different pages, off-page references are automatically created.

5. Network link(s) get created with next free default variable/network name link, link1, link2, ... and automatically routed.
Connect Using Mouse

There are two alternate methods to connect function component ports using the mouse as described below:

**To create a new connection (alternative 1)**

1. Press the left mouse button on the source port.
2. Move the mouse to the sink port or already existing connection on the same page.
3. Release the mouse button.
4. The connection link gets automatically routed. It gets the next free default variable/network name link, link1, link2... .

No modifier keys are used in this case and the user need not provide any ‘connection mode switch on the toolbar’.

**To create a new connection (alternative 2)**

1. Click and select the required source port.
2. Click ALT+left on sink port on the same or another page.
3. In case of connecting ports on different pages, off-page references are automatically created.
4. Network link(s) get created with next free default variable/network name link, link1, link2, ... and also gets automatically routed.

If a connection (sink) is already existing, additionally a new vertex is created automatically.

**Manual routing by inserting/freezing vertices on connection links**

1. Click and select a connection link.
2. Click ALT+left on the connection link where a new vertex is to be inserted.
3. Click CTRL + SHIFT + left on the new vertex to pin it, i.e. to freeze it for auto routing. The pinned vertex is indicated in red color.
4. Unpin a frozen vertex by CTRL + SHIFT + left mouse click.
5. Delete a vertex by CTRL + left click.

In some instances, the automatically routed connection lines overlap. Move related symbols within diagram to overcome the overlapping.

In some instances, connections lines overlap after a close and reopen of a Function Diagram. Modification of distances between links and symbols by using **Edit > Options > Autorouting** overcomes this overlapping.

**Disconnect**

Perform any of the following to disconnect a port or some port(s) from a network:

- Select a port in the diagram, reset its connect string to an empty one in the **Connection** toolbar.
- Select a port in the diagram, and click ‘Disconnect port only’ or ‘Disconnect complete network’ from the **Connection** toolbar.
- Select a connector symbol displayed left or right at a port in the diagram, and delete it.
- Select a function component symbol in the diagram and reset its connect strings in the **Aspect Properties Dialog (Ports Tab)** dialog.
- Reset connect strings in Bulk Data Manager.

**Inversion**

Perform any of the following to invert an input port of data type ‘bool’:

- Select a port in the diagram, and press the ‘Invert’ button of the **Connection** toolbar.
- Select a function component symbol in the diagram and edit the port’s inversion properties in the **Aspect Properties Dialog (Ports Tab)** dialog.
- Update inversion properties in Bulk Data Manager, see **Figure 46**.
Figure 46. Inversion of Boolean Inputs
Vertical Navigation

For a better overview on Function Diagrams, it is possible to build a hierarchical Functional Structure with parent-child diagrams. Functions on a lower level can be summarized in a separate diagram and displayed in an overview diagram on a higher level as a single function component with input and output ports. Diagrams on lower level are also called child or nested diagrams. They can be opened from an overview diagram by choosing View > Goto Child Diagram or Goto Child Diagram from the context menu. This is also called vertical navigation - top down, bottom up, throughout the functional hierarchy.

For more information about vertical navigation through Single Control Modules, refer to the Vertical Navigation on page 612.

Horizontal Navigation

Function Diagrams can also be split using (Off-) Diagram References. User can navigate through a group of Function Diagrams that are connected through diagram references. This is also referred to as horizontal navigation.

There is no restriction in connecting/referencing diagrams located anywhere in the Functional Structure. Double-click the required diagram reference to open and access the referenced diagram directly.

Alternatively, user can navigate from one diagram to another by any of the following methods:

1. Select the referenced object and choose View > Goto Referenced Diagram.
2. Select the referenced object and choose Goto Reference... from the context.
Two variants of input or output diagram references are supported:

- Reduced:
  Only the variable name and the path to the connected reference is displayed. No Description fields for references and variable are displayed. They save drawing space on the diagram.

- Non-reduced (as in earlier system versions):
  Additional Description fields for references and variable are displayed.

Inputs and outputs of referenced diagrams are function components of type [Object Type Structure]Object Types/Functional Planning/Generic Function Components/Connectors/Off Diagram Reference/Input (Output) Reference or Reduced Input (Output) Reference:
User can include diagram references to diagrams in Functional Structure only. They are not supported by diagram types in Object Type Structure. In Figure 48, we have an overview diagram D0 and two diagrams D1 and D2 with (off-) diagram references. D1:Out is connected to D2:In, and D2:Out is connected to D1:In1 and D1:In2. This is indicated by automatically calculated cross-references in D1 and
D2. The blue colored field available in the diagram reference symbol as shown in Figure 48, indicates that communication is established between the referenced diagrams.

Figure 48. Referenced Diagrams
Reduced Input (Output) Diagram References only show the path information of the reference to save diagram drawing space.

Diagram Reference Object types "Off-Diagram References (SIL)" are available for Communication Variables which can be used for communication from non-SIL based Function Diagrams with Control Builder POUs that are part of SIL-2 and SIL-3 Applications.

Figure 49. Diagram Reference Object Types

The Diagram Reference object types under "Off-Diagram References(SIL)" must be used only for Communication Variables and not for Diagram Variables.

For more information on IAC refer to AC 800M Communication Protocols (3BSE035982*).
Global Variable and Communication Variables

The global variable facilitates communication between restored diagrams (created up to System Version 5.0 SP2).

The communication variable facilitates communication between:

- Newly created Function Diagrams in System Version 5.1 or later.
- A restored diagram (created up to System Version 5.0 SP2) and a newly created diagram in System Version 5.1 or later.
- Restored Function Diagrams.

In effect, diagram references consist of an input/output reference and communication variable.

Diagram references can be connected through Bulk Data Manager, see Working with Diagram References (Symbol Objects) Using Bulk Data Manager on page 255.

In the sense of a structural programming language, diagram references and diagram variables refer to global or communication variables.

The global variable and the communication variable takes the name, description, data type, initial value and attributes of the diagram variable.

Two engineering templates named BDM_DiagramRef_Var_Basic and BDM_DiagramRef_Var_Advanced are used to modify diagram references and diagram variables represented as symbol objects.

Connect To Diagram Variable

User can interactively create (off-) diagram reference and connect to diagram variables by the following steps:

1. In Diagram view, insert a function component of type
   [Object Type Structure]Object Types/Functional Planning/Generic Function Components/Connectors/Off Diagram Reference/Input (Output) Reference
   or Reduced Input (Output) Reference.

2. The Variable Properties dialog appears, enter Name and Description of the diagram reference.
3. Click **OK** if the user wants to leave the diagram reference without having it connected to a diagram variable.

4. If the user wants to create a diagram variable and connect to it or if the user wants to connect to an existing diagram variable, click **Connect** instead of **OK**.

5. In the dialog **Connect to Diagram Variable** enter the name of the variable or select an existing variable from the list.

6. Click **OK**.

   Double-click the Diagram Reference which does not have a variable connection to invoke the **Connect To Diagram Variable** dialog.

   Double-click an **Output Diagram Reference** which is connected to a variable but has no reference to the input, to invoke the **Variable Properties** dialog.

![Variable Properties dialog](image)

![Connect To Diagram Variable dialog](image)

**Figure 50. Connect to Diagram Variable**
7. A new diagram variable gets created or an existing one gets inserted in Functional Structure.

8. The diagram reference is connected to that diagram variable. Cross References are automatically updated in the diagram as shown in Figure 48. The datatype of the Valid bit present in a diagram reference used for cross communication is dword. When a proper communication is established, the value of this bit is 192.

If user drags and drops a port to the left border of a function diagram, a new reduced diagram reference gets automatically created with corresponding data type. The default name of the diagram reference equals <PortName>.

In addition, the user can connect to an existing diagram variable or create a new one. The default name of the diagram variable equals <DiagramName>_<PortName>.

The same applies for reduced output references that get automatically created on drag and drop of a port to the right border of a diagram.

This functionality is not available in Function Diagrams containing SPL components. User is recommended to use the context menu New Diagram Output Reference... or New Diagram Input Reference... based on the requirement.

Connection between Restored Diagrams (created upto 800xA 5.0 SP2) and New Diagrams (created from 800xA 5.1 onwards)

Follow the steps to connect an output diagram reference of a restored diagram (created upto System Version 5.0 SP2) to an input diagram reference of a new diagram created in System Version 5.1 or later:

1. Reserve the required restored Function Diagram.
2. Right-click the required output port and select New Diagram Output Reference... from the context menu.
3. Click Connect... in the appeared Variable Properties dialog as in Figure 51, to open the Connect to Diagram Variable dialog.
4. In the **Connect to Diagram Variable** dialog, select **Variable Type** as **Communication Variable** from the drop-down list as in **Figure 52**.

As part of system upgrade to 800xA 5.1, Function Diagrams variables list includes both diagram variables and communication variables.
5. Enter the required communication variable name in the **Variable** field of **Connect To Diagram Variable** dialog.
6. Click **OK**.
7. Click **OK** in the **Variable Properties** dialog.
8. Open the new diagram created in System Version 5.1 or later.
9. Right-click the required input port and select **New Diagram Input Reference**....
10. Click **Connect...** in the **Variable Properties** dialog window.
11. Select the communication variable created in **Step 5**.
12. Provide the required ISP value in the **ISP Value** field.

   The **ISP (Input Set as Predetermined)** is applicable only for communication input variables. This field defines the ISP value to be set for the **In** variable.
This value can only be set for basic data types. If an ISP value is not specified, the default value is the last good value. If no last good value exists (because of a communication failure), the init value is applied. For structured data types, the ISP values can be set only in the data type for each individual component. Hence, it is not possible to configure instance specific ISP values for structured data types.

13. Select the required cycle time from the **Cycle Time** drop-down option.

   **Communication cycle time** is applicable for peer-to-peer communication. The possible values are fast, normal, slow, very fast, and very slow. The default value is normal.

   In Function Diagrams restored to 800xA 5.1, the **ISP Value** and **Cycle Time** are unavailable to the user.

14. Clear the AutoIP check box, to provide the IP address manually together with the port number details.

   **IP address** is applicable only for communication input variables. This field defines the IP address of the controller that contains the corresponding communication output variable (with the same name) in any of its applications. When no value for the IP address is entered, the editor automatically fills in the default value 'auto'. The IP address is resolved during compilation.

15. Click **OK** in the **Connect To Diagram Variable** dialog.

16. Click **OK** in the **Variable Properties** dialog.

To connect an output diagram reference of a new diagram created in System Version 5.1 or a later version to an input diagram reference of a restored diagram (created upto System Version 5.0 SP2), follow the above procedure with the following modifications:

- Create a **New Diagram Output Reference** at the output port of the required newly created diagram.
- Create a **New Diagram Input Reference** at the input port of the required restored Function Diagram.
Diagram Reference object type under "Off-Diagram References(SIL)" additionally includes two properties "UniqueID" and "ExpectedSIL" as part of the aspect properties, Figure 53.

The user must manually update the properties to communicate with respective Communication Variables in SIL2 or SIL3 POUs.

The expected SIL property entered in the aspect properties of Communication Variable should match with the entry in Control Builder for communication.
User can interactively disconnect from a diagram variable by the following steps:

1. In Diagram view, right-click on a diagram reference symbol and choose ‘Disconnect from Diagram Variable’ from the context menu.
2. All references are disconnected, and corresponding function diagrams get automatically updated.

From 800xA 5.1 onwards, the output diagram reference symbol indicates if the connected variable is a communication variable (CV) or a global variable (GV).

**Goto Reference**

User can navigate from one diagram to another one by the following steps:

1. In the Diagram view, select a diagram reference symbol and choose View > Goto Referenced Diagram, or right-click on the diagram reference symbol and choose Goto Reference from the context menu. Alternatively double-click on the diagram reference symbol or use the shortcut CTRL+T.

2. If one reference is available the referenced diagram is opened with the corresponding Diagram Reference selected.

3. If more than one reference is available (on output diagram references) the Goto Reference dialog appears.

4. Select a reference to open the corresponding diagram. The corresponding diagram reference symbol gets selected in the referenced diagram.

**Number of Diagram References**

By default, diagram reference symbols grow from top to bottom to display all references. As the number of references displayed is limited by the actual page size,
user can define the maximum number that gets displayed in one column by the following steps:

1. In Diagram view, select a diagram reference symbol, right-click and choose Number Of Diagram Reference... from the context menu.

2. Define the maximum number of diagram references to be displayed in one column. If the actual number of references exceeds this number, the diagram reference symbol automatically adds additional columns and grows from left to right.

![Figure 55. Dialog Number of Diagram References](image)

Diagram references are sorted according to diagram names, or, for equal diagram names according to diagram reference names.

**Diagram Variables on Copy/Paste**

Links on a single diagram define 1:1 or 1:N networks. Same can be considered for diagram variables which define 1:1 or 1:N networks between diagrams.

**Keep connection to source:**

To keep input or output diagram references stay connected to the diagram variable of the copy source, select the option **Keep connection to source** on **Variable Properties** dialog box. This allows you to quickly connect several input diagram references to one and the same variable of an output diagram reference.
Disconnect always:
To disconnect input or output diagram references from the diagram variable of the copy source, select the option Disconnect always on Variable Properties dialog box. Then the user has to connect / create diagram variables manually.

Make new unique connection:
Select Make new unique connection on Variable Properties dialog box to create new unique diagram variable.

Disconnect if source is outside copied range:
Select Disconnect if source is outside copied range on Variable Properties dialog box to disconnect the input diagram reference from the diagram variable if the variable was created outside of the copied diagram or copied diagram parts. This option is only available for input diagram references.

If an empty reference without Communication Variables or Diagram Variables is connected across the pages through page connector, then Function Diagram gives an error during Configuration Data Generation. To avoid this make sure that empty input reference is on the same page of connecting function block.

External reference to Communication Variable
Display of External Reference and navigation to Control Builder M Project Explorer from Function Designer Diagram based Diagram References is possible for Communication Variables used within a Control Builder Application.

The procedure mentioned below describes the use of the new feature.
1. On drag and drop of a Diagram Reference to a Function Diagram, a dialog box appears that connects to the Communication Variable.

Figure 56. Input Reference
2. A new check-box for **CBM Communication Variables** is introduced. It displays all the communication variables allocated to the Function Diagram in the CBM Application.

![Connect to Diagram Variable](image)

*Figure 57. Connect to Diagram Variable*

3. In the **Connect to Diagram Variable** dialog box, enable the check-box of the new feature **CBM Communication Variables**.
4. A list of communication variables appears that were created in CBM under Application.

![Connect to Diagram Variable - Communication Variable list](image)

*Figure 58. Connect to Diagram Variable - Communication Variable list*

5. From the list, any communication variable of required Data Type can be selected.

6. In the Diagram Reference, a yellow reference is added. It shows the path of the CBM POU.
7. On double-clicking the yellow reference, **CBM Editor** window opens.

8. On selection of **Project Explorer**, it navigates to the Diagram in CBM wherein the communication variable is declared.

9. On selection of **Diagram editor** in the CBM editor, it launches the Diagram Editor of corresponding Diagram where communication variable is declared.
Diagram Type Enhancement

The Control Software for AC 800M was enhanced with the following features for 800xA 5.1 Feature Pack 4:

**Diagram Editor with Function Diagram**

Diagram is a new graphical language that graphically interconnects functions, function blocks, control modules and embedded ST and SFC code blocks on the same page. For more information, refer *System 800xA 5.1 Revision D Feature Pack 4 Release Notes (2PAA109967-514)*.

Using the Diagram editor, Diagram Types can be created similar to that of the Control Module types or the Function Block types. This enhancement is to extend the support of Diagram Types in Function Designer Diagrams. Diagram Types created in Control Builder M can be instantiated in Function Designer Diagrams. The procedures mentioned below describe the usage of Diagram Types in Function Designer Diagrams.

Diagram Types created using Control Builder M only can be instantiated in Function Designer Diagrams.

Diagram Types that are created using Function Designer are not supported for instantiation in Function Designer Diagrams.

**Enabling Diagram Types to be Instantiated in Function Designer Diagrams:**

Diagram Types can be part of a standard library or can be created by a user.

Refer *AC 800M Getting Started (3BSE041880)* and *AC 800M Configuration (3BSE035980)* manuals, on how to create Diagram Type using the Control Builder M.

For Diagram Types created using Control Builder M, perform the following steps to enable instantiation in Function Designer Diagrams:

1. Open **Engineering Workplace**.
2. In the structure browser, navigate to **Object Type Structure > Library Name > Diagram Type**.

By default Diagram Types do not have Function and Function Parameter Aspects.

![Diagram](image)

To extend the support of Diagram Types in Function Designer Diagrams, the Function and Function Parameter Aspect needs to be added.

3. Right-click the **Diagram Type** object and select **New Aspect**.
4. In the **New Aspect** dialog, select **Function Aspect** and click **Create**. The Function Aspect is added and the Function Parameter is added automatically.

### Table: Aspects of DT1

<table>
<thead>
<tr>
<th>Aspects of DT1</th>
<th>Modified</th>
<th>Modified by</th>
<th>Desc...</th>
<th>Inherited</th>
<th>Category name</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function Parameters</td>
<td>3/13/2014 10:34:52 AM</td>
<td>ABB</td>
<td>Used...</td>
<td>False</td>
<td>Function Param...</td>
<td>1</td>
</tr>
<tr>
<td>Function</td>
<td>3/13/2014 10:34:52 AM</td>
<td>ABB</td>
<td>Used...</td>
<td>False</td>
<td>Function</td>
<td>1</td>
</tr>
<tr>
<td>Alarm Block Type Scanner</td>
<td>1/25/2014 3:35:54 AM</td>
<td>ABB Function Dt...</td>
<td>True</td>
<td>False</td>
<td>Alarm Block</td>
<td>1</td>
</tr>
<tr>
<td>Aspect Category Definition</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>The...</td>
<td>False</td>
<td>Aspect Category</td>
<td>1</td>
</tr>
<tr>
<td>Control Alarm Event</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>Aspe...</td>
<td>False</td>
<td>Control Alarm E...</td>
<td>1</td>
</tr>
<tr>
<td>Control Properties</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>The...</td>
<td>False</td>
<td>Control Builder ...</td>
<td>1</td>
</tr>
<tr>
<td>Control Properties</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>Cont...</td>
<td>False</td>
<td>Control Properties</td>
<td>1</td>
</tr>
<tr>
<td>Diagram Block</td>
<td>3/13/2014 10:26:37 AM</td>
<td>ABB</td>
<td>False</td>
<td></td>
<td>Diagram Block</td>
<td>1</td>
</tr>
<tr>
<td>Diagram Type Reference</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>False</td>
<td></td>
<td>Diagram Type</td>
<td>1</td>
</tr>
<tr>
<td>OT Type Definition</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>False</td>
<td></td>
<td>OT Type Def...</td>
<td>1</td>
</tr>
<tr>
<td>Event List</td>
<td>4/6/2008 5:20:54 AM</td>
<td>AC800M Connect</td>
<td>This...</td>
<td>True</td>
<td>Alarm and Even...</td>
<td>1</td>
</tr>
<tr>
<td>Hidden Alarm List</td>
<td>4/6/2008 5:21:07 PM</td>
<td>AC800M Connect</td>
<td>This...</td>
<td>True</td>
<td>Alarm and Even...</td>
<td>1</td>
</tr>
<tr>
<td>Library Member</td>
<td>3/13/2014 10:34:52 AM</td>
<td>ABB</td>
<td>False</td>
<td></td>
<td>Library Member</td>
<td>1</td>
</tr>
<tr>
<td>Node</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>The...</td>
<td>False</td>
<td>Name</td>
<td>1</td>
</tr>
<tr>
<td>Object Icon</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>Icon...</td>
<td>False</td>
<td>Object Icon</td>
<td>1</td>
</tr>
<tr>
<td>Object Type Structure</td>
<td>3/13/2014 10:28:37 AM</td>
<td>ABB</td>
<td>[Obj]...</td>
<td>False</td>
<td>Object Type Str...</td>
<td>1</td>
</tr>
<tr>
<td>Object Type Structure</td>
<td>3/13/2014 10:25:54 AM</td>
<td>ABB</td>
<td>[Obj]...</td>
<td>False</td>
<td>Object Type Str...</td>
<td>1</td>
</tr>
<tr>
<td>Shredded Alarm List</td>
<td>6/13/2009 2:17:02 PM</td>
<td>AC800M Connect</td>
<td>This...</td>
<td>True</td>
<td>Alarm and Even...</td>
<td>1</td>
</tr>
</tbody>
</table>

**Figure 60. Function Parameter and Function Aspect**

**Instantiation of Diagram Type in Function Designer:**

The Diagram Type can be instantiated in a Function Designer Diagram in the following ways:

a. Inside Function Designer Diagram editor:
   - Drag-and-drop the Diagram Type from structure browser.
   - By using the Insert menu.

b. In the structure browser of Engineering Workplace, under Function Structure by a right-click on the Function Designer Diagram object > New object > Browse to OTS > Library > Diagram Type object > Create.

c. Using Bulk Data Manager.

The instantiation of Diagram Types is not supported inside a Sequence Block.

**i**

Bulk copy of the Function Designer Diagram with Diagram Type instance/s is supported using Bulk Data Manager.
Edit the Port for Diagram Type:

It's possible to edit the ports for Diagram Types similar to that of Control Module type using the Insert menu of Engineering Workplace. For more information refer the section Configuring Favorite Object Types and Default Visible Ports of System 800xA Engineering, Function Designer Getting Started (3BDS100968*).

Child Aspect Objects of Diagram Types or Control Module Types visible in Functional Structure:

A Diagram Type or Control Module Type may have child aspect objects. When the Diagram Type or Control Module Type is instantiated in a Function Diagram then the child aspect objects are displayed in the Functional Structure, Figure 61.

Diagram Type Reactor_Process is instantiated under Function Diagram B_Block. The Diagram Type has ValveUni, MotorUni Control Module Types which are child aspect objects, visible in Functional Structure.
System Functions

*Function Designer* is an aspect system in the 800xA system and supports therefore all system functions like reservation, electronic signature, audit trail, user log-over, backup/restore, and export/import. Most functions are covered by the 800xA system, however *Function Designer* provides some extensions as described below.
Reservation

Function Designer requires reservation of an existing, non-blank Function Diagram for further modification work.

Not reserved Function Diagrams are read only, they show READ indication in the status bar.

The reservation of a created generic object with Function aspect in Functional Structure is released automatically, if the Function aspect is opened, modified and closed.

This happens only if the diagram is not allocated to an application.

Functions related to an application such as Allocate or Generate Configuration Data require reservation of the Control Application.

1. Click File > Reserve Diagram to get exclusive modify access to a Function Diagram. Click File > Reserve Diagram again to release the diagram.

   User can perform the same function by pressing the corresponding Reserve / Release toggle button of the Standard toolbar:

   ![Reserve/Release button](image)

   A new diagram is reserved by default. Closing the diagram releases the diagram automatically.

   Press the CTRL+W keys to reserve an opened Function Diagram.

2. Click File > Reserve Application to get exclusive modify access to the application including all Function Diagrams.

   Note that reserving the application could be done already in Control Builder Professional or in the Manage dialog of Plant Explorer.

3. Click File > Release Reservation to cancel reservation of diagram or application.
In the diagram view of a reserved Function Diagram, all the modifications will be saved automatically, while releasing the reservation through Plant Explorer using the **Release…** command in the context menu.

Graphical changes such as, moving the existing Function Blocks / Control Modules, Field Devices, CBM_Signal objects and their signal connections are not saved by this operation.

It is always recommended to release a Function Diagram from the Function Designer.

**Audit Trail**

*Function Designer* creates specific Audit Trail Events if the Audit Trail feature is enabled within the current 800xA system:

- On **File > Save**, an Audit Trail event **Save Information FuD** is written. An additional audit trail log message can be appended, see **Dialog Audit Trail Log Message**.

- On any diagram state change, an audit trail event **InfoChangeDiagramState** is written, see **Diagram States and Transitions** on page 162.

*Figure 62. Dialog Audit Trail Log Message*
Permissions and user roles

Users of Function Designer who want to modify and configure diagrams and components need to hold the Application Engineer user role. An application engineer has good knowledge about working with the Aspect Object Framework, Engineering Workplace, Control Builder M, and FieldBus Builder.

Users of Function Designer who want to open or print diagrams and components can be a system engineer, an operator, or a maintenance employee.

It is recommended that the Operator user role should not have access to Control Builder M.

Authority

Function Designer supports the 800xA system’s authority concept by checking

- permissions granted to a user and
- roles connected with this user.

This is done against the permissions required for actions in Function Designer and roles required for user interface availability.

To create, edit, or generate configuration data you need the application engineer role. In case you do not hold that role, or in case a Security Definition Aspect restricts configuration permissions for specific users, user groups, or locations, the
corresponding Function Diagram and Component views are in Read-only mode. This is indicated by:

- A Read indicator in the status bar. Double click on that indicator to get more detailed information.
- A Read-Only indicator in the title of various dialogs, e.g. Aspect Properties dialog and Component Properties dialog.

**User Log-Over**

You can use the Log-Over function with Function Designer. After log-over the current Diagram View / Component View is closed, the next Diagram View / Component View you open is then shown according to the new user rights.

**AC 800M Integration**

**Introduction and Requirements**

AC 800M integration of Function Designer describes the workflow of functional planning, allocation of functions to an AC 800M controller within Control Structure and generation of configuration data for Control Builder M.

For function component allocation and controller configuration, the system extension Function Designer for AC800M Connect is needed. This extension is dependent on system extensions Function Designer, AC800M Connect, and Signal Extension for AC800M Connect. All tools have to be installed, all system extensions have to be loaded by installing the Engineering Workplace System Function through the System Installer.
With Function Designer users can:

- Create diagrams including function components for Control Builder M. A newly created Function Diagram in Functional Structure represents a Diagram, a diagram in Object Type Structure represents a Control Module Type. A diagram includes:
  - Functions,
  - Function block types,
  - Control module types,
  - I/O signal types,
  - Diagram types,
  - Sequences (IEC 61131 compatible or Sequence2D).

- Define data flow order.
- Define variables for your control code.
- Configure channels on I/O hardware units.
- Display on-line values in the diagram and in the Watch Window.
- Establish cross-communication automatically

**Workflow Overview**

The basic workflow to work with Function Diagrams and Sequences is described in System 800xA Engineering, Function Designer Getting Started (3BDS100968*). How to configure Sequences with Function Designer is described in this introductory manual only.

The following sub-sections give you detail information on functions you use when you work according to this workflow:

- **Building up Functional Structure and Function Diagrams** on page 129
- **Defining Data Flow Order** on page 131
- **Explicitly and Implicitly Defined Variables** on page 133
- **Building up Control Structure** on page 139
- **Allocating Function Diagrams** on page 141
- **Variable Creation** on page 148
Building up Functional Structure and Function Diagrams

*Function Designer* is used for function oriented engineering of an automation system. For details, refer to subsection Create Process Functions in *System 800xA, System Planning (3BSE041389)*.

Diagram Parameters are not supported in Functional Structure from system version 5.1 onwards.
Figure 64 shows the allocatable group aspect for a diagram inside Functional Structure:

![Image of Allocatable Group Created in Functional Structure]

**Figure 64. Allocatable Group Created in Functional Structure**

If the Control Builder Application does not appear when user clicks *Allocate*: Check if Control Builder is in on-line mode. Switch Control Builder into off-line mode before invoking the *Allocate*. 
Defining Data Flow Order

When instantiating a new component, a default “Data Flow Order” number is assigned. If the “Extended Name” dialog or the “Variable Properties” dialog pops up during instantiation this is used to select a certain entry in the new “Insert Before” combo box of these dialogs.

Click Auto Sort Order icon from the Quick Access toolbar option to automatically sort the Data Flow Order for the various symbols of a Function Diagram. The shortcut key for this menu option is Ctrl+Shift+D.

The Data Flow Order can also be assigned through the Data Flow Order dialog. All components of an allocatable group can be moved up or down to get the required Data Flow Order.

The Data Flow Order number begins with 1.

Follow the steps to define the Data Flow Order:

1. Open the required function diagram.

2. Choose the menu command Allocation > Define Data Flow Order or click the icon of the Allocation toolbar. The Data Flow Order dialog is opened.

![Data Flow Order Dialog](image)

*Figure 65. Data Flow Order Dialog*
3. Select a function component from the **Data Flow Order** list and move it to the required location:
   
   – Click the selection to move up the selected function component.
   – Click the selection to move down the selected function component.

4. Click **Apply** to assign the new Data Flow Order to the respective function components.

In Function Designer, always generate the data flow order after any changes in the configuration.

The **Generate** button can be used to sort the listed function components in the Data Flow Order in **Allocatable Group** window according to the default Data Flow Order. The default order is calculated according the rule “left up to right down”, as shown in **Figure 66**. After generating the default Data Flow Order, click **Apply** to assign the Data Flow Order to the function components accordingly.

If a connection is made between output port of a block having higher dataflow order and the input port of another block having lower dataflow order, attribute of connected link variable is set to nosort. In order to ensure that the values are retained, it is advisable to make connections through local variables.
Explicitly and Implicitly Defined Variables

Variables can be declared explicitly, or they get implicitly created whenever needed during configuration data generation. Explicitly declared variables are:

1. Diagram Variables which are further available as:
   1. Global variables
   2. Communication variables
2. Local variables, see Figure 67.
The dialog **Variable Properties** in Figure 68 is used to define properties for diagram references/diagram variables, and local variables. You can set

- **Name** of variable/reference
- **Description** of variable/reference
- **Data type** of variable/reference. The combo box **Data Type** lists all system-, library- and application defined data types.
- **Attributes** of variable/reference.
Function Designer allows to use the state attribute for variables. For a variable with “state” attribute the following is valid, if the variable is required in two different code blocks:

- Read applies to the “old” value.
- Write applies to the current value.

![Variable Properties]

Figure 68. Dialog Variable Properties

If you modify data type or attributes of diagram references you get asked to update the data type or attributes for connected diagram variable as well. In case they differ, you will get corresponding warnings on File > Check and on open diagram.
Local variables of structured data type display ports to connect to sub-variables (use the Show/Hide Ports command to show or hide individual sub-variables). Initial values can be defined via the aspect property, `Initval`.

Connection links implicitly create variables whenever needed. The variable name for such a link can be displayed by the dialog in Figure 69. Select a link, right click and select ‘Variable Name...’ from the context menu.

![Figure 69. Dialog Variable Name](image)

**Conversion of Global Variables (Diagram Variables) into Communication Variables**

Workflow to convert Global Variable (GV) used in Function Diagrams into Communication Variable (CV) using Bulk Data Manager (BDM):

1. In **Function Structure** of **Engineering Workplace**, right-click on **Function Diagram**, and select **Engineering templates** from **Advanced** menu.
2. Double-click **BDM_DiagramRef_Var_Basic.xlsx** in the **Engineering Templates** dialog. The template opens in an MS-Excel spreadsheet.

![Figure 70. Engineering Templates](image)

3. Move the **Function Diagram** from **Engineering workplace** into the open **Template** by a drag-and-drop action.

4. Create a copy of the **Template** and save it with a different name, then close it.

5. Delete the Variable Names in earlier **Template** and perform **Save all Objects**.
Global Variables are disconnected from the references in Function Diagram.

6. Open the copy of Template (saved in Step 4).
7. Under CanCreateCV column, replace False by True, and perform Save all Objects.

Figure 71. Variable Name String Screen

Figure 72. CanCreateCV Column
Communication Variables are connected to the diagram references.

The output references of Function Diagram may still show Global Variables but they use Communication Variables.


9. In the MS-Excel spreadsheet, for all Input References under CrossCommunication.CycleTime column, update the cycle time either by typing, or by selecting the value from the drop-down list for each cell.

Input References under CrossCommunication.CycleTime column should not be kept empty or invalid. It may result in errors during generation of Configuration Data.

10. Generate the Configuration Data for the Function Diagram.

Same set of steps, that is, Step 1 to Step 10, can be used for conversion of Global Variables to Communication Variables for multiple Function Diagrams also.

### Building up Control Structure

The Control Structure gets automatically updated, see Table 11.

**Table 11. Changes in Control Structure**

<table>
<thead>
<tr>
<th>Change in Function Diagram or Functional Structure</th>
<th>Change in Control Structure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instantiate/copy/delete function or procedure</td>
<td>none (Diagram gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete function block or control module as symbol object</td>
<td>none (Diagram gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy function block or control module as aspect object</td>
<td>Function block or control module gets inserted below diagram / allocatable group (Diagram)</td>
</tr>
<tr>
<td>Delete function block or control module aspect object in diagram</td>
<td>Function block or control module gets deleted from diagram / allocatable group (Diagram)</td>
</tr>
<tr>
<td>Change in Function Diagram or Functional Structure</td>
<td>Change in Control Structure</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Delete function block or control module aspect object in Engineering Workplace Advanced Menu Delete from All Structures</td>
<td>Function block or control module gets deleted from diagram / allocatable group (Diagram)</td>
</tr>
<tr>
<td>Delete function block or control module aspect object in Plant Explorer object browser</td>
<td>none. You need to manually remove the instance from the Control Structure.</td>
</tr>
<tr>
<td>Instantiate/copy/delete CBM IO signal</td>
<td>none (Diagram/application gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete diagram parameter</td>
<td>none (Diagram gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete diagram reference and connect to diagram variable</td>
<td>none (Diagram/application get updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete local variable</td>
<td>none (Diagram gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Copy/paste diagram objects</td>
<td>Creates a copy of diagram and put it into the same CBM application. (IO signals need to be reallocated to appropriate hardware units)</td>
</tr>
<tr>
<td>Creates a copy of Functional Structure with same parent</td>
<td>Copy/paste diagram objects (IO signals need to be reallocated to appropriate hardware units)</td>
</tr>
<tr>
<td>Create copies of related diagrams with same parents</td>
<td>Copy/paste application (IO signals need to be reallocated to appropriate hardware units)</td>
</tr>
<tr>
<td>Delete diagram object</td>
<td>Diagram object gets deleted from Control Structure and CBM (and vice versa)</td>
</tr>
<tr>
<td>Allocate diagram / allocatable group</td>
<td>Diagram gets moved from unallocated application to corresponding CB application</td>
</tr>
</tbody>
</table>
Table 11. Changes in Control Structure (Continued)

<table>
<thead>
<tr>
<th>Change in Function Diagram or Functional Structure</th>
<th>Change in Control Structure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate configuration data</td>
<td>Nested (still unallocated) children get moved to corresponding CB application</td>
</tr>
<tr>
<td>Unallocate diagram / allocatable group</td>
<td>Diagram gets moved from CB application to unallocated application</td>
</tr>
</tbody>
</table>

In Engineering Workplace object browser (e.g. Functional Structure):
- Paste moves the cut object to the new parent.
- Cut, Delete, Paste no longer supported.
- Cut, Paste, Paste no longer supported.

Function Designer, Diagram View or Component View
- Cut still copies selected component(s) to the clipboard and deletes them as in previous system versions.
- Paste inserts the components from the clipboard.
- Cut, Paste, Paste still supported.
- Cut in diagram, paste in Plant Explorer object browser (Functional Structure) no longer supported.
- Cut in Plant Explorer object browser (Functional Structure), paste in diagram no longer supported.

Allocating Function Diagrams

After having defined the data flow order, user can allocate the function diagram logic to a specific application. The following requirements must be fulfilled:
- *Control Builder M* (CBM) has to run.
- The corresponding CBM project has to be opened.

Allocation of a Function Diagram
The default allocatable group contains the whole function diagram. The allocated diagram gets a Diagram in the Control Builder M.

![Figure 73. Function Designer Generated Diagram Aspect in Functional Structure](image)

**Unallocation**

To unallocate an already allocated group, click **Allocate / Unallocate Diagram** from the Quick Access toolbar.

- Child diagrams, if any, are also unallocated.
- Control modules and function blocks are unallocated, i.e. moved from the CBM application to the unallocated application.

**Allocating I/O Signals**

After having allocated the logic of the function diagrams to the Control Structure, the I/O signals are to be allocated to hardware objects.

I/O parameters like Channel Settings and Scaling are configured in the **CBM_SignalParameter** aspect. User need not configure the Connection parameters Application, Variable, and Type. These parameters are automatically
updated by Function Designer. Double-click a CBM_Signal to invoke the **Signal Parameters** dialog.

![Image of Signal Parameters dialog]

**Figure 74. I/O SignalParameter Aspect**

The I/O allocation type is configured in the **CBM_SignalInformation** aspect, see **Figure 75**.
Typically, you will create and connect an I/O signal to a local variable. Examples and a description for the other options, e.g. create and connect to local variable, or signal groups, are described in detail in section IO Allocation of System 800xA Engineering, Engineering Studio (3BDS011223*). An example how to configure a signal group is also given in System 800xA Engineering, Function Designer Getting Started (3BDS100968*), subsection Creating a Signal Group Object Type.

Allocation of I/O signals means insertion into the following Control Structure path (see also Figure 76):

**Control Network\CBM_project\Controllers\Controller_n\Hardware\...**, for example: Control Network\CBM_project\Controllers\Controller_n\Hardware\0\11\1 for a CBM_AIS object below a AI810 I/O board on ModuleBus.

*Figure 75. I/O SignalInformation Aspect*
The channel number is configured by the I/O signal’s ChannelNumber aspect, see Figure 77.

Preferably use the I/O Allocation tool, see System 800xA Engineering, Engineering Studio (3BDS011223*).

**Figure 76. I/O Signal Allocation in Control Structure**

**Figure 77. I/O Signal ChannelNumber Aspect**
The I/O Allocation tool can be started in different contexts. To start the tool in the context of a Function Diagram:

1. Either click the IO Allocation icon from the Quick Access menubar, or click Allocation > IO Allocation or right-click on white space of the Function Diagram and click Advanced > IO Allocation. The tool shows all CBM_Signals inserted in the diagram. If they are already allocated, the boards are shown to which the signals are allocated.

2. To allocate a signal and to transfer allocation information and signal parameters to Control Builder M:
   a. Right-click the Boards object.
   b. Click Insert Element.
   c. In the dialog’s Control Structure navigate to and select an appropriate I/O board hard unit, for example AI810 and click Add.
   d. Click Close to close the dialog.
   e. Select one or several signals in the right pane and drag it/them on to the boards object (or on a board object or on a specific channel of a board) in the left pane.
   f. Click File > Generate Configuration Data in Function Designer or Edit > Write Allocation into CBM of the I/O Allocation tool to write results to CBM.

Generating Configuration Data in bulk for the Function Diagrams using Bulk Data Manager, requires more time.

If any Function Diagram is modified, it is advisable to generate Configuration Data for only that Function Diagram.

The graphical symbols for the CBM_Signal object types installed by the Function Designer for AC800M Connect system extension use text and label components with property references in order to display

- I/O signal name
- Designation (location) in Control Structure
- FilterTime (AIS, AOS)
• SignalRange (AIS, AOS)
• Min, Max, Unit (AIS, AOS)
• On-line Values.

**Generate Configuration Data**

After allocation of the diagrams/groups, user generates configuration data to transfer or update the Function Designer data into Control Builder M. In detail, configuration data generation creates/updates

- FD Code Blocks with parameters, variables, communication variables, function blocks, functions, procedures.
- Control modules and connections.
- Control properties.
- Application global and local variables.
- Hardware connections (due to IO Allocation).
- OPC properties.

Start configuration data generation by:

- Function diagram, **Generate Configuration Data (Full Build)** icon or **Generate Configuration Data** icon from the Quick Access toolbar.
- Function diagram, **File > Generate Configuration Data (Full Build)** or **File > Generate Configuration Data**
- Allocatable Group aspect, buttons **Generate Configuration Data (Full Build)** or **Generate Configuration Data**, see Figure 64.
- Allocatable Group aspect verbs **Generate Configuration Data (Full Build)** or **Generate Configuration Data**. This is also useful on **Bulk Generate Configuration Data**.

**Generate Configuration Data (Full Build)** updates all selected diagram(s)/group(s) and their children, independent of the diagram state, see **Instance Specific Initial Values** on page 160.
Generate Configuration Data optimizes the build process and updates diagrams in modified (red) state only. Diagrams in already generated (yellow) or loaded (green) state are not changed.

Changes done in Function Designer after generating configuration data can be handled in two different ways:

- **File > Save** or **File > Save All** saves the changes within Functional Structure. The already generated Single Control Modules and Diagrams within the Control Structure are not updated.

- **File > Generate Configuration Data** saves the changes within Functional Structure and also updates the already generated Single Control Modules and Diagrams within the Control Structure.

- **File > Generate Configuration Data (Full Build)** saves the changes within Functional Structure, and (re)generates configuration data for an already allocated solution in Control Structure.

User can select **File > Save** or **File > Save All** to save the intermediate changes while working with Function Diagrams. Finally the Single Control Modules and Diagrams can be updated by selecting **File > Generate Configuration Data** once.

While working with SPL sub-diagrams, user needs to select **File > Save All** to save the intermediate changes in all SPL sub-elements (Steps, Transitions, N_Action) before generating configuration data. The Function Diagram can be updated by selecting **File > Generate Configuration Data** once.

Before performing the Generate Configuration Data for Function Diagrams, set **ConnectLibsOnGenerateConfigData** property to False, so that the library version of Function Diagram is not replaced by latest ones during the system update. After performing the Generation of Configuration Data for Function Diagrams, change **ConnectLibsOnGenerateConfigData** property to True.

Variable Creation

In **Control Builder M**, variables are used for the following kinds of connection:

- Connections between Blocks inside an Allocatable Group
- Connections across Diagrams (horizontal cross references)
- Connections to I/O Channels
Connections from I/O Channels

The following table contains the descriptions of abbreviations used in the tables of this section:

Table 12. AC 800M Connect: Abbreviations

<table>
<thead>
<tr>
<th>Action Abbreviation</th>
<th>Action Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccessVar</td>
<td>Create Access Variable</td>
</tr>
<tr>
<td>Appl: GlobVar</td>
<td>Create global variable on application (editor) level</td>
</tr>
<tr>
<td>CM</td>
<td>Control module</td>
</tr>
<tr>
<td>FB</td>
<td>Function block</td>
</tr>
<tr>
<td>DT</td>
<td>Diagram Type</td>
</tr>
<tr>
<td>FUN</td>
<td>Function</td>
</tr>
<tr>
<td>Parent SCM</td>
<td>SCM one level above (within nested Allocatable Groups)</td>
</tr>
<tr>
<td>SCM</td>
<td>Single control module (= Allocatable group)</td>
</tr>
<tr>
<td>SCM: Var</td>
<td>Creates variable on single control module (editor) level</td>
</tr>
<tr>
<td>SCM: Ext.Var</td>
<td>Creates external variable on single control module (editor) level</td>
</tr>
<tr>
<td>SCM: Par</td>
<td>Creates Parameter on single control module (editor) level</td>
</tr>
<tr>
<td>TmpVar</td>
<td>Creates direct logic connection (= temporary variable in ST Code)</td>
</tr>
<tr>
<td>Diagram:Comm Var</td>
<td>Create Communication variable on Diagram</td>
</tr>
<tr>
<td>Diagram:Var</td>
<td>Create a Variable on Diagram</td>
</tr>
</tbody>
</table>

Connections between Blocks inside an Allocatable Group

If there are connections between blocks (functions, function blocks, control modules) inside an allocatable group, the following variables will be created:

Table 13. Connections of Blocks Inside an Allocatable Group

<table>
<thead>
<tr>
<th>Target</th>
<th>Source</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
<th>DT</th>
</tr>
</thead>
<tbody>
<tr>
<td>FB</td>
<td>TmpVar</td>
<td>SCM/Diagram: Var</td>
<td>TmpVar</td>
<td>Diagram: Var</td>
<td></td>
</tr>
</tbody>
</table>
The variable will be named according to the rule ‘__+link+[unique number]’ if the connections don’t have a label. If you have defined a labelled connection, the name of the label is taken for the variable name (Var instead a TmpVar in the table above).

Connections across Diagrams (horizontal cross references)

If there are cross reference connections across diagrams, the diagram reference objects are used and the following variables will be used:

Table 14. Diagram References\(^{(1)}\)

<table>
<thead>
<tr>
<th>Target (\Rightarrow) Source (\Leftrightarrow)</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
<th>DT</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM</td>
<td>SCM/Diagram: Var</td>
<td>SCM/Diagram: Var</td>
<td>SCM/Diagram: Var</td>
<td>Diagram: Var</td>
</tr>
<tr>
<td>FUN</td>
<td>TmpVar</td>
<td>SCM/Diagram: Var</td>
<td>TmpVar</td>
<td>Diagram: Var</td>
</tr>
<tr>
<td>DT</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
</tr>
</tbody>
</table>

\(^{(1)}\) The abbreviations are described in Table 12

Table 13. Connections of Blocks Inside an Allocatable Group\(^{(1)}\)

<table>
<thead>
<tr>
<th>Target (\Rightarrow) Source (\Leftrightarrow)</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
<th>DT</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM</td>
<td>SCM/Diagram: Var</td>
<td>SCM/Diagram: Var</td>
<td>SCM/Diagram: Var</td>
<td>Diagram: Var</td>
</tr>
<tr>
<td>FUN</td>
<td>TmpVar</td>
<td>SCM/Diagram: Var</td>
<td>TmpVar</td>
<td>Diagram: Var</td>
</tr>
<tr>
<td>DT</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
</tr>
</tbody>
</table>
Table 14. Diagram References

<table>
<thead>
<tr>
<th>FUN</th>
<th>Appl: GlobVar</th>
<th>SCM: External Var/Comm Var</th>
<th>Diagram: Comm Var</th>
</tr>
</thead>
<tbody>
<tr>
<td>DT</td>
<td>Diagram: Comm Var</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

(1) The abbreviations are described in Table 12

Table 15. Diagram References

<table>
<thead>
<tr>
<th>Target (outside AG)</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
<th>DT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

+-------------------+-----------------+-----------------+-----------------+-----------------|
| Diagram Reference | Appl: GlobVar   | Appl: GlobVar   | Appl: GlobVar   | Diagram: Comm Var |
|                   | SCM: External Var / Comm Var | SCM: External Var / Comm Var | SCM: External Var / Comm Var |     |
|                   | Diagram: Comm Var | Diagram: Comm Var | Diagram: Comm Var |     |

(1) The abbreviations are described in Table 12

Connections to I/O Channels

If there are connections to I/O channels, the following variables will be used:

Table 16. Connections to I/O Channels

<table>
<thead>
<tr>
<th>Target (outside AG)</th>
<th>I/O: Out</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FB</th>
<th>Appl: GlobVar</th>
<th>SCM: Ext.Var</th>
<th>Diagram: Var</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM</td>
<td>Appl: GlobVar</td>
<td>SCM: Ext.Var</td>
<td>Diagram: Var</td>
</tr>
</tbody>
</table>
Connections from I/O Channels

If there are connections from I/O channels, the following variables will be used:

Table 16. Connections to I/O Channels\(^{(1)}\)

<table>
<thead>
<tr>
<th>FUN</th>
<th>Appl: GlobVar</th>
<th>SCM: Ext.Var</th>
<th>Diagram: Var</th>
</tr>
</thead>
<tbody>
<tr>
<td>DT</td>
<td>Diagram: Var</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

(1) The abbreviations are described in Table 12

Connections from I/O Channels

If there are connections from I/O channels, the following variables will be used:

Table 17. Connections from I/O Channels\(^{(1)}\)

<table>
<thead>
<tr>
<th>Target (outside AG)</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
<th>DT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>I/O: In</td>
<td>Appl: GlobVar</td>
<td>Appl: GlobVar</td>
<td>Appl: GlobVar</td>
<td>Diagram: Var</td>
</tr>
<tr>
<td></td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
<td>Diagram: Var</td>
</tr>
</tbody>
</table>

(1) The abbreviations are described in Table 12

Annotation

For all two kinds of connections (Diagram References - I/Os) ‘MOVE’ blocks are inserted.

Connection and Inversion Checks

General

When two ports are connected to each other, or when one port is connected to an existing network, variable or to a constant, plausibility checks are executed. The same applies when a port is going to be inverted.

If the plausibility checks fail, the faulty connection or inversion is tolerated and visualized by a red line or red circle, respectively. Corresponding warnings/errors are written to the output window.
Direction Rules for Data Connections

The source attribute indicates a value. This value is transferred to the destination attribute.

Consequently in a data connection, a connection port referring to:

- an input (in) parameter can serve only as a destination.
- an output (out) parameter can serve only as a source.
- an input/output (in_out) parameter can serve only as a destination.

An input/output (in_out) port can not accept connections from input references (communication variables) and other output (out) ports.

Figure 78 provides the possible combinations of sources and destinations for data connections when applied to parameters. Figure 78 does not apply for function return values.
Connection and Inversion Checks

Section 2 Configuration

Checks for Connections
For port-to-port, port-to-network, port-to-variable, and port-to-constant connections the data types of the two objects have to be the same (exception: there is no data type check if one of the related objects has got the data type 'any').

Checks for Inversions
• Output ports and inout ports cannot not be inverted.
• Only ports with data type 'boolean' (or 'generic' or 'any') can be inverted.
Checking of constant literals

- **Data Type REAL**
  A real constant is checked for the legal range
  \[-3.402823466e+38 \leq \text{real} \leq 3.402823466e+38\]

- **Data Type INT, DINT, UINT, WORD, DWORD**
  The constants are checked for legal range
  \[-32768 \leq \text{int} \leq 32767\]
  \[0 \leq \text{uint} \leq 65535 \quad (= \text{word})\]
  \[-2,147,483,648 \leq \text{dint} \leq 2,147,483,647\]
  \[0 \leq \text{dword} \leq 4,294,967,295\]

Numbers to bases other than 10 are represented in base 2, 8 or 16
(prefix 2#, 8# or 16#),

- **Data Type BOOL**
  Valid constants for BOOL are 0, 1, FALSE, TRUE (case insensitive)

- **Data Type TIME (= duration)**
  Time literals are written in the form \(<n>d<n>h<n>m<n>s<n>ms\) where
  \(d = \text{days}, \ h = \text{hours}, \ m = \text{minutes}, \ s = \text{seconds}, \ ms = \text{milliseconds}, \)
  \(<n> = \text{a positive integer.}\)
  An optional prefix T# or TIME# can be used.

- **Data Type DATE_AND_TIME**
  This type is presented in ISO_Format (YYYY-MM-DD-hh:mm:ss.ttt)
  The minimum date is 1979-12-31-00:00:00.000.
  An optional prefix DT# can be used.

**Visualization**

Faulty connections / inversions are indicated in red color. For faulty port-to-port
connections the link indicating the connection is drawn red. For faulty variable or
constant connections the connection string is drawn in red color. A red circle
indicates faulty inversions, see Figure 80.
Invocation of the Checks

The connection checks are executed when a port is going to be connected / inverted. If the checks fail a message box is popped up with an according error text. For connections leading to implicit casts a warning is issued in interactive mode only.

Figure 79. Warning Implicit Casts

When opening a diagram the checks are performed for all connections / inversions on the diagram. The error texts for failed checks are collected and displayed in the output window. A possibility to navigate to the faulty connection by double-clicking the error message in the output window is provided, see Figure 80.
Additionally, the checks run

- On Function Designer menu item **File > Check**. It provides the same functionality as if the diagram is opened (see above). For diagrams with child diagrams this function has an option to check the whole tree of diagrams.

- Before allocating/generating configuration data for Control Builder M. If the checks fail with error, configuration data generation does not start.

![Diagram with Errors in Connections and Inversions](image)

*Figure 80. Diagram with Errors in Connections and Inversions*

**Splitter and Joiner**

In systems prior to 800xA 5.1, connection mapping automatically creates and connects the different structured data types by instantiating the local variables. Dependent on the data type, one or more local variables get created and connected between the desired ports.
From 800xA 5.1 onwards the connection mapping between function blocks that do not have Data Flow Order is not supported. Splitter and Joiner blocks which has Data Flow Order, are introduced to establish the connection mapping between the structured and basic data types.

Constant values can not be assigned to local variables but can be assigned to joiner function blocks.

The splitter and joiner function blocks can be invoked by any of the following methods:

1. Select the required port of the control module / function block. Right-click and select **New Splitter** or **New Joiner** options from the available context menu as shown in Figure 81.

2. Select the splitter or joiner function block by navigating to the required object from the Insert > Object dialog, as shown in Figure 81.

3. Drag & drop the required splitter or joiner function block from Object Type Structure as shown in Figure 81.

![Figure 81. Splitter and Joiner Invocation Methods](image)
A splitter or joiner is inserted based on the following conditions (refer to Figure 82):

- If the direction of the selected port is *input*, then a joiner is inserted.
- If the direction of the selected port is *output*, then a splitter is inserted.

![Function Diagram with Splitter and Joiner Connections](image)

*Figure 82. Function Diagram with Splitter and Joiner Connections*

### Limitations of Splitter and Joiner Blocks

Following are some of the limitations of *Splitter* and *Joiner* blocks:

1. Direct connection from a joiner block to a splitter block is not supported.
2. INOUT ports support splitter and joiner blocks through an implicit Move block.

### Connection Mapping

Use the function **Connection Mapping** to connect ports of different structured data type. This function is implicitly invoked for connections that cannot be automatically cast. User can also explicitly invoke the Connection Mapping command from a link or a variable component. In both cases, user can select which substructures shall be interconnected. Necessary splitter or joiner and links get automatically created. For more details, refer to **Connection Mapping** on page 532.
Instance Specific Initial Values

Function Blocks and Control Modules provide the possibility to set instance specific initial values for most of the unconnected ports. Then, independent of the object type, the instance will get an instance specific initial value for that unconnected port, if desired:

Most of the ports of a function block or control module contain two aspect properties regarding initial values. For example see Figure 83: Port ‘PriorityCmd1’ has aspect properties

- PriorityCmd1.InitVal
- PriorityCmd1.InitValOfObjectType

If the PriorityCmd1.InitVal is set to ‘true’ for example, then - after configuration data generation - this value gets configured in the Control Properties aspect of that
control module. During download into the controller this port gets an instance specific initial value of value ‘true’.

![Control Properties After Configuration Data Generation for the Example in Figure 83 Above](image)

**Figure 84. Control Properties After Configuration Data Generation for the Example in Figure 83 Above**

**Hints:**

- For function blocks all unconnected ports can be configured, which provide an ‘InitVal’ aspect property.
- For control modules, only unconnected ports which have an ‘InitValOfObjectType’ of Value ‘default’ can get an instance specific initial value, because only these ports have a corresponding control property. If you specify ‘InitVal’ at other ports you will get a warning on configuration data generation.
- Modifications of the ‘InitVal’ property within the Control Properties aspect directly are currently not reflected back to Function Designer.
Consistency

General

To address both authority/access control and consistency of Function Designer generated configuration data, function diagrams follow a state model.

Consistency guarantees, that:

a. Code blocks that have been generated by Function Designer cannot be modified in Control Builder (locking).

b. Any modifications of objects that are generated by Function Designer (global variables, Object Names, …) which are not locked inside Control Builder nor in Plant Explorer are correctly reflected in Function Designer.

In addition, diagram states answer the following questions:

a. Which diagrams are not yet been allocated to any application?

b. Which diagrams are actually loaded into the controller?

c. Which diagrams have been altered since loading them into the controller?

If a Function block that is inserted under a Function Diagram is dragged and dropped under another Function Diagram in the Functional Structure, then errors may be reported during a Consistency Check.

Diagram States and Transitions

The following figure shows the different states of a diagram that is based on a writeable Function aspect in Functional Structure. Function Diagrams that are build in Object Type Structure and Function Diagrams with an inherited Function aspect follow different state models, which are described in Consistency for Diagrams created from Control Module Types and in Consistency for Diagrams in Object Type Structure.

Audit Trail

Specific Audit-Trail messages are written when the diagram state changes.
Section 2  Configuration

Consistency

The diagram state is indicated in Function Designer’s status bar. Diagram state is explained in System 800xA Engineering, Function Designer Getting Started (3BDS100968*), subsection Verifying Diagram States.

Figure 85. Diagram States

The diagram state is indicated in Function Designer’s status bar. Diagram state is explained in System 800xA Engineering, Function Designer Getting Started (3BDS100968*), subsection Verifying Diagram States.

Figure 86. Diagram Status
The status of all diagrams in a (sub) tree of a structure can also be checked using the System Status Viewer.

**Figure 87. System Status Viewer**

**Consistency for Diagrams created from Control Module Types**

Instances of Control Modules are based on a Control Module type. You cannot modify any content of the Control Module. Any changes of

- connections of the Control Module
- initial values of the Control Module

are regarded as being changes to the container of the Control Module. The following objects can act as containers for Control Modules:

- Control Modules
- Diagrams / Single Control Modules
- Applications
For Control Modules, Function Designer does not generate any code. It just writes the connections of the Control Module. So, there is no state ‘Generated’.

For Control Modules, Function Designer does not generate any code. It just writes the connections of the Control Module. So, there is no state ‘Generated’.

**Figure 88. State Model for Diagrams Created from Diagram Types**

**Consistency for Diagrams in Object Type Structure**

Function Diagrams that are created in Object Type structure to build Control Module types follow a different state model. They are never ‘Allocated’ (moved into Control Structure) nor ‘Loaded’.

**Figure 89** shows the reduced state diagram for this type of Function Diagrams:

**Figure 89. State Model for Diagram Types**
Diagram Status Display

A diagram makes its status (Modified, Allocated...) available to the system via a number of properties. These properties are read (for example) by the System Status Viewer. The following table describes these properties.

Table 18. System Status Properties

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S_STATUS</td>
<td>The status of the diagram as integer value.</td>
</tr>
<tr>
<td>S_DESCRIPTION</td>
<td>A textual description of the diagram status.</td>
</tr>
<tr>
<td>S_TIME</td>
<td>Time stamp of the diagram.</td>
</tr>
<tr>
<td>S_FUD_STATUS</td>
<td>Same as S_STATUS</td>
</tr>
<tr>
<td>S_FUD_DESCRIPTION</td>
<td>Same as S_DESCRIPTION</td>
</tr>
<tr>
<td>S_FUD_TIME</td>
<td>Same as S_TIME</td>
</tr>
</tbody>
</table>

For complex objects, the status of the Function Diagram may only represent a fraction of object’s status. To get a combined status information, do the following:
1. Select the **Publish Status Information** check box in the Allocatable Group aspect.

![Allocatable Group window](image)

*Figure 90. Allocatable Group*

This prevents the Function Designer from publishing the status properties ‘S_STATUS’, ‘S_DESCRIPTION’ and ‘S_TIME’.
2. Setup an aspect of the category “Property Translation Extended”.

**Figure 91. Property Translations**

**Cross References**

Function Designer creates communication variables in Control Builder to implement the data exchange between diagrams. Function Designer informs the user about the usage of these variables in form of a cross-reference list that is attached to the variable as shown in the **Figure 92**.

**Figure 92. Graphical Representation of Cross References**
Enhanced Naming

This section describes the enhanced name handling functions in the Engineering Workplace of System 800xA. They take care of names according to KKS naming rules and parent-child name concatenation.

Dialog New Component Name

When you insert a new component into a diagram, a dialog prompts for its name and description. How to insert new components, see Inserting Designer Components on page 401.

The default name takes the diagram name as prefix, adds a ‘_’, the object type name, and a unique running number 1,2...N. E.g. 1ABC_UniM1. If you have already existing components of the same type, the default name is the name of an existing object with a unique running number. The name pattern used in this dialog is defined in the Function Settings aspect, see Function Settings.

Figure 93. Dialog New Component Name
This dialog may be switched off for specific component types, see Options on page 511 and Naming on page 515.

**Name Conversion**

Each Aspect Object in the Plant Explorer has a Name aspect, which contains the corresponding aspect object name and description. For control objects there is an additional Control Builder Name (CBName) aspect, which gets synchronized with the name in Project Explorer, and therefore always follows IEC 61131-3 naming conventions, see also *System 800xA Control, AC 800M Configuration* (*3BSE035980*). If the control object is created in Plant Explorer and the name is in conflict with the IEC 61131-3 name restrictions, the aspect system automatically converts the name so that it follows these rules.

If a name is entered in Plant Explorer that does not follow IEC 61131-3 naming conventions, the Project Explorer name will be changed to fit the IEC 61131-3 naming conventions. If we, in Plant Explorer, name a tank object "12-1456%tank", the Control Builder conversion would look like "x12_1456_tank". The automatic name conversion function always adds an “x” to the beginning of the name and replaces all non-alphanumeric characters with underscore. Names of newly created Function Diagrams and its child objects should not exceed 32 characters. For restored diagrams, if the name is longer than 32 characters, it will be truncated.
Figure 94. Diagram with Conflicts to IEC 61131-3 Names

Figure 94 shows an example for components with names, which are in conflict with the IEC 61131-3 name restrictions. The Control Module and the signals have an additional CBName aspect. The name of the diagram variable and other local variables have to fulfill IEC 61131-3 name restrictions. Figure 95 and Figure 96 show the Control Builder view for this example.

Figure 95. Objects in Control Builder

<table>
<thead>
<tr>
<th>Name</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>x1ABC_D81_FB0</td>
<td>BoolIO</td>
</tr>
<tr>
<td>x1ABC_D81_FB1</td>
<td>BoolIO</td>
</tr>
<tr>
<td>x1ABC_D81_Out0</td>
<td>BoolIO</td>
</tr>
<tr>
<td>x1ABC_D81_Out1</td>
<td>BoolIO</td>
</tr>
<tr>
<td>x1ABC_Ref1</td>
<td>BoolIO</td>
</tr>
</tbody>
</table>

Figure 96. Generated Variables in Control Builder
Name Synchronization

For engineering efficiency, Function Designer synchronizes the *Name* aspect, *CBName* aspect, *Name* parameter and *Description* parameter. The advantage of having synchronized names is that objects always have the same name in Plant Explorer and Project Explorer with the exception of IEC 61131-3 name restrictions, see Name Conversion on page 170.

Many Function Blocks and Control Modules have a *Name* and *Description* parameter, which are important for alarm handling. You connect these parameters to a constant value or to some logic instead. If the parameters are connected to a constant, the values are synchronized to the *Name* aspect.

When an aspect object is renamed, the related *CBName* aspect and the *Name* parameter is updated. When an object description is modified, the related *Description* parameter is updated.

Because of that name synchronization you do not need to run Name Uploader for Function Designer engineered diagrams. In effect, if you do so, name synchronization is switched off while Name Uploader is running.

Synchronization between Name aspect and parameters at Function Blocks/Control Modules can be disabled in Function Settings aspect.

This aspect is located in [Object Type Structure]ObjectTypes.FunctionalPlanning.Settings.

In order to disable synchronization for the whole system, set property Naming.SynchronizeParameters to "false". Especially this function setting should be set to "false" in case of an upgrade from 800xA 3.1 or 800xA 4.1 to 800xA 5.1.

Aspect Verb Synchronize Names

Name aspect, Control Builder Name aspect, name parameters and description parameters are synchronized during engineering. If you right-click on the Function aspect of a diagram, you may trigger the name synchronization for the diagram and the related sub-tree manually.
**Rename Substructure**

When you rename a diagram, the names of the children are renamed too, if these start with the same prefix. In the following example the diagram 1ABC is copied with Bulk Data Manager to 1ABD and 1ABE, see Figure 97 and Figure 98.

<table>
<thead>
<tr>
<th>Command</th>
<th>Object Identification</th>
<th>Source Object</th>
</tr>
</thead>
<tbody>
<tr>
<td>[DIRECT]</td>
<td>[Functional Structure]</td>
<td>[DIRECT]</td>
</tr>
<tr>
<td></td>
<td>Root:Naming.1ABC</td>
<td>Root:Naming.1ABC</td>
</tr>
<tr>
<td>[DIRECT]</td>
<td>[Functional Structure]</td>
<td>[DIRECT]</td>
</tr>
<tr>
<td></td>
<td>Root:Naming.1ABC</td>
<td>Root:Naming.1ABC</td>
</tr>
<tr>
<td>[DIRECT]</td>
<td>[Functional Structure]</td>
<td>[DIRECT]</td>
</tr>
<tr>
<td></td>
<td>Root:Naming.1ABC</td>
<td>Root:Naming.1ABC</td>
</tr>
</tbody>
</table>

**Figure 97. Excel Sheet for Diagram Copy**

**Figure 98. Result of Copy Diagram with BDM in Plant Explorer**
When you copy the diagram 1ABC in Plant Explorer, you get a result according to Figure 99. The copied objects have the same object names as in the source.

However, the Control Builder name of the corresponding SCM can be renamed (extended by a number), because of name collisions in the Unallocated_Inst_App application. To rename the whole substructure you can use the object item Advanced > Rename Substructure.

It is recommended not to use Advanced > Rename Substructure when Naming is set to None in the Function Settings aspect of the Settings object.

**Rename Function Diagrams**

The following workflow is used frequently with Function Designer:

1. You prepare a Function Diagram in Function Structure.
2. You copy this diagram with Bulk Data Manager in Functional Structure. The copied diagram gets a new name.

Function Designer supports automatic renaming of the components within the diagram according to two concepts. In addition configurable naming rules are supported.
Two naming concepts are supported:

- Naming with name pattern.
- Automatic naming.

The actual used concept is determined by a Property “Naming” stored in Aspect “Function Settings” of Object “Settings” ([Object Type Structure]Functional Planning). It is possible to switch between both concepts or to switch off automatic renaming during copy/paste completely.

- The property Naming may have the following values:
  - None - Do not rename on copy/paste.
  - Auto – use automatic naming.
  - Pattern – use name pattern for renaming.
The name pattern is defined in Sub-Property “NamePattern”.

Figure 100. Global Definition of Naming and Name Pattern
Name Pattern

Name Pattern Definitions

There are two different name patterns defined:

1. Simple name pattern
2. Standard name pattern

Either a simple name pattern or alternatively a standard name pattern has to be used.

1. Simple Name Pattern Definition

A Simple Name Pattern is defined like this:

- `?`: any single character
- `*`: one or more characters

Samples:

<table>
<thead>
<tr>
<th>Diagram Name</th>
<th>Name Pattern</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>*???</td>
<td>Replaces 'PRC1111' in child names</td>
</tr>
<tr>
<td>PRC1111_FD</td>
<td>???*???</td>
<td>Replaces '1111' in child names</td>
</tr>
</tbody>
</table>

If the substring is found more than once in child names then only the first substring will be replaced.

Default Function Setting for Naming = “Pattern”, and NamePattern = “*”.

To improve the engineering efficiency, Function Designer deletes the _FD and _FUD indexes automatically from the proposed name when creating new objects or assigning diagram variables. This can be configured in Function Settings Aspect.

2. Standard Name Pattern Definition

A Standard Name Pattern is defined like this:

- `N`: a digit 0-9
- L: any character (not a digit)
- (): parts included in parenthesis are optional
- \x: x is a specific fixed character, escaped by \ 
\x can be used to define a fixed character within the pattern.

**Samples:**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LLLNNNNN</td>
<td>3 characters followed by 4 digits</td>
</tr>
<tr>
<td>NNNLLNNNN(N)</td>
<td>3 digits, then 2 characters followed by 3 or 4 digits</td>
</tr>
<tr>
<td>LL(L)NN(N)(N)</td>
<td>2 or 3 characters followed by 2,3 or 4 digits</td>
</tr>
<tr>
<td>LL(L)NN(NN)</td>
<td>2 or 3 characters followed by 2 or 4 digits</td>
</tr>
<tr>
<td>LLLNNNN_</td>
<td>3 characters followed by 4 digits and the character _</td>
</tr>
<tr>
<td>LLLNNNN\N</td>
<td>3 characters followed by 4 digits and the character N</td>
</tr>
</tbody>
</table>

**Renaming with Name Pattern**

During copy Function Designer checks the name of the source diagram and the name of the target diagram. If both names match a name pattern, the differences within the name pattern are recognized. It is not necessary, that a name pattern matches the complete name. A name pattern defines only a substring within a name, which is subject to be changed during copy. The copied components of the diagram are renamed based on the name changes done for the parent diagram within the name pattern.

A common name pattern should be defined as long as possible. Replacements are more flexible and reliable with longer name patterns.

Characters outside the name pattern are not modified at all. Names of components, which do not fit to the pattern, are not modified.

**Samples**

<table>
<thead>
<tr>
<th>Name Pattern</th>
<th>LLLNNNNN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Result</td>
</tr>
</tbody>
</table>
### Enhanced Naming

<table>
<thead>
<tr>
<th>Name Pattern</th>
<th>NNNLLNNN(N)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source</strong></td>
<td><strong>Result</strong></td>
</tr>
<tr>
<td>123LT2546_Fud</td>
<td>123LT455_Fud</td>
</tr>
<tr>
<td>123LT2546</td>
<td>123LT455</td>
</tr>
<tr>
<td>123LT2546_1</td>
<td>123LT455_1</td>
</tr>
<tr>
<td>123LT2546_Intl</td>
<td>123LT455_Intl</td>
</tr>
<tr>
<td>AlcBlk</td>
<td>AlcBlk</td>
</tr>
<tr>
<td>MV_LT_H1_</td>
<td>MV_LT_H1_</td>
</tr>
<tr>
<td>MV_GT_H1_</td>
<td>MV_GT_H1_</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name Pattern</th>
<th>NNLLNN</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source</strong></td>
<td><strong>Result</strong></td>
</tr>
<tr>
<td>51CD05</td>
<td>52CD07</td>
</tr>
<tr>
<td>51CD05_EinR</td>
<td>52CD07_EinR</td>
</tr>
<tr>
<td>51CD05_GrpR</td>
<td>52CD07_GrpR</td>
</tr>
<tr>
<td>51CD05X</td>
<td>52CD07X</td>
</tr>
<tr>
<td>51CD05</td>
<td>52CD07</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name Pattern</th>
<th>LLL(L)NN(N)(N)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source</strong></td>
<td><strong>Result</strong></td>
</tr>
</tbody>
</table>

---

**Value**

**Alarm**
### Enhanced Naming Section 2 Configuration

<table>
<thead>
<tr>
<th>Source</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>XYC122_FD</td>
</tr>
<tr>
<td>PRC1111</td>
<td>XYC122</td>
</tr>
<tr>
<td>PVCD1111_STO</td>
<td>XYCD122_STO</td>
</tr>
<tr>
<td>PRXY1111_STO</td>
<td>XYXY122_STO</td>
</tr>
<tr>
<td>Inc</td>
<td>Inc</td>
</tr>
<tr>
<td>Dec</td>
<td>Dec</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRCD1111_FD</td>
<td>PRA1111_FD</td>
</tr>
<tr>
<td>PRC1111</td>
<td>PRA1111</td>
</tr>
<tr>
<td>PVCD1111_STO</td>
<td>PVA1111_STO</td>
</tr>
<tr>
<td>PRXY1111_STO</td>
<td>PRA1111_STO</td>
</tr>
<tr>
<td>Inc</td>
<td>Inc</td>
</tr>
<tr>
<td>Dec</td>
<td>Dec</td>
</tr>
</tbody>
</table>

PVCD1111_STO was renamed to PVA1111_STO, because 3rd character was modified from C to A and 4. optional character was removed.
Name Pattern LLL(L)NN(N)(N)

<table>
<thead>
<tr>
<th>Source</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>PRCD11_FD</td>
</tr>
<tr>
<td>PRC1111</td>
<td>PRCD11</td>
</tr>
<tr>
<td>PVCD1111_STO</td>
<td>PVCDD11_STO</td>
</tr>
<tr>
<td>PRXY1111_STO</td>
<td>PRXYD11_STO</td>
</tr>
<tr>
<td>Inc</td>
<td>Inc</td>
</tr>
<tr>
<td>Dec</td>
<td>Dec</td>
</tr>
</tbody>
</table>

Optional character D was inserted.

**Renaming with Name Pattern = ***

This specific Name Pattern = * setting handles renaming in two different ways.

1. Splitting source text strings into substring tokens and rename them.
2. Splitting digits present in the source string into separate characters and rename them.

For example PRC1111_FD CONTROL will be divided into substring tokens such as PRC, 1111, _, RD, single space, and CONTROL.

**Samples for Renaming with Name Pattern = * setting**

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC33_FD</td>
<td>PRC34_FD</td>
<td>Replace substring token 33 with 34</td>
<td>PRC34_FD</td>
</tr>
<tr>
<td>PRC33</td>
<td>PRC34</td>
<td></td>
<td>PRC34_STO</td>
</tr>
<tr>
<td>PRC33_STO</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC33_FD</td>
<td>PRC314_FD</td>
<td>Replace substring token 33 with 314</td>
<td>PRC314_FD</td>
</tr>
<tr>
<td>MV_PRC33_H1</td>
<td>MV_PRC314_H1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MV_PRC33_H2</td>
<td>MV_PRC314_H2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Enhanced Naming

#### Section 2  Configuration

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC33_FD</td>
<td>HH_PRC314_FD</td>
<td>Insert HH_ before PRC and replace 33 with 314</td>
<td>HH_PRC314_FD</td>
</tr>
<tr>
<td>MV_PRC33_HH</td>
<td>HH_PRC314_HH</td>
<td>Replace substring token 33 with 314 and add _H1 after HH</td>
<td>HH_PRC314_HH_H1</td>
</tr>
<tr>
<td>MV_PRC33</td>
<td>MV_PRC314_HH_H1</td>
<td></td>
<td>MV_PRC314_HH_H1</td>
</tr>
</tbody>
</table>

**Replace substring token 33 with 314 and add _H1 after HH.**
Section 2  Configuration

Enhanced Naming

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC33_FD</td>
<td><strong>PR_HH33_FD</strong></td>
<td>Replace PRC with PR and insert _HH between PRC and 33</td>
<td><strong>PR_HH33_FD</strong></td>
</tr>
<tr>
<td>PRC33_HH1</td>
<td><strong>PR_HH33_HH1</strong></td>
<td></td>
<td><strong>PR_HH33_HH1</strong></td>
</tr>
<tr>
<td>PRC33_HH2</td>
<td><strong>PR_HH33_HH2</strong></td>
<td></td>
<td><strong>PR_HH33_HH2</strong></td>
</tr>
<tr>
<td>ARC33_HH1</td>
<td><strong>ARC33_HH1</strong></td>
<td></td>
<td><strong>ARC33_HH1</strong></td>
</tr>
<tr>
<td>PRC35_HH1</td>
<td><strong>PR35_HH1</strong></td>
<td></td>
<td><strong>PR35_HH1</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC30_FD</td>
<td><strong>PRC40_FD</strong></td>
<td>Replace 30 with 40 or perform character replacement for digits. i.e. replace 3 with 4</td>
<td><strong>PRC40_FD</strong></td>
</tr>
<tr>
<td>PRC31_FD</td>
<td><strong>PRC41_FD</strong></td>
<td></td>
<td><strong>PRC41_FD</strong></td>
</tr>
<tr>
<td>PRC32_HH</td>
<td><strong>PRC42_HH</strong></td>
<td></td>
<td><strong>PRC42_HH</strong></td>
</tr>
</tbody>
</table>

**Definition of Name Patterns**

A name pattern can be defined in Functional Settings aspect in Object Type Structure, see Figure 100. This name pattern is the global default for all Function diagrams.

Alternatively a name pattern can be defined for specific Function diagrams. In this case an aspect property "NamePattern" can be added to the diagram aspect properties. To do this right mouse click on the background of the diagram and select “Aspect Properties...”. In the upcoming dialog select tab “All”, right mouse click again and select “Add Property”. Add the property according to Figure 101.
Search Strategy for Name Pattern

A name pattern is searched in the following order:

- Function Designer searches first for aspect property "NamePattern" within the copied Function Diagram. If there is one, the pattern is defined locally for the specific diagram. The aspect property will be copied/imported/exported together with the diagram.

- If aspect property is not found, Function Designer searches in Functional Settings aspect in Object Type Structure. In this case the pattern is defined globally for all Function Diagrams, if not overwritten by an aspect property.
• If no name pattern is found or if the name pattern does not fit to the old and the new name, the automatic naming algorithm is used.

The Pattern naming algorithm can be switched off in Functional Settings aspect, see Figure 100.

**Automatic Naming**

A project may define a name pattern as described in Name Pattern on page 177. If the Naming property in Functional Settings aspect is set to Auto (or a name pattern is not defined), see Figure 100, Function Designer does the renaming based on the differences between the source and target name.

For that reason the names are split into tokens identifying unmodified/modified substrings and numbers. The result is a to-do list to be applied to component names.

This to-do list may contain several of the following commands:

• Replace substring by other substring
• Replace number by other number
• Delete substring
• Insert substring
• Add prefix
• Add postfix

Sometimes the position within a component name cannot be located precisely, especially if substrings are very short. In this case the previous or next character are checked in addition in order to find the correct position.

Auto(matic) naming algorithm is set as the default naming algorithm. It may be switched off in Functional Settings aspect, see Figure 100.

**Samples for Automatic Renaming**

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>PRC1_FD</td>
<td>Replace 1111 by 1</td>
<td>PRC1_FD</td>
</tr>
<tr>
<td>PRC1111</td>
<td>PRC1</td>
<td></td>
<td>PRC1</td>
</tr>
<tr>
<td>PRC1111_STO</td>
<td>PRC1_STO</td>
<td></td>
<td>PRC1_STO</td>
</tr>
<tr>
<td>PRC1111_</td>
<td>PRC1_</td>
<td></td>
<td>PRC1_</td>
</tr>
</tbody>
</table>
### Enhanced Naming

#### Section 2: Configuration

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>PRC1111</td>
<td>Remove _FD</td>
<td>PRC1111</td>
</tr>
<tr>
<td>PRC1111</td>
<td></td>
<td></td>
<td>PRC1111</td>
</tr>
<tr>
<td>PRC1111_STO</td>
<td></td>
<td></td>
<td>PRC1111_STO</td>
</tr>
<tr>
<td>PRC1111_FD_INC1</td>
<td></td>
<td></td>
<td>PRC1111_INC1</td>
</tr>
<tr>
<td>PRC1111_FD</td>
<td></td>
<td></td>
<td>PRC1111</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIS01_FUD</td>
<td>123AI456_FUD</td>
<td>Add prefix 123 replace AIS by AI replace 01 by 456</td>
<td>123AI456_FUD</td>
</tr>
<tr>
<td>AIS01</td>
<td></td>
<td></td>
<td>123AI456</td>
</tr>
<tr>
<td>AIS01_Intl</td>
<td></td>
<td></td>
<td>123AI456_Intl</td>
</tr>
<tr>
<td>AIS01_MV</td>
<td></td>
<td></td>
<td>123AI456_MV</td>
</tr>
<tr>
<td>AlcBlk</td>
<td></td>
<td></td>
<td>123AlcBlk</td>
</tr>
<tr>
<td>MV_GT_L1_</td>
<td></td>
<td></td>
<td>123MV_GT_L1_</td>
</tr>
<tr>
<td>MV_LT_H1_</td>
<td></td>
<td></td>
<td>123MV_LT_H1_</td>
</tr>
<tr>
<td>Value</td>
<td></td>
<td></td>
<td>123Value</td>
</tr>
</tbody>
</table>
Alternative solution for previous sample with pattern (NNN)LL(L)NN(N)(LLLLL)

<table>
<thead>
<tr>
<th>Source</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIS01_FUD</td>
<td>123Al456_FUD</td>
</tr>
<tr>
<td>AIS01</td>
<td>123Al456</td>
</tr>
<tr>
<td>AIS01_Intl</td>
<td>123Al456_Intl</td>
</tr>
<tr>
<td>AIS01_MV</td>
<td>123Al456_MV</td>
</tr>
<tr>
<td>AlcBlk</td>
<td>AlcBlk</td>
</tr>
<tr>
<td>MV_GT_L1_</td>
<td>MV_GT_L1_</td>
</tr>
<tr>
<td>MV_LT_H1_</td>
<td>MV_LT_H1_</td>
</tr>
<tr>
<td>Value</td>
<td>Value</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIS01_Norm_FUD</td>
<td>AIS01Norm_FUD</td>
<td>Remove _</td>
<td>AIS01Norm_FUD</td>
</tr>
<tr>
<td>AIS01_Norm</td>
<td>AIS01Norm</td>
<td></td>
<td>AIS01Norm</td>
</tr>
<tr>
<td>AIS01_Norm_Intl</td>
<td>AIS01Norm_Intl</td>
<td></td>
<td>AIS01Norm_Intl</td>
</tr>
<tr>
<td>AIS01_Norm_MV</td>
<td>AIS01Norm_MV</td>
<td></td>
<td>AIS01Norm_MV</td>
</tr>
<tr>
<td>AlcBlk</td>
<td>AlcBlk</td>
<td></td>
<td>AlcBlk</td>
</tr>
<tr>
<td>MV_GT_L1_</td>
<td>MV_GT_L1_</td>
<td></td>
<td>MV_GT_L1_</td>
</tr>
<tr>
<td>MV_LT_H1_</td>
<td>MV_LT_H1_</td>
<td></td>
<td>MV_LT_H1_</td>
</tr>
<tr>
<td>Value</td>
<td>Value</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

MV_GT_L1_ was renamed to MV_GT_L1 because 1 is previous character in source name. Same applies for MV_LT_H1_.

Alternative solution for previous sample with pattern LL(L)NN(N)(L)LLL\m

<table>
<thead>
<tr>
<th>Source</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIS01_Norm_FUD</td>
<td>AIS01Norm_FUD</td>
</tr>
<tr>
<td>AIS01_Norm</td>
<td>AIS01Norm</td>
</tr>
<tr>
<td>AIS01_Norm_Intl</td>
<td>AIS01Norm_Intl</td>
</tr>
<tr>
<td>AIS01_Norm_MV</td>
<td>AIS01Norm_MV</td>
</tr>
<tr>
<td>AlcBlk</td>
<td>AlcBlk</td>
</tr>
<tr>
<td>MV_GT_L1_</td>
<td>MV_GT_L1_</td>
</tr>
<tr>
<td>MV_LT_H1_</td>
<td>MV_LT_H1_</td>
</tr>
<tr>
<td>Value</td>
<td>Value</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>PXC1111_FD</td>
<td>Replace R by X</td>
<td>PXC1111_FD</td>
</tr>
<tr>
<td>PRC1111</td>
<td>PXC1111</td>
<td></td>
<td>PXC1111</td>
</tr>
<tr>
<td>PRC1111_S</td>
<td>PXC1111_S</td>
<td></td>
<td>PXC1111_S</td>
</tr>
<tr>
<td>PRC1111_FD_IC1</td>
<td>PXC1111_FD_IC1</td>
<td></td>
<td>PXC1111_FD_IC1</td>
</tr>
<tr>
<td>PVCD1111_FD_S</td>
<td>PVCD1111_FD_S</td>
<td></td>
<td>PVCD1111_FD_S</td>
</tr>
<tr>
<td>PRXY1111_S</td>
<td>PXXY1111_S</td>
<td></td>
<td>PXXY1111_S</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRC1111_FD</td>
<td>YPRC1111_FD</td>
<td>Add prefix Y</td>
<td>YPRC1111_FD</td>
</tr>
<tr>
<td>PRC1111</td>
<td>YPRC1111</td>
<td></td>
<td>YPRC1111</td>
</tr>
<tr>
<td>PRC1111_S</td>
<td>YPRC1111_S</td>
<td></td>
<td>YPRC1111_S</td>
</tr>
<tr>
<td>PRC1111_FD_IC1</td>
<td>YPRC1111_FD_IC1</td>
<td></td>
<td>YPRC1111_FD_IC1</td>
</tr>
<tr>
<td>PVCD1111_FD_S</td>
<td>YPVC1111_FD_S</td>
<td></td>
<td>YPVC1111_FD_S</td>
</tr>
<tr>
<td>PRXY1111_S</td>
<td>YPXXY1111_S</td>
<td></td>
<td>YPXXY1111_S</td>
</tr>
</tbody>
</table>
Section 2  Configuration

Paste Rename Functionality

In the regular copy paste operation names are automatically decided by the function settings, where as, Paste Rename functionality enables renaming of Function Diagrams and its various components interactively. Below steps describes the procedure to use Paste Rename functionality.

<table>
<thead>
<tr>
<th>Source</th>
<th>Target Name</th>
<th>To-do</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>PID01MAST_FuD</td>
<td>999TT927_FuD</td>
<td>add prefix 999</td>
<td>999TT927_FuD</td>
</tr>
<tr>
<td>PID01MAST</td>
<td></td>
<td>replace PID by TT</td>
<td>999TT927</td>
</tr>
<tr>
<td>PID01MAST_Intl</td>
<td></td>
<td>replace 01 by 927</td>
<td>999TT927_Intl</td>
</tr>
<tr>
<td>PID01MAST_Slav</td>
<td></td>
<td>delete MAST</td>
<td>999TT927_Slav</td>
</tr>
<tr>
<td>PID01MAST_MV</td>
<td></td>
<td></td>
<td>999TT927_MV</td>
</tr>
</tbody>
</table>
1. In the Engineering Workplace navigate to the source Function Diagram object under **Functional Structure**, right-click and select **Copy**.

![Figure 102. Function Diagram Object Copying](image-url)
2. Right-click on the intended **Object**, navigate to **Advanced** and select **Paste Rename**.

*Figure 103. Paste Rename Functionality*
3. **Paste Rename** dialog box appears with a unique Diagram Name along with the list of all components of Function Diagram, see Figure 104.

![Figure 104. Paste Rename Dialog Box](image)

4. In **Diagram Name** field enter a new name if required and press **Enter** to commit the change.
5. Enter the required strings in **Find** and **Replace** fields, see **Figure 105**.

![Figure 105. Find and Replace](image)

6. Click **Replace** to rename a single string. As a results last component of the **New Name** list gets replaced.

7. Else click **ReplaceAll** to rename all the components having same string.
As an example, **ReplaceAll** is selected for illustrative purpose, see Figure 106. All the components named LC1 are replaced with Test under **New Name** list.

![Components Renamed Dialog](image)

**Figure 106. Components Renamed Dialog**

8. Click **Cancel** to cancel the changes and close the dialog box.

9. Click **Restore to Default** to revert back the original component names under **New Name** list.

10. Click **Save**, to save the changes in the destination diagram. A message appears, click **OK**.

![Conformation Popup](image)

**Figure 107. Conformation Popup**
Communication Between Applications using Cross Communication

Cross communication links must be configured to establish communication between different applications of an AC 800M controller or several AC 800M controllers. Also, the Function Diagrams must be allocated to different applications of the same or different control projects.

For details on configuring and generating MMS Cross Communication for diagrams created prior to Engineering Studio 800xA 5.1, refer to the MMS Cross Communication on page 555.

Prerequisites

The following prerequisites must be fulfilled to successfully establish cross communication:

- All Function Diagrams containing Communication Variables must be allocated to required applications.
- Generate configuration data for these diagrams.
• Applications executing these Function Diagrams must be assigned to controllers and tasks.

• For projects restored to system version 5.1, if the IAC MMS unit is not available as indicated in the diagram below, then user needs to manually insert the unit.

Cross Communication Procedure

The example in this subsection describes the procedure to create cross communication diagrams.

1. Create two Function Diagrams named SenderDiagram1, and ReceiverDiagram1.

2. Create logic in SenderDiagram1 and ReceiverDiagram1 as shown in Figure 108.
Section 2  Configuration  Cross Communication Procedure

3. Allocate each diagram to a different Application (see Figure 109).

The Communication Variable Variable1 is source for the diagram reference in SenderDiagram1 and sink for the diagram references in ReceiverDiagram1.

Figure 108. Diagram Variables without Cross Communication Field

Figure 109. Diagram Variables with Cross Communication Field
4. Generate configuration data for these Function Diagrams.

Configuration data generation establishes cross communication links between the diagrams through the Communication Variables according to the engineered logic.

Additional basic information on cross communication is given in *System 800xA Control, AC 800M Configuration (3BSE035980*) and AC 800M, Communication Protocols (3BSE035982*)*.

From 800xA 5.1 onwards, the Inter Application Communication supports the Input Set as Predetermined (ISP) functionality. The input diagram reference is used to set the ISP value. The Diagram Variable Properties dialog passes the ISP value to the input Communication Variable.

When the inter communication fails, the input variable gets a predefined value, or a deterministic value. If a good value is not available in the previous list of values, the input variable shall be set to its defined initial value.

**Deleting a Diagram Variable or Changing the Name**

If the user deletes the diagram reference with variable Variable2 in source SenderDiagram1 or renames the diagram variable, then configuration data should be generated for the sender and all its receiver diagrams.

If only the application (SenderDiagram1) of the sender Function Diagram is downloaded to the controller and the applications of the receiver Function Diagrams are not yet loaded, then the variables of the ReceiverDiagram1 hold the last Retain Values. Give reference to ISP value.

**Download and go Online**

After downloading the project data into the controller(s) you can check the Valid ports at the MMS diagram references. Subscribe for live data and select the Valid...
User can verify the correct behavior of MMS communication through an Alarm and Event List aspect. In case of communication failures, an alarm gets generated to indicate the faulty sender or receiver.

**Current Limitations**

- Connection to multiple output diagram references in different applications having same diagram variable name is not supported.
On-line Display

General

Online display of values is possible for a diagram or a portion of a diagram that is in state ‘Loaded’.

Display of online values is also enabled for modified diagrams if they had been generated at least once (i.e. allocatable group has a FDVersion property). A warning is given that the modified diagram does not match the one running in the controller, similar to the case that a regenerated diagram is not yet loaded.

On-line values cannot be modified directly in Function Diagram. Use Watch Window instead, see Watch Window on page 208.

Display Style

Function Designer follows the 800xA system standard faceplate's style regarding the use of colors and other graphical elements for value display. However, because the faceplate do not have to distinguish between live data and configuration data, Function Designer uses an additional graphical element to indicate that a value is a ‘live’ value.
Table 19. Display Style of On-line Values

<table>
<thead>
<tr>
<th>Description</th>
<th>Display Style</th>
</tr>
</thead>
<tbody>
<tr>
<td>A configuration value (initial value).</td>
<td></td>
</tr>
<tr>
<td>Live values are indicated by a red frame around the value.</td>
<td></td>
</tr>
</tbody>
</table>
Table 19. Display Style of On-line Values  (Continued)

<table>
<thead>
<tr>
<th>Description</th>
<th>Display Style</th>
</tr>
</thead>
<tbody>
<tr>
<td>If a property indicates a bad quality (from the OPC server), the value is</td>
<td></td>
</tr>
<tr>
<td>displayed in red color with the strikeout font.</td>
<td></td>
</tr>
<tr>
<td>A forced value is indicated using a gray background color.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CBM_AIS19</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter: 0</td>
</tr>
<tr>
<td>Input: 4-20mA</td>
</tr>
<tr>
<td>Range: 0 - 100</td>
</tr>
<tr>
<td>I0Value: 0</td>
</tr>
<tr>
<td>Value: 21</td>
</tr>
</tbody>
</table>

If a property indicates a bad quality (from the OPC server), the value is displayed in red color with the strikeout font. A forced value is indicated using a gray background color.
You can select to display the actual process value for a port, a connection link, or for all ports of a component. On-line values are received from the OPC server. The values are available for the following ports, connections, and components:

Table 20. Display of On-line Values

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagram Reference</td>
<td>Diagram references are implemented as global variables. The symbol for the diagram reference contains a field to display the process value.</td>
<td><img src="image" alt="Diagram Reference Example" /></td>
</tr>
<tr>
<td>Diagram Parameter*</td>
<td>Diagram parameters are implemented as input or output variable of a single control module. The symbol for the diagram parameter contains a field to display the process value.</td>
<td><img src="image" alt="Diagram Parameter Example" /></td>
</tr>
<tr>
<td>Port of Control Module</td>
<td>All terminals of all Control Modules are OPC readable.</td>
<td><img src="image" alt="Port of Control Module Example" /></td>
</tr>
<tr>
<td>Port of Function Block</td>
<td>All input and output ports of a nested function are readable.</td>
<td><img src="image" alt="Port of Function Block Example" /></td>
</tr>
<tr>
<td>Port of Child Function Diagram</td>
<td></td>
<td><img src="image" alt="Port of Child Function Diagram Example" /></td>
</tr>
</tbody>
</table>
### On-line Display Section 2 Configuration

*Table 20. Display of On-line Values (Continued)*

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port of Function</td>
<td>Ports of Functions are not accessible through OPC.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td>• If the port of the Function is connected to an OPC readable variable, the value of the variable is displayed.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• If the port is connected to a ‘__link’ type variable, display of on-line values depends on how configuration data was generated. In case of ‘Online Optimized’ code, all ‘__link’ variables are automatically converted to ‘internal_link’ variables that are OPC readable. Otherwise, internal links between functions are not OPC readable. This is indicated by a ‘<em>’ or a ‘?’.</em></td>
<td></td>
</tr>
<tr>
<td>IO Signal</td>
<td>For an IO signal, Function Designer generates a global variable of the following type: RealIO/BoolIO. Function Designer displays the “Value” part of the variable and the “Unit” string (RealIO only). If the value is forced, it is displayed in bold with grey background color.</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td>Networks</td>
<td>Networks correspond to variables. The variables are OPC readable if:</td>
<td><img src="image" alt="Example" /></td>
</tr>
<tr>
<td></td>
<td>a) You defined an explicit network name.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>b) You selected to generate “Online Optimized” code.</td>
<td></td>
</tr>
</tbody>
</table>

* - Valid only for Function Diagrams restored to 800xA 5.1.
Function Designer is aware of some frequently used data type. Table 21 describes these data types, and how the Function Designer displays them in on-line display.

Other structured data types with a ‘Value’ record element display that value. Other structured data types without ‘Value’ are not displayed in the diagram directly. This is indicated by a “?” or “*”. However, their on-line values can be displayed in the Watch Window.

Table 21. Display of On-line Values for Some Common Data Types

<table>
<thead>
<tr>
<th>Type Name</th>
<th>Usage</th>
<th>Online Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>RealIO</td>
<td>Connection to process IO.</td>
<td>RealIO.SignalPar.Unit. Example: 3.14 m/s</td>
</tr>
<tr>
<td>BoolIO</td>
<td>Connection to process IO.</td>
<td>BoolIO.Value</td>
</tr>
<tr>
<td>ControlConnection</td>
<td>Two-way communication between control modules.</td>
<td>ControlConnection.Forward.Value ControlConnection.Forward.Range.Unit Example: 100 %</td>
</tr>
<tr>
<td>SignalPar</td>
<td></td>
<td>SignalPar.Min SignalPar.Unit &lt;= X &lt;= SignalPar.Max SignalPar.Unit Example: 10 m/s &lt;= X &lt;= 12.5 m/s</td>
</tr>
<tr>
<td>Range</td>
<td>Value range.</td>
<td>Range.Min Range.Unit&lt;=X&lt;= Range.Max Range.Unit Example: 10 m/s &lt;= X &lt;= 12.5 m/s</td>
</tr>
<tr>
<td>HWStatus</td>
<td>IO Diagnostics</td>
<td>HWStatus.HwState Example: 0xADD45000</td>
</tr>
<tr>
<td>DwordIO</td>
<td>Connection to process IO</td>
<td>DwordIO.Value</td>
</tr>
<tr>
<td>DintIO</td>
<td>Connection to process IO</td>
<td>DintIO.Value</td>
</tr>
<tr>
<td>Any other structured data type with a .Value record element.</td>
<td>AnyType.Value</td>
<td></td>
</tr>
</tbody>
</table>
User Interface

All online commands are available from the **Online** menu, as shown in Figure:

![Online Menu](image)

**Figure 111. Online Menu**

**Online > Add to Display List**

This command adds the selected object to the list of objects where you want to see online value. Following objects are supported:

- a single port
- a multi-selection of ports
- a component symbol (all ports will be added)
- a network link
- an IO signal

It is also possible to add a combination of these objects. The command is using the current selection in the diagram as source. The command is also available in the for the objects listed above.

- **Online > Remove from Display List**
  
  This command reverses the action of the command **Online > Add to Display List**.
• **Online > Add Links to Current Page**
  This menu command displays the on-line values for all the links on the current page.

• **Online > Add all Links to Display List**
  This command adds all connection links on the current page to the display list.

• **Online > Remove all from Display List**
  This command reverses the action of the command **Online > Add all Links to Display List**.

• **Online > Watch Window**
  In Diagram view, choose this menu command to open the Watch window. The command displays the watch window. The window shows a grid where you can add the (OPC) name of variables you are interested in. See **Watch Window** on page 208.

• **Online > Show Last Value(s)**
  This command show/hides recent on-line values retrieved from the OPC server if subscription for live data has stopped.

• **Online > Display in Hexadecimal Format**
  This menu command displays the online values in hexadecimal format.

• **Online > Force...**
  This dialog allows to force the Value of an allocated input IO signal or the IOValue of an allocated input IO signal.

**Subscribe to Live Data Functionalities:**
From the below mentioned Live Data functionalities user can enable only one option at a time.

• **Online > Subscribe for Live Data**
  This command starts/stops on-line display of live data. The recent OPC timestamp and quality is displayed in Function Designer’s status bar, see **Figure 112.**
Watch Window

Watch Window Section 2  Configuration

- **Online > Subscribe For Live Data All Open Diagrams**
  In Diagram view, choose this toggle menu command to start/stop display of on-line values collected in the diagram’s display list and/or collected in the Watch window for all open diagrams.

- **Online > Subscribe for Live Data All Output Ports**
  The command adds labels to display live values for all the pages of function diagram and subscribes live data for the current page.

- **Online > Subscribe for Live Data Connected Output Ports**
  The command adds labels to display live values for the connected output ports and subscribes live data for the current page.

  - In Function Diagrams, links connected through the output port of MOVE block are not animated with color.
  - Subscribe for Live Data is not supported for Extensible Parameters.

*Figure 112. Diagram in Loaded State Displaying On-Line Values*

**Watch Window**

This section describes, how to use the Watch window of Function Designer. The purpose of the Watch window is to display a user defined collection of on-line values. This function is typically used during the commissioning phase of a function.
To display the watch window, use command **Online > Watch Window**. Like the structure browsers and the output window, the Watch window can be

- docked inside Function Designer, Diagram View
- undocked as popup-window.

**Figure 113. Watch Window for a Function Diagram Online Display**

The watch-window displays online values from:

- The current function diagram that you are viewing.
- Any other diagram.
- Any other aspect, not belonging to a function diagram (a Control Builder Application for example).

If a variable is of a structured data type, the watch window displays **struct** as data type. You can click on such a structured variable to expand it and to view the individual elements it consists of.
How to add variables see Adding Variables on page 214.

To active the value update, use command Online > Subscribe for Live Data.

Function Designer saves the configuration of the Watch window. When opening the same Function Diagram next time, the watch window will show the same configuration. If any of the variables in the watch window does not exist anymore in your diagram, it will be marked as invalid.

Saving the Watch Window can be done implicitly during exit of the Function Diagram or explicitly using the Save / Save As commands, see Watch Window Commands on page 212.

Watch Window data are stored in an aspect of the aspect category Function Online Data.

Aspects of this aspect category are copied. An aspect object (typically the one representing a Function Diagram or a Function Diagram Type) may carry 0...n aspects of the category Function Online Data.

When a diagram or a diagram type is opened the Watch Window is filled with the data used last time. This is ensured by loading the Function Online Data aspect with

Figure 114. Save Watch Window Configuration to Function Online Data Aspect
the latest modification date. When closing the Watch Window the aspect modification date is always updated (even if no data is saved).

Aspects of the aspect category Function Online Data do not have an aspect view.

**Watch Window Grid**

The Watch Window grid displays the variables to be watched. For each variable the following properties are displayed:

- **Variable Name**
- **Data Type**
- **OPC Value**
- **Prepared Value**
- a **Force** check box determining whether to force (if applicable) or to set the prepared value

The values in the cells of columns **Variable Name**, **Data Type** and **OPC Value** are read-only in the grid. The cells of columns **Prepared Value** and the **Force** check box can be edited. Like in online display in diagrams together with the **OPC Value**, its quality (bad quality is indicated by red text color and strike through font), and the information whether it is forced is displayed (in this case the value is displayed on a gray background).

The **Force** check box shows up only for variables which can be forced at all (i.e. if the according data type has got a component called **Forced**) in order to distinguish between forcing and setting the prepared value. This applies to the following data types:

- RealIO
- BoolIO
- DintIO
- DWordIO
- ControlConnection (component Forward.Forced)
- ControlConnectionForward
For an alternative to force CBM_Signals see Force Dialog on page 215.

Data types which have a Value component but no Forced component can only be set (i.e. the set value could be overwritten by the controller in the next cycle).

For data types which don't have a Value component the entries in the Value and Prepared Value columns are missing (exception: for the data type HWStatus the component HWState is taken instead).

Communication Variables are read only and do not support the entry of a Prepared Value.

If the OPC property is not writable the according Prepared Value edit field is disabled (dimmed).

If for a structured variable the Value and/or the Forced component exist as separate entries (besides the variable itself) in the Watch Window grid the according Prepared Value and Force entries are synchronized.

If editing a Prepared Value is finished by pressing <CR> or <Enter> the input focus changes to the Activate button in order to allow the user to activate the prepared value quickly.

Operations on variable entries in the grid:

- **Expand** - expands the next level of a variable of structured data type
  Expanded components can be added as separate entries to the Watch Window with a item "Add".

- **Collapse** - collapses the level of a variable of structured data type

- **Move** - A Watch Window entry can be moved to another position by means of drag & drop.

- **Select All** - Using the Ctrl/A accelerator all entries can be selected before performing commands like Activate, Deactivate, Remove, etc.

**Watch Window Commands**

- **Pin / Unpin** - If pinned, the Watch Window contents is kept even if another diagram gets active in the Function Designer's client area (e.g. when opening a child diagram or when navigating via Diagram References).
  If unpinned, the Watch Window contents is cleared and reloaded according to
the related Watch Window data of the activated diagram (see also "Function Online Data" aspect). Refilling is done when the diagram gets active.

- **Open** - Offers the possibility to chose a Function Online Data aspect (of any object) and to fill the Watch Window with the according data.

- **Save** - Stores the Watch Window data in the Function Online Data aspect from which it was loaded. In case the Watch Window is "dirty", i.e. was changed after Open, the user is queried to save its contents.

- **Save As** - Offers the possibility to store the Watch Window data in a (new) Function Online Data aspect (of any object), see Figure 114.

- **Add** - Pops up the Add Variable to Watch Window dialog which allows adding a new variable to the Watch Window. See Adding Variables on page 214

- **Remove** - Removes the selected variables are removed from the Watch Window (using the Ctrl/A accelerator all variables can be selected to remove them). Besides the toolbar the Remove command is available in a popping up on selected variables.

- **Activate** - Activates the selected prepared values in the controller (using the Ctrl/A accelerator all prepared values can be activated in the controller). The activation has to be acknowledged by the user. If the according Forced check box is checked the prepared value is forced in the controller (i.e. held permanently). If the according Forced check box is unchecked the prepared value is set in the controller (i.e. may be overwritten by the controller in the next cycle). Besides the toolbar the Activate command is available in a popping up on selected variables.

- **Deactivate** - Deactivates the selected values in the controller (using the Ctrl/A accelerator before all values can be deactivated in the controller). The deactivation has to be acknowledged by the user. The prepared values are reset to "" and the according Force check boxes get unchecked. Besides the toolbar the Deactivate command is available in a popping up on selected variables.
Adding Variables

To add a new variable to the watch window, click the **Add…** button. Function Designer displays the following dialog:

![Add Variable to Watch Window](image)

**Figure 115. Add Watch Variable**

Select one or more variables from the list in the right part of the window and click **Apply** to add the selected variable to the watch window.

You can also type the name of a variable in the edit field.

To display a variable of a structured data type, type the name of the variable up to the first dot into the edit field and press **Apply**. Example `x1T3FC1_CBM_AIS1`.

The Watch Window settings are not stored for a specific user but they are shared for all users of this diagram.

Alternative for adding variables to the Watch Window: The **Online** menu and the submenus which pop up on ports, links and symbols provide a menu item Add to Watch Window. When performed on symbols (the variables related to) all visible ports of the symbol get added to the Watch Window.
Force Dialog

An alternative to the Watch Window functionality to activate a force value is the entry **Force**... or **Online > Force...** on ports and links. The command is enabled for the Value (data types RealIO, and BoolIO) of an allocated input IO signal (object type CBM_AIS, CBM_DIS) and the IOValue (datatype RealIO, BoolIO) of an allocated input IO signal (object type CBM_AOS, CBM_DOS). This command displays the dialog:

![Image of Force Dialog](image)

*Figure 116. Force Dialog, Value of a CBM_AIS Forced*
Field Device Integration

Introduction

The Fieldbus Builder PROFIBUS/HART Integration of *Function Designer* supports a basic workflow of functional planning with HART device (object) types represented as CBM_Signals. See [HART Devices](#) on page 217. HART device types by default provide a function aspect with a function component and can be instantiated in the Functional Structure.

From 800xA 5.0 SP2 onwards a basic workflow of functional planning with CBM_Signals to be allocated to channels of modules of PROFIBUS devices is also supported. New CBM_Signal objects (CBM_DINTIS, CBM_DINTOS, CBM_DWIS, CBM_DWOS, and CBM_HWStatus) have been introduced in Function Designer to support PROFIBUS devices. These signal objects support DInt and DWord data types. See [PROFIBUS Devices](#) on page 222.

For HART, PROFIBUS and FOUNDATION Fieldbus devices it is supported to reference and navigate to the IO variables representing these devices in a control application. This support bases on the general functionality of Function Designer’s AC 800M integration to reference (and even create) application global IO variables via diagram references. After the variable is connected to the hardware the diagram reference shows the control designation of the device. The context menu on the reference can be used to navigate to the corresponding hardware editor in Control Builder M Professional, see [Referencing Devices](#) on page 626.

PROFIBUS and FOUNDATION Fieldbus device types by default do not provide a function aspect with a function component and therefore cannot be inserted into function diagrams. Alternatively you can add an own Function aspect containing a Function Component view to an instance of such a device type, see [Function Components and Diagrams](#) on page 29. You then can insert the instances\(^1\) from the Control Structure into the Functional Structure below corresponding Function Diagram objects. They show up in the function diagram and can serve to fulfill your documentation and, via context menu, your aspect navigation needs. If you copy such a function diagram object the device representations contained in the diagram are removed. You have to insert other devices in the new diagram.

---

\(^1\) While PROFIBUS device types can only be instantiated in the Control Structure, FOUNDATION Fieldbus device type instances can only be uploaded into the Control Structure.
HART Devices

Prerequisites

The system extension Function Designer for Fieldbus Builder PROFIBUS/HART is based on the system extensions Function Designer and on HART Device Integration Library and Fieldbus Builder PROFIBUS/HART. All tools have to be installed, all system extensions have to be loaded.

To load the system extension Function Designer for FB P/H, use the Configuration Wizard via System Administration > (System Name) > System Extension Load and select first HART Device Integration Library - Basics followed by Fieldbus Builder PROFIBUS/HART and then Function Designer for Fieldbus Builder PROFIBUS/HART.

Object Types for HART Devices

Following object types for HART devices (HART device types) are provided by default in Object Type Structure, Object Types\Field Devices, see Figure 117:

- HART Actuators
  - ABB Generic HART Actuator
- HART Transmitter
  - ABB Generic HART Transmitter

Additional specific HART device types can be installed from the Device Library System 800xA Media through the Device Library Wizard below the object type groups HART Actuators and HART Transmitter.

All standard HART device types should already include the aspects needed to be treated as signal object types, see HART device support in section IO Allocation of System 800xA Engineering, Engineering Studio (3BDS011223*).

If this is not the case you can add these aspects using the HWDProcessor utility as described in this referenced instruction book.
In earlier system versions it was supported to have a separate CBM_Signal object for a HART device object and to have both objects represented in a function Diagram. Now the HART device represents the CBM_Signal object for a HART device object also.

Projects already using two separate objects can continue with the same objects. In this case the Fieldbus Management view on the board object is not updated by IO Allocation.

Configuration Data Generation of restored Function Diagrams using HART devices connected to CBM_Signals results in errors. Hence, user needs to ensure that the HART device object types have not been preprocessed with HWDPProcessor.

Follow the steps below to configure the HART devices manually after IO Allocation of CBM_Signals:

1. Assign the HART device object to the IO board object (for example AI895 or AO895) in Control Structure, using either SHIFT+CTRL Drag & Drop from Function Diagram or Insert Object in Plant Explorer.

2. In the Main View of the Fieldbus Management aspect on the IO board object in Control Structure use Drag & Drop to assign the HART device object to the same channel as the corresponding CBM_Signal object.

System extension Function Designer for Fieldbus Builder PROFIBUS/HART adds the following aspects to all these device (object) types:

- Function
  The HART Actuators object type group object and the HART Transmitter object type group object each have one Function aspect for the whole corresponding group of HART device types.
Function Parameters

For a specific HART device that is not supported you can prepare a copy of the generic device type e.g. Generic HART Actuator or Transmitter. Check that the device (object) types include the aspects Function and Function Parameters.

Building up the Functional Structure

You can build up the Functional Structure by inserting HART device types in a function diagram of Function Designer. You connect them to other function components on the diagram as you do it with CBM signal objects. DTM (Device Management) aspects, Fieldbus Management aspects, and other aspects of the device object can be selected inside the function diagram opening the component by right mouse click.
Allocating Devices to the Control Structure

Instances of the HART device types can be allocated to channels of HART-IO boards, for example AI895/OAO895, with the IO Allocation tool:

1. In Function Designer with the opened diagram click **Allocation > IO Allocation** to open the IO Allocation tool in the context of this diagram. The right pane shows the HART devices in the context of this diagram.

*Figure 118. HART Device Objects in Function Diagram*
2. On the Boards object in the left pane of the IO Allocation tool click right to open the structure browser.

3. Click **Insert Elements** and add the needed boards from the Control Structure of the structure browser opened.

4. Drag and drop the HART devices from the right pane to the left pane, for example onto the Boards object to automatically do the allocation.

![Production S10Sys1 - IO-Allocation](image)

*Figure 119. IO Allocation of HART Devices*
In Function Designer generate configuration data to write the allocation information to Control Builder M Professional (or use **Write to CBM** item on the Boards object).

![Control Structure Diagram]

**Figure 120. HART Devices Allocated in Control Structure**

For further information on IO Allocation see *System 800xA Engineering, Engineering Studio (3BDS011223*)*. Referencing of HART devices is possible only for Function Diagrams created on system versions prior to 5.1. For details on referencing of such Function Diagrams, refer to **Referencing Devices** on page 626.

**PROFIBUS Devices**

**CBM Signals for PROFIBUS**

The following signal object types are introduced to support PROFIBUS device integration. They also can be used to read / write channels of I/O boards of corresponding data types. As well as the signal object types CBM_AIS,
CBM_AOS, CBM_DIS, CBM_DOS can be used to read / write channels of corresponding data types of PROFIBUS modules.

<table>
<thead>
<tr>
<th>Signal Object Type Name</th>
<th>Description</th>
<th>Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>CBM_DINTIS</td>
<td>Double Integer Input Signal (input)</td>
<td>DInitIO</td>
</tr>
<tr>
<td>CBM_DINTOS</td>
<td>Double Integer Output Signal (output)</td>
<td>DInitIO</td>
</tr>
<tr>
<td>CBM_DWIS</td>
<td>Double Word Input Signal (input)</td>
<td>DWordIO</td>
</tr>
<tr>
<td>CBM_DWOS</td>
<td>Double Word Output Signal (output)</td>
<td>DWordIO</td>
</tr>
<tr>
<td>CBM_HWStatus</td>
<td>Hardware Status (input)</td>
<td>HWStatus</td>
</tr>
</tbody>
</table>

Figure 121. Symbols of CBM Signals for PROFIBUS Device Integration

Prerequisites

The system extension Function Designer for Fieldbus Builder PROFIBUS/HART is based on the system extensions Function Designer and on PROFIBUS Device Integration Library and Fieldbus Builder PROFIBUS/HART. All tools have to be installed, all system extensions have to be loaded.
To load the system extension Function Designer for FB P/H, use the Configuration Wizard via System Administration > (System Name) > System Extension Load and select first PROFIBUS Device Integration Library - Basics followed by Fieldbus Builder PROFIBUS/HART and then Function Designer for Fieldbus Builder PROFIBUS/HART.

After installing the software PROFIBUS devices need to be loaded on the system using Device Library Wizard (DLW).

**Preparation of PROFIBUS Devices.**

PROFIBUS specific device libraries can be installed through Device Library Wizard. User has to prepare these libraries using HWDProcessor to use them in Engineering Studio for allocating or de-allocating signals to the channels of PROFIBUS modules.

For further information about preparation of PROFIBUS devices see System 800xA Engineering, Engineering Studio (3BDS011223*).

**Building up the Functional Structure**

Functional Structure can be built by inserting PROFIBUS related signals in a Function Diagram. Connect them to other function components on the diagram as you do it with all other CBM signal objects.

Allocate the Function Diagram to an Application and Generate Configuration Data as explained in Allocating Function Diagrams on page 141.

1. Select the signal object in Function Diagram.
2. Right click to open object context menu.
3. Then Device Functions verb can be used to execute the different device functions.
4. The aspects Device Management, Fieldbus Management or Property Management can be opened from context menu also.

Figure 122. Object Context Menu with Device Functions Verb

Allocating Signals

After allocating the logic of the Function Diagrams to an Application in the Control Structure, the IO signals (CBM_Signals) need to be allocated to the channels of PROFIBUS modules using IO Allocation tool. Follow the steps below to allocate the IO signals.

1. In Function Designer with an opened diagram click Allocation > IO Allocation from the menu bar to open the IO Allocation tool in the context of the opened diagram.
2. Right click on the Boards object in the left pane of the IO Allocation tool and select Insert Element.

3. Add required PROFIBUS modules from the Control Structure of the structure browser opened.

4. Drag the signals from the right pane and drop them on to the Boards object in the left pane to allocate the signals automatically.

To write allocation information to Control Builder M Professional either generate configuration data in Function Designer or right click on the Boards object in IO Allocation tool and select Write Allocation into CBM.

User can write allocation information to CBM through Plant Explorer also. Follow the steps below to write to CBM through plant explorer.

1. Open Plant Explorer and select Control Structure in the structure browser.

2. Select required object, right click and select Advanced > Write Allocation into CBM.
Advanced IO for Foundation Fieldbus helps the user to use the Fieldbus Application Diagram (FBAD) in the Function Diagram Editor by creating the FF Proxy Object. Engineering Studio supports the Foundation Fieldbus (FF) diagrams for IO configuration. During the **Configuration Data Generation** the FF signals used in the FBAD diagram are updated to the control builder CI860 board.

The FBAD diagram used in the Function Diagram is published by FF Builder to the control builder CI860 board. This is done before allocating the FBAD diagram to the FF Proxy Object.

**Loading the System Extension**

To use the FF Proxy Objects in the Function diagrams, load the extension object created for the **ABB FF Proxy Extension for Function Designer**. As this extension has dependency with the Fieldbus extension, user has to load the required Fieldbus extensions before or along with the IO for FF.

Following image shows the extension for FF Proxy:

![Figure 124. FF Proxy Extension](image-url)
Once the extension is loaded successfully, the FF Proxy Object is available in the Object Type Structure and the Application Engineer can start using it in the Function Diagram.

![Figure 125. FF Proxy in Object Type Structure](image)

**Inserting FF Proxy Object to Function Diagram**

Application Engineer can use the FBAD in Function Diagram through the FF Proxy Object available in the Object Type Structure. After inserting the FF Proxy Object in the Function Diagram, the new object inserted is defined as a generic object without any ports, as this proxy object does not know the FBAD diagram it is representing. Hence allocate the FBAD diagram to this proxy object.

If user generates the diagram without allocating the FBAD diagram, following warning message is displayed:

**FF Proxy 'Proxy name' is not Allocated to FBAD**
Procedure to add FBAD to the Function Diagram:

1. Drag and drop the FF Proxy Object from the Object Type Structure.
2. Select the valid FBAD to allocate the proxy object and click OK to create ports and save the allocation details.

Once the FBAD is allocated, ports are created to the FF Proxy object. Based on requirement, users can connect to the ports later.

Click Cancel to continue without allocating the FBAD. The FBAD diagram can be allocated in later stage.
Allocating FBAD to FF Proxy Object

Once the proxy object is inserted to the Function Diagram, FBAD diagram is allocated /reallocated to the proxy object.

Application Engineer can allocate the FF Proxy from the context menu of the FF Proxy Object.

To allocate FBAD:

1. Right-click on FF Proxy Object and click Allocate FBAD menu. Select FBAD dialog is displayed, for information on Select FBAD, refer p. 228, Inserting FF Proxy Object to Function Diagram.

User has to select one proxy object at a time for the allocation.
2. Select the FBAD Application for allocation. It validates the FBAD diagram published by the FF builder by checking the port information.

If the FBAD diagram is not published, following error message is displayed:

Selected FF Application is not consistent: Please select a valid FF Application

To avoid this error user has to publish the corresponding diagram from the FF builder.

After the allocation user can insert glue logic such as communication variables, global variables, and page connectors based on user specific requirement.

**Configuration Data Generation on FF Proxy Object**

Configuration Data Generation creates the corresponding variable in CBM, based on the signal type for each port.

*Figure 128. FF Variable Generation*
Created variables are allocated to the respective channels CI860 board's in CBM.

If the FF Proxy Object is not allocated to any FBAD diagram then configuration data generation will continue with following warning message:

Warning: FF Proxy 'Proxy name' is not Allocated to FBAD

Configuration Data Generation displays an error message, if the same FBAD diagram is allocated to multiple FF proxy and if the allocated channel is assigned to some other diagram variable.

As the Proxy object is not supported in CBM, online values are not displayed in the ports of FF proxy object.

Handling Cascaded Loop Back Signals

IO for FF handles the cascaded loop back FF signals in Function Diagrams as a single pin for the bidirectional connection if the signal name has the predefined suffixes \_FRWD and \_BKWD or \_frwd and \_bkwd.

Example

The cascaded signal SIGNCASCA has to follow the naming convention as SIGNCASCA\_FRWD and SIGNCASCA\_BKWD in FF Builder as shown in
Figure 130. While allocating the same FBAD to FF Proxy object in Function Diagram, it creates a single port with merged signal **SIGNCASCA** for the backward and forward as shown in Figure 131. If the naming convention is handled properly, then during the configuration data generation, the forward and backward signals is written to the corresponding channels of CI860.

**Figure 130. Handling Cascaded Loop Back Signals**
If one signal is named with the suffix _FRWD, then it must have the counter signal name with the suffix _BKWD. Else, it will treat it as a separate signal instead of the merged signal.

If FBAD is modified in FF Builder, the FF Proxy Object allocated to the same FBAD needs to be reallocated and generated.

**Copy/Paste on FF Proxy Object**
Performing copy/paste deletes all the previous port information, and a new proxy template object instance is created. User has to reallocate the FBAD diagram for the new pasted object.

**Open FF project in FF Builder**
To open FF project in FF builder, right-click on FF Proxy Object and click **Open FF Application** menu. This opens the FF Builder with allocated FBAD diagram. After allocating the FF Proxy Object to the FBAD diagram, the FBAD diagram is opened in FF Builder through the **Open FF Application** option.

*Figure 131. Open FF Application*
Communication Interface

FOUNDATION Fieldbus devices can be referenced for Function Diagrams created prior to system version 5.1. The procedure is similar as described for HART devices in Referencing Devices on page 626.

Differences to take care of when creating the references:
- The data types and IO variables are defined by Fieldbus Builder FF.

Error Messages

Function Diagram checks the Channel/HSE HOST/Direction/Data Type attributes of the FF Signal. These attributes are mandatory for Function Diagram to create the ports and generate the code. If any one of these attributes are missed during FF engineering, then FuD displays error while allocating the FBAD to the FF Proxy object.

Table 22 shows the list of error messages displayed by FuD while allocating the FBAD to the FF Proxy object with possible solution.

Table 22. Errors with solution

<table>
<thead>
<tr>
<th>Serial No.</th>
<th>Error Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>If the <strong>Channel</strong> is not assigned to the signal in FF Builder, FuD displays following error message: <strong>Channel is not allocated for some signals</strong></td>
<td>Correct the FBAD Diagram and reallocate the FBAD.</td>
</tr>
<tr>
<td>2</td>
<td>If the <strong>HSE HOST/ Direction/ Data Type</strong> is not assigned to the signal in FF Builder, FuD displays following error message: <strong>Channel information is not found for some signals</strong></td>
<td>Correct the FBAD diagram and reallocate the FBAD.</td>
</tr>
</tbody>
</table>
PROFINET Devices

Table 22. Errors with solution

<table>
<thead>
<tr>
<th>Serial No.</th>
<th>Error Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>If the allocated FBAD do not have any FF signal, FuD displays following error message: Signal Information is not Found This may happen if the FBAD diagram is not saved properly after modification.</td>
<td>Correct the FBAD and reallocate the FBAD to the FF Proxy object.</td>
</tr>
<tr>
<td>4</td>
<td>If the XML received from the FBAD is not proper, FuD displays following error message: XML Parsing failed</td>
<td>Re-save the FBAD diagram properly.</td>
</tr>
<tr>
<td>5</td>
<td>If any fault occurred during the processing of FBAD XML, FuD displays following error message: XML Error</td>
<td>Check if all the signal names and their attributes are saved properly.</td>
</tr>
<tr>
<td>6</td>
<td>If the selected FBAD diagram do not have any XML data, FuD displays following error message: Failed to get the FF information</td>
<td>Save the selected FBAD in FF builder properly.</td>
</tr>
</tbody>
</table>

PROFINET Devices

IO allocation for PROFINET allows the user to use IO allocation tool for the signal allocation of PROFINET devices.

Prerequisites

- 800xA system should be created and running.
- GSDML files for PROFINET devices required for installation should be available.
Install PROFINET devices manually, as Device Library Wizard does not support PROFINET devices.

**Installing PROFINET devices manually**

Steps:

1. Right-click on Hardware in **Control Builder M** to create a New Hardware Library.

![Create New Hardware Library](image)

*Figure 132. Create New Hardware Library*

2. Assign a valid name to the library and insert the hardware types.
3. Browse and select the required PROFINET hardware definition file (*GSDML.xml*) and click **Open**.
4. After installation, the device is visible under the library.
Preparing PROFINET IO Module

PROFINET specific device libraries cannot be installed through Device Library Wizard, refer Installing PROFINET devices manually on page 237 to extract the libraries in to the engineering workplace.

User has to prepare PROFINET specific device libraries using HWDProcessor to use them in IO allocation tool as well as Function Diagram for allocating or de-allocating signals to the channels of PROFINET IO modules.

For further information about preparation of PROFINET IO Modules see System 800xA Engineering, Engineering Studio (3BDS011223*).

Building Functional Structure

Functional Structure is built by inserting the CBM signals in a Function Diagram. Connect them to other function components on the diagram as done to other CBM signal objects.

Allocate the Function Diagram to an application and Generate Configuration Data as explained in Allocating Function Diagrams on page 141.

Allocating Signals

After allocating the logic of the Function Diagrams to an application in the Control Structure, the IO signals (CBM_Signals) need to be allocated to the channels of PROFINET modules using IO Allocation tool. Follow the steps below to allocate the IO signals:

1. In Function Designer with an opened diagram click Allocation > IO Allocation from the menu bar.
   The IO Allocation tool in the context of the opened diagram opens.
2. Right-click on the Boards object in the left pane of the IO Allocation tool and select Insert Element.
3. Add required PROFINET modules from the Control Structure of the opened structure browser.
4. Drag the signals from the right pane and drop them on to the boards object in the left pane to allocate the signals automatically.
To write allocation information to Control Builder M Professional either perform Configuration Data Generation in Function Designer or right click on the Boards object in IO Allocation tool and select Write Allocation into CBM.

User can write allocation information to CBM through Plant Explorer. Follow the steps below to write to CBM through plant explorer:

1. Open the Plant Explorer and select Control Structure in the structure browser.
2. Select the required object, right-click and select Advanced > Write Allocation in to CBM.

**IEC61850 Devices**

Input output allocation for IEC61850 allocates the signals of the hardware type CI868IEC61850HwLib.

**Prerequisites**

- 800xA system should be created and running.
- Engineering Studio build should be installed.
- ABB AC800M Signal Extension for IEC61850 should be loaded.
Create System Extension for IEC61850

ABB AC800M Signal Extension for IEC61850 is available in the System Extension Load of Configuration Wizard.

System extension has dependency on ABB Signal Extension for AC800M Connect.

Installing IEC61850 devices

Steps:
1. In Control Builder M, insert CI868IEC61850Hwlib at project level under the hardware folder and then insert CI868IEC61850Hwlib at controller level under the connected library folder.
2. Right-click on the hardware and click Insert Unit,
   Insert Unit dialog box is displayed.
3. In Insert Unit dialog box, select CI868 and click Insert.

After insertion, CI868 is visible under the Control Structure.

CI868 can also be added from control structure.

Steps to insert objects

1. In control structure, right-click on Hardware and select New Object.
New Object dialog box is displayed.

![New Object dialog box](image1)

**Figure 137. New Object**

2. In New Object window, browse and expand CI868IEC61850HwLib (higher or lower version) and select **IED** or **MyIED**.

![Library Path](image2)

**Figure 138. Library Path**
3. Under IED or MyIED add new modules.

Allocating Signals

After allocating the Function Diagrams to an Application in the Control Structure, the IO signals (CBM_Signals) configured in Function Diagram is to be allocated to the channels of IEC61850 modules using IO Allocation tool.

To allocate the IO signals:

1. In Function Designer with an opened diagram click **Allocation > IO Allocation** from the menu bar to open the IO Allocation tool in the context of the opened diagram.

2. Right-click on the Board’s object in the left pane of the IO Allocation tool and select Insert Element.

3. Add required IEC61850 modules from the Control Structure of the opened structure browser.

4. Drag the signals from the right pane and drop them on to the Board's object in the left pane to allocate the signals.
Section 2  Configuration  IEC61850 Devices

To write allocation information to Control Builder M Professional either generate configuration data in Function Designer or right-click on the Boards object in IO Allocation tool and select Write Allocation into CBM.

User can write allocation information to CBM through Plant Explorer also.

To write to CBM through plant explorer.

1. Open Plant Explorer and select Control Structure in the structure browser.
2. Right-click the desired object and select Advanced > Write Allocation into CBM.

Avoid allocating non relevant signals for IEC1850 modules.

Figure 140. Signal Allocation
Bulk Data Manager Support and Bulk Operations

Bulk Data Manager is described in detail in *System 800xA Engineering, Engineering Studio (3BDS011223*)*. This chapter addresses some enhanced functionality useful when copying function diagrams or function components, or when setting property values via Bulk Data Manager.

*Function Designer* publishes its internal properties via the Function aspect, the Function Parameter aspect, and the Allocatable Group aspect. These include:

- Internal properties like DiagramSaveTime, ComponentSaveTime, ObjectTypeSaveTime that are used internally to subscribe to changes and to update open diagrams.
- Diagram properties like DiagramIsBad and DiagramSize.
- Allocatable group (configuration data generation) properties like FDVERSIONGEN, GENERATED, ALLOCATED, IOALLOCATED, S_STATUS, S_DESCRIPTION, ModifiedBy, ModifiedTime. See *Diagram Status in Bulk Data Manager and in System Status Viewer* on page 263.
- Component name properties like ObjectName, ObjectDescription, ControlBuilderName, ControlBuilderDescription.
- Component properties like AspectObject and NumberOfInputs.
- Component positioning properties like Position.Page or Position.X. See *Create Diagram(s) through Bulk Data Manager* on page 273.
- Port parameter properties like In1, In1.Direction, In1.DataType, In1.initVal, In1.Inversion, and In1.Visible.
- Variable properties like VariableDataType and VariableAttributes.

All copied and inherited diagram properties are published via the diagram's Function aspect. All copied and inherited component and port properties including
connect strings are published via the component's Function aspect - even if the data is physically stored inside the Function Parameter aspect, see Table 23.

Table 23. Properties get published via...

<table>
<thead>
<tr>
<th>Property</th>
<th>... gets published via</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copied diagram property</td>
<td>• Diagram’s Function aspect</td>
</tr>
<tr>
<td></td>
<td>• Diagram’s Function Parameter aspect</td>
</tr>
<tr>
<td>Inherited diagram property</td>
<td>• Diagram’s Function aspect</td>
</tr>
<tr>
<td>Copied component/port property</td>
<td>• Component’s Function aspect</td>
</tr>
<tr>
<td></td>
<td>• Component’s Function Parameter aspect</td>
</tr>
<tr>
<td>Copied component/port property marked as “Publish as”</td>
<td>• Parent diagram’s Function aspect</td>
</tr>
<tr>
<td></td>
<td>• Parent diagram’s Function Parameter aspect</td>
</tr>
<tr>
<td></td>
<td>• Component’s Function aspect</td>
</tr>
<tr>
<td></td>
<td>• Component’s Function Parameter aspect</td>
</tr>
<tr>
<td>Inherited component/port property</td>
<td>• Component’s Function aspect</td>
</tr>
<tr>
<td>Inherited component/port property marked as “Publish as”</td>
<td>• Parent Diagram’s Function aspect</td>
</tr>
<tr>
<td></td>
<td>• Component’s Function aspect</td>
</tr>
</tbody>
</table>

The number and kind of published properties vary from Function aspect to Function aspect. A simple CBM_AIS e.g. publishes Value, Value.DataType, Value.Direction, while a control module publishes all its control module parameters.

Preparation of bulk data sheets to modify or copy complete Function diagrams can be a time consuming task. It is necessary to add Function aspects from different components, and to filter out relevant properties which should be modified during copy, e.g. initial values for set points.

This is improved by the Publish via Parent Diagram setting, see Figure 10. All component and port properties marked as “Publish as” are additionally published through the parent diagram’s Function aspect. Thus user can quickly define the most important properties/parameter of a diagram (template), add the diagram’s Function...
aspect to a bulk data sheet, and copy them through Bulk Data Manager while setting individual properties/parameter, see also the following example:

Copy/paste or move for Function Diagrams between different projects is not supported through Bulk Data Manager.

When data is populated in the BDM sheet from 800xA System, if data in any cell is not in the required format, change the format accordingly.

**Copy Diagram(s) via Bulk Data Manager**

Assume you configure a simple diagram **MyTank** that measures some level and indicates that a specific level has reached. The parameters **Level** and **Start Delay** of function block **LevelDetection1** are marked as **Publish via Parent Diagram**, see **Figure 141**. These values shall be set individually while copying the diagram using Bulk Data Manager (BDM).
1. Right-click on any background inside Function diagram MyTank, and invoke the Engineering Workplace command Advanced > Bulk Data Manager.

2. Use BDM options ‘Subtree enabled’ and ‘Transaction by object’ as in Figure 145.

3. Drag&Drop the Function aspect of MyTank into an empty bulk data sheet.

4. BDM displays the Configure Properties dialog. As the LevelDetection1 parameter Level and StartDelay were marked as Publish via Parent Diagram, they are listed as diagram properties LevelDetection1.Level and LevelDetection1.StartDelay, see Figure 142. Check them in order to modify them while copying diagram(s). They get displayed in bulk data sheet row 1.

Figure 141. Example Diagram MyTank to be Copied via Bulk Data Manager
5. Drag&Drop **MyTank** into the bulk data sheet. The current values are echoed in bulk data sheet row 2.

6. In BDM copy row 2 into row 3(4,5...), set **MyTank** as source object, set individual parameter values, and invoke BDM command **Save (all Objects)**.

![Image of bulk data sheet with properties configured](image)

Figure 142. Bulk Copy Diagram(s) with Properties Published via Parent Diagram
Copy and Rename Loop Diagram(s) via Bulk Data Manager

Assume you need to bulk copy and rename a loop control, see example Figure 143. Mind that components and the ‘Name’ parameter of control modules take the diagram name ‘Typ1’ as prefix.

The BDM sheet in Figure 144 copies and renames the loops F001\LC1...LC5 and F002\LC6...LC10 in a single row. F001 and F002 are two folder objects in Functional Structure that are used later for allocation. The BDM sheet consists of two columns only:

- Object Identification (F001\LC1…LC5 and F002\LC6...LC10)
- Source Object (Typ1)

The following BDM options are used, see Figure 145:

- Subtree enabled’ (Otherwise diagram components will not be copied.)
- Transaction ‘By Object’.

Make sure **NOT** to use Transaction ‘Data Area’. ‘Data Area’ is actually not supported by CB/Function Designer. If you do so, you might get inconsistencies in your data in Functional Structure and in Control Structure.

In the copied loop diagrams ‘LCx’ the components and the ‘Name’ parameter of control modules are automatically renamed, see Figure 146. Same holds for the Control Builder Name used inside Control Builder, see Figure 147.

![Bulk Copy and Rename Loop Diagram(s)](image-url)
Figure 145. BDM Options to Copy Diagram(s)
Figure 146. Copied Loop Diagram LC1
Section 2  Configuration  

Bulk Data Manager Support and Bulk Operations

Working with Diagram References (Symbol Objects) Using Bulk Data Manager

Diagram references and diagram variables are supported as symbol objects.

Diagram references created through Bulk Data Manager must be converted from aspect object to symbol object. Upgrading aspect object to symbol object is described in System 800xA, 5.1 to 6.0 Upgrade (2PAA111694*).

Two engineering templates named **BDM_DiagramRef_Var_Basic** and **BDM_DiagramRef_Var_Advanced** are used to modify diagram references and diagram variables represented as symbol objects.

These templates display the details of each diagram reference such as reference path, reference type (input / output), reference name, reference description, variable name, variable description, variable data type, variable init value, variable attributes, can create communication variable, on copy diagram reference, source count, sink count, and MMS count in a single row.
User can perform the following operations using these templates by editing the respective fields:

- Connecting and disconnecting diagram variables.
- Modification of description of diagram variables.
- Modification of name and description of diagram references.
- Modification of datatype, initial value, and attributes of diagram variables (possible only through BDM_DiagramRef_Var_Advanced template).
- Modification of Communication Variable.
- Modification of On Copy Diagram Reference.

The above operations can also be performed when the user drags and drops the Function Diagram References aspect on to an ordinary BDM activated excel sheet. Select the required attributes from the navigation tree that is displayed.

Follow the steps to connect the diagram references in bulk:

1. Open BDM_DiagramRef_Var_Advanced engineering template.
2. Drag and drop the required object(s) having the details of diagram references and variables that need to be modified, into the template (see Figure 148).

Do not modify the values in the read only columns (columns with pink color header) of the template.

3. Enter / edit the reference name, reference description, variable name, variable description, variable datatype, variable init value, variable attributes, communication variable, and on copy diagram reference as required (see Figure 149).

An error message is displayed, when the user provides invalid entries in the variable datatype (e.g. bool, real, BoolIO, RealIO, int) and variable attribute (e.g. retain, coldretain, nosort, constant, hidden, state) columns.

4. Click Save All Objects.
In the entered diagram variable names, the existing diagram variables get connected to the respective diagram references. The new diagram variables are created and get connected to the respective diagram references.

All the changes made in the descriptions / value / data type / attributes are also incorporated.

**Bulk Allocate Diagrams**

The diagrams copied and connected in the bulk examples above are placed in Control Structure in the Unallocated Application, see Figure 150. In order to allocate them to different control applications, they could be moved individually in Control Structure.

Because we have located them in folders/groups F001, F002 in Functional Structure, another approach is taken here: Allocate the folders/groups including the child diagrams in a single step:
F001 and its child diagrams LC1...LC5 shall be allocated to Application_1.
F002 and its child diagrams LC6...LC10 shall be allocated to Application_2.

The bulk data sheets in Figure 151 and Figure 153 first add a Function, an Allocatable Group, and a Diagram aspect to the folders/groups F001 and F002. In a 2nd step the folders/groups are moved to the corresponding applications.

*Figure 150. Unallocated Diagrams LC1...LC10*
After step 1, the folders/groups F001, F002 are also placed in the unallocated application.

Figure 151. Bulk Allocate, Step 1: Create Allocation Aspects

After step 1, the folders/groups F001, F002 are also placed in the unallocated application.

Figure 152. Unallocated Diagrams F001, F002, LC1...LC10 After Step 1
After step2, the folder/group F001 is allocated to Application_1, and F002 is allocated to Application_2. The child diagrams LC1...LC10 are still located in the unallocated application, they get moved to the correct application when generating configuration data for the parent folders/groups F001, F002, see Bulk Generate Configuration Data on page 261.

Figure 153. Bulk Allocate, Step2: Move Folders/Groups to Applications.
Bulk Generate Configuration Data

Configuration data for the diagrams in the bulk examples above can be bulk generated by the bulk data sheet in Figure 155. Multi select the folders/groups and invoke allocatable group aspect command Generate Configuration Data. Alternatively, aspect command Generate Configuration Data (Full Build) can be

Figure 154. Allocated Diagrams F001, F002 After Step2
invoked. Full build always generates all diagrams / groups including their children. Without full build, only modified diagrams/groups get generated.

It is recommended not to generate more than 2500 function diagrams at one shot through Bulk Data Manager.

These aspect commands can also be invoked from the Allocatable Group aspect in the Plant Explorer. E.g. select **FuD_Instances\F002.Allocatable Group** aspect and invoke command **Generate Configuration Data (Full Build)**.

![Bulk Generate Configuration Data](image)

**Figure 155. Bulk Generate Configuration Data**

In either case, a working dialog indicating the progress and a Cancel button is displayed. For each generated diagram/group, errors and warnings are written to the AES Error Context aspect. Successful configuration data generation can also be verified by checking the diagram status, see **Diagram Status in Bulk Data Manager**.
and in System Status Viewer on page 263.

During configuration data generation, the child diagrams LC1...LC10 and Out1, Out2 are to the correct application, see Figure 156.

![Control Builder M Professional - Project1 (Offline)](image)

**Figure 156. Allocated and Generated Diagrams**

**Diagram Status in Bulk Data Manager and in System Status Viewer**

The diagram status can be checked
- by the traffic light status bar indication for each diagram, see *Instance Specific Initial Values* on page 160.
• by the bulk data sheet in Figure 157. The allocatable group aspect properties
  - GENERATED
  - S_STATUS
  - S_DESCRIPTION
  indicate successful configuration data generation.
• in System Status Viewer, see Figure 158 and Instance Specific Initial Values on page 160. Add a System Status Viewer aspect to a folder/group or to any parent object in Functional Structure or in Control Structure. The System Status Viewer displays the status of all child diagrams/groups.

Figure 157. Check Diagram Status in BDM
Bulk Documentation and Contents

User can bulk print and create a contents diagram for each substructure in Functional Structure. E.g. to print and create a contents chapter for all diagrams, add a Function aspect to the Root object in Functional Structure and follow the steps below.

Following the bulk examples above, we print and create a contents chapter for the diagrams in folder/group F001:

- Open the Function aspect of F001.
- Invoke command **File > Create Contents** to create a contents diagram.
- In the **Create Contents dialog** select a template and check complete or overview contents, see **Figure 159**.
  - Complete contents create detailed contents for each diagram and all its pages including functional designation (if any), name, description, page comment and page number. See **Figure 160**.
  - Overview contents create contents for all diagrams according to the selected number of levels. The overview includes functional designation, name, description, and number of pages. Child diagrams are indented according to their level in Functional Structure.
• On OK, the contents diagram gets created according to the selected template and settings, see Figure 160. The diagrams get listed according to their level in alphabetical order. In this example, the contents diagram lists the diagram name, its description, and page numbers.

• You can modify and save the created contents diagram, e.g. add some binder information and simple graphical components like lines and texts.
  – **File > Open Contents** command opens an already created contents diagram.
  – **File > Create Contents** command overwrites an already created one.

![Create Contents Dialog](image)

*Figure 159. Create Contents Dialog*
User can add individual page comments to the diagrams. E.g. open diagram F001\LC1 and invoke the page comment button on the Page toolbar, or the View > Pages > Page Comment command.

- In the Page Comment dialog enter a page comment and select a range of pages to apply the comment to. See Figure 161.
• Recreate the F001 contents diagram with page comments by the File > Create Contents command. See Figure 162.

*Figure 161. Page Comment Dialog and Page Comment in Diagram*
User can also modify the contents template and adapt them to your needs. E.g. change fonts, distances, and references displayed. In [Object Type Structure] Functional Planning \Diagram Templates\ContentsTemplates select a corresponding contents template and open its Function Diagram Contents Template aspect, see Figure 163. The templates installed by the Function Designer system extension define the following aspect property and document references:

- **Detailed contents:**
  - $$.Functional Designation:Name$$
  - $$.Name:Name$$
  - $$.Name:Description$$
  - $$.PgComment$$
  - $$.Page/$$Page/$$LastPage$$

- **Overview contents**
  - $$.Functional Designation:Name$$
In order to bulk print diagrams or a complete substructure of diagrams in Functional Structure, select the parent Function aspect.

1. Invoke the **File > Page Setup** command to open a standard Windows Page Setup Dialog. Enter a suitable printer page size. Typically, this printer page equals the diagram page size selected by the diagram template.

Check the **component properties** of selected text elements in the contents templates. Component names prefixed by **DetailedContents**... define the complete/detailed contents, and component names prefixed by **OverviewContents**... define the overview contents.

![Figure 163. Contents Templates in Object Type Structure](image)

**Figure 163. Contents Templates in Object Type Structure**

In order to bulk print diagrams or a complete substructure of diagrams in Functional Structure, select the parent Function aspect.
a. Invoke the **File > Template** or **Edit > Measurements and Size** command in order to check the diagram page size, see Figure 164.

b. In cases that the diagram page size (e.g. A3 landscape) differs from the printer page size (e.g. A4 landscape), select **Fit to sheet(s)** in Figure 164.

---

**Figure 164. Edit > Measurements and Size Dialog**

2. Invoke the **File > Print** command in order to run the bulk print job.
   a. Check **Contents** to print the contents diagram.
   b. Check **Diagrams** [Child Diagrams] to print diagrams including children.
   c. Check **Instances of Diagram Types** to print diagrams of object types with their instance specific data.
   d. Check required options for additional Port Documentation:
      - **Hidden Ports with Modified Initial Values**
      - **Connected Hidden Ports**
      - **Visible Ports with Modified Initial Value**
      This additional documentation is generated in list form.
   e. Check the **Printer and Printer Page Settings** to print the contents and diagrams with individual printer and printer page settings, or you can inherit and even save the settings from the parent Function aspect. In the
latter case you can verify or change these settings by pressing the **Page Setup** button.

f. Check the **Print Components on Layers** options to print the diagrams as laid out on the screen, or in their original color. In the first case, components on different layers get grayed or not printed at all according to the layer properties.

![Print Dialog](image)

Figure 165. Function Designer Print Dialog (File > Print)

- **Check the Hide Online Values** option as required
- **Click OK.** The standard Windows Print dialog gets displayed, see Figure 291. Confirm or change the selected printer driver, number of copies, and option Print To File, and press OK again.
- **A print working dialog indicating the current printed diagram gets displayed.** You can cancel the print job by pressing its **Cancel** button.
5. The printed diagrams are printed according to their level in alphabetical order. And they get listed in the output window of the parent Function aspect.

Create Diagram(s) through Bulk Data Manager

You can also bulk create diagrams via BDM from scratch. E.g. the bulk sheet in Figure 166

- creates a diagram F010D1 from a diagram template type Function Diagram A4 portrait,
- adds components D1_PV1, D1_PVIn, D1_PID
- and positions them to the given positions and page numbers:
  - Position.Page sets the page number
  - Position.Y and Position.X set the top-left position of a component
    - in 0.01 mm for metric (ISO) diagram templates like A4, A3, and
    - in 0.001 inch for english (US) templates like letter, legal.

Perform the following while inserting Function Blocks or Control Modules in several pages of a Function Diagram using Bulk Data Manager:

- The Bulk Data Manager sheet must be sorted in ascending order with respect to the Position.Page values (shown in figure), if these values are provided in the Bulk Data Manager sheet.

- These components get instantiated as aspect object. By setting the aspect property Function Parameters.Aspect Object to ‘false’ user can bulk convert
them into symbol objects, see *Aspect Objects and Symbol Objects* on page 69.

Figure 166. Bulk Create Diagrams From Scratch

- User can also bulk connect components via BDM. E.g. bulk sheet **Figure 167**
  - connects D1_PV1.Value with D1_PVIn.AnalogInput via link1
Section 2  Configuration

Bulk Data Manager Support and Bulk Operations

- connects D1_PVIn.Out with D1_PID through link2.

Figure 167. Bulk Connect Components
Figure 168. Diagram Created from Scratch with BDM
Import / Export (AFW-Files)

A Function Diagram defines the allocatable group which implement the entities for a Function Diagram object in the Functional Structure. They are a sub-entities to a Control Application entity. Importing / exporting a Function Diagram object is performed by the Import / Export tool.

A Function Diagram type object is implemented as a Control Module Type object and therefore also is an entity.

The Import / Export tool is described in System 800xA, Administration and Security (3BSE037410*).

Import/export for control projects, control applications, control libraries, control module types etc. is described in System 800xA Control, AC 800M Configuration (3BSE035980*).

Export / Import Function Diagram

A Function Diagram can be exported /imported either allocated or un-allocated. If the control application does not exist in the target system you are queried for a corresponding new placement. If the signals of the diagram are allocated they will loose the allocation to boards during export and have to be re-allocated in the target system.

The following procedure assumes that the dependencies of the Function Diagram are already fulfilled except for new placements to be done on the target system: All required system extensions are loaded, all user defined libraries and object types are available, the target Control Project is available and the needed libraries are connected to the target Control Application.

To export a single Function Diagram:

1. Launch the Import / Export tool from the toolbar of Plant Explorer.
2. Drag and drop the Function Diagram object into the left pane of the Contents tab of the Import / Export tool window.
3. Accept the check-marked contents shown in the Add Items dialog and press OK. By default export is done without dependencies.
4. In the toolbar press Save.
5. In the Save import/export-file dialog navigate to an appropriate folder, enter a file name and click **Save**.

The Function Diagram is now available as .afw archive file. Neither the parent objects not the dependencies of the Function Diagram have been added.

To import a single, not yet existing Function Diagram:

1. Transfer (or give access to) the stored .afw file to the workstation where you want to do the import.
2. Make sure that the required system extensions and user-defined libraries are loaded.
3. Launch the Import / Export tool from toolbar of Plant Explorer.
4. In the toolbar press **Open**.
5. In the Open import/export-file dialog navigate to the stored .afw archive file and press **Open**.
6. If the parent object hierarchy given in the Functional Structure and in the Control Structure of the source system is not available in the Functional Structure and in the Control Structure of the target system: Provide corresponding substitutions by editing new placements in the Placements tab. Or rely on the Import Export tool querying you for new parent objects during import. This includes placements in Control Structure that assign the Function Diagram to a new Control Project and a new Control Application.
7. In the toolbar press **Import All**.
8. A progress dialog pops up. Wait until an end message like “Import succeeded” is shown in the grid area of this dialog.

   A warning message is given: “Restore Single Control Module <SCM name> succeeded with warnings. Reason: A single control module may only be imported as part of an entity.”

   This warning can be accepted as Generate Configuration Data command (see below) will incorporate the single control module representing the Function Diagram into the control application.
Section 2  Configuration

Export / Import Application

9. If no further error messages are shown in the grid area of the progress dialog: Press **Done** to exit.

10. To complete the imported diagram:
   a. Re-connect the diagram references to appropriate diagram variables.
   b. If not allocated: Allocate the diagram to an application.
   c. (Re-)Allocate the signals to I/O boards.
   d. Perform Write Allocation into CBM.
   e. Perform Generate Configuration Data. This is required in any case.
   f. Download the corresponding application to make this new diagram work in the controller.

   If the Function Diagram object already exists in the target system you are queried for replacement of this object. If you press **Yes** the diagram will be replaced completely by the imported one.

   Replacing the Function Diagram overwrites changes of the same diagram the in target system done in parallel to the changes in the engineering system.

Export / Import Application

A control application can be exported / imported with all Function Diagrams allocated to it.

The following procedure assumes that the dependencies of the control application and Function Diagrams are already fulfilled except for new placements to be done on the target system:

To export the control application:

1. In the Control Structure navigate to the control application and drag and drop it onto the Contents tab of the Import / Export tool.
   Alternative:
   In the Function Structure navigate to a Function Diagram allocated to the control application and drag and drop it onto the Contents tab of the Import / Export tool. Additionally add the dependency of this Function Diagram to the control application via the Add Items context menu to the contents to export.
2. Save the .afw-file.

To import the control application:
1. Open the .afw file with the Import / Export tool
2. Edit placements in the Placements tab or rely on editing placements when query boxes on missing placements during import show.
   If the project does not exist on the target system the application can be placed into another project.
3. In the toolbar press **Import All** and wait until an end message like “Import succeeded” is shown in the progress dialog.
4. If no error messages are shown in the grid area of the progress dialog: Press **Done** to exit.
5. To complete the diagrams of the imported application:
   a. If needed: Re-connect the diagram references to appropriate diagram variables.
   b. Allocate the signals to I/O boards.
   c. Perform Write Allocation into CBM.
   d. Perform Generate Configuration Data for all Function Diagrams. This is required in any case.
   e. If needed: Change task connection of the imported application.
   f. Download the application to make it work in the controller.

If the control application object already exists in the target system you are queried for replacement of this object. If you press **Yes** the application will be replaced completely by the imported one.

Replacing the control application overwrites changes of the same control application in the target system done in parallel to the changes in the engineering system.
**Export / Import IO Allocation**

A control application with several Function Diagrams can be exported / imported with keeping the allocation of signals to I/O boards. This requires to export / import the controller, which includes the corresponding I/O boards, too.

To export:

1. In the Control Structure navigate to the control application and drag and drop it onto the Contents tab of the Import / Export tool.
2. In the Control Structure navigate to the controller and drag and drop it onto the Contents tab of the Import / Export tool.
3. Save the afw-file.

You can also split the required contents into two files: One for the application and one for the controller.

To import:

- Replacing the controller overwrites changes of the same controller in the target system done in parallel to the changes in the engineering system.
- Replacing the control application overwrites changes of the same control application in the target system done in parallel to the changes in the engineering system.

1. Open the .afw file with the Import / Export tool.
2. If the control project does not exist: Edit placements in the Placements tab or rely on editing placements when query boxes on missing placements during import show.
3. In the entity view navigate to and right-click on the controller.
4. Click **Import** to import the controller.
5. If controller is already existing: Answer the replace queries with **Yes**.

A warning message is given: “Restore Application <application name> succeeded with warnings. Reason: An application may only be imported as part of an entity.”

This warning can be accepted as the import of the control application that follows will correct the situation.
6. If no error messages are shown in the grid area of the progress dialog: Press **Done** to exit.

7. In the entity view navigate to and right click on the control application.

8. Click **Import** to import the control application.

9. If the control application is already existing: Answer the replace queries with **Yes**.

10. If no error messages are shown in the grid area of the progress dialog: Press **Done** to exit.

11. To complete the diagrams of the imported control application:
   a. If needed: Re-connect the diagram references to appropriate diagram variables and perform Generate Configuration Data for the affected Function Diagrams.
   b. Download the application to make it work in the controller.

Always disable function **Automatic Write Allocation into CBM** in IO Allocation tool before performing import operation.

---

**Export / Import Project**

A control project can be exported with all its control applications, its Function Diagrams and controllers.

To export:

1. In the Control Structure navigate to the control project and drag and drop it onto the Contents tab of the Import / Export tool.

2. Depending on the target system add the needed dependencies.

3. Save the afw-file.

To import:

Replacing the control project overwrites changes of the same control project in the target system done in parallel to the changes in the engineering system.

1. Open the .afw file with the Import / Export tool.
2. In the toolbar press **Import All** and wait until an end message like “Import succeeded” is shown in the progress dialog.

3. If no error messages are shown in the grid area of the progress dialog: Press **Done** to exit.

4. All Function Diagrams keep their allocation to control applications and their I/O allocation. Do adaptations to the project contents as required.

**Detailed Difference Report**

Difference report provides the differences between Function Diagrams in the system and Diagrams present in the afw file to be imported. If there are any modifications between the Function Diagrams, the difference report provides a report for the Function aspect indicating the additions, deletions, or modifications between the Function Diagrams. For more details, refer to the *System 800xA, Maintenance* \(3BSE046784\*) manual.

**Segmentation of AFW-Files**

To limit memory consumption during export or import of an afw-file a segmentation of the exported contents into several afw-files can be necessary. Note that memory consumption is determined by the size of the aspects included into an afw-file. The size of an aspect depends on many circumstances, like for example added bitmaps to Function Diagrams or Graphic Displays or added documents to Document aspect, etc.

A control project to export can be segmented for example into:

- One file for the Control Project, in the Add items dialog un-check the check box **Include children**.
- One file for each Control Application.
- One file for each Controller.

A control application can be segmented for example into:

- One file for the Control application, in the Add items dialog un-check the check box **Include children**.
One file for each Function Diagram.

CBM shows error messages “Error reading sourceblock: <application name> ...” during import of the application and during import of the diagrams until import of the last but one. Further, Import shows a warning “Restore Single Control Module <SCM name> succeeded with warnings. ...” for each diagram’s single control module. These messages can be accepted as mandatory generation of configuration data for the diagrams will correct the data of the application.

The files have to be imported in the same sequence as they were exported.

### Engineering Repository

The 800xA System Engineering Repository set up is described in *System 800xA, Maintenance (3BSE046784*)

Standard entities of the control structure can be used to store and move Function Diagrams between different systems using the Engineering Repository. These entities can be directly exported to the Engineering Repository by selecting the Engineering Repository context menu available from the Control Project, Control Applications, and Controller.

If the target system does not contain the same functional structure, define a parent object as custom entity in the source system and then export the functional structure.

Configure the source and target systems to move engineering solutions including the functional structure elements from a source system to a target system using Engineering Repository:

**In Source System:**

1. Define a custom entity of the functional parent object with dependencies including children in the Repository Browser.
2. Export the custom entity of the source system to Engineering Repository.
3. In the Control Structure, export the desired standard entity of the Source System to the Engineering Repository.
In Target System:
1. Import the custom entity of the Functional Structure from Repository.
2. Import the Control Structure entity from Repository.

For more details on Engineering Repository, refer to *System 800xA, 5.1 Configuration (3BDS011222)*.

**Application Change Management**

The 800xA System Application Change Management (ACM) is described in *System 800xA Engineering, Application Change Management (2PAA108438)*.

Standard entities of the control structure can be used to store and move Function Diagrams between different systems using the ACM. These entities can be directly checked in to ACM Server using the context menu available from the Control Project, Control Applications, and Controller.

Configure the source and target systems to move engineering solutions including the functional structure elements from a source system to a target system ACM:

In Source System:
1. A Function Diagram created in functional structure is by default an entity. If the diagrams are organized under a generic parent object, define that object as custom entity in the ACM Client application.
2. Check in the parent object from the source system to ACM Server.
3. If the Function Diagram is created using a user defined diagram template, then the template must be checked in separately from the Object Type Structure.
In Target System:

1. Perform GetLatest of the diagram template from ACM Client to target system.

2. Perform GetLatest of the parent object from the ACM Client to the target system.

For more details on Application Change Management, refer to System 800xA Engineering, Application Change Management (2PAA108438*).
Section 3  Graphic Editor Reference

This section describes the graphic editor user interface of both Function Designer and Topology Designer.

The texts denominate designer / designer aspect / designer structure / designer component where

- Function Designer / Function aspect / Functional Structure / Function component / Function diagram
- and Topology Designer / Topology aspect / Control Structure / Topology component / Topology diagram apply

Figures are taken from Function Designer. Exceptions for Topology Designer are mentioned explicitly.

Topology Designer / Topology Status Viewer functions are described further in *System 800xA Engineering, Topology Designer (3BDS011225)*.

Exploring the Windows User Interface

Designer can be used with full functionality in a preview window as part of the Plant Explorer window of the **Engineering Workplace** or Plant Explorer Workplace, or in a separate popup (overlap) window, see *System 800xA Engineering, Function Designer Getting Started (3BDS100968)*.

You can open several windows and order the windows cascading, tiled or as icons. It is also possible to split a window horizontally and/or vertically.
Main Window Handling

On top, the main window displays a navigation toolbar containing useful commands for navigating between aspects, views, and menus.

![Navigation Toolbar of the Designer’s Main Window](image)

*Figure 169. Navigation Toolbar of the Designer’s Main Window*

In detail, the following commands and controls are offered:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Back Arrow" /></td>
<td>Goes back to previous Aspect in display history</td>
</tr>
<tr>
<td><img src="image" alt="Forward Arrow" /></td>
<td>Goes forward to next Aspect in display history</td>
</tr>
<tr>
<td><img src="image" alt="Menu" /></td>
<td>Opens a context menu with object verbs of the selected Aspect Object. The icon displayed is the one of the selected Object.</td>
</tr>
<tr>
<td><img src="image" alt="Pointer" /></td>
<td>Clicking on the pointer lists all Aspects in display list.</td>
</tr>
<tr>
<td><img src="image" alt="Drop Target" /></td>
<td>Drop Target; only active if the window is unpinned.</td>
</tr>
<tr>
<td><img src="image" alt="Pin/Unpin" /></td>
<td>Pins/Unpins the current window</td>
</tr>
<tr>
<td><img src="image" alt="Aspect View Change" /></td>
<td>Opens a context menu for changing between aspect views, e.g. between Diagram and the Component view</td>
</tr>
<tr>
<td><img src="image" alt="Aspect Verb" /></td>
<td>Opens a context menu with aspect verbs of the selected Aspect.</td>
</tr>
</tbody>
</table>

**Diagram/Component View**

Designer offers three different views on the designer aspect:

- **Component view:**
  
  Use Component view to create symbols or templates for designer components.
• Diagram view:
  Use Diagram view to create designer diagrams and to insert designer components.

• Parent Diagram view:
  Use Parent Diagram view to navigate to the parent diagram. This view only exists if there is a diagram in an object in the designer structure above the object containing the designer aspect.

To open one of these views right click on the designer aspect and select the corresponding context menu item.

On choosing an object from designer structure or Object Type Structure, designer recognizes whether a (parent) diagram and/or component data is existing and automatically opens a corresponding default view.

The Component view is default if there exists component data, but no diagram nor a parent diagram.

The Parent Diagram view is default if there exists component data and a parent diagram, but no diagram data.

If both component data and diagram data are existing in a designer aspect, the Diagram view is opened.

Component View

To open designer’s Component view, click the pointer on icon <image> in the navigation toolbar, and choose Component from the context menu.

Component view displays component document windows with optional split panes.

Diagram View

To open designer’s Diagram view, click the pointer on icon <image> in the navigation toolbar, and choose Diagram from the context menu.

Diagram view displays a diagram document window with optional split panes.
Parent Diagram View

To open designer’s Parent Diagram view, click the pointer on icon in the navigation toolbar, and choose Parent Diagram from the context menu.

Parent Diagram view displays the parent diagram in designer structure, opens a diagram document window with optional split panes, and automatically navigates to the diagram page and scrolls to the component selected in Plant Explorer.

Diagram/Component Document Windows

Open Diagram/Component Documents

Diagram/Component document windows can be opened in several ways:

- To create a new diagram / component document on a function aspect, choose the File > New menu command.
- To open an existing Diagram / Component document, choose the File > Open menu command and use the Open Aspect dialog.
- To open a child (nested) diagram, containing a detailed diagram, choose the View > Goto Child Diagram menu command or the Goto Child Diagram context menu command (Designer Component Context Menu).

Open New Windows

The designer offers the possibility to open simultaneously several diagram/component documents. Each diagram/component document is opened in a separate window, so you can have several windows open at the same time.

The designer also offers the possibility to open the same diagram/component document in several windows. That can be useful, for example, to display different parts or pages of a diagram/component simultaneously in different windows.

To open a new window for an already diagram/component, choose the Window > New Window menu command. Each window displaying the same diagram/component document automatically gets a unique number as suffix in the window’s title separated by a colon from the original title.
Arranging Windows

If you have opened simultaneously several diagram/component document windows you can arrange them by using Window Menu items Cascade, Tile, Arrange Icons, and Workbook Mode.

Splitting Windows

It is possible to split a window either in horizontal or in vertical direction or in both. These so-called splitter windows can be used to display different parts or pages of the same diagram which normally could not be simultaneously displayed on the screen.

To split a window, do as follows:

- To split the window horizontally, point to the corresponding area on top of the vertical scroll bar, and drag and drop the split bar.
- To split the window vertically, point to the corresponding area on the left side of the horizontal scroll bar, and drag and drop the split bar.

The following figure illustrates the procedure respectively the result of splitting a window horizontally and vertically.

Figure 170. Splitting Windows
Dockable Windows/Toolbars

In designer, the menu bar, tool bars, Structure Browsers, Output Window, and Watch Window are dockable. That means, they can be

- docked on top of the main window
- docked on bottom of the main window
- docked at the left border of the main window
- docked at the right border of the main window
- or undocked, i.e. floating as popup window independent of the main window.

Figure 171 displays an example with undocked windows/toolbars.

![Figure 171. Undocked Windows/Toolbars](image)
Figure 172 displays an example with docked windows/toolbars.

Figure 172. Docked Windows/Toolbars
Changing the Location of Docked Windows/Toolbars

You can dock a window/toolbar at the four border areas of the main window. To dock a window/toolbar at another location, drag-and-drop it to the wanted location.

Figure 173 displays an example with different dock locations.

The menu bar cannot be docked back by drag and drop action. Double-click the menu bar to dock it back.

Figure 173. Toolbar Locations for Docking
Working with Menus

Designer’s menu bar is switched according to
- the active view, Component View or (Parent) Diagram View
- the existence of component / diagram data.

The complete Menu bar contains the following menus:
- File Menu
- Edit Menu
- View Menu
- Insert Menu
- Layout Menu
- Allocation Menu (not available in Topology Designer)
- Online Menu (not available in Topology Designer)
- Window Menu
- Help Menu

The entry in the D/C column of tables listing menu commands indicates in which designer view (Diagram/Component) the menu command is available.
File Menu

Figure 174 and Figure 175 provides the different File menu options available in the Plant Explorer for the diagram and component views.

Figure 174. File Menu - Diagram View
### Table 24. Description for File Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; New...</td>
<td>ALT &gt; F &gt; N</td>
<td>CTRL+N Opens the dialog New dialog to create a new component, component template, or XML type definition. Topology Designer: No dialog.</td>
<td>C</td>
<td>Standard</td>
</tr>
<tr>
<td>File &gt; New...</td>
<td>ALT &gt; F &gt; N</td>
<td>CTRL+N Creates a new diagram. Opens the Select Master Page Template dialog to copy or reference a template with header and footer like A3, A4 portrait/landscape. Topology Designer: Templates and Skeletons</td>
<td>D</td>
<td>Standard</td>
</tr>
<tr>
<td>File &gt; Open...</td>
<td>ALT &gt; F &gt; O</td>
<td>CTRL+O Opens the Open Aspect dialog to open any component/diagram document, or any other aspect.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>File &gt; Save</td>
<td>ALT &gt; F &gt; S</td>
<td>CTRL+S Saves the current component/diagram document into the function aspect.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
</tbody>
</table>

*Figure 175. File Menu - Component View*
### Table 24. Description for File Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save All</td>
<td>ALT &gt; F &gt; L</td>
<td>Saves all open component/diagram documents.</td>
<td>D</td>
<td>Standard</td>
</tr>
<tr>
<td>File &gt; Skip Modifications</td>
<td>ALT &gt; F &gt; M</td>
<td>Undo all changes in current component/diagram document since last saving.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>File &gt; Reserve Diagram</td>
<td>ALT &gt; F &gt; R</td>
<td>Reserves the diagram or control module type for exclusive modify access.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>Topology Designer:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File &gt; Reserve Project or</td>
<td>ALT &gt; F &gt; R</td>
<td>Reserves the project or application or controller for exclusive modify access.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>File &gt; Reserve Application or File &gt; Reserve Controller</td>
<td>ALT &gt; F &gt; E</td>
<td>Reserves the application (including all diagrams) or library for exclusive modify access.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>File &gt; Reserve Application</td>
<td>ALT &gt; F &gt; E</td>
<td>Reserves the application (including all diagrams) or library for exclusive modify access.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>File &gt; Release Reservation Diagram</td>
<td>ALT &gt; F &gt; V</td>
<td>Releases the diagram / the application or the control module type / the library from exclusive modify access.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Function Designer (Component View)</td>
<td>ALT &gt; F &gt; A</td>
<td>Releases the controller from exclusive modify access.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>File &gt; Release Reservation Diagram</td>
<td>ALT &gt; F &gt; A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Topology Designer:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File &gt; Release Reservation</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File &gt; Generate Configuration Data</td>
<td>ALT &gt; F &gt; G</td>
<td>Saves the diagram and (re)generates configuration data, e.g. for AC 800M.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Not available in Topology Designer</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Table 24. Description for File Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File &gt; Generate Configuration Data (Full Build)</strong></td>
<td>ALT &gt; F &gt; D, CTRL+ALT+G</td>
<td>Saves the diagram and (re)generates configuration data, e.g., for AC 800M. This command builds all diagram.</td>
</tr>
<tr>
<td>Not available in Topology Designer</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>File &gt; SVG Import...</strong></td>
<td>ALT &gt; F &gt; I</td>
<td>Opens the File Import dialog to import component or background graphics.</td>
</tr>
<tr>
<td>Topology Designer &amp; Function Diagram (Component View): File &gt; Import</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>File &gt; SVG Export...</strong></td>
<td>ALT &gt; F &gt; X</td>
<td>Opens the File Export dialog to export the current component/diagram document into a different file format.</td>
</tr>
<tr>
<td>Topology Designer &amp; Function Diagram (Component View): File &gt; Export</td>
<td>ALT &gt; F &gt; E</td>
<td></td>
</tr>
<tr>
<td><strong>File &gt; Import Diagram Data</strong></td>
<td></td>
<td>Opens the <strong>Open</strong> dialog to import the .xml file.</td>
</tr>
<tr>
<td><strong>File &gt; Export Diagram Data</strong></td>
<td></td>
<td>Opens the <strong>Save As</strong> dialog to save the required file in .xml format.</td>
</tr>
<tr>
<td><strong>File &gt; Template...</strong></td>
<td>ALT &gt; F &gt; T</td>
<td>Opens the Select Master Page Template dialog to copy or reference a drawing template with header and footer like A3, A4 portrait/landscape.</td>
</tr>
<tr>
<td><strong>File &gt; Create Contents...</strong></td>
<td></td>
<td>Creates or updates a contents diagram for a function diagram or a complete substructure.</td>
</tr>
<tr>
<td><strong>File &gt; Open Contents</strong></td>
<td></td>
<td>Opens already create contents diagrams.</td>
</tr>
<tr>
<td><strong>File &gt; Page Setup...</strong></td>
<td>ALT &gt; F &gt; U</td>
<td>Opens the Page Setup dialog to change page layout settings.</td>
</tr>
</tbody>
</table>
Table 24. Description for File Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Print...</td>
<td>ALT &gt; F &gt; P</td>
<td>Prints the active component/diagram document, and optionally child diagrams.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>File &gt; Print Preview</td>
<td>ALT &gt; F &gt; W</td>
<td>Displays a print preview of the active document.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Topology Designer &amp; Function Designer (Component View) File &gt; Print Preview</td>
<td>ALT &gt; F &gt; V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File &gt; Check... Not available in Topology Designer</td>
<td>ALT &gt; F &gt; C</td>
<td>Check diagram for valid identifiers and connections.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>File &gt; Replace Constants... Not available in Topology Designer</td>
<td></td>
<td>Remove constant connections that equal the initial value.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>File &gt; Exit</td>
<td></td>
<td>Allows the user to close the Function Diagram.</td>
<td>D/C</td>
<td></td>
</tr>
</tbody>
</table>

- **File > New**

  In Component view, choose this menu command to create a new function component, or to overwrite an existing one. For Function Designer, the command opens the New dialog. It allows to select between the three options:

  - **Component**: To create or overwrite a complete designer component definition including fixed graphical symbol with ports, and a fixed parameter set.
  
  - **Component Template**: To create or overwrite designer component template, i.e. a graphical symbol template. On instantiation in a function diagram, a complete graphical symbol and ports are automatically created on base of this template and on the actual parameter set.
  
  - **XML Type Definition**: To create or overwrite a XML based type definition including a fixed and extensible set of parameters. On instantiation in a designer diagram, parameters are automatically created on base of this type definition. Typically used together with a designer component template to define object types.
For Topology Designer no dialog is shown.

In Diagram view, choose this menu command to create a new designer diagram, or to overwrite an existing one. The command opens the Select Master Page Template dialog for Function Designer and the Templates and Skeletons for Topology Designer:

- to copy or reference a template for the master page layer with header and footer like A3, A4 portrait/landscape
- or to leave the initial diagram blank
- or to copy a skeleton (Topology Designer only).

See also File > Template.

- **File > Open**
  Choose this menu command to open an existing designer component, designer diagram, or any other aspect. See also Open Aspect on page 390.

- **File > Save**
  Choose this menu command to save your current designer component or designer diagram.

- **File > Save All**
  Choose this menu command to save all open designer diagrams.

- **File > Skip Modifications**
  Choose this menu command to undo all changes done in the current designer component or designer diagram since last save operation. User will get a warning as shown below:

 ![Warning Function Designer (Diagram View)](image)
Click **Yes** to confirm skipping the modification. Click **No** to cancel it, if you want to continue working your designer component or designer diagram.

If in Diagram view, you did create / delete aspect objects, modify aspect properties or modify connections these modifications are not undone on File > Skip Modifications, or on Close Diagram.

File > Skip Modifications restores graphics data stored in the designer aspect only, but does not restore aspect objects nor aspect property values.

- **File > Reserve Diagram**
  In Functional Structure, it reserves the opened Function Diagram to gain exclusive modify access. This is a toggle menu item, and can be used to release a reserved Function Diagram.
  
  In Object Type Structure, it reserves the library that is allocated to the control module object type of the opened Function Diagram to gain exclusive modify access.

- **File > Reserve Application**
  It reserves the application to which the Function Diagram is allocated. This is a toggle menu item, and can be used to release a reserved application.

- **File > Release Reservation Diagram**
  In Functional Structure, it releases the Function Diagram.
  
  In Object Type Structure, it releases the Function Diagram.

- **File > Generate Configuration Data (Full Build)**
  Note: This command is not available in Topology Designer.
  
  Choose this menu command to your current function diagram and to (re)generate configuration data for an already allocated solution in Control Structure. In detail, code is regenerated for all allocatable groups belonging to this function diagram, which have a Control Structure aspect. For AC 800M objects this means that *Function Designer* generated diagrams / single control modules are generated again. The command generates the open diagram and all child (nested) diagrams, independent of their modification state.
- **File > Generate Configuration Data**
  Note: This command is not available in Topology Designer.
  For Function Diagrams created in 800xA 5.1:
  This command does the same as command **File > Generate Configuration Data (Full Build)**.
  For Function Diagrams restored to 800xA 5.1:
  This command does the same as command **File > Generate Configuration Data (Full Build)**, but is generates only those diagrams which are in state ‘modified’ (red traffic light indication in the status bar).

- **File > SVG Import**
  Opens the File Import dialog where you can select files to be imported.
  See also **Import/Export** on page 517.

- **File > SVG Export**
  Opens the File Export dialog where you can define name, location and format to export graphics data of
  - a designer component
  - a single layer/page of a designer diagram
  - a complete designer component.
  See also **Import/Export** on page 517.

- **File > Import Diagram Data**
  Opens the Open File dialog to select the required .xml file.
  See also **Export Diagram Data / Import Diagram Data** on page 519.

- **File > Export Diagram Data**
  Opens the Save As dialog to save the required file in .xml format.
  See also **Export Diagram Data / Import Diagram Data** on page 519.
• **File > Template**

For Function Designer it opens the **Select Master Page Template** dialog where you can select a predefined template with header/footers for the function diagram.

For Topology Designer it opens the **Templates and Skeletons** dialog where you can select a predefined template or skeleton with header/footers for the topology diagram.

You can add additional templates or customize installed ones in Object Type Structure:
- For Function Designer under Object Types\Functional Planning\Diagram Templates
- For Topology Designer under Object Types\Topology Planning\Diagram Templates.

See also the description in the Name aspect of corresponding object type group.

If you reference a template, the diagram’s master page layer gets read-only. That means:

- Header/footer entries like author, document number, cannot be edited inside the diagram, but are referenced as aspect properties from a Function (or Topology) Diagram Document aspect of type Document.
- Diagram instances with referenced templates get automatically updated when the template changes.

If you copy a template, the diagram’s master page layer gets writable. That means:

- Header/footer entries like author, document number, can be edited directly inside the diagram, but can also be referenced as aspect properties from a Function (or Topology) Diagram Document aspect of type Document.
- Diagram instances with copied templates do NOT get automatically updated when the template changes.

• **File > Create Contents**

Opens the **Contents** dialog to create a contents diagram

• **File > Open Contents**

Open already generated contents diagrams, see **Contents** on page 500.
• **File > Page Setup**

Choose this menu command to open the standard Page Setup dialog where you can set page layout settings like printer paper format, page orientation, and margins.

• **File > Print**

Choose this menu command to open the standard Print dialog. In case there exist child diagrams on lower level, you can optionally print all sub-diagrams.

• **File > Print Preview**

Choose this menu command to open the Print Preview where you can check how your component or diagram would be printed. Via the following buttons, you can navigate through different pages of your designer diagram, zoom the previews, display two pages simultaneously and start printing:

```
Print...  Next Page  Prev Page  Two Page  Zoom In  Zoom Out  Close
```

*Figure 176. Print Preview buttons*

• **File > Check**

Note: This command is not available in Topology Designer.

Choose this menu command to check the function diagram for valid identifiers connections, and inversions.

Save the modified Function Diagrams before performing a File > Check operation. Otherwise the latest graphical modifications (moving the existing Function Blocks / Control Modules, Field Devices, CBM_Signal objects and their signal connections) after last save will be lost.

In case there exist child diagrams on lower level, you can optionally check all sub-diagrams. The results of this command are displayed

– in the function diagram itself: Invalid identifiers, connections, or inversions are drawn in red.
– as warnings/errors in the output window in textual form. A double-click
on such a warning/error navigates to the corresponding symbol, label,
port, or connection link in the function diagram.

• **File > Complete Check**

In 800xA 5.1 and systems restored to 800xA 5.1, the **File > Complete Check**
generates a Diagram check and the compilation errors or warnings appear in
the Build pane of the Function Designer.

• **File > Replace Constants**

Note: This command is not available in Topology Designer.

Choose this menu command to remove constant connections if they equal the
initial value. By that it is possible to tune the value after download without the
need to regenerate configuration data.

This command can be optionally applied to child diagrams as well. You can
invoke this command in order to bulk update diagrams created with 800xA 3.1
where initial values of the type were connected as constants.

• **File > Exit**

Choose this menu command in Diagram view or Component view to close the
Function Diagram. It prompts the user to save the data before closing the
Function Diagram.
Edit Menu

Figure 177. Edit Menu

Table 25. Description for Edit Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Undo</td>
<td>ALT &gt; E &gt; U</td>
<td>CTRL+Z Undoes the last action.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>Edit &gt; Redo</td>
<td>ALT &gt; E &gt; R</td>
<td>CTRL+Y Redoes the previously undone action.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>Edit &gt; Cut</td>
<td>ALT &gt; E &gt; T</td>
<td>CTRL+X Cuts the selection to the clipboard.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>Edit &gt; Copy</td>
<td>ALT &gt; E &gt; C</td>
<td>CTRL+C Copies the selection to the clipboard.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
<tr>
<td>Edit &gt; Paste</td>
<td>ALT &gt; E &gt; P</td>
<td>CTRL+V Inserts the clipboards contents.</td>
<td>D/C</td>
<td>Standard</td>
</tr>
</tbody>
</table>
### Table 25. Description for Edit Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Paste with Multiple Invocation</td>
<td>SHIFT+CTRL+ALT+V</td>
<td>Inserts Diagram References and Variables with the same name as the source.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Delete</td>
<td>ALT &gt; E &gt; D DEL</td>
<td>Deletes the selected item(s).</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Find</td>
<td>ALT &gt; E &gt; F CTRL+F</td>
<td>Finds a string according to selected Options.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Replace</td>
<td>ALT &gt; E &gt; E CTRL+H</td>
<td>Finds and replaces a string according to selected Options.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Select All</td>
<td>ALT &gt; E &gt; L CTRL+A</td>
<td>Selects all components of the active layer and active page.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Components...</td>
<td>ALT &gt; E &gt; M</td>
<td>Opens the Components dialog to navigate to individual graphical components.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Component Properties...</td>
<td>ALT &gt; E &gt; I CTRL+RETURN</td>
<td>Opens the Component Properties dialog to set graphical properties.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Edit &gt; Aspect Properties...</td>
<td>ALT &gt; E &gt; A ALT+RETURN</td>
<td>Opens the Aspect Properties dialog (Ports property page) dialog.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Variable Properties...</td>
<td>ALT &gt; E &gt; V CTRL+ALT+RETURN</td>
<td>Opens the Variable Properties dialog.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Number of Inputs...</td>
<td>ALT &gt; E &gt; B CTRL+M</td>
<td>Opens the Number of Inputs dialog to configure number of inputs for system functions like and / or</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Change Type...</td>
<td>ALT &gt; E &gt; Y CTRL+ALT+Y</td>
<td>Opens the Change Type dialog to change the type of a system function, function block or control module.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Ambient Properties</td>
<td></td>
<td>Opens the Ambient Properties dialog to set ambient properties valid for the whole component/diagram.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Default Properties</td>
<td></td>
<td>Opens the Default Properties dialog to set default graphical properties for new components.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Edit &gt; Measurements and Size</td>
<td>ALT &gt; E &gt; S</td>
<td>Opens the Measurements and Size dialog to set properties of the drawing page,</td>
<td>D/C</td>
<td></td>
</tr>
</tbody>
</table>
Table 25. Description for Edit Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit &gt; Options</td>
<td>ALT &gt; E &gt; O</td>
<td>Opens the Options dialog</td>
<td>D</td>
<td></td>
</tr>
</tbody>
</table>

- **Edit > Undo**
  Choose this menu command to undo the last action. See also Undo on page 521.

- **Edit > Redo**
  Choose this menu command to redo the last undone action. See also Redo on page 522.

- **Edit > Cut**
  Choose this menu command to cut selected components to the clipboard.

- **Edit > Copy**
  Choose this menu command to copy selected components to the clipboard.

- **Edit > Paste**
  Choose this menu command to paste components (cut or copied via the Cut or Copy command) from the clipboard into the component/diagram document.

- **Edit > Paste with Multiple Invocation**
  Note: Not available for Topology Designer.
  Choose this menu command to paste diagram references or variable components with the same name as the source. For Function Diagrams restored to 800xA 5.1, choose this menu command to paste function blocks or variable components with the same name as the source.

- **Edit > Delete**
  Choose this menu command to delete selected component(s) from the component/diagram document.

- **Edit > Select All**
  Choose this menu command to select all components of the active layer and active page.
• **Edit > Find**

**Note:** Not available for Topology Designer.
Choose this menu command to open the Find tab of the Find dialog and then to find a string according to selected **Options**.

![Find Dialog, Find Tab (Options Shown)](image)

**Figure 178. Find Dialog, Find Tab (Options Shown)**

Press **Options>>** to show, press **Options<<** to hide the options part of the dialog:

- **Match case**: Mark this check box if the case of the Find what: string shall be matched.

- **Match whole word**: Mark this check box if the whole Find what: string shall be matched.

- **Search up**: Mark this check box if the search direction shall be upwards.

- **Use**: Mark this check box if the wildcards * (for a sequence of arbitrary characters) or ? (for one arbitrary character) shall be taken care during search. Disables the check boxes for case and whole word.

- **Scope**:
  In the first combo box you can choose between: Component name, component type name, control builder name, connection string, unconnected mandatory ports, unconnected ports, unconnected inputs, unconnected outputs, port name, any string.
  Default is component name.
In the second combo box you can choose between: Current layer, current diagram (all layers), current page, current selection.

- **Edit > Replace**

  Note: Not available for Topology Designer.
  Choose this menu command to open the Replace tab of the Find dialog and then to find and replace a string according to selected Options. Options see **Edit > Find** above.

![Figure 179. Find Dialog, Replace Tab (Options Not Shown)](image)

**Edit > Components**

Choose this menu command to open the Components dialog
- to navigate to individual graphical components in the component/diagram document
- to open the Component Properties dialog.

**Edit > Component Properties**

Choose this menu command to open the Component Properties dialog to set graphical properties of the selected graphic component(s) like line width, fill color, font, etc.

**Edit > Aspect Properties**

Choose this menu command to open the Aspect Properties dialog to view or set Aspect Properties of the selected designer diagram, designer component, or port.
• **Edit > Variable Properties**
  Note: Not available for Topology Designer.
  Choose this menu command to open the Variable Properties dialog to change variable properties.

• **Edit > Number of Inputs**
  Note: Not available for Topology Designer.
  Choose this menu command to change the number of input ports of applicable components.

• **Edit > Change Type**
  Note: Not available for Topology Designer.
  Choose this menu command to change the type of applicable components.

• **Edit > Ambient Properties**
  Choose this menu command to open the Ambient Properties dialog to set ambient properties that are valid for the while component/diagram document like background and selection colors.

• **Edit > Default Properties**
  Choose this menu command to open the Default Properties dialog to set default graphical properties valid for newly created/inserted graphic components (primitives).

• **Edit > Measurements and Size**
  Choose this menu command to open the Measurements and Size dialog to adjust units of measure, drawing scale, module, and the drawing page size for the active function component / function diagram.

• **Edit > Options**
  Choose this menu command to open the Options dialog to set some options concerning printing, pasting components, and auto routing.
View Menu

Figure 180. View Menu

Table 26. Description for View Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Short Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Structure Browser 1</td>
<td></td>
<td>Choose this menu option to access the Structure Browser 1.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Structure Browser 2</td>
<td></td>
<td>Choose this menu option to access the Structure Browser 2.</td>
<td>D</td>
<td></td>
</tr>
</tbody>
</table>
### Table 26. Description for View Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Short Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Output Window</td>
<td></td>
<td>Choose this menu option to access the Output window.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Watch Window</td>
<td></td>
<td>Choose this menu option to access the Watch window.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; SFC Overview</td>
<td></td>
<td>Choose this menu option to open a new dockable window that contains the sequence tree structure.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Toolbar &gt; Customize</td>
<td>ALT &gt; V &gt; T &gt; C</td>
<td>Opens the Customize dialog.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>View &gt; Status Bar</td>
<td>ALT &gt; V &gt; S</td>
<td>Turns on or off the display of the status bar.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>View &gt; Grid</td>
<td>ALT &gt; V &gt; G</td>
<td>Shows or hides the grid.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>View &gt; Snap to Grid</td>
<td>ALT &gt; V &gt; N</td>
<td>Snaps symbols to grid.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>View &gt; Grid Properties</td>
<td>ALT &gt; V &gt; D</td>
<td>Opens the Grid Properties dialog.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>View &gt; Printable Area</td>
<td>ALT &gt; V &gt; R</td>
<td>Check to outline printable area in print preview according to the selected printer and print paper size.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>View &gt; Zoom Normal</td>
<td>ALT &gt; V &gt; Z</td>
<td>Zooms the canvas display to the normal default size (100%).</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>View &gt; Zoom Percent</td>
<td>ALT &gt; V &gt; C &gt; 5</td>
<td>Zooms the canvas display to 50% of the normal size.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ALT &gt; V &gt; C &gt; 7</td>
<td>Zooms the canvas display to 75% of the normal size.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ALT &gt; V &gt; C &gt; 1</td>
<td>Zooms the canvas display to the normal default size (100%).</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ALT &gt; V &gt; C &gt; 2</td>
<td>Zooms the canvas display to 200% of the normal size.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>View &gt; Zoom Custom</td>
<td>ALT &gt; V &gt; U</td>
<td>Opens the Zoom dialog.</td>
<td>D/C</td>
<td></td>
</tr>
</tbody>
</table>
Table 26. Description for View Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Short Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Zoom to Fit</td>
<td>ALT &gt; V &gt; F</td>
<td>Zooms so that all components are visible.</td>
<td>D/C</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Layers &gt; Properties</td>
<td>ALT &gt; V &gt; L &gt; P</td>
<td>Sets Layer Properties.</td>
<td>D</td>
<td>View, Drawing</td>
</tr>
<tr>
<td>View &gt; Layers &gt; L1 Master Page Layer</td>
<td>ALT &gt; V &gt; L &gt; 1</td>
<td>Sets active layer to Master Page Layer.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Layers &gt; L2 Background Layer</td>
<td>ALT &gt; V &gt; L &gt; 2</td>
<td>Sets active layer to Background Layer.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Layers &gt; L3 Logic Layer</td>
<td>ALT &gt; V &gt; L &gt; 3</td>
<td>Sets active layer to Logic Layer.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Layers &gt; L4 Annotation Layer</td>
<td>ALT &gt; V &gt; L &gt; 4</td>
<td>Sets active layer to Annotation Layer.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Pages &gt; Insert New Page</td>
<td>ALT &gt; V &gt; P &gt; I</td>
<td>Inserts a new page.</td>
<td>D</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Pages &gt; Delete Page</td>
<td>ALT &gt; V &gt; P &gt; D</td>
<td>Deletes the active page. A page must be empty before it can be deleted.</td>
<td>D</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Pages &gt; First Page</td>
<td>ALT &gt; V &gt; P &gt; F</td>
<td>Navigates to the first page.</td>
<td>D</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Pages &gt; Previous Page</td>
<td>ALT &gt; V &gt; P &gt; P</td>
<td>Navigates to the previous page.</td>
<td>D</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Pages &gt; Next Page</td>
<td>ALT &gt; V &gt; P &gt; N</td>
<td>Navigates to the next page.</td>
<td>D</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Pages &gt; Last Page</td>
<td>ALT &gt; V &gt; P &gt; L</td>
<td>Navigates to the last page.</td>
<td>D</td>
<td>View</td>
</tr>
<tr>
<td>View &gt; Pages &gt; Goto Page</td>
<td>ALT &gt; V &gt; P &gt; G</td>
<td>Opens the Goto page dialog.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Pages &gt; Page Comment</td>
<td>ALT &gt; V &gt; P &gt; C</td>
<td>Opens the Page Comment dialog.</td>
<td>D</td>
<td>Page</td>
</tr>
<tr>
<td>View &gt; Goto Child Diagram</td>
<td>ALT &gt; V &gt; H</td>
<td>Returns to the selected symbol.</td>
<td>D</td>
<td></td>
</tr>
</tbody>
</table>
Table 26. Description for View Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Short Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>View &gt; Goto Parent Diagram</td>
<td>ALT &gt; V &gt; A</td>
<td>Shift + Return Open the parent diagram represented by the selected symbol.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Goto Referenced Diagram</td>
<td>ALT &gt; V &gt; M</td>
<td>Ctrl + T Open the referenced diagram represented by the selected off-diagram</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>symbol.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>View &gt; Subscribe for Live Data</td>
<td>ALT &gt; V &gt; B</td>
<td>Ctrl + F7 Start/Stop display of live data (on-line values) in the function</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>diagram and/or in the Watch window.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>View &gt; Subscribe for Live Data All Open Diagrams</td>
<td>Ctrl + Alt +</td>
<td>F7 Start/Stop display of live data (on-line values) for all open Function</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td></td>
<td>F7</td>
<td>Diagrams.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>View &gt; Show Last Value(s)</td>
<td>ALT &gt; V &gt; V</td>
<td>Show/Hide recent on-line values when subscription for life data has stopped.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>View &gt; Subscribe for Live Data All Output Ports</td>
<td>ALT &gt; V &gt; S</td>
<td>F9 Show/Hide recent on-line values when subscription for life data has stopped.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>View &gt; Subscribe for Live Data Connected Output</td>
<td>ALT &gt; V &gt; U</td>
<td>F11 Show/Hide recent on-line values when subscription for live data has stopped.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Ports</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>View &gt; SVG/XML Source</td>
<td>ALT &gt; V &gt; X</td>
<td>Opens the SVG/XML Source window.</td>
<td>D/C</td>
<td></td>
</tr>
</tbody>
</table>

- **View > Toolbar > Customize**

Choose this menu command to open the Customize dialog to customize toolbars.
• **View > Status Bar**

Choose this menu command to turn on or off the display of the Status Bar on bottom of the designer window.

![Figure 181. Status bar](image)

The Status Bar displays, for example,

- short menu and toolbar button help texts.
- OPC quality and time stamp while **Online > Subscribe for Live Data** is active.
  Note: Not available for Topology Designer.
- indicator ‘NUM’ and ‘SCRL’ for Numlock or Scroll-lock, respectively.
- indicator ‘Read’ for read-only components, diagrams, and layers.
  Components and diagrams might be read-only due to access control and/or inheritance of relevant aspects and/or if ActiveX Run Mode is enabled.
- information about the currently displayed mode (view) of the designer, **Diagram** or **Component**.
- information about the diagram state, e.g. modified, generated, and loaded.
  Note: Not available for Topology Designer.

If the display is turned on, the menu item is checked by ✔.

• **View > Grid**

Choose this menu command to turn on or off grid display in the current component/diagram document.

• **View > Snap to Grid**

Choose this menu command to snap components to the current grid on create, move, or copy.
• **View > Grid Properties**
  Choose this menu command to open the **Grid Properties** dialog to adjust grid size and color.

• **View > Printable Area**
  Check this menu command to outline the printable area in print preview according to the selected printer and print paper size.

• **View > Zoom Normal**
  Choose this menu command to zoom the canvas display to default size (100%). See also **Zoom Normal** on page 407.

• **View > Zoom Percent**
  Choose this menu command and select any of the available submenus to zoom the canvas display to the required percentage of normal size.

• **View > Zoom Custom**
  Choose this menu command to open the **Zoom** dialog to zoom the canvas display to the **Magnification** value selected. See also **Zoom Custom** on page 407.

![Figure 182. Zoom dialog](image)

• **View > Zoom to Fit**
  Choose this menu command to zoom the canvas to a size in order to display all all components of the active page without the need for scrolling.
• **View > Layers > Properties**  
  Choose this menu command to open the Layer Properties dialog to set properties of the different layers.

• **View > Layers > L1 Master Page Layer**  
  Choose this menu command to make the Master Page Layer active.

• **View > Layers > L2 Background Layer**  
  Choose this menu command to make the Background Layer active.

• **View > Layers > L3 Logic Layer**  
  Choose this menu command to make the Logic Layer active.

• **View > Layers > L4 Annotation Layer**  
  Choose this menu command to make the Annotation Layer active.

• **View > Pages > Insert New Page**  
  Choose this menu command to insert a new page to the diagram.

• **View > Pages > Delete Page**  
  Choose this menu command to delete the current page of the diagram. A page to be deleted must be empty, i.e. there are no components on any layer besides the master page layer.

• **View > Pages > First Page**  
  Choose this menu command to navigate to the first page of the diagram.

• **View > Pages > Previous**  
  Choose this menu command to navigate to the previous page of the diagram.

• **View > Pages > Next**  
  Choose this menu command to navigate to the next page of the diagram.

• **View > Pages > Last**  
  Choose this menu command to navigate to the last page of the diagram.
• **View > Pages > Goto Page**
  Choose this menu command to open the **Goto Page** dialog to enter the page number of interest in order to navigate to. (see also [Page Navigation on page 498](#)).

• **View > Pages > Page Comment**
  Choose this menu command to open the **Page Comments** dialog to enter a comment for a single page or a set of pages.

• **View > Goto Child Diagram**
  Choose this menu command to open the child (nested) diagram that is represented in the active diagram by the symbol selected.
  
  This menu command is only accessible if a symbol representing a (nested) diagram is selected.

• **View > Goto Parent Diagram**
  Choose this menu command to open the parent diagram that is represented in the active diagram by the symbol selected.
  
  This menu command is only accessible if a parent diagram exists for the current diagram.

• **View > Goto Referenced Diagram**
  Note: Not available for Topology Designer.
  
  Choose this menu command to open the referenced diagram that is represented in the active diagram by the selected off-diagram reference symbol.
  
  This menu command is only accessible if an off-diagram reference symbol is selected.

• **View > Subscribe for Live Data**
  Choose this toggle menu command to start/stop display of live data (on-line values) in the designer diagram or in the Watch window (**Function Designer** only).
• **View > Subscribe for Live Data All Open Diagrams**

Choose this toggle menu command to start/stop display of live data (on-line values) for all opened Function Diagrams.

• **View > Show Last Value(s)**

Choose this toggle menu command to show/hide recent on-line values when subscription for live data has stopped.

• **View > Subscribe for Live Data All Output Ports**

Choose this menu command to display on-line values for all links at the output pins on the current page. The shortcut key for this menu option is F9.

  – If selected, Subscribe for Live Data All Output Ports is active. i.e. on-line values are retrieved from the OPC server and displayed on the output pins of the current page.

  – If unchecked, Subscribe for Live Data All Output Ports is inactive. i.e. no on-line values are retrieved from the OPC server. According to the setting of ‘Show Last Value(s)’, the OPC items in the diagram display a ‘*’ or the recent value retrieved, and the OPC items display an empty value or the recent value retrieved.

• **View > Subscribe for Live Data Connected Output Ports**

Choose this menu command to display on-line values for all links at the connected output pins on the current page. The shortcut key for this menu option is F11.

• **View > SVG/XML Source**

Choose this menu command to open the SVG/XML Source window displaying the designer component / designer diagram represented as SVG/XML source code.
Insert Menu

Figure 183. SVG/XML Source Window

Table 27. Description for Insert Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert &gt; Object</td>
<td>ALT &gt; I &gt; Ins</td>
<td>Inserts an object (designer component) into the diagram.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Insert &gt; Circle Port</td>
<td>ALT &gt; I &gt; C</td>
<td>Inserts a circle port.</td>
<td>C</td>
<td>Port</td>
</tr>
</tbody>
</table>
### Table 27. Description for Insert Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert &gt; Line Port</td>
<td>ALT &gt; I &gt; P</td>
<td>Inserts a line port.</td>
<td>C</td>
<td>Port</td>
</tr>
<tr>
<td>Insert &gt; Text</td>
<td>ALT &gt; I &gt; T</td>
<td>Inserts text.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Label</td>
<td>ALT &gt; I &gt; L</td>
<td>Inserts a label.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Lines</td>
<td>ALT &gt; I &gt; G &gt; L</td>
<td>Draws a single line.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Polyline</td>
<td>ALT &gt; I &gt; G &gt; P</td>
<td>Draws a multi-segmented line.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Rectangle</td>
<td>ALT &gt; I &gt; G &gt; R</td>
<td>Draws a rectangle.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Polygon</td>
<td>ALT &gt; I &gt; G &gt; O</td>
<td>Draws a polygon.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Poly Curve</td>
<td>ALT &gt; I &gt; G &gt; C</td>
<td>Draws a series of connected curves.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Closed Curve</td>
<td>ALT &gt; I &gt; G &gt; U</td>
<td>Draws a polycurve with connecting start and end points.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Graphic &gt; Ellipse</td>
<td>ALT &gt; I &gt; G &gt; P</td>
<td>Draws an ellipse.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Picture</td>
<td>ALT &gt; I &gt; I</td>
<td>Inserts a picture.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; ActiveX</td>
<td>ALT &gt; I &gt; A</td>
<td>Inserts an ActiveX component.</td>
<td>D/C</td>
<td>Drawing</td>
</tr>
<tr>
<td>Insert &gt; Page</td>
<td>ALT &gt; I &gt; E</td>
<td>Creates a Page.</td>
<td>D</td>
<td>Page</td>
</tr>
</tbody>
</table>

- **Insert > Object**

  In the Diagram view, click **Insert > Object** to open the **Insert Objects** dialog box. In the **Object Types** tab, select the required Structure and navigate and select the required object. Click **Apply**. The selected object is inserted in the Function Diagram.
See Inserting/Creating Components on page 390.

- **Insert > Circle Port**
  In Component view, choose this command to insert a circle port. See also Inserting Ports on page 397.

- **Insert > Line Port**
  In Component view, choose this command to insert a line port. See also Inserting Ports on page 397.

- **Insert > Text**
  Choose this menu command to insert a text component. See Inserting Text Components on page 395.

- **Insert > Label**
  Choose this menu command to insert a label. See Inserting Label Components on page 395.

- **Insert > Graphic > Lines**
  Choose this menu command to insert a single line. See also Inserting a Line on page 394.

- **Insert > Graphic > Polyline**
  Choose this menu command to insert a polyline.

- **Insert > Graphic > Rectangle**
  Choose this menu command to insert a rectangle.

- **Insert > Graphic > Polygon**
  Choose this menu command to insert a polygon.

- **Insert > Graphic > Poly Curve**
  Choose this menu command to insert a polycurve.

- **Insert > Graphic > Closed Curve**
  Choose this menu command to insert a closed curve.
• **Insert > Graphic > Ellipse**
  Choose this menu command to insert an ellipse.

• **Insert > Picture**
  Choose this menu command to open a standard File Open dialog from which you can select an image in either .bmp, .wmf or .dib format. See also Inserting Pictures/Images on page 397.

• **Insert > ActiveX**
  Choose this menu command to insert an ActiveX control, or a Graphic Element built with Graphics Builder. See also Inserting ActiveX Controls on page 398.

• **Insert > Page**
  In Diagram view, choose this menu command to create a new page. The new page normally will be inserted behind the active page.
  If you choose this menu command when the 1st page is active, the system will ask you where you want to insert the new page:

![](image.png)

*Figure 185. New Page*

Click **Yes** or **No** according to the requirement.

See also Pages on page 486.
## Layout Menu

**Table 28. Description for Layout Menu Commands**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Layout &gt; Align &gt; Left</strong></td>
<td>ALT &gt; L &gt; A &gt; L</td>
<td>Aligns left.</td>
<td>D/C</td>
<td>Align</td>
</tr>
<tr>
<td><strong>Layout &gt; Align &gt; Center</strong></td>
<td>ALT &gt; L &gt; A &gt; C</td>
<td>Aligns centered.</td>
<td>D/C</td>
<td>Align</td>
</tr>
<tr>
<td><strong>Layout &gt; Align &gt; Right</strong></td>
<td>ALT &gt; L &gt; A &gt; R</td>
<td>Aligns right.</td>
<td>D/C</td>
<td>Align</td>
</tr>
<tr>
<td><strong>Layout &gt; Align &gt; Top</strong></td>
<td>ALT &gt; L &gt; A &gt; T</td>
<td>Aligns top.</td>
<td>D/C</td>
<td>Align</td>
</tr>
<tr>
<td><strong>Layout &gt; Align &gt; Middle</strong></td>
<td>ALT &gt; L &gt; A &gt; M</td>
<td>Aligns middle.</td>
<td>D/C</td>
<td>Align</td>
</tr>
<tr>
<td><strong>Layout &gt; Align &gt; Bottom</strong></td>
<td>ALT &gt; L &gt; A &gt; B</td>
<td>Aligns bottom.</td>
<td>D/C</td>
<td>Align</td>
</tr>
<tr>
<td><strong>Layout &gt; Space Evenly &gt; Across</strong></td>
<td>ALT &gt; L &gt; S &gt; A</td>
<td>Spaces components horizontally.</td>
<td>D/C</td>
<td>Layout</td>
</tr>
<tr>
<td><strong>Layout &gt; Space Evenly &gt; Down</strong></td>
<td>ALT &gt; L &gt; S &gt; D</td>
<td>Spaces components vertically.</td>
<td>D/C</td>
<td>Layout</td>
</tr>
<tr>
<td><strong>Layout &gt; Make Same Size &gt; Width</strong></td>
<td>ALT &gt; L &gt; M &gt; W</td>
<td>Makes components in the same width.</td>
<td>D/C</td>
<td>Layout</td>
</tr>
<tr>
<td><strong>Layout &gt; Make Same Size &gt; Height</strong></td>
<td>ALT &gt; L &gt; M &gt; H</td>
<td>Makes components in the same height.</td>
<td>D/C</td>
<td>Layout</td>
</tr>
<tr>
<td><strong>Layout &gt; Make Same Size &gt; Both</strong></td>
<td>ALT &gt; L &gt; M &gt; B</td>
<td>Makes components in the same size.</td>
<td>D/C</td>
<td>Layout</td>
</tr>
<tr>
<td><strong>Layout &gt; Rotate &gt; Free</strong></td>
<td>ALT &gt; L &gt; R &gt; F</td>
<td>Rotates components.</td>
<td>D/C</td>
<td>Rotate</td>
</tr>
<tr>
<td><strong>Layout &gt; Rotate &gt; Left</strong></td>
<td>ALT &gt; L &gt; R &gt; L</td>
<td>Rotates 90 degrees counter clockwise.</td>
<td>D/C</td>
<td>Rotate</td>
</tr>
<tr>
<td><strong>Layout &gt; Rotate &gt; Right</strong></td>
<td>ALT &gt; L &gt; R &gt; R</td>
<td>Rotates 90 degrees clockwise.</td>
<td>D/C</td>
<td>Rotate</td>
</tr>
<tr>
<td><strong>Layout &gt; Flip &gt; Horizontal</strong></td>
<td>ALT &gt; L &gt; F &gt; H</td>
<td>Flips around the horizontal center.</td>
<td>D/C</td>
<td>Rotate</td>
</tr>
<tr>
<td><strong>Layout &gt; Flip &gt; Vertical</strong></td>
<td>ALT &gt; L &gt; F &gt; V</td>
<td>Flips around the vertical center.</td>
<td>D/C</td>
<td>Rotate</td>
</tr>
</tbody>
</table>
### Table 28. Description for Layout Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout &gt; Order &gt; Bring to Front</td>
<td>ALT &gt; L &gt; O &gt; T</td>
<td>Brings to front.</td>
<td>D/C</td>
<td>Structure</td>
</tr>
<tr>
<td>Layout &gt; Order &gt; Send to Back</td>
<td>ALT &gt; L &gt; O &gt; K</td>
<td>Sends to back.</td>
<td>D/C</td>
<td>Structure</td>
</tr>
<tr>
<td>Layout &gt; Order &gt; Bring Forward</td>
<td>ALT &gt; L &gt; O &gt; F</td>
<td>Brings forward.</td>
<td>D/C</td>
<td>Structure</td>
</tr>
<tr>
<td>Layout &gt; Order &gt; Send Backward</td>
<td>ALT &gt; L &gt; O &gt; B</td>
<td>Sends backward.</td>
<td>D/C</td>
<td>Structure</td>
</tr>
<tr>
<td>Layout &gt; Group</td>
<td>ALT &gt; L &gt; G</td>
<td>Groups components.</td>
<td>D/C</td>
<td>Structure</td>
</tr>
<tr>
<td>Layout &gt; Ungroup</td>
<td>ALT &gt; L &gt; U</td>
<td>Ungroups components.</td>
<td>D/C</td>
<td>Structure</td>
</tr>
</tbody>
</table>

- **Layout > Align > Left**
  Choose this menu command to align vertically selected components to the left edge of the anchor component.

- **Layout > Align > Center**
  Choose this menu command to vertically align selected components to the center of the anchor component.

- **Layout > Align > Right**
  Choose this menu command to vertically align selected components to the right edge of the anchor component.

- **Layout > Align > Top**
  Choose this menu command to horizontally align selected components to the top of the anchor component.

- **Layout > Align > Middle**
  Choose this menu command to horizontally align selected components to the center of the anchor component.
• **Layout > Align > Bottom**
  Choose this menu command to horizontally align selected components to the bottom of the anchor component.

• **Layout > Space Evenly > Across**
  Choose this menu command to space selected components evenly between the left-most and right-most components selected.

• **Layout > Space Evenly > Down**
  Choose this menu command to space selected components evenly between the top-most and bottom-most components selected.

• **Layout > Make Same Size > Width**
  Choose this menu command to change the width of selected components to match the width of the anchor component.

• **Layout > Make Same Size > Height**
  Choose this menu command to change the height of selected components to match the height of the anchor component.

• **Layout > Make Same Size > Both**
  Choose this menu command to change the width and height of selected components to match the size of the anchor component.

• **Layout > Rotate > Free**
  Choose this menu command to set the canvas to rotate mode. Changes the cursor to a circular arrow when it is over a component, and allows you to grab a component and rotate it by mouse. See also Rotate on page 430.

• **Layout > Rotate > Left**
  Choose this menu command to rotate selected components by 90 degrees to the left. See also Rotate on page 430.

• **Layout > Rotate > Right**
  Choose this menu command to rotate selected components by 90 degrees to the right.
- **Layout > Flip > Horizontal**
  Choose this menu command to flip selected components 180 degrees around the X axis.

- **Layout > Flip > Vertical**
  Choose this menu command to flip selected components 180 degrees around the Y axis.

- **Layout > Order > Bring to Front**
  Choose this menu command to bring selected components to front so that they are not hidden by other components. See also Order on page 432.

- **Layout > Order > Send to Back**
  Choose this menu command to send the selected components back so that they can get hidden by other components in the foreground. See also Order on page 433.

- **Layout > Order > Bring Forward**
  Choose this menu command to bring selected component(s) one level forward. See also Order on page 433.

- **Layout > Order > Send Backward**
  Choose this menu command to send selected component(s) one level backward. See also Order on page 434.

- **Layout > Group**
  Choose this menu command to group selected components. All grouped components can now be manipulated as one component.

- **Layout > Ungroup**
  Choose this menu command to ungroup a group of components.

**Allocation Menu**

The Allocation menu is not available in Topology Designer.
Figure 186. Allocation Menu

Table 29. Description for Allocation Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocation &gt; Allocate Diagram</td>
<td>Ctrl + Q</td>
<td>This menu option calls the Allocatable Group aspect and allows the user to allocate the Function Diagram to the required application in Control builder M.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Allocation &gt; IO Allocation</td>
<td>ALT &gt; A &gt; I + I</td>
<td>Opens the IO Allocation tool in the context of the diagram.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Allocation &gt; Define Data Flow Order</td>
<td>ALT &gt; A &gt; F + D</td>
<td>Opens a dialog to define the data flow order.</td>
<td>D</td>
<td>Allocation</td>
</tr>
<tr>
<td>Allocation &gt; Show Allocation Details</td>
<td>ALT &gt; A &gt; S + L</td>
<td>Shows allocation group details like name, short name, data flow order, and color</td>
<td>D</td>
<td>Allocation</td>
</tr>
<tr>
<td>Allocation &gt; Advanced &gt; Allocation Grouping...*</td>
<td></td>
<td>This menu option groups the existing allocatable groups.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Allocation &gt; Advanced &gt; New Allocatable Group...*</td>
<td></td>
<td>This menu option is used to create a new allocatable group.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Allocation &gt; Advanced &gt; Delete Allocatable Group...*</td>
<td></td>
<td>This menu option is used to delete an existing allocatable group.</td>
<td>D</td>
<td></td>
</tr>
</tbody>
</table>

* This option is supported only in Function Diagrams restored to 800xA 5.1.
• **Allocation > Allocate Diagram**
  Choose this menu command to call the Allocatable Group aspect and to allocate the Function Diagram to the required application in Control builder M.

• **Allocation > IO Allocation**
  In Diagram view, choose this menu command to allocate signals given by the diagram.

• **Allocation > Define Data Flow Order**
  In Diagram view, choose this menu command to Define the Data Flow Order of the Function Diagram.

• **Allocation > Show Allocation Details**
  In Diagram view, choose this menu command to display allocation details at function components, e.g. data flow order, name, short name, and color of the allocatable group.

• **Allocation > Advanced > Allocation Grouping...**
  In Diagram view, choose this menu command to group the existing allocatable groups available in the Function Diagrams created prior to 800xA 5.1 and for diagrams restored to 800xA 5.1.

• **Allocation > Advanced > New Allocatable Group...**
  In Diagram view, choose this menu command to create a new allocatable group for Function Diagrams created prior to 800xA 5.1 and for diagrams restored to 800xA 5.1.

• **Allocation > Advanced > Delete Allocatable Group...**
  In Diagram view, choose this menu command to delete an existing allocatable group for Function Diagrams created prior to 800xA 5.1 and for diagrams restored to 800xA 5.1.
The following menu options are unavailable and appear dimmed for the newly created Function Diagrams using 800xA 5.1:

- Allocation grouping...
- New Allocatable Group...
- Delete Allocatable Group...

These menu options are available for Function Diagrams created prior to 800xA 5.1 and for diagrams restored to 800xA 5.1.

**Online Menu**

The Online Menu is not available in Topology Designer.

The online menu options are provided in Fig below:

![Online Menu](image)

*Figure 187. Online Menu*
Table 30. Description for Online Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online &gt; Add to Display List</td>
<td>ALT &gt; O &gt; A</td>
<td>F7 Add selected item (port, symbol, link) to display list.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Remove from Display List</td>
<td>ALT &gt; O &gt; R</td>
<td>Shift+F7 Remove selected item(s) (port, symbol, link) from display list.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Add Links to Current Page</td>
<td>ALT &gt; O &gt; P</td>
<td>ALT+F6 Add all links on current page to display list.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Add all Links to Display List</td>
<td>ALT &gt; O &gt; L</td>
<td>ALT+F7 Add all links on current page to display list.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Remove all from Display List</td>
<td>ALT &gt; O &gt; M</td>
<td>ALT+SHIFT+F7 Remove all links on current page from display list.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Watch Window</td>
<td>ALT &gt; O &gt; W</td>
<td>ALT+F8 Display the Watch window to check and set variable values.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Subscribe for Live Data</td>
<td>ALT &gt; O &gt; B</td>
<td>CTRL+F7 Start/Stop display of on-line values (live data)</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Subscribe For Live Data All Open Diagram</td>
<td>ALT &gt; O &gt; B</td>
<td>CTRL+ALT+F7 In Diagram view, choose this toggle menu command to start/stop display of on-line values for all open diagrams.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Show Last Value(s)</td>
<td>ALT &gt; O &gt; V</td>
<td>Show/Hide recent on-line values when subscription for live data has stopped.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Online &gt; Display in Hexadecimal Format</td>
<td>ALT &gt; O &gt; H</td>
<td>Show/Hide on-line values in hexadecimal format.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Online &gt; Force...</td>
<td>ALT &gt; O &gt; F</td>
<td>CTRL+F8 Opens the Force dialog to force applicable signals.</td>
<td>D</td>
<td>Online Menu</td>
</tr>
<tr>
<td>Online &gt; Subscribe for Live Data All Output Ports</td>
<td>ALT &gt; O &gt; S</td>
<td>F9 The Function Diagram subscribes for Online Data at the output pins.</td>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Online &gt; Subscribe for Live Data Connected Output Ports</td>
<td>ALT &gt; O &gt; U</td>
<td>F11 The Function Diagram subscribes for Online Data at the connected output pins.</td>
<td>D</td>
<td></td>
</tr>
</tbody>
</table>
• **Online > Add to Display List**
  
  In Diagram view, choose this menu command to display on-line values from an OPC server for the selected port(s), symbol(s), link(s). In effect, the selected item(s) are added to the display list which collects all OPC items to be displayed while **Subscribe for Live Data** is active.

  The command can be used while **Subscribe for Live Data** is inactive or active:
  
  – If inactive, no on-line values are retrieved from the OPC server, and added items just display a “*” indicating that they are prepared to display on-line values.
  
  – If active, on-line values are retrieved from the OPC server. In that case, added items display the on-line value retrieved.

• **Online > Remove from Display List**
  
  In Diagram view, choose this menu command to no longer display on-line values for the selected port, symbol, or link. In effect, the selected item(s) are removed from the display list.

• **Online > Add Links to Current Page**
  
  In Diagram view, choose this menu command to display on-line values for all links on the current page. In effect, all links on the current page are added to the display list.

• **Online > Add all Links to Display List**
  
  In Diagram view, choose this menu command to display on-line values for all links available in a Function Diagram. In effect, all links on all pages of the Function Diagram are added to the display list.

• **Online > Remove all from Display List**
  
  In Diagram view, choose this menu command to no longer display on-line values for all links on the current page.

• **Online > Watch Window**
  
  In Diagram view, choose this menu command to open the Watch window in order to
  
  – display and set on-line values in textual form in a list box.
– display and set on-line values for variables of structured data type.
– display and set on-line values from another function diagram
– display and set on-line values from an arbitrary aspect exposing OPC properties, e.g. a CBM application.

**Set on-line value** means that the OPC value is written once.

**Online > Subscribe for Live Data**

In Diagram view, choose this toggle menu command to start/stop display of on-line values collected in the diagram’s display list and/or collected in the Watch window.

– If checked, Subscribe for Live Data is active. i.e. on-line values are retrieved from the OPC server and displayed in the diagram or in the Watch window.

– If unchecked, Subscribe for Live Data is inactive. i.e. no on-line values are retrieved from the OPC server. According to the setting ‘**Show Last Value(s)**’, the OPC items in the diagram display a ‘*’ or the recent value retrieved, and the OPC items in the Watch window display an empty value or the recent value retrieved.

**Online > Subscribe For Live Data All Open Diagram**

In Diagram view, choose this toggle menu command to start/stop display of on-line values collected in the diagram’s display list and/or collected in the Watch window for all open diagrams.

– If checked, Subscribe for Live Data for all open diagrams is active. I.e. on-line values are retrieved from the OPC server and displayed in the diagram or in the Watch window.

– If unchecked, Subscribe for Live Data for all open diagrams is inactive. No on-line values are retrieved from the OPC server. According to the setting ‘**Show Last Value(s)**’, the OPC items in the diagram display a ‘*’ or the recent value retrieved, and the OPC items in the Watch window display an empty value or the recent value retrieved.
• **Online > Show Last Value(s)**

   In Diagram view, choose this toggle menu command to show or hide recent online values when subscription for live data has stopped.
   
   – If checked, recent values retrieved from the OPC server are still displayed in the diagram and/or in the Watch window.
   
   – If unchecked, the OPC items in the diagram display a ‘*’, and the OPC items in the Watch window display an empty value.

• **Online > Display in Hexadecimal Format**

   This menu command displays the online values in hexadecimal format.

• **Online > Force...**

   This dialog allows to force the Value (datatype RealIO, BoolIO) of an allocated input IO signal (object type CBM_AIS, CBM_DIS) or the IOValue (datatype RealIO, BoolIO) of an allocated input IO signal (object type CBM_AOS, CBM_DOS).

• **Online > Subscribe for Live Data All Output Ports**

   The command adds labels to display live values for all the pages of function diagram and subscribes live data for the current page. The shortcut key for this menu option is F9.
   
   – If selected, Subscribe for Live Data All Output Ports is active. i.e. on-line values are retrieved from the OPC server and displayed on the output pins of the current page.
   
   – If unchecked, Subscribe for Live Data All Output Ports is inactive. i.e. no on-line values are retrieved from the OPC server.

• **Online > Subscribe for Live Data Connected Output Ports**

   The command adds labels to display live values for the connected output ports and subscribes live data for the current page. The shortcut key for this menu option is F11.
   
   – If selected, Subscribe for Live Data Connected Output Ports is active. i.e. on-line values are retrieved from the OPC server and displayed on the output pins of the current page.
– If unchecked, Subscribe for Live Data Connected Output Ports is inactive. i.e. no on-line values are retrieved from the OPC server.

**Window Menu**

*Table 31. Description for Window Menu Commands*

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>D/C</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window &gt; Workbook Mode</td>
<td>ALT &gt; W &gt; W</td>
<td>Turns on or off the workbook mode (display with tabs), see Window &gt; Workbook Mode</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Window &gt; New Window</td>
<td>ALT &gt; W &gt; N</td>
<td>Opens a new document window of an already open designer component or designer diagram. You can display different areas or different pages of a diagram at the same time.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Window &gt; Cascade</td>
<td>ALT &gt; W &gt; C</td>
<td>Arranges windows cascading.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Window &gt; Tile</td>
<td>ALT &gt; W &gt; T</td>
<td>Arranges windows tiled.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Window &gt; Arrange Icons</td>
<td>ALT &gt; W &gt; A</td>
<td>Arranges icons of minimized windows.</td>
<td>D/C</td>
<td></td>
</tr>
<tr>
<td>Window &gt; Close All</td>
<td>ALT &gt; W &gt; I</td>
<td>Close all open windows.</td>
<td>D/C</td>
<td></td>
</tr>
</tbody>
</table>

**Window > Workbook Mode**

Choose this menu command to display open windows in workbook mode. In workbook mode, MS-Excel sheet-like tabs are displayed at the bottom of the main window in order to navigate to the component/diagram document of interest by a single mouse click.
Figure 188. Windows Arranged in Workbook Mode

Help Menu

Table 32. Description for Help Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help &gt; Contents</td>
<td>ALT &gt; H &gt;C</td>
<td>Display on-line help contents, index, search page, and favorites.</td>
<td>Standard</td>
</tr>
<tr>
<td>Help &gt; About</td>
<td>ALT &gt; H &gt;A</td>
<td>Display program information, version number and copyright.</td>
<td>Standard</td>
</tr>
</tbody>
</table>

- **Help > Contents**
  Choose this menu command to display the contents of designer’s on-line help.

- **Help > Reference Manual**
  Choose this menu command to display this designer reference manual via Adobe Acrobat Reader.
• **Help > About**

Choose this menu command to display product version and copyright information. Depending on the view (Diagram/Component view), the corresponding About dialog is displayed.

### Context Menus

On right-click of mouse, context menus are opened according to the selected object/area in designer.

• The context menu of a designer component (right-click on a component) offers related menu options such as Cut, Copy, Paste, Order, and other aspects and verbs of the corresponding Aspect Object. By that the user can quickly navigate to other aspects of each component from within the designer diagram.

• The diagram’s context menu (right-click on the empty diagram background) offers designer menus like Paste, Grid, Zoom, and other aspects and verbs of the corresponding diagram Aspect Object. User can quickly navigate to other aspects of the diagram.

• The diagram’s context menu (right-click on the empty diagram background) offers a **Diagram Viewer** option to view the Diagram from the Control Builder editor mode.

• The following options are available as context menus:
  – Allocate/UnAllocate Diagram
  – Define Data Flow Order
  – Generate Configuration Data
  – Generate Configuration Data (Full Build)
  – I/O Allocation

Most context menus are dynamic and the menu items are displayed according to the selected object.

The aspect categories are grouped and a submenu with all related instances is created.
User will find the following object-specific context menus:

- Designer Aspect Context Menu
- Diagram/Component Document Context Menu
- Designer Component Context Menu
- Graphic Component Context Menu
- Dockable Window Context Menu
- Horizontal Scrollbar Context Menu
- Output Window Context Menu
- Toolbar Context Menu
- Vertical Scrollbar Context Menu

**Designer Aspect Context Menu**

The designer aspect supports three views, see Diagram/Component View on page 288:

- Diagram
- Component
- Parent Diagram

The Function aspect supports the additional aspect verbs:

- Generate Configuration Data.
- Generate Configuration Data (Full Build)
- Synchronize Names.
- Upload Control Properties
- XML Type Description (on object types only).

Only the relevant menu items appear in the context menu.
Right-click a designer aspect to open the context menu:

![Context Menu of Designer Aspect]

**Figure 189. Context Menu of Designer Aspect**

A corresponding context menu can be opened on the Allocatable Group aspect. The actual menu items are described in **Table 33:**

**Table 33. Designer Aspect / Allocatable Group Aspect Context Menu Commands**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Config View</td>
<td>On Allocatable Group aspect only: Opens Allocatable Group dialog.</td>
</tr>
<tr>
<td>Diagram</td>
<td>(1)On Designer aspect only: Opens a new overlap window and displays the designer diagram view of the current selected diagram aspect object, see Diagram/Component View on page 288.</td>
</tr>
<tr>
<td>Component</td>
<td>1) Opens a new overlap window and displays the designer component view of the current selected component aspect object, see Diagram/Component View on page 288.</td>
</tr>
<tr>
<td>Parent Diagram</td>
<td>1) Opens a new overlap window, displays the designer diagram view of the parent diagram of the current selected component aspect object, and navigates to the selected component, see Diagram/Component View on page 288.</td>
</tr>
<tr>
<td>New Aspect</td>
<td>1) Opens the dialog for creating a new aspect of an Aspect Object.</td>
</tr>
</tbody>
</table>
Table 33. Designer Aspect / Allocatable Group Aspect Context Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Cuts the selected aspect and places it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected aspect to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes the cut/copied aspect to the aspect list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected aspect.</td>
</tr>
<tr>
<td>Rename</td>
<td>Allows to rename the selected aspect.</td>
</tr>
<tr>
<td>Override</td>
<td>If the aspect is inherited, this operation makes a local copy of the aspect.</td>
</tr>
<tr>
<td>Generate Configuration Data (Not available in Topology Designer)</td>
<td>Generate the configuration data for the diagram and all child (nested) diagrams. The command generates only diagrams in modified state (red traffic light indicator in the status bar).</td>
</tr>
<tr>
<td>Clear Configuration Data</td>
<td>Clears the generated configuration data for the Function Diagram or Allocatable Group in CBM.</td>
</tr>
<tr>
<td>Synchronize Names (Not available in Topology Designer)</td>
<td>1) Synchronizes/maps the .:Name.Name to • .:Control Builder Name.Name. • Name parameter of control modules</td>
</tr>
<tr>
<td>Upload Control Properties (Init_Vals) (Not available in Topology Designer)</td>
<td>Uploads initial values from the Control Properties.</td>
</tr>
<tr>
<td>Upload Control Properties(Par_Cons) (Not available in Topology Designer)</td>
<td>Uploads connection parameters from the Control Properties.</td>
</tr>
<tr>
<td>This menu command is visible only to the users belongs to the Software Developers User Group.</td>
<td>Uploads connection parameters from the Control Properties.</td>
</tr>
</tbody>
</table>
### Table 33. Designer Aspect / Allocatable Group Aspect Context Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aspect Object (Not available in Topology Designer)</td>
<td>On components only: Converts the Aspect Object to a Symbol Object. This command is also available on the Function Diagram Variable aspect: It switches all connected diagram references (sources and sinks) from Aspect Object to Symbol Object. In both cases the aspect command is also supported via Bulk Data Manager. <strong>Note:</strong> Always keep Diagram References and their Diagram Variables as symbol object only.</td>
</tr>
<tr>
<td>References</td>
<td>If the Aspect Object has cross-references, for example the Aspect Object could be included in a graphic display, the display's name is shown when you select this item</td>
</tr>
<tr>
<td>Show System Status Viewer</td>
<td>Displays the system status for the diagram.</td>
</tr>
<tr>
<td>Add To Aspect Menu...</td>
<td>Add the selected diagram to Aspect Favorites.</td>
</tr>
<tr>
<td>Reserve</td>
<td>Allows to reserve the diagram.</td>
</tr>
<tr>
<td>Release</td>
<td>Allows to reserve the diagram.</td>
</tr>
<tr>
<td>Manage</td>
<td>Allows to View (Reserve, Release), Deploy and Update the Function Diagram.</td>
</tr>
<tr>
<td>Details</td>
<td>Opens the designer aspect’s Details dialog. The dialog consists of the following pages: Identification, Property View, Name Tool, Names &amp; Paths, Permission, Lock Status, References.</td>
</tr>
</tbody>
</table>

### Diagram/Component Document Context Menu

In Component view or Diagram view, right-click any free area in a document window to open the following context menu:
Figure 190. Diagram/Component Document Context Menu

The menu items are described in Table 34:

Table 34. Diagram/Component Document Context Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Aspect or &lt;Aspect&gt;</td>
<td>If this menu item appears as Default Aspect (disabled), it indicates that no Default Aspect is defined for the current selected Aspect Object. If this menu item appears as &lt;Aspect&gt; (for example, Function, Name, and so on), it navigates directly to the default &lt;Aspect&gt;-specific view.</td>
</tr>
<tr>
<td>Cut</td>
<td>Cuts the Diagram/Component document and copies to the Clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the Diagram/Component document to the Clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Equals menu command Edit &gt; Paste.</td>
</tr>
</tbody>
</table>
Table 34. Diagram/Component Document Context Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste with Multiple Invocation Invocation</td>
<td>Equals menu command <strong>Edit &gt; Paste with Multiple Invocation.</strong></td>
</tr>
<tr>
<td>Routing Page &gt; Freeze Routing</td>
<td>Enables auto routing capability of all link components on the current page.</td>
</tr>
<tr>
<td>Routing Page &gt; Unfreeze Routing</td>
<td>Enables auto routing capability of all link components on the current page.</td>
</tr>
<tr>
<td>Routing Page &gt; Reroute</td>
<td>Enables auto routing capability of all link components on the current page and all the link components of the current page get rerouted.</td>
</tr>
<tr>
<td>Routing Diagram &gt; Freeze Routing</td>
<td>Enables auto routing capability of all link components of the diagram.</td>
</tr>
<tr>
<td>Routing Diagram &gt; Unfreeze Routing</td>
<td>Enables auto routing capability of all link components of the diagram.</td>
</tr>
<tr>
<td>Grid</td>
<td>Equals menu command <strong>View &gt; Grid.</strong></td>
</tr>
<tr>
<td>Snap to Grid</td>
<td>Equals menu command <strong>View &gt; Snap to Grid.</strong></td>
</tr>
<tr>
<td>Angle Snap</td>
<td></td>
</tr>
<tr>
<td>Grid Properties</td>
<td>Equals menu command <strong>View &gt; Grid Properties.</strong></td>
</tr>
<tr>
<td>Zoom &gt; 50%</td>
<td>Equals menu command <strong>View &gt; Zoom Percent &gt; 50%.</strong></td>
</tr>
<tr>
<td>Zoom &gt; 75%</td>
<td>Equals menu command <strong>View &gt; Zoom Percent &gt; 75%.</strong></td>
</tr>
<tr>
<td>Zoom &gt; 100%</td>
<td>Equals menu command <strong>View &gt; Zoom Percent &gt; 100%.</strong></td>
</tr>
<tr>
<td>Zoom &gt; 200%</td>
<td>Equals menu command <strong>View &gt; Zoom Percent &gt; 200%.</strong></td>
</tr>
<tr>
<td>Zoom &gt; Zoom to Fit</td>
<td>Equals menu command <strong>View &gt; Zoom to Fit.</strong></td>
</tr>
<tr>
<td>Aspect Properties</td>
<td>Equals menu command <strong>Edit &gt; Aspect Properties.</strong></td>
</tr>
<tr>
<td>Ambient Properties</td>
<td>Equals menu command <strong>Edit &gt; Ambient Properties.</strong></td>
</tr>
<tr>
<td>Default Properties</td>
<td>Equals menu command <strong>Edit &gt; Default Properties.</strong></td>
</tr>
<tr>
<td>Measurements and Size</td>
<td>Equals menu command <strong>Edit &gt; Measurements and Size.</strong></td>
</tr>
<tr>
<td>Options(1)</td>
<td>Equals menu command <strong>Edit &gt; Options.</strong></td>
</tr>
<tr>
<td>&lt;Aspect&gt;</td>
<td>Navigates to the corresponding &lt;Aspect&gt; of the current Aspect Object.</td>
</tr>
</tbody>
</table>
Table 34. Diagram/Component Document Context Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>References</td>
<td>If the Aspect Object has cross-references, for example the Aspect Object could be included in a graphic display, the display's name is shown when you select this item</td>
</tr>
<tr>
<td>Advanced</td>
<td>Engineering Workplace only: Open Engineering Workplace Advanced menu with some useful commands for I/O Allocation, Bulk Data Manager, Document Manager, and Structure operations.</td>
</tr>
<tr>
<td>Details</td>
<td>Opens the Details dialog of the selected aspect object.</td>
</tr>
</tbody>
</table>

(1) All menu items from here on are part of the dynamic System 800xA Aspect Object menu.
Designer Component Context Menu

Right-click a designer component to open the following context menu:

Figure 191. Designer Component Context Menu
The menu items are described in Table 35:

**Table 35. Designer Component Context Menu Commands**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Aspect or &lt;Aspect&gt;</td>
<td>If this menu item appears as Default Aspect (disabled), it indicates that no Default Aspect is defined for the current selected Aspect Object. If this menu item appears as &lt;Aspect&gt; (for example, <em>Function</em>, <em>Name</em>, and so on), it navigates directly to the default &lt;Aspect&gt;-specific view.</td>
</tr>
<tr>
<td>Cut</td>
<td>Equals menu command <em>Edit &gt; Cut</em>.</td>
</tr>
<tr>
<td>Copy</td>
<td>Equals menu command <em>Edit &gt; Copy</em>.</td>
</tr>
<tr>
<td>Paste</td>
<td>Equals menu command <em>Edit &gt; Paste</em>.</td>
</tr>
<tr>
<td>Delete</td>
<td>Equals menu command <em>Edit &gt; Delete</em>.</td>
</tr>
<tr>
<td>Order &gt; Bring Forward</td>
<td>Equals menu command <em>Layout &gt; Order &gt; Bring Forward</em>.</td>
</tr>
<tr>
<td>Order &gt; Bring to Front</td>
<td>Equals menu command <em>Layout &gt; Order &gt; Bring to Front</em>.</td>
</tr>
<tr>
<td>Order &gt; Send Backward</td>
<td>Equals menu command <em>Layout &gt; Order &gt; Send Backward</em>.</td>
</tr>
<tr>
<td>Order &gt; Send to Back</td>
<td>Equals menu command <em>Layout &gt; Order &gt; Send to Back</em>.</td>
</tr>
<tr>
<td>Grouping &gt; Group</td>
<td>Equals menu command <em>Layout &gt; Group</em>.</td>
</tr>
<tr>
<td>Grouping &gt; Ungroup</td>
<td>Equals menu command <em>Layout &gt; Ungroup</em>.</td>
</tr>
<tr>
<td>Add to Display List</td>
<td>Equals menu command <em>Online &gt; Add to Display List</em>.</td>
</tr>
<tr>
<td>Remove From Display List</td>
<td>Equals menu command <em>Online &gt; Remove from Display List</em>.</td>
</tr>
<tr>
<td>Allocation Grouping</td>
<td>Equals menu command Allocation &gt; Allocation Grouping.</td>
</tr>
<tr>
<td>Aspect Properties</td>
<td>Equals menu command <em>Edit &gt; Aspect Properties</em>.</td>
</tr>
<tr>
<td>Component Properties</td>
<td>Equals menu command <em>Edit &gt; Default Properties</em>.</td>
</tr>
<tr>
<td>Aspect Object</td>
<td>Toggles instance kind aspect object &lt;-&gt; symbol object.</td>
</tr>
</tbody>
</table>
Table 35. Designer Component Context Menu Commands  (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
</table>
| Show Hidden Ports  
(Not available in Topology Designer) | This menu item is enabled only for components with hidden ports. |
| Number of Inputs  
(Not available in Topology Designer) | This menu item is enabled only for components with variable (extensible) number of parameters. |
| Change Type  
(Not available in Topology Designer) | This menu item is enabled only for symbol objects, not for aspect objects. |
| Variable Properties  
(Not available in Topology Designer) | This menu item is enabled only for variables, diagram references, and diagram parameters. |
| Connection Mapping  
(Not available in Topology Designer) | Displays the Connection Mapping dialog in order to map connections between different structured data types. |
| Goto Child Diagram | Equals menu command View > Goto Child Diagram. |
| Goto Reference | Opens the dialog to select and navigate to an off-diagram reference on another diagram. |
| Connect To Diagram Variable | Opens the dialog to define a connection to an off-diagram reference on another diagram. |
| Disconnect from Diagram Variable | Opens the dialog to remove a connection to an off-diagram reference on another diagram. |
| Number of Diagram References | Opens the Number of Diagram References dialog to define the maximum number of diagram references displayed in one column. This menu item is enabled only for diagram references. |
| Show Type (1) | Navigates to the object type in Object Type Structure |
| <Aspect> | Opens the <Aspect> dialog for the current Aspect Object. |
| References | If the Aspect Object has cross-references, for example the Aspect Object could be included in a graphic display, the display’s name is shown when you select this item |
Table 35. Designer Component Context Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced</td>
<td>Engineering Workplace only: Open Engineering Workplace Advanced menu with some useful commands for I/O Allocation, Bulk Data Manager, Document Manager, and Structure operations.</td>
</tr>
<tr>
<td>Properties</td>
<td>Opens the Properties dialog for the selected aspect object, if any.</td>
</tr>
</tbody>
</table>

(1) All menu items from here on are part of the dynamic System 800xA Aspect Object menu.

**Graphic Component Context Menu**

Right mouse click on a graphic component (e.g. a primitive) to open the following context menu:

![Context Menu](image)

The menu items are described in Table 36.

**Link Component Context Menu**

Note: Not available in Topology Designer.
Right-click a link component that connects two symbol ports to access the following context menu:

![Context Menu Table]

The menu items are described in Table 36.

**Symbol Port Context Menu**

Note: Not available in Topology Designer.

Right-click a symbol port to access the following context menu:

![Symbol Port Context Menu Table]
The menu items are described in Table 36:

**Table 36. Graphic Component, Link, Port Context Menu Commands**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Equals menu command <strong>Edit &gt; Cut.</strong></td>
</tr>
<tr>
<td>Copy</td>
<td>Equals menu command <strong>Edit &gt; Copy.</strong></td>
</tr>
<tr>
<td>Paste</td>
<td>Equals menu command <strong>Edit &gt; Paste.</strong></td>
</tr>
<tr>
<td>Delete</td>
<td>Equals menu command <strong>Edit &gt; Delete.</strong></td>
</tr>
<tr>
<td>Routing &gt; Freeze Routing</td>
<td>Disables auto routing capability of link component.</td>
</tr>
<tr>
<td>Routing &gt; Unfreeze Routing</td>
<td>Enables auto routing capability of link component.</td>
</tr>
<tr>
<td>Routing &gt; Reroute</td>
<td>Enables auto routing capability of link component and the link component gets rerouted.</td>
</tr>
<tr>
<td>Order &gt; Bring Forward</td>
<td>Equals menu command <strong>Layout &gt; Order &gt; Bring Forward.</strong></td>
</tr>
<tr>
<td>Order &gt; Bring to Front</td>
<td>Equals menu command <strong>Layout &gt; Order &gt; Bring to Front.</strong></td>
</tr>
<tr>
<td>Order &gt; Send Backward</td>
<td>Equals menu command <strong>Layout &gt; Order &gt; Send Backward.</strong></td>
</tr>
<tr>
<td>Order &gt; Send to Back</td>
<td>Equals menu command <strong>Layout &gt; Order &gt; Send to Back.</strong></td>
</tr>
<tr>
<td>Grouping &gt; Group</td>
<td>Equals menu command <strong>Layout &gt; Group.</strong></td>
</tr>
<tr>
<td>Grouping &gt; Ungroup</td>
<td>Equals menu command <strong>Layout &gt; Ungroup.</strong></td>
</tr>
<tr>
<td>Add To Display List (Not available in Topology Designer)</td>
<td>Equals menu command <strong>Online &gt; Add to Display List.</strong> (Links and ports only).</td>
</tr>
<tr>
<td>Remove from Display List</td>
<td>Equals menu command <strong>Online &gt; Remove from Display List.</strong> (Links and ports only).</td>
</tr>
<tr>
<td>Variable Name (Not available in Topology Designer)</td>
<td>Opens the dialog Variable Name in order to check the mapped and generated variable name (Links only).</td>
</tr>
<tr>
<td>Connection Mapping (Not available in Topology Designer)</td>
<td>Opens the Connection Mapping dialog in order to map connections between structured data types.</td>
</tr>
</tbody>
</table>
Table 36. Graphic Component, Link, Port Context Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component Properties</td>
<td>Equals menu command Edit &gt; Default Properties.</td>
</tr>
<tr>
<td>Hide Port(s)</td>
<td>Hides the selected port(s)</td>
</tr>
<tr>
<td>(Not available in Topology Designer)</td>
<td></td>
</tr>
<tr>
<td>Aspect Properties</td>
<td>Equals menu command Edit &gt; Aspect Properties (Ports only).</td>
</tr>
<tr>
<td>New Action</td>
<td>Adds new action to a step of a SPL diagram.</td>
</tr>
</tbody>
</table>

**Toolbar Context Menu**

Right-click the Menu/Toolbar area to access the following context menu:
The menu items are described in Table 37:

**Table 37. Toolbar Context Menu Commands**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Window</td>
<td>Show/Hide the Output Window as either a docked window or as a floating popup window. The Output Window lists results from the File &gt; Check and File &gt; Generate Configuration Data (Full Build) commands.</td>
</tr>
<tr>
<td>Structure Browser 1</td>
<td>Show/Hide the Structure Browser 1 Window as either a docked window or as a floating popup window. The Structure Browser Window can be used as an alternative to Plant Explorer’s object browser window.</td>
</tr>
<tr>
<td>Structure Browser 2</td>
<td>Show/Hide the Structure Browser 2 Window as either a docked window or as a floating popup window. The Structure Browser Window can be used as an alternative to Plant Explorer’s object browser window.</td>
</tr>
<tr>
<td>SFC Overview</td>
<td>Click SFC Overview to access the details of all sequences and sequence components (steps, transition, and action) that are available in a Function Diagram. In case of nested diagrams, open the relevant function Diagram to navigate using the sequence tree structure.</td>
</tr>
<tr>
<td>Watch Window</td>
<td>Show/Hide the Watch Window as either a docked window or as a floating popup window. The Watch Window displays and sets on-line values from any OPC server</td>
</tr>
<tr>
<td>Standard</td>
<td>Show/Hide the Standard toolbar with commands New, Open, Save, Print...</td>
</tr>
<tr>
<td>Drawing</td>
<td>Show/Hide the Drawing toolbar with commands Select, Line, Rectangle, Port, Text, Label...</td>
</tr>
<tr>
<td>View</td>
<td>Show/Hide the View toolbar with commands Layer, Zoom, Pan, Grid.</td>
</tr>
<tr>
<td>Page</td>
<td>Show/Hide the Page toolbar with commands New Page, Delete Page, Goto Page.</td>
</tr>
<tr>
<td>Align</td>
<td>Show/Hide the Align toolbar with commands Align Top, Middle, Left...</td>
</tr>
<tr>
<td>Nudge</td>
<td>Show/Hide the Nudge toolbar with commands Nudge Up, Down, Left, Right.</td>
</tr>
<tr>
<td>Rotate</td>
<td>Show/Hide the Rotate toolbar with commands Rotate and Flip.</td>
</tr>
<tr>
<td>Structure</td>
<td>Show/Hide the Structure toolbar with commands Group, Ungroup, Bring to Front, Send to Back.</td>
</tr>
<tr>
<td>Layout</td>
<td>Show/Hide the Layout toolbar with commands Space Across, Same Width...</td>
</tr>
<tr>
<td>Selection</td>
<td>Show/Hide the Selection toolbar with commands for multi selection and network/symbol traversal.</td>
</tr>
<tr>
<td>Allocation (Not available in Topology Designer)</td>
<td>Show/Hide the Allocation Menu toolbar. with commands Select/Create/Delete Allocatable Group, Define Data Flow Order.</td>
</tr>
</tbody>
</table>
Table 37. Toolbar Context Menu Commands (Continued)

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online</td>
<td>Show/Hide the <strong>Online Menu</strong> toolbar with commands to Add links / Remove links etc.</td>
</tr>
<tr>
<td>Connection</td>
<td>Show/Hide the <strong>Connection</strong> toolbar with commands Connect, Disconnect, Invert.</td>
</tr>
<tr>
<td>Sequence</td>
<td>Show/Hide the <strong>Sequence</strong> toolbar with commands: Insert Transition, Insert Step, Insert Jump, Create Multiple Transitions / Steps, Renumber, Enables and disables execution of the actions associated with the step, Forces next step to become active, Forces previous step to become active.</td>
</tr>
</tbody>
</table>

**Vertical Scrollbar Context Menu**

Right-click a vertical scroll bar to access the following context menu:

![Vertical Scrollbar Context Menu](image)

The menu items are described in Table 38.

Table 38. Vertical Scrollbar Context Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll Here</td>
<td>Moves the scroll bar to the current cursor location.</td>
</tr>
<tr>
<td>Top</td>
<td>Moves the scroll bar to the top.</td>
</tr>
<tr>
<td>Bottom</td>
<td>Moves the scroll bar to the bottom.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Moves the scroll bar one page division up. Same as click above the scroll bar.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Moves the scroll bar one page division down. Same as click below of scroll bar.</td>
</tr>
<tr>
<td>Scroll Up</td>
<td>Moves the scroll bar one division up. Same as click on up arrow.</td>
</tr>
<tr>
<td>Scroll Down</td>
<td>Moves the scroll bar one division down. Same as click on down arrow.</td>
</tr>
</tbody>
</table>
Horizontal Scrollbar Context Menu

Right-click right a horizontal scroll bar to access the following context menu:

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll Here</td>
<td>Moves the scroll bar to the current cursor location.</td>
</tr>
<tr>
<td>Left Edge</td>
<td>Moves the scroll bar to the left edge.</td>
</tr>
<tr>
<td>Right Edge</td>
<td>Moves the scroll bar to the right edge.</td>
</tr>
<tr>
<td>Page Left</td>
<td>Moves the scroll bar one page division left. Same as click left of scroll bar.</td>
</tr>
<tr>
<td>Page Right</td>
<td>Moves the scroll bar one page division right. Same as click right of scroll bar.</td>
</tr>
<tr>
<td>Scroll Left</td>
<td>Moves the scroll bar one division left. Same as click on left arrow.</td>
</tr>
<tr>
<td>Scroll Right</td>
<td>Moves the scroll bar one division right. Same as click on right arrow.</td>
</tr>
</tbody>
</table>

Output Window Context Menu

Right-click the Output Window’s Output or Build page to access the following context menu:
The menu items are described in Table 40.

Table 40. Output Window Context Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Equals menu command <strong>Edit &gt; Undo.</strong></td>
</tr>
<tr>
<td>Cut</td>
<td>Equals menu command <strong>Edit &gt; Cut.</strong></td>
</tr>
<tr>
<td>Copy</td>
<td>Equals menu command <strong>Edit &gt; Copy.</strong></td>
</tr>
<tr>
<td>Paste</td>
<td>Equals menu command <strong>Edit &gt; Paste.</strong></td>
</tr>
<tr>
<td>Delete</td>
<td>Equals menu command <strong>Edit &gt; Delete.</strong></td>
</tr>
<tr>
<td>Select All</td>
<td>Equals menu command <strong>Edit &gt; Select All.</strong></td>
</tr>
</tbody>
</table>

Dockable Window Context Menu

Right-click a Structure Browser’s or Output Window’s border/tab to access the following context menu:

- **Allow Docking**
- **Hide**
- **Clear Window**

The menu items are described in Table 41:

Table 41. Dockable Window Context Menu Commands

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Docking</td>
<td>Allows docking of the window/toolbar within the main window.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides the window/toolbar,</td>
</tr>
<tr>
<td>Clear Window</td>
<td>Clear the window contents (only available for some dockable windows, for example the Output window)</td>
</tr>
</tbody>
</table>

Working with Toolbars

User can get access to different useful commands by clicking the appropriate button using the Toolbar Categories. These commands are mostly accessible through an
appropriate menu command, too. Use the Customize dialog to turn on or off the display of toolbars, or to create user-defined toolbars.

User can have different toolbar settings in the Diagram view and the Component view, in the preview window and overlap (separate) window.

Customize

Use the Customize dialog for:

- Showing/Hiding Toolbars
- Creating a User-Defined Toolbar
- Adding Tool Buttons to Toolbars
- Deleting a User-Defined Toolbar
- Changing the Look of Toolbars
- Showing Tooltips

Open this dialog through the menu command View > Toolbar > Customize. The dialog contains the following two pages:

- Toolbars
- Toolbar Commands
Toolbars

Click the Toolbars tab of the Customize dialog to display the Toolbars page.

![Customize Dialog: Toolbars Page](image)

**Figure 192. Customize Dialog: Toolbars Page**

The Toolbars page of the Customize dialog contains the following fields, buttons, and other items:

- **Toolbars (tab)**

  Click the Toolbars tab to display the Toolbars page with all available toolbars.

  For more details, refer to Working with Toolbars on page 357.
- **Toolbars**

  In the Toolbars list box, all available toolbars are listed. You can select multiple toolbars to display them in the application’s main window.

  Select or clear the appropriate check boxes (except the Menu bar which is protected against un-marking) to turn on or off the display. See also Toolbar Categories on page 363 and Showing/Hiding Toolbars on page 381.

- **Toolbar name.**

  The Toolbar name field displays the name of the toolbar selected in the Toolbars list box. If a user-defined toolbar is selected, the name can be changed here. See also Renaming a User-Defined Toolbar on page 385.

- **Show Tooltips**

  Select or clear this check box to turn on or off the display of the tooltips. The tooltips are short context-sensitive description texts displayed in small popup boxes with a yellow background if you point to a button of a toolbar. See also Showing Tooltips on page 386.

- **Cool Look**

  Select or clear this check box to turn on or off the display of the tool buttons in the Cool Look manner. See also Changing the Look of Toolbars on page 386.

- **Large Buttons**

  Select or clear this check box to turn on or off the display of large buttons. See also Changing the Look of Toolbars on page 386.

- **New**

  Click this button to open the New Toolbar dialog for creating a new user-defined toolbar. See also Creating a User-Defined Toolbar on page 383.
Figure 193. New Toolbar Dialog

- **Reset**
  
  Click this button to reset the layout of the current selected system toolbar to the original state. See also Adding Tool Buttons to Toolbars on page 383.

- **Delete**
  
  Click this button to delete the current selected user-defined toolbar. See also Deleting a User-Defined Toolbar on page 385.
Toolbar Commands

Click on the Toolbar Commands tab of the Customize dialog to display the Toolbar Commands page.

Figure 194. Customize Dialog, Toolbar Commands Page
The **Toolbar Commands** property sheet of the Customize dialog contains the following fields, buttons, and other items:

- **Toolbar Commands**
  Click this tab to display the **Toolbar Commands** page for getting access to the tool buttons (commands) in the **Buttons** area. From here, you can copy tool buttons to each existing toolbar. See also Adding Tool Buttons to Toolbars on page 383.

- **Categories**
  Displays all available **Toolbar Categories** delivered with the Function Designer. Select the wanted toolbar to display the buttons belonging to it. See also Adding Tool Buttons to Toolbars on page 383.

- **Buttons**
  Displays the tool buttons of the currently selected toolbar.

- **Description**
  Displays the description of the currently selected tool button.

### Toolbar Categories

The designer offers the following toolbars (toolbar categories):

- **Standard**
  The **Standard** toolbar contains commands for handling the whole diagram like saving and printing, and it contains commands for handling components like copying and saving. You will find the most commands also as menu commands of the **File** and **Edit** menu.

- **Drawing**
  The **Drawing** toolbar contains commands for inserting graphic objects (primitives, symbols, and so on) and their handling within the diagram (e.g. snapping to grid). You will find the most commands also as menu commands of the **Insert** and **View** menu.
• **View**

The View toolbar contains commands for the layer handling and for zooming the diagram’s/component’s display. You will find the most commands also as menu commands of the View menu.

• **Page**

The Page toolbar contains commands for creating pages and for navigation between pages. You will find the command for creating a page also as menu command in the Insert menu.

• **Align**

The Align toolbar contains commands for aligning components within the diagram. You will find the commands also as menu commands of the Layout menu.

• **Nudge**

The Nudge toolbar contains commands for nudging components within the diagram. You will not find the commands also as menu commands.

• **Rotate**

The Rotate toolbar contains commands for rotating and flipping components. You will find the commands also as menu commands of the Layout menu.

• **Structure**

The Structure toolbar contains commands for moving components to back or to front, and to group components. You will find the commands also as menu commands of the Layout menu.

• **Layout**

The Layout toolbar contains commands for spacing and sizing components. You will find the commands also as menu commands of the Layout menu.

• **Selection**

The Selection toolbar contains commands for choosing the selection mode of components. You will not find the commands as menu commands but it is possible to execute these commands via keys.
• **Allocation**

  Note: Not available in Topology Designer.

  The *Allocation Menu* toolbar contains commands for allocating function components and defining their data flow order. You will find the commands also as menu commands of the *Allocation* menu.

• **Online**

  Note: Not available in Topology Designer.

  The *Online Menu* toolbar contains commands for viewing and forcing online values (OPC Properties). You will find the commands also as menu commands of the Online menu.

• **Connection**

  The *Connection* toolbar contains commands for connecting, disconnecting, and inverting ports.

• **Sequence**

  Note: Not available in Topology Designer.

  The *Sequence* toolbar contains commands for editing the overview diagram of a sequence and forcing steps and transitions.

• **Quick Access**

  Note: Not available in Topology Designer.

  The *Quick Access* toolbar can be used to insert a symbol, allocate / un-allocate diagrams, generate configuration data, and subscribe for live data.

---

**Standard**
The **Standard** toolbar of the Toolbar Categories contains the following tool buttons:

**Figure 195. Standard Toolbar**
Drawing

The **Drawing** toolbar of the Toolbar Categories contains the following tool buttons:

- Select or move components.
- Edit individual link vertices.
- Opens the Component Properties dialog to set graphical properties.
- Draws a single line.
- Draws a multi-segmented line.
- Draws a polygon.
- Draws a rectangle.
- Draws a series of connected curves.
- Draws a polycurve with connecting start and end points.
- Draws an ellipse.
- Inserts text.
- Inserts a label.
- Inserts a picture.
- Inserts an ActiveX component.

*Figure 196. Drawing Toolbar*

Port

The **Port** toolbar of the Toolbar Categories contains the following tool buttons:
Figure 197. Port Toolbar
View

The View toolbar of the Toolbar Categories contains the following tool buttons:

![View Toolbar Diagram]

*Figure 198. View Toolbar*
**Page**

The **Page** toolbar of the Toolbar Categories contains the following tool buttons:

![Page Toolbar Diagram](image)

*Figure 199. Page Toolbar*

**Align**

The **Align** toolbar of the Toolbar Categories contains the following tool buttons:

![Align Toolbar Diagram](image)

*Figure 200. Align Toolbar*
Nudge

The **Nudge** toolbar of the Toolbar Categories contains the following tool buttons:

![Nudge Toolbar](image1)

*Figure 201. Nudge Toolbar*

Rotate

The **Rotate** toolbar of the Toolbar Categories contains the following tool buttons:

![Rotate Toolbar](image2)

*Figure 202. Rotate Toolbar*
Structure

The **Structure** toolbar of the Toolbar Categories contains the following tool buttons:

![Structure Toolbar](image)

*Figure 203. Structure Toolbar*
Layout

The **Layout** toolbar of the Toolbar Categories contains the following tool buttons:

![Layout Toolbar](image1)

*Spaces components horizontally.*
*Spaces components vertically.*
*Makes components in the same width.*
*Makes components in the same height.*
*Makes components in the same size.*

**Figure 204. Layout Toolbar**

Selection

The **Selection** toolbar of the Toolbar Categories contains the following tool buttons:

![Selection Toolbar Category 1](image2)

*Toggles contiguous rectangular/linear multiple selection.*
*Toggles network/symbol traversal.*

**Figure 205. Selection Toolbar Category 1**

![Selection Toolbar Category 2](image3)

*Defines Data Flow Order.*
*Shows Allocation Details.*
*Deletes allocatable group.*
*Creates allocatable group.*
*Shows active allocatable group.*

**Figure 206. Selection Toolbar Category 2**
* The toolbar options to delete or create allocatable groups are available only for Function Diagrams restored to system version 5.1 and later versions.

Figure 207. Selection Toolbar Category 3
Connection

The **Connection** toolbar of the Toolbar Categories contains the following tool buttons:

![Diagram of Connection Toolbar]

*Figure 208. Connection Toolbar*
Sequence

The Sequence toolbar of the Toolbar Categories contains the following tool buttons:

![Sequence Toolbar Diagram]

Figure 209. SPL Sequence Toolbar

- SFC in Function Designer does not support the following:
  - Reset.
  - Hold.
  - Disable all Actions.

- The following features are not supported in Function Diagram:
  - Creating subsequence.
  - Setting the priority to execute different branches.
Quick Access

The Quick Access toolbar of the Toolbar Categories contains the following tool buttons:

- Insert Object.
- Allocate or UnAllocate Diagram.
- IO Allocation.
- Auto Sort Order.
- Generate Configuration Data.
- Generate Configuration Data (Full Build).
- Subscribe for Live Data Connected Output Ports.

Figure 210. Quick Access Toolbar

The **Standard**, **Page**, **Online**, and **Quick Access** toolbars are the default toolbars that are available on opening a Function Diagram for the first time in a newly created 800xA 5.1 system or a restored system.
SFC Overview

Right-click the menubar / toolbar area and click SFC Overview from the available context menu, as shown in Figure 211.

![SFC Overview Window]

*Figure 211. SFC Overview Menu Option*

A new dockable window that contains the sequence tree structure appears.

User can navigate through the sequence tree structure and obtain details regarding all the sequences and sequence components (steps, transition, and action) available in that particular Function Diagram (refer to Figure 212). The Function Diagram containing the sequence is automatically saved on expanding the sequence tree structure.

In case of nested diagrams, open the relevant Function Diagram to navigate using the sequence tree structure.
User can also click the desired sequence component to access it directly.

Right-click a component in the sequence diagram to access the SPL context menu. The context menu is dynamic and provides options to insert steps, transitions, parallel branches, and jump. The context menu varies with the selected component, as provided in Table 42.

Figure 212. SFC Overview
When a module is inserted through the context menu, the connection between the active port and the inserted module is automatically created.
Table 43 provides the description for the SPL context menu commands.

Table 43. SPL Context Menu Command Description

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Step</td>
<td>Ctrl+Alt+S</td>
<td>Inserts a step in the sequence diagram.</td>
</tr>
<tr>
<td>Insert Transition</td>
<td>Ctrl+Alt+T</td>
<td>Inserts a transition in the sequence diagram.</td>
</tr>
<tr>
<td>Insert Parallel Branch</td>
<td>Ctrl+Alt+Q</td>
<td>Inserts a parallel branch in the sequence diagram.</td>
</tr>
<tr>
<td>Insert Jump</td>
<td>Ctrl+Alt+J</td>
<td>Inserts a jump in the sequence diagram.</td>
</tr>
</tbody>
</table>

Showing/Hiding Toolbars

To display the required toolbars in the main window, do as follows:

1. Open the **Customize** dialog.
2. Select the required toolbars for display:
   - To turn on the display of a toolbar, select the appropriate check box.
   - To turn off the display of a toolbar, clear the appropriate check box.
3. Click **OK**.

Alternatively, to show or hide a toolbar, do as follows:

1. Right-click the blank area of the menu bar or toolbar area. A pop-up menu will appear, displaying all available toolbars.
2. To turn on or off the display of a toolbar, click on it. All marked toolbars will be displayed.
If different toolbars are arranged in a single row, some of the toolbar options appear beyond the active window and will not be visible to the user. It is recommended to avoid arranging the different toolbars in a single row.
Creating a User-Defined Toolbar

To create a new, user-defined toolbar, do as follows:

1. Open the Customize dialog.
3. Enter the name for the new toolbar in the Toolbar name field.
4. Click OK.

The new (yet empty) toolbar is created as separate window on the application’s main window with the toolbar name as window title. For adding tools (buttons) to the toolbar, refer to Adding Tool Buttons to Toolbars on page 383.

Adding Tool Buttons to Toolbars

To add tool buttons to a toolbar, do as follows:

1. Open the Customize dialog.
2. Click on the Toolbar Commands tab.
3. Select the toolbar with the wanted tool button from the Categories list box.
4. Drag-and-drop the wanted tool button from the Buttons group box to the target toolbar out of the Customize dialog.
5. Click OK.
Removing Tool Buttons from a Toolbar

To remove tool buttons from a toolbar, do as follows:

1. Open the **Customize** dialog.
2. Point to the tool button within the toolbar from where it shall be removed, drag-and-drop it out of the toolbar

3. Click OK to close Customize dialog.

Removing tool buttons from a toolbar is only possible if the Customize dialog is open.

**Resetting the Composition of a Toolbar**

To reset a system (not user-defined) toolbar to its original composition, do as follows:

1. Open the Customize dialog.
2. Click on the Toolbar Commands tab.
3. From the Categories list box, select the (system) toolbar to be reset.
4. Click Reset.
5. Click OK.

Resetting is only possible for system toolbars not for user-defined toolbars.

**Renaming a User-Defined Toolbar**

To rename a user-defined toolbar, do as follows:

1. Open the Customize dialog.
2. Select the wanted toolbar from the Toolbars list box on the Toolbars page.
3. Rename the toolbar in the Toolbar name field.
4. Click OK.

**Deleting a User-Defined Toolbar**

To delete a user-defined toolbar, do as follows:

1. Open the Customize dialog.
2. Select the wanted toolbar from the Toolbars list box on the Toolbars page.
3. Click **Delete**.
4. Click **OK**.

**Changing the Look of Toolbars**

You can display the toolbar buttons in a **Cool Look** manner. Then, the buttons looks like as follows:

![Toolbar with Cool Look](image1)

![Toolbar without Cool Look](image2)

*Figure 216. Changing the Toolbar Look*

To change the look of the toolbars, do as follows:

1. Open the **Customize** dialog.
2. Depending on the wanted look, mark or un-mark the **Cool Look** check box:
   - To turn on the **Cool Look** display, mark the check box.
   - To turn off the **Cool Look** display, un-mark the check box.
3. Click **OK**.

**Showing Tooltips**

Tooltips are short context-sensitive descriptions of the toolbar buttons. A tooltip is displayed on pointing to the appropriate toolbar button.

![Save (Ctrl+S) Tooltip](image3)

*Figure 217. Tooltips*
To turn on or off the display of the tooltips, do as follows:

1. Open the **Customize** dialog.
2. Mark or un-mark the **Show Tooltips** check box:
   - To turn on showing tooltips, mark the check box.
   - To turn off showing tooltips, un-mark the check box.
3. Click **OK**.

### General Accelerator Keys

The following table lists the general accelerator keys for having quick access to certain functions.

**Table 44. General Accelerator Keys Description**

<table>
<thead>
<tr>
<th>Key</th>
<th>Context</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor key (up, down, right left)</td>
<td>on symbols</td>
<td>Symbol traversal: Selects prev/next symbol according to graphical order</td>
</tr>
<tr>
<td></td>
<td>on ports</td>
<td>Network traversal: Selects prev/next port or connection link according to graphical order</td>
</tr>
<tr>
<td></td>
<td>on connection links</td>
<td>Network traversal: Selects prev/next port or connection link according to graphical order</td>
</tr>
<tr>
<td>SHIFT + left click</td>
<td>on symbols</td>
<td>Contiguous multiple selection</td>
</tr>
<tr>
<td></td>
<td>on ports</td>
<td>Contiguous multiple selection</td>
</tr>
<tr>
<td>SHIFT + cursor key (up, down, right, left)</td>
<td>on symbols</td>
<td>Contiguous multiple selection</td>
</tr>
<tr>
<td></td>
<td>on ports</td>
<td>Contiguous multiple selection</td>
</tr>
<tr>
<td>SHIFT + left drag</td>
<td>on symbols</td>
<td>Moves selected symbols only in x/y direction</td>
</tr>
<tr>
<td></td>
<td>on symbol selection handle</td>
<td>Sizes selected symbols and keep aspect ratio</td>
</tr>
<tr>
<td></td>
<td>on empty area (selection rectangle)</td>
<td>Selects (only) symbols in the selection rectangle</td>
</tr>
</tbody>
</table>
### Table 44. General Accelerator Keys Description (Continued)

<table>
<thead>
<tr>
<th>Key</th>
<th>Context</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + left click</td>
<td>on symbols</td>
<td>Disjoint multi selection</td>
</tr>
<tr>
<td></td>
<td>on ports</td>
<td>Disjoint multi selection</td>
</tr>
<tr>
<td></td>
<td>on connection links</td>
<td>Multi selection</td>
</tr>
<tr>
<td></td>
<td>on link vertex</td>
<td>Removes link vertex</td>
</tr>
<tr>
<td>CTRL + cursor</td>
<td>on symbols</td>
<td>Disjoint multi selection</td>
</tr>
<tr>
<td></td>
<td>on ports</td>
<td>Disjoint multi selection</td>
</tr>
<tr>
<td></td>
<td>on connection links</td>
<td>Disjoint multi selection</td>
</tr>
<tr>
<td>CTRL + left drag</td>
<td>on symbols</td>
<td>Copies selected symbols</td>
</tr>
<tr>
<td></td>
<td>on symbol selection handle</td>
<td>Sizes selected symbols and keep center</td>
</tr>
<tr>
<td></td>
<td>on empty area (selection rectangle)</td>
<td>Selects only connections in the selection rectangle</td>
</tr>
<tr>
<td>Shift + Ctrl + left click</td>
<td>on link vertex</td>
<td>freeze / unfreeze link vertex</td>
</tr>
<tr>
<td>Shift + Ctrl + left drag</td>
<td>on function component(s)</td>
<td>Insert function component(s) from/into another structure</td>
</tr>
<tr>
<td>ALT + left click</td>
<td>on port</td>
<td>Connects marked port to this port</td>
</tr>
<tr>
<td></td>
<td>on selected connection link</td>
<td>Inserts link vertex</td>
</tr>
<tr>
<td>ALT + left drag</td>
<td>on symbols</td>
<td>Moves selected symbols, ignore grid setting</td>
</tr>
<tr>
<td></td>
<td>on symbol selection handle</td>
<td>Sizes selected symbols, ignore grid setting</td>
</tr>
<tr>
<td></td>
<td>on empty area (selection rectangle)</td>
<td>Selects only ports in the selection rectangle</td>
</tr>
<tr>
<td>Space + cursor</td>
<td>on selected objects</td>
<td>Moves selected objects by cursor keys 1/10 of the module (Nudge)</td>
</tr>
</tbody>
</table>
Table 44. General Accelerator Keys Description (Continued)

<table>
<thead>
<tr>
<th>Key</th>
<th>Context</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space + SHIFT + cursor</td>
<td>on selected objects</td>
<td>Moves selected objects by cursor keys 1/2 of the module (Nudge)</td>
</tr>
<tr>
<td>N + SHIFT + cursor</td>
<td></td>
<td></td>
</tr>
<tr>
<td>P + left drag</td>
<td>-</td>
<td>Pan diagram by mouse</td>
</tr>
<tr>
<td>P + cursor</td>
<td></td>
<td>Pan diagram by cursor keys 1/10 of the module</td>
</tr>
<tr>
<td>P + SHIFT + cursor</td>
<td></td>
<td>Pan diagram by cursor keys 1/2 of the module</td>
</tr>
<tr>
<td>NUMPAD “5”</td>
<td>on symbols</td>
<td>Toggles cursor key navigation context from symbol traversal to network traversal</td>
</tr>
<tr>
<td></td>
<td>on ports/connection links</td>
<td>Toggles cursor key navigation context from network traversal to symbol traversal</td>
</tr>
<tr>
<td>NUMPAD “.-”</td>
<td>on ports</td>
<td>Marks this port for connection</td>
</tr>
<tr>
<td>ALT + NUMPAD “.-”</td>
<td>on ports</td>
<td>Connects this port to marked port by keyboard</td>
</tr>
<tr>
<td>DEL</td>
<td>on symbols</td>
<td>Deletes selected symbol(s)</td>
</tr>
<tr>
<td></td>
<td>on ports</td>
<td>Deletes selected port(s)</td>
</tr>
<tr>
<td></td>
<td>on connection links</td>
<td>Deletes selected connection(s) (disconnect)</td>
</tr>
<tr>
<td>F2</td>
<td>MMS editor</td>
<td>Rename sender/receiver diagrams and access variables</td>
</tr>
<tr>
<td>(Not in Topology Designer)</td>
<td></td>
<td>Change cycle time</td>
</tr>
<tr>
<td>CTRL+F5</td>
<td>MMS editor</td>
<td>Print the tree with MMS configuration data.</td>
</tr>
<tr>
<td>(Not in Topology Designer)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTRL+F6</td>
<td>MMS editor</td>
<td>Copy the tree contents with MMS configuration data onto the clipboard.</td>
</tr>
<tr>
<td>(Not in Topology Designer)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CTRL+right arrow</td>
<td>MMS editor</td>
<td>Expand the selected tree node.</td>
</tr>
<tr>
<td>(Not in Topology Designer)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Open Aspect

Use the Open Aspect dialog to navigate to and open an aspect of any Aspect Object. Open the dialog by choosing designer’s File > Open menu command:

![Open Aspect Dialog](image)

**Figure 218. Open Aspect Dialog**

The Open Aspect dialog is similar to the common File Open dialog. Instead of selecting a file, you select an aspect to open.

You do this by browsing through structures and Aspect Object hierarchies as you do it in the common File Open dialog when browsing through directories. Aspect Objects display a folder icon, and Aspects display their aspect icon.

- On top level, the **Look in** drop-down box offers all 800xA system structures.
- User selects a structure to display all Aspect Objects on root level of the selected structure.
- User selects an Aspect Object to display all its aspects and child Aspect Objects.

Inserting/Creating Components

There are different workflows while inserting/creating components:

- In Component view,
  - you insert/create graphic components (e.g. primitives) to define a designer component symbol respectively the type of it.
• In Diagram view,
  – you create new designer component Aspect Objects in designer structure. Typically, you drag & drop an object type with a designer aspect from Object Type Structure into the logic layer of a designer diagram.
  – you insert an existing designer component Aspect Object from another structure. Typically, you Shift+Ctrl drag & drop the Aspect Object from e.g. Control Structure into a designer diagram.
  – you insert/create graphic components, e.g. primitives, on the master page, logic, background, or annotation layer.

• From Diagram view,
  – you insert an existing designer component Aspect Object into another structure. Typically, you Shift+Ctrl drag & drop the Aspect Object from the designer diagram e.g. into Control Structure.
  – you can even insert designer component Aspect Objects into Bulk Data Manager. Typically, you drag & drop the Aspect Objects from the function diagram into a MS Excel sheet with activated Bulk Data Manager.

**General Procedure for Inserting/Creating a Graphic Component in Component/Diagram View**

To insert/create a graphic component, do as follows:

1. Select a graphic component to be inserted in a diagram by toolbar or menu command.
2. Left-click on the diagram where you want to insert the graphic component. This point will be the graphic components’s upper left corner.
3. Move the mouse to define the graphic components’s size/length/direction.
4. Release the mouse button.
The graphic component(s) is (are) sized according to the modifier key(s). In general,
  – SHIFT locks the aspect ratio (sizes equally in both x and y direction)
  – CTRL draws component centered on point where you started
– ALT ignores grid setting.

*Table 45. Modifier Keys for inserting/creating graphic components*

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Size</td>
</tr>
<tr>
<td>SHIFT</td>
<td>Size and keep aspect ratio</td>
</tr>
<tr>
<td>CTRL</td>
<td>Size and center to starting point</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>Size, keep aspect ratio, and center to starting point</td>
</tr>
<tr>
<td>ALT</td>
<td>Size and ignore grid setting</td>
</tr>
<tr>
<td>ALT+SHIFT</td>
<td>Size, keep aspect ratio, and ignore grid setting</td>
</tr>
<tr>
<td>ALT+CTRL</td>
<td>Size, center to starting point, and ignore grid setting</td>
</tr>
<tr>
<td>ALT+SHIFT+CTRL</td>
<td>Size, keep aspect ratio, center to starting point, and ignore grid setting</td>
</tr>
</tbody>
</table>

User can insert the following graphic components:

- **Inserting Graphic Primitives** (Component View and Diagram View)
- **Inserting Text Components** (Component View and Diagram View)
- **Inserting Label Components** (Component View and Diagram View)
- **Inserting Ports** (Component View only)
- **Inserting Pictures/Images** (Component View and Diagram View)
- **Inserting ActiveX Controls** (Component View and Diagram View)
- **Inserting Graphic Elements build with Graphics Builder** (Component View and Diagram View)

**General Procedure for Inserting a Designer Component in Diagram View**

To create a new designer component Aspect Object, do as follows:

1. Select an object type with designer aspect from Object Type Structure.
2. Drag & Drop it into the designer diagram.
3. A new Aspect Object gets created in designer structure.
4. Its symbol gets displayed on the designer diagram.

To insert an existing designer component Aspect Object instance into a designer diagram, do as follows:

1. Select an Aspect Object with Designer aspect from any structure, except Object Type Structure and Designer structure (because insert of one and the same designer component in two designer diagrams is not supported).
2. Hold down the Shift+Ctrl keys while dragging and dropping it into the designer diagram. These are the same modifier keys as used in Plant Explorer to insert Aspect Objects.
3. The Aspect Object gets inserted into designer structure.
4. Its symbol gets displayed on the designer diagram.

To insert an existing designer component Aspect Object from the designer diagram into another structure, e.g. Control Structure, do as follows:

1. Select a designer component on the designer diagram.
2. Hold down the Shift+Ctrl keys while dragging and dropping it from the designer diagram into another structure. These are the same modifier keys as used in Plant Explorer to insert Aspect Objects.
3. The Aspect Object gets inserted into the other structure.

*Table 46. Modifier Keys for Inserting/Creating Designer Components*

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Create designer component from Object Type Structure.</td>
</tr>
<tr>
<td></td>
<td>Move designer component into other structure, or into other diagram</td>
</tr>
<tr>
<td>CTRL</td>
<td>Copy designer component</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>Insert designer component into/from another structure</td>
</tr>
</tbody>
</table>
Inserting Graphic Primitives

If you insert graphic primitives in Component view or in the Diagram view, the cursor appearance will give you information about the allowed drop location. In that case, the cursor will change its appearance from an arrow to a plus sign. After insertion has finished, the cursor’s appearance is reset to an arrow. The inserted graphic primitive is displayed with its vertices.

Inserting a Line

To insert a line, do as follows:

1. Choose the menu command Insert > Graphic > Lines or click the appropriate toolbar button.
2. Move the cursor to the source point on the diagram.
3. Press the mouse button on the source point of the line, drag it to the target point and then release it. The line is displayed with its vertices.

Figure 219. Line

Inserting a graphic primitive also includes the following options:

- Inserting a Polyline
- Inserting a Polygon
• Inserting a Rectangle
• Inserting a Polycurve
• Inserting a Closed Curve
• Inserting an Ellipse

**Inserting Text Components**

To insert a text component, do as follows:

1. Choose the menu command **Insert > Text** or click the appropriate toolbar button.
2. Click on the place in the diagram where the text component shall be inserted.
3. In-cell edit the text string inside the text component.
4. Modify the text component properties to define fonts, alignment, multiple lines with word wrapping etc.

**Inserting Label Components**

Labels are special text components which are associated with an owner component, a symbol or a (connection) link. Labels get positioned in relation to their owner.

When you move a symbol or a link, its label(s) are also moved. However, labels can be selected, moved, and modified independently of their owner.

The label’s orientation property tells the label to position itself at one of nine orientation points around the owner symbol or owner link. You can also define how much distance there should be between a label and its owner.

**To label a symbol**

1. Choose menu command **Insert > Label** or click in the Drawing toolbar. The cursor changes to .
2. In Diagram view, click inside a symbol where you want to associate and position the label. A label component gets created. In Component view, click on any place in the symbol definition where the label shall be inserted. A label component gets created.
To label a link (connection line)

1. Choose menu command **Insert > Label** or click ![label icon] in the **Drawing** toolbar. The cursor changes to ![label cursor].

2. Click on the link where you want to associate and position the label. A label component with default name gets created.

3. To modify the default link name,
   - double-click the label and modify the name directly, or
   - right click on the link to open its context menu, choose **Component Properties** and modify the name in the **Name** field on the **General** page of the **Component Properties** dialog.

The link will now have the name of the label as displayed in the following figure:

![Figure 220. Labeled Link](image)

While inserting or editing the name, label, or text in a Function Diagram, text box with blue background is displayed, to overcome this problem, press Enter or click outside the text box.
Inserting Ports

A port defines a location on a symbol at which other symbol ports can be connected to. A port always belongs to exactly one symbol, and can be visible or invisible. Ports can be used to create connections between any two symbols.

Ports can only be defined in Component view (see Diagram/Component View on page 288).

1. Open the designer’s Component View.
2. Click the appropriate toolbar button from the Drawing toolbar or choose the corresponding menu command Insert > Circle Port or Insert > Line Port.
3. A circle port consists of just a circle ‘hot spot’ to connect to. To insert a circle port, simply click on the place in the symbol definition, where you want to insert the port.
4. A line port consists of a line and a circle ‘hot spot’ to connect to. To insert a line port, press and hold the mouse button on the place in the symbol definition where you want to start the line port, drag the mouse and release the button where the line port’s circle ‘hot spot’ shall end.

Thus to insert an ‘input’ line port at the left side of a symbol definition, drag the mouse from right to left, and to insert an ‘output’ port at the right side of a symbol definition, drag the mouse from left to right.

Inserting Pictures/Images

To insert a picture/image, do as follows:

1. Click the Image button from the Drawing toolbar or choose the Insert > Picture menu command.
2. From the displayed standard File Open dialog, select the wanted picture/image in either .bmp, .wmf or .dib format.
3. Click Open. The dialog is closed and the mouse pointer changes to .
4. Click on the place in the diagram where you want to insert the image.
Open

Use this standard dialog to open a file such as a picture/image for inserting it into a symbol definition or into a diagram.

Access this dialog via the menu commands **Insert > Picture** or via the appropriate toolbar button.

![Open Dialog](image)

*Figure 221. Open Dialog*

- **Open**
  
  Click **Open** to confirm the image selection for inserting the file (for example, an image file) into the active diagram.

- **Cancel**
  
  Click **Cancel** to quit the dialog without inserting an image.

**Inserting ActiveX Controls**

To insert an ActiveX Control, do as follows:
1. Click the ActiveX button from the Drawing toolbar or choose the Insert > ActiveX menu command. The Insert ActiveX Control dialog appears:

![Insert ActiveX Control](image)

Figure 222. Insert ActiveX Control

2. Select the wanted ActiveX Control from the list.
3. Click OK. The dialog is closed and the mouse pointer changes to 
4. Click on the place in the diagram where you want to insert the ActiveX Control.
Inserting Graphic Elements build with Graphics Builder

To insert a graphic element built with *Graphics Builder*, do as follows:

1. Click the ActiveX button from the **Drawing** toolbar or choose the **Insert > ActiveX** menu command. The **Insert ActiveX Control** dialog box appears.

2. Select the page **Graphic Elements**:

3. Select the wanted graphic element from the list.

4. Click **OK**. The dialog is closed and the mouse pointer changes to .

5. Click on the place in the diagram where you want to insert the graphic element.

*Figure 223. Insert Graphic Elements*
Inserting Designer Components

Designer components can be inserted into a designer diagram by creating new instances from an object type in Object Type Structure, or by inserting existing Aspect Objects from other structures (for example, from Control Structure).

Inserting Designer Components from Object Type Structure

To insert new designer components from Object Type Structure into a designer diagram, choose one of the following methods:

- Inserting via Drag & Drop
- Inserting via Menu Command

Inserting via Drag & Drop

1. Select Object Type Structure from any structure browser of designer or from the object browser of Plant Explorer.
2. Choose the wanted object type from Object Type Structure.
3. Drag the object type to the wanted location in the diagram and drop it.
4. For Function Designer only: An optional New Component Name dialog gets displayed in order to accept or change the proposed default name and to define the data flow order of the new function component, see Figure 302.
After having dropped the object type in the diagram, a new designer component object is created (instantiated) in the designer diagram. According to the object type’s Create Info definition, an Aspect Object is created (instantiated) as child of the diagram object in designer structure.
Inserting via Menu Command

1. Choose menu command **Insert > Object**. The **Insert Objects** dialog appears.
2. On the **Object Type** page, select the wanted structure (for example, designer structure, Object Type Structure) from the drop-down list.
3. Select the wanted object type with a designer aspect from the list.
4. Note: Not available for Topology Designer. An optional **New Component Name** dialog gets displayed in order to accept or change the proposed default name and to define the data flow order of the new designer component, see Figure 302.
5. A new designer component object is created (instantiated) and automatically placed in the designer diagram at the next free location. If necessary, a new page is created. According to the object type’s create info definition, a new Aspect Object is created (instantiated) as child of the diagram object in designer structure.

6. If you want to apply several designer components, click **Apply** and continue with step 3.
   If you want to apply only one designer component, click **OK**.

**Insert Objects**

Use this dialog to insert designer components by selecting them from the appropriate structure browser on the dialog’s **Object Types** page.

Open this dialog via the menu command **Insert > Object**.

*Figure 226. Insert Objects Dialog*
• **Object Types**
  Click this tab to navigate through various Structures and select specific Object Types.

• **SPL**
  Click this tab to get list of objects that can be used in SPL diagrams.

• **Transition**
  Click this tab to get list of Object types like Arithmetic expressions, Comparison expressions, and Boolean type logical expressions.

• **OK**
  Click **OK** to apply the selected object to the active diagram and close the dialog.

• **Cancel**
  Click **Cancel** to quit the dialog without applying the selected object.

• **Apply**
  Click **Apply** to apply (auto-insert) the selected object to the active diagram and leave the dialog open.

• **Help**
  Click **Help** to get dialog-specific help.

**Configure Favorite Pages**

Function Designer supports to configure your own favorite pages in the Insert Objects dialog to reduce navigation time during insertion of objects into function diagrams.

To configure favorite pages, do as follows:

1. Open Insert Object dialog via the menu command **Insert > Symbol**.
2. Press **Configure** to open the Configure Favorite Object Types dialog.
4. In the Favorites Page Name edit box enter a name for the page.
5. Press OK.

6. From the Object Type Structure in the object browser on the left side of Configure Favorite Object Types dialog drag and drop your favorite object types / groups of object types / libraries into the favorite page on the right side of the dialog. The favorite page shows the favorite object types in a flat list.

7. Press OK.

A new tab with the favorite page name is created in the **Insert Object** dialog.

Function designer supports to configure more than one favorite pages.

---

**Inserting Designer Components from/into Other Structures**

**Inserting into other structures**

It is often useful to place designer component Aspect Objects also in other structures than in designer structure.

For example: Place function component I/O signal objects of Functional Structure into Control Structure to allocate them.

To insert Aspect Objects from a diagram into another structure, use drag-and-drop with SHIFT+CTRL.

**Inserting from other structures**

To insert existing Aspect Objects from other structures into designer structure, use drag-and-drop with SHIFT+CTRL.

For example: Place already allocated I/O signals from Control Structure into a function diagram.

---

**Viewing Components**

If user has complex designer component definitions or complex diagrams, it is very important to have a possibility to find and display that particular part of the diagram. Designer offers comfortable **Zoom** and **Pan** functionality. Using them, user can always have an optimal view and good overview of the diagrams.
Zooming means to scale up or down the display of an arbitrary area in Function Designer’s Diagram/Component. Zooming is supported by several menu and toolbar commands described in the following.

**Zoom Normal**

Choose the View > **Zoom Normal** menu command to zoom to set (reset) the default size of components (100%). All other zoom values refer to that size.

**Zoom Percent**

Designer offers some predefined values for zooming accessible via menu commands or from a context menu:

Choose one of the following submenu options of **Zoom Percent** to zoom to the required size:

- View > Zoom Percent > 50%
- View > Zoom Percent > 75%
- View > Zoom Percent > 100% (Normal)
- View > Zoom Percent > 200%

**Zoom Percent through a Context Menu**

Right-click an empty area (not on a component) and choose one of the following commands from the context menu:

- Zoom > 50%
- Zoom > 75%
- Zoom > 100%
- Zoom > 200%

**Zoom Custom**

You can adjust an arbitrary value for zooming the display of components. For it, open the Zoom dialog by choosing the View > **Zoom Custom** menu command and
enter the wanted value in the Magnification% field or choose one of the predefined values from the drop-down list box.

**Zoom to Fit**

Zoom to fit means to display all available components of the designer aspect’s Diagram view/Component view. You get this overview by doing one of the following alternatives:

- Choose the menu command View > Zoom to Fit
- Choose Zoom > Zoom to Fit from the context menu
- Choose the Zoom to Fit toolbar command.

**Zoom to Selection**

Zoom to selection means to display all selected components maximum sized in the current window. Choose this command to display the wanted selection in the optimal (maximum) size.

*Figure 227. View: Zoom to Fit*
Zoom in steps via Mouse

It is possible to zoom via mouse. Do this as follows:

1. Click the Zoom button 🕵️‍♂️ from the View toolbar. The cursor in the Diagram/Component view changes to 🔬.

2. Zoom by mouse-clicks as follows:
   - To zoom increasing, click left onto the area you want to have centered after zooming.
   - To zoom decreasing, click right onto the area you want to have centered after zooming.

Pan

Using the Pan functionality means to move the whole content of the diagram/component document within the corresponding window.

It can be easier to use the Pan functionality than to configure the wanted area via the horizontal and vertical scroll bars.
To use the Pan functionality, do as follows:

1. Click the Pan button  from the View toolbar. The cursor in the Diagram/Component view changes to .
2. Move the cursor to the center of the area you want to move.
3. Press the left mouse button and move the diagram/component document to the wanted location.
4. Release the mouse button.

Selecting Components

You can select or deselect one or multiple components by mouse or by keyboard in the drawing area of the active layer in the active view. The selection can include components on one page or on multiple pages. Selected components are highlighted and define the context for commands like move, delete, cut, copy, and so on.

The components displayed in the drawing area are ordered by the top-left coordinates of their surrounding rectangle in the sense of top to bottom and left to right. Assuming the coordinates \((x, y) = (0, 0)\) at the top-left corner and \(x\) growing to the right and \(y\) growing to the bottom, a component precedes another one

- if it is located above (lower \(y\) value)
- if it is located to the left (lower \(x\) value)

This order is called graphical order. Independent from that, there might exist some logical order, for example, the insertion or data flow order of symbols.

Selection always follows the graphical order, not the logical order.

Multiple Selection

Multiple selection (multi-selection) includes only components of the same type. Following type-specific selections are possible:

- Selecting Symbols
- Selecting Ports
- Selecting Connections
Symbols, ports and connections are selected according to the modifier key(s). In general,

- None (without pressing any key) selects all symbols, ports and connections lying completely inside the selection rectangle
- SHIFT filters and selects symbols only
- CTRL filters and selects connections only
- ALT filters and selects ports only

*Table 47. Modifier Keys for Selecting by Dragging a Selection Rectangle*

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Select all objects inside selection rectangle</td>
</tr>
<tr>
<td>SHIFT</td>
<td>Select symbols only</td>
</tr>
<tr>
<td>CTRL</td>
<td>Select connections only</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>Select symbols and connections only</td>
</tr>
<tr>
<td>ALT</td>
<td>Select ports only</td>
</tr>
<tr>
<td>ALT+SHIFT</td>
<td>Select ports and symbols only</td>
</tr>
<tr>
<td>ALT+CTRL</td>
<td>Select ports and connections only</td>
</tr>
<tr>
<td>ALT+SHIFT+CTRL</td>
<td>Select all (As None)</td>
</tr>
</tbody>
</table>

When switching between different layers or splitter views (windows), the selection data is kept per layer and view.

**Anchor and Focus**

Selected components are highlighted by their selection handles. One of the selected components will be the anchor, one will have the (input) focus. The component having the focus is indicated by a focus rectangle as shown in the following figure:
On multiple selection via mouse,
- the anchor will be the upper left selected component and
- the lower right component will have the focus.

On multiple selection via keyboard,
- the anchor will be the first selected component and
- the last selected component will have the focus.

Contiguous Multiple Selection

For selecting several contiguous components, you have the following methods:

- **Contiguous rectangular multiple selection:**
  This kind of multiple selection is rectangle oriented. The selected area on a diagram is determined by a rectangle given from the coordinates of the selection start point (anchor) and the selection endpoint (focus, diagonal of the rectangle).

- **Contiguous linear multiple selection:**
  This kind of multiple selection is row oriented (as selecting text in MS Word or any other word processing system). The selected area on a diagram is determined by the graphical order of the components. All objects between (according to graphical order) the anchor and the component having the focus will be selected.

The behavior for contiguous multiple selection can be set using of the toolbar:
- Button pressed means contiguous multiple linear selection
- Button not pressed means contiguous multiple rectangle selection.

Figure 229. Selection Handles and Focus Rectangle
The behavior for network/symbol traversal with cursor keys can be set via the toolbar or by selecting a port/symbol:

- Button pressed means network traversal (ports and connection links)
- Button not pressed means symbol traversal.

**Disjoint selection**

Using mouse and keyboard modifiers, it is also possible to disjointedly select components (see also General Accelerator Keys on page 387).

**Selecting Symbols**

For selecting symbols, you have the following possibilities:

- Selecting Single Symbols
- Contiguous Rectangular Multiple Selection of Symbols
- Contiguous Linear Multiple Selection of Symbols
- Selecting Symbols through the Components Dialog Box

**Selecting Single Symbols**

To select single symbols (not in graphical order) from the designer window, choose one of the following methods:

- To select only one symbol, simply click it.
- To select several symbols, click the first symbols, press and hold the CTRL key, and then click the other wanted symbols.
Contiguous Rectangular Multiple Selection of Symbols

To select contiguous symbols within a rectangular diagram area, you have two methods:

- Selecting symbols by defining a rectangle selection using the mouse
- Selecting symbols by defining a rectangle selection through keyboard.

All relevant symbols must be located totally in the selection rectangle

Selecting symbols by defining a rectangle selection using the mouse

1. Left-click on some background in the drawing area.
2. Move the mouse and drag a selection rectangle as needed
3. Release the mouse button.
Selecting symbols by defining a rectangle selection through keyboard

1. Select the anchor symbol by clicking on it.

2. Switch to the Contiguous Rectangular Multiple Selection mode by clicking of the Selection toolbar (button/icon must be released)

3. Press SHIFT and select the symbol defining the other (diagonal) end of the selection rectangle. You can do this via mouse or using the cursor keys. This symbol automatically gets the focus.

Figure 231. Contiguous Rectangular Multiple Selection
Contiguous Linear Multiple Selection of Symbols

To select all symbols, located in the horizontal (diagram) stripe between two symbols, the anchor symbol and the symbols having (getting) the focus, do as follows:

1. Select the anchor symbol by clicking on it.
2. Switch to the Contiguous Linear Multiple Selection mode by clicking ⌐ of the Selection toolbar (button/icon must be pressed)
3. Press SHIFT and select the symbols defining the other end of the selection stripe. This symbol automatically gets the focus.

Figure 232. Contiguous Linear Multiple Selection of Symbols
Selecting Symbols through the Components Dialog Box

To select symbols from the Components dialog’s list box, do as follows:

- To select only one symbol (component) from the list, simply click it.
- To select several series listed symbols, click the first symbol of the series, then press and hold the Shift key, and then click the last symbol of the series. All symbols of the series will be highlighted.
- To select several symbols not listed in series. Press and hold the CTRL key, then click the wanted symbols.

This kind of selection doesn’t mark the selected symbols with vertices inside the diagram.

Selecting Ports

For selecting ports, you have the following possibilities:

- Selecting Single Ports
- Contiguous rectangular multiple selection of Ports
- Contiguous linear multiple selection of Ports

Selecting Single Ports

To select single ports (not in graphical order) from the designer window, choose one of the following methods:

- To select only one port, simply click it.
To select several ports, click the first port, then press and hold the CTRL key, and click the other wanted ports.

Contiguous rectangular multiple selection of Ports

To select the contiguous ports within a rectangular diagram area, you have two methods:

- Selecting symbols by defining a rectangle selection using the mouse
- Selecting symbols by defining a rectangle selection through keyboard

All relevant ports must be located totally in the selection rectangle.

Selecting ports by defining a rectangle selection through mouse

1. Left-click on some background in the drawing area.
2. Press ALT, move the mouse and drag a selection rectangle as needed.
3. Release the mouse button and ALT key.

Figure 234. Contiguous Rectangular Multiple Selection of Ports via Mouse

Selecting ports by defining a rectangle selection through keyboard

1. Select the anchor port by clicking on it.
2. Switch to the Contiguous Rectangular Multiple Selection mode by clicking [button] of the Selection toolbar (button/icon must be released)
3. Press SHIFT and select the port defining the other (diagonal) end of the selection rectangle. You can do this via mouse or using the cursor keys.
Contiguous linear multiple selection of Ports

To select all ports, located in the horizontal (diagram) stripe between two ports, the anchor port and the port having (getting) the focus, do as follows:

1. Select the anchor port by clicking on it.
2. Switch to the Contiguous Linear Multiple Selection mode by clicking of the Selection toolbar (button/icon must be pressed).
3. Press SHIFT and select the port defining the other end of the selection stripe. This port automatically gets the focus.

Figure 235. Contiguous Rectangular Multiple Selection of Ports via Keyboard
For selecting connections, you have the following possibilities:

- **Selecting Single Connections**
- **Contiguous Rectangular Multiple Selection of Connections**
- **Contiguous Linear Multiple Selection of Connections**

**Selecting Single Connections**

To select single connections (not in graphical order) from the designer window, choose one of the following methods:

- To select only one connection, simply click it.
To select several connections, click the first connection, then press and hold the CTRL key, and click the other wanted connections.

**Contiguous Rectangular Multiple Selection of Connections**

To select the contiguous connections within a rectangular diagram area, you have two methods:

- Selecting symbols by defining a rectangle selection using the mouse
- Selecting ports by defining a rectangle selection through keyboard

All relevant connections must be located totally in the selection rectangle

**Selecting connections by defining a rectangle selection via mouse**

1. Press left mouse button on some background in the drawing area.
2. Press CTRL, move the mouse and drag a selection rectangle as needed
3. Release the mouse button and CTRL key.

![Diagram of Contiguous Rectangular Multiple Selection of Connections via Mouse](image)

*Figure 238. Contiguous Rectangular Multiple Selection of Connections via Mouse*

**Selecting connections by defining a rectangle selection via keyboard**

1. Select the anchor connection by clicking on it.
2. Switch to the Contiguous Rectangular Multiple Selection mode by clicking \[\text{Cursor Keys}^2\] of the Selection toolbar (button/icon must be released)
3. Press SHIFT and select the connection defining the other (diagonal) end of the selection rectangle. You can do this via mouse (click on the target connection) or using the cursor keys.
Contiguous Linear Multiple Selection of Connections

To select all connections, located in the horizontal (diagram) stripe between two connections, the anchor connection and the connection having (getting) the focus, do as follows:

1. Select the anchor connection by clicking on it.
2. Switch to the Contiguous Linear Multiple Selection mode by clicking "Contiguous Linear Multiple Selection" button of the Selection toolbar (button/icon must be pressed)
3. Press SHIFT and select the connection defining the other end of the selection stripe. This connection automatically gets the focus.

Layout of Components

For manipulating the layout of components, designer offers the following methods:

- Grid
- Move
- Size
- Align
- Rotate
- Flip
- Order
- Group

Grid

Working with a grid is useful for positioning components on same levels (horizontally or vertically). To enable and adjusting a grid, use the Grid Properties dialog.

Grid Properties

The Grid Properties dialog allows you to set
Access this dialog through the **View > Grid Properties** menu command.

![Grid Properties Dialog](image)

**Figure 239. Grid Properties Dialog**

<table>
<thead>
<tr>
<th><strong>Grid Property</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid Visible</td>
<td>Select this check box to make the grid visible. Otherwise unmark it.</td>
</tr>
<tr>
<td>Snap to Grid</td>
<td>Select this check box to snap to the grid on creating, moving, or copying components. Otherwise unmark it.</td>
</tr>
<tr>
<td>Angle Snap</td>
<td>Select this check box to snap to the grid on rotating components.</td>
</tr>
<tr>
<td>Grid Color</td>
<td>Click on the drop-down list box to open the <strong>Color</strong> dialog for selecting the grid color.</td>
</tr>
<tr>
<td>Grid Spacing</td>
<td>Groups the fields for entering the grid spacing values.</td>
</tr>
<tr>
<td>Horizontal</td>
<td>Enter the value for horizontal grid spacing. The unit is adjusted in the <strong>Measurements and Size</strong> dialog.</td>
</tr>
<tr>
<td>Vertical</td>
<td>Enter the value for vertical grid spacing. The unit is adjusted in the <strong>Measurements and Size</strong> dialog.</td>
</tr>
</tbody>
</table>
Move

For moving components, choose one of the following methods:

- To move components through drag-and-drop with left-click.
- To move components through drag-and-drop with right mouse.

If components are moved between different diagrams, the Functional Structure is updated automatically.

See also:

- To cut and paste components inside designer diagram via context menu.
- To cut and paste components inside designer diagram via menu command.

**To move components through drag-and-drop with left-click**

1. Select the required components (see Selecting Components on page 410)
2. Left-click on one of the selected components.
3. Move the mouse.
4. Release the mouse button.

   The selected component(s) are moved according to the modifier key(s):
   
   - SHIFT moves only in x/y direction relative to center
   - ALT ignores grid setting

**Table 49. Modifier Keys for Moving Components via Left Mouse**

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Move</td>
</tr>
<tr>
<td>SHIFT</td>
<td>Move only in x/y direction relative to center</td>
</tr>
<tr>
<td>ALT</td>
<td>Move, ignore grid setting</td>
</tr>
<tr>
<td>ALT+SHIFT</td>
<td>Move only in x/y direction relative to center, ignore grid setting</td>
</tr>
</tbody>
</table>

**To move components through drag-and-drop with right mouse**

1. Select the required components (see Selecting Components on page 410)
2. Right-click on one of the selected components.
3. Move the mouse to drag the selected component(s).
4. Release the mouse button. A context menu is displayed.
5. Choose **Move Here** from the context menu.

**Table 50. Modifier Keys for Right Mouse Handling**

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Displays context menu:</td>
</tr>
<tr>
<td></td>
<td><strong>Move Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Copy Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Cancel</strong></td>
</tr>
<tr>
<td>SHIFT</td>
<td>Moves only in x/y direction relative to center. Displays context menu:</td>
</tr>
<tr>
<td></td>
<td><strong>Move Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Copy Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Cancel</strong></td>
</tr>
<tr>
<td>CTRL</td>
<td>As None</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>As CTRL, ignore SHIFT</td>
</tr>
<tr>
<td>ALT</td>
<td>Ignores grid setting. Display context menu:</td>
</tr>
<tr>
<td></td>
<td><strong>Move Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Copy Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Cancel.</strong></td>
</tr>
<tr>
<td>ALT+SHIFT</td>
<td>Ignore grid setting and move only in x/y direction relative to center.</td>
</tr>
<tr>
<td></td>
<td>Display context menu:</td>
</tr>
<tr>
<td></td>
<td><strong>Move Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Copy Here</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Cancel.</strong></td>
</tr>
<tr>
<td>ALT+CTRL</td>
<td>As None</td>
</tr>
<tr>
<td>ALT+SHIFT+CTRL</td>
<td>As ALT+CTRL, ignore SHIFT</td>
</tr>
</tbody>
</table>
To change the size of components, do as follows:

1. Left-click on a selection handle (vertex) of selected component(s)
2. Move the mouse.
3. Release the mouse button.

The component(s) is (are) sized according to the used modifier key(s):

- SHIFT locks the aspect ratio (sizes equally in both x and y direction)
- CTRL sizes keeping the component(s) center
- ALT ignores grid setting

*Table 51. Modifier Keys for Sizing Components*

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Size</td>
</tr>
<tr>
<td>SHIFT</td>
<td>Size and keep aspect ratio</td>
</tr>
<tr>
<td>CTRL</td>
<td>Size and keep center</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>Size and keep aspect ratio and keep center</td>
</tr>
<tr>
<td>ALT</td>
<td>Size, ignore grid setting</td>
</tr>
<tr>
<td>ALT+SHIFT</td>
<td>Size and keep aspect ratio, ignore grid setting</td>
</tr>
<tr>
<td>ALT+CTRL</td>
<td>Size and keep center, ignore grid setting</td>
</tr>
<tr>
<td>ALT+SHIFT+CTRL</td>
<td>Size and keep aspect ratio and keep center, ignore grid setting</td>
</tr>
</tbody>
</table>

To align selected components, Function Designer offers the following methods:

For vertically aligning:

- **Align Left/Center/Right**

For horizontally aligning:

- **Align Top/Middle/Bottom**
One of the selected components is the anchor component. A dashed border indicates the anchor component. All other components will be aligned with the anchor component.

**Align Left/Center/Right**

To align selected components vertically with the left side of the anchor component, choose the menu command **Layout > Align > Left**.

To align selected components vertically with the center/right of the anchor component, choose the respective menu command:

- **Layout > Align > Center**.
- **Layout > Align > Right**.

**Align Top/Middle/Bottom**

To align selected components horizontally with the top/middle/bottom side of the anchor component, choose the required menu command:

- **Layout > Align > Top**.
- **Layout > Align > Middle**.
- **Layout > Align > Bottom**.

**Figure 240. Aligning Components Left**

To align selected components vertically with the center/right of the anchor component, choose the respective menu command:
Function Designer provides menu and toolbar commands for rotating components:

- **Rotate Free**
- **Rotate Left/Right**

### Rotate Free

To rotate a component freely, do as follows:

1. Choose the **Layout > Rotate > Free** menu command or the command from the Rotate toolbar.
2. Point on a component (single, selection, group). The cursor changes to 
3. Left-click and move the mouse until the component’s preview is displayed with the wanted rotating angle.
4. Leave the mouse button.

![Component Rotating Free]

*Figure 241. Component Rotating Free*

### Rotate Left/Right

To rotate the selected components by 90 degrees to the left/right, choose:

- **Layout > Rotate > Left** menu command or the command from the Rotate toolbar.
Flip

Designer provides menu and toolbar commands for flipping components horizontally/vertically. Choose:

- **Layout > Flip > Horizontal** menu command or the command from the Rotate toolbar to flip horizontally.

![Figure 242. Flip Horizontal](image)

- **Layout > Flip > Vertical** menu command or the command from the Rotate toolbar to flip vertically.

![Figure 243. Flip Vertical](image)

Order

Designer provides menu and toolbar commands for ordering components within the diagram/component document:
• **Bring to Front** means to move a component in the foreground of the diagram/component document so that no other component could overlap (cover) it.

• **Send to Back** means to move a component in the background of the diagram/component document so that all other components would overlap (cover) it.

• **Bring Forward** means to move a component one level higher (forward) within the internal component order of the diagram/component document.

• **Send Backward** means to move a component one level lower (backward) within the internal component order of the diagram/component document.

Because moving a component forward/backward regards all components of a diagram/component document, it can be that nothing seems to happen on executing the Bring Forward/Send Backward command. This is the case if the order of non-overlapping components is changed.

**Bring to Front**

To bring a component to front (to the highest level), select a component and choose one of the following methods:

• Choose the **Layout > Order > Bring to Front** menu command.

• Click the **Structure** toolbar button.

• Choose the **Order > Bring to Front** command of the Graphic Component Context Menu/Designer Component Context Menu context menu.
Send to Back

To send a component to back (to the lowest level), select it and choose one of the following methods:

- Choose the **Layout > Order > Send to Back** menu command.
- Click the Structure toolbar button 📊.
- Choose the **Order > Send to Back** command of the Graphic Component Context Menu/Designer Component Context Menu context menu.

Bring Forward

To bring a component forward (to the next higher level), select it and choose one of the following methods:

- Choose the **Layout > Order > Bring Forward** menu command.
- Click the Structure toolbar button 📊.
Choose the **Order > Bring Forward** command of the Graphic Component Context Menu/Designer Component Context Menu context menu.

To bring a component backward (to the next lower level), select it and choose one of the following methods:

- Choose the **Layout > Order > Send Backward** menu command.
- Click the Structure toolbar button 📸.
- Choose the **Order > Send Backward** command of the Graphic Component Context Menu/Designer Component Context Menu context menu.

**Group**

Several selected components can be grouped or ungrouped:

- **Group** several components to handle them as one component.
- **Ungroup** a component group to handle each component separated.

**Group**

To group several components, select them and choose one of the following methods:

- Choose the **Layout > Group** menu command.
Click the **Structure** toolbar button .

Choose the **Grouping > Group** command of the **Graphic Component Context Menu/Designer Component Context Menu** context menu.

**Ungroup**

To ungroup a component group, select the group and choose one of the following methods:

- Choose the **Layout > Ungroup** menu command.
- Click the **Structure** toolbar button .
- Choose the **Grouping > Ungroup** command of the **Graphic Component Context Menu/Designer Component Context Menu** context menu.

**Cut/Copy/Paste/Delete Components**

There are different workflows while cutting/copying/pasting/deleting components:

- In Component view,
  - you cut/copy/paste/delete graphic components (primitives) to define a designer component symbol or symbol template.

- In Diagram view,
  - you cut/copy/paste/delete designer components within the diagram. Designer structure gets automatically updated for function component Aspect Objects.
  - you paste designer components copied from another diagram or from designer structure. Designer structure gets automatically updated for designer component Aspect Objects.
  - you cut/copy/paste/delete graphic components on the master page, logic, background, or annotation layer.

- From Diagram view,
you cut/copy designer components, to paste them into another designer diagram or into the designer structure. Designer structure gets automatically updated for designer component Aspect Objects.

Cut in diagram, paste in Plant Explorer object browser (Functional Structure) is not supported.

Cut in Plant Explorer object browser (Functional Structure), paste in diagram is not supported.

In each case, the following actions are possible:

- Cut and Paste
- Copy and Paste
- Delete

The behavior on pasting symbols respectively connection links depends on the settings done in the Options dialog (see Paste on page 513).

**Cut and Paste**

To cut and paste components via menu commands, use one of the following methods:

- To cut and paste components inside designer diagram via context menu
- To cut and paste components inside designer diagram via menu command

You can also move components via drag & drop. For it, see also:

- To move components through drag-and-drop with left-click
- To move components through drag-and-drop with right mouse

**To cut and paste components inside designer diagram via context menu**

1. Select the wanted components (see Selecting Components on page 410)
2. Click right over the selected components and choose Cut from the Graphic Component Context Menu.
3. Click right on the wanted target location.
4. Choose Paste from the Graphic Component Context Menu.
To cut and paste components inside designer diagram via menu command

1. Select the wanted components (see Selecting Components)
2. Choose the menu command **Edit > Cut**. The selected components are removed from the diagram/component document window and copied to the Clipboard.
3. Click on the wanted target location.
4. Choose the menu command **Edit > Paste**. The selected components are pasted from the Clipboard.

If step 3 is left, the pasted components are located into the upper left corner of the diagram/component window.

Cut/Paste Function Blocks and Control Modules in Function Diagram:
On contrast to Delete, Cut in the diagram does NOT delete the Control Structure aspect, only the Functional Structure aspect. A Paste will create a "copy" of the Function Block / Control Module.

Copy and Paste

To copy and paste components inside a designer diagram, use one of the following methods:

- To copy components inside designer structure through left mouse drag and drop
- To copy components inside designer diagram through right mouse drag-and-drop
- To copy components inside designer diagram through context menu
- To copy components inside designer diagram through menu command

The designer structure is updated automatically for designer component Aspect Objects.

To copy and paste designer component Aspect Objects inside designer structure, use one of the following methods:

- To copy a designer component Aspect Object inside designer structure through drag and drop
• To copy a designer component Aspect Object inside designer structure through context menu

To copy components inside designer structure through left mouse drag and drop
1. Select the required components (see Selecting Components on page 410)
2. Left-click on one of the selected components.
3. Press CTRL and moves the mouse to the wanted location.
4. Release CTRL key and mouse button.
   The selected component(s) are copied according to the modifier key(s):
   – ALT ignores grid setting.

Table 52. Modifier keys for copying components via left mouse

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL</td>
<td>Copy</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>As CTRL, ignore SHIFT</td>
</tr>
<tr>
<td>ALT+CTRL</td>
<td>Copy, ignore grid setting</td>
</tr>
<tr>
<td>ALT+SHIFT+CTRL</td>
<td>As ALT+CTRL, ignore SHIFT</td>
</tr>
</tbody>
</table>

To copy components inside designer diagram through right mouse drag-and-drop
1. Select the required components (see Selecting Components on page 410)
2. Right-click on one of the selected components.
3. Move the mouse to drag the selected component(s).
4. Release the mouse button. A context menu is displayed.
5. Choose **Copy Here** from the context menu.

*Table 53. Modifier keys for moving via right mouse key*

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Displays context menu:</td>
</tr>
<tr>
<td></td>
<td><em>Move Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Copy Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Cancel</em></td>
</tr>
<tr>
<td>SHIFT</td>
<td>Moves only in x/y direction relative to center.</td>
</tr>
<tr>
<td></td>
<td>Displays context menu:</td>
</tr>
<tr>
<td></td>
<td><em>Move Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Copy Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Cancel</em></td>
</tr>
<tr>
<td>CTRL</td>
<td>As None</td>
</tr>
<tr>
<td>SHIFT+CTRL</td>
<td>As CTRL, ignore SHIFT</td>
</tr>
<tr>
<td>ALT</td>
<td>Ignores grid setting.</td>
</tr>
<tr>
<td></td>
<td>Display context menu:</td>
</tr>
<tr>
<td></td>
<td><em>Move Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Copy Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Cancel.</em></td>
</tr>
<tr>
<td>ALT+SHIFT</td>
<td>Ignore grid setting and move only in x/y direction relative to center.</td>
</tr>
<tr>
<td></td>
<td>Display context menu:</td>
</tr>
<tr>
<td></td>
<td><em>Move Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Copy Here</em></td>
</tr>
<tr>
<td></td>
<td><em>Cancel.</em></td>
</tr>
<tr>
<td>ALT+CTRL</td>
<td>As None</td>
</tr>
<tr>
<td>ALT+SHIFT+CTRL</td>
<td>As ALT+CTRL, ignore SHIFT</td>
</tr>
</tbody>
</table>
To copy components inside designer diagram through context menu
1. Select the wanted components (see Selecting Components on page 410)
2. Click right over the selected components and choose Copy from the Graphic Component Context Menu.
3. Click right on the wanted target location.
4. Choose Paste from the Graphic Component Context Menu.

To copy components inside designer diagram through menu command
1. Select the wanted components (see Selecting Components on page 410)
2. Choose the menu command Edit > Copy. The selected components are copied to the Clipboard.
3. Click on the wanted target location.
4. Choose the menu command Edit > Paste. The selected components are pasted from the Clipboard.

If step 3 is left, the pasted components are located moved a little bit right down from the components’ source location to make the copied components conspicuously.

To copy a designer component Aspect Object inside designer structure through drag and drop
1. Open the designer structure in the Engineering Studio Workplace.
2. Select the wanted object (component).
3. Drag the object and drop it on the wanted target location in the designer structure.

The copied designer component is automatically inserted in the designer diagram.

To copy a designer component Aspect Object inside designer structure through context menu
1. Open the designer structure in the Engineering Studio Workplace.
2. Select the wanted object (component).
3. Click right and choose **Copy** from the context menu.
4. Select the target location (object with designer aspect) in the designer structure.
5. Click right and choose **Paste** from the context menu.

The copied designer component is automatically inserted in the designer diagram.

**Paste Options**

If you copy (or cut and paste) a selected range of designer components, you can define which links (connections) from, to, or within the selection shall be copied together with the designer components. The following variants (or combinations of them) are possible:

- **Copying Designer Components without Links**
- **Copying Designer Components including Internal Links**
- **Copying Designer Components including External Input Links**
- **Copying Designer Components including External Output Links**

**Copying Designer Components without Links**

To copy a selected range of designer components without any links, unmark all check boxes as displayed in the following figure:

**Figure 246** displays the result of copying a selected range of components (copy of Symbol2+3 to Symbol5+6):
Copying Designer Components including Internal Links

To copy a selected range of designer components including internal links, mark the **Internal Links in the Copied/Pasted Range** check box of the paste options. The following figure displays an example for it (copy of Symbol2+3 to Symbol5+6):
Section 3 Graphic Editor Reference

Paste Options

Copying Designer Components including External Input Links

To copy a selected range of designer components including internal links, mark the **Internal Links in the Copied/Pasted Range** check box of the paste options. The following figure displays an example for it (copy of Symbol2+3 to Symbol5+6):
Copying Designer Components including External Output Links

To copy a selected range of designer components including internal links, mark the **Internal Links in the Copied/Pasted Range** check box of the paste options. The following figure displays an example for it (copy of Symbol2+3 to Symbol5+6):
Delete

To delete components, choose one of the following methods:

- To delete components from a designer diagram
- To delete designer components from the designer structure
- To delete components via Components dialog

User can do it directly from the diagram, or can use the Component Properties dialog:

Figure 249. Paste Option for External Output Links
To delete components from a designer diagram
1. Select the wanted component(s). See Selecting Components on page 410.
2. Click the **DEL** key, or choose **Edit > Delete**.

The object is automatically removed from the designer structure.

To delete designer components from the designer structure
1. Open the designer structure in the Engineering Studio Workplace
2. Choose the component to be deleted.
3. Click right and choose **Delete** from the object-specific context menu.

The object is automatically removed from the designer diagram.

To delete components via Components dialog
1. Open the **Components** dialog.
2. Select the wanted component(s) from the list box.
   (See also Selecting Symbols through the Components Dialog Box on page 417.
3. Click **Delete**.
4. Click **OK**.

Delete Function Block or Control Module: Function Blocks and Control Modules get inserted in Control Structure, too. If user deletes them in Plant Explorer from Functional Structure, they still exist in Control Structure and inside Control Builder.

As a consequence,
- user cannot create further instances with the same name and
- on copy diagram in Functional Structure, the still existing instance gets inserted into the copied diagram.

Delete Function Blocks and Control Modules either:
- within Function Diagram (this will remove them from both structures),
- within Plant Explorer with object context menu, item **Advanced > Delete from all Structures**.
Defining Component Properties

Each component of a designer diagram is described by its properties. These properties can be adjusted in appropriate dialogs.

- Ambient properties valid for the whole diagram document can be adjusted in the Ambient Properties dialog.
- Default graphical properties common for newly created graphical components (primitives) can be adjusted in the Default Properties dialog.
- Graphic properties for a single selected component or for multiple selected components can be adjusted in the Component Properties dialog.
- Aspect properties / parameters for the designer diagram, for a single selected designer component, or for a single selected port or can be adjusted in the corresponding dialog.

Ambient Properties

In this dialog, you set ambient properties which are valid for the whole diagram. E.g. background color for the diagram, selection handle colors, foreground and background color for ActiveX Controls and so on. The appropriate menu command is only accessible in Function Designer’s Diagram view.

To access the Ambient Properties dialog, verify that designer’s Diagram view is active, then choose menu command Edit > Ambient Properties. The dialog displays the following property pages:

- Colors
- ActiveX Controls
- Off Page Connector
The Ambient Properties dialog contains the following buttons common for all dialog pages:

- **Colors**
  Click on the Colors tab to access the ambient properties on the Colors page.

- **ActiveX Controls**
  Click on the ActiveX Controls tab to access the ambient properties on the ActiveX Controls page.

- **Off Page Connector**
  Click on the Off Page Connector tab to access the ambient properties on the Off Page Connector.

- **OK**
  Click OK to save your settings and to close the dialog.
• **Cancel**
  Click **Cancel** to quit the dialog without saving your setting modifications.

• **Apply**
  Click **Apply** to save your settings and leave the dialog open.

**Colors**

On the **Colors** page of the **Ambient Properties** dialog, you have access to the properties for setting the colors for background, selection handles and ports.

![Figure 251. Ambient Properties Dialog: Colors Page]

This page contains the following property items:

**Background Color**

Groups the controls for setting the background color.

• **Use Windows Background Color**
  Set this option, if the diagram shall have the same background color as the operating system windows.

• **Use Custom Color**
  Set this option to get access to the drop-down color table from where you can choose the wanted background color for the diagrams.

**Selection Color**
Groups the controls for setting the color of the selection handles.

- **Use Windows Selection Color**
  
  Set this option, if the diagram shall have the same selection color as the operating system windows.

- **Use Custom Color**
  
  Set this option to get access to the drop-down color table from where you can choose the wanted selection (handle) color for the diagrams.

**Color of Marked Port**

- **Color of Marked Port**
  
  Set this option to get access to the drop-down color table from where you can choose the wanted color of marked ports.

![Diagram of Ambient Properties, Modified Colors](image)

*Figure 252. Ambient Properties, Modified Colors (Example)*
For more colors than the offered ones, click on Other to open the Color dialog.

![Drop-down Color Table](image)

**Figure 253. Drop-down Color Table**

**ActiveX Controls**

On the ActiveX Controls page of the Ambient Properties dialog, you have access to properties defining the foreground and background color for ActiveX Controls.

![Ambient Properties Dialog: ActiveX Controls Page](image)

**Figure 254. Ambient Properties Dialog: ActiveX Controls Page**

This page contains the following property items:

- **Back Color**

  Choose the background color for ActiveX Controls from the drop-down color table by clicking on the down pointer and selecting a color by clicking on it.
For more colors, click on **Other** to open the **Color** dialog.

![Drop-down Color Table](image)

*Figure 255. Drop-down Color Table*

- **Fore Color**
  Choose the foreground color for ActiveX Controls from the drop-down color table by clicking on the down pointer and selecting a color by clicking on it.
  
  See *Figure 255*. For more colors, click on **Other** to open the **Color** dialog.

- **Font**
  Click on the font button. The **Font** dialog will appear where you can set font option such as type, style, size, and so on.

- **ActiveX Run Mode**
  Set this option to enable “ActiveX Run Mode”. If enabled you can operate ActiveX Controls (e.g. press buttons, edit text fields, etc.). If disabled you can select ActiveX Controls and perform graphic operations (e.g. Copy, Move, Size, etc.).

  If “ActiveX Run Mode” is enabled the diagram is set read-only.
Off Page Connector

On the Off Page Connector page of the Ambient Properties dialog, you have access to the source and sink of the Off-Page Connectors.

This page contains the following property items:

**Off-Page Connector Source**

- **Align to Master Page Client Area**
  Set this option to align off-page connectors at the left side of the master page client area.

- **Align to Port**
  Select this option to align off-page connectors near the connected port.

- **Distance**
  Specify the distance between port and off-page connector.

**Off-Page Connector Sink**

- **Align to Master Page Client Area**
  Set this option to align off-page connector sink to the right side of the master page client area.

- **Align to Port**
  Select this option to align off-page connectors near the connected port.

- **Distance**
Specify the distance between port and off-page connector.

**Font**

Use this standard dialog to set the font type, style, size, color and some other effects such as strikeout or underline. The font options are valid for the current selected object.

This dialog will be opened from other designer dialogs, for example, by clicking a **Font** button (see **Figure 254**).

![Figure 257. Font Dialog](image)

**Component Properties**

Graphic Components are defined by a number of graphical properties. To determine which properties are associated with such a component, you need to open the **Component Properties** dialog:
Setting Component Properties

To access the Component Properties dialog, select one or more components, and choose one of the following methods:

- Choose the Edit > Default Properties menu command.
- Right-click on a component, and choose Properties from the context menu.
- Click the corresponding toolbar button from the Drawing toolbar.
- Click the Properties button from the Components dialog.

Figure 258. Component Properties Dialog: General Page

If the dialog is open from the Components dialog, the dialog’s title will be Properties instead of Component Properties.

Depending on the selected component(s), the appropriate pages are displayed.
The **Component Properties** dialog contains the following tabs (pages) and buttons accessible from all dialog pages:

- **Edit**
  Click on the **Edit** tab to access the properties on the **Edit** page.

- **Field**
  Note: Not available for Topology Designer
  Click on the **Field** tab to access the properties on the **Field** page.

- **Fill**
  Click on the **Fill** tab to access the properties on the **Fill** page.

- **Font**
  Click on the **Font** tab to access the properties on the **Font** page.

- **General**
  Click on the **General** tab to access the properties on the **General** page.

- **Labels**
  Note: Not available for Topology Designer
  Click on the **Labels** tab to access the properties on the **Labels** page.

- **Line**
  Click on the **Line** tab to access the properties on the **Line** page.

- **Position and Size**
  Click on the **Position and Size** tab to access the properties on the **Position and Size** page.

- **Text**
  Note: Not available for Topology Designer
  Click on the **Text** tab to access the properties on the **Text** page.
Edit

On the **Edit** page of the **Component Properties** dialog, you have access to properties defining which editing actions you can perform on a component. For instance, you can prevent stretching a component.

This page is identical with the **Edit** page of the **Default Properties** dialog.

![Component Properties Dialog: Edit Page](image)

**Figure 259. Component Properties Dialog: Edit Page**

The page contains the following property items:

- **Read Only**
  Check this option to lock the component for any editing actions. Then, it is no longer possible to change the position, appearance, or any other graphical properties of the component. All editing options, except **Allow Selection**, will be disabled.

- **Allow Selection**
  Check this option to allow selection of the component using the mouse.
  
  If this option is not set, the component can only be selected via the **Components** dialog.

- **Allow Move**
  Check this option to allow moving the component within designer diagrams.
• **Allow Rotation**
  Check this option to allow rotating the component.

• **Allow Vertex Editing**
  Check this option to allow editing (adding, moving, deleting) the component’s vertices.

• **Allow Scaling**
  Check this option to allow changing the component’s size. This option is corresponding to the option **Allow Stretch**:
  - If the option **Allow Stretch** is set, on changing the component’s size, height and width can be changed separately.
  - If the option **Allow Stretch** is not set, on changing the size of the component, the relationship between height and width is kept.

If this option is turned off, the option Allow Stretch is not accessible.

• **Allow Stretch**
  Check this option to allow changing the component’s height and width separately. This option is only active if the option **Allow Scaling** is set.

• **Allow Containment**
  Check this option to allow that on moving the selected component, all other components overlapped by (contained in) the selected one will automatically moved, too.

*Figure 260. Component Property: Allow Containment*
**Figure 260** displays an example for moving a rectangle overlapping (containing) a circle. Both components are moved, although only the rectangle is selected and the components are not grouped.

**Field**

On the **Field** page of the Component Properties dialog, you define document and aspect property references.

*Figure 261. Component Properties Dialog: Field Page*

This page contains the following property items:

- **Field**
  
  This field contains the **Field Code** defined as **Document Reference** or **Aspect Property Reference**. You can edit this field code definition and mix fixed texts with references, e.g. ‘This is page $Page of $LastPage’. You can also enter multiline field codes by pressing the ‘Return’ key as line separator. In that case make sure to also check **Multiple Lines** in Component Properties Dialog: **Text** page.

- **Subscribe for Live Data**

  Check **Subscribe for Live Data** if the **Field Code** contains references to properties retrieved from an OPC server, i.e. on-line values. This setting just prepares the field for display of on-line values. To activate/start on-line display for all such prepared fields, use command **Online > Subscribe for Live Data**.
• **Show Last Value**
  Check **Show Last Value** in order to display the recent on-line value after **Online > Subscribe for Live Data** has stopped. Uncheck in order to display an empty string instead.

• **Current Value**
  This field displays the current value of the **Field Code** entered in **Field**.

• **Field Code**
  Groups the fields for setting the **Document Reference** or **Aspect Property Reference**.

• **Document Reference**
  Choose a predefined document reference from the drop-down list box. The following document references can be used:

  *Table 54. Document References as Field Parameters*

<table>
<thead>
<tr>
<th>Document Reference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$?$</td>
<td>Optional prefix to be displayed if evaluation fails. E.g. $?$*$OPCValue displays a * if no OPC value can be retrieved.</td>
</tr>
<tr>
<td>$AllocDetails</td>
<td>Allocation details as defined in the <strong>Allocation &gt; Allocate Diagram</strong> command. E.g. data flow order, allocatable group name and color.</td>
</tr>
<tr>
<td>$AllocGroup</td>
<td>Name of assigned Allocatable Group Aspect Object</td>
</tr>
<tr>
<td>$Date</td>
<td>Current date</td>
</tr>
<tr>
<td>$GroupName</td>
<td>Group name</td>
</tr>
<tr>
<td>$LastPage</td>
<td>Last page number of the current document</td>
</tr>
<tr>
<td>$Name</td>
<td>Name property of the component</td>
</tr>
<tr>
<td>$NextPage</td>
<td>Page number following to the current page</td>
</tr>
<tr>
<td>$OPC Forced</td>
<td><strong>Online &gt; Subscribe for Live Data</strong>: On-line indication of a forced signal.</td>
</tr>
</tbody>
</table>
Table 54. Document References as Field Parameters (Continued)

<table>
<thead>
<tr>
<th>Document Reference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$OPCIOStatus</td>
<td>Online &gt; Subscribe for Live Data: On-line indication of the IO status.</td>
</tr>
<tr>
<td>$OPCIOValue</td>
<td>Online &gt; Subscribe for Live Data: On-line IO value of associated IO signal.</td>
</tr>
<tr>
<td>$OPCValue</td>
<td>Online &gt; Subscribe for Live Data: On-line value of associated port, link, or signal from OPC server.</td>
</tr>
<tr>
<td>$Order</td>
<td>Data Flow Order</td>
</tr>
<tr>
<td>$Page</td>
<td>Current page number</td>
</tr>
<tr>
<td>$PgComment</td>
<td>Current page comment.</td>
</tr>
<tr>
<td>$RefPage</td>
<td>Off-Page Connector: Referenced page number</td>
</tr>
<tr>
<td>$RefPort</td>
<td>Off-Page Connector: Referenced port</td>
</tr>
<tr>
<td>$RefSymbol</td>
<td>Off-Page Connector: Referenced symbol (function component)</td>
</tr>
<tr>
<td>$SymbolName</td>
<td>Symbol name</td>
</tr>
<tr>
<td>$Time</td>
<td>Current time</td>
</tr>
</tbody>
</table>

- **Aspect Property Reference**
  
  Edit an aspect property reference, e.g. ‘$.:Name:Name$’. Or press ‘...’ to open the Aspect Property Reference dialog.

- **Add**
  
  Click this button to add the selected Document/Aspect Property Reference to the **Field** field.

**Fill**

On the **Fill** page of the Component Properties dialog, you have access to properties defining how a component is filled. The most commonly used fill is a solid fill,
which is a foreground color with no hatching. You can also choose a hatched fill pattern with a background color.

![Component Properties Dialog: Fill Page](image)

**Figure 262. Component Properties Dialog: Fill Page**

This page which is identical with the Fill page of the Default Properties dialog. It contains the following property items:

- **Foreground Color**
  From the Foreground Color drop down list, select the component’s foreground (hatch) color.

- **Transparent Fill**
  Mark this option, to make the component transparent, that is to deactivate all fill settings. Neither the background nor the hatch will be displayed.

- **Background Color**
  From the Background Color drop down list, select the component’s background color.

- **Transparent Background**
  Mark this option, to make the background transparent. Only the hatch will be visible.
• **Hatch**
  
  From the **Hatch** list box, select the hatch displayed as foreground in the component.

**Font**

On the **Font** page of the Component Properties dialog, you have access to properties defining how the text appears in a component. You can choose any True Type font and then apply any typographical effects such as italic or underline.

![Component Properties Dialog: Font Page](image)

**Figure 263. Component Properties Dialog: Font Page**

This page which is identical with the **Font** page of the Default Properties dialog and nearly identical with the Font standard dialog. It contains the following property items:

- **<Font Family>**
  
  Select the font wanted for the selected text from the list by clicking on it.

- **<Font Style>**
  
  Select the font angle/weight wanted for the selected text from the list by clicking on it.
• **<Font Size>**
  Select the font size wanted for the text from the list by clicking on it.

• **Underline**
  Mark this option to underline the selected text.

• **Strike-Out**
  Mark this option to strike-out (strike through) the selected text.

• **Text Color**
  Click on the down pointer and select a color by clicking on it.
  For more colors, click on Other to open the Color dialog.

*Figure 264. Color Drop-Down Table*
Sample

General

On the **General** page of the Component Properties dialog, you have access to properties such as the name and type of the component. The properties displayed here depend on the type of the component:

![Component Properties Dialog: General Page](image)

*Figure 265. Component Properties Dialog: General Page*

This page contains the following property items:

- **Name**
  
  Displays the graphical name of the selected component. If only one component is selected, the name can be changed.

- **Type**
  
  Displays the graphical type of the selected component. If you have selected several components, the field displays the entry `<Multiple Types Selected>`.
Labels

On the **Labels** page of the Component Properties dialog, you have access properties defining the orientation of the label component.

This page which is identical with the **Labels** page of the Default Properties dialog contains the following property items:

- **Enable Orientation**
  
  Check to enable the following label orientation options.

- **Label Orientation**
  
  Groups the options for label orientation.

- **Top-Left**

  Check this option to place the label on top-left of the selected component.

- **Center-Left**

  Check this option to place the label on center-left of the selected component.

- **Bottom-Left**

  Check this option to place the label on bottom-left of the selected component.
- **Top-Center**
  Check this option to place the label on top-center of the selected component.

- **Center-Center**
  Check this option to place the label on center-center of the selected component.

- **Bottom-Center**
  Check this option to place the label on bottom-center of the selected component.

- **Top-Right**
  Check this option to place the label on top-right of the selected component.

- **Center-Right**
  Check this option to place the label on center-right of the selected component.

- **Bottom-Right**
  Check this option to place the label on bottom-right of the selected component.

- **Orientation Offset**
  Groups the properties for setting the orientation offset. Orientation offset means moving the label orientation in x and y direction.

- **X**
  Enter the value (in the selected measurement unit, e.g. ‘mm’) for moving the orientation offset in x direction. Positive value result in moving to right, a negative values result in moving to the left.

- **Y**
  Enter the value (in the selected measurement unit, e.g. ‘mm’) for moving the orientation offset in y direction. Positive values result in moving down, negative values result in moving up.

- **<Orientation Preview>**
  Displays the meaning of the label orientation offset in x (horizontal) and y (vertical) direction.
Line

On the Line page of the Component Properties dialog, you have access to properties defining how the lines appear in the component. You can set color, style and width.

![Figure 267. Component Properties Dialog: Line Page](image)

This page which is identical with the Line page of the Default Properties dialog contains the following property items:

- **Color**
  Use this drop down list for selecting the line color for the component’s border.

- **Transparent**
  Check this option to make the component’s border transparent, that is to turn off the display.

- **Style**
  From the Style list box, select the line style for the component’s border.

- **Width**
  From the Width list box, select the line width for the component’s border.
Position and Size

On the Position and Size page of the Component Properties dialog, you have access to properties giving information about the position and size of the component. It is only shown when a single component is selected. The position and size is shown using the current measurement unit.

![Component Properties Dialog: Position and Size Page](image)

You can also edit the displayed position and size to manually adjust or align components.

This page contains the following property items:

- **Left**
  Displays the component’s position from the left border in the unit defined in Measurements and Size dialog.

- **Top**
  Displays the component’s position from the top border in the unit defined in Measurements and Size dialog.
**Component Properties**  

**Section 3  Graphic Editor Reference**

- **Width**
  Displays the component’s width in the unit defined in Measurements and Size dialog.

- **Height**
  Displays the component’s height in the unit defined in Measurements and Size dialog.

**Show / Hide**

The **Show/Hide** page is similar to the **Field** page of the Component Properties dialog. You define document and aspect property references in order to show or hide the selected graphic component or primitive.

![Component Properties Dialog: Show/Hide Page](image)

*Figure 269. Component Properties Dialog: Show/Hide Page*

This page contains the following property items:

- **Show**
  Check this option to always show the graphic component.

- **Hide**
  Check this option to always hide the graphic component.
• **Hide if Condition is False(0), Show Otherwise**
  Check this option to show or hide the graphic component based on a condition. You can enter a Visual Basic script enclosed into `<vbs>` and `</vbs>`. And you can combine that script with any document or aspect property reference, see Field on page 459.

• **Current Value**
  This field displays the current value of the **Condition**.

• **Subscribe for Live Data**
  Check **Subscribe for Live Data** if the **Condition** contains references to properties retrieved from an OPC server, i.e. on-line values. This setting just prepares the field for display of on-line values. To activate/start on-line display for all such prepared fields, use command **Online > Subscribe for Live Data**.

• **Field Code**
  Groups the fields for setting the **Document Reference** or **Aspect Property Reference**.

• **Document Reference**
  Choose a predefined document reference from the drop-down list box, see Document References as Field Parameters.

• **Aspect Property Reference**
  Edit an aspect property reference, e.g. `$.:Name:Name$`. Or press ‘...’ to open the Aspect Property Reference dialog.

• **Add**
  Click this button to add the selected Document/Aspect Property Reference to the **Condition** field.

**Text**
On the **Text** page of the Component Properties dialog, you have access to properties allowing the user to enter a string value and set properties that determine how the text is displayed and edited. You can use a check box to toggle between single line and multiple line text. If multi-line text is enabled, the **Word Break** check box
allows you to toggle automatic word break on and off. Horizontal alignment can be set to left, center, or right. Vertical alignment can be set to top, center, or bottom.

![Component Properties Dialog: Text Page](image)

**Figure 270. Component Properties Dialog: Text Page**

- This page contains the following property items:
  - **Text**
    
    In the **Text** field, enter the text, displayed within the component.
  - **Multiple Lines**
    
    Check this option to prepare the text location for multiple lines. If this option is set, you can skip to the next line by pressing the ENTER key.
  - **Word Break**
    
    Check this option to retain the component’s width on writing text of any length. New text is automatically written in a new line, if the right border is reached. Unmark this option, if text shall only be written in a new line after pressing the ENTER key.
  - **Left**
    
    Check this option of the **Horizontal Alignment** group box to align the component’s text left.
• **Center (horizontal)**
  Check this option of the **Horizontal Alignment** group box to align the component’s text horizontally centered.

• **Right**
  Check this option of the **Horizontal Alignment** group box to align the component’s text right.

• **Top**
  Check this option of the **Vertical Alignment** group box to align the component’s text vertically on top.

  This option is only accessible and can be set if the **Multiple Lines** option is not set.

• **Center (vertical)**
  Check this option of the **Vertical Alignment** group box to align the component’s text vertically centered.

  This option is only accessible and can be set if the **Multiple Lines** option is not set.

• **Bottom**
  Check this option of the **Vertical Alignment** group box to align the component’s text vertically on bottom.

  This option is only accessible and can be set if the **Multiple Lines** option is not set.

• **Auto grow to text size**
  Check this option for automatically adjusting the component’s width to the length of the entered text.

• **Auto shrink to text size**
  Check this option for automatically shrinking the component’s width to the length of the entered text.
Color

Use the **Color** dialog to define a color for the previously selected component(s).

Access this dialog, for example, from the **Font** page of the **Component Properties** dialog by clicking on the **Other** button of the **Text Color** drop-down list box. Such color drop-down lists are also offered in some other dialogs.

![Color Dialog](image)

**Figure 271. Color Dialog**

The **Color** dialog contains the following property items:

- **Basic Colors**
  Displays the basic colors available. You can choose the wanted color by clicking on it.

- **Custom Colors**
  User defined colors added from the color matrix. You can choose the wanted color by clicking on it.

- **Define Custom Colors**
  Not active.
• **Color | Solid**
  Displays a preview of the color selected from the color matrix.

• **Hue**
  Specifies the hue of the color selected from the color matrix.

• **Sat**
  Specifies the saturation of the color selected from the color matrix.

• **Lum**
  Specifies the luminosity of the color selected from the color matrix.

• **Red**
  Specifies the Red value in the sense of a RGB color value.

• **Green**
  Specifies the Green value in the sense of a RGB color value.

• **Blue**
  Specifies the Blue value in the sense of a RGB color value.

• **Add to Custom Colors**
  Click this button to add the color selected from the color matrix to the **Custom colors**.

• **OK**
  Click **OK** to save your settings and to close the dialog.

• **Cancel**
  Click **Cancel** to quit the dialog without saving your setting modifications.

**Components**
Use the **Components** dialog to navigate to components, to delete components, or to get access to the properties of components.
Open the **Components** dialog via the **Edit > Components** menu command.

![Components Dialog](image)

**Figure 272. Components Dialog**

- **OK**
  
  Click this button to close the window.

- **Go To**
  
  Click this button to navigate to the selected component(s).

The navigation will result in displaying the selected component in the center of the document window.

- If you have selected one component, it will be selected in the document window.
- If you have selected several components, the focus of the window will be the center of the area built by the selected components.

- **Properties**
  
  Click this button to open the **Component Properties** dialog.

- **Delete**
  
  Click this button to delete the component from the diagram.

**Setting Component Properties**

To set the properties of one or more components, do as follows:

1. Select the required component(s) as described in **Selecting Components**.
2. Open the Component Properties dialog by choosing one of the following methods:
   – Right-click the selected components on the Function Designer window.
   – Choose the menu command Edit > Component Properties.
   – Click the appropriate toolbar button.
3. Click on the appropriate tab, to open the page containing the wanted properties.
4. Set the properties according to your wishes.
5. Click OK.

Alternatively, you can open the Properties dialog for getting access to the selected components’ properties, do as follows:
1. Open the Components dialog.
2. Select the wanted component(s) from the list box. See Component Properties on page 454.
3. Click Properties. See Component Properties on page 454.
4. Click OK in the Components dialog after having finished the work in the Properties dialog.

**Default Properties**

In this dialog, you can define default properties for graphic components. The default properties are automatically used by designer for newly created components. Default properties are not component-specific.

You can define

- default edit properties, e.g. allow scale
- default label properties, e.g. enable orientation
- default line properties, e.g. line width
- default fill properties, e.g. fill color
- default font properties, e.g. font size.
To access the **Default Properties** dialog, choose the **Edit > Default Properties** menu command.

![Default Properties Dialog]

**Figure 273. Default Properties Dialog**

This dialog contains the following tabs and buttons common for all dialog pages:

- **Edit**
  Click on the **Edit** tab to access the properties on the **Edit** page.

- **Fill**
  Click on the **Fill** tab to access the properties on the **Fill** page.

- **Font**
  Click on the **Font** tab to access the properties on the **Font** page.

- **Labels**
  Click on the **Labels** tab to access the properties on the **Labels** page.

- **Line**
  Click on the **Line** tab to access the properties on the **Line** page.
• **OK**
  Click **OK** to save your settings and to close the dialog.

• **Cancel**
  Click **Cancel** to quit the dialog without saving your setting modifications.

• **Apply**
  Click **Apply** to save your settings and leave the dialog open.

**Edit**

This page is identical with the **Edit** page of the **Component Properties** dialog.

![Figure 274. Default Properties Dialog: Edit Page](image)
Fill

This page is identical with the Fill page of the Component Properties dialog.

![Fill Page](image)

*Figure 275. Default Properties Dialog: Fill Page*

Font

This page is identical with the Font page of the Component Properties dialog.

![Font Page](image)

*Figure 276. Default Properties Dialog: Font Page*
If the font size is changed in **Default Properties**, the new font size is applicable till the Function Diagram is open. Once the Function Diagram is closed and reopened, the font size retains the default font, that is seven (7) points.

**To Save Font Size**

Perform the following procedure to save font size of your choice:

1. Select **Edit > Default Properties** menu command.
2. Click **Font** and select a font size of your choice.
3. Do some minor changes (graphical changes) in the **Default Properties** of Function Diagram for **Edit**, **Fill**, etc.
4. Click **Save** on the dialog that appears.
5. Close and open the Function Diagram.

The saved font size along with the other changes are reflected in the Function Designer, and are used automatically by Function Designer while creating a component.

**Labels**

This page is identical with the **Labels** page of the **Component Properties** dialog.

![Default Properties Dialog: Labels Page](image)

*Figure 277. Default Properties Dialog: Labels Page*
Line

This page is identical with the Line page of the Component Properties dialog.

Figure 278. Default Properties Dialog: Line Page
Layers

The designer, Diagram view, allows you to design your diagram distributed on in several layers:

- Logic Layer
- Master Page Layer
- Background Layer
- Annotation Layer

For each layer, you can set properties defining the display of the layer in the diagram, if the layer is active or inactive. Use the Layer Properties dialog to set the properties for each layer.

Layer Properties

The Layer Properties dialog allows you to set the properties for each layer of the designer.

Access this dialog via the View > Layers > Properties menu command.

![Layer Properties Dialog](image)

*Figure 279. Layer Properties Dialog*
• **OK**
  Click **OK** to save your settings and to close the dialog.

• **Cancel**
  Click **Cancel** to quit the dialog without saving your setting modifications.

• **Apply**
  Click **Apply** to save your settings and leave the dialog open.

• **Master Page Layer**
  Click this tab to access properties for the **Master Page Layer**.

• **Background Layer**
  Click this tab to access properties for the **Background Layer**.

• **Logic Layer**
  Click this tab to access properties for the **Logic Layer**.

• **Annotation Layer**
  Click this tab to access properties for the **Annotation Layer**.

• **If Layer is Active**
  Groups the properties defining the display of the active layer.

• **Components are drawn in their original color**
  Check this option in group **If Layer is Active** to draw the layer’s components in their original color - if the layer is active.
  
  Check this option in group **If Layer is Inactive** to draw the layer’s components in their original color - if the layer is inactive.

• **Components are drawn in**
  Check this option to draw the layer’s components in a user-defined color - if the layer is active.
  
  Select a user-defined color from the color drop-down list box. For more colors, click the **Color** button to open the **Color** dialog.
• **Bring Components to Front**
  Check this check box to bring components of the active layer to front.

• **If Layer is inactive**
  Groups the properties defining the layer’s display - if it is inactive, that is another layer is active.

• **Components are drawn in grey color**
  Check this option to draw the layer’s components in grey color - if the layer is inactive.

• **Components are Not Drawn at All**
  Check this option to prevent drawing of the layer’s components - if the layer is inactive.

• **Allow Components to be Moved**
  Check this option to allow moving components on the layer.

• **Allow Components to be Edited**
  Check this option to allow editing components on the layer. If unchecked, the layer is read-only.
In Diagram view, a diagram consists of several drawing pages of fixed page size. If a page is full, a new page can be inserted. Then, connections between components on different pages are automatically referenced via off-page-connectors. Size and orientation of a drawing page are defined via Edit > Measurements and Size dialog, whereas size and orientation of the printer page is defined via Page Setup dialog.

In Component view, a component or component template definition consists of one page only.

Keep in mind:

- The page you see on the screen is called the **drawing page**.
- You print the drawing on the **printed page**, which is the paper in the printer.

Typically the size and orientation of the printer page equals the drawing page. However, they can differ in the following cases:

- Your designer diagram is drawn on a drawing page A4 portrait (21.0 cm * 29.7 cm), but you print it on A3 landscape (42.0 cm * 29.7 cm) or Legal (8.5 cm * 11 inch) paper. If the printer paper size is less than the drawing page size, the drawing gets clipped.

- Your function diagram is drawn on a drawing page A3 landscape (42.0 cm * 29.7 cm), but you print it on A4 landscape (29.7 cm * 21 cm). You can zoom each page of the diagram to fit to the printer page size, either by a percentage value or on a Fit to number of printer sheets basis, see Edit > Measurements and Size.

- Your function diagram is scaled, e.g. uses a predefined or user-defined drawing scale like 1 : 2 or 5 : 1. In that case, the drawing units differ from the page units. Thus you can print a A3 drawing also on A4 paper. Or you can insert more function component symbols on a page. Assume your symbols are drawn in 1 : 1 scale. Using 1 : 2 drawing scale, you can insert four times the number of symbols on a single diagram page. The drawing units are defined together with the drawing page size by Edit > Measurements and Size.

In any case you can check the print results before actually printing via File > Print Preview. It is recommended to check menu command View > Printable Area to
outline the printable area in print preview, i.e. the printer paper size reduced by print margins.

Blocks and reference in Function Diagram may exceed boundary on performing copy/paste of Function Diagram across the pages. To avoid this user has to manually move blocks and reference inside the boundary.

**Measurements and Size**

The **Measurements and Size** dialog allows you to change the units of measure (drawing units), the drawing scale, and the drawing page size.

The dialog is accessible via the **Edit > Measurements and Size** menu command.

![Figure 280. Measurement and Size Dialog](image)

The dialog contains the following pages and buttons accessible from all pages:

- **Drawing Scale**
  Click this tab to get access to the properties of the **Drawing Scale** page.

- **Page Size**
  Click this tab to get access to the properties of the **Page Size** page.

- **Print Size**
  Click this tab to get access to the properties of the **Print Size** page.
• **OK**

Click **OK** to save your settings and to close the dialog.

• **Cancel**

Click **Cancel** to quit the dialog without saving your setting modifications.

**Drawing Scale**

The **Drawing Scale** page allows you to specify what a given real-world size on the drawing represents. It also influences how measurements are presented to you.

Suppose you defined symbols (object types) with default scale 1 : 1. Let’s say, the symbol’s size equals 2 cm * 8 cm in real-world coordinates. Instantiate the symbol on a diagram...

• with drawing scale 1 : 1. The drawing on the screen, the rulers, and the symbols component properties, position and size, will display a symbol of size 2 cm * 8 cm. Print the diagram.
  On the printer you will get a symbol of size 2 cm * 8 cm.

• with drawing scale 1 : 2. The drawing on the screen, the rulers, and the symbols component properties, position and size, will still display a symbol of size 2 cm * 8 cm. Print the diagram.
  On the printer you will get a symbol of size 1 cm * 4 cm.

• with drawing scale 2 : 1. The drawing on the screen, the rulers, and the symbols component properties, position and size, will still display a symbol of size 2 cm * 8 cm. Print the diagram.
  On the printer you will get a symbol of size 4 cm * 16 cm.

The default drawing scale is 1 : 1.
• **Unit of Measure**

Select the value of the drawing units from the drop-down list box. If you change the value, no measurement is changed at all. The chosen value just influences the measurement unit(s) displayed in

- Rulers
- **View > Grid Properties**: Grid spacing.
- **Edit > Ambient Properties**: Off-Page Connector and Snap port distance.
- **Edit > Options > Autorouting**

• **Drawing Scale**

Select No Scale (1 : 1), a predefined drawing scale, or define a drawing scale by yourself.

• **Module**

Defines a base unit for font size increments, nudge by keyboard, and pan by keyboard. It is recommended to always set the following measurements in multiples of the module (default 1 mm):

- font size, e.g. 1mm, 2mm, 3mm...
- 10 * line width, e.g. 0.1mm, 0.2mm, 0.3mm...
- grid spacing, e.g. 1mm, 2mm, 3mm...
- auto routing settings, e.g. 1mm, 2mm, 3mm...
Page Size

On the Page Size page, you define the size of the drawing page.

![Image of Measurement and Size Dialog: Page Size Page]

**Figure 281. Measurement and Size Dialog: Page Size Page**

- **Predefined**
  
The predefined drawing page sizes offered are filtered by the Metric (ISO) and English (US) setting. Select Metric (ISO) or English (US) and a drawing page size from the drop-down list.

  If you choose Metric (ISO), all internal coordinates are based on 0.01 mm. If you choose English (US), all internal coordinates are based in 0.001 inch.

- **Orientation**
  
  Select portrait or landscape.

- **User Defined**
  
  Enter any size of the drawing page in the selected Units of Measure.
Print Size

Use this Print Size page if the diagram drawing page size does not fit the printer page size. E.g. your diagram page size equals A3 landscape, and you want to print on A4 landscape.

Figure 282. Measurement and Size Dialog: Print Size Page

- **Adjust to**
  
  Reduces or enlarges a drawing page to a specified percentage. For example, to reduce a A3 drawing to A4, type 70.

- **Fit to**

  Fits each drawing page on the number of sheets you specify across and down. Depending on the number of sheets you specify, the drawing is enlarged or reduced.

  If the pages across and down are not proportional to the drawing's dimensions, only those sheets needed to maintain the drawing's proportions are used.

  Fit to 1 sheet(s) across and 1 sheet(s) down guarantees that each diagram page fits on one sheet.
Page Setup

(Printer) page setup determine how the diagram / component is printed. The standard Windows Page Setup dialog allows you to select paper size, page orientation, margins for a specific printer. These settings are saved with your diagram, and the default printer is used to initialize the page setup for a new diagram.

Access the dialog via the File > Page Setup menu command to:

- Choose the Paper Size (A4, and so on) from drop-down list.
- Choose the Paper Source from the drop-down list.
- Choose either the Portrait or Landscape orientation.
- Choose the Left, Right, Top, and Bottom Margins.

![Page Setup Dialog](image)

**Figure 283. Page Setup Dialog**

Select Master Page Template

The Select Master Page Template dialog lists predefined templates for diagrams. In effect, the selected master page template is referenced or copied into the active
diagram. The dialog is displayed when creating a new Function Diagram, see also *System 800xA Engineering, Function Designer Getting Started (3BDS100968*)*, or by invoking the **File > Template** command.

![Select Master Page Template dialog](image)

**Figure 284. Select Master Page Template dialog**

- **Template List**
  Select a predefined diagram template. You can add additional templates or customize installed ones in Object Type Structure under Object Types\Functional Planning\Diagram Templates, see also **Figure 284**.

- **Reference Template**
  Select this option to reference the selected template in the active diagram. The diagram’s master page layer gets read-only, but automatically updated when the template changes. Header/footer entries like author, document number, cannot be edited inside the diagram, but are referenced as aspect properties from a Function Diagram Document aspect of type Document.

- **Copy Template**
  Select this option to copy the selected template into the active diagram. The diagram’s master page layer gets writable, but not updated when the template changes. Header/footer entries like author, document number, can be edited.
inside the diagram, but also referenced as aspect properties from a Function Diagram Document aspect of type Document.

Templates and Skeletons

The Templates and Skeletons dialog of Topology Designer corresponds to the Select Master Page Template dialog of Function Designer.

The Templates and Skeletons dialog allows to access predefined templates and skeletons for diagrams. In effect, the selected master page template is referenced or copied or the selected skeleton is copied into the active diagram. The dialog is displayed when creating a new Topology Diagram, or by invoking the File > Template command.

![Templates and Skeletons Dialog](image)

Figure 285. Topology Designer: Templates and Skeletons Dialog

You can add additional templates or customize installed ones in Object Type Structure under Object Types\Topology Planning\Diagram Templates.

You can add additional skeletons or customize installed ones in Object Type Structure under Object Types\Topology Planning\Topology Settings\Skeletons. See also Name.Description of these object type groups.

- **Reference Template**

  Select this option to reference the template selected in the Template combo box in the active diagram. The diagram’s master page layer gets read-only, but
automatically updated when the template changes. Header/footer entries like author, document number, cannot be edited inside the diagram, but are referenced as aspect properties from a Topology Diagram Document aspect of type Document.

- **Copy Template**
  Select this option to copy the template selected in the Template combo box into the active diagram. The diagram’s master page layer gets writable, but not updated when the template changes. Header/footer entries like author, document number, can be edited inside the diagram, but also referenced as aspect properties from a Topology Diagram Document aspect of type Document.

- **Skeleton**
  Select this option to copy the skeleton selected in the Skeleton combo box into the active diagram. Skeletons behave like copied templates but contain additional prepared contents.

### Insert/Delete Page

#### Insert Page

To insert a page in a designer diagram, choose one of the following methods:

- Click the **Page** toolbar button.
- Choose the **Insert > Page** menu command.
- Choose the **View > Pages > Insert New Page** menu command.
- Optionally enter a page comment, see Figure 286.

![Figure 286. Dialog Enter Page Comment](image)
For performance reasons a Function Diagram should not have more than 20 pages. A corresponding warning message box is displayed if you try to insert more pages.

In Diagram view, current page number is displayed in the first pane of the status bar and in the page toolbar.

**Delete Page**

To delete a page from a designer diagram, select the page to be deleted, and choose one of the following methods:

- Click the **Page** toolbar button.
- Choose the **View > Pages > Delete Page** menu command

This function is enabled only if the according page is empty.

**Page Comments**

You can enter a page comment on **Insert Page** in the Enter Page Comment dialog, see Figure 286. In addition, the Page comment command from the **Page** toolbar or menu command **View > Pages > Page Comment** support,

- modify/delete page comment.
- copy page comment to different pages.
See Figure 288.

![Page Comment Dialog Box](image)

*Figure 287. Page Comment Dialog Box*

The page comment gets displayed

- on the lower-right corner of the page template, see Figure 287.
- in the complete (detailed) contents diagram, created according to Figure 289.

**Page Navigation**

To navigate to the wanted page, you have the following possibilities:

- Navigation to the first page
- Navigation to the last page
- Navigation to the next page
- Navigation to the previous page
- Navigation to a certain page

**Navigation to the first page**

To navigate to the first page, do one of the following:
- Click ⌋ of the Page toolbar
- Choose the View > Pages > First Page menu command.

**Navigation to the last page**

To navigate to the last page, do one of the following:

- Click ⌋ of the Page toolbar
- Choose the View > Pages > Last menu command.

**Navigation to the next page**

To navigate to the next page, do one of the following:

- Click ⏳ of the Page toolbar
- Choose the View > Pages > Next menu command.

**Navigation to the previous page**

To navigate to the previous page, do one of the following:

- Click ⌈ of the Page toolbar
- Choose the View > Pages > Previous menu command.

**Navigation to a certain page**

To navigate to a certain page, do one of the following:

- Select page number from combo box 2 in the Page toolbar.
• Choose the **View > Pages > Goto Page** menu command, enter the wanted page number (see Figure 340) and click **OK**.

![Goto Page Dialog](image)

*Figure 288. Goto Page Dialog*

• Click directly in the wanted page if it is displayed in the diagram.

**Printing**

User can bulk print and create a contents diagram for each substructure by creating a dummy designer aspect at any level in designer structure. In order print and create a contents chapter for all diagrams in designer structure,

• create an empty designer aspect at the root object in designer structure
• open the (empty) Diagram view
• invoke the **File > Create Contents** command
• invoke the **File > Print** command.

The diagrams are listed and printed according to their level in alphabetical order.
Contents

User can create a contents diagram for

- a single diagram in Diagram view
- multiple diagrams in Diagram view (bulk printing).

User invoke creation or update of a contents diagram by the File > Create Contents command, see Figure 289, and you open an already existing contents diagram by the File > Open Contents command.

![Create Contents Dialog]

Figure 289. Create Contents Dialog

- **Complete Contents**
  Select Complete contents to create detailed contents for each diagram and all its pages including functional designation (if any), name, description, page comment and page number.

- **Overview Contents**
  Select Overview contents to create contents for all diagrams according to the selected number of levels. The overview includes functional designation, name, description, and number of pages. Child diagrams are indented according to their level in designer structure.
• **Contents Template**

Select a contents template for the contents diagram. The contents diagram page size must not necessarily fit the diagram size. E.g. you can print the contents on A4 portrait, while your diagrams are printed on A4 landscape paper.

**Print**

User can print

- a single component in Component view
- a single diagram in Diagram view
- multiple diagrams in Diagram view (bulk printing).

User invoke printing by the **File > Print** command or by the corresponding toolbar button. In case there exist a contents diagram and/or sub- (child-) diagrams in designer structure, the dialog **Figure 290** gets displayed. Select the required options for the bulk print job.

![Info]

It is recommended to split the bulk printing into smaller functional groups instead of printing as a single job. This helps to optimize available memory and avoids aborting of printing due to insufficient memory.
Figure 290. Bulk Print Dialog

- **Contents**
  
  Check in order to print a contents diagram.
• **Diagrams**
  Check in order to print diagram(s).

• **Child Diagrams**
  Check in order to print child diagram(s).

• **Instances of Diagram Types**
  Check in order to print instances of diagram types with their instance-specific appearance.

• **Print as one job**
  Check in order to print everything as a single job.

• **Port Documentation**
  If at least one of the check boxes is checked an additional document is generated with the corresponding information.
  – Hidden Ports with Modified Initial Value
  – Connected Hidden Ports
  – Visible Ports with Modified Initial Value

• **Bulk Print**: On printing with this option selected, a new Engineering Workplace is opened to print the Function Diagrams. The Bulk Print option is available for every Function Diagram. This option is used to print, about a thousand or more Function Diagrams, to prevent aborting of print due to lack of memory. For more information, refer to Bulk Printing of Diagrams on page 506.

• **Printer and Printer Page Settings**
  Select an option
  – to print the contents/diagrams with the same printer and printer page settings defined by this starting diagram (starting parent Function aspect). You can check and modify these settings by pressing the **Page Setup** button.
  – to print and to update and save the contents/diagrams with the same printer and printer page settings defined by this starting diagram (starting parent aspect).
designer aspect). You can check and modify these settings by pressing the **Page Setup** button.

- to print the contents/diagrams with individual printer and printer page settings, as setup and saved in each contents/diagram.

**Print Components on Layers**

Select an option

- print the diagrams as laid out on the screen. In this case, components on different layers get grayed or not printed at all according to the Layer Properties.

- print the diagrams in their original color.

**Hide Online Values**

Select this option to print the diagrams without online values.

Click **OK**, the standard **Print** dialog Figure 291 appears which allows the user to set further printer parameters:

- Select the **Printer Name** from a drop-down list.
- Access the printer-specific **Properties** dialog.
- Define the **Print range** by choosing one of the following options:
  - To print all pages, choose the **All** option.
  - To print a range of pages, define **from** which page to **to** which page you want to print.
  - To print only the selected components, choose the **Selection** option.
Define the **Number of copies** to be printed.

![Print Dialog](image)

**Figure 291. Print Dialog**

The settings in **Figure 291** are valid for all diagrams printed in one job.

Click **OK**, a print working dialog indicating the current printed diagram appears. Click **Cancel** to cancel the print job.

The printed diagrams are printed according to their level in alphabetical order. They get listed in the output window of the starting parent designer aspect.
Bulk Printing of Diagrams

To print Function Diagrams in bulk, do the following steps:

1. Select **File** and click **Print**. The print dialog box is displayed, see Figure 292.

2. Select **Bulk Print**.

![Print dialog box with Bulk Print option selected](image)
3. Select required **Printer and Print Page Settings** and click **OK**. A new dialog box is displayed, see **Figure 293**.

![Select the Root Object](image)

**Figure 293. Selecting the Root Object**

4. Select an Object in the Functional Structure or Control Structure, see **Figure 293**.

5. Select any or all of following settings (see **Figure 293**) based on the requirement:
   - Contents
   - Child Diagrams
   - Instances of Diagram Types

6. Click **OK**.
A new Engineering Workplace opens up to print the Function Diagrams which are child objects of the selected object in Step 4. If the print terminates with insufficient memory, then the Engineering Workplace reopens and resumes printing from the diagram where it stopped.

Large Sequences Overview Printing

The print of Sequence Overview Diagram could be split into multiple pages as per user input.

To print diagrams with large sequences, so that each step and transition is visible in the print, do the following:

1. Open the Sequence Overview Diagram and reserve it.
2. Select **Edit** and click **Measurement and Size**.

![Figure 294. Accessing the Settings](image)
3. In the Measurement and Size dialog box, do the following steps:
   a. Click **Print Size**.
   b. Select **Fit to** option.
   c. For **sheet(s) across** and **sheet(s) down** enter a required value.

   For Example, when user enters value 1 and 4 as shown in **Figure 295**, the sequence diagram of a single page is split vertically and printed across 4 pages. For more information, refer *Measurements and Size on page 487*.

   d. Click **OK**.

![Image of Measurement and Size dialog box with settings](image)

*Figure 295. Measurement and Size Settings*

4. Save on the Sequence Overview Diagram is enabled to save to **Print Size** settings. Save the settings.

The Sequence Overview Diagram can be printed individually or in bulk as per the settings saved.
Print Preview

Use this preview to display the current diagram as it will be printed. Open the preview via the **File > Print Preview** menu command.

**Figure 296. Print Preview**

- **Print**
  
  Click this button to open the **Print** dialog.

- **Next Page**
  
  Click this button to navigate to the next page of the diagram.

- **Prev Page**
  
  Click this button to navigate to the previous page of the diagram.
• **Two Page**
  Click this button to display two pages side by side.

• **Zoom In**
  Click this button to zoom in the selected area, that means to display this area enlarged.

• **Zoom Out**
  Click this button to zoom out the selected area, that means to display this area reduced.

• **Close**
  Click this button to close the preview.

**Options**

The **Options** dialog allows you to set various designer options
Access this dialog via the **Edit > Options** the menu command.

*Figure 297. Options Dialog*
The dialog contains the following pages and buttons accessible from all pages:

- **OK**
  Click **OK** to save your settings and to close the dialog.

- **Cancel**
  Click **Cancel** to quit the dialog without saving your setting modifications.

- **Apply**
  Click **Apply** to save your settings and leave the dialog open.

- **Print**
  Click this tab to access the options of the **Print** page.

- **Paste**
  Click this tab to access the options of the **Paste** page.

- **Autorouting**
  Click this tab to access the options of the **Autorouting** page.

- **Naming**
  Note: Not available for Topology Designer.
  Click this tab to access the options of the **Naming** page.

### Print

The **Print** page of the Options dialog offers two options for printing components on layers:

- **As Laid out on Screen**
  Check this option to print components as displayed on the screen. In that case layer properties Figure 298 are taken into account, e.g. components on background layer are drawn greyed.
• **In Original Color**

Check this option to print all components on all layers in their original color.

![Figure 298. Options Dialog: Print Page](image)

### Paste

The **Paste** page of the Options dialog allows you to define the behavior on pasting copied components, see also **Paste Options** on page 441:

![Figure 299. Options Dialog: Paste Page](image)
• **Internal Links in the Copied/Pasted Range**
  Check to paste links (connections) between copied/pasted symbols. By default, this setting is checked, see Copying Designer Components including Internal Links, Figure 246 and Figure 249.
  Uncheck to disconnect links (connections) between copied/pasted symbols.

• **Inputs**
  Check to paste links (connections) between input ports of copied/pasted symbols and symbols outside the copied/pasted range (external inputs), see Copying Designer Components including External Input Links, Figure 248.
  Uncheck to disconnect them.

• **Outputs**
  Check to paste links (connections) between output ports of copied/pasted symbols and symbols outside the copied/pasted range (external outputs), see Copying Designer Components including External Output Links, Figure 249.
  Uncheck to disconnect them.

**Autorouting**

Autorouting enables the capability of automatically routing all link components in a page or diagram. Link components get rerouted accordingly whenever:

• The linked symbols are moved.
• Show / Hidden state of the port(s) of an existing linked symbol is changed.

The **Autorouting** page of the Options dialog offers the possibility to set the following options:

• **Distance between Links**
• **Distance Link to Symbol**
For both options, you can set the horizontal and vertical value based on the unit defined in the **Measurements and Size** dialog.

![Figure 300. Options Dialog: Autorouting Page](image)

**Naming**

Note: The Naming Page is not available for Topology Designer.

The **Naming** page of the Options dialog defines if the optional **New Component Name** prompt gets displayed on **Inserting Designer Components**, see Figure 302. Check/uncheck the various component types in order to show/hide the **New Component Name** prompt. The settings get stored in the registry per user.
Name

Accept or modify the default name proposed for the new instance. The default name itself can be configured in the Function Settings aspect. For aspect objects, the entered name equals the .:Name.Name and the .:Function Parameters.ObjectName aspect properties. For symbol objects, the entered name equals .:Function Parameters.ObjectName.

Figure 301. Options Dialog: Naming Page

Figure 302. Dialog New Component Name

- **Name**

  Accept or modify the default name proposed for the new instance. The default name itself can be configured in the Function Settings aspect. For aspect objects, the entered name equals the .:Name.Name and the .:Function Parameters.ObjectName aspect properties. For symbol objects, the entered name equals .:Function Parameters.ObjectName.
Function Designer supports displaying NLS (National Language Settings) variants for type name and instance name in Function Diagrams for blocks representing Aspect Objects (typically Function Blocks, Control Modules and CBM Signals).

For Aspect Objects the New Component Name dialog allows to insert a NLS variant of Name and Description according to the current Regional Settings of the Windows operating system.

For example, entering a name and a description under regional settings English (United States) results in a ENU NLS variant for Name and Description.

To add additional NLS variants of name and description use the Config View on the Name aspect of the object in Plant Explorer.

NLS variants are not supported for Symbol Objects.

- **Description**
  
  Enter any description for the new instance. For aspect objects, the entered description equals the .:Name.Description and the .:Function Parameters.ObjectDescription aspect properties. For symbol objects, the entered name equals .:Function Parameters.ObjectDescription.

- **Data Flow Order Insert Before**
  
  The combo box **Data Flow Order Insert Before** lists all function components of the current allocatable group. Select the function component before which the new instance shall be located. Select **at the end of the Allocatable Group** if you want the new instance to be located at the end of the current allocatable group. If you want to change the data flow order of the instance later use the **Data Flow Order** dialog.

**Import/Export**

In addition to the Import/Export of .afw-files supported by the 800xA system, Function Designer supports export of diagrams and components into

- **XML**
- **SVG (Scalable Vector Graphics)**
File Export

This dialog lets you export:

- The complete diagram with all pages and all layers as a set of XML and SVG files (*.xml, *.svg). The exported files contain graphics data only, but no other aspects nor aspect properties. To export the complete diagram with all its dependencies and substructure use System 800xA Import Export tool.
- The active layer as SVG file (*.svg). The exported SVG file contains graphics data only, but no other aspects nor aspect properties.
- The active page (canvas) as bitmap (*.bmp, *.dib)
- The active page (canvas) as enhanced metafile (*.emf)

This dialog appears when you choose the File > SVG Export menu command.

Figure 303. File Export Dialog
File Import

This dialog lets you import SVG files

• exported via the File Export dialog.
• exported via commercial graphic tools supporting SVG, e.g. Adobe Illustrator.

This dialog appears when you choose the File > SVG Import menu command.

Export Diagram Data / Import Diagram Data

This feature enables the users to migrate the existing Single Control Modules (Function Diagrams created up to 800xA 5.0 SP2) to Diagrams.

Follow the steps to migrate the existing Single Control Modules to Diagrams:

1. Launch the Plant Explorer.
2. Select the Functional Structure in the structure browser.
3. Select the required object in the Functional Structure and open the respective Function aspect.
4. Select File > Export Diagram Data.
5. Select a location and enter a file name in the Save As window.
6. Click Save. The diagram data is saved as a .xml file.
7. Create a blank Function Diagram. For more details refer to subsection Creating a new Function Diagram in System 800xA Engineering, Function Designer Getting Started (3BDS100968*).

8. Select **File > Import Diagram Data** in the created blank Function Diagram.

9. Select the exported .xml file in step 6 from the **Open File** window.

10. Click **Import**.

The exported diagram data is imported to the blank Function Diagram with all its Function Blocks, Control Modules, Signals, Variables, etc and their connected links.

Graphical position of Function Blocks, Control Modules, Signals, and Variables are maintained in the imported diagrams.

The diagram data of the multi page Function Diagrams are imported with the page details and interconnections.

After migrating the existing Single Control Modules to Diagrams, ensure the following before performing configuration data generation:

a) Delete the existing connections between the Local Variables, CBM signals, and Diagram References and establish new connections.

b) Explicit Splitter/Joiner blocks need to be used instead of variables.

To convert Function Diagrams having a parent and child structure:

1. Individually export the diagram data of the parent diagram.

2. Create a blank parent diagram similar to the exported Function Diagram structure.

3. Import the .xml files of the parent Function Diagram individually.

4. Individually export the diagram data of the child diagram.

5. Create a blank child diagram structure similar to the exported Function Diagram structure.

6. Import the .xml files of the child Function Diagram individually.
Newly created diagrams in system version 5.1 can also be exported and imported to the other newly created diagrams, using the above workflow. Ensure there are no missing connections within the imported diagrams.

**Limitations of Export Diagram Data / Import Diagram Data**

The following are not supported for import to a Function Diagram in the 800xA 5.1 system:

1. Diagram Parameters.
2. Global variables.
3. SFCs.
4. Text properties and text box properties.

If the XML file being imported has blocks like Function Blocks or Control Modules, that are part of a library, then the library is not connected automatically to the application to which the Function Diagram is allocated.

**Undo/Redo**

With the **Undo** and **Redo** command you can restore the state of a diagram/component diagram before doing the last designer command.

It is also possible to undo/redo several commands step by step. The undo/redo stack is only limited by the computer’s RAM.

**Undo**

Use the **Edit > Undo** menu command to undo the previous command. Alternatively, you can use the shortcut **CTRL+Z**. The following commands cannot be undone:

- **File > New**
- **File > Save, File > Save All, File > Skip Modifications**
- **File > Generate Configuration Data (Full Build)**
- **Allocation > Allocate Diagram**
- **Changing Type of Component Instances**
• **Changing Number of Inputs**
• Any modifications done outside Function Designer diagram view or component view. E.g. Plant Explorer create/delete/move/cut/paste aspect objects cannot be undone, nor Bulk Data Manager modifications.
• Any code-relevant changes modifying the state (e.g. generated or loaded) cannot be undone.

**Redo**

If the last Function Designer command is undone, user can restore the state to before undoing. Select **Edit > Redo** menu command or alternatively, the shortcut CTRL+Y.
Function Designer checks the Channel/HSE HOST/Direction/Data Type attributes of the FF Signal. These attributes are mandatory for Function Designer to create the ports and generate the code. If any one of these attributes is missed during FF engineering, then FuD will prompt some error while allocating the FBAD to the FF Proxy object.

Table 55 shows the list of error messages prompted by FuD while allocating the FBAD to the FF Proxy object with possible solution.

Table 55. Errors with solution

<table>
<thead>
<tr>
<th>Serial No.</th>
<th>Error Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>If the “Channel” is not assigned for the signal in FF Builder, FuD says “Channel is not allocated for some signals” while allocating the FBAD to FF Proxy object.</td>
<td>Correct the FBAD Diagram and reallocate the FBAD.</td>
</tr>
<tr>
<td>2</td>
<td>If the “HSE HOST”/ “Direction” / “Data Type” is not assigned for the signal in FF Builder, FuD says “Channel information is not found for some signals” while allocating the FBAD to the FF Proxy object.</td>
<td>Correct the FBAD diagram and reallocate the FBAD.</td>
</tr>
</tbody>
</table>
Table 55. Errors with solution

<table>
<thead>
<tr>
<th>Serial No.</th>
<th>Error Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>If the allocated FBAD do not have any FF signal, FuD says “Signal Information is not Found” while allocating the FBAD to FF Proxy object. This may happen if the FBAD diagram is not saved properly after modification.</td>
<td>Correct the FBAD and reallocate the FBAD to the FF Proxy object.</td>
</tr>
<tr>
<td>4</td>
<td>If the XML received from the FBAD is not proper, FuD says “XML Parsing failed”.</td>
<td>Re-save the FBAD diagram properly.</td>
</tr>
<tr>
<td>5</td>
<td>If any fault occurred during the processing of FBAD XML, FuD says “XML Error”.</td>
<td>Check if all the signal names and their attributes are saved properly.</td>
</tr>
<tr>
<td>6</td>
<td>If the selected FBAD diagram do not have any XML data, FuD says “Failed to get the FF information”.</td>
<td>Save the selected FBAD in FF builder properly.</td>
</tr>
</tbody>
</table>
Appendix A  Restored Functionalities

This appendix provides information for specific Engineering Studio functionalities or features available in Function Diagrams restored to Engineering Studio 800xA 5.1.

Single Control Modules

Function Diagrams created up to 800xA 5.0 SP2 are available as Single Control Modules (SCM) in Control Builder M, as shown in Figure 305.

Creation of an SCM based Function Diagram

Follow the steps to create Single Control Module (SCM) aspect based Function Diagram:

1. In the Plant Explorer, navigate to a parent object in the Functional Structure.
2. Right-click the parent object and click New Object... from the context menu to open the New Object dialog.
3. In the structure browser of this dialog, click Generic Type.
4. Enter a name in the Name field.
5. Enter a description in the Object description field.
6. Click Create.
7. Right-click this object and select New Aspect....
8. In the Common tab, select the List presentation check box.
9. Select the Single Control Module aspect.
10. Click Create.
11. In the Common tab, select the List presentation check box.
12. Select the Function aspect.
13. Click **Create**.

14. Double-click the Function aspect, and select **File > Template...** to assign the required template.

15. Allocate the Function Diagram to an application (see **Allocating Function Diagrams**) and use it as a SCM based diagram.

Alternatively, an existing SCM based Function Diagram can also be copy / pasted. This Function Diagram can be modified and used as a SCM diagram.

![Function Diagram](image)

**Figure 305. Function Diagram Available as Single Control Module**

From 800xA 5.1 onwards the newly created Function Diagrams are available within the **Diagram** folder in the Control Builder and Control Structure as shown in **Figure 2**.
Implicit Casts

Function Designer supports implicit casts of data types / connections. These include:

- Insertion of upcast function in CBM (e.g. DINT_TO_REAL)
- Insertion of downcast function in CBM (e.g. REAL_TO_DINT) with warning
- Conversion of real constants to CBM format (2 -> 2.0)
- Selection of proper element of structured data type (e.g. Value of RealIO)

Figure 306. Example Function Diagram for Implicit Casts

Figure 307. Generated CBM Code with Implicit Casts
## Casted Data Types

*Table 56. Support Implicit Casts*

<table>
<thead>
<tr>
<th>Source</th>
<th>BOOL</th>
<th>INT</th>
<th>DINT</th>
<th>UINT</th>
<th>WORD</th>
<th>DWORD</th>
<th>REAL</th>
<th>TIME</th>
<th>STRING</th>
</tr>
</thead>
<tbody>
<tr>
<td>BOOL</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>INT</td>
<td>+w</td>
<td>+</td>
<td>+w</td>
<td>+w</td>
<td>+w</td>
<td>+</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>DINT</td>
<td>+w</td>
<td>+w</td>
<td>+w</td>
<td>+w</td>
<td>+w</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>UINT</td>
<td>+w</td>
<td>+w</td>
<td>+</td>
<td>+w</td>
<td>+w</td>
<td>+</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>WORD</td>
<td>+w</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>-</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>DWORD</td>
<td>+w</td>
<td>+w</td>
<td>+</td>
<td>+w</td>
<td>+w</td>
<td>-</td>
<td>-</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>REAL</td>
<td>+w</td>
<td>+w</td>
<td>+w</td>
<td>+w</td>
<td>-</td>
<td>-</td>
<td>+</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>TIME</td>
<td>-</td>
<td>-</td>
<td>+</td>
<td>-</td>
<td>-</td>
<td>+</td>
<td>+</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>STRING</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
<td>+x</td>
</tr>
</tbody>
</table>

Legend:

- **Same data type** (no action needed)
- **Conversion inserted**
- **+w** Conversion inserted, warning given (possible effects:
  - Truncation, change of sign)
- **+x** String with wrong format sets the destination value to 0 / False at runtime (see also CBM documentation)
- **-** not supported

The used conversion functions of CBM are named

<Source Data Type>_TO_<Destination Data Type>

E.g. INT_TO_REAL, TIME_TO_STRING.
There is only one cast function used (i.e. no cascading of implicit casts).

A conversion function (e.g. INT_TO_REAL) always belongs to the input that needs a conversion, i.e. networks may need more than one conversion function. E.g. an integer output gets connected to three real inputs will use three INT_TO_REAL functions.

Ports with data type ANY (e.g. MOVE) are not checked.

**Structured Data Types**

If a basic data type (e.g. real) is connected to a structured one, the main element of the structure is connected. (e.g. ‘.Value’ of RealIO); see also table below.

*Table 57. Used Elements of Structured Data Types*

<table>
<thead>
<tr>
<th>Type Name</th>
<th>Usage</th>
<th>Connected element</th>
</tr>
</thead>
<tbody>
<tr>
<td>RealIO</td>
<td>Connection to process IO</td>
<td>RealIO.Value</td>
</tr>
<tr>
<td>BoolIO</td>
<td>Connection to process IO</td>
<td>BoolIO.Value</td>
</tr>
<tr>
<td>ControlConnection</td>
<td>Two-way communication between control modules</td>
<td>ControlConnection. Forward.Value</td>
</tr>
<tr>
<td>HWStatus</td>
<td>IO Diagnostics</td>
<td>HWStatus.HwState</td>
</tr>
<tr>
<td>DwordIO</td>
<td>Connection to process IO</td>
<td>DwordIO.Value</td>
</tr>
<tr>
<td>DintIO</td>
<td>Connection to process IO</td>
<td>DintIO.Value</td>
</tr>
</tbody>
</table>

**Constant Connections, Literals**

This sub chapter only describes additions that are done by the code generator for CBM to produce valid and better readable code.

- Data Type REAL
  - If the decimal separator is missing, ‘. 0’ is added (e.g. 4711 -> 4711.0)
- Data Type INT, DINT, UINT, WORD, DWORD
- Numbers to bases other than 10 are represented in base 2, 8 or 16 (prefix 2#, 8# or 16#)

- Data Type BOOL
  - Valid constants for BOOL are 0, 1, FALSE, TRUE
  - If written in lowercase, they are converted to upper case

- Data Type TIME
  - If the prefix T# or TIME# is missing, it is added
    (e.g. 39m1s -> T#39m1s)

- Data Type DATE_AND_TIME
  - If the prefix DT# is missing, it is added
    (e.g. 2003-12-31-21:35:07 -> DT#2003-12-31-21:35:07)

**Checks for Connections**

Certain combinations of unequal data types are accepted and lead to implicit casts (see below):

- Input ports and inout ports must not be connected more than once.
- Output ports and inout ports must not be connected to direct constants or variables with the flag 'constant'.
- Corresponding inout ports must not be connected to each other.

More than one connection to InOut Port: Create Variable object and connect Variable to InOutPort (right side); right side of Variable can be connected several times to other symbols.

**Connection/Networks**

Consider a network having a set of M:N connections between ports. A connection network has 1...M sources and 1...N sinks, and is defined by its unique network name, that equals the connect string of type variable. All network components, i.e. all links and off-page connectors, share the variable/network name as component name property. The variable/network name is also accessible by a label attached to network links. Automatically created links get the default variable/network names link, link1, link2...
Consider the following examples:

- In Figure 308, S4:Out was connected to variable abc. A M:N network, M = 2, N = 2, gets automatically created.

![Figure 308. M : N Network (M = 2, N = 2)](image)

In Figure 309, S2 was moved from page 1 to page 2. Off-page connectors with page references get automatically created. Page referencing is not reflected in the aspect properties nor in Bulk Data Manager, i.e. S1:Out and S2:In still hold the connect string abc. In other words, off-page connectors are also automatically created when connecting symbols on different pages by updating aspect properties, e.g. in Bulk Data Manager.

Behavior of page references:

- Page references to symbols without name (functions) display the name of the connection instead.
- There may be multiple page references on a page to the same source or sink.
Connection Mapping

Use the function **Connection Mapping** to connect ports of different structured data type. This function is implicitly invoked for connections that cannot be automatically cast. User can also explicitly invoke the Connection Mapping command from a link or a variable component. In both cases, user can select which substructures shall be interconnected. Necessary variables and links get automatically created.

Suppose you want to connect a port of data type ‘TenRealIO’ to a port of data type ‘RealIO’, see Figure 310. ‘TenRealIO’ is a library-defined structured data type and consists of 10 record elements of type RealIO.

The connection checks display an error message indicating that there is no implicit conversion possible. Now you can either

- insert a connection mapping. In that case, the **Connection Mapping** dialog gets displayed where you define a mapping between individual sub-structures or record elements of the source data type and the sink data type. On OK, necessary variable(s) and links get automatically created. Use command Show/Hide ports in order to connect the rest of the IO.

*Figure 309. M : N Network with Off-Page Connectors*
• ignore the error. This will result in an erroneous connection link drawn in red color.

• cancel the connection.

In Figure 311, two variables and corresponding links get created to map the data types ‘TenRealIO’ (structured data type with 10 record elements RealIO) and ‘FiveRealIO’ (structured data type with 5 record elements RealIO). The automatically created variables are named <SourceComponent>_<SourcePort> and <SinkComponent>_<SinkPort>.

In order to modify a connection mapping, select such a mapping variable and invoke its Connection Mapping.
Figure 310. Connection Mapping TenRealIO to RealIO
Code Relevant Changes

Code relevant changes are modifications that affect the configuration data that Function Designer generates. These changes are causing transitions between the states.

You can make these kind of changes in:

- Function Designer (FD)
- Control Builder M (CBM)
- Plant Explorer (PE)
- Bulk Data Manager (BDM)
- or any other environment that modifies the Function Designer's Aspect Objects.

Figure 311. Connection Mapping TenRealIO to FiveRealIO
Diagram State Modifications cannot be Undone. If you do code-relevant modifications ‘Generated’ or ‘Loaded’ Function Designer displays a warning in order to cancel the modification. If you ignore this warning, the diagram gets ‘Modified’ state. ‘Undo’ or ‘File > Skip Modifications’ will restore the diagram data, but not the diagram state. Regenerate configuration data and download the diagram.

If you connect an Application object to a new version of a user defined library containing data types with changed definition. The related function diagram with instances (variables) of these data types should become ‘red’. The diagram state remains ‘yellow’, however.

Table 58. Modifications of Function Designer Generated Code

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AO1§</td>
<td>You remove a Control Module or a Function Block that is a child of a Function Designer generated Single Control Module from Control Structure.</td>
<td>PE</td>
<td>F1:</td>
<td>If the object ‘MyPID’ has a parent object in the Functional Structure, this object will undergo the same state change as the parent object in the Control Structure. Any open Function Diagram is updated. <strong>Note:</strong> if the object that has been removed is a Control Module, this has no effect on the code blocks or variable definitions of the parent Single Control Module. However, this is not treated in a different way, because it is expected that the parent object in the Control Structure is also the parent object in the Functional Structure in most cases.</td>
</tr>
</tbody>
</table>
You insert a Control Module or a Function Block as a child of a Function Designer generated Single Control Module in the Control Structure.

The parent propagates its own state change to all its child objects in the Control Structure. If the newly inserted object is not placed in the Functional Structure, the parent object in the Control Structure will also become the parent object in the Functional Structure. Any open Function Diagram is updated.

Note: if the Function aspect is inherited, the object cannot be in state ‘Modified’.

If the object ‘NewObj’ has a parent object in the Functional Structure, this object will undergo the same state change as the parent object in the Control Structure, but the state change is not propagated to the child objects in the Functional Structure.
Table 58. Modifications of Function Designer Generated Code  (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AO3</td>
<td>You insert an object with a Function aspect as a child of a Function Designer generated Single Control Module in the Control Structure. Note: ‘NewObj’ is a child diagram.</td>
<td>PE</td>
<td>F1:</td>
<td>The code generator automatically starts for object ‘NewObj’ during the insertion of the object into the Control Structure. If the code generator runs without error, ‘NewObj’ ends in state ‘Generated’. Any open Function Diagram is updated.</td>
</tr>
<tr>
<td>AO4</td>
<td>You insert a Control Module or a Function Block as a child of a Function in the Functional Structure.</td>
<td>PE, FD</td>
<td>F1:</td>
<td>Any open Function Diagram is updated.</td>
</tr>
</tbody>
</table>
Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AO5</td>
<td>You move a Function Designer generated Control Module or a Function Block to a new location in the <strong>Control Structure</strong>.</td>
<td>PE</td>
<td>F1: Like in AO1&lt;br&gt;F2: Like in AO3</td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td>AO6</td>
<td>You remove a Function Block or a Control Module from a Function in the Functional Structure</td>
<td>PE</td>
<td>F1:</td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td>AO7</td>
<td>You rename a Function Designer generated Function Block or Control Module</td>
<td>PE</td>
<td>F1:</td>
<td>The object (F1_2) detects the modification and notifies its parent in Control Structure and the parent in Functional Structure. Any open Function Diagram is updated.</td>
</tr>
</tbody>
</table>
Table 58. Modifications of Function Designer Generated Code  (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AO8</td>
<td>Copy &amp; Paste in <strong>Functional Structure</strong></td>
<td>FD PE</td>
<td></td>
<td>See AO4 for the receiving parent diagram. The source object or its parent is not affected.</td>
</tr>
<tr>
<td>AO9</td>
<td>Copy &amp; Paste in <strong>Control Structure</strong></td>
<td>PE</td>
<td></td>
<td>See AO2 for the receiving diagram.</td>
</tr>
<tr>
<td>AO10</td>
<td>Cut &amp; Paste in <strong>Control Structure</strong></td>
<td>PE</td>
<td></td>
<td>See AO1 for the source object. See AO2 for the sink.</td>
</tr>
<tr>
<td>AO11</td>
<td>Cut &amp; Paste in <strong>Functional Structure</strong></td>
<td>FD PE</td>
<td></td>
<td>See AO6 for the source. See AO4 for the sink.</td>
</tr>
<tr>
<td>AO12</td>
<td>You insert a new Control Module or Function Block as a child to an existing Control Module in <strong>Control Structure</strong></td>
<td>PE</td>
<td>None</td>
<td>This action is rejected by CBM. It is not possible to add a new child object to an instance of a Control Module type. This would be a type change.</td>
</tr>
<tr>
<td>AO13</td>
<td>You insert a new Control Module or Function Block as a child to an existing Control Module in the <strong>Functional Structure</strong></td>
<td>PE</td>
<td>F3:</td>
<td>The Function Diagram of ‘F3’ is updated with the new object. Any open Function Diagram is updated.</td>
</tr>
</tbody>
</table>
Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AO14</td>
<td>You change the type of an object. (Supported only for symbol objects).</td>
<td>FD</td>
<td></td>
<td>The effected parent object in Functional Structure (diagram or allocatable group) change their state to ‘Modified’.</td>
</tr>
<tr>
<td>AO15</td>
<td>You override an inherited Function aspect</td>
<td>PE</td>
<td>F1:</td>
<td></td>
</tr>
<tr>
<td>CS1</td>
<td>You change the connect string of a Function Designer generated Control Module.</td>
<td>PE</td>
<td>F1:</td>
<td>The object F1_2 detects the modification and notifies its parent in Control Structure and the parent in Functional Structure. If a diagram that shows the connection is open, the diagram gets updated. If you modify a connect string in Function Designer, the changes are written to the Control Properties of the effected Control Module immediately.</td>
</tr>
</tbody>
</table>
Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CS2</td>
<td>You modify the initial value of an internal variable of a Function Designer</td>
<td>PE FD</td>
<td>F1_1:</td>
<td>If the modification is done using the Control Properties aspect, the change</td>
</tr>
<tr>
<td></td>
<td>generated Single Control Module</td>
<td></td>
<td></td>
<td>is reflected in Diagram.</td>
</tr>
<tr>
<td></td>
<td><img src="image-url" alt="Diagram" /></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CS3</td>
<td>You modify the initial value of an internal variable of a Control Module</td>
<td>PE</td>
<td></td>
<td>The containing Single Control Module (parent in the Control Structure)</td>
</tr>
<tr>
<td></td>
<td>that is part of a Function Diagram.</td>
<td></td>
<td></td>
<td>changes its state to ‘modified’. If such a Single Control Module does</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>not exist, the containing application changes its state to ‘modified’.</td>
</tr>
</tbody>
</table>

You add an IEC 61131-3 function (a none Aspect Object one) to a Function Diagram.

The state of the diagram that contains the new IEC 61131-3 function is changed to ‘modified’.
### Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SO2</td>
<td>You remove a Function (a none Aspect Object one) from a Function Diagram</td>
<td>FD</td>
<td>F1:</td>
<td>The state of the diagram that contains the new IEC 61131-3 function is changed to ‘modified’.</td>
</tr>
</tbody>
</table>

![Diagram of Function Diagram](attachment:image.png)

![Diagram of Function Diagram](attachment:image2.png)

![Diagram of Function Diagram](attachment:image3.png)
### Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GV1</td>
<td>You delete a global variable that has been generated by the Function Designer.</td>
<td>CBM FD PE</td>
<td>F1_2, F2:</td>
<td>All Functions reading or writing the effected global variable are set to the state ‘Modified’.</td>
</tr>
<tr>
<td></td>
<td><img src="image1" alt="Diagram" /></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GV2</td>
<td>The global variable ‘VarOlle’ is generated by Function Designer to connect the two Control Modules. The two Control Modules are defined in two different allocatable groups. If the modification is done in the Control Builder, the change is not reflected in the diagram. The variable is re-created the next time we generate configuration data.</td>
<td>CBM FD</td>
<td>F5:</td>
<td></td>
</tr>
<tr>
<td></td>
<td><img src="image2" alt="Diagram" /></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GV3</td>
<td>You rename a global variable that has been generated by the Function Designer.</td>
<td>CBM, FD</td>
<td></td>
<td>See GV1</td>
</tr>
<tr>
<td>GV4</td>
<td>You change the initial value of a global variable.</td>
<td>CBM, FD, PE</td>
<td></td>
<td>All Functions using the effected global variable are set to the state ‘Modified’. For any open Function Diagram the display is updated.</td>
</tr>
<tr>
<td>GV5</td>
<td>You change the attributes of a global variable.</td>
<td>CBM, FD</td>
<td></td>
<td>Changes done in CBM are synchronized to attributes stored in diagram variables and diagram references. The state of effected diagrams is not changed. Changes done directly in diagram variables or diagram references set all effected diagrams to state ‘Modified’.</td>
</tr>
<tr>
<td>GV7</td>
<td>You add a diagram reference</td>
<td>FD, PE</td>
<td>F5:</td>
<td>Any open Function Diagram is updated.</td>
</tr>
</tbody>
</table>
Table 58. Modifications of Function Designer Generated Code  (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GV8</td>
<td>You connect a diagram variable to a diagram reference.</td>
<td>FD</td>
<td>F5:</td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td></td>
<td><img src="image1" alt="Diagram" /></td>
<td>PE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IO1</td>
<td>You add a new IO signal as a child of an object with a Function in the Functional Structure.</td>
<td>PE</td>
<td>F5:</td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td></td>
<td><img src="image2" alt="Diagram" /></td>
<td>FD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IO2</td>
<td>You remove an IO signal from a Function.</td>
<td>PE</td>
<td>F5:</td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td></td>
<td><img src="image3" alt="Diagram" /></td>
<td>FD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IO3</td>
<td>You rename an IO signal</td>
<td>PE</td>
<td></td>
<td>See AO7</td>
</tr>
<tr>
<td></td>
<td><img src="image4" alt="Diagram" /></td>
<td>FD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IO4</td>
<td>You change the allocation of an IO signal.</td>
<td>PE</td>
<td></td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td></td>
<td><img src="image5" alt="Diagram" /></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Table 58. Modifications of Function Designer Generated Code  (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IO5</td>
<td>You move an unallocated IO signal to a Hardware Unit.</td>
<td>PE</td>
<td>F5:</td>
<td>The IO signal object detects the structure change. It notifies all its parent objects in the Functional Structure. You can now re-generate the configuration data. This will result in the correct assignment of the (global) variable to the IO channels.</td>
</tr>
<tr>
<td>IO6</td>
<td>You remove an allocated IO signal from its Hardware Unit.</td>
<td>PE</td>
<td>F5:</td>
<td></td>
</tr>
</tbody>
</table>

![Diagram showing the movement of an unallocated IO signal to a Hardware Unit.](image1)

![Diagram showing the removal of an allocated IO signal from its Hardware Unit.](image2)
### Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IO7</td>
<td>You move an IO signal from one Hardware Unit to another one.</td>
<td>PE</td>
<td>F5:</td>
<td>Any ‘Loaded’ diagram that contains the signal is changed to the state ‘Generated’ to indicate to the user that the diagram data does not correspond to the running application anymore.</td>
</tr>
</tbody>
</table>

![Diagram](image)
### Table 58. Modifications of Function Designer Generated Code  (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IO8</td>
<td>You change one of the parameters of an IO signal</td>
<td>PE</td>
<td>None</td>
<td>The diagram state is not modified on signal parameter changes. No new Function Designer configuration data generation is necessary. However, in order to update the signal parameter values in Control Builder, you should use the IO Allocation function Write Allocation to CBM of Engineering Workplace. Be aware that change of signal name (case IO3) does change the state, AO7 applies.</td>
</tr>
<tr>
<td>PA1</td>
<td>You add a diagram parameter</td>
<td>FD</td>
<td>F1_1:</td>
<td>The Single Control Module that represents the diagram changes its state to ‘Modified’. The containing diagram is not affected. Any open Function Diagram is updated.</td>
</tr>
</tbody>
</table>
### Table 58. Modifications of Function Designer Generated Code (Continued)

<table>
<thead>
<tr>
<th>Case Id</th>
<th>Modification</th>
<th>Source</th>
<th>State Change</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PA2</td>
<td>You remove a diagram parameter</td>
<td>FD</td>
<td>F1_1:</td>
<td>The Single Control Module that represents the diagram changes its state to ‘Modified’.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Diagram" /></td>
<td>PE</td>
<td>F1:</td>
<td>The containing diagram also changes its state to ‘Modified’, because any connection to the removed parameter is also deleted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td>PA3</td>
<td>You rename a diagram parameter</td>
<td>FD</td>
<td>F1_1:</td>
<td>The affected Single Control module changes the state to ‘Modified’.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Diagram" /></td>
<td>PE</td>
<td>F1:</td>
<td>The parent diagram (Functional Structure) also changes its state to ‘Modified’.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Any open Function Diagram is updated.</td>
</tr>
<tr>
<td>AL1</td>
<td>You select ‘Unallocate’</td>
<td>FD</td>
<td>F1, F1_1:</td>
<td>The effected diagram and all its children in the <strong>Control Structure</strong> are changing their state to ‘Unallocated’.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Diagram" /></td>
<td>PE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AL2</td>
<td>You select ‘Allocate’</td>
<td>FD</td>
<td></td>
<td>The effected diagram and all unallocated children in the <strong>Functional Structure</strong> are allocated.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Diagram" /></td>
<td>PE</td>
<td></td>
<td>Their state is change to ‘Modified’ or ‘Generated’.</td>
</tr>
</tbody>
</table>
The above table lists the different code relevant changes and their consequence.

**Cross References**

The global variables that the Function Designer creates in Control Builder can also be used by parts of the application that are not generated by Function Designer through cross references.

Table 59 shows, how Function Designer shows the different usages of the variables that are created by the Function Designer.
Cross-references to other Function diagrams are updated when the reference gets modified. Cross-references to I/O, into control modules or into programs are updated when the Function diagram gets opened.

**Table 59. Cross References**

<table>
<thead>
<tr>
<th>Variable Usage</th>
<th>Display</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Usage in a different diagram</td>
<td>Reference string in Functional Structure.</td>
<td>This reference is always displayed.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Reference string in Functional Structure" /></td>
<td></td>
</tr>
<tr>
<td>IO Connection</td>
<td>Reference string in Control Structure plus IO channel name.</td>
<td>The reference is displayed in diagram states Allocated, Modified, or Loaded.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Reference string in Control Structure" /></td>
<td></td>
</tr>
<tr>
<td>Usage in a Control Module</td>
<td>Reference string in Control Structure.</td>
<td>The reference is displayed in diagram states Allocated, Modified, or Loaded.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Reference string in Control Structure" /></td>
<td></td>
</tr>
<tr>
<td>Usage in a Program</td>
<td>Reference string in Control Structure.</td>
<td>The reference is displayed in diagram states Allocated, Modified, or Loaded.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Reference string in Control Structure" /></td>
<td></td>
</tr>
</tbody>
</table>
You can navigate to any cross-reference by the command Goto Reference. In case of cross-references to I/O, into control modules, or into programs you can navigate directly into various Control Builder editors:

![Goto Reference Inside Control Builder](image)

**Figure 312. Goto Reference Inside Control Builder**
**Control Application Allocation Change**

MMS communication: There is no message when control application allocation is changed.

It is possible to download code even though the cross communication is not consistent. Create cross communication once more after allocation changes.

**MMS Cross Communication**

To establish communication between different applications of one AC 800M controller or of several AC 800M controllers MMS cross communication links have to be configured. Access variables need to be created and both on the sender side and on the receiver side some logic needs to be configured using function blocks / control modules of MMSCommLib library.

Function Designer provides a MMS cross communication generator. It supports configuring MMS cross communication links by automatically generating all required access variables, their data types and the necessary logic included in sender and receiver diagrams.

For details on configuring the communication between a restored Function Diagram and a newly created 800xA 5.1 Function Diagram, refer to Connection between Restored Diagrams (created upto 800xA 5.0 SP2) and New Diagrams (created from 800xA 5.1 onwards) on page 106.

From 800xA 5.1 onwards, an unavailable **Create FDCodeBlock** check box in the Allocatable Group window indicates whether the Function Diagrams are available as Diagram or Single Control Module in Control Builder and Control Structure.

By default, if the unavailable Create FDCodeBlock is in selected state, then the Function Diagrams are available as Diagram in the Control Builder and Control Structure (only for 800xA 5.1 systems and systems restored to 800xA 5.1).

By default, if the unavailable Create FDCodeBlock is not in selected state, then the Function Diagrams are available as Single Control Module in the Control Builder and Control Structure (only for systems prior to 800xA 5.1).
Suppose there exist two diagrams which are connected by two diagram references Variable1 and Variable2: SenderDiagram1 and ReceiverDiagram1.

Figure 313. SenderDiagram1

Figure 314. ReceiverDiagram1

If these diagrams later on are allocated in different applications, there exists a hint on the receiver side that MMS communication is required.
An additional field in blue is added to the diagram reference symbol and its CrossCommunication aspect property is set to ‘MMS’:

**Figure 315. Allocation of Sender and Receiver Diagram in Different Applications**

In order to establish MMS communication some additional configuration is required. An access variable has to be created.

- Variables Variable1 and Variable2 need to be connected to this access variable on the sender side.
- Variables Variable1 and Variable2 need to be read on the receiver side by the function blocks ‘MMSConnect’ and ‘MMSReadCyc’ (or control module MMSToCC in case of data type ControlConnection) from the ‘MMSCommLib’ library.

**Figure 316. ReceiverDiagram1 with MMS Diagram References and Valid Port**
On request, MMS CrossCommunication generator of Function Designer can create the required additional access variables and function blocks / control modules by creating some additional diagrams, one diagram for the sender of a cross communication and diagram(s) for the receivers of this sender (one diagram for each application where receivers occur).

Cross communication using variables of data type ControlConnection is supported using one fixed access variable per ControlConnection variable connection.

User can also take advantage of the boolean Valid port displayed at the MMS diagram reference: Here user will get a validation flag indicating that the corresponding MMSReadCyc function block or MMSToCC control module was able to read the required signal from the sender side. User can connect the Valid port to some glue logic to evaluate this condition within the loop.

If user does not want to get automatic MMS cross communication for the variables, user can set the CrossCommunication aspect property of these diagram references to ‘manual’. Then user has to take care for cross communication configuration for these variables.

Additional basic information on MMS communication is given in

*System 800xA Control, AC 800M Configuration (3BSE035980*) and AC 800M Communication Protocols (3BSE035982).*

**Prerequisites**

Before generating MMS cross communication the following prerequisites need to be fulfilled:

- All diagrams containing MMS diagram references need to be allocated to applications.
- Generation of configuration data need to be finished for these diagrams.
- Applications running these diagrams need to be connected to controllers and to tasks.

The task connected to the applications should be of the following format: 

**ControllerName.Taskname**

If this is not the case, it results in an unspecified error during MMS Create.
Reasons:

- The function block MMSReadCyc or control module MMSToCC reads a variable from a sender. Therefore the IP address of the controller of the sender side has to be known.

- The function block MMSReadCyc or control module MMSToCC has a cycle time for reading the variable. A default for that cycle time is calculated according to the scheme:
  
  - Take the interval time of the task of the sender diagram and take the interval time of the task of the receiver diagram. Variables shall be read as double as fast as the slowest interval time.
  
  - That default can be modified by MMS Editor on page 571.

Figure 317. Prerequisites for Automatic Cross Communication Fulfilled: Applications Connected to Controllers and Tasks; IP Addresses Configured.
The length of a MMS cross communication message is limited to 957 bytes. This message size is defined by a MMSReadCyc function block. The length of this message is calculated by the data types of the access variables of all input terminals of this MMSReadCyc block.

Function Designer’s MMS CrossCommunication generator is considering this message size: In a sender diagram, global variables are collected into one access variable as long as the message size is not reached. If the message size is reached (regarding some overhead message load), a new access variable is created and following variables are collected into this new one. So one access variable, composed of a lot of global variables, is limited by the maximum message size. Therefore only MMSReadCyc[1] function blocks with only one input parameter are used.

When using the ControlConnection data type and MMSToCC control module only one global variable is handled by one access variable.

1. Consider the following while naming manually created cross communication Function Diagrams that configure cross communication between different applications, projects, and control networks:

   a. Do not use S_MMS or R_MMS in the naming convention. If they are used, the Function Diagrams will get deleted while performing Clear Generated Data context verb on the MMS cross communication aspect.

   b. Diagram names must be unique.

2. Save, manually created Function Diagrams that configure cross communication between different applications, projects, and control networks using MMS blocks in a separate folder. Do not save in Function Designer created CrossCommunication_<project name> folder within the Functional Structure.

**MMS Cross Communication Generation Principle.**

The example in this subsection explains the basic steps how MMS cross communication diagrams are generated and how adding and deleting a diagram variable is handled.

1. Create three Function Diagrams, each one allocated to another Application. The diagram variable Variable1 is source for the diagram reference in
FunctionDiagram1 and sink for the diagram references in FunctionDiagram2 and FunctionDiagram3.

2. Perform Generate Configuration Data for the three Function Diagrams. The result is that the Single Control Module for each Function Diagram is created in the Application and the global variable Variable1 is created.

3. Perform Analyze and Create MMS, using the MMS CrossCommunication generator.

For each Application the same Access Variable datatype (in Figure 318 sketched as DataType1) gets created with the same diagram variable e.g. Variable1.

And for each Application a Send or Receive Diagram is created, each represented by a corresponding Single Control Module in Control Builder M.

In the Send Diagram a packer variable of DataType1 with connection to the variable Variable1 gets generated. This is connected to an MMSDefAccVar Function Block.

In the Receive Diagram an MMSReadCyc Function Block gets connected to a unpacker variable of DataType1 with connection to Variable1.
Adding a Diagram Variable

For an existing MMS cross communication link add a diagram variable.

1. Create an additional output diagram reference connected to a newly created diagram variable Variable2 in source FunctionDiagram1 and only one sink (input diagram reference connected to the variable Variable2) in FunctionDiagram3.

Figure 318. MMS Cross Communication Principle
2. Now perform Generate Configuration Data for FunctionDiagram1 and Function Diagram3. The result is that the Single Control Modules for both Function Diagrams are re-created in the Application, now including the global variables Variable1 and Variable2.

3. Then use MMS CrossCommunication generator and perform Analyze and then Create Differences. The changes are taken care in MMS cross communication configuration as follows:

- The access variable data type (DataType1) is updated in all three applications to hold Valid, Variable1 and Variable2.
- The Send Diagram is re-created to also pack Variable2 and to re-create the access variable according to changed DataType1.
- Both Receive Diagrams are re-created to also unpack Variable2 according to changed DataType1.

If only the Sender application is downloaded first and the Receiver Applications are not yet loaded then the variables in FunctionDiagram2 and FunctionDiagram3 according to Figure 118 (which are in Receiver Applications) will hold the last Retain Values. MMSReadCyc Function Block will set communication invalid with error code -463.

The same behavior is observed in cases were Function Designer is not involved (i.e.) engineering is done in CBM for MMS communication.

Deleting a Diagram Variable or Changing the Name

If the user deletes the diagram reference with variable Variable2 in source FunctionDiagram1 or rename the diagram variable, the same steps as described for the adding of the diagram variable apply. As result we have changed FunctionDiagram1, FunctionDiagram3, the Send Diagram and the Receive Diagrams.

Regarding download the same information as given in the above warning box applies.

How to Start Generation

The MMS CrossCommunication generator is started by the object verb
**Advanced > Cross Communication** on

- Control Project,
- Control Network or
- Control Structure Root level.

In case you configure cross communication across several Control Projects or networks, use the verb on Control Network or Root level. If you configure cross communication within a single Control Project, use the verb on project level.

A CrossCommunication object is only allowed as child of one level:

Either parallel objects on project level (in case of several projects) or parallel objects on Network level (in case of several Networks) or only one object on Root level.

If Cross Communication is performed from a generic object, the following message is displayed: **Please select a CBM project.**
After starting MMS CrossCommunication generator a generic object named ‘CrossCommunication_<startingObjectName>’ gets created. It is placed inside Functional Structure on Root level.
inside Control Structure below the object where the object verb was started. A **CrossCommunication** aspect is added.

![Control Structure](image1)

**Figure 320. New Object with CrossCommunication Aspect**

The CrossCommunication aspect offers as main view an editor where you can start and influence the generation of MMS cross communication:

![Main View of Aspect CrossCommunication](image2)

**Figure 321. Main View of Aspect CrossCommunication**
Workflow of Generation

The automatic generation of MMS communication requires the following workflow:

1. Make sure that the prerequisites for using the MMS CrossCommunication generator are fulfilled. See Prerequisites on page 558.

2. Start up the MMS CrossCommunication generator on the appropriate Control Structure level. See How to Start Generation on page 563.

3. Click Check Reservation.
   - The reservation dialog window appears with reservation details of the project, applications, and all the diagrams under that application (if any of the MMS Cross Communication established project or application or diagrams available in that application is reserved by another user, then MMS > Analyze fails at the end of the analyze operation). User can modify the reservation status.

   If the cross communication object is available in the root or control network level, then the reservation dialog box opens in sequence.
It is advisable to perform Check Reservation before executing MMS > Analyze or MMS > Analyze and Create or MMS > Analyze and Correct in Depth menu commands.

4. Click MMS > Analyze to perform the analysis:
   - All diagrams below the object containing this CrossCommunication aspect (e.g. of the whole Control Project or even of a whole system) are examined for cross communication
   - All global variables of diagram references found on diagrams belonging to different applications are collected into access variables on the sender side
   - They are read from these access variables on receiver side with an interval time, calculated as mentioned above.

The analysis result is presented in different views for sender side, receiver side or variables. See MMS Analysis on page 570.

In some situations (after import/copy application or after import project) the CrossCommunication aspect property of a diagram reference may set wrong such as:

- CrossCommunication aspect is set to "None" instead of "MMS" and the receiver diagram reference do not show the presence of global variable across applications by the additional blue color field.
- CrossCommunication aspect is set to "MMS" instead of "None" and the receiver diagram reference shows additional blue color field even though there is no global variable present across applications.

MMS > Analyze and Correct in Depth option can be performed in this situation to check the correctness of CrossCommunication aspect property of all diagram references and afterwards to execute the Analyze command.

Alternatively, the Consistency Check tool or the Consistency Checker aspect will also perform the same action.

Analyze and Correct in Depth command is slower than Analyze command.
5. If required edit modifications in the MMS editor’s tree window (in view Senders / modifier Actual Analyze only):

After analysis, optionally some modifications can be done within the MMS editor, for example:

– Rename access variables
– Move variables to other Access Variable (except for ControlConnection variables).
– Change calculated cycle time.

Note that modifications edited in the analysis tree are overwritten by a next analysis!

See MMS Editor on page 571.

6. Analyze and Create Diagrams.

a. Click MMS > Analyze and Create to analyze (refer to Step 4 for details about the analysis) and create all additional diagrams. After analysis and optional modification, all additional diagrams for sender and receiver side of cross communication can be created. All variables are collected into one or more access variables of a new structured data type. This data type gets created within the required applications.

See Analyze and Create on page 577.

b. Or, if prerequisites listed below are fulfilled: Click MMS > Create Differences to re-generate just those additional diagrams covering the differences to the previous generation.

Prerequisites for Create Differences are:

– A first complete generation of diagrams for sender and receiver side of cross communication has already been done.
– Then you have done changes in parts of the cross communication configuration.
– You have performed a new analysis before Create Differences.

Optional modifications done in the differences after the analysis are taken care.
See Create Differences on page 584.

7. Optional: Verify generated diagrams, access variables and data types. You find them in the Functional Structure under an object named CrossCommunication_<startingObjectName> in the generated cross communication objects below this object.

8. Download Control Project(s) to the controllers, go online and test the in connections to verify the communication functionality of the downloaded generated code.

See Download and go Online on page 586 for some test possibilities.

Do not configure Function Diagrams connected by diagram references requiring MMS communication while MMS analysis (Analyze) and corresponding MMS generation (Analyze and Create MMS or Generate Difference) is in progress.

**MMS Analysis**

All diagrams are searched for necessary (non-manual) cross communication. The result are presented in the MMS editor. In case there are diagrams in state ‘modified, red’ which need cross communication, an error log is displayed.

![CrossCommunication](image)

*Figure 323. Errors During Analysis Phase*

Only diagram references with CrossCommunication aspect property set to ‘None’ or to ‘MMS’ are regarded. Unallocated diagrams assigned to Unallocated_Inst_App application are not regarded at all.
If the analysis is done without errors, create MMS configuration data continues. After creation, the user can check the analyzed and created data.

**MMS Editor**

The CrossCommunication aspect displays the MMS Editor (see also Figure 321) in its main view.

**MMS Menu**

- **Analyze** - Analyses the Function Diagrams for MMS communication, builds up the Analyze result tree and displays the results in the Editor Tree view.
- **Analyze and Create** - Always analyzes and creates additional MMS communication diagrams newly according to the Actual Analyze tree and deletes old diagrams.
- **Create Differences** - Always only re-generates those additional MMS communication diagrams that have to be changed. Only active if differences are available.
- **Copy Tree to Clipboard** - Copies the Editor Tree view to the clipboard.
- **Goto Next Difference** - Selects the next difference in the Editor Tree view.
- **Export Analyse to CSV...** - Exports the analysis tree result to a .CSV file.
- **Export generated data to CSV...** - Exports the generated data tree result to .CSV file.
- **Export Analyse Log...** - Exports the analysis (Analyze) error logger results to a text file.
- **Export Generated Log...** - Exports the generated (Analyze and Create, Create Differences) error log to a text file.

**Buttons**

- **Apply** - Saves the changes (optional modifications) done in Editor Tree view, Analyze tree
- **Cancel** - Cancels the current action.
Check Reservation - Opens the reservation dialog window with reservation details of project, applications, and diagrams.

Check Box

- **Generate Configuration Data** - Automatically starts the configuration data generation if Analyze and Create / Create Differences menu items are activated.

Views and Modifiers

The result of the analysis is presented by a tree view in three different views:

- Senders (default), supported modifiers: Actual Analyze (default), Differences, Generated Data.
- Receivers, supported modifiers: Actual Analyze (default), Differences, Generated Data.
- Variables, supported modifiers: Actual Analyze (default), Generated Data.

*Figure 324. MMS Editor Displaying Sender View*
The default **Sender view** lists the applications which contain diagrams with output diagram references (as senders of cross communication). An additional sender diagram gets created and named as displayed in parenthesis:

- Below this new sender diagram the created access variables are displayed together with the collected global variables. The current message size of this access variable that is based on the data types of the global variables gets displayed, too. Later during creation of MMS diagrams the required data types of these Access Variable are created inside the required applications as application defined data types.

- Furthermore the MMS receiver applications belonging to a MMS sender are listed. These are the applications which contain diagrams with input diagram references (as receivers of cross communication data). An additional receiver diagram gets created and named as displayed in parenthesis. Its children are the global variables read by this receiver diagram and corresponding access variable. The global variables read are sorted by the calculated default cycle time (calculation depends on connected tasks of original sender and receiver diagram, default can be changed, see below.

The other views for receivers and variables are displayed in a similar way, starting with receiver diagrams or variables respectively.

It is recommended to work with the default sender view.

The views can be modified using the modifiers:

- Generated Data
  Shows the result of the analysis tree of the last creation of MMS communication. Editing in the tree is not allowed.

- Actual Analyze
  Shows the result of the current analysis tree. Editing in the tree is allowed.

- Differences
  Shows the differences between the already generated data and the current analysis tree data.

Icons in the tree are marked if modified, deleted or additionally appearing, see Figure 325. Editing in the tree is not allowed.
Tool tips get displayed for applications or global variables:

**Figure 325. Icons Within the Differences Tree**

**Figure 326. Tool Tip for a Global Variable**

**Editing in the Actual Analyze Result Tree**

Modifications edited in the analysis result tree are overwritten by a next analysis and have to be re-edited afterwards if they are still needed.
Only an experienced user should do any modifications at all.

Inside the MMS editor the following modifications are supported if modifier Actual Analyze is switched on:

- **Rename**
  - MMS sender diagram(s)
  - MMS receiver diagram(s)
  - Access variable(s).

Press the F2 key or left click in the name field or right click on parent tree node.

Do not re-name access variables in MMS Editor, and give name manually created access variables according to the default scheme S_MMS.

- **Change cycle time.** Press the F2 key or left click on the Cycle Time tree node field.

Following are the recommendations for optimal MMS communication:

- The task interval on the receiver side (generated R_MMS diagram) should be at least twice as fast as (half of) the cycle time parameter on the MMSReadCyc block.

- The task interval of the sender side (generated S_MMS diagram) should be double of the receiver side task interval, which means equal to the Cycle Time parameter for MMSReadCyc block.

- **Add new access variable** nodes by right mouse click on parent tree node.
A new access variable is empty (message size 0 bytes). The message size is calculated when variables to be transferred via this access variable are moved below it, see Move variables described below.

- **Add new cycle time** nodes by right mouse click on parent tree node.
- **Move variables** between access variables or between cycle times. The new message sizes are shown at the changed access variables.

Create MMS results in an error if an access variable becomes empty after moving its variables to some other access variables.

It is not possible to move variables using ControlConnection variables.
Delete empty access variables or empty cycle times. Right click on tree node.

Print the tree: The tree gets printed by pressing ‘CRTL+F5’ keys.

Expand the tree by selecting a node and pressing the ‘CRTL+ right arrow’ keys. Collapse the tree by pressing the ‘CRTL+ left arrow’ keys.

Copy the tree into the clipboard (as *.emf format): Press ‘CRTL+F6’ keys. (Advantage of the *.emf format: Text inside the picture can be edited.)

Click Apply to save the modifications.

Analyze and Create

All required MMS sender and receiver diagrams, access variables, and necessary data types of access variables are generated after analysis.

Figure 328. Moving a Variable From one Access Variable to Another one
The additional created diagrams are placed below the object which contains the CrossCommunication aspect in the Functional Structure and below the corresponding applications in Control Structure.

Figure 329. Control Structure and Functional Structure after MMS Creation
Default naming is done according to Table 60.

**Table 60. Default Naming done by Create MMS**

<table>
<thead>
<tr>
<th>Item</th>
<th>Sender Side</th>
<th>Receiver Side</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top Object</td>
<td>CrossCommunication_&lt;startingObjectName&gt;</td>
<td></td>
<td>Object with CrossCommunication aspect in Functional Structure, also placed in Control Structure</td>
</tr>
<tr>
<td>Object</td>
<td>S_MMSCom_&lt;sn&gt;</td>
<td>R_MMS_&lt;applicationname&gt;_&lt;rn&gt;</td>
<td>sn Sender Number</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>rr Receiver Number</td>
</tr>
<tr>
<td>Diagram</td>
<td>S_MMSCom_&lt;sn&gt;</td>
<td>R_MMS_&lt;applicationname&gt;_&lt;rn&gt;</td>
<td></td>
</tr>
<tr>
<td>Access Variable</td>
<td>S_MMSCom_&lt;sn&gt;<em>AV</em>&lt;avn&gt;</td>
<td></td>
<td>avn Access Variable Number</td>
</tr>
<tr>
<td>Data Type of Access</td>
<td>S_MMSCom_&lt;sn&gt;<em>AV</em>&lt;avn&gt;_DT</td>
<td></td>
<td>application specific</td>
</tr>
<tr>
<td>Variable</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Variable for Valid</td>
<td>R_MMS_&lt;applicationname&gt;_&lt;rn&gt;_V</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Flags</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Type of</td>
<td>R_MMS_&lt;applicationname&gt;_&lt;rn&gt;DT</td>
<td></td>
<td>application specific</td>
</tr>
<tr>
<td>Variable for Valid</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Flags</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Maximum Limit**: User needs to ensure that the maximum number of characters including the default name (listed in Table 60) that get appended for Diagrams and Access Variables are as provided below:

- Access Variable Name <= 21 Characters
- Sender Diagram Name <= 28 Characters
- Receiver Diagram Name <= 28 Characters
If the maximum limit exceeds, then the following warning message appears:

*Diagram Names are exceeding the limit of 28 characters: <Diagram Name> Please check.*

The actual names of the created diagrams are related to the names configured in the MMS editor after analysis and optional modifications. For each access variable an application defined data type is created with substructures composed of the data types of the global variables collected into that access variable:

![Diagram showing created data type for new access variable]

*Figure 330. Created Data Type for new Access Variable*

The following explanations are based on the use of function blocks MMSConnect and MMSReadCyc. ControlConnection variables are handled using control module MMSToCC accordingly.
An access variable is read by a MMSReadCyc function block. This function block contains a boolean Valid parameter indicating the result of the reading of that variable (the same port exist at the MMSConnect function block).

These both boolean values are combined and sent to the Valid port of the input diagram reference of the original receiver diagram. In order to do that, a structured variable is created that collects all these valid flags in order to get only one global variable per each receiver diagram. Thus this new variable of structured data type collects all single boolean valid parameters of all MMSConnnect and MMSReadCyc function blocks (one per receiver diagram).

This new data type is also created within the required application:

**Analyze and Create** MMS / Generate Configuration Data generates code that creates access variables by means of MMSDefAccVar. Therefore the access variables are not visible in the Access Variables editor of Control Builder M Professional. But it is visible only in the MMS variables window shown by Show MMS Variables as described in Download and go Online on page 586.
In the example of ReceiverDiagram1 there exist only one MMSReadCyc function block and one valid parameter which is collected into a structured data type and sent to the two input diagram references Valid ports.

**Alarm and Events**: Additionally the valid flags of the MMSConnect and MMSReadCyc function blocks are send to an AlarmCond function block in order to get communication errors in the Alarm and Event List.

*Figure 331. New Structured Data Type Containing Valid Flags*

In the example of ReceiverDiagram1 there exist only one MMSReadCyc function block and one valid parameter which is collected into a structured data type and sent to the two input diagram references Valid ports.

**Alarm and Events**: Additionally the valid flags of the MMSConnect and MMSReadCyc function blocks are send to an AlarmCond function block in order to get communication errors in the Alarm and Event List.
If the MMS Control Modules are modified due to MMS Create or Create Difference operation and the changes are downloaded to the controller, the following problems exist for those alarms:

1. The status of the active alarms does not change in the alarm list, when the alarm condition recovers to normal.

2. The existing unacknowledged MMS alarms cannot be acknowledged.

However, the new alarms appear normally along with the existing list. These alarms need to be manually deleted from the alarm list.

To prevent this situation, ensure that there are no alarms related to MMS, before performing the MMS Create or Create Difference operation.

Figure 332. Page 2 of a Generated Receiver Diagram Containing an AlarmCond

After the MMS creation the diagram reference symbol(s) on the original receiver diagram ReceiverDiagram1 show the current cycle time, see Figure 335.
Click **Cancel** to stop the creation process. Then the current transaction is finished and MMS creation is stopped. Diagrams already created are valid, but not all required ones are maybe available. Therefore a complete rerun is required afterwards in order to have a complete MMS communication generation.

### Create Differences

Execute **MMS > Analyze and Create** command to analyze and create the MMS CrossCommunication.

After successful execution of **MMS > Analyze and Create**, if the existing diagram is modified (e.g. adding / deleting cross references, changing data types, modifying Cycle Times or IP addresses), always execute **MMS > Analyze** before performing **MMS > Create Differences**. It is also possible to generate the differences by executing **MMS > Analyze and Create** command. However, this will take more execution time.

### Deletion of Obsolete MMS Diagrams

Altering the MMS configuration by deleting diagram references or disconnecting the diagram variables may result in obsolete MMS generated diagrams and datatypes.

These diagrams and datatypes are not deleted by **MMS > Analyze** or **Analyze and Correct in Depth** followed by **MMS > Analyze and Create** or **MMS > Create Differences**.

Perform the following to delete the obsolete diagrams and datatypes:

- **If MMS > Analyze and Create** is used:
  Execute **MMS > Clear Generated Data** before executing **MMS > Analyze and Create** or **MMS > Analyze and Correct in Depth** followed by **MMS > Analyze and Create**.

- **If MMS > Create Differences** is used, perform either of the following depending on the scenario:
  a. In case, cross communication happens between a sender diagram and receiver diagram across applications, and the respective sender / receiver diagrams are not involved in communication with any other diagrams. A tool tip (see **Figure 333**) on the CrossCommunication object in the Sender
diagram’s **Differences** view provides the list of applications and variables that contain the obsolete MMS generated diagrams. User must navigate to the respective application and manually identify and delete the obsolete diagrams and datatypes individually.

![Figure 333. CrossCommunication between Single Sender and Receiver Diagram](image)

b. Incase, cross communication occurs between multiple sender and receiver diagrams across multiple applications, and the each sender / receiver diagram are involved in communication with other diagrams. The Sender diagram’s **Differences** view provides the list of applications and variables including the names of the obsolete MMS generated diagrams (see Figure 334). User must navigate to the respective application and manually delete the obsolete diagrams and datatypes individually.
Download and go Online

After downloading the project data into the controller(s) you can check the Valid ports at the MMS diagram references. Subscribe for live data and select the Valid ports for display, see chapter On-line Display on page 200.

Figure 334. CrossCommunication between Multiple Sender and Receiver Diagrams
Follow the steps to check the access variables in CBM:

1. Right-click the required controller and select **Remote System**.
2. Click **Show MMS Variables**.

All MMS access variables corresponding to the selected controller are displayed in the **MMS Variables** window (refer to Figure 336).

*Figure 335. Diagram Reference Shows 375 ms Cycle Time for MMS*
By adding an **Alarm and Event List** aspect to your project or by using an existing one you can also verify correct behavior of MMS communication. In case of communication failures alarms indicating the corresponding receiver and sender gets generated.

*Figure 336. MMS Access Variables of Controller_2*

*Figure 337. Alarm and Event List in Case of MMS Communication Failures*
Aspect Verbs of CrossCommunication Aspect

The CrossCommunication aspect supports additional aspect verbs:

- **Clear Generated Data** - All diagrams, global variables and application defined data types, created by the MMS CrossCommunication generator, will be cleaned. This will also be done automatically if you restart the generator for a second run.

  Before performing **Clear Generated Data**, check the reservation details of all the MMS related application / Function Diagrams using the **Reserved by** option in the **Find** Tool. Release the relevant reservations performed by other users and then perform **Clear Generated Data**.

- **Generate Configuration Data** - If the user started creation by **MMS > Analyze and Create** without checking the check box Generate Configuration Data, then generation can be started by this aspect verb for all generated MMS diagrams (This step is necessary in order to transfer all configuration data into CBM for download).

- **Show Log File** - During the analysis or during the MMS creation step, you can see what is actually going on inside the error logger list box. When the run is finished, this list box shows the errors, but the content of this box is not saved.
If you want to see the errors again, you can open the XML log file for the whole process and search for errors.

Click “CRTL + F5” keys to print the Cross Communication Aspect window.

The results of **Analyze** and generation can be exported to .csv files, read into Excel, and also printed in tabular layout.

**Current Limitations**

- Generation of MMS cross communication is supported only for diagram references between diagrams. Connections between different allocatable groups allocated to different applications on one diagram are not supported.
- Only MMS communication is supported, other protocols have to be configured manually.
- Only function blocks MMSDefAccVar, MMSConnect and MMSReadCyc and control modules CCToMMS and MMSToCC from the MMSCommLib are actually supported.
- Connection to multiple output diagram references in different applications having same diagram variable name is not supported.
- If user is configuring the Root level Cross Communication object, there should not be any cross communication objects in Control Network and Project level. Otherwise this might lead to some inconsistency while creating the MMS Diagram and its variables.
- Do not use S_MMS or R_MMS in the naming convention. Manually created cross communication data types and diagrams under cross communication object having name starting with S_MMS, R_MMS will get deleted while generating cross communication using MMS Cross Communication aspect.
- Bidirectional MMS CrossCommunication is limited to ControlConnection data type. Function Designer does not support CrossCommunication using diagram references having data types that has InOut directions.

**Outdated MMS Cross Communication Data**

If you have finished MMS cross communication generation, and change afterwards the original sender or receiver diagram with a MMS relevant change, for example
delete a diagram reference, then the generated MMS diagrams are marked **outdated**, which can be seen within the system status viewer (for example added on Control Project level). The outdated diagram state is also indicated in the diagram’s status bar, see **Diagram States and Transitions** on page 162.

In Function Designer, if the user changes any MMS relevant data within the hardware tree after finishing the generation of MMS cross communication, for example, connect application to another controller, change an interval time, change connected tasks, or change the IP addresses, MMS CrossCommunication must be regenerated through **MMS > Analyze and Create**. The system does not inform the user that CrossCommunication must be regenerated.

![Figure 339. System Status Viewer After Deletion of a Diagram Reference in Sender Diagram](image)

**Template Settings**

It is possible to change the template settings (from e.g. A4 portrait to Letter portrait) for the diagrams which will be generated for MMS communication: This can be done by opening the Function MMS Receiver Template aspect of the MMS Receiver Diagram object in Object Type Structure (same for MMS Sender Diagram Object), see **Figure 340**.
Other changes must not be done in the Function MMS Receiver Template aspect and the Function MMS Sender Template aspect, which will affect the MMS CrossCommunication generator.

**Figure 340. MMS Templates in Object Type Structure**

### Number of Input Ports

MMS_Read/Write Function Blocks have an extensible number of inputs. If the Function Block is created with the max. value (32), the symbol does not fit on an A4 portrait page. Add a component template with smaller fonts and less port distance to the MMS_Read/Write object types.

### Control Application Allocation Change

MMS communication: There is no message when control application allocation is changed.
It is possible to download code even though the cross communication is not consistent. Create cross communication again after allocation changes.

Export / Import of MMS Generated Function Diagrams from Engineering System to Production System

The following export / import procedure assumes:

- that the dependencies of the Function Diagram are already fulfilled except for new placements to be done on the target system: All required system extensions are loaded, all user defined libraries and object types are available, the target Control Project is available and the needed libraries are connected to the target Control Application.

- that MMS Cross Communication already exists in both the Engineering system and Production system.

Follow the steps to import the additional MMS generated diagrams from Engineering system to Production system:

1. In Engineering system, click Launch Import Export tool.
2. Drag and drop the CrossCommunication object or MMS Receiver and MMS Sender diagrams to the Import / Export window.
3. Select Include dependencies check box in the appeared Add Items window.
4. Click OK.

The Adding items… window appears with a progress bar that indicates the process. The Finished adding items window appears when all the items have been added.

5. Click Done in the appeared Finished adding items window.
6. Click Save and provide a path and file name in the Save import/export file window.
7. Click Done in the appeared Finished saving file window.
8. In the Import / Export - <file name>.afw window, select Production from the drop-down list.
9. Click File > Open.
Multiple Allocatable Groups and Multiple Code Blocks

Appendix A Restored Functionalities

10. In the Open import/export file window, browse to and select the file saved in
Step 6.
11. Click Done in the appeared Finished loading file window.
12. Click Differences.
13. In the Show Differences dialog box, select Production in the Environment
drop-down list.
Ensure that all the differences between the Engineering system and the Production
system are listed.
14. Click Import All to import all the objects and aspects available in the Function
Diagram.
15. In the Import objects and aspects dialog box, select Production in the
Environment drop-down list.
16. Click Finish.
The Importing <file path>\<file name>.afw… window appears with a progress
bar that indicates the process.
17. In the Replace Existing Function Block Type window, select the Apply to all
check box and click Yes that appears during the import.
18. Click Done.
It is recommended to always perform MMS > Analyze to ensure that all the
additional MMS generated diagrams are imported from the Engineering system
to the Production system.

Multiple Allocatable Groups and Multiple Code Blocks
Mapping Aspect Objects
Each allocatable group can belong to only one Function Diagram. It is not possible
to assign logic of different Function Diagrams into the same allocatable group. A
Function Diagram can have nested components with its own Function Diagrams
(and own allocatable group aspects). If function component objects of different
Function Diagrams have to be located in the same task on the same controller, they

594

3BDS011224-600 C


are allocated each of them in an own allocatable group. It is possible to allocate several allocatable groups to the same task.

For AC 800M controllers, each allocatable group creates a single control module (SCM) or an I/O signal.

**Grouping Function Components into Allocatable Groups**

If the user wants to split the logic of one function diagram, in order to distribute the function components into different locations later on, it is possible to create additional allocatable groups, which will lead to generic objects with an allocatable group aspect. This allocatable group aspect will act as folder object. These folder objects appear as child objects of function diagrams in the plant explorer’s Functional Structure.

The function components in a diagram can be split into several allocatable groups:

- **Splitting Function Diagram Logic to Several Allocatable Groups:**
  If the user wants to split the logic in order to allocate it to several tasks, controllers or applications, user has the possibility to create allocatable groups for assigning the different parts of the function diagram to different allocatable groups.
Creation of allocatable groups means creation of generic objects having an allocatable group aspect. These generic objects appear as child objects below the object containing the function diagram and they act as folder objects.

If the control logic of a function diagram is to be assigned (split) to several allocatable groups in order to allocate the control logic parts to different tasks, applications, or controllers, do the following:

1. **Create a new allocatable group inside Function Designer**
2. **Grouping function components inside Function Designer**

From 800xA 5.1 onwards, newly created Function Diagrams do not support multiple allocatable groups.

**Create a new allocatable group inside Function Designer**

1. Open the Function Diagram whose logic shall be split to several allocatable groups.
2. Choose the menu command **Allocation > New Allocatable Group**, or the corresponding button in the Allocation toolbar. The **Create Allocatable Group** dialog is opened.
3. In the **Create Allocatable Group Dialog**, enter a name for the new allocatable group in the **Name** field and a short name in the **Short Name** field. Optionally, you can also choose a color for indicating all function components assigned to this new allocatable group.
4. Click **OK**.

The created allocated object is located as child object below the function diagram object in Functional Structure. It can be seen as folder object to separate parts of the logic of a function diagram.

**Create Allocatable Group**

Use the **Create Allocatable Group** dialog to create a new, additional allocatable groups. Access this dialog via the **Allocation > New Allocatable Group** menu command, or via the Allocation toolbar.
Name

Enter a name for the new allocatable group object. This name equals the aspect objects Name aspect.

Short Name

Enter a short name for the new allocatable group. If any, the short name gets displayed in the Allocation toolbar, in the Data Flow Order dialog, and in the diagram when showing allocation details via the document reference $AllocGroup.

Color

Click on the arrow down to open the color palette and choose the wanted color by clicking on it.

If there is not offered an appropriate color, click Other to open the Color dialog offering the whole color palette of the system. The selected color gets optionally displayed in the diagram when showing allocation details.

Exclude from Configuration Data Generation

This allocatable group is to be excluded from configuration data generation.
Grouping function components inside *Function Designer*

Follow the steps to assign function components to an allocatable group inside *Function Designer*:

1. Select one or more function component(s) inside the function diagram.
2. Choose main menu item *Allocation > Allocation Grouping* or the component *Allocation Grouping*.
3. The dialog **Destination Group** is opened. Select an allocatable group and click **OK**.
4. Selected function component aspect objects get automatically moved in Functional Structure and located as child objects of the corresponding allocatable group, see **Figure 344**.

**Figure 343. Destination Group Dialog**

- **OK**
  
  Click **OK** to save your settings and to close the dialog.

- **Cancel**
  
  Click **Cancel** to quit the dialog without saving your setting modifications.
Assigning Function Components of Different Function Diagrams to One Task

An allocatable group belongs to one function diagram only. Therefore, it is not possible to group function components belonging to different function diagrams into the same allocatable group folder in order to assign them to the same task in the same application.

If you want to get such a kind of allocation, you have to create separate allocatable groups within all these function diagrams and allocate all of them later on to the...
same task. The following figures displays an example for wrong and correct grouping of function components:

**Figure 345. Wrong Grouping of Function Components**

```
Function diagram 1
  Function component 1.1
  Function component 1.2

Function diagram 2
  Function component 2.1
  Function component 2.2
```

**Figure 346. Correct Grouping of Function Components**

```
Function diagram 1
  Function component 1.1
  Function component 1.2

Function diagram 2
  Function component 2.1
  Function component 2.2
```

**Grouping Child Function Diagrams**

**Figure 347** shows an example of a function diagram, whose function component **Flow Control** represents a child function diagram. The child function diagram is shown in **Figure 348**:
Figure 347. Function Diagram
Copying Function Components and Allocatable Groups

Note the following features on copying function components (Aspect Objects and/or symbol objects):

- If you copy and paste a function component Aspect Object inside the Functional Structure and the parent of the target object has a function diagram, this function component is automatically inserted into this function diagram.

- If you copy and paste a complete allocatable group, you will get a new allocatable group with all child function components (Aspect Objects and symbol objects). These objects are automatically inserted into the corresponding function diagram.

Figure 348. Child Function Diagram

See Allocating Child Function Diagrams on page 623.
• If you copy and paste function components inside a function diagram (Diagram view), the function components are assigned to the active allocatable group (see Figure 349).

![Figure 349. Copying Inside Function Designer](image)

**Code Block Generation**

Function Designer generates at least one code block for each Function Diagram. In case of Function Diagrams with Control Modules, the code blocks are created as explained below:

1. Based on the assigned data flow order, add the first function/function block to a code block and include additional functions / function blocks until the occurrence of a Control Module.

2. Create a new code block for the Control Module.
3. Create a new code block and add the next functions / function blocks after the Control Module until the next occurrence of a Control Module in the data flow order.

4. Repeat step 2 and 3 until the end of the data flow order.

*Figure 350. Code Block Sorting*

In *Figure 350*, the dataflow order is defined from 1 to 9.

Code block splitting happens as shown in the *Table 61*:

*Table 61. Code Block Splitting Details*

<table>
<thead>
<tr>
<th>Data Flow Order</th>
<th>Function Block / Control Module</th>
<th>Code Block</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Function A</td>
<td>Code Block A</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Control Module A</td>
<td>Code Block B</td>
<td>Data flow order 2 is assigned to a control module (Control Module A). A new code block is created.</td>
</tr>
<tr>
<td>3</td>
<td>Function Block B</td>
<td>Code Block C</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Function G</td>
<td>Code Block C</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Function Block F</td>
<td>Code Block C</td>
<td></td>
</tr>
</tbody>
</table>
Function Designer generates a new aspect property named `NewCodeBlock` for every element which could generate a new code block.

**Creation of New Code Blocks**

In Diagram view, choose Allocation > Data Flow Order to open the Data Flow Order in Allocatable Group dialog. For Function Diagrams created prior to 800xA 5.1 and for diagrams restored to 800xA 5.1, right-click the required component and select New Code Block. Provide a Code Block Name in the Code Block dialog, and click OK. The selected component is assigned to the new code block.

**Edit Existing Code Blocks**

Right-click the component which is already assigned to a code block and select Edit Code Block. Edit the Code Block Name in the Code Block dialog, and click OK. The selected component is assigned to the newly named code block.

**Delete Existing Code Block**

Right-click the component which is already assigned to a code block and select Delete Code Block to delete the required code block.

---

Table 61. Code Block Splitting Details

<table>
<thead>
<tr>
<th>Data Flow Order</th>
<th>Function Block / Control Module</th>
<th>Code Block</th>
<th>Reason</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Control Module B</td>
<td>Code Block D</td>
<td>Data flow order 6 is assigned to a Control Module (Control Module B). Hence, a new Code Block is created.</td>
</tr>
<tr>
<td>7</td>
<td>Function E</td>
<td>Code Block E</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Function Block C</td>
<td>Code Block E</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Function Block D</td>
<td>Code Block E</td>
<td></td>
</tr>
</tbody>
</table>
Code Block Sorting

To get an optimal execution order, code blocks created by the Function Designer are sorted by the Control Builder compiler while downloading them to the controller.

For more details on code block sorting, refer to *System 800xA Control 5.1 AC 800M Planning (3BSE043732*)*.

Loops in Control Modules

The compiler sorts the execution order of code blocks based on the data flow between code blocks. Circular data flow between code blocks form a loop.

When a loop is detected between a set of code blocks, those code blocks are sorted in a random order. Downloading such randomly sorted code blocks to the controller along with the loop may cause undesired execution behavior in the controller.

Compiler Switches

To detect the loops before downloading them to the controller, set the compiler switch **Loops in Control Modules** to either **Warning** or **Error** for all control projects. This provides a text file with the information of the code blocks that form the loop.

If the compiler switch is set to:

- **Warning** - control projects are downloaded to the controller even when a loop is detected.
- **Error** - control projects are not downloaded to the controller when a loop is detected.
Appendix A  Restored Functionalities  Grouping Function Components into Allocatable Groups

Resolving Loops

The following scenarios can cause loops in Single Control Modules:

- Two code blocks read and write values to the same variable.
- Circular data flow between code blocks.
- User defined Control Module type is created in Control Builder and a port (For example, Out port) is configured to read and write from a connected Control Module.

Scenario 1: Two Code Blocks Read and Write Values to the Same Variable

Figure 352. Two Code Blocks Read and Write to the Same Variable
In Figure 353, code block 1 reads Max, Min, and Unit from the variable and writes Value to the variable in code block 2. Code block 2 writes Max, Min, and Unit to variable and reads Value from the variable. A loop is created due to the circular dataflow between the code blocks, as shown in Figure 354.

Variables do not belong to any code blocks.

To resolve this loop, create a new code block from the Move block as shown in the Figure 355:
Follow the steps to create a new code block:

1. Launch the **Data Flow Order in Allocatable Group** dialog window.
2. Right-click the respective block (Move block) from the list and select **New Code Block**.
3. Enter the new code block name.
4. Click **OK**.
5. Click **Apply**.

The newly created code block resolves the loop formation as the read-write operation is now handled by two different code blocks, as indicated in Figure 356.
Scenario 2: Circular dataflow between codeblocks

In Figure 358, circular dataflow occurs between code block 1 and code block 2. In this scenario, the code blocks are formed due to the presence of the AnalogInCC control module between the OR and TOn blocks.

This can be resolved by moving the AnalogInCC control module towards right (as shown in Figure 359) and generating the data flow order. This change in logic combines code block 1 and code block 3 (refer to Figure 359) and eliminates the loop in the logic.
Scenario 3: Forward and Backward Communication between Control Modules

In some instances, user defined control modules are configured to write and read from another control module through the same port, as indicated in Figure 360. Each control module forms a code block. This also creates a loop in the logic.

Figure 359. Resolving Circular Dataflow Between Code Blocks

Figure 360. Forward and Backward Communication between Control Modules

It is always recommended to avoid such configurations in user defined control modules, which may create forward and backward data flow between connected control modules.

Showing Allocation Details

User can view and print allocation details and data flow order through function diagram.
Border color and short name of an allocatable group can be set through the Color and Short Name property of the allocatable group aspect.

The allocatable group details and data flow order of a function component can be displayed by any text or label component using the field codes:

- $AllocDetails
- $AllocGroup
- $Order

**To define allocation details**

1. Open the required function diagram.
2. Choose the menu command **Allocation > Allocate Diagram** or click the icon of the Allocation toolbar. The allocation details are shown in the function diagram.

![Show Allocation Details](image)

*Figure 361. Showing Allocation Details*

**Vertical Navigation**

For a better overview on Function Diagrams, it is possible to built a hierarchical Functional Structure with parent-child diagrams. Functions on a lower level can be summarized in a separate diagram and displayed in an overview diagram on a higher level as a single function component with input and output ports / parameters. Diagrams on lower level are also called child or nested diagrams. They can be opened from an overview diagram by choosing **View > Goto Child Diagram** or **Goto Child Diagram** from the context menu. This is also called vertical navigation - top down, bottom up, throughout the functional hierarchy.
Inputs and outputs of child diagrams are function components of type [Object Type Structure]Object Types/Functional Planning/Generic Function Components/Connectors/Diagram Parameters/Input (Output, Inout) Parameter:

User can apply diagram parameters to:

- Child diagrams in Functional Structure, see Figure 363 and
- Diagram types in Object Type Structure.
  For more information on diagram type, refer to System 800xA Engineering, Function Designer Getting Started (3BDS100968*).

In Figure 363, an overview diagram D0 and two child diagrams D1 and D2 are available. The diagram parameters D1:In1, D1:In2, D1:Out and D2:In, D2:Out

- are accessible as aspect properties in diagram D0 and
- are visible as ports in overview diagram D0.

Thus they can be connected in the overview diagram as any other ports. Diagram Parameter connections are visible in the overview diagram, not in the child diagrams.
If there is no component view defined for a child diagram, a symbol is automatically created on base of the default component template. However you can also define your own symbol for child diagrams:

1. Create a Component view for the child diagram to be customized.
3. Draw your customized symbol with corresponding ports.
4. Name the ports exactly as the diagram parameters.

On configuration data generation, the diagram parameter description is copied to the corresponding control module / single control module parameter.

User can apply any Control Builder parameter keyword in the diagram parameter description as IN, OUT, IN(OUT), OUT(IN), NODE, or EDIT. Control Builder expects that control module:

- input parameter starts with description 'IN' or 'IN(OUT)'
- output parameter starts with description 'OUT' or 'OUT(IN)'
- inout parameter starts with description 'NODE' or 'EDIT' or any string other than a keyword.

The diagram parameter description gets displayed as tooltip at the corresponding port of the child diagram.

User can define **initial values** at the **Value.InitVal** aspect property of the diagram parameter.
In Horizontal navigation, user can combine diagram references and diagram parameters in one diagram.

Generating the Configuration Data of a parent object must be done before generating the Configuration Data of a child object.

Figure 363. Child Diagrams
Variable Creation

In Control Builder M, variables are used for connections within child diagrams (vertical navigation). If there are connections across child diagrams / nested allocatable groups, the Diagram parameter objects are used and the following variables will be used:

Table 62. Diagram Parameter\(^{(1)}\)

<table>
<thead>
<tr>
<th>Target (outside AG)</th>
<th>Diagram Parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>FB</td>
<td>Parent-SCM:Var</td>
</tr>
<tr>
<td></td>
<td>SCM: Parameter</td>
</tr>
<tr>
<td>CM</td>
<td>Parent-SCM:Var</td>
</tr>
<tr>
<td></td>
<td>SCM: Parameter</td>
</tr>
<tr>
<td>FUN</td>
<td>Parent-SCM:Var</td>
</tr>
<tr>
<td></td>
<td>SCM: Parameter</td>
</tr>
</tbody>
</table>

(1) The abbreviations are described in Table 12

Table 63. Diagram Parameter\(^{(1)}\)

<table>
<thead>
<tr>
<th>Target (outside AG)</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Parent-SCM:Var</td>
<td>Parent-SCM:Var</td>
<td>Parent-SCM:Var</td>
</tr>
<tr>
<td></td>
<td>SCM: Parameter</td>
<td>SCM: Parameter</td>
<td>SCM: Parameter</td>
</tr>
</tbody>
</table>

(1) The abbreviations are described in Table 12

Explicitly and Implicitly Defined Variables

Data Flow Order of variable/parameter/reference. The combo box Data Flow Order Insert Before lists all function components of the current allocatable group.
Select the function component before which the variable/parameter/reference shall be located. Select **at the end of the Allocatable Group** if you want the variable/parameter/reference to be located at the end of the current allocatable group. The combo box **Data Flow Order Insert Before** is visible at creation time of the variable/parameter/reference only. If you want to change the data flow order of the variable/parameter/reference later use the **Data Flow Order** dialog.

The Data Flow Order of variable/parameter/reference influences the order of execution of MOVE functions implicitly inserted into a Function Diagram and generated into corresponding code blocks by Function Designer in cases as:

- Mapping of structured variables of different data types.
- Connection of variables to other variables (diagram references etc).
- Connection to the "old" values in own code block, if using the state attribute.

**Labelling Split Connections**

If the logic of a function diagram is assigned to several allocatable groups, so that a connection link between two or more function components is split, a communication object is needed in **Control Builder M** to hold the connection. This communication object will be a variable (output of the allocatable group) corresponding to single control module parameters of **Control Builder M**. The variable is created automatically on allocating the allocatable groups to the Control Structure respectively to **Control Builder M**.

The name of the variable depends on whether the connection line in the function diagram has a label or not:

- If you have given a unique label to the connection line (see **Inserting Label Components** on page 396), the variable will get the name of that label.
- If you have not given a label to the connection line a unique default label will be created automatically by the **Function Designer** itself. Then, the name is composed of: “__”+“Out”+[ordered number] (for example, “__Out1”)

**Figure 364** shows an example for splitting a connection line between two directly connected function components grouped into two different allocatable groups.
On allocating the allocatable groups **Allocatable Group1/2**, for the split connection line **Label1**, a variable with the same name **Label1** is created connecting the single control module (SCM) parameters **__Out1** and **__In1**:

*Figure 364. Splitting of Connected Function Components*
## Building up Control Structure

The Control Structure gets automatically updated, see Table 64.

### Table 64. Changes in Control Structure

<table>
<thead>
<tr>
<th>Change in Function Diagram or Functional Structure</th>
<th>Change in Control Structure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instantiate/copy/delete function or procedure</td>
<td>none (SCM gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete function block or control module as symbol object</td>
<td>none (SCM gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy function block or control module as aspect object</td>
<td>Function block or control module gets inserted below diagram / allocatable group (SCM)</td>
</tr>
<tr>
<td>Delete function block or control module aspect object in diagram</td>
<td>Function block or control module gets deleted from diagram / allocatable group (SCM)</td>
</tr>
<tr>
<td>Delete function block or control module aspect object in Engineering Workplace Advanced Menu <strong>Delete from All Structures</strong></td>
<td>Function block or control module gets deleted from diagram / allocatable group (SCM)</td>
</tr>
<tr>
<td>Delete function block or control module aspect object in Plant Explorer object browser</td>
<td>none. You need to manually remove the instance from the Control Structure.</td>
</tr>
<tr>
<td>Instantiate/copy/delete CBM IO signal</td>
<td>none (SCM/application get updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete diagram parameter</td>
<td>none (SCM gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete diagram reference and connect to diagram variable</td>
<td>none (SCM/application get updated on configuration data generation)</td>
</tr>
<tr>
<td>Instantiate/copy/delete local variable</td>
<td>none (SCM gets updated on configuration data generation)</td>
</tr>
<tr>
<td>Copy/paste diagram objects</td>
<td>Creates a copy of diagram and put it into the same CBM application. (IO signals need to be reallocated to appropriate hardware units)</td>
</tr>
</tbody>
</table>
After having defined the data flow order within the allocatable groups, you can allocate the function diagram logic to a specific application. The following requirements must be fulfilled:

- *Control Builder M* (CBM) has to run
- The corresponding CBM project has to be opened

The insertion of allocatable groups from the Functional Structure into the Control Structure can be done through the Allocate button in the Allocatable group’s aspect page. User can also use BDM.

1. Open the Functional Structure and navigate to the allocatable group to be allocated.
2. Open its allocatable group aspect.
3. Select the **Allocate** button.

### Table 64. Changes in Control Structure (Continued)

<table>
<thead>
<tr>
<th>Change in Function Diagram or Functional Structure</th>
<th>Change in Control Structure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creates a copy of Functional Structure with same parent</td>
<td>Copy/paste diagram objects (IO signals need to be reallocated to appropriate hardware units)</td>
</tr>
<tr>
<td>Create copies of related diagrams with same parents</td>
<td>Copy/paste application (IO signals need to be reallocated to appropriate hardware units)</td>
</tr>
<tr>
<td>Delete diagram object</td>
<td>Diagram object gets deleted from Control Structure and CBM (and vice versa)</td>
</tr>
<tr>
<td>Allocate diagram / allocatable group</td>
<td>Diagram / allocatable group (SCM) gets moved from unallocated application to corresponding CB application</td>
</tr>
<tr>
<td>Generate configuration data</td>
<td>Nested (still unallocated) children get moved to corresponding CB application</td>
</tr>
<tr>
<td>Unallocate diagram / allocatable group</td>
<td>Diagram / allocatable group (SCM) gets moved from CB application to unallocated application</td>
</tr>
</tbody>
</table>
4. The **Allocate** dialog is opened.

![Allocate Diagram to Control Builder Application in Control Structure](image)

*Figure 365. Allocate to Control Builder Application in Control Structure*

The allocation of the allocatable groups initiates the following actions:

- Control Structure aspect and Single Control Module aspect is added to the allocatable group object.

- Control modules and function blocks are allocated, i.e. moved from the CBM unallocated application to the selected application.

- Same holds for child function diagrams.

Depending on the allocatable groups defined in the Functional Structure and depending on the intended allocation within the Control Structure, one of the following allocation variants is possible:

- **Allocation of a Whole Function Diagram**

- **Allocation of Parts of a Function Diagram**

**Allocation of a Whole Function Diagram**

If no extra allocatable groups have been created for a function diagram in the Functional Structure, the allocatable group contains the whole function diagram.

The allocated diagram gets a single control module aspect in the *Control Builder M.*
Allocation of Parts of a Function Diagram

If extra allocatable groups have been created for a function diagram in the Functional Structure (each allocatable group contains a part of the function diagram), you have two possibilities to allocate the allocatable groups to applications:

- You allocate the allocatable groups into different control applications. Then, you will get a single control module for each allocatable group object (see Figure 367, left).
- You allocate the top level object containing the function diagram to a control application. You will get a single control module for the top level object and additionally single control modules for each allocatable group object (see Figure 367, right).
Allocating Child Function Diagrams

It is possible to nest function diagrams within other function diagrams. Nesting means that a function component of a function diagram contains an own (child) function diagram (see function components FC2 and FC6 in Figure 368).
The whole logic of a function diagram (inclusive the logic of all child function diagrams) has to be allocated to the same application. Only the function diagram on the highest level has to be allocated (see MyFDD containing the function

Figure 368. Child Function Diagrams
components FC1, FC2, FC3 in Figure 369).

![Figure 369. Child Function Diagrams Assigned to one Allocatable Group (Within Functional Structure and Control Builder M)](image)

Every function component representing a nested function diagram becomes a nested single control module within *Control Builder M*.

**Connections between Allocatable Groups inside same Application**

Connections between allocatable groups always means we have to deal with two single control modules, one for each allocatable group; on both single control modules parameters have to be created: Parameter for source single control module S_SCM and target T_SCM and connect these single control module parameters with a global variable on application level.

If you have connections between allocatable groups, the following variables will be used:
Referencing Devices

HART Devices

After a function diagram has been IO allocated and configuration data generated, the IO variable created for the HART device can be referenced in another (or the same) function diagram:

1. Create a diagram reference of the data type given by the HART device.

2. Connect this reference to a variable by entering exactly the name of the IO variable created for this HART device. The variable you can look up in the control application, it is named according to the Name aspect or according to the Control Builder Name aspect.

### Table 65. Connections Between Allocatable Groups Inside Same Application

<table>
<thead>
<tr>
<th>Source (FB)</th>
<th>Target (outside AG)</th>
<th>FB</th>
<th>CM</th>
<th>FUN</th>
</tr>
</thead>
</table>

(1) If there are more than one action listed inside a cell, all of them are created.
3. Automatically the yellow part will show the control designation of the hardware channel.

Figure 370. Diagram Reference to an Existing HART Device I/O Variable

The connect to diagram variable part of the creation of diagram references can create a not yet existing application global variable. Therefore you can create the IO variable before doing device insertion, IO allocation and corresponding configuration data generation.

1. Create a diagram reference of the data type given by the HART device.
2. Connect it to a variable (this here means creation of this variable) named exactly according to the device to be inserted later.
3. Perform configuration data generation.
4. Later on: Insert the corresponding device with the already chosen name.
5. Perform IO allocation and corresponding configuration data generation. The existing variable is then identified via the Name or Control Builder Name aspect of the HART device.

As soon as the configuration data generation is done the control designation of the hardware channel will show up in the corresponding diagram reference symbol(s).

Synchronization between Control Builder Name aspect and Name aspect

Function Designer extensions enable synchronization between **Name** aspect and **Control Builder Name** aspect of an objects in 800xA System. In case engineering is not carried out using Function Designer, synchronization can be disabled by creating a new function setting.
The procedure to create new function setting is as follow:

1. Open **Engineering Workplace** and navigate to **Object Type Structure -> Function Planning -> Settings**, see [Figure 371](#).

![Figure 371. Settings in Object Type Structure](#)
2. Right-click on **Function Settings** and select **Config View**.

---

**Figure 372. Function Settings**
3. **Function Settings** dialog box appears.

![Function Settings dialog box](image)

*Figure 373. Function Settings Config View*
4. Click **Add** and select **Property After**.

*Figure 374. ADD Dialog Box*
The following dialog box is seen.

![Add New Property Dialog](image)

*Figure 375. Add New Property Dialog*

5. Enter the **Name**, **Readable permission**, **Writable permission**, **Value**, **Data Type** and **Deploy Scheme** as per figure.
Figure 376. Details Addition Dialog Box
6. Click **Ok**. A new property CBNameSync is added.

![CBNameSync Dialog Box](image)

**Figure 377. CBNameSync Dialog Box**

7. Click **Cancel** to revert the newly created setting.

8. Click **Help** to refer help at any point during the operation.

9. Click **Apply** to apply the newly created setting to the system.

10. Restart **Engineering Workplace** for the settings to take effect.

    Synchronization can be disabled by changing the setting **Value** to **False** from the **Main View** of the Function Settings aspect.
Appendix B  Diagram Upgrade

Function Designer Diagram Upgrade

Function Diagrams are instantiated with Function Blocks and Control Modules from the standard AC800M, or BU specific, or user defined libraries. As part of a new system version/revision these libraries may be updated and a newer version of the library replaces the older version in the Control Builder M Applications. Control Modules and Function Blocks of the new library version replace the older Control Modules and Function Blocks in the Function Diagrams, that are allocated to these Applications during the Control Builder M Project Upgrade.

In Control Modules or Function Blocks, if there are changes in Function Diagram such as, port direction and so on, then Configuration Data for Function Diagrams with instances of these objects must be generated again.

Until the 6.0 system version, this process had to be performed manually by opening individual Function Diagram and generating them if required. Function Diagram Upgrade automates this process in system version.

The Function Diagram Upgrade can also be carried out from the Engineering Workplace by navigating to Object Type Structure > Functional Planning > Settings > Upgrade.

Following are the prerequisites for the Function Diagram Upgrade:

- Engineering Workplace Service should be enabled.
- Function Diagram Upgrade should be done with 800xAInstaller account, or using an account who is a member of IndustrialITAdmin and local administrators.
- Control Builder M projects should be upgraded prior to the Function Diagram Upgrade.

The setting of the Function Diagram Upgrade in the workplace is as shown in the Figure 378.
On initiating the Function Diagram Upgrade a new Engineering Workplace opens up. Function Diagram Upgrade iterates through all the Function Diagrams under the root object of the Functional Structure and performs the upgrade.

If the Function Diagram Upgrade terminates for some reason, such as, in-sufficient memory etc., then the Engineering Workplace re-starts and the upgrade resumes from the point where it stopped last.
After the Function Designer Diagram upgrade:

1. All Function Diagrams are updated with objects from the updated libraries.

2. Configuration Data is generated for all the diagrams which are modified if the Generate Configuration Data During Diagram Upgrade (see Figure 378) is selected, else it does not generate.

The Function Diagram Upgrade process may take several minutes/hours till it is completed. Engineering Workplace may not be available for performing other operations.

During the upgrade/update process if a message appears, user needs to intervene and update as required.

During the upgrade/update process, the settings dialog box shows the status bar with the current diagram being upgraded and the progress in percentage (%), see
A log is generated and updated during the Function Diagram Upgrade. It can be accessed from the aspect **Function Upgrade Log**, or from the temp folder in the C drive. The location for the log created in C drive is C:\ProgramData\ABB\Engineering Studio\Function Designer\ logname.log. A
sample log is shown in Figure 380.

![Figure 380. A Sample Function Diagram Upgrade Log](image)

The following are the columns in the log, as shown in Figure 380:

- **Diagram Name**
  - Lists the full path of Function Diagrams which are under the root object in Functional Structure, that have been opened during Function Diagram Upgrade.

  If a Function Diagram name includes a comma (,), then the data in the log for that particular diagram may not be updated in correct format. For example, the data that needs to be updated under **Status Before Upgrade** column might get moved to the **Status After Upgrade** column.

- **Status Before Upgrade**
  - Shows the status of the Function Diagram before Function Diagram Upgrade. The value can be either “Modified” or “Generated”.

  Status of the diagram is Modified if the Function Diagram is not generated
and traffic signal status is Red.

Status of the diagram is Generated if the configuration data for the Function Diagram is generated and traffic light status is green/yellow.

- **Status After Upgrade**
  - Shows the status of the Function Diagram before Function Diagram Upgrade. The value can be either “Modified” or “Generated”.

Status of the diagram is Modified if the Function Diagram is not generated and traffic signal status is red.

Status of the diagram is Generated if the configuration data for the Function Diagram is generated and traffic light status is green/yellow.

For more information on Generated and Modified states refer Scenario 1 to Scenario 5.

If any of the Control Modules or Function Blocks have addition/deletion of mandatory ports after the Control Builder M project upgrade, then the traffic light status of the Function Diagram may not change. There may be errors relevant to the mandatory ports in Control Builder M during compilation and download of the project.

- **Generated**
  - Describes if the diagram was generated during upgrade or not. Possible values are:

    **YES**: There was a modification in the diagram during upgrade. As a result the diagram is generated.

    **NO**: There were no changes in the diagram during upgrade. As a result the diagram is not generated.

For more information on a YES or NO status refer Scenario 1 to Scenario 5.

- **Status After Generate**
- Displays status of the Function Diagram after generating the Configuration Data. Possible values are:

**Generated**: Diagram is generated without errors. traffic light status is green.

**Modified**: Diagram is not generated successfully and the traffic light status is red.

- Blank: In case the diagram is not generated.

For more information on a Generated or Modified status refer **Scenario 1** to **Scenario 5**.

- **Errors**
  - Displays the number of errors for a Function Diagram after generation of configuration data.
Scenarios

There are various scenarios for the Function Diagram Upgrade depending on the diagram generation. These scenarios explain whether the Function Diagram is generated or not. If it is generated, is it generated with errors or without. Following are the scenarios:

- Scenario 1
  - After upgrade there are no changes in the diagram. As a result, after upgrade, the status remains Generated. As part of the upgrade, diagram is not generated and column indicates NO. No errors are generated.

<table>
<thead>
<tr>
<th>Diagram Name</th>
<th>Status Before Upgrade</th>
<th>Status After Upgrade</th>
<th>GENERATED</th>
<th>Status After GENERATE</th>
<th>Errors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root/A1</td>
<td>Generated</td>
<td>Generated</td>
<td>NO</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Root/My_Upgrade_Tests/SFC_Basics/BASFM001_FD</td>
<td>Generated</td>
<td>Generated</td>
<td>NO</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 381. Diagram Upgrade Scenario 1

- Scenario 2
  - After upgrade there are changes in the diagram. As a result, after the upgrade, the status changes to Modified. As part of the upgrade, diagram is generated and column indicates YES. No errors are generated.

<table>
<thead>
<tr>
<th>Diagram Name</th>
<th>Status Before Upgrade</th>
<th>Status After Upgrade</th>
<th>GENERATED</th>
<th>Status After GENERATE</th>
<th>Errors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root/08- Engineering</td>
<td>Generated</td>
<td>Modified</td>
<td>YES</td>
<td>Generated</td>
<td>0</td>
</tr>
<tr>
<td>Root/08- Engineering</td>
<td>Generated</td>
<td>Modified</td>
<td>YES</td>
<td>Generated</td>
<td>0</td>
</tr>
<tr>
<td>Root/My_Upgrade_Tests/SFC_Basics/BASFM001_FD</td>
<td>Generated</td>
<td>Modified</td>
<td>YES</td>
<td>Generated</td>
<td>0</td>
</tr>
<tr>
<td>Root/08- Engineering</td>
<td>Generated</td>
<td>Modified</td>
<td>YES</td>
<td>Generated</td>
<td>0</td>
</tr>
<tr>
<td>Root/08- Engineering</td>
<td>Generated</td>
<td>Modified</td>
<td>YES</td>
<td>Generated</td>
<td>0</td>
</tr>
</tbody>
</table>

Figure 382. Diagram Upgrade Scenario 2

- Scenario 3
Before the upgrade there are changes in the diagram and the column indicates Modified. After the upgrade, there are changes in the diagram. As a result, after the upgrade, the status changes to Modified. As part of the upgrade, diagram is generated and column indicates YES. No errors are generated.

---

**Figure 383. Diagram Upgrade Scenario 3**

- Scenario 4
  - Before the upgrade there are changes in the diagram and the column indicates Modified. After the upgrade, there are changes in the diagram. As a result, after the upgrade, the status changes to Modified. As part of the upgrade, diagram is Modified and column indicates YES. There are errors generated.

---

**Figure 384. Diagram Upgrade Scenario 4**
Scenario 5

- After upgrade there are changes in the diagram. As a result, after the upgrade, the status changes to Modified. As part of the upgrade, the diagram is not generated and column indicates NO. There are no errors generated.

<table>
<thead>
<tr>
<th>CrossCommunication</th>
<th>Generated</th>
<th>Modified</th>
<th>NO</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>CrossCommunication</td>
<td>Generated</td>
<td>Modified</td>
<td>NO</td>
<td>0</td>
</tr>
<tr>
<td>CrossCommunication</td>
<td>Generated</td>
<td>Modified</td>
<td>NO</td>
<td>0</td>
</tr>
<tr>
<td>CrossCommunication</td>
<td>Generated</td>
<td>Modified</td>
<td>NO</td>
<td>0</td>
</tr>
</tbody>
</table>

Figure 385. Diagram Upgrade Scenario 5

After the Function Diagram Upgrade is complete, the upgrade log is completely updated.

User is required to download the changes to the AC800M controller from the Control Builder M.
Appendix C  Update Page Connector

A Function Diagram can include Page Connectors that are connected to blocks such as Control Modules, Function Blocks, Diagram Types and so on. If a Function Diagram or its blocks are renamed, without opening the Function Diagram from the Functional/Control Structure in the 800xA Workplace or by using Bulk Data Manager, then the Page Connector references to the internal blocks are not updated. Generation of Configuration Data for such Function Diagrams results in errors related to page connectors. Opening the Function Diagram and moving the page connectors manually resolves the error.

A new **Update Page Connector** tool is developed to update Page Connectors in multiple Function Diagrams and resolve errors after a re-name.

**Prerequisites:**

Following are the prerequisites for the **Update Page Connector** tool:

- Workplace Service should be running.
- Page Connector Update should be done with 800xAInstaller account, or using an account who is a member of IndustrialITAdmin and local administrators.

Update Page Connector Tool can be launched from any Function Diagram. However, it is recommended that a new Function Diagram is created outside the parent object of all Function Diagrams in Functional Structure to launch and run this tool.

Follow the steps below to use the **Update Page Connector** tool:

1. Open the Function Diagram from which the tool has to be launched.
2. Navigate to **Tools > Auto Update PageConnectors**, Figure 386

![Tools Menu](Figure_386_Tools_Menu.png)

**Figure 386. Tools Menu**

3. The Page Connector tool is launched. Now, select the parent object of the Function Diagram that include page connectors and require update of Page Connectors.

   It is recommended to split the Page Connector Update into smaller functional groups instead of printing as a single job. Select the parent object that includes a few hundred diagrams.
The Update Page Connectors window appears as shown in Figure 387.

![Update Page Connectors](image)

**Figure 387. Update Page Connectors**

4. Select **Child Diagrams**.

5. Click **Start Update**.

On initiating the **Update Page Connector** tool, a new Engineering Workplace is opened. The **Update Page Connector** tool iterates through all the Function Diagrams under selected parent object of the Functional Structure and updates the affected Page Connectors.

Update Progress is displayed by the progress bar. A window below the progress bar lists all the Function Diagrams that are iterated during the update.

- Close and restart the **Update Page Connector** tool if there is no update in the progress bar and in the list of diagrams.

- The **Update Page Connector** tool has to be closed and re-opened after it completes an update.

After all Function Diagrams under the selected parent object are iterated and page connectors updated by the tool, a dialog box appears as shown in Figure 388.
6. Click **Yes** to export the *.csv* file.

7. Enter the filename and select the location where the *.csv* file has to be exported.

An example of the *.csv* file is shown in **Figure 389**. This is a log file that lists all the Function Diagrams and the status of the page connector update against them.

**Status Interpretation:**

*Completed*: Page Connector found and Updated.

*PageConnectorsNotFound*: No Page Connector Found in the Function Diagram.

*NoDiagramData*: Not a valid Function Diagram.

*Error*: Error in updating or opening Function Diagram.
For corrected Function Diagrams against which the status is updated as 'Completed', use Bulk Data Manager for generation of Configuration Data.

![CSV File Example](image)

<table>
<thead>
<tr>
<th>DiagramPath</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Root/UTPlant/A19/T062_Typical/062432Y915_FD_2</td>
<td>PageConnectorsNotFound</td>
</tr>
<tr>
<td>Root/UTPlant/A19/T062_Typical/062432Y915_FD_1</td>
<td>Completed</td>
</tr>
<tr>
<td>Root/UTPlant/A19/T062_Typical/062432P911_FD_1</td>
<td>Completed</td>
</tr>
<tr>
<td>Root/UTPlant/A19/T062_Typical/062413P902_FD_1</td>
<td>Completed</td>
</tr>
<tr>
<td>Root/UTPlant/A19/T062_Typical/062412Y912_FD_1</td>
<td>Completed</td>
</tr>
<tr>
<td>Root/UTPlant/A19/T062_Typical/062412K002_MV_FD_1</td>
<td>Completed</td>
</tr>
<tr>
<td>Root/UTPlant/A19/T062_Typical</td>
<td>NoDiagramData</td>
</tr>
</tbody>
</table>
Revision History

The revision index of this User Manual is not related to the 800xA 6.0 System Revision.

The following table lists the revision history of this User Manual.

<table>
<thead>
<tr>
<th>Revision Index</th>
<th>Description</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Updated for 800xA System Version 6.0</td>
<td>December 2014</td>
</tr>
<tr>
<td>B</td>
<td>Updated for 800xA System Version 6.0.1</td>
<td>October 2015</td>
</tr>
<tr>
<td>C</td>
<td>Updated for 800xA System Version 6.0.3</td>
<td>September 2016</td>
</tr>
</tbody>
</table>

Updates in Revision Index A

The user manual has been updated for 800xA System Version 6.0 release, based on PRCs.
Updates in Revision Index B

The following table shows the updates made in this user manual for 800xA System Version 6.0.1.

<table>
<thead>
<tr>
<th>Updated Section/Sub-section</th>
<th>Description of Update</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appendix A, Create Differences</td>
<td>Deleted the following information: Whenever a new receiver application is mapped to an existing sender application which is already involved in cross communication across applications, MMS &gt; Create Differences does not establish the cross communication to the new receiver application. Alternatively, perform MMS &gt; Clear Generated Data and MMS &gt; Analyze and Create.</td>
</tr>
<tr>
<td>Section 2 Configuration, Subscribe to Live Data functionalities</td>
<td>The following information has been added: Subscribe for Live Data is not supported for Extensible Parameters.</td>
</tr>
<tr>
<td>Section 2 Configuration, Generate Configuration Data</td>
<td>The following information has been added: Before performing the Generate Configuration Data for Function Diagrams, set ConnectLibsOnGenerateConfigData property to False, so that the library version of Function Diagram is not replaced by latest ones during the system update. After performing the Generation of Configuration Data for Function Diagrams, change ConnectLibsOnGenerateConfigData property to True.</td>
</tr>
<tr>
<td>Section 3 Graphic Editor Reference, Changing the Location of Docked Windows/Toolbars</td>
<td>The following information has been added: The menu bar cannot be docked back by drag and drop action. Double-click the menu bar to dock it back.</td>
</tr>
<tr>
<td>Updated Section/Sub-section</td>
<td>Description of Update</td>
</tr>
<tr>
<td>--------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Section 2 Configuration, Preparation of PROFIBUS Devices | Deleted the following information:  
If there are modules starting with DP in the .gsd file, perform the workaround before importing the .gsd file of Hardware Library into Function Designer.  
1. Open .gsd file in a Notepad.  
2. Search for module names starting with DP.  
3. Replace the letters DP with some other name.  
4. Save the file.  
4. Import the .gsd file from Hardware Library.  
The signal allocation using IO Allocation tool of Function Designer for the GSD Library will not have issues after this. |
| Section 1, Prerequisites and Requirements,        | Added the following information:  
Prerequisites, requirements, and the installation procedures are explained in System 800xA Installation and Upgrade Getting Started (2PAA111708*).                        |
| Appendix B, Function Designer Diagram Upgrade     | Updated the following images:  
• Settings of Function Diagram Upgrade.  
• Function Diagram Upgrade.                                                                                                    |
| Appendix B, Diagram Upgrade                       | Added the following:  
After the Function Designer Diagram upgrade:  
1. All Function Diagrams are updated with objects from the updated libraries.  
2. Configuration Data is generated for all the diagrams which are modified if the Generate Configuration Data During Diagram Upgrade (see Figure 163) is selected, else it does not generate. |
<table>
<thead>
<tr>
<th>Updated Section/Sub-section</th>
<th>Description of Update</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section 3, Graphic Editor Reference,</td>
<td>Added the following bullet point: <em>Bulk Print: On printing with this option selected, a new Engineering Workplace is opened to print the Function Diagrams. The Bulk Print option is available for every Function Diagram. This option is used to print, about a thousand or more Function Diagrams, to prevent aborting of print due to lack of memory. For more information, refer to Bulk Printing of Diagrams.</em></td>
</tr>
<tr>
<td>Section 3, Graphic Editor Reference</td>
<td>Added a new sub-section: Bulk Printing of Diagrams.</td>
</tr>
<tr>
<td>Section 3, Graphic Editor Reference</td>
<td>Added a new sub-section: Large Sequences Overview Printing.</td>
</tr>
<tr>
<td>About this User Manual, Released User Manuals and Release Notes</td>
<td>Changed the user manual name from: <em>System 800xA Released User Manuals and Release Notes (3BUA000263</em>) To: <em>System 800xA Released User Documents (3BUA000263).</em></td>
</tr>
</tbody>
</table>
The following table shows the updates made in this user manual for 800xA System Version 6.0.3.

<table>
<thead>
<tr>
<th>Updated Section/Sub-section</th>
<th>Description of Update</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section 2, Configuration, Consistency</td>
<td>Added the information: If a Function block that is inserted under a Function Diagram is dragged and dropped under another Function Diagram in the Functional Structure, then errors may be reported during a Consistency Check.</td>
</tr>
</tbody>
</table>
| Appendix A, Restored Functionalities, Prerequisites             | Added the information: The task connected to the applications should be of the following format: **ControllerName.Taskname**.  
If this is not the case, it results in an unspecified error during MMS Create. |
<p>| Section 2, Configuration, Guidelines for using Page Connectors | Added the following information: An Update Page Connector Utility is available in the Function Designer menu to correct Page Connector errors after a rename of Function Diagrams or its blocks. For more information, refer to Appendix C, Update Page Connector. |</p>
<table>
<thead>
<tr>
<th>Updated Section/Sub-section</th>
<th>Description of Update</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section 2 Configuration, Horizontal Navigation</td>
<td>Added the following:</td>
</tr>
<tr>
<td></td>
<td>1. Diagram Reference Object types &quot;Off-Diagram References (SIL)&quot; are available for Communication Variables which can be used for communication from non-SIL based Function Diagrams with Control Builder POU's that are part of SIL-2 and SIL-3 Applications.</td>
</tr>
<tr>
<td></td>
<td>2. Added a new figures: Diagram Reference Object Types and Aspect Properties</td>
</tr>
<tr>
<td></td>
<td>3. The Diagram Reference object types under &quot;Off-Diagram References(SIL)&quot; must be used only for Communication Variables and not for Diagram Variables.</td>
</tr>
<tr>
<td></td>
<td>4. Diagram Reference object type under &quot;Off-Diagram References(SIL)&quot; additionally includes two properties &quot;UniqueId&quot; and &quot;ExpectedSIL&quot; as part of the aspect properties, Figure 53.</td>
</tr>
<tr>
<td></td>
<td>The user must manually update the properties to communicate with respective Communication Variables in SIL2 or SIL3 POU's.</td>
</tr>
<tr>
<td></td>
<td>The expected SIL property entered in the aspect properties of Communication Variable should match with the entry in Control Builder for communication.</td>
</tr>
<tr>
<td>Updated Section/Sub-section</td>
<td>Description of Update</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Section 2, AC 800M Integration, Introduction and Requirements. | Deleted: To load the system extension Function Designer for AC800M Connect, use the Configuration Wizard via System Administration > (System Name) > System Extension Load as displayed in Figure 64.  
Added: All tools have to be installed, all system extensions have to be loaded by installing the Engineering Workplace System Function through the System Installer.  
Deleted the image: System Extension Function Designer for AC800M Connect. |
| Section 2, Configuration, IEC61850 Devices    | Deleted the image: Loading System Extension.                                                              |
Updates in Revision Index C
Symbols

.DataType 47
.Direction 47
.In 47
.Initval 47
.InitvalOfType 47
.Inverted 47
.Out 47
.Visible 47, 86
$? 460
$AllocDetails 460, 612
$AllocGroup 460, 597, 612
$Date 460
$GroupName 460
$LastPage 460
$Name 460
$NextPage 460
$OPCForced 460
$OPCIOStatus 461
$OPCIOValue 461
$OPCValue 461
$Order 461, 612
$Page 461
$PGComment 461
$RefPage 461
$RefPort 461
$RefSymbol 461
$SymbolName 461
$Time 461

A

AC 800M/C controller 127
AC800M Connect 127
accelerator keys 387
AccordingCB 70

AccordingCBAlarmOwnerFlag 70
AccordingTypeDefCreateInfo 70 to 71
ActiveX Control 451
ActiveX Run Mode 317, 452
add
aspect property 47
Administrative Document Properties 555
AES Error Context aspect 262
AlarmOwner 70
align 327, 354
components 428 to 429, 469, 473
Allocatable Group
Color 597
Exclude from Configuration Data
Generation 597
Short Name 597
Show Allocation Details 612
allocatable group 28, 302, 460
allocate
diagram to AC800M/C 141, 620
I/O Signals 142
allocation
child diagrams 623
details 330, 611
in Control Structure 220
of diagram 622
toolbar 354
Alt key 392, 411
left click 388
left drag 388
Alt+Ctrl key 392, 411
Alt+Shift key 392, 411
Alt+Shift+Ctrl key 392, 411
ambient properties 345, 447
anchor component 411
Application Engineer User Role 126
Arranging Windows 291
AsAspectObject 71
aspect
  default 80
  parameters 37
  properties 37
aspect command Generate Configuration Data 261
aspect command Generate Configuration Data (Full Build) 261
Aspect Control 75
Aspect Object Mapping 28, 594
Aspect Property 44, 47, 87, 311 to 312, 345
Aspect Property Reference 51, 67, 459, 461, 471
aspect ratio 392
Aspect Verb Synchronize Names 172
AspectObject 45
assign
  components to task 599
AsSymbolObject 71
Audit Trail 125
Authority 126
Autorouting page 514 to 515

B
Backup/restore 123
BDM option Subtree enabled 251
BDM option Transaction ?y Object? 252
BDM option Transaction ?ata Area? 252
BDM options 251
BoolIO 204 to 205, 529
Bulk Data Manager 246
Bulk Data Manager Allocate Diagrams 257
Bulk Data Manager Copy Diagram(s) 248, 251
Bulk Data Manager Diagram Status 263
Bulk Data Manager Generate Configuration Data 261
Bulk Data Manager Generate Diagram(s) 273
Bulk Documentation 265
bulk print 500 to 501

C
Casted Data Types 528
Casts 527
Change Type 82
Checks
  Connections 154
  Constants 155
  Inversions 154
Checks for Connections 154
Checks for Inversions 154
circle port 397
Color
  Background 449, 462
  Foreground 462
  Marked Port 450
  Selection 449
  Transparent Background 462
color
  dialog 474
  page 449
  user-defined 484
command
  group 329
  ungroup 329
Complete Contents 500
Complete contents 265
component
  document 290 to 291, 344
  graphic 311, 390
  group 364
  moving 364
  pages 290
  properties 311
types 27
  view 288
Component Properties 447, 465, 476
Component Properties dialog 462
Component View
  Context Menu 343
Component view 288
ComponentHidden 45
Components Dialog 417, 475
connect
  by keyboard 94
  by mouse 96
  string 87
  to diagram variable 104, 349
connection
  across diagrams 150
  between allocatable groups 625
  between blocks 149
  from I/O channels 152
  to I/O channels 151
Consistency 160
Contents Chapter 265
contents diagram 265, 500
Contents Template 501
contents template 269
context menu 339
  dockable window 357
  Object Aspect 288
  output window 356
  toolbar 353
Control Builder Name 170
control module
  user-defined 26
Control Properties 160
ControlBuilderDescription 46
ControlBuilderName 46
ControlConnection 205, 529
copy
  aspect 342
  components 393, 437, 443, 602
  document 344
  range 441
  reference 301
  template 301, 493, 495
  tool buttons 363
copy and paste components 437
Copy Diagram(s) via Bulk Data Manager 248, 251
Copy to All Instances 75
create
  allocatable group 596
  component 391
  connections 397
  graphic component 391
  toolbar 383
  variables 148, 616
Create Contents dialog 265
Create Info options 71
CrossCommunication 45
CrossCommunication.CycleTime 45
CrossCommunication.Valid 45
Ctrl key 392, 411
  cursor 388
  left click 388
  left drag 388
Customize dialog for toolbars 358
cut
  components 436
  document 344
cut and paste components 436

D

Data Flow Order 131
data flow order 330
DataType 43
default aspect 80, 344, 348
default properties 345, 477
default properties dialog 466
DefaultIsVisible 30
DefaultName 30
define
  component properties 447
  function components 52
delete 348
  active page 315
  aspect 342
  Aspect Property 49
  components 445, 475
connections 389
page 319, 496
ports 389
symbols 389
toolbar 361
user-defined toolbar 385
Delete from All Structures 140, 619
DescriptionIsVisible 30
Detailed contents 269
Device Integration 217
diagram
  child 320
  context menu 339
  document 290, 344
  nested 142, 315 to 316
  pages 290
  parent 320
  reference 106
  referenced 320
  variable 106
  view 288
diagram page size 270
Diagram Parameter 133, 613
Diagram Reference 100
Diagram States 162
Diagram Types 165
Diagram view 289
Diagram View Context Menu 343
DiagramIsBad 46
DiagramSize.Height 46
DiagramSize.Unit 46
DiagramSize.Width 46
dialog
  color 474
  Component Properties 456
  components 475
  page 478
DintIO 205, 529
disconnect
  Diagram Variable 349
  from diagram variable 111
  port 97
Display List 206
Display of On-line Values 201, 203
dockable
  windows 292
dockable windows 292
Dockable Windows Context Menu 357
Document Properties, List of 555
Document Reference 460, 471
Documentation 265
drag and drop 82, 288, 291, 294, 383, 385, 391 to
  392, 401, 406, 426, 436, 438, 440
drawing
  page size 312
  scale 312, 489
Drawing Scale 489
DTM 219
DwordIO 205, 529

E
Edit > Measurements and Size 271
Edit page 457, 479
Electronic signature 123
Engineering Studio Workplace 287, 440
Error Messages 523
Explicit Object Type 72
export file 518
External Links
  Input 443
  Output 444

F
Field Code 459, 471
Field page 459, 470
Fieldbus Builder 217
Fieldbus Management 219
file
  check 305 to 306
  create contents 304
Index

export 303, 518
import 303, 519
open contents 304
template 304

File > Generate Configuration Data 298
File > Generate Configuration Data (Full Build) 299
File > Open Contents 266
File > Page Setup 270
File > Print 271
File > Template 271
File Menu 296
Fill page 461, 480
fit to sheet(s) 271
flip
around the horizontal 326
around the vertical 326
components 431
horizontal 329
vertical 329
focus component 411
Font page 463, 474, 480
font properties 477
function block
user-defined 26
Function Component
context menu 347
Function Designer for AC800M 127
Function Diagram Contents Template aspect 269
Function Settings 30

G
General Accelerator Keys 387
General page 455, 465
graphic component 312, 454, 477
context menu 350
graphic element 400
grid 314, 345, 363
properties 345, 424
group

box 472
components 434, 599

H
HART 26, 216
HSI 26
HWStatus 205, 529

I
IEC 61131-3 naming conventions 170
Import Export
  Dependencies 277
import file 519
indicator read? 317
inherit
  properties 74 to 75
Inherit to All Instances 74
initial value 614
Initial values 136
InitVal 160
InitValIsVisible 30
InitValOfObjectType 160
insert
ActiveX 325
ActiveX Control 398, 400
circle port 324
closed curve 324
component 388, 391, 393, 401
ellipse 325
Fieldbus Builder 219
function component 289
graphic component 312, 391
graphic element 325, 400
graphic objects 363
graphic primitive 394
image 397
label 324
label components 395
line port 324
page 319, 325, 495
Index

picture 325, 397
polycurve 324
polygon 324
polyline 324
ports 397
rectangle 324
single line 324
symbol 404
text 324
text component 395
via drag and drop 401
via menu command 403
InstantiateAsAspectObject 70
InstantiateComponents 30, 70 to 71
InstantiatedByDesignerVersion 46
integration AC 800M/C 127
Internal Links 442
Inversion 97

L

label 467
insert 324
orientation 466
page 466
properties 477
layer 364
annotation 483
Annotation Layer 319
background 483
logic 483
master page 301, 319, 483, 493 to 494
properties 319, 483
set 315
Layout
Align Bottom 328
Align Center 327
Align Left 327
Align Middle 327
Align Right 327
Align Top 327
Flip 329
Group 329
Make Same Site 328
of components 424
Order 329
Rotate 328
Space Evenly 328
Line page 468, 482
line port 397
Local variables 133

M

master page 315
layer 493 to 494
template 492, 494
Master Page Client Area 453
Master Page Template 492, 494
measurement unit 489
Measurements 312, 345, 488 to 489
Measurements and Size 487
Menu
Allocation 329, 332
bar 292
Context 339
Edit 307
File 296
Help 338
Insert 322
Layout 326, 364
Online 332
View 313
Window 337
menu bar 295
Module 489
move
components 426
object 388
symbols 388
via drag and drop 426
multiple selection 387, 410, 412, 422, 447
Index

N
Name Synchronization 172
Name Uploader 172
NameIsVisible 30
naming rules 30
navigate 305
   Goto page 320
   page 315, 497
   to page 319
navigation
   horizontal 99
   vertical 99, 612
navigation toolbar 288
Nested Diagram 99, 612
Network 87, 91, 530, 532
network traversal 389
New Component Name 169, 515
Nudge 389
Number of Input 312
NumberOfInputs 45, 83

O
Object Type Definition Aspect 71
Object Type Definition aspect 74
Object Type Definition Extension aspect 74
object types
   define 300
   of Fieldbus Builder 217
ObjectDescription 45, 517
ObjectName 45, 516
ObjectTypeGroup 45
ObjectTypeName 45
OffPageConnector 453
Online
   Add to Display List 206 to 207
   Remove from Display List 206 to 207
   Watch Window 208
Online > Remove all Links from Display List 207
Online > Subscribe for Live Data 207
On-line Display 200
Online Menu 332
Online Optimized 204
OPC 49
   bad quality 202
   Forced value 202
open
   aspect dialog 390
Open Diagram/Component Documents 290
Open New Windows 290
Options dialog 511
order components 431
output window 156
Override 78
override components 342
Overview
   workflow 128
Overview Contents 500
Overview contents 265, 269

P
page
   ActiveX Controls 451
   Autorouting 514 to 515
   colors 449
drawing 486
   Drawing Scale 487
   edit 457
field 459, 470
fill 461
font 463, 474, 480
general 465
label 481
labels 466
line 468, 482
navigation 364, 497
Off Page Connector 453
paste 513
Position and Size 469
print 512
setup 305, 492
Index

- text 471
- page comments 267
- Pan
  - diagram 389
  - functionality 409
- Parent Diagram view 289
- paste
  - components 436 to 437, 602
  - dokument 344 to 345
  - links 514
  - page 513
- Permissions 126
- port
  - disconnect 97
  - input 25
  - invert 97
  - multiple selection 418
  - output 25
- Port Direction 42
- Position and Size page 469
  - Position.Page 46
  - Position.Unit 46
  - Position.X 46
  - Position.Y 46
- Preview
  - window 287
- Preview window 287
- print
  - allocation details 611
  - Component 305
  - Diagram 305
  - page 512
  - preview 305
- Print Components on Layers 504
- Printer and Printer Page Settings 503
- printer page size 270
- Product
  - scope 20
- PROFIBUS 26
- Project constants 87
- properties 65, 67, 311, 353
  - ambient 308, 312
  - component 457
  - components 454
  - default 312, 477
  - font 477
  - graphical 308
  - label 477
- property reference 49
- Property Reference dialog 51
- Property References 49
- Publish via Parent Diagram 247

R

- Read indicator 127, 317
- Read Only 457
- RealIO 204 to 205, 529
- redo command 307, 521
- reference
  - Goto 112
  - template 493 to 494
- remove aspect property 49
- Rename Substructure 173
- rotate components 430

S

- Scope 20
- scrollbar
  - horizontal 356
  - vertical 355
- Security Definition Aspect 126
- select
  - all connections 424
  - components 410
  - connections 411, 421
  - contiguous components 412
  - contiguous connections 422
  - multiple pages 410
  - ports 411, 417 to 418, 420
  - single connections 421
Index

single ports 417
single symbols 413
symbols 411, 413, 415, 417
text 412
toolbar 415

set
  properties 476
setup page 492
SHIFT
  left click 387
Shift key 392, 411
cursor key 387
  left click 387
  left drag 387
Shift+Ctrl key 392, 411
  left click 388
  left drag 388
show / hide 470
show allocation details 612
Show/Hide Ports 84
Signal Extension for AC800M Connect 127
size
  component 391, 407, 428, 458, 469
  font 464, 477, 489
  grid 318
  page 469, 486 to 487, 490
  paper 314, 318, 492
  properties 456
  symbols 387
  text 473
Space key
  cursor 388
split connection 617
Splitting Windows 291
Structured Data Types 529
Subscribe for Life Data 320 to 321
Subscribe for Live Data 471
support
  Bulk Data Manager 248
SVG 518

symbol object 72
symbol traversal 389
Synchronize Names 172
system extension 127
System Status Viewer aspect 264

T
Template 492, 494
Template dialog 492
Text page 471
tool buttons 363
	toolbar
  add tool buttons 383
  align 370
  allocation 365, 596
  area 353
  categories 363
  connection 365
  connection 87, 94, 97, 375
  create user-defined 383
  delete 385
  drawing 399, 455
  hide 381
  layout 364, 373
  list box 360
  look of 360
  name 360
  nudge 364, 371
  page 359, 364, 370
  remove tool buttons 384
  rename user-defined 385
  rotate 364, 430 to 431
  selection 364, 416, 420, 423
  sequence 376
  standard 366
  structure 372
  user-defined 360
  view 369, 409 to 410
  working with toolbar 358
Toolbar Commands 363
toolbars
  name 360
TypeOfInputs 45

U
Unallocated Application 257
undo command 307, 521
Undo/Redo 521
ungroup
  command 329
  components 434
User Log-Over 127
User Roles 126

V
Value.InitVal 614
Variable Property 312
VariableAttributes 45
VariableDataType 45
VariableDataTypeGroup 45
View
  allocation details 611
  Component and Diagram 288
  Diagram 289 to 290
  grid 317
  grid properties 318
  layers 319
  pages 319
  Printable Area 318
  Snap to Grid 317
  Status Bar 317
  zoom 318

W
Watch Window 208
Watch window 208
window
  Component document 289
  overlap 358
  preview 358

Windows registry 35
Workspace 35

Z
zoom 345, 407 to 409, 511
zooming 314, 409