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Introduction

Contents of this chapter
This chapter contains informationon theapplicability, compatibility, target audience,
and purpose of the manual. It also describes the contents of the manual.

Purpose of the manual
This manual describes the Drive Composer PC tool and instructs how to use it in the
commissioning and maintenance of ABB drives.

Applicability
This manual applies to the Drive Composer PC tool, version 2.9.1 available in two
different variants:

• Drive Composer entry, DCET-01

• Drive Composer pro, DCPT-01 (code: 3AUA0000108087).

YoucandownloadDriveComposer entry for freebynavigating towww.abb.com/drives
and selecting Drive Composer from the Software tools menu. Drive Composer Pro
includes all features and is available through ABB sales channels.

Note: In thismanual, the featuresapplicableonlywithDriveComposerProare indicated
as “(Pro)”.

1
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Compatibility
DriveComposer is a software tool for all ABB commonarchitecture drives anddevices.
The tool recognizes the connected drive based on type code and firmware version
and then adapts the availability of features accordingly. For example, if any of the
feature is not applicable to the connected drive type, then Drive Composer user
interface does not display that particular module to the user.

The tool supports following drive families:

OthersACQxxxACHxxxACSxxx

DCS880ACQ531ACH480ACS180

DCT880ACQ580ACH531ACS380

HES880ACQ80ACH580ACS480

ACS530

ACS560

ACS580

ACS580MV

ACS860

ACS880

ACS6080

Compatible featuresDrive Composer
version

• Offers basic features common to all compatible drives.
• Connections to the drive with an Assistant control panel is common for all

compatible drives and devices.
• Allows configuring safety settings using FSOmodule when Drive Composer

entry is in demo mode.
• Allows adaptive programming in demo mode.

DriveComposer entry

• Offers a variety of features and softwaremodules. The features and software
modules are based on the drive type.

• Recognizes the connecteddrive basedon type code and firmware version and
then adapts the availability of features accordingly. For example, if any of the
features are not applicable to the connected drive type, the Drive Composer
UI does not display that particular module to the user.

• For non-recognized, but compatible drives, the same common basic features
are available than with Drive Composer entry.

• For ACS800 drives: Has limited support (parameter editing and monitoring)
and requires DriveWindow 2.40 installation on the same PC.

Drive Composer pro

Target audience
The reader is expected to be an automation or electrical engineering professional
familiar with drive products and the concepts regarding their commissioning and
operation, including the parameter system of ABB drives. Also, a basic knowledge of
Microsoft Windows operating system is needed.
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Terms and abbreviations used in this manual

ExplanationTerm

You can set a low or high alarm limit for monitoring. Color(s) of the
signal(s) change(s) on themonitoring graph area if the limit is reached.

Alarm limit of monitoring

Provides predefined steps for setting the parameters of the drive. For
example, the basic start-up assistant.

Assistant

Control panel with a USB connector enabling a PC tool connection forAssistant control panel

common architecture drives. The assistant control panel is a generic
name, for example, ACS-AP-I and ACS-AP-S panels.

Y-axis scaling is set automatically when this button is enabled. User-
defined y-axis limits are then disabled.

Autoscaling

Note: Zooming is not possible in the Autoscaling mode.
Backupof thedrive. BackupcanbecreatedwithDriveComposerorwith
control panel*. TheDriveComposer backup file (.dcparamsbak) includes
all parameters, adaptive program and user sets.

Backup

With a backup file from an old drive, you can quickly configure a new
drive or restore configuration after firmware update.

Note: Backup file does not include firmware, IEC program or license.
* Refer to control panels user’s manual.

Control panel with limited basic functionality usedwith common archi-
tecture drives.

Basic control panel

You can filter bits of the Status word and monitor them individually.Bit mask of monitoring

BusinessOnline. A common customer interfacewith electronic integra-
tion and order entry to all ABB business units.

BOL

Common Connectivity EngineCCE

For example, ACS880, DCS880, ACS580, ACH580, ACQ580, ACS560 and
ACS480.

Common architecture drives

You can compare parameters between drives or between a drive and a
file to find out differences.

Compare parameters

Graphical presentation of the drive reference chain or other function.
Shows online values of a parameter, switch positions and signals.

Control diagrams

Parameters can bemodified online. Functionality is not available for all
drives.

Visibleparametersof aparameterwindowor customparameterwindow
are copied/downloaded to a drive.

Copy/Download parameters

Monitor window has a double cursor tool and the positions of cursors
can be freely set in the monitor window. y2—y1 and x2—x1 differences
are calculated.

Cursor tool

You can create windows and drag drop (copy) parameters to these
windows. You can also changeparameter values in thewindowand save

Custom parameter window

thechanges forusing inofflinemode.TheFilenameextension for custom
parameters is *.dccustparams.

In the Demo/Offline mode, the monitor window can be used as a data
file viewer when saved monitored data (*.dcmon) or data logger data
is analyzed.

Data file viewer

Signals are buffered inside a drive with a fast sample interval. Can be
triggered and uploaded to the monitor window to be analyzed.

Data logger

In Demomode you can only view the default parameter values and set-
tings in a pre-configured file. The FSO configuration file can be edited
only in Demomode (for offline configuration).

Demo/Offline

In Offline mode you can set/view the saved parameter files offline.
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ExplanationTerm

Drives Online Firmware StorageDOFS

Adaptive Programming of a drive. Functionality of a drive can bemodi-
fied by adding some IEC 61131 -based blocks. Adaptive Programming
can be done also with an Assistant control panel.

DriveAP

Note: Adaptive Programming is not available with all drives.
Drive Installed Base (DIB) is a knowledge base containing information
aboutdrives. DriveComposer is the client application forDrive Installed
Base service which is used to register a drive and to create service re-
ports.

Drive Installed Base

Electronic Data Sheet. EDS files are simple text files used by network
configuration tools to identify products and describe the properties of
these products and to commission them on a network.

EDS

Consist of faults, warnings and pure events. Only faults stop the drive.
Latest faults and all Electronic Data Sheet arms are also seen in the
parameter interface
group 4, Warnings and Faults.

Event logger

Ethernet adapter module for ABB drives.FENA-xx

PROFINET fieldbus adapter module for ABB drives.FPNO-xx

LOC denotes local control of the drive, either with an Assistant control
panel or with Drive Composer PC tool.

LOC/REM

REM denotes that drive is remotely controlled by the fieldbus master
PLC or by I/O connections.

Parameter can be locked by a drive. You can only view the parameter
values, but cannot modify them.

Lock/Unlock parameter

User-written sequence of macro statements for reading and writing
parameters/signals. Filename extension for macro scripts is *.p.

Macro script

You can set parameters or signals to the monitor window. Values are
collected with the sampling interval and drawn to a window.

Monitoring

National Language Support, the user interface (UI) of Drive Composer
canbe easilymodifiedby editing language files found in the LANG folder
of the Drive Composer PC tool.

NLS support

In Online mode PC tool is connected with the drive.Online/Offline

In Offlinemode PC tool is not connectedwith the drive. In Offlinemode
it is possible to open parameter files, save monitored data, etc.

OPC DA server interface for Drive Composer pro that allows other pro-
grams, such as Control Builder Pro (Advanced drive programming), to
communicate with the drive.

OPC server

Backup of the drive parameters that are viewed, edited or expanded.
When thedriveparameterbackup is slow, user has theoption toperform
a quick parameter backup or proceed with regular parameter backup.

Quick parameter backup

RemoteAuthenticationDial-InUser Service. RADIUS is an authentication
protocol tomanage access to the Internet or internal networks,wireless
networks, and integrated e-mail services.

RADIUS

Parameter values are updated when a group is opened. You can set
parameters to the Auto-update mode or refresh the value manually.
Signals are always updated automatically. In the parameter list, signals
are shown in bold text.

Refresh the parameter

You can use report templates for energy savings, commissioning and
maintenance. Templates can be modified.

Report
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ExplanationTerm

You can restore the drive. You can select the parameters to be restored
during the restore operation. For example, motor identification run
results can be restored or deleted during the restore operation. Can be
used for cloning drives.

Restore

Visibleparametersof aparameterwindowor customparameterwindow
are saved to a file. Filename extension for saved parameters is
*.dcparamsbak.

Save parameters

Note: Some values are not editable in the Offline mode.
You can collect all data from a drive for troubleshooting purposes by
clicking a button in Drive Composer or on an Assistant control panel.

Support diagnostics package

Transport Layer Security. Protocol to protect data transfer on an Ether-
net connection.

TLS

Type of memory unit, attached to the control unit.UMU

Workspace consists of the user interface status, such as parameters
shown in the custom parameter window(s) and their status. You can
save the current workspace status to a file and restore it later. Custom
parameter windows with their contents and the monitor window con-
tents (signals selected, scalings, colors) are saved to a workspace. You
can set one default workspace. Filename extension for the workspace
is *.dcxml.

Workspace

Type of memory unit, attached to the control unit.ZMU
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Related documents

Code (English)Drive firmware manuals and guides

Appropriate drive firmware manuals

Option manuals and guides

3AUA0000093568FENA-01/-11/-21 Ethernet adapter module user’s manual

3AXD50000015612FSO-12 safety functions module user’s manual

3AXD50000015614FSO-21 safety functions module user’s manual

3AFE68573271FPBA-01 PROFIBUS DP adapter module user’s manual

3AXD50000158607FMBT-21 Modbus/TCP adapter module user’s manual

3AXD50000158621FEIP-21 EtherNet/IP fieldbus adapter module user’s manual

3AXD50000158614FPNO-21 PROFINET fieldbus adapter module user’s manual

3AXD50000158638FSPS-21 PROFIsafe safety functions module user's manual

Tool manuals

3AUA0000085685ACS-AP-I, -S, -W and ACH-AP-H, -W Assistant control panels user’s manual

3AUA0000094606Drive Composer Start-up and maintenance PC tool user’s manual

3AXD50000422128Virtual drives quick installation and start-up guide

3AUA0000125635Ethernet tool network for ACS880 drives application guide

3AXD50000028574Adaptive programming application guide
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Overview of Drive Composer

Contents of this chapter
This chapter briefly lists the main features of the Drive Composer software and
instructs howandwhere it canbe run, andhowtoget help andadditional information.

Drive Composer PC tool overview
Drive Composer is a 32-bit Windows application for commissioning and maintaining
ABB common architecture drives.

The full version is called Drive Composer pro and the limited version is called Drive
Composer entry. Both versions allows you to test the user interface functionality, edit
parameter files offline (pro) or open and analyze the saved ormonitored files without
connecting to a physical drive.

Supported features
With Drive Composer, you can:

• control a drive: start, stop, direction, speed/torque/frequency reference

• monitor the operation and status of a drive

• view and adjust drive parameters

• preview and add customized text to parameters

• monitor signals in numerical and graphical (trending) format

• work simultaneously with multiple drives like master and follower drives (pro)

• display control diagramsof adrive for parameter setting anddiagnostic purposes
(pro)

• create user-specific workspaces by customizing parameter windows

2
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• configure the optional FSO-12, FSO-21 safety functions module (pro)

• create a secured network connection with OPC server configuration

• handle workspaces

• create and execute macro scripts (pro)

• create and work with user set parameters (pro)

• useEthernet-based fieldbusadaptermodules for PC tool communication (onewire
solution, Profinet, Ethernet IP) (pro) or a drive-embedded Ethernet port

• use the USB port of an Assistant control panel for an USB connection

• use an OPC-based commissioning and maintenance tool (pro)

• connect to Drive Installed Base service portal and do following tasks: register a
drive, search drive information, create service reports

• recover drive from FB14 fault state

• prevent FB14 fault

• check the status of Service pack installation

• update FSO module firmware

• update drive firmware.

Drive Composer entry Vs pro
The table lists the features supported in the two versions of Drive Composer.

Drive ComposerFeature

proentry

Parameter window features

YesYesSearch/Modify/Print parameters

YesYesParameters changed by user (or automatically updated) have an
orange background

YesYesSave parameters to a file

YesNoQuick drive parameter backup

YesYesCopy/download parameters to a drive

YesYesCustomize parameter windows

YesNoEdit parameters offline

YesNoCompare parameters between parameter lists or drives

YesNoCreate and work with User set functionality

Diagnostics and monitor window features

YesYesCollect data for support service using Support package icon

YesYesMonitor up to eight signals as a simple monitoring method for
basic purposes

YesNoMonitor maximum 26 signals for professional analysis of a single
drive or multidrive

YesYesSave the monitored data to the hard drive of a PC
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Diagnostics and monitor window features

YesYesExport monitored data to a PC using tab separated file

YesPartlyView contents of an event logger (faults, warnings)

YesYesView contents of System info (drive serial number, modules, ver-
sions, SW, etc.)

YesYesRestore or clone a drive using Backup/Restore feature

YesNoRestore a setof components/parameter settingsusingAdvanced
restore feature

YesNoCreate a backup of complete multidrive with a single click using
the Network Backup feature

YesNoUse PC to analyze data logged in a drive by a data logger

YesNoCreate and execute macro scripts

YesYesUpdate drive firmware

YesNoFieldbus adapter loader

Connections

YesNoConnect network drives via Ethernet or with a panel bus

YesYesConnect point-to-point USB through a panel port

YesNoCreating a secured network connectionwithOPC server configur-
ation

NoYesConnecting drives via Bluetooth connection

Safety features

YesNoConfigure safety settings to a safety functions module (FSO)

Other Feature

YesNoUsecontroldiagramsofadrive forparameter settinganddiagnost-
ic purposes

YesYesUser interface is available in different languages

YesYesCreate and edit Adaptive programs

YesNoSupport Virtual drive smart components

YesYesConnect to Drive Installed Base service portal to: register a drive,
search for drive information, create service report

YesYesRecover drive from FB14 fault state

YesYesRecover and prevent FB14 fault without updating drive firmware

YesYesCheck the status of Service pack installation

YesYesAdd customized text to parameter with drive text editor

YesYesNew Drive Composer version notification
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System requirements

￭ Drive Composer hardware requirements

For...Cable type

connectingDriveComposer entry/pro through the
USB port of the control panel to a drive (maximum
3 meters)

USB type A (PC) type mini B (panel) cable

Note: ABB recommends to use ferrite core cables.

connecting through Ethernet adapter module or
embedded Ethernet

Ethernet cable RJ45

￭ Computer minimum hardware requirements

SpecificationHardware

With virtual drive: Intel i5 or equivalentProcessor

Without virtual drive: Intel i3 or equivalent

With virtual drive: 8GBMemory

Without virtual drive: 1GB

1024 x 600 display resolution with 256 colorsDisplay

At least 4.5 GB free hard disk spaceStorage

One free USB port or Ethernet portCommunication port

￭ Software requirements

SpecificationSoftware

Windows 11 (32- or 64-bit) and laterOperating system

.Net framework 4.8 or higherFramework
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Installation anduninstallation ofDrive
Composer

Contents of this chapter
This chapter describes how to install and uninstall the Drive Composer software.

Determining the current Drive Composer version
To know the version of the Drive Composer PC tool, go to Help→ About the product.

The About the product dialog box displays the Drive Composer version.

3
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Drive Composer update notification
If any new version of Drive Composer is available, a DRIVE COMPOSER UPDATES ARE
AVAILABLE dialog box appears. In the dialog box, you can click HERE and download
the latest package file.

If you clickOK, the dialog box appears again the next time you open Drive Composer.
If you select the Don’t remind me again for this version check box and click OK, the
dialog box does not appear again.
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Installing Drive Composer with the installer

Note:

• ABB recommends to uninstall all previous versions of Drive Composer before you
install a new version. See section Uninstalling Drive Composer with the installer.

• Close all applications before starting the installation.

1. Run the setup.exe file from the folder where you unzipped the Drive Composer
files.

2. Right-click on the setup.exe file and select Run as administrator.

3. In the Drive Composer- Setup Wizard, click Next.
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4. Choose a destination folder and click Next.

5. Click Install to start the installation.
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If Drive Composer installation is complete, click Finish. Now Drive Composer is ready
for use.

On running the application for the first time, it displays a notification seeking
permission to collect the tool’s usagedata to sent it toABB. This is used for improving
the performance and user experience. ABB does not collect any personal data. This is
optional and is not mandatory to accept.

Installation and uninstallation of Drive Composer 25



You can enable or disable the usage data collection any time from View→ Settings.
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Uninstalling Drive Composer with the installer
Drive Composer can be uninstalled either through the Settingswindowor the Control
Panel.

1. Navigate to Settings → Apps→ Installed apps, and select the installed Drive
Composer pro installer. Click the ellipsis icon and then click Uninstall.

Alternatively, navigate to Control Panel → Programs → Programs and Features,
and select the installed Drive Composer Pro installer program. Click Uninstall.

2. In the Drive Composer pro Installer Setup, click Uninstall.
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3. Wait for the uninstallation to complete.

The progress bar turns green and the application is removed from your PC.

Activating Drive Composer pro
Drive Composer pro includes a license key and requires activation. You can run Drive
Composer pro for 30 days in fully functional evaluation mode.

During the first launch, Drive Composer pro prompts to enter the registration code
(license key). Fill in the code and click Activate.

You can also later at any time, enter the registration code or the license key. Go to
Help → Enter license code and fill in the code and click Activate.
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Connections

Contents of this chapter
This chapter describes how to make a Bluetooth connection, USB connection or an
Ethernet connection to an ABB drive with Drive Composer.

The USB device drivers
You can connect a PCwith Drive Composer to an Assistant control panel throughUSB
after installing the required USB device drivers or through Bluetooth connection. The
Drive Composer installer installs the requireddrivers automatically, so no user actions
are needed.

If the installer failed to install the drivers automatically, you can manually install the
USB drivers by downloading the tool from software tools website:
http://new.abb.com/drives/software-tools/drive-composer

Obey the instructions provided with the drive package.

Connecting to a drive through an Assistant control panel
for the first time

￭ Cable type
To establish a connection between Drive Composer and drive,

• connect aUSB typeA (PC) typemini B (panel) cable to theUSBport of the computer
and the USB port of the Assistant control panel.

• use a USB cable of maximum length three meters.

• use separate USB/485 adapter if the drive is used without an Assistant control
panel or with a Basic control panel.

4
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￭ Connecting to drive
1. Connect your PC to the Assistant control panel with a USB cable.

ABB drive Assistant
control panel

USB cable PC with
Drive Composer

This text appears on the Assistant control panel screen: "USB connected"

Note: It is not possible to use the Assistant control panel when it is connected to
a PC.

2. For the entry version, double-clickDriveComposer entry.exe file and launchDrive
Composer.

3. ClickUSBconnection. In theCOMportdrop-down list, select the appropriateCOM
port.

4. For the pro version, double-click Drive Composer pro.exe file and launch Drive
Composer.

5. In theWelcomewizard, clickConnect to connect to thedrive. If youwant to connect
in Offline mode, click Offline/Virtual Drives.
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For more information on Offline/Virtual Drives connection, refer Virtual drives
Quick installation and start-up guide (3AXD50000422128 [English]) .

You can also select the dedicated connections to the drive:

DescriptionConnections

Connects to thedrive throughDDCS(fiberoptic) communication.
This option is applicable only with ACS800 drive type.

DDCS enabled (ACS800 only)

Connects to the drive through USB connection. Use this option
only when you want to connect to the drive through serial con-
nection, example, USB cable to the Assistant control panel.

USB/COM enabled

Connects to the drive through Ethernet network.Ethernet enabled

Opensadialogwhere you can configure the connections inmore
detail.

Comm settings

Note:

• The status LED starts flickering in theAssistant control panel to indicate data
transfer between drive and PC. The LED keeps blinking as long as there is a
PC tool connected to thedrive. Thewelcomedialogbox is shownon the screen
indicating that the application is initialized.

• First time connection, parameter texts are loaded fromthedrive and thismay
take a few minutes depending on the drive type.

If Drive Composer is connected online with the drive, the drive parameters are
loaded and this window appears.
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If you have a single drive and a point-to-point connection, refer to chapter
Parameter window.

If Drive Composer failed to connect online with the drive, the NO DRIVE FOUND!
message appears. Make sure that all the instructions displayed in this window
are satisfied.

6. Go to View → Settings to check COM settings and click View→ Refresh (Ctrl+R)
to connect Drive Composer to the drive.
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￭ Connecting to drive with Bluetooth assistant control panel or
connectivity panel (Entry)
To establish a connection between Drive Composer and drive using Bluetooth
connection,

1. Double-click Drive Composer entry/pro.exe and launch Drive Composer.

2. Click Bluetooth connection and from the Available Bluetooth devices, select the
drive.

3. Enter the Bluetooth pairing code. For information on pairing Bluetooth of your
computer with the drive, click . To reload the drives, click .

4. ClickConnect to connect to the drive. ClickDemo orOffline if youwant to choose
the demo or offline mode.

5. To disconnect any connected drive(s), navigate to the Drive list and click
Disconnect.
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Note:

• The status LED starts flickering in the Assistant control panel to indicate data
transfer between drive and PC. The LED keeps blinking as long as there is a PC
tool connected to the drive. The welcome dialog box appears on the screen
indicating that the application is initialized.

• At first time connection, the parameter texts are loaded from the drive and this
may take a few minutes depending on the drive type.
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Changing the language settings
To change the language setting of the Drive Composer user interface,

1. Go to View→ Settings.

2. In the Settingswindow, choose the required language for the Drive Composer
user interface.
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• Drive Composer default language–selects the default language of the menu
or button text in Drive Composer.

• Drive default language–selects the default language for parameters.
By changing language settings you can always use the same language when you
connect Drive Composer to the drive.

3. After changing the language settings, click View → Refresh (Ctrl + R) or restart
the Drive Composer tool.

Note: Some elementsmight require to restart Drive Composer to update the selected
language.
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Connecting to a drive through an Ethernet network

￭ Ethernet network connection
It is possible to connect a PC to the drive with an Ethernet cable through optional
adapter modules that support the Ethernet connection. If the drive type supports an
embedded tool Ethernet network, it is also possible to connect the PC directly to the
drive through its embedded tool Ethernet connector.

Refer to the drive manuals for information on:

• availability and type of optional adapter modules with the Ethernet connection

• availability of embedded tool Ethernet network connector and support.

For the installation of the adapter modules, see the related user’s manual.

Configure the PC/Ethernet Switch firewall to allow a connection for Drive Composer
(port HTTP 80 and UDP), or disable firewall.

￭ Creating an Ethernet network connection through FENA-01, -11 or -21
Ethernet adapter module
1. Install a FENA module to the drive. If you plan to have an Ethernet link between

several drives, install a FENA module to each drive. Connect the Ethernet link
between the FENA modules according to the FENA-01, -11- and -21 user's manual
(3AUA0000093568 [English]).

2. Double-click the Drive Composer.exe file to launch Drive Composer.

3. Make the preparatory Ethernet communication settings in each drive (steps 3...6)
using control panel or Drive Composer. In case of Drive Composer, connect the
PC with the Drive composer to each drive over the USB link and the control panel.
If you plan to have several drives in the same Ethernet link, repeat the settings in
steps with each drive separately. Use either the control panel or the Drive
composer. Connect the PC with the Drive Composer with point-to-point to each
drive over the USB link and the control panel.
a. If you use only one fieldbus adapter module with the drive, enable FENA by

setting parameter 50.01 FBA A enable = Option slot 1 (if fieldbus adapter is
connected to option slot 1) and parameter 50.21FBA A Timelevel sel = Fast
(orMonitoring for Tool network only).

b. If you use two fieldbus adapters with the drive and FENA is installed as FBA
B, enable FENA by setting parameters 50.31 FBA B enable = Enable and 50.51
FBA B Timelevel sel = Fast (orMonitoring for Tool network only).

4. Set a static IP address for each drive in parameter group 51. If you plan to have
only one drive in the link, you can use address: xxx.xxx.xxx.xxx. If you plan to have
several drives in the link, each drive must have a unique address.

For example:

drive 1: xxx.xxx.xxx.xxx

drive 2: xxx.xxx.xxx.xxx

drive 3: xxx.xxx.xxx.xxx

etc.
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5. Refresh the settings with parameter 51.27 FBA par refresh.

Note: Refreshing the Node setting will lose the communication to the drive. To
establish the connection with the drive, select View → Refresh.

6. Disconnect the PC with the Drive Composer from the USB-panel link (if it was
used). If you plan to connect the PC to one drive only, connect it to the FENA
module of the drive using an Ethernet cable. If you plan to connect the PC to an
Ethernet link of several drives, connect the PC to a suitable connection point in
the link (a router or a FENA-21 module).

7. Make sure theTCP/IP addressof your PC is configured. In this example theTCP/IP
address is xxx.xxx.xxx.xxx. Refer to section Configuring the TCP/IP
address (page 39).

8. Name each drive to facilitate the recognition of drives when creating an Ethernet
network connection.

In the System info tab, type the Drive name and click Set.

Note: The drive name changes only after you refreshed the view. The previous
names in other existing workspaces are not affected.
If you use Assistant control panel, name the drive from the Settingmenu of the
panel.

9. Configure the TCP/IP address of your PC. In this example the TCP/IP address is
xxx.xxx.xxx.xxx. For more information on configuring the TCP/IP address, refer
section Configuring the TCP/IP address (page 39).
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￭ Configuring the TCP/IP address
1. Go to Control Panel and click network and Sharing Center.

2. Click Change adapter settings on the left pane. A Network connections window
displays.

3. Double-click Local Area Connection.

4. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.
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5. Select Use the following IP address, type the IP address and subnet mask and
click OK.

6. Connect the RJ45 cable between the FENAmodule and PC. Alternatively, connect
all drives and PC to the same Ethernet switch.
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7. Opencommandprompt (cmd.exe) andpingall thedrives that youhave configured.

8. Open http port 80 of the firewall in your computer to enable Drive Composer pro
to communicate with drives.
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9. Open Drive Composer pro. In the Welcome window, make sure Ethernet enabled
is checked and click on Comm settings button.

10. In theDrive EthernetConfigurationToolwindow, clickScan→ScanNetwork.Make
sure Auto configuration mode is checked.

Drive Composer scans all the COM ports and Ethernet ports to find drives.
If problems arise, see Ethernet tool network for ACS880 drives application guide
(3AUA0000125635 [English]).
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￭ Creatinga securednetwork connectionwithOPCserver configuration
The FPNO-21 fieldbus adapter module supports HTTPS (secured network) for PC tool
communication. Refer FPNO-21 PROFINET fieldbus adapter module user’s manual
(3AXD50000158614 [English]). The module and OPC server configuration in the Drive
Composer configuration tool allows a secured connectionbetween thedrive andDrive
Composer. To create a secured network connection, make sure that following
pre-requisites are available.

Prerequisite 1

Windows TLS 1.2 is needed for communication between drive and Drive Composer
through the FPNOmodule. If not available, Drive Composer prompts to update TLS
or set TLS 1.2 as default.

Prerequisite 2

Client and Server certificates are needed for Cybersecurity requirement. Client
certificate is a self-signed certificate used by PC tool and Server certificate is used by
the FPNOmodule. See sections, Install Client certificate and Install Server certificate.

See also instructions for Checking TLS version .

Install Client certificate

To install Client certificate follow the below steps:

1. In your local PC, go toManage computer certificates → Personal→ Certificates
and import the certificate to this folder.

2. Right-click on the Client certificate → All Tasks →Manage private keys.
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3. Click Add and type Authenticated users. Domain can be hostname or current
network domain. Then allow full control rights and click Apply.

4. Allow full control rights and click Apply.

Client certificate is installed and available for authenticated users.

Install Server certificate

To install Server certificate, follow the below steps:

1. Open the browser and enter the IP address if the module and press Enter. When
prompted, enter the Username (admin) and password (last 6-digits in macID of
the module).

44 Connections



2. In the FPNO configuration window, under Drive Composer certificate settings,
upload the certificate and click Submit all.

The selected certificates are installed. Proceed with Configuring OPC server
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Configuring OPC server

If Prerequisite 1 and Prerequisite 2 are available, configure the OPC server.

1. Open Drive Composer pro. In the Welcome window, make sure Ethernet enabled
is selected and click on Comm settings button.

2. In theDrive EthernetConfigurationToolwindow, clickScan→ScanNetwork. Make
sure Auto configuration mode is selected.

Drive Composer scans all the COM ports and Ethernet ports to find drives. For
more information, see Ethernet tool network for ACS880drives application guide
(3AUA0000125635 [English]).

3. Click OPC Server config tab.

4. In Certificate settings, check the option Customized certificate and select a
certificate. Click Save.
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5. You will be prompted to restart the drive. Click OK to proceed. If certificate is
validated, the drive successfully connects through HTTPSmode and indicates “
Secure connection with custom certificate”.

Note: There are other instances of network connectivity between drive and Drive
Composer:

• If drive connects through HTTP mode, it indicates as “ Not secure connection”.

• If drive connects through HTTPSmode without a client certificate, it indicates as
“ Encrypted communicationwithout client certificate” anddisplays the following
error message:

This notification setting can be changed from View → Settings. Select the option
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Show notification if... in HTTPS connection and click Save.

For more information on OPC foundation, refer the OPC website.
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Creating HTTPS certificates

The instructions below is an example to create amatchingpair of certificates, tomake
Common Connectivity Engine (CCE) work with HTTPS client authentication. The
certificates are created using openssl installed from an unofficial installer Win64
OpenSSL v1.1.1k Light from slproweb.com.

To create HTTPS certificates, perform the below steps:

1. Install openssl.

2. Create a folder for the files created during the steps.

3. Open command prompt (cmd) in the folder and run the following commands.

Note:Make sure that the openssl found via the PATH environment variable is the
one you installed. You may have other old openssl executables that come as part
of other software installations. Edit the path accordingly, or replace openssl with
C:\ProgramFiles\OpenSSL-Win64\bin\openssl.exe inbeginningofeachcommand
to run the correct openssl.exe.

ResultCommand

Creates 2048 bit root certificate RSA
key.

openssl genrsa -out TestCCE01_RootKey.key 2048

Creates root certificate.openssl req -x509 -new -days 3650 -key Test-
CCE01_RootKey.key -out TestCCE01_RootCert.crt -subj
"/O=ABB/OU=Testing/CN=TestCCE01_RootCA_2048"

Creates 2048 bit client key.openssl genrsa -out TestCCE01_ClientKey.key 2048

Creates client certificate.openssl req -new -key TestCCE01_ClientKey.key -out Test-
CCE01_ClientCert.csr -subj "/O=ABB/OU=Testing/CN=Test-
CCE01_Client_2048"

Signs client certificate.openssl x509 -req -days 1000 -in TestCCE01_ClientCert.csr
-CA TestCCE01_RootCert.crt -CAkey Test-
CCE01_RootKey.key -CAcreateserial -out TestCCE01_Cli-
entCert.crt

Creates a PKCS#12 keystore file for
certificate installation.

openssl pkcs12 -export -in TestCCE01_ClientCert.crt -inkey
TestCCE01_ClientKey.key -out TestCCE01_ClientCert.p12
-name "clientPrivateKey"

Note: This command prompts to choose a password, re-
quired later for certificate installation.

4. After the commands are run, make sure that the following files are available.

5. Install the following certificate files:
• File to upload to FPNO (Drive): TestCCE01_RootCert.crt
• File to install on Local Computer store: TestCCE01_ClientCert.p12

Note: Double click to install the required password.
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Checking TLS version

Make sure that the Windows TLS version is 1.2 or later if trying to make a HTTPS
connection.

Check if theMicrosoft update 'kb3140245' is installed (does not apply toWindows 10).

Check if the registry key
'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet
Settings\WinHttp\DefaultSecureProtocols' has a value '0x00000A00' or '0x00000800'
(refer the table below).

1. Check if registry key
'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet
Settings\WinHttp\DefaultSecureProtocols'
has a value '0x00000A00' or '0x00000800' (refer the table below)

2. In 64-bit PC, check also key
'HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet
Settings\WinHttp\DefaultSecureProtocols'
has a value '0x00000A00' or '0x00000800'

Protocol onDecimal valueDefaultSecureProtocols
Hex value

SSL 2.080x00000008

SSL 3.0320x00000020

TLS 1.01280x00000080

TLS 1.15120x00000200

TLS 1.220480x00000800

TLS 1.1 + TLS 1.225600x00000a00

TLS 1.0 + TLS 1.1 + TLS 1.226880x00000a80

TLS 1.2 (Experimental) available
with Win10 build 1903

Connecting network drives (pro)

￭ Panel bus network connection
Dependingon thedrive type, it is possible to construct apanel busbetween thedrives
using either of these methods:

• Use the twin panel bus connectors in the control panel holders of the drives. The
ACS880-01 drive has twin connectors, but not available inmost of the other drive
types. Refer to the hardware manual of the drive, and the below instructions.

• Connect the panel bus connectors of FDPI-02 option modules installed onto the
drive control units. The option is available for ACS880 drive series. Refer to the
ordering informationof thedrive (availability), andFDPI-02diagnostics andpanel
interface unit user's manual (3AUA0000113618 [English]).

• Connect the panel bus connectors of CDPI-01 or -02 panel bus adapters installed
onto the drive control panel holders. The option is available for ACH480, ACS480,
ACH580, ACQ580, and ACS580 drive series. Refer to the ordering information of
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the drive (availability) and CDPI-01/-02 panel bus adapters user’s manual
(3AXD50000009929 [English]).

￭ Creating a panel bus with Drive Composer(pro)
1. Create a point-to-point connection from the Assistant control panel or Drive

Composer to each drive.

2. Set an independent node ID for eachdrive (withparameter 49.01Node IDnumber).
The node ID must be between 1…32.

3. Refresh the settings (with parameter 49.06 Refresh settings).

Note: Refreshing the Node setting will lose the communication to the drive. To
re-establish the connection with the drive, select View → Refresh.

4. With parameter 49.05 Communication loss action, define how the drive reacts to
a control panel (or PC tool) communication break by selecting No action.

5. Give a name for each drive to facilitate the recognition of drives when creating a
panel bus connection.

In the System info tab, type the Drive name and click Set.

Note: The drive name changes only after you refreshed the view. The previous
names in other existing workspaces are not affected.
If you used Assistant control panel, name the drives through the Settingmenu of
the panel.

6. Remove all panels connected to drives.

7. For connecting thedrives in adaisy-chain, connect a standardRJ45 (straightCAT5)
cable on the left-hand side connector of the Assistant control panel holder in the
first drive to the control panel. Refer to below figure. This is possible with
ACS880-01 drive with the twin panel connectors in the control panel holder. For
other connection options, refer to Panel bus network connection (page 50).
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8. Connect a standardRJ45 (straightCAT5) cable fromthe right-hand side connector
of the Assistant control panel holder in the first drive to the left-hand side
connector of the Assistant control panel holder in the second drive.

9. Continue chaining the rest of the drives as described above.

10. Set the bus termination resistor to ON position in the last node. The switch is
located in between the twin connectors of the control panel holder.

￭ Checking the visibility of the drives in the panel bus
1. Connect a USB cable between the Assistant control panel and your PC.

2. Double-click Drive Composer pro.exe to launch Drive Composer. The status LED
starts flickering on the Assistant control panel.

3. Drive Composer starts scanning all selected networks and loads the connected
drives.

4. Make sure you see all drives in the Drives list.

Note:

• If you see a missing drive, close the PC tool and try again. If you still do not
see all drives, check Group 49 Panel port communication for the settings of
the missing drives.

• Drive Composer does not automatically open any parameterwindowor other
object.

5. Select and click a drive from the Drive list.

Sharing connection (pro)
1. Go to View→Settings.

2. In the Settings screen, select the option Share connection with Automation
Builder to enable simultaneous connection to the same drive from both
applications.
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3. Click Save to save the new settings.

4. You may be prompted to restart Drive Composer. Click OK, to restart.
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Main user interface components

Contents of this chapter
This chapter describes the user interface (UI) components and how to use them.

5
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Drive Composer UI overview
The Drive Composer user interface consists of the following parts.

1

2

5

3

6

4

Title bar1

Menu bar2

Drive control panel3

Drives list panel (refer also Drives list panel: status indication)4

Status panel (including the output view of the selected drive).5

Working area for parameter windows, event logger, control diagrams, assistants etc.6
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Title bar
The title bar is located at the top of the main window. It consists of the following
parts:

Systemmenu icon. See description in Systemmenu.1

Application name and version number (Drive Composer entry/pro)2

Name of the workspace (if there is an active workspace)3

Minimize button–has the same function as Minimize in the Systemmenu. With this
button, you can reduce themainwindow to the task bar or a sub-window to the bottom
of the window area.

4

Maximize/Restore Down button (the name depends on the status of the maximized
window)– has the same function as Maximize or Restore in the Systemmenu.

5

• With the Maximize button, you can enlarge the window to fill the available space.
• With the Restore Down button or the Restore (from systemmenu), you can restore

the window to the size and position it had before it was maximized.
Note:
• You can also maximize or restore the window by double-clicking the title bar.
• You can move a window by dragging the title bar or you can move a dialog box by

dragging its title bar. But you cannotmove awindow by dragging the title bar if you
have maximized or minimized a window.

Close button–has the same function asClose in the Systemmenu.With this button, you
can end the Drive Composer session. See also description of Closing the application.

6

￭ Closing the application
When you close the application, system prompts to confirm. Click Ok to close the
application. Before closing, Drive Composer may:

• warn you about releasing control of the drive if the drive is controlled locally by
Drive Composer

• prompt you to save the workspace with unsaved changes. See Saving the
workspace with unsaved changes.

• remind you to save your monitor data

• remind you of unfinished printing.

Note: If you disconnect the cable from the drive before closing Drive Composer there
might be a long delay in operation.

￭ Alternate methods to close the application
You can also close Drive Composer by

• double-clicking the Systemmenu icon

• selecting Close in the Systemmenu
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• selecting Exit in the File menu

• pressing the shortcut key Alt+F4.

￭ Saving the workspace with unsaved changes
You can close Drive Composer without saving the changes to workspace.

1. Go to View → Settings.

2. In the Settings window, check the option Save workspace on exit.

The function that prompts to save the workspace with unsaved changes is disabled.

￭ Systemmenu
You can open the Systemmenu by

• left- or right-clicking the Systemmenu icon

• pressing the shortcut key Alt+space bar

• right-clicking within the non-button area of the title bar.

The Systemmenu contains the following commands:
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Systemmenu commands description

DescriptionCommand

Restores the window to its size and position which it had before it was maximized.Restore

This command is the same function asMaximize/Restore Downbutton in the title barwhen
the window is maximized.

Allows moving the window with arrow keys. To stop moving the window, press ENTER. To
cancel the move, press ESC.

Move

This function can also be performed by dragging the title bar.

Allows resizing the window with arrow keys. To stop resizing the window, press ENTER. To
cancel resizing, press ESC.

Size

This function can also be performed by dragging any of the sides or corners of the window.

Reduces the window to the task bar or to the bottom of the window area. This command
is the same function as the Minimize button in the title bar.

Minimize

Enlarges the window to fill the available space.Maximize

This command is the same function as theMaximizebutton in the title barwhen thewindow
has not been maximized.

Ends the Drive Composer session.Close

This command is the same function as the Close button in the title bar.
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Menu bar
Themenu bar is located below the title bar. It contains the following drop-downmain
menus:

• File

• Edit

• View

• Tools

• Help

￭ Using the menu bar
• Click on a menu name to execute a command

• Use arrow keys to navigate between the menus

• Press ENTER to execute a highlighted command

• Press ESC, to close a menu

• Use also shortcut keys to execute the commands.

￭ File menu
The File menu is always located in the menu bar. See description in View menu
commands description.

File menu → New

File menu → Open
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File menu commands description

Keyboardshort-
cut

DescriptionSub-commandCommand

Ctrl+NCreates a new parameter set window.
You can also set this window as the de-
fault.

Custom parameter setNew..

Ctrl+LOpens the latest saved workspace.Open the latest saved
workspace

Open..

Ctrl+OOpens a new window where you can se-
lect the saved workspace to be opened.

Open Workspace

Alt+WOpensanewwindowwhereyoucanopen
the saved custom parameter file.

Custom parameter file

Ctrl+MOpens a window to open the parameter
file for monitoring.

Monitor file

Alt+POpens a new window where you can se-
lect the saved parameter file to be
opened.

Parameter file

-Opens a new window where you can se-
lect the saved support package file to be
opened.

Open support package

Ctrl+SSaves the active workspace of a file.-Save workspace

Ctrl+DSaves the active workspace to default
workspace.Thedefaultworkspaceopens
automatically when Drive Composer is
opened.

-Save workspace as
default

Alt+F4Ends the Drive Composer session.-Exit

Ctrl+PPrints the parameter screen.-Print

-Prints the monitor screen.-Print real-time
monitor view (pro)

￭ Edit menu
The Edit menu is always located in the menu bar.

The menu contains the language commands with which you can select the language
for the Drive Composer user interface.

Note: Restart the Drive Composer to see the language changes.
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￭ View menu
The View menu is always located in the menu bar.
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View menu commands description

Keyboard shortcutDescriptionCommand

Ctrl+F7Selects normal font size.

Note: The change in the font size does not affect the
size of the monitor window font.

Normal text font size

Ctrl+F8Selects larger font size.Large text font size

Ctrl+F9Selects the largest font size.

You canalso change the font sizes using the following
A-letter icons.

The largest text font size

Alt+TChanges working area to be viewed as tabs.

Note: The monitor window cannot be tabbed.

Tabs

Alt+FChanges working area to a separate window.

Note: The monitor window cannot be a floating win-
dow.

Floating windows

Alt+HChanges floating windows to be tiled horizontally.Tile horizontally

Alt+VChanges floating windows to be tiled vertically.Tile vertically

Alt+CChanges floatingwindows to cascade. You can resize
and freely locate the cascadedwindows in theworking
area.

Cascade

-Defines language and connection configuration.

Enables to

Settings

• save workspace settings
• disable local control
• share connection to the same drive
Allows to

• select temporary file location
• set the appropriate Drive Installed Base server

location.

Ctrl+QDisconnects Drive Composer from the drive.Disconnect

Ctrl+RCreates a new connection between Drive Composer
and the drive, which means, uploading parameter in-
formation from a single drive and creating a new
connection with multidrives.

Refresh
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￭ Tools menu
The Tools menu is located in the menu bar. The commands of the Tools menu may
vary between different software versions and drives.

Tools menu commands description

Keyboard
shortcut

DescriptionCommand

-Prints safety functions configuration report if FSO module
is installed.

Safety Configuration Re-
port

-Creates backup of all connected drives in a PC tool network.Backup network

-Compares parameters of two drives or a parameter file and
a drive or two parameter files.

Compare drive data

-Uploads PSL2 data logger files from the drive flash memory
to PC local hard drive. This option is applicable only in BCU-
x2 control unit. See Using the PSL2 data logger
(pro) (page 222).

PSL2 data logger

-Opens and views contents of the uploaded PSL2 data logger
files in the PC local hard drive. See Using the PSL2 data
viewer (pro) (page 223).

PSL2 Data Viewer

-Allows reading texts from the drive to make changes and to
update texts to the drive. See Using the Drive text edit-
or (page 218)r.

Drive Text Editor

Ctrl+Alt+PConverts parameters. SeeUsing theDrive parameter conver-
sion tool (pro) (page 220).

Drive Parameter Conver-
sion Tool

Ctrl+ICreates EDS files of a connected drive.EDS Export
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Keyboard
shortcut

DescriptionCommand

Alt+MSets parameter values to multiple networked drives when
custom window functionality is not sufficient. See Macro
(pro) (page 129) and Macro commands (page 130).

Macro

-Registers anABBdrive in theDrive InstalledBase service (DIB)
portal. See Registering an ABB drive to Drive Installed Base
service (page 198).

Register drive

Alt+AShows symbols exported from Control Builder Plus applica-
tion to the drive. The application list will remain empty if
drive does not have Control Builder Plus.

Application symbols

-Retrieves information of a registered ABB drive in Drive In-
stalled Base. You will need access permissions to Drive In-
stalled Base portal. See Searching a registered ABB drive in
Drive Installed Base (page 202).

Search drive from Drive
Installed Base

-Creates service report of a registered ABB drive in Drive In-
stalled Base. You will need access permissions to Drive In-
stalled Base portal. See Creating a service report from Drive
Installed Base (page 205).

Create service report

-Downloads firmware to the drive. See Drive configura-
tion (page 159).

Drive firmware loader

-Downloads firmware to the Fieldbus adapter module. See
Loading the fieldbus adapter firmware (page 179).

Fieldbus adapter loader

-DownloadsOffline/Virtual drive packages to the Drive Com-
poser.

Offline/Virtual drive
package loader

Ctrl+LLaunches the Offline/Virtual Drive Launcher window if Off-
line/Virtual Drives button is enabled on the Drive Composer
tool start-up screen.

Virtual drive launcher
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￭ Help menu
The Help menu is always located in the menu bar.

Help menu commands

Keyboard
shortcut

DescriptionCommand

F1Opens Drive Composer user manual as a PDF file.Content

F3Opens firmwaremanual of the connecteddrive type in a separatewindow
as a PDF file. If you selected a parameter or some other significant item
when you clicked this command or pressed F3 key, the appropriate
chapter in the firmware manual is displayed.

You can also read the firmwaremanual of the connecteddrive by clicking
on the i button.

Firmwaremanual

-Creates a single file that can be sent to the local ABB support contact if
you need any support.

Make support
package

-Registers the Drive Composer license code, during the first-time launch
of the software. See steps for Activating Drive Composer pro (page 28).

Enter licence
code (pro)

-Checks for newer version of the software.Check for up-
dates

-Displays Drive Composer software version and copyright text.About the
product
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Drive control panel
The drive control panel is located below the menu bar. It has buttons for controlling
a connected drive. It also shows the status of the drive.

DescriptionButton
name

Item no.

Motor icon (clockwise open circle arrow) for drive status indication. For descrip-
tion, refer Drives list panel: status indication (page 70).

-1

The nameof the connecteddrive and “{1}{1}” represent the channel number and
node number of the connected drive, respectively.

-2

Allowscontrolling the selecteddrive throughDriveComposeror allows releasing
control of the drive.

Control3

Sends a reset command to the drive. If the fault is not active, the drive clears
it.

Reset fault4

Starts the currently controlled drive. A motor connected to the drive starts ro-
tating according to the set reference value.

Start5

Stops rotation of the motor connected to the currently controlled drive.Stop6

Coasts the currently controlled drive to stop.Coast stop7

Allows entering a new reference value. The Reference fieldwill show the current
reference value used in the drive.

When you click the Reference field, a tooltip shows theminimumandmaximum
limits for the reference and current/actual reference value.

For reverse direction, set the value manually with negative (-) sign.

Reference8

Displays the active reference value.Active refer-
ence

9

Enforces the value in the reference value field to the currently controlled drive.
You can also perform the same command by pressing ENTER.

Set10

Activates step cycle with the reference value.
Allows modifying Step type, Step value and Step duration with reference

value. The available configuration is dependent on the connected drive.

Step11
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￭ Using the drive control panel to start the drive
1. Set the drive parameter values necessary to start the drive. See firmware manual

of the drive.

2. Click Control button.
The control box indicator changes to LOC.

3. Enter a reference value and press ENTER or click the Set button.

4. Click Start.
The drive starts. The indicator box arrow changes to green.

Note: Limit settings in parameter group 30 affect the reference limits.
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Drives list panel
The drive list panel shows all connected drives and open files. The drives status is
indicated with a motor icon (clockwise open circle arrow). For description of status,
refer Drives list panel: status indication.

When you click on a connected drive type, a pop-up window/context menu appears
with different drive view types.

DescriptionDrive view

See Parameter window.Parameters

See Amplitude logger (pro).Amplitude logger

See Datalogger (pro).Datalogger

See Adaptive programming.Adaptive Programming

See Control diagrams (Pro).Diagrams

See System info.System info

See Event logger.Event logger

SeeUsingDrive InstalledBase service andRestoring
a drive.

Backup/restore

SeeRegistering anABBdrive toDrive InstalledBase
service.

Register drive

See Searching a registered ABB drive in Drive In-
stalled Base.

Search drive from Drive Installed Base

See Creating a service report from Drive Installed
Base.

Create service report

You can open those views either as new tabs or floatingwindows. If an activewindow
is associated with a drive or a file, the corresponding tree item is highlighted in the
drive list.
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￭ Drives list panel: status indication

DescriptionStatus

A Grey circle arrow indicates a stopped drive.Stopped drive

A green circle arrow indicates a running drive.Running drive

A red circle with a white cross (x) indicates a faulty
drive.

Faulty drive

An orange background means that a drive has an
alarm.

Alarm

A red broken line (—/ /—) means that the connec-
tion to a drive has broken.

Broken connection

A lock symbol next to the Drive name means drive
is enabledwithRADIUSauthenticationandyoumust
login for specific operations of the drive.

RADIUS authentication enabled
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Working area
The working area shows the following views:

• Parameter windows

• Custom parameter windows

• Event logger

• System info

• Control diagrams

• Assistants, and so on.

￭ Using the working area
In the working area, you can

• use either tabs or floating windows

• adjust the size of theworking areabydragging thewhite separating line up/down

• adjust the size of the drive list to the left/right

• resize the windows that are not maximized by dragging any corner

• scroll the content using scroll bars on the side or bottom of a window.

The user interface is tabbed by default. You can change the order of tabs by dragging
them. You can open tabs for a single drive or for multiple drives.

You can set the working area to a floating window. For example, parameter window,
event logger, system info, etc. can be shown as floating windows. You can also tile
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the floating windows vertically or horizontally, or cascade using the Viewmenu
commands.
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Parameter window

Contents of this chapter
This chapter describes the parameter and custom parameter windows.

Parameter window overview
The parameter window view displays parameter groups, parameters and their values
for the associated drive or a file. The working area can show several parameter
windows. The headline of each parameter window shows which drive it belongs to.

• With Drive Composer entry, the parameter window opens only when the drive is
connected.

• WithDriveComposer pro, theparameterwindowopensby clickingon the selected
drive in the drive list panel and selecting Parameters.

6
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￭ Parameter window command icons

DescriptionIcon

Expands/collapsesparameter groups.Whenparameter groupsare expan-
ded, all parameter values are read once from the drive.

Saves parameters to a file. Saves visible parameters to a file. File extension
is dcparams(bak).

Enables User set function and allows to add, remove, copy and save User
set parameters.

Enables you to search parameter lists with a keyword. Search is activ-
ated/deactivated by clicking the Filter check box. When the Filter check
box is unchecked all parameters are seen.

Note: If parameter groups have not been expanded, the first search takes
about 30…60 seconds.

Allows you to select/deselect columns to be seen in a parameter window.

Parameters are updated only when a group is opened. With the Enable
updating function it is possible to set all open and visible groups to be
updated automatically. Parameters that have been set to be updated
automatically have a yellow background.

Allows you to download parameters from a file to a drive. With a custom
parameter window allows downloading offline values to a drive.

Enables you to change thewindow target, which is useful if you haveDrive
Composer pro and you have to check certain parameters of another drive.
Included only in custom parameter windows.

Provides you with a list of all user-changed parameters if you click the
check box. These parameters have an orange background.

Allows you toaddor removeoneparameter or signal or several parameters
or signals to/from a custom parameter window.
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￭ Parameter window: view parameters

￭ Parameters list representation
The parameter window contains different types of parameters. Some of these types
are identified by colors or bold fonts as shown in the table below:

ExplanationIllustration

Normal parameters20.3 Ext1 In1 source D1

Signals (bold)1.1 Motor speed used 0.00 rpm

Bit names of a parameter can be seen by double-clicking on
the parameter. New window opens.10.21 RO status

Parameter value is set from another parameter, for example,
parameter group 10, index 1, bit 1.

11.6 DIO1 output source P.10.1.1

Parameter value is an invertedbitof anotherparameter, group
10, index 1, bit 1.

11.6 DIO1 output source P.10.1.1 -

User has changed the value of a parameter (shown with an
orange background).20.1 Ext1 commands

Note:

• The most common type is the regular parameter.

• Parameters arenormally readable andwritable.However,when thedrive is running,
some parameters may be write-protected.

• The parameter view shows: Parameter names, values, units, default values and
different user sets. The number of user sets depends on the drive type.
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• The value of a parameter is read only once. If is necessary to update this value,
right-click and select Refresh the parameter.

• You can set all visible parameters to update automatically by clicking the Enable
updating button.

• You cannot modify values of signals. If you attempt to modify a signal, an error
is indicated. Signals are updated cyclically in the parameter window.

• Parameter signals are also updated frequently, but you can modify these values.

Navigating parameters and groups

￭ Updating parameter values
Parameter values are updated if they are modified.

• To modify a parameter value, double-click the parameter or press ENTER on the
highlighted parameter.

• Toupdate aparameter group value, right-click thegroupnameandselectRefresh
group parameters.

￭ Hidden parameters
In special cases, hidden parameters and groups become available bymodifying some
parameter values. The View→ Refresh command updates the whole parameter table.
For example, group 51 FBA A Settings: When the adapter module is enabled in group
50, you can see parameter names by selecting View→ Refresh.

Note:Close theparameterwindowbefore refreshing andopen again after refreshing.

￭ Alternate formats to view parameters
There are five alternative formats in which parameters are shown: default, binary,
hexadecimal, integer and float format.

To change the format of a parameter, right-click and select eitherUsedefault format,
Use binary format,Use hexadecimal format,Use integer format orUse float format.

You can change the widths of the columns by dragging the vertical lines between the
column headers.

￭ Viewing bit names
To see the bit names of certain binary parameters, double-click the value field box.
For example, refer the below parameter 10.1 DI status.
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To reset a parameter, right-click and select Reset to default.

Parameter values are read once when a group is opened. You can set independent
parameters from different groups to the Auto-update mode by right-clicking and
selecting Add to auto-update. The parameters that are updated automatically are
seen with a yellow background as shown in the following figure.

Note: Signals are automatically updated cyclically
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Parameters or signals can be sent to the monitor window by right-clicking them and
selecting Send tomonitor. Parameters can be copied to a customparameter window
by right-clicking them and selecting Copy. In addition, you can drag and drop
parameters to a custom parameter window.

Pointer parameters overview
Pointer parameter is a special type of parameter that reads value from the parameter
it points to. Depending on the pointer parameter, value or bit pointer, its target can
be another parameter or one of its bits. You can assign Active (false) or Inactive (true)
status to some pointer parameters.

Typically, common settings are offered as a selection list. If the selection list does not
offer the correct pointer, you can set thepointer by selectingOther… fromaselection
list. Select a parameter from the list for a value pointer and then its bit from 0 to 31
for a bit pointer.

You can also enter a value manually by selecting the Edit manually check box. Use the
value form P.#.#.#, where the first # is the parameter group number, the second # is
the parameter number and the third # is the bit number without leading zeros (for
example P.2.1.2). The constant values are Active (false) or Inactive (true).
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￭ Inverting a bit pointer
In the Set pointer parameter window, select Invert value check box.

The invertedbit pointer value is shownwith theminus signat the endof theparameter.

￭ Setting fieldbus data in/out parameters
Process data transferred to and from the drive/PLC is set with parameter groups 52
and 53. With an ACS880 drive it is possible to select the data type for each selected
parameter/signal in these groups.

1. Double-click FBA data in/out parameter and select Other.
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2. Select the format in which the value is handled:16-bit, 32-bit or floating point
format.

In the parameter window the selections are shown inside brackets: [16], [32] or
[F].
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Note:

The floatingpoint or 32-bit value reserves twoslots in the configuration. Consequently,
if you try to select a value for parameter 52.04 as in the figure above, a Parwrite failed
error message appears. See the scalings of parameters/signals in ACS880 primary
control program firmware manual (AUA0000085967 [English]).

Always check the parameter mapping from themanual of the used fieldbus protocol.
Example, FENA-01/-11/-21 Ethernet adaptermoduleuser'smanual (3AUA0000093568
[English]) or FPBA-01 PROFIBUS DP adapter module user's manual (3AFE68573271
[English]).

Binary parameters
Binary parameters have a special meaning for each of their bits. These parameters
are modified in a special Set binary parameter dialog. You can modify the value
numerically in binary, hexadecimal or decimal format.

• One way to modify the value in the field is, double-click the value field for each
bit. Some bits may be greyed out or disabled to edit.

• Another way tomodify a bit is to type the bit value directly to the New value [bin]
/ [hex] / [dec] field.

You can view the binary format of signal values in a similar dialog.
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Search for groups and parameters
You can search the names of parameters and groups inside the parameter window.
The search result is a list of all parameters matching the search text criteria. For
example, all torque-relatedparameters canbe foundbyenteringsearchcriteria “torque”
in the Enter keyword field and clicking the Filter check box. To uncheck the Filter box,
click it again.

Note: The first search takes about 30…60 seconds, because Drive Composer goes
through the whole parameter structure. The next searches are fast. All searches are
in memory of the PC as long as Drive Composer is on.
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Custom parameter window
In Drive Composer you can customize parameter windows by:

• dragging and dropping parameters/signals

• changing parameter values

• copying from the main parameter window or from any other custom parameter
window

• renaming custom parameter windows.

For example, you can

• collect all the typical parameter sused in a quick start-up to one window or

• create separate windows for separate functions (example: references, limits,
ACS880 I/O).

￭ Custom parameter window features
The Custom parameter window

• opens automatically when a connection to a drive ismade because they are saved
with the workplace.

• can be used both in tabbed and floating windows environment.

• can also be opened separately.

￭ Saving custom parameter window
To save a separately opened custom parameter window to a file, select Save
parameters to file. Note that changed values in theOffline value columnare also saved.
You can use the saved file for parameterization of another drive. You can also send
this file to other users to open the file with Drive Composer and view the parameters
list.

Note:When you saved a custom parameter window, the actual drive values of the
Value column are copied to the Offline value column. During loading, the values in the
Offline value column are shown in comparison with the current actual values. From
the savedcustomerparameterwindow file you can copy the valuesof theOffline value
column to another drive by clicking the Download to device button.

￭ Viewing copied parameter values
In a network of drives, you can create a custom parameter window including
parameters/signals selected fromdifferentdrives. Tohavea viewwhereall parameters
are from one drive, click the Change drive button and select the drive.

To see the value of a parameter/signal used in another drive, right-click the
parameter/signal and select Change drive.
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￭ Adding parameters to a custom parameter window
The following example shows how to:

• create a new custom parameter window

• add parameters to a custom parameter window

• modify the Offline value column in the custom parameter window

• copy/download parameters to a drive.

1. Click File →New→ Custom parameter set.

2. Name the custom parameter window.

3. ClickAddbutton toaddparameters/signals to thenewcustomparameterwindow
or copy paste from other parameter window.
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4. For example, select minimum and maximum speed values from the parameter
group 30 Limits and click Apply changes.

5. TheValue column shows the values of connected drive. Enter values in theOffline
value column to be same as Value column or you can type new values.

Test X ACS880 {1}{1}.dcparamsbak X

8 
E] 

I Index 

Enter keyword • 

[Name 

Minimum speed 

Maximum speed 

■ Filter ■ Not at default Select columns: • ■ Enable updating I
[Value 

-1500.00

1500.00

I Offline value I Unit I Min I Max I Default 
rpm -30000.00 30000.00 -1500.00

rpm -30000.00 30000.00 1500.00
{2}{1}Par.30.11 

{2}{1}Par.30.12
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6. Click on Save parameters to file icon to save the custom parameter window.

Drive Composer saves to file the values in theOffline value column. If theOffline
value column was empty, then values in the Values column is saved.

7. When connecting the next drive open the created custom parameter window by
clicking File→ Open→ Custom parameter file.
You can now see the online values of the new drive.

8. Copy theofflineparameter values to anewdriveby clickingonDownload todevice
icon.

Test X ACS880 {1}{1}.dcparamsbak X 

8 

El 

I Index

Enter keyword • 

I Name

Minimum speed 

Maximum speed 

■ Filter ■ Not at defa

I value

-1500.00

1500.00

{2}{1}Par.30.11 

{2}{1}Par.30.12 
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Working with offline files

￭ Types of offline files
There are two types of offline files containing parameter information.

• Parameter file is an offline file containing all parameter values.

• Support package is an offline file package that contains a collection of drive
information, including all parameter values. You can open a support package file
using Drive Composer pro. For further information on support package, refer
chapter Diagnostics (page 119).

￭ Saving parameters to a parameter file
1. Connect Drive Composer to a drive and open the parameter window.

2. In the parameter window, click Save parameters to file icon.

3. Select a folder, enter a name for the dcparamsbak file and click Save.

￭ Opening a parameter file (entry)
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To open a parameter file and view the parameter values offline, proceed as follows:

1. Connect to a drive.

2. Go to File→ Open→ Parameter file.

3. Parameter window displays.

￭ Opening an offline file containing parameter values (pro)
To open a file and view the parameter values offline, proceed as follows:

1. Connect to a drive.

2. Go to File → Open → Parameter file / Open Support package.

3. New item appears under File drives.

4. Select Parameters to open parameter window.

￭ Downloading parameter values to a drive

Note: The operation do not perform full restore. Only visible parameters and ID run
results are copied to a drive when the download command is used. Also, drive type
and software version are not checked when downloading parameter values from an
offline file to a drive. For further information on Restore function, refer chapter Other
functions (page 197).

To download offline parameter values to a drive, proceed as follows:

1. Open an offline parameter window.

2. If you have multiple drives connected online, click Change drive to select a drive
you want to download the parameters.

3. Download the parameter values to a drive by clicking the Download to device
icon.

4. If you get a message indicating that the upload of parameter values is going on,
click OK.
You will get a report of the operation at the end of the restore operation.

5. Check the parameters that are failed during the restore operation.
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￭ Comparing drive data (pro)

Note: Both versions of Drive Composer have Not at default function for listing
user-changed parameters. The Compare drive data function compares parameter
values.

With Drive Composer pro you can compare parameters between

• two drives

• two parameter files

• drive and parameter file.

1. Go to Tools→ Compare drive data (Alt+C).

2. In a PC tool network, select drives from Drive A and Drive B drop-down menus.

3. To open a parameter file for comparison, click Open.

4. To see the parameter listwithout differences, deactivateShowdifferences check
box.

5. Click Start compare.

Note: The operation may take some time to compare two different parameter
structures.
The following figure shows an example of the result.
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6. To export the result to a text (*.txt) file, click the Export.

Note: Click the >> << buttons to copy parameter values from Drive A to Drive B.

User set functionality (Pro)

￭ User set overview
User set or user parameter set functionality is an interface to work with user set
parameters. The user set parameters can be saved to the permanent memory of the
drive and recalled using specific parameters. Digital inputs allow switching between
the user sets. Multiple user sets can be used to control multiple motors through a
single drive.

With the User set function, you can:

• Creating user set (page 95)

• Saving user set (page 96)

• compare user set values side-by-side

• Copying user set parameter values (page 97)

• Removing user set (page 98)

￭ User set system requirements
The User set functionality is available only if the following requirements are satisfied:

• PC must have the configurations listed in System requirements (page 20).

• Virtual drives softwaremustbe installed in yourPC, otherwise theUser set function
is hidden.

• You must have a valid Virtual drives license.

• You must register the Virtual drives license with ABB license manager. Note that
ABB license manager is installer together with the Virtual drives software.
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￭ Limitations
The User set function

• is supported only in ACS880 drive

• works only in the parameter window from where it was enabled.

• worksonly inoneparameterwindow, i.e., youmustdisable the function (if enabled)
in any other parameter window to allow the function in the current window.
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￭ Starting the user set function
To start or stop the user set function,

1. In the Drive Composer pro Welcome window, click Connect.

2. Open the Parameters file or the parameters backup file.
The User set function is visible in the parameter window tool bar.

3. Click the User set drop-down menu. By default the User set function is disabled.

4. Click on the Enable switch.
• If drive firmware version or the parameter backup file is deviated from the

virtual drive, then Drive Composer notifies that User set parameters may be
incompatible for editing. Note that small deviations may not affect the User
set functionality. Click Yes, to proceed.
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• If drive firmware version is not compatible with the virtual drive version, then
User set functionality can not be started. Click OK. to close the window. You
can either update the Virtual drive version or contact your local ABB
representative for support.

5. User set initialization starts. If initialization is complete, click OK.

6. User set function is enabled. The enable switch color appears in blue.
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Note:Todisable or stop theUser set function, click the enable switch again. The switch
color appears in Grey.

If user sets was configured in the connected drive or saved in the parameter backup
file, the available user set is displayed in different columns next to each other.

￭ Creating user set
1. In the User set menu, click Add.

2. From the user set options, select the appropriate option and click OK.

• Uses defaults—takes the parameter values from defaults
• Copy from parameter values—copies the current parameter values
• Copy from user set—copies from another user set.

The new user set is displayed in the parameter window.

Note: If the maximum number of supported user sets is reached, the Add option is
disabled in the user set menu. The maximum number of user sets is determined by
thedrive firmware. For example, the current virtual drive firmware version2.82 supports
four user sets.
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￭ Active and unsaved user set
The active user set is highlighted in blue in the header row of the parameter window.
To change the active user set, configure parameter 96.11 User set save/load = Load
user set X.

The unsaved user set is highlighted with * symbol in the header row of the parameter
window.

￭ Saving user set
1. In the User set menu, click Save.

2. User sets are saved. Click OK.

Note:

• When all user sets are saved, the Save option is disabled in the User set menu.

• If there are unsaveduser sets at the timeof disabling the user set function, closing
the parameterwindowor exitingDrive Composer, a reminder appears to save the
unsaved user set(s).

• You can also save user sets using parameter 96.11 User set save/load. ABB
recommends to save user sets using the Save option in the User set menu.
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￭ Copying user set parameter values
You can copy specific parameter values between user sets.

Note:Parameter(s) in the backup file only canbe used as the source of copy operation.

1. In the parameters window, select the parameters to copy.

Note: If no parameters are selected, the Copy parameter option will be disabled.

2. In the User set menu, click Copy parameters.

3. In the Copy parameters window, select the source and destination parameters.
Click OK.

The selected values in User Set1 is copied to User Set2.
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￭ Removing user set
1. In the User set menu, click Remove.

Note: The Remove option is disabled if no user sets are available.

2. Select user set(s) to remove and click Remove.

The selected user set is removed.

￭ Show/hide user set
You can show/hide a user set in the columns list.

1. In the Parameter window, click Select columns.

2. Check/uncheck the desired User set to show/hide.
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￭ User set parameters limitation
• Parameters not valid for user set are disabled and appears as Grey boxes. For

information of invalid user set parameters, refer the firmware manual.

• All signal parameters are disabled, by default.

• User set parameterswith different unit/min/max/default values are displayed in
different rows.
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Monitor window

Contents of this chapter
This chapter describes the monitor window and its use.

Monitor window overview
In Drive Composer you can monitor the operation of connected drives. In the online
mode, themonitor window shows signal values in graphical or numerical format. The
monitor data can be saved to a file for later use.

With Drive Composer entry you can monitor up to 8 signals.

With Drive Composer pro you can monitor up to 26 signals. If Drive Composer pro is
used with an ACS880 drive, it is possible to monitor 1 signal per 1-ms time interval.

The monitor window is always a tabbed window, in other words, there is only one
monitor window available.

User-made monitoring settings (selected signals, y-scalings for signals, pen colors,
number of grids etc.) are saved by default. In other words, when you open the tool,
there are always the latest settings available.

￭ Resizing the monitor window
When you start Drive Composer themonitor window is in theminimized position and
you have to lift it in the following way before you can start monitoring.

• You can resize themonitorwindowby clicking the title barwith theprimarymouse
button and dragging it upwards.

7
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• You can resize themonitorwindowwith theMinimize,Maximize andSplitmonitor
buttons included in the Monitor menu bar.

• You can lift the monitor window by clicking the arrow buttons in the title bar.
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Adding parameters/signals for monitoring
There are two ways to add parameters/signals to the monitor window:

• Right-click a parameter/signal in the parameter window and select Send to
monitor.

• Click the Add signal icon on the configurations and control area in the monitor
window.

Select parameters fromtheDriveparameters list bydouble-clicking themor select
a parameter and click Add button. You can add maximum of 26 parameters in
Drive Composer pro and eight parameters in Drive Composer entry.

Note:
• With Drive Composer pro you can select signals/parameters from different

drives. Change the drive from the Drive list as shown in the following figure.
• In the PC tool network via Ethernet or with a panelbus, ABB recommends you

to select Disable polling to enable the best sampling result for monitoring.
The status of the drive(s) cannot be read before you have unselectedDisable
polling.
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The selected signals appear in the legend area.

To change the scalings of the y-axis of selected parameters/signals, click the Min or
Max column in the legend area.

Active signals can be changed from the pull-down menu on the left side of the graph
area.

All the other signal scalings are performed on the right side of the legend area. The
right side y-scalings can be hidden by removing the check mark from the Y-scale
column check box.

You can change the color and thickness of the pen only after you haveminimized, that
is hidden the legend area with the Arrow button on the left (refer the figure above).

To change the scalings of the y-axis for selected parameters/signals, click the Min or
Max column in the legend area.

￭ Monitor window components
The monitor window consists of the following parts:

• Configuration and control settings

• Graph area

• Y-axis

• X-axis

• Legend area

• Limit, color settings.
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Configuration and control settings

DescriptionIcon

Opens the saved monitored file to the graph area, which can be done only
aftermonitoring has been stopped. File extension is *.dcemon or *.dcpmon.

Note: If you have an online connection and want to start a new monitoring
session after viewing opened monitored data, you can click the Monitor
configuration icon.

Saves the accumulatedmonitor data to amonitored data file. File extension
is *.dcemon for the entry version and *.dcpmon for the pro version.

Chart configuration can be used to set the colors for grids, number of grids,
background color, color of alarm pen etc.

Opens the Monitor settings windowwhere you canmodify the monitor set-
tings and the select the sample interval time for monitoring. You can also
set the method for starting and/or stopping monitoring (by hand/time).
You have to select the HD where the saved data is stored.

Note: The monitored data is saved cyclically to the selected file.

Created monitoring configuration can be saved and restored from Monitor
settings window.

Allows you to create anarithmetic signal formonitoringbyusing twosignals
used in monitoring. Available operations are ADD, SUB, MUL and DIV.

Note: Remember to save settings in a workspace.

Opens a dialog where you can add or remove one signal or several signals
from the monitor configuration.

Note: You can use the Add signal function only when monitoring has been
stopped.

Shows the signal values in text format. Only the values seen in graph area
are included in the numeric signal value list.

Copies the monitoring graph to a clipboard.

Scales the y-axis automatically.

Note: Zooming is not possible in the Autoscaling mode.

Resets both x- and y-axis zooming to original 100%.

You can export themonitored data in csv format to a PC. Exported data can
analyzed with other tools. Use the Tab key for delimiting the columns.File
extension is *.dcexp.

Aligns signals.
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DescriptionIcon

Selects or changes the drive.

Zooms in the x- and/or y-axis up to 1000%.

Monitor controls

DescriptionIcon

Starts recording data in the selected drives and displaying it on the screen.

Pauses monitoring on the screen but monitoring continues on the back-
ground. When you click the Pause icon again, all values are seen and monit-
oring continues normally.

Stops recording data in the selected drives. The graph or numerical values
remain on the screen. The graph can be saved for later purposes.

Active signal area overview

The Active signal area consists of functions that can be done with the selected active
signal. The signal can be changed from the pull-down menu.

The main functions are the following:
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DescriptionIcon

Allows you to see themeasuring points of the active signal. See figure Mon-
itor window: Measuring points for active signal.

Note:This functionalityworksonly if youhave zoomed in enough in thegraph
area, that is, if the length of the x-axis is short enough.

Allows you to see the numeric values of the measuring points for the active
signal. See figure Monitor window: Measuring points for active signal.

Note:This functionalityworksonly if youhave zoomed in enough in thegraph
area.

Searches backwards. The following search conditions can be selected from
the

pull-downmenu: Above, Below or Either. See figureMonitor window: Search
functionality.

Searches forwards. The following search conditions can be selected from
the

pull-downmenu: Above, Below or Either. See figureMonitor window: Search
functionality.

Zooming the graph
To enlarge the graph and take a closer look at the details, follow these steps:

1. To set the starting corner for the enlargement, place the mouse cursor in the
graph area and press down the primary mouse button.

2. Drag to the opposite desired corner, and release the button.
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The part of the graph that was inside the selection rectangle zooms out to fill the
graph area.

3. To reset the zoom tool, click the Reset zoom icon.

You can also use the zooming tool by selecting independent values from x and y pull-
down menus.

Note:Monitoring is paused during zooming. To continue monitoring, click the Reset
zoom icon shown in the figure below.

Panning the graph
The graph can be panned by dragging the graphwith the rightmouse button pressed
down.

Legend area functions
The legend area shows selected signals. You can perform the following actions in the
legend area:

• Change the color of the pen, thickness and style of the pen by minimizing the
legend area and setting the values of each signal. See figure Monitor window:
Legend area functions.

• Make signals visible or invisible by clicking the check box in the Visible column.

• Set abitmask formonitoring.When youdouble-click the value in theMask column,
a new window opens allowing you to select bits for monitoring.

• MakeY-scalings visible or invisible by clicking the check box in the Y-scale column.

• Set values for y-axis scaling. You can modify the minimum and maximum values
by clicking them and entering a new value. Press Enter to enforce the new value
or press Esc to restore the value.
Note: If you do not see immediate changes in the graph area, check that
autoscaling is not enabled.

• Set alarm limits for monitored signals. The color of a signal changes when the
limit in the Alarm low or Alarm high column is reached. The color and style for the
pen are selected from Chart settings.

• See the double cursor tool, y1 and y2 values and y2—y1 and x2—x1 differences.
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Graph area functions
The monitor window and data logger window have similar graph area facilities for
displaying signal values. Their usage is described here. Before Drive Composer starts
monitoring online, the OnLine monitor text is seen in the graph area. When monitor
files are viewed, the Data File Viewer text is seen in the monitor window.

The graph area shows the selected signal values with different colors. The x-axis
represents Time and can be set from 1 to 120s. You can change the values in online
monitoring mode. Scalings of the y-axis are changed in the legend area.

For data logger files, an orange arrow-head on the x-axis indicates where triggering
has occurred. Data can be combined from several files to one graph.

￭ Double cursor tool
With the cursor tool, you can see the exact values of the signals at two positions in
the graph area. You can move the position of cursors by clicking the primary mouse
button down on the red cursor tool icon and moving it. While the mouse button is
pressed down, you can move the cursor line to the left and right.

The time stamp of the cursor tool is shown in the header of the cursor tool. This is
shown for the active signal. The time stamp changes if active signal is changed. The
values for y1 and y2 are shown in the legend area. Signal value differences are shown
in the column y2—y1. The time difference for x2—x1 is also shown in the figure below.
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Workspace handling

Contents of this chapter
This chapter describes the workspace functionality.

Workspace overview
Workspace consists of the user interface status, such as parameter windows and
custom parameter windows.

The current workspace status can be saved to a file and restored later.

Note:

• You cannot save/restore the following status data:
• drive control status
• If a drive is controlled locally with Drive Composer when the workspace is

saved, the workspace is savedwithout the change in the drive control status.
• content, status and zooming levels of a stopped, paused or runningmonitor.

• Donot edit aworkspaceor graph file. Theworkspace (.dcxml) andmonitoreddata
(.dcmon) files can contain binary data. For example, if the default workspace file
is corrupted, Drive Composer does not open. If Drive Composer does not open,
delete your default (.dcxml) file from the PC and open Drive Composer again.

Creating a customparameter set and using it as a default
workspace
1. Make a connection to a drive.

2. Resize the monitor window to half of the screen.

3. Create a new custom parameter window by clicking File → New..→ Custom
parameter set and name it “Own limit window”.
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4. In the File menu, click Save workspace to save the workspace.

5. Create another customparameter window and name it “Own reference window”.

6. Select floating windows by clicking View→ Floating windows.

7. Enter keyword “Limit” in the Enter keyword field of the main parameter window.

8. Selectparameters in themainparameterwindowanddraganddropor copy them
to custom parameter window Limit.

9. Clear the search result and enter keyword “ref” in the Enter keyword field.

10. Selectparameters in themainparameterwindowanddraganddropor copy them
to custom parameter window Own reference window.

11. Close the main parameter window.

12. Click Event logger icon in the drive list on the left.

13. Click File→ Save workspace and name it “OwnWorkspaceFor_ACS880”.
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14. Close the connection to the drive and make a new connection.

15. Click File→ Open.. → Open workspace and open the workplace that you have
saved.

The workspace is ready to use for commissioning and maintaining drives.
Theworkspacecanalsobesavedasadefaultworkspacewhichopensautomatically
when Drive Composer is started.
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Event logger

Contents of this chapter
This chapter describes the event logger and fault data logger view and its use.

Event logger view
The event logger view displays the event logs of a connected drive. The event logs can
be faults (stopping the drive), alarms or events. With some drives there can be more
data of a fault in the monitor window.

Note:Fault logger data can alsobe seen fromother faults than the latest active faults.
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In the drive list, click on a connected drive and select Event logger.

The event logs of the connected drive appears in a separate tab.

The event logger always relates to a single drive and resides in its window.

The Icon column shows the following alarm and fault icons:

Indicates...Icon

drive has a fault
Red circle with white cross (x)

drive has an alarm
Yellow triangle with exclamation mark (!)

fault or alarm has disappeared from the drive
or Grey circle/triangle

The time stamp for faults, alarms and events comes from the drive.

You can view the sorted list of faults, alarms and events by clicking the header of the
Fault column.

Fault data logger

The Fault data icon in the Event logger view shows that the drive has fault data
that can be seenwith amonitor component. The icon is visible only if the drive sports
the functionality.
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1. In the Event logger window, click on theicon.

The message “Please wait. Loading fault data” appears. The data is loaded after
the message box disappears.

2. When Drive Composer prompts to save the fault data, click Yes.

3. Give a file name for the monitor file.
The file is saved with .dcpmon extension.

Note: You can continue the normal monitoring by clicking theMonitor configuration

icon in the Monitor controls box of the Data Logger window.

Themessage “This operation will changemonitor intomeasuringmode and restore
the last used configuration. Data on display will be lost. Do you want to continue”
appears.

If you clicked Yes, the monitor settings window appears. Select necessary settings
and click OK.
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Diagnostics

Contents of this chapter
This chapter describes how to troubleshoot a drive with the Support package button
of Drive Composer and a Datalogger included in the drive. It also includes how to
register anABBdrive to theDrive InstalledBase (DIB) portal and create service reports.
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Support package
Support package is an offline package file that contains, for example, full parameter
backup, system information, and event logger contents. Themainpurpose is to collect
troubleshooting data and send it to the support personnel for analysis.

￭ Creating a support package
By clicking the Support package button, you can create and save a support package
file (.dcsupport format). You can also do this function from Help→Make support
package.

￭ Sending a support package to Drive InstalledBase
After you saved the support package file (.dcsupport) in your PC, Drive Composer
prompts to send the package to Drive Installed Base. Select the server location and
click Next.

If package is sent, in the completed message window, click OK.
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￭ Opening a support package (pro)
You can open a Support package file in Drive Composer pro by selecting File→ Open
→ Open support package, a new File drive appears. There is similar menu available
with online drives.

For further informationoneachmodule, refer sectionSystem info (page 122), chapters
Parameter window (page 73) and Event logger (page 115).

Drive application programming license
The drive application programming license N8010 is required for downloading and
executing theprogramcodeon theACS880drive. InDriveComposerPro, selectSystem
info tab. Check if the appropriate license is loaded to the drive. If the required license
code is not available, contact your local ABB representative.
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System info
The System info tab provides basic information about the drive and its options, for
example, drive type codeand firmware version. You canalso check the statusof Service
pack installation. See Checking the status of Service pack (page 217).

You can also set the time for the drive and name the drive.

Datalogger (pro)
ABB drives have Datalogger(s) that can record data from various signals of a drive
even if thedrive is not connected to aPC. ADatalogger is operatedwith theDatalogger
view.

The data collecting can be stopped with a specific stop command or automatically
when a triggering condition is true in the drive. After data collection stops you can
read and study the data in Drive Composer pro.
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The Datalogger view resembles the monitor window. Normally the Datalogger view
provides data from a single drive.

￭ Datalogger settings
The Datalogger settings window contains the following functions:

• Datalogger commands

• Datalogger content configuration

• Datalogger trigger configuration.

Datalogger commands

DescriptionButton

Start button recordsdata in the current logger of thedrive until Datalogger
is triggered or stopped.

Stop button ends recording immediatelywithout any post trigger record-
ing.

Trigger button triggers the associated logger in the drive. Trigger Data-
logger is displayed in Datalogger status with trigger code 15.

Upload button moves data from the drive to PC and draws it to the mon-
itor window. Datalogger replaces any previous data in monitor window.

Apply button appliesmonitored signal andDatalogger sampling settings.
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Datalogger content configuration

With the Datalogger content configuration you can determine which Datalogger of a
drive is used.

FunctionDatalogger configuration
commands

Determineswhich logger settingsaremodified.Adrivehasuser logger(s)
and factory logger(s). Factory logger settings cannot be modified.

Logger

Determines inmicrosecondshowoften the logger reads samples of the
signal values. The time level shows the available lengths of the internal
cycle time of the drive. Sample interval is formed frommultiplier (1-
65535) and time level selection.

Sampling interval

FunctionDatalogger configuration
commands

Specifies howmany samples are stored after the triggering condition
occurswhen the value is smaller thanDatalogger total space count. The
Datalogger total space count depends on drive type, selected signal
types and total signal count. If the post trigger count value is bigger
than Datalogger total space count, the triggering point is not visible
anymore in the Datalogger.

Post trigger count

Shows the minimum sampling time with a selected number of signals
and a selected sample interval.

Sampling time

Shows a list of signals selected to record. You can add/remove a signal
by clicking the Add signal icon.

Logger signals panel

To add parameters to the logger, proceed as follows:

1. In the Datalogger screen, click to add parameters.

2. Select a parameter in theDrive parameters list and double-click or click Add. The
parameter is added to Selected parameters.
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Note: The maximum number of signals that a logger can record at one time
depends on the drive. Add button is disabled when maximum number of
parameters are reached.

3. To remove theparameter fromSelectedparameters, select thedesiredparameter
and click Remove.

4. Click Apply changes after making the changes.

Datalogger trigger configuration

Datalogger has four triggers that can be configured to stop the Datalogger. After
Datalogger has triggered, the Datalogger samples post trigger the amount of new
samples.
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￭ Adding a trigger
1. To modify the conditions of a trigger, select the trigger from the Trigger

drop-down menu.
Trigger 1 is normally used for user logger 1, Trigger 2 for user logger 2 etc.

2. Choose the type for the triggering condition from the Type drop-down menu.
Following are the alternatives (however, not all of them are available at all times):
• Bit mask stops according to the bit mask of the selected signal.
• Disabled can temporarily disable a trigger condition.
• Falling edge level stops according to the selected signal, triggering level and

hysteresis values.
• Fault stops when the drive reports a fault.
• Event stops when the drive reports an event.
• Rising edge level stops according to the selected signal, triggering level and

hysteresis values.
• Warning stops when the drive reports a warning.

3. If you use Rising edge level or Falling edge level as the type for the triggering
condition, refer Using the level triggers.

4. Click Apply.

Using the level triggers

When condition Rising edge level is used, the functionwakes upwhen the actual value
of the triggering signal is below the triggering level - hysteresis. Similarly, when
condition Falling edge level is used, the function wakes up when the actual value of
the triggering signal is above the triggering level + hysteresis.

Triggering signal is below the triggering level when the Datalogger is
started:

Rising edge

Triggering occurs when the signal goes above the triggering level.

Triggering signal is above the triggering level when the Datalogger is
started:

Triggering occurs when the signal goes above the triggering level, but
before that the signal must go below the triggering level - hysteresis.

Triggering signal is above the triggering level when the Datalogger is
started:

Falling edge

Triggering occurs when the signal goes below the triggering level.

Triggering signal is below the triggering level when the Datalogger is
started:

Triggering occurs when the signal goes below the triggering level, but
before that the signal must go above the triggering level + hysteresis.

Using bit mask trigger

Bitmask trigger reads signal value andmasks out user selected bits with givenmask.
Masking is done by using a logical AND operation. Masked value is compared to user
given bit values selection. When masked value and bit values match, Datalogger is
triggered.
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￭ Uploading triggered or stopped Datalogger data
1. In the Datalogger view select a logger from the Logger drop-down menu. If the

logger status is stopped or triggered, data can be uploaded.

2. Click Upload to upload data to the monitor window.

Note: If youwant to continue normalmonitoring after using the Datalogger, click
Monitor configuration icon and select a sampling interval for monitoring.

3. Click Add signal icon to add signals for monitoring.
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￭ Amplitude logger (pro)
ABB drives have an amplitude loggers that can record data from various signals of a
drive. The results of an amplitude logger 1 (current) are displayed by the following
curve. Each parameter represents an amplitude range and showswhat portion of the
samples fall within that range.

Note: Dataloggers or amplitude loggers are not available for all ABB drives.
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Macro (pro)
ABB drives have Macro functionality that can automatize a task or sequence of tasks.
You can use macros is set parameter value to multiple networked drives when the
Customwindow functionality is not sufficient. You canalsousemacros for taskswhich
require logical or conditional parameterization of a drive.

• From the Drive Composer title bar, navigate to Tools→Macro.

A Macro screen is displayed.
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Macro commands

￭ Macro language
Macro language is based on PAWN. For general programming guidelines, refer to
PAWNmanual.

Note: Some PAWN features are disabled for security reasons, such as file operations
and other external IO functions.

Simple example

Macro tries to read parameter 1.1 value from each target in 100 network channels.

main()

{

for(new i = 0; i < 100; i++)

{

//note the channels are indexed instead of nodes

// this should be modified according network topology

//change target

Target(i+1,1)

new targetName[100]

//get target name TargetName (target name)

//read parameter 1.1 value

new Float:val0101 = ParRead(1,1);

//output to console

printf"%s(%d,%d): %f\n", target name, 1, 1, val0101;

}

}
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￭ Additional macro commands

Target

Changes the target of the macro command after target command is issued.

ExampleReturnsSyntax

Target (1, 10)0 if success, 1 if failedTarget (Channel, node)

Target name

Command reads the current target name as string.

ExampleReturnsSyntax

//reserve name string0 if success, 1 if failedTargetName (string)

new name[100] if(Target-
Name(name)==0)

{

printf "target name is %s\n"
name

}

ParWrite

Command writes parameter value to current target.

ExampleReturnsSyntax

//write value 1 to group 12 index 160 if success, 1 if failedParWrite (group, index,value)

main ()

{

ParWrite (12, 16, 1)

}

Note: The command does not write pointer or bit pointer type parameter values. Use
the ParWriteInt command to write pointer or bit pointer type parameter values.

ParWriteInt

Command writes parameter value to current target.
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ExampleReturnsSyntax

//writeparameter06.17.b0 toparameter06.60

main ()

{

ParWriteInt (6, 60, 1073743377)

}

To get the integer value 1073743377,

0 if success, 1 if failed.

If an error was detected, the
error message appears in the
log.

ParWriteInt (group, in-
dex, value)

1. In Drive Composer offline mode, set para-
meter 06.60 User status word 1 bit 0 sel =
06.17.b0

2. Right-click the value and set Integer
format.

Value P.6.17.0 appears in integer format as
1073743377.
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ParRead

Command reads the parameter value to current target.

ExampleReturnsSyntax

//Read value of the parameter in

group 10 index 5

main ()

{

new Float.val = ParRead(10,5);

printf “Value of (%d,%d):

%f\n”, 10,5, val105;

}

Parameter value or 0 if failed.

If an error is detected, the error
message appears in the log.

ParRead (group, index)

Note: The command does not read pointer or bit pointer type parameter values. Use
the ParReadInt command to read pointer or bit pointer type parameter values.

ParReadInt

Command reads parameter value to current target from the same source as in the
parameters window. The values are cached and refreshed on a notification or every
half a second, if you selected the Enable updating option in the parameters window.
When real time values are required, you can use the commandParReadIntFromDevice.

ExampleReturnsSyntax

//Read value of the parameter in group 7
index 11

main ()

{

new val = ParReadInt (7,11);

printf “Value of (%d, %d) :

%d\n”, 7,11, val;

}

Parameter value casted to in-
teger or 0 if failed.

If an error is detected, the error
message appears in the

log.

ParReadInt (group, index)
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ParReadFromDevice

Command reads the parameter value to current target directly from drive.

ExampleReturnsSyntax

//Read value of the parameter in group 1
index 11 each second.

main()

{

new Float:val;

do

{

val = ParReadFromDevice(1,

11);

printf "Value of

(%d,%d):%f\n", 1, 11, val;

Wait(1000);

}

while (1);

}

Parameter value or 0 if failed. If
an error is detected, the error
message appears in the log.

ParReadFromDevice
(group, index)

ParReadIntFromDevice

Command reads the parameter value to current target directly from the drive.

ExampleReturnsSyntax

//Read value of the parameter in group 7
index 11 each second.

main()

{

new val;

do

{

val = ParReadIntFromDevice(7,

11);

printf "Value of (%d,%d):%d\n",

7, 11, val;

Wait(1000);

}

while (1);

}

Parameter value casted to in-
teger or 0 if failed.

If an error is detected, the error
message appears in

the log.

ParReadIntFromDevice
(group, index)

Wait

Command delays the macro execution for given time in milliseconds.

ExampleReturnsSyntax

//wait 0.1 seconds

Wait(100)

0 in all casesWait (milliseconds)
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EndMacro

Command ends the macro execution.

ExampleReturnsSyntax

//End execution

EndMacro()

0 in all casesEndMacro()

GotoMacro

Command changes the macro execution. Currently running macro execution is
terminated.

ExampleReturnsSyntax

//Change execution to macro jeejee

new macrofilename[100] macrofi-
lename = “jeejee.p” GotoM-
acro(macro filename)

0 in all casesGotoMacro(string)

MessageBox

Command shows message box with ok button.

ExampleReturnsSyntax

//showmessage box

new message[100]

message = "dingalongdangdong"
MessageBox (message)

0 in all casesMessageBox (string)
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Control diagrams (Pro)

Contents this chapter
This chapter describes the use of control diagrams that help in understanding the
behavior of a drive.

Control diagrams overview
Control diagrams provide a graphical presentation of, for example, the control chain
of adrive, the speedand torquecontrol chainsand the logicof Start andStop functions.
With thesediagrams it is possible to seeparameter values related to certain functions.
Diagramsalso illustrate thepositionof switches according toparameter values,which
helps to understand how the drive logic works. The values of parameters can be
changed via control diagrams. A control diagram consists of two levels. The top level
shows an overview of the diagrams and connections between them.

￭ Note:
• Control Diagrams are drive-specific and they are not available for all drive types.

• When you connect a drive for the first time, it takes some time to upload control
diagrams from the drive. If Control Diagrams are not found in the drive, Drive
Composer asks to upload diagrams from the local source (PC).

Viewing control diagrams
1. In the drive list, click on a connected drive and select Diagrams.
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2. The top level of a control diagram consists of several diagrams and appears in a
separate tab. See the example screen below. To open a specific diagram, click on
a top level control diagram box.

The lower level control diagram appears in a separate tab. See the example diagram
below.
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To navigate back to the top level of a Control Diagram, click the Diagrams top icon.
To navigate through the reference chain, click the buttons circled in the figure above.

To zoom the control diagrams, use the zooming tool in the top left-hand corner of a
Control Diagram.
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FSO configuration (Pro)

Contents of this chapter
This chapter contains the configuration procedure of FSO-12 and FSO-21 safety
functionswithDriveComposer pro andprovides anexampleof how to configure these
optional FSO safety functions modules.

Configuring FSO-12 and FSO-21
The safety configuration of FSO-12 and FSO-21 safety functions module is available
only in Drive Composer pro, DCPT-01 (code: 3AUA0000108087).

￭ Note:
• Only trained persons are allowed to configure the safety functions.

• Stop the drive before configuring the safety functions modules. You cannot
download/upload the configuration file to/from safety functions module or
change the password when the drive is modulating.

• You need a password to copy the configuration to the safety functions and also
to validate the safety parameter settings.

Fordetailed informationaboutFSO-12andFSO-21, refer the respective safety functions
module user’s manual:

• FSO-12 safety functions module user’s manual (3AXD50000015612 [English]).

• FSO-21 safety functions module user’s manual (3AXD50000015614) [English]).

￭ Hardware connection
The hardware connection is common for both FSO-12 and FSO-21 safety functions
module. For instructions on the hardware connections, refer FSO-12 safety functions
module user’smanual (3AXD50000015612 [English])/ FSO-21 safety functionsmodule
user’s manual (3AXD50000015614 [English]).
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The followingconfigurationdescriptionassumes that all hardware-relatedconnections
are made properly and the ID run procedure of the drive is completed.

￭ Setting the safety functions with Drive Composer pro

WARNING!
Themotormust be stopped. Safety configuration file canbe edited (and sanity
checked) inOffline/Virtual Drivesmode for offline configuration. Edit and save
the file to PC without connecting to the drive/FSO.

1. Power up the drive. Make sure that the motor is not running. See Working
area (page 71).

2. Right-click on drive and select Safety settings.

In online mode with FSO installed, the safety configuration already available in
the drive is displayed (refer figure below). In offlinemode the view is always empty
before opening the safety file.

You can switch between Graphical view and Parameter view. Refer Figures FSO
configuration: Graphical view and FSO configuration: Parameter view.
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3. Click Read settings from drive.

Note:When you upload the safety settings from FSOmodule to PC tool, the FSO
goes intoConfiguration state and indicates a fault. You can exit theConfiguration
state by rebooting the FSO module if you do not want to download the settings
but want to keep the existing setting.
The Fault FSO general fault: 7A8B appears on the drive.

4. Type the password (8 numbers). The factory default password is “12345678”.

Note: You can change password by clicking Change password (refer figure FSO
configuration: Parameter view). Make sure the drive is not modulating. The
password must contain 4…8 digits. Do not forget the new password; otherwise
youhave todoa factory reset to the FSOwhich clears the configuration and resets
the parameters to the factory defaults.

5. Configure the safety parameters. Set the following safety function parameters:
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• General parameters: Check that the motor parameters are correct.
• I/O: Check that I/O parameters are set according to the installation (wiring)

plan. Remove diagnostic pulsing from any unused I/O. The test pulses are off
by default. Check possible safety relays and cascade connections.

• Safety functions: Check all safety settings. You must at least check and set
theSTOandSSE relatedsettings, regardlessofwhicheverFSOsafety functions
you use. The FSO activates the STO and SSE functions (also in internal fault
situations). The FSO uses the STO and SSE functions for making the system
safe. All other functions are used only for monitoring the drive.

Note:

• Graphical viewcannotbeused for setting safe IO, cascade functionor for SBC
function (refer Figure FSO configuration: Graphical view). Instead use the
Parameter view (refer Figure FSO configuration: Parameter view).

• Parameter groups (200, 91 and 92) that include common parameters to drive
and FSO are referred with group numbers and index numbers.

• Group names like FSOGEN, STO and so on have only index numbers (refer
Figure FSO configuration: Edit parameters).

For detailed information about FSO-12 and FSO-21 configuration settings, refer
the respective safety functions module user’s manual:
• FSO-12 safety functionsmodule user’smanual (3AXD50000015612 [English]).
• FSO-21 safety functionsmodule user’smanual (3AXD50000015614) [English]).

6. If required, click Filter functions by setups and filter the safety functions tile. You
can click anyof the filteringoptions to viewsafety functions related to the selected
selection.

7. In the Graphical view, double-click to open the function. Use the slider switch to
enable or disable a function.
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Note:

• By default, General settings, SSE-Emergency stop, and STO- Torque off
groups are enabled and cannot be disabled.

• Some functions are dependent on their main functions. Enable the main
function to activate its dependent functions. For example:

• SDI-Safe direction can be enabled only if you enable the main Encoder
function.

• Profisafe-Variable SLS can be enabled only if you enable the main
Profi-Safe Activation

• SLSxGeneral Settings is automatically activated if you enable anyof these
main functions: SLS1...SLS4 or the ProfiSafe-Varialbe SLS.

Seealso the representationsof enabledanddisabled functions inbelow figure.
Note that a dependent disabled function appears in a dotted box.

___,. Encoder 

Disabled 

Encoder 

----.. Enabled 

I 
Disabled 

I 
I 
I 
I 

I 

I 

SDI - Safe Direction 

Disabled 

�----  Dependent function

Function enabled

Function disabled

• After youmake changesand if you try todisable a function, awarningmessage
dialog box appears. Click Yes to save the changes and disable the function.
This helps to make the changes available during the edit. To discard the
changes, click No.

8. In the opened tile view, configure the function and edit the necessary parameters.
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9. Click Save to save the changes. ClickReset if youwant to disable the function and
reset the values to default values. A yellow circle appears in the function, if you
change the default values in the function.

If you close the window before you save the changes, a warning message dialog
box appears. Click Yes to save the changes. To cancel the changes, click No.

Note: In graphical view the SAR settings are combined with safety function
parameters. Using the reset option for parameters that are used crosswise (e.g.
SAR1 is used with SS1 and SLS functions) resets the particular settings for both
functions. The functionworks the same inparameter view inwhich theparameters
are in separate groups.
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10. In Parameter view, double-click on the value field and change all necessary
configuration settings to match the safety configuration.

11. Test your safety configuration when the motor is running.

12. Right-click on drive and select Parameters to check the values in parameter

group 200.

You can also validate the safety function parameters using the signal monitoring
feature. See the instructions for Adding parameters/signals for monitoring. It is
possible to check the ramp times and the statusof bit changes in the timedomain.
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13. Check the values in online mode while testing the safety functions. If there are
unexpected values, right-click the parameter and select Refresh the parameter.

14. After testing save the FSO configuration to PC. In Parameter view, click Save to
file.

The file is savedasdcsafety formatand theFilewritten successfully dialogappears.
Click Ok.

15. Click Apply settings to drive.

16. Enter the password to apply the settings to the drive and click Ok.

The following Validate dialog appears. Click Yes.
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Note: If you do not want to download the changes in safety parameters, you can
boot FSO without downloading to FSO using Reboot FSO (refer figure FSO
configuration: Saving the safety settings).

17. Click Ok to close the dialogs.
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￭ Printing the safety functions configuration report (Online)
With the FSOmodule installed, you canprint the online safety functions configuration
report.

1. From the Safety settings view, click Print report.

2. Select a print template and click Continue.

3. Fill in the Drive and FSO version information. Click Next.
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The next screen(s) contain different aspects of safety configuration such as
configured safety functions, commissioning checklist, and so on.

The List of configured safety functions andacknowledgedmethods appears. Click
Next.

In the FSO commissioning checklist, click on the check boxes to mark
configurations are ok. Click Next.
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In the FSO changes/repair details, type the required details and click Next.
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4. In the final screen fill in the required details and click Print preview.

5. Select the required printer settings and click Print.
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The configuration and commissioning report is printed based on the selected printer
settings.

￭ Printing the safety functions configuration report (Offline)
To print a FSO safety functions configuration report in the Offline mode, you must
have a saved safety file. See section Setting the safety functionswithDrive Composer
pro (page 142).

1. Click Tools → Safety Configuration Report.

2. Select the saved file to print and click Continue.

Continue fromstep 3 in sectionPrinting the safety functions configuration report
(Online) (page 150).
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Changing FSO module password
1. Right-click on drive and select Safety settings.

2. In the Safety settings window, click Change password.

3. In the Change password dialog, type the old or default password and type the
new password. Click OK.

Note: The password should contain 4...8 numbers. For more information, refer
FSO module manual.

4. Wait while the password change is in progress and the parameters are reloaded.
Click OK.
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5. Click OK, to confirm the password change. You can test the new password, for
example, to log in to FSO module (refer section, Continue from step 3 in section
Printing the safety functions configuration report (Online) (page 150), page 152.)
or to readFSOdrive parameters (refer section, Reading FSOmodule parameters).

156 FSO configuration (Pro)



Reading FSO module parameters
To read the FSOmodule drive parameters:

1. In the Safety settings window, click Read settings from drive.

2. Type the FSO module password. Click OK.

3. Wait while Drive Composer is updating the safety parameters file and displays
the safety settings dashboard. Click Parameter view to switch to parameter
window and vice versa.
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Drive configuration

Contents of this chapter
This chapter contains the configuration procedure of the drive.
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Loading firmware (entry)
To load the drive firmware,

1. Make sure that the drive is connected to Drive Composer via USB cable. For more
information, refer section Connecting to drive (page 30).

2. Power up the drive.

Note:Make sure that themotor is not running (inverter) or theunit is not operating
(supply unit).

3. Select the COM port to which the drive is connected, and click Connect.

4. Click Tools→ Drive firmware loader.

The Firmware update window appears.

If you have connected the Drive Composer in the demomode, and you open the
drive firmware loader, a FIRMWARE UPDATEwarningmessage appears. ClickOK.
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5. Click Browse to upload the firmware package from your computer.

Note: Login and cloud update features are only available in Drive Composer Pro.

Note: The tool displays an error message when:

• You try to load an invalid loading package file.

• You upgrade Drive Composer without first uninstalling the previous version.
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6. In the firmware update window, Click Next.

7. Select the desired check boxes to,

• create a parameter backup file before updating the firmware.
• restore the parameters automatically after the firmware update.
• delete the parameter back file after the parameter restore.
Select a custom location or use the default backup storage to save the file if you
want to create a backup.

Note: In ACS380, for successful parameters back up and restore, the drive needs
to be in local control mode. Hence, during a firmware update, if the drive is in
remote control mode, the tool automatically changes it to local control mode.
After the firmware update, the control mode is restored to its original mode.
Click Start.
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8. Wait for the firmware to be loaded. The loading time can bemore if you select the
parameter backup option.

The message Parameterschanged. Parameters are reloaded appears. Click OK.

9. The firmware update is complete when the progress bars turns green and a
message appears that the Drive firmware update is successfully done! Click
Close.

Drive configuration 163



Loading firmware (pro)
To load the drive firmware,

1. Make sure that the drive is connected to Drive Composer via USB cable. For more
information, refer the section Connecting to drive (page 30).

2. Click Connect.

Note: If drive is connected via aUSBcable, DriveComposer automatically discovers
the drive.

3. Power up the drive. Make sure that the motor is not running (inverter) or the unit
is not operating (supply unit). Refer section Using the working area (page 71). If
drive is connected via USB cable, Drive Composer automatically discovers the
drive.

4. Click Tools→ Drive firmware loader.
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The Firmware update window appears.

If you have connected through Ethernet cable or the Drive Composer in the
Offline/Virtual Drives mode, and you open the firmware loader, a FIRMWARE
UPDATE warning message appears. Click OK.
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5. Click Log in to view the firmwares.
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6. Select the firmware package. You can either select the firmware from cloud or
upload from your computer.

• To select the firmware package from the cloud, clickCloud update, select the
firmware package and click Select.

Note:Availability of drive firmwaredependson thedrivemodel and configuration.

An error message is displayed if the system cannot connect to the cloud.

• To select the firmware package from your computer, click Offline update,
Browse the package and click Select.

Note: If you try to load a corrupted or invalid loading package file, the application
displays an error message.
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7. If multiple drives are connected, from the selection list, select the drive to load
the firmware and click OK.

8. In firmware update window, Click Next.
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9. Select the desired check box if you want to create backup, restore parameters
from backup file or delete the file automatically after parameter restore. Select
the location to save the file if you want to create a backup. Click Start.

Note: In ACS380, for successful parameters back up and restore, the drive needs
to be in local control mode. Hence, during a firmware update, if the drive is in
remote control mode, the tool automatically changes it to local control mode.
After the firmware update, the control mode is restored to its original mode.

10. Wait for the firmware to be loaded. The backup time can bemore if you select the
parameter backup option.

The message Parameters changed. Parameters are reloaded appears. Click OK.

11. Optional (only with access to DIB): Enter the service report information. Formore
information, refer sectionCreate online service report (page 206).Note:Youneed
access to Drive installed base to send the service report.
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12. Optional (only with access to DIB): Click Send.

The installation successful page appears.

13. Click Close.
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Loading firmware to an empty memory unit
You can load firmware to a drive with an empty memory unit, for both ZMU and UMU
memory units.

￭ Loading firmware to an empty ZMUmemory unit
1. Make sure that an empty ZMUmemory unit is connected to the drive.

2. Start Drive Composer.

3. Select USB/COM enabled, and click on Offline/Virtual Drives.

4. Click Tools→ Drive firmware loader.

The Drive firmware loader window appears.

5. Click Browse and select the bootloader file (.lp) in your PC.
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6. Click Select.

7. Enable the required software package to be loaded (Eg. Software package 1.), as
shown in above figure.

8. Readandaccept the agreement to install the firmwarepackage, as shown in above
figure. Click Start.

The firmware update begins.
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9. After the firmware is updated the Completed message appears.

10. An error mesage appears to prompt on rebooting the drive. Click Next.

11. The firmware installed successully message appears. If drive is not connected,
make sure that all the instructions displayed in the message are satisfied.

12. Start Drive Composer again and repeat steps 3 & 4.
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13. To install the CBinfo package to the drive, do the below steps:
a. Click Browse and select the CBinfo package file (.lp) in your PC.

b. Click Select and Start to begin the firmware installation.
c. After the firmware is updated the Completed message appears.

14. An error mesage appears to prompt on rebooting the drive. Click Next.

15. Start Drive Composer again and repeat steps 3 & 4.
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16. To install the Drive firmware loading package to the drive, do the below steps:
a. Click Browse and select the Drive firmware file (.lp) in your PC.

b. Click Select and Start to begin the firmware installation.
c. After the firmware is updated the Completed message appears.

17. The firmware updated message appears. Click Next.

The firmware is successfully updated.
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￭ Loading firmware to an empty UMUmemory unit
1. Make sure that an empty UMUmemory unit is connected to the drive.

2. Start Drive Composer.

3. Select USB/COM enabled, and click on Offline/Virtual Drives.

4. Click Tools→ Drive firmware loader.

The Drive firmware loader window appears.

5. To install the CBinfo package to the drive, do the below steps:
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a. Click Browse and select the CBinfo package file (.lp) in your PC.

b. Click Select and Start to begin the firmware installation.
c. After the firmware is updated the Completed message appears.

6. An error mesage appears to prompt on rebooting the drive. Click Next.

7. Start Drive Composer again and repeat steps 3 and 4.
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8. To install the Drive firmware loading package to the drive, do the below steps:
a. Click Browse and select the Drive firmware file (.lp) in your PC.

b. Click Select and Start to begin the firmware installation.
c. After the firmware is updated the Completed message appears.

9. The firmware updated message appears. Click Next.

The firmware is successfully updated.

178 Drive configuration



Loading the fieldbus adapter firmware
These fieldbus types are supported:

• FPNO-21 PROFINETFieldbus adapter module

• FEIP-21 EtherNet/IP fieldbus adapter module

• FBIP-21 BACnet/IP adapter module

• FMBT-21 Modbus/TCP adapter module

Note: It is not possible to use the drive and fieldbus adapter loader simultaneously.

To update the fieldbus adapter firmware, do the below steps:

1. Go to Control Panel and click network and Sharing Center.

2. Click Change adapter settings on the left pane. A Network connections window
displays.

3. Double-click Local Area Connection.
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4. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

Local A ea Co ection P�o erties 

1 

! Internet Protocol Version 4 {TCP /I P-v4)
·-------- --------------- -- -- ----------------- ----

X 

5. Select Use the following IP address, type the IP address and subnet mask and
click OK.
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6. To enable the fieldbus adapter module in the drive, select the slot connected to
the adapter module in parameter 50.1 FBA A enable.

7. To connect the drive to the fieldbus adapter module,

• Set a static IP address in parameter group 51. You can use address:
xxx.xxx.xxx.xxx. The drive must have a unique address.
For example:
drive 1: xxx.xxx.xxx.xxx
drive 2: xxx.xxx.xxx.xxx
drive 3: xxx.xxx.xxx.xxx
etc.
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8. Refresh the fieldbus adapter in parameter 51.27 FBA A par refresh.

9. Go to View → Settings.
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10. In the Setting window, click Ethernet config...

11. Enter the same IP address configured in the parameter group 51 into the drive
Ethernet configurator tool.

12. Click Add fixed ip and the new IP addresses appear in the Fixed IP address list as
shown in the above figure.

13. Click Save fixed IPs and the new IPs are saved. Click exit to close the window.
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14. Go to Tools → Fieldbus adapter loader.
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15. In the Fielbus firmware update window, select the firmware package. You can
either select the firmware from cloud or upload from your computer.

Firmware
update -
cloud

To select the firmware from the cloud, click on Log In.a.

Drive Composer login window appears.
b. Enter email address and click Login.

The available fieldbus firmware packages appears.
c. Select the package from the list and click Select to update the

firmware.

IfDriveComposer failed todownlod theselected firmwarepackage,
due to, eg. Network failure, the below error message appears.

Check the possible occurrences and do the update again.
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Firmware
update -
Offline

a. To select the firmware offline, click on Offline.

b. ClickBrowseandselect signedPKI package for theoffline firmware
loading and then click Select.

c.

Note: The tool displays an error message when:

• You try to load an invalid loading package file.

• You upgrade Drive Composer without first uninstalling the
previous version.

It is not possible to save the signed PKI packages to the PC for
offline firmware loading.
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16. Click Next to update the firmware.

The installation successful message appears.

Note:Make sure the Ethernet cable is properly connected to the drive/fieldbus
to prevent any failure with the firmware updates.

17. After the firmware is updated the completed message appears. Click Close.
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Drive backup

￭ Creating a backup of a drive

Note: Creating a drive backup is possible only when parameter 96.102 User lock
functionality, bit 6 Protect AP has value 0, that is backup/ restore backup function
is enabled.

1. Click on a connected drive and select Backup/restore.

2. Select the file location for the backup and give a name for the backup file.

3. Click Backup to start the backup process.
The backup process takes a few minutes.

You can also create a backup in the drive parameter view. See Creating a backup in
drive parameter view.

￭ Creating a backup in drive parameter view

Note: Creating a drive backup is possible only when parameter 96.102 User lock
functionality, bit 6 Protect AP has value 0, that is backup/ restore backup function
is enabled.

1. In the parameters view, click on Save parameters to file icon.
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2. Select a file location in your computer for the backup and give backup file name.
Click Save.
The backup process takes a few minutes.
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￭ Creating a quick parameter backup (pro)

Note: Creating a drive backup is possible only when parameter 96.102 User lock
functionality, bit 6 Protect AP has value 0, that is backup/ restore backup function
is enabled.

The quick parameter backup feature helps to create a faster parameter backup, when
the network speed is slow and effects the communication speed between Drive
Composer and the drive. In quick parameter backup, the Drive Composer stores only
the parameter groups that are viewed, expanded or edited. This helps to save the
parameter backup time and avoids parameter backup failure.

When the drive parameter backup is slow, the function automatically detects the
connection speed between the Drive Composer and the drive, and provides you an
option of quick parameter backup. You can select between a full parameter backup
or a quick parameter backup.

Notes:

• This function is applicable when the drive is connected to the Drive Composer via
Ethernet cable.

• The restore function works as usual, i.e. the function restores the complete
parameter list.

To create a quick parameter backup,

1. Go to View→Settings.

2. In the Settings screen, select the option Quick parameter backup.

Drive configuration 191



3. Click Save to save the new settings.

4. You may be prompted to restart Drive Composer. Click OK, to restart.

You can select this option, and create a backup in the parameters view for a quicker
save operation and a smaller backup file. See Creating a backup in drive parameter
view.
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Restoring a drive

￭ Restoring a drive backup

Note: Restoring a drive backup is possible only when:

• The drive is in Local control mode.

• Parameter96.102User lock functionality, bit 6ProtectAPhasa valueof0, enabling
the backup/restore backup function.

Restoring a parameter file will overwrite the Adaptive program.

1. Click on a connected drive and select Backup/restore.

2. Select the backup file to restore to the drive.

3. Click Restore.

Note:Make sure not todisconnect theUSB cable from thedrive during the restore.
All available components are restored from the backup file and all unavailable
components are preserved in the drive. A detailed status is available in a log file
that is saved on the PC.
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If the restore fails, an error message will appear. Click OK.

Restart Drive Composer, and check the connections before attempting to restore
the backup again.

4. You can check the log file saved at
C:\Users\CurrentUser\Documents\DriveWare\Composer\Logs.

￭ Restoring a backup in the drive parameter view

Note: Restoring a drive backup is possible only when:

• The drive is in Local control mode.

• Parameter96.102User lock functionality, bit 6ProtectAPhasa valueof0, enabling
the backup/restore backup function.

Restoring a parameter file will overwrite the Adaptive program.

Open a parameter backup file. Click Download to device icon.

All available components are restored from the backup file and all unavailable
components are preserved in the drive.
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￭ Restoring a set of components/parameters settings (pro)

Note: Restoring a drive backup is possible only when:

• The drive is in Local control mode.

• Parameter96.102User lock functionality, bit 6ProtectAPhasa valueof0, enabling
the backup/restore backup function.

Restoring a parameter file will overwrite the Adaptive program.

With theAdvanced restore function you can restore separate items or group of items
in the backup file.

1. Click on a connected drive and select Backup/restore.

2. Click Advanced restore to select a restored backup file.

3. Select a saved backup file and click Open.

4. In All Items, you can select single item(s) or a total group to restore. Click right
arrow (>>) to move the selected items to Selected items.
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Note: Themessage “Please remove the selected items to restore disabled items.”
appears inside the restore window only when you select

• single item(s) and all other items are disabled, or

• a group item and all single items are disabled.

5. Click Restore.
The selected items are restored from the backup file. A restored successful
message appears. Non-selected items are preserved in the drive.

Note:

• The parameter values that are notwritten to the drive are listed in the restore
report after the restore process.

• The drive does not allow to restore the grey items in the advanced list.
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Other functions

Contents of this chapter
This chapter describes common functions that are not associated with any view or
window.

Using Drive Installed Base service
Drive InstalledBase (Drive InstalledBase) is a knowledgebase for all information about
drives. Using Drive Installed Base service you can,

• register an ABB drive through Drive Composer

• obtain the required drive information

• create service reports.
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￭ Registering an ABB drive to Drive Installed Base service
1. From the drive context menu select Register drive, or go to Tools→ Register

drive.

If you used the drive context menu, make sure that Drive Composer is connected
online with the drive for successfully registering the drive. If you used Tools→
Register drive, you can register the drive when Drive Composer is either in
online/offline mode with the drive.

2. In the Drive registration tab, type the drive serial number (for example, 7350008)
and click Validate. You can see the drive serial number on the type designation
label or see the drive’s hardware manual for more information.

Drive Composer connects to Drive Installed Base portal (external website) and
validates the serial number with an associated type code. If the number is valid,
the drive type code is automatically filled. For example, FREQUENCY
CONVERTACS580 DEMOSUITCASE.
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Note: You can register a serial number for first-time only. If attempted second
time, the message “This serial number has been already registered” is displayed.

3. Enter drive location details in the appropriate fields.

InformationField name

Name of country where the drive is located, for example, India.Site country

Nameof companywhere thedrive is located. For example, ABB India.Company name

Site name where the drive is located.Site name

Name of the city where the drive is located.Site city

Postal codeSite postal code

Site address.Site address

Optional. Plant /building name where the drive is located.Plant/Building

Optional. Area/room where the drive is located.Area/Room
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4. Type First name, Last name and email address of the drive owner or the contact
person details. Phone number is optional.

5. Type/select drive information in the appropriate fields.

InformationField name

Optional. Customer identification of drive, if available.Customer equipment id for the
Drive

Drive commissioned startup date.Commissioning start up date

Application where the drive is used (for example, Spinning).Application

Criticality of the application based on the time required to stop
the drive in the event of a fault.

Criticality in process

Low - No direct impact Medium - Delayed stop High - Immediate
stop

Industry where the application is in use.Industry
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6. Check and accept the Terms and conditions, and click Next.

7. Check the summary of registered information and click Save.

The “Registrationwas completed successfully”message is displayed. Youwill also
receive an email to the registered email address
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￭ Searching a registered ABB drive in Drive Installed Base
You can search for information about an ABB drive that is registered in Drive Installed
Base service portal. Note: Make sure you have access permissions to Drive Installed
Base service portal.

1. From drive context menu select Search drive from DIB or go to Tools→ Search
drive from DIB.

• If you used the drive context menu, Drive Composer extracts the drive serial
number directly from the connected drive. Otherwise the “Drive has not got
serial number” message is displayed.

• If you used Tools→ Search drive from DIB, Drive Composer asks for serial
number.

2. Type the serial number and click Ok.

• If the serial number matches with the drive data in Drive Installed Base, Drive
Composer downloads all data related to the drive and opens in a separate
tab .

• If you typed a wrong serial number or if the drive was not registered in Drive
Installed Base, themessage............................................. “Authorization failed, do
you want to log in again” or “Drive has not got serial number” is displayed.
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3. Click Product info, to view the drive information, for example, serial number, type
code, commissioning date, etc.

4. Click Service history, to view the maintenance history of the drive, for
example,event or service type, date of service, name of service engineer, etc. You
can download the attached service report file, if the file was added to the report.

5. Click Recommended services, to view the recommended drive services.

6. Click Components, to view the details of service components.
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￭ Setting the Drive Installed Base server location
The drive data is stored only in two server locations: Europe and China. The default
location is Europe. For drives located in China, select China and for drives located in
countries other than China, select Europe.

1. Go to View→Settings.

2. In the Settingswindow, select the appropriateDrive InstalledBase server location.
Example: Europe.

3. Click Save.

The Drive Installed Base server location is set to the selected country.
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￭ Creating a service report from Drive Installed Base
You can create a service report for an ABB drive registered in Drive Installed Base, if
you have access permissions to the Drive Installed Base portal.

Note: The service report templates arepredefined.However, if it is necessary to change
the template, contact your local ABB representative.

1. Click on the drive list, selectCreate service reportor go toTools→Create service
report.

2. In the Service reporting page, click Select.

3. Select the appropriate drive. Click Ok.
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4. In the Service reporting page, type the drive serial number.

5. In Select service type field, select the necessary service type, for example,
ACS880-01 Cooling fault - Code 4290.
Note: Drive Composer downloads the selected service type. If downloading failed
due to network error, you can use the previously downloaded Service pack.

6. If the registered drive serial number and service type matched with the Drive
Installed Base data, you canCreate online service report or Creating offline report.
See sections below.

￭ Create online service report
Note: The contents in the report pagearebasedon the service type andsomecontents
in thewizardmaybe filledwith information fromthedrive if the serial numbermatched
with the drive.

In the below steps, refer an example report of ACS880-01 Cooling fault.

1. Click on the drive list, selectCreate service reportor go toTools→Create service
report.

2. Wait while Drive Composer connects to the Drive Installed base.

3. In the service reporting page, click Select to select a connected drive or enter the
drive serial number.

4. Click Report online.

5. In the General Info page, fill the necessary information. Click Next.

Note: All mandatory fields in this page and in the consecutive pages are marked
with an asterisk (*).
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6. In the End customer page, type details of location where the drive is installed.
Click Next.

7. In the Onsite check list, check and confirm that all actions are completed. Click
Next.
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8. The Attachments page is optional. You can add the required attachments to
support the service report.

9. In the Components list, confirm that the listed components are available in the
drive. Check against the listed component to report toDrive InstalledBase service.
Click Next.
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10. The consecutivepages forMaterial data areoptional. You can fill up to fivematerial
data. Type the information if necessary and click Next.

11. Navigate to Material data 5 and fill required data. Click Send.
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12. Read and accept the privacy terms and conditions. Click Next.

13. If report is sent, themessage “Sending toDrive InstalledBase completed” appears.
Click OK.

If report sending failed, DriveComposer prompts to save the report asOffline reports,
which you can try sending later. See Creating offline report.
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￭ Creating offline report
Note: The contents in the report are based on the service type and some contents in
the wizardmay be filled with information from the drive if the serial numbermatched
with the drive.

1. In the service reporting page, click Create offline report.

A service report is generated and appears in the Offline reports table.

2. Select the report and do the necessary actions:
• Click Edit, if it is necessary to modify the report. See section Create online

service report (step 3 onwards).
• Click Send,if the report is ready to send to Drive Installed Base.
• ClickRemove, to delete a report. Confirm themessage “Theoffline report has

not been sent to Drive Installed Base. Are you sure you want to remove it and
lose all changes?”

3. If you clicked Send, read and accept the privacy terms and conditions. ClickNext.
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4. If report is sent to Drive Installed Base service portal, the message “Sending to
Drive Installed Base completed” appears. Click OK.

If report sending failed, DriveComposer prompts to save the report asOffline reports,
which you can try sending later.

Recovery and prevention of FB14 fault in drive
When the fault FB14 is active, the drive’s control panel displays the fault message
(refer figure below).

Drive Composer can be used to remedy this fault by:

1. recovering the drive (refer FB14 Recovery pack) and

2. preventing the fault (refer FB14 Service pack).

You can check the status of Service pack installation in the System infowindow. Refer
Checking the status of Service pack (page 217).
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￭ FB14 Recovery pack
1. If there is FB14 fault active in the drive, Drive Composer detectsthis and prompts

to recover the fault using FB14 Recovery pack. Click Start downloading to run the
Recovery pack. Follow instructions in the note and wait while downloading is in
progress.

Note: If downloading theRecoverypack failed, follow instructions in FB14Recovery
and Service pack failure.

2. After installation is completed, drive is recovered and FB14 fault is reset.

The drive may be functional now, but the fault root cause still exists in the drive.
Proceed with installing FB14 Service pack, to completely prevent the FB14 fault.
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￭ FB14 Service pack
1. In the Recover drive window, click FB14 Service pack.

2. In the FB14 Service pack window, click Continue. Follow instructions in the Note.

3. Before installing the Service pack, Drive Composer creates a parameter backup.
Check Parameter backup.

4. If you prefer to change the backup folder, browse to select a new folder and click

WARNING!
Do not interrupt the drive during backup and loading process, this may
cause severe damage to the drive.

5. WaitwhileDriveComposer completesparameterbackupanddownloading. Follow
instructions in the note.
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6. After installation is complete, Drive Composer sends the Service pack update
event to ABB server. Later this information is maintained in the Drives Installed
Base. Click Next.

7. A thank you message appears to acknowledge the Service pack installation. You
can continue using the drive with the parameter backup saved in your PC. To
access the saved location, click on the link Open file location.

See also,
• Sending offline FB14 Service pack event
• FB14 Recovery and Service pack failure
• Checking the status of Service pack
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￭ Sending FB14 Service pack event
After the FB14 Service pack installation and update is completed, Drive Composer
automatically sends the service information to ABB server. The server is updated
periodically to transfer the service information toDrives Installed Base (Drive Installed
Base) inwhich theDrive history ismaintained. See figure FB14Service pack installation
DONE!.

￭ Sending offline FB14 Service pack event
If networkwas offline during FB14 fault remedy, the “................... no connection to ABB
server”message appears. DriveComposer saves the event report locally and confirms
if the report can be sent at the next start whenever the drive is online.

￭ FB14 Recovery and Service pack failure
If the Recovery and Service pack process failed, Drive Composer opens the default
mail client with filledmessage, for example, drive ID andDrive Composer version. You
can check the filled details and send the mail to ABB global technical support to help
diagnose the cause of failure.

Note: Drive ID is filled only when the Service pack installation fails. Drive Composer
attaches the log file to the mail. But you can also attach the backup file.
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￭ Checking the status of Service pack
You can check the status of Service pack installation from the System info window.

The following status appears in the System info window:

DescriptionStatus

indicates that thedrive requiresServicepack installation. ABB recommends
to install the Service pack to prevent any possible fault in the future.

To install,

UpdateAvailable(Recommen-
ded)

1. Click on the status.
Note:Make sure that the drive is poweredon andUSB cable is connec-
ted between drive control panel and PC.

2. Follow the instructions on how toproceedwith installation. See, FB14
Service pack, step 7 onwards.

indicates that Service pack is installed in the drive, and no further action
is required.

Updated

indicates that the memory unit or drive firmware includes the FB14 fault
remedy and drive does not require Service pack installation.

Not Required
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Using the Drive text editor
You can manage user editable texts using the Drive text editor. The function allows
to read texts from the drive, to make changes and to update texts to the drive.

1. From the Drive Composer title bar, select Tools→ Drive Text Editor.

2. Select the drive to work with and click Ok.

The Drive text editor is started and attached to the selected drive.

3. Click Read, to read the data from the drive and make the changes in the column
Localized text. Also, select theEnable checkbox todisplay the contact information
in the panel.
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Note:

• The changed text appears as highlighted until it is saved.

• The contact info appears in the preview even if the Enable check box is not
selected.

4. Click Preview, to review the changes.

Previewof External fault 1Warn-
ing label

Preview of External fault 1 Fault
label

Preview of Contact info

5. In the Drive text editor window, click Apply.

The changes are written to the drive and the message Parameters changed.
Parameters are reloaded appears.

6. Click OK.
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Using the Drive parameter conversion tool (pro)
Theparameter filesofACS800/ACS600ABBdrive typescommissionedandmaintained
with Drive Window can be accessed with Drive Composer via the Drive parameter
conversion tool.

Note: Not all ACS800/ACS600 drives and software are supported.

1. From the Drive Composer title bar, select Tools→ Drive parameter conversion
tool.

2. In the Drive Parameter Conversion Introduction screen, click Next.

3. Browse and select appropriate source and destination drive parameter files.
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Note: Select an empty parameter file with default values. You must create an
offline parameter file (of the destination drive family) to select here.

4. Select a file name to save the target file. Click Next.
Note: Do not overwrite the empty file.

5. Answer Yes.

The Conversion report shows the parameters which are converted successfully
and failed. Read the report carefully and fix the parameter values manually for
which the conversion was not successful.
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Using the PSL2 data logger (pro)
With BCU-x2 control unit, you can upload the PSL2 data logger files from the drive
flashmemory to PC local harddrive. The files contain real timedata from the converter
modules that help in fault tracing and analysis.

Note: The files can be uploaded from drive to local computer only. You cannot read
the contents or open the files. For any further assistance contact ABB customer
support.

￭ Uploading PSL2 data logger files
1. From the Drive Composer title bar, select Tools→ PSL2 data logger.

2. Move the PSU data logger file(s) that you want to upload to the right side box.
Use the right arrow (>>) or the left arrow (<<) button.
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3. In the Upload directory field, click and select an upload folder in your PC local
hard drive.

4. Click Upload...
The selected files are transferred to your local folder.

Using the PSL2 data viewer (pro)
You can open and view contents of the uploaded PSL2 data logger files in the PC local
hard drive. The files contain real time data from the converter modules that help in
fault tracing and analysis.

￭ Viewing PSL2 data logger files
1. From the Drive Composer title bar, select Tools→ PSL2 Data Viewer.

2. PSL2 Data Viewer screen with PSL2 plotting tools appears. The plotting area is
empty by default. See PSL2 Data Viewer instructions below to open and save the
plot.
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￭ PSL2 Data Viewer instructions
The PSL2 plotting tools can be used to plot current and DC voltage using the uff or
csv file. The table below describes how to use the plotting tools. Match the below
instructions with the above PSL2 Data viewer screen.

InstructionAction

In the PSL2 Data Viewer window, clickOpen file icon and
select the file to open.

Opening uff or csv file.

Click Save to CSV icon.Saving the plot as csv file.

Click Save plot icon.Saving the plot into different file formats.

Select number of channels in the Number of visible
channels

Selecting number of channels to view in the
plot.

drop-down list.

See in Selected channel drop-down list..Viewing the selected channels.

Click on Use only one axis check box.Aligning selected channels on the same axis

Use this option todrawall selected channels on the same
axis.

Set requiredminimumandmaximumvalues in thebelow
fields and click on Update axis button.

Setting minimum and maximum values of X-
axis and Y-axis

• Y-axis min
• Y-axis max
• X-axis min
• X-axis max
Note: Themin/max values of X-axis and Y-axis are equal
in all visible plots.

Click on Auto Scale button.Scaling X-axis and Y-axis automatically

The largest and smallest values of data are scaled to Y-
max Y- min respectively.

Note: This action does not maintain the same scale in
every parallel axis.
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InstructionAction

Click on Default Scale button.Resettingmin/max values of Y-axis to default
values The graph is reset to the updated default values.

Set current and voltage values in Curr meas range [A]
and

Updating calculation parameters to plot and
recalculate the data

DCmeas range [V]. Click on Update button.

Click on the tabs to view the required plot:Viewing different plots

• Total Current and DC SI
• Sum currents %
• Phase X current diff %
• Sum current filtered %
• DC voltage diff %
• Module currents % and DC %

• use the right mouse button to move (pan) the plot
up/down. The x-/ y-axis moves accordingly.

• use the mouse wheel to zoom the plot. Zooming
multiple channels works best when the cursor is
placedonanempty space i.e. topof upper axis, below
the lower axis, or between the axis.

• mark a rectangle with Ctrl+Right mouse button or
Ctrl+Left mouse button to zoom the marked area

• hold the Left mouse button to view the plot tracker
• press 'A' key to reset the axis to set values
• press Ctrl+C to copy the bitmap of plot.

Inside the plot you can also do the following
actions using keypad and mouse:

Adaptive programming
Adaptive programming is a feature to control the operation of a drive by parameters.
Each parameter has a fixed set of choices or a setting range. The parameters make
programming easy, but the choices are limited. You cannot customize the operation
further.

The Adaptive programming makes easy customizing possible without the need of a
special programming tool or language. The program is built of function blocks.

For further information on Adaptive programming, refer Adaptive programming
application guide in Related documents.
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Locking user interface
A user interface lock function is implemented to notify the device lock states, for
example, when parameter system is locked or when file downloading is disabled.

The function prevents you from:

• uploadingdevicedata,when file download function is disabledorwhenparameter
system is locked

• creating device backup when the device is in protected state.

The function is implemented inDCPT-01andDCET-01. Seebelowsections thatdescribe
the lock states visible in different pages or views in the Drive Composer.

￭ Lock state in System info page
Go to the System info page by right clicking on the selected drive in the drive list and
select System info. The different lock states displayed in the System info page are
listed below.

Lock state messagesDevice lock state

Set button is enabled.Initial state

Set button is disabled.When youmouse hover the button, the tooltip
“Parameters are locked on drive” appears.

Parameter system is locked

Set button is disabled.When youmouse hover the button, the tooltip
“File downloading is disabled on drive” appears.

File download is disabled

￭ Lock state in parameter view
The user interface lock states are displayed in the following parameters view:

• Parameters view for online drive

• Custom parameter view

• Offline parameter view

• File parameter view
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In the parameters view, the device lock states, i.e. Parameter system is locked or the
File downloading is disabled, are accessible when you mouse hover the below two
buttons:

• Save parameters to file

• Download to device

The table below lists the different device states displayed in the parameters view. The
example screens are from the custom parameter view.

Note: The two buttons listed abovemay be hidden andmay not be visible in all views.
When data in the view is loaded for different drives, the drive which is connectedmay
not show the correct state of the buttons until you change the drive.

Lock state messagesDevice lock state

Saveparameters to file andDownload todevicebuttons are enabled.Initial state

Saveparameters to filebutton is enabled.Download todevicebutton
is disabled. When you mouse hover the disabled button, the tool tip
“Parameters are locked on drive” appears.

Parameter system is locked

Saveparameters to filebutton is enabled.Download todevicebutton
is disabled. When you mouse hover the disabled button, the tool tip
“File downloading is disabled on drive” appears.

File download is disabled

￭ Lock state in Backup/Restore page
Go to the Backup/Restore page by right clicking on the selected drive in the drive list
and selectBackup/Restore. Thedifferent lock states displayed in theBackup/Restore
page are listed below.

Lock state messagesDevice lock state

All buttons, Backup, Restore and Advanced restore are enabled.Initial state

Note: Advanced restore button is available only in Drive Composer
pro, DCPT- 01 (code: 3AUA0000108087).
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Lock state messagesDevice lock state

Backup button is enabled. Restore and Advance restore buttons are
disabled. When you mouse hover the disabled buttons, the tooltip
“Parameters are locked on drive” appears.

Parameter system is locked

Note: Advanced restore button is available only in Drive Composer
pro, DCPT- 01 (code: 3AUA0000108087).

Backup button is enabled. Restore and Advance restore buttons are
disabled. When you mouse hover the disabled buttons, the tooltip
“File downloading is disabled on drive” appears.

File download is disabled

Note:Advanced restore is available only inDriveComposerpro,DCPT-
01 (code: 3AUA0000108087).

￭ Lock state in Safety settings page (pro)
Go to the Safety settings page by right clicking on the selected drive in the drive list
and select Safety settings. The different lock states displayed in the Safety settings
page are listed below.

Note: The lock statemessages are visible only in Drive Composer pro, DCPT-01 (code:
3AUA0000108087).

Lock state messagesDevice lock state

Buttons enabled:Initial state

Read settings from drive
Apply settings to drive
Print report
Reboot FSO
Change password.

Load from file is always enabled.
Save to file is enabled only when data is read.
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Lock state messagesDevice lock state

Buttons disabled:Parameter system is locked

Read settings from drive
Apply settings to drive
Print report
Reboot FSO
Change password.

When you mouse hover the disabled buttons, the tooltip
“Parameters are locked on drive” appears.

Load from file is always enabled.
Save to file is enabled only when data is read.

Buttons disabled:File download is disabled

Read settings from drive
Apply settings to drive
Print report
Reboot FSO
Change password.

When youmouse hover the disabled buttons, the tooltip “File
downloading is disabled on drive” appears.

Load from file is always enabled.
Save to file is enabled only when data is read.

￭ Lock state in Drive text editor (pro)
Go to Tools→ Drive Text Editor. Select the drive to work with and clickOk. The Drive
text editor screen appears.

The different lock states displayedin the Drive text editor are listed below.

Note: The lock statemessages are visible only in Drive Composer pro, DCPT-01 (code:
3AUA0000108087).
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Lock state messagesDevice lock state

Read button is always enabled.Initial state

Apply button is enabled only when text is changed in the Localized
text column.

Read button is always enabled.Parameter system is locked

If you changed text in the Localized text column, the changes are not
effective and the Apply button is disabled. When you mouse hover
the disabled button, the tool tip “Parameters are locked on drive”
appears.

Read button is always enabled.File download is disabled

If you changed text in the Localized text column, the changes are not
effective and the Apply button is disabled. When you mouse hover
the disabled button, the tool tip “File downloading is disabled on
drive” appears.
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Annexure A: Creating drive installed
base service report template

Contents of this chapter
This chapter describes the factors to considerwhen creating a service report template
file for Drive Installed Base (DIB).

15
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Creating a template forDrive InstalledBase service report
(Internal use only)

Note: Service report templates are created by authorized ABB personnel only. If you
need to create template, contact your local ABB representative.

You can create a template file for Drive Installed Base service report using the Step
Designer tool. You will need necessary permissions to access the tool. The tool has
different steps and components, but not all of them are used in the Drive Installed
Base service reporting template.

The project file (SDDIBTemplate.xml) is located in the Drive Installed Base service
portal. The file contains all currently supported components and data bindings. See
descriptions in below sections.

The example screens show General Information for service actions.
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Generic wizard step
TheGenericwizard step is used in theDrive InstalledBase template structure. Currently,
the template supports only this step.

The table below lists the sections and properties of the Generic wizard step used in
the Drive Installed Base service report.

CommentPropertySection

Mandatory to fill this value.DisplayName(presentedas “Title”
in Drive Installed Base service re-
port)

Configuration

Appears below “Title”Description

Determines thatpage is visible on
print preview.

AddToReportDC Wizard Printing

Components
The table below lists the components used in Drive Installed Base service reports.

Presented as ...Component

multiline text componentCommentsControl

numeric componentNumericTextBox

Note: Accepts numeric values only.

checkboxCheckBox, ThreeStateCheckBox

one-line text componentsTextBox,BinaryTextBox,StringTextBox,HexTextBox

user file selectable componentFilechooser

drop-down listComboBox

tableDataGridView
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￭ Common properties of components
The following properties are common for the components defined in Drive Installed
Base service report.

CommentPropertySection

Defines data input and output of
thecomponent.SeealsoDataBind-
ing xx.

DataBindingConfiguration

Defines default value of the com-
ponent. This value is used if
sourcedatabinding is notdefined.

DefaultValue

Appears as “Title” in service re-
port. This is a mandatory value.

Display Name

Defines that component is read-
only

enabled (value)

Not supportedenabled (expression)

Defines if value must be filled.ValueRequired

True = Value is required before
navigating to the next page.

False = Value is not required

Determines the print preview of
service report page.

AddToReportDC Wizard Printing

Adds one empty line in print re-
port after this component.

BlankLineAfter

Does not print the component if
there is no value.

OmitIfEmpty

Adds page break in print report
after this component.

PageBreakAfter

￭ ComboBox properties of components
You can use the following combo box property to define the components in Drive
Installed Base service report.

CommentProperty

Shows values in the drop down list. Selecting a value opens a new editor.
You can add, change or remove a value. See example screen below.

PossibleValues (value)

In the new editor, you can define name and value of the property. Data
in the Value field is sent to Drive Installed Base service. Make sure that
this data is synchronized with the expected data value.

Not supportedPossibleValues (expression)
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￭ Data Grid View properties
You can use the following data grid view property to define components in Drive
Installed Base service report.

CommentProperty

Defines columns in the table. Selecting a column value opens a new editor.DCWizardColumns

You can add, change or remove a column value. See example screen below.

In the new editor, you can define the column properties:

CommentColumn property

Defines data input and output. See also
DataBindings (page 236)

DataBinding

Enables read-only column mode.Enabled

Defines column header text.Name

Defines possible values if column type is
DropDown.

Note: This property is not supported for
other column types.

PossibleValue

Defines following data types: String,
Numeric, Date, CheckBox, DropDown

Type

Note:Columns defined are not visible in Step Designer, but are visible only in Drive
Installed Base service report wizard.
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DataBindings
DataBindings define how to fill the component with data and to where the filled data
mustbe sent. TheDrive InstalledBase service report includes two typesofDataBinding
properties:

• DataSource

• DataTarget

You can fill the properties using existing DataBinding properties in the StepDesigner
tool. See the sample format below:

"{DataSourceBinding}{DataTargetBinding}"

The format is converted to:

DataSource = "DataSourceBinding"

DataTarget = "DataTargetBinding"

If value in “DataBinding”doesnotmatchwith theprevious format, the value is assigned
to

"DataSource" property and "DataTarget" remains empty.

￭ DataSource
DataSource is aDataBindingproperty that defines howcomponentdatamustbe filled
if you started the service report wizard for the first time and default valuewas empty.

See the data source list supported by Drive Composer PC tool:

CommentProperty

Defines current dateDateTimeNow

Drive parameter group and index.Par.G.I

For example, Par.1.11,means thatDriveComposer reads value from
parameter group 1 and index 11 of the selected drive.

System info ID number or drive info defined by ID.Info.ID

For example, Info.1, means that Drive Composer reads drive serial
number.

Email ID of user logged in to Drive Installed Base service.UserEmail

Data object received fromDrive InstalledBase service. For example,Drive

Drive.SerialNumber–reads drive serial number

Drive.EndCustomer.Name–reads end customer name

Drive.Site.StreetAddress–reads site address where the drive is in-
stalled
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CommentProperty

Drive components for table data. Each column has an appropriate
component

Component

type property as its DataSource. See below example code:

<Components>

<Component c:type="CfrTable" id="DataGridView_1"

dataBinding="{Component}{}">

<DCWizardColumns>

<Column name="Version" databinding="{Version}{}"
type="String"

enabled="tru

e" />

<Column name="Description" databinding="{}{De-
scription}"

type="String" enab

led="true" />

</DCWizardColumns>

</Component>

• Each row fills with a component property
• The column name Version reads data from Component.Version

property
• The columnnameDescription reads value fromComponent.De-

scription property.

DataTarget
DataTarget is a DataBinding property that defines how to send value of current
component toDrive InstalledBase service. DriveComposer sends the value tomultiple
object types of Drive Installed Base service.

￭ DataTarget objects
The table below list the objects created based on DataTarget definitions:

SubtypesObject

ServiceEventWarrranty ServiceEventFaultDriveComposerServiceEvent

Collection of objects of ServiceEventReplacedPart type Ser-
viceEventSite

ServiceEventEndCustomer ServiceEventFieldServiceEngineer

Collection of objects of MaterialCodeInstalled type Ser-
viceEventServiceProvider

OnSiteActivities

Commissioning

Collection of Fault type objects

Collection of Attachment type objects

-MaintainedComponent (collectionof ob-
jects)
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￭ DataTarget examples

Value fills this propertyIf DataTarget =...

SerialNumber in object typeDriveComposerServiceEvent.SerialNumber
DriveComposerServiceEvent

Name in object type ServiceEventEndCustomer, which is
defined as property EndCustomer in object type DriveCom-
poserServiceEvent

ServiceEventEndCustomer.Name

ResponsibleUnit in object type ServiceEventWarranty,which
is defined as property Warranty in object type DriveCom-
poserServiceEvent

ServiceEventWarranty.ResponsibleUnit

The objects defined as collection, use the DataTarget in two ways:

Fault.Code–value from this component fills property Code in object type Fault. If you
added more than one component, Drive Composer sends only the value of first
component in the page to Drive Installed Base service.

Fault.Code|1...3–based on componentswith three different bindings three objects of
Fault type are created. You can definemore than one collection element on one page.
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Saving the DC wizard template in StepDesigner
After you designed a service report template with the StepDesigner tool using
components, databindings, etc., save the template file to Drive Composer reporting
wizard format (.dcwiz) and set the file as customprinting template file format (.xaml).
The custom printing template defines the common appearance of printed pages like
header, footer, etc.

To save the template file,

1. In StepDesigner, go to File →Save DCWizard template.

The file is saved in .dcwiz format.

2. Click Yes, to set the file as custom printing template file (.xaml format) or click
No, to use the default printing template.

￭ Note:
• The template must contain a ContentControl named "cc".

• ABB recommends that you use the same name for both files for better
identification.
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Deploying a template file
The Service reporting (create_service_report.html) module contains all service report
template files. You can see a range of entries in the Select service type list. Each entry
refers to a template file.

To deploy a template file,

1. Create a template structure in StepDesigner tool. See Creating a template for
Drive Installed Base service report (Internal use only) (page 232).

2. Save the file to StepDesigner format.

3. Create a .dcwiz file. See steps for Saving the DCwizard template in StepDesigner.
ABB recommends that you use the same name for both files for better
identification.

4. If you have multiple templates, repeat steps 1...3.

5. Create a zip file of the multiple files.

6. Upload the zip file to Drive Installed Base service portal. If you do not have the
necessary permissions, you can request the Drive Installed Base team to upload
the files.

Localizing service report templates
Consider the following points,

• Whenever you change the language settings in Drive Composer, see the localized
templates list in service types of Service reporting (create_service_report.html)
module.

• Language files are recognized by their file names. For example,

• File.dcwiz or File_en.dcwiz refers to English template file.•
• File_pl.dcwiz refers to Polish template file.
• File_fi.dcwiz refers to Finnish template file.

• When you selected a language, all properties (Display Name, Description, Name,
etc.) are translated to their respective languages.

• When you selected a language, the filesmatching that language selection are only
visible. If a particular language file does not exist, then English version is displayed
as default.

The below example cases show the list of files visible when you selected a language.

The template file is a zip file of following files.

Example:

• File.dcwiz

• SecondFile.dcwiz

• ThirdFile_en.dcwiz

• File_fi.dcwiz

• FourthFile_fi.dcwiz
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The Select service type dropdown
lists the following files:

If language selected is...Case

• File
• SecondFile
• ThirdFile_en

EnglishCase 1

• File_fi
• SecondFile
• ThirdFile_en
• FourthFile_fi

FinnishCase 2
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Further information
—

Product and service inquiries
Address any inquiries about the product to your local ABB representative, quoting the type
designation and serial number of the unit in question. A listingof ABBsales, support and service
contacts can be found by navigating to www.abb.com/contact-centers.

Product training
For information on ABB product training, navigate to new.abb.com/service/training.

Providing feedback on ABB manuals
Your comments on our manuals are welcome. Navigate to forms.abb.com/form-26567.

Document library on the Internet
You can find manuals and other product documents in PDF format on the Internet at
www.abb.com/drives/documents.
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