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Introduction

1.1

Scope of the document
This Application Note describes how to protect the project and the running application in an
AC500 V3 PLC.
To archive this a user management is used, the communication and the boot application are
encrypted with a certificate from the controller in order to prevent unauthorized access and
to make sure that it cannot be exchanged.
In addition, we want to sign the application on the controller.
With AB V2.4.1 it is not possible to just sign the application. It’s always required to encrypt
the application as well. It’s possible to encrypt the application without sign it.
To do this, a corresponding certificate must be created on the controller and installed in the
Windows Certificate Store of your computer.
Be sure you have a battery plugged to you PLC. This is required to restore the date and time
inside the PLC. Certificates have always an expiration date.

All available certificates are located in the Windows Certificate Store “certmgr” on your computer. There are two types of keys:
•

Certificates with private keys
– for file decryption
– for digital signatures

•

Certificates with public keys
– for file encryption
– for verifying digital signatures

1.2

Compatibility
The application example explained in this document have been used with the below engineering system versions. They should also work with other versions, nevertheless some small adaptations may be necessary, for future versions.
•

AC500 V3 PLC

•

Automation Builder V2.4.1 or newer
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1.3

Overview

Authentification &
Encrypted communication

Bootproject
Encrypted & Signed

The steps described in this Application Note can be used to protect the Application. In the
first step the communication between computer and AC500 V3 is authenticated and encrypted to make sure that no unauthorized person can access the PLC.
In the second step the download and boot application become encrypted and signed to
make sure that nobody can replicate the boot application for other processes without the
certificates.
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User management and encrypted
communication

2.1

User management
To prevent that any unauthorized person can access the PLC, overwrite the Application,
change the firmware or similar a User Management is needed.
How the User Management can be activated and configured is described in the Application
Note AC500 User Management with V3 in chapter 2.2 in this example the default user Management is used.

CAUTION!
Please check and remember your Administrator password.
There is also no workaround to login to the PLC without this password. If
this happens, the PLC must be replaced!

Only an Administrator has been added to the user management and the password has been
set.

If now a project should be downloaded an authorized user needs to log in.

If now a user which don’t has the password tries to log in or update the firmware this is not
working as he has insufficient rights.
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2.2

Encrypted communication
As described in the last chapter only authorized user can log in to the PLC.
To ensure that nobody can read the login data you sent from your computer to the PLC an encrypted communication must be used. The steps to archive this are also described in the Application Note AC500 User Management with V3 in the chapter 2.2.1.4.
Afterwards go to the Communication Settings.
1. In the tab “Device” choose “Encrypted Communication”

Now the communication between the PLC and the PC is encrypted so that nobody can get
any log in information or read any system values. This setting is only done locally on your Automation Builder and will be saved within the project.

Note: In case you want to login from different computers to the controller,
you will need the appropriate certificate for each computer. Otherwise the
communication from other PCs is not encrypted and attackers could read
confidential data.

In the next step the comunication policy from the device is changed to allow only encrypted
communication. Then it is not possible to log in without an encrypted communication.
2. Click “Change Communication Policy”

3. Change the communication policy to “Enforced encryption”
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It is also possible to force the usermanagement here. Then it is not possible to delete the
usermanagement from the PLC.
In the next step the communication from another PC to this PLC shall be established.
4. When trying to log in without encrypted communication following error will pop up

5. Use also on the second computer encrypted communication like shown in step 1
6. With the next login the certificate for the encrypted communication will be stored in your
certificate manager on your PC. Click “OK” to confirm
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Encrypt the application with certificate
In addition to securing the communication to the PLC also the stored boot application can be
encrypted to make sure that nobody who could access the PLC is able to duplicate the existing boot application for other PLCs.
In this step, we are encrypting the boot application, Download and Online Change.
You have a project with an application that you want to download to the controller as an encrypted boot application. In the Windows Certificate Store of your computer, you have a certificate of this controller for encrypting the application.

Note: In case you want to download the application to different controllers,
you will need the appropriate certificate for each controller.

1. Login to your PLC
2. Open the “Security-Screen” view by double-clicking the
by clicking “View → Security-Screen”
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3. Go to “Devices” tab and click the button to refresh the list of available devices and
their certificate store
You can see that there are no certificates available.

4. Open the “Project” tab and double-click the “Application” entry in the area “Encryption
of boot application, download, and online change”
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5. The “Properties” dialog of the Application opens

6. Select the “Encryption” tab and select “Encryption with certificates” as the “Encryption
technology”.

7. Click on the “Encryption Wizard” button
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8. Click on “Start” and select the Key Length “4096” and the Validity period in days:

9. Confirm with “OK”
10. The server certificate on the PLC will be created. Also, the certificate will be installed on
the Cert store in Windows.

11. Click on “Close”
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12. The certificate is automatically added for the encrypted application. Please remove the
checkbox for “Digitally signing application code” if it is set.
This will be handled in the chapter: Sign the application with certificate

13. Confirm with “OK”
14. You will see this window

15. Go to “Devices” tab and click the button to refresh the list of available devices and
their certificate store
You can see that the certificate is available
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16. When you go again to your certmgr.msc (see Start the certmgr.msc via PowerShell)
Navigate to “Controller Certificates” you can see the installed certificate on your Certificate
Store on Windows

17. Open the “Users” tab in the “Security-Screen”.
Activate the option “Enforce encryption of downloads, online changes, and boot applications” in the “Security-Level” area.

18. Logout of the PLC
19. Select Build → Clean All
20. Login to the PLC
21. The certificate is now used to encrypt the application. It can only be transferred to the
controller on computers that have a corresponding key installed in the Windows Certificate Store.
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Create self-signed certificates with Win10
In the face of increasing security precautions and security issues, it has become of fundamental importance to websites and services to be implemented with always activated security. Various service providers now need secure connections, also for development environments. In most cases it is not possible to use cryptographic certificates for the local
development environment any developer, but you can easily get self-signed certificates for
free.
These certificates can be used in local environments and cover the security requirements during the development of the solution.

CAUTION!
Self-signed certificates should NEVER be used on production or public
websites.

PowerShell in Windows 10 includes the command New-SelfSignedCertificate. This command
can be used to create self-signed certificates.
1. Open a PowerShell window in Administrator mode

2. Enter the following command:
New-SelfSignedCertificate -type CodeSigningCert -KeyLength 4096 -Subject
"E=test@example.com,CN=Test" -FriendlyName "MySelfSignedCert" -CertStoreLocation "Cert:\CurrentUser\"
3. The result will be a Thumbprint
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4. Start the certmgr.msc via PowerShell

5. A new window will open
Navigate to Personal→ Certificates
Here you can see the currently created self-signed certificate with private key

6. Select the Test certificate, right click and select:
All Tasks -> Export…
7. Select Next
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8. Select: No, do not export the private key

9. Select DER encoded binary X.509 (.CER)
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10. Choose a path and name e.g. MyCertForSinging.cer to store the certificate.
Confirm with Next

11. The final result will be shown:

12. Confirm with Finish
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5

Sign the application with certificate
In this step, we are signing the boot application. Currently AB V2.4.0 allows only to sing the
application, when you also encrypt the application. The encryption of the application was already handled in the chapter: Encrypt the application with certificate
1. Open the “Security-Screen” view by double-clicking the
by clicking “View → Security-Screen”

symbol in the status bar or

2. In the “User” tab, select the user profile for which the communication will be encrypted. By default, the specified user profile is the one you have used on your computer to sign into Windows.
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3. Click the
opens.

button in the “Digital signature” area. The “Certificate Selection” dialog

4. Select the certificate with a private key from the list “Personal certificates” what we
have created in chapter: Create self-signed certificates with Win10
Certificates with a private key are identified by the symbol.
5. Click on the arrow up

button to add the certificate to the upper part of the dialog

6. Click “OK” to confirm your selection. The selected certificate is displayed in the “Security Screen” in the “Digital signature” area.
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7. Activate the option “Enforce signing of downloads, online changes and boot
applications” in the “Security-Level” area.

8. Open the “Project” tab and double-click the “Application” entry in the area “Encryption
of boot application, download, and online change”. The “Properties” dialog of the application opens.
Confirm, the “Digitally sing application code” is selected

9. Confirm with “OK”
10. Go to “Devices” tab and click the
their certificate store.
Select “Trusted Certificates”

button to refresh the list of available devices and

11. Import the certificate (MyCertForSinging.cer), we have created in chapter: Create self signed certificates with Win10, to the “Trusted Certificates” in your PLC, using the
symbol.
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12. Once imported you get the confirmation screen

13. The imported certificate is now visible in the “Trusted Certificates” area.

14. Logout of the PLC
15. Select Build → Clean All
16. Login to the PLC
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Delete certificates and user management
You delete the certificate in the “Security Screen” view, either directly on the “User” tab or in
the “Certificate Selection” dialog.

6.1

Delete certificate for signing the application
•

Dialog “Security Screen”, tab “User”, “Digital signature”.
Select a certificate and click

Remove the checkboxes in the “Security Level”.

6.2

Deleting a certificate for the encryption of boot
application, download and, online change
1. In the “Security Screen” view, on the “User” tab, remove the checkbox for “Enforce encryption of downloads, online changes, and boot applications“
2. In the “Security Screen” view, on the “Project” tab, in the bottom view, double click the
entry for the “Application”.
3. The “Properties dialog for the application opens with the “Encryption” tab.
4. In the “Certificates” group, click
.
In the “Certificate Selection” dialog, delete the certificate by selecting the certificate
and click
5. Click “OK” to close the “Certificate Selection” dialog.
6. The certificate is no longer displayed in the “Properties” dialog.
7. Remove the checkbox in the “Certificates” section for “Digitally sign application code”
8. Set the “Encryption technology” to “No encryption”
9. Click “Apply” and “OK”
10. In the “Security Screen” view, on the “Device” tab, select the PLC and remove the certificate for “Encrypted Application”
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6.3

Deleting a certificate for the encrypted
communication
1. In the “Security Screen” view, on the “User” tab, remove the checkbox for “Enforce encrypted communication“
2. In the “Security Screen” view, on the “Device” tab, select the PLC and remove the certificate for “Encrypted Communication”

6.4

Delete the user management
1. Login as Administrator
2. Right click to the PLC_AC500 in the device tree
3. Select reset origin Device

4. Confirm with yes

5. Wait about 30s, you’ll be logged out
6. Login Again, you’ll be asked for Username and Password

7. Type in and confirm. The error message “Too many Tries” is shown
8. Now the user management is deleted and no more password is needed
3ADR010707, 2, en_US

23

7

FAQs
Q1: What’s wrong when I got the Error: Operation aborted, no valid certificate for signing
found

A1: If you do not want to use Code Signing, it could happen, that you have selected the “Digitally sign application code” is selected

If you want to use Code Signing than, please be sure you have imported your certificate.
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