Notice 1

The information in this document is subject to change without notice and should not be construed as a commitment by ABB. ABB assumes no responsibility for any error that may occur in this document.

Notice 2

This module is included in CAP 501, CAP 505, LIB 510 in MicroSCADA and in SMS 510.

Notice 3

Additional information such as Release Notes and Last Minute Remarks can be found on the program distribution media.

Trademarks

Microsoft is a registered trademark of Microsoft Corporation.
Windows NT is a trademark of Microsoft Corporation.
LONWORKS is registered trademark of Echelon Corporation.
Other brand or product names are trademarks or registered trademarks of their respective holders.
All Microsoft products referenced in this document are either trademarks or registered trademarks of Microsoft Corporation.
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 RED Relay Tool Overview</td>
<td>5</td>
</tr>
<tr>
<td>1.1 Description</td>
<td>5</td>
</tr>
<tr>
<td>1.2 Features/Options</td>
<td>5</td>
</tr>
<tr>
<td>2 Environments</td>
<td>7</td>
</tr>
<tr>
<td>2.1 Starting from LIB 510 in MicroSCADA</td>
<td>7</td>
</tr>
<tr>
<td>2.2 Starting from CAP 501/505, SMS 510</td>
<td>9</td>
</tr>
<tr>
<td>3 Relay Setting Tool</td>
<td>11</td>
</tr>
<tr>
<td>3.1 General</td>
<td>11</td>
</tr>
<tr>
<td>3.2 Start-up</td>
<td>11</td>
</tr>
<tr>
<td>3.2.1 Build Active Menu</td>
<td>11</td>
</tr>
<tr>
<td>3.2.2 Import Relay Parameter Settings from External Programs</td>
<td>12</td>
</tr>
<tr>
<td>3.3 Main View</td>
<td>13</td>
</tr>
<tr>
<td>4 Using Relay Setting Tool</td>
<td>15</td>
</tr>
<tr>
<td>4.1 File Menu</td>
<td>15</td>
</tr>
<tr>
<td>4.1.1 Import...</td>
<td>15</td>
</tr>
<tr>
<td>4.1.2 Export...</td>
<td>16</td>
</tr>
<tr>
<td>4.1.3 Page Setup...</td>
<td>17</td>
</tr>
<tr>
<td>4.1.4 Print Setup...</td>
<td>17</td>
</tr>
<tr>
<td>4.1.5 Print...</td>
<td>19</td>
</tr>
<tr>
<td>4.1.6 Exit...</td>
<td>21</td>
</tr>
<tr>
<td>4.2 View Menu</td>
<td>21</td>
</tr>
<tr>
<td>4.3 Transfer Menu</td>
<td>21</td>
</tr>
<tr>
<td>4.3.1 Upload</td>
<td>22</td>
</tr>
<tr>
<td>4.3.2 Download</td>
<td>22</td>
</tr>
<tr>
<td>4.3.3 Store</td>
<td>24</td>
</tr>
<tr>
<td>4.3.4 Reset (Example)</td>
<td>25</td>
</tr>
</tbody>
</table>
4.4 Tools Menu ........................................................................................ 25
  4.4.1 Compare ..................................................................................... 26
  4.4.2 Edit History ................................................................................ 28
  4.4.3 View Transducers ....................................................................... 28
4.5 Options Menu .................................................................................... 29
  4.5.1 Resize Dialog Box ....................................................................... 29
  4.5.2 Rebuild Active Menu ................................................................... 29
  4.5.3 Menu Configuration .................................................................... 30
    4.5.3.1 Menu Configuration/View Menu ............................................... 31
    4.5.3.2 Menu Configuration/Transfers Menu ....................................... 33
4.6 Help ................................................................................................... 35
  4.6.1 About Setting Tool ....................................................................... 35
4.7 Monitoring and Changing Parameters ................................................ 36
  4.7.1 RED Menus ................................................................................. 36
  4.7.2 Tabbed Pages ............................................................................. 36
  4.7.3 Parametrisation ........................................................................... 37
5 PQ-Monitoring Tool in LIB510/MicroSCADA ............................................. 39
  5.1 General ............................................................................................ 39
  5.2 Startup ............................................................................................. 39
  5.3 Main View ........................................................................................ 40
    5.3.1 Menu Bar .................................................................................... 41
      5.3.1.1 File Menu ............................................................................. 41
      5.3.1.2 View Menu .......................................................................... 44
      5.3.1.3 Options Menu ....................................................................... 45
      5.3.1.4 Help Menu ............................................................................ 45
    5.3.2 Toolbar ....................................................................................... 46
    5.3.3 Tabbed Page ............................................................................... 46
      5.3.4 Visualisation Area ..................................................................... 47
      5.3.5 Status Bar ................................................................................ 50
  5.4 Monitoring Functionality ..................................................................... 51
    5.4.1 On-line Monitoring ................................................................. 51
    5.4.2 Monitoring of Saved Data ........................................................ 52
1 RED Relay Tool Overview

1.1 Description

These tools are used for relay units regarding:

- Configuration for using in control system
- Parametrisation
- Creation of needed process objects

1.2 Features/Options

- On-line parametrisation
- Off-line parametrisation
- Upload/Download all parameters
- Upload/Download group of parameters
- Selection of setting group
- Reset of registers (user settable)
- Tool can be started from a process picture (LIB 510/MicroSCADA)
- Alarm indication (in the station picture)
- Authorization support
- Compare
- Parametrisation of times nominal values and primary values
2
Environments

2.1
Starting from LIB 510 in MicroSCADA

The relay units are displayed as push-buttons in the station picture (see the following picture).

![Diagram of Eastwick 110/20kV]

Figure 1. The station picture including a relay unit push button

In case objects need updating, a dialog box as presented in Figure 2 appears when pressing the relay units’ push-button. Objects can be updated either manually in the Picture Editor or automatically by selecting Yes in the following dialog. In case objects are updated manually in the Picture Editor, the whole configuration procedure has to be updated. In case the automatic updating is selected, a dialog box confirming that updating was successful appears to the screen (Figure 3).
Figure 2. The dialog indicating that an object needs updating

Figure 3. Dialog box indicating that an object has been updated successfully

After the object has been updated successfully or a picture function has been clicked in the station picture (in case updating was not necessary), the Tool Menu dialog box (Figure 4) for the chosen object appears on the screen. This dialog box contains a list of tools available for the relay unit.

Figure 4. The Tool Menu for a relay unit object

Select the desired tool and click Run if you want to change or view the Relay unit setting parameters. The main view of the Tool is shown in the Figure 9 further on in this manual.
2.2 Starting from CAP 501/505, SMS 510

![Project Structure Navigator - Master Design View](image)

**Figure 5.** Starting Relay Setting Tool from the Project Structure Navigator

Navigate to the desired relay object in the Project Structure navigation tree on the left and select it. The tools that are available for the selected object appear in the Object Tools list box on the right. Open the Relay Setting Tool by clicking it in the list.
3 Relay Setting Tool

3.1 General

The HMI of a RED Relay unit is built up with the same menu structure as the local HMI. The available RED Relay configurations are included in the object types (e.g. REF54x) of the SW Package SM/RED. The representation of the parameters in the Relay Setting Tool is based on HMI files (Menu, Image, Index and Help files). These files are included in the used relay configuration. The Active Menu File, which is needed to present the HMI in Relay Setting Tool, must be build when a new relay unit object is selected for this tool for the first time or when the relay unit object application has been reconfigured. The active menu file is built by using the HMI files as input.

3.2 Start-up

3.2.1 Build Active Menu

The message in Figure 6 and the Build Active Menu File dialog box appear if the active menu of the used relay configuration is not found. Click Build in the Build Active Menu File dialog box to build the active menu for the relay configuration. This dialog box will also open in the menu Options.

Figure 6. Active menu of the used relay configuration has not been found
3.2.2 Import Relay Parameter Settings from External Programs

The relay parametrisation that is made by another program (e.g. Event Editor) can be imported to the Relay Setting Tool. This import function appears automatically at startup. Click Yes if you want to update the columns New Values by these values. The dialog box will appear only once.

Figure 7. The dialog box for building the Active Menu File

Figure 8. The dialog for importing relay settings
3.3 Main View

Figure 9. The main view for the Relay Setting Tool

The main view includes the following functions:

1. **Menu bar**

The menu with commands for the Relay Setting Tool.

2. **Toolbar**

A bar with buttons that perform some of the most common tasks.

<table>
<thead>
<tr>
<th>Button</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Import parameters icon]</td>
<td>Import parameters</td>
</tr>
<tr>
<td>![Export parameters icon]</td>
<td>Export parameters</td>
</tr>
<tr>
<td>![Printing icon]</td>
<td>Printing</td>
</tr>
</tbody>
</table>
3 Relay unit menu tabbed pages

These pages represent the functions of the selected relay unit. The function to be operated is selected by clicking the page tab.

The tool also shows the name of the selected object and relay unit in the header field.

4. Minimise button

The relay tool can be minimised to an icon in the station picture.

5. Tool area

The relay tool is opened into this part of the HMI. The Setting tool function offers a complete tool for monitoring and configuring the relay unit.

6. Status bar

The status bar shows information about the current situation in the Relay Setting Tool. The status bar has two fields. The first one shows information of the relay unit type e.g. REF 541. The second field shows the upload status of the parameters. The status might be:

- **Uploaded 00-00-00 00:00:00**, when the parameters of the selected page have been read from the default file.
- **Uploaded 00-00-00 00.00.00**, when the parameters of the selected page have been uploaded from the relay

![Figure 10. The status bar](image-url)
4 Using Relay Setting Tool

4.1 File Menu

The file menu contains the functions belonging to file handling.

<table>
<thead>
<tr>
<th>File</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import</td>
<td>Opens a parameter database for importing parameters. The parameter file is selected on the Import dialog (shown in Figure 12.).</td>
</tr>
</tbody>
</table>

![Image of the File menu](image)

*Figure 11. The File menu*

4.1.1 Import…

![Image of the Import dialog](image)

*Figure 12. The Import dialog for the import function*

4.1.2 Export...

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td>Saves all parameters for exporting into the file being currently selected. The file name can be selected from the dialog, which is opened first.</td>
</tr>
</tbody>
</table>

Access: User level 2

The default directory for the user files is /apl/’apl_name’/protection/prj/obj0000/misc.

![Image](image.png)

**Figure 13.** The Save as dialog for the export function

4.1.3 Page Setup…

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Setup</td>
<td>Opens a dialog in which page setup as to margins (Top, Left, Bottom, Right) can be defined.</td>
</tr>
</tbody>
</table>

![Page Setup dialog](image1)

Figure 14. Page Setup dialog

4.1.4 Print Setup…

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print Setup</td>
<td>Opens a dialog in which print setup for the paper as well as for the printer can be defined, if the option VS Local has been selected in the MicroSCADA Monitor (Figure 16).</td>
</tr>
</tbody>
</table>

![Print Setup dialog](image2)

Figure 15. Print Setup dialog

**NOTE!** In case the option VS Remote has been selected in the MicroSCADA Monitor dialog (Figure 16), the option Print Setup in the File menu is unavailable, and the dialog presented in Figure 17 pops up. In this case, information concerning the printer is given in the MicroSCADA Monitor dialog (the last field on the left-hand side of the dialog in Figure 16).
**MicroSCADA Monitor**

- **Pre Defined Monitor:**
  - In Use:
  - Setting:

- **Monitor Type:**
  - VS Local
  - VS Remote
  - X

- **Network Node Name**
  - MicroSCADA:
    - FIMITRVSAW283
  - Display:
    - FIMITRVSAW2830

- **Application #**:
  - Default

- **Picture Size**:
  - 640 by 480 pixels

- **VS Printer**:
  - LT1

---

**Figure 16.** VS Remote monitor selected in the MicroSCADA Monitor dialog

---

**Figure 17.** Dialog indicating that print setup cannot be opened when VS Remote Monitor has been selected
### 4.1.5 Print...

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print</td>
<td>Opens a dialog in which it is possible to select printing of the current page, all pages or of certain pages (the page numbers can be entered in the field). It is also possible to select whether present values, new values, or both present and new values are printed. When selecting printing of both present and new values, printing requires more pages than selecting printing of either present values or new values.</td>
</tr>
</tbody>
</table>

![Print dialog](image1.png)

**Figure 18. Print dialog**

![Print dialog 2](image2.png)

**Figure 19. Print dialog 2**

After the desired printing option has been selected and OK has been pressed in the Print dialog (Figure 18), the second Print dialog (Figure 19) pops up. In this dialog printing is either confirmed or cancelled.

Printouts can be made from a Visual SCIL tool, such as the RED Relay Tool, to a local or network printer defined in the operating system. The availability of printers and the configuration work needed depends on which context the MicroSCADA
monitor is opened to. This varies in different MicroSCADA technology products as in the following.

**CAP 501, CAP 505 and SMS 510**

In these products a tool is always opened to the context of the current operating system user, i.e. the user that has logged in to the operating system. In this case all the printers that are provided by the operating system to the user are available also for printing from the tools.

**LIB 510/MicroSCADA**

In these products a monitor is by default opened to the context of the MicroSCADA user i.e. the user with the user name “MicroSCADA”. In this case only local printers can be used for printing from RED Relay Tool. Local printers are:

- Printers connected directly to computer's serial or parallel port
- Network printers defined as local port.

The procedure how to define a network printer as local port is described in section 3.4 in the SYS 500 8.4.3 System Management Operator’s Manual (1MRS751258-MUM).

If a monitor is opened from command prompt or from SCIL with an operating system call, it can be opened to the context of the current operating system user. This requires that the command line option start_as_logon_user is used when opening the monitor. Further details for the opening of monitors can be found in section 2.6.2 in the SYS 500 8.4.3 System Management Operator’s Manual (1MRS751258-MUM). When a monitor is opened to the context of the current operating system user, printers can be used as in CAP 501, CAP 505 and SMS 500.

When Local printers are used, the MicroSCADA user should have access to these printers.
4.1.6 Exit…

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exit</td>
<td>Exits the Relay Setting Tool and returns to the station picture from where the tool is started.</td>
</tr>
</tbody>
</table>

Figure 20. The Exit dialog

Access: No limitations

4.2 View Menu

The View menu contains a selection of views for the currently selected relay configuration. The All view is always available and it shows all parameters of the active menu. The other possible views are subviews of the All view and they are user-specific. These additional alternatives may be added by using the Options/Menu configuration (described further on in this manual).

Figure 21. The View menu

4.3 Transfer Menu

The Transfer menu contains commands used to communicate with the relay unit. The offered selections below the line in the menu are user-specific. These additional possibilities are to be added by using the Options/Menu configuration (described further on in this manual).

Figure 22. The Transfers menu, the Reset... selection is shown as an example of an user-specific configuration
4.3.1 Upload

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
</table>
| Upload    | Connects to the selected unit and uploads (receives):  
            1) parameters that are defined in the current page  
            2) all parameters  
            3) parameters on the entered pages. |

![Upload dialog box](image)

*Figure 23. The dialog box for selecting the uploading method*

Access: User level 0.

4.3.2 Download

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
</table>
| Download  | Connects to the selected relay unit and downloads (sends):  
            1) parameters that are defined in the current page  
            2) all parameters  
            3) parameters on the entered pages. |

![Download dialog box](image)

*Figure 24. The Dialog box for selecting the downloading method*


After uploading/downloading has been started, the dialog shown in Figure 25 appears on the screen. The dialog gives the user information of the current operation (uploading/downloading). It also shows how downloading proceeds. The Stop button cancels the operation and removes the dialog.
Figure 25. The communication dialog

If the communication error is such that the relay unit does not answer, a dialog that invokes the user to select whether to Retry or Cancel the downloading process is opened.

If an error occurs during communication (the relay answers with the NAK code), the error dialog is shown with the possibility to either skip, retry or cancel the reading.

Figure 26. An example of a Communication Error dialog

After the uploading/downloading process is completed, the dialog is closed and the tool area is updated.
4.3.3 Store

NOTE! Applies only to certain relays.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store</td>
<td>Stores settings to the non-volatile memory in the relay unit. Clicking Close in the Storing dialog box does not cancel storing operation in the relay unit, but then it cannot be guaranteed that storing has been completed successfully (Figure 28). This function is not provided by all relays.</td>
</tr>
</tbody>
</table>

*Figure 28. The dialog in which the storing of parameter values is confirmed*

*Figure 29. The dialog box indicating progress in the storing process*

Clicking the Close button in Figure 29 does not interrupt the storing operation, but asks the user whether he wants to close the dialog or not (Figure 30). The dialog can be closed by selecting Yes, but the user will not receive any information whether storing was successful or not. By selecting No, the program will return to the Storing dialog (Figure 29).

*Figure 30. Dialog asking whether you want to close the storing dialog*
4.3.4 Reset (Example)

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reset...</td>
<td>Opens a dialog box for some general resetting operations. Select the wanted action and click Send. <strong>NOTE!</strong> This is an example how additional selections can be used.</td>
</tr>
</tbody>
</table>

Figure 32. The dialog box for resetting relay unit

![Confirm dialog box](image)

Figure 33. The Confirm dialog box in which the selected action can be confirmed

4.4 Tools Menu

The Tools menu contains miscellaneous tools and commands.

![Tools menu](image)

Figure 34. Tools menu
4.4.1 Compare

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compare</td>
<td>The purpose of this function is to check that the values in the parameter file and in the relay are the same. In the Compare dialog there are two tabs, one for Present Values and the other for New Values. Present Values tab shows the differences between the Present Values in the file and the values in the relay. New Values tab shows the differences between the New Values in the file and the values in the relay.</td>
</tr>
</tbody>
</table>

![Compare dialog](image)

Figure 35. Compare dialog in which the comparing process can be started by pressing the Compare button

In the Present Values and in the New Values tabs there are several fields in which the character # stands for a consecutive number, the second field (called Parameter) indicates the description of the parameter, and the Database name is presented in the third field. File Value is given in the fourth field, and the Relay Value is given in the last field. The values will be shown only if the values in the parameter file differ from the values in the relay. In case there has been an error during the reading process, an error message will be shown in the Relay Value field. The comparing process can be started by pressing the Compare button in the lower part of the dialog. To exit the dialog without starting the comparing process, press Close.

![Compare Uploading dialog](image)

Figure 36. Compare Uploading dialog

By clicking a field in the Present Values or New Values tab, the field is activated (shown in blue as presented in the following figure) and a menu path is shown in the field on the left-hand side in the lower part of the dialog. The time when the File Value was updated last time is shown in the field on the right-hand side of the dialog.
Figure 37. Compare Present Values dialog

Figure 38. Compare New Values dialog

To exit the dialog, click Close.
4.4.2 Edit History

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit history</td>
<td>Made changes are collected and presented in the Edit history dialog. These changes remain in the dialog only until the end of the session (i.e. they are not saved).</td>
</tr>
</tbody>
</table>

![Edit History dialog]

Figure 39. Edit History dialog

To erase all information from the dialog, click Clear. The dialog can be closed by clicking Close.

4.4.3 View Transducers

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Transducers</td>
<td>Nominal values can be viewed in the View Transducers dialog. These nominal values are used when calculating primary values for certain parameters (Figure 53, note 6). Values are defined in the Object Configuration Tool, please refer to SM/RED Configuration Manual (1MRS751392-MEN).</td>
</tr>
</tbody>
</table>

![Transducers dialog]

Figure 40. Transducers dialog

To exit the dialog, click Close.
4.5 Options Menu

The Options menu contains miscellaneous tools and commands.

![Options Menu](image)

**Figure 41. The Options menu**

4.5.1 Resize Dialog Box

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize Dialog Box</td>
<td>Opens a dialog in which the size of the dialog box can be changed (see Figure 42).</td>
</tr>
</tbody>
</table>


![Resize Dialog Box](image)

**Figure 42. The dialog box for resizing the Relay Setting Tool**

4.5.2 Rebuild Active Menu

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebuild Active Menu</td>
<td>Opens a dialog box, where the building of the Active Menu File is started. This file is needed to present the HMI in the Relay Setting Tool. The dialog box is automatically opened at the startup of the relay setting tool if the relay unit application has been reconfigured.</td>
</tr>
</tbody>
</table>

Under Source HMI files there is a tab page for every HMI file. These tab pages contain information about file location, relay type, software number, version and state, date of creation and author. These files are used when building the new active menu.
Under Build Active Menu File there is information about the current active menu file: file location, date of creation and status. Details of used HMI files, on the basis of which the current active menu file has been created, can be found under Files Used.


![Figure 43. The dialog box for building the Active Menu File](image)

### 4.5.3 Menu Configuration

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Configuration</td>
<td>With this function the user has the possibility to customise the View and Transfers menu options. All menu configuration settings apply only to the object that has been selected in a station picture (in LIB/MicroSCADA environment) or in the navigation tree (in CAP 501/505 environment).</td>
</tr>
</tbody>
</table>


An example of how to add a function to the View menu will be given in the following. The method is the same for both View and Transfers. Several new selections can be added to the menus. It is also possible to delete inactual selections from the menus.
4.5.3.1 Menu Configuration/View Menu

![Menu Configuration/View Menu Diagram]

Figure 44. Adding a new configuration to the list of Configurations

Start by creating a new configuration with the function Create. After Create is pressed, the “raw material” New Config1 is added to the Configurations list. Select this item and click Properties.

![Properties Diagram]

Figure 45. Giving the properties for Serial number
Table 1 The function Properties has the following fields and functions:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give a useful name for the configured function, otherwise it will remain</td>
</tr>
<tr>
<td></td>
<td>as e.g. New Config1. In the example mentioned above the name Serial</td>
</tr>
<tr>
<td></td>
<td>number has been given by the user.</td>
</tr>
<tr>
<td>Menu Tree</td>
<td>Navigate in the menu tree and select the wanted function.</td>
</tr>
<tr>
<td>Parameters</td>
<td>The selectable parameters are shown in this field. Select the ones</td>
</tr>
<tr>
<td></td>
<td>needed.</td>
</tr>
<tr>
<td>OK</td>
<td>Verify the choices made.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Regret and return without changes.</td>
</tr>
</tbody>
</table>

After New Config1 has been configured, it will have the name Serial number. The following step is to prepare the Menu Commands. Start by pressing Add, and the New Command1 appears on the list.

Figure 46. A new menu item New Command 1 is added to the Menu Commands, but it still has to be prepared with the help of the Properties functions

Select New Command1 and press Properties.
Table 2  Menu Properties contains the following fields and functions:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>View name</td>
<td>Replace the New Command1 with the name you intend to present in the View menu.</td>
</tr>
<tr>
<td>Bind to Configurations</td>
<td>You will now have to bind a configuration with the menu selection.</td>
</tr>
<tr>
<td>OK</td>
<td>Verify your changes/setup</td>
</tr>
<tr>
<td>Cancel</td>
<td>Regret and leave without changes</td>
</tr>
</tbody>
</table>

The new menu selection is at your disposal after ending the Options/Menu configuration function.

Figure 48.  The new menu selection is at your disposal

4.5.3.2  Menu Configuration/Transfers Menu

The user has the possibility of preparing a Transfers menu of his/her own. The method is exactly the same as described in the previous section regarding the View menu. Please refer to that part for detailed information.
4 Using Relay Setting Tool

RED Relay Tool Operator’s Manual

Figure 49. The Transfers menu is customized in the same way as the View menu. In this connection the option Properties has slightly different functions as in the View menu, see Figure 46

Select Properties for the created New Config 1, see Figure 50:

Figure 50. Giving the properties for the new configuration
Table 3  The fields and functions are used in the following way:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Give a useful name for your configured function, otherwise it will remain as e.g. New Config 1. In the example above the name Outputs/Events is given by the user.</td>
</tr>
<tr>
<td>Source</td>
<td>Select the wanted parameters or items to be added to the Target list by the Add button</td>
</tr>
<tr>
<td>Target</td>
<td>The Target list contains a list of all added items from the Source list. By selecting the items one by one, the text can be edited. The field for the parameter code, e.g. F127V107 cannot be edited, but the value in the field to the left can be changed. Apply has to be used for verifying each change of an item on the Target list.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the selected item from the Source list to the Target list</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected item from the Target list</td>
</tr>
<tr>
<td>OK</td>
<td>Verify your selections and modifications made</td>
</tr>
<tr>
<td>Cancel</td>
<td>Regret and return without changes, also those done by Apply</td>
</tr>
</tbody>
</table>

Remarks regarding Figure 50:

As it can be seen in the Source list in Figure 50, a huge amount of parameters/items is selectable and can be added to the Target list. Normally, the idea is not to make parametrisation of the relay parameters via the Transfers menu even if it is possible, but to enable e.g. resetting of registers, indications etc. in the relay. Relay parametrisation and monitoring is described further on in chapter 4.7. Furthermore, the user should check that the value of each parameter/item in the Target list has the right value (in the field on the right side of the parameter code). In other words, the user should ensure that the parameter/item has the value the user wants to send to the relay. The default value is not always the wanted one. The values can, of course, be changed afterwards, whenever necessary. It is also recommended to take into consideration that giving “wrong” value may result in that the expected result remains unfulfilled when executing the menu selection in the Transfers menu.

4.6 Help

The Help menu contains an on-line help for the tool functions.

Figure 51. The Help menu

4.6.1 About Setting Tool

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Setting Tool</td>
<td>Gives information regarding the setting tool.</td>
</tr>
</tbody>
</table>

Access: No limitations.
4.7 Monitoring and Changing Parameters

The RED Relay Setting Tool gives the relay engineer a powerful tool for monitoring and configuring the relay units.

4.7.1 RED Menus

When a menu from the Relay Setting Tool is selected, a menu hierarchy of the functions (Figure 53, note 1) available for the relay unit is displayed in the tool area. Each function holds several tabbed pages of configurable parameters.

4.7.2 Tabbed Pages

The Relay Setting Tool Main View contains tabbed pages. The hierarchy and the number of these tabbed pages depends on the selected relay. A tabbed page can be selected by clicking the wanted page with the mouse, e.g. page 41 (see note 2 in Figure 53). Note 3 in Figure 53 indicates the last page (214).
4.7.3 Parametrisation

The Setting Tool pictures hold a field indicating the Present Values and a field indicating the New Values. After changing the New Values, the changes have to be downloaded to the relay unit. Downloading is done by the function Download parameters (which can be found in the Transfers menu). The Present Values are also updated when the values are downloaded.

If there are multiple choices, the suitable alternative can be selected from the drop-down combo box (see note 4 in Figure 53). If the relay unit is protected by a password, the password is asked before the changes are downloaded. The dialog in which a new value can be entered (Figure 54) can be brought out by pressing the left mouse button on the field (note 5 in Figure 53) and by pressing any key.

- Note 4 in Figure 53: The value changes color when selected. A suitable alternative can be selected in the drop-down combo box.
- Note 5 in Figure 53: The dialog presenting possible alternatives for the new value.
• Note 6 in Figure 53: Primary value. Whether this is in use or not is defined in the Object Configuration Tool.

![New Value](image)

*Figure 54. The input field of the Setting Tool*
5 PQ-Monitoring Tool in LIB510/MicroSCADA

5.1 General

The Power Quality Monitoring Tool is used to visualise the data generated by PQ IEDs (Power Quality Intelligent Electronic Devices) and uploaded by MicroSCADA.

5.2 Startup

The tool is started by first clicking the relay units' push-button in the station picture and then by selecting the PQ-Monitoring Tool from the opened dialog box and clicking Run.

![Tool Menu for a relay unit object](PQMoTool.png)

*Figure 55. Tool Menu for a relay unit object*

If the selected relay unit does not have any PQ-Monitoring Function, the Monitoring Tool will not open and the following dialog box will appear.

![Error Dialog](ErrorDlg.png)

*Figure 56. An indication dialog box for PQ function not available*
5.3 Main View

![Main View Diagram](image)

**Figure 57. Main view of the PQ-Monitoring Tool**

This is a main view of the tool when Voltage waveform distortion measurement is selected (the other implemented function, Current waveform distortion measurement, looks exactly same). The main view consists of the following functions:

1. Menu bar
   A set of menus for basic functions of the tool.
2. Toolbar
   A bar of buttons for commonly used operations.
3. Tabbed page
   A tabbed page where each tab opens a new visualisation area depending on the used monitoring function.
4. Visualisation area
An area where the monitored data is displayed.

5. Status bar
A bar where some various monitoring information is displayed.

### 5.3.1 Menu Bar

The Menu bar includes the following menus.

#### 5.3.1.1 File Menu

The File menu contains the file handling functions.

![File Menu](image)

**Figure 58. File Menu**

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print Setup</td>
<td>Opens a dialog in which the used printer setup can be modified if the used MicroSCADA Monitor type is VS Local.</td>
</tr>
</tbody>
</table>

![Print Setup dialog box](image)

**Figure 59. Print Setup dialog box**

If the used MicroSCADA Monitor type is VS Remote, the following error dialog box appears.
The print setup dialog is not available on VS Remote monitor. Please, select the printer in MicroSCADA Monitor window when starting a VS Remote monitor.

Figure 60. Print Setup error dialog box

When the VS Remote monitor is used the printer selection must be done when starting the MicroSCADA monitor.

Figure 61. VS Printer selection in MicroSCADA VS Remote Monitor startup
### Selection | Functionality
--- | ---
Print | Opens a printing dialog of the current page where the setup can also be changed (VS Local Monitor type). If the used Monitor type is VS Remote, the Print dialog is different.

![Print dialog box on a VS Local Monitor](image1.png)

*Figure 62. Print dialog box on a VS Local Monitor*

![The Print dialog on a VS Remote Monitor](image2.png)

*Figure 63. The Print dialog on a VS Remote Monitor*

**NOTE!** Printing needs info from the active menu of the used relay. If the active menu file of the relay is not found, an error dialog pops up and the menu should be build by the Relay Setting Tool.
5.3.1.2 View Menu

The available PQ-Monitoring functions are listed and selectable in the View menu of the tool.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>PQVO3H</td>
<td>Opens a view of “Voltage waveform distortion measurement”. The monitorable PQ indices can be seen and selected on the tabs of the opened page.</td>
</tr>
<tr>
<td>PQCU3H</td>
<td>Opens a view of “Current waveform distortion measurement”. The monitorable PQ indices can be seen and selected on the tabs of the opened page.</td>
</tr>
</tbody>
</table>
5.3.1.3 Options Menu

This menu includes some configurable options of the PQ-Monitoring Tool.

```
Options
✓ Enable automated data upload on PQV/93H Harmonic violation event
✓ Enable automated data upload on PQV/93H Obs. period ended event
Enable automated data upload on PQV/93H Harmonic violation event
Enable automated data upload on PQV/93H Obs. period ended event
```

Figure 67. Options Menu

The automated data uploading is started on "Harmonic violation" and "Obs. Period ended" events. On this menu the auto-upload feature can be enabled or disabled (toggled on and off) by selecting the modifiable item. On the menu above, the first 2 items are enabled and the last two disabled.

**NOTE!** Enabling and disabling automated data upload is only allowed on authorisation level Engineering (2) (or higher). If the level is inadequate, the following error dialog is opened.

```
Enabling or disabling automated data upload needs Engineering (2) rights
```

Figure 68. Insufficient user rights to change the auto-upload option

5.3.1.4 Help Menu

The Help menu includes the on-line help of the tool functions.

```
Help
Help
About PQ-Monitoring Tool...
```

Figure 69. Help Menu

<table>
<thead>
<tr>
<th>Selection</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>Opens a dialog containing the on-line help of the tool functions.</td>
</tr>
<tr>
<td>About PQ-Monitoring Tool</td>
<td>Opens a dialog containing some general information of the PQ-Monitoring Tool.</td>
</tr>
</tbody>
</table>
5.3.2 Toolbar

The Toolbar includes the commonly used buttons presented in the following:

<table>
<thead>
<tr>
<th>Button</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Exit Icon" /></td>
<td>Exit</td>
</tr>
<tr>
<td><img src="image" alt="Print Setup Icon" /></td>
<td>Print Setup</td>
</tr>
<tr>
<td><img src="image" alt="Print Icon" /></td>
<td>Print</td>
</tr>
<tr>
<td><img src="image" alt="Upload Icon" /></td>
<td>Upload</td>
</tr>
</tbody>
</table>

The first three buttons do the same file handling functions as the choices in the File menu and the fourth button is used to upload on-line data from the relay unit.

Some further info is also viewed on the toolbar. The presented info depends on what is being monitored. If the on-line values are viewed, the information of "Measured input" is shown. In the case of harmonic violation the "Violation Period" is shown and can be selected from the toolbar. If the values from a certain period are monitored, the "Observation Period" is shown and selectable on the toolbar.

![Violation Period](image)

*Figure 70. Information of the selected Harmonic Violation Period*

5.3.3 Tabbed Page

A tabbed page is opened when a selection of the monitoring function (Voltage or Current waveform distortion measurement) is done from the View menu. By clicking the wanted tab, the actual page for visualisation opens.

![Tabbed Page](image)

*Figure 71. The list of monitored data on Voltage or Current Harmonics*

If there is no saved data for a Harmonic Violation Period or an Observation Period the following information dialog is opened.
5.3.4 Visualisation Area

This is the area where the actual results are being visualised. The uploaded or saved data is shown on a bar chart of harmonics or on a cumulative curve of the selected harmonic.

The bar chart of a Harmonic Violation Period consists of bars and a curve.
Figure 73. A bar chart of a Selected Harmonic Violation Period

In this picture, the height of each bar describes the magnitude of a harmonic value. The values under the adjustable limits (yellow lines) are shown with green bars and the values over the limits with red bars. The continuous black curve describes the limits of the EN 50160 Standard for each harmonic.

A picture of a Selected Harmonic during a selected Observation Period is shown below.
**Figure 74. A cumulative curve of selected harmonic during an Observation Period (Requirements fulfilled)**

This curve is drawn according to five percentiles (1%, 5%, 50%, 95% and 99%) calculated by the relay unit. The adjusted limit value for a selected harmonic is shown with a red horizontal line. If the 95% percentile value for the selected harmonic is under the adjusted limit, the cumulative curve is blue and the requirements are fulfilled.

If the 95% percentile value for the selected harmonic exceeds the adjusted limit, the cumulative curve changes to red and the requirements are not fulfilled.
5 PQ-Monitoring Tool in LIB510/MicroSCADA

RED Relay Tool
Operator’s Manual

5.3.5 Status Bar

Some various information is displayed on this bar depending on the monitoring function.

Figure 75. A cumulative curve of selected harmonic during an Observation Period (Requirements not fulfilled)

Figure 76. A status bar info on a selected Harmonic Violation period

The status bar has always the information of the data generating Function Block and the explanation. The rest depends on what is being monitored. If on-line values are monitored, the status bar includes the info of the ending of current observation period. When a harmonic violation period is displayed, the status bar has the time stamp of the recorded maximum values. In the case of X % values, the adjusted X (percentile) is shown. A number of the harmonic (or THD) is viewed when the curve of selected harmonic is presented.
5.4 Monitoring Functionality

After the PQ-Monitoring Tool has been started, the wanted monitoring function should be selected from the View menu. By selecting the first or second tab from the opened page, the on-line values from the relay can be uploaded. The on-line mode is also indicated by the upload button that has just become enabled. The rest of the tabs are used for saved data visualisation. When any of these tabbed pages is selected, the upload button becomes disabled.

5.4.1 On-line Monitoring

The on-line monitoring is started by pressing the upload button on the toolbar. When the uploading begins, the following indicator of the process proceeding pops up.

![Progress Indicator](image)

*Figure 77. An indication dialog of the uploading process proceeding*

If the relay unit does not answer or there is some other communication problem, an error dialog appears.

![Error Dialog](image)

*Figure 78. An error dialog of communication problem*

**NOTE!** The manual data uploading requires authorisation level Control (1) or higher. Otherwise, the following information dialog is opened.
5.4.2 Monitoring of Saved Data

The monitoring of previously saved data is done by selecting the wanted time period from the dropdown list on the toolbar.

![Information Dialog]

Figure 79. Insufficient user rights to manual data uploading

<table>
<thead>
<tr>
<th>Violation Period</th>
<th>1999-12-10 10:19:00.094 - 1999-12-10 10:19:18.477</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1999-12-10 10:12:30.996 - 1999-12-10 10:12:30.266</td>
</tr>
<tr>
<td></td>
<td>1999-12-10 10:12:20.017 - 1999-12-10 10:12:29.413</td>
</tr>
<tr>
<td></td>
<td>1999-12-10 10:12:34.697 - 1999-12-10 10:12:41.627</td>
</tr>
<tr>
<td></td>
<td>1999-12-10 10:18:48.956 - 1999-12-10 10:18:56.867</td>
</tr>
<tr>
<td></td>
<td>1999-12-10 10:18:56.694 - 1999-12-10 10:19:16.477</td>
</tr>
</tbody>
</table>

Figure 80. Selection of a harmonic violation period from a dropdown list

When a period is selected, the progress indicator opens and the saved data is read from the disk. After that, the results are ready to be visualised.
# Index

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
</table>

## #

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
</table>

## A

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Setting Tool</td>
</tr>
<tr>
<td>Active Menu File</td>
</tr>
<tr>
<td>Add</td>
</tr>
<tr>
<td>All view</td>
</tr>
<tr>
<td>automatic updating</td>
</tr>
</tbody>
</table>

## B

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bind to Configurations</td>
</tr>
<tr>
<td>Build Active Menu File</td>
</tr>
</tbody>
</table>

## C

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compare</td>
</tr>
<tr>
<td>Compare New Values dialog</td>
</tr>
<tr>
<td>Compare Present Values dialog</td>
</tr>
<tr>
<td>creating a new configuration</td>
</tr>
</tbody>
</table>

## D

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database name</td>
</tr>
<tr>
<td>default directory</td>
</tr>
<tr>
<td>download</td>
</tr>
<tr>
<td>download parameters</td>
</tr>
</tbody>
</table>

## E

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit history</td>
</tr>
<tr>
<td>error dialog</td>
</tr>
<tr>
<td>Exit</td>
</tr>
<tr>
<td>Export</td>
</tr>
<tr>
<td>Export parameters</td>
</tr>
</tbody>
</table>

## F

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Value</td>
</tr>
</tbody>
</table>

## H

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Harmonic violation</td>
</tr>
<tr>
<td>Harmonic Violation Period</td>
</tr>
<tr>
<td>HMI</td>
</tr>
</tbody>
</table>

## I

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import</td>
</tr>
<tr>
<td>Import parameters</td>
</tr>
</tbody>
</table>
local printer .......................................................................................................................... 19, 20

Menu bar .............................................................................................................................. 13, 40
Menu Commands .................................................................................................................. 32
Menu Configuration ............................................................................................................. 30
menu hierarchy ....................................................................................................................... 36
Menu Properties ................................................................................................................... 33
Menu Tree .............................................................................................................................. 32
MicroSCADA Monitor dialog .............................................................................................. 17
Minimise button .................................................................................................................. 14

name .................................................................................................................................. 32, 35
network printer ..................................................................................................................... 19, 20
New Values ......................................................................................................................... 26, 37

Objects ................................................................................................................................ 7
Obs. Period ended .................................................................................................................. 45
Observation Period .............................................................................................................. 46, 48
Options/Menu configuration ................................................................................................. 21

Page Setup ........................................................................................................................... 17
parameter ............................................................................................................................. 11, 26, 32
percentile value ..................................................................................................................... 49
PQCU3H ................................................................................................................................ 44
PQVO3H ................................................................................................................................ 44
Present Values ...................................................................................................................... 26, 37
Print ...................................................................................................................................... 19, 43
Print dialog .......................................................................................................................... 19
Print dialog 2 ......................................................................................................................... 19
Print Setup ............................................................................................................................ 17, 41
Printing ................................................................................................................................ 13
Properties ............................................................................................................................. 31, 32
push-button ......................................................................................................................... 7

Rebuild Active Menu .......................................................................................................... 29
RED Relay configurations .................................................................................................... 11
relay parametrisation ............................................................................................................. 12
Relay Setting Tool ................................................................................................................. 36
Relay unit menu tabbed pages ............................................................................................. 14
Relay Value ............................................................................................................................ 26
Remove ................................................................................................................................ 35
Reset .................................................................................................................................... 25
Resize Dialog Box .................................................................................................................. 29

Selected Harmonic .............................................................................................................. 48
setting parameters ................................................................................................................ 8
Source .................................................................................................................................. 35
Status bar ............................................................................................................................... 14, 41
Store ........................................................................................................................................... 24

T
Tabbed page .................................................................................................................................. 40
Target ................................................................................................................................................ 35
time period ...................................................................................................................................... 52
Tool area .......................................................................................................................................... 14
Tool Menu dialog box .................................................................................................................. 8
Toolbar .......................................................................................................................................... 13, 40

U
Upload ........................................................................................................................................... 22
upload parameters ........................................................................................................................ 14

V
View name ...................................................................................................................................... 33
View Transducers ........................................................................................................................ 28
Violation Period ............................................................................................................................ 46
Visualisation area .......................................................................................................................... 41
VS Remote ...................................................................................................................................... 41